Sitecore.Commerce Namespace

A Sandcastle Documented Class Library
Sitecore.Commerce Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce"]

Classes
 | Class | Description
Public class | Constants | Container class used to hold all constants
Public class | ConstantsKnownFieldNames | Some known widely used fieldnames
Public class | ConstantsKnownPageEventDataNames | The names of commmonly used page event data items.
Public class | ConstantsKnownPageEventIds | The IDs of commonly used page event IDs.
Public class | ConstantsKnownServiceNames | The names of commonly used services.
Public class | ConstantsKnownServiceProviderNames | The names of commonly used service providers.
Public class | ConstantsKnownWorkflowDataNames | The names of commonly used workflow state data keys
Public class | PropertyCollection | Represents a list of properties organized as key/value pairs.
Public class | PropertyItem | Represents an entry in the PropertyCollection
Public class | Templates | Contains the CommerceConnect template unique identifiers.
Public class | Texts | Defines the Texts class.


Constants Class

Constants Class
Container class used to hold all constants
Inheritance Hierarchy
SystemObject
Sitecore.CommerceConstants

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class Constants
Public NotInheritable Class Constants
public ref class Constants abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Constants =  class end

The Constants type exposes the following members.

Fields
Name | Description
CommerceContext | The Commerce context.
InventoryProductBuilder | The inventory product builder.
Top
See Also

Reference

Sitecore.Commerce Namespace


Constants Fields

Constants Fields

The Constants type exposes the following members.

Fields
Name | Description
CommerceContext | The Commerce context.
InventoryProductBuilder | The inventory product builder.
Top
See Also

Reference

Constants Class
Sitecore.Commerce Namespace


Constants.CommerceContext Field

ConstantsCommerceContext Field
The Commerce context.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CommerceContext
Public Const CommerceContext As String
public:
literal String^ CommerceContext
static val mutable CommerceContext: string

Field Value

Type: String
See Also

Reference

Constants Class
Sitecore.Commerce Namespace


Constants.InventoryProductBuilder Field

ConstantsInventoryProductBuilder Field
The inventory product builder.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string InventoryProductBuilder
Public Const InventoryProductBuilder As String
public:
literal String^ InventoryProductBuilder
static val mutable InventoryProductBuilder: string

Field Value

Type: String
See Also

Reference

Constants Class
Sitecore.Commerce Namespace


Constants.KnownFieldNames Class

ConstantsKnownFieldNames Class
Some known widely used fieldnames
Inheritance Hierarchy
SystemObject
Sitecore.CommerceConstantsKnownFieldNames

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class KnownFieldNames
Public NotInheritable Class KnownFieldNames
public ref class KnownFieldNames abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type KnownFieldNames =  class end

The ConstantsKnownFieldNames type exposes the following members.

Fields
Name | Description
ExternalId | The instocklocations field.
ManufacturerFieldName | The productclasses field
NameField | The Name field
ProductClassesFieldName | The productclasses field
ProductTypeFieldName | The productclasses field
Top
See Also

Reference

Sitecore.Commerce Namespace


KnownFieldNames Fields

KnownFieldNames Fields

The ConstantsKnownFieldNames type exposes the following members.

Fields
Name | Description
ExternalId | The instocklocations field.
ManufacturerFieldName | The productclasses field
NameField | The Name field
ProductClassesFieldName | The productclasses field
ProductTypeFieldName | The productclasses field
Top
See Also

Reference

ConstantsKnownFieldNames Class
Sitecore.Commerce Namespace


Constants.KnownFieldNames.ExternalId Field

ConstantsKnownFieldNamesExternalId Field
The instocklocations field.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ExternalId
Public Const ExternalId As String
public:
literal String^ ExternalId
static val mutable ExternalId: string

Field Value

Type: String
See Also

Reference

ConstantsKnownFieldNames Class
Sitecore.Commerce Namespace


Constants.KnownFieldNames.ManufacturerFieldName Field

ConstantsKnownFieldNamesManufacturerFieldName Field
The productclasses field

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ManufacturerFieldName
Public Const ManufacturerFieldName As String
public:
literal String^ ManufacturerFieldName
static val mutable ManufacturerFieldName: string

Field Value

Type: String
See Also

Reference

ConstantsKnownFieldNames Class
Sitecore.Commerce Namespace


Constants.KnownFieldNames.NameField Field

ConstantsKnownFieldNamesNameField Field
The Name field

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string NameField
Public Const NameField As String
public:
literal String^ NameField
static val mutable NameField: string

Field Value

Type: String
See Also

Reference

ConstantsKnownFieldNames Class
Sitecore.Commerce Namespace


Constants.KnownFieldNames.ProductClassesFieldName Field

ConstantsKnownFieldNamesProductClassesFieldName Field
The productclasses field

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ProductClassesFieldName
Public Const ProductClassesFieldName As String
public:
literal String^ ProductClassesFieldName
static val mutable ProductClassesFieldName: string

Field Value

Type: String
See Also

Reference

ConstantsKnownFieldNames Class
Sitecore.Commerce Namespace


Constants.KnownFieldNames.ProductTypeFieldName Field

ConstantsKnownFieldNamesProductTypeFieldName Field
The productclasses field

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ProductTypeFieldName
Public Const ProductTypeFieldName As String
public:
literal String^ ProductTypeFieldName
static val mutable ProductTypeFieldName: string

Field Value

Type: String
See Also

Reference

ConstantsKnownFieldNames Class
Sitecore.Commerce Namespace


Constants.KnownPageEventDataNames Class

ConstantsKnownPageEventDataNames Class
The names of commmonly used page event data items.
Inheritance Hierarchy
SystemObject
Sitecore.CommerceConstantsKnownPageEventDataNames

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class KnownPageEventDataNames
Public NotInheritable Class KnownPageEventDataNames
public ref class KnownPageEventDataNames abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type KnownPageEventDataNames =  class end

The ConstantsKnownPageEventDataNames type exposes the following members.

Fields
Name | Description
Products | The name of the Products page event data item.
ShopName | The name of the ShopName page event data item.
Top
See Also

Reference

Sitecore.Commerce Namespace


KnownPageEventDataNames Fields

KnownPageEventDataNames Fields

The ConstantsKnownPageEventDataNames type exposes the following members.

Fields
Name | Description
Products | The name of the Products page event data item.
ShopName | The name of the ShopName page event data item.
Top
See Also

Reference

ConstantsKnownPageEventDataNames Class
Sitecore.Commerce Namespace


Constants.KnownPageEventDataNames.Products Field

ConstantsKnownPageEventDataNamesProducts Field
The name of the Products page event data item.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string Products
Public Const Products As String
public:
literal String^ Products
static val mutable Products: string

Field Value

Type: String
See Also

Reference

ConstantsKnownPageEventDataNames Class
Sitecore.Commerce Namespace


Constants.KnownPageEventDataNames.ShopName Field

ConstantsKnownPageEventDataNamesShopName Field
The name of the ShopName page event data item.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ShopName
Public Const ShopName As String
public:
literal String^ ShopName
static val mutable ShopName: string

Field Value

Type: String
See Also

Reference

ConstantsKnownPageEventDataNames Class
Sitecore.Commerce Namespace


Constants.KnownPageEventIds Class

ConstantsKnownPageEventIds Class
The IDs of commonly used page event IDs.
Inheritance Hierarchy
SystemObject
Sitecore.CommerceConstantsKnownPageEventIds

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class KnownPageEventIds
Public NotInheritable Class KnownPageEventIds
public ref class KnownPageEventIds abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type KnownPageEventIds =  class end

The ConstantsKnownPageEventIds type exposes the following members.

Fields
Name | Description
ProductsAreBackInStock | The ID of the Products Are Back In Stock page event.
Top
See Also

Reference

Sitecore.Commerce Namespace


KnownPageEventIds Fields

KnownPageEventIds Fields

The ConstantsKnownPageEventIds type exposes the following members.

Fields
Name | Description
ProductsAreBackInStock | The ID of the Products Are Back In Stock page event.
Top
See Also

Reference

ConstantsKnownPageEventIds Class
Sitecore.Commerce Namespace


Constants.KnownPageEventIds.ProductsAreBackInStock Field

ConstantsKnownPageEventIdsProductsAreBackInStock Field
The ID of the Products Are Back In Stock page event.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static readonly ID ProductsAreBackInStock
Public Shared ReadOnly ProductsAreBackInStock As ID
public:
static initonly ID^ ProductsAreBackInStock
static val ProductsAreBackInStock: ID

Field Value

Type: ID
See Also

Reference

ConstantsKnownPageEventIds Class
Sitecore.Commerce Namespace


Constants.KnownServiceNames Class

ConstantsKnownServiceNames Class
The names of commonly used services.
Inheritance Hierarchy
SystemObject
Sitecore.CommerceConstantsKnownServiceNames

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class KnownServiceNames
Public NotInheritable Class KnownServiceNames
public ref class KnownServiceNames abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type KnownServiceNames =  class end

The ConstantsKnownServiceNames type exposes the following members.

Fields
Name | Description
ItemClassificationService | The itemClassificationService service.
Top
See Also

Reference

Sitecore.Commerce Namespace


KnownServiceNames Fields

KnownServiceNames Fields

The ConstantsKnownServiceNames type exposes the following members.

Fields
Name | Description
ItemClassificationService | The itemClassificationService service.
Top
See Also

Reference

ConstantsKnownServiceNames Class
Sitecore.Commerce Namespace


Constants.KnownServiceNames.ItemClassificationService Field

ConstantsKnownServiceNamesItemClassificationService Field
The itemClassificationService service.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ItemClassificationService
Public Const ItemClassificationService As String
public:
literal String^ ItemClassificationService
static val mutable ItemClassificationService: string

Field Value

Type: String
See Also

Reference

ConstantsKnownServiceNames Class
Sitecore.Commerce Namespace


Constants.KnownServiceProviderNames Class

ConstantsKnownServiceProviderNames Class
The names of commonly used service providers.
Inheritance Hierarchy
SystemObject
Sitecore.CommerceConstantsKnownServiceProviderNames

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class KnownServiceProviderNames
Public NotInheritable Class KnownServiceProviderNames
public ref class KnownServiceProviderNames abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type KnownServiceProviderNames =  class end

The ConstantsKnownServiceProviderNames type exposes the following members.

Fields
Name | Description
EaPlanProvider | The eaPlanProvider service provider.
InventoryAutomationProvider | The inventory service automation provider.
InventoryServiceProvider | The inventoryServiceProvider service provider.
Top
See Also

Reference

Sitecore.Commerce Namespace


KnownServiceProviderNames Fields

KnownServiceProviderNames Fields

The ConstantsKnownServiceProviderNames type exposes the following members.

Fields
Name | Description
EaPlanProvider | The eaPlanProvider service provider.
InventoryAutomationProvider | The inventory service automation provider.
InventoryServiceProvider | The inventoryServiceProvider service provider.
Top
See Also

Reference

ConstantsKnownServiceProviderNames Class
Sitecore.Commerce Namespace


Constants.KnownServiceProviderNames.EaPlanProvider Field

ConstantsKnownServiceProviderNamesEaPlanProvider Field
The eaPlanProvider service provider.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string EaPlanProvider
Public Const EaPlanProvider As String
public:
literal String^ EaPlanProvider
static val mutable EaPlanProvider: string

Field Value

Type: String
See Also

Reference

ConstantsKnownServiceProviderNames Class
Sitecore.Commerce Namespace


Constants.KnownServiceProviderNames.InventoryAutomationProvider Field

ConstantsKnownServiceProviderNamesInventoryAutomationProvider Field
The inventory service automation provider.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string InventoryAutomationProvider
Public Const InventoryAutomationProvider As String
public:
literal String^ InventoryAutomationProvider
static val mutable InventoryAutomationProvider: string

Field Value

Type: String
See Also

Reference

ConstantsKnownServiceProviderNames Class
Sitecore.Commerce Namespace


Constants.KnownServiceProviderNames.InventoryServiceProvider Field

ConstantsKnownServiceProviderNamesInventoryServiceProvider Field
The inventoryServiceProvider service provider.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string InventoryServiceProvider
Public Const InventoryServiceProvider As String
public:
literal String^ InventoryServiceProvider
static val mutable InventoryServiceProvider: string

Field Value

Type: String
See Also

Reference

ConstantsKnownServiceProviderNames Class
Sitecore.Commerce Namespace


Constants.KnownWorkflowDataNames Class

ConstantsKnownWorkflowDataNames Class
The names of commonly used workflow state data keys
Inheritance Hierarchy
SystemObject
Sitecore.CommerceConstantsKnownWorkflowDataNames

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class KnownWorkflowDataNames
Public NotInheritable Class KnownWorkflowDataNames
public ref class KnownWorkflowDataNames abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type KnownWorkflowDataNames =  class end

The ConstantsKnownWorkflowDataNames type exposes the following members.

Fields
Name | Description
BackInStockProducts | The products that have become back in-stock, and for which the requesting visitor should be notified.
ExpiredNotifications | The back-in-stock notifications that have expired due to being past interest date.
ProductNotifications | The products for which a visitor has required to recieve back-in-stock notifications
Top
See Also

Reference

Sitecore.Commerce Namespace


KnownWorkflowDataNames Fields

KnownWorkflowDataNames Fields

The ConstantsKnownWorkflowDataNames type exposes the following members.

Fields
Name | Description
BackInStockProducts | The products that have become back in-stock, and for which the requesting visitor should be notified.
ExpiredNotifications | The back-in-stock notifications that have expired due to being past interest date.
ProductNotifications | The products for which a visitor has required to recieve back-in-stock notifications
Top
See Also

Reference

ConstantsKnownWorkflowDataNames Class
Sitecore.Commerce Namespace


Constants.KnownWorkflowDataNames.BackInStockProducts Field

ConstantsKnownWorkflowDataNamesBackInStockProducts Field
The products that have become back in-stock, and for which the requesting visitor should be notified.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string BackInStockProducts
Public Const BackInStockProducts As String
public:
literal String^ BackInStockProducts
static val mutable BackInStockProducts: string

Field Value

Type: String
See Also

Reference

ConstantsKnownWorkflowDataNames Class
Sitecore.Commerce Namespace


Constants.KnownWorkflowDataNames.ExpiredNotifications Field

ConstantsKnownWorkflowDataNamesExpiredNotifications Field
The back-in-stock notifications that have expired due to being past interest date.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ExpiredNotifications
Public Const ExpiredNotifications As String
public:
literal String^ ExpiredNotifications
static val mutable ExpiredNotifications: string

Field Value

Type: String
See Also

Reference

ConstantsKnownWorkflowDataNames Class
Sitecore.Commerce Namespace


Constants.KnownWorkflowDataNames.ProductNotifications Field

ConstantsKnownWorkflowDataNamesProductNotifications Field
The products for which a visitor has required to recieve back-in-stock notifications

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ProductNotifications
Public Const ProductNotifications As String
public:
literal String^ ProductNotifications
static val mutable ProductNotifications: string

Field Value

Type: String
See Also

Reference

ConstantsKnownWorkflowDataNames Class
Sitecore.Commerce Namespace


PropertyCollection Class

PropertyCollection Class
Represents a list of properties organized as key/value pairs.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection PropertyItem
System.Collections.ObjectModelKeyedCollection String, PropertyItem
Sitecore.CommercePropertyCollection

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PropertyCollection : KeyedCollection<string, PropertyItem>
<SerializableAttribute>
Public Class PropertyCollection
    Inherits KeyedCollection(Of String, PropertyItem)
[SerializableAttribute]
public ref class PropertyCollection : public KeyedCollection<String^, PropertyItem^>
[<SerializableAttribute>]
type PropertyCollection =
    class
        inherit KeyedCollection<string, PropertyItem>
    end

The PropertyCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyCollection | Initializes a new instance of the PropertyCollection class
Top
Methods
 | Name | Description
Public method | Add(String) | Adds the specified key.
Public method | Add(String) | Adds the specified keys.
Public method | Add(T) | Adds an object to the end of the CollectionT. (Inherited from Collection PropertyItem .)
Public method | Add(String, Object) | Adds the specified key.
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection String, PropertyItem .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection PropertyItem .)
Protected method | ClearItems | Removes all elements from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, PropertyItem .)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection String, PropertyItem .)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection PropertyItem .)
Public method | ContainsProperty | Determines whether the specified key contains the given property.
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection PropertyItem .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection PropertyItem .)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Protected method | GetKeyForItem | When implemented in a derived class, extracts the key from the specified element. (Overrides KeyedCollectionTKey, TItemGetKeyForItem(TItem).)
Public method | GetPropertyOrDefaultT | Gets the property or the default value
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection PropertyItem .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection PropertyItem .)
Protected method | InsertItem | Inserts an element into the KeyedCollectionTKey, TItem at the specified index. (Inherited from KeyedCollection String, PropertyItem .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, PropertyItem .)
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection PropertyItem .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection PropertyItem .)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, PropertyItem .)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection String, PropertyItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection String, PropertyItem .)
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection PropertyItem .)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, PropertyItem .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection PropertyItem .)
Public property | ItemString | Gets or sets the Object with the specified key.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection PropertyItem .)
Public property | Keys | Gets the enumerator that permits the iteration through the list.
Top
See Also

Reference

Sitecore.Commerce Namespace


PropertyCollection Constructor

PropertyCollection Constructor
Initializes a new instance of the PropertyCollection class

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PropertyCollection()
Public Sub New
public:
PropertyCollection()
new : unit -> PropertyCollection
See Also

Reference

PropertyCollection Class
Sitecore.Commerce Namespace


PropertyCollection Methods

PropertyCollection Methods

The PropertyCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(String) | Adds the specified key.
Public method | Add(String) | Adds the specified keys.
Public method | Add(T) | Adds an object to the end of the CollectionT. (Inherited from Collection PropertyItem .)
Public method | Add(String, Object) | Adds the specified key.
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection String, PropertyItem .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection PropertyItem .)
Protected method | ClearItems | Removes all elements from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, PropertyItem .)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection String, PropertyItem .)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection PropertyItem .)
Public method | ContainsProperty | Determines whether the specified key contains the given property.
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection PropertyItem .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection PropertyItem .)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Protected method | GetKeyForItem | When implemented in a derived class, extracts the key from the specified element. (Overrides KeyedCollectionTKey, TItemGetKeyForItem(TItem).)
Public method | GetPropertyOrDefaultT | Gets the property or the default value
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection PropertyItem .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection PropertyItem .)
Protected method | InsertItem | Inserts an element into the KeyedCollectionTKey, TItem at the specified index. (Inherited from KeyedCollection String, PropertyItem .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, PropertyItem .)
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection PropertyItem .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection PropertyItem .)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, PropertyItem .)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection String, PropertyItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyCollection Class
Sitecore.Commerce Namespace


PropertyCollection.Add Method

PropertyCollectionAdd Method
Overload List
 | Name | Description
Public method | Add(String) | Adds the specified key.
Public method | Add(String) | Adds the specified keys.
Public method | Add(T) | Adds an object to the end of the CollectionT. (Inherited from Collection PropertyItem .)
Public method | Add(String, Object) | Adds the specified key.
Top
See Also

Reference

PropertyCollection Class
Sitecore.Commerce Namespace


PropertyCollection.Add Method (String)

PropertyCollectionAdd Method (String)
Adds the specified key.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string key
)
Public Sub Add (
    key As String
)
public:
void Add(
    String^ key
)
member Add :
        key : string -> unit

Parameters

key
Type: SystemString
The property key.
Exceptions
Exception | Condition
ArgumentNullException | key is null
ArgumentException | an element with the same key already exists
See Also

Reference

PropertyCollection Class
Add Overload
Sitecore.Commerce Namespace


PropertyCollection.Add Method (String[])

PropertyCollectionAdd Method (String)
Adds the specified keys.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string[] keys
)
Public Sub Add (
    keys As String()
)
public:
void Add(
    array<String^>^ keys
)
member Add :
        keys : string[] -> unit

Parameters

keys
Type: SystemString
An array of keys.
See Also

Reference

PropertyCollection Class
Add Overload
Sitecore.Commerce Namespace


PropertyCollection.Add Method (String, Object)

PropertyCollectionAdd Method (String, Object)
Adds the specified key.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string key,
    Object value
)
Public Sub Add (
    key As String,
    value As Object
)
public:
void Add(
    String^ key,
    Object^ value
)
member Add :
        key : string *
        value : Object -> unit

Parameters

key
Type: SystemString
The property key.
value
Type: SystemObject
The property value.
See Also

Reference

PropertyCollection Class
Add Overload
Sitecore.Commerce Namespace


PropertyCollection.ContainsProperty Method

PropertyCollectionContainsProperty Method
Determines whether the specified key contains the given property.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public bool ContainsProperty(
    string key
)
Public Function ContainsProperty (
    key As String
) As Boolean
public:
bool ContainsProperty(
    String^ key
)
member ContainsProperty :
        key : string -> bool

Parameters

key
Type: SystemString
The property key.

Return Value

Type: Boolean
true if the specified key contains property; otherwise, false.
See Also

Reference

PropertyCollection Class
Sitecore.Commerce Namespace


PropertyCollection.GetHashCode Method

PropertyCollectionGetHashCode Method
Returns a hash code for this instance.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

PropertyCollection Class
Sitecore.Commerce Namespace


PropertyCollection.GetKeyForItem Method

PropertyCollectionGetKeyForItem Method
When implemented in a derived class, extracts the key from the specified element.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetKeyForItem(
    PropertyItem item
)
Protected Overrides Function GetKeyForItem (
    item As PropertyItem
) As String
protected:
virtual String^ GetKeyForItem(
    PropertyItem^ item
) override
abstract GetKeyForItem :
        item : PropertyItem -> string
override GetKeyForItem :
        item : PropertyItem -> string

Parameters

item
Type: Sitecore.CommercePropertyItem
The element from which to extract the key.

Return Value

Type: String
The key for the specified element.
See Also

Reference

PropertyCollection Class
Sitecore.Commerce Namespace


PropertyCollection.GetPropertyOrDefault(T) Method

PropertyCollectionGetPropertyOrDefaultT Method
Gets the property or the default value

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public T GetPropertyOrDefault<T>(
    string key,
    T defaultValue
)

Public Function GetPropertyOrDefault(Of T) (
    key As String,
    defaultValue As T
) As T
public:
generic<typename T>
T GetPropertyOrDefault(
    String^ key,
    T defaultValue
)
member GetPropertyOrDefault :
        key : string *
        defaultValue : 'T -> 'T

Parameters

key
Type: SystemString
The key of the property to retrieve.
defaultValue
Type: T
The default value.

Type Parameters

T
The type of the property to return

Return Value

Type: T
Returns the property or if it's null and/or doesn't exist it returns the defaultValue specified
See Also

Reference

PropertyCollection Class
Sitecore.Commerce Namespace


PropertyCollection Properties

PropertyCollection Properties

The PropertyCollection type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection String, PropertyItem .)
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection PropertyItem .)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, PropertyItem .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection PropertyItem .)
Public property | ItemString | Gets or sets the Object with the specified key.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection PropertyItem .)
Public property | Keys | Gets the enumerator that permits the iteration through the list.
Top
See Also

Reference

PropertyCollection Class
Sitecore.Commerce Namespace


PropertyCollection.Item Property

PropertyCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection PropertyItem .)
Public property | ItemString | Gets or sets the Object with the specified key.
Top
See Also

Reference

PropertyCollection Class
Sitecore.Commerce Namespace


PropertyCollection.Item Property (String)

PropertyCollectionItem Property (String)
Gets or sets the Object with the specified key.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Object this[
    string key
] { get; set; }
Public Default Property Item (
    key As String
) As Object
    Get
    Set
public:
property Object^ default[String^ key] {
    Object^ get (String^ key);
    void set (String^ key, Object^ value);
}
member Item : Object with get, set

Parameters

key
Type: SystemString
The key to be used to access a particular property.

Property Value

Type: Object
See Also

Reference

PropertyCollection Class
Item Overload
Sitecore.Commerce Namespace


PropertyCollection.Keys Property

PropertyCollectionKeys Property
Gets the enumerator that permits the iteration through the list.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> Keys { get; }
Public ReadOnly Property Keys As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ Keys {
    IEnumerable<String^>^ get ();
}
member Keys : IEnumerable<string> with get

Property Value

Type: IEnumerable String
The 'keys' enumerator.
See Also

Reference

PropertyCollection Class
Sitecore.Commerce Namespace


PropertyItem Class

PropertyItem Class
Represents an entry in the PropertyCollection
Inheritance Hierarchy
SystemObject
Sitecore.CommercePropertyItem

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class PropertyItem
Public Class PropertyItem
public ref class PropertyItem
type PropertyItem =  class end

The PropertyItem type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyItem | Initializes a new instance of the PropertyItem class.
Public method | PropertyItem(String, Object) | Initializes a new instance of the PropertyItem class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Key | Gets or sets the key.
Public property | Value | Gets or sets the value.
Top
See Also

Reference

Sitecore.Commerce Namespace


PropertyItem Constructor

PropertyItem Constructor
Overload List
 | Name | Description
Public method | PropertyItem | Initializes a new instance of the PropertyItem class.
Public method | PropertyItem(String, Object) | Initializes a new instance of the PropertyItem class.
Top
See Also

Reference

PropertyItem Class
Sitecore.Commerce Namespace


PropertyItem Constructor

PropertyItem Constructor
Initializes a new instance of the PropertyItem class.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PropertyItem()
Public Sub New
public:
PropertyItem()
new : unit -> PropertyItem
See Also

Reference

PropertyItem Class
PropertyItem Overload
Sitecore.Commerce Namespace


PropertyItem Constructor (String, Object)

PropertyItem Constructor (String, Object)
Initializes a new instance of the PropertyItem class.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PropertyItem(
    string key,
    Object value
)
Public Sub New (
    key As String,
    value As Object
)
public:
PropertyItem(
    String^ key,
    Object^ value
)
new :
        key : string *
        value : Object -> PropertyItem

Parameters

key
Type: SystemString
The key for this property.
value
Type: SystemObject
The value associated with the key.
See Also

Reference

PropertyItem Class
PropertyItem Overload
Sitecore.Commerce Namespace


PropertyItem Methods

PropertyItem Methods

The PropertyItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyItem Class
Sitecore.Commerce Namespace


PropertyItem Properties

PropertyItem Properties

The PropertyItem type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets or sets the key.
Public property | Value | Gets or sets the value.
Top
See Also

Reference

PropertyItem Class
Sitecore.Commerce Namespace


PropertyItem.Key Property

PropertyItemKey Property
Gets or sets the key.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Key { get; set; }
Public Property Key As String
    Get
    Set
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}
member Key : string with get, set

Property Value

Type: String
The property key.
See Also

Reference

PropertyItem Class
Sitecore.Commerce Namespace


PropertyItem.Value Property

PropertyItemValue Property
Gets or sets the value.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
The value.
See Also

Reference

PropertyItem Class
Sitecore.Commerce Namespace


Templates Class

Templates Class
Contains the CommerceConnect template unique identifiers.
Inheritance Hierarchy
SystemObject
Sitecore.CommerceTemplates

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class Templates
Public NotInheritable Class Templates
public ref class Templates abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Templates =  class end

The Templates type exposes the following members.

Fields
Name | Description
ProductBranchId | The product branch id.
ProductTemplateId | The product template id.
Top
See Also

Reference

Sitecore.Commerce Namespace


Templates Fields

Templates Fields

The Templates type exposes the following members.

Fields
Name | Description
ProductBranchId | The product branch id.
ProductTemplateId | The product template id.
Top
See Also

Reference

Templates Class
Sitecore.Commerce Namespace


Templates.ProductBranchId Field

TemplatesProductBranchId Field
The product branch id.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static readonly ID ProductBranchId
Public Shared ReadOnly ProductBranchId As ID
public:
static initonly ID^ ProductBranchId
static val ProductBranchId: ID

Field Value

Type: ID
See Also

Reference

Templates Class
Sitecore.Commerce Namespace


Templates.ProductTemplateId Field

TemplatesProductTemplateId Field
The product template id.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static readonly ID ProductTemplateId
Public Shared ReadOnly ProductTemplateId As ID
public:
static initonly ID^ ProductTemplateId
static val ProductTemplateId: ID

Field Value

Type: ID
See Also

Reference

Templates Class
Sitecore.Commerce Namespace


Texts Class

Texts Class
Defines the Texts class.
Inheritance Hierarchy
SystemObject
Sitecore.CommerceTexts

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class Texts
Public NotInheritable Class Texts
public ref class Texts abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Texts =  class end

The Texts type exposes the following members.

Fields
Name | Description
AllShopsMustNotBeNullOrEmpty | The "Shops must not be empty. All shops must not be null or empty." message.
ArgumentIsNotAnId | Defines the message: "Argument is not an id."
CannotFindDivisionRepositoryItemWith0 | Defines the message: "Cannot find division repository item with 0."
CannotFindManufacturerRepositoryItemWith0 | Defines the message: "Cannot find manufacturer repository item with 0."
CannotFindProductTypeRepositoryItemWith0 | Defines the message: "Cannot find product type repository item with 0."
CannotFindResourceRepositoryItemWith0 | Defines the message: "Cannot find resource repository item with 0."
CannotFindShopCorrespondingToEaPlanWithName0 | Defines the message: "Cannot find shop corresponding to engagement automation plan with name {0}."
CannotFindTemplateItemWithId0 | Defines the message: "Cannot find template item with 0."
CartCouldNotBeProcessedItIsLocked | Defines the message: "Cart could not be processed. It is locked."
CartCouldNotBeProcessedItIsUnlocked | Defines the message: "Cart could not be processed. It is unlocked."
CartIsNotFound | Defines the message: "Cart is not found.".
CartIsNotSpecified | Defines the message: "Car is not specified."
CollectionOfContextItemsShouldHaveTheOnlyElement | Defines the message: "Collection of context items should have the only element."
ContextSiteCannotBeNull | Defines the message: "Context site cannot be null"
CustomerCouldNotBeCreatedExternalIdIsNotValid | The "Customer could not be created. ExternalId is not valid." message.
CustomerCouldNotBeCreatedItAlreadyExists | The "Customer could not be created. It already exists." message.
CustomerCouldNotBeCreatedNameIsNotProvided | The "Customer could not be created. Name is not provided." message.
CustomerCouldNotBeCreatedShopsAreNotValid | The "Customer could not be created. Shops are not valid." message.
CustomerCouldNotBeDeletedItDoesNotExist | The "Customer could not be deleted. It does not exist." message.
CustomerCouldNotBeDeletedNameIsNotProvided | The "Customer could not be deleted. Name is not provided." message.
CustomerCouldNotBeDisabledItDoesNotExist | The "Customer could not be disabled. It does not exist." message.
CustomerCouldNotBeDisabledNameIsNotProvided | The "Customer could not be disabled. Name is not provided." message.
CustomerCouldNotBeEnabledItDoesNotExist | The "Customer could not be enabled. It does not exist." message.
CustomerCouldNotBeEnabledNameIsNotProvided | The "Customer could not be enabled. Name is not provided." message.
CustomerCouldNotBeUpdatedItDoesNotExist | The "Customer could not be updated. It does not exist." message.
CustomerCouldNotBeUpdatedNameIsNotProvided | The "Customer could not be updated. Name is not provided." message.
CustomerExternalIdIsNotProvided | The "Customer created but external Id was not provided." message.
CustomerMustExist | The "Customer must exist." message.
CustomerMustNotExist | The customer must not exist.
DataIsStoredInWrongFormatCorrentFormatIs | Defines the message: "Data is stored in wrong format. The correct format is =;=;...=. ';' and '=' are escaped by duplication."
EaPlanStateWithName0CannotBeFound | Defines the message: "Engagement automation plan state with name {0} cannot be found."
EaPlanWithName0CannotBeFound | Defines the message: "Engagement automation plan with name {0} cannot be found."
FailedToCreateACart | Defines the message: "Failed to create a cart."
FailedToCreateItemForTheEntityBeingSynchronized | Defines the message: "Failed to create item for the entity being synchronized."
FailedToProcessCart | Defines the message: "Failed to process cart."
FailedToSaveCart | Defines the message: "Failed to save cart."
FailedToSynchronizeProduct0 | Defines the message: "Failed to synchronize product: {}"
OperatorIsNotSupported | Defines the message: "Operator is not supported" phrase.
PaymentInformationPartyDoesNotExist0 | Defines the message: "The given payment information Party reference does not exist: {0}"
ProductClassificationGroupPrefixMustBeSpecified | Defines the message: "ProductClassificationGroupPrefix must be specified."
ProductClassificationPrefixMustBeSpecified | Defines the message: "ProductClassificationPrefix must be specified."
ProductMustNotBeNull | Defines the message: "Product must not be null."
ProductSynchronized0 | Defines the message: "Product synchronized: {0}"
Property0MustBeSet | Defines the message: "Property 0 must be set."
ShippingInformationPartyDoesNotExist0 | Defines the message: "The given shipping information party reference does not exist: {0}"
ShopNameIsNotSpecified | Defines the message: "Shop name is not specified."
ShopsMustNotBeEmpty | The "Shops must not be empty." message.
SynchronizeAllProducts | The synchronize all products.
SynchronizeArtifacts | The synchronize artifacts.
SynchronizeProduct | The synchronize product.
SynchronizeProductDeleted | Defines the message: "Synchronize product. Product deleted: {}"
SynchronizeProductList | The synchronize product list.
SynchronizingAllProductsFromExternalSystem | The synchronizing all products from external system.
SynchronizingArtifactsFromExternalSystem | The synchronizing artifacts from external system.
SynchronizingClassifications | The synchronizing classifications.
SynchronizingClassificationsSpecifications | The synchronizing classifications specifications.
SynchronizingCurrentProductFromExternalSystem | The synchronizing current product from external system.
SynchronizingDivisions | The synchronizing divisions.
SynchronizingGlobalSpecifications | The synchronizing global specifications.
SynchronizingListOfSelectedProductsFromExternalSystem | The synchronizing list of selected products from external system.
SynchronizingManufacturers | The synchronizing manufacturers.
SynchronizingProduct | The synchronizing product.
SynchronizingResources | The "Synchronizing resources" message.
SynchronizingTypeDefaultValues | The synchronizing type default values.
SynchronizingTypes | The synchronizing types.
SynchronizingTypeSpecifications | The synchronizing type specifications.
TheCommerceConnectPageEventsCannotBeDeployedSeeLogForDetails | Defines the message: "The CommerceConnect page events cannot be deployed. See log for details."
UnableToRebuildSearchIndexIndexNameIsMissing | The "Unable to rebuild search index. Index name is missing." text.
UnableToRetrieveProductEntitiesProductIndexIsNotSet | The "Unable to retrieve product entities. Product index is not set." text.
UnableToRetrieveSearchIndex | The "Unable to retrieve search index." text.
UserExternalIdMustBeProvided | The "User created but external Id was not provided." message.
UserNameMustBeProvided | Defines the message: "The user name must be provided."
UserWithName0AlreadyExists | The user with name0 already exists.
UserWithName0DoesNotExist | The user with name0 does not exist.
Top
See Also

Reference

Sitecore.Commerce Namespace


Texts Fields

Texts Fields

The Texts type exposes the following members.

Fields
Name | Description
AllShopsMustNotBeNullOrEmpty | The "Shops must not be empty. All shops must not be null or empty." message.
ArgumentIsNotAnId | Defines the message: "Argument is not an id."
CannotFindDivisionRepositoryItemWith0 | Defines the message: "Cannot find division repository item with 0."
CannotFindManufacturerRepositoryItemWith0 | Defines the message: "Cannot find manufacturer repository item with 0."
CannotFindProductTypeRepositoryItemWith0 | Defines the message: "Cannot find product type repository item with 0."
CannotFindResourceRepositoryItemWith0 | Defines the message: "Cannot find resource repository item with 0."
CannotFindShopCorrespondingToEaPlanWithName0 | Defines the message: "Cannot find shop corresponding to engagement automation plan with name {0}."
CannotFindTemplateItemWithId0 | Defines the message: "Cannot find template item with 0."
CartCouldNotBeProcessedItIsLocked | Defines the message: "Cart could not be processed. It is locked."
CartCouldNotBeProcessedItIsUnlocked | Defines the message: "Cart could not be processed. It is unlocked."
CartIsNotFound | Defines the message: "Cart is not found.".
CartIsNotSpecified | Defines the message: "Car is not specified."
CollectionOfContextItemsShouldHaveTheOnlyElement | Defines the message: "Collection of context items should have the only element."
ContextSiteCannotBeNull | Defines the message: "Context site cannot be null"
CustomerCouldNotBeCreatedExternalIdIsNotValid | The "Customer could not be created. ExternalId is not valid." message.
CustomerCouldNotBeCreatedItAlreadyExists | The "Customer could not be created. It already exists." message.
CustomerCouldNotBeCreatedNameIsNotProvided | The "Customer could not be created. Name is not provided." message.
CustomerCouldNotBeCreatedShopsAreNotValid | The "Customer could not be created. Shops are not valid." message.
CustomerCouldNotBeDeletedItDoesNotExist | The "Customer could not be deleted. It does not exist." message.
CustomerCouldNotBeDeletedNameIsNotProvided | The "Customer could not be deleted. Name is not provided." message.
CustomerCouldNotBeDisabledItDoesNotExist | The "Customer could not be disabled. It does not exist." message.
CustomerCouldNotBeDisabledNameIsNotProvided | The "Customer could not be disabled. Name is not provided." message.
CustomerCouldNotBeEnabledItDoesNotExist | The "Customer could not be enabled. It does not exist." message.
CustomerCouldNotBeEnabledNameIsNotProvided | The "Customer could not be enabled. Name is not provided." message.
CustomerCouldNotBeUpdatedItDoesNotExist | The "Customer could not be updated. It does not exist." message.
CustomerCouldNotBeUpdatedNameIsNotProvided | The "Customer could not be updated. Name is not provided." message.
CustomerExternalIdIsNotProvided | The "Customer created but external Id was not provided." message.
CustomerMustExist | The "Customer must exist." message.
CustomerMustNotExist | The customer must not exist.
DataIsStoredInWrongFormatCorrentFormatIs | Defines the message: "Data is stored in wrong format. The correct format is =;=;...=. ';' and '=' are escaped by duplication."
EaPlanStateWithName0CannotBeFound | Defines the message: "Engagement automation plan state with name {0} cannot be found."
EaPlanWithName0CannotBeFound | Defines the message: "Engagement automation plan with name {0} cannot be found."
FailedToCreateACart | Defines the message: "Failed to create a cart."
FailedToCreateItemForTheEntityBeingSynchronized | Defines the message: "Failed to create item for the entity being synchronized."
FailedToProcessCart | Defines the message: "Failed to process cart."
FailedToSaveCart | Defines the message: "Failed to save cart."
FailedToSynchronizeProduct0 | Defines the message: "Failed to synchronize product: {}"
OperatorIsNotSupported | Defines the message: "Operator is not supported" phrase.
PaymentInformationPartyDoesNotExist0 | Defines the message: "The given payment information Party reference does not exist: {0}"
ProductClassificationGroupPrefixMustBeSpecified | Defines the message: "ProductClassificationGroupPrefix must be specified."
ProductClassificationPrefixMustBeSpecified | Defines the message: "ProductClassificationPrefix must be specified."
ProductMustNotBeNull | Defines the message: "Product must not be null."
ProductSynchronized0 | Defines the message: "Product synchronized: {0}"
Property0MustBeSet | Defines the message: "Property 0 must be set."
ShippingInformationPartyDoesNotExist0 | Defines the message: "The given shipping information party reference does not exist: {0}"
ShopNameIsNotSpecified | Defines the message: "Shop name is not specified."
ShopsMustNotBeEmpty | The "Shops must not be empty." message.
SynchronizeAllProducts | The synchronize all products.
SynchronizeArtifacts | The synchronize artifacts.
SynchronizeProduct | The synchronize product.
SynchronizeProductDeleted | Defines the message: "Synchronize product. Product deleted: {}"
SynchronizeProductList | The synchronize product list.
SynchronizingAllProductsFromExternalSystem | The synchronizing all products from external system.
SynchronizingArtifactsFromExternalSystem | The synchronizing artifacts from external system.
SynchronizingClassifications | The synchronizing classifications.
SynchronizingClassificationsSpecifications | The synchronizing classifications specifications.
SynchronizingCurrentProductFromExternalSystem | The synchronizing current product from external system.
SynchronizingDivisions | The synchronizing divisions.
SynchronizingGlobalSpecifications | The synchronizing global specifications.
SynchronizingListOfSelectedProductsFromExternalSystem | The synchronizing list of selected products from external system.
SynchronizingManufacturers | The synchronizing manufacturers.
SynchronizingProduct | The synchronizing product.
SynchronizingResources | The "Synchronizing resources" message.
SynchronizingTypeDefaultValues | The synchronizing type default values.
SynchronizingTypes | The synchronizing types.
SynchronizingTypeSpecifications | The synchronizing type specifications.
TheCommerceConnectPageEventsCannotBeDeployedSeeLogForDetails | Defines the message: "The CommerceConnect page events cannot be deployed. See log for details."
UnableToRebuildSearchIndexIndexNameIsMissing | The "Unable to rebuild search index. Index name is missing." text.
UnableToRetrieveProductEntitiesProductIndexIsNotSet | The "Unable to retrieve product entities. Product index is not set." text.
UnableToRetrieveSearchIndex | The "Unable to retrieve search index." text.
UserExternalIdMustBeProvided | The "User created but external Id was not provided." message.
UserNameMustBeProvided | Defines the message: "The user name must be provided."
UserWithName0AlreadyExists | The user with name0 already exists.
UserWithName0DoesNotExist | The user with name0 does not exist.
Top
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.AllShopsMustNotBeNullOrEmpty Field

TextsAllShopsMustNotBeNullOrEmpty Field
The "Shops must not be empty. All shops must not be null or empty." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string AllShopsMustNotBeNullOrEmpty
Public Const AllShopsMustNotBeNullOrEmpty As String
public:
literal String^ AllShopsMustNotBeNullOrEmpty
static val mutable AllShopsMustNotBeNullOrEmpty: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.ArgumentIsNotAnId Field

TextsArgumentIsNotAnId Field
Defines the message: "Argument is not an id."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ArgumentIsNotAnId
Public Const ArgumentIsNotAnId As String
public:
literal String^ ArgumentIsNotAnId
static val mutable ArgumentIsNotAnId: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CannotFindDivisionRepositoryItemWith0 Field

TextsCannotFindDivisionRepositoryItemWith0 Field
Defines the message: "Cannot find division repository item with 0."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CannotFindDivisionRepositoryItemWith0
Public Const CannotFindDivisionRepositoryItemWith0 As String
public:
literal String^ CannotFindDivisionRepositoryItemWith0
static val mutable CannotFindDivisionRepositoryItemWith0: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CannotFindManufacturerRepositoryItemWith0 Field

TextsCannotFindManufacturerRepositoryItemWith0 Field
Defines the message: "Cannot find manufacturer repository item with 0."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CannotFindManufacturerRepositoryItemWith0
Public Const CannotFindManufacturerRepositoryItemWith0 As String
public:
literal String^ CannotFindManufacturerRepositoryItemWith0
static val mutable CannotFindManufacturerRepositoryItemWith0: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CannotFindProductTypeRepositoryItemWith0 Field

TextsCannotFindProductTypeRepositoryItemWith0 Field
Defines the message: "Cannot find product type repository item with 0."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CannotFindProductTypeRepositoryItemWith0
Public Const CannotFindProductTypeRepositoryItemWith0 As String
public:
literal String^ CannotFindProductTypeRepositoryItemWith0
static val mutable CannotFindProductTypeRepositoryItemWith0: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CannotFindResourceRepositoryItemWith0 Field

TextsCannotFindResourceRepositoryItemWith0 Field
Defines the message: "Cannot find resource repository item with 0."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CannotFindResourceRepositoryItemWith0
Public Const CannotFindResourceRepositoryItemWith0 As String
public:
literal String^ CannotFindResourceRepositoryItemWith0
static val mutable CannotFindResourceRepositoryItemWith0: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CannotFindShopCorrespondingToEaPlanWithName0 Field

TextsCannotFindShopCorrespondingToEaPlanWithName0 Field
Defines the message: "Cannot find shop corresponding to engagement automation plan with name {0}."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CannotFindShopCorrespondingToEaPlanWithName0
Public Const CannotFindShopCorrespondingToEaPlanWithName0 As String
public:
literal String^ CannotFindShopCorrespondingToEaPlanWithName0
static val mutable CannotFindShopCorrespondingToEaPlanWithName0: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CannotFindTemplateItemWithId0 Field

TextsCannotFindTemplateItemWithId0 Field
Defines the message: "Cannot find template item with 0."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CannotFindTemplateItemWithId0
Public Const CannotFindTemplateItemWithId0 As String
public:
literal String^ CannotFindTemplateItemWithId0
static val mutable CannotFindTemplateItemWithId0: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CartCouldNotBeProcessedItIsLocked Field

TextsCartCouldNotBeProcessedItIsLocked Field
Defines the message: "Cart could not be processed. It is locked."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CartCouldNotBeProcessedItIsLocked
Public Const CartCouldNotBeProcessedItIsLocked As String
public:
literal String^ CartCouldNotBeProcessedItIsLocked
static val mutable CartCouldNotBeProcessedItIsLocked: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CartCouldNotBeProcessedItIsUnlocked Field

TextsCartCouldNotBeProcessedItIsUnlocked Field
Defines the message: "Cart could not be processed. It is unlocked."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CartCouldNotBeProcessedItIsUnlocked
Public Const CartCouldNotBeProcessedItIsUnlocked As String
public:
literal String^ CartCouldNotBeProcessedItIsUnlocked
static val mutable CartCouldNotBeProcessedItIsUnlocked: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CartIsNotFound Field

TextsCartIsNotFound Field
Defines the message: "Cart is not found.".

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CartIsNotFound
Public Const CartIsNotFound As String
public:
literal String^ CartIsNotFound
static val mutable CartIsNotFound: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CartIsNotSpecified Field

TextsCartIsNotSpecified Field
Defines the message: "Car is not specified."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CartIsNotSpecified
Public Const CartIsNotSpecified As String
public:
literal String^ CartIsNotSpecified
static val mutable CartIsNotSpecified: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CollectionOfContextItemsShouldHaveTheOnlyElement Field

TextsCollectionOfContextItemsShouldHaveTheOnlyElement Field
Defines the message: "Collection of context items should have the only element."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CollectionOfContextItemsShouldHaveTheOnlyElement
Public Const CollectionOfContextItemsShouldHaveTheOnlyElement As String
public:
literal String^ CollectionOfContextItemsShouldHaveTheOnlyElement
static val mutable CollectionOfContextItemsShouldHaveTheOnlyElement: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.ContextSiteCannotBeNull Field

TextsContextSiteCannotBeNull Field
Defines the message: "Context site cannot be null"

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ContextSiteCannotBeNull
Public Const ContextSiteCannotBeNull As String
public:
literal String^ ContextSiteCannotBeNull
static val mutable ContextSiteCannotBeNull: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerCouldNotBeCreatedExternalIdIsNotValid Field

TextsCustomerCouldNotBeCreatedExternalIdIsNotValid Field
The "Customer could not be created. ExternalId is not valid." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerCouldNotBeCreatedExternalIdIsNotValid
Public Const CustomerCouldNotBeCreatedExternalIdIsNotValid As String
public:
literal String^ CustomerCouldNotBeCreatedExternalIdIsNotValid
static val mutable CustomerCouldNotBeCreatedExternalIdIsNotValid: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerCouldNotBeCreatedItAlreadyExists Field

TextsCustomerCouldNotBeCreatedItAlreadyExists Field
The "Customer could not be created. It already exists." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerCouldNotBeCreatedItAlreadyExists
Public Const CustomerCouldNotBeCreatedItAlreadyExists As String
public:
literal String^ CustomerCouldNotBeCreatedItAlreadyExists
static val mutable CustomerCouldNotBeCreatedItAlreadyExists: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerCouldNotBeCreatedNameIsNotProvided Field

TextsCustomerCouldNotBeCreatedNameIsNotProvided Field
The "Customer could not be created. Name is not provided." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerCouldNotBeCreatedNameIsNotProvided
Public Const CustomerCouldNotBeCreatedNameIsNotProvided As String
public:
literal String^ CustomerCouldNotBeCreatedNameIsNotProvided
static val mutable CustomerCouldNotBeCreatedNameIsNotProvided: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerCouldNotBeCreatedShopsAreNotValid Field

TextsCustomerCouldNotBeCreatedShopsAreNotValid Field
The "Customer could not be created. Shops are not valid." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerCouldNotBeCreatedShopsAreNotValid
Public Const CustomerCouldNotBeCreatedShopsAreNotValid As String
public:
literal String^ CustomerCouldNotBeCreatedShopsAreNotValid
static val mutable CustomerCouldNotBeCreatedShopsAreNotValid: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerCouldNotBeDeletedItDoesNotExist Field

TextsCustomerCouldNotBeDeletedItDoesNotExist Field
The "Customer could not be deleted. It does not exist." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerCouldNotBeDeletedItDoesNotExist
Public Const CustomerCouldNotBeDeletedItDoesNotExist As String
public:
literal String^ CustomerCouldNotBeDeletedItDoesNotExist
static val mutable CustomerCouldNotBeDeletedItDoesNotExist: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerCouldNotBeDeletedNameIsNotProvided Field

TextsCustomerCouldNotBeDeletedNameIsNotProvided Field
The "Customer could not be deleted. Name is not provided." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerCouldNotBeDeletedNameIsNotProvided
Public Const CustomerCouldNotBeDeletedNameIsNotProvided As String
public:
literal String^ CustomerCouldNotBeDeletedNameIsNotProvided
static val mutable CustomerCouldNotBeDeletedNameIsNotProvided: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerCouldNotBeDisabledItDoesNotExist Field

TextsCustomerCouldNotBeDisabledItDoesNotExist Field
The "Customer could not be disabled. It does not exist." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerCouldNotBeDisabledItDoesNotExist
Public Const CustomerCouldNotBeDisabledItDoesNotExist As String
public:
literal String^ CustomerCouldNotBeDisabledItDoesNotExist
static val mutable CustomerCouldNotBeDisabledItDoesNotExist: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerCouldNotBeDisabledNameIsNotProvided Field

TextsCustomerCouldNotBeDisabledNameIsNotProvided Field
The "Customer could not be disabled. Name is not provided." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerCouldNotBeDisabledNameIsNotProvided
Public Const CustomerCouldNotBeDisabledNameIsNotProvided As String
public:
literal String^ CustomerCouldNotBeDisabledNameIsNotProvided
static val mutable CustomerCouldNotBeDisabledNameIsNotProvided: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerCouldNotBeEnabledItDoesNotExist Field

TextsCustomerCouldNotBeEnabledItDoesNotExist Field
The "Customer could not be enabled. It does not exist." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerCouldNotBeEnabledItDoesNotExist
Public Const CustomerCouldNotBeEnabledItDoesNotExist As String
public:
literal String^ CustomerCouldNotBeEnabledItDoesNotExist
static val mutable CustomerCouldNotBeEnabledItDoesNotExist: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerCouldNotBeEnabledNameIsNotProvided Field

TextsCustomerCouldNotBeEnabledNameIsNotProvided Field
The "Customer could not be enabled. Name is not provided." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerCouldNotBeEnabledNameIsNotProvided
Public Const CustomerCouldNotBeEnabledNameIsNotProvided As String
public:
literal String^ CustomerCouldNotBeEnabledNameIsNotProvided
static val mutable CustomerCouldNotBeEnabledNameIsNotProvided: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerCouldNotBeUpdatedItDoesNotExist Field

TextsCustomerCouldNotBeUpdatedItDoesNotExist Field
The "Customer could not be updated. It does not exist." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerCouldNotBeUpdatedItDoesNotExist
Public Const CustomerCouldNotBeUpdatedItDoesNotExist As String
public:
literal String^ CustomerCouldNotBeUpdatedItDoesNotExist
static val mutable CustomerCouldNotBeUpdatedItDoesNotExist: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerCouldNotBeUpdatedNameIsNotProvided Field

TextsCustomerCouldNotBeUpdatedNameIsNotProvided Field
The "Customer could not be updated. Name is not provided." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerCouldNotBeUpdatedNameIsNotProvided
Public Const CustomerCouldNotBeUpdatedNameIsNotProvided As String
public:
literal String^ CustomerCouldNotBeUpdatedNameIsNotProvided
static val mutable CustomerCouldNotBeUpdatedNameIsNotProvided: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerExternalIdIsNotProvided Field

TextsCustomerExternalIdIsNotProvided Field
The "Customer created but external Id was not provided." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerExternalIdIsNotProvided
Public Const CustomerExternalIdIsNotProvided As String
public:
literal String^ CustomerExternalIdIsNotProvided
static val mutable CustomerExternalIdIsNotProvided: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerMustExist Field

TextsCustomerMustExist Field
The "Customer must exist." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerMustExist
Public Const CustomerMustExist As String
public:
literal String^ CustomerMustExist
static val mutable CustomerMustExist: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.CustomerMustNotExist Field

TextsCustomerMustNotExist Field
The customer must not exist.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerMustNotExist
Public Const CustomerMustNotExist As String
public:
literal String^ CustomerMustNotExist
static val mutable CustomerMustNotExist: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.DataIsStoredInWrongFormatCorrentFormatIs Field

TextsDataIsStoredInWrongFormatCorrentFormatIs Field
Defines the message: "Data is stored in wrong format. The correct format is =;=;...=. ';' and '=' are escaped by duplication."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string DataIsStoredInWrongFormatCorrentFormatIs
Public Const DataIsStoredInWrongFormatCorrentFormatIs As String
public:
literal String^ DataIsStoredInWrongFormatCorrentFormatIs
static val mutable DataIsStoredInWrongFormatCorrentFormatIs: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.EaPlanStateWithName0CannotBeFound Field

TextsEaPlanStateWithName0CannotBeFound Field
Defines the message: "Engagement automation plan state with name {0} cannot be found."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string EaPlanStateWithName0CannotBeFound
Public Const EaPlanStateWithName0CannotBeFound As String
public:
literal String^ EaPlanStateWithName0CannotBeFound
static val mutable EaPlanStateWithName0CannotBeFound: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.EaPlanWithName0CannotBeFound Field

TextsEaPlanWithName0CannotBeFound Field
Defines the message: "Engagement automation plan with name {0} cannot be found."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string EaPlanWithName0CannotBeFound
Public Const EaPlanWithName0CannotBeFound As String
public:
literal String^ EaPlanWithName0CannotBeFound
static val mutable EaPlanWithName0CannotBeFound: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.FailedToCreateACart Field

TextsFailedToCreateACart Field
Defines the message: "Failed to create a cart."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string FailedToCreateACart
Public Const FailedToCreateACart As String
public:
literal String^ FailedToCreateACart
static val mutable FailedToCreateACart: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.FailedToCreateItemForTheEntityBeingSynchronized Field

TextsFailedToCreateItemForTheEntityBeingSynchronized Field
Defines the message: "Failed to create item for the entity being synchronized."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string FailedToCreateItemForTheEntityBeingSynchronized
Public Const FailedToCreateItemForTheEntityBeingSynchronized As String
public:
literal String^ FailedToCreateItemForTheEntityBeingSynchronized
static val mutable FailedToCreateItemForTheEntityBeingSynchronized: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.FailedToProcessCart Field

TextsFailedToProcessCart Field
Defines the message: "Failed to process cart."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string FailedToProcessCart
Public Const FailedToProcessCart As String
public:
literal String^ FailedToProcessCart
static val mutable FailedToProcessCart: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.FailedToSaveCart Field

TextsFailedToSaveCart Field
Defines the message: "Failed to save cart."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string FailedToSaveCart
Public Const FailedToSaveCart As String
public:
literal String^ FailedToSaveCart
static val mutable FailedToSaveCart: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.FailedToSynchronizeProduct0 Field

TextsFailedToSynchronizeProduct0 Field
Defines the message: "Failed to synchronize product: {}"

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string FailedToSynchronizeProduct0
Public Const FailedToSynchronizeProduct0 As String
public:
literal String^ FailedToSynchronizeProduct0
static val mutable FailedToSynchronizeProduct0: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.OperatorIsNotSupported Field

TextsOperatorIsNotSupported Field
Defines the message: "Operator is not supported" phrase.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string OperatorIsNotSupported
Public Const OperatorIsNotSupported As String
public:
literal String^ OperatorIsNotSupported
static val mutable OperatorIsNotSupported: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.PaymentInformationPartyDoesNotExist0 Field

TextsPaymentInformationPartyDoesNotExist0 Field
Defines the message: "The given payment information Party reference does not exist: {0}"

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string PaymentInformationPartyDoesNotExist0
Public Const PaymentInformationPartyDoesNotExist0 As String
public:
literal String^ PaymentInformationPartyDoesNotExist0
static val mutable PaymentInformationPartyDoesNotExist0: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.ProductClassificationGroupPrefixMustBeSpecified Field

TextsProductClassificationGroupPrefixMustBeSpecified Field
Defines the message: "ProductClassificationGroupPrefix must be specified."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ProductClassificationGroupPrefixMustBeSpecified
Public Const ProductClassificationGroupPrefixMustBeSpecified As String
public:
literal String^ ProductClassificationGroupPrefixMustBeSpecified
static val mutable ProductClassificationGroupPrefixMustBeSpecified: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.ProductClassificationPrefixMustBeSpecified Field

TextsProductClassificationPrefixMustBeSpecified Field
Defines the message: "ProductClassificationPrefix must be specified."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ProductClassificationPrefixMustBeSpecified
Public Const ProductClassificationPrefixMustBeSpecified As String
public:
literal String^ ProductClassificationPrefixMustBeSpecified
static val mutable ProductClassificationPrefixMustBeSpecified: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.ProductMustNotBeNull Field

TextsProductMustNotBeNull Field
Defines the message: "Product must not be null."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ProductMustNotBeNull
Public Const ProductMustNotBeNull As String
public:
literal String^ ProductMustNotBeNull
static val mutable ProductMustNotBeNull: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.ProductSynchronized0 Field

TextsProductSynchronized0 Field
Defines the message: "Product synchronized: {0}"

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ProductSynchronized0
Public Const ProductSynchronized0 As String
public:
literal String^ ProductSynchronized0
static val mutable ProductSynchronized0: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.Property0MustBeSet Field

TextsProperty0MustBeSet Field
Defines the message: "Property 0 must be set."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string Property0MustBeSet
Public Const Property0MustBeSet As String
public:
literal String^ Property0MustBeSet
static val mutable Property0MustBeSet: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.ShippingInformationPartyDoesNotExist0 Field

TextsShippingInformationPartyDoesNotExist0 Field
Defines the message: "The given shipping information party reference does not exist: {0}"

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ShippingInformationPartyDoesNotExist0
Public Const ShippingInformationPartyDoesNotExist0 As String
public:
literal String^ ShippingInformationPartyDoesNotExist0
static val mutable ShippingInformationPartyDoesNotExist0: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.ShopNameIsNotSpecified Field

TextsShopNameIsNotSpecified Field
Defines the message: "Shop name is not specified."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ShopNameIsNotSpecified
Public Const ShopNameIsNotSpecified As String
public:
literal String^ ShopNameIsNotSpecified
static val mutable ShopNameIsNotSpecified: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.ShopsMustNotBeEmpty Field

TextsShopsMustNotBeEmpty Field
The "Shops must not be empty." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ShopsMustNotBeEmpty
Public Const ShopsMustNotBeEmpty As String
public:
literal String^ ShopsMustNotBeEmpty
static val mutable ShopsMustNotBeEmpty: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizeAllProducts Field

TextsSynchronizeAllProducts Field
The synchronize all products.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeAllProducts
Public Const SynchronizeAllProducts As String
public:
literal String^ SynchronizeAllProducts
static val mutable SynchronizeAllProducts: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizeArtifacts Field

TextsSynchronizeArtifacts Field
The synchronize artifacts.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeArtifacts
Public Const SynchronizeArtifacts As String
public:
literal String^ SynchronizeArtifacts
static val mutable SynchronizeArtifacts: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizeProduct Field

TextsSynchronizeProduct Field
The synchronize product.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProduct
Public Const SynchronizeProduct As String
public:
literal String^ SynchronizeProduct
static val mutable SynchronizeProduct: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizeProductDeleted Field

TextsSynchronizeProductDeleted Field
Defines the message: "Synchronize product. Product deleted: {}"

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProductDeleted
Public Const SynchronizeProductDeleted As String
public:
literal String^ SynchronizeProductDeleted
static val mutable SynchronizeProductDeleted: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizeProductList Field

TextsSynchronizeProductList Field
The synchronize product list.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProductList
Public Const SynchronizeProductList As String
public:
literal String^ SynchronizeProductList
static val mutable SynchronizeProductList: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizingAllProductsFromExternalSystem Field

TextsSynchronizingAllProductsFromExternalSystem Field
The synchronizing all products from external system.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizingAllProductsFromExternalSystem
Public Const SynchronizingAllProductsFromExternalSystem As String
public:
literal String^ SynchronizingAllProductsFromExternalSystem
static val mutable SynchronizingAllProductsFromExternalSystem: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizingArtifactsFromExternalSystem Field

TextsSynchronizingArtifactsFromExternalSystem Field
The synchronizing artifacts from external system.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizingArtifactsFromExternalSystem
Public Const SynchronizingArtifactsFromExternalSystem As String
public:
literal String^ SynchronizingArtifactsFromExternalSystem
static val mutable SynchronizingArtifactsFromExternalSystem: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizingClassifications Field

TextsSynchronizingClassifications Field
The synchronizing classifications.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizingClassifications
Public Const SynchronizingClassifications As String
public:
literal String^ SynchronizingClassifications
static val mutable SynchronizingClassifications: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizingClassificationsSpecifications Field

TextsSynchronizingClassificationsSpecifications Field
The synchronizing classifications specifications.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizingClassificationsSpecifications
Public Const SynchronizingClassificationsSpecifications As String
public:
literal String^ SynchronizingClassificationsSpecifications
static val mutable SynchronizingClassificationsSpecifications: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizingCurrentProductFromExternalSystem Field

TextsSynchronizingCurrentProductFromExternalSystem Field
The synchronizing current product from external system.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizingCurrentProductFromExternalSystem
Public Const SynchronizingCurrentProductFromExternalSystem As String
public:
literal String^ SynchronizingCurrentProductFromExternalSystem
static val mutable SynchronizingCurrentProductFromExternalSystem: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizingDivisions Field

TextsSynchronizingDivisions Field
The synchronizing divisions.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizingDivisions
Public Const SynchronizingDivisions As String
public:
literal String^ SynchronizingDivisions
static val mutable SynchronizingDivisions: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizingGlobalSpecifications Field

TextsSynchronizingGlobalSpecifications Field
The synchronizing global specifications.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizingGlobalSpecifications
Public Const SynchronizingGlobalSpecifications As String
public:
literal String^ SynchronizingGlobalSpecifications
static val mutable SynchronizingGlobalSpecifications: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizingListOfSelectedProductsFromExternalSystem Field

TextsSynchronizingListOfSelectedProductsFromExternalSystem Field
The synchronizing list of selected products from external system.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizingListOfSelectedProductsFromExternalSystem
Public Const SynchronizingListOfSelectedProductsFromExternalSystem As String
public:
literal String^ SynchronizingListOfSelectedProductsFromExternalSystem
static val mutable SynchronizingListOfSelectedProductsFromExternalSystem: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizingManufacturers Field

TextsSynchronizingManufacturers Field
The synchronizing manufacturers.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizingManufacturers
Public Const SynchronizingManufacturers As String
public:
literal String^ SynchronizingManufacturers
static val mutable SynchronizingManufacturers: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizingProduct Field

TextsSynchronizingProduct Field
The synchronizing product.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizingProduct
Public Const SynchronizingProduct As String
public:
literal String^ SynchronizingProduct
static val mutable SynchronizingProduct: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizingResources Field

TextsSynchronizingResources Field
The "Synchronizing resources" message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizingResources
Public Const SynchronizingResources As String
public:
literal String^ SynchronizingResources
static val mutable SynchronizingResources: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizingTypeDefaultValues Field

TextsSynchronizingTypeDefaultValues Field
The synchronizing type default values.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizingTypeDefaultValues
Public Const SynchronizingTypeDefaultValues As String
public:
literal String^ SynchronizingTypeDefaultValues
static val mutable SynchronizingTypeDefaultValues: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizingTypes Field

TextsSynchronizingTypes Field
The synchronizing types.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizingTypes
Public Const SynchronizingTypes As String
public:
literal String^ SynchronizingTypes
static val mutable SynchronizingTypes: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.SynchronizingTypeSpecifications Field

TextsSynchronizingTypeSpecifications Field
The synchronizing type specifications.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizingTypeSpecifications
Public Const SynchronizingTypeSpecifications As String
public:
literal String^ SynchronizingTypeSpecifications
static val mutable SynchronizingTypeSpecifications: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.TheCommerceConnectPageEventsCannotBeDeployedSeeLogForDetails Field

TextsTheCommerceConnectPageEventsCannotBeDeployedSeeLogForDetails Field
Defines the message: "The CommerceConnect page events cannot be deployed. See log for details."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string TheCommerceConnectPageEventsCannotBeDeployedSeeLogForDetails
Public Const TheCommerceConnectPageEventsCannotBeDeployedSeeLogForDetails As String
public:
literal String^ TheCommerceConnectPageEventsCannotBeDeployedSeeLogForDetails
static val mutable TheCommerceConnectPageEventsCannotBeDeployedSeeLogForDetails: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.UnableToRebuildSearchIndexIndexNameIsMissing Field

TextsUnableToRebuildSearchIndexIndexNameIsMissing Field
The "Unable to rebuild search index. Index name is missing." text.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UnableToRebuildSearchIndexIndexNameIsMissing
Public Const UnableToRebuildSearchIndexIndexNameIsMissing As String
public:
literal String^ UnableToRebuildSearchIndexIndexNameIsMissing
static val mutable UnableToRebuildSearchIndexIndexNameIsMissing: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.UnableToRetrieveProductEntitiesProductIndexIsNotSet Field

TextsUnableToRetrieveProductEntitiesProductIndexIsNotSet Field
The "Unable to retrieve product entities. Product index is not set." text.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UnableToRetrieveProductEntitiesProductIndexIsNotSet
Public Const UnableToRetrieveProductEntitiesProductIndexIsNotSet As String
public:
literal String^ UnableToRetrieveProductEntitiesProductIndexIsNotSet
static val mutable UnableToRetrieveProductEntitiesProductIndexIsNotSet: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.UnableToRetrieveSearchIndex Field

TextsUnableToRetrieveSearchIndex Field
The "Unable to retrieve search index." text.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UnableToRetrieveSearchIndex
Public Const UnableToRetrieveSearchIndex As String
public:
literal String^ UnableToRetrieveSearchIndex
static val mutable UnableToRetrieveSearchIndex: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.UserExternalIdMustBeProvided Field

TextsUserExternalIdMustBeProvided Field
The "User created but external Id was not provided." message.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UserExternalIdMustBeProvided
Public Const UserExternalIdMustBeProvided As String
public:
literal String^ UserExternalIdMustBeProvided
static val mutable UserExternalIdMustBeProvided: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.UserNameMustBeProvided Field

TextsUserNameMustBeProvided Field
Defines the message: "The user name must be provided."

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UserNameMustBeProvided
Public Const UserNameMustBeProvided As String
public:
literal String^ UserNameMustBeProvided
static val mutable UserNameMustBeProvided: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.UserWithName0AlreadyExists Field

TextsUserWithName0AlreadyExists Field
The user with name0 already exists.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UserWithName0AlreadyExists
Public Const UserWithName0AlreadyExists As String
public:
literal String^ UserWithName0AlreadyExists
static val mutable UserWithName0AlreadyExists: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Texts.UserWithName0DoesNotExist Field

TextsUserWithName0DoesNotExist Field
The user with name0 does not exist.

Namespace: Sitecore.Commerce
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UserWithName0DoesNotExist
Public Const UserWithName0DoesNotExist As String
public:
literal String^ UserWithName0DoesNotExist
static val mutable UserWithName0DoesNotExist: string

Field Value

Type: String
See Also

Reference

Texts Class
Sitecore.Commerce Namespace


Sitecore.Commerce.Automation.MarketingAutomation Namespace

Sitecore.Commerce.Automation.MarketingAutomation Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Automation.MarketingAutomation"]

Classes
 | Class | Description
Public class | AutomationHelper | Represents the engagement automation helper. This class is used to set values for the different fields in automation states table.
Public class | InventoryAutomationProvider | Helper class for inventory automation rules and conditions


AutomationHelper Class

AutomationHelper Class
Represents the engagement automation helper. This class is used to set values for the different fields in automation states table.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Automation.MarketingAutomationAutomationHelper

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class AutomationHelper
Public NotInheritable Class AutomationHelper
public ref class AutomationHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AutomationHelper =  class end

The AutomationHelper type exposes the following members.

Methods
Name | Description
GetPageEventDataT | Retrieves page event data from the current context.
GetStateDataT | Retrieves data from an automation plan state.
SerializeData | Serializes data into an automation plan state.
SetStateNameAndWakeUpDateTimeValues | Assigns values for the state Name] and [WakeupDateTime] fields of the [AutomationStates] table. StateName is taken from the item as is, and wakeupDateTime is calculated regarding the timeout value.
SetStateNameWakeUpDateTimeAndDataValues | Fill the values of the [StateName], [WakeupDateTime] and [Data] fields of the [AutomationStates] table. StateName is taken from the item as is, and wakeupDateTime is calculated regarding the timeout value. Data is filled as is.
VisitorIsInAnyEngagementPlanState | Checks is the visitor is already in the engagement plan
Top
See Also

Reference

Sitecore.Commerce.Automation.MarketingAutomation Namespace


AutomationHelper Methods

AutomationHelper Methods

The AutomationHelper type exposes the following members.

Methods
Name | Description
GetPageEventDataT | Retrieves page event data from the current context.
GetStateDataT | Retrieves data from an automation plan state.
SerializeData | Serializes data into an automation plan state.
SetStateNameAndWakeUpDateTimeValues | Assigns values for the state Name] and [WakeupDateTime] fields of the [AutomationStates] table. StateName is taken from the item as is, and wakeupDateTime is calculated regarding the timeout value.
SetStateNameWakeUpDateTimeAndDataValues | Fill the values of the [StateName], [WakeupDateTime] and [Data] fields of the [AutomationStates] table. StateName is taken from the item as is, and wakeupDateTime is calculated regarding the timeout value. Data is filled as is.
VisitorIsInAnyEngagementPlanState | Checks is the visitor is already in the engagement plan
Top
See Also

Reference

AutomationHelper Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


AutomationHelper.GetPageEventData(T) Method

AutomationHelperGetPageEventDataT Method
Retrieves page event data from the current context.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static T GetPageEventData<T>(
    Guid pageEventId
)

Public Shared Function GetPageEventData(Of T) (
    pageEventId As Guid
) As T
public:
generic<typename T>
static T GetPageEventData(
    Guid pageEventId
)
static member GetPageEventData :
        pageEventId : Guid -> 'T

Parameters

pageEventId
Type: SystemGuid
The Id of the page event

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.Commerce.Automation.MarketingAutomation.AutomationHelper.GetPageEventData``1(System.Guid)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Sitecore.Commerce.Automation.MarketingAutomation.AutomationHelper.GetPageEventData``1(System.Guid)"]

See Also

Reference

AutomationHelper Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


AutomationHelper.GetStateData(T) Method

AutomationHelperGetStateDataT Method
Retrieves data from an automation plan state.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static T GetStateData<T>(
    string dataKey,
    AutomationStatesRow dataRow
)

Public Shared Function GetStateData(Of T) (
    dataKey As String,
    dataRow As AutomationStatesRow
) As T
public:
generic<typename T>
static T GetStateData(
    String^ dataKey,
    AutomationStatesRow^ dataRow
)
static member GetStateData :
        dataKey : string *
        dataRow : AutomationStatesRow -> 'T

Parameters

dataKey
Type: SystemString
The name of the data key.
dataRow
Type: AutomationStatesRow
The automation state data row.

Type Parameters

T
The type of data to return.

Return Value

Type: T
The automation plan state data.
See Also

Reference

AutomationHelper Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


AutomationHelper.SerializeData Method

AutomationHelperSerializeData Method
Serializes data into an automation plan state.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static void SerializeData(
    string dataKey,
    AutomationStatesRow dataRow,
    Object data
)
Public Shared Sub SerializeData (
    dataKey As String,
    dataRow As AutomationStatesRow,
    data As Object
)
public:
static void SerializeData(
    String^ dataKey,
    AutomationStatesRow^ dataRow,
    Object^ data
)
static member SerializeData :
        dataKey : string *
        dataRow : AutomationStatesRow *
        data : Object -> unit

Parameters

dataKey
Type: SystemString
The name of the data key.
dataRow
Type: AutomationStatesRow
The automation state data row.
data
Type: SystemObject
The data to serialize.
See Also

Reference

AutomationHelper Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


AutomationHelper.SetStateNameAndWakeUpDateTimeValues Method

AutomationHelperSetStateNameAndWakeUpDateTimeValues Method
Assigns values for the state Name] and [WakeupDateTime] fields of the [AutomationStates] table. StateName is taken from the item as is, and wakeupDateTime is calculated regarding the timeout value.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static void SetStateNameAndWakeUpDateTimeValues(
    ID stateId,
    string userId
)
Public Shared Sub SetStateNameAndWakeUpDateTimeValues (
    stateId As ID,
    userId As String
)
public:
static void SetStateNameAndWakeUpDateTimeValues(
    ID^ stateId,
    String^ userId
)
static member SetStateNameAndWakeUpDateTimeValues :
        stateId : ID *
        userId : string -> unit

Parameters

stateId
Type: ID
The state ID.
userId
Type: SystemString
The user ID.
See Also

Reference

AutomationHelper Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


AutomationHelper.SetStateNameWakeUpDateTimeAndDataValues Method

AutomationHelperSetStateNameWakeUpDateTimeAndDataValues Method
Fill the values of the [StateName], [WakeupDateTime] and [Data] fields of the [AutomationStates] table. StateName is taken from the item as is, and wakeupDateTime is calculated regarding the timeout value. Data is filled as is.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static void SetStateNameWakeUpDateTimeAndDataValues(
    ID stateId,
    string userId,
    string data
)
Public Shared Sub SetStateNameWakeUpDateTimeAndDataValues (
    stateId As ID,
    userId As String,
    data As String
)
public:
static void SetStateNameWakeUpDateTimeAndDataValues(
    ID^ stateId,
    String^ userId,
    String^ data
)
static member SetStateNameWakeUpDateTimeAndDataValues :
        stateId : ID *
        userId : string *
        data : string -> unit

Parameters

stateId
Type: ID
The state ID.
userId
Type: SystemString
The user ID.
data
Type: SystemString
The data.
See Also

Reference

AutomationHelper Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


AutomationHelper.VisitorIsInAnyEngagementPlanState Method

AutomationHelperVisitorIsInAnyEngagementPlanState Method
Checks is the visitor is already in the engagement plan

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static bool VisitorIsInAnyEngagementPlanState(
    string visitorId,
    EngagementPlanItem engagementPlan,
    out ID stateId
)
Public Shared Function VisitorIsInAnyEngagementPlanState (
    visitorId As String,
    engagementPlan As EngagementPlanItem,
    <OutAttribute> ByRef stateId As ID
) As Boolean
public:
static bool VisitorIsInAnyEngagementPlanState(
    String^ visitorId,
    EngagementPlanItem^ engagementPlan,
    [OutAttribute] ID^% stateId
)
static member VisitorIsInAnyEngagementPlanState :
        visitorId : string *
        engagementPlan : EngagementPlanItem *
        stateId : ID byref -> bool

Parameters

visitorId
Type: SystemString
The visitor ID.
engagementPlan
Type: EngagementPlanItem
The engagement plan.
stateId
Type: ID
The state id.

Return Value

Type: Boolean
True is visitor is already in the engagement plan, false otherwise.
See Also

Reference

AutomationHelper Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider Class

InventoryAutomationProvider Class
Helper class for inventory automation rules and conditions
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Automation.MarketingAutomationInventoryAutomationProvider

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class InventoryAutomationProvider
Public Class InventoryAutomationProvider
public ref class InventoryAutomationProvider
type InventoryAutomationProvider =  class end

The InventoryAutomationProvider type exposes the following members.

Constructors
 | Name | Description
Public method | InventoryAutomationProvider | Initializes an instance of the InventoryAutomationProvider class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindBackInStockProductsFromPageEventData | Finds the products that are back in stock based on page evennt data.
Protected method | FindBackInStockProductsFromServiceProvider | Finds the products that are back in stock based on a GetBackInStockInformationResult.
Public method | FindNotification | Finds a StockNotificationRequest from a list
Public method | GetAutomationStatesRow | Gets the auutomation state data row data for a visitor.
Public method | GetBackInStockProducts | Gets the products from a product notification list that are now back in stock
Protected method | GetBackInStockProductsFromPageEventData | Gets the products from a product notification list that are now back in stock based on page event data.
Protected method | GetBackInStockProductsFromServiceProvider | Gets the products from a product notification list that are now back in stock.
Protected method | GetEqualityComparer | Gets the comparer used to determine if two StockNotificationRequest objects are equal.
Public method | GetExpiredNotifications | Retrieves expired back-in-stock notifaction requests from the EAP state.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProductNotifications | Retrieves the product back-in-stock notifaction requests from the EAP state.
Public method | GetProductsBackInStock | Retrieves new back-in-stock products from the EAP state
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVisitor | Retrieves a Visitor by ID or external user name.
Protected method | IsBackInStock | Determines if a StockNotificationRequest is satisfied by a StockInformationUpdate.
Protected method | IsBackInStockLocation | Determines if a StockNotificationRequest is satisfied by a StockInformationUpdateLocation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveBackInStockProductsFromNotificationList | Removes all products from a notification list that are now back in stock.
Public method | RemoveExpiredNotifications | Removes expired back-in-stock notification requests that have expired.
Public method | RemoveNotification | Finds a StockNotificationRequest from a list
Public method | SerializeData | Serializes a notification list for storage.
Public method | SerializeExpiredNotifications | Serializes expired back-in-stock notification a AutomationStatesRow.
Public method | SerializeProductNotifications | Serializes back-in-stock notification requests into a AutomationStatesRow.
Public method | SerializeProductsBackInStock | Serializes new back-in-stock product IDs into a AutomationStatesRow.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | ServiceProvider | Gets the inventory service provider.
Top
See Also

Reference

Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider Constructor

InventoryAutomationProvider Constructor
Initializes an instance of the InventoryAutomationProvider class.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public InventoryAutomationProvider()
Public Sub New
public:
InventoryAutomationProvider()
new : unit -> InventoryAutomationProvider
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider Methods

InventoryAutomationProvider Methods

The InventoryAutomationProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindBackInStockProductsFromPageEventData | Finds the products that are back in stock based on page evennt data.
Protected method | FindBackInStockProductsFromServiceProvider | Finds the products that are back in stock based on a GetBackInStockInformationResult.
Public method | FindNotification | Finds a StockNotificationRequest from a list
Public method | GetAutomationStatesRow | Gets the auutomation state data row data for a visitor.
Public method | GetBackInStockProducts | Gets the products from a product notification list that are now back in stock
Protected method | GetBackInStockProductsFromPageEventData | Gets the products from a product notification list that are now back in stock based on page event data.
Protected method | GetBackInStockProductsFromServiceProvider | Gets the products from a product notification list that are now back in stock.
Protected method | GetEqualityComparer | Gets the comparer used to determine if two StockNotificationRequest objects are equal.
Public method | GetExpiredNotifications | Retrieves expired back-in-stock notifaction requests from the EAP state.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProductNotifications | Retrieves the product back-in-stock notifaction requests from the EAP state.
Public method | GetProductsBackInStock | Retrieves new back-in-stock products from the EAP state
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVisitor | Retrieves a Visitor by ID or external user name.
Protected method | IsBackInStock | Determines if a StockNotificationRequest is satisfied by a StockInformationUpdate.
Protected method | IsBackInStockLocation | Determines if a StockNotificationRequest is satisfied by a StockInformationUpdateLocation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveBackInStockProductsFromNotificationList | Removes all products from a notification list that are now back in stock.
Public method | RemoveExpiredNotifications | Removes expired back-in-stock notification requests that have expired.
Public method | RemoveNotification | Finds a StockNotificationRequest from a list
Public method | SerializeData | Serializes a notification list for storage.
Public method | SerializeExpiredNotifications | Serializes expired back-in-stock notification a AutomationStatesRow.
Public method | SerializeProductNotifications | Serializes back-in-stock notification requests into a AutomationStatesRow.
Public method | SerializeProductsBackInStock | Serializes new back-in-stock product IDs into a AutomationStatesRow.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.FindBackInStockProductsFromPageEventData Method

InventoryAutomationProviderFindBackInStockProductsFromPageEventData Method
Finds the products that are back in stock based on page evennt data.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual List<StockNotificationRequest> FindBackInStockProductsFromPageEventData(
    List<StockNotificationRequest> productNotifications,
    ProductsAreBackInStockRequest pageEventData
)
Protected Overridable Function FindBackInStockProductsFromPageEventData (
    productNotifications As List(Of StockNotificationRequest),
    pageEventData As ProductsAreBackInStockRequest
) As List(Of StockNotificationRequest)
protected:
virtual List<StockNotificationRequest^>^ FindBackInStockProductsFromPageEventData(
    List<StockNotificationRequest^>^ productNotifications,
    ProductsAreBackInStockRequest^ pageEventData
)
abstract FindBackInStockProductsFromPageEventData :
        productNotifications : List<StockNotificationRequest> *
        pageEventData : ProductsAreBackInStockRequest -> List<StockNotificationRequest>
override FindBackInStockProductsFromPageEventData :
        productNotifications : List<StockNotificationRequest> *
        pageEventData : ProductsAreBackInStockRequest -> List<StockNotificationRequest>

Parameters

productNotifications
Type: System.Collections.GenericList StockNotificationRequest
The list of product notification requests.
pageEventData
Type: Sitecore.Commerce.Services.InventoryProductsAreBackInStockRequest
The page event data.

Return Value

Type: List StockNotificationRequest
The requested products that are back in stock, or null if no page event data was found.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.FindBackInStockProductsFromServiceProvider Method

InventoryAutomationProviderFindBackInStockProductsFromServiceProvider Method
Finds the products that are back in stock based on a GetBackInStockInformationResult.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual List<StockNotificationRequest> FindBackInStockProductsFromServiceProvider(
    List<StockNotificationRequest> productNotifications,
    GetBackInStockInformationResult result
)
Protected Overridable Function FindBackInStockProductsFromServiceProvider (
    productNotifications As List(Of StockNotificationRequest),
    result As GetBackInStockInformationResult
) As List(Of StockNotificationRequest)
protected:
virtual List<StockNotificationRequest^>^ FindBackInStockProductsFromServiceProvider(
    List<StockNotificationRequest^>^ productNotifications,
    GetBackInStockInformationResult^ result
)
abstract FindBackInStockProductsFromServiceProvider :
        productNotifications : List<StockNotificationRequest> *
        result : GetBackInStockInformationResult -> List<StockNotificationRequest>
override FindBackInStockProductsFromServiceProvider :
        productNotifications : List<StockNotificationRequest> *
        result : GetBackInStockInformationResult -> List<StockNotificationRequest>

Parameters

productNotifications
Type: System.Collections.GenericList StockNotificationRequest
The list of product notification requests.
result
Type: Sitecore.Commerce.Services.InventoryGetBackInStockInformationResult
The GetBackInStockInformationResult.

Return Value

Type: List StockNotificationRequest
The requested products that are back in stock.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.FindNotification Method

InventoryAutomationProviderFindNotification Method
Finds a StockNotificationRequest from a list

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual StockNotificationRequest FindNotification(
    IEnumerable<StockNotificationRequest> productNotifications,
    StockNotificationRequest searchCriteria
)
Public Overridable Function FindNotification (
    productNotifications As IEnumerable(Of StockNotificationRequest),
    searchCriteria As StockNotificationRequest
) As StockNotificationRequest
public:
virtual StockNotificationRequest^ FindNotification(
    IEnumerable<StockNotificationRequest^>^ productNotifications,
    StockNotificationRequest^ searchCriteria
)
abstract FindNotification :
        productNotifications : IEnumerable<StockNotificationRequest> *
        searchCriteria : StockNotificationRequest -> StockNotificationRequest
override FindNotification :
        productNotifications : IEnumerable<StockNotificationRequest> *
        searchCriteria : StockNotificationRequest -> StockNotificationRequest

Parameters

productNotifications
Type: System.Collections.GenericIEnumerable StockNotificationRequest
The list of notifications to search.
searchCriteria
Type: Sitecore.Commerce.Entities.InventoryStockNotificationRequest
The notification to find.

Return Value

Type: StockNotificationRequest
The stock notification, or null if it was not found.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.GetAutomationStatesRow Method

InventoryAutomationProviderGetAutomationStatesRow Method
Gets the auutomation state data row data for a visitor.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual AutomationStatesRow GetAutomationStatesRow(
    string visitorId,
    ID stateId
)
Public Overridable Function GetAutomationStatesRow (
    visitorId As String,
    stateId As ID
) As AutomationStatesRow
public:
virtual AutomationStatesRow^ GetAutomationStatesRow(
    String^ visitorId,
    ID^ stateId
)
abstract GetAutomationStatesRow :
        visitorId : string *
        stateId : ID -> AutomationStatesRow
override GetAutomationStatesRow :
        visitorId : string *
        stateId : ID -> AutomationStatesRow

Parameters

visitorId
Type: SystemString
The ID or external user name of the visitor.
stateId
Type: ID
The ID of the state whose automation state data will be retrieved.

Return Value

Type: AutomationStatesRow
The automation state data.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.GetBackInStockProducts Method

InventoryAutomationProviderGetBackInStockProducts Method
Gets the products from a product notification list that are now back in stock

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<StockNotificationRequest> GetBackInStockProducts(
    List<StockNotificationRequest> productNotifications,
    AutomationStatesRow rowData
)
Public Overridable Function GetBackInStockProducts (
    productNotifications As List(Of StockNotificationRequest),
    rowData As AutomationStatesRow
) As List(Of StockNotificationRequest)
public:
virtual List<StockNotificationRequest^>^ GetBackInStockProducts(
    List<StockNotificationRequest^>^ productNotifications,
    AutomationStatesRow^ rowData
)
abstract GetBackInStockProducts :
        productNotifications : List<StockNotificationRequest> *
        rowData : AutomationStatesRow -> List<StockNotificationRequest>
override GetBackInStockProducts :
        productNotifications : List<StockNotificationRequest> *
        rowData : AutomationStatesRow -> List<StockNotificationRequest>

Parameters

productNotifications
Type: System.Collections.GenericList StockNotificationRequest
The products the user has requested to be notified about.
rowData
Type: AutomationStatesRow
The current automation state row data.

Return Value

Type: List StockNotificationRequest
A list containing the IDs of the products of interest that are now back in stock.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.GetBackInStockProductsFromPageEventData Method

InventoryAutomationProviderGetBackInStockProductsFromPageEventData Method
Gets the products from a product notification list that are now back in stock based on page event data.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual List<StockNotificationRequest> GetBackInStockProductsFromPageEventData(
    List<StockNotificationRequest> productNotifications,
    AutomationStatesRow rowData
)
Protected Overridable Function GetBackInStockProductsFromPageEventData (
    productNotifications As List(Of StockNotificationRequest),
    rowData As AutomationStatesRow
) As List(Of StockNotificationRequest)
protected:
virtual List<StockNotificationRequest^>^ GetBackInStockProductsFromPageEventData(
    List<StockNotificationRequest^>^ productNotifications,
    AutomationStatesRow^ rowData
)
abstract GetBackInStockProductsFromPageEventData :
        productNotifications : List<StockNotificationRequest> *
        rowData : AutomationStatesRow -> List<StockNotificationRequest>
override GetBackInStockProductsFromPageEventData :
        productNotifications : List<StockNotificationRequest> *
        rowData : AutomationStatesRow -> List<StockNotificationRequest>

Parameters

productNotifications
Type: System.Collections.GenericList StockNotificationRequest
The products the user has requested to be notified about.
rowData
Type: AutomationStatesRow
The current automation state row data.

Return Value

Type: List StockNotificationRequest
A list containing the IDs of the products of interest that are now back in stock, or null if no page event data exists.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.GetBackInStockProductsFromServiceProvider Method

InventoryAutomationProviderGetBackInStockProductsFromServiceProvider Method
Gets the products from a product notification list that are now back in stock.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual List<StockNotificationRequest> GetBackInStockProductsFromServiceProvider(
    List<StockNotificationRequest> productNotifications,
    AutomationStatesRow rowData
)
Protected Overridable Function GetBackInStockProductsFromServiceProvider (
    productNotifications As List(Of StockNotificationRequest),
    rowData As AutomationStatesRow
) As List(Of StockNotificationRequest)
protected:
virtual List<StockNotificationRequest^>^ GetBackInStockProductsFromServiceProvider(
    List<StockNotificationRequest^>^ productNotifications,
    AutomationStatesRow^ rowData
)
abstract GetBackInStockProductsFromServiceProvider :
        productNotifications : List<StockNotificationRequest> *
        rowData : AutomationStatesRow -> List<StockNotificationRequest>
override GetBackInStockProductsFromServiceProvider :
        productNotifications : List<StockNotificationRequest> *
        rowData : AutomationStatesRow -> List<StockNotificationRequest>

Parameters

productNotifications
Type: System.Collections.GenericList StockNotificationRequest
The products the user has requested to be notified about.
rowData
Type: AutomationStatesRow
The current automation state row data.

Return Value

Type: List StockNotificationRequest
A list containing the IDs of the products of interest that are now back in stock.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.GetEqualityComparer Method

InventoryAutomationProviderGetEqualityComparer Method
Gets the comparer used to determine if two StockNotificationRequest objects are equal.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual IEqualityComparer<StockNotificationRequest> GetEqualityComparer()
Protected Overridable Function GetEqualityComparer As IEqualityComparer(Of StockNotificationRequest)
protected:
virtual IEqualityComparer<StockNotificationRequest^>^ GetEqualityComparer()
abstract GetEqualityComparer : unit -> IEqualityComparer<StockNotificationRequest>
override GetEqualityComparer : unit -> IEqualityComparer<StockNotificationRequest>

Return Value

Type: IEqualityComparer StockNotificationRequest
The comparer used to determine if two StockNotificationRequest objects are equal.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.GetExpiredNotifications Method

InventoryAutomationProviderGetExpiredNotifications Method
Retrieves expired back-in-stock notifaction requests from the EAP state.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<StockNotificationRequest> GetExpiredNotifications(
    AutomationStatesRow dataRow
)
Public Overridable Function GetExpiredNotifications (
    dataRow As AutomationStatesRow
) As List(Of StockNotificationRequest)
public:
virtual List<StockNotificationRequest^>^ GetExpiredNotifications(
    AutomationStatesRow^ dataRow
)
abstract GetExpiredNotifications :
        dataRow : AutomationStatesRow -> List<StockNotificationRequest>
override GetExpiredNotifications :
        dataRow : AutomationStatesRow -> List<StockNotificationRequest>

Parameters

dataRow
Type: AutomationStatesRow
The EAP state.

Return Value

Type: List StockNotificationRequest
The expired back-in-stock notification requests in the EAP state.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.GetProductNotifications Method

InventoryAutomationProviderGetProductNotifications Method
Retrieves the product back-in-stock notifaction requests from the EAP state.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<StockNotificationRequest> GetProductNotifications(
    AutomationStatesRow dataRow
)
Public Overridable Function GetProductNotifications (
    dataRow As AutomationStatesRow
) As List(Of StockNotificationRequest)
public:
virtual List<StockNotificationRequest^>^ GetProductNotifications(
    AutomationStatesRow^ dataRow
)
abstract GetProductNotifications :
        dataRow : AutomationStatesRow -> List<StockNotificationRequest>
override GetProductNotifications :
        dataRow : AutomationStatesRow -> List<StockNotificationRequest>

Parameters

dataRow
Type: AutomationStatesRow
The EAP state.

Return Value

Type: List StockNotificationRequest
The back-in-stock notification requests in the EAP state.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.GetProductsBackInStock Method

InventoryAutomationProviderGetProductsBackInStock Method
Retrieves new back-in-stock products from the EAP state

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<StockNotificationRequest> GetProductsBackInStock(
    AutomationStatesRow dataRow
)
Public Overridable Function GetProductsBackInStock (
    dataRow As AutomationStatesRow
) As List(Of StockNotificationRequest)
public:
virtual List<StockNotificationRequest^>^ GetProductsBackInStock(
    AutomationStatesRow^ dataRow
)
abstract GetProductsBackInStock :
        dataRow : AutomationStatesRow -> List<StockNotificationRequest>
override GetProductsBackInStock :
        dataRow : AutomationStatesRow -> List<StockNotificationRequest>

Parameters

dataRow
Type: AutomationStatesRow
The EAP state.

Return Value

Type: List StockNotificationRequest
The new back-in-stock products in the EAP state.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.GetVisitor Method

InventoryAutomationProviderGetVisitor Method
Retrieves a Visitor by ID or external user name.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual Visitor GetVisitor(
    string visitorId
)
Public Overridable Function GetVisitor (
    visitorId As String
) As Visitor
public:
virtual Visitor^ GetVisitor(
    String^ visitorId
)
abstract GetVisitor :
        visitorId : string -> Visitor
override GetVisitor :
        visitorId : string -> Visitor

Parameters

visitorId
Type: SystemString
The visitor ID or external user name.

Return Value

Type: Visitor
The requested Visitor or null if it could not be found.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.IsBackInStock Method

InventoryAutomationProviderIsBackInStock Method
Determines if a StockNotificationRequest is satisfied by a StockInformationUpdate.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual bool IsBackInStock(
    StockNotificationRequest notification,
    StockInformationUpdate update
)
Protected Overridable Function IsBackInStock (
    notification As StockNotificationRequest,
    update As StockInformationUpdate
) As Boolean
protected:
virtual bool IsBackInStock(
    StockNotificationRequest^ notification,
    StockInformationUpdate^ update
)
abstract IsBackInStock :
        notification : StockNotificationRequest *
        update : StockInformationUpdate -> bool
override IsBackInStock :
        notification : StockNotificationRequest *
        update : StockInformationUpdate -> bool

Parameters

notification
Type: Sitecore.Commerce.Entities.InventoryStockNotificationRequest
The StockNotificationRequest.
update
Type: Sitecore.Commerce.Entities.InventoryStockInformationUpdate
The StockInformationUpdate.

Return Value

Type: Boolean
True if the back-in-stock notification request is satisfied by the specified stock information update, otherwise false.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.IsBackInStockLocation Method

InventoryAutomationProviderIsBackInStockLocation Method
Determines if a StockNotificationRequest is satisfied by a StockInformationUpdateLocation.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual bool IsBackInStockLocation(
    StockNotificationRequest notification,
    StockInformationUpdateLocation location
)
Protected Overridable Function IsBackInStockLocation (
    notification As StockNotificationRequest,
    location As StockInformationUpdateLocation
) As Boolean
protected:
virtual bool IsBackInStockLocation(
    StockNotificationRequest^ notification,
    StockInformationUpdateLocation^ location
)
abstract IsBackInStockLocation :
        notification : StockNotificationRequest *
        location : StockInformationUpdateLocation -> bool
override IsBackInStockLocation :
        notification : StockNotificationRequest *
        location : StockInformationUpdateLocation -> bool

Parameters

notification
Type: Sitecore.Commerce.Entities.InventoryStockNotificationRequest
The StockNotificationRequest.
location
Type: Sitecore.Commerce.Entities.InventoryStockInformationUpdateLocation
The StockInformationUpdateLocation.

Return Value

Type: Boolean
True if the back-in-stock notification request is satisfied by the specified stock information for the location, otherwise false.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.RemoveBackInStockProductsFromNotificationList Method

InventoryAutomationProviderRemoveBackInStockProductsFromNotificationList Method
Removes all products from a notification list that are now back in stock.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveBackInStockProductsFromNotificationList(
    List<StockNotificationRequest> backInStockProducts,
    List<StockNotificationRequest> productNotifications
)
Public Overridable Sub RemoveBackInStockProductsFromNotificationList (
    backInStockProducts As List(Of StockNotificationRequest),
    productNotifications As List(Of StockNotificationRequest)
)
public:
virtual void RemoveBackInStockProductsFromNotificationList(
    List<StockNotificationRequest^>^ backInStockProducts,
    List<StockNotificationRequest^>^ productNotifications
)
abstract RemoveBackInStockProductsFromNotificationList :
        backInStockProducts : List<StockNotificationRequest> *
        productNotifications : List<StockNotificationRequest> -> unit
override RemoveBackInStockProductsFromNotificationList :
        backInStockProducts : List<StockNotificationRequest> *
        productNotifications : List<StockNotificationRequest> -> unit

Parameters

backInStockProducts
Type: System.Collections.GenericList StockNotificationRequest
The products that are now back in stock.
productNotifications
Type: System.Collections.GenericList StockNotificationRequest
The back-in-stock notifications requested by the user.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.RemoveExpiredNotifications Method

InventoryAutomationProviderRemoveExpiredNotifications Method
Removes expired back-in-stock notification requests that have expired.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<StockNotificationRequest> RemoveExpiredNotifications(
    List<StockNotificationRequest> productNotifications
)
Public Overridable Function RemoveExpiredNotifications (
    productNotifications As List(Of StockNotificationRequest)
) As List(Of StockNotificationRequest)
public:
virtual List<StockNotificationRequest^>^ RemoveExpiredNotifications(
    List<StockNotificationRequest^>^ productNotifications
)
abstract RemoveExpiredNotifications :
        productNotifications : List<StockNotificationRequest> -> List<StockNotificationRequest>
override RemoveExpiredNotifications :
        productNotifications : List<StockNotificationRequest> -> List<StockNotificationRequest>

Parameters

productNotifications
Type: System.Collections.GenericList StockNotificationRequest
The back-in-stock notifiaction requests the user has subscribed to.

Return Value

Type: List StockNotificationRequest
A list containing the IDs of the products that were removed from the user's notification requests.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.RemoveNotification Method

InventoryAutomationProviderRemoveNotification Method
Finds a StockNotificationRequest from a list

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual int RemoveNotification(
    List<StockNotificationRequest> productNotifications,
    StockNotificationRequest searchCriteria
)
Public Overridable Function RemoveNotification (
    productNotifications As List(Of StockNotificationRequest),
    searchCriteria As StockNotificationRequest
) As Integer
public:
virtual int RemoveNotification(
    List<StockNotificationRequest^>^ productNotifications,
    StockNotificationRequest^ searchCriteria
)
abstract RemoveNotification :
        productNotifications : List<StockNotificationRequest> *
        searchCriteria : StockNotificationRequest -> int
override RemoveNotification :
        productNotifications : List<StockNotificationRequest> *
        searchCriteria : StockNotificationRequest -> int

Parameters

productNotifications
Type: System.Collections.GenericList StockNotificationRequest
The list of notifications to search.
searchCriteria
Type: Sitecore.Commerce.Entities.InventoryStockNotificationRequest
The notification to find.

Return Value

Type: Int32
The stock notification, or null if it was not found.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.SerializeData Method

InventoryAutomationProviderSerializeData Method
Serializes a notification list for storage.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string SerializeData(
    List<StockNotificationRequest> notificationList,
    string existingData,
    string workflowDataName
)
Public Overridable Function SerializeData (
    notificationList As List(Of StockNotificationRequest),
    existingData As String,
    workflowDataName As String
) As String
public:
virtual String^ SerializeData(
    List<StockNotificationRequest^>^ notificationList,
    String^ existingData,
    String^ workflowDataName
)
abstract SerializeData :
        notificationList : List<StockNotificationRequest> *
        existingData : string *
        workflowDataName : string -> string
override SerializeData :
        notificationList : List<StockNotificationRequest> *
        existingData : string *
        workflowDataName : string -> string

Parameters

notificationList
Type: System.Collections.GenericList StockNotificationRequest
The notification list to serialize.
existingData
Type: SystemString
Any existing serialized data.
workflowDataName
Type: SystemString
The name of the workflow data key.

Return Value

Type: String
The serialized notification list.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.SerializeExpiredNotifications Method

InventoryAutomationProviderSerializeExpiredNotifications Method
Serializes expired back-in-stock notification a AutomationStatesRow.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void SerializeExpiredNotifications(
    AutomationStatesRow dataRow,
    List<StockNotificationRequest> expiredNotifications
)
Public Overridable Sub SerializeExpiredNotifications (
    dataRow As AutomationStatesRow,
    expiredNotifications As List(Of StockNotificationRequest)
)
public:
virtual void SerializeExpiredNotifications(
    AutomationStatesRow^ dataRow,
    List<StockNotificationRequest^>^ expiredNotifications
)
abstract SerializeExpiredNotifications :
        dataRow : AutomationStatesRow *
        expiredNotifications : List<StockNotificationRequest> -> unit
override SerializeExpiredNotifications :
        dataRow : AutomationStatesRow *
        expiredNotifications : List<StockNotificationRequest> -> unit

Parameters

dataRow
Type: AutomationStatesRow
The AutomationStatesRow that represents the current engagement plan state.
expiredNotifications
Type: System.Collections.GenericList StockNotificationRequest
The expired back-in-stock notification requests to serialize into the engagement plan state.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.SerializeProductNotifications Method

InventoryAutomationProviderSerializeProductNotifications Method
Serializes back-in-stock notification requests into a AutomationStatesRow.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void SerializeProductNotifications(
    AutomationStatesRow dataRow,
    List<StockNotificationRequest> productNotifications
)
Public Overridable Sub SerializeProductNotifications (
    dataRow As AutomationStatesRow,
    productNotifications As List(Of StockNotificationRequest)
)
public:
virtual void SerializeProductNotifications(
    AutomationStatesRow^ dataRow,
    List<StockNotificationRequest^>^ productNotifications
)
abstract SerializeProductNotifications :
        dataRow : AutomationStatesRow *
        productNotifications : List<StockNotificationRequest> -> unit
override SerializeProductNotifications :
        dataRow : AutomationStatesRow *
        productNotifications : List<StockNotificationRequest> -> unit

Parameters

dataRow
Type: AutomationStatesRow
The AutomationStatesRow that represents the current engagement plan state.
productNotifications
Type: System.Collections.GenericList StockNotificationRequest
The back-in-stock notification requests to serialize into the engagement plan state.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.SerializeProductsBackInStock Method

InventoryAutomationProviderSerializeProductsBackInStock Method
Serializes new back-in-stock product IDs into a AutomationStatesRow.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void SerializeProductsBackInStock(
    AutomationStatesRow dataRow,
    List<StockNotificationRequest> productsBackInStock
)
Public Overridable Sub SerializeProductsBackInStock (
    dataRow As AutomationStatesRow,
    productsBackInStock As List(Of StockNotificationRequest)
)
public:
virtual void SerializeProductsBackInStock(
    AutomationStatesRow^ dataRow,
    List<StockNotificationRequest^>^ productsBackInStock
)
abstract SerializeProductsBackInStock :
        dataRow : AutomationStatesRow *
        productsBackInStock : List<StockNotificationRequest> -> unit
override SerializeProductsBackInStock :
        dataRow : AutomationStatesRow *
        productsBackInStock : List<StockNotificationRequest> -> unit

Parameters

dataRow
Type: AutomationStatesRow
The AutomationStatesRow that represents the current engagement plan state.
productsBackInStock
Type: System.Collections.GenericList StockNotificationRequest
The new back-in-stock products to serialize into the engagement plan state.
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider Properties

InventoryAutomationProvider Properties

The InventoryAutomationProvider type exposes the following members.

Properties
 | Name | Description
Protected property | ServiceProvider | Gets the inventory service provider.
Top
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


InventoryAutomationProvider.ServiceProvider Property

InventoryAutomationProviderServiceProvider Property
Gets the inventory service provider.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected InventoryServiceProvider ServiceProvider { get; }
Protected ReadOnly Property ServiceProvider As InventoryServiceProvider
    Get
protected:
property InventoryServiceProvider^ ServiceProvider {
    InventoryServiceProvider^ get ();
}
member ServiceProvider : InventoryServiceProvider with get

Property Value

Type: InventoryServiceProvider
See Also

Reference

InventoryAutomationProvider Class
Sitecore.Commerce.Automation.MarketingAutomation Namespace


Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace

Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions"]

Classes
 | Class | Description
Public class | RemoveExpiredBackInStockNotificationsAction | The automation action which removes expired entires from a user's out-of-stock notification list.
Public class | SendBackInStockNotificationEmailAction | The automation action which removes expired entires from a user's out-of-stock notification list.
Public class | SetCartStatusAction | Defines the action that is used to set the cart status. This class implements the AutomationAction class.


RemoveExpiredBackInStockNotificationsAction Class

RemoveExpiredBackInStockNotificationsAction Class
The automation action which removes expired entires from a user's out-of-stock notification list.
Inheritance Hierarchy
SystemObject
AutomationAction
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActionsRemoveExpiredBackInStockNotificationsAction

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveExpiredBackInStockNotificationsAction : AutomationAction
Public Class RemoveExpiredBackInStockNotificationsAction
    Inherits AutomationAction
public ref class RemoveExpiredBackInStockNotificationsAction : public AutomationAction
type RemoveExpiredBackInStockNotificationsAction =
    class
        inherit AutomationAction
    end

The RemoveExpiredBackInStockNotificationsAction type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveExpiredBackInStockNotificationsAction | Initializes an instance of the RemoveExpiredBackInStockNotificationsAction class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the action on the specified automation states row. (Overrides AutomationAction.Execute(AutomationStatesRow, Item, Boolean).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutomationVisitor | (Inherited from AutomationAction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetParameters | (Inherited from AutomationAction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | AutomationProvider | Gets the inventory automation provider.
Top
See Also

Reference

Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


RemoveExpiredBackInStockNotificationsAction Constructor

RemoveExpiredBackInStockNotificationsAction Constructor
Initializes an instance of the RemoveExpiredBackInStockNotificationsAction class.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveExpiredBackInStockNotificationsAction()
Public Sub New
public:
RemoveExpiredBackInStockNotificationsAction()
new : unit -> RemoveExpiredBackInStockNotificationsAction
See Also

Reference

RemoveExpiredBackInStockNotificationsAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


RemoveExpiredBackInStockNotificationsAction Methods

RemoveExpiredBackInStockNotificationsAction Methods

The RemoveExpiredBackInStockNotificationsAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the action on the specified automation states row. (Overrides AutomationAction.Execute(AutomationStatesRow, Item, Boolean).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutomationVisitor | (Inherited from AutomationAction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetParameters | (Inherited from AutomationAction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveExpiredBackInStockNotificationsAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


RemoveExpiredBackInStockNotificationsAction.Execute Method

RemoveExpiredBackInStockNotificationsActionExecute Method
Executes the action on the specified automation states row.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override AutomationActionResult Execute(
    AutomationStatesRow automationStatesRow,
    Item action,
    bool isBackgroundThread
)
Public Overrides Function Execute (
    automationStatesRow As AutomationStatesRow,
    action As Item,
    isBackgroundThread As Boolean
) As AutomationActionResult
public:
virtual AutomationActionResult Execute(
    AutomationStatesRow^ automationStatesRow,
    Item^ action,
    bool isBackgroundThread
) override
abstract Execute :
        automationStatesRow : AutomationStatesRow *
        action : Item *
        isBackgroundThread : bool -> AutomationActionResult
override Execute :
        automationStatesRow : AutomationStatesRow *
        action : Item *
        isBackgroundThread : bool -> AutomationActionResult

Parameters

automationStatesRow
Type: AutomationStatesRow
The automation states row.
action
Type: Item
The action.
isBackgroundThread
Type: SystemBoolean
if set to true is executed in background thread.

Return Value

Type: AutomationActionResult
Result of action execution.
See Also

Reference

RemoveExpiredBackInStockNotificationsAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


RemoveExpiredBackInStockNotificationsAction Properties

RemoveExpiredBackInStockNotificationsAction Properties

The RemoveExpiredBackInStockNotificationsAction type exposes the following members.

Properties
 | Name | Description
Protected property | AutomationProvider | Gets the inventory automation provider.
Top
See Also

Reference

RemoveExpiredBackInStockNotificationsAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


RemoveExpiredBackInStockNotificationsAction.AutomationProvider Property

RemoveExpiredBackInStockNotificationsActionAutomationProvider Property
Gets the inventory automation provider.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected InventoryAutomationProvider AutomationProvider { get; }
Protected ReadOnly Property AutomationProvider As InventoryAutomationProvider
    Get
protected:
property InventoryAutomationProvider^ AutomationProvider {
    InventoryAutomationProvider^ get ();
}
member AutomationProvider : InventoryAutomationProvider with get

Property Value

Type: InventoryAutomationProvider
See Also

Reference

RemoveExpiredBackInStockNotificationsAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SendBackInStockNotificationEmailAction Class

SendBackInStockNotificationEmailAction Class
The automation action which removes expired entires from a user's out-of-stock notification list.
Inheritance Hierarchy
SystemObject
AutomationAction
SendEmailMessageAction
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActionsSendBackInStockNotificationEmailAction

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SendBackInStockNotificationEmailAction : SendEmailMessageAction
Public Class SendBackInStockNotificationEmailAction
    Inherits SendEmailMessageAction
public ref class SendBackInStockNotificationEmailAction : public SendEmailMessageAction
type SendBackInStockNotificationEmailAction =
    class
        inherit SendEmailMessageAction
    end

The SendBackInStockNotificationEmailAction type exposes the following members.

Constructors
 | Name | Description
Public method | SendBackInStockNotificationEmailAction | Initializes an instance of the SendBackInStockNotificationEmailAction class.
Top
Methods
 | Name | Description
Protected method | AddTableRow | Adds a table row to indicate that a product is back in stock.
Protected method | CreateTable | Createst the table that will display the back-in-stock products.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the action on the specified automation states row. (Overrides SendEmailMessageAction.Execute(AutomationStatesRow, Item, Boolean).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutomationVisitor | (Inherited from AutomationAction.)
Protected method | GetBackInStockProductsHtml | Gets the HTML for the table that will be injected into the email message when a {{ProductsBackInStock}} toke is present in the email message body.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetParameters | (Inherited from AutomationAction.)
Protected method | GetProductDisplayName | Gets the display name for a product.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SendBackInStockEmail | Sends back-in-stock email notifications.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
ProductsBackInStockVariable | The email message body variable token that indicates where the back-in-stock products table should be inserted.
Top
Properties
 | Name | Description
Protected property | AutomationProvider | Gets the inventory automation provider.
Protected property | ProductsIndexName | Gets the name of the products index.
Top
See Also

Reference

Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SendBackInStockNotificationEmailAction Constructor

SendBackInStockNotificationEmailAction Constructor
Initializes an instance of the SendBackInStockNotificationEmailAction class.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SendBackInStockNotificationEmailAction()
Public Sub New
public:
SendBackInStockNotificationEmailAction()
new : unit -> SendBackInStockNotificationEmailAction
See Also

Reference

SendBackInStockNotificationEmailAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SendBackInStockNotificationEmailAction Fields

SendBackInStockNotificationEmailAction Fields

The SendBackInStockNotificationEmailAction type exposes the following members.

Fields
Name | Description
ProductsBackInStockVariable | The email message body variable token that indicates where the back-in-stock products table should be inserted.
Top
See Also

Reference

SendBackInStockNotificationEmailAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SendBackInStockNotificationEmailAction.ProductsBackInStockVariable Field

SendBackInStockNotificationEmailActionProductsBackInStockVariable Field
The email message body variable token that indicates where the back-in-stock products table should be inserted.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ProductsBackInStockVariable
Public Const ProductsBackInStockVariable As String
public:
literal String^ ProductsBackInStockVariable
static val mutable ProductsBackInStockVariable: string

Field Value

Type: String
See Also

Reference

SendBackInStockNotificationEmailAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SendBackInStockNotificationEmailAction Methods

SendBackInStockNotificationEmailAction Methods

The SendBackInStockNotificationEmailAction type exposes the following members.

Methods
 | Name | Description
Protected method | AddTableRow | Adds a table row to indicate that a product is back in stock.
Protected method | CreateTable | Createst the table that will display the back-in-stock products.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the action on the specified automation states row. (Overrides SendEmailMessageAction.Execute(AutomationStatesRow, Item, Boolean).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutomationVisitor | (Inherited from AutomationAction.)
Protected method | GetBackInStockProductsHtml | Gets the HTML for the table that will be injected into the email message when a {{ProductsBackInStock}} toke is present in the email message body.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetParameters | (Inherited from AutomationAction.)
Protected method | GetProductDisplayName | Gets the display name for a product.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SendBackInStockEmail | Sends back-in-stock email notifications.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SendBackInStockNotificationEmailAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SendBackInStockNotificationEmailAction.AddTableRow Method

SendBackInStockNotificationEmailActionAddTableRow Method
Adds a table row to indicate that a product is back in stock.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void AddTableRow(
    Table table,
    StockNotificationRequest notification,
    Item action
)
Protected Overridable Sub AddTableRow (
    table As Table,
    notification As StockNotificationRequest,
    action As Item
)
protected:
virtual void AddTableRow(
    Table^ table,
    StockNotificationRequest^ notification,
    Item^ action
)
abstract AddTableRow :
        table : Table *
        notification : StockNotificationRequest *
        action : Item -> unit
override AddTableRow :
        table : Table *
        notification : StockNotificationRequest *
        action : Item -> unit

Parameters

table
Type: System.Web.UI.WebControlsTable
The table to populate.
notification
Type: Sitecore.Commerce.Entities.InventoryStockNotificationRequest
The StockNotificationRequest that identifies the product that is back in stock.
action
Type: Item
The current action item being evaluated.
See Also

Reference

SendBackInStockNotificationEmailAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SendBackInStockNotificationEmailAction.CreateTable Method

SendBackInStockNotificationEmailActionCreateTable Method
Createst the table that will display the back-in-stock products.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual Table CreateTable(
    Item action
)
Protected Overridable Function CreateTable (
    action As Item
) As Table
protected:
virtual Table^ CreateTable(
    Item^ action
)
abstract CreateTable :
        action : Item -> Table
override CreateTable :
        action : Item -> Table

Parameters

action
Type: Item
The current action item being evaluated.

Return Value

Type: Table
The table that will display the back-in-stock products.
See Also

Reference

SendBackInStockNotificationEmailAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SendBackInStockNotificationEmailAction.Execute Method

SendBackInStockNotificationEmailActionExecute Method
Executes the action on the specified automation states row.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override AutomationActionResult Execute(
    AutomationStatesRow automationStatesRow,
    Item action,
    bool isBackgroundThread
)
Public Overrides Function Execute (
    automationStatesRow As AutomationStatesRow,
    action As Item,
    isBackgroundThread As Boolean
) As AutomationActionResult
public:
virtual AutomationActionResult Execute(
    AutomationStatesRow^ automationStatesRow,
    Item^ action,
    bool isBackgroundThread
) override
abstract Execute :
        automationStatesRow : AutomationStatesRow *
        action : Item *
        isBackgroundThread : bool -> AutomationActionResult
override Execute :
        automationStatesRow : AutomationStatesRow *
        action : Item *
        isBackgroundThread : bool -> AutomationActionResult

Parameters

automationStatesRow
Type: AutomationStatesRow
The automation states row.
action
Type: Item
The action.
isBackgroundThread
Type: SystemBoolean
if set to true is executed in background thread.

Return Value

Type: AutomationActionResult
Result of action execution.
See Also

Reference

SendBackInStockNotificationEmailAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SendBackInStockNotificationEmailAction.GetBackInStockProductsHtml Method

SendBackInStockNotificationEmailActionGetBackInStockProductsHtml Method
Gets the HTML for the table that will be injected into the email message when a {{ProductsBackInStock}} toke is present in the email message body.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual string GetBackInStockProductsHtml(
    List<StockNotificationRequest> backInStockProducts,
    Item action
)
Protected Overridable Function GetBackInStockProductsHtml (
    backInStockProducts As List(Of StockNotificationRequest),
    action As Item
) As String
protected:
virtual String^ GetBackInStockProductsHtml(
    List<StockNotificationRequest^>^ backInStockProducts,
    Item^ action
)
abstract GetBackInStockProductsHtml :
        backInStockProducts : List<StockNotificationRequest> *
        action : Item -> string
override GetBackInStockProductsHtml :
        backInStockProducts : List<StockNotificationRequest> *
        action : Item -> string

Parameters

backInStockProducts
Type: System.Collections.GenericList StockNotificationRequest
The list of StockNotificationRequest objects that represent the products that are not available for purchase.
action
Type: Item
The current action item.

Return Value

Type: String
The back-in-stock products table HTML.
See Also

Reference

SendBackInStockNotificationEmailAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SendBackInStockNotificationEmailAction.GetProductDisplayName Method

SendBackInStockNotificationEmailActionGetProductDisplayName Method
Gets the display name for a product.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual string GetProductDisplayName(
    InventoryProduct product,
    Item action
)
Protected Overridable Function GetProductDisplayName (
    product As InventoryProduct,
    action As Item
) As String
protected:
virtual String^ GetProductDisplayName(
    InventoryProduct^ product,
    Item^ action
)
abstract GetProductDisplayName :
        product : InventoryProduct *
        action : Item -> string
override GetProductDisplayName :
        product : InventoryProduct *
        action : Item -> string

Parameters

product
Type: Sitecore.Commerce.Entities.InventoryInventoryProduct
The product identifier.
action
Type: Item
The current action item being evaluated.

Return Value

Type: String
The display name for the product.
See Also

Reference

SendBackInStockNotificationEmailAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SendBackInStockNotificationEmailAction.SendBackInStockEmail Method

SendBackInStockNotificationEmailActionSendBackInStockEmail Method
Sends back-in-stock email notifications.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void SendBackInStockEmail(
    List<StockNotificationRequest> backInStockProducts,
    AutomationStatesRow automationStatesRow,
    Item action,
    bool isBackgroundThread
)
Protected Overridable Sub SendBackInStockEmail (
    backInStockProducts As List(Of StockNotificationRequest),
    automationStatesRow As AutomationStatesRow,
    action As Item,
    isBackgroundThread As Boolean
)
protected:
virtual void SendBackInStockEmail(
    List<StockNotificationRequest^>^ backInStockProducts,
    AutomationStatesRow^ automationStatesRow,
    Item^ action,
    bool isBackgroundThread
)
abstract SendBackInStockEmail :
        backInStockProducts : List<StockNotificationRequest> *
        automationStatesRow : AutomationStatesRow *
        action : Item *
        isBackgroundThread : bool -> unit
override SendBackInStockEmail :
        backInStockProducts : List<StockNotificationRequest> *
        automationStatesRow : AutomationStatesRow *
        action : Item *
        isBackgroundThread : bool -> unit

Parameters

backInStockProducts
Type: System.Collections.GenericList StockNotificationRequest
The products that are now back in-stock.
automationStatesRow
Type: AutomationStatesRow
The current automation state.
action
Type: Item
The current action item.
isBackgroundThread
Type: SystemBoolean
if set to true is executed in background thread.
See Also

Reference

SendBackInStockNotificationEmailAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SendBackInStockNotificationEmailAction Properties

SendBackInStockNotificationEmailAction Properties

The SendBackInStockNotificationEmailAction type exposes the following members.

Properties
 | Name | Description
Protected property | AutomationProvider | Gets the inventory automation provider.
Protected property | ProductsIndexName | Gets the name of the products index.
Top
See Also

Reference

SendBackInStockNotificationEmailAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SendBackInStockNotificationEmailAction.AutomationProvider Property

SendBackInStockNotificationEmailActionAutomationProvider Property
Gets the inventory automation provider.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected InventoryAutomationProvider AutomationProvider { get; }
Protected ReadOnly Property AutomationProvider As InventoryAutomationProvider
    Get
protected:
property InventoryAutomationProvider^ AutomationProvider {
    InventoryAutomationProvider^ get ();
}
member AutomationProvider : InventoryAutomationProvider with get

Property Value

Type: InventoryAutomationProvider
See Also

Reference

SendBackInStockNotificationEmailAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SendBackInStockNotificationEmailAction.ProductsIndexName Property

SendBackInStockNotificationEmailActionProductsIndexName Property
Gets the name of the products index.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual string ProductsIndexName { get; }
Protected Overridable ReadOnly Property ProductsIndexName As String
    Get
protected:
virtual property String^ ProductsIndexName {
    String^ get ();
}
abstract ProductsIndexName : string with get
override ProductsIndexName : string with get

Property Value

Type: String
See Also

Reference

SendBackInStockNotificationEmailAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SetCartStatusAction Class

SetCartStatusAction Class
Defines the action that is used to set the cart status. This class implements the AutomationAction class.
Inheritance Hierarchy
SystemObject
AutomationAction
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActionsSetCartStatusAction

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SetCartStatusAction : AutomationAction
Public Class SetCartStatusAction
    Inherits AutomationAction
public ref class SetCartStatusAction : public AutomationAction
type SetCartStatusAction =
    class
        inherit AutomationAction
    end

The SetCartStatusAction type exposes the following members.

Constructors
 | Name | Description
Public method | SetCartStatusAction | Initializes an instance of the SetCartStatusAction class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the action on the specified automation states row. (Overrides AutomationAction.Execute(AutomationStatesRow, Item, Boolean).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutomationVisitor | (Inherited from AutomationAction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetParameters | (Inherited from AutomationAction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | CartServiceProvider | Gets or sets the cart service provider.
Top
See Also

Reference

Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SetCartStatusAction Constructor

SetCartStatusAction Constructor
Initializes an instance of the SetCartStatusAction class.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SetCartStatusAction()
Public Sub New
public:
SetCartStatusAction()
new : unit -> SetCartStatusAction
See Also

Reference

SetCartStatusAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SetCartStatusAction Methods

SetCartStatusAction Methods

The SetCartStatusAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the action on the specified automation states row. (Overrides AutomationAction.Execute(AutomationStatesRow, Item, Boolean).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutomationVisitor | (Inherited from AutomationAction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetParameters | (Inherited from AutomationAction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SetCartStatusAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SetCartStatusAction.Execute Method

SetCartStatusActionExecute Method
Executes the action on the specified automation states row.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override AutomationActionResult Execute(
    AutomationStatesRow automationStatesRow,
    Item action,
    bool isBackgroundThread
)
Public Overrides Function Execute (
    automationStatesRow As AutomationStatesRow,
    action As Item,
    isBackgroundThread As Boolean
) As AutomationActionResult
public:
virtual AutomationActionResult Execute(
    AutomationStatesRow^ automationStatesRow,
    Item^ action,
    bool isBackgroundThread
) override
abstract Execute :
        automationStatesRow : AutomationStatesRow *
        action : Item *
        isBackgroundThread : bool -> AutomationActionResult
override Execute :
        automationStatesRow : AutomationStatesRow *
        action : Item *
        isBackgroundThread : bool -> AutomationActionResult

Parameters

automationStatesRow
Type: AutomationStatesRow
The automation states row.
action
Type: Item
The action.
isBackgroundThread
Type: SystemBoolean
if set to true is executed in background thread.

Return Value

Type: AutomationActionResult
Result of action execution.
See Also

Reference

SetCartStatusAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SetCartStatusAction Properties

SetCartStatusAction Properties

The SetCartStatusAction type exposes the following members.

Properties
 | Name | Description
Protected property | CartServiceProvider | Gets or sets the cart service provider.
Top
See Also

Reference

SetCartStatusAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


SetCartStatusAction.CartServiceProvider Property

SetCartStatusActionCartServiceProvider Property
Gets or sets the cart service provider.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected CartServiceProvider CartServiceProvider { get; set; }
Protected Property CartServiceProvider As CartServiceProvider
    Get
    Set
protected:
property CartServiceProvider^ CartServiceProvider {
    CartServiceProvider^ get ();
    void set (CartServiceProvider^ value);
}
member CartServiceProvider : CartServiceProvider with get, set

Property Value

Type: CartServiceProvider
The cart service provider.
See Also

Reference

SetCartStatusAction Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationActions Namespace


Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace

Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions"]

Classes
 | Class | Description
Public class | AreProductsBackInStockConditionT | Represents the "Has List of Visitor Notifications Expired" condition. This class is used to check if all of the back-in-stock notifications a user has requested have expired due to being past interest date.
Public class | HasEmailConditionT | Represents the Has Email condition. This class is used to check whether an e-mail is available for the user being tested with the rule.
Public class | HasEmptyCartConditionT | Represents the Has Empty Cart condition. This class is used to check whether the cart, for the user being tested with the rule, is empty.
Public class | HasListOfVisitorNotificationsExpiredConditionT | Represents the "Has List of Visitor Notifications Expired" condition. This class is used to check if all of the back-in-stock notifications a user has requested have expired due to being past interest date.


AreProductsBackInStockCondition(T) Class

AreProductsBackInStockConditionT Class
Represents the "Has List of Visitor Notifications Expired" condition. This class is used to check if all of the back-in-stock notifications a user has requested have expired due to being past interest date.
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditionsAreProductsBackInStockConditionT

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AreProductsBackInStockCondition<T> : WhenCondition<T>
where T : WorkflowRuleContext

Public Class AreProductsBackInStockCondition(Of T As WorkflowRuleContext)
    Inherits WhenCondition(Of T)
generic<typename T>
where T : WorkflowRuleContext
public ref class AreProductsBackInStockCondition : public WhenCondition<T>
type AreProductsBackInStockCondition<'T when 'T : WorkflowRuleContext> =
    class
        inherit WhenCondition<'T>
    end

Type Parameters

T
The rule context.

The AreProductsBackInStockConditionT type exposes the following members.

Constructors
 | Name | Description
Public method | AreProductsBackInStockConditionT | Initializes an instance of the AreProductsBackInStockConditionT class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | The execute. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | AutomationProvider | Gets the inventory automation provider.
Top
See Also

Reference

Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


AreProductsBackInStockCondition(T) Constructor

AreProductsBackInStockConditionT Constructor
Initializes an instance of the AreProductsBackInStockConditionT class.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AreProductsBackInStockCondition()
Public Sub New
public:
AreProductsBackInStockCondition()
new : unit -> AreProductsBackInStockCondition
See Also

Reference

AreProductsBackInStockConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


AreProductsBackInStockCondition(T) Methods

AreProductsBackInStockConditionT Methods

The AreProductsBackInStockConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | The execute. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AreProductsBackInStockConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


AreProductsBackInStockCondition(T).Execute Method

AreProductsBackInStockConditionTExecute Method
The execute.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override bool Execute(
    T ruleContext
)
Protected Overrides Function Execute (
    ruleContext As T
) As Boolean
protected:
virtual bool Execute(
    T ruleContext
) override
abstract Execute :
        ruleContext : 'T -> bool
override Execute :
        ruleContext : 'T -> bool

Parameters

ruleContext
Type: T
The rule context.

Return Value

Type: Boolean
The Boolean.
See Also

Reference

AreProductsBackInStockConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


AreProductsBackInStockCondition(T) Properties

AreProductsBackInStockConditionT Properties

The AreProductsBackInStockConditionT generic type exposes the following members.

Properties
 | Name | Description
Protected property | AutomationProvider | Gets the inventory automation provider.
Top
See Also

Reference

AreProductsBackInStockConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


AreProductsBackInStockCondition(T).AutomationProvider Property

AreProductsBackInStockConditionTAutomationProvider Property
Gets the inventory automation provider.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected InventoryAutomationProvider AutomationProvider { get; }
Protected ReadOnly Property AutomationProvider As InventoryAutomationProvider
    Get
protected:
property InventoryAutomationProvider^ AutomationProvider {
    InventoryAutomationProvider^ get ();
}
member AutomationProvider : InventoryAutomationProvider with get

Property Value

Type: InventoryAutomationProvider
See Also

Reference

AreProductsBackInStockConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasEmailCondition(T) Class

HasEmailConditionT Class
Represents the Has Email condition. This class is used to check whether an e-mail is available for the user being tested with the rule.
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditionsHasEmailConditionT

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class HasEmailCondition<T> : WhenCondition<T>
where T : WorkflowRuleContext

Public Class HasEmailCondition(Of T As WorkflowRuleContext)
    Inherits WhenCondition(Of T)
generic<typename T>
where T : WorkflowRuleContext
public ref class HasEmailCondition : public WhenCondition<T>
type HasEmailCondition<'T when 'T : WorkflowRuleContext> =
    class
        inherit WhenCondition<'T>
    end

Type Parameters

T
The workflow rule context.

The HasEmailConditionT type exposes the following members.

Constructors
 | Name | Description
Public method | HasEmailConditionT | Initializes a new instance of the HasEmailConditionT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | Executes the specified rule context. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasEmailCondition(T) Constructor

HasEmailConditionT Constructor
Initializes a new instance of the HasEmailConditionT class

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public HasEmailCondition()
Public Sub New
public:
HasEmailCondition()
new : unit -> HasEmailCondition
See Also

Reference

HasEmailConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasEmailCondition(T) Methods

HasEmailConditionT Methods

The HasEmailConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | Executes the specified rule context. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HasEmailConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasEmailCondition(T).Execute Method

HasEmailConditionTExecute Method
Executes the specified rule context.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override bool Execute(
    T ruleContext
)
Protected Overrides Function Execute (
    ruleContext As T
) As Boolean
protected:
virtual bool Execute(
    T ruleContext
) override
abstract Execute :
        ruleContext : 'T -> bool
override Execute :
        ruleContext : 'T -> bool

Parameters

ruleContext
Type: T
The rule context.

Return Value

Type: Boolean
True if user has email. Otherwise false.
See Also

Reference

HasEmailConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasEmptyCartCondition(T) Class

HasEmptyCartConditionT Class
Represents the Has Empty Cart condition. This class is used to check whether the cart, for the user being tested with the rule, is empty.
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditionsHasEmptyCartConditionT

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class HasEmptyCartCondition<T> : WhenCondition<T>
where T : WorkflowRuleContext

Public Class HasEmptyCartCondition(Of T As WorkflowRuleContext)
    Inherits WhenCondition(Of T)
generic<typename T>
where T : WorkflowRuleContext
public ref class HasEmptyCartCondition : public WhenCondition<T>
type HasEmptyCartCondition<'T when 'T : WorkflowRuleContext> =
    class
        inherit WhenCondition<'T>
    end

Type Parameters

T
The rule context.

The HasEmptyCartConditionT type exposes the following members.

Constructors
 | Name | Description
Public method | HasEmptyCartConditionT | Initializes an instance of the HasEmptyCartConditionT class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | The execute. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | EaPlanProvider | Gets the ea plan provider.
Top
See Also

Reference

Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasEmptyCartCondition(T) Constructor

HasEmptyCartConditionT Constructor
Initializes an instance of the HasEmptyCartConditionT class.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public HasEmptyCartCondition()
Public Sub New
public:
HasEmptyCartCondition()
new : unit -> HasEmptyCartCondition
See Also

Reference

HasEmptyCartConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasEmptyCartCondition(T) Methods

HasEmptyCartConditionT Methods

The HasEmptyCartConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | The execute. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HasEmptyCartConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasEmptyCartCondition(T).Execute Method

HasEmptyCartConditionTExecute Method
The execute.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override bool Execute(
    T ruleContext
)
Protected Overrides Function Execute (
    ruleContext As T
) As Boolean
protected:
virtual bool Execute(
    T ruleContext
) override
abstract Execute :
        ruleContext : 'T -> bool
override Execute :
        ruleContext : 'T -> bool

Parameters

ruleContext
Type: T
The rule context.

Return Value

Type: Boolean
The Boolean.
See Also

Reference

HasEmptyCartConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasEmptyCartCondition(T) Properties

HasEmptyCartConditionT Properties

The HasEmptyCartConditionT generic type exposes the following members.

Properties
 | Name | Description
Protected property | EaPlanProvider | Gets the ea plan provider.
Top
See Also

Reference

HasEmptyCartConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasEmptyCartCondition(T).EaPlanProvider Property

HasEmptyCartConditionTEaPlanProvider Property
Gets the ea plan provider.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected IEaPlanProvider EaPlanProvider { get; }
Protected ReadOnly Property EaPlanProvider As IEaPlanProvider
    Get
protected:
property IEaPlanProvider^ EaPlanProvider {
    IEaPlanProvider^ get ();
}
member EaPlanProvider : IEaPlanProvider with get

Property Value

Type: IEaPlanProvider
The ea plan provider.
See Also

Reference

HasEmptyCartConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasListOfVisitorNotificationsExpiredCondition(T) Class

HasListOfVisitorNotificationsExpiredConditionT Class
Represents the "Has List of Visitor Notifications Expired" condition. This class is used to check if all of the back-in-stock notifications a user has requested have expired due to being past interest date.
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditionsHasListOfVisitorNotificationsExpiredConditionT

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class HasListOfVisitorNotificationsExpiredCondition<T> : WhenCondition<T>
where T : WorkflowRuleContext

Public Class HasListOfVisitorNotificationsExpiredCondition(Of T As WorkflowRuleContext)
    Inherits WhenCondition(Of T)
generic<typename T>
where T : WorkflowRuleContext
public ref class HasListOfVisitorNotificationsExpiredCondition : public WhenCondition<T>
type HasListOfVisitorNotificationsExpiredCondition<'T when 'T : WorkflowRuleContext> =
    class
        inherit WhenCondition<'T>
    end

Type Parameters

T
The rule context.

The HasListOfVisitorNotificationsExpiredConditionT type exposes the following members.

Constructors
 | Name | Description
Public method | HasListOfVisitorNotificationsExpiredConditionT | Initializes an instance of the HasListOfVisitorNotificationsExpiredConditionT class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | The execute. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | AutomationProvider | Gets the inventory automation provider.
Top
See Also

Reference

Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasListOfVisitorNotificationsExpiredCondition(T) Constructor

HasListOfVisitorNotificationsExpiredConditionT Constructor
Initializes an instance of the HasListOfVisitorNotificationsExpiredConditionT class.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public HasListOfVisitorNotificationsExpiredCondition()
Public Sub New
public:
HasListOfVisitorNotificationsExpiredCondition()
new : unit -> HasListOfVisitorNotificationsExpiredCondition
See Also

Reference

HasListOfVisitorNotificationsExpiredConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasListOfVisitorNotificationsExpiredCondition(T) Methods

HasListOfVisitorNotificationsExpiredConditionT Methods

The HasListOfVisitorNotificationsExpiredConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | The execute. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HasListOfVisitorNotificationsExpiredConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasListOfVisitorNotificationsExpiredCondition(T).Execute Method

HasListOfVisitorNotificationsExpiredConditionTExecute Method
The execute.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override bool Execute(
    T ruleContext
)
Protected Overrides Function Execute (
    ruleContext As T
) As Boolean
protected:
virtual bool Execute(
    T ruleContext
) override
abstract Execute :
        ruleContext : 'T -> bool
override Execute :
        ruleContext : 'T -> bool

Parameters

ruleContext
Type: T
The rule context.

Return Value

Type: Boolean
The Boolean.
See Also

Reference

HasListOfVisitorNotificationsExpiredConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasListOfVisitorNotificationsExpiredCondition(T) Properties

HasListOfVisitorNotificationsExpiredConditionT Properties

The HasListOfVisitorNotificationsExpiredConditionT generic type exposes the following members.

Properties
 | Name | Description
Protected property | AutomationProvider | Gets the inventory automation provider.
Top
See Also

Reference

HasListOfVisitorNotificationsExpiredConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


HasListOfVisitorNotificationsExpiredCondition(T).AutomationProvider Property

HasListOfVisitorNotificationsExpiredConditionTAutomationProvider Property
Gets the inventory automation provider.

Namespace: Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected InventoryAutomationProvider AutomationProvider { get; }
Protected ReadOnly Property AutomationProvider As InventoryAutomationProvider
    Get
protected:
property InventoryAutomationProvider^ AutomationProvider {
    InventoryAutomationProvider^ get ();
}
member AutomationProvider : InventoryAutomationProvider with get

Property Value

Type: InventoryAutomationProvider
See Also

Reference

HasListOfVisitorNotificationsExpiredConditionT Class
Sitecore.Commerce.Automation.MarketingAutomation.AutomationConditions Namespace


Sitecore.Commerce.Commands.Products Namespace

Sitecore.Commerce.Commands.Products Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Commands.Products"]

Classes
Class Description
Public class ProductSynchronizationCommand
Defines the base class for all Content Editor commands that launch the synchronization of the products. This class inherits from the Command class.
Public class SynchronizeAllProducts
Defines the back-end operations of the synchronize-all-products command. To synchronize all the products from and to external commerce systems, this command:
  1. Extracts the language from the context parameters and specifies that the direction of the synchronization is both ways.
  2. Uses the language and direction to create a synchronization request.
  3. Passes this request as a parameter to the SynchronizeProducts method of the ProductSynchronizationProvider class.
This class inherits from the ProductSynchronizationCommand class.
Public class SynchronizeArtifacts
Defines the back-end operations of the synchronize-all-artifacts command. For example, artifacts can be products, manufacturers, categories, or specification. To synchronize all artifacts from and to external commerce systems, this command:
  1. Extracts the language from the context parameters and specifies that the direction of the synchronization is both ways.
  2. Uses the language and direction to create a synchronization request.
  3. Passes this request as a parameter to the SynchronizeArtifacts method of the ProductSynchronizationProvider class.
This class inherits from the ProductSynchronizationCommand class.
Public class SynchronizeProduct
Defines the back-end operations of the synchronize-single-product command. To synchronize a single product from and to external commerce systems, this command: Extracts the language from the context parameters and specifies that the direction of the synchronization is both ways. Uses the product identifier, the language and direction to create a synchronization request. Passes this request as a parameter to the SynchronizeProduct method of the ProductSynchronizationProvider class. This class inherits the ProductSynchronizationCommand class.
Public class SynchronizeProductList
The synchronize product list.


ProductSynchronizationCommand Class

ProductSynchronizationCommand Class
Defines the base class for all Content Editor commands that launch the synchronization of the products. This class inherits from the Command class.
Inheritance Hierarchy
SystemObject
Command
Sitecore.Commerce.Commands.ProductsProductSynchronizationCommand
Sitecore.Commerce.Commands.ProductsSynchronizeAllProducts
Sitecore.Commerce.Commands.ProductsSynchronizeArtifacts
Sitecore.Commerce.Commands.ProductsSynchronizeProduct
Sitecore.Commerce.Commands.ProductsSynchronizeProductList

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class ProductSynchronizationCommand : Command
Public MustInherit Class ProductSynchronizationCommand
    Inherits Command
public ref class ProductSynchronizationCommand abstract : public Command
[<AbstractClassAttribute>]
type ProductSynchronizationCommand =
    class
        inherit Command
    end

The ProductSynchronizationCommand type exposes the following members.

Constructors
 | Name | Description
Protected method | ProductSynchronizationCommand | Initializes a new instance of the ProductSynchronizationCommand class
Top
Methods
 | Name | Description
Protected method | DeserializeItems | (Inherited from Command.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command that is specified in the Content Editor context. (Overrides Command.Execute(CommandContext).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClick | (Inherited from Command.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeader | (Inherited from Command.)
Public method | GetIcon | (Inherited from Command.)
Protected method | GetProcessParameters | Gets the process parameters.
Public method | GetSubmenuItems | (Inherited from Command.)
Public method | GetToolTip | (Inherited from Command.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | (Inherited from Command.)
Protected method | HasField(Item, ID) | (Inherited from Command.)
Protected method | HasField(Item, String) | (Inherited from Command.)
Protected method | IsAdvancedClient | (Inherited from Command.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QueryState | (Inherited from Command.)
Protected method | SerializeItems | (Inherited from Command.)
Protected method | Start | (Inherited from Command.)
Protected method | StartProcess | Starts the process.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommandMessage | Gets or sets the command message to show within progress box during synchronization.
Public property | CommandName | Gets or sets the name of the command to be shown in the progress box during the synchronization process.
Public property | Name | (Inherited from Command.)
Public property | ProductSynchronizationProvider | Gets or sets the instance of the ProductSynchronizationProvider class that performs synchronization by starting the corresponding pipelines.
Top
See Also

Reference

Sitecore.Commerce.Commands.Products Namespace


ProductSynchronizationCommand Constructor

ProductSynchronizationCommand Constructor
Initializes a new instance of the ProductSynchronizationCommand class

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected ProductSynchronizationCommand()
Protected Sub New
protected:
ProductSynchronizationCommand()
new : unit -> ProductSynchronizationCommand
See Also

Reference

ProductSynchronizationCommand Class
Sitecore.Commerce.Commands.Products Namespace


ProductSynchronizationCommand Methods

ProductSynchronizationCommand Methods

The ProductSynchronizationCommand type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeItems | (Inherited from Command.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command that is specified in the Content Editor context. (Overrides Command.Execute(CommandContext).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClick | (Inherited from Command.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeader | (Inherited from Command.)
Public method | GetIcon | (Inherited from Command.)
Protected method | GetProcessParameters | Gets the process parameters.
Public method | GetSubmenuItems | (Inherited from Command.)
Public method | GetToolTip | (Inherited from Command.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | (Inherited from Command.)
Protected method | HasField(Item, ID) | (Inherited from Command.)
Protected method | HasField(Item, String) | (Inherited from Command.)
Protected method | IsAdvancedClient | (Inherited from Command.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QueryState | (Inherited from Command.)
Protected method | SerializeItems | (Inherited from Command.)
Protected method | Start | (Inherited from Command.)
Protected method | StartProcess | Starts the process.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductSynchronizationCommand Class
Sitecore.Commerce.Commands.Products Namespace


ProductSynchronizationCommand.Execute Method

ProductSynchronizationCommandExecute Method
Executes the command that is specified in the Content Editor context.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Execute(
    CommandContext context
)
Public Overrides Sub Execute (
    context As CommandContext
)
public:
virtual void Execute(
    CommandContext^ context
) override
abstract Execute :
        context : CommandContext -> unit
override Execute :
        context : CommandContext -> unit

Parameters

context
Type: CommandContext
The command context
See Also

Reference

ProductSynchronizationCommand Class
Sitecore.Commerce.Commands.Products Namespace


ProductSynchronizationCommand.GetProcessParameters Method

ProductSynchronizationCommandGetProcessParameters Method
Gets the process parameters.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual Object[] GetProcessParameters(
    CommandContext context
)
Protected Overridable Function GetProcessParameters (
    context As CommandContext
) As Object()
protected:
virtual array<Object^>^ GetProcessParameters(
    CommandContext^ context
)
abstract GetProcessParameters :
        context : CommandContext -> Object[]
override GetProcessParameters :
        context : CommandContext -> Object[]

Parameters

context
Type: CommandContext
The context

Return Value

Type: Object
a collection of the parameters
See Also

Reference

ProductSynchronizationCommand Class
Sitecore.Commerce.Commands.Products Namespace


ProductSynchronizationCommand.StartProcess Method

ProductSynchronizationCommandStartProcess Method
Starts the process.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract void StartProcess(
    Object[] parameters
)
Protected MustOverride Sub StartProcess (
    parameters As Object()
)
protected:
virtual void StartProcess(
    array<Object^>^ parameters
) abstract
abstract StartProcess :
        parameters : Object[] -> unit

Parameters

parameters
Type: SystemObject
The parameters.
See Also

Reference

ProductSynchronizationCommand Class
Sitecore.Commerce.Commands.Products Namespace


ProductSynchronizationCommand Properties

ProductSynchronizationCommand Properties

The ProductSynchronizationCommand type exposes the following members.

Properties
 | Name | Description
Public property | CommandMessage | Gets or sets the command message to show within progress box during synchronization.
Public property | CommandName | Gets or sets the name of the command to be shown in the progress box during the synchronization process.
Public property | Name | (Inherited from Command.)
Public property | ProductSynchronizationProvider | Gets or sets the instance of the ProductSynchronizationProvider class that performs synchronization by starting the corresponding pipelines.
Top
See Also

Reference

ProductSynchronizationCommand Class
Sitecore.Commerce.Commands.Products Namespace


ProductSynchronizationCommand.CommandMessage Property

ProductSynchronizationCommandCommandMessage Property
Gets or sets the command message to show within progress box during synchronization.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string CommandMessage { get; set; }
Public Property CommandMessage As String
    Get
    Set
public:
property String^ CommandMessage {
    String^ get ();
    void set (String^ value);
}
member CommandMessage : string with get, set

Property Value

Type: String
The command message.
See Also

Reference

ProductSynchronizationCommand Class
Sitecore.Commerce.Commands.Products Namespace


ProductSynchronizationCommand.CommandName Property

ProductSynchronizationCommandCommandName Property
Gets or sets the name of the command to be shown in the progress box during the synchronization process.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string CommandName { get; set; }
Public Property CommandName As String
    Get
    Set
public:
property String^ CommandName {
    String^ get ();
    void set (String^ value);
}
member CommandName : string with get, set

Property Value

Type: String
The name of the command
See Also

Reference

ProductSynchronizationCommand Class
Sitecore.Commerce.Commands.Products Namespace


ProductSynchronizationCommand.ProductSynchronizationProvider Property

ProductSynchronizationCommandProductSynchronizationProvider Property
Gets or sets the instance of the ProductSynchronizationProvider class that performs synchronization by starting the corresponding pipelines.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductSynchronizationProvider ProductSynchronizationProvider { get; set; }
Public Property ProductSynchronizationProvider As ProductSynchronizationProvider
    Get
    Set
public:
property ProductSynchronizationProvider^ ProductSynchronizationProvider {
    ProductSynchronizationProvider^ get ();
    void set (ProductSynchronizationProvider^ value);
}
member ProductSynchronizationProvider : ProductSynchronizationProvider with get, set

Property Value

Type: ProductSynchronizationProvider
The product synchronization provider
See Also

Reference

ProductSynchronizationCommand Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeAllProducts Class

SynchronizeAllProducts Class
Defines the back-end operations of the synchronize-all-products command. To synchronize all the products from and to external commerce systems, this command:
  1. Extracts the language from the context parameters and specifies that the direction of the synchronization is both ways.
  2. Uses the language and direction to create a synchronization request.
  3. Passes this request as a parameter to the SynchronizeProducts method of the ProductSynchronizationProvider class.
This class inherits from the ProductSynchronizationCommand class.
Inheritance Hierarchy
SystemObject
Command
Sitecore.Commerce.Commands.ProductsProductSynchronizationCommand
Sitecore.Commerce.Commands.ProductsSynchronizeAllProducts

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeAllProducts : ProductSynchronizationCommand
Public Class SynchronizeAllProducts
    Inherits ProductSynchronizationCommand
public ref class SynchronizeAllProducts : public ProductSynchronizationCommand
type SynchronizeAllProducts =
    class
        inherit ProductSynchronizationCommand
    end

The SynchronizeAllProducts type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeAllProducts | Initializes an instance of the SynchronizeAllProducts class.
Top
Methods
 | Name | Description
Protected method | DeserializeItems | (Inherited from Command.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command that is specified in the Content Editor context. (Inherited from ProductSynchronizationCommand.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClick | (Inherited from Command.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeader | (Inherited from Command.)
Public method | GetIcon | (Inherited from Command.)
Protected method | GetProcessParameters | Gets the process parameters. (Inherited from ProductSynchronizationCommand.)
Public method | GetSubmenuItems | (Inherited from Command.)
Public method | GetToolTip | (Inherited from Command.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | (Inherited from Command.)
Protected method | HasField(Item, ID) | (Inherited from Command.)
Protected method | HasField(Item, String) | (Inherited from Command.)
Protected method | IsAdvancedClient | (Inherited from Command.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QueryState | (Inherited from Command.)
Protected method | SerializeItems | (Inherited from Command.)
Protected method | Start | (Inherited from Command.)
Protected method | StartProcess | Starts the process of the synchronization. This method calls the SynchronizeProducts method of the ProductSynchronizationProvider class passing the language and demand to synchronize products both ways. (Overrides ProductSynchronizationCommandStartProcess(Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommandMessage | Gets or sets the command message to show within progress box during synchronization. (Inherited from ProductSynchronizationCommand.)
Public property | CommandName | Gets or sets the name of the command to be shown in the progress box during the synchronization process. (Inherited from ProductSynchronizationCommand.)
Public property | Name | (Inherited from Command.)
Public property | ProductSynchronizationProvider | Gets or sets the instance of the ProductSynchronizationProvider class that performs synchronization by starting the corresponding pipelines. (Inherited from ProductSynchronizationCommand.)
Top
See Also

Reference

Sitecore.Commerce.Commands.Products Namespace


SynchronizeAllProducts Constructor

SynchronizeAllProducts Constructor
Initializes an instance of the SynchronizeAllProducts class.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeAllProducts()
Public Sub New
public:
SynchronizeAllProducts()
new : unit -> SynchronizeAllProducts
See Also

Reference

SynchronizeAllProducts Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeAllProducts Methods

SynchronizeAllProducts Methods

The SynchronizeAllProducts type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeItems | (Inherited from Command.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command that is specified in the Content Editor context. (Inherited from ProductSynchronizationCommand.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClick | (Inherited from Command.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeader | (Inherited from Command.)
Public method | GetIcon | (Inherited from Command.)
Protected method | GetProcessParameters | Gets the process parameters. (Inherited from ProductSynchronizationCommand.)
Public method | GetSubmenuItems | (Inherited from Command.)
Public method | GetToolTip | (Inherited from Command.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | (Inherited from Command.)
Protected method | HasField(Item, ID) | (Inherited from Command.)
Protected method | HasField(Item, String) | (Inherited from Command.)
Protected method | IsAdvancedClient | (Inherited from Command.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QueryState | (Inherited from Command.)
Protected method | SerializeItems | (Inherited from Command.)
Protected method | Start | (Inherited from Command.)
Protected method | StartProcess | Starts the process of the synchronization. This method calls the SynchronizeProducts method of the ProductSynchronizationProvider class passing the language and demand to synchronize products both ways. (Overrides ProductSynchronizationCommandStartProcess(Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeAllProducts Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeAllProducts.StartProcess Method

SynchronizeAllProductsStartProcess Method
Starts the process of the synchronization. This method calls the SynchronizeProducts method of the ProductSynchronizationProvider class passing the language and demand to synchronize products both ways.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void StartProcess(
    Object[] parameters
)
Protected Overrides Sub StartProcess (
    parameters As Object()
)
protected:
virtual void StartProcess(
    array<Object^>^ parameters
) override
abstract StartProcess :
        parameters : Object[] -> unit
override StartProcess :
        parameters : Object[] -> unit

Parameters

parameters
Type: SystemObject
The parameters should include language as first parameter of the array.
See Also

Reference

SynchronizeAllProducts Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeAllProducts Properties

SynchronizeAllProducts Properties

The SynchronizeAllProducts type exposes the following members.

Properties
 | Name | Description
Public property | CommandMessage | Gets or sets the command message to show within progress box during synchronization. (Inherited from ProductSynchronizationCommand.)
Public property | CommandName | Gets or sets the name of the command to be shown in the progress box during the synchronization process. (Inherited from ProductSynchronizationCommand.)
Public property | Name | (Inherited from Command.)
Public property | ProductSynchronizationProvider | Gets or sets the instance of the ProductSynchronizationProvider class that performs synchronization by starting the corresponding pipelines. (Inherited from ProductSynchronizationCommand.)
Top
See Also

Reference

SynchronizeAllProducts Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeArtifacts Class

SynchronizeArtifacts Class
Defines the back-end operations of the synchronize-all-artifacts command. For example, artifacts can be products, manufacturers, categories, or specification. To synchronize all artifacts from and to external commerce systems, this command:
  1. Extracts the language from the context parameters and specifies that the direction of the synchronization is both ways.
  2. Uses the language and direction to create a synchronization request.
  3. Passes this request as a parameter to the SynchronizeArtifacts method of the ProductSynchronizationProvider class.
This class inherits from the ProductSynchronizationCommand class.
Inheritance Hierarchy
SystemObject
Command
Sitecore.Commerce.Commands.ProductsProductSynchronizationCommand
Sitecore.Commerce.Commands.ProductsSynchronizeArtifacts

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeArtifacts : ProductSynchronizationCommand
Public Class SynchronizeArtifacts
    Inherits ProductSynchronizationCommand
public ref class SynchronizeArtifacts : public ProductSynchronizationCommand
type SynchronizeArtifacts =
    class
        inherit ProductSynchronizationCommand
    end

The SynchronizeArtifacts type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeArtifacts | Initializes an instance of the SynchronizeArtifacts class.
Top
Methods
 | Name | Description
Protected method | DeserializeItems | (Inherited from Command.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command that is specified in the Content Editor context. (Inherited from ProductSynchronizationCommand.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClick | (Inherited from Command.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeader | (Inherited from Command.)
Public method | GetIcon | (Inherited from Command.)
Protected method | GetProcessParameters | Gets the process parameters. (Inherited from ProductSynchronizationCommand.)
Public method | GetSubmenuItems | (Inherited from Command.)
Public method | GetToolTip | (Inherited from Command.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | (Inherited from Command.)
Protected method | HasField(Item, ID) | (Inherited from Command.)
Protected method | HasField(Item, String) | (Inherited from Command.)
Protected method | IsAdvancedClient | (Inherited from Command.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QueryState | (Inherited from Command.)
Protected method | SerializeItems | (Inherited from Command.)
Protected method | Start | (Inherited from Command.)
Protected method | StartProcess | Starts the process of the synchronization. This method calls the SynchronizeArtifacts method of the ProductSynchronizationProvider class passing the language and demand to synchronize artifacts both ways. (Overrides ProductSynchronizationCommandStartProcess(Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommandMessage | Gets or sets the command message to show within progress box during synchronization. (Inherited from ProductSynchronizationCommand.)
Public property | CommandName | Gets or sets the name of the command to be shown in the progress box during the synchronization process. (Inherited from ProductSynchronizationCommand.)
Public property | Name | (Inherited from Command.)
Public property | ProductSynchronizationProvider | Gets or sets the instance of the ProductSynchronizationProvider class that performs synchronization by starting the corresponding pipelines. (Inherited from ProductSynchronizationCommand.)
Top
See Also

Reference

Sitecore.Commerce.Commands.Products Namespace


SynchronizeArtifacts Constructor

SynchronizeArtifacts Constructor
Initializes an instance of the SynchronizeArtifacts class.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeArtifacts()
Public Sub New
public:
SynchronizeArtifacts()
new : unit -> SynchronizeArtifacts
See Also

Reference

SynchronizeArtifacts Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeArtifacts Methods

SynchronizeArtifacts Methods

The SynchronizeArtifacts type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeItems | (Inherited from Command.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command that is specified in the Content Editor context. (Inherited from ProductSynchronizationCommand.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClick | (Inherited from Command.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeader | (Inherited from Command.)
Public method | GetIcon | (Inherited from Command.)
Protected method | GetProcessParameters | Gets the process parameters. (Inherited from ProductSynchronizationCommand.)
Public method | GetSubmenuItems | (Inherited from Command.)
Public method | GetToolTip | (Inherited from Command.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | (Inherited from Command.)
Protected method | HasField(Item, ID) | (Inherited from Command.)
Protected method | HasField(Item, String) | (Inherited from Command.)
Protected method | IsAdvancedClient | (Inherited from Command.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QueryState | (Inherited from Command.)
Protected method | SerializeItems | (Inherited from Command.)
Protected method | Start | (Inherited from Command.)
Protected method | StartProcess | Starts the process of the synchronization. This method calls the SynchronizeArtifacts method of the ProductSynchronizationProvider class passing the language and demand to synchronize artifacts both ways. (Overrides ProductSynchronizationCommandStartProcess(Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeArtifacts Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeArtifacts.StartProcess Method

SynchronizeArtifactsStartProcess Method
Starts the process of the synchronization. This method calls the SynchronizeArtifacts method of the ProductSynchronizationProvider class passing the language and demand to synchronize artifacts both ways.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void StartProcess(
    Object[] parameters
)
Protected Overrides Sub StartProcess (
    parameters As Object()
)
protected:
virtual void StartProcess(
    array<Object^>^ parameters
) override
abstract StartProcess :
        parameters : Object[] -> unit
override StartProcess :
        parameters : Object[] -> unit

Parameters

parameters
Type: SystemObject
The parameters should include language as first parameter of the array.
See Also

Reference

SynchronizeArtifacts Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeArtifacts Properties

SynchronizeArtifacts Properties

The SynchronizeArtifacts type exposes the following members.

Properties
 | Name | Description
Public property | CommandMessage | Gets or sets the command message to show within progress box during synchronization. (Inherited from ProductSynchronizationCommand.)
Public property | CommandName | Gets or sets the name of the command to be shown in the progress box during the synchronization process. (Inherited from ProductSynchronizationCommand.)
Public property | Name | (Inherited from Command.)
Public property | ProductSynchronizationProvider | Gets or sets the instance of the ProductSynchronizationProvider class that performs synchronization by starting the corresponding pipelines. (Inherited from ProductSynchronizationCommand.)
Top
See Also

Reference

SynchronizeArtifacts Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeProduct Class

SynchronizeProduct Class
Defines the back-end operations of the synchronize-single-product command. To synchronize a single product from and to external commerce systems, this command: Extracts the language from the context parameters and specifies that the direction of the synchronization is both ways. Uses the product identifier, the language and direction to create a synchronization request. Passes this request as a parameter to the SynchronizeProduct method of the ProductSynchronizationProvider class. This class inherits the ProductSynchronizationCommand class.
Inheritance Hierarchy
SystemObject
Command
Sitecore.Commerce.Commands.ProductsProductSynchronizationCommand
Sitecore.Commerce.Commands.ProductsSynchronizeProduct

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProduct : ProductSynchronizationCommand
Public Class SynchronizeProduct
    Inherits ProductSynchronizationCommand
public ref class SynchronizeProduct : public ProductSynchronizationCommand
type SynchronizeProduct =
    class
        inherit ProductSynchronizationCommand
    end

The SynchronizeProduct type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProduct | Initializes an instance of the SynchronizeProduct class.
Top
Methods
Name | Description
Protected method | DeserializeItems | (Inherited from Command.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Execute
Executes the command that is specified in the Content Editor context.
(Inherited from ProductSynchronizationCommand.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetClick | (Inherited from Command.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetHeader | (Inherited from Command.)
Public method | GetIcon | (Inherited from Command.)
Protected method GetProcessParameters
Gets the parameters from the command context.
(Overrides ProductSynchronizationCommandGetProcessParameters(CommandContext).)
Public method | GetSubmenuItems | (Inherited from Command.)
Public method | GetToolTip | (Inherited from Command.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetValue | (Inherited from Command.)
Protected method | HasField(Item, ID) | (Inherited from Command.)
Protected method | HasField(Item, String) | (Inherited from Command.)
Protected method | IsAdvancedClient | (Inherited from Command.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method QueryState
Determines whether to show, hide, or disable command in the ribbon. This method:
  • Disables the command if there is no product selected.
  • Hides the command if the current item does not represent a product.
(Overrides Command.QueryState(CommandContext).)
Protected method | SerializeItems | (Inherited from Command.)
Protected method | Start | (Inherited from Command.)
Protected method StartProcess
Starts the process of the synchronization. This method calls the SynchronizeProduct method of the ProductSynchronizationProvider passing the product id, language and demand to synchronize product both ways.
(Overrides ProductSynchronizationCommandStartProcess(Object).)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommandMessage | Gets or sets the command message to show within progress box during synchronization. (Inherited from ProductSynchronizationCommand.)
Public property | CommandName | Gets or sets the name of the command to be shown in the progress box during the synchronization process. (Inherited from ProductSynchronizationCommand.)
Public property | Name | (Inherited from Command.)
Public property | ProductSynchronizationProvider | Gets or sets the instance of the ProductSynchronizationProvider class that performs synchronization by starting the corresponding pipelines. (Inherited from ProductSynchronizationCommand.)
Top
See Also

Reference

Sitecore.Commerce.Commands.Products Namespace


SynchronizeProduct Constructor

SynchronizeProduct Constructor
Initializes an instance of the SynchronizeProduct class.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProduct()
Public Sub New
public:
SynchronizeProduct()
new : unit -> SynchronizeProduct
See Also

Reference

SynchronizeProduct Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeProduct Methods

SynchronizeProduct Methods

The SynchronizeProduct type exposes the following members.

Methods
Name | Description
Protected method | DeserializeItems | (Inherited from Command.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Execute
Executes the command that is specified in the Content Editor context.
(Inherited from ProductSynchronizationCommand.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method | GetClick | (Inherited from Command.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method | GetHeader | (Inherited from Command.)
Public method | GetIcon | (Inherited from Command.)
Protected method GetProcessParameters
Gets the parameters from the command context.
(Overrides ProductSynchronizationCommandGetProcessParameters(CommandContext).)
Public method | GetSubmenuItems | (Inherited from Command.)
Public method | GetToolTip | (Inherited from Command.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | GetValue | (Inherited from Command.)
Protected method | HasField(Item, ID) | (Inherited from Command.)
Protected method | HasField(Item, String) | (Inherited from Command.)
Protected method | IsAdvancedClient | (Inherited from Command.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method QueryState
Determines whether to show, hide, or disable command in the ribbon. This method:
  • Disables the command if there is no product selected.
  • Hides the command if the current item does not represent a product.
(Overrides Command.QueryState(CommandContext).)
Protected method | SerializeItems | (Inherited from Command.)
Protected method | Start | (Inherited from Command.)
Protected method StartProcess
Starts the process of the synchronization. This method calls the SynchronizeProduct method of the ProductSynchronizationProvider passing the product id, language and demand to synchronize product both ways.
(Overrides ProductSynchronizationCommandStartProcess(Object).)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

SynchronizeProduct Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeProduct.GetProcessParameters Method

SynchronizeProductGetProcessParameters Method
Gets the parameters from the command context.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override Object[] GetProcessParameters(
    CommandContext context
)
Protected Overrides Function GetProcessParameters (
    context As CommandContext
) As Object()
protected:
virtual array<Object^>^ GetProcessParameters(
    CommandContext^ context
) override
abstract GetProcessParameters :
        context : CommandContext -> Object[]
override GetProcessParameters :
        context : CommandContext -> Object[]

Parameters

context
Type: CommandContext
The context

Return Value

Type: Object
A collection of the parameters.
See Also

Reference

SynchronizeProduct Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeProduct.QueryState Method

SynchronizeProductQueryState Method
Determines whether to show, hide, or disable command in the ribbon. This method:
  • Disables the command if there is no product selected.
  • Hides the command if the current item does not represent a product.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override CommandState QueryState(
    CommandContext context
)
Public Overrides Function QueryState (
    context As CommandContext
) As CommandState
public:
virtual CommandState QueryState(
    CommandContext^ context
) override
abstract QueryState :
        context : CommandContext -> CommandState
override QueryState :
        context : CommandContext -> CommandState

Parameters

context
Type: CommandContext
The context

Return Value

Type: CommandState
The command state
See Also

Reference

SynchronizeProduct Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeProduct.StartProcess Method

SynchronizeProductStartProcess Method
Starts the process of the synchronization. This method calls the SynchronizeProduct method of the ProductSynchronizationProvider passing the product id, language and demand to synchronize product both ways.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void StartProcess(
    Object[] parameters
)
Protected Overrides Sub StartProcess (
    parameters As Object()
)
protected:
virtual void StartProcess(
    array<Object^>^ parameters
) override
abstract StartProcess :
        parameters : Object[] -> unit
override StartProcess :
        parameters : Object[] -> unit

Parameters

parameters
Type: SystemObject
The parameters should include product ID as first parameter of the array and language as second parameter of the array.
See Also

Reference

SynchronizeProduct Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeProduct Properties

SynchronizeProduct Properties

The SynchronizeProduct type exposes the following members.

Properties
 | Name | Description
Public property | CommandMessage | Gets or sets the command message to show within progress box during synchronization. (Inherited from ProductSynchronizationCommand.)
Public property | CommandName | Gets or sets the name of the command to be shown in the progress box during the synchronization process. (Inherited from ProductSynchronizationCommand.)
Public property | Name | (Inherited from Command.)
Public property | ProductSynchronizationProvider | Gets or sets the instance of the ProductSynchronizationProvider class that performs synchronization by starting the corresponding pipelines. (Inherited from ProductSynchronizationCommand.)
Top
See Also

Reference

SynchronizeProduct Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeProductList Class

SynchronizeProductList Class
The synchronize product list.
Inheritance Hierarchy
SystemObject
Command
Sitecore.Commerce.Commands.ProductsProductSynchronizationCommand
Sitecore.Commerce.Commands.ProductsSynchronizeProductList

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductList : ProductSynchronizationCommand
Public Class SynchronizeProductList
    Inherits ProductSynchronizationCommand
public ref class SynchronizeProductList : public ProductSynchronizationCommand
type SynchronizeProductList =
    class
        inherit ProductSynchronizationCommand
    end

The SynchronizeProductList type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductList | Initializes a new instance of the SynchronizeProductList class.
Top
Methods
 | Name | Description
Protected method | DeserializeItems | (Inherited from Command.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command that is specified in the Content Editor context. (Inherited from ProductSynchronizationCommand.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClick | (Inherited from Command.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeader | (Inherited from Command.)
Public method | GetIcon | (Inherited from Command.)
Protected method | GetProcessParameters | Gets the process parameters. (Overrides ProductSynchronizationCommandGetProcessParameters(CommandContext).)
Protected method | GetSearchResultItems | The UI search result items.
Public method | GetSubmenuItems | (Inherited from Command.)
Public method | GetToolTip | (Inherited from Command.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | (Inherited from Command.)
Protected method | HasField(Item, ID) | (Inherited from Command.)
Protected method | HasField(Item, String) | (Inherited from Command.)
Protected method | IsAdvancedClient | (Inherited from Command.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QueryState | (Inherited from Command.)
Protected method | SerializeItems | (Inherited from Command.)
Protected method | Start | (Inherited from Command.)
Protected method | StartProcess | Starts the process. (Overrides ProductSynchronizationCommandStartProcess(Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommandMessage | Gets or sets the command message to show within progress box during synchronization. (Inherited from ProductSynchronizationCommand.)
Public property | CommandName | Gets or sets the name of the command to be shown in the progress box during the synchronization process. (Inherited from ProductSynchronizationCommand.)
Public property | Name | (Inherited from Command.)
Public property | ProductSynchronizationProvider | Gets or sets the instance of the ProductSynchronizationProvider class that performs synchronization by starting the corresponding pipelines. (Inherited from ProductSynchronizationCommand.)
Top
See Also

Reference

Sitecore.Commerce.Commands.Products Namespace


SynchronizeProductList Constructor

SynchronizeProductList Constructor
Initializes a new instance of the SynchronizeProductList class.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductList()
Public Sub New
public:
SynchronizeProductList()
new : unit -> SynchronizeProductList
See Also

Reference

SynchronizeProductList Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeProductList Methods

SynchronizeProductList Methods

The SynchronizeProductList type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeItems | (Inherited from Command.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command that is specified in the Content Editor context. (Inherited from ProductSynchronizationCommand.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClick | (Inherited from Command.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeader | (Inherited from Command.)
Public method | GetIcon | (Inherited from Command.)
Protected method | GetProcessParameters | Gets the process parameters. (Overrides ProductSynchronizationCommandGetProcessParameters(CommandContext).)
Protected method | GetSearchResultItems | The UI search result items.
Public method | GetSubmenuItems | (Inherited from Command.)
Public method | GetToolTip | (Inherited from Command.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | (Inherited from Command.)
Protected method | HasField(Item, ID) | (Inherited from Command.)
Protected method | HasField(Item, String) | (Inherited from Command.)
Protected method | IsAdvancedClient | (Inherited from Command.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QueryState | (Inherited from Command.)
Protected method | SerializeItems | (Inherited from Command.)
Protected method | Start | (Inherited from Command.)
Protected method | StartProcess | Starts the process. (Overrides ProductSynchronizationCommandStartProcess(Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductList Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeProductList.GetProcessParameters Method

SynchronizeProductListGetProcessParameters Method
Gets the process parameters.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override Object[] GetProcessParameters(
    CommandContext context
)
Protected Overrides Function GetProcessParameters (
    context As CommandContext
) As Object()
protected:
virtual array<Object^>^ GetProcessParameters(
    CommandContext^ context
) override
abstract GetProcessParameters :
        context : CommandContext -> Object[]
override GetProcessParameters :
        context : CommandContext -> Object[]

Parameters

context
Type: CommandContext
The context.

Return Value

Type: Object
The collection of parameters.
See Also

Reference

SynchronizeProductList Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeProductList.GetSearchResultItems Method

SynchronizeProductListGetSearchResultItems Method
The UI search result items.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual IQueryable<SitecoreUISearchResultItem> GetSearchResultItems(
    IProviderSearchContext searchContext,
    IEnumerable<SearchStringModel> searchStringModels,
    Item root
)
Protected Overridable Function GetSearchResultItems (
    searchContext As IProviderSearchContext,
    searchStringModels As IEnumerable(Of SearchStringModel),
    root As Item
) As IQueryable(Of SitecoreUISearchResultItem)
protected:
virtual IQueryable<SitecoreUISearchResultItem^>^ GetSearchResultItems(
    IProviderSearchContext^ searchContext,
    IEnumerable<SearchStringModel^>^ searchStringModels,
    Item^ root
)
abstract GetSearchResultItems :
        searchContext : IProviderSearchContext *
        searchStringModels : IEnumerable<SearchStringModel> *
        root : Item -> IQueryable<SitecoreUISearchResultItem>
override GetSearchResultItems :
        searchContext : IProviderSearchContext *
        searchStringModels : IEnumerable<SearchStringModel> *
        root : Item -> IQueryable<SitecoreUISearchResultItem>

Parameters

searchContext
Type: IProviderSearchContext
The search context.
searchStringModels
Type: System.Collections.GenericIEnumerable SearchStringModel
The search string models.
root
Type: Item
The root.

Return Value

Type: IQueryable SitecoreUISearchResultItem
The collection of the search result items.
See Also

Reference

SynchronizeProductList Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeProductList.StartProcess Method

SynchronizeProductListStartProcess Method
Starts the process.

Namespace: Sitecore.Commerce.Commands.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void StartProcess(
    Object[] parameters
)
Protected Overrides Sub StartProcess (
    parameters As Object()
)
protected:
virtual void StartProcess(
    array<Object^>^ parameters
) override
abstract StartProcess :
        parameters : Object[] -> unit
override StartProcess :
        parameters : Object[] -> unit

Parameters

parameters
Type: SystemObject
The parameters.
See Also

Reference

SynchronizeProductList Class
Sitecore.Commerce.Commands.Products Namespace


SynchronizeProductList Properties

SynchronizeProductList Properties

The SynchronizeProductList type exposes the following members.

Properties
 | Name | Description
Public property | CommandMessage | Gets or sets the command message to show within progress box during synchronization. (Inherited from ProductSynchronizationCommand.)
Public property | CommandName | Gets or sets the name of the command to be shown in the progress box during the synchronization process. (Inherited from ProductSynchronizationCommand.)
Public property | Name | (Inherited from Command.)
Public property | ProductSynchronizationProvider | Gets or sets the instance of the ProductSynchronizationProvider class that performs synchronization by starting the corresponding pipelines. (Inherited from ProductSynchronizationCommand.)
Top
See Also

Reference

SynchronizeProductList Class
Sitecore.Commerce.Commands.Products Namespace


Sitecore.Commerce.Data Namespace

Sitecore.Commerce.Data Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Data"]

Classes
 | Class | Description
Public class | DataColumnUtility | Defines the utility class that eases the work with the data column of engagement plans.
Interfaces
 | Interface | Description
Public interface | IEntityRepositoryTEntity | Defines the interface for the basic CRUD operations that are performed on the main commerce entities such as carts and customers.


DataColumnUtility Class

DataColumnUtility Class
Defines the utility class that eases the work with the data column of engagement plans.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.DataDataColumnUtility

Namespace: Sitecore.Commerce.Data
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class DataColumnUtility
Public NotInheritable Class DataColumnUtility
public ref class DataColumnUtility abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataColumnUtility =  class end

The DataColumnUtility type exposes the following members.

Methods
Name | Description
Deserialize | Deserializes the specified data column content.
GetData | Deserializes the collection of the Commerce entities that are stored in a special format in the the engagement plan table in the [DATA] column. This method uses the key that distinguishes the necessary data from the other values that are stored in the same field. The serialized data has the following format: key1=;;serialized_data1;;key2==serialized_data2
SerializeNameValueCollection | Serializes the name-value collection.
SetData | Serializes the collection of the Commerce entities using a special format to store them in the engagement plan table in the [DATA] column. This method uses the key that distinguishes the necessary data from the other values that are stored in the same field. The serialized data has the following format: key1=;;serialized_data1;;key2==serialized_data2
Top
Fields
Name | Description
CartDataKey | The cart data key.
CustomerDataKey | The customer data key.
Top
See Also

Reference

Sitecore.Commerce.Data Namespace


DataColumnUtility Fields

DataColumnUtility Fields

The DataColumnUtility type exposes the following members.

Fields
Name | Description
CartDataKey | The cart data key.
CustomerDataKey | The customer data key.
Top
See Also

Reference

DataColumnUtility Class
Sitecore.Commerce.Data Namespace


DataColumnUtility.CartDataKey Field

DataColumnUtilityCartDataKey Field
The cart data key.

Namespace: Sitecore.Commerce.Data
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CartDataKey
Public Const CartDataKey As String
public:
literal String^ CartDataKey
static val mutable CartDataKey: string

Field Value

Type: String
See Also

Reference

DataColumnUtility Class
Sitecore.Commerce.Data Namespace


DataColumnUtility.CustomerDataKey Field

DataColumnUtilityCustomerDataKey Field
The customer data key.

Namespace: Sitecore.Commerce.Data
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CustomerDataKey
Public Const CustomerDataKey As String
public:
literal String^ CustomerDataKey
static val mutable CustomerDataKey: string

Field Value

Type: String
See Also

Reference

DataColumnUtility Class
Sitecore.Commerce.Data Namespace


DataColumnUtility Methods

DataColumnUtility Methods

The DataColumnUtility type exposes the following members.

Methods
Name | Description
Deserialize | Deserializes the specified data column content.
GetData | Deserializes the collection of the Commerce entities that are stored in a special format in the the engagement plan table in the [DATA] column. This method uses the key that distinguishes the necessary data from the other values that are stored in the same field. The serialized data has the following format: key1=;;serialized_data1;;key2==serialized_data2
SerializeNameValueCollection | Serializes the name-value collection.
SetData | Serializes the collection of the Commerce entities using a special format to store them in the engagement plan table in the [DATA] column. This method uses the key that distinguishes the necessary data from the other values that are stored in the same field. The serialized data has the following format: key1=;;serialized_data1;;key2==serialized_data2
Top
See Also

Reference

DataColumnUtility Class
Sitecore.Commerce.Data Namespace


DataColumnUtility.Deserialize Method

DataColumnUtilityDeserialize Method
Deserializes the specified data column content.

Namespace: Sitecore.Commerce.Data
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static NameValueCollection Deserialize(
    string dataColumnContent
)
Public Shared Function Deserialize (
    dataColumnContent As String
) As NameValueCollection
public:
static NameValueCollection^ Deserialize(
    String^ dataColumnContent
)
static member Deserialize :
        dataColumnContent : string -> NameValueCollection

Parameters

dataColumnContent
Type: SystemString
The content of the data column

Return Value

Type: NameValueCollection
The deserialized Name-Value collection
Exceptions
Exception | Condition
InvalidOperationException | Exception thrown when provided content is not in proper format.
See Also

Reference

DataColumnUtility Class
Sitecore.Commerce.Data Namespace


DataColumnUtility.GetData Method

DataColumnUtilityGetData Method
Deserializes the collection of the Commerce entities that are stored in a special format in the the engagement plan table in the [DATA] column. This method uses the key that distinguishes the necessary data from the other values that are stored in the same field. The serialized data has the following format: key1=;;serialized_data1;;key2==serialized_data2

Namespace: Sitecore.Commerce.Data
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static string GetData(
    string dataColumnContent,
    string key
)
Public Shared Function GetData (
    dataColumnContent As String,
    key As String
) As String
public:
static String^ GetData(
    String^ dataColumnContent,
    String^ key
)
static member GetData :
        dataColumnContent : string *
        key : string -> string

Parameters

dataColumnContent
Type: SystemString
The content of the data column
key
Type: SystemString
The key

Return Value

Type: String
The application-constrained content of the [DATA] column
See Also

Reference

DataColumnUtility Class
Sitecore.Commerce.Data Namespace


DataColumnUtility.SerializeNameValueCollection Method

DataColumnUtilitySerializeNameValueCollection Method
Serializes the name-value collection.

Namespace: Sitecore.Commerce.Data
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static string SerializeNameValueCollection(
    NameValueCollection collection
)
Public Shared Function SerializeNameValueCollection (
    collection As NameValueCollection
) As String
public:
static String^ SerializeNameValueCollection(
    NameValueCollection^ collection
)
static member SerializeNameValueCollection :
        collection : NameValueCollection -> string

Parameters

collection
Type: System.Collections.SpecializedNameValueCollection
The collection

Return Value

Type: String
The serialized representation of collection
See Also

Reference

DataColumnUtility Class
Sitecore.Commerce.Data Namespace


DataColumnUtility.SetData Method

DataColumnUtilitySetData Method
Serializes the collection of the Commerce entities using a special format to store them in the engagement plan table in the [DATA] column. This method uses the key that distinguishes the necessary data from the other values that are stored in the same field. The serialized data has the following format: key1=;;serialized_data1;;key2==serialized_data2

Namespace: Sitecore.Commerce.Data
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static string SetData(
    string dataColumnContent,
    string value,
    string key
)
Public Shared Function SetData (
    dataColumnContent As String,
    value As String,
    key As String
) As String
public:
static String^ SetData(
    String^ dataColumnContent,
    String^ value,
    String^ key
)
static member SetData :
        dataColumnContent : string *
        value : string *
        key : string -> string

Parameters

dataColumnContent
Type: SystemString
The content of the data column
value
Type: SystemString
The value
key
Type: SystemString
The key

Return Value

Type: String
The modified data column contents
See Also

Reference

DataColumnUtility Class
Sitecore.Commerce.Data Namespace


IEntityRepository(TEntity) Interface

IEntityRepositoryTEntity Interface
Defines the interface for the basic CRUD operations that are performed on the main commerce entities such as carts and customers.

Namespace: Sitecore.Commerce.Data
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public interface IEntityRepository<in TEntity>
where TEntity : new()

Public Interface IEntityRepository(Of In TEntity As New)
generic<typename TEntity>
where TEntity : gcnew()
public interface class IEntityRepository
type IEntityRepository<'TEntity when 'TEntity : new()> =  interface end

Type Parameters

TEntity
The type of the entity.

The IEntityRepositoryTEntity type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates the specified entity.
Public method | Delete | Deletes the specified entity.
Public method | Update | Updates the specified entity.
Top
See Also

Reference

Sitecore.Commerce.Data Namespace


IEntityRepository(TEntity) Methods

IEntityRepositoryTEntity Methods

The IEntityRepositoryTEntity generic type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates the specified entity.
Public method | Delete | Deletes the specified entity.
Public method | Update | Updates the specified entity.
Top
See Also

Reference

IEntityRepositoryTEntity Interface
Sitecore.Commerce.Data Namespace


IEntityRepository(TEntity).Create Method

IEntityRepositoryTEntityCreate Method
Creates the specified entity.

Namespace: Sitecore.Commerce.Data
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
void Create(
    TEntity entity
)
Sub Create (
    entity As TEntity
)
void Create(
    TEntity entity
)
abstract Create :
        entity : 'TEntity -> unit

Parameters

entity
Type: TEntity
The entity
See Also

Reference

IEntityRepositoryTEntity Interface
Sitecore.Commerce.Data Namespace


IEntityRepository(TEntity).Delete Method

IEntityRepositoryTEntityDelete Method
Deletes the specified entity.

Namespace: Sitecore.Commerce.Data
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
void Delete(
    TEntity entity
)
Sub Delete (
    entity As TEntity
)
void Delete(
    TEntity entity
)
abstract Delete :
        entity : 'TEntity -> unit

Parameters

entity
Type: TEntity
The entity
See Also

Reference

IEntityRepositoryTEntity Interface
Sitecore.Commerce.Data Namespace


IEntityRepository(TEntity).Update Method

IEntityRepositoryTEntityUpdate Method
Updates the specified entity.

Namespace: Sitecore.Commerce.Data
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
void Update(
    TEntity entity
)
Sub Update (
    entity As TEntity
)
void Update(
    TEntity entity
)
abstract Update :
        entity : 'TEntity -> unit

Parameters

entity
Type: TEntity
The entity
See Also

Reference

IEntityRepositoryTEntity Interface
Sitecore.Commerce.Data Namespace


Sitecore.Commerce.Data.Carts Namespace

Sitecore.Commerce.Data.Carts Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Data.Carts"]

Classes
 | Class | Description
Public class | EaStateCartRepository | The cart repository.
Public class | EaStateSqlBasedCartRepository | The EA state SQL-based cart repository.
Interfaces
 | Interface | Description
Public interface | ICartRepository | The cart repository interface. This interface allows you to store carts.


EaStateCartRepository Class

EaStateCartRepository Class
The cart repository.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.CartsEaStateCartRepository

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EaStateCartRepository : ICartRepository,
    IEntityRepository<Cart>
Public Class EaStateCartRepository
    Implements ICartRepository, IEntityRepository(Of Cart)
public ref class EaStateCartRepository : ICartRepository,
    IEntityRepository<Cart^>
type EaStateCartRepository =
    class
        interface ICartRepository
        interface IEntityRepository<Cart>
    end

The EaStateCartRepository type exposes the following members.

Constructors
 | Name | Description
Public method | EaStateCartRepository | Initializes a new instance of the EaStateCartRepository class.
Top
Methods
 | Name | Description
Public method | Create | Creates the specified entity.
Public method | Delete | Deletes the specified entity.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAll | Gets all carts.
Public method | GetByCartId | Gets cart by cart id.
Public method | GetByUserName | Gets list of the carts by user name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the specified entity.
Top
See Also

Reference

Sitecore.Commerce.Data.Carts Namespace


EaStateCartRepository Constructor

EaStateCartRepository Constructor
Initializes a new instance of the EaStateCartRepository class.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EaStateCartRepository(
    IEntityFactory entityFactory,
    IEaPlanProvider eaPlanProvider
)
Public Sub New (
    entityFactory As IEntityFactory,
    eaPlanProvider As IEaPlanProvider
)
public:
EaStateCartRepository(
    IEntityFactory^ entityFactory,
    IEaPlanProvider^ eaPlanProvider
)
new :
        entityFactory : IEntityFactory *
        eaPlanProvider : IEaPlanProvider -> EaStateCartRepository

Parameters

entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
eaPlanProvider
Type: Sitecore.Commerce.MultishopIEaPlanProvider
The engagement plan provider.
See Also

Reference

EaStateCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateCartRepository Methods

EaStateCartRepository Methods

The EaStateCartRepository type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates the specified entity.
Public method | Delete | Deletes the specified entity.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAll | Gets all carts.
Public method | GetByCartId | Gets cart by cart id.
Public method | GetByUserName | Gets list of the carts by user name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the specified entity.
Top
See Also

Reference

EaStateCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateCartRepository.Create Method

EaStateCartRepositoryCreate Method
Creates the specified entity.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Create(
    Cart entity
)
Public Overridable Sub Create (
    entity As Cart
)
public:
virtual void Create(
    Cart^ entity
)
abstract Create :
        entity : Cart -> unit
override Create :
        entity : Cart -> unit

Parameters

entity
Type: Sitecore.Commerce.Entities.CartsCart
The entity.

Implements

IEntityRepositoryTEntityCreate(TEntity)
See Also

Reference

EaStateCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateCartRepository.Delete Method

EaStateCartRepositoryDelete Method
Deletes the specified entity.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Delete(
    Cart entity
)
Public Overridable Sub Delete (
    entity As Cart
)
public:
virtual void Delete(
    Cart^ entity
)
abstract Delete :
        entity : Cart -> unit
override Delete :
        entity : Cart -> unit

Parameters

entity
Type: Sitecore.Commerce.Entities.CartsCart
The entity.

Implements

IEntityRepositoryTEntityDelete(TEntity)
See Also

Reference

EaStateCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateCartRepository.GetAll Method

EaStateCartRepositoryGetAll Method
Gets all carts.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<CartBase> GetAll(
    string shopName
)
Public Overridable Function GetAll (
    shopName As String
) As IEnumerable(Of CartBase)
public:
virtual IEnumerable<CartBase^>^ GetAll(
    String^ shopName
)
abstract GetAll :
        shopName : string -> IEnumerable<CartBase>
override GetAll :
        shopName : string -> IEnumerable<CartBase>

Parameters

shopName
Type: SystemString
Name of the shop.

Return Value

Type: IEnumerable CartBase
List of carts.

Implements

ICartRepositoryGetAll(String)
See Also

Reference

EaStateCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateCartRepository.GetByCartId Method

EaStateCartRepositoryGetByCartId Method
Gets cart by cart id.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual Cart GetByCartId(
    string cartId,
    string shopName
)
Public Overridable Function GetByCartId (
    cartId As String,
    shopName As String
) As Cart
public:
virtual Cart^ GetByCartId(
    String^ cartId,
    String^ shopName
)
abstract GetByCartId :
        cartId : string *
        shopName : string -> Cart
override GetByCartId :
        cartId : string *
        shopName : string -> Cart

Parameters

cartId
Type: SystemString
The cart id.
shopName
Type: SystemString
Name of the shop.

Return Value

Type: Cart
Specified cart.

Implements

ICartRepositoryGetByCartId(String, String)
See Also

Reference

EaStateCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateCartRepository.GetByUserName Method

EaStateCartRepositoryGetByUserName Method
Gets list of the carts by user name.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<CartBase> GetByUserName(
    string userName,
    string shopName
)
Public Overridable Function GetByUserName (
    userName As String,
    shopName As String
) As IEnumerable(Of CartBase)
public:
virtual IEnumerable<CartBase^>^ GetByUserName(
    String^ userName,
    String^ shopName
)
abstract GetByUserName :
        userName : string *
        shopName : string -> IEnumerable<CartBase>
override GetByUserName :
        userName : string *
        shopName : string -> IEnumerable<CartBase>

Parameters

userName
Type: SystemString
The user name.
shopName
Type: SystemString
Name of the shop.

Return Value

Type: IEnumerable CartBase
List of carts.

Implements

ICartRepositoryGetByUserName(String, String)
See Also

Reference

EaStateCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateCartRepository.Update Method

EaStateCartRepositoryUpdate Method
Updates the specified entity.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Update(
    Cart entity
)
Public Overridable Sub Update (
    entity As Cart
)
public:
virtual void Update(
    Cart^ entity
)
abstract Update :
        entity : Cart -> unit
override Update :
        entity : Cart -> unit

Parameters

entity
Type: Sitecore.Commerce.Entities.CartsCart
The entity.

Implements

IEntityRepositoryTEntityUpdate(TEntity)
See Also

Reference

EaStateCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateSqlBasedCartRepository Class

EaStateSqlBasedCartRepository Class
The EA state SQL-based cart repository.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.CartsEaStateSqlBasedCartRepository

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EaStateSqlBasedCartRepository : ICartRepository,
    IEntityRepository<Cart>
Public Class EaStateSqlBasedCartRepository
    Implements ICartRepository, IEntityRepository(Of Cart)
public ref class EaStateSqlBasedCartRepository : ICartRepository,
    IEntityRepository<Cart^>
type EaStateSqlBasedCartRepository =
    class
        interface ICartRepository
        interface IEntityRepository<Cart>
    end

The EaStateSqlBasedCartRepository type exposes the following members.

Constructors
 | Name | Description
Public method | EaStateSqlBasedCartRepository | Initializes a new instance of the EaStateSqlBasedCartRepository class.
Top
Methods
 | Name | Description
Public method | Create | Creates the new cart in EA state. If cart creation was not successful throws an exception.
Public method | Delete | Deletes the existing cart.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAll | Gets all carts that are stored in Engagement Automation state.
Public method | GetByCartId | Gets cart by cart id.
Public method | GetByUserName | Gets the carts by user name.
Protected method | GetCartJsonConvertersT | Gets the cart json converters.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the existing cart.
Top
See Also

Reference

Sitecore.Commerce.Data.Carts Namespace


EaStateSqlBasedCartRepository Constructor

EaStateSqlBasedCartRepository Constructor
Initializes a new instance of the EaStateSqlBasedCartRepository class.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EaStateSqlBasedCartRepository(
    IEntityFactory entityFactory,
    SqlDataApi sqlDataApi,
    IEaPlanProvider eaPlanProvider
)
Public Sub New (
    entityFactory As IEntityFactory,
    sqlDataApi As SqlDataApi,
    eaPlanProvider As IEaPlanProvider
)
public:
EaStateSqlBasedCartRepository(
    IEntityFactory^ entityFactory,
    SqlDataApi^ sqlDataApi,
    IEaPlanProvider^ eaPlanProvider
)
new :
        entityFactory : IEntityFactory *
        sqlDataApi : SqlDataApi *
        eaPlanProvider : IEaPlanProvider -> EaStateSqlBasedCartRepository

Parameters

entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
sqlDataApi
Type: SqlDataApi
The SQL data API.
eaPlanProvider
Type: Sitecore.Commerce.MultishopIEaPlanProvider
The EA plan provider.
See Also

Reference

EaStateSqlBasedCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateSqlBasedCartRepository Methods

EaStateSqlBasedCartRepository Methods

The EaStateSqlBasedCartRepository type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates the new cart in EA state. If cart creation was not successful throws an exception.
Public method | Delete | Deletes the existing cart.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAll | Gets all carts that are stored in Engagement Automation state.
Public method | GetByCartId | Gets cart by cart id.
Public method | GetByUserName | Gets the carts by user name.
Protected method | GetCartJsonConvertersT | Gets the cart json converters.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the existing cart.
Top
See Also

Reference

EaStateSqlBasedCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateSqlBasedCartRepository.Create Method

EaStateSqlBasedCartRepositoryCreate Method
Creates the new cart in EA state. If cart creation was not successful throws an exception.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Create(
    Cart cart
)
Public Overridable Sub Create (
    cart As Cart
)
public:
virtual void Create(
    Cart^ cart
)
abstract Create :
        cart : Cart -> unit
override Create :
        cart : Cart -> unit

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart to create.

Implements

IEntityRepositoryTEntityCreate(TEntity)
See Also

Reference

EaStateSqlBasedCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateSqlBasedCartRepository.Delete Method

EaStateSqlBasedCartRepositoryDelete Method
Deletes the existing cart.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Delete(
    Cart cart
)
Public Overridable Sub Delete (
    cart As Cart
)
public:
virtual void Delete(
    Cart^ cart
)
abstract Delete :
        cart : Cart -> unit
override Delete :
        cart : Cart -> unit

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.

Implements

IEntityRepositoryTEntityDelete(TEntity)
See Also

Reference

EaStateSqlBasedCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateSqlBasedCartRepository.GetAll Method

EaStateSqlBasedCartRepositoryGetAll Method
Gets all carts that are stored in Engagement Automation state.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<CartBase> GetAll(
    string shopName
)
Public Overridable Function GetAll (
    shopName As String
) As IEnumerable(Of CartBase)
public:
virtual IEnumerable<CartBase^>^ GetAll(
    String^ shopName
)
abstract GetAll :
        shopName : string -> IEnumerable<CartBase>
override GetAll :
        shopName : string -> IEnumerable<CartBase>

Parameters

shopName
Type: SystemString
Name of the shop.

Return Value

Type: IEnumerable CartBase
List of carts.

Implements

ICartRepositoryGetAll(String)
See Also

Reference

EaStateSqlBasedCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateSqlBasedCartRepository.GetByCartId Method

EaStateSqlBasedCartRepositoryGetByCartId Method
Gets cart by cart id.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual Cart GetByCartId(
    string cartId,
    string shopName
)
Public Overridable Function GetByCartId (
    cartId As String,
    shopName As String
) As Cart
public:
virtual Cart^ GetByCartId(
    String^ cartId,
    String^ shopName
)
abstract GetByCartId :
        cartId : string *
        shopName : string -> Cart
override GetByCartId :
        cartId : string *
        shopName : string -> Cart

Parameters

cartId
Type: SystemString
The cart id.
shopName
Type: SystemString
Name of the shop.

Return Value

Type: Cart
Specified cart.

Implements

ICartRepositoryGetByCartId(String, String)
See Also

Reference

EaStateSqlBasedCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateSqlBasedCartRepository.GetByUserName Method

EaStateSqlBasedCartRepositoryGetByUserName Method
Gets the carts by user name.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<CartBase> GetByUserName(
    string userName,
    string shopName
)
Public Overridable Function GetByUserName (
    userName As String,
    shopName As String
) As IEnumerable(Of CartBase)
public:
virtual IEnumerable<CartBase^>^ GetByUserName(
    String^ userName,
    String^ shopName
)
abstract GetByUserName :
        userName : string *
        shopName : string -> IEnumerable<CartBase>
override GetByUserName :
        userName : string *
        shopName : string -> IEnumerable<CartBase>

Parameters

userName
Type: SystemString
Name of the user.
shopName
Type: SystemString
Name of the shop.

Return Value

Type: IEnumerable CartBase
List of carts.

Implements

ICartRepositoryGetByUserName(String, String)
See Also

Reference

EaStateSqlBasedCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateSqlBasedCartRepository.GetCartJsonConverters(T) Method

EaStateSqlBasedCartRepositoryGetCartJsonConvertersT Method
Gets the cart json converters.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual JsonConverter[] GetCartJsonConverters<T>()

Protected Overridable Function GetCartJsonConverters(Of T) As JsonConverter()
protected:
generic<typename T>
virtual array<JsonConverter^>^ GetCartJsonConverters()
abstract GetCartJsonConverters : unit -> JsonConverter[]
override GetCartJsonConverters : unit -> JsonConverter[]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.Commerce.Data.Carts.EaStateSqlBasedCartRepository.GetCartJsonConverters``1"]

Return Value

Type: JsonConverter
An array of Json converters for the cart,
See Also

Reference

EaStateSqlBasedCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


EaStateSqlBasedCartRepository.Update Method

EaStateSqlBasedCartRepositoryUpdate Method
Updates the existing cart.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Update(
    Cart cart
)
Public Overridable Sub Update (
    cart As Cart
)
public:
virtual void Update(
    Cart^ cart
)
abstract Update :
        cart : Cart -> unit
override Update :
        cart : Cart -> unit

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.

Implements

IEntityRepositoryTEntityUpdate(TEntity)
See Also

Reference

EaStateSqlBasedCartRepository Class
Sitecore.Commerce.Data.Carts Namespace


ICartRepository Interface

ICartRepository Interface
The cart repository interface. This interface allows you to store carts.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public interface ICartRepository : IEntityRepository<Cart>
Public Interface ICartRepository
    Inherits IEntityRepository(Of Cart)
public interface class ICartRepository : IEntityRepository<Cart^>
type ICartRepository =
    interface
        interface IEntityRepository<Cart>
    end

The ICartRepository type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates the specified entity. (Inherited from IEntityRepositoryTEntity.)
Public method | Delete | Deletes the specified entity. (Inherited from IEntityRepositoryTEntity.)
Public method | GetAll | Gets all carts.
Public method | GetByCartId | Gets a cart by cart ID.
Public method | GetByUserName | Gets list of the carts by user name.
Public method | Update | Updates the specified entity. (Inherited from IEntityRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Carts Namespace


ICartRepository Methods

ICartRepository Methods

The ICartRepository type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates the specified entity. (Inherited from IEntityRepositoryTEntity.)
Public method | Delete | Deletes the specified entity. (Inherited from IEntityRepositoryTEntity.)
Public method | GetAll | Gets all carts.
Public method | GetByCartId | Gets a cart by cart ID.
Public method | GetByUserName | Gets list of the carts by user name.
Public method | Update | Updates the specified entity. (Inherited from IEntityRepositoryTEntity.)
Top
See Also

Reference

ICartRepository Interface
Sitecore.Commerce.Data.Carts Namespace


ICartRepository.GetAll Method

ICartRepositoryGetAll Method
Gets all carts.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
IEnumerable<CartBase> GetAll(
    string shopName
)
Function GetAll (
    shopName As String
) As IEnumerable(Of CartBase)
IEnumerable<CartBase^>^ GetAll(
    String^ shopName
)
abstract GetAll :
        shopName : string -> IEnumerable<CartBase>

Parameters

shopName
Type: SystemString
Name of the shop.

Return Value

Type: IEnumerable CartBase
List of carts.
See Also

Reference

ICartRepository Interface
Sitecore.Commerce.Data.Carts Namespace


ICartRepository.GetByCartId Method

ICartRepositoryGetByCartId Method
Gets a cart by cart ID.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
Cart GetByCartId(
    string cartId,
    string shopName
)
Function GetByCartId (
    cartId As String,
    shopName As String
) As Cart
Cart^ GetByCartId(
    String^ cartId,
    String^ shopName
)
abstract GetByCartId :
        cartId : string *
        shopName : string -> Cart

Parameters

cartId
Type: SystemString
The cart ID.
shopName
Type: SystemString
Name of the shop.

Return Value

Type: Cart
Specified cart.
See Also

Reference

ICartRepository Interface
Sitecore.Commerce.Data.Carts Namespace


ICartRepository.GetByUserName Method

ICartRepositoryGetByUserName Method
Gets list of the carts by user name.

Namespace: Sitecore.Commerce.Data.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
IEnumerable<CartBase> GetByUserName(
    string userName,
    string shopName
)
Function GetByUserName (
    userName As String,
    shopName As String
) As IEnumerable(Of CartBase)
IEnumerable<CartBase^>^ GetByUserName(
    String^ userName,
    String^ shopName
)
abstract GetByUserName :
        userName : string *
        shopName : string -> IEnumerable<CartBase>

Parameters

userName
Type: SystemString
The user name.
shopName
Type: SystemString
Name of the shop.

Return Value

Type: IEnumerable CartBase
List of carts.
See Also

Reference

ICartRepository Interface
Sitecore.Commerce.Data.Carts Namespace


Sitecore.Commerce.Data.Converters Namespace

Sitecore.Commerce.Data.Converters Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Data.Converters"]

Classes
 | Class | Description
Public class | EntityJsonConverterT | Provides the type definition that is passed to the Newtonsoft JSON Converter. The JSON coverter can then deserialize the JSON string into an instance of the correct type. The main goal is to serve the instantiation of the Commerce business entities that are registered in commerce.Entities configuration section.


EntityJsonConverter(T) Class

EntityJsonConverterT Class
Provides the type definition that is passed to the Newtonsoft JSON Converter. The JSON coverter can then deserialize the JSON string into an instance of the correct type. The main goal is to serve the instantiation of the Commerce business entities that are registered in commerce.Entities configuration section.
Inheritance Hierarchy
SystemObject
JsonConverter
CustomCreationConverterT
Sitecore.Commerce.Data.ConvertersEntityJsonConverterT

Namespace: Sitecore.Commerce.Data.Converters
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EntityJsonConverter<T> : CustomCreationConverter<T>

Public Class EntityJsonConverter(Of T)
    Inherits CustomCreationConverter(Of T)
generic<typename T>
public ref class EntityJsonConverter : public CustomCreationConverter<T>
type EntityJsonConverter<'T> =
    class
        inherit CustomCreationConverter<'T>
    end

Type Parameters

T
The object type

The EntityJsonConverterT type exposes the following members.

Constructors
 | Name | Description
Public method | EntityJsonConverterT | Initializes an instance of the EntityJsonConverterT class.
Top
Methods
 | Name | Description
Public method | CanConvert | (Inherited from CustomCreationConverterT.)
Public method | Create | Creates an instance of the entity using the EntityFactory class and the name of the Type type. This method allows the Newtonsoft JSON Converter to instantiate the Commerce business entities that are registered in commerce.Entities configuration section. (Overrides CustomCreationConverter.Create(Type).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchema | (Inherited from JsonConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadJson | (Inherited from CustomCreationConverterT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteJson | (Inherited from CustomCreationConverterT.)
Top
Properties
 | Name | Description
Public property | CanRead | (Inherited from JsonConverter.)
Public property | CanWrite | (Inherited from CustomCreationConverterT.)
Top
See Also

Reference

Sitecore.Commerce.Data.Converters Namespace


EntityJsonConverter(T) Constructor

EntityJsonConverterT Constructor
Initializes an instance of the EntityJsonConverterT class.

Namespace: Sitecore.Commerce.Data.Converters
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EntityJsonConverter(
    IEntityFactory entityFactory
)
Public Sub New (
    entityFactory As IEntityFactory
)
public:
EntityJsonConverter(
    IEntityFactory^ entityFactory
)
new :
        entityFactory : IEntityFactory -> EntityJsonConverter

Parameters

entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory
See Also

Reference

EntityJsonConverterT Class
Sitecore.Commerce.Data.Converters Namespace


EntityJsonConverter(T) Methods

EntityJsonConverterT Methods

The EntityJsonConverterT generic type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | (Inherited from CustomCreationConverterT .)
Public method | Create | Creates an instance of the entity using the EntityFactory class and the name of the Type type. This method allows the Newtonsoft JSON Converter to instantiate the Commerce business entities that are registered in commerce.Entities configuration section. (Overrides CustomCreationConverter.Create(Type).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchema | (Inherited from JsonConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadJson | (Inherited from CustomCreationConverterT .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteJson | (Inherited from CustomCreationConverterT .)
Top
See Also

Reference

EntityJsonConverterT Class
Sitecore.Commerce.Data.Converters Namespace


EntityJsonConverter(T).Create Method

EntityJsonConverterTCreate Method
Creates an instance of the entity using the EntityFactory class and the name of the Type type. This method allows the Newtonsoft JSON Converter to instantiate the Commerce business entities that are registered in commerce.Entities configuration section.

Namespace: Sitecore.Commerce.Data.Converters
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override T Create(
    Type objectType
)
Public Overrides Function Create (
    objectType As Type
) As T
public:
virtual T Create(
    Type^ objectType
) override
abstract Create :
        objectType : Type -> 'T
override Create :
        objectType : Type -> 'T

Parameters

objectType
Type: SystemType
The object type

Return Value

Type: T
The Type
See Also

Reference

EntityJsonConverterT Class
Sitecore.Commerce.Data.Converters Namespace


EntityJsonConverter(T) Properties

EntityJsonConverterT Properties

The EntityJsonConverterT generic type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | (Inherited from JsonConverter.)
Public property | CanWrite | (Inherited from CustomCreationConverterT .)
Top
See Also

Reference

EntityJsonConverterT Class
Sitecore.Commerce.Data.Converters Namespace


Sitecore.Commerce.Data.Customers Namespace

Sitecore.Commerce.Data.Customers Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Data.Customers"]

Classes
 | Class | Description
Public class | EaStateCustomerRepository | Represents the customer repository of the engagement automation state. This class implements the ICustomerRepository interface.
Public class | SitecoreMembershipCustomerRepository | Defines the SitecoreMembershipCustomerRepository class.
Public class | SitecoreUserRepository | The Sitecore user repository.
Public class | UserProfileRepository | Defines the UserProfileRepository class.
Interfaces
 | Interface | Description
Public interface | ICustomerRepository | Represents the customer repository interface.
Public interface | IUserRepository | The user repository interface.


EaStateCustomerRepository Class

EaStateCustomerRepository Class
Represents the customer repository of the engagement automation state. This class implements the ICustomerRepository interface.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.CustomersEaStateCustomerRepository

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EaStateCustomerRepository : ICustomerRepository,
    IEntityRepository<CommerceCustomer>
Public Class EaStateCustomerRepository
    Implements ICustomerRepository, IEntityRepository(Of CommerceCustomer)
public ref class EaStateCustomerRepository : ICustomerRepository,
    IEntityRepository<CommerceCustomer^>
type EaStateCustomerRepository =
    class
        interface ICustomerRepository
        interface IEntityRepository<CommerceCustomer>
    end

The EaStateCustomerRepository type exposes the following members.

Constructors
 | Name | Description
Public method | EaStateCustomerRepository | Initializes an instance of the EaStateCustomerRepository class.
Top
Methods
 | Name | Description
Public method | AddCustomerParties | Adds the customer parties.
Public method | AddParties | Adds the parties.
Public method | Create | Creates the customer repository state of the engagement automation.
Public method | Delete | Deletes a commerce customer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the customer by name.
Public method | GetAll | Gets all customeers.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParties | Gets the parties.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveCustomerParties | Removes the customer parties.
Public method | RemoveParties | Removes the parties. Any customer party referencing the party will also be removed.
Public method | Search | Searches the specified search criteria.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates a commerce customer.
Public method | UpdateCustomerParties | Updates the customer parties.
Public method | UpdateParties | Updates the parties.
Top
See Also

Reference

Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository Constructor

EaStateCustomerRepository Constructor
Initializes an instance of the EaStateCustomerRepository class.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EaStateCustomerRepository(
    IEntityFactory entityFactory,
    string automationId,
    string initialStateId
)
Public Sub New (
    entityFactory As IEntityFactory,
    automationId As String,
    initialStateId As String
)
public:
EaStateCustomerRepository(
    IEntityFactory^ entityFactory,
    String^ automationId,
    String^ initialStateId
)
new :
        entityFactory : IEntityFactory *
        automationId : string *
        initialStateId : string -> EaStateCustomerRepository

Parameters

entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
automationId
Type: SystemString
The automation id.
initialStateId
Type: SystemString
The initial state id.
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository Methods

EaStateCustomerRepository Methods

The EaStateCustomerRepository type exposes the following members.

Methods
 | Name | Description
Public method | AddCustomerParties | Adds the customer parties.
Public method | AddParties | Adds the parties.
Public method | Create | Creates the customer repository state of the engagement automation.
Public method | Delete | Deletes a commerce customer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the customer by name.
Public method | GetAll | Gets all customeers.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParties | Gets the parties.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveCustomerParties | Removes the customer parties.
Public method | RemoveParties | Removes the parties. Any customer party referencing the party will also be removed.
Public method | Search | Searches the specified search criteria.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates a commerce customer.
Public method | UpdateCustomerParties | Updates the customer parties.
Public method | UpdateParties | Updates the parties.
Top
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository.AddCustomerParties Method

EaStateCustomerRepositoryAddCustomerParties Method
Adds the customer parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<CustomerParty> AddCustomerParties(
    CommerceCustomer customer,
    List<CustomerParty> customerParties
)
Public Overridable Function AddCustomerParties (
    customer As CommerceCustomer,
    customerParties As List(Of CustomerParty)
) As List(Of CustomerParty)
public:
virtual List<CustomerParty^>^ AddCustomerParties(
    CommerceCustomer^ customer,
    List<CustomerParty^>^ customerParties
)
abstract AddCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> List<CustomerParty>
override AddCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> List<CustomerParty>

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
customerParties
Type: System.Collections.GenericList CustomerParty
The customer parties.

Return Value

Type: List CustomerParty
A list of the new customer parties that were added.

Implements

ICustomerRepositoryAddCustomerParties(CommerceCustomer, ListCustomerParty)
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository.AddParties Method

EaStateCustomerRepositoryAddParties Method
Adds the parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<Party> AddParties(
    CommerceCustomer customer,
    List<Party> parties
)
Public Overridable Function AddParties (
    customer As CommerceCustomer,
    parties As List(Of Party)
) As List(Of Party)
public:
virtual List<Party^>^ AddParties(
    CommerceCustomer^ customer,
    List<Party^>^ parties
)
abstract AddParties :
        customer : CommerceCustomer *
        parties : List<Party> -> List<Party>
override AddParties :
        customer : CommerceCustomer *
        parties : List<Party> -> List<Party>

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList Party
The parties.

Return Value

Type: List Party
List of parties that were added along with any updated information.

Implements

ICustomerRepositoryAddParties(CommerceCustomer, ListParty)
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository.Create Method

EaStateCustomerRepositoryCreate Method
Creates the customer repository state of the engagement automation.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Create(
    CommerceCustomer customer
)
Public Overridable Sub Create (
    customer As CommerceCustomer
)
public:
virtual void Create(
    CommerceCustomer^ customer
)
abstract Create :
        customer : CommerceCustomer -> unit
override Create :
        customer : CommerceCustomer -> unit

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.

Implements

IEntityRepositoryTEntityCreate(TEntity)
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository.Delete Method

EaStateCustomerRepositoryDelete Method
Deletes a commerce customer.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Delete(
    CommerceCustomer commerceCustomer
)
Public Overridable Sub Delete (
    commerceCustomer As CommerceCustomer
)
public:
virtual void Delete(
    CommerceCustomer^ commerceCustomer
)
abstract Delete :
        commerceCustomer : CommerceCustomer -> unit
override Delete :
        commerceCustomer : CommerceCustomer -> unit

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The commerce customer.

Implements

IEntityRepositoryTEntityDelete(TEntity)
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository.Get Method

EaStateCustomerRepositoryGet Method
Gets the customer by name.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CommerceCustomer Get(
    string name
)
Public Overridable Function Get (
    name As String
) As CommerceCustomer
public:
virtual CommerceCustomer^ Get(
    String^ name
)
abstract Get :
        name : string -> CommerceCustomer
override Get :
        name : string -> CommerceCustomer

Parameters

name
Type: SystemString
The name of the customer.

Return Value

Type: CommerceCustomer
The customer that matches the given name.

Implements

ICustomerRepositoryGet(String)
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository.GetAll Method

EaStateCustomerRepositoryGetAll Method
Gets all customeers.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<CommerceCustomer> GetAll()
Public Overridable Function GetAll As IEnumerable(Of CommerceCustomer)
public:
virtual IEnumerable<CommerceCustomer^>^ GetAll()
abstract GetAll : unit -> IEnumerable<CommerceCustomer>
override GetAll : unit -> IEnumerable<CommerceCustomer>

Return Value

Type: IEnumerable CommerceCustomer
The collection of the customers.

Implements

ICustomerRepositoryGetAll
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository.GetParties Method

EaStateCustomerRepositoryGetParties Method
Gets the parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<Party> GetParties(
    CommerceCustomer customer
)
Public Overridable Function GetParties (
    customer As CommerceCustomer
) As List(Of Party)
public:
virtual List<Party^>^ GetParties(
    CommerceCustomer^ customer
)
abstract GetParties :
        customer : CommerceCustomer -> List<Party>
override GetParties :
        customer : CommerceCustomer -> List<Party>

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.

Return Value

Type: List Party
List of parties associated with the customer.

Implements

ICustomerRepositoryGetParties(CommerceCustomer)
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository.RemoveCustomerParties Method

EaStateCustomerRepositoryRemoveCustomerParties Method
Removes the customer parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveCustomerParties(
    CommerceCustomer customer,
    List<CustomerParty> customerParties
)
Public Overridable Sub RemoveCustomerParties (
    customer As CommerceCustomer,
    customerParties As List(Of CustomerParty)
)
public:
virtual void RemoveCustomerParties(
    CommerceCustomer^ customer,
    List<CustomerParty^>^ customerParties
)
abstract RemoveCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> unit
override RemoveCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> unit

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
customerParties
Type: System.Collections.GenericList CustomerParty
The customer parties.

Implements

ICustomerRepositoryRemoveCustomerParties(CommerceCustomer, ListCustomerParty)
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository.RemoveParties Method

EaStateCustomerRepositoryRemoveParties Method
Removes the parties. Any customer party referencing the party will also be removed.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveParties(
    CommerceCustomer customer,
    List<Party> parties
)
Public Overridable Sub RemoveParties (
    customer As CommerceCustomer,
    parties As List(Of Party)
)
public:
virtual void RemoveParties(
    CommerceCustomer^ customer,
    List<Party^>^ parties
)
abstract RemoveParties :
        customer : CommerceCustomer *
        parties : List<Party> -> unit
override RemoveParties :
        customer : CommerceCustomer *
        parties : List<Party> -> unit

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList Party
The parties.

Return Value

Type:
List of the removed customer parties.

Implements

ICustomerRepositoryRemoveParties(CommerceCustomer, ListParty)
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository.Search Method

EaStateCustomerRepositorySearch Method
Searches the specified search criteria.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<CommerceCustomer> Search(
    CustomerSearchCriteria searchCriteria
)
Public Overridable Function Search (
    searchCriteria As CustomerSearchCriteria
) As List(Of CommerceCustomer)
public:
virtual List<CommerceCustomer^>^ Search(
    CustomerSearchCriteria^ searchCriteria
)
abstract Search :
        searchCriteria : CustomerSearchCriteria -> List<CommerceCustomer>
override Search :
        searchCriteria : CustomerSearchCriteria -> List<CommerceCustomer>

Parameters

searchCriteria
Type: Sitecore.Commerce.Services.CustomersCustomerSearchCriteria
The search criteria.

Return Value

Type: List CommerceCustomer
A list of customers.

Implements

ICustomerRepositorySearch(CustomerSearchCriteria)
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository.Update Method

EaStateCustomerRepositoryUpdate Method
Updates a commerce customer.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Update(
    CommerceCustomer commerceCustomer
)
Public Overridable Sub Update (
    commerceCustomer As CommerceCustomer
)
public:
virtual void Update(
    CommerceCustomer^ commerceCustomer
)
abstract Update :
        commerceCustomer : CommerceCustomer -> unit
override Update :
        commerceCustomer : CommerceCustomer -> unit

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The commerce customer.

Implements

IEntityRepositoryTEntityUpdate(TEntity)
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository.UpdateCustomerParties Method

EaStateCustomerRepositoryUpdateCustomerParties Method
Updates the customer parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateCustomerParties(
    CommerceCustomer customer,
    List<CustomerParty> customerParties
)
Public Overridable Sub UpdateCustomerParties (
    customer As CommerceCustomer,
    customerParties As List(Of CustomerParty)
)
public:
virtual void UpdateCustomerParties(
    CommerceCustomer^ customer,
    List<CustomerParty^>^ customerParties
)
abstract UpdateCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> unit
override UpdateCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> unit

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
customerParties
Type: System.Collections.GenericList CustomerParty
The customer parties.

Implements

ICustomerRepositoryUpdateCustomerParties(CommerceCustomer, ListCustomerParty)
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


EaStateCustomerRepository.UpdateParties Method

EaStateCustomerRepositoryUpdateParties Method
Updates the parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateParties(
    CommerceCustomer customer,
    List<Party> parties
)
Public Overridable Sub UpdateParties (
    customer As CommerceCustomer,
    parties As List(Of Party)
)
public:
virtual void UpdateParties(
    CommerceCustomer^ customer,
    List<Party^>^ parties
)
abstract UpdateParties :
        customer : CommerceCustomer *
        parties : List<Party> -> unit
override UpdateParties :
        customer : CommerceCustomer *
        parties : List<Party> -> unit

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList Party
The parties.

Implements

ICustomerRepositoryUpdateParties(CommerceCustomer, ListParty)
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

EaStateCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


ICustomerRepository Interface

ICustomerRepository Interface
Represents the customer repository interface.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public interface ICustomerRepository : IEntityRepository<CommerceCustomer>
Public Interface ICustomerRepository
    Inherits IEntityRepository(Of CommerceCustomer)
public interface class ICustomerRepository : IEntityRepository<CommerceCustomer^>
type ICustomerRepository =
    interface
        interface IEntityRepository<CommerceCustomer>
    end

The ICustomerRepository type exposes the following members.

Methods
 | Name | Description
Public method | AddCustomerParties | Adds the customer parties.
Public method | AddParties | Adds the parties.
Public method | Create | Creates the specified entity. (Inherited from IEntityRepositoryTEntity.)
Public method | Delete | Deletes the specified entity. (Inherited from IEntityRepositoryTEntity.)
Public method | Get | Gets the commerce customer by name.
Public method | GetAll | Gets all commerce customers.
Public method | GetParties | Gets the parties.
Public method | RemoveCustomerParties | Removes the customer parties.
Public method | RemoveParties | Removes the parties. Any customer party referencing the party will also be removed.
Public method | Search | Searches the specified search criteria.
Public method | Update | Updates the specified entity. (Inherited from IEntityRepositoryTEntity.)
Public method | UpdateCustomerParties | Updates the customer parties.
Public method | UpdateParties | Updates the parties.
Top
See Also

Reference

Sitecore.Commerce.Data.Customers Namespace


ICustomerRepository Methods

ICustomerRepository Methods

The ICustomerRepository type exposes the following members.

Methods
 | Name | Description
Public method | AddCustomerParties | Adds the customer parties.
Public method | AddParties | Adds the parties.
Public method | Create | Creates the specified entity. (Inherited from IEntityRepositoryTEntity.)
Public method | Delete | Deletes the specified entity. (Inherited from IEntityRepositoryTEntity.)
Public method | Get | Gets the commerce customer by name.
Public method | GetAll | Gets all commerce customers.
Public method | GetParties | Gets the parties.
Public method | RemoveCustomerParties | Removes the customer parties.
Public method | RemoveParties | Removes the parties. Any customer party referencing the party will also be removed.
Public method | Search | Searches the specified search criteria.
Public method | Update | Updates the specified entity. (Inherited from IEntityRepositoryTEntity.)
Public method | UpdateCustomerParties | Updates the customer parties.
Public method | UpdateParties | Updates the parties.
Top
See Also

Reference

ICustomerRepository Interface
Sitecore.Commerce.Data.Customers Namespace


ICustomerRepository.AddCustomerParties Method

ICustomerRepositoryAddCustomerParties Method
Adds the customer parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
List<CustomerParty> AddCustomerParties(
    CommerceCustomer customer,
    List<CustomerParty> customerParties
)
Function AddCustomerParties (
    customer As CommerceCustomer,
    customerParties As List(Of CustomerParty)
) As List(Of CustomerParty)
List<CustomerParty^>^ AddCustomerParties(
    CommerceCustomer^ customer,
    List<CustomerParty^>^ customerParties
)
abstract AddCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> List<CustomerParty>

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
customerParties
Type: System.Collections.GenericList CustomerParty
The customer parties.

Return Value

Type: List CustomerParty
A list of the new customer parties that were added.
See Also

Reference

ICustomerRepository Interface
Sitecore.Commerce.Data.Customers Namespace


ICustomerRepository.AddParties Method

ICustomerRepositoryAddParties Method
Adds the parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
List<Party> AddParties(
    CommerceCustomer customer,
    List<Party> parties
)
Function AddParties (
    customer As CommerceCustomer,
    parties As List(Of Party)
) As List(Of Party)
List<Party^>^ AddParties(
    CommerceCustomer^ customer,
    List<Party^>^ parties
)
abstract AddParties :
        customer : CommerceCustomer *
        parties : List<Party> -> List<Party>

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList Party
The parties.

Return Value

Type: List Party
List of parties that were added along with any updated information.
See Also

Reference

ICustomerRepository Interface
Sitecore.Commerce.Data.Customers Namespace


ICustomerRepository.Get Method

ICustomerRepositoryGet Method
Gets the commerce customer by name.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
CommerceCustomer Get(
    string name
)
Function Get (
    name As String
) As CommerceCustomer
CommerceCustomer^ Get(
    String^ name
)
abstract Get :
        name : string -> CommerceCustomer

Parameters

name
Type: SystemString
The name.

Return Value

Type: CommerceCustomer
The customer that matches the given name.
See Also

Reference

ICustomerRepository Interface
Sitecore.Commerce.Data.Customers Namespace


ICustomerRepository.GetAll Method

ICustomerRepositoryGetAll Method
Gets all commerce customers.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
IEnumerable<CommerceCustomer> GetAll()
Function GetAll As IEnumerable(Of CommerceCustomer)
IEnumerable<CommerceCustomer^>^ GetAll()
abstract GetAll : unit -> IEnumerable<CommerceCustomer>

Return Value

Type: IEnumerable CommerceCustomer
The collection of the customers.
See Also

Reference

ICustomerRepository Interface
Sitecore.Commerce.Data.Customers Namespace


ICustomerRepository.GetParties Method

ICustomerRepositoryGetParties Method
Gets the parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
List<Party> GetParties(
    CommerceCustomer customer
)
Function GetParties (
    customer As CommerceCustomer
) As List(Of Party)
List<Party^>^ GetParties(
    CommerceCustomer^ customer
)
abstract GetParties :
        customer : CommerceCustomer -> List<Party>

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.

Return Value

Type: List Party
List of parties associated with the customer.
See Also

Reference

ICustomerRepository Interface
Sitecore.Commerce.Data.Customers Namespace


ICustomerRepository.RemoveCustomerParties Method

ICustomerRepositoryRemoveCustomerParties Method
Removes the customer parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
void RemoveCustomerParties(
    CommerceCustomer customer,
    List<CustomerParty> customerParties
)
Sub RemoveCustomerParties (
    customer As CommerceCustomer,
    customerParties As List(Of CustomerParty)
)
void RemoveCustomerParties(
    CommerceCustomer^ customer,
    List<CustomerParty^>^ customerParties
)
abstract RemoveCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> unit

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
customerParties
Type: System.Collections.GenericList CustomerParty
The customer parties.
See Also

Reference

ICustomerRepository Interface
Sitecore.Commerce.Data.Customers Namespace


ICustomerRepository.RemoveParties Method

ICustomerRepositoryRemoveParties Method
Removes the parties. Any customer party referencing the party will also be removed.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
void RemoveParties(
    CommerceCustomer customer,
    List<Party> parties
)
Sub RemoveParties (
    customer As CommerceCustomer,
    parties As List(Of Party)
)
void RemoveParties(
    CommerceCustomer^ customer,
    List<Party^>^ parties
)
abstract RemoveParties :
        customer : CommerceCustomer *
        parties : List<Party> -> unit

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList Party
The parties.
See Also

Reference

ICustomerRepository Interface
Sitecore.Commerce.Data.Customers Namespace


ICustomerRepository.Search Method

ICustomerRepositorySearch Method
Searches the specified search criteria.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
List<CommerceCustomer> Search(
    CustomerSearchCriteria searchCriteria
)
Function Search (
    searchCriteria As CustomerSearchCriteria
) As List(Of CommerceCustomer)
List<CommerceCustomer^>^ Search(
    CustomerSearchCriteria^ searchCriteria
)
abstract Search :
        searchCriteria : CustomerSearchCriteria -> List<CommerceCustomer>

Parameters

searchCriteria
Type: Sitecore.Commerce.Services.CustomersCustomerSearchCriteria
The search criteria.

Return Value

Type: List CommerceCustomer
A list of customers based on the given search criteria.
See Also

Reference

ICustomerRepository Interface
Sitecore.Commerce.Data.Customers Namespace


ICustomerRepository.UpdateCustomerParties Method

ICustomerRepositoryUpdateCustomerParties Method
Updates the customer parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
void UpdateCustomerParties(
    CommerceCustomer customer,
    List<CustomerParty> customerParties
)
Sub UpdateCustomerParties (
    customer As CommerceCustomer,
    customerParties As List(Of CustomerParty)
)
void UpdateCustomerParties(
    CommerceCustomer^ customer,
    List<CustomerParty^>^ customerParties
)
abstract UpdateCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> unit

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
customerParties
Type: System.Collections.GenericList CustomerParty
The customer parties.
See Also

Reference

ICustomerRepository Interface
Sitecore.Commerce.Data.Customers Namespace


ICustomerRepository.UpdateParties Method

ICustomerRepositoryUpdateParties Method
Updates the parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
void UpdateParties(
    CommerceCustomer customer,
    List<Party> parties
)
Sub UpdateParties (
    customer As CommerceCustomer,
    parties As List(Of Party)
)
void UpdateParties(
    CommerceCustomer^ customer,
    List<Party^>^ parties
)
abstract UpdateParties :
        customer : CommerceCustomer *
        parties : List<Party> -> unit

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList Party
The parties.
See Also

Reference

ICustomerRepository Interface
Sitecore.Commerce.Data.Customers Namespace


IUserRepository Interface

IUserRepository Interface
The user repository interface.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public interface IUserRepository
Public Interface IUserRepository
public interface class IUserRepository
type IUserRepository =  interface end

The IUserRepository type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates the specified entity.
Public method | Delete | Deletes the specified entity.
Public method | Get | Gets the specified name.
Public method | Search | Searches the specified search criteria.
Public method | Update | Updates the specified entity.
Public method | UpdatePassword | Searches the specified search criteria.
Top
See Also

Reference

Sitecore.Commerce.Data.Customers Namespace


IUserRepository Methods

IUserRepository Methods

The IUserRepository type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates the specified entity.
Public method | Delete | Deletes the specified entity.
Public method | Get | Gets the specified name.
Public method | Search | Searches the specified search criteria.
Public method | Update | Updates the specified entity.
Public method | UpdatePassword | Searches the specified search criteria.
Top
See Also

Reference

IUserRepository Interface
Sitecore.Commerce.Data.Customers Namespace


IUserRepository.Create Method

IUserRepositoryCreate Method
Creates the specified entity.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
void Create(
    CommerceUser entity,
    string password
)
Sub Create (
    entity As CommerceUser,
    password As String
)
void Create(
    CommerceUser^ entity,
    String^ password
)
abstract Create :
        entity : CommerceUser *
        password : string -> unit

Parameters

entity
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The entity.
password
Type: SystemString
The password.
See Also

Reference

IUserRepository Interface
Sitecore.Commerce.Data.Customers Namespace


IUserRepository.Delete Method

IUserRepositoryDelete Method
Deletes the specified entity.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
void Delete(
    CommerceUser entity
)
Sub Delete (
    entity As CommerceUser
)
void Delete(
    CommerceUser^ entity
)
abstract Delete :
        entity : CommerceUser -> unit

Parameters

entity
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The entity.
See Also

Reference

IUserRepository Interface
Sitecore.Commerce.Data.Customers Namespace


IUserRepository.Get Method

IUserRepositoryGet Method
Gets the specified name.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
CommerceUser Get(
    string name
)
Function Get (
    name As String
) As CommerceUser
CommerceUser^ Get(
    String^ name
)
abstract Get :
        name : string -> CommerceUser

Parameters

name
Type: SystemString
The name.

Return Value

Type: CommerceUser
The CommerceUser with the given name.
See Also

Reference

IUserRepository Interface
Sitecore.Commerce.Data.Customers Namespace


IUserRepository.Search Method

IUserRepositorySearch Method
Searches the specified search criteria.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
List<CommerceUser> Search(
    UserSearchCriteria searchCriteria
)
Function Search (
    searchCriteria As UserSearchCriteria
) As List(Of CommerceUser)
List<CommerceUser^>^ Search(
    UserSearchCriteria^ searchCriteria
)
abstract Search :
        searchCriteria : UserSearchCriteria -> List<CommerceUser>

Parameters

searchCriteria
Type: Sitecore.Commerce.Services.CustomersUserSearchCriteria
The search criteria.

Return Value

Type: List CommerceUser
A list of users based on the given search criteria.
See Also

Reference

IUserRepository Interface
Sitecore.Commerce.Data.Customers Namespace


IUserRepository.Update Method

IUserRepositoryUpdate Method
Updates the specified entity.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
void Update(
    CommerceUser entity
)
Sub Update (
    entity As CommerceUser
)
void Update(
    CommerceUser^ entity
)
abstract Update :
        entity : CommerceUser -> unit

Parameters

entity
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The entity.
See Also

Reference

IUserRepository Interface
Sitecore.Commerce.Data.Customers Namespace


IUserRepository.UpdatePassword Method

IUserRepositoryUpdatePassword Method
Searches the specified search criteria.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
bool UpdatePassword(
    string userName,
    string oldPassword,
    string newPassword
)
Function UpdatePassword (
    userName As String,
    oldPassword As String,
    newPassword As String
) As Boolean
bool UpdatePassword(
    String^ userName,
    String^ oldPassword,
    String^ newPassword
)
abstract UpdatePassword :
        userName : string *
        oldPassword : string *
        newPassword : string -> bool

Parameters

userName
Type: SystemString
The user name.
oldPassword
Type: SystemString
The user old password.
newPassword
Type: SystemString
The user new password.

Return Value

Type: Boolean
True if the user's password was successfully updated, false otherwise
See Also

Reference

IUserRepository Interface
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository Class

SitecoreMembershipCustomerRepository Class
Defines the SitecoreMembershipCustomerRepository class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.CustomersUserProfileRepository
Sitecore.Commerce.Data.CustomersSitecoreMembershipCustomerRepository

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SitecoreMembershipCustomerRepository : UserProfileRepository,
    ICustomerRepository, IEntityRepository<CommerceCustomer>
Public Class SitecoreMembershipCustomerRepository
    Inherits UserProfileRepository
    Implements ICustomerRepository, IEntityRepository(Of CommerceCustomer)
public ref class SitecoreMembershipCustomerRepository : public UserProfileRepository,
    ICustomerRepository, IEntityRepository<CommerceCustomer^>
type SitecoreMembershipCustomerRepository =
    class
        inherit UserProfileRepository
        interface ICustomerRepository
        interface IEntityRepository<CommerceCustomer>
    end

The SitecoreMembershipCustomerRepository type exposes the following members.

Constructors
 | Name | Description
Public method | SitecoreMembershipCustomerRepository | Initializes a new instance of the SitecoreMembershipCustomerRepository class.
Top
Methods
 | Name | Description
Public method | AddCustomerParties | Adds the customer parties.
Protected method | AddCustomerPartiesToExistingCustomer | Adds the customer parties to existing customer.
Public method | AddParties | Adds the parties.
Protected method | AddPartiesToExistingCustomer | Adds the parties to existing customer.
Public method | Create | Creates the specified customer.
Protected method | DecorateUser | Decorates the user.
Public method | Delete | Deletes the specified customer entity.
Protected method | DeserializeCustomer | Deserializes the user.
Protected method | DeserializeParties | Deserializes the parties.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the commerce customer by name.
Public method | GetAll | Gets all commerce customers.
Protected method | GetCustomerFullName | Gets the full name of the customer including the path.
Protected method | GetDomain | Gets the domain.
Protected method | GetExistingCustomer | Reads the existing user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParties | Gets the parties.
Protected method | GetPartiesFromExistingCustomer | Gets the parties from existing customer.
Protected method | GetRole | Gets the role. (Inherited from UserProfileRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveCustomerParties | Removes the customer parties.
Protected method | RemoveCustomerPartiesFromExistingCustomer | Removes the customer parties from existing customer.
Public method | RemoveParties | Removes the parties. Any customer party referencing the party will also be removed.
Protected method | RemovePartiesFromExistingCustomer | Removes the parties from existing customer.
Public method | Search | Searches the specified search criteria.
Protected method | SerializeCustomer | Serializes the user.
Protected method | SerializeParties | Serializes the parties.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the specified customer entity.
Public method | UpdateCustomerParties | Updates the customer parties.
Protected method | UpdateCustomerPartiesFromExistingCustomer | Updates the customer parties from existing customer.
Protected method | UpdateExistingUser | Updates the existing user.
Public method | UpdateParties | Updates the parties.
Top
Properties
 | Name | Description
Public property | DefaultDomain | Gets or sets the default domain.
Public property | DefaultRole | Gets or sets the default role.
Protected property | EntityFactory | Gets or sets the entity factory.
Public property | PartySerializationProperty | Gets or sets the party serialization property.
Public property | SerializationProperty | Gets or sets the serialization property.
Top
See Also

Reference

Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository Constructor

SitecoreMembershipCustomerRepository Constructor
Initializes a new instance of the SitecoreMembershipCustomerRepository class.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SitecoreMembershipCustomerRepository(
    IEntityFactory entityFactory,
    string customerSerializationProperty,
    string partySerializationProperty,
    string domain,
    string role
)
Public Sub New (
    entityFactory As IEntityFactory,
    customerSerializationProperty As String,
    partySerializationProperty As String,
    domain As String,
    role As String
)
public:
SitecoreMembershipCustomerRepository(
    IEntityFactory^ entityFactory,
    String^ customerSerializationProperty,
    String^ partySerializationProperty,
    String^ domain,
    String^ role
)
new :
        entityFactory : IEntityFactory *
        customerSerializationProperty : string *
        partySerializationProperty : string *
        domain : string *
        role : string -> SitecoreMembershipCustomerRepository

Parameters

entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
customerSerializationProperty
Type: SystemString
The serialization property.
partySerializationProperty
Type: SystemString
The party serialization property.
domain
Type: SystemString
The domain.
role
Type: SystemString
The role.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository Methods

SitecoreMembershipCustomerRepository Methods

The SitecoreMembershipCustomerRepository type exposes the following members.

Methods
 | Name | Description
Public method | AddCustomerParties | Adds the customer parties.
Protected method | AddCustomerPartiesToExistingCustomer | Adds the customer parties to existing customer.
Public method | AddParties | Adds the parties.
Protected method | AddPartiesToExistingCustomer | Adds the parties to existing customer.
Public method | Create | Creates the specified customer.
Protected method | DecorateUser | Decorates the user.
Public method | Delete | Deletes the specified customer entity.
Protected method | DeserializeCustomer | Deserializes the user.
Protected method | DeserializeParties | Deserializes the parties.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the commerce customer by name.
Public method | GetAll | Gets all commerce customers.
Protected method | GetCustomerFullName | Gets the full name of the customer including the path.
Protected method | GetDomain | Gets the domain.
Protected method | GetExistingCustomer | Reads the existing user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParties | Gets the parties.
Protected method | GetPartiesFromExistingCustomer | Gets the parties from existing customer.
Protected method | GetRole | Gets the role. (Inherited from UserProfileRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveCustomerParties | Removes the customer parties.
Protected method | RemoveCustomerPartiesFromExistingCustomer | Removes the customer parties from existing customer.
Public method | RemoveParties | Removes the parties. Any customer party referencing the party will also be removed.
Protected method | RemovePartiesFromExistingCustomer | Removes the parties from existing customer.
Public method | Search | Searches the specified search criteria.
Protected method | SerializeCustomer | Serializes the user.
Protected method | SerializeParties | Serializes the parties.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the specified customer entity.
Public method | UpdateCustomerParties | Updates the customer parties.
Protected method | UpdateCustomerPartiesFromExistingCustomer | Updates the customer parties from existing customer.
Protected method | UpdateExistingUser | Updates the existing user.
Public method | UpdateParties | Updates the parties.
Top
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.AddCustomerParties Method

SitecoreMembershipCustomerRepositoryAddCustomerParties Method
Adds the customer parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<CustomerParty> AddCustomerParties(
    CommerceCustomer customer,
    List<CustomerParty> customerParties
)
Public Overridable Function AddCustomerParties (
    customer As CommerceCustomer,
    customerParties As List(Of CustomerParty)
) As List(Of CustomerParty)
public:
virtual List<CustomerParty^>^ AddCustomerParties(
    CommerceCustomer^ customer,
    List<CustomerParty^>^ customerParties
)
abstract AddCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> List<CustomerParty>
override AddCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> List<CustomerParty>

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
customerParties
Type: System.Collections.GenericList CustomerParty
The customer parties.

Return Value

Type: List CustomerParty
A list of the new customer parties that were added.

Implements

ICustomerRepositoryAddCustomerParties(CommerceCustomer, ListCustomerParty)
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.AddCustomerPartiesToExistingCustomer Method

SitecoreMembershipCustomerRepositoryAddCustomerPartiesToExistingCustomer Method
Adds the customer parties to existing customer.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual List<CustomerParty> AddCustomerPartiesToExistingCustomer(
    User user,
    List<CustomerParty> customerParties
)
Protected Overridable Function AddCustomerPartiesToExistingCustomer (
    user As User,
    customerParties As List(Of CustomerParty)
) As List(Of CustomerParty)
protected:
virtual List<CustomerParty^>^ AddCustomerPartiesToExistingCustomer(
    User^ user,
    List<CustomerParty^>^ customerParties
)
abstract AddCustomerPartiesToExistingCustomer :
        user : User *
        customerParties : List<CustomerParty> -> List<CustomerParty>
override AddCustomerPartiesToExistingCustomer :
        user : User *
        customerParties : List<CustomerParty> -> List<CustomerParty>

Parameters

user
Type: User
The user.
customerParties
Type: System.Collections.GenericList CustomerParty
The customer parties.

Return Value

Type: List CustomerParty
List of newly added customer parties.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.AddParties Method

SitecoreMembershipCustomerRepositoryAddParties Method
Adds the parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<Party> AddParties(
    CommerceCustomer customer,
    List<Party> parties
)
Public Overridable Function AddParties (
    customer As CommerceCustomer,
    parties As List(Of Party)
) As List(Of Party)
public:
virtual List<Party^>^ AddParties(
    CommerceCustomer^ customer,
    List<Party^>^ parties
)
abstract AddParties :
        customer : CommerceCustomer *
        parties : List<Party> -> List<Party>
override AddParties :
        customer : CommerceCustomer *
        parties : List<Party> -> List<Party>

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList Party
The parties.

Return Value

Type: List Party
List of parties that were added along with any updated information.

Implements

ICustomerRepositoryAddParties(CommerceCustomer, ListParty)
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.AddPartiesToExistingCustomer Method

SitecoreMembershipCustomerRepositoryAddPartiesToExistingCustomer Method
Adds the parties to existing customer.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual List<Party> AddPartiesToExistingCustomer(
    User user,
    List<Party> parties
)
Protected Overridable Function AddPartiesToExistingCustomer (
    user As User,
    parties As List(Of Party)
) As List(Of Party)
protected:
virtual List<Party^>^ AddPartiesToExistingCustomer(
    User^ user,
    List<Party^>^ parties
)
abstract AddPartiesToExistingCustomer :
        user : User *
        parties : List<Party> -> List<Party>
override AddPartiesToExistingCustomer :
        user : User *
        parties : List<Party> -> List<Party>

Parameters

user
Type: User
The user.
parties
Type: System.Collections.GenericList Party
The parties.

Return Value

Type: List Party
A list of Party items that were added to the party list of the customer.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.Create Method

SitecoreMembershipCustomerRepositoryCreate Method
Creates the specified customer.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Create(
    CommerceCustomer entity
)
Public Overridable Sub Create (
    entity As CommerceCustomer
)
public:
virtual void Create(
    CommerceCustomer^ entity
)
abstract Create :
        entity : CommerceCustomer -> unit
override Create :
        entity : CommerceCustomer -> unit

Parameters

entity
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The entity.

Implements

IEntityRepositoryTEntityCreate(TEntity)
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.DecorateUser Method

SitecoreMembershipCustomerRepositoryDecorateUser Method
Decorates the user.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual User DecorateUser(
    User user
)
Protected Overridable Function DecorateUser (
    user As User
) As User
protected:
virtual User^ DecorateUser(
    User^ user
)
abstract DecorateUser :
        user : User -> User
override DecorateUser :
        user : User -> User

Parameters

user
Type: User
The user.

Return Value

Type: User
The decorated user.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.Delete Method

SitecoreMembershipCustomerRepositoryDelete Method
Deletes the specified customer entity.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Delete(
    CommerceCustomer entity
)
Public Overridable Sub Delete (
    entity As CommerceCustomer
)
public:
virtual void Delete(
    CommerceCustomer^ entity
)
abstract Delete :
        entity : CommerceCustomer -> unit
override Delete :
        entity : CommerceCustomer -> unit

Parameters

entity
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The entity.

Implements

IEntityRepositoryTEntityDelete(TEntity)
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.DeserializeCustomer Method

SitecoreMembershipCustomerRepositoryDeserializeCustomer Method
Deserializes the user.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual CommerceCustomer DeserializeCustomer(
    User user
)
Protected Overridable Function DeserializeCustomer (
    user As User
) As CommerceCustomer
protected:
virtual CommerceCustomer^ DeserializeCustomer(
    User^ user
)
abstract DeserializeCustomer :
        user : User -> CommerceCustomer
override DeserializeCustomer :
        user : User -> CommerceCustomer

Parameters

user
Type: User
The user.

Return Value

Type: CommerceCustomer
The commerce user.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.DeserializeParties Method

SitecoreMembershipCustomerRepositoryDeserializeParties Method
Deserializes the parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual List<Party> DeserializeParties(
    User user
)
Protected Overridable Function DeserializeParties (
    user As User
) As List(Of Party)
protected:
virtual List<Party^>^ DeserializeParties(
    User^ user
)
abstract DeserializeParties :
        user : User -> List<Party>
override DeserializeParties :
        user : User -> List<Party>

Parameters

user
Type: User
The user.

Return Value

Type: List Party
List of parties.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.Get Method

SitecoreMembershipCustomerRepositoryGet Method
Gets the commerce customer by name.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CommerceCustomer Get(
    string name
)
Public Overridable Function Get (
    name As String
) As CommerceCustomer
public:
virtual CommerceCustomer^ Get(
    String^ name
)
abstract Get :
        name : string -> CommerceCustomer
override Get :
        name : string -> CommerceCustomer

Parameters

name
Type: SystemString
The name.

Return Value

Type: CommerceCustomer
The customer that matches the given name.

Implements

ICustomerRepositoryGet(String)
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.GetAll Method

SitecoreMembershipCustomerRepositoryGetAll Method
Gets all commerce customers.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<CommerceCustomer> GetAll()
Public Overridable Function GetAll As IEnumerable(Of CommerceCustomer)
public:
virtual IEnumerable<CommerceCustomer^>^ GetAll()
abstract GetAll : unit -> IEnumerable<CommerceCustomer>
override GetAll : unit -> IEnumerable<CommerceCustomer>

Return Value

Type: IEnumerable CommerceCustomer
The collection of the customers.

Implements

ICustomerRepositoryGetAll
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.GetCustomerFullName Method

SitecoreMembershipCustomerRepositoryGetCustomerFullName Method
Gets the full name of the customer including the path.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual string GetCustomerFullName(
    string userName
)
Protected Overridable Function GetCustomerFullName (
    userName As String
) As String
protected:
virtual String^ GetCustomerFullName(
    String^ userName
)
abstract GetCustomerFullName :
        userName : string -> string
override GetCustomerFullName :
        userName : string -> string

Parameters

userName
Type: SystemString
Name of the user.

Return Value

Type: String

[Missing <returns> documentation for "M:Sitecore.Commerce.Data.Customers.SitecoreMembershipCustomerRepository.GetCustomerFullName(System.String)"]

See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.GetDomain Method

SitecoreMembershipCustomerRepositoryGetDomain Method
Gets the domain.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual string GetDomain()
Protected Overridable Function GetDomain As String
protected:
virtual String^ GetDomain()
abstract GetDomain : unit -> string
override GetDomain : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Sitecore.Commerce.Data.Customers.SitecoreMembershipCustomerRepository.GetDomain"]

See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.GetExistingCustomer Method

SitecoreMembershipCustomerRepositoryGetExistingCustomer Method
Reads the existing user.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual CommerceCustomer GetExistingCustomer(
    User user
)
Protected Overridable Function GetExistingCustomer (
    user As User
) As CommerceCustomer
protected:
virtual CommerceCustomer^ GetExistingCustomer(
    User^ user
)
abstract GetExistingCustomer :
        user : User -> CommerceCustomer
override GetExistingCustomer :
        user : User -> CommerceCustomer

Parameters

user
Type: User
The user.

Return Value

Type: CommerceCustomer
Corresponding commerce customer.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.GetParties Method

SitecoreMembershipCustomerRepositoryGetParties Method
Gets the parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<Party> GetParties(
    CommerceCustomer customer
)
Public Overridable Function GetParties (
    customer As CommerceCustomer
) As List(Of Party)
public:
virtual List<Party^>^ GetParties(
    CommerceCustomer^ customer
)
abstract GetParties :
        customer : CommerceCustomer -> List<Party>
override GetParties :
        customer : CommerceCustomer -> List<Party>

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.

Return Value

Type: List Party
List of parties associated with the customer.

Implements

ICustomerRepositoryGetParties(CommerceCustomer)
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.GetPartiesFromExistingCustomer Method

SitecoreMembershipCustomerRepositoryGetPartiesFromExistingCustomer Method
Gets the parties from existing customer.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual List<Party> GetPartiesFromExistingCustomer(
    User user
)
Protected Overridable Function GetPartiesFromExistingCustomer (
    user As User
) As List(Of Party)
protected:
virtual List<Party^>^ GetPartiesFromExistingCustomer(
    User^ user
)
abstract GetPartiesFromExistingCustomer :
        user : User -> List<Party>
override GetPartiesFromExistingCustomer :
        user : User -> List<Party>

Parameters

user
Type: User
The user.

Return Value

Type: List Party
The list of parties associated with the customer.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.RemoveCustomerParties Method

SitecoreMembershipCustomerRepositoryRemoveCustomerParties Method
Removes the customer parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveCustomerParties(
    CommerceCustomer customer,
    List<CustomerParty> customerParties
)
Public Overridable Sub RemoveCustomerParties (
    customer As CommerceCustomer,
    customerParties As List(Of CustomerParty)
)
public:
virtual void RemoveCustomerParties(
    CommerceCustomer^ customer,
    List<CustomerParty^>^ customerParties
)
abstract RemoveCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> unit
override RemoveCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> unit

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
customerParties
Type: System.Collections.GenericList CustomerParty
The customer parties.

Implements

ICustomerRepositoryRemoveCustomerParties(CommerceCustomer, ListCustomerParty)
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.RemoveCustomerPartiesFromExistingCustomer Method

SitecoreMembershipCustomerRepositoryRemoveCustomerPartiesFromExistingCustomer Method
Removes the customer parties from existing customer.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void RemoveCustomerPartiesFromExistingCustomer(
    User user,
    List<CustomerParty> customerParties
)
Protected Overridable Sub RemoveCustomerPartiesFromExistingCustomer (
    user As User,
    customerParties As List(Of CustomerParty)
)
protected:
virtual void RemoveCustomerPartiesFromExistingCustomer(
    User^ user,
    List<CustomerParty^>^ customerParties
)
abstract RemoveCustomerPartiesFromExistingCustomer :
        user : User *
        customerParties : List<CustomerParty> -> unit
override RemoveCustomerPartiesFromExistingCustomer :
        user : User *
        customerParties : List<CustomerParty> -> unit

Parameters

user
Type: User
The user.
customerParties
Type: System.Collections.GenericList CustomerParty
The customer parties.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.RemoveParties Method

SitecoreMembershipCustomerRepositoryRemoveParties Method
Removes the parties. Any customer party referencing the party will also be removed.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveParties(
    CommerceCustomer customer,
    List<Party> parties
)
Public Overridable Sub RemoveParties (
    customer As CommerceCustomer,
    parties As List(Of Party)
)
public:
virtual void RemoveParties(
    CommerceCustomer^ customer,
    List<Party^>^ parties
)
abstract RemoveParties :
        customer : CommerceCustomer *
        parties : List<Party> -> unit
override RemoveParties :
        customer : CommerceCustomer *
        parties : List<Party> -> unit

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList Party
The parties.

Implements

ICustomerRepositoryRemoveParties(CommerceCustomer, ListParty)
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.RemovePartiesFromExistingCustomer Method

SitecoreMembershipCustomerRepositoryRemovePartiesFromExistingCustomer Method
Removes the parties from existing customer.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void RemovePartiesFromExistingCustomer(
    User user,
    List<Party> partiesToRemove
)
Protected Overridable Sub RemovePartiesFromExistingCustomer (
    user As User,
    partiesToRemove As List(Of Party)
)
protected:
virtual void RemovePartiesFromExistingCustomer(
    User^ user,
    List<Party^>^ partiesToRemove
)
abstract RemovePartiesFromExistingCustomer :
        user : User *
        partiesToRemove : List<Party> -> unit
override RemovePartiesFromExistingCustomer :
        user : User *
        partiesToRemove : List<Party> -> unit

Parameters

user
Type: User
The user.
partiesToRemove
Type: System.Collections.GenericList Party
The parties.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.Search Method

SitecoreMembershipCustomerRepositorySearch Method
Searches the specified search criteria.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<CommerceCustomer> Search(
    CustomerSearchCriteria searchCriteria
)
Public Overridable Function Search (
    searchCriteria As CustomerSearchCriteria
) As List(Of CommerceCustomer)
public:
virtual List<CommerceCustomer^>^ Search(
    CustomerSearchCriteria^ searchCriteria
)
abstract Search :
        searchCriteria : CustomerSearchCriteria -> List<CommerceCustomer>
override Search :
        searchCriteria : CustomerSearchCriteria -> List<CommerceCustomer>

Parameters

searchCriteria
Type: Sitecore.Commerce.Services.CustomersCustomerSearchCriteria
The search criteria.

Return Value

Type: List CommerceCustomer
A list of customers.

Implements

ICustomerRepositorySearch(CustomerSearchCriteria)
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.SerializeCustomer Method

SitecoreMembershipCustomerRepositorySerializeCustomer Method
Serializes the user.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void SerializeCustomer(
    User user,
    CommerceCustomer commerceCustomer
)
Protected Overridable Sub SerializeCustomer (
    user As User,
    commerceCustomer As CommerceCustomer
)
protected:
virtual void SerializeCustomer(
    User^ user,
    CommerceCustomer^ commerceCustomer
)
abstract SerializeCustomer :
        user : User *
        commerceCustomer : CommerceCustomer -> unit
override SerializeCustomer :
        user : User *
        commerceCustomer : CommerceCustomer -> unit

Parameters

user
Type: User
The user.
commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The commerce user.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.SerializeParties Method

SitecoreMembershipCustomerRepositorySerializeParties Method
Serializes the parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void SerializeParties(
    User user,
    List<Party> parties
)
Protected Overridable Sub SerializeParties (
    user As User,
    parties As List(Of Party)
)
protected:
virtual void SerializeParties(
    User^ user,
    List<Party^>^ parties
)
abstract SerializeParties :
        user : User *
        parties : List<Party> -> unit
override SerializeParties :
        user : User *
        parties : List<Party> -> unit

Parameters

user
Type: User
The user.
parties
Type: System.Collections.GenericList Party
The parties.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.Update Method

SitecoreMembershipCustomerRepositoryUpdate Method
Updates the specified customer entity.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Update(
    CommerceCustomer entity
)
Public Overridable Sub Update (
    entity As CommerceCustomer
)
public:
virtual void Update(
    CommerceCustomer^ entity
)
abstract Update :
        entity : CommerceCustomer -> unit
override Update :
        entity : CommerceCustomer -> unit

Parameters

entity
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The entity.

Implements

IEntityRepositoryTEntityUpdate(TEntity)
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.UpdateCustomerParties Method

SitecoreMembershipCustomerRepositoryUpdateCustomerParties Method
Updates the customer parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateCustomerParties(
    CommerceCustomer customer,
    List<CustomerParty> customerParties
)
Public Overridable Sub UpdateCustomerParties (
    customer As CommerceCustomer,
    customerParties As List(Of CustomerParty)
)
public:
virtual void UpdateCustomerParties(
    CommerceCustomer^ customer,
    List<CustomerParty^>^ customerParties
)
abstract UpdateCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> unit
override UpdateCustomerParties :
        customer : CommerceCustomer *
        customerParties : List<CustomerParty> -> unit

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
customerParties
Type: System.Collections.GenericList CustomerParty
The customer parties.

Implements

ICustomerRepositoryUpdateCustomerParties(CommerceCustomer, ListCustomerParty)
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.UpdateCustomerPartiesFromExistingCustomer Method

SitecoreMembershipCustomerRepositoryUpdateCustomerPartiesFromExistingCustomer Method
Updates the customer parties from existing customer.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void UpdateCustomerPartiesFromExistingCustomer(
    User user,
    List<CustomerParty> customerParties
)
Protected Overridable Sub UpdateCustomerPartiesFromExistingCustomer (
    user As User,
    customerParties As List(Of CustomerParty)
)
protected:
virtual void UpdateCustomerPartiesFromExistingCustomer(
    User^ user,
    List<CustomerParty^>^ customerParties
)
abstract UpdateCustomerPartiesFromExistingCustomer :
        user : User *
        customerParties : List<CustomerParty> -> unit
override UpdateCustomerPartiesFromExistingCustomer :
        user : User *
        customerParties : List<CustomerParty> -> unit

Parameters

user
Type: User
The user.
customerParties
Type: System.Collections.GenericList CustomerParty
The customer parties.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.UpdateExistingUser Method

SitecoreMembershipCustomerRepositoryUpdateExistingUser Method
Updates the existing user.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void UpdateExistingUser(
    User user,
    CommerceCustomer commerceCustomer
)
Protected Overridable Sub UpdateExistingUser (
    user As User,
    commerceCustomer As CommerceCustomer
)
protected:
virtual void UpdateExistingUser(
    User^ user,
    CommerceCustomer^ commerceCustomer
)
abstract UpdateExistingUser :
        user : User *
        commerceCustomer : CommerceCustomer -> unit
override UpdateExistingUser :
        user : User *
        commerceCustomer : CommerceCustomer -> unit

Parameters

user
Type: User
The user.
commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The commerce customer.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.UpdateParties Method

SitecoreMembershipCustomerRepositoryUpdateParties Method
Updates the parties.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateParties(
    CommerceCustomer customer,
    List<Party> parties
)
Public Overridable Sub UpdateParties (
    customer As CommerceCustomer,
    parties As List(Of Party)
)
public:
virtual void UpdateParties(
    CommerceCustomer^ customer,
    List<Party^>^ parties
)
abstract UpdateParties :
        customer : CommerceCustomer *
        parties : List<Party> -> unit
override UpdateParties :
        customer : CommerceCustomer *
        parties : List<Party> -> unit

Parameters

customer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList Party
The parties.

Implements

ICustomerRepositoryUpdateParties(CommerceCustomer, ListParty)
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository Properties

SitecoreMembershipCustomerRepository Properties

The SitecoreMembershipCustomerRepository type exposes the following members.

Properties
 | Name | Description
Public property | DefaultDomain | Gets or sets the default domain.
Public property | DefaultRole | Gets or sets the default role.
Protected property | EntityFactory | Gets or sets the entity factory.
Public property | PartySerializationProperty | Gets or sets the party serialization property.
Public property | SerializationProperty | Gets or sets the serialization property.
Top
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.DefaultDomain Property

SitecoreMembershipCustomerRepositoryDefaultDomain Property
Gets or sets the default domain.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string DefaultDomain { get; protected set; }
Public Overridable Property DefaultDomain As String
    Get
    Protected Set
public:
virtual property String^ DefaultDomain {
    String^ get ();
    protected: void set (String^ value);
}
abstract DefaultDomain : string with get, set
override DefaultDomain : string with get, set

Property Value

Type: String
The default domain.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.DefaultRole Property

SitecoreMembershipCustomerRepositoryDefaultRole Property
Gets or sets the default role.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string DefaultRole { get; protected set; }
Public Overridable Property DefaultRole As String
    Get
    Protected Set
public:
virtual property String^ DefaultRole {
    String^ get ();
    protected: void set (String^ value);
}
abstract DefaultRole : string with get, set
override DefaultRole : string with get, set

Property Value

Type: String
The default role.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.EntityFactory Property

SitecoreMembershipCustomerRepositoryEntityFactory Property
Gets or sets the entity factory.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected IEntityFactory EntityFactory { get; set; }
Protected Property EntityFactory As IEntityFactory
    Get
    Set
protected:
property IEntityFactory^ EntityFactory {
    IEntityFactory^ get ();
    void set (IEntityFactory^ value);
}
member EntityFactory : IEntityFactory with get, set

Property Value

Type: IEntityFactory
The entity factory.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.PartySerializationProperty Property

SitecoreMembershipCustomerRepositoryPartySerializationProperty Property
Gets or sets the party serialization property.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string PartySerializationProperty { get; protected set; }
Public Overridable Property PartySerializationProperty As String
    Get
    Protected Set
public:
virtual property String^ PartySerializationProperty {
    String^ get ();
    protected: void set (String^ value);
}
abstract PartySerializationProperty : string with get, set
override PartySerializationProperty : string with get, set

Property Value

Type: String
The party serialization property.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreMembershipCustomerRepository.SerializationProperty Property

SitecoreMembershipCustomerRepositorySerializationProperty Property
Gets or sets the serialization property.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string SerializationProperty { get; protected set; }
Public Overridable Property SerializationProperty As String
    Get
    Protected Set
public:
virtual property String^ SerializationProperty {
    String^ get ();
    protected: void set (String^ value);
}
abstract SerializationProperty : string with get, set
override SerializationProperty : string with get, set

Property Value

Type: String
The serialization property.
See Also

Reference

SitecoreMembershipCustomerRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository Class

SitecoreUserRepository Class
The Sitecore user repository.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.CustomersUserProfileRepository
Sitecore.Commerce.Data.CustomersSitecoreUserRepository

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SitecoreUserRepository : UserProfileRepository,
    IUserRepository
Public Class SitecoreUserRepository
    Inherits UserProfileRepository
    Implements IUserRepository
public ref class SitecoreUserRepository : public UserProfileRepository,
    IUserRepository
type SitecoreUserRepository =
    class
        inherit UserProfileRepository
        interface IUserRepository
    end

The SitecoreUserRepository type exposes the following members.

Constructors
 | Name | Description
Public method | SitecoreUserRepository | Initializes a new instance of the SitecoreUserRepository class.
Top
Methods
 | Name | Description
Public method | Create | Creates the specified entity.
Protected method | DecorateUser | Decorates the user.
Public method | Delete | Deletes the specified entity.
Protected method | DeserializeUser | Deserializes the user.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the specified name.
Protected method | GetDomain | Gets the domain.
Protected method | GetExistingUser | Reads the existing user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRole | Gets the role. (Inherited from UserProfileRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUserFullName | Gets the full name of the customer including the path.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Search | Searches the specified search criteria.
Protected method | SerializeUser | Serializes the user.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the specified entity.
Protected method | UpdateExistingUser | Updates the existing user.
Public method | UpdatePassword | Searches the specified search criteria.
Top
Properties
 | Name | Description
Public property | DefaultDomain | Gets or sets the default domain.
Public property | DefaultRole | Gets or sets the default role.
Protected property | EntityFactory | Gets or sets the entity factory.
Public property | SerializationProperty | Gets or sets the serialization property.
Top
See Also

Reference

Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository Constructor

SitecoreUserRepository Constructor
Initializes a new instance of the SitecoreUserRepository class.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SitecoreUserRepository(
    IEntityFactory entityFactory,
    string serializationProperty,
    string domain,
    string role
)
Public Sub New (
    entityFactory As IEntityFactory,
    serializationProperty As String,
    domain As String,
    role As String
)
public:
SitecoreUserRepository(
    IEntityFactory^ entityFactory,
    String^ serializationProperty,
    String^ domain,
    String^ role
)
new :
        entityFactory : IEntityFactory *
        serializationProperty : string *
        domain : string *
        role : string -> SitecoreUserRepository

Parameters

entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
serializationProperty
Type: SystemString
The serialization property.
domain
Type: SystemString
The domain.
role
Type: SystemString
The role.
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository Methods

SitecoreUserRepository Methods

The SitecoreUserRepository type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates the specified entity.
Protected method | DecorateUser | Decorates the user.
Public method | Delete | Deletes the specified entity.
Protected method | DeserializeUser | Deserializes the user.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the specified name.
Protected method | GetDomain | Gets the domain.
Protected method | GetExistingUser | Reads the existing user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRole | Gets the role. (Inherited from UserProfileRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUserFullName | Gets the full name of the customer including the path.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Search | Searches the specified search criteria.
Protected method | SerializeUser | Serializes the user.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the specified entity.
Protected method | UpdateExistingUser | Updates the existing user.
Public method | UpdatePassword | Searches the specified search criteria.
Top
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.Create Method

SitecoreUserRepositoryCreate Method
Creates the specified entity.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Create(
    CommerceUser entity,
    string password
)
Public Overridable Sub Create (
    entity As CommerceUser,
    password As String
)
public:
virtual void Create(
    CommerceUser^ entity,
    String^ password
)
abstract Create :
        entity : CommerceUser *
        password : string -> unit
override Create :
        entity : CommerceUser *
        password : string -> unit

Parameters

entity
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The entity.
password
Type: SystemString
The password.

Implements

IUserRepositoryCreate(CommerceUser, String)
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.DecorateUser Method

SitecoreUserRepositoryDecorateUser Method
Decorates the user.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual User DecorateUser(
    User user
)
Protected Overridable Function DecorateUser (
    user As User
) As User
protected:
virtual User^ DecorateUser(
    User^ user
)
abstract DecorateUser :
        user : User -> User
override DecorateUser :
        user : User -> User

Parameters

user
Type: User
The user.

Return Value

Type: User
The decorated user.
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.Delete Method

SitecoreUserRepositoryDelete Method
Deletes the specified entity.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Delete(
    CommerceUser entity
)
Public Overridable Sub Delete (
    entity As CommerceUser
)
public:
virtual void Delete(
    CommerceUser^ entity
)
abstract Delete :
        entity : CommerceUser -> unit
override Delete :
        entity : CommerceUser -> unit

Parameters

entity
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The entity.

Implements

IUserRepositoryDelete(CommerceUser)
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.DeserializeUser Method

SitecoreUserRepositoryDeserializeUser Method
Deserializes the user.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual CommerceUser DeserializeUser(
    User user
)
Protected Overridable Function DeserializeUser (
    user As User
) As CommerceUser
protected:
virtual CommerceUser^ DeserializeUser(
    User^ user
)
abstract DeserializeUser :
        user : User -> CommerceUser
override DeserializeUser :
        user : User -> CommerceUser

Parameters

user
Type: User
The user.

Return Value

Type: CommerceUser
The commerce user.
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.Get Method

SitecoreUserRepositoryGet Method
Gets the specified name.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CommerceUser Get(
    string name
)
Public Overridable Function Get (
    name As String
) As CommerceUser
public:
virtual CommerceUser^ Get(
    String^ name
)
abstract Get :
        name : string -> CommerceUser
override Get :
        name : string -> CommerceUser

Parameters

name
Type: SystemString
The name.

Return Value

Type: CommerceUser
The CommerceUser with the given name.

Implements

IUserRepositoryGet(String)
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.GetDomain Method

SitecoreUserRepositoryGetDomain Method
Gets the domain.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual string GetDomain()
Protected Overridable Function GetDomain As String
protected:
virtual String^ GetDomain()
abstract GetDomain : unit -> string
override GetDomain : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Sitecore.Commerce.Data.Customers.SitecoreUserRepository.GetDomain"]

See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.GetExistingUser Method

SitecoreUserRepositoryGetExistingUser Method
Reads the existing user.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual CommerceUser GetExistingUser(
    User user
)
Protected Overridable Function GetExistingUser (
    user As User
) As CommerceUser
protected:
virtual CommerceUser^ GetExistingUser(
    User^ user
)
abstract GetExistingUser :
        user : User -> CommerceUser
override GetExistingUser :
        user : User -> CommerceUser

Parameters

user
Type: User
The user.

Return Value

Type: CommerceUser
Corresponding commerce user.
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.GetUserFullName Method

SitecoreUserRepositoryGetUserFullName Method
Gets the full name of the customer including the path.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual string GetUserFullName(
    string userName
)
Protected Overridable Function GetUserFullName (
    userName As String
) As String
protected:
virtual String^ GetUserFullName(
    String^ userName
)
abstract GetUserFullName :
        userName : string -> string
override GetUserFullName :
        userName : string -> string

Parameters

userName
Type: SystemString
Name of the user.

Return Value

Type: String

[Missing <returns> documentation for "M:Sitecore.Commerce.Data.Customers.SitecoreUserRepository.GetUserFullName(System.String)"]

See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.Search Method

SitecoreUserRepositorySearch Method
Searches the specified search criteria.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<CommerceUser> Search(
    UserSearchCriteria searchCriteria
)
Public Overridable Function Search (
    searchCriteria As UserSearchCriteria
) As List(Of CommerceUser)
public:
virtual List<CommerceUser^>^ Search(
    UserSearchCriteria^ searchCriteria
)
abstract Search :
        searchCriteria : UserSearchCriteria -> List<CommerceUser>
override Search :
        searchCriteria : UserSearchCriteria -> List<CommerceUser>

Parameters

searchCriteria
Type: Sitecore.Commerce.Services.CustomersUserSearchCriteria
The search criteria.

Return Value

Type: List CommerceUser

[Missing <returns> documentation for "M:Sitecore.Commerce.Data.Customers.SitecoreUserRepository.Search(Sitecore.Commerce.Services.Customers.UserSearchCriteria)"]

Implements

IUserRepositorySearch(UserSearchCriteria)
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.SerializeUser Method

SitecoreUserRepositorySerializeUser Method
Serializes the user.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void SerializeUser(
    User user,
    CommerceUser commerceUser
)
Protected Overridable Sub SerializeUser (
    user As User,
    commerceUser As CommerceUser
)
protected:
virtual void SerializeUser(
    User^ user,
    CommerceUser^ commerceUser
)
abstract SerializeUser :
        user : User *
        commerceUser : CommerceUser -> unit
override SerializeUser :
        user : User *
        commerceUser : CommerceUser -> unit

Parameters

user
Type: User
The user.
commerceUser
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The commerce user.
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.Update Method

SitecoreUserRepositoryUpdate Method
Updates the specified entity.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Update(
    CommerceUser entity
)
Public Overridable Sub Update (
    entity As CommerceUser
)
public:
virtual void Update(
    CommerceUser^ entity
)
abstract Update :
        entity : CommerceUser -> unit
override Update :
        entity : CommerceUser -> unit

Parameters

entity
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The entity.

Implements

IUserRepositoryUpdate(CommerceUser)
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.UpdateExistingUser Method

SitecoreUserRepositoryUpdateExistingUser Method
Updates the existing user.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void UpdateExistingUser(
    User user,
    CommerceUser commerceUser
)
Protected Overridable Sub UpdateExistingUser (
    user As User,
    commerceUser As CommerceUser
)
protected:
virtual void UpdateExistingUser(
    User^ user,
    CommerceUser^ commerceUser
)
abstract UpdateExistingUser :
        user : User *
        commerceUser : CommerceUser -> unit
override UpdateExistingUser :
        user : User *
        commerceUser : CommerceUser -> unit

Parameters

user
Type: User
The user.
commerceUser
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The commerce user.
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.UpdatePassword Method

SitecoreUserRepositoryUpdatePassword Method
Searches the specified search criteria.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual bool UpdatePassword(
    string userName,
    string oldPassword,
    string newPassword
)
Public Overridable Function UpdatePassword (
    userName As String,
    oldPassword As String,
    newPassword As String
) As Boolean
public:
virtual bool UpdatePassword(
    String^ userName,
    String^ oldPassword,
    String^ newPassword
)
abstract UpdatePassword :
        userName : string *
        oldPassword : string *
        newPassword : string -> bool
override UpdatePassword :
        userName : string *
        oldPassword : string *
        newPassword : string -> bool

Parameters

userName
Type: SystemString
The user name.
oldPassword
Type: SystemString
The user old password.
newPassword
Type: SystemString
The user new password.

Return Value

Type: Boolean
True if the user's password was successfully updated, false otherwise

Implements

IUserRepositoryUpdatePassword(String, String, String)
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository Properties

SitecoreUserRepository Properties

The SitecoreUserRepository type exposes the following members.

Properties
 | Name | Description
Public property | DefaultDomain | Gets or sets the default domain.
Public property | DefaultRole | Gets or sets the default role.
Protected property | EntityFactory | Gets or sets the entity factory.
Public property | SerializationProperty | Gets or sets the serialization property.
Top
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.DefaultDomain Property

SitecoreUserRepositoryDefaultDomain Property
Gets or sets the default domain.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string DefaultDomain { get; protected set; }
Public Overridable Property DefaultDomain As String
    Get
    Protected Set
public:
virtual property String^ DefaultDomain {
    String^ get ();
    protected: void set (String^ value);
}
abstract DefaultDomain : string with get, set
override DefaultDomain : string with get, set

Property Value

Type: String
The default domain.
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.DefaultRole Property

SitecoreUserRepositoryDefaultRole Property
Gets or sets the default role.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string DefaultRole { get; protected set; }
Public Overridable Property DefaultRole As String
    Get
    Protected Set
public:
virtual property String^ DefaultRole {
    String^ get ();
    protected: void set (String^ value);
}
abstract DefaultRole : string with get, set
override DefaultRole : string with get, set

Property Value

Type: String
The default role.
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.EntityFactory Property

SitecoreUserRepositoryEntityFactory Property
Gets or sets the entity factory.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected IEntityFactory EntityFactory { get; set; }
Protected Property EntityFactory As IEntityFactory
    Get
    Set
protected:
property IEntityFactory^ EntityFactory {
    IEntityFactory^ get ();
    void set (IEntityFactory^ value);
}
member EntityFactory : IEntityFactory with get, set

Property Value

Type: IEntityFactory
The entity factory.
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


SitecoreUserRepository.SerializationProperty Property

SitecoreUserRepositorySerializationProperty Property
Gets or sets the serialization property.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string SerializationProperty { get; protected set; }
Public Overridable Property SerializationProperty As String
    Get
    Protected Set
public:
virtual property String^ SerializationProperty {
    String^ get ();
    protected: void set (String^ value);
}
abstract SerializationProperty : string with get, set
override SerializationProperty : string with get, set

Property Value

Type: String
The serialization property.
See Also

Reference

SitecoreUserRepository Class
Sitecore.Commerce.Data.Customers Namespace


UserProfileRepository Class

UserProfileRepository Class
Defines the UserProfileRepository class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.CustomersUserProfileRepository
Sitecore.Commerce.Data.CustomersSitecoreMembershipCustomerRepository
Sitecore.Commerce.Data.CustomersSitecoreUserRepository

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UserProfileRepository
Public Class UserProfileRepository
public ref class UserProfileRepository
type UserProfileRepository =  class end

The UserProfileRepository type exposes the following members.

Constructors
 | Name | Description
Public method | UserProfileRepository | Initializes a new instance of the UserProfileRepository class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRole | Gets the role.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Data.Customers Namespace


UserProfileRepository Constructor

UserProfileRepository Constructor
Initializes a new instance of the UserProfileRepository class

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UserProfileRepository()
Public Sub New
public:
UserProfileRepository()
new : unit -> UserProfileRepository
See Also

Reference

UserProfileRepository Class
Sitecore.Commerce.Data.Customers Namespace


UserProfileRepository Methods

UserProfileRepository Methods

The UserProfileRepository type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRole | Gets the role.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UserProfileRepository Class
Sitecore.Commerce.Data.Customers Namespace


UserProfileRepository.GetRole Method

UserProfileRepositoryGetRole Method
Gets the role.

Namespace: Sitecore.Commerce.Data.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual Role GetRole(
    string roleName
)
Protected Overridable Function GetRole (
    roleName As String
) As Role
protected:
virtual Role^ GetRole(
    String^ roleName
)
abstract GetRole :
        roleName : string -> Role
override GetRole :
        roleName : string -> Role

Parameters

roleName
Type: SystemString

[Missing <param name="roleName"/> documentation for "M:Sitecore.Commerce.Data.Customers.UserProfileRepository.GetRole(System.String)"]

Return Value

Type: Role

[Missing <returns> documentation for "M:Sitecore.Commerce.Data.Customers.UserProfileRepository.GetRole(System.String)"]

See Also

Reference

UserProfileRepository Class
Sitecore.Commerce.Data.Customers Namespace


Sitecore.Commerce.Data.Products Namespace

Sitecore.Commerce.Data.Products Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Data.Products"]

Classes
Class Description
Public class ArtifactRepositoryTEntity
The base class for managing all the artifacts.
Public class DefaultValueRepository
Defines the repository which is able to save specification default values
Public class DefaultValuesRepository
Defines the repository to store the default values as items in the content tree. A default value is another type of global specification. The product items can be linked to specifications items. The items that represent default values are stored under the same repository path as for the global specification and based on the same template. For more information about the default values repository, see the Sitecore.Commerce.Products.config file.
Public class DelayedSyncProductRepository
The delayed sync product repository.
Public class DelayedSyncProductRepositoryHelper
The temp product repository helper.
Public class DivisionRepository
The division repository.
Public class EntityRepositoryTEntity
The default implementation of the base entity repository class.
Public class FieldNames
The field names.
Public class ManufacturerRepository
Defines default implementation of manufacturer factory repository. For more information about the manufacturer repository, see the Sitecore.Commerce.Products.config file.
Public class Md5IdGenerator
Defines the default implementation of ID generator. This class implements the IIdGenerator interface. This class is used in all synchronization classes to generate the ID for the Sitecore Item. It generates the ID on the ID in the external commerce system. It gets the Sitecore ID from the External ID quickly and without a mapping table.
Public class ParentBasedSpecificationRepository
Defines the repository that stores the global product specifications. This class implements the SpecificationRepository class.
Public class ProductClassificationGroupRepository
Defines default implementation of product classification group repository. For more information on the product repository, see the Sitecore.Commerce.Products.config file.
Public class ProductClassificationRepository
Defines default implementation of product classification repository. For more information about the product classification repository, see the Sitecore.Commerce.Products.config file.
Public class ProductClassificationsFieldRepository
Defines the repository that stores the product classifications as links from the product items to the product classification items. The link is stored as a field value in the product item.
Public class ProductFieldRepository
Defines the repository that stores the product artifacts as links from the product items to the artifact items. The link is stored in a field of the product item. You can store any type of product artifact as a field value in the product item.
Public class ProductFieldRepositoryBaseTEntity
Defines the base abstract class for all repositories that store the product artifacts as links from the product items to the artifact items. The link is stored as a field value in the product item. You can use the descendants of this class to save any type of product artifact that is stored as a field value in a product item.
Public class ProductItemRepositoryBaseTEntity
Defines the base abstract class for all repositories that store the product artifacts as sub-items of of the product item sub-folders. You can use the descendants of this class to store any type of product artifact that is stored as a sub-item.
Public class ProductRelationsRepository
Represents the repository that stores the product relations as sub-items of the Relations sub-folder of the product item.
Public class ProductRepository
Defines default implementation of product repository. For more information about the product repository, see the Sitecore.Commerce.Products.config file.
Public class ProductResourcesRepository
The product resource repository.
Public class ProductSpecificationsRepository
The product specifications repository.
Public class ResourceRepository
Represents the repository that saves resources as items in the Media Library. This class:
  • Receives the stream of bytes that define a resource. This stream contains the name and the MIME-type of a resource.
  • Generates different types of items according to the MIME-type of the resource.
Public class ResourceTypes
Presents the constant values of the different types of the product resources. These constant values can be:
  • Images in the Media Library. In this case, the constant value is Image.
  • Non-image items in the Media Library, such as .zip and .pdf files. In this case, the constant value is Download.
The links to the external resources are also defined as downloads.
Public class SpecificationOptionRepository
Defines the repository that is able to save global specification options.
Public class SpecificationRepository
Defines the repository that stores the global product specifications as items in the content tree.
Public class SpecificationsRepository
Defines the repository that stores global specifications as items in the content tree. The product items can then be linked to specifications items. For more information about the specifications repository, see the Sitecore.Commerce.Products.config file.
Public class TypeRepository
Defines the repository that you can use to save the types as the items in the content tree. The product items can then be linked to types items. The type can also have type specifications and type default values assigned to it. For more information about the type repository, see the Sitecore.Commerce.Products.config file.
Public class XmlUtility
Defines the utility that is created to parse the string that represents XML node, check whether the specified attribute exists and their value represents GUID and return this GUID value. The main purpose is to get ID of the media item from the "src" attribute of the value of the image field.
Interfaces
 | Interface | Description
Public interface | IIdGenerator | Defines interface for the ID generator. This interface is used in all synchronization classes to generate the ID for the Sitecore Item. It generates this ID based on the ID in the external commerce system. It gets the Sitecore ID from the External ID quickly and without a mapping table.
Public interface | IProductRelatedEntityRepositoryTEntity | Defines the interface that you can implement to save any type of artifact that is related to the current product.


ArtifactRepository(TEntity) Class

ArtifactRepositoryTEntity Class
The base class for managing all the artifacts.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository TEntity
Sitecore.Commerce.Data.ProductsArtifactRepositoryTEntity
More...

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class ArtifactRepository<TEntity> : EntityRepository<TEntity>
where TEntity : ProductEntity

Public MustInherit Class ArtifactRepository(Of TEntity As ProductEntity)
    Inherits EntityRepository(Of TEntity)
generic<typename TEntity>
where TEntity : ProductEntity
public ref class ArtifactRepository abstract : public EntityRepository<TEntity>
[<AbstractClassAttribute>]
type ArtifactRepository<'TEntity when 'TEntity : ProductEntity> =
    class
        inherit EntityRepository<'TEntity>
    end

Type Parameters

TEntity
The artifact entity type.

The ArtifactRepositoryTEntity type exposes the following members.

Constructors
 | Name | Description
Protected method | ArtifactRepositoryTEntity | Initializes a new instance of the ArtifactRepositoryTEntity class.
Top
Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item.
Public method | DeleteItem | Deletes the item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item.
Public method | Get(String) | Gets the specified entity identifier.
Public method | GetEntities | Gets the list of entities.
Public method | GetEntities(Item) | Gets the list of entities under the specified root.
Protected method | GetEntityItem | Gets the entity item.
Protected method | GetEntityItemId | Gets the entity item id.
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root.
Protected method | GetEntityItemName | Gets the item name of the entity.
Protected method | GetEntityItems | Gets entity items under the repository root.
Protected method | GetEntityItemTemplateId | Gets the entity item template id.
Protected method | GetEntityKey | Gets the entity key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity.
Protected method | IsValid | Determines whether the specified root is valid.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket.
Protected method | MoveToImmediateRoot | Moves to immediate root.
Protected method | PopulateEntity | Fills the entity.
Protected method | ProcessEntityItem | Processes the entity item.
Public method | Save(TEntity) | Saves the specified entity.
Public method | Save(Item, TEntity) | Saves the specified root.
Public method | Save(TEntity, Boolean) | Saves the specified entity.
Public method | Save(Item, TEntity, Boolean) | Saves the specified root.
Protected method | SetEntityItemStatistics | Sets the entity item statistics.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item.
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch.
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory.
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template.
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository TEntity
Sitecore.Commerce.Data.ProductsArtifactRepositoryTEntity
Sitecore.Commerce.Data.ProductsDefaultValueRepository
Sitecore.Commerce.Data.ProductsDefaultValuesRepository
Sitecore.Commerce.Data.ProductsDivisionRepository
Sitecore.Commerce.Data.ProductsManufacturerRepository
Sitecore.Commerce.Data.ProductsProductClassificationGroupRepository
Sitecore.Commerce.Data.ProductsProductClassificationRepository
Sitecore.Commerce.Data.ProductsProductRepository
Sitecore.Commerce.Data.ProductsResourceRepository
Sitecore.Commerce.Data.ProductsSpecificationOptionRepository
Sitecore.Commerce.Data.ProductsSpecificationRepository
Sitecore.Commerce.Data.ProductsSpecificationsRepository
Sitecore.Commerce.Data.ProductsTypeRepository


ArtifactRepository(TEntity) Constructor

ArtifactRepositoryTEntity Constructor
Initializes a new instance of the ArtifactRepositoryTEntity class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected ArtifactRepository()
Protected Sub New
protected:
ArtifactRepository()
new : unit -> ArtifactRepository
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity) Methods

ArtifactRepositoryTEntity Methods

The ArtifactRepositoryTEntity generic type exposes the following members.

Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item.
Public method | DeleteItem | Deletes the item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item.
Public method | Get(String) | Gets the specified entity identifier.
Public method | GetEntities | Gets the list of entities.
Public method | GetEntities(Item) | Gets the list of entities under the specified root.
Protected method | GetEntityItem | Gets the entity item.
Protected method | GetEntityItemId | Gets the entity item id.
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root.
Protected method | GetEntityItemName | Gets the item name of the entity.
Protected method | GetEntityItems | Gets entity items under the repository root.
Protected method | GetEntityItemTemplateId | Gets the entity item template id.
Protected method | GetEntityKey | Gets the entity key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity.
Protected method | IsValid | Determines whether the specified root is valid.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket.
Protected method | MoveToImmediateRoot | Moves to immediate root.
Protected method | PopulateEntity | Fills the entity.
Protected method | ProcessEntityItem | Processes the entity item.
Public method | Save(TEntity) | Saves the specified entity.
Public method | Save(Item, TEntity) | Saves the specified root.
Public method | Save(TEntity, Boolean) | Saves the specified entity.
Public method | Save(Item, TEntity, Boolean) | Saves the specified root.
Protected method | SetEntityItemStatistics | Sets the entity item statistics.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item.
Top
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).CreateEntityItem Method

ArtifactRepositoryTEntityCreateEntityItem Method
Creates the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual Item CreateEntityItem(
    Item root,
    Item entityItemImmediateRoot,
    TEntity entity,
    bool moveToBucket
)
Protected Overridable Function CreateEntityItem (
    root As Item,
    entityItemImmediateRoot As Item,
    entity As TEntity,
    moveToBucket As Boolean
) As Item
protected:
virtual Item^ CreateEntityItem(
    Item^ root,
    Item^ entityItemImmediateRoot,
    TEntity entity,
    bool moveToBucket
)
abstract CreateEntityItem :
        root : Item *
        entityItemImmediateRoot : Item *
        entity : 'TEntity *
        moveToBucket : bool -> Item
override CreateEntityItem :
        root : Item *
        entityItemImmediateRoot : Item *
        entity : 'TEntity *
        moveToBucket : bool -> Item

Parameters

root
Type: Item
The root.
entityItemImmediateRoot
Type: Item
The entity item immediate root.
entity
Type: TEntity
The entity.
moveToBucket
Type: SystemBoolean
if set to true [move to bucket].

Return Value

Type: Item
The item.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).DeleteItem Method

ArtifactRepositoryTEntityDeleteItem Method
Deletes the item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public bool DeleteItem(
    Item entityItem
)
Public Function DeleteItem (
    entityItem As Item
) As Boolean
public:
bool DeleteItem(
    Item^ entityItem
)
member DeleteItem :
        entityItem : Item -> bool

Parameters

entityItem
Type: Item
The entity item.

Return Value

Type: Boolean
true if the specified item was deleted; otherwise, false.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).Get Method

ArtifactRepositoryTEntityGet Method
Overload List
 | Name | Description
Protected method | Get(Item) | Gets entity from corresponding item.
Public method | Get(String) | Gets the specified entity identifier.
Top
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).Get Method (Item)

ArtifactRepositoryTEntityGet Method (Item)
Gets entity from corresponding item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual TEntity Get(
    Item entityItem
)
Protected Overridable Function Get (
    entityItem As Item
) As TEntity
protected:
virtual TEntity Get(
    Item^ entityItem
)
abstract Get :
        entityItem : Item -> 'TEntity
override Get :
        entityItem : Item -> 'TEntity

Parameters

entityItem
Type: Item
The entity item.

Return Value

Type: TEntity
The entity.
See Also

Reference

ArtifactRepositoryTEntity Class
Get Overload
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).Get Method (String)

ArtifactRepositoryTEntityGet Method (String)
Gets the specified entity identifier.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual TEntity Get(
    string entityKey
)
Public Overridable Function Get (
    entityKey As String
) As TEntity
public:
virtual TEntity Get(
    String^ entityKey
)
abstract Get :
        entityKey : string -> 'TEntity
override Get :
        entityKey : string -> 'TEntity

Parameters

entityKey
Type: SystemString
The entity key.

Return Value

Type: TEntity
The entity instance.
See Also

Reference

ArtifactRepositoryTEntity Class
Get Overload
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).GetEntities Method

ArtifactRepositoryTEntityGetEntities Method
Overload List
 | Name | Description
Public method | GetEntities | Gets the list of entities.
Public method | GetEntities(Item) | Gets the list of entities under the specified root.
Top
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).GetEntities Method

ArtifactRepositoryTEntityGetEntities Method
Gets the list of entities.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<TEntity> GetEntities()
Public Overridable Function GetEntities As IEnumerable(Of TEntity)
public:
virtual IEnumerable<TEntity>^ GetEntities()
abstract GetEntities : unit -> IEnumerable<'TEntity>
override GetEntities : unit -> IEnumerable<'TEntity>

Return Value

Type: IEnumerable TEntity
The list of entities.
See Also

Reference

ArtifactRepositoryTEntity Class
GetEntities Overload
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).GetEntities Method (Item)

ArtifactRepositoryTEntityGetEntities Method (Item)
Gets the list of entities under the specified root.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<TEntity> GetEntities(
    Item root
)
Public Overridable Function GetEntities (
    root As Item
) As IEnumerable(Of TEntity)
public:
virtual IEnumerable<TEntity>^ GetEntities(
    Item^ root
)
abstract GetEntities :
        root : Item -> IEnumerable<'TEntity>
override GetEntities :
        root : Item -> IEnumerable<'TEntity>

Parameters

root
Type: Item
The root.

Return Value

Type: IEnumerable TEntity
The list of entities.
See Also

Reference

ArtifactRepositoryTEntity Class
GetEntities Overload
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).GetEntityItem Method

ArtifactRepositoryTEntityGetEntityItem Method
Gets the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual Item GetEntityItem(
    Item root,
    string entityKey
)
Protected Overridable Function GetEntityItem (
    root As Item,
    entityKey As String
) As Item
protected:
virtual Item^ GetEntityItem(
    Item^ root,
    String^ entityKey
)
abstract GetEntityItem :
        root : Item *
        entityKey : string -> Item
override GetEntityItem :
        root : Item *
        entityKey : string -> Item

Parameters

root
Type: Item
The root.
entityKey
Type: SystemString
The entity key.

Return Value

Type: Item
The entity item or null if such item does not exist.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).GetEntityItemId Method

ArtifactRepositoryTEntityGetEntityItemId Method
Gets the entity item id.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual ID GetEntityItemId(
    Item root,
    string entityKey
)
Protected Overridable Function GetEntityItemId (
    root As Item,
    entityKey As String
) As ID
protected:
virtual ID^ GetEntityItemId(
    Item^ root,
    String^ entityKey
)
abstract GetEntityItemId :
        root : Item *
        entityKey : string -> ID
override GetEntityItemId :
        root : Item *
        entityKey : string -> ID

Parameters

root
Type: Item
The root.
entityKey
Type: SystemString
The entity key.

Return Value

Type: ID
ID of the entity item.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).GetEntityItemImmediateRoot Method

ArtifactRepositoryTEntityGetEntityItemImmediateRoot Method
Gets the entity item immediate root.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual Item GetEntityItemImmediateRoot(
    Item root,
    TEntity entity
)
Protected Overridable Function GetEntityItemImmediateRoot (
    root As Item,
    entity As TEntity
) As Item
protected:
virtual Item^ GetEntityItemImmediateRoot(
    Item^ root,
    TEntity entity
)
abstract GetEntityItemImmediateRoot :
        root : Item *
        entity : 'TEntity -> Item
override GetEntityItemImmediateRoot :
        root : Item *
        entity : 'TEntity -> Item

Parameters

root
Type: Item
The root.
entity
Type: TEntity
The entity.

Return Value

Type: Item
Item immediate root.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).GetEntityItemName Method

ArtifactRepositoryTEntityGetEntityItemName Method
Gets the item name of the entity.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract string GetEntityItemName(
    Item root,
    TEntity entity
)
Protected MustOverride Function GetEntityItemName (
    root As Item,
    entity As TEntity
) As String
protected:
virtual String^ GetEntityItemName(
    Item^ root,
    TEntity entity
) abstract
abstract GetEntityItemName :
        root : Item *
        entity : 'TEntity -> string

Parameters

root
Type: Item
The root.
entity
Type: TEntity
The entity.

Return Value

Type: String
Name of the entity item.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).GetEntityItems Method

ArtifactRepositoryTEntityGetEntityItems Method
Gets entity items under the repository root.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual IEnumerable<Item> GetEntityItems(
    Item root
)
Protected Overridable Function GetEntityItems (
    root As Item
) As IEnumerable(Of Item)
protected:
virtual IEnumerable<Item^>^ GetEntityItems(
    Item^ root
)
abstract GetEntityItems :
        root : Item -> IEnumerable<Item>
override GetEntityItems :
        root : Item -> IEnumerable<Item>

Parameters

root
Type: Item
The root.

Return Value

Type: IEnumerable Item
The entity items.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).GetEntityItemTemplateId Method

ArtifactRepositoryTEntityGetEntityItemTemplateId Method
Gets the entity item template id.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual ID GetEntityItemTemplateId(
    Item root,
    TEntity entity
)
Protected Overridable Function GetEntityItemTemplateId (
    root As Item,
    entity As TEntity
) As ID
protected:
virtual ID^ GetEntityItemTemplateId(
    Item^ root,
    TEntity entity
)
abstract GetEntityItemTemplateId :
        root : Item *
        entity : 'TEntity -> ID
override GetEntityItemTemplateId :
        root : Item *
        entity : 'TEntity -> ID

Parameters

root
Type: Item
The root.
entity
Type: TEntity
The entity.

Return Value

Type: ID
Entity item template id.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).GetEntityKey Method

ArtifactRepositoryTEntityGetEntityKey Method
Gets the entity key.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual string GetEntityKey(
    Item root,
    TEntity entity
)
Protected Overridable Function GetEntityKey (
    root As Item,
    entity As TEntity
) As String
protected:
virtual String^ GetEntityKey(
    Item^ root,
    TEntity entity
)
abstract GetEntityKey :
        root : Item *
        entity : 'TEntity -> string
override GetEntityKey :
        root : Item *
        entity : 'TEntity -> string

Parameters

root
Type: Item
The root.
entity
Type: TEntity
The entity.

Return Value

Type: String
The key of the entity.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).GetRepositoryRootItem Method

ArtifactRepositoryTEntityGetRepositoryRootItem Method
Gets the repository root item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual Item GetRepositoryRootItem()
Protected Overridable Function GetRepositoryRootItem As Item
protected:
virtual Item^ GetRepositoryRootItem()
abstract GetRepositoryRootItem : unit -> Item
override GetRepositoryRootItem : unit -> Item

Return Value

Type: Item
The repository root item.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).InstantiateEntity Method

ArtifactRepositoryTEntityInstantiateEntity Method
Instantiates the entity.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual TEntity InstantiateEntity()
Protected Overridable Function InstantiateEntity As TEntity
protected:
virtual TEntity InstantiateEntity()
abstract InstantiateEntity : unit -> 'TEntity
override InstantiateEntity : unit -> 'TEntity

Return Value

Type: TEntity
The entity.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).IsValid Method

ArtifactRepositoryTEntityIsValid Method
Determines whether the specified root is valid.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual bool IsValid(
    Item root,
    TEntity entity
)
Protected Overridable Function IsValid (
    root As Item,
    entity As TEntity
) As Boolean
protected:
virtual bool IsValid(
    Item^ root,
    TEntity entity
)
abstract IsValid :
        root : Item *
        entity : 'TEntity -> bool
override IsValid :
        root : Item *
        entity : 'TEntity -> bool

Parameters

root
Type: Item
The root.
entity
Type: TEntity
The entity.

Return Value

Type: Boolean
true if the specified root is valid; otherwise, false.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).MoveItemIntoBucket Method

ArtifactRepositoryTEntityMoveItemIntoBucket Method
Moves the item into bucket.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void MoveItemIntoBucket(
    Item root,
    Item entityItem,
    TEntity entity,
    bool moveToBucket
)
Protected Overridable Sub MoveItemIntoBucket (
    root As Item,
    entityItem As Item,
    entity As TEntity,
    moveToBucket As Boolean
)
protected:
virtual void MoveItemIntoBucket(
    Item^ root,
    Item^ entityItem,
    TEntity entity,
    bool moveToBucket
)
abstract MoveItemIntoBucket :
        root : Item *
        entityItem : Item *
        entity : 'TEntity *
        moveToBucket : bool -> unit
override MoveItemIntoBucket :
        root : Item *
        entityItem : Item *
        entity : 'TEntity *
        moveToBucket : bool -> unit

Parameters

root
Type: Item
The root.
entityItem
Type: Item
The entity item.
entity
Type: TEntity
The entity.
moveToBucket
Type: SystemBoolean
if set to true [move to bucket].
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).MoveToImmediateRoot Method

ArtifactRepositoryTEntityMoveToImmediateRoot Method
Moves to immediate root.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void MoveToImmediateRoot(
    Item root,
    Item entityItemImmediateRoot,
    Item entityItem
)
Protected Overridable Sub MoveToImmediateRoot (
    root As Item,
    entityItemImmediateRoot As Item,
    entityItem As Item
)
protected:
virtual void MoveToImmediateRoot(
    Item^ root,
    Item^ entityItemImmediateRoot,
    Item^ entityItem
)
abstract MoveToImmediateRoot :
        root : Item *
        entityItemImmediateRoot : Item *
        entityItem : Item -> unit
override MoveToImmediateRoot :
        root : Item *
        entityItemImmediateRoot : Item *
        entityItem : Item -> unit

Parameters

root
Type: Item
The root.
entityItemImmediateRoot
Type: Item
The entity item immediate root.
entityItem
Type: Item
The entity item.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).PopulateEntity Method

ArtifactRepositoryTEntityPopulateEntity Method
Fills the entity.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void PopulateEntity(
    Item entityItem,
    TEntity entity
)
Protected Overridable Sub PopulateEntity (
    entityItem As Item,
    entity As TEntity
)
protected:
virtual void PopulateEntity(
    Item^ entityItem,
    TEntity entity
)
abstract PopulateEntity :
        entityItem : Item *
        entity : 'TEntity -> unit
override PopulateEntity :
        entityItem : Item *
        entity : 'TEntity -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: TEntity
The entity.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).ProcessEntityItem Method

ArtifactRepositoryTEntityProcessEntityItem Method
Processes the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual Item ProcessEntityItem(
    Item entityItem,
    TEntity entity
)
Protected Overridable Function ProcessEntityItem (
    entityItem As Item,
    entity As TEntity
) As Item
protected:
virtual Item^ ProcessEntityItem(
    Item^ entityItem,
    TEntity entity
)
abstract ProcessEntityItem :
        entityItem : Item *
        entity : 'TEntity -> Item
override ProcessEntityItem :
        entityItem : Item *
        entity : 'TEntity -> Item

Parameters

entityItem
Type: Item
The entity item.
entity
Type: TEntity
The entity.

Return Value

Type: Item
The result of item processing.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).Save Method

ArtifactRepositoryTEntitySave Method
Overload List
 | Name | Description
Public method | Save(TEntity) | Saves the specified entity.
Public method | Save(Item, TEntity) | Saves the specified root.
Public method | Save(TEntity, Boolean) | Saves the specified entity.
Public method | Save(Item, TEntity, Boolean) | Saves the specified root.
Top
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).Save Method (TEntity)

ArtifactRepositoryTEntitySave Method (TEntity)
Saves the specified entity.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual TEntity Save(
    TEntity entity
)
Public Overridable Function Save (
    entity As TEntity
) As TEntity
public:
virtual TEntity Save(
    TEntity entity
)
abstract Save :
        entity : 'TEntity -> 'TEntity
override Save :
        entity : 'TEntity -> 'TEntity

Parameters

entity
Type: TEntity
The entity.

Return Value

Type: TEntity
The saved entity.
See Also

Reference

ArtifactRepositoryTEntity Class
Save Overload
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).Save Method (Item, TEntity)

ArtifactRepositoryTEntitySave Method (Item, TEntity)
Saves the specified root.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Save(
    Item root,
    TEntity entity
)
Public Overridable Sub Save (
    root As Item,
    entity As TEntity
)
public:
virtual void Save(
    Item^ root,
    TEntity entity
)
abstract Save :
        root : Item *
        entity : 'TEntity -> unit
override Save :
        root : Item *
        entity : 'TEntity -> unit

Parameters

root
Type: Item
The root.
entity
Type: TEntity
The entity.
See Also

Reference

ArtifactRepositoryTEntity Class
Save Overload
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).Save Method (TEntity, Boolean)

ArtifactRepositoryTEntitySave Method (TEntity, Boolean)
Saves the specified entity.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual TEntity Save(
    TEntity entity,
    bool moveToBucket
)
Public Overridable Function Save (
    entity As TEntity,
    moveToBucket As Boolean
) As TEntity
public:
virtual TEntity Save(
    TEntity entity,
    bool moveToBucket
)
abstract Save :
        entity : 'TEntity *
        moveToBucket : bool -> 'TEntity
override Save :
        entity : 'TEntity *
        moveToBucket : bool -> 'TEntity

Parameters

entity
Type: TEntity
The entity.
moveToBucket
Type: SystemBoolean
if set to true [move to bucket].

Return Value

Type: TEntity
The entity.
See Also

Reference

ArtifactRepositoryTEntity Class
Save Overload
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).Save Method (Item, TEntity, Boolean)

ArtifactRepositoryTEntitySave Method (Item, TEntity, Boolean)
Saves the specified root.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Save(
    Item root,
    TEntity entity,
    bool moveToBucket
)
Public Overridable Sub Save (
    root As Item,
    entity As TEntity,
    moveToBucket As Boolean
)
public:
virtual void Save(
    Item^ root,
    TEntity entity,
    bool moveToBucket
)
abstract Save :
        root : Item *
        entity : 'TEntity *
        moveToBucket : bool -> unit
override Save :
        root : Item *
        entity : 'TEntity *
        moveToBucket : bool -> unit

Parameters

root
Type: Item
The root.
entity
Type: TEntity
The entity.
moveToBucket
Type: SystemBoolean
if set to true [move to bucket].
See Also

Reference

ArtifactRepositoryTEntity Class
Save Overload
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).SetEntityItemStatistics Method

ArtifactRepositoryTEntitySetEntityItemStatistics Method
Sets the entity item statistics.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void SetEntityItemStatistics(
    Item entityItem,
    TEntity entity
)
Protected Overridable Sub SetEntityItemStatistics (
    entityItem As Item,
    entity As TEntity
)
protected:
virtual void SetEntityItemStatistics(
    Item^ entityItem,
    TEntity entity
)
abstract SetEntityItemStatistics :
        entityItem : Item *
        entity : 'TEntity -> unit
override SetEntityItemStatistics :
        entityItem : Item *
        entity : 'TEntity -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: TEntity
The entity.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).UpdateEntityItem Method

ArtifactRepositoryTEntityUpdateEntityItem Method
Updates the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract void UpdateEntityItem(
    Item entityItem,
    TEntity entity
)
Protected MustOverride Sub UpdateEntityItem (
    entityItem As Item,
    entity As TEntity
)
protected:
virtual void UpdateEntityItem(
    Item^ entityItem,
    TEntity entity
) abstract
abstract UpdateEntityItem :
        entityItem : Item *
        entity : 'TEntity -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: TEntity
The entity.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity) Properties

ArtifactRepositoryTEntity Properties

The ArtifactRepositoryTEntity generic type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch.
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory.
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template.
Top
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).Branch Property

ArtifactRepositoryTEntityBranch Property
Gets or sets the branch.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Branch { get; set; }
Public Property Branch As String
    Get
    Set
public:
property String^ Branch {
    String^ get ();
    void set (String^ value);
}
member Branch : string with get, set

Property Value

Type: String
The branch.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).EntityFactory Property

ArtifactRepositoryTEntityEntityFactory Property
Gets the entity factory.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected IEntityFactory EntityFactory { get; }
Protected ReadOnly Property EntityFactory As IEntityFactory
    Get
protected:
property IEntityFactory^ EntityFactory {
    IEntityFactory^ get ();
}
member EntityFactory : IEntityFactory with get

Property Value

Type: IEntityFactory
The entity factory.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


ArtifactRepository(TEntity).Template Property

ArtifactRepositoryTEntityTemplate Property
Gets or sets the template.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Template { get; set; }
Public Property Template As String
    Get
    Set
public:
property String^ Template {
    String^ get ();
    void set (String^ value);
}
member Template : string with get, set

Property Value

Type: String
The template.
See Also

Reference

ArtifactRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


DefaultValueRepository Class

DefaultValueRepository Class
Defines the repository which is able to save specification default values
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository Specification
Sitecore.Commerce.Data.ProductsArtifactRepository Specification
Sitecore.Commerce.Data.ProductsDefaultValueRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DefaultValueRepository : ArtifactRepository<Specification>
Public Class DefaultValueRepository
    Inherits ArtifactRepository(Of Specification)
public ref class DefaultValueRepository : public ArtifactRepository<Specification^>
type DefaultValueRepository =
    class
        inherit ArtifactRepository<Specification>
    end

The DefaultValueRepository type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultValueRepository | Initializes a new instance of the DefaultValueRepository class
Top
Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Overrides ArtifactRepositoryTEntityGetEntityItemId(Item, String).)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


DefaultValueRepository Constructor

DefaultValueRepository Constructor
Initializes a new instance of the DefaultValueRepository class

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DefaultValueRepository()
Public Sub New
public:
DefaultValueRepository()
new : unit -> DefaultValueRepository
See Also

Reference

DefaultValueRepository Class
Sitecore.Commerce.Data.Products Namespace


DefaultValueRepository Methods

DefaultValueRepository Methods

The DefaultValueRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Overrides ArtifactRepositoryTEntityGetEntityItemId(Item, String).)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
See Also

Reference

DefaultValueRepository Class
Sitecore.Commerce.Data.Products Namespace


DefaultValueRepository.GetEntityItemId Method

DefaultValueRepositoryGetEntityItemId Method
Gets the entity item id.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override ID GetEntityItemId(
    Item root,
    string entityKey
)
Protected Overrides Function GetEntityItemId (
    root As Item,
    entityKey As String
) As ID
protected:
virtual ID^ GetEntityItemId(
    Item^ root,
    String^ entityKey
) override
abstract GetEntityItemId :
        root : Item *
        entityKey : string -> ID
override GetEntityItemId :
        root : Item *
        entityKey : string -> ID

Parameters

root
Type: Item
The root.
entityKey
Type: SystemString
The entity key.

Return Value

Type: ID
Entity item name.
See Also

Reference

DefaultValueRepository Class
Sitecore.Commerce.Data.Products Namespace


DefaultValueRepository.GetEntityItemName Method

DefaultValueRepositoryGetEntityItemName Method
Gets the name of the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetEntityItemName(
    Item root,
    Specification entity
)
Protected Overrides Function GetEntityItemName (
    root As Item,
    entity As Specification
) As String
protected:
virtual String^ GetEntityItemName(
    Item^ root,
    Specification^ entity
) override
abstract GetEntityItemName :
        root : Item *
        entity : Specification -> string
override GetEntityItemName :
        root : Item *
        entity : Specification -> string

Parameters

root
Type: Item
The root.
entity
Type: Sitecore.Commerce.Entities.ProductsSpecification
The entity.

Return Value

Type: String
Entity item name.
See Also

Reference

DefaultValueRepository Class
Sitecore.Commerce.Data.Products Namespace


DefaultValueRepository.UpdateEntityItem Method

DefaultValueRepositoryUpdateEntityItem Method
Updates the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void UpdateEntityItem(
    Item entityItem,
    Specification entity
)
Protected Overrides Sub UpdateEntityItem (
    entityItem As Item,
    entity As Specification
)
protected:
virtual void UpdateEntityItem(
    Item^ entityItem,
    Specification^ entity
) override
abstract UpdateEntityItem :
        entityItem : Item *
        entity : Specification -> unit
override UpdateEntityItem :
        entityItem : Item *
        entity : Specification -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: Sitecore.Commerce.Entities.ProductsSpecification
The entity.
See Also

Reference

DefaultValueRepository Class
Sitecore.Commerce.Data.Products Namespace


DefaultValueRepository Properties

DefaultValueRepository Properties

The DefaultValueRepository type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

DefaultValueRepository Class
Sitecore.Commerce.Data.Products Namespace


DefaultValuesRepository Class

DefaultValuesRepository Class
Defines the repository to store the default values as items in the content tree. A default value is another type of global specification. The product items can be linked to specifications items. The items that represent default values are stored under the same repository path as for the global specification and based on the same template. For more information about the default values repository, see the Sitecore.Commerce.Products.config file.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository ProductSpecifications
Sitecore.Commerce.Data.ProductsArtifactRepository ProductSpecifications
Sitecore.Commerce.Data.ProductsDefaultValuesRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DefaultValuesRepository : ArtifactRepository<ProductSpecifications>
Public Class DefaultValuesRepository
    Inherits ArtifactRepository(Of ProductSpecifications)
public ref class DefaultValuesRepository : public ArtifactRepository<ProductSpecifications^>
type DefaultValuesRepository =
    class
        inherit ArtifactRepository<ProductSpecifications>
    end

The DefaultValuesRepository type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultValuesRepository | Initializes an instance of the SpecificationsRepository class.
Top
Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item ID. (Overrides ArtifactRepositoryTEntityGetEntityItemId(Item, String).)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


DefaultValuesRepository Constructor

DefaultValuesRepository Constructor
Initializes an instance of the SpecificationsRepository class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DefaultValuesRepository(
    string specificationLookupsFolderName,
    ArtifactRepository<Specification> globalSpecificationRepository
)
Public Sub New (
    specificationLookupsFolderName As String,
    globalSpecificationRepository As ArtifactRepository(Of Specification)
)
public:
DefaultValuesRepository(
    String^ specificationLookupsFolderName,
    ArtifactRepository<Specification^>^ globalSpecificationRepository
)
new :
        specificationLookupsFolderName : string *
        globalSpecificationRepository : ArtifactRepository<Specification> -> DefaultValuesRepository

Parameters

specificationLookupsFolderName
Type: SystemString
Name of the specification lookups folder
globalSpecificationRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository Specification
The global specification repository
See Also

Reference

DefaultValuesRepository Class
Sitecore.Commerce.Data.Products Namespace


DefaultValuesRepository Methods

DefaultValuesRepository Methods

The DefaultValuesRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item ID. (Overrides ArtifactRepositoryTEntityGetEntityItemId(Item, String).)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
See Also

Reference

DefaultValuesRepository Class
Sitecore.Commerce.Data.Products Namespace


DefaultValuesRepository.GetEntityItemId Method

DefaultValuesRepositoryGetEntityItemId Method
Gets the entity item ID.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override ID GetEntityItemId(
    Item root,
    string entityKey
)
Protected Overrides Function GetEntityItemId (
    root As Item,
    entityKey As String
) As ID
protected:
virtual ID^ GetEntityItemId(
    Item^ root,
    String^ entityKey
) override
abstract GetEntityItemId :
        root : Item *
        entityKey : string -> ID
override GetEntityItemId :
        root : Item *
        entityKey : string -> ID

Parameters

root
Type: Item
The root
entityKey
Type: SystemString
The entity key

Return Value

Type: ID
The ID of the entity
See Also

Reference

DefaultValuesRepository Class
Sitecore.Commerce.Data.Products Namespace


DefaultValuesRepository.GetEntityItemName Method

DefaultValuesRepositoryGetEntityItemName Method
Gets the name of the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetEntityItemName(
    Item root,
    ProductSpecifications entity
)
Protected Overrides Function GetEntityItemName (
    root As Item,
    entity As ProductSpecifications
) As String
protected:
virtual String^ GetEntityItemName(
    Item^ root,
    ProductSpecifications^ entity
) override
abstract GetEntityItemName :
        root : Item *
        entity : ProductSpecifications -> string
override GetEntityItemName :
        root : Item *
        entity : ProductSpecifications -> string

Parameters

root
Type: Item
The root
entity
Type: Sitecore.Commerce.Entities.ProductsProductSpecifications
The entity

Return Value

Type: String
Entity item name
See Also

Reference

DefaultValuesRepository Class
Sitecore.Commerce.Data.Products Namespace


DefaultValuesRepository.UpdateEntityItem Method

DefaultValuesRepositoryUpdateEntityItem Method
Updates the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void UpdateEntityItem(
    Item entityItem,
    ProductSpecifications entity
)
Protected Overrides Sub UpdateEntityItem (
    entityItem As Item,
    entity As ProductSpecifications
)
protected:
virtual void UpdateEntityItem(
    Item^ entityItem,
    ProductSpecifications^ entity
) override
abstract UpdateEntityItem :
        entityItem : Item *
        entity : ProductSpecifications -> unit
override UpdateEntityItem :
        entityItem : Item *
        entity : ProductSpecifications -> unit

Parameters

entityItem
Type: Item
The entity item
entity
Type: Sitecore.Commerce.Entities.ProductsProductSpecifications
The entity
See Also

Reference

DefaultValuesRepository Class
Sitecore.Commerce.Data.Products Namespace


DefaultValuesRepository Properties

DefaultValuesRepository Properties

The DefaultValuesRepository type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

DefaultValuesRepository Class
Sitecore.Commerce.Data.Products Namespace


DelayedSyncProductRepository Class

DelayedSyncProductRepository Class
The delayed sync product repository.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository Product
Sitecore.Commerce.Data.ProductsArtifactRepository Product
Sitecore.Commerce.Data.ProductsProductRepository
Sitecore.Commerce.Data.ProductsDelayedSyncProductRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DelayedSyncProductRepository : ProductRepository
Public Class DelayedSyncProductRepository
    Inherits ProductRepository
public ref class DelayedSyncProductRepository : public ProductRepository
type DelayedSyncProductRepository =
    class
        inherit ProductRepository
    end

The DelayedSyncProductRepository type exposes the following members.

Constructors
 | Name | Description
Public method | DelayedSyncProductRepository | Initializes a new instance of the DelayedSyncProductRepository class
Top
Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteProduct | Deletes the product. (Inherited from ProductRepository.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetDelayedRepositoryRootItem | Gets the delayed repository root item.
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Inherited from ProductRepository.)
Protected method | GetEntityItems | Gets the entity items. (Inherited from ProductRepository.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ProductRepository.)
Protected method | PopulateEntity | Assigns values for the entity's name, external ID, short description, full description, identification, manufacturers, product types, devisions, classification groups, resources, product specifications and relation types. (Inherited from ProductRepository.)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Product, Boolean) | Saves the specified entity. (Overrides ArtifactRepositoryTEntitySave(TEntity, Boolean).)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | SaveProductClassifications | Saves the product classifications. (Inherited from ProductRepository.)
Public method | SaveProductClassificationsSpecifications | Saves the product classifications specifications. (Inherited from ProductRepository.)
Public method | SaveProductDivisions | Saves the product divisions. (Inherited from ProductRepository.)
Public method | SaveProductGlobalSpecifications | Saves the product specifications. (Inherited from ProductRepository.)
Public method | SaveProductManufacturers | Saves the product manufacturers. (Inherited from ProductRepository.)
Public method | SaveProductRelations | Saves the product relations. (Inherited from ProductRepository.)
Public method | SaveProductResources | Saves the product resources. (Inherited from ProductRepository.)
Public method | SaveProductTypes | Saves the product types. (Inherited from ProductRepository.)
Public method | SaveProductTypeSpecifications | Saves the product type specifications. (Inherited from ProductRepository.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Inherited from ProductRepository.)
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Public property | ClassificationsRepository | Gets or sets the classifications repository. (Inherited from ProductRepository.)
Public property | ClassificationsSpecificationsRepository | Gets or sets the classifications specifications repository. (Inherited from ProductRepository.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | DivisionRepository | Gets or sets the division repository. (Inherited from ProductRepository.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | GlobalSpecificationsRepository | Gets or sets the specifications repository. (Inherited from ProductRepository.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | ManufacturerRepository | Gets or sets the manufacturer repository. (Inherited from ProductRepository.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | ProductsIndex | Gets or sets the index of the products. (Inherited from ProductRepository.)
Public property | RelationsRepository | Gets or sets the relations repository. (Inherited from ProductRepository.)
Public property | ResourcesRepository | Gets or sets the resources repository. (Inherited from ProductRepository.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Public property | TypeRepository | Gets or sets the type repository. (Inherited from ProductRepository.)
Public property | TypeSpecificationsRepository | Gets or sets the type specifications repository. (Inherited from ProductRepository.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


DelayedSyncProductRepository Constructor

DelayedSyncProductRepository Constructor
Initializes a new instance of the DelayedSyncProductRepository class

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DelayedSyncProductRepository()
Public Sub New
public:
DelayedSyncProductRepository()
new : unit -> DelayedSyncProductRepository
See Also

Reference

DelayedSyncProductRepository Class
Sitecore.Commerce.Data.Products Namespace


DelayedSyncProductRepository Methods

DelayedSyncProductRepository Methods

The DelayedSyncProductRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteProduct | Deletes the product. (Inherited from ProductRepository.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetDelayedRepositoryRootItem | Gets the delayed repository root item.
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Inherited from ProductRepository.)
Protected method | GetEntityItems | Gets the entity items. (Inherited from ProductRepository.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ProductRepository.)
Protected method | PopulateEntity | Assigns values for the entity's name, external ID, short description, full description, identification, manufacturers, product types, devisions, classification groups, resources, product specifications and relation types. (Inherited from ProductRepository.)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Product, Boolean) | Saves the specified entity. (Overrides ArtifactRepositoryTEntitySave(TEntity, Boolean).)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | SaveProductClassifications | Saves the product classifications. (Inherited from ProductRepository.)
Public method | SaveProductClassificationsSpecifications | Saves the product classifications specifications. (Inherited from ProductRepository.)
Public method | SaveProductDivisions | Saves the product divisions. (Inherited from ProductRepository.)
Public method | SaveProductGlobalSpecifications | Saves the product specifications. (Inherited from ProductRepository.)
Public method | SaveProductManufacturers | Saves the product manufacturers. (Inherited from ProductRepository.)
Public method | SaveProductRelations | Saves the product relations. (Inherited from ProductRepository.)
Public method | SaveProductResources | Saves the product resources. (Inherited from ProductRepository.)
Public method | SaveProductTypes | Saves the product types. (Inherited from ProductRepository.)
Public method | SaveProductTypeSpecifications | Saves the product type specifications. (Inherited from ProductRepository.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Inherited from ProductRepository.)
Top
See Also

Reference

DelayedSyncProductRepository Class
Sitecore.Commerce.Data.Products Namespace


DelayedSyncProductRepository.GetDelayedRepositoryRootItem Method

DelayedSyncProductRepositoryGetDelayedRepositoryRootItem Method
Gets the delayed repository root item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual Item GetDelayedRepositoryRootItem()
Protected Overridable Function GetDelayedRepositoryRootItem As Item
protected:
virtual Item^ GetDelayedRepositoryRootItem()
abstract GetDelayedRepositoryRootItem : unit -> Item
override GetDelayedRepositoryRootItem : unit -> Item

Return Value

Type: Item

[Missing <returns> documentation for "M:Sitecore.Commerce.Data.Products.DelayedSyncProductRepository.GetDelayedRepositoryRootItem"]

See Also

Reference

DelayedSyncProductRepository Class
Sitecore.Commerce.Data.Products Namespace


DelayedSyncProductRepository.Save Method

DelayedSyncProductRepositorySave Method
Overload List
 | Name | Description
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Product, Boolean) | Saves the specified entity. (Overrides ArtifactRepositoryTEntitySave(TEntity, Boolean).)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

DelayedSyncProductRepository Class
Sitecore.Commerce.Data.Products Namespace


DelayedSyncProductRepository.Save Method (Product, Boolean)

DelayedSyncProductRepositorySave Method (Product, Boolean)
Saves the specified entity.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override Product Save(
    Product entity,
    bool moveToBucket
)
Public Overrides Function Save (
    entity As Product,
    moveToBucket As Boolean
) As Product
public:
virtual Product^ Save(
    Product^ entity,
    bool moveToBucket
) override
abstract Save :
        entity : Product *
        moveToBucket : bool -> Product
override Save :
        entity : Product *
        moveToBucket : bool -> Product

Parameters

entity
Type: Sitecore.Commerce.Entities.ProductsProduct
The entity.
moveToBucket
Type: SystemBoolean
if set to true [move to bucket].

Return Value

Type: Product
The entity.
See Also

Reference

DelayedSyncProductRepository Class
Save Overload
Sitecore.Commerce.Data.Products Namespace


DelayedSyncProductRepository Properties

DelayedSyncProductRepository Properties

The DelayedSyncProductRepository type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Public property | ClassificationsRepository | Gets or sets the classifications repository. (Inherited from ProductRepository.)
Public property | ClassificationsSpecificationsRepository | Gets or sets the classifications specifications repository. (Inherited from ProductRepository.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | DivisionRepository | Gets or sets the division repository. (Inherited from ProductRepository.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | GlobalSpecificationsRepository | Gets or sets the specifications repository. (Inherited from ProductRepository.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | ManufacturerRepository | Gets or sets the manufacturer repository. (Inherited from ProductRepository.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | ProductsIndex | Gets or sets the index of the products. (Inherited from ProductRepository.)
Public property | RelationsRepository | Gets or sets the relations repository. (Inherited from ProductRepository.)
Public property | ResourcesRepository | Gets or sets the resources repository. (Inherited from ProductRepository.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Public property | TypeRepository | Gets or sets the type repository. (Inherited from ProductRepository.)
Public property | TypeSpecificationsRepository | Gets or sets the type specifications repository. (Inherited from ProductRepository.)
Top
See Also

Reference

DelayedSyncProductRepository Class
Sitecore.Commerce.Data.Products Namespace


DelayedSyncProductRepositoryHelper Class

DelayedSyncProductRepositoryHelper Class
The temp product repository helper.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsDelayedSyncProductRepositoryHelper

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class DelayedSyncProductRepositoryHelper
<ExtensionAttribute>
Public NotInheritable Class DelayedSyncProductRepositoryHelper
[ExtensionAttribute]
public ref class DelayedSyncProductRepositoryHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DelayedSyncProductRepositoryHelper =  class end

The DelayedSyncProductRepositoryHelper type exposes the following members.

Methods
Name | Description
GetDelayedSyncRepositoryItem | Gets the temporary repository item.
Top
Fields
Name | Description
DelayedSyncProductRepositoryName | The temporary product repository name.
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


DelayedSyncProductRepositoryHelper Fields

DelayedSyncProductRepositoryHelper Fields

The DelayedSyncProductRepositoryHelper type exposes the following members.

Fields
Name | Description
DelayedSyncProductRepositoryName | The temporary product repository name.
Top
See Also

Reference

DelayedSyncProductRepositoryHelper Class
Sitecore.Commerce.Data.Products Namespace


DelayedSyncProductRepositoryHelper.DelayedSyncProductRepositoryName Field

DelayedSyncProductRepositoryHelperDelayedSyncProductRepositoryName Field
The temporary product repository name.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string DelayedSyncProductRepositoryName
Public Const DelayedSyncProductRepositoryName As String
public:
literal String^ DelayedSyncProductRepositoryName
static val mutable DelayedSyncProductRepositoryName: string

Field Value

Type: String
See Also

Reference

DelayedSyncProductRepositoryHelper Class
Sitecore.Commerce.Data.Products Namespace


DelayedSyncProductRepositoryHelper Methods

DelayedSyncProductRepositoryHelper Methods

The DelayedSyncProductRepositoryHelper type exposes the following members.

Methods
Name | Description
GetDelayedSyncRepositoryItem | Gets the temporary repository item.
Top
See Also

Reference

DelayedSyncProductRepositoryHelper Class
Sitecore.Commerce.Data.Products Namespace


DelayedSyncProductRepositoryHelper.GetDelayedSyncRepositoryItem Method

DelayedSyncProductRepositoryHelperGetDelayedSyncRepositoryItem Method
Gets the temporary repository item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static Item GetDelayedSyncRepositoryItem(
    this Item rootRepositoryItem
)
<ExtensionAttribute>
Public Shared Function GetDelayedSyncRepositoryItem (
    rootRepositoryItem As Item
) As Item
public:
[ExtensionAttribute]
static Item^ GetDelayedSyncRepositoryItem(
    Item^ rootRepositoryItem
)
static member GetDelayedSyncRepositoryItem :
        rootRepositoryItem : Item -> Item

Parameters

rootRepositoryItem
Type: Item
The root repository item.

Return Value

Type: Item
The temporary repository item

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Item. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DelayedSyncProductRepositoryHelper Class
Sitecore.Commerce.Data.Products Namespace


DivisionRepository Class

DivisionRepository Class
The division repository.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository Division
Sitecore.Commerce.Data.ProductsArtifactRepository Division
Sitecore.Commerce.Data.ProductsDivisionRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DivisionRepository : ArtifactRepository<Division>
Public Class DivisionRepository
    Inherits ArtifactRepository(Of Division)
public ref class DivisionRepository : public ArtifactRepository<Division^>
type DivisionRepository =
    class
        inherit ArtifactRepository<Division>
    end

The DivisionRepository type exposes the following members.

Constructors
 | Name | Description
Public method | DivisionRepository | Initializes a new instance of the DivisionRepository class
Top
Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Overrides ArtifactRepositoryTEntityPopulateEntity(Item, TEntity).)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


DivisionRepository Constructor

DivisionRepository Constructor
Initializes a new instance of the DivisionRepository class

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DivisionRepository()
Public Sub New
public:
DivisionRepository()
new : unit -> DivisionRepository
See Also

Reference

DivisionRepository Class
Sitecore.Commerce.Data.Products Namespace


DivisionRepository Methods

DivisionRepository Methods

The DivisionRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Overrides ArtifactRepositoryTEntityPopulateEntity(Item, TEntity).)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
See Also

Reference

DivisionRepository Class
Sitecore.Commerce.Data.Products Namespace


DivisionRepository.GetEntityItemName Method

DivisionRepositoryGetEntityItemName Method
Gets the name of the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetEntityItemName(
    Item root,
    Division entity
)
Protected Overrides Function GetEntityItemName (
    root As Item,
    entity As Division
) As String
protected:
virtual String^ GetEntityItemName(
    Item^ root,
    Division^ entity
) override
abstract GetEntityItemName :
        root : Item *
        entity : Division -> string
override GetEntityItemName :
        root : Item *
        entity : Division -> string

Parameters

root
Type: Item
The root.
entity
Type: Sitecore.Commerce.Entities.ProductsDivision
The entity.

Return Value

Type: String
Entity item name.
See Also

Reference

DivisionRepository Class
Sitecore.Commerce.Data.Products Namespace


DivisionRepository.PopulateEntity Method

DivisionRepositoryPopulateEntity Method
Fills the entity.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void PopulateEntity(
    Item entityItem,
    Division entity
)
Protected Overrides Sub PopulateEntity (
    entityItem As Item,
    entity As Division
)
protected:
virtual void PopulateEntity(
    Item^ entityItem,
    Division^ entity
) override
abstract PopulateEntity :
        entityItem : Item *
        entity : Division -> unit
override PopulateEntity :
        entityItem : Item *
        entity : Division -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: Sitecore.Commerce.Entities.ProductsDivision
The entity.
See Also

Reference

DivisionRepository Class
Sitecore.Commerce.Data.Products Namespace


DivisionRepository.UpdateEntityItem Method

DivisionRepositoryUpdateEntityItem Method
Updates the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void UpdateEntityItem(
    Item entityItem,
    Division entity
)
Protected Overrides Sub UpdateEntityItem (
    entityItem As Item,
    entity As Division
)
protected:
virtual void UpdateEntityItem(
    Item^ entityItem,
    Division^ entity
) override
abstract UpdateEntityItem :
        entityItem : Item *
        entity : Division -> unit
override UpdateEntityItem :
        entityItem : Item *
        entity : Division -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: Sitecore.Commerce.Entities.ProductsDivision
The entity.
See Also

Reference

DivisionRepository Class
Sitecore.Commerce.Data.Products Namespace


DivisionRepository Properties

DivisionRepository Properties

The DivisionRepository type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

DivisionRepository Class
Sitecore.Commerce.Data.Products Namespace


EntityRepository(TEntity) Class

EntityRepositoryTEntity Class
The default implementation of the base entity repository class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepositoryTEntity
Sitecore.Commerce.Data.ProductsArtifactRepositoryTEntity
Sitecore.Commerce.Data.ProductsProductFieldRepositoryBaseTEntity
Sitecore.Commerce.Data.ProductsProductItemRepositoryBaseTEntity

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class EntityRepository<TEntity>

Public MustInherit Class EntityRepository(Of TEntity)
generic<typename TEntity>
public ref class EntityRepository abstract
[<AbstractClassAttribute>]
type EntityRepository<'TEntity> =  class end

Type Parameters

TEntity
The type of the entity.

The EntityRepositoryTEntity type exposes the following members.

Constructors
 | Name | Description
Protected method | EntityRepositoryTEntity | Initializes a new instance of the EntityRepositoryTEntity class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | Database | Gets the database.
Public property | IdGenerator | Gets or sets the unique identifier generator.
Public property | Path | Gets or sets the path.
Public property | Prefix | Gets or sets the prefix.
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


EntityRepository(TEntity) Constructor

EntityRepositoryTEntity Constructor
Initializes a new instance of the EntityRepositoryTEntity class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected EntityRepository()
Protected Sub New
protected:
EntityRepository()
new : unit -> EntityRepository
See Also

Reference

EntityRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


EntityRepository(TEntity) Methods

EntityRepositoryTEntity Methods

The EntityRepositoryTEntity generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EntityRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


EntityRepository(TEntity) Properties

EntityRepositoryTEntity Properties

The EntityRepositoryTEntity generic type exposes the following members.

Properties
 | Name | Description
Protected property | Database | Gets the database.
Public property | IdGenerator | Gets or sets the unique identifier generator.
Public property | Path | Gets or sets the path.
Public property | Prefix | Gets or sets the prefix.
Top
See Also

Reference

EntityRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


EntityRepository(TEntity).Database Property

EntityRepositoryTEntityDatabase Property
Gets the database.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual Database Database { get; }
Protected Overridable ReadOnly Property Database As Database
    Get
protected:
virtual property Database^ Database {
    Database^ get ();
}
abstract Database : Database with get
override Database : Database with get

Property Value

Type: Database
The database.
See Also

Reference

EntityRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


EntityRepository(TEntity).IdGenerator Property

EntityRepositoryTEntityIdGenerator Property
Gets or sets the unique identifier generator.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IIdGenerator IdGenerator { get; protected set; }
Public Overridable Property IdGenerator As IIdGenerator
    Get
    Protected Set
public:
virtual property IIdGenerator^ IdGenerator {
    IIdGenerator^ get ();
    protected: void set (IIdGenerator^ value);
}
abstract IdGenerator : IIdGenerator with get, set
override IdGenerator : IIdGenerator with get, set

Property Value

Type: IIdGenerator
The unique identifier generator.
See Also

Reference

EntityRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


EntityRepository(TEntity).Path Property

EntityRepositoryTEntityPath Property
Gets or sets the path.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Path { get; set; }
Public Overridable Property Path As String
    Get
    Set
public:
virtual property String^ Path {
    String^ get ();
    void set (String^ value);
}
abstract Path : string with get, set
override Path : string with get, set

Property Value

Type: String
The path.
See Also

Reference

EntityRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


EntityRepository(TEntity).Prefix Property

EntityRepositoryTEntityPrefix Property
Gets or sets the prefix.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Prefix { get; set; }
Public Overridable Property Prefix As String
    Get
    Set
public:
virtual property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
abstract Prefix : string with get, set
override Prefix : string with get, set

Property Value

Type: String
The prefix.
See Also

Reference

EntityRepositoryTEntity Class
Sitecore.Commerce.Data.Products Namespace


FieldNames Class

FieldNames Class
The field names.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsFieldNames

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class FieldNames
Public NotInheritable Class FieldNames
public ref class FieldNames abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FieldNames =  class end

The FieldNames type exposes the following members.

Fields
Name | Description
ExternalId | The external identifier field name.
FullDescription | The full description field name.
Identification | The identification field name.
Name | The name field name.
ShortDescription | The short description field name.
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


FieldNames Fields

FieldNames Fields

The FieldNames type exposes the following members.

Fields
Name | Description
ExternalId | The external identifier field name.
FullDescription | The full description field name.
Identification | The identification field name.
Name | The name field name.
ShortDescription | The short description field name.
Top
See Also

Reference

FieldNames Class
Sitecore.Commerce.Data.Products Namespace


FieldNames.ExternalId Field

FieldNamesExternalId Field
The external identifier field name.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ExternalId
Public Const ExternalId As String
public:
literal String^ ExternalId
static val mutable ExternalId: string

Field Value

Type: String
See Also

Reference

FieldNames Class
Sitecore.Commerce.Data.Products Namespace


FieldNames.FullDescription Field

FieldNamesFullDescription Field
The full description field name.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string FullDescription
Public Const FullDescription As String
public:
literal String^ FullDescription
static val mutable FullDescription: string

Field Value

Type: String
See Also

Reference

FieldNames Class
Sitecore.Commerce.Data.Products Namespace


FieldNames.Identification Field

FieldNamesIdentification Field
The identification field name.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string Identification
Public Const Identification As String
public:
literal String^ Identification
static val mutable Identification: string

Field Value

Type: String
See Also

Reference

FieldNames Class
Sitecore.Commerce.Data.Products Namespace


FieldNames.Name Field

FieldNamesName Field
The name field name.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string Name
Public Const Name As String
public:
literal String^ Name
static val mutable Name: string

Field Value

Type: String
See Also

Reference

FieldNames Class
Sitecore.Commerce.Data.Products Namespace


FieldNames.ShortDescription Field

FieldNamesShortDescription Field
The short description field name.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ShortDescription
Public Const ShortDescription As String
public:
literal String^ ShortDescription
static val mutable ShortDescription: string

Field Value

Type: String
See Also

Reference

FieldNames Class
Sitecore.Commerce.Data.Products Namespace


IIdGenerator Interface

IIdGenerator Interface
Defines interface for the ID generator. This interface is used in all synchronization classes to generate the ID for the Sitecore Item. It generates this ID based on the ID in the external commerce system. It gets the Sitecore ID from the External ID quickly and without a mapping table.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public interface IIdGenerator
Public Interface IIdGenerator
public interface class IIdGenerator
type IIdGenerator =  interface end

The IIdGenerator type exposes the following members.

Methods
 | Name | Description
Public method | StringToID | String to Sitecore ID.
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


IIdGenerator Methods

IIdGenerator Methods

The IIdGenerator type exposes the following members.

Methods
 | Name | Description
Public method | StringToID | String to Sitecore ID.
Top
See Also

Reference

IIdGenerator Interface
Sitecore.Commerce.Data.Products Namespace


IIdGenerator.StringToID Method

IIdGeneratorStringToID Method
String to Sitecore ID.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
ID StringToID(
    string value,
    string prefix
)
Function StringToID (
    value As String,
    prefix As String
) As ID
ID^ StringToID(
    String^ value,
    String^ prefix
)
abstract StringToID :
        value : string *
        prefix : string -> ID

Parameters

value
Type: SystemString
The value.
prefix
Type: SystemString
The prefix.

Return Value

Type: ID
The generated ID
See Also

Reference

IIdGenerator Interface
Sitecore.Commerce.Data.Products Namespace


IProductRelatedEntityRepository(TEntity) Interface

IProductRelatedEntityRepositoryTEntity Interface
Defines the interface that you can implement to save any type of artifact that is related to the current product.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public interface IProductRelatedEntityRepository<in TEntity>

Public Interface IProductRelatedEntityRepository(Of In TEntity)
generic<typename TEntity>
public interface class IProductRelatedEntityRepository
type IProductRelatedEntityRepository<'TEntity> =  interface end

Type Parameters

TEntity
The type of the entity

The IProductRelatedEntityRepositoryTEntity type exposes the following members.

Methods
 | Name | Description
Public method | SaveProductEntities | Saves the entities that are related to the current product. For example, these entities can be manufacturers or specifications.
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


IProductRelatedEntityRepository(TEntity) Methods

IProductRelatedEntityRepositoryTEntity Methods

The IProductRelatedEntityRepositoryTEntity generic type exposes the following members.

Methods
 | Name | Description
Public method | SaveProductEntities | Saves the entities that are related to the current product. For example, these entities can be manufacturers or specifications.
Top
See Also

Reference

IProductRelatedEntityRepositoryTEntity Interface
Sitecore.Commerce.Data.Products Namespace


IProductRelatedEntityRepository(TEntity).SaveProductEntities Method

IProductRelatedEntityRepositoryTEntitySaveProductEntities Method
Saves the entities that are related to the current product. For example, these entities can be manufacturers or specifications.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
void SaveProductEntities(
    string externalProductId,
    IEnumerable<TEntity> entities
)
Sub SaveProductEntities (
    externalProductId As String,
    entities As IEnumerable(Of TEntity)
)
void SaveProductEntities(
    String^ externalProductId,
    IEnumerable<TEntity>^ entities
)
abstract SaveProductEntities :
        externalProductId : string *
        entities : IEnumerable<'TEntity> -> unit

Parameters

externalProductId
Type: SystemString
The external product ID
entities
Type: System.Collections.GenericIEnumerable TEntity
A list of the entities
See Also

Reference

IProductRelatedEntityRepositoryTEntity Interface
Sitecore.Commerce.Data.Products Namespace


ManufacturerRepository Class

ManufacturerRepository Class
Defines default implementation of manufacturer factory repository. For more information about the manufacturer repository, see the Sitecore.Commerce.Products.config file.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository Manufacturer
Sitecore.Commerce.Data.ProductsArtifactRepository Manufacturer
Sitecore.Commerce.Data.ProductsManufacturerRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ManufacturerRepository : ArtifactRepository<Manufacturer>
Public Class ManufacturerRepository
    Inherits ArtifactRepository(Of Manufacturer)
public ref class ManufacturerRepository : public ArtifactRepository<Manufacturer^>
type ManufacturerRepository =
    class
        inherit ArtifactRepository<Manufacturer>
    end

The ManufacturerRepository type exposes the following members.

Constructors
 | Name | Description
Public method | ManufacturerRepository | Initializes a new instance of the ManufacturerRepository class
Top
Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Assigns values to the entity's name, external ID, description, and website URL. (Overrides ArtifactRepositoryTEntityPopulateEntity(Item, TEntity).)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


ManufacturerRepository Constructor

ManufacturerRepository Constructor
Initializes a new instance of the ManufacturerRepository class

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ManufacturerRepository()
Public Sub New
public:
ManufacturerRepository()
new : unit -> ManufacturerRepository
See Also

Reference

ManufacturerRepository Class
Sitecore.Commerce.Data.Products Namespace


ManufacturerRepository Methods

ManufacturerRepository Methods

The ManufacturerRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Assigns values to the entity's name, external ID, description, and website URL. (Overrides ArtifactRepositoryTEntityPopulateEntity(Item, TEntity).)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
See Also

Reference

ManufacturerRepository Class
Sitecore.Commerce.Data.Products Namespace


ManufacturerRepository.GetEntityItemName Method

ManufacturerRepositoryGetEntityItemName Method
Gets the name of the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetEntityItemName(
    Item root,
    Manufacturer entity
)
Protected Overrides Function GetEntityItemName (
    root As Item,
    entity As Manufacturer
) As String
protected:
virtual String^ GetEntityItemName(
    Item^ root,
    Manufacturer^ entity
) override
abstract GetEntityItemName :
        root : Item *
        entity : Manufacturer -> string
override GetEntityItemName :
        root : Item *
        entity : Manufacturer -> string

Parameters

root
Type: Item
The root.
entity
Type: Sitecore.Commerce.Entities.ProductsManufacturer
The entity.

Return Value

Type: String
Entity item name.
See Also

Reference

ManufacturerRepository Class
Sitecore.Commerce.Data.Products Namespace


ManufacturerRepository.PopulateEntity Method

ManufacturerRepositoryPopulateEntity Method
Assigns values to the entity's name, external ID, description, and website URL.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void PopulateEntity(
    Item entityItem,
    Manufacturer entity
)
Protected Overrides Sub PopulateEntity (
    entityItem As Item,
    entity As Manufacturer
)
protected:
virtual void PopulateEntity(
    Item^ entityItem,
    Manufacturer^ entity
) override
abstract PopulateEntity :
        entityItem : Item *
        entity : Manufacturer -> unit
override PopulateEntity :
        entityItem : Item *
        entity : Manufacturer -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: Sitecore.Commerce.Entities.ProductsManufacturer
The entity.
See Also

Reference

ManufacturerRepository Class
Sitecore.Commerce.Data.Products Namespace


ManufacturerRepository.UpdateEntityItem Method

ManufacturerRepositoryUpdateEntityItem Method
Updates the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void UpdateEntityItem(
    Item entityItem,
    Manufacturer entity
)
Protected Overrides Sub UpdateEntityItem (
    entityItem As Item,
    entity As Manufacturer
)
protected:
virtual void UpdateEntityItem(
    Item^ entityItem,
    Manufacturer^ entity
) override
abstract UpdateEntityItem :
        entityItem : Item *
        entity : Manufacturer -> unit
override UpdateEntityItem :
        entityItem : Item *
        entity : Manufacturer -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: Sitecore.Commerce.Entities.ProductsManufacturer
The entity.
See Also

Reference

ManufacturerRepository Class
Sitecore.Commerce.Data.Products Namespace


ManufacturerRepository Properties

ManufacturerRepository Properties

The ManufacturerRepository type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

ManufacturerRepository Class
Sitecore.Commerce.Data.Products Namespace


Md5IdGenerator Class

Md5IdGenerator Class
Defines the default implementation of ID generator. This class implements the IIdGenerator interface. This class is used in all synchronization classes to generate the ID for the Sitecore Item. It generates the ID on the ID in the external commerce system. It gets the Sitecore ID from the External ID quickly and without a mapping table.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsMd5IdGenerator

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class Md5IdGenerator : IIdGenerator
Public Class Md5IdGenerator
    Implements IIdGenerator
public ref class Md5IdGenerator : IIdGenerator
type Md5IdGenerator =
    class
        interface IIdGenerator
    end

The Md5IdGenerator type exposes the following members.

Constructors
 | Name | Description
Public method | Md5IdGenerator | Initializes a new instance of the Md5IdGenerator class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StringToID | String to Sitecore ID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


Md5IdGenerator Constructor

Md5IdGenerator Constructor
Initializes a new instance of the Md5IdGenerator class

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Md5IdGenerator()
Public Sub New
public:
Md5IdGenerator()
new : unit -> Md5IdGenerator
See Also

Reference

Md5IdGenerator Class
Sitecore.Commerce.Data.Products Namespace


Md5IdGenerator Methods

Md5IdGenerator Methods

The Md5IdGenerator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StringToID | String to Sitecore ID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Md5IdGenerator Class
Sitecore.Commerce.Data.Products Namespace


Md5IdGenerator.StringToID Method

Md5IdGeneratorStringToID Method
String to Sitecore ID.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ID StringToID(
    string value,
    string prefix
)
Public Function StringToID (
    value As String,
    prefix As String
) As ID
public:
virtual ID^ StringToID(
    String^ value,
    String^ prefix
) sealed
abstract StringToID :
        value : string *
        prefix : string -> ID
override StringToID :
        value : string *
        prefix : string -> ID

Parameters

value
Type: SystemString
The value.
prefix
Type: SystemString
The prefix.

Return Value

Type: ID
The generated ID

Implements

IIdGeneratorStringToID(String, String)
See Also

Reference

Md5IdGenerator Class
Sitecore.Commerce.Data.Products Namespace


ParentBasedSpecificationRepository Class

ParentBasedSpecificationRepository Class
Defines the repository that stores the global product specifications. This class implements the SpecificationRepository class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository GlobalSpecification
Sitecore.Commerce.Data.ProductsArtifactRepository GlobalSpecification
Sitecore.Commerce.Data.ProductsSpecificationRepository
Sitecore.Commerce.Data.ProductsParentBasedSpecificationRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ParentBasedSpecificationRepository : SpecificationRepository
Public Class ParentBasedSpecificationRepository
    Inherits SpecificationRepository
public ref class ParentBasedSpecificationRepository : public SpecificationRepository
type ParentBasedSpecificationRepository =
    class
        inherit SpecificationRepository
    end

The ParentBasedSpecificationRepository type exposes the following members.

Constructors
 | Name | Description
Public method | ParentBasedSpecificationRepository | Initializes an instance of the ParentBasedSpecificationRepository class.
Top
Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item ID. This method uses the ID of the root item and entity key to generate the ID of the newly created entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemId(Item, String).)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Inherited from SpecificationRepository.)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template ID. (Inherited from SpecificationRepository.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Inherited from SpecificationRepository.)
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


ParentBasedSpecificationRepository Constructor

ParentBasedSpecificationRepository Constructor
Initializes an instance of the ParentBasedSpecificationRepository class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ParentBasedSpecificationRepository(
    string specificationTemplateId,
    string specificationLookupTemplateId,
    ArtifactRepository<GlobalSpecificationOption> specificationOptionRepository
)
Public Sub New (
    specificationTemplateId As String,
    specificationLookupTemplateId As String,
    specificationOptionRepository As ArtifactRepository(Of GlobalSpecificationOption)
)
public:
ParentBasedSpecificationRepository(
    String^ specificationTemplateId,
    String^ specificationLookupTemplateId,
    ArtifactRepository<GlobalSpecificationOption^>^ specificationOptionRepository
)
new :
        specificationTemplateId : string *
        specificationLookupTemplateId : string *
        specificationOptionRepository : ArtifactRepository<GlobalSpecificationOption> -> ParentBasedSpecificationRepository

Parameters

specificationTemplateId
Type: SystemString
The specification template ID
specificationLookupTemplateId
Type: SystemString
The division template ID
specificationOptionRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository GlobalSpecificationOption
The specification option repository
See Also

Reference

ParentBasedSpecificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ParentBasedSpecificationRepository Methods

ParentBasedSpecificationRepository Methods

The ParentBasedSpecificationRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item ID. This method uses the ID of the root item and entity key to generate the ID of the newly created entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemId(Item, String).)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Inherited from SpecificationRepository.)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template ID. (Inherited from SpecificationRepository.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Inherited from SpecificationRepository.)
Top
See Also

Reference

ParentBasedSpecificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ParentBasedSpecificationRepository.GetEntityItemId Method

ParentBasedSpecificationRepositoryGetEntityItemId Method
Gets the entity item ID. This method uses the ID of the root item and entity key to generate the ID of the newly created entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override ID GetEntityItemId(
    Item root,
    string entityKey
)
Protected Overrides Function GetEntityItemId (
    root As Item,
    entityKey As String
) As ID
protected:
virtual ID^ GetEntityItemId(
    Item^ root,
    String^ entityKey
) override
abstract GetEntityItemId :
        root : Item *
        entityKey : string -> ID
override GetEntityItemId :
        root : Item *
        entityKey : string -> ID

Parameters

root
Type: Item
The root item
entityKey
Type: SystemString
The entity key

Return Value

Type: ID
The ID of the Entity item
See Also

Reference

ParentBasedSpecificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ParentBasedSpecificationRepository Properties

ParentBasedSpecificationRepository Properties

The ParentBasedSpecificationRepository type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

ParentBasedSpecificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationGroupRepository Class

ProductClassificationGroupRepository Class
Defines default implementation of product classification group repository. For more information on the product repository, see the Sitecore.Commerce.Products.config file.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository ClassificationGroup
Sitecore.Commerce.Data.ProductsArtifactRepository ClassificationGroup
Sitecore.Commerce.Data.ProductsProductClassificationGroupRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ProductClassificationGroupRepository : ArtifactRepository<ClassificationGroup>
Public Class ProductClassificationGroupRepository
    Inherits ArtifactRepository(Of ClassificationGroup)
public ref class ProductClassificationGroupRepository : public ArtifactRepository<ClassificationGroup^>
type ProductClassificationGroupRepository =
    class
        inherit ArtifactRepository<ClassificationGroup>
    end

The ProductClassificationGroupRepository type exposes the following members.

Constructors
 | Name | Description
Public method | ProductClassificationGroupRepository | Initializes an instance of the ProductClassificationGroupRepository class.
Top
Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item identifier. (Overrides ArtifactRepositoryTEntityGetEntityItemId(Item, String).)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Overrides ArtifactRepositoryTEntityGetEntityKey(Item, TEntity).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Overrides ArtifactRepositoryTEntityGetRepositoryRootItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Assigns values to the entity's name, external ID and description. (Overrides ArtifactRepositoryTEntityPopulateEntity(Item, TEntity).)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


ProductClassificationGroupRepository Constructor

ProductClassificationGroupRepository Constructor
Initializes an instance of the ProductClassificationGroupRepository class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductClassificationGroupRepository(
    string productClassificationGroupRepositoryId
)
Public Sub New (
    productClassificationGroupRepositoryId As String
)
public:
ProductClassificationGroupRepository(
    String^ productClassificationGroupRepositoryId
)
new :
        productClassificationGroupRepositoryId : string -> ProductClassificationGroupRepository

Parameters

productClassificationGroupRepositoryId
Type: SystemString
The product classification group repository ID.
See Also

Reference

ProductClassificationGroupRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationGroupRepository Methods

ProductClassificationGroupRepository Methods

The ProductClassificationGroupRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item identifier. (Overrides ArtifactRepositoryTEntityGetEntityItemId(Item, String).)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Overrides ArtifactRepositoryTEntityGetEntityKey(Item, TEntity).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Overrides ArtifactRepositoryTEntityGetRepositoryRootItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Assigns values to the entity's name, external ID and description. (Overrides ArtifactRepositoryTEntityPopulateEntity(Item, TEntity).)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
See Also

Reference

ProductClassificationGroupRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationGroupRepository.GetEntityItemId Method

ProductClassificationGroupRepositoryGetEntityItemId Method
Gets the entity item identifier.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override ID GetEntityItemId(
    Item root,
    string entityKey
)
Protected Overrides Function GetEntityItemId (
    root As Item,
    entityKey As String
) As ID
protected:
virtual ID^ GetEntityItemId(
    Item^ root,
    String^ entityKey
) override
abstract GetEntityItemId :
        root : Item *
        entityKey : string -> ID
override GetEntityItemId :
        root : Item *
        entityKey : string -> ID

Parameters

root
Type: Item
The root.
entityKey
Type: SystemString
The entity key.

Return Value

Type: ID
The entity item ID.
See Also

Reference

ProductClassificationGroupRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationGroupRepository.GetEntityItemName Method

ProductClassificationGroupRepositoryGetEntityItemName Method
Gets the name of the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetEntityItemName(
    Item root,
    ClassificationGroup entity
)
Protected Overrides Function GetEntityItemName (
    root As Item,
    entity As ClassificationGroup
) As String
protected:
virtual String^ GetEntityItemName(
    Item^ root,
    ClassificationGroup^ entity
) override
abstract GetEntityItemName :
        root : Item *
        entity : ClassificationGroup -> string
override GetEntityItemName :
        root : Item *
        entity : ClassificationGroup -> string

Parameters

root
Type: Item
The root.
entity
Type: Sitecore.Commerce.Entities.ProductsClassificationGroup
The entity.

Return Value

Type: String
The entity name.
See Also

Reference

ProductClassificationGroupRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationGroupRepository.GetEntityKey Method

ProductClassificationGroupRepositoryGetEntityKey Method
Gets the entity key.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetEntityKey(
    Item root,
    ClassificationGroup entity
)
Protected Overrides Function GetEntityKey (
    root As Item,
    entity As ClassificationGroup
) As String
protected:
virtual String^ GetEntityKey(
    Item^ root,
    ClassificationGroup^ entity
) override
abstract GetEntityKey :
        root : Item *
        entity : ClassificationGroup -> string
override GetEntityKey :
        root : Item *
        entity : ClassificationGroup -> string

Parameters

root
Type: Item
The root.
entity
Type: Sitecore.Commerce.Entities.ProductsClassificationGroup
The entity.

Return Value

Type: String
The key of the entity.
See Also

Reference

ProductClassificationGroupRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationGroupRepository.GetRepositoryRootItem Method

ProductClassificationGroupRepositoryGetRepositoryRootItem Method
Gets the repository root item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override Item GetRepositoryRootItem()
Protected Overrides Function GetRepositoryRootItem As Item
protected:
virtual Item^ GetRepositoryRootItem() override
abstract GetRepositoryRootItem : unit -> Item
override GetRepositoryRootItem : unit -> Item

Return Value

Type: Item
The repository root item.
See Also

Reference

ProductClassificationGroupRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationGroupRepository.PopulateEntity Method

ProductClassificationGroupRepositoryPopulateEntity Method
Assigns values to the entity's name, external ID and description.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void PopulateEntity(
    Item entityItem,
    ClassificationGroup entity
)
Protected Overrides Sub PopulateEntity (
    entityItem As Item,
    entity As ClassificationGroup
)
protected:
virtual void PopulateEntity(
    Item^ entityItem,
    ClassificationGroup^ entity
) override
abstract PopulateEntity :
        entityItem : Item *
        entity : ClassificationGroup -> unit
override PopulateEntity :
        entityItem : Item *
        entity : ClassificationGroup -> unit

Parameters

entityItem
Type: Item

[Missing <param name="entityItem"/> documentation for "M:Sitecore.Commerce.Data.Products.ProductClassificationGroupRepository.PopulateEntity(Sitecore.Data.Items.Item,Sitecore.Commerce.Entities.Products.ClassificationGroup)"]

entity
Type: Sitecore.Commerce.Entities.ProductsClassificationGroup

[Missing <param name="entity"/> documentation for "M:Sitecore.Commerce.Data.Products.ProductClassificationGroupRepository.PopulateEntity(Sitecore.Data.Items.Item,Sitecore.Commerce.Entities.Products.ClassificationGroup)"]

See Also

Reference

ProductClassificationGroupRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationGroupRepository.UpdateEntityItem Method

ProductClassificationGroupRepositoryUpdateEntityItem Method
Updates the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void UpdateEntityItem(
    Item entityItem,
    ClassificationGroup entity
)
Protected Overrides Sub UpdateEntityItem (
    entityItem As Item,
    entity As ClassificationGroup
)
protected:
virtual void UpdateEntityItem(
    Item^ entityItem,
    ClassificationGroup^ entity
) override
abstract UpdateEntityItem :
        entityItem : Item *
        entity : ClassificationGroup -> unit
override UpdateEntityItem :
        entityItem : Item *
        entity : ClassificationGroup -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: Sitecore.Commerce.Entities.ProductsClassificationGroup
The entity.
See Also

Reference

ProductClassificationGroupRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationGroupRepository Properties

ProductClassificationGroupRepository Properties

The ProductClassificationGroupRepository type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

ProductClassificationGroupRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository Class

ProductClassificationRepository Class
Defines default implementation of product classification repository. For more information about the product classification repository, see the Sitecore.Commerce.Products.config file.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository Classification
Sitecore.Commerce.Data.ProductsArtifactRepository Classification
Sitecore.Commerce.Data.ProductsProductClassificationRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ProductClassificationRepository : ArtifactRepository<Classification>
Public Class ProductClassificationRepository
    Inherits ArtifactRepository(Of Classification)
public ref class ProductClassificationRepository : public ArtifactRepository<Classification^>
type ProductClassificationRepository =
    class
        inherit ArtifactRepository<Classification>
    end

The ProductClassificationRepository type exposes the following members.

Constructors
 | Name | Description
Public method | ProductClassificationRepository | Initializes an instance of the ProductClassificationRepository class.
Top
Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(String) | Gets the classifications for the specified product classification group.
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Overrides ArtifactRepositoryTEntityGetEntityItemId(Item, String).)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Overrides ArtifactRepositoryTEntityGetEntityItemImmediateRoot(Item, TEntity).)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Overrides ArtifactRepositoryTEntityGetEntityItems(Item).)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Overrides ArtifactRepositoryTEntityGetEntityKey(Item, TEntity).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Overrides ArtifactRepositoryTEntityPopulateEntity(Item, TEntity).)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Classification, String) | Saves the specified product classification.
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | SaveSpecifications | Saves the specifications.
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | ProductClassificationGroupPrefix | Gets or sets the product classification group prefix.
Public property | ProductClassificationPrefix | Gets or sets the product classification prefix.
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository Constructor

ProductClassificationRepository Constructor
Initializes an instance of the ProductClassificationRepository class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductClassificationRepository(
    ArtifactRepository<GlobalSpecifications> globalSpecificationsRepository
)
Public Sub New (
    globalSpecificationsRepository As ArtifactRepository(Of GlobalSpecifications)
)
public:
ProductClassificationRepository(
    ArtifactRepository<GlobalSpecifications^>^ globalSpecificationsRepository
)
new :
        globalSpecificationsRepository : ArtifactRepository<GlobalSpecifications> -> ProductClassificationRepository

Parameters

globalSpecificationsRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository GlobalSpecifications
The global specifications repository.
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository Methods

ProductClassificationRepository Methods

The ProductClassificationRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(String) | Gets the classifications for the specified product classification group.
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Overrides ArtifactRepositoryTEntityGetEntityItemId(Item, String).)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Overrides ArtifactRepositoryTEntityGetEntityItemImmediateRoot(Item, TEntity).)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Overrides ArtifactRepositoryTEntityGetEntityItems(Item).)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Overrides ArtifactRepositoryTEntityGetEntityKey(Item, TEntity).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Overrides ArtifactRepositoryTEntityPopulateEntity(Item, TEntity).)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Classification, String) | Saves the specified product classification.
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | SaveSpecifications | Saves the specifications.
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository.GetEntities Method

ProductClassificationRepositoryGetEntities Method
Overload List
 | Name | Description
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(String) | Gets the classifications for the specified product classification group.
Top
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository.GetEntities Method (String)

ProductClassificationRepositoryGetEntities Method (String)
Gets the classifications for the specified product classification group.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<Classification> GetEntities(
    string productClassificationRepositoryItemId
)
Public Overridable Function GetEntities (
    productClassificationRepositoryItemId As String
) As IEnumerable(Of Classification)
public:
virtual IEnumerable<Classification^>^ GetEntities(
    String^ productClassificationRepositoryItemId
)
abstract GetEntities :
        productClassificationRepositoryItemId : string -> IEnumerable<Classification>
override GetEntities :
        productClassificationRepositoryItemId : string -> IEnumerable<Classification>

Parameters

productClassificationRepositoryItemId
Type: SystemString
The product classification repository item id.

Return Value

Type: IEnumerable Classification
The stored classifications.
See Also

Reference

ProductClassificationRepository Class
GetEntities Overload
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository.GetEntityItemId Method

ProductClassificationRepositoryGetEntityItemId Method
Gets the entity item id.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override ID GetEntityItemId(
    Item root,
    string entityKey
)
Protected Overrides Function GetEntityItemId (
    root As Item,
    entityKey As String
) As ID
protected:
virtual ID^ GetEntityItemId(
    Item^ root,
    String^ entityKey
) override
abstract GetEntityItemId :
        root : Item *
        entityKey : string -> ID
override GetEntityItemId :
        root : Item *
        entityKey : string -> ID

Parameters

root
Type: Item
The root.
entityKey
Type: SystemString
The entity key.

Return Value

Type: ID
Entity item id.
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository.GetEntityItemImmediateRoot Method

ProductClassificationRepositoryGetEntityItemImmediateRoot Method
Gets the entity item immediate root.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override Item GetEntityItemImmediateRoot(
    Item root,
    Classification entity
)
Protected Overrides Function GetEntityItemImmediateRoot (
    root As Item,
    entity As Classification
) As Item
protected:
virtual Item^ GetEntityItemImmediateRoot(
    Item^ root,
    Classification^ entity
) override
abstract GetEntityItemImmediateRoot :
        root : Item *
        entity : Classification -> Item
override GetEntityItemImmediateRoot :
        root : Item *
        entity : Classification -> Item

Parameters

root
Type: Item
The root.
entity
Type: Sitecore.Commerce.Entities.ProductsClassification
The entity.

Return Value

Type: Item
The immedaite root item of the entity.
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository.GetEntityItemName Method

ProductClassificationRepositoryGetEntityItemName Method
Gets the name of the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetEntityItemName(
    Item root,
    Classification entity
)
Protected Overrides Function GetEntityItemName (
    root As Item,
    entity As Classification
) As String
protected:
virtual String^ GetEntityItemName(
    Item^ root,
    Classification^ entity
) override
abstract GetEntityItemName :
        root : Item *
        entity : Classification -> string
override GetEntityItemName :
        root : Item *
        entity : Classification -> string

Parameters

root
Type: Item
The root.
entity
Type: Sitecore.Commerce.Entities.ProductsClassification
The entity.

Return Value

Type: String
Entity item name.
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository.GetEntityItems Method

ProductClassificationRepositoryGetEntityItems Method
Gets entity items under the repository root.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IEnumerable<Item> GetEntityItems(
    Item root
)
Protected Overrides Function GetEntityItems (
    root As Item
) As IEnumerable(Of Item)
protected:
virtual IEnumerable<Item^>^ GetEntityItems(
    Item^ root
) override
abstract GetEntityItems :
        root : Item -> IEnumerable<Item>
override GetEntityItems :
        root : Item -> IEnumerable<Item>

Parameters

root
Type: Item
The root.

Return Value

Type: IEnumerable Item
The entity items.
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository.GetEntityKey Method

ProductClassificationRepositoryGetEntityKey Method
Gets the entity key.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetEntityKey(
    Item root,
    Classification entity
)
Protected Overrides Function GetEntityKey (
    root As Item,
    entity As Classification
) As String
protected:
virtual String^ GetEntityKey(
    Item^ root,
    Classification^ entity
) override
abstract GetEntityKey :
        root : Item *
        entity : Classification -> string
override GetEntityKey :
        root : Item *
        entity : Classification -> string

Parameters

root
Type: Item
The root.
entity
Type: Sitecore.Commerce.Entities.ProductsClassification
The entity.

Return Value

Type: String
The key of the entity.
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository.PopulateEntity Method

ProductClassificationRepositoryPopulateEntity Method
Fills the entity.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void PopulateEntity(
    Item entityItem,
    Classification entity
)
Protected Overrides Sub PopulateEntity (
    entityItem As Item,
    entity As Classification
)
protected:
virtual void PopulateEntity(
    Item^ entityItem,
    Classification^ entity
) override
abstract PopulateEntity :
        entityItem : Item *
        entity : Classification -> unit
override PopulateEntity :
        entityItem : Item *
        entity : Classification -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: Sitecore.Commerce.Entities.ProductsClassification
The entity.
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository.Save Method

ProductClassificationRepositorySave Method
Overload List
 | Name | Description
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Classification, String) | Saves the specified product classification.
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository.Save Method (Classification, String)

ProductClassificationRepositorySave Method (Classification, String)
Saves the specified product classification.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual Classification Save(
    Classification classification,
    string productClassificationRepositoryItemId
)
Public Overridable Function Save (
    classification As Classification,
    productClassificationRepositoryItemId As String
) As Classification
public:
virtual Classification^ Save(
    Classification^ classification,
    String^ productClassificationRepositoryItemId
)
abstract Save :
        classification : Classification *
        productClassificationRepositoryItemId : string -> Classification
override Save :
        classification : Classification *
        productClassificationRepositoryItemId : string -> Classification

Parameters

classification
Type: Sitecore.Commerce.Entities.ProductsClassification
The product classification.
productClassificationRepositoryItemId
Type: SystemString
The product classification repository item id.

Return Value

Type: Classification
The updated product classification.
See Also

Reference

ProductClassificationRepository Class
Save Overload
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository.SaveSpecifications Method

ProductClassificationRepositorySaveSpecifications Method
Saves the specifications.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GlobalSpecifications SaveSpecifications(
    string classificationGroupName,
    string classificationGroupId,
    string classificationId,
    GlobalSpecifications specifications
)
Public Overridable Function SaveSpecifications (
    classificationGroupName As String,
    classificationGroupId As String,
    classificationId As String,
    specifications As GlobalSpecifications
) As GlobalSpecifications
public:
virtual GlobalSpecifications^ SaveSpecifications(
    String^ classificationGroupName,
    String^ classificationGroupId,
    String^ classificationId,
    GlobalSpecifications^ specifications
)
abstract SaveSpecifications :
        classificationGroupName : string *
        classificationGroupId : string *
        classificationId : string *
        specifications : GlobalSpecifications -> GlobalSpecifications
override SaveSpecifications :
        classificationGroupName : string *
        classificationGroupId : string *
        classificationId : string *
        specifications : GlobalSpecifications -> GlobalSpecifications

Parameters

classificationGroupName
Type: SystemString
Name of the classification group.
classificationGroupId
Type: SystemString
The classification group id.
classificationId
Type: SystemString
The classification id.
specifications
Type: Sitecore.Commerce.Entities.ProductsGlobalSpecifications
The specifications.

Return Value

Type: GlobalSpecifications
The updated product classification.
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository.UpdateEntityItem Method

ProductClassificationRepositoryUpdateEntityItem Method
Updates the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void UpdateEntityItem(
    Item entityItem,
    Classification entity
)
Protected Overrides Sub UpdateEntityItem (
    entityItem As Item,
    entity As Classification
)
protected:
virtual void UpdateEntityItem(
    Item^ entityItem,
    Classification^ entity
) override
abstract UpdateEntityItem :
        entityItem : Item *
        entity : Classification -> unit
override UpdateEntityItem :
        entityItem : Item *
        entity : Classification -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: Sitecore.Commerce.Entities.ProductsClassification
The entity.
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository Properties

ProductClassificationRepository Properties

The ProductClassificationRepository type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | ProductClassificationGroupPrefix | Gets or sets the product classification group prefix.
Public property | ProductClassificationPrefix | Gets or sets the product classification prefix.
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository.ProductClassificationGroupPrefix Property

ProductClassificationRepositoryProductClassificationGroupPrefix Property
Gets or sets the product classification group prefix.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ProductClassificationGroupPrefix { get; set; }
Public Property ProductClassificationGroupPrefix As String
    Get
    Set
public:
property String^ ProductClassificationGroupPrefix {
    String^ get ();
    void set (String^ value);
}
member ProductClassificationGroupPrefix : string with get, set

Property Value

Type: String
The product classification group prefix.
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationRepository.ProductClassificationPrefix Property

ProductClassificationRepositoryProductClassificationPrefix Property
Gets or sets the product classification prefix.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ProductClassificationPrefix { get; set; }
Public Property ProductClassificationPrefix As String
    Get
    Set
public:
property String^ ProductClassificationPrefix {
    String^ get ();
    void set (String^ value);
}
member ProductClassificationPrefix : string with get, set

Property Value

Type: String
The product classification prefix.
See Also

Reference

ProductClassificationRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationsFieldRepository Class

ProductClassificationsFieldRepository Class
Defines the repository that stores the product classifications as links from the product items to the product classification items. The link is stored as a field value in the product item.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository ClassificationGroup
Sitecore.Commerce.Data.ProductsProductFieldRepositoryBase ClassificationGroup
Sitecore.Commerce.Data.ProductsProductClassificationsFieldRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ProductClassificationsFieldRepository : ProductFieldRepositoryBase<ClassificationGroup>
Public Class ProductClassificationsFieldRepository
    Inherits ProductFieldRepositoryBase(Of ClassificationGroup)
public ref class ProductClassificationsFieldRepository : public ProductFieldRepositoryBase<ClassificationGroup^>
type ProductClassificationsFieldRepository =
    class
        inherit ProductFieldRepositoryBase<ClassificationGroup>
    end

The ProductClassificationsFieldRepository type exposes the following members.

Constructors
 | Name | Description
Public method | ProductClassificationsFieldRepository | Initializes an instance of the ProductClassificationsFieldRepository class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetEntityItemIds | Gets the entity item IDs. (Overrides ProductFieldRepositoryBaseTEntityGetEntityItemIds(IEnumerableTEntity).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetProductItemByExternalId | Gets the product item using the external ID. (Inherited from ProductFieldRepositoryBaseTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveProductEntities | Saves the product entities. (Inherited from ProductFieldRepositoryBaseTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateField | Updates the field. (Inherited from ProductFieldRepositoryBaseTEntity.)
Top
Fields
 | Name | Description
Protected field | ProductFieldName | The product field name. (Inherited from ProductFieldRepositoryBaseTEntity.)
Protected field | ProductPrefix | The product prefix. (Inherited from ProductFieldRepositoryBaseTEntity.)
Top
Properties
 | Name | Description
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


ProductClassificationsFieldRepository Constructor

ProductClassificationsFieldRepository Constructor
Initializes an instance of the ProductClassificationsFieldRepository class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductClassificationsFieldRepository(
    string productFieldName,
    string productPrefix,
    string productClassificationGroupPrefix
)
Public Sub New (
    productFieldName As String,
    productPrefix As String,
    productClassificationGroupPrefix As String
)
public:
ProductClassificationsFieldRepository(
    String^ productFieldName,
    String^ productPrefix,
    String^ productClassificationGroupPrefix
)
new :
        productFieldName : string *
        productPrefix : string *
        productClassificationGroupPrefix : string -> ProductClassificationsFieldRepository

Parameters

productFieldName
Type: SystemString
Name of the product field
productPrefix
Type: SystemString
The product prefix
productClassificationGroupPrefix
Type: SystemString
The product classification group prefix
See Also

Reference

ProductClassificationsFieldRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationsFieldRepository Fields

ProductClassificationsFieldRepository Fields

The ProductClassificationsFieldRepository type exposes the following members.

Fields
 | Name | Description
Protected field | ProductFieldName | The product field name. (Inherited from ProductFieldRepositoryBaseTEntity.)
Protected field | ProductPrefix | The product prefix. (Inherited from ProductFieldRepositoryBaseTEntity.)
Top
See Also

Reference

ProductClassificationsFieldRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationsFieldRepository Methods

ProductClassificationsFieldRepository Methods

The ProductClassificationsFieldRepository type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetEntityItemIds | Gets the entity item IDs. (Overrides ProductFieldRepositoryBaseTEntityGetEntityItemIds(IEnumerableTEntity).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetProductItemByExternalId | Gets the product item using the external ID. (Inherited from ProductFieldRepositoryBaseTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveProductEntities | Saves the product entities. (Inherited from ProductFieldRepositoryBaseTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateField | Updates the field. (Inherited from ProductFieldRepositoryBaseTEntity.)
Top
See Also

Reference

ProductClassificationsFieldRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationsFieldRepository.GetEntityItemIds Method

ProductClassificationsFieldRepositoryGetEntityItemIds Method
Gets the entity item IDs.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IEnumerable<string> GetEntityItemIds(
    IEnumerable<ClassificationGroup> entityIds
)
Protected Overrides Function GetEntityItemIds (
    entityIds As IEnumerable(Of ClassificationGroup)
) As IEnumerable(Of String)
protected:
virtual IEnumerable<String^>^ GetEntityItemIds(
    IEnumerable<ClassificationGroup^>^ entityIds
) override
abstract GetEntityItemIds :
        entityIds : IEnumerable<ClassificationGroup> -> IEnumerable<string>
override GetEntityItemIds :
        entityIds : IEnumerable<ClassificationGroup> -> IEnumerable<string>

Parameters

entityIds
Type: System.Collections.GenericIEnumerable ClassificationGroup
The entity IDs

Return Value

Type: IEnumerable String
Collection of entity item IDs
See Also

Reference

ProductClassificationsFieldRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductClassificationsFieldRepository Properties

ProductClassificationsFieldRepository Properties

The ProductClassificationsFieldRepository type exposes the following members.

Properties
 | Name | Description
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Top
See Also

Reference

ProductClassificationsFieldRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepository Class

ProductFieldRepository Class
Defines the repository that stores the product artifacts as links from the product items to the artifact items. The link is stored in a field of the product item. You can store any type of product artifact as a field value in the product item.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository String
Sitecore.Commerce.Data.ProductsProductFieldRepositoryBase String
Sitecore.Commerce.Data.ProductsProductFieldRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ProductFieldRepository : ProductFieldRepositoryBase<string>
Public Class ProductFieldRepository
    Inherits ProductFieldRepositoryBase(Of String)
public ref class ProductFieldRepository : public ProductFieldRepositoryBase<String^>
type ProductFieldRepository =
    class
        inherit ProductFieldRepositoryBase<string>
    end

The ProductFieldRepository type exposes the following members.

Constructors
 | Name | Description
Public method | ProductFieldRepository | Initializes an instance of the ProductFieldRepository class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetEntityItemIds | Gets the entity item IDs. (Overrides ProductFieldRepositoryBaseTEntityGetEntityItemIds(IEnumerableTEntity).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetProductItemByExternalId | Gets the product item using the external ID. (Inherited from ProductFieldRepositoryBaseTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveProductEntities | Saves the product entities. (Inherited from ProductFieldRepositoryBaseTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateField | Updates the field. (Inherited from ProductFieldRepositoryBaseTEntity.)
Top
Fields
 | Name | Description
Protected field | ProductFieldName | The product field name. (Inherited from ProductFieldRepositoryBaseTEntity.)
Protected field | ProductPrefix | The product prefix. (Inherited from ProductFieldRepositoryBaseTEntity.)
Top
Properties
 | Name | Description
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


ProductFieldRepository Constructor

ProductFieldRepository Constructor
Initializes an instance of the ProductFieldRepository class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductFieldRepository(
    string productFieldName,
    string productPrefix
)
Public Sub New (
    productFieldName As String,
    productPrefix As String
)
public:
ProductFieldRepository(
    String^ productFieldName,
    String^ productPrefix
)
new :
        productFieldName : string *
        productPrefix : string -> ProductFieldRepository

Parameters

productFieldName
Type: SystemString
Name of the product field
productPrefix
Type: SystemString
The product prefix
See Also

Reference

ProductFieldRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepository Fields

ProductFieldRepository Fields

The ProductFieldRepository type exposes the following members.

Fields
 | Name | Description
Protected field | ProductFieldName | The product field name. (Inherited from ProductFieldRepositoryBaseTEntity.)
Protected field | ProductPrefix | The product prefix. (Inherited from ProductFieldRepositoryBaseTEntity.)
Top
See Also

Reference

ProductFieldRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepository Methods

ProductFieldRepository Methods

The ProductFieldRepository type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetEntityItemIds | Gets the entity item IDs. (Overrides ProductFieldRepositoryBaseTEntityGetEntityItemIds(IEnumerableTEntity).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetProductItemByExternalId | Gets the product item using the external ID. (Inherited from ProductFieldRepositoryBaseTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveProductEntities | Saves the product entities. (Inherited from ProductFieldRepositoryBaseTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateField | Updates the field. (Inherited from ProductFieldRepositoryBaseTEntity.)
Top
See Also

Reference

ProductFieldRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepository.GetEntityItemIds Method

ProductFieldRepositoryGetEntityItemIds Method
Gets the entity item IDs.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IEnumerable<string> GetEntityItemIds(
    IEnumerable<string> entityIds
)
Protected Overrides Function GetEntityItemIds (
    entityIds As IEnumerable(Of String)
) As IEnumerable(Of String)
protected:
virtual IEnumerable<String^>^ GetEntityItemIds(
    IEnumerable<String^>^ entityIds
) override
abstract GetEntityItemIds :
        entityIds : IEnumerable<string> -> IEnumerable<string>
override GetEntityItemIds :
        entityIds : IEnumerable<string> -> IEnumerable<string>

Parameters

entityIds
Type: System.Collections.GenericIEnumerable String
The entity IDs

Return Value

Type: IEnumerable String
A collection of entity item IDs
See Also

Reference

ProductFieldRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepository Properties

ProductFieldRepository Properties

The ProductFieldRepository type exposes the following members.

Properties
 | Name | Description
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Top
See Also

Reference

ProductFieldRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepositoryBase(TEntity) Class

ProductFieldRepositoryBaseTEntity Class
Defines the base abstract class for all repositories that store the product artifacts as links from the product items to the artifact items. The link is stored as a field value in the product item. You can use the descendants of this class to save any type of product artifact that is stored as a field value in a product item.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository TEntity
Sitecore.Commerce.Data.ProductsProductFieldRepositoryBaseTEntity
Sitecore.Commerce.Data.ProductsProductClassificationsFieldRepository
Sitecore.Commerce.Data.ProductsProductFieldRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class ProductFieldRepositoryBase<TEntity> : EntityRepository<TEntity>,
    IProductRelatedEntityRepository<TEntity>

Public MustInherit Class ProductFieldRepositoryBase(Of TEntity)
    Inherits EntityRepository(Of TEntity)
    Implements IProductRelatedEntityRepository(Of TEntity)
generic<typename TEntity>
public ref class ProductFieldRepositoryBase abstract : public EntityRepository<TEntity>,
    IProductRelatedEntityRepository<TEntity>
[<AbstractClassAttribute>]
type ProductFieldRepositoryBase<'TEntity> =
    class
        inherit EntityRepository<'TEntity>
        interface IProductRelatedEntityRepository<'TEntity>
    end

Type Parameters

TEntity
The type of the entity

The ProductFieldRepositoryBaseTEntity type exposes the following members.

Constructors
 | Name | Description
Protected method | ProductFieldRepositoryBaseTEntity | Initializes an instance of the ProductFieldRepositoryBaseTEntity class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetEntityItemIds | Gets the entity item IDs.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetProductItemByExternalId | Gets the product item using the external ID.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveProductEntities | Saves the product entities.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateField | Updates the field.
Top
Fields
 | Name | Description
Protected field | ProductFieldName | The product field name.
Protected field | ProductPrefix | The product prefix.
Top
Properties
 | Name | Description
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


ProductFieldRepositoryBase(TEntity) Constructor

ProductFieldRepositoryBaseTEntity Constructor
Initializes an instance of the ProductFieldRepositoryBaseTEntity class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected ProductFieldRepositoryBase(
    string productFieldName,
    string productPrefix
)
Protected Sub New (
    productFieldName As String,
    productPrefix As String
)
protected:
ProductFieldRepositoryBase(
    String^ productFieldName,
    String^ productPrefix
)
new :
        productFieldName : string *
        productPrefix : string -> ProductFieldRepositoryBase

Parameters

productFieldName
Type: SystemString
Name of the product field
productPrefix
Type: SystemString
The product prefix
See Also

Reference

ProductFieldRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepositoryBase(TEntity) Fields

ProductFieldRepositoryBaseTEntity Fields

The ProductFieldRepositoryBaseTEntity generic type exposes the following members.

Fields
 | Name | Description
Protected field | ProductFieldName | The product field name.
Protected field | ProductPrefix | The product prefix.
Top
See Also

Reference

ProductFieldRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepositoryBase(TEntity).ProductFieldName Field

ProductFieldRepositoryBaseTEntityProductFieldName Field
The product field name.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected readonly string ProductFieldName
Protected ReadOnly ProductFieldName As String
protected:
initonly String^ ProductFieldName
val ProductFieldName: string

Field Value

Type: String
See Also

Reference

ProductFieldRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepositoryBase(TEntity).ProductPrefix Field

ProductFieldRepositoryBaseTEntityProductPrefix Field
The product prefix.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected readonly string ProductPrefix
Protected ReadOnly ProductPrefix As String
protected:
initonly String^ ProductPrefix
val ProductPrefix: string

Field Value

Type: String
See Also

Reference

ProductFieldRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepositoryBase(TEntity) Methods

ProductFieldRepositoryBaseTEntity Methods

The ProductFieldRepositoryBaseTEntity generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetEntityItemIds | Gets the entity item IDs.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetProductItemByExternalId | Gets the product item using the external ID.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveProductEntities | Saves the product entities.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateField | Updates the field.
Top
See Also

Reference

ProductFieldRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepositoryBase(TEntity).GetEntityItemIds Method

ProductFieldRepositoryBaseTEntityGetEntityItemIds Method
Gets the entity item IDs.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract IEnumerable<string> GetEntityItemIds(
    IEnumerable<TEntity> entityIds
)
Protected MustOverride Function GetEntityItemIds (
    entityIds As IEnumerable(Of TEntity)
) As IEnumerable(Of String)
protected:
virtual IEnumerable<String^>^ GetEntityItemIds(
    IEnumerable<TEntity>^ entityIds
) abstract
abstract GetEntityItemIds :
        entityIds : IEnumerable<'TEntity> -> IEnumerable<string>

Parameters

entityIds
Type: System.Collections.GenericIEnumerable TEntity
The entity IDs

Return Value

Type: IEnumerable String
Collection of entity item IDs
See Also

Reference

ProductFieldRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepositoryBase(TEntity).GetProductItemByExternalId Method

ProductFieldRepositoryBaseTEntityGetProductItemByExternalId Method
Gets the product item using the external ID.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual Item GetProductItemByExternalId(
    string externalProductId
)
Protected Overridable Function GetProductItemByExternalId (
    externalProductId As String
) As Item
protected:
virtual Item^ GetProductItemByExternalId(
    String^ externalProductId
)
abstract GetProductItemByExternalId :
        externalProductId : string -> Item
override GetProductItemByExternalId :
        externalProductId : string -> Item

Parameters

externalProductId
Type: SystemString
The external product ID

Return Value

Type: Item
The product item
See Also

Reference

ProductFieldRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepositoryBase(TEntity).SaveProductEntities Method

ProductFieldRepositoryBaseTEntitySaveProductEntities Method
Saves the product entities.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public void SaveProductEntities(
    string externalProductId,
    IEnumerable<TEntity> entities
)
Public Sub SaveProductEntities (
    externalProductId As String,
    entities As IEnumerable(Of TEntity)
)
public:
virtual void SaveProductEntities(
    String^ externalProductId,
    IEnumerable<TEntity>^ entities
) sealed
abstract SaveProductEntities :
        externalProductId : string *
        entities : IEnumerable<'TEntity> -> unit
override SaveProductEntities :
        externalProductId : string *
        entities : IEnumerable<'TEntity> -> unit

Parameters

externalProductId
Type: SystemString
The external product ID
entities
Type: System.Collections.GenericIEnumerable TEntity
The entities

Implements

IProductRelatedEntityRepositoryTEntitySaveProductEntities(String, IEnumerableTEntity)
See Also

Reference

ProductFieldRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepositoryBase(TEntity).UpdateField Method

ProductFieldRepositoryBaseTEntityUpdateField Method
Updates the field.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void UpdateField(
    string externalProductId,
    IEnumerable<string> entityIds
)
Protected Overridable Sub UpdateField (
    externalProductId As String,
    entityIds As IEnumerable(Of String)
)
protected:
virtual void UpdateField(
    String^ externalProductId,
    IEnumerable<String^>^ entityIds
)
abstract UpdateField :
        externalProductId : string *
        entityIds : IEnumerable<string> -> unit
override UpdateField :
        externalProductId : string *
        entityIds : IEnumerable<string> -> unit

Parameters

externalProductId
Type: SystemString
The external product ID
entityIds
Type: System.Collections.GenericIEnumerable String
The entity IDs
See Also

Reference

ProductFieldRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductFieldRepositoryBase(TEntity) Properties

ProductFieldRepositoryBaseTEntity Properties

The ProductFieldRepositoryBaseTEntity generic type exposes the following members.

Properties
 | Name | Description
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Top
See Also

Reference

ProductFieldRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductItemRepositoryBase(TEntity) Class

ProductItemRepositoryBaseTEntity Class
Defines the base abstract class for all repositories that store the product artifacts as sub-items of of the product item sub-folders. You can use the descendants of this class to store any type of product artifact that is stored as a sub-item.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository TEntity
Sitecore.Commerce.Data.ProductsProductItemRepositoryBaseTEntity
Sitecore.Commerce.Data.ProductsProductRelationsRepository
Sitecore.Commerce.Data.ProductsProductResourcesRepository
Sitecore.Commerce.Data.ProductsProductSpecificationsRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class ProductItemRepositoryBase<TEntity> : EntityRepository<TEntity>,
    IProductRelatedEntityRepository<TEntity>

Public MustInherit Class ProductItemRepositoryBase(Of TEntity)
    Inherits EntityRepository(Of TEntity)
    Implements IProductRelatedEntityRepository(Of TEntity)
generic<typename TEntity>
public ref class ProductItemRepositoryBase abstract : public EntityRepository<TEntity>,
    IProductRelatedEntityRepository<TEntity>
[<AbstractClassAttribute>]
type ProductItemRepositoryBase<'TEntity> =
    class
        inherit EntityRepository<'TEntity>
        interface IProductRelatedEntityRepository<'TEntity>
    end

Type Parameters

TEntity
The type of the entity

The ProductItemRepositoryBaseTEntity type exposes the following members.

Constructors
 | Name | Description
Protected method | ProductItemRepositoryBaseTEntity | Initializes an instance of the ProductItemRepositoryBaseTEntity class.
Top
Methods
 | Name | Description
Protected method | CreateOrUpdateEntity | Creates or updates the entity.
Protected method | DeleteObsoleteEntityItems | Deletes the obsolete entity items.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetTypesRootItem | Gets the types root item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveProductEntities | Saves the product artifacts sub-items of the product item sub-folders and Removes all obsolete sub-items after every round of the synchronization.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | ProductPrefix | The product prefix.
Top
Properties
 | Name | Description
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


ProductItemRepositoryBase(TEntity) Constructor

ProductItemRepositoryBaseTEntity Constructor
Initializes an instance of the ProductItemRepositoryBaseTEntity class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected ProductItemRepositoryBase(
    string productFolderName,
    string productPrefix,
    string productEntityTemplateId
)
Protected Sub New (
    productFolderName As String,
    productPrefix As String,
    productEntityTemplateId As String
)
protected:
ProductItemRepositoryBase(
    String^ productFolderName,
    String^ productPrefix,
    String^ productEntityTemplateId
)
new :
        productFolderName : string *
        productPrefix : string *
        productEntityTemplateId : string -> ProductItemRepositoryBase

Parameters

productFolderName
Type: SystemString
Name of the product folder
productPrefix
Type: SystemString
The product prefix
productEntityTemplateId
Type: SystemString
The product entity template ID
See Also

Reference

ProductItemRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductItemRepositoryBase(TEntity) Fields

ProductItemRepositoryBaseTEntity Fields

The ProductItemRepositoryBaseTEntity generic type exposes the following members.

Fields
 | Name | Description
Protected field | ProductPrefix | The product prefix.
Top
See Also

Reference

ProductItemRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductItemRepositoryBase(TEntity).ProductPrefix Field

ProductItemRepositoryBaseTEntityProductPrefix Field
The product prefix.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected readonly string ProductPrefix
Protected ReadOnly ProductPrefix As String
protected:
initonly String^ ProductPrefix
val ProductPrefix: string

Field Value

Type: String
See Also

Reference

ProductItemRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductItemRepositoryBase(TEntity) Methods

ProductItemRepositoryBaseTEntity Methods

The ProductItemRepositoryBaseTEntity generic type exposes the following members.

Methods
 | Name | Description
Protected method | CreateOrUpdateEntity | Creates or updates the entity.
Protected method | DeleteObsoleteEntityItems | Deletes the obsolete entity items.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetTypesRootItem | Gets the types root item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveProductEntities | Saves the product artifacts sub-items of the product item sub-folders and Removes all obsolete sub-items after every round of the synchronization.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductItemRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductItemRepositoryBase(TEntity).CreateOrUpdateEntity Method

ProductItemRepositoryBaseTEntityCreateOrUpdateEntity Method
Creates or updates the entity.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract Item CreateOrUpdateEntity(
    string externalProductId,
    TEntity entity,
    Item productEntityFolderItem,
    Item productEntityTemplateItem,
    Item entityTypeRootItem
)
Protected MustOverride Function CreateOrUpdateEntity (
    externalProductId As String,
    entity As TEntity,
    productEntityFolderItem As Item,
    productEntityTemplateItem As Item,
    entityTypeRootItem As Item
) As Item
protected:
virtual Item^ CreateOrUpdateEntity(
    String^ externalProductId,
    TEntity entity,
    Item^ productEntityFolderItem,
    Item^ productEntityTemplateItem,
    Item^ entityTypeRootItem
) abstract
abstract CreateOrUpdateEntity :
        externalProductId : string *
        entity : 'TEntity *
        productEntityFolderItem : Item *
        productEntityTemplateItem : Item *
        entityTypeRootItem : Item -> Item

Parameters

externalProductId
Type: SystemString
The external product ID
entity
Type: TEntity
The entity
productEntityFolderItem
Type: Item
The product entity folder item
productEntityTemplateItem
Type: Item
The product entity template item
entityTypeRootItem
Type: Item
The entity type root item

Return Value

Type: Item
The created or updated entity item
See Also

Reference

ProductItemRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductItemRepositoryBase(TEntity).DeleteObsoleteEntityItems Method

ProductItemRepositoryBaseTEntityDeleteObsoleteEntityItems Method
Deletes the obsolete entity items.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void DeleteObsoleteEntityItems(
    IEnumerable<Item> entityItems,
    Item productEntityFolderItem
)
Protected Overridable Sub DeleteObsoleteEntityItems (
    entityItems As IEnumerable(Of Item),
    productEntityFolderItem As Item
)
protected:
virtual void DeleteObsoleteEntityItems(
    IEnumerable<Item^>^ entityItems,
    Item^ productEntityFolderItem
)
abstract DeleteObsoleteEntityItems :
        entityItems : IEnumerable<Item> *
        productEntityFolderItem : Item -> unit
override DeleteObsoleteEntityItems :
        entityItems : IEnumerable<Item> *
        productEntityFolderItem : Item -> unit

Parameters

entityItems
Type: System.Collections.GenericIEnumerable Item
The entity items
productEntityFolderItem
Type: Item
The product entity folder item
See Also

Reference

ProductItemRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductItemRepositoryBase(TEntity).GetTypesRootItem Method

ProductItemRepositoryBaseTEntityGetTypesRootItem Method
Gets the types root item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual Item GetTypesRootItem()
Protected Overridable Function GetTypesRootItem As Item
protected:
virtual Item^ GetTypesRootItem()
abstract GetTypesRootItem : unit -> Item
override GetTypesRootItem : unit -> Item

Return Value

Type: Item
The root item of entity types
See Also

Reference

ProductItemRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductItemRepositoryBase(TEntity).SaveProductEntities Method

ProductItemRepositoryBaseTEntitySaveProductEntities Method
Saves the product artifacts sub-items of the product item sub-folders and Removes all obsolete sub-items after every round of the synchronization.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public void SaveProductEntities(
    string externalProductId,
    IEnumerable<TEntity> entities
)
Public Sub SaveProductEntities (
    externalProductId As String,
    entities As IEnumerable(Of TEntity)
)
public:
virtual void SaveProductEntities(
    String^ externalProductId,
    IEnumerable<TEntity>^ entities
) sealed
abstract SaveProductEntities :
        externalProductId : string *
        entities : IEnumerable<'TEntity> -> unit
override SaveProductEntities :
        externalProductId : string *
        entities : IEnumerable<'TEntity> -> unit

Parameters

externalProductId
Type: SystemString
The external product ID
entities
Type: System.Collections.GenericIEnumerable TEntity
The entities

Implements

IProductRelatedEntityRepositoryTEntitySaveProductEntities(String, IEnumerableTEntity)
See Also

Reference

ProductItemRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductItemRepositoryBase(TEntity) Properties

ProductItemRepositoryBaseTEntity Properties

The ProductItemRepositoryBaseTEntity generic type exposes the following members.

Properties
 | Name | Description
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Top
See Also

Reference

ProductItemRepositoryBaseTEntity Class
Sitecore.Commerce.Data.Products Namespace


ProductRelationsRepository Class

ProductRelationsRepository Class
Represents the repository that stores the product relations as sub-items of the Relations sub-folder of the product item.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository RelationType
Sitecore.Commerce.Data.ProductsProductItemRepositoryBase RelationType
Sitecore.Commerce.Data.ProductsProductRelationsRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ProductRelationsRepository : ProductItemRepositoryBase<RelationType>
Public Class ProductRelationsRepository
    Inherits ProductItemRepositoryBase(Of RelationType)
public ref class ProductRelationsRepository : public ProductItemRepositoryBase<RelationType^>
type ProductRelationsRepository =
    class
        inherit ProductItemRepositoryBase<RelationType>
    end

The ProductRelationsRepository type exposes the following members.

Constructors
 | Name | Description
Public method | ProductRelationsRepository | Initializes an instance of the ProductRelationsRepository class.
Top
Methods
 | Name | Description
Protected method | CreateOrUpdateEntity | Creates or updates the entity. (Overrides ProductItemRepositoryBaseTEntityCreateOrUpdateEntity(String, TEntity, Item, Item, Item).)
Protected method | DeleteObsoleteEntityItems | Deletes the obsolete entity items. (Overrides ProductItemRepositoryBaseTEntityDeleteObsoleteEntityItems(IEnumerableItem, Item).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetTypesRootItem | Gets the root item of the entity types. (Overrides ProductItemRepositoryBaseTEntityGetTypesRootItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveProductEntities | Saves the product artifacts sub-items of the product item sub-folders and Removes all obsolete sub-items after every round of the synchronization. (Inherited from ProductItemRepositoryBaseTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | ProductPrefix | The product prefix. (Inherited from ProductItemRepositoryBaseTEntity.)
Top
Properties
 | Name | Description
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


ProductRelationsRepository Constructor

ProductRelationsRepository Constructor
Initializes an instance of the ProductRelationsRepository class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductRelationsRepository(
    string productFolderName,
    string productPrefix,
    string productEntityTemplateId,
    string relationTypesRootItemId
)
Public Sub New (
    productFolderName As String,
    productPrefix As String,
    productEntityTemplateId As String,
    relationTypesRootItemId As String
)
public:
ProductRelationsRepository(
    String^ productFolderName,
    String^ productPrefix,
    String^ productEntityTemplateId,
    String^ relationTypesRootItemId
)
new :
        productFolderName : string *
        productPrefix : string *
        productEntityTemplateId : string *
        relationTypesRootItemId : string -> ProductRelationsRepository

Parameters

productFolderName
Type: SystemString
Name of the product folder
productPrefix
Type: SystemString
The product prefix
productEntityTemplateId
Type: SystemString
The template ID of the product entity
relationTypesRootItemId
Type: SystemString
The root item ID of the product relation types
See Also

Reference

ProductRelationsRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRelationsRepository Fields

ProductRelationsRepository Fields

The ProductRelationsRepository type exposes the following members.

Fields
 | Name | Description
Protected field | ProductPrefix | The product prefix. (Inherited from ProductItemRepositoryBaseTEntity.)
Top
See Also

Reference

ProductRelationsRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRelationsRepository Methods

ProductRelationsRepository Methods

The ProductRelationsRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateOrUpdateEntity | Creates or updates the entity. (Overrides ProductItemRepositoryBaseTEntityCreateOrUpdateEntity(String, TEntity, Item, Item, Item).)
Protected method | DeleteObsoleteEntityItems | Deletes the obsolete entity items. (Overrides ProductItemRepositoryBaseTEntityDeleteObsoleteEntityItems(IEnumerableItem, Item).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetTypesRootItem | Gets the root item of the entity types. (Overrides ProductItemRepositoryBaseTEntityGetTypesRootItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveProductEntities | Saves the product artifacts sub-items of the product item sub-folders and Removes all obsolete sub-items after every round of the synchronization. (Inherited from ProductItemRepositoryBaseTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductRelationsRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRelationsRepository.CreateOrUpdateEntity Method

ProductRelationsRepositoryCreateOrUpdateEntity Method
Creates or updates the entity.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override Item CreateOrUpdateEntity(
    string externalProductId,
    RelationType entity,
    Item productEntityFolderItem,
    Item productEntityTemplateItem,
    Item entityTypeRootItem
)
Protected Overrides Function CreateOrUpdateEntity (
    externalProductId As String,
    entity As RelationType,
    productEntityFolderItem As Item,
    productEntityTemplateItem As Item,
    entityTypeRootItem As Item
) As Item
protected:
virtual Item^ CreateOrUpdateEntity(
    String^ externalProductId,
    RelationType^ entity,
    Item^ productEntityFolderItem,
    Item^ productEntityTemplateItem,
    Item^ entityTypeRootItem
) override
abstract CreateOrUpdateEntity :
        externalProductId : string *
        entity : RelationType *
        productEntityFolderItem : Item *
        productEntityTemplateItem : Item *
        entityTypeRootItem : Item -> Item
override CreateOrUpdateEntity :
        externalProductId : string *
        entity : RelationType *
        productEntityFolderItem : Item *
        productEntityTemplateItem : Item *
        entityTypeRootItem : Item -> Item

Parameters

externalProductId
Type: SystemString
The external product ID
entity
Type: Sitecore.Commerce.Entities.ProductsRelationType
The entity
productEntityFolderItem
Type: Item
The product entity folder item
productEntityTemplateItem
Type: Item
The product entity template item
entityTypeRootItem
Type: Item
The root item of the entity type

Return Value

Type: Item
The created or updated entity item
See Also

Reference

ProductRelationsRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRelationsRepository.DeleteObsoleteEntityItems Method

ProductRelationsRepositoryDeleteObsoleteEntityItems Method
Deletes the obsolete entity items.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void DeleteObsoleteEntityItems(
    IEnumerable<Item> entityItems,
    Item productEntityFolderItem
)
Protected Overrides Sub DeleteObsoleteEntityItems (
    entityItems As IEnumerable(Of Item),
    productEntityFolderItem As Item
)
protected:
virtual void DeleteObsoleteEntityItems(
    IEnumerable<Item^>^ entityItems,
    Item^ productEntityFolderItem
) override
abstract DeleteObsoleteEntityItems :
        entityItems : IEnumerable<Item> *
        productEntityFolderItem : Item -> unit
override DeleteObsoleteEntityItems :
        entityItems : IEnumerable<Item> *
        productEntityFolderItem : Item -> unit

Parameters

entityItems
Type: System.Collections.GenericIEnumerable Item
The entity items
productEntityFolderItem
Type: Item
The product entity folder item
See Also

Reference

ProductRelationsRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRelationsRepository.GetTypesRootItem Method

ProductRelationsRepositoryGetTypesRootItem Method
Gets the root item of the entity types.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override Item GetTypesRootItem()
Protected Overrides Function GetTypesRootItem As Item
protected:
virtual Item^ GetTypesRootItem() override
abstract GetTypesRootItem : unit -> Item
override GetTypesRootItem : unit -> Item

Return Value

Type: Item
The root item of the entity types
See Also

Reference

ProductRelationsRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRelationsRepository Properties

ProductRelationsRepository Properties

The ProductRelationsRepository type exposes the following members.

Properties
 | Name | Description
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Top
See Also

Reference

ProductRelationsRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository Class

ProductRepository Class
Defines default implementation of product repository. For more information about the product repository, see the Sitecore.Commerce.Products.config file.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository Product
Sitecore.Commerce.Data.ProductsArtifactRepository Product
Sitecore.Commerce.Data.ProductsProductRepository
Sitecore.Commerce.Data.ProductsDelayedSyncProductRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ProductRepository : ArtifactRepository<Product>
Public Class ProductRepository
    Inherits ArtifactRepository(Of Product)
public ref class ProductRepository : public ArtifactRepository<Product^>
type ProductRepository =
    class
        inherit ArtifactRepository<Product>
    end

The ProductRepository type exposes the following members.

Constructors
 | Name | Description
Public method | ProductRepository | Initializes a new instance of the ProductRepository class
Top
Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteProduct | Deletes the product.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets the entity items. (Overrides ArtifactRepositoryTEntityGetEntityItems(Item).)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Overrides ArtifactRepositoryTEntityMoveToImmediateRoot(Item, Item, Item).)
Protected method | PopulateEntity | Assigns values for the entity's name, external ID, short description, full description, identification, manufacturers, product types, devisions, classification groups, resources, product specifications and relation types. (Overrides ArtifactRepositoryTEntityPopulateEntity(Item, TEntity).)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | SaveProductClassifications | Saves the product classifications.
Public method | SaveProductClassificationsSpecifications | Saves the product classifications specifications.
Public method | SaveProductDivisions | Saves the product divisions.
Public method | SaveProductGlobalSpecifications | Saves the product specifications.
Public method | SaveProductManufacturers | Saves the product manufacturers.
Public method | SaveProductRelations | Saves the product relations.
Public method | SaveProductResources | Saves the product resources.
Public method | SaveProductTypes | Saves the product types.
Public method | SaveProductTypeSpecifications | Saves the product type specifications.
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Public property | ClassificationsRepository | Gets or sets the classifications repository.
Public property | ClassificationsSpecificationsRepository | Gets or sets the classifications specifications repository.
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | DivisionRepository | Gets or sets the division repository.
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | GlobalSpecificationsRepository | Gets or sets the specifications repository.
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | ManufacturerRepository | Gets or sets the manufacturer repository.
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | ProductsIndex | Gets or sets the index of the products.
Public property | RelationsRepository | Gets or sets the relations repository.
Public property | ResourcesRepository | Gets or sets the resources repository.
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Public property | TypeRepository | Gets or sets the type repository.
Public property | TypeSpecificationsRepository | Gets or sets the type specifications repository.
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


ProductRepository Constructor

ProductRepository Constructor
Initializes a new instance of the ProductRepository class

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductRepository()
Public Sub New
public:
ProductRepository()
new : unit -> ProductRepository
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository Methods

ProductRepository Methods

The ProductRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteProduct | Deletes the product.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets the entity items. (Overrides ArtifactRepositoryTEntityGetEntityItems(Item).)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Overrides ArtifactRepositoryTEntityMoveToImmediateRoot(Item, Item, Item).)
Protected method | PopulateEntity | Assigns values for the entity's name, external ID, short description, full description, identification, manufacturers, product types, devisions, classification groups, resources, product specifications and relation types. (Overrides ArtifactRepositoryTEntityPopulateEntity(Item, TEntity).)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | SaveProductClassifications | Saves the product classifications.
Public method | SaveProductClassificationsSpecifications | Saves the product classifications specifications.
Public method | SaveProductDivisions | Saves the product divisions.
Public method | SaveProductGlobalSpecifications | Saves the product specifications.
Public method | SaveProductManufacturers | Saves the product manufacturers.
Public method | SaveProductRelations | Saves the product relations.
Public method | SaveProductResources | Saves the product resources.
Public method | SaveProductTypes | Saves the product types.
Public method | SaveProductTypeSpecifications | Saves the product type specifications.
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.DeleteProduct Method

ProductRepositoryDeleteProduct Method
Deletes the product.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual bool DeleteProduct(
    string externalId
)
Public Overridable Function DeleteProduct (
    externalId As String
) As Boolean
public:
virtual bool DeleteProduct(
    String^ externalId
)
abstract DeleteProduct :
        externalId : string -> bool
override DeleteProduct :
        externalId : string -> bool

Parameters

externalId
Type: SystemString
The external identifier.

Return Value

Type: Boolean
true if the specified item was deleted; otherwise, false.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.GetEntityItemName Method

ProductRepositoryGetEntityItemName Method
Gets the name of the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetEntityItemName(
    Item root,
    Product entity
)
Protected Overrides Function GetEntityItemName (
    root As Item,
    entity As Product
) As String
protected:
virtual String^ GetEntityItemName(
    Item^ root,
    Product^ entity
) override
abstract GetEntityItemName :
        root : Item *
        entity : Product -> string
override GetEntityItemName :
        root : Item *
        entity : Product -> string

Parameters

root
Type: Item
The root.
entity
Type: Sitecore.Commerce.Entities.ProductsProduct
The entity.

Return Value

Type: String
The entity item name.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.GetEntityItems Method

ProductRepositoryGetEntityItems Method
Gets the entity items.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IEnumerable<Item> GetEntityItems(
    Item repositoryItem
)
Protected Overrides Function GetEntityItems (
    repositoryItem As Item
) As IEnumerable(Of Item)
protected:
virtual IEnumerable<Item^>^ GetEntityItems(
    Item^ repositoryItem
) override
abstract GetEntityItems :
        repositoryItem : Item -> IEnumerable<Item>
override GetEntityItems :
        repositoryItem : Item -> IEnumerable<Item>

Parameters

repositoryItem
Type: Item
The repository item.

Return Value

Type: IEnumerable Item
The list of entity items.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.MoveToImmediateRoot Method

ProductRepositoryMoveToImmediateRoot Method
Moves to immediate root.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void MoveToImmediateRoot(
    Item root,
    Item entityItemImmediateRoot,
    Item entityItem
)
Protected Overrides Sub MoveToImmediateRoot (
    root As Item,
    entityItemImmediateRoot As Item,
    entityItem As Item
)
protected:
virtual void MoveToImmediateRoot(
    Item^ root,
    Item^ entityItemImmediateRoot,
    Item^ entityItem
) override
abstract MoveToImmediateRoot :
        root : Item *
        entityItemImmediateRoot : Item *
        entityItem : Item -> unit
override MoveToImmediateRoot :
        root : Item *
        entityItemImmediateRoot : Item *
        entityItem : Item -> unit

Parameters

root
Type: Item
The root.
entityItemImmediateRoot
Type: Item
The entity item immediate root.
entityItem
Type: Item
The entity item.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.PopulateEntity Method

ProductRepositoryPopulateEntity Method
Assigns values for the entity's name, external ID, short description, full description, identification, manufacturers, product types, devisions, classification groups, resources, product specifications and relation types.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void PopulateEntity(
    Item entityItem,
    Product entity
)
Protected Overrides Sub PopulateEntity (
    entityItem As Item,
    entity As Product
)
protected:
virtual void PopulateEntity(
    Item^ entityItem,
    Product^ entity
) override
abstract PopulateEntity :
        entityItem : Item *
        entity : Product -> unit
override PopulateEntity :
        entityItem : Item *
        entity : Product -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: Sitecore.Commerce.Entities.ProductsProduct
The entity.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.SaveProductClassifications Method

ProductRepositorySaveProductClassifications Method
Saves the product classifications.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void SaveProductClassifications(
    string externalProductId,
    IEnumerable<ClassificationGroup> classificationGroups
)
Public Overridable Sub SaveProductClassifications (
    externalProductId As String,
    classificationGroups As IEnumerable(Of ClassificationGroup)
)
public:
virtual void SaveProductClassifications(
    String^ externalProductId,
    IEnumerable<ClassificationGroup^>^ classificationGroups
)
abstract SaveProductClassifications :
        externalProductId : string *
        classificationGroups : IEnumerable<ClassificationGroup> -> unit
override SaveProductClassifications :
        externalProductId : string *
        classificationGroups : IEnumerable<ClassificationGroup> -> unit

Parameters

externalProductId
Type: SystemString
The external product ID.
classificationGroups
Type: System.Collections.GenericIEnumerable ClassificationGroup
The classification groups.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.SaveProductClassificationsSpecifications Method

ProductRepositorySaveProductClassificationsSpecifications Method
Saves the product classifications specifications.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void SaveProductClassificationsSpecifications(
    string externalProductId,
    IDictionary<ID, Specification> productSpecifications
)
Public Overridable Sub SaveProductClassificationsSpecifications (
    externalProductId As String,
    productSpecifications As IDictionary(Of ID, Specification)
)
public:
virtual void SaveProductClassificationsSpecifications(
    String^ externalProductId,
    IDictionary<ID^, Specification^>^ productSpecifications
)
abstract SaveProductClassificationsSpecifications :
        externalProductId : string *
        productSpecifications : IDictionary<ID, Specification> -> unit
override SaveProductClassificationsSpecifications :
        externalProductId : string *
        productSpecifications : IDictionary<ID, Specification> -> unit

Parameters

externalProductId
Type: SystemString
The external product identifier.
productSpecifications
Type: System.Collections.GenericIDictionary ID, Specification
The product specifications.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.SaveProductDivisions Method

ProductRepositorySaveProductDivisions Method
Saves the product divisions.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void SaveProductDivisions(
    string externalProductId,
    IEnumerable<string> divisionIds
)
Public Overridable Sub SaveProductDivisions (
    externalProductId As String,
    divisionIds As IEnumerable(Of String)
)
public:
virtual void SaveProductDivisions(
    String^ externalProductId,
    IEnumerable<String^>^ divisionIds
)
abstract SaveProductDivisions :
        externalProductId : string *
        divisionIds : IEnumerable<string> -> unit
override SaveProductDivisions :
        externalProductId : string *
        divisionIds : IEnumerable<string> -> unit

Parameters

externalProductId
Type: SystemString
The external product ID.
divisionIds
Type: System.Collections.GenericIEnumerable String
The division IDs.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.SaveProductGlobalSpecifications Method

ProductRepositorySaveProductGlobalSpecifications Method
Saves the product specifications.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void SaveProductGlobalSpecifications(
    string externalProductId,
    IDictionary<ID, Specification> productSpecifications
)
Public Overridable Sub SaveProductGlobalSpecifications (
    externalProductId As String,
    productSpecifications As IDictionary(Of ID, Specification)
)
public:
virtual void SaveProductGlobalSpecifications(
    String^ externalProductId,
    IDictionary<ID^, Specification^>^ productSpecifications
)
abstract SaveProductGlobalSpecifications :
        externalProductId : string *
        productSpecifications : IDictionary<ID, Specification> -> unit
override SaveProductGlobalSpecifications :
        externalProductId : string *
        productSpecifications : IDictionary<ID, Specification> -> unit

Parameters

externalProductId
Type: SystemString
The external product ID.
productSpecifications
Type: System.Collections.GenericIDictionary ID, Specification
The product specifications dictionary. Contains ID of related specification item in key and Specification entity in value.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.SaveProductManufacturers Method

ProductRepositorySaveProductManufacturers Method
Saves the product manufacturers.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void SaveProductManufacturers(
    string externalProductId,
    IEnumerable<string> manufacturerIds
)
Public Overridable Sub SaveProductManufacturers (
    externalProductId As String,
    manufacturerIds As IEnumerable(Of String)
)
public:
virtual void SaveProductManufacturers(
    String^ externalProductId,
    IEnumerable<String^>^ manufacturerIds
)
abstract SaveProductManufacturers :
        externalProductId : string *
        manufacturerIds : IEnumerable<string> -> unit
override SaveProductManufacturers :
        externalProductId : string *
        manufacturerIds : IEnumerable<string> -> unit

Parameters

externalProductId
Type: SystemString
The external product ID.
manufacturerIds
Type: System.Collections.GenericIEnumerable String
The manufacturer IDs.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.SaveProductRelations Method

ProductRepositorySaveProductRelations Method
Saves the product relations.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void SaveProductRelations(
    string externalProductId,
    IEnumerable<RelationType> relationTypes
)
Public Overridable Sub SaveProductRelations (
    externalProductId As String,
    relationTypes As IEnumerable(Of RelationType)
)
public:
virtual void SaveProductRelations(
    String^ externalProductId,
    IEnumerable<RelationType^>^ relationTypes
)
abstract SaveProductRelations :
        externalProductId : string *
        relationTypes : IEnumerable<RelationType> -> unit
override SaveProductRelations :
        externalProductId : string *
        relationTypes : IEnumerable<RelationType> -> unit

Parameters

externalProductId
Type: SystemString
The external product ID.
relationTypes
Type: System.Collections.GenericIEnumerable RelationType
The relation types.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.SaveProductResources Method

ProductRepositorySaveProductResources Method
Saves the product resources.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void SaveProductResources(
    string externalProductId,
    IEnumerable<ProductResource> productResources
)
Public Overridable Sub SaveProductResources (
    externalProductId As String,
    productResources As IEnumerable(Of ProductResource)
)
public:
virtual void SaveProductResources(
    String^ externalProductId,
    IEnumerable<ProductResource^>^ productResources
)
abstract SaveProductResources :
        externalProductId : string *
        productResources : IEnumerable<ProductResource> -> unit
override SaveProductResources :
        externalProductId : string *
        productResources : IEnumerable<ProductResource> -> unit

Parameters

externalProductId
Type: SystemString
The external product ID.
productResources
Type: System.Collections.GenericIEnumerable ProductResource
The product resources.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.SaveProductTypes Method

ProductRepositorySaveProductTypes Method
Saves the product types.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void SaveProductTypes(
    string externalProductId,
    IEnumerable<string> productTypeIds
)
Public Overridable Sub SaveProductTypes (
    externalProductId As String,
    productTypeIds As IEnumerable(Of String)
)
public:
virtual void SaveProductTypes(
    String^ externalProductId,
    IEnumerable<String^>^ productTypeIds
)
abstract SaveProductTypes :
        externalProductId : string *
        productTypeIds : IEnumerable<string> -> unit
override SaveProductTypes :
        externalProductId : string *
        productTypeIds : IEnumerable<string> -> unit

Parameters

externalProductId
Type: SystemString
The external product ID.
productTypeIds
Type: System.Collections.GenericIEnumerable String
The product type IDs.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.SaveProductTypeSpecifications Method

ProductRepositorySaveProductTypeSpecifications Method
Saves the product type specifications.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void SaveProductTypeSpecifications(
    string externalProductId,
    IDictionary<ID, Specification> productSpecifications
)
Public Overridable Sub SaveProductTypeSpecifications (
    externalProductId As String,
    productSpecifications As IDictionary(Of ID, Specification)
)
public:
virtual void SaveProductTypeSpecifications(
    String^ externalProductId,
    IDictionary<ID^, Specification^>^ productSpecifications
)
abstract SaveProductTypeSpecifications :
        externalProductId : string *
        productSpecifications : IDictionary<ID, Specification> -> unit
override SaveProductTypeSpecifications :
        externalProductId : string *
        productSpecifications : IDictionary<ID, Specification> -> unit

Parameters

externalProductId
Type: SystemString
The external product identifier.
productSpecifications
Type: System.Collections.GenericIDictionary ID, Specification
The product specifications.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.UpdateEntityItem Method

ProductRepositoryUpdateEntityItem Method
Updates the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void UpdateEntityItem(
    Item entityItem,
    Product entity
)
Protected Overrides Sub UpdateEntityItem (
    entityItem As Item,
    entity As Product
)
protected:
virtual void UpdateEntityItem(
    Item^ entityItem,
    Product^ entity
) override
abstract UpdateEntityItem :
        entityItem : Item *
        entity : Product -> unit
override UpdateEntityItem :
        entityItem : Item *
        entity : Product -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: Sitecore.Commerce.Entities.ProductsProduct
The entity.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository Properties

ProductRepository Properties

The ProductRepository type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Public property | ClassificationsRepository | Gets or sets the classifications repository.
Public property | ClassificationsSpecificationsRepository | Gets or sets the classifications specifications repository.
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | DivisionRepository | Gets or sets the division repository.
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | GlobalSpecificationsRepository | Gets or sets the specifications repository.
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | ManufacturerRepository | Gets or sets the manufacturer repository.
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | ProductsIndex | Gets or sets the index of the products.
Public property | RelationsRepository | Gets or sets the relations repository.
Public property | ResourcesRepository | Gets or sets the resources repository.
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Public property | TypeRepository | Gets or sets the type repository.
Public property | TypeSpecificationsRepository | Gets or sets the type specifications repository.
Top
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.ClassificationsRepository Property

ProductRepositoryClassificationsRepository Property
Gets or sets the classifications repository.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IProductRelatedEntityRepository<ClassificationGroup> ClassificationsRepository { get; set; }
Public Property ClassificationsRepository As IProductRelatedEntityRepository(Of ClassificationGroup)
    Get
    Set
public:
property IProductRelatedEntityRepository<ClassificationGroup^>^ ClassificationsRepository {
    IProductRelatedEntityRepository<ClassificationGroup^>^ get ();
    void set (IProductRelatedEntityRepository<ClassificationGroup^>^ value);
}
member ClassificationsRepository : IProductRelatedEntityRepository<ClassificationGroup> with get, set

Property Value

Type: IProductRelatedEntityRepository ClassificationGroup
The classifications repository.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.ClassificationsSpecificationsRepository Property

ProductRepositoryClassificationsSpecificationsRepository Property
Gets or sets the classifications specifications repository.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IProductRelatedEntityRepository<KeyValuePair<ID, Specification>> ClassificationsSpecificationsRepository { get; set; }
Public Property ClassificationsSpecificationsRepository As IProductRelatedEntityRepository(Of KeyValuePair(Of ID, Specification))
    Get
    Set
public:
property IProductRelatedEntityRepository<KeyValuePair<ID^, Specification^>>^ ClassificationsSpecificationsRepository {
    IProductRelatedEntityRepository<KeyValuePair<ID^, Specification^>>^ get ();
    void set (IProductRelatedEntityRepository<KeyValuePair<ID^, Specification^>>^ value);
}
member ClassificationsSpecificationsRepository : IProductRelatedEntityRepository<KeyValuePair<ID, Specification>> with get, set

Property Value

Type: IProductRelatedEntityRepository KeyValuePair ID, Specification
The classifications specifications repository.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.DivisionRepository Property

ProductRepositoryDivisionRepository Property
Gets or sets the division repository.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IProductRelatedEntityRepository<string> DivisionRepository { get; set; }
Public Property DivisionRepository As IProductRelatedEntityRepository(Of String)
    Get
    Set
public:
property IProductRelatedEntityRepository<String^>^ DivisionRepository {
    IProductRelatedEntityRepository<String^>^ get ();
    void set (IProductRelatedEntityRepository<String^>^ value);
}
member DivisionRepository : IProductRelatedEntityRepository<string> with get, set

Property Value

Type: IProductRelatedEntityRepository String
The division repository.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.GlobalSpecificationsRepository Property

ProductRepositoryGlobalSpecificationsRepository Property
Gets or sets the specifications repository.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IProductRelatedEntityRepository<KeyValuePair<ID, Specification>> GlobalSpecificationsRepository { get; set; }
Public Property GlobalSpecificationsRepository As IProductRelatedEntityRepository(Of KeyValuePair(Of ID, Specification))
    Get
    Set
public:
property IProductRelatedEntityRepository<KeyValuePair<ID^, Specification^>>^ GlobalSpecificationsRepository {
    IProductRelatedEntityRepository<KeyValuePair<ID^, Specification^>>^ get ();
    void set (IProductRelatedEntityRepository<KeyValuePair<ID^, Specification^>>^ value);
}
member GlobalSpecificationsRepository : IProductRelatedEntityRepository<KeyValuePair<ID, Specification>> with get, set

Property Value

Type: IProductRelatedEntityRepository KeyValuePair ID, Specification
The specifications repository.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.ManufacturerRepository Property

ProductRepositoryManufacturerRepository Property
Gets or sets the manufacturer repository.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IProductRelatedEntityRepository<string> ManufacturerRepository { get; set; }
Public Property ManufacturerRepository As IProductRelatedEntityRepository(Of String)
    Get
    Set
public:
property IProductRelatedEntityRepository<String^>^ ManufacturerRepository {
    IProductRelatedEntityRepository<String^>^ get ();
    void set (IProductRelatedEntityRepository<String^>^ value);
}
member ManufacturerRepository : IProductRelatedEntityRepository<string> with get, set

Property Value

Type: IProductRelatedEntityRepository String
The manufacturer repository.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.ProductsIndex Property

ProductRepositoryProductsIndex Property
Gets or sets the index of the products.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ProductsIndex { get; set; }
Public Property ProductsIndex As String
    Get
    Set
public:
property String^ ProductsIndex {
    String^ get ();
    void set (String^ value);
}
member ProductsIndex : string with get, set

Property Value

Type: String
The index of the products.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.RelationsRepository Property

ProductRepositoryRelationsRepository Property
Gets or sets the relations repository.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IProductRelatedEntityRepository<RelationType> RelationsRepository { get; set; }
Public Property RelationsRepository As IProductRelatedEntityRepository(Of RelationType)
    Get
    Set
public:
property IProductRelatedEntityRepository<RelationType^>^ RelationsRepository {
    IProductRelatedEntityRepository<RelationType^>^ get ();
    void set (IProductRelatedEntityRepository<RelationType^>^ value);
}
member RelationsRepository : IProductRelatedEntityRepository<RelationType> with get, set

Property Value

Type: IProductRelatedEntityRepository RelationType
The relations repository.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.ResourcesRepository Property

ProductRepositoryResourcesRepository Property
Gets or sets the resources repository.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IProductRelatedEntityRepository<ProductResource> ResourcesRepository { get; set; }
Public Property ResourcesRepository As IProductRelatedEntityRepository(Of ProductResource)
    Get
    Set
public:
property IProductRelatedEntityRepository<ProductResource^>^ ResourcesRepository {
    IProductRelatedEntityRepository<ProductResource^>^ get ();
    void set (IProductRelatedEntityRepository<ProductResource^>^ value);
}
member ResourcesRepository : IProductRelatedEntityRepository<ProductResource> with get, set

Property Value

Type: IProductRelatedEntityRepository ProductResource
The resources repository.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.TypeRepository Property

ProductRepositoryTypeRepository Property
Gets or sets the type repository.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IProductRelatedEntityRepository<string> TypeRepository { get; set; }
Public Property TypeRepository As IProductRelatedEntityRepository(Of String)
    Get
    Set
public:
property IProductRelatedEntityRepository<String^>^ TypeRepository {
    IProductRelatedEntityRepository<String^>^ get ();
    void set (IProductRelatedEntityRepository<String^>^ value);
}
member TypeRepository : IProductRelatedEntityRepository<string> with get, set

Property Value

Type: IProductRelatedEntityRepository String
The type repository.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductRepository.TypeSpecificationsRepository Property

ProductRepositoryTypeSpecificationsRepository Property
Gets or sets the type specifications repository.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IProductRelatedEntityRepository<KeyValuePair<ID, Specification>> TypeSpecificationsRepository { get; set; }
Public Property TypeSpecificationsRepository As IProductRelatedEntityRepository(Of KeyValuePair(Of ID, Specification))
    Get
    Set
public:
property IProductRelatedEntityRepository<KeyValuePair<ID^, Specification^>>^ TypeSpecificationsRepository {
    IProductRelatedEntityRepository<KeyValuePair<ID^, Specification^>>^ get ();
    void set (IProductRelatedEntityRepository<KeyValuePair<ID^, Specification^>>^ value);
}
member TypeSpecificationsRepository : IProductRelatedEntityRepository<KeyValuePair<ID, Specification>> with get, set

Property Value

Type: IProductRelatedEntityRepository KeyValuePair ID, Specification
The type specifications repository.
See Also

Reference

ProductRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductResourcesRepository Class

ProductResourcesRepository Class
The product resource repository.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository ProductResource
Sitecore.Commerce.Data.ProductsProductItemRepositoryBase ProductResource
Sitecore.Commerce.Data.ProductsProductResourcesRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ProductResourcesRepository : ProductItemRepositoryBase<ProductResource>
Public Class ProductResourcesRepository
    Inherits ProductItemRepositoryBase(Of ProductResource)
public ref class ProductResourcesRepository : public ProductItemRepositoryBase<ProductResource^>
type ProductResourcesRepository =
    class
        inherit ProductItemRepositoryBase<ProductResource>
    end

The ProductResourcesRepository type exposes the following members.

Constructors
 | Name | Description
Public method | ProductResourcesRepository | Initializes a new instance of the ProductResourcesRepository class.
Top
Methods
 | Name | Description
Protected method | CreateOrUpdateEntity | Creates or updates the entity. (Overrides ProductItemRepositoryBaseTEntityCreateOrUpdateEntity(String, TEntity, Item, Item, Item).)
Protected method | DeleteObsoleteEntityItems | Deletes the obsolete entity items. (Inherited from ProductItemRepositoryBaseTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetTypesRootItem | Gets the types root item. (Overrides ProductItemRepositoryBaseTEntityGetTypesRootItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveProductEntities | Saves the product artifacts sub-items of the product item sub-folders and Removes all obsolete sub-items after every round of the synchronization. (Inherited from ProductItemRepositoryBaseTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | ProductPrefix | The product prefix. (Inherited from ProductItemRepositoryBaseTEntity.)
Top
Properties
 | Name | Description
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


ProductResourcesRepository Constructor

ProductResourcesRepository Constructor
Initializes a new instance of the ProductResourcesRepository class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductResourcesRepository(
    string productFolderName,
    string productPrefix,
    string productEntityTemplateId,
    string productResourceTypesRootItemId,
    string resourcePrefix
)
Public Sub New (
    productFolderName As String,
    productPrefix As String,
    productEntityTemplateId As String,
    productResourceTypesRootItemId As String,
    resourcePrefix As String
)
public:
ProductResourcesRepository(
    String^ productFolderName,
    String^ productPrefix,
    String^ productEntityTemplateId,
    String^ productResourceTypesRootItemId,
    String^ resourcePrefix
)
new :
        productFolderName : string *
        productPrefix : string *
        productEntityTemplateId : string *
        productResourceTypesRootItemId : string *
        resourcePrefix : string -> ProductResourcesRepository

Parameters

productFolderName
Type: SystemString
Name of the product folder.
productPrefix
Type: SystemString
The product prefix.
productEntityTemplateId
Type: SystemString
The product entity template id.
productResourceTypesRootItemId
Type: SystemString
The product resource types root item id.
resourcePrefix
Type: SystemString
The resource prefix.
See Also

Reference

ProductResourcesRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductResourcesRepository Fields

ProductResourcesRepository Fields

The ProductResourcesRepository type exposes the following members.

Fields
 | Name | Description
Protected field | ProductPrefix | The product prefix. (Inherited from ProductItemRepositoryBaseTEntity.)
Top
See Also

Reference

ProductResourcesRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductResourcesRepository Methods

ProductResourcesRepository Methods

The ProductResourcesRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateOrUpdateEntity | Creates or updates the entity. (Overrides ProductItemRepositoryBaseTEntityCreateOrUpdateEntity(String, TEntity, Item, Item, Item).)
Protected method | DeleteObsoleteEntityItems | Deletes the obsolete entity items. (Inherited from ProductItemRepositoryBaseTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetTypesRootItem | Gets the types root item. (Overrides ProductItemRepositoryBaseTEntityGetTypesRootItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveProductEntities | Saves the product artifacts sub-items of the product item sub-folders and Removes all obsolete sub-items after every round of the synchronization. (Inherited from ProductItemRepositoryBaseTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductResourcesRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductResourcesRepository.CreateOrUpdateEntity Method

ProductResourcesRepositoryCreateOrUpdateEntity Method
Creates or updates the entity.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override Item CreateOrUpdateEntity(
    string externalProductId,
    ProductResource entity,
    Item productEntityFolderItem,
    Item productEntityTemplateItem,
    Item entityTypeRootItem
)
Protected Overrides Function CreateOrUpdateEntity (
    externalProductId As String,
    entity As ProductResource,
    productEntityFolderItem As Item,
    productEntityTemplateItem As Item,
    entityTypeRootItem As Item
) As Item
protected:
virtual Item^ CreateOrUpdateEntity(
    String^ externalProductId,
    ProductResource^ entity,
    Item^ productEntityFolderItem,
    Item^ productEntityTemplateItem,
    Item^ entityTypeRootItem
) override
abstract CreateOrUpdateEntity :
        externalProductId : string *
        entity : ProductResource *
        productEntityFolderItem : Item *
        productEntityTemplateItem : Item *
        entityTypeRootItem : Item -> Item
override CreateOrUpdateEntity :
        externalProductId : string *
        entity : ProductResource *
        productEntityFolderItem : Item *
        productEntityTemplateItem : Item *
        entityTypeRootItem : Item -> Item

Parameters

externalProductId
Type: SystemString
The external product id.
entity
Type: Sitecore.Commerce.Entities.ProductsProductResource
The entity.
productEntityFolderItem
Type: Item
The product entity folder item.
productEntityTemplateItem
Type: Item
The product entity template item.
entityTypeRootItem
Type: Item
The entity type root item.

Return Value

Type: Item
Created or updated entity item.
See Also

Reference

ProductResourcesRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductResourcesRepository.GetTypesRootItem Method

ProductResourcesRepositoryGetTypesRootItem Method
Gets the types root item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override Item GetTypesRootItem()
Protected Overrides Function GetTypesRootItem As Item
protected:
virtual Item^ GetTypesRootItem() override
abstract GetTypesRootItem : unit -> Item
override GetTypesRootItem : unit -> Item

Return Value

Type: Item
The entity types root item.
See Also

Reference

ProductResourcesRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductResourcesRepository Properties

ProductResourcesRepository Properties

The ProductResourcesRepository type exposes the following members.

Properties
 | Name | Description
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Top
See Also

Reference

ProductResourcesRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductSpecificationsRepository Class

ProductSpecificationsRepository Class
The product specifications repository.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository KeyValuePair ID, Specification
Sitecore.Commerce.Data.ProductsProductItemRepositoryBase KeyValuePair ID, Specification
Sitecore.Commerce.Data.ProductsProductSpecificationsRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ProductSpecificationsRepository : ProductItemRepositoryBase<KeyValuePair<ID, Specification>>
Public Class ProductSpecificationsRepository
    Inherits ProductItemRepositoryBase(Of KeyValuePair(Of ID, Specification))
public ref class ProductSpecificationsRepository : public ProductItemRepositoryBase<KeyValuePair<ID^, Specification^>>
type ProductSpecificationsRepository =
    class
        inherit ProductItemRepositoryBase<KeyValuePair<ID, Specification>>
    end

The ProductSpecificationsRepository type exposes the following members.

Constructors
 | Name | Description
Public method | ProductSpecificationsRepository | Initializes a new instance of the ProductSpecificationsRepository class.
Top
Methods
 | Name | Description
Protected method | CreateOrUpdateEntity | Creates or updates the entity. (Overrides ProductItemRepositoryBaseTEntityCreateOrUpdateEntity(String, TEntity, Item, Item, Item).)
Protected method | DeleteObsoleteEntityItems | Deletes the obsolete entity items. (Inherited from ProductItemRepositoryBaseTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetTypesRootItem | Gets the types root item. (Inherited from ProductItemRepositoryBaseTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveProductEntities | Saves the product artifacts sub-items of the product item sub-folders and Removes all obsolete sub-items after every round of the synchronization. (Inherited from ProductItemRepositoryBaseTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | ProductPrefix | The product prefix. (Inherited from ProductItemRepositoryBaseTEntity.)
Top
Properties
 | Name | Description
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


ProductSpecificationsRepository Constructor

ProductSpecificationsRepository Constructor
Initializes a new instance of the ProductSpecificationsRepository class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductSpecificationsRepository(
    string productFolderName,
    string productPrefix,
    string productEntityTemplateId
)
Public Sub New (
    productFolderName As String,
    productPrefix As String,
    productEntityTemplateId As String
)
public:
ProductSpecificationsRepository(
    String^ productFolderName,
    String^ productPrefix,
    String^ productEntityTemplateId
)
new :
        productFolderName : string *
        productPrefix : string *
        productEntityTemplateId : string -> ProductSpecificationsRepository

Parameters

productFolderName
Type: SystemString
Name of the product folder.
productPrefix
Type: SystemString
The product prefix.
productEntityTemplateId
Type: SystemString
The product entity template id.
See Also

Reference

ProductSpecificationsRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductSpecificationsRepository Fields

ProductSpecificationsRepository Fields

The ProductSpecificationsRepository type exposes the following members.

Fields
 | Name | Description
Protected field | ProductPrefix | The product prefix. (Inherited from ProductItemRepositoryBaseTEntity.)
Top
See Also

Reference

ProductSpecificationsRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductSpecificationsRepository Methods

ProductSpecificationsRepository Methods

The ProductSpecificationsRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateOrUpdateEntity | Creates or updates the entity. (Overrides ProductItemRepositoryBaseTEntityCreateOrUpdateEntity(String, TEntity, Item, Item, Item).)
Protected method | DeleteObsoleteEntityItems | Deletes the obsolete entity items. (Inherited from ProductItemRepositoryBaseTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetTypesRootItem | Gets the types root item. (Inherited from ProductItemRepositoryBaseTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveProductEntities | Saves the product artifacts sub-items of the product item sub-folders and Removes all obsolete sub-items after every round of the synchronization. (Inherited from ProductItemRepositoryBaseTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductSpecificationsRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductSpecificationsRepository.CreateOrUpdateEntity Method

ProductSpecificationsRepositoryCreateOrUpdateEntity Method
Creates or updates the entity.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override Item CreateOrUpdateEntity(
    string externalProductId,
    KeyValuePair<ID, Specification> entity,
    Item productEntityFolderItem,
    Item productEntityTemplateItem,
    Item entityTypeRootItem
)
Protected Overrides Function CreateOrUpdateEntity (
    externalProductId As String,
    entity As KeyValuePair(Of ID, Specification),
    productEntityFolderItem As Item,
    productEntityTemplateItem As Item,
    entityTypeRootItem As Item
) As Item
protected:
virtual Item^ CreateOrUpdateEntity(
    String^ externalProductId,
    KeyValuePair<ID^, Specification^> entity,
    Item^ productEntityFolderItem,
    Item^ productEntityTemplateItem,
    Item^ entityTypeRootItem
) override
abstract CreateOrUpdateEntity :
        externalProductId : string *
        entity : KeyValuePair<ID, Specification> *
        productEntityFolderItem : Item *
        productEntityTemplateItem : Item *
        entityTypeRootItem : Item -> Item
override CreateOrUpdateEntity :
        externalProductId : string *
        entity : KeyValuePair<ID, Specification> *
        productEntityFolderItem : Item *
        productEntityTemplateItem : Item *
        entityTypeRootItem : Item -> Item

Parameters

externalProductId
Type: SystemString
The external product id.
entity
Type: System.Collections.GenericKeyValuePair ID, Specification
The entity.
productEntityFolderItem
Type: Item
The product entity folder item.
productEntityTemplateItem
Type: Item
The product entity template item.
entityTypeRootItem
Type: Item
The entity type root item.

Return Value

Type: Item
Created or updated entity item.
See Also

Reference

ProductSpecificationsRepository Class
Sitecore.Commerce.Data.Products Namespace


ProductSpecificationsRepository Properties

ProductSpecificationsRepository Properties

The ProductSpecificationsRepository type exposes the following members.

Properties
 | Name | Description
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Top
See Also

Reference

ProductSpecificationsRepository Class
Sitecore.Commerce.Data.Products Namespace


ResourceRepository Class

ResourceRepository Class
Represents the repository that saves resources as items in the Media Library. This class:
  • Receives the stream of bytes that define a resource. This stream contains the name and the MIME-type of a resource.
  • Generates different types of items according to the MIME-type of the resource.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository Resource
Sitecore.Commerce.Data.ProductsArtifactRepository Resource
Sitecore.Commerce.Data.ProductsResourceRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ResourceRepository : ArtifactRepository<Resource>
Public Class ResourceRepository
    Inherits ArtifactRepository(Of Resource)
public ref class ResourceRepository : public ArtifactRepository<Resource^>
type ResourceRepository =
    class
        inherit ArtifactRepository<Resource>
    end

The ResourceRepository type exposes the following members.

Constructors
 | Name | Description
Public method | ResourceRepository | Initializes an instance of the ResourceRepository class.
Top
Methods
Name Description
Protected method CreateEntityItem
Creates the entity item.
(Inherited from ArtifactRepositoryTEntity.)
Public method DeleteItem
Deletes the item.
(Inherited from ArtifactRepositoryTEntity.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Protected method Get(Item)
Gets entity from corresponding item.
(Inherited from ArtifactRepositoryTEntity.)
Public method Get(String)
Gets the specified entity identifier.
(Inherited from ArtifactRepositoryTEntity.)
Public method GetEntities
Gets the list of entities.
(Inherited from ArtifactRepositoryTEntity.)
Public method GetEntities(Item)
Gets the list of entities under the specified root.
(Inherited from ArtifactRepositoryTEntity.)
Protected method GetEntityItem
Gets the entity item.
(Inherited from ArtifactRepositoryTEntity.)
Protected method GetEntityItemId
Gets the entity item id.
(Inherited from ArtifactRepositoryTEntity.)
Protected method GetEntityItemImmediateRoot
Gets the entity item immediate root.
(Inherited from ArtifactRepositoryTEntity.)
Protected method GetEntityItemName
Gets the name of the entity item.
(Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method GetEntityItems
Gets entity items under the repository root.
(Inherited from ArtifactRepositoryTEntity.)
Protected method GetEntityItemTemplateId
Gets the entity item template id.
(Inherited from ArtifactRepositoryTEntity.)
Protected method GetEntityKey
Gets the entity key.
(Inherited from ArtifactRepositoryTEntity.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Protected method GetRepositoryRootItem
Gets the repository root item.
(Inherited from ArtifactRepositoryTEntity.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method InstantiateEntity
Instantiates the entity.
(Inherited from ArtifactRepositoryTEntity.)
Protected method IsValid
Determines whether the specified root is valid.
(Inherited from ArtifactRepositoryTEntity.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method MoveItemIntoBucket
Moves the item into bucket.
(Inherited from ArtifactRepositoryTEntity.)
Protected method MoveToImmediateRoot
Moves to immediate root.
(Inherited from ArtifactRepositoryTEntity.)
Protected method PopulateEntity
Fills the entity.
(Inherited from ArtifactRepositoryTEntity.)
Protected method ProcessEntityItem
Processes the entity item.
(Overrides ArtifactRepositoryTEntityProcessEntityItem(Item, TEntity).)
Public method Save(Resource)
Saves the resource as an item in the Media Library. This class:
  • Receives the stream of bytes that define a resource. This stream contains the name and the MIME-type of a resource.
  • Generates different types of items according to the MIME-type of the resource.
(Overrides ArtifactRepositoryTEntitySave(TEntity).)
Public method Save(Item, TEntity)
Saves the specified root.
(Inherited from ArtifactRepositoryTEntity.)
Public method Save(TEntity, Boolean)
Saves the specified entity.
(Inherited from ArtifactRepositoryTEntity.)
Public method Save(Item, TEntity, Boolean)
Saves the specified root.
(Inherited from ArtifactRepositoryTEntity.)
Protected method SetEntityItemStatistics
Sets the entity item statistics.
(Inherited from ArtifactRepositoryTEntity.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Protected method UpdateEntityItem
Updates the entity item.
(Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


ResourceRepository Constructor

ResourceRepository Constructor
Initializes an instance of the ResourceRepository class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ResourceRepository(
    MediaProvider mediaProvider
)
Public Sub New (
    mediaProvider As MediaProvider
)
public:
ResourceRepository(
    MediaProvider^ mediaProvider
)
new :
        mediaProvider : MediaProvider -> ResourceRepository

Parameters

mediaProvider
Type: MediaProvider
The media provider
See Also

Reference

ResourceRepository Class
Sitecore.Commerce.Data.Products Namespace


ResourceRepository Methods

ResourceRepository Methods

The ResourceRepository type exposes the following members.

Methods
Name Description
Protected method CreateEntityItem
Creates the entity item.
(Inherited from ArtifactRepositoryTEntity.)
Public method DeleteItem
Deletes the item.
(Inherited from ArtifactRepositoryTEntity.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Protected method Get(Item)
Gets entity from corresponding item.
(Inherited from ArtifactRepositoryTEntity.)
Public method Get(String)
Gets the specified entity identifier.
(Inherited from ArtifactRepositoryTEntity.)
Public method GetEntities
Gets the list of entities.
(Inherited from ArtifactRepositoryTEntity.)
Public method GetEntities(Item)
Gets the list of entities under the specified root.
(Inherited from ArtifactRepositoryTEntity.)
Protected method GetEntityItem
Gets the entity item.
(Inherited from ArtifactRepositoryTEntity.)
Protected method GetEntityItemId
Gets the entity item id.
(Inherited from ArtifactRepositoryTEntity.)
Protected method GetEntityItemImmediateRoot
Gets the entity item immediate root.
(Inherited from ArtifactRepositoryTEntity.)
Protected method GetEntityItemName
Gets the name of the entity item.
(Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method GetEntityItems
Gets entity items under the repository root.
(Inherited from ArtifactRepositoryTEntity.)
Protected method GetEntityItemTemplateId
Gets the entity item template id.
(Inherited from ArtifactRepositoryTEntity.)
Protected method GetEntityKey
Gets the entity key.
(Inherited from ArtifactRepositoryTEntity.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Protected method GetRepositoryRootItem
Gets the repository root item.
(Inherited from ArtifactRepositoryTEntity.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method InstantiateEntity
Instantiates the entity.
(Inherited from ArtifactRepositoryTEntity.)
Protected method IsValid
Determines whether the specified root is valid.
(Inherited from ArtifactRepositoryTEntity.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method MoveItemIntoBucket
Moves the item into bucket.
(Inherited from ArtifactRepositoryTEntity.)
Protected method MoveToImmediateRoot
Moves to immediate root.
(Inherited from ArtifactRepositoryTEntity.)
Protected method PopulateEntity
Fills the entity.
(Inherited from ArtifactRepositoryTEntity.)
Protected method ProcessEntityItem
Processes the entity item.
(Overrides ArtifactRepositoryTEntityProcessEntityItem(Item, TEntity).)
Public method Save(Resource)
Saves the resource as an item in the Media Library. This class:
  • Receives the stream of bytes that define a resource. This stream contains the name and the MIME-type of a resource.
  • Generates different types of items according to the MIME-type of the resource.
(Overrides ArtifactRepositoryTEntitySave(TEntity).)
Public method Save(Item, TEntity)
Saves the specified root.
(Inherited from ArtifactRepositoryTEntity.)
Public method Save(TEntity, Boolean)
Saves the specified entity.
(Inherited from ArtifactRepositoryTEntity.)
Public method Save(Item, TEntity, Boolean)
Saves the specified root.
(Inherited from ArtifactRepositoryTEntity.)
Protected method SetEntityItemStatistics
Sets the entity item statistics.
(Inherited from ArtifactRepositoryTEntity.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Protected method UpdateEntityItem
Updates the entity item.
(Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
See Also

Reference

ResourceRepository Class
Sitecore.Commerce.Data.Products Namespace


ResourceRepository.GetEntityItemName Method

ResourceRepositoryGetEntityItemName Method
Gets the name of the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetEntityItemName(
    Item root,
    Resource entity
)
Protected Overrides Function GetEntityItemName (
    root As Item,
    entity As Resource
) As String
protected:
virtual String^ GetEntityItemName(
    Item^ root,
    Resource^ entity
) override
abstract GetEntityItemName :
        root : Item *
        entity : Resource -> string
override GetEntityItemName :
        root : Item *
        entity : Resource -> string

Parameters

root
Type: Item
The root.
entity
Type: Sitecore.Commerce.Entities.ProductsResource
The entity.

Return Value

Type: String
Entity name.
See Also

Reference

ResourceRepository Class
Sitecore.Commerce.Data.Products Namespace


ResourceRepository.ProcessEntityItem Method

ResourceRepositoryProcessEntityItem Method
Processes the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override Item ProcessEntityItem(
    Item entityItem,
    Resource entity
)
Protected Overrides Function ProcessEntityItem (
    entityItem As Item,
    entity As Resource
) As Item
protected:
virtual Item^ ProcessEntityItem(
    Item^ entityItem,
    Resource^ entity
) override
abstract ProcessEntityItem :
        entityItem : Item *
        entity : Resource -> Item
override ProcessEntityItem :
        entityItem : Item *
        entity : Resource -> Item

Parameters

entityItem
Type: Item
The entity item.
entity
Type: Sitecore.Commerce.Entities.ProductsResource
The entity.

Return Value

Type: Item
The result of entity item processing.
See Also

Reference

ResourceRepository Class
Sitecore.Commerce.Data.Products Namespace


ResourceRepository.Save Method

ResourceRepositorySave Method
Overload List
Name Description
Public method Save(Resource)
Saves the resource as an item in the Media Library. This class:
  • Receives the stream of bytes that define a resource. This stream contains the name and the MIME-type of a resource.
  • Generates different types of items according to the MIME-type of the resource.
(Overrides ArtifactRepositoryTEntitySave(TEntity).)
Public method Save(Item, TEntity)
Saves the specified root.
(Inherited from ArtifactRepositoryTEntity.)
Public method Save(TEntity, Boolean)
Saves the specified entity.
(Inherited from ArtifactRepositoryTEntity.)
Public method Save(Item, TEntity, Boolean)
Saves the specified root.
(Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

ResourceRepository Class
Sitecore.Commerce.Data.Products Namespace


ResourceRepository.Save Method (Resource)

ResourceRepositorySave Method (Resource)
Saves the resource as an item in the Media Library. This class:
  • Receives the stream of bytes that define a resource. This stream contains the name and the MIME-type of a resource.
  • Generates different types of items according to the MIME-type of the resource.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override Resource Save(
    Resource resource
)
Public Overrides Function Save (
    resource As Resource
) As Resource
public:
virtual Resource^ Save(
    Resource^ resource
) override
abstract Save :
        resource : Resource -> Resource
override Save :
        resource : Resource -> Resource

Parameters

resource
Type: Sitecore.Commerce.Entities.ProductsResource
The resource

Return Value

Type: Resource
The Resource object.
See Also

Reference

ResourceRepository Class
Save Overload
Sitecore.Commerce.Data.Products Namespace


ResourceRepository.UpdateEntityItem Method

ResourceRepositoryUpdateEntityItem Method
Updates the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void UpdateEntityItem(
    Item entityItem,
    Resource entity
)
Protected Overrides Sub UpdateEntityItem (
    entityItem As Item,
    entity As Resource
)
protected:
virtual void UpdateEntityItem(
    Item^ entityItem,
    Resource^ entity
) override
abstract UpdateEntityItem :
        entityItem : Item *
        entity : Resource -> unit
override UpdateEntityItem :
        entityItem : Item *
        entity : Resource -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: Sitecore.Commerce.Entities.ProductsResource
The entity.
See Also

Reference

ResourceRepository Class
Sitecore.Commerce.Data.Products Namespace


ResourceRepository Properties

ResourceRepository Properties

The ResourceRepository type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

ResourceRepository Class
Sitecore.Commerce.Data.Products Namespace


ResourceTypes Class

ResourceTypes Class
Presents the constant values of the different types of the product resources. These constant values can be:
  • Images in the Media Library. In this case, the constant value is Image.
  • Non-image items in the Media Library, such as .zip and .pdf files. In this case, the constant value is Download.
The links to the external resources are also defined as downloads.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsResourceTypes

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class ResourceTypes
Public NotInheritable Class ResourceTypes
public ref class ResourceTypes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ResourceTypes =  class end

The ResourceTypes type exposes the following members.

Fields
Name | Description
Download | The resource type: a download files, such as .zip and .pdf files.
Image | The resource type: image in Media Library.
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


ResourceTypes Fields

ResourceTypes Fields

The ResourceTypes type exposes the following members.

Fields
Name | Description
Download | The resource type: a download files, such as .zip and .pdf files.
Image | The resource type: image in Media Library.
Top
See Also

Reference

ResourceTypes Class
Sitecore.Commerce.Data.Products Namespace


ResourceTypes.Download Field

ResourceTypesDownload Field
The resource type: a download files, such as .zip and .pdf files.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string Download
Public Const Download As String
public:
literal String^ Download
static val mutable Download: string

Field Value

Type: String
See Also

Reference

ResourceTypes Class
Sitecore.Commerce.Data.Products Namespace


ResourceTypes.Image Field

ResourceTypesImage Field
The resource type: image in Media Library.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string Image
Public Const Image As String
public:
literal String^ Image
static val mutable Image: string

Field Value

Type: String
See Also

Reference

ResourceTypes Class
Sitecore.Commerce.Data.Products Namespace


SpecificationOptionRepository Class

SpecificationOptionRepository Class
Defines the repository that is able to save global specification options.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository GlobalSpecificationOption
Sitecore.Commerce.Data.ProductsArtifactRepository GlobalSpecificationOption
Sitecore.Commerce.Data.ProductsSpecificationOptionRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SpecificationOptionRepository : ArtifactRepository<GlobalSpecificationOption>
Public Class SpecificationOptionRepository
    Inherits ArtifactRepository(Of GlobalSpecificationOption)
public ref class SpecificationOptionRepository : public ArtifactRepository<GlobalSpecificationOption^>
type SpecificationOptionRepository =
    class
        inherit ArtifactRepository<GlobalSpecificationOption>
    end

The SpecificationOptionRepository type exposes the following members.

Constructors
 | Name | Description
Public method | SpecificationOptionRepository | Initializes a new instance of the SpecificationOptionRepository class
Top
Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Overrides ArtifactRepositoryTEntityGetEntityItemId(Item, String).)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


SpecificationOptionRepository Constructor

SpecificationOptionRepository Constructor
Initializes a new instance of the SpecificationOptionRepository class

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SpecificationOptionRepository()
Public Sub New
public:
SpecificationOptionRepository()
new : unit -> SpecificationOptionRepository
See Also

Reference

SpecificationOptionRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationOptionRepository Methods

SpecificationOptionRepository Methods

The SpecificationOptionRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Overrides ArtifactRepositoryTEntityGetEntityItemId(Item, String).)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
See Also

Reference

SpecificationOptionRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationOptionRepository.GetEntityItemId Method

SpecificationOptionRepositoryGetEntityItemId Method
Gets the entity item id.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override ID GetEntityItemId(
    Item root,
    string entityKey
)
Protected Overrides Function GetEntityItemId (
    root As Item,
    entityKey As String
) As ID
protected:
virtual ID^ GetEntityItemId(
    Item^ root,
    String^ entityKey
) override
abstract GetEntityItemId :
        root : Item *
        entityKey : string -> ID
override GetEntityItemId :
        root : Item *
        entityKey : string -> ID

Parameters

root
Type: Item
The root.
entityKey
Type: SystemString
The entity key.

Return Value

Type: ID
Entity item id.
See Also

Reference

SpecificationOptionRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationOptionRepository.GetEntityItemName Method

SpecificationOptionRepositoryGetEntityItemName Method
Gets the name of the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetEntityItemName(
    Item root,
    GlobalSpecificationOption entity
)
Protected Overrides Function GetEntityItemName (
    root As Item,
    entity As GlobalSpecificationOption
) As String
protected:
virtual String^ GetEntityItemName(
    Item^ root,
    GlobalSpecificationOption^ entity
) override
abstract GetEntityItemName :
        root : Item *
        entity : GlobalSpecificationOption -> string
override GetEntityItemName :
        root : Item *
        entity : GlobalSpecificationOption -> string

Parameters

root
Type: Item
The root.
entity
Type: Sitecore.Commerce.Entities.ProductsGlobalSpecificationOption
The entity.

Return Value

Type: String
Entity item name.
See Also

Reference

SpecificationOptionRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationOptionRepository.UpdateEntityItem Method

SpecificationOptionRepositoryUpdateEntityItem Method
Updates the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void UpdateEntityItem(
    Item entityItem,
    GlobalSpecificationOption entity
)
Protected Overrides Sub UpdateEntityItem (
    entityItem As Item,
    entity As GlobalSpecificationOption
)
protected:
virtual void UpdateEntityItem(
    Item^ entityItem,
    GlobalSpecificationOption^ entity
) override
abstract UpdateEntityItem :
        entityItem : Item *
        entity : GlobalSpecificationOption -> unit
override UpdateEntityItem :
        entityItem : Item *
        entity : GlobalSpecificationOption -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: Sitecore.Commerce.Entities.ProductsGlobalSpecificationOption
The entity.
See Also

Reference

SpecificationOptionRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationOptionRepository Properties

SpecificationOptionRepository Properties

The SpecificationOptionRepository type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

SpecificationOptionRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationRepository Class

SpecificationRepository Class
Defines the repository that stores the global product specifications as items in the content tree.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository GlobalSpecification
Sitecore.Commerce.Data.ProductsArtifactRepository GlobalSpecification
Sitecore.Commerce.Data.ProductsSpecificationRepository
Sitecore.Commerce.Data.ProductsParentBasedSpecificationRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SpecificationRepository : ArtifactRepository<GlobalSpecification>
Public Class SpecificationRepository
    Inherits ArtifactRepository(Of GlobalSpecification)
public ref class SpecificationRepository : public ArtifactRepository<GlobalSpecification^>
type SpecificationRepository =
    class
        inherit ArtifactRepository<GlobalSpecification>
    end

The SpecificationRepository type exposes the following members.

Constructors
 | Name | Description
Public method | SpecificationRepository | Initializes an instance of the SpecificationRepository class.
Top
Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template ID. (Overrides ArtifactRepositoryTEntityGetEntityItemTemplateId(Item, TEntity).)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


SpecificationRepository Constructor

SpecificationRepository Constructor
Initializes an instance of the SpecificationRepository class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SpecificationRepository(
    string specificationTemplateId,
    string specificationLookupTemplateId,
    ArtifactRepository<GlobalSpecificationOption> specificationOptionRepository
)
Public Sub New (
    specificationTemplateId As String,
    specificationLookupTemplateId As String,
    specificationOptionRepository As ArtifactRepository(Of GlobalSpecificationOption)
)
public:
SpecificationRepository(
    String^ specificationTemplateId,
    String^ specificationLookupTemplateId,
    ArtifactRepository<GlobalSpecificationOption^>^ specificationOptionRepository
)
new :
        specificationTemplateId : string *
        specificationLookupTemplateId : string *
        specificationOptionRepository : ArtifactRepository<GlobalSpecificationOption> -> SpecificationRepository

Parameters

specificationTemplateId
Type: SystemString
The specification template ID
specificationLookupTemplateId
Type: SystemString
The division template ID
specificationOptionRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository GlobalSpecificationOption
The repository of the specification option
See Also

Reference

SpecificationRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationRepository Methods

SpecificationRepository Methods

The SpecificationRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template ID. (Overrides ArtifactRepositoryTEntityGetEntityItemTemplateId(Item, TEntity).)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
See Also

Reference

SpecificationRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationRepository.GetEntityItemName Method

SpecificationRepositoryGetEntityItemName Method
Gets the name of the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetEntityItemName(
    Item root,
    GlobalSpecification entity
)
Protected Overrides Function GetEntityItemName (
    root As Item,
    entity As GlobalSpecification
) As String
protected:
virtual String^ GetEntityItemName(
    Item^ root,
    GlobalSpecification^ entity
) override
abstract GetEntityItemName :
        root : Item *
        entity : GlobalSpecification -> string
override GetEntityItemName :
        root : Item *
        entity : GlobalSpecification -> string

Parameters

root
Type: Item
The root
entity
Type: Sitecore.Commerce.Entities.ProductsGlobalSpecification
The entity

Return Value

Type: String
Entity item name
See Also

Reference

SpecificationRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationRepository.GetEntityItemTemplateId Method

SpecificationRepositoryGetEntityItemTemplateId Method
Gets the entity item template ID.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override ID GetEntityItemTemplateId(
    Item root,
    GlobalSpecification entity
)
Protected Overrides Function GetEntityItemTemplateId (
    root As Item,
    entity As GlobalSpecification
) As ID
protected:
virtual ID^ GetEntityItemTemplateId(
    Item^ root,
    GlobalSpecification^ entity
) override
abstract GetEntityItemTemplateId :
        root : Item *
        entity : GlobalSpecification -> ID
override GetEntityItemTemplateId :
        root : Item *
        entity : GlobalSpecification -> ID

Parameters

root
Type: Item
The root
entity
Type: Sitecore.Commerce.Entities.ProductsGlobalSpecification
The entity

Return Value

Type: ID
Entity item template name
See Also

Reference

SpecificationRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationRepository.UpdateEntityItem Method

SpecificationRepositoryUpdateEntityItem Method
Updates the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void UpdateEntityItem(
    Item entityItem,
    GlobalSpecification entity
)
Protected Overrides Sub UpdateEntityItem (
    entityItem As Item,
    entity As GlobalSpecification
)
protected:
virtual void UpdateEntityItem(
    Item^ entityItem,
    GlobalSpecification^ entity
) override
abstract UpdateEntityItem :
        entityItem : Item *
        entity : GlobalSpecification -> unit
override UpdateEntityItem :
        entityItem : Item *
        entity : GlobalSpecification -> unit

Parameters

entityItem
Type: Item
The entity item
entity
Type: Sitecore.Commerce.Entities.ProductsGlobalSpecification
The entity
See Also

Reference

SpecificationRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationRepository Properties

SpecificationRepository Properties

The SpecificationRepository type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

SpecificationRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationsRepository Class

SpecificationsRepository Class
Defines the repository that stores global specifications as items in the content tree. The product items can then be linked to specifications items. For more information about the specifications repository, see the Sitecore.Commerce.Products.config file.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository GlobalSpecifications
Sitecore.Commerce.Data.ProductsArtifactRepository GlobalSpecifications
Sitecore.Commerce.Data.ProductsSpecificationsRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SpecificationsRepository : ArtifactRepository<GlobalSpecifications>
Public Class SpecificationsRepository
    Inherits ArtifactRepository(Of GlobalSpecifications)
public ref class SpecificationsRepository : public ArtifactRepository<GlobalSpecifications^>
type SpecificationsRepository =
    class
        inherit ArtifactRepository<GlobalSpecifications>
    end

The SpecificationsRepository type exposes the following members.

Constructors
 | Name | Description
Public method | SpecificationsRepository | Initializes an instance of the SpecificationsRepository class.
Top
Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item ID. (Overrides ArtifactRepositoryTEntityGetEntityItemId(Item, String).)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


SpecificationsRepository Constructor

SpecificationsRepository Constructor
Initializes an instance of the SpecificationsRepository class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SpecificationsRepository(
    string specificationLookupsFolderName,
    ArtifactRepository<GlobalSpecification> globalSpecificationRepository
)
Public Sub New (
    specificationLookupsFolderName As String,
    globalSpecificationRepository As ArtifactRepository(Of GlobalSpecification)
)
public:
SpecificationsRepository(
    String^ specificationLookupsFolderName,
    ArtifactRepository<GlobalSpecification^>^ globalSpecificationRepository
)
new :
        specificationLookupsFolderName : string *
        globalSpecificationRepository : ArtifactRepository<GlobalSpecification> -> SpecificationsRepository

Parameters

specificationLookupsFolderName
Type: SystemString
Name of the specification lookups folder.
globalSpecificationRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository GlobalSpecification
The global specification repository.
See Also

Reference

SpecificationsRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationsRepository Methods

SpecificationsRepository Methods

The SpecificationsRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item ID. (Overrides ArtifactRepositoryTEntityGetEntityItemId(Item, String).)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets entity items under the repository root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
See Also

Reference

SpecificationsRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationsRepository.GetEntityItemId Method

SpecificationsRepositoryGetEntityItemId Method
Gets the entity item ID.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override ID GetEntityItemId(
    Item root,
    string entityKey
)
Protected Overrides Function GetEntityItemId (
    root As Item,
    entityKey As String
) As ID
protected:
virtual ID^ GetEntityItemId(
    Item^ root,
    String^ entityKey
) override
abstract GetEntityItemId :
        root : Item *
        entityKey : string -> ID
override GetEntityItemId :
        root : Item *
        entityKey : string -> ID

Parameters

root
Type: Item
The root
entityKey
Type: SystemString
The entity key

Return Value

Type: ID
The ID for the entity
See Also

Reference

SpecificationsRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationsRepository.GetEntityItemName Method

SpecificationsRepositoryGetEntityItemName Method
Gets the name of the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetEntityItemName(
    Item root,
    GlobalSpecifications entity
)
Protected Overrides Function GetEntityItemName (
    root As Item,
    entity As GlobalSpecifications
) As String
protected:
virtual String^ GetEntityItemName(
    Item^ root,
    GlobalSpecifications^ entity
) override
abstract GetEntityItemName :
        root : Item *
        entity : GlobalSpecifications -> string
override GetEntityItemName :
        root : Item *
        entity : GlobalSpecifications -> string

Parameters

root
Type: Item
The root
entity
Type: Sitecore.Commerce.Entities.ProductsGlobalSpecifications
The entity

Return Value

Type: String
Entity item name
See Also

Reference

SpecificationsRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationsRepository.UpdateEntityItem Method

SpecificationsRepositoryUpdateEntityItem Method
Updates the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void UpdateEntityItem(
    Item entityItem,
    GlobalSpecifications entity
)
Protected Overrides Sub UpdateEntityItem (
    entityItem As Item,
    entity As GlobalSpecifications
)
protected:
virtual void UpdateEntityItem(
    Item^ entityItem,
    GlobalSpecifications^ entity
) override
abstract UpdateEntityItem :
        entityItem : Item *
        entity : GlobalSpecifications -> unit
override UpdateEntityItem :
        entityItem : Item *
        entity : GlobalSpecifications -> unit

Parameters

entityItem
Type: Item
The entity item
entity
Type: Sitecore.Commerce.Entities.ProductsGlobalSpecifications
The entity
See Also

Reference

SpecificationsRepository Class
Sitecore.Commerce.Data.Products Namespace


SpecificationsRepository Properties

SpecificationsRepository Properties

The SpecificationsRepository type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

SpecificationsRepository Class
Sitecore.Commerce.Data.Products Namespace


TypeRepository Class

TypeRepository Class
Defines the repository that you can use to save the types as the items in the content tree. The product items can then be linked to types items. The type can also have type specifications and type default values assigned to it. For more information about the type repository, see the Sitecore.Commerce.Products.config file.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsEntityRepository ProductType
Sitecore.Commerce.Data.ProductsArtifactRepository ProductType
Sitecore.Commerce.Data.ProductsTypeRepository

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TypeRepository : ArtifactRepository<ProductType>
Public Class TypeRepository
    Inherits ArtifactRepository(Of ProductType)
public ref class TypeRepository : public ArtifactRepository<ProductType^>
type TypeRepository =
    class
        inherit ArtifactRepository<ProductType>
    end

The TypeRepository type exposes the following members.

Constructors
 | Name | Description
Public method | TypeRepository | Initializes an instance of the TypeRepository class.
Top
Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Overrides ArtifactRepositoryTEntityGetEntityItemImmediateRoot(Item, TEntity).)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets the entity items under the repository root. (Overrides ArtifactRepositoryTEntityGetEntityItems(Item).)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Overrides ArtifactRepositoryTEntityPopulateEntity(Item, TEntity).)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | SaveDefaultValues | Saves the default values.
Public method | SaveSpecifications | Saves the specifications.
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


TypeRepository Constructor

TypeRepository Constructor
Initializes an instance of the TypeRepository class.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TypeRepository(
    ArtifactRepository<GlobalSpecifications> specificationsRepository,
    ArtifactRepository<ProductSpecifications> defaultValuesRepository
)
Public Sub New (
    specificationsRepository As ArtifactRepository(Of GlobalSpecifications),
    defaultValuesRepository As ArtifactRepository(Of ProductSpecifications)
)
public:
TypeRepository(
    ArtifactRepository<GlobalSpecifications^>^ specificationsRepository,
    ArtifactRepository<ProductSpecifications^>^ defaultValuesRepository
)
new :
        specificationsRepository : ArtifactRepository<GlobalSpecifications> *
        defaultValuesRepository : ArtifactRepository<ProductSpecifications> -> TypeRepository

Parameters

specificationsRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository GlobalSpecifications
The specifications repository.
defaultValuesRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository ProductSpecifications
The default values repository.
See Also

Reference

TypeRepository Class
Sitecore.Commerce.Data.Products Namespace


TypeRepository Methods

TypeRepository Methods

The TypeRepository type exposes the following members.

Methods
 | Name | Description
Protected method | CreateEntityItem | Creates the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | DeleteItem | Deletes the item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Get(Item) | Gets entity from corresponding item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Get(String) | Gets the specified entity identifier. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities | Gets the list of entities. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetEntities(Item) | Gets the list of entities under the specified root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItem | Gets the entity item. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemId | Gets the entity item id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityItemImmediateRoot | Gets the entity item immediate root. (Overrides ArtifactRepositoryTEntityGetEntityItemImmediateRoot(Item, TEntity).)
Protected method | GetEntityItemName | Gets the name of the entity item. (Overrides ArtifactRepositoryTEntityGetEntityItemName(Item, TEntity).)
Protected method | GetEntityItems | Gets the entity items under the repository root. (Overrides ArtifactRepositoryTEntityGetEntityItems(Item).)
Protected method | GetEntityItemTemplateId | Gets the entity item template id. (Inherited from ArtifactRepositoryTEntity.)
Protected method | GetEntityKey | Gets the entity key. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRepositoryRootItem | Gets the repository root item. (Inherited from ArtifactRepositoryTEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InstantiateEntity | Instantiates the entity. (Inherited from ArtifactRepositoryTEntity.)
Protected method | IsValid | Determines whether the specified root is valid. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveItemIntoBucket | Moves the item into bucket. (Inherited from ArtifactRepositoryTEntity.)
Protected method | MoveToImmediateRoot | Moves to immediate root. (Inherited from ArtifactRepositoryTEntity.)
Protected method | PopulateEntity | Fills the entity. (Overrides ArtifactRepositoryTEntityPopulateEntity(Item, TEntity).)
Protected method | ProcessEntityItem | Processes the entity item. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(TEntity, Boolean) | Saves the specified entity. (Inherited from ArtifactRepositoryTEntity.)
Public method | Save(Item, TEntity, Boolean) | Saves the specified root. (Inherited from ArtifactRepositoryTEntity.)
Public method | SaveDefaultValues | Saves the default values.
Public method | SaveSpecifications | Saves the specifications.
Protected method | SetEntityItemStatistics | Sets the entity item statistics. (Inherited from ArtifactRepositoryTEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateEntityItem | Updates the entity item. (Overrides ArtifactRepositoryTEntityUpdateEntityItem(Item, TEntity).)
Top
See Also

Reference

TypeRepository Class
Sitecore.Commerce.Data.Products Namespace


TypeRepository.GetEntityItemImmediateRoot Method

TypeRepositoryGetEntityItemImmediateRoot Method
Gets the entity item immediate root.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override Item GetEntityItemImmediateRoot(
    Item root,
    ProductType entity
)
Protected Overrides Function GetEntityItemImmediateRoot (
    root As Item,
    entity As ProductType
) As Item
protected:
virtual Item^ GetEntityItemImmediateRoot(
    Item^ root,
    ProductType^ entity
) override
abstract GetEntityItemImmediateRoot :
        root : Item *
        entity : ProductType -> Item
override GetEntityItemImmediateRoot :
        root : Item *
        entity : ProductType -> Item

Parameters

root
Type: Item
The root
entity
Type: Sitecore.Commerce.Entities.ProductsProductType
The entity

Return Value

Type: Item
The immediate root item of the entity
See Also

Reference

TypeRepository Class
Sitecore.Commerce.Data.Products Namespace


TypeRepository.GetEntityItemName Method

TypeRepositoryGetEntityItemName Method
Gets the name of the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetEntityItemName(
    Item root,
    ProductType entity
)
Protected Overrides Function GetEntityItemName (
    root As Item,
    entity As ProductType
) As String
protected:
virtual String^ GetEntityItemName(
    Item^ root,
    ProductType^ entity
) override
abstract GetEntityItemName :
        root : Item *
        entity : ProductType -> string
override GetEntityItemName :
        root : Item *
        entity : ProductType -> string

Parameters

root
Type: Item
The root
entity
Type: Sitecore.Commerce.Entities.ProductsProductType
The entity

Return Value

Type: String
Entity item name
See Also

Reference

TypeRepository Class
Sitecore.Commerce.Data.Products Namespace


TypeRepository.GetEntityItems Method

TypeRepositoryGetEntityItems Method
Gets the entity items under the repository root.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IEnumerable<Item> GetEntityItems(
    Item root
)
Protected Overrides Function GetEntityItems (
    root As Item
) As IEnumerable(Of Item)
protected:
virtual IEnumerable<Item^>^ GetEntityItems(
    Item^ root
) override
abstract GetEntityItems :
        root : Item -> IEnumerable<Item>
override GetEntityItems :
        root : Item -> IEnumerable<Item>

Parameters

root
Type: Item
The root

Return Value

Type: IEnumerable Item
The entity items
See Also

Reference

TypeRepository Class
Sitecore.Commerce.Data.Products Namespace


TypeRepository.PopulateEntity Method

TypeRepositoryPopulateEntity Method
Fills the entity.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void PopulateEntity(
    Item entityItem,
    ProductType entity
)
Protected Overrides Sub PopulateEntity (
    entityItem As Item,
    entity As ProductType
)
protected:
virtual void PopulateEntity(
    Item^ entityItem,
    ProductType^ entity
) override
abstract PopulateEntity :
        entityItem : Item *
        entity : ProductType -> unit
override PopulateEntity :
        entityItem : Item *
        entity : ProductType -> unit

Parameters

entityItem
Type: Item
The entity item.
entity
Type: Sitecore.Commerce.Entities.ProductsProductType
The entity.
See Also

Reference

TypeRepository Class
Sitecore.Commerce.Data.Products Namespace


TypeRepository.SaveDefaultValues Method

TypeRepositorySaveDefaultValues Method
Saves the default values.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ProductSpecifications SaveDefaultValues(
    string typeId,
    ProductSpecifications defaultValues
)
Public Overridable Function SaveDefaultValues (
    typeId As String,
    defaultValues As ProductSpecifications
) As ProductSpecifications
public:
virtual ProductSpecifications^ SaveDefaultValues(
    String^ typeId,
    ProductSpecifications^ defaultValues
)
abstract SaveDefaultValues :
        typeId : string *
        defaultValues : ProductSpecifications -> ProductSpecifications
override SaveDefaultValues :
        typeId : string *
        defaultValues : ProductSpecifications -> ProductSpecifications

Parameters

typeId
Type: SystemString
The type ID
defaultValues
Type: Sitecore.Commerce.Entities.ProductsProductSpecifications
The specifications

Return Value

Type: ProductSpecifications
Saved default value specifications
See Also

Reference

TypeRepository Class
Sitecore.Commerce.Data.Products Namespace


TypeRepository.SaveSpecifications Method

TypeRepositorySaveSpecifications Method
Saves the specifications.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GlobalSpecifications SaveSpecifications(
    string typeId,
    GlobalSpecifications specifications
)
Public Overridable Function SaveSpecifications (
    typeId As String,
    specifications As GlobalSpecifications
) As GlobalSpecifications
public:
virtual GlobalSpecifications^ SaveSpecifications(
    String^ typeId,
    GlobalSpecifications^ specifications
)
abstract SaveSpecifications :
        typeId : string *
        specifications : GlobalSpecifications -> GlobalSpecifications
override SaveSpecifications :
        typeId : string *
        specifications : GlobalSpecifications -> GlobalSpecifications

Parameters

typeId
Type: SystemString
The type ID
specifications
Type: Sitecore.Commerce.Entities.ProductsGlobalSpecifications
The specifications that are saved

Return Value

Type: GlobalSpecifications
Saved specifications
See Also

Reference

TypeRepository Class
Sitecore.Commerce.Data.Products Namespace


TypeRepository.UpdateEntityItem Method

TypeRepositoryUpdateEntityItem Method
Updates the entity item.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void UpdateEntityItem(
    Item entityItem,
    ProductType entity
)
Protected Overrides Sub UpdateEntityItem (
    entityItem As Item,
    entity As ProductType
)
protected:
virtual void UpdateEntityItem(
    Item^ entityItem,
    ProductType^ entity
) override
abstract UpdateEntityItem :
        entityItem : Item *
        entity : ProductType -> unit
override UpdateEntityItem :
        entityItem : Item *
        entity : ProductType -> unit

Parameters

entityItem
Type: Item
The entity item
entity
Type: Sitecore.Commerce.Entities.ProductsProductType
The entity
See Also

Reference

TypeRepository Class
Sitecore.Commerce.Data.Products Namespace


TypeRepository Properties

TypeRepository Properties

The TypeRepository type exposes the following members.

Properties
 | Name | Description
Public property | Branch | Gets or sets the branch. (Inherited from ArtifactRepositoryTEntity.)
Protected property | Database | Gets the database. (Inherited from EntityRepositoryTEntity.)
Protected property | EntityFactory | Gets the entity factory. (Inherited from ArtifactRepositoryTEntity.)
Public property | IdGenerator | Gets or sets the unique identifier generator. (Inherited from EntityRepositoryTEntity.)
Public property | Path | Gets or sets the path. (Inherited from EntityRepositoryTEntity.)
Public property | Prefix | Gets or sets the prefix. (Inherited from EntityRepositoryTEntity.)
Public property | Template | Gets or sets the template. (Inherited from ArtifactRepositoryTEntity.)
Top
See Also

Reference

TypeRepository Class
Sitecore.Commerce.Data.Products Namespace


XmlUtility Class

XmlUtility Class
Defines the utility that is created to parse the string that represents XML node, check whether the specified attribute exists and their value represents GUID and return this GUID value. The main purpose is to get ID of the media item from the "src" attribute of the value of the image field.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Data.ProductsXmlUtility

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class XmlUtility
<ExtensionAttribute>
Public NotInheritable Class XmlUtility
[ExtensionAttribute]
public ref class XmlUtility abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type XmlUtility =  class end

The XmlUtility type exposes the following members.

Methods
Name | Description
GetGuidFromAtributeOfXmlNodeString | Parses the string that represents XML node, check whether the specified attribute exists and their value represents GUID and return this GUID value.
Top
See Also

Reference

Sitecore.Commerce.Data.Products Namespace


XmlUtility Methods

XmlUtility Methods

The XmlUtility type exposes the following members.

Methods
Name | Description
GetGuidFromAtributeOfXmlNodeString | Parses the string that represents XML node, check whether the specified attribute exists and their value represents GUID and return this GUID value.
Top
See Also

Reference

XmlUtility Class
Sitecore.Commerce.Data.Products Namespace


XmlUtility.GetGuidFromAtributeOfXmlNodeString Method

XmlUtilityGetGuidFromAtributeOfXmlNodeString Method
Parses the string that represents XML node, check whether the specified attribute exists and their value represents GUID and return this GUID value.

Namespace: Sitecore.Commerce.Data.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static Guid GetGuidFromAtributeOfXmlNodeString(
    this string xmlNodeString,
    string attributeName
)
<ExtensionAttribute>
Public Shared Function GetGuidFromAtributeOfXmlNodeString (
    xmlNodeString As String,
    attributeName As String
) As Guid
public:
[ExtensionAttribute]
static Guid GetGuidFromAtributeOfXmlNodeString(
    String^ xmlNodeString,
    String^ attributeName
)
static member GetGuidFromAtributeOfXmlNodeString :
        xmlNodeString : string *
        attributeName : string -> Guid

Parameters

xmlNodeString
Type: SystemString
The XML string.
attributeName
Type: SystemString
Name of the attribute.

Return Value

Type: Guid
The GUID value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlUtility Class
Sitecore.Commerce.Data.Products Namespace


Sitecore.Commerce.Entities Namespace

Sitecore.Commerce.Entities Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Entities"]

Classes
 | Class | Description
Public class | Entity | Defines the base class used by all Commerce entities.
Public class | EntityFactory | Defines the entity factory that uses Sitecore mechanisms of dependency injection to instantiate objects according to their definitions in the configuration file. The dependency injection is handled by the Factory class. Commerce entities are configured in the "//sitecore/commerce.Entities" node. This class inherits from the IEntityFactory interface.
Public class | EntityFactoryExtensions | The extensions for the the EntityFactory which is the default implementation of the IEntityFactory interface. The entity factory uses Sitecore mechanisms of dependency injection to instantiate objects according to their definitions in the configuration file. The dependency injection is handled by the Factory class. Commerce entities are configured in the "//sitecore/commerce.Entities" node. You can uses these extensions to strongly specify the type of the instantiated entity to prevent subsequent type casting.
Public class | MappedEntity | Defines the base class for any object that can be managed by a unique string identifier.
Public class | Party | Defines the Party class shared by Customers and Orders.
Interfaces
 | Interface | Description
Public interface | IEntityFactory | Defines the interface that you can use to instantiate an object with a specific name. This name should be an identifier and not the name of the class name. The default implementation of this interface is the EntityFactory class. The EntityFactory class uses Sitecore mechanism of embedded dependency injection. to instantiate objects according to their definitions in the Factory configuration file. In the Factory file, Commerce entities are configured in the //sitecore/commerce.Entities node.


Entity Class

Entity Class
Defines the base class used by all Commerce entities.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
More...

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class Entity
<SerializableAttribute>
Public MustInherit Class Entity
[SerializableAttribute]
public ref class Entity abstract
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Entity =  class end

The Entity type exposes the following members.

Constructors
 | Name | Description
Protected method | Entity | Initializes a new instance of the Entity class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value.
Public method | SetPropertyValue(String, Object) | Sets a property value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
Top
See Also

Reference

Sitecore.Commerce.Entities Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.CartsCartAdjustment
Sitecore.Commerce.Entities.CartsCartLine
Sitecore.Commerce.Entities.CartsCartOption
Sitecore.Commerce.Entities.CartsCartProduct
Sitecore.Commerce.Entities.InventoryIndexStockInformation
Sitecore.Commerce.Entities.InventoryInventoryProduct
Sitecore.Commerce.Entities.InventoryOrderableInformation
Sitecore.Commerce.Entities.InventoryStockDetailsLevel
Sitecore.Commerce.Entities.InventoryStockInformation
Sitecore.Commerce.Entities.InventoryStockInformationUpdate
Sitecore.Commerce.Entities.InventoryStockInformationUpdateLocation
Sitecore.Commerce.Entities.InventoryStockNotificationRequest
Sitecore.Commerce.Entities.InventoryStockStatus
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.PricesPrice
Sitecore.Commerce.Entities.PricesPriceCondition
Sitecore.Commerce.Entities.PricesTaxSubtotal
Sitecore.Commerce.Entities.PricesTaxTotal
Sitecore.Commerce.Entities.PricesTotal
Sitecore.Commerce.Services.CustomersCustomerSearchCriteria
Sitecore.Commerce.Services.CustomersUserSearchCriteria


Entity Constructor

Entity Constructor
Initializes a new instance of the Entity class

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected Entity()
Protected Sub New
protected:
Entity()
new : unit -> Entity
See Also

Reference

Entity Class
Sitecore.Commerce.Entities Namespace


Entity Methods

Entity Methods

The Entity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value.
Public method | SetPropertyValue(String, Object) | Sets a property value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Entity Class
Sitecore.Commerce.Entities Namespace


Entity.GetPropertyValue Method

EntityGetPropertyValue Method
Gets a property value.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Object GetPropertyValue(
    string key
)
Public Function GetPropertyValue (
    key As String
) As Object
public:
Object^ GetPropertyValue(
    String^ key
)
member GetPropertyValue :
        key : string -> Object

Parameters

key
Type: SystemString
The key value for the entity Properties collection.

Return Value

Type: Object
The entity property value.
See Also

Reference

Entity Class
Sitecore.Commerce.Entities Namespace


Entity.SetPropertyValue Method

EntitySetPropertyValue Method
Overload List
 | Name | Description
Public method | SetPropertyValue(String) | Sets a property value.
Public method | SetPropertyValue(String, Object) | Sets a property value.
Top
See Also

Reference

Entity Class
Sitecore.Commerce.Entities Namespace


Entity.SetPropertyValue Method (String)

EntitySetPropertyValue Method (String)
Sets a property value.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public void SetPropertyValue(
    string key
)
Public Sub SetPropertyValue (
    key As String
)
public:
void SetPropertyValue(
    String^ key
)
member SetPropertyValue :
        key : string -> unit

Parameters

key
Type: SystemString
The key value to add to the entity Properties collection.
See Also

Reference

Entity Class
SetPropertyValue Overload
Sitecore.Commerce.Entities Namespace


Entity.SetPropertyValue Method (String, Object)

EntitySetPropertyValue Method (String, Object)
Sets a property value.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public void SetPropertyValue(
    string key,
    Object value
)
Public Sub SetPropertyValue (
    key As String,
    value As Object
)
public:
void SetPropertyValue(
    String^ key,
    Object^ value
)
member SetPropertyValue :
        key : string *
        value : Object -> unit

Parameters

key
Type: SystemString
The key value to add to the entity Properties collection.
value
Type: SystemObject
The property value.
See Also

Reference

Entity Class
SetPropertyValue Overload
Sitecore.Commerce.Entities Namespace


Entity Properties

Entity Properties

The Entity type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
Top
See Also

Reference

Entity Class
Sitecore.Commerce.Entities Namespace


Entity.Properties Property

EntityProperties Property
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PropertyCollection Properties { get; set; }
Public Property Properties As PropertyCollection
    Get
    Set
public:
property PropertyCollection^ Properties {
    PropertyCollection^ get ();
    void set (PropertyCollection^ value);
}
member Properties : PropertyCollection with get, set

Property Value

Type: PropertyCollection
The properties.
See Also

Reference

Entity Class
Sitecore.Commerce.Entities Namespace


EntityFactory Class

EntityFactory Class
Defines the entity factory that uses Sitecore mechanisms of dependency injection to instantiate objects according to their definitions in the configuration file. The dependency injection is handled by the Factory class. Commerce entities are configured in the "//sitecore/commerce.Entities" node. This class inherits from the IEntityFactory interface.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntityFactory

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EntityFactory : IEntityFactory
Public Class EntityFactory
    Implements IEntityFactory
public ref class EntityFactory : IEntityFactory
type EntityFactory =
    class
        interface IEntityFactory
    end

The EntityFactory type exposes the following members.

Constructors
 | Name | Description
Public method | EntityFactory | Initializes a new instance of the EntityFactory class
Top
Methods
 | Name | Description
Public method | Create | Creates the entity based on the name that acts as their identifier. This method uses the facilities of the Sitecore embedded dependency injection mechanisms to instantiate objects according to their definitions in the configuration file. The dependency injection is handled by the Factory class. Commerce entities are configured in the "//sitecore/commerce.Entities" node.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateT | Creates the entity based on the name which acts as their identifier. Performs the additional type casting before returning value. (Defined by EntityFactoryExtensions.)
Top
See Also

Reference

Sitecore.Commerce.Entities Namespace


EntityFactory Constructor

EntityFactory Constructor
Initializes a new instance of the EntityFactory class

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EntityFactory()
Public Sub New
public:
EntityFactory()
new : unit -> EntityFactory
See Also

Reference

EntityFactory Class
Sitecore.Commerce.Entities Namespace


EntityFactory Methods

EntityFactory Methods

The EntityFactory type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates the entity based on the name that acts as their identifier. This method uses the facilities of the Sitecore embedded dependency injection mechanisms to instantiate objects according to their definitions in the configuration file. The dependency injection is handled by the Factory class. Commerce entities are configured in the "//sitecore/commerce.Entities" node.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateT | Creates the entity based on the name which acts as their identifier. Performs the additional type casting before returning value. (Defined by EntityFactoryExtensions.)
Top
See Also

Reference

EntityFactory Class
Sitecore.Commerce.Entities Namespace


EntityFactory.Create Method

EntityFactoryCreate Method
Creates the entity based on the name that acts as their identifier. This method uses the facilities of the Sitecore embedded dependency injection mechanisms to instantiate objects according to their definitions in the configuration file. The dependency injection is handled by the Factory class. Commerce entities are configured in the "//sitecore/commerce.Entities" node.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Object Create(
    string entityName
)
Public Function Create (
    entityName As String
) As Object
public:
virtual Object^ Create(
    String^ entityName
) sealed
abstract Create :
        entityName : string -> Object
override Create :
        entityName : string -> Object

Parameters

entityName
Type: SystemString
The name of the entity

Return Value

Type: Object
The entity

Implements

IEntityFactoryCreate(String)
See Also

Reference

EntityFactory Class
Sitecore.Commerce.Entities Namespace


EntityFactoryExtensions Class

EntityFactoryExtensions Class
The extensions for the the EntityFactory which is the default implementation of the IEntityFactory interface. The entity factory uses Sitecore mechanisms of dependency injection to instantiate objects according to their definitions in the configuration file. The dependency injection is handled by the Factory class. Commerce entities are configured in the "//sitecore/commerce.Entities" node. You can uses these extensions to strongly specify the type of the instantiated entity to prevent subsequent type casting.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntityFactoryExtensions

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class EntityFactoryExtensions
<ExtensionAttribute>
Public NotInheritable Class EntityFactoryExtensions
[ExtensionAttribute]
public ref class EntityFactoryExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type EntityFactoryExtensions =  class end

The EntityFactoryExtensions type exposes the following members.

Methods
Name | Description
CreateT | Creates the entity based on the name which acts as their identifier. Performs the additional type casting before returning value.
Top
See Also

Reference

Sitecore.Commerce.Entities Namespace


EntityFactoryExtensions Methods

EntityFactoryExtensions Methods

The EntityFactoryExtensions type exposes the following members.

Methods
Name | Description
CreateT | Creates the entity based on the name which acts as their identifier. Performs the additional type casting before returning value.
Top
See Also

Reference

EntityFactoryExtensions Class
Sitecore.Commerce.Entities Namespace


EntityFactoryExtensions.Create(T) Method

EntityFactoryExtensionsCreateT Method
Creates the entity based on the name which acts as their identifier. Performs the additional type casting before returning value.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static T Create<T>(
    this IEntityFactory entityFactory,
    string entityName
)

<ExtensionAttribute>
Public Shared Function Create(Of T) (
    entityFactory As IEntityFactory,
    entityName As String
) As T
public:
[ExtensionAttribute]
generic<typename T>
static T Create(
    IEntityFactory^ entityFactory,
    String^ entityName
)
static member Create :
        entityFactory : IEntityFactory *
        entityName : string -> 'T

Parameters

entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory
entityName
Type: SystemString
The name of the entity

Type Parameters

T
The return type

Return Value

Type: T
The entity

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEntityFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EntityFactoryExtensions Class
Sitecore.Commerce.Entities Namespace


IEntityFactory Interface

IEntityFactory Interface
Defines the interface that you can use to instantiate an object with a specific name. This name should be an identifier and not the name of the class name. The default implementation of this interface is the EntityFactory class. The EntityFactory class uses Sitecore mechanism of embedded dependency injection. to instantiate objects according to their definitions in the Factory configuration file. In the Factory file, Commerce entities are configured in the //sitecore/commerce.Entities node.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public interface IEntityFactory
Public Interface IEntityFactory
public interface class IEntityFactory
type IEntityFactory =  interface end

The IEntityFactory type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates the entity with a specific name.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateT | Creates the entity based on the name which acts as their identifier. Performs the additional type casting before returning value. (Defined by EntityFactoryExtensions.)
Top
See Also

Reference

Sitecore.Commerce.Entities Namespace


IEntityFactory Methods

IEntityFactory Methods

The IEntityFactory type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates the entity with a specific name.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateT | Creates the entity based on the name which acts as their identifier. Performs the additional type casting before returning value. (Defined by EntityFactoryExtensions.)
Top
See Also

Reference

IEntityFactory Interface
Sitecore.Commerce.Entities Namespace


IEntityFactory.Create Method

IEntityFactoryCreate Method
Creates the entity with a specific name.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
Object Create(
    string entityName
)
Function Create (
    entityName As String
) As Object
Object^ Create(
    String^ entityName
)
abstract Create :
        entityName : string -> Object

Parameters

entityName
Type: SystemString
Name of the entity

Return Value

Type: Object
The entity
See Also

Reference

IEntityFactory Interface
Sitecore.Commerce.Entities Namespace


MappedEntity Class

MappedEntity Class
Defines the base class for any object that can be managed by a unique string identifier.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
More...

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class MappedEntity : Entity
<SerializableAttribute>
Public MustInherit Class MappedEntity
    Inherits Entity
[SerializableAttribute]
public ref class MappedEntity abstract : public Entity
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type MappedEntity =
    class
        inherit Entity
    end

The MappedEntity type exposes the following members.

Constructors
 | Name | Description
Protected method | MappedEntity | Initializes a new instance of the MappedEntity class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

Sitecore.Commerce.Entities Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.CartsCartBase
Sitecore.Commerce.Entities.CartsCartParty
Sitecore.Commerce.Entities.CartsPaymentInfo
Sitecore.Commerce.Entities.CartsShippingInfo
Sitecore.Commerce.Entities.CustomersCommerceCustomer
Sitecore.Commerce.Entities.CustomersCommerceUser
Sitecore.Commerce.Entities.CustomersCustomerParty
Sitecore.Commerce.EntitiesParty
Sitecore.Commerce.Entities.ProductsProductEntity


MappedEntity Constructor

MappedEntity Constructor
Initializes a new instance of the MappedEntity class

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected MappedEntity()
Protected Sub New
protected:
MappedEntity()
new : unit -> MappedEntity
See Also

Reference

MappedEntity Class
Sitecore.Commerce.Entities Namespace


MappedEntity Methods

MappedEntity Methods

The MappedEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MappedEntity Class
Sitecore.Commerce.Entities Namespace


MappedEntity Properties

MappedEntity Properties

The MappedEntity type exposes the following members.

Properties
 | Name | Description
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

MappedEntity Class
Sitecore.Commerce.Entities Namespace


MappedEntity.ExternalId Property

MappedEntityExternalId Property
Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string ExternalId { get; set; }
Public Overridable Property ExternalId As String
    Get
    Set
public:
virtual property String^ ExternalId {
    String^ get ();
    void set (String^ value);
}
abstract ExternalId : string with get, set
override ExternalId : string with get, set

Property Value

Type: String
The external ID
See Also

Reference

MappedEntity Class
Sitecore.Commerce.Entities Namespace


Party Class

Party Class
Defines the Party class shared by Customers and Orders.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.EntitiesParty

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Party : MappedEntity
<SerializableAttribute>
Public Class Party
    Inherits MappedEntity
[SerializableAttribute]
public ref class Party : public MappedEntity
[<SerializableAttribute>]
type Party =
    class
        inherit MappedEntity
    end

The Party type exposes the following members.

Constructors
 | Name | Description
Public method | Party | Initializes a new instance of the Party class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address1 | Gets or sets the address1.
Public property | Address2 | Gets or sets the address2.
Public property | City | Gets or sets the city.
Public property | Company | Gets or sets the company.
Public property | Country | Gets or sets the country.
Public property | Email | Gets or sets the email.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | FirstName | Gets or sets the first name.
Public property | LastName | Gets or sets the last name.
Public property | PartyId | Gets or sets the party identifier.
Public property | PhoneNumber | Gets or sets the phone number.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | State | Gets or sets the state.
Public property | ZipPostalCode | Gets or sets the zip postal code.
Top
See Also

Reference

Sitecore.Commerce.Entities Namespace


Party Constructor

Party Constructor
Initializes a new instance of the Party class

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Party()
Public Sub New
public:
Party()
new : unit -> Party
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Party Methods

Party Methods

The Party type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Party Properties

Party Properties

The Party type exposes the following members.

Properties
 | Name | Description
Public property | Address1 | Gets or sets the address1.
Public property | Address2 | Gets or sets the address2.
Public property | City | Gets or sets the city.
Public property | Company | Gets or sets the company.
Public property | Country | Gets or sets the country.
Public property | Email | Gets or sets the email.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | FirstName | Gets or sets the first name.
Public property | LastName | Gets or sets the last name.
Public property | PartyId | Gets or sets the party identifier.
Public property | PhoneNumber | Gets or sets the phone number.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | State | Gets or sets the state.
Public property | ZipPostalCode | Gets or sets the zip postal code.
Top
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Party.Address1 Property

PartyAddress1 Property
Gets or sets the address1.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Address1 { get; set; }
Public Property Address1 As String
    Get
    Set
public:
property String^ Address1 {
    String^ get ();
    void set (String^ value);
}
member Address1 : string with get, set

Property Value

Type: String
The address1.
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Party.Address2 Property

PartyAddress2 Property
Gets or sets the address2.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Address2 { get; set; }
Public Property Address2 As String
    Get
    Set
public:
property String^ Address2 {
    String^ get ();
    void set (String^ value);
}
member Address2 : string with get, set

Property Value

Type: String
The address2.
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Party.City Property

PartyCity Property
Gets or sets the city.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string City { get; set; }
Public Property City As String
    Get
    Set
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}
member City : string with get, set

Property Value

Type: String
The city.
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Party.Company Property

PartyCompany Property
Gets or sets the company.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Company { get; set; }
Public Property Company As String
    Get
    Set
public:
property String^ Company {
    String^ get ();
    void set (String^ value);
}
member Company : string with get, set

Property Value

Type: String
The company.
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Party.Country Property

PartyCountry Property
Gets or sets the country.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Country { get; set; }
Public Property Country As String
    Get
    Set
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}
member Country : string with get, set

Property Value

Type: String
The country.
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Party.Email Property

PartyEmail Property
Gets or sets the email.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}
member Email : string with get, set

Property Value

Type: String
The email.
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Party.FirstName Property

PartyFirstName Property
Gets or sets the first name.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string FirstName { get; set; }
Public Property FirstName As String
    Get
    Set
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}
member FirstName : string with get, set

Property Value

Type: String
The first name.
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Party.LastName Property

PartyLastName Property
Gets or sets the last name.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string LastName { get; set; }
Public Property LastName As String
    Get
    Set
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}
member LastName : string with get, set

Property Value

Type: String
The last name.
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Party.PartyId Property

PartyPartyId Property
Gets or sets the party identifier.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string PartyId { get; set; }
Public Property PartyId As String
    Get
    Set
public:
property String^ PartyId {
    String^ get ();
    void set (String^ value);
}
member PartyId : string with get, set

Property Value

Type: String
The party identifier.
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Party.PhoneNumber Property

PartyPhoneNumber Property
Gets or sets the phone number.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string PhoneNumber { get; set; }
Public Property PhoneNumber As String
    Get
    Set
public:
property String^ PhoneNumber {
    String^ get ();
    void set (String^ value);
}
member PhoneNumber : string with get, set

Property Value

Type: String
The phone number.
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Party.State Property

PartyState Property
Gets or sets the state.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string State { get; set; }
Public Property State As String
    Get
    Set
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}
member State : string with get, set

Property Value

Type: String
The state.
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Party.ZipPostalCode Property

PartyZipPostalCode Property
Gets or sets the zip postal code.

Namespace: Sitecore.Commerce.Entities
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ZipPostalCode { get; set; }
Public Property ZipPostalCode As String
    Get
    Set
public:
property String^ ZipPostalCode {
    String^ get ();
    void set (String^ value);
}
member ZipPostalCode : string with get, set

Property Value

Type: String
The zip postal code.
See Also

Reference

Party Class
Sitecore.Commerce.Entities Namespace


Sitecore.Commerce.Entities.Carts Namespace

Sitecore.Commerce.Entities.Carts Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Entities.Carts"]

Classes
Class Description
Public class Cart
Represents a group of products that a customer wants to buy. The customer uses the cart to view its content and decide on any further personalization. The Cart class implements the CartBase class.
Public class CartAdjustment
Describes a charge or a discount on a Cart, CartLine or a product on a cart line. Some examples are:
  • Coupon codes that are manually triggered on the cart or the cart line.
  • Shipping surcharges that are automatically triggered on the cart or cart Line.
Public class CartBase
Represents a data summary of the main cart. The CartBase class is used as a return type for the GetCarts method.
Public class CartLine
Represents a line in the cart. Each line represents a product and the quantity of the product that a visitor has added to the cart. The CartLine class also represents the position of the line relative to other lines in the cart, which controls the order in which the lines appear when they are displayed.
Public class CartOption
Represents a configurable or variable value that is specific to a product in the cart. An example of an option is an engraving on a personalized product. When the engraving service is added to the cart, the text to be engraved is also required. The CartOption represents this. If an option has an additional charge, the option is represented as a separate total on a new cart line. The option is only used to describe variables or settings on a specific product, not adjustments or pricing changes.
Public class CartParty
Defines the CartParty class.
Public class CartProduct
Represents a product on a cart line, or, in some cases, a subitem of a cart product such as insurance.
Public class PaymentInfo
Defines the PaymentInfo class.
Public class ShippingInfo
Defines the ShippingInfo class.


Cart Class

Cart Class
Represents a group of products that a customer wants to buy. The customer uses the cart to view its content and decide on any further personalization. The Cart class implements the CartBase class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.CartsCartBase
Sitecore.Commerce.Entities.CartsCart
Sitecore.Commerce.Entities.OrdersOrder

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Cart : CartBase
<SerializableAttribute>
Public Class Cart
    Inherits CartBase
[SerializableAttribute]
public ref class Cart : public CartBase
[<SerializableAttribute>]
type Cart =
    class
        inherit CartBase
    end

The Cart type exposes the following members.

Constructors
 | Name | Description
Public method | Cart | Initializes a new instance of the Cart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
Name Description
Public property AccountingCustomerParty
Gets or sets the accounting customer party.
(Inherited from CartBase.)
Public property Adjustments
Gets or sets the adjustments that describe any differences between the total and the sum of the prices of the individual cart line items. Examples are coupon codes that are manually triggered and shipping surcharges that are automatically triggered.
Public property BuyerCustomerParty
Gets or sets the buyer customer party.
(Inherited from CartBase.)
CartType
Gets or sets the type of cart.
Examples
  • Regular
  • Wish list
(Inherited from CartBase.)
Public property CustomerId
Gets or sets the customer ID.
(Inherited from CartBase.)
Public property ExternalId
Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created.
(Inherited from MappedEntity.)
Public property IsLocked
Gets or sets a value that indicates whether the cart is locked.
(Inherited from CartBase.)
Public property Lines
Gets or sets the sublines of the cart line.
Public property Name
Gets or sets the cart name.
(Inherited from CartBase.)
Public property Parties
Gets or sets the parties.
Public property Payment
Gets or sets the payment list.
Public property Properties
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
(Inherited from Entity.)
Public property Shipping
Gets or sets the shipping list.
Public property ShopName
Gets or sets the shop name.
(Inherited from CartBase.)
Public property Status
Gets or sets the cart status.
(Inherited from CartBase.)
Public property Total
Gets or sets the total for the products in the cart.
Public property UserId
Gets or sets the user ID.
(Inherited from CartBase.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Carts Namespace


Cart Constructor

Cart Constructor
Initializes a new instance of the Cart class

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Cart()
Public Sub New
public:
Cart()
new : unit -> Cart
See Also

Reference

Cart Class
Sitecore.Commerce.Entities.Carts Namespace


Cart Methods

Cart Methods

The Cart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cart Class
Sitecore.Commerce.Entities.Carts Namespace


Cart Properties

Cart Properties

The Cart type exposes the following members.

Properties
Name Description
Public property AccountingCustomerParty
Gets or sets the accounting customer party.
(Inherited from CartBase.)
Public property Adjustments
Gets or sets the adjustments that describe any differences between the total and the sum of the prices of the individual cart line items. Examples are coupon codes that are manually triggered and shipping surcharges that are automatically triggered.
Public property BuyerCustomerParty
Gets or sets the buyer customer party.
(Inherited from CartBase.)
CartType
Gets or sets the type of cart.
Examples
  • Regular
  • Wish list
(Inherited from CartBase.)
Public property CustomerId
Gets or sets the customer ID.
(Inherited from CartBase.)
Public property ExternalId
Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created.
(Inherited from MappedEntity.)
Public property IsLocked
Gets or sets a value that indicates whether the cart is locked.
(Inherited from CartBase.)
Public property Lines
Gets or sets the sublines of the cart line.
Public property Name
Gets or sets the cart name.
(Inherited from CartBase.)
Public property Parties
Gets or sets the parties.
Public property Payment
Gets or sets the payment list.
Public property Properties
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
(Inherited from Entity.)
Public property Shipping
Gets or sets the shipping list.
Public property ShopName
Gets or sets the shop name.
(Inherited from CartBase.)
Public property Status
Gets or sets the cart status.
(Inherited from CartBase.)
Public property Total
Gets or sets the total for the products in the cart.
Public property UserId
Gets or sets the user ID.
(Inherited from CartBase.)
Top
See Also

Reference

Cart Class
Sitecore.Commerce.Entities.Carts Namespace


Cart.Adjustments Property

CartAdjustments Property
Gets or sets the adjustments that describe any differences between the total and the sum of the prices of the individual cart line items. Examples are coupon codes that are manually triggered and shipping surcharges that are automatically triggered.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection Adjustments { get; set; }
Public Property Adjustments As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ Adjustments {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member Adjustments : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
See Also

Reference

Cart Class
Sitecore.Commerce.Entities.Carts Namespace


Cart.Lines Property

CartLines Property
Gets or sets the sublines of the cart line.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection Lines { get; set; }
Public Property Lines As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ Lines {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member Lines : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
See Also

Reference

Cart Class
Sitecore.Commerce.Entities.Carts Namespace


Cart.Parties Property

CartParties Property
Gets or sets the parties.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection Parties { get; set; }
Public Property Parties As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ Parties {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member Parties : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The parties.
See Also

Reference

Cart Class
Sitecore.Commerce.Entities.Carts Namespace


Cart.Payment Property

CartPayment Property
Gets or sets the payment list.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection Payment { get; set; }
Public Property Payment As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ Payment {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member Payment : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The payment list.
See Also

Reference

Cart Class
Sitecore.Commerce.Entities.Carts Namespace


Cart.Shipping Property

CartShipping Property
Gets or sets the shipping list.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection Shipping { get; set; }
Public Property Shipping As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ Shipping {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member Shipping : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The shipping list.
See Also

Reference

Cart Class
Sitecore.Commerce.Entities.Carts Namespace


Cart.Total Property

CartTotal Property
Gets or sets the total for the products in the cart.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Total Total { get; set; }
Public Property Total As Total
    Get
    Set
public:
property Total^ Total {
    Total^ get ();
    void set (Total^ value);
}
member Total : Total with get, set

Property Value

Type: Total
See Also

Reference

Cart Class
Sitecore.Commerce.Entities.Carts Namespace


CartAdjustment Class

CartAdjustment Class
Describes a charge or a discount on a Cart, CartLine or a product on a cart line. Some examples are:
  • Coupon codes that are manually triggered on the cart or the cart line.
  • Shipping surcharges that are automatically triggered on the cart or cart Line.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.CartsCartAdjustment

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class CartAdjustment : Entity
<SerializableAttribute>
Public Class CartAdjustment
    Inherits Entity
[SerializableAttribute]
public ref class CartAdjustment : public Entity
[<SerializableAttribute>]
type CartAdjustment =
    class
        inherit Entity
    end

The CartAdjustment type exposes the following members.

Constructors
 | Name | Description
Public method | CartAdjustment | Initializes a new instance of the CartAdjustment class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Amount | Gets or sets the amount of the adjustment.
Public property | Description | Gets or sets the description of the adjustment.
Public property | IsCharge | Gets or sets a value that indicates whether the adjustment is a charge.
Public property | LineNumber | Gets or sets the line number.
Public property | Percentage | Gets or sets the percentage of the adjustment.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Carts Namespace


CartAdjustment Constructor

CartAdjustment Constructor
Initializes a new instance of the CartAdjustment class

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CartAdjustment()
Public Sub New
public:
CartAdjustment()
new : unit -> CartAdjustment
See Also

Reference

CartAdjustment Class
Sitecore.Commerce.Entities.Carts Namespace


CartAdjustment Methods

CartAdjustment Methods

The CartAdjustment type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CartAdjustment Class
Sitecore.Commerce.Entities.Carts Namespace


CartAdjustment Properties

CartAdjustment Properties

The CartAdjustment type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Gets or sets the amount of the adjustment.
Public property | Description | Gets or sets the description of the adjustment.
Public property | IsCharge | Gets or sets a value that indicates whether the adjustment is a charge.
Public property | LineNumber | Gets or sets the line number.
Public property | Percentage | Gets or sets the percentage of the adjustment.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

CartAdjustment Class
Sitecore.Commerce.Entities.Carts Namespace


CartAdjustment.Amount Property

CartAdjustmentAmount Property
Gets or sets the amount of the adjustment.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public decimal Amount { get; set; }
Public Property Amount As Decimal
    Get
    Set
public:
property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
member Amount : decimal with get, set

Property Value

Type: Decimal
See Also

Reference

CartAdjustment Class
Sitecore.Commerce.Entities.Carts Namespace


CartAdjustment.Description Property

CartAdjustmentDescription Property
Gets or sets the description of the adjustment.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

CartAdjustment Class
Sitecore.Commerce.Entities.Carts Namespace


CartAdjustment.IsCharge Property

CartAdjustmentIsCharge Property
Gets or sets a value that indicates whether the adjustment is a charge.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public bool IsCharge { get; set; }
Public Property IsCharge As Boolean
    Get
    Set
public:
property bool IsCharge {
    bool get ();
    void set (bool value);
}
member IsCharge : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CartAdjustment Class
Sitecore.Commerce.Entities.Carts Namespace


CartAdjustment.LineNumber Property

CartAdjustmentLineNumber Property
Gets or sets the line number.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public uint LineNumber { get; set; }
Public Property LineNumber As UInteger
    Get
    Set
public:
property unsigned int LineNumber {
    unsigned int get ();
    void set (unsigned int value);
}
member LineNumber : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

CartAdjustment Class
Sitecore.Commerce.Entities.Carts Namespace


CartAdjustment.Percentage Property

CartAdjustmentPercentage Property
Gets or sets the percentage of the adjustment.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public float Percentage { get; set; }
Public Property Percentage As Single
    Get
    Set
public:
property float Percentage {
    float get ();
    void set (float value);
}
member Percentage : float32 with get, set

Property Value

Type: Single
See Also

Reference

CartAdjustment Class
Sitecore.Commerce.Entities.Carts Namespace


CartBase Class

CartBase Class
Represents a data summary of the main cart. The CartBase class is used as a return type for the GetCarts method.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.CartsCartBase
Sitecore.Commerce.Entities.CartsCart
Sitecore.Commerce.Entities.OrdersOrderHeader

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class CartBase : MappedEntity
<SerializableAttribute>
Public Class CartBase
    Inherits MappedEntity
[SerializableAttribute]
public ref class CartBase : public MappedEntity
[<SerializableAttribute>]
type CartBase =
    class
        inherit MappedEntity
    end

The CartBase type exposes the following members.

Constructors
 | Name | Description
Public method | CartBase | Initializes a new instance of the CartBase class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
Name Description
Public property AccountingCustomerParty
Gets or sets the accounting customer party.
Public property BuyerCustomerParty
Gets or sets the buyer customer party.
CartType
Gets or sets the type of cart.
Examples
  • Regular
  • Wish list
Public property CustomerId
Gets or sets the customer ID.
Public property ExternalId
Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created.
(Inherited from MappedEntity.)
Public property IsLocked
Gets or sets a value that indicates whether the cart is locked.
Public property Name
Gets or sets the cart name.
Public property Properties
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
(Inherited from Entity.)
Public property ShopName
Gets or sets the shop name.
Public property Status
Gets or sets the cart status.
Public property UserId
Gets or sets the user ID.
Top
See Also

Reference

Sitecore.Commerce.Entities.Carts Namespace


CartBase Constructor

CartBase Constructor
Initializes a new instance of the CartBase class

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CartBase()
Public Sub New
public:
CartBase()
new : unit -> CartBase
See Also

Reference

CartBase Class
Sitecore.Commerce.Entities.Carts Namespace


CartBase Methods

CartBase Methods

The CartBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CartBase Class
Sitecore.Commerce.Entities.Carts Namespace


CartBase Properties

CartBase Properties

The CartBase type exposes the following members.

Properties
Name Description
Public property AccountingCustomerParty
Gets or sets the accounting customer party.
Public property BuyerCustomerParty
Gets or sets the buyer customer party.
CartType
Gets or sets the type of cart.
Examples
  • Regular
  • Wish list
Public property CustomerId
Gets or sets the customer ID.
Public property ExternalId
Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created.
(Inherited from MappedEntity.)
Public property IsLocked
Gets or sets a value that indicates whether the cart is locked.
Public property Name
Gets or sets the cart name.
Public property Properties
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
(Inherited from Entity.)
Public property ShopName
Gets or sets the shop name.
Public property Status
Gets or sets the cart status.
Public property UserId
Gets or sets the user ID.
Top
See Also

Reference

CartBase Class
Sitecore.Commerce.Entities.Carts Namespace


CartBase.AccountingCustomerParty Property

CartBaseAccountingCustomerParty Property
Gets or sets the accounting customer party.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CartParty AccountingCustomerParty { get; set; }
Public Property AccountingCustomerParty As CartParty
    Get
    Set
public:
property CartParty^ AccountingCustomerParty {
    CartParty^ get ();
    void set (CartParty^ value);
}
member AccountingCustomerParty : CartParty with get, set

Property Value

Type: CartParty
The accounting customer party.
See Also

Reference

CartBase Class
Sitecore.Commerce.Entities.Carts Namespace


CartBase.BuyerCustomerParty Property

CartBaseBuyerCustomerParty Property
Gets or sets the buyer customer party.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CartParty BuyerCustomerParty { get; set; }
Public Property BuyerCustomerParty As CartParty
    Get
    Set
public:
property CartParty^ BuyerCustomerParty {
    CartParty^ get ();
    void set (CartParty^ value);
}
member BuyerCustomerParty : CartParty with get, set

Property Value

Type: CartParty
The buyer customer party.
See Also

Reference

CartBase Class
Sitecore.Commerce.Entities.Carts Namespace


CartBase.CartType Property

CartBaseCartType Property
Gets or sets the type of cart.
Examples
  • Regular
  • Wish list

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string CartType { get; set; }
Public Property CartType As String
    Get
    Set
public:
property String^ CartType {
    String^ get ();
    void set (String^ value);
}
member CartType : string with get, set

Property Value

Type: String
The type of the cart.
See Also

Reference

CartBase Class
Sitecore.Commerce.Entities.Carts Namespace


CartBase.CustomerId Property

CartBaseCustomerId Property
Gets or sets the customer ID.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string CustomerId { get; set; }
Public Property CustomerId As String
    Get
    Set
public:
property String^ CustomerId {
    String^ get ();
    void set (String^ value);
}
member CustomerId : string with get, set

Property Value

Type: String
See Also

Reference

CartBase Class
Sitecore.Commerce.Entities.Carts Namespace


CartBase.IsLocked Property

CartBaseIsLocked Property
Gets or sets a value that indicates whether the cart is locked.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> IsLocked { get; set; }
Public Property IsLocked As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsLocked {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member IsLocked : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

CartBase Class
Sitecore.Commerce.Entities.Carts Namespace


CartBase.Name Property

CartBaseName Property
Gets or sets the cart name.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

CartBase Class
Sitecore.Commerce.Entities.Carts Namespace


CartBase.ShopName Property

CartBaseShopName Property
Gets or sets the shop name.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
See Also

Reference

CartBase Class
Sitecore.Commerce.Entities.Carts Namespace


CartBase.Status Property

CartBaseStatus Property
Gets or sets the cart status.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
member Status : string with get, set

Property Value

Type: String
See Also

Reference

CartBase Class
Sitecore.Commerce.Entities.Carts Namespace


CartBase.UserId Property

CartBaseUserId Property
Gets or sets the user ID.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string UserId { get; set; }
Public Property UserId As String
    Get
    Set
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}
member UserId : string with get, set

Property Value

Type: String
See Also

Reference

CartBase Class
Sitecore.Commerce.Entities.Carts Namespace


CartLine Class

CartLine Class
Represents a line in the cart. Each line represents a product and the quantity of the product that a visitor has added to the cart. The CartLine class also represents the position of the line relative to other lines in the cart, which controls the order in which the lines appear when they are displayed.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.CartsCartLine

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class CartLine : Entity
<SerializableAttribute>
Public Class CartLine
    Inherits Entity
[SerializableAttribute]
public ref class CartLine : public Entity
[<SerializableAttribute>]
type CartLine =
    class
        inherit Entity
    end

The CartLine type exposes the following members.

Constructors
 | Name | Description
Public method | CartLine | Initializes a new instance of the CartLine class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
 | Adjustments | Gets or sets the collection of adjustments that contains charges and discounts that are applied to the cart line. The actual content of the adjustments are provided by the external commerce system.
Public property | ExternalCartLineId | Gets or sets the external cart line ID. It is a unique identifier for the cart line in the commerce system. It is empty when you add cart lines and can be set by the external commerce system. You can use it to remove or update cart lines.
Public property | LineNumber | Gets or sets the cart line ID. It is a unique identifier that represents the position of the cart line in the cart. It is empty when you add the cart line and is set by the external commerce system. You can use it to remove or update cart lines.
Public property | Product | Gets or sets the object that represents the actual product.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Quantity | Gets or sets the quantity of a product in the cart line.
Public property | SubLines | Gets or sets the cart line sublines.
Public property | Total | Gets or sets the total of the cart line. It represents the total price of the product. If no break-pricing or other price adjustments are applied, this value is the same as the total price of the product (or subitem) multiplied by the quantity including the adjustments. It is reserved for the pricing service layer and you should not change its value when you add, remove, or update the cart lines.
Top
See Also

Reference

Sitecore.Commerce.Entities.Carts Namespace


CartLine Constructor

CartLine Constructor
Initializes a new instance of the CartLine class

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CartLine()
Public Sub New
public:
CartLine()
new : unit -> CartLine
See Also

Reference

CartLine Class
Sitecore.Commerce.Entities.Carts Namespace


CartLine Methods

CartLine Methods

The CartLine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CartLine Class
Sitecore.Commerce.Entities.Carts Namespace


CartLine Properties

CartLine Properties

The CartLine type exposes the following members.

Properties
 | Name | Description
 | Adjustments | Gets or sets the collection of adjustments that contains charges and discounts that are applied to the cart line. The actual content of the adjustments are provided by the external commerce system.
Public property | ExternalCartLineId | Gets or sets the external cart line ID. It is a unique identifier for the cart line in the commerce system. It is empty when you add cart lines and can be set by the external commerce system. You can use it to remove or update cart lines.
Public property | LineNumber | Gets or sets the cart line ID. It is a unique identifier that represents the position of the cart line in the cart. It is empty when you add the cart line and is set by the external commerce system. You can use it to remove or update cart lines.
Public property | Product | Gets or sets the object that represents the actual product.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Quantity | Gets or sets the quantity of a product in the cart line.
Public property | SubLines | Gets or sets the cart line sublines.
Public property | Total | Gets or sets the total of the cart line. It represents the total price of the product. If no break-pricing or other price adjustments are applied, this value is the same as the total price of the product (or subitem) multiplied by the quantity including the adjustments. It is reserved for the pricing service layer and you should not change its value when you add, remove, or update the cart lines.
Top
See Also

Reference

CartLine Class
Sitecore.Commerce.Entities.Carts Namespace


CartLine.Adjustments Property

CartLineAdjustments Property
Gets or sets the collection of adjustments that contains charges and discounts that are applied to the cart line. The actual content of the adjustments are provided by the external commerce system.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection Adjustments { get; set; }
Public Property Adjustments As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ Adjustments {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member Adjustments : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
Examples
  • Coupon codes that are manually triggered
  • Shipping charges that are automatically triggered
See Also

Reference

CartLine Class
Sitecore.Commerce.Entities.Carts Namespace


CartLine.ExternalCartLineId Property

CartLineExternalCartLineId Property
Gets or sets the external cart line ID. It is a unique identifier for the cart line in the commerce system. It is empty when you add cart lines and can be set by the external commerce system. You can use it to remove or update cart lines.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ExternalCartLineId { get; set; }
Public Property ExternalCartLineId As String
    Get
    Set
public:
property String^ ExternalCartLineId {
    String^ get ();
    void set (String^ value);
}
member ExternalCartLineId : string with get, set

Property Value

Type: String
See Also

Reference

CartLine Class
Sitecore.Commerce.Entities.Carts Namespace


CartLine.LineNumber Property

CartLineLineNumber Property
Gets or sets the cart line ID. It is a unique identifier that represents the position of the cart line in the cart. It is empty when you add the cart line and is set by the external commerce system. You can use it to remove or update cart lines.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public uint LineNumber { get; set; }
Public Property LineNumber As UInteger
    Get
    Set
public:
property unsigned int LineNumber {
    unsigned int get ();
    void set (unsigned int value);
}
member LineNumber : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

CartLine Class
Sitecore.Commerce.Entities.Carts Namespace


CartLine.Product Property

CartLineProduct Property
Gets or sets the object that represents the actual product.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CartProduct Product { get; set; }
Public Property Product As CartProduct
    Get
    Set
public:
property CartProduct^ Product {
    CartProduct^ get ();
    void set (CartProduct^ value);
}
member Product : CartProduct with get, set

Property Value

Type: CartProduct
See Also

Reference

CartLine Class
Sitecore.Commerce.Entities.Carts Namespace


CartLine.Quantity Property

CartLineQuantity Property
Gets or sets the quantity of a product in the cart line.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public uint Quantity { get; set; }
Public Property Quantity As UInteger
    Get
    Set
public:
property unsigned int Quantity {
    unsigned int get ();
    void set (unsigned int value);
}
member Quantity : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

CartLine Class
Sitecore.Commerce.Entities.Carts Namespace


CartLine.SubLines Property

CartLineSubLines Property
Gets or sets the cart line sublines.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection SubLines { get; set; }
Public Property SubLines As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ SubLines {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member SubLines : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
See Also

Reference

CartLine Class
Sitecore.Commerce.Entities.Carts Namespace


CartLine.Total Property

CartLineTotal Property
Gets or sets the total of the cart line. It represents the total price of the product. If no break-pricing or other price adjustments are applied, this value is the same as the total price of the product (or subitem) multiplied by the quantity including the adjustments. It is reserved for the pricing service layer and you should not change its value when you add, remove, or update the cart lines.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Total Total { get; set; }
Public Property Total As Total
    Get
    Set
public:
property Total^ Total {
    Total^ get ();
    void set (Total^ value);
}
member Total : Total with get, set

Property Value

Type: Total
See Also

Reference

CartLine Class
Sitecore.Commerce.Entities.Carts Namespace


CartOption Class

CartOption Class
Represents a configurable or variable value that is specific to a product in the cart. An example of an option is an engraving on a personalized product. When the engraving service is added to the cart, the text to be engraved is also required. The CartOption represents this. If an option has an additional charge, the option is represented as a separate total on a new cart line. The option is only used to describe variables or settings on a specific product, not adjustments or pricing changes.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.CartsCartOption

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class CartOption : Entity
<SerializableAttribute>
Public Class CartOption
    Inherits Entity
[SerializableAttribute]
public ref class CartOption : public Entity
[<SerializableAttribute>]
type CartOption =
    class
        inherit Entity
    end

The CartOption type exposes the following members.

Constructors
 | Name | Description
Public method | CartOption | Initializes a new instance of the CartOption class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Description | Gets or sets the description. The description property is optional and explains the option, for example, "engraving" and "names on t-shirts."
Public property | OptionId | Gets or sets the internal ID of the option. The ID is typically provided by Sitecore when the user adds an option to the cart line.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Value | Gets or sets the the actual custom value.
Top
See Also

Reference

Sitecore.Commerce.Entities.Carts Namespace


CartOption Constructor

CartOption Constructor
Initializes a new instance of the CartOption class

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CartOption()
Public Sub New
public:
CartOption()
new : unit -> CartOption
See Also

Reference

CartOption Class
Sitecore.Commerce.Entities.Carts Namespace


CartOption Methods

CartOption Methods

The CartOption type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CartOption Class
Sitecore.Commerce.Entities.Carts Namespace


CartOption Properties

CartOption Properties

The CartOption type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets the description. The description property is optional and explains the option, for example, "engraving" and "names on t-shirts."
Public property | OptionId | Gets or sets the internal ID of the option. The ID is typically provided by Sitecore when the user adds an option to the cart line.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Value | Gets or sets the the actual custom value.
Top
See Also

Reference

CartOption Class
Sitecore.Commerce.Entities.Carts Namespace


CartOption.Description Property

CartOptionDescription Property
Gets or sets the description. The description property is optional and explains the option, for example, "engraving" and "names on t-shirts."

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

CartOption Class
Sitecore.Commerce.Entities.Carts Namespace


CartOption.OptionId Property

CartOptionOptionId Property
Gets or sets the internal ID of the option. The ID is typically provided by Sitecore when the user adds an option to the cart line.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string OptionId { get; set; }
Public Property OptionId As String
    Get
    Set
public:
property String^ OptionId {
    String^ get ();
    void set (String^ value);
}
member OptionId : string with get, set

Property Value

Type: String
See Also

Reference

CartOption Class
Sitecore.Commerce.Entities.Carts Namespace


CartOption.Value Property

CartOptionValue Property
Gets or sets the the actual custom value.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

CartOption Class
Sitecore.Commerce.Entities.Carts Namespace


CartParty Class

CartParty Class
Defines the CartParty class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.CartsCartParty

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class CartParty : MappedEntity
<SerializableAttribute>
Public Class CartParty
    Inherits MappedEntity
[SerializableAttribute]
public ref class CartParty : public MappedEntity
[<SerializableAttribute>]
type CartParty =
    class
        inherit MappedEntity
    end

The CartParty type exposes the following members.

Constructors
 | Name | Description
Public method | CartParty | Initializes a new instance of the CartParty class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the name.
Public property | PartyID | Gets or sets the party identifier.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Carts Namespace


CartParty Constructor

CartParty Constructor
Initializes a new instance of the CartParty class

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CartParty()
Public Sub New
public:
CartParty()
new : unit -> CartParty
See Also

Reference

CartParty Class
Sitecore.Commerce.Entities.Carts Namespace


CartParty Methods

CartParty Methods

The CartParty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CartParty Class
Sitecore.Commerce.Entities.Carts Namespace


CartParty Properties

CartParty Properties

The CartParty type exposes the following members.

Properties
 | Name | Description
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the name.
Public property | PartyID | Gets or sets the party identifier.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

CartParty Class
Sitecore.Commerce.Entities.Carts Namespace


CartParty.Name Property

CartPartyName Property
Gets or sets the name.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

CartParty Class
Sitecore.Commerce.Entities.Carts Namespace


CartParty.PartyID Property

CartPartyPartyID Property
Gets or sets the party identifier.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string PartyID { get; set; }
Public Property PartyID As String
    Get
    Set
public:
property String^ PartyID {
    String^ get ();
    void set (String^ value);
}
member PartyID : string with get, set

Property Value

Type: String
The party identifier.
See Also

Reference

CartParty Class
Sitecore.Commerce.Entities.Carts Namespace


CartProduct Class

CartProduct Class
Represents a product on a cart line, or, in some cases, a subitem of a cart product such as insurance.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.CartsCartProduct

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class CartProduct : Entity
<SerializableAttribute>
Public Class CartProduct
    Inherits Entity
[SerializableAttribute]
public ref class CartProduct : public Entity
[<SerializableAttribute>]
type CartProduct =
    class
        inherit Entity
    end

The CartProduct type exposes the following members.

Constructors
 | Name | Description
Public method | CartProduct | Initializes a new instance of the CartProduct class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Adjustments | Gets or sets a group of adjustments that describes the charges or the discounts that are applied to a product.
Public property | InStockDate | Gets or sets the product in-stock date. You can assign a value to the stock status property when you add or update cart lines in the cart.
Public property | LineNumber | Gets or sets the number of the cart line that also represents the position of the product in the cart.
 | Options | Gets or sets the product options that are specified by the visitor.
Public property | Price | Gets or sets the product price. You can assign a value to the Price property when you add or update cart lines in the cart. When the GetCartTotal pipeline is called, the Pricing service layer sets the product property.
Public property | ProductId | Gets or sets a unique identifier for the product in the external commerce system.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | ShippingDate | Gets or sets the product shipping date. You can assign a value to the stock status property when you add or update cart lines in the cart.
Public property | SitecoreProductItemId | Gets or sets the Sitecore product item ID. You can use the SitecoreProductItemId property to reference a product item in Sitecore directly.
Public property | StockStatus | Gets or sets the product stock status. You can assign a value to the stock status property when you add or update cart lines in the cart.
Top
See Also

Reference

Sitecore.Commerce.Entities.Carts Namespace


CartProduct Constructor

CartProduct Constructor
Initializes a new instance of the CartProduct class

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CartProduct()
Public Sub New
public:
CartProduct()
new : unit -> CartProduct
See Also

Reference

CartProduct Class
Sitecore.Commerce.Entities.Carts Namespace


CartProduct Methods

CartProduct Methods

The CartProduct type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CartProduct Class
Sitecore.Commerce.Entities.Carts Namespace


CartProduct Properties

CartProduct Properties

The CartProduct type exposes the following members.

Properties
 | Name | Description
Public property | Adjustments | Gets or sets a group of adjustments that describes the charges or the discounts that are applied to a product.
Public property | InStockDate | Gets or sets the product in-stock date. You can assign a value to the stock status property when you add or update cart lines in the cart.
Public property | LineNumber | Gets or sets the number of the cart line that also represents the position of the product in the cart.
 | Options | Gets or sets the product options that are specified by the visitor.
Public property | Price | Gets or sets the product price. You can assign a value to the Price property when you add or update cart lines in the cart. When the GetCartTotal pipeline is called, the Pricing service layer sets the product property.
Public property | ProductId | Gets or sets a unique identifier for the product in the external commerce system.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | ShippingDate | Gets or sets the product shipping date. You can assign a value to the stock status property when you add or update cart lines in the cart.
Public property | SitecoreProductItemId | Gets or sets the Sitecore product item ID. You can use the SitecoreProductItemId property to reference a product item in Sitecore directly.
Public property | StockStatus | Gets or sets the product stock status. You can assign a value to the stock status property when you add or update cart lines in the cart.
Top
See Also

Reference

CartProduct Class
Sitecore.Commerce.Entities.Carts Namespace


CartProduct.Adjustments Property

CartProductAdjustments Property
Gets or sets a group of adjustments that describes the charges or the discounts that are applied to a product.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection Adjustments { get; set; }
Public Property Adjustments As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ Adjustments {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member Adjustments : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
See Also

Reference

CartProduct Class
Sitecore.Commerce.Entities.Carts Namespace


CartProduct.InStockDate Property

CartProductInStockDate Property
Gets or sets the product in-stock date. You can assign a value to the stock status property when you add or update cart lines in the cart.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> InStockDate { get; set; }
Public Property InStockDate As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> InStockDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member InStockDate : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

CartProduct Class
Sitecore.Commerce.Entities.Carts Namespace


CartProduct.LineNumber Property

CartProductLineNumber Property
Gets or sets the number of the cart line that also represents the position of the product in the cart.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public uint LineNumber { get; set; }
Public Property LineNumber As UInteger
    Get
    Set
public:
property unsigned int LineNumber {
    unsigned int get ();
    void set (unsigned int value);
}
member LineNumber : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

CartProduct Class
Sitecore.Commerce.Entities.Carts Namespace


CartProduct.Options Property

CartProductOptions Property
Gets or sets the product options that are specified by the visitor.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection Options { get; set; }
Public Property Options As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ Options {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member Options : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
Examples
engraving=Adam
See Also

Reference

CartProduct Class
Sitecore.Commerce.Entities.Carts Namespace


CartProduct.Price Property

CartProductPrice Property
Gets or sets the product price. You can assign a value to the Price property when you add or update cart lines in the cart. When the GetCartTotal pipeline is called, the Pricing service layer sets the product property.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Price Price { get; set; }
Public Property Price As Price
    Get
    Set
public:
property Price^ Price {
    Price^ get ();
    void set (Price^ value);
}
member Price : Price with get, set

Property Value

Type: Price
See Also

Reference

CartProduct Class
Sitecore.Commerce.Entities.Carts Namespace


CartProduct.ProductId Property

CartProductProductId Property
Gets or sets a unique identifier for the product in the external commerce system.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ProductId { get; set; }
Public Property ProductId As String
    Get
    Set
public:
property String^ ProductId {
    String^ get ();
    void set (String^ value);
}
member ProductId : string with get, set

Property Value

Type: String
See Also

Reference

CartProduct Class
Sitecore.Commerce.Entities.Carts Namespace


CartProduct.ShippingDate Property

CartProductShippingDate Property
Gets or sets the product shipping date. You can assign a value to the stock status property when you add or update cart lines in the cart.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> ShippingDate { get; set; }
Public Property ShippingDate As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> ShippingDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member ShippingDate : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

CartProduct Class
Sitecore.Commerce.Entities.Carts Namespace


CartProduct.SitecoreProductItemId Property

CartProductSitecoreProductItemId Property
Gets or sets the Sitecore product item ID. You can use the SitecoreProductItemId property to reference a product item in Sitecore directly.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ID SitecoreProductItemId { get; set; }
Public Property SitecoreProductItemId As ID
    Get
    Set
public:
property ID^ SitecoreProductItemId {
    ID^ get ();
    void set (ID^ value);
}
member SitecoreProductItemId : ID with get, set

Property Value

Type: ID
See Also

Reference

CartProduct Class
Sitecore.Commerce.Entities.Carts Namespace


CartProduct.StockStatus Property

CartProductStockStatus Property
Gets or sets the product stock status. You can assign a value to the stock status property when you add or update cart lines in the cart.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockStatus StockStatus { get; set; }
Public Property StockStatus As StockStatus
    Get
    Set
public:
property StockStatus^ StockStatus {
    StockStatus^ get ();
    void set (StockStatus^ value);
}
member StockStatus : StockStatus with get, set

Property Value

Type: StockStatus
See Also

Reference

CartProduct Class
Sitecore.Commerce.Entities.Carts Namespace


PaymentInfo Class

PaymentInfo Class
Defines the PaymentInfo class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.CartsPaymentInfo

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PaymentInfo : MappedEntity
<SerializableAttribute>
Public Class PaymentInfo
    Inherits MappedEntity
[SerializableAttribute]
public ref class PaymentInfo : public MappedEntity
[<SerializableAttribute>]
type PaymentInfo =
    class
        inherit MappedEntity
    end

The PaymentInfo type exposes the following members.

Constructors
 | Name | Description
Public method | PaymentInfo | Initializes a new instance of the PaymentInfo class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | LineIDs | Gets or sets the line item id list.
Public property | PartyID | Gets or sets the party identifier.
Public property | PaymentMethodID | Gets or sets the payment method identifier.
Public property | PaymentProviderID | Gets or sets the payment provider identifier.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Carts Namespace


PaymentInfo Constructor

PaymentInfo Constructor
Initializes a new instance of the PaymentInfo class

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PaymentInfo()
Public Sub New
public:
PaymentInfo()
new : unit -> PaymentInfo
See Also

Reference

PaymentInfo Class
Sitecore.Commerce.Entities.Carts Namespace


PaymentInfo Methods

PaymentInfo Methods

The PaymentInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PaymentInfo Class
Sitecore.Commerce.Entities.Carts Namespace


PaymentInfo Properties

PaymentInfo Properties

The PaymentInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | LineIDs | Gets or sets the line item id list.
Public property | PartyID | Gets or sets the party identifier.
Public property | PaymentMethodID | Gets or sets the payment method identifier.
Public property | PaymentProviderID | Gets or sets the payment provider identifier.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

PaymentInfo Class
Sitecore.Commerce.Entities.Carts Namespace


PaymentInfo.LineIDs Property

PaymentInfoLineIDs Property
Gets or sets the line item id list.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection LineIDs { get; set; }
Public Property LineIDs As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ LineIDs {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member LineIDs : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The line item id list.
See Also

Reference

PaymentInfo Class
Sitecore.Commerce.Entities.Carts Namespace


PaymentInfo.PartyID Property

PaymentInfoPartyID Property
Gets or sets the party identifier.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string PartyID { get; set; }
Public Property PartyID As String
    Get
    Set
public:
property String^ PartyID {
    String^ get ();
    void set (String^ value);
}
member PartyID : string with get, set

Property Value

Type: String
The party identifier.
See Also

Reference

PaymentInfo Class
Sitecore.Commerce.Entities.Carts Namespace


PaymentInfo.PaymentMethodID Property

PaymentInfoPaymentMethodID Property
Gets or sets the payment method identifier.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string PaymentMethodID { get; set; }
Public Property PaymentMethodID As String
    Get
    Set
public:
property String^ PaymentMethodID {
    String^ get ();
    void set (String^ value);
}
member PaymentMethodID : string with get, set

Property Value

Type: String
The payment method identifier.
See Also

Reference

PaymentInfo Class
Sitecore.Commerce.Entities.Carts Namespace


PaymentInfo.PaymentProviderID Property

PaymentInfoPaymentProviderID Property
Gets or sets the payment provider identifier.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string PaymentProviderID { get; set; }
Public Property PaymentProviderID As String
    Get
    Set
public:
property String^ PaymentProviderID {
    String^ get ();
    void set (String^ value);
}
member PaymentProviderID : string with get, set

Property Value

Type: String
The payment provider identifier.
See Also

Reference

PaymentInfo Class
Sitecore.Commerce.Entities.Carts Namespace


ShippingInfo Class

ShippingInfo Class
Defines the ShippingInfo class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.CartsShippingInfo

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ShippingInfo : MappedEntity
<SerializableAttribute>
Public Class ShippingInfo
    Inherits MappedEntity
[SerializableAttribute]
public ref class ShippingInfo : public MappedEntity
[<SerializableAttribute>]
type ShippingInfo =
    class
        inherit MappedEntity
    end

The ShippingInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ShippingInfo | Initializes a new instance of the ShippingInfo class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | LineIDs | Gets or sets the line item id list.
Public property | PartyID | Gets or sets the party identifier.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | ShippingMethodID | Gets or sets the shipping method identifier.
Public property | ShippingProviderID | Gets or sets the shipping provider identifier.
Top
See Also

Reference

Sitecore.Commerce.Entities.Carts Namespace


ShippingInfo Constructor

ShippingInfo Constructor
Initializes a new instance of the ShippingInfo class

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ShippingInfo()
Public Sub New
public:
ShippingInfo()
new : unit -> ShippingInfo
See Also

Reference

ShippingInfo Class
Sitecore.Commerce.Entities.Carts Namespace


ShippingInfo Methods

ShippingInfo Methods

The ShippingInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ShippingInfo Class
Sitecore.Commerce.Entities.Carts Namespace


ShippingInfo Properties

ShippingInfo Properties

The ShippingInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | LineIDs | Gets or sets the line item id list.
Public property | PartyID | Gets or sets the party identifier.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | ShippingMethodID | Gets or sets the shipping method identifier.
Public property | ShippingProviderID | Gets or sets the shipping provider identifier.
Top
See Also

Reference

ShippingInfo Class
Sitecore.Commerce.Entities.Carts Namespace


ShippingInfo.LineIDs Property

ShippingInfoLineIDs Property
Gets or sets the line item id list.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection LineIDs { get; set; }
Public Property LineIDs As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ LineIDs {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member LineIDs : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The line item id list.
See Also

Reference

ShippingInfo Class
Sitecore.Commerce.Entities.Carts Namespace


ShippingInfo.PartyID Property

ShippingInfoPartyID Property
Gets or sets the party identifier.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string PartyID { get; set; }
Public Property PartyID As String
    Get
    Set
public:
property String^ PartyID {
    String^ get ();
    void set (String^ value);
}
member PartyID : string with get, set

Property Value

Type: String
The party identifier.
See Also

Reference

ShippingInfo Class
Sitecore.Commerce.Entities.Carts Namespace


ShippingInfo.ShippingMethodID Property

ShippingInfoShippingMethodID Property
Gets or sets the shipping method identifier.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShippingMethodID { get; set; }
Public Property ShippingMethodID As String
    Get
    Set
public:
property String^ ShippingMethodID {
    String^ get ();
    void set (String^ value);
}
member ShippingMethodID : string with get, set

Property Value

Type: String
The shipping method identifier.
See Also

Reference

ShippingInfo Class
Sitecore.Commerce.Entities.Carts Namespace


ShippingInfo.ShippingProviderID Property

ShippingInfoShippingProviderID Property
Gets or sets the shipping provider identifier.

Namespace: Sitecore.Commerce.Entities.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShippingProviderID { get; set; }
Public Property ShippingProviderID As String
    Get
    Set
public:
property String^ ShippingProviderID {
    String^ get ();
    void set (String^ value);
}
member ShippingProviderID : string with get, set

Property Value

Type: String
The shipping provider identifier.
See Also

Reference

ShippingInfo Class
Sitecore.Commerce.Entities.Carts Namespace


Sitecore.Commerce.Entities.Customers Namespace

Sitecore.Commerce.Entities.Customers Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Entities.Customers"]

Classes
 | Class | Description
Public class | CommerceCustomer | Represents a person in business-to-consumer scenarios and a company in business-to-business scenarios. The CommerceCustomer class implements the Entity class.
Public class | CommerceUser | Represents a user account. A user is a visitor to a webshop that has identified themselves by creating a login account. The CommerceUser entity is always extended to include custom information that is specific to the external commerce system. The CommerceUser class implements the Entity class.
Public class | CustomerParty | Defines the CustomerParty class.
Public class | CustomerPartyTypes | Defines the types of customer party.


CommerceCustomer Class

CommerceCustomer Class
Represents a person in business-to-consumer scenarios and a company in business-to-business scenarios. The CommerceCustomer class implements the Entity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.CustomersCommerceCustomer

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class CommerceCustomer : MappedEntity
<SerializableAttribute>
Public Class CommerceCustomer
    Inherits MappedEntity
[SerializableAttribute]
public ref class CommerceCustomer : public MappedEntity
[<SerializableAttribute>]
type CommerceCustomer =
    class
        inherit MappedEntity
    end

The CommerceCustomer type exposes the following members.

Constructors
 | Name | Description
Public method | CommerceCustomer | Initializes a new instance of the CommerceCustomer class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | IsDisabled | Gets or sets a value indicating whether [is disabled].
Public property | Name | Gets or sets the name of the customer.
Public property | Parties | Gets or sets customer parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Shops | Gets or sets the shops.
Public property | Users | Gets or sets the user ids.
Top
See Also

Reference

Sitecore.Commerce.Entities.Customers Namespace


CommerceCustomer Constructor

CommerceCustomer Constructor
Initializes a new instance of the CommerceCustomer class

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CommerceCustomer()
Public Sub New
public:
CommerceCustomer()
new : unit -> CommerceCustomer
See Also

Reference

CommerceCustomer Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceCustomer Methods

CommerceCustomer Methods

The CommerceCustomer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommerceCustomer Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceCustomer Properties

CommerceCustomer Properties

The CommerceCustomer type exposes the following members.

Properties
 | Name | Description
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | IsDisabled | Gets or sets a value indicating whether [is disabled].
Public property | Name | Gets or sets the name of the customer.
Public property | Parties | Gets or sets customer parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Shops | Gets or sets the shops.
Public property | Users | Gets or sets the user ids.
Top
See Also

Reference

CommerceCustomer Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceCustomer.IsDisabled Property

CommerceCustomerIsDisabled Property
Gets or sets a value indicating whether [is disabled].

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public bool IsDisabled { get; set; }
Public Property IsDisabled As Boolean
    Get
    Set
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}
member IsDisabled : bool with get, set

Property Value

Type: Boolean
true if [is disabled]; otherwise, false.
See Also

Reference

CommerceCustomer Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceCustomer.Name Property

CommerceCustomerName Property
Gets or sets the name of the customer.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name of the customer.
See Also

Reference

CommerceCustomer Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceCustomer.Parties Property

CommerceCustomerParties Property
Gets or sets customer parties.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection Parties { get; set; }
Public Property Parties As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ Parties {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member Parties : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The parties.
See Also

Reference

CommerceCustomer Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceCustomer.Shops Property

CommerceCustomerShops Property
Gets or sets the shops.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection Shops { get; set; }
Public Property Shops As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ Shops {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member Shops : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The shops.
See Also

Reference

CommerceCustomer Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceCustomer.Users Property

CommerceCustomerUsers Property
Gets or sets the user ids.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection Users { get; set; }
Public Property Users As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ Users {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member Users : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The user ids.
See Also

Reference

CommerceCustomer Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser Class

CommerceUser Class
Represents a user account. A user is a visitor to a webshop that has identified themselves by creating a login account. The CommerceUser entity is always extended to include custom information that is specific to the external commerce system. The CommerceUser class implements the Entity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.CustomersCommerceUser

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class CommerceUser : MappedEntity
<SerializableAttribute>
Public Class CommerceUser
    Inherits MappedEntity
[SerializableAttribute]
public ref class CommerceUser : public MappedEntity
[<SerializableAttribute>]
type CommerceUser =
    class
        inherit MappedEntity
    end

The CommerceUser type exposes the following members.

Constructors
 | Name | Description
Public method | CommerceUser | Initializes a new instance of the CommerceUser class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Comment | Gets or sets the text that represents the comment.
Public property | CreationDate | Gets or sets the time stamp that indicates the creation date and time of the account.
Public property | Customers | Gets or sets the customer acccount ids that the visitor can use.
Public property | Email | Gets or sets the email of the user.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | FirstName | Gets or sets the first name of the user.
Public property | IsDisabled | Gets or sets a value indicating whether this instance is disabled.
Public property | LastActivityDate | Gets or sets the time stamp that indicates the last time that the user was authenticated or accessed the shop.
Public property | LastDisabledDate | Gets or sets the time stamp that indicates the last time that the user account was disabled.
Public property | LastLoginDate | Gets or sets the time stamp that indicates the last time that the user was authenticated.
Public property | LastName | Gets or sets the last name of the user.
Public property | LastPasswordChangedDate | Gets or sets the time stamp that indicates the last time that the user's password was updated.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Shops | Gets or sets the shops that the user has access to.
Public property | UserName | Gets or sets the name of the user.
Top
See Also

Reference

Sitecore.Commerce.Entities.Customers Namespace


CommerceUser Constructor

CommerceUser Constructor
Initializes a new instance of the CommerceUser class

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CommerceUser()
Public Sub New
public:
CommerceUser()
new : unit -> CommerceUser
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser Methods

CommerceUser Methods

The CommerceUser type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser Properties

CommerceUser Properties

The CommerceUser type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or sets the text that represents the comment.
Public property | CreationDate | Gets or sets the time stamp that indicates the creation date and time of the account.
Public property | Customers | Gets or sets the customer acccount ids that the visitor can use.
Public property | Email | Gets or sets the email of the user.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | FirstName | Gets or sets the first name of the user.
Public property | IsDisabled | Gets or sets a value indicating whether this instance is disabled.
Public property | LastActivityDate | Gets or sets the time stamp that indicates the last time that the user was authenticated or accessed the shop.
Public property | LastDisabledDate | Gets or sets the time stamp that indicates the last time that the user account was disabled.
Public property | LastLoginDate | Gets or sets the time stamp that indicates the last time that the user was authenticated.
Public property | LastName | Gets or sets the last name of the user.
Public property | LastPasswordChangedDate | Gets or sets the time stamp that indicates the last time that the user's password was updated.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Shops | Gets or sets the shops that the user has access to.
Public property | UserName | Gets or sets the name of the user.
Top
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser.Comment Property

CommerceUserComment Property
Gets or sets the text that represents the comment.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
member Comment : string with get, set

Property Value

Type: String
The comment.
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser.CreationDate Property

CommerceUserCreationDate Property
Gets or sets the time stamp that indicates the creation date and time of the account.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DateTime CreationDate { get; set; }
Public Property CreationDate As DateTime
    Get
    Set
public:
property DateTime CreationDate {
    DateTime get ();
    void set (DateTime value);
}
member CreationDate : DateTime with get, set

Property Value

Type: DateTime
The creation date and time.
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser.Customers Property

CommerceUserCustomers Property
Gets or sets the customer acccount ids that the visitor can use.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection Customers { get; set; }
Public Property Customers As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ Customers {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member Customers : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The customer account.
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser.Email Property

CommerceUserEmail Property
Gets or sets the email of the user.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}
member Email : string with get, set

Property Value

Type: String
The email.
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser.FirstName Property

CommerceUserFirstName Property
Gets or sets the first name of the user.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string FirstName { get; set; }
Public Property FirstName As String
    Get
    Set
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}
member FirstName : string with get, set

Property Value

Type: String
The first name.
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser.IsDisabled Property

CommerceUserIsDisabled Property
Gets or sets a value indicating whether this instance is disabled.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public bool IsDisabled { get; set; }
Public Property IsDisabled As Boolean
    Get
    Set
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}
member IsDisabled : bool with get, set

Property Value

Type: Boolean
true if this instance is disabled.
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser.LastActivityDate Property

CommerceUserLastActivityDate Property
Gets or sets the time stamp that indicates the last time that the user was authenticated or accessed the shop.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DateTime LastActivityDate { get; set; }
Public Property LastActivityDate As DateTime
    Get
    Set
public:
property DateTime LastActivityDate {
    DateTime get ();
    void set (DateTime value);
}
member LastActivityDate : DateTime with get, set

Property Value

Type: DateTime
The last activity date.
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser.LastDisabledDate Property

CommerceUserLastDisabledDate Property
Gets or sets the time stamp that indicates the last time that the user account was disabled.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DateTime LastDisabledDate { get; set; }
Public Property LastDisabledDate As DateTime
    Get
    Set
public:
property DateTime LastDisabledDate {
    DateTime get ();
    void set (DateTime value);
}
member LastDisabledDate : DateTime with get, set

Property Value

Type: DateTime
The last disabled date.
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser.LastLoginDate Property

CommerceUserLastLoginDate Property
Gets or sets the time stamp that indicates the last time that the user was authenticated.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DateTime LastLoginDate { get; set; }
Public Property LastLoginDate As DateTime
    Get
    Set
public:
property DateTime LastLoginDate {
    DateTime get ();
    void set (DateTime value);
}
member LastLoginDate : DateTime with get, set

Property Value

Type: DateTime
The last login date.
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser.LastName Property

CommerceUserLastName Property
Gets or sets the last name of the user.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string LastName { get; set; }
Public Property LastName As String
    Get
    Set
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}
member LastName : string with get, set

Property Value

Type: String
The last name.
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser.LastPasswordChangedDate Property

CommerceUserLastPasswordChangedDate Property
Gets or sets the time stamp that indicates the last time that the user's password was updated.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DateTime LastPasswordChangedDate { get; set; }
Public Property LastPasswordChangedDate As DateTime
    Get
    Set
public:
property DateTime LastPasswordChangedDate {
    DateTime get ();
    void set (DateTime value);
}
member LastPasswordChangedDate : DateTime with get, set

Property Value

Type: DateTime
The last password changed date.
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser.Shops Property

CommerceUserShops Property
Gets or sets the shops that the user has access to.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection Shops { get; set; }
Public Property Shops As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ Shops {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member Shops : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The shops.
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CommerceUser.UserName Property

CommerceUserUserName Property
Gets or sets the name of the user.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
The name of the user.
See Also

Reference

CommerceUser Class
Sitecore.Commerce.Entities.Customers Namespace


CustomerParty Class

CustomerParty Class
Defines the CustomerParty class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.CustomersCustomerParty

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class CustomerParty : MappedEntity
<SerializableAttribute>
Public Class CustomerParty
    Inherits MappedEntity
[SerializableAttribute]
public ref class CustomerParty : public MappedEntity
[<SerializableAttribute>]
type CustomerParty =
    class
        inherit MappedEntity
    end

The CustomerParty type exposes the following members.

Constructors
 | Name | Description
Public method | CustomerParty | Initializes a new instance of the CustomerParty class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the name.
Public property | PartyID | Gets or sets the party identifier.
Public property | PartyType | Gets or sets the type of the party.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Customers Namespace


CustomerParty Constructor

CustomerParty Constructor
Initializes a new instance of the CustomerParty class

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CustomerParty()
Public Sub New
public:
CustomerParty()
new : unit -> CustomerParty
See Also

Reference

CustomerParty Class
Sitecore.Commerce.Entities.Customers Namespace


CustomerParty Methods

CustomerParty Methods

The CustomerParty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomerParty Class
Sitecore.Commerce.Entities.Customers Namespace


CustomerParty Properties

CustomerParty Properties

The CustomerParty type exposes the following members.

Properties
 | Name | Description
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the name.
Public property | PartyID | Gets or sets the party identifier.
Public property | PartyType | Gets or sets the type of the party.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

CustomerParty Class
Sitecore.Commerce.Entities.Customers Namespace


CustomerParty.Name Property

CustomerPartyName Property
Gets or sets the name.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

CustomerParty Class
Sitecore.Commerce.Entities.Customers Namespace


CustomerParty.PartyID Property

CustomerPartyPartyID Property
Gets or sets the party identifier.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string PartyID { get; set; }
Public Property PartyID As String
    Get
    Set
public:
property String^ PartyID {
    String^ get ();
    void set (String^ value);
}
member PartyID : string with get, set

Property Value

Type: String
The party identifier.
See Also

Reference

CustomerParty Class
Sitecore.Commerce.Entities.Customers Namespace


CustomerParty.PartyType Property

CustomerPartyPartyType Property
Gets or sets the type of the party.

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public uint PartyType { get; set; }
Public Property PartyType As UInteger
    Get
    Set
public:
property unsigned int PartyType {
    unsigned int get ();
    void set (unsigned int value);
}
member PartyType : uint32 with get, set

Property Value

Type: UInt32
The type of the party.
See Also

Reference

CustomerParty Class
Sitecore.Commerce.Entities.Customers Namespace


CustomerPartyTypes Class

CustomerPartyTypes Class
Defines the types of customer party.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Entities.CustomersCustomerPartyTypes

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CustomerPartyTypes
Public Class CustomerPartyTypes
public ref class CustomerPartyTypes
type CustomerPartyTypes =  class end

The CustomerPartyTypes type exposes the following members.

Constructors
 | Name | Description
Public method | CustomerPartyTypes | Initializes a new instance of the CustomerPartyTypes class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
AccountingParty | The accounting party
BuyerParty | The buyer party
Top
See Also

Reference

Sitecore.Commerce.Entities.Customers Namespace


CustomerPartyTypes Constructor

CustomerPartyTypes Constructor
Initializes a new instance of the CustomerPartyTypes class

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CustomerPartyTypes()
Public Sub New
public:
CustomerPartyTypes()
new : unit -> CustomerPartyTypes
See Also

Reference

CustomerPartyTypes Class
Sitecore.Commerce.Entities.Customers Namespace


CustomerPartyTypes Fields

CustomerPartyTypes Fields

The CustomerPartyTypes type exposes the following members.

Fields
Name | Description
AccountingParty | The accounting party
BuyerParty | The buyer party
Top
See Also

Reference

CustomerPartyTypes Class
Sitecore.Commerce.Entities.Customers Namespace


CustomerPartyTypes.AccountingParty Field

CustomerPartyTypesAccountingParty Field
The accounting party

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const uint AccountingParty
Public Const AccountingParty As UInteger
public:
literal unsigned int AccountingParty
static val mutable AccountingParty: uint32

Field Value

Type: UInt32
See Also

Reference

CustomerPartyTypes Class
Sitecore.Commerce.Entities.Customers Namespace


CustomerPartyTypes.BuyerParty Field

CustomerPartyTypesBuyerParty Field
The buyer party

Namespace: Sitecore.Commerce.Entities.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const uint BuyerParty
Public Const BuyerParty As UInteger
public:
literal unsigned int BuyerParty
static val mutable BuyerParty: uint32

Field Value

Type: UInt32
See Also

Reference

CustomerPartyTypes Class
Sitecore.Commerce.Entities.Customers Namespace


CustomerPartyTypes Methods

CustomerPartyTypes Methods

The CustomerPartyTypes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomerPartyTypes Class
Sitecore.Commerce.Entities.Customers Namespace


Sitecore.Commerce.Entities.Inventory Namespace

Sitecore.Commerce.Entities.Inventory Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Entities.Inventory"]

Classes
 | Class | Description
Public class | IndexStockInformation | IndexStockInformation represents indexing information for the inventory information about a product.
Public class | InventoryProduct | InventoryProduct represents the product.
Public class | OrderableInformation | Represents when a product is available for purchase. The orderable information provides an estimate as to when a product will become available in case a product is out-of-stock or pre-orderable.
Public class | StockDetailsLevel | StockDetailsLevel represents the level of detail being requested when retrieving stock information.
Public class | StockDetailsLevelConverter | Type converter for the StockDetailsLevel entity.
Public class | StockInformation | Represents the availability of a product. The inventory status is used to determine if and when a product is available for purchase, and how manu units of the product are currently on-hand.
Public class | StockInformationUpdate | StockInformationUpdate is used as a strongly typed composite return value from method GetBackInStockInformation to indicate the product and the locations where it will be back in stock optionally along with availability date and count.
Public class | StockInformationUpdateLocation | StockInformationUpdateLocation is used as a strongly typed value nested only into StockInformationUpdate returned from method GetBackInStockInformation to indicate the locations where the product will be back in stock optionally along with availability date and count
Public class | StockNotificationRequest | Represents data associated with a user request to be notified when a product is back in stock.
Public class | StockNotificationRequestEqualityComparer | Tests two StockNotificationRequest objects for equality.
Public class | StockStatus | Represents the current stock status of a product;
Public class | StockStatusConverter | Type converter for the StockStatus entity.


IndexStockInformation Class

IndexStockInformation Class
IndexStockInformation represents indexing information for the inventory information about a product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.InventoryIndexStockInformation

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class IndexStockInformation : Entity
<SerializableAttribute>
Public Class IndexStockInformation
    Inherits Entity
[SerializableAttribute]
public ref class IndexStockInformation : public Entity
[<SerializableAttribute>]
type IndexStockInformation =
    class
        inherit Entity
    end

The IndexStockInformation type exposes the following members.

Constructors
 | Name | Description
Public method | IndexStockInformation | Initializes a new instance of the IndexStockInformation class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | InStockLocations | Gets or sets the locations where the product is in-stock.
Public property | OrderableLocations | Gets or sets the locations where the product can be ordered from.
Public property | OutOfStockLocations | Gets or sets the locations where the product is out-of-stock.
Public property | PreOrderable | Gets or sets a value indicating whether the product can be pre-ordered.
Public property | Product | Gets or sets the product
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Inventory Namespace


IndexStockInformation Constructor

IndexStockInformation Constructor
Initializes a new instance of the IndexStockInformation class

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IndexStockInformation()
Public Sub New
public:
IndexStockInformation()
new : unit -> IndexStockInformation
See Also

Reference

IndexStockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


IndexStockInformation Methods

IndexStockInformation Methods

The IndexStockInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IndexStockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


IndexStockInformation Properties

IndexStockInformation Properties

The IndexStockInformation type exposes the following members.

Properties
 | Name | Description
Public property | InStockLocations | Gets or sets the locations where the product is in-stock.
Public property | OrderableLocations | Gets or sets the locations where the product can be ordered from.
Public property | OutOfStockLocations | Gets or sets the locations where the product is out-of-stock.
Public property | PreOrderable | Gets or sets a value indicating whether the product can be pre-ordered.
Public property | Product | Gets or sets the product
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

IndexStockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


IndexStockInformation.InStockLocations Property

IndexStockInformationInStockLocations Property
Gets or sets the locations where the product is in-stock.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection InStockLocations { get; set; }
Public Property InStockLocations As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ InStockLocations {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member InStockLocations : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
See Also

Reference

IndexStockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


IndexStockInformation.OrderableLocations Property

IndexStockInformationOrderableLocations Property
Gets or sets the locations where the product can be ordered from.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection OrderableLocations { get; set; }
Public Property OrderableLocations As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ OrderableLocations {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member OrderableLocations : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
See Also

Reference

IndexStockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


IndexStockInformation.OutOfStockLocations Property

IndexStockInformationOutOfStockLocations Property
Gets or sets the locations where the product is out-of-stock.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection OutOfStockLocations { get; set; }
Public Property OutOfStockLocations As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ OutOfStockLocations {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member OutOfStockLocations : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
See Also

Reference

IndexStockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


IndexStockInformation.PreOrderable Property

IndexStockInformationPreOrderable Property
Gets or sets a value indicating whether the product can be pre-ordered.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public bool PreOrderable { get; set; }
Public Property PreOrderable As Boolean
    Get
    Set
public:
property bool PreOrderable {
    bool get ();
    void set (bool value);
}
member PreOrderable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IndexStockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


IndexStockInformation.Product Property

IndexStockInformationProduct Property
Gets or sets the product

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public InventoryProduct Product { get; set; }
Public Property Product As InventoryProduct
    Get
    Set
public:
property InventoryProduct^ Product {
    InventoryProduct^ get ();
    void set (InventoryProduct^ value);
}
member Product : InventoryProduct with get, set

Property Value

Type: InventoryProduct
See Also

Reference

IndexStockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


InventoryProduct Class

InventoryProduct Class
InventoryProduct represents the product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.InventoryInventoryProduct

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class InventoryProduct : Entity
<SerializableAttribute>
Public Class InventoryProduct
    Inherits Entity
[SerializableAttribute]
public ref class InventoryProduct : public Entity
[<SerializableAttribute>]
type InventoryProduct =
    class
        inherit Entity
    end

The InventoryProduct type exposes the following members.

Constructors
 | Name | Description
Public method | InventoryProduct | Initializes a new instance of the InventoryProduct class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ProductId | Gets or sets the unique identifier for the product or product variant in the commerce system.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Inventory Namespace


InventoryProduct Constructor

InventoryProduct Constructor
Initializes a new instance of the InventoryProduct class

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public InventoryProduct()
Public Sub New
public:
InventoryProduct()
new : unit -> InventoryProduct
See Also

Reference

InventoryProduct Class
Sitecore.Commerce.Entities.Inventory Namespace


InventoryProduct Methods

InventoryProduct Methods

The InventoryProduct type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InventoryProduct Class
Sitecore.Commerce.Entities.Inventory Namespace


InventoryProduct Properties

InventoryProduct Properties

The InventoryProduct type exposes the following members.

Properties
 | Name | Description
Public property | ProductId | Gets or sets the unique identifier for the product or product variant in the commerce system.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

InventoryProduct Class
Sitecore.Commerce.Entities.Inventory Namespace


InventoryProduct.ProductId Property

InventoryProductProductId Property
Gets or sets the unique identifier for the product or product variant in the commerce system.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ProductId { get; set; }
Public Property ProductId As String
    Get
    Set
public:
property String^ ProductId {
    String^ get ();
    void set (String^ value);
}
member ProductId : string with get, set

Property Value

Type: String
See Also

Reference

InventoryProduct Class
Sitecore.Commerce.Entities.Inventory Namespace


OrderableInformation Class

OrderableInformation Class
Represents when a product is available for purchase. The orderable information provides an estimate as to when a product will become available in case a product is out-of-stock or pre-orderable.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.InventoryOrderableInformation

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class OrderableInformation : Entity
<SerializableAttribute>
Public Class OrderableInformation
    Inherits Entity
[SerializableAttribute]
public ref class OrderableInformation : public Entity
[<SerializableAttribute>]
type OrderableInformation =
    class
        inherit Entity
    end

The OrderableInformation type exposes the following members.

Constructors
 | Name | Description
Public method | OrderableInformation | Initializes a new instance of the OrderableInformation class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CartQuantityLimit | Gets or sets a limit to the quantity of the product that the visitor can add to his or her cart.
Public property | InStockDate | Gets or sets an ETA date for when the product is back in stock.
Public property | OrderableEndDate | Gets or sets a date and time for which the last orders can be placed for the product.
Public property | OrderableStartDate | Gets or sets a date and time for which the first orders can be placed for the product.
Public property | Product | Gets or sets the product information in the commerce system.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | RemainingQuantity | Gets or sets the quantity of the product that is currently available.
Public property | ShippingDate | Gets or sets an ETA date for when the product is shippable.
Public property | Status | Gets or sets the stock status.
Top
See Also

Reference

Sitecore.Commerce.Entities.Inventory Namespace


OrderableInformation Constructor

OrderableInformation Constructor
Initializes a new instance of the OrderableInformation class

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public OrderableInformation()
Public Sub New
public:
OrderableInformation()
new : unit -> OrderableInformation
See Also

Reference

OrderableInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


OrderableInformation Methods

OrderableInformation Methods

The OrderableInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OrderableInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


OrderableInformation Properties

OrderableInformation Properties

The OrderableInformation type exposes the following members.

Properties
 | Name | Description
Public property | CartQuantityLimit | Gets or sets a limit to the quantity of the product that the visitor can add to his or her cart.
Public property | InStockDate | Gets or sets an ETA date for when the product is back in stock.
Public property | OrderableEndDate | Gets or sets a date and time for which the last orders can be placed for the product.
Public property | OrderableStartDate | Gets or sets a date and time for which the first orders can be placed for the product.
Public property | Product | Gets or sets the product information in the commerce system.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | RemainingQuantity | Gets or sets the quantity of the product that is currently available.
Public property | ShippingDate | Gets or sets an ETA date for when the product is shippable.
Public property | Status | Gets or sets the stock status.
Top
See Also

Reference

OrderableInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


OrderableInformation.CartQuantityLimit Property

OrderableInformationCartQuantityLimit Property
Gets or sets a limit to the quantity of the product that the visitor can add to his or her cart.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public double CartQuantityLimit { get; set; }
Public Property CartQuantityLimit As Double
    Get
    Set
public:
property double CartQuantityLimit {
    double get ();
    void set (double value);
}
member CartQuantityLimit : float with get, set

Property Value

Type: Double
See Also

Reference

OrderableInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


OrderableInformation.InStockDate Property

OrderableInformationInStockDate Property
Gets or sets an ETA date for when the product is back in stock.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> InStockDate { get; set; }
Public Property InStockDate As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> InStockDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member InStockDate : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

OrderableInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


OrderableInformation.OrderableEndDate Property

OrderableInformationOrderableEndDate Property
Gets or sets a date and time for which the last orders can be placed for the product.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> OrderableEndDate { get; set; }
Public Property OrderableEndDate As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> OrderableEndDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member OrderableEndDate : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

OrderableInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


OrderableInformation.OrderableStartDate Property

OrderableInformationOrderableStartDate Property
Gets or sets a date and time for which the first orders can be placed for the product.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> OrderableStartDate { get; set; }
Public Property OrderableStartDate As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> OrderableStartDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member OrderableStartDate : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

OrderableInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


OrderableInformation.Product Property

OrderableInformationProduct Property
Gets or sets the product information in the commerce system.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public InventoryProduct Product { get; set; }
Public Property Product As InventoryProduct
    Get
    Set
public:
property InventoryProduct^ Product {
    InventoryProduct^ get ();
    void set (InventoryProduct^ value);
}
member Product : InventoryProduct with get, set

Property Value

Type: InventoryProduct
See Also

Reference

OrderableInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


OrderableInformation.RemainingQuantity Property

OrderableInformationRemainingQuantity Property
Gets or sets the quantity of the product that is currently available.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public double RemainingQuantity { get; set; }
Public Property RemainingQuantity As Double
    Get
    Set
public:
property double RemainingQuantity {
    double get ();
    void set (double value);
}
member RemainingQuantity : float with get, set

Property Value

Type: Double
See Also

Reference

OrderableInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


OrderableInformation.ShippingDate Property

OrderableInformationShippingDate Property
Gets or sets an ETA date for when the product is shippable.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> ShippingDate { get; set; }
Public Property ShippingDate As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> ShippingDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member ShippingDate : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

OrderableInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


OrderableInformation.Status Property

OrderableInformationStatus Property
Gets or sets the stock status.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockStatus Status { get; set; }
Public Property Status As StockStatus
    Get
    Set
public:
property StockStatus^ Status {
    StockStatus^ get ();
    void set (StockStatus^ value);
}
member Status : StockStatus with get, set

Property Value

Type: StockStatus
See Also

Reference

OrderableInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel Class

StockDetailsLevel Class
StockDetailsLevel represents the level of detail being requested when retrieving stock information.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.InventoryStockDetailsLevel

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class StockDetailsLevel : Entity
<SerializableAttribute>
Public Class StockDetailsLevel
    Inherits Entity
[SerializableAttribute]
public ref class StockDetailsLevel : public Entity
[<SerializableAttribute>]
type StockDetailsLevel =
    class
        inherit Entity
    end

The StockDetailsLevel type exposes the following members.

Constructors
 | Name | Description
Public method | StockDetailsLevel | Initializes an instance of the StockDetailsLevel class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Retrieves a hash code for the object. (Overrides ObjectGetHashCode.)
 | GetKnownValues | Gets a list of the well-known StockDetailsLevel values.
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Top
Operators
Name | Description
(Int32 to StockDetailsLevel) | Implicitly convverts an integer to a StockDetailsLevel.
(StockDetailsLevel to Int32) | Implicitly converts a StockDetailsLevel to an integer.
Top
Fields
Name | Description
All | Indicates that all stock information is to be returned.
AvailibilityFlag | Bit flag representing availability details.
Count | Indicates that the status, availability date, and stock count information is to be returned.
CountFlag | Bit flag representing stock count details.
Status | Indicates that the minimum information is to be returned (only stock status).
StatusAndAvailability | Indicates that the status and availability date information is to be returned.
StatusFlag | Bit flag representing status details.
Top
Properties
 | Name | Description
Public property | Name | Gets the name of the stock details level.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Value | Gets the integer value of the stock details level.
Top
See Also

Reference

Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel Constructor

StockDetailsLevel Constructor
Initializes an instance of the StockDetailsLevel class.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockDetailsLevel(
    int value,
    string name
)
Public Sub New (
    value As Integer,
    name As String
)
public:
StockDetailsLevel(
    int value,
    String^ name
)
new :
        value : int *
        name : string -> StockDetailsLevel

Parameters

value
Type: SystemInt32

[Missing <param name="value"/> documentation for "M:Sitecore.Commerce.Entities.Inventory.StockDetailsLevel.#ctor(System.Int32,System.String)"]

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Sitecore.Commerce.Entities.Inventory.StockDetailsLevel.#ctor(System.Int32,System.String)"]

See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel Fields

StockDetailsLevel Fields

The StockDetailsLevel type exposes the following members.

Fields
Name | Description
All | Indicates that all stock information is to be returned.
AvailibilityFlag | Bit flag representing availability details.
Count | Indicates that the status, availability date, and stock count information is to be returned.
CountFlag | Bit flag representing stock count details.
Status | Indicates that the minimum information is to be returned (only stock status).
StatusAndAvailability | Indicates that the status and availability date information is to be returned.
StatusFlag | Bit flag representing status details.
Top
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel.All Field

StockDetailsLevelAll Field
Indicates that all stock information is to be returned.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static readonly StockDetailsLevel All
Public Shared ReadOnly All As StockDetailsLevel
public:
static initonly StockDetailsLevel^ All
static val All: StockDetailsLevel

Field Value

Type: StockDetailsLevel
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel.AvailibilityFlag Field

StockDetailsLevelAvailibilityFlag Field
Bit flag representing availability details.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const int AvailibilityFlag
Public Const AvailibilityFlag As Integer
public:
literal int AvailibilityFlag
static val mutable AvailibilityFlag: int

Field Value

Type: Int32
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel.Count Field

StockDetailsLevelCount Field
Indicates that the status, availability date, and stock count information is to be returned.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static readonly StockDetailsLevel Count
Public Shared ReadOnly Count As StockDetailsLevel
public:
static initonly StockDetailsLevel^ Count
static val Count: StockDetailsLevel

Field Value

Type: StockDetailsLevel
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel.CountFlag Field

StockDetailsLevelCountFlag Field
Bit flag representing stock count details.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const int CountFlag
Public Const CountFlag As Integer
public:
literal int CountFlag
static val mutable CountFlag: int

Field Value

Type: Int32
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel.Status Field

StockDetailsLevelStatus Field
Indicates that the minimum information is to be returned (only stock status).

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static readonly StockDetailsLevel Status
Public Shared ReadOnly Status As StockDetailsLevel
public:
static initonly StockDetailsLevel^ Status
static val Status: StockDetailsLevel

Field Value

Type: StockDetailsLevel
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel.StatusAndAvailability Field

StockDetailsLevelStatusAndAvailability Field
Indicates that the status and availability date information is to be returned.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static readonly StockDetailsLevel StatusAndAvailability
Public Shared ReadOnly StatusAndAvailability As StockDetailsLevel
public:
static initonly StockDetailsLevel^ StatusAndAvailability
static val StatusAndAvailability: StockDetailsLevel

Field Value

Type: StockDetailsLevel
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel.StatusFlag Field

StockDetailsLevelStatusFlag Field
Bit flag representing status details.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const int StatusFlag
Public Const StatusFlag As Integer
public:
literal int StatusFlag
static val mutable StatusFlag: int

Field Value

Type: Int32
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel Methods

StockDetailsLevel Methods

The StockDetailsLevel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Retrieves a hash code for the object. (Overrides ObjectGetHashCode.)
 | GetKnownValues | Gets a list of the well-known StockDetailsLevel values.
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Top
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel.Equals Method

StockDetailsLevelEquals Method
Determines whether the specified object is equal to the current object.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
True if the specified object is equal to the current object; otherwise false.
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel.GetHashCode Method

StockDetailsLevelGetHashCode Method
Retrieves a hash code for the object.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel.GetKnownValues Method

StockDetailsLevelGetKnownValues Method
Gets a list of the well-known StockDetailsLevel values.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static IReadOnlyCollection GetKnownValues()
Public Shared Function GetKnownValues As IReadOnlyCollection
public:
static IReadOnlyCollection^ GetKnownValues()
static member GetKnownValues : unit -> IReadOnlyCollection

Return Value

Type: IReadOnlyCollectionT
A list of the well-known StockDetailsLevel values.
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel.ToString Method

StockDetailsLevelToString Method
Returns a string that represents the current object.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A string that represents the current object.
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel Type Conversions

StockDetailsLevel Type Conversions
Operators
Name | Description
(Int32 to StockDetailsLevel) | Implicitly convverts an integer to a StockDetailsLevel.
(StockDetailsLevel to Int32) | Implicitly converts a StockDetailsLevel to an integer.
Top
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel Implicit Conversion Operators

StockDetailsLevel Conversion Operators
Overload List
Name | Description
(Int32 to StockDetailsLevel) | Implicitly convverts an integer to a StockDetailsLevel.
(StockDetailsLevel to Int32) | Implicitly converts a StockDetailsLevel to an integer.
Top
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel Implicit Conversion (Int32 to StockDetailsLevel)

StockDetailsLevel Conversion (Int32 to StockDetailsLevel)
Implicitly convverts an integer to a StockDetailsLevel.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static implicit operator StockDetailsLevel (
    int value
)
Public Shared Widening Operator CType (
    value As Integer
) As StockDetailsLevel
static implicit operator StockDetailsLevel^ (
    int value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SystemInt32
The value to convert.

Return Value

Type: StockDetailsLevel
The converted value.
See Also

Reference

StockDetailsLevel Class
Overload
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel Implicit Conversion (StockDetailsLevel to Int32)

StockDetailsLevel Conversion (StockDetailsLevel to Int32)
Implicitly converts a StockDetailsLevel to an integer.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static implicit operator int (
    StockDetailsLevel value
)
Public Shared Widening Operator CType (
    value As StockDetailsLevel
) As Integer
static implicit operator int (
    StockDetailsLevel^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: Sitecore.Commerce.Entities.InventoryStockDetailsLevel
The value to convert.

Return Value

Type: Int32
The converted value.
See Also

Reference

StockDetailsLevel Class
Overload
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel Properties

StockDetailsLevel Properties

The StockDetailsLevel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the stock details level.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Value | Gets the integer value of the stock details level.
Top
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel.Name Property

StockDetailsLevelName Property
Gets the name of the stock details level.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevel.Value Property

StockDetailsLevelValue Property
Gets the integer value of the stock details level.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public int Value { get; }
Public ReadOnly Property Value As Integer
    Get
public:
property int Value {
    int get ();
}
member Value : int with get

Property Value

Type: Int32
See Also

Reference

StockDetailsLevel Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevelConverter Class

StockDetailsLevelConverter Class
Type converter for the StockDetailsLevel entity.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
Sitecore.Commerce.Entities.InventoryStockDetailsLevelConverter

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class StockDetailsLevelConverter : TypeConverter
Public Class StockDetailsLevelConverter
    Inherits TypeConverter
public ref class StockDetailsLevelConverter : public TypeConverter
type StockDetailsLevelConverter =
    class
        inherit TypeConverter
    end

The StockDetailsLevelConverter type exposes the following members.

Constructors
 | Name | Description
Public method | StockDetailsLevelConverter | Initializes a new instance of the StockDetailsLevelConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter.)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevelConverter Constructor

StockDetailsLevelConverter Constructor
Initializes a new instance of the StockDetailsLevelConverter class

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockDetailsLevelConverter()
Public Sub New
public:
StockDetailsLevelConverter()
new : unit -> StockDetailsLevelConverter
See Also

Reference

StockDetailsLevelConverter Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevelConverter Methods

StockDetailsLevelConverter Methods

The StockDetailsLevelConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter.)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StockDetailsLevelConverter Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevelConverter.ConvertFrom Method

StockDetailsLevelConverterConvertFrom Method
Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

StockDetailsLevelConverter Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevelConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

StockDetailsLevelConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override
abstract ConvertFrom :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object -> Object
override ConvertFrom :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object -> Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The Object to convert.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

StockDetailsLevelConverter Class
ConvertFrom Overload
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevelConverter.ConvertTo Method

StockDetailsLevelConverterConvertTo Method
Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

StockDetailsLevelConverter Class
Sitecore.Commerce.Entities.Inventory Namespace


StockDetailsLevelConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

StockDetailsLevelConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
Converts the given value object to the specified type, using the specified context and culture information.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override
abstract ConvertTo :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object *
        destinationType : Type -> Object
override ConvertTo :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object *
        destinationType : Type -> Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
A CultureInfo. If null is passed, the current culture is assumed.
value
Type: SystemObject
The Object to convert.
destinationType
Type: SystemType
The Type to convert the value parameter to.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

StockDetailsLevelConverter Class
ConvertTo Overload
Sitecore.Commerce.Entities.Inventory Namespace


StockInformation Class

StockInformation Class
Represents the availability of a product. The inventory status is used to determine if and when a product is available for purchase, and how manu units of the product are currently on-hand.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.InventoryStockInformation

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class StockInformation : Entity
<SerializableAttribute>
Public Class StockInformation
    Inherits Entity
[SerializableAttribute]
public ref class StockInformation : public Entity
[<SerializableAttribute>]
type StockInformation =
    class
        inherit Entity
    end

The StockInformation type exposes the following members.

Constructors
 | Name | Description
Public method | StockInformation | Initializes a new instance of the StockInformation class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AvailabilityDate | Gets or sets the date on which the product will become available, in case the product is out-of-stock or pre-orderable.
Public property | Count | Gets or sets the quantity of the product available.
Public property | Product | Gets or sets the product information in the commerce system.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Status | Gets or sets the stock status.
Top
See Also

Reference

Sitecore.Commerce.Entities.Inventory Namespace


StockInformation Constructor

StockInformation Constructor
Initializes a new instance of the StockInformation class

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockInformation()
Public Sub New
public:
StockInformation()
new : unit -> StockInformation
See Also

Reference

StockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformation Methods

StockInformation Methods

The StockInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformation Properties

StockInformation Properties

The StockInformation type exposes the following members.

Properties
 | Name | Description
Public property | AvailabilityDate | Gets or sets the date on which the product will become available, in case the product is out-of-stock or pre-orderable.
Public property | Count | Gets or sets the quantity of the product available.
Public property | Product | Gets or sets the product information in the commerce system.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Status | Gets or sets the stock status.
Top
See Also

Reference

StockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformation.AvailabilityDate Property

StockInformationAvailabilityDate Property
Gets or sets the date on which the product will become available, in case the product is out-of-stock or pre-orderable.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> AvailabilityDate { get; set; }
Public Property AvailabilityDate As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> AvailabilityDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member AvailabilityDate : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

StockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformation.Count Property

StockInformationCount Property
Gets or sets the quantity of the product available.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public double Count { get; set; }
Public Property Count As Double
    Get
    Set
public:
property double Count {
    double get ();
    void set (double value);
}
member Count : float with get, set

Property Value

Type: Double
See Also

Reference

StockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformation.Product Property

StockInformationProduct Property
Gets or sets the product information in the commerce system.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public InventoryProduct Product { get; set; }
Public Property Product As InventoryProduct
    Get
    Set
public:
property InventoryProduct^ Product {
    InventoryProduct^ get ();
    void set (InventoryProduct^ value);
}
member Product : InventoryProduct with get, set

Property Value

Type: InventoryProduct
See Also

Reference

StockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformation.Status Property

StockInformationStatus Property
Gets or sets the stock status.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockStatus Status { get; set; }
Public Property Status As StockStatus
    Get
    Set
public:
property StockStatus^ Status {
    StockStatus^ get ();
    void set (StockStatus^ value);
}
member Status : StockStatus with get, set

Property Value

Type: StockStatus
See Also

Reference

StockInformation Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformationUpdate Class

StockInformationUpdate Class
StockInformationUpdate is used as a strongly typed composite return value from method GetBackInStockInformation to indicate the product and the locations where it will be back in stock optionally along with availability date and count.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.InventoryStockInformationUpdate

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class StockInformationUpdate : Entity
<SerializableAttribute>
Public Class StockInformationUpdate
    Inherits Entity
[SerializableAttribute]
public ref class StockInformationUpdate : public Entity
[<SerializableAttribute>]
type StockInformationUpdate =
    class
        inherit Entity
    end

The StockInformationUpdate type exposes the following members.

Constructors
 | Name | Description
Public method | StockInformationUpdate | Initializes a new instance of the StockInformationUpdate class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Product | Gets or sets the product in the commerce system.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | StockInformationUpdateLocations | Gets or sets the stock information update locations.
Top
See Also

Reference

Sitecore.Commerce.Entities.Inventory Namespace


StockInformationUpdate Constructor

StockInformationUpdate Constructor
Initializes a new instance of the StockInformationUpdate class

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockInformationUpdate()
Public Sub New
public:
StockInformationUpdate()
new : unit -> StockInformationUpdate
See Also

Reference

StockInformationUpdate Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformationUpdate Methods

StockInformationUpdate Methods

The StockInformationUpdate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StockInformationUpdate Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformationUpdate Properties

StockInformationUpdate Properties

The StockInformationUpdate type exposes the following members.

Properties
 | Name | Description
Public property | Product | Gets or sets the product in the commerce system.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | StockInformationUpdateLocations | Gets or sets the stock information update locations.
Top
See Also

Reference

StockInformationUpdate Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformationUpdate.Product Property

StockInformationUpdateProduct Property
Gets or sets the product in the commerce system.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public InventoryProduct Product { get; set; }
Public Property Product As InventoryProduct
    Get
    Set
public:
property InventoryProduct^ Product {
    InventoryProduct^ get ();
    void set (InventoryProduct^ value);
}
member Product : InventoryProduct with get, set

Property Value

Type: InventoryProduct
See Also

Reference

StockInformationUpdate Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformationUpdate.StockInformationUpdateLocations Property

StockInformationUpdateStockInformationUpdateLocations Property
Gets or sets the stock information update locations.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection StockInformationUpdateLocations { get; set; }
Public Property StockInformationUpdateLocations As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ StockInformationUpdateLocations {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member StockInformationUpdateLocations : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The stock information update locations.
See Also

Reference

StockInformationUpdate Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformationUpdateLocation Class

StockInformationUpdateLocation Class
StockInformationUpdateLocation is used as a strongly typed value nested only into StockInformationUpdate returned from method GetBackInStockInformation to indicate the locations where the product will be back in stock optionally along with availability date and count
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.InventoryStockInformationUpdateLocation

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class StockInformationUpdateLocation : Entity
<SerializableAttribute>
Public Class StockInformationUpdateLocation
    Inherits Entity
[SerializableAttribute]
public ref class StockInformationUpdateLocation : public Entity
[<SerializableAttribute>]
type StockInformationUpdateLocation =
    class
        inherit Entity
    end

The StockInformationUpdateLocation type exposes the following members.

Constructors
 | Name | Description
Public method | StockInformationUpdateLocation | Initializes a new instance of the StockInformationUpdateLocation class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AvailabilityDate | Gets or sets an optional date and time indicating when the product will be in stock.
Public property | Count | Gets or sets an optional count of products that are in stock at the Location at the specified AvailabilityDate.
Public property | Location | Gets or sets the name of the location.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Inventory Namespace


StockInformationUpdateLocation Constructor

StockInformationUpdateLocation Constructor
Initializes a new instance of the StockInformationUpdateLocation class

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockInformationUpdateLocation()
Public Sub New
public:
StockInformationUpdateLocation()
new : unit -> StockInformationUpdateLocation
See Also

Reference

StockInformationUpdateLocation Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformationUpdateLocation Methods

StockInformationUpdateLocation Methods

The StockInformationUpdateLocation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StockInformationUpdateLocation Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformationUpdateLocation Properties

StockInformationUpdateLocation Properties

The StockInformationUpdateLocation type exposes the following members.

Properties
 | Name | Description
Public property | AvailabilityDate | Gets or sets an optional date and time indicating when the product will be in stock.
Public property | Count | Gets or sets an optional count of products that are in stock at the Location at the specified AvailabilityDate.
Public property | Location | Gets or sets the name of the location.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Top
See Also

Reference

StockInformationUpdateLocation Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformationUpdateLocation.AvailabilityDate Property

StockInformationUpdateLocationAvailabilityDate Property
Gets or sets an optional date and time indicating when the product will be in stock.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> AvailabilityDate { get; set; }
Public Property AvailabilityDate As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> AvailabilityDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member AvailabilityDate : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

StockInformationUpdateLocation Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformationUpdateLocation.Count Property

StockInformationUpdateLocationCount Property
Gets or sets an optional count of products that are in stock at the Location at the specified AvailabilityDate.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> Count { get; set; }
Public Property Count As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> Count {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member Count : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

StockInformationUpdateLocation Class
Sitecore.Commerce.Entities.Inventory Namespace


StockInformationUpdateLocation.Location Property

StockInformationUpdateLocationLocation Property
Gets or sets the name of the location.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
See Also

Reference

StockInformationUpdateLocation Class
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequest Class

StockNotificationRequest Class
Represents data associated with a user request to be notified when a product is back in stock.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.InventoryStockNotificationRequest

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class StockNotificationRequest : Entity
<SerializableAttribute>
Public Class StockNotificationRequest
    Inherits Entity
[SerializableAttribute]
public ref class StockNotificationRequest : public Entity
[<SerializableAttribute>]
type StockNotificationRequest =
    class
        inherit Entity
    end

The StockNotificationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | StockNotificationRequest | Initializes an instance of the StockNotificationRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | InterestDate | Gets or sets the a date and time that signals the deadline for which to notify the visitor
Public property | Location | Gets or sets the location.
Public property | Product | Gets or sets the unique identifier for the product or product variant in the commerce system.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | ShopName | Gets or sets the shop name.
Top
See Also

Reference

Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequest Constructor

StockNotificationRequest Constructor
Initializes an instance of the StockNotificationRequest class.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockNotificationRequest(
    InventoryProduct product,
    string shopName,
    string interestDate
)
Public Sub New (
    product As InventoryProduct,
    shopName As String,
    interestDate As String
)
public:
StockNotificationRequest(
    InventoryProduct^ product,
    String^ shopName,
    String^ interestDate
)
new :
        product : InventoryProduct *
        shopName : string *
        interestDate : string -> StockNotificationRequest

Parameters

product
Type: Sitecore.Commerce.Entities.InventoryInventoryProduct
The inventory product identifier.
shopName
Type: SystemString
The shop name.
interestDate
Type: SystemString
The interest date.
See Also

Reference

StockNotificationRequest Class
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequest Methods

StockNotificationRequest Methods

The StockNotificationRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StockNotificationRequest Class
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequest Properties

StockNotificationRequest Properties

The StockNotificationRequest type exposes the following members.

Properties
 | Name | Description
Public property | InterestDate | Gets or sets the a date and time that signals the deadline for which to notify the visitor
Public property | Location | Gets or sets the location.
Public property | Product | Gets or sets the unique identifier for the product or product variant in the commerce system.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | ShopName | Gets or sets the shop name.
Top
See Also

Reference

StockNotificationRequest Class
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequest.InterestDate Property

StockNotificationRequestInterestDate Property
Gets or sets the a date and time that signals the deadline for which to notify the visitor

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string InterestDate { get; set; }
Public Property InterestDate As String
    Get
    Set
public:
property String^ InterestDate {
    String^ get ();
    void set (String^ value);
}
member InterestDate : string with get, set

Property Value

Type: String
See Also

Reference

StockNotificationRequest Class
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequest.Location Property

StockNotificationRequestLocation Property
Gets or sets the location.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
See Also

Reference

StockNotificationRequest Class
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequest.Product Property

StockNotificationRequestProduct Property
Gets or sets the unique identifier for the product or product variant in the commerce system.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public InventoryProduct Product { get; set; }
Public Property Product As InventoryProduct
    Get
    Set
public:
property InventoryProduct^ Product {
    InventoryProduct^ get ();
    void set (InventoryProduct^ value);
}
member Product : InventoryProduct with get, set

Property Value

Type: InventoryProduct
See Also

Reference

StockNotificationRequest Class
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequest.ShopName Property

StockNotificationRequestShopName Property
Gets or sets the shop name.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
See Also

Reference

StockNotificationRequest Class
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequestEqualityComparer Class

StockNotificationRequestEqualityComparer Class
Tests two StockNotificationRequest objects for equality.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Entities.InventoryStockNotificationRequestEqualityComparer

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class StockNotificationRequestEqualityComparer : IEqualityComparer<StockNotificationRequest>
Public Class StockNotificationRequestEqualityComparer
    Implements IEqualityComparer(Of StockNotificationRequest)
public ref class StockNotificationRequestEqualityComparer : IEqualityComparer<StockNotificationRequest^>
type StockNotificationRequestEqualityComparer =
    class
        interface IEqualityComparer<StockNotificationRequest>
    end

The StockNotificationRequestEqualityComparer type exposes the following members.

Constructors
 | Name | Description
Public method | StockNotificationRequestEqualityComparer | Initializes a new instance of the StockNotificationRequestEqualityComparer class
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(StockNotificationRequest, StockNotificationRequest) | Compares two StockNotificationRequest objects for equality.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(StockNotificationRequest) | Gets the hash code for the specified StockNotificationRequest object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
Name | Description
Default | Gets the default StockNotificationRequestEqualityComparer implementation.
Top
See Also

Reference

Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequestEqualityComparer Constructor

StockNotificationRequestEqualityComparer Constructor
Initializes a new instance of the StockNotificationRequestEqualityComparer class

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockNotificationRequestEqualityComparer()
Public Sub New
public:
StockNotificationRequestEqualityComparer()
new : unit -> StockNotificationRequestEqualityComparer
See Also

Reference

StockNotificationRequestEqualityComparer Class
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequestEqualityComparer Methods

StockNotificationRequestEqualityComparer Methods

The StockNotificationRequestEqualityComparer type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(StockNotificationRequest, StockNotificationRequest) | Compares two StockNotificationRequest objects for equality.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(StockNotificationRequest) | Gets the hash code for the specified StockNotificationRequest object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StockNotificationRequestEqualityComparer Class
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequestEqualityComparer.Equals Method

StockNotificationRequestEqualityComparerEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(StockNotificationRequest, StockNotificationRequest) | Compares two StockNotificationRequest objects for equality.
Top
See Also

Reference

StockNotificationRequestEqualityComparer Class
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequestEqualityComparer.Equals Method (StockNotificationRequest, StockNotificationRequest)

StockNotificationRequestEqualityComparerEquals Method (StockNotificationRequest, StockNotificationRequest)
Compares two StockNotificationRequest objects for equality.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual bool Equals(
    StockNotificationRequest x,
    StockNotificationRequest y
)
Public Overridable Function Equals (
    x As StockNotificationRequest,
    y As StockNotificationRequest
) As Boolean
public:
virtual bool Equals(
    StockNotificationRequest^ x,
    StockNotificationRequest^ y
)
abstract Equals :
        x : StockNotificationRequest *
        y : StockNotificationRequest -> bool
override Equals :
        x : StockNotificationRequest *
        y : StockNotificationRequest -> bool

Parameters

x
Type: Sitecore.Commerce.Entities.InventoryStockNotificationRequest
The first object.
y
Type: Sitecore.Commerce.Entities.InventoryStockNotificationRequest
The second object.

Return Value

Type: Boolean
True if the objects are equal, otherwise false.

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

StockNotificationRequestEqualityComparer Class
Equals Overload
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequestEqualityComparer.GetHashCode Method

StockNotificationRequestEqualityComparerGetHashCode Method
Overload List
 | Name | Description
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(StockNotificationRequest) | Gets the hash code for the specified StockNotificationRequest object.
Top
See Also

Reference

StockNotificationRequestEqualityComparer Class
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequestEqualityComparer.GetHashCode Method (StockNotificationRequest)

StockNotificationRequestEqualityComparerGetHashCode Method (StockNotificationRequest)
Gets the hash code for the specified StockNotificationRequest object.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual int GetHashCode(
    StockNotificationRequest obj
)
Public Overridable Function GetHashCode (
    obj As StockNotificationRequest
) As Integer
public:
virtual int GetHashCode(
    StockNotificationRequest^ obj
)
abstract GetHashCode :
        obj : StockNotificationRequest -> int
override GetHashCode :
        obj : StockNotificationRequest -> int

Parameters

obj
Type: Sitecore.Commerce.Entities.InventoryStockNotificationRequest
The StockNotificationRequest object.

Return Value

Type: Int32
The hash code for the specified StockNotificationRequest object.

Implements

IEqualityComparerTGetHashCode(T)
See Also

Reference

StockNotificationRequestEqualityComparer Class
GetHashCode Overload
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequestEqualityComparer Properties

StockNotificationRequestEqualityComparer Properties

The StockNotificationRequestEqualityComparer type exposes the following members.

Properties
Name | Description
Default | Gets the default StockNotificationRequestEqualityComparer implementation.
Top
See Also

Reference

StockNotificationRequestEqualityComparer Class
Sitecore.Commerce.Entities.Inventory Namespace


StockNotificationRequestEqualityComparer.Default Property

StockNotificationRequestEqualityComparerDefault Property
Gets the default StockNotificationRequestEqualityComparer implementation.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static IEqualityComparer<StockNotificationRequest> Default { get; set; }
Public Shared Property Default As IEqualityComparer(Of StockNotificationRequest)
    Get
    Set
public:
static property IEqualityComparer<StockNotificationRequest^>^ Default {
    IEqualityComparer<StockNotificationRequest^>^ get ();
    void set (IEqualityComparer<StockNotificationRequest^>^ value);
}
static member Default : IEqualityComparer<StockNotificationRequest> with get, set

Property Value

Type: IEqualityComparer StockNotificationRequest
See Also

Reference

StockNotificationRequestEqualityComparer Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus Class

StockStatus Class
Represents the current stock status of a product;
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.InventoryStockStatus

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class StockStatus : Entity
<SerializableAttribute>
Public Class StockStatus
    Inherits Entity
[SerializableAttribute]
public ref class StockStatus : public Entity
[<SerializableAttribute>]
type StockStatus =
    class
        inherit Entity
    end

The StockStatus type exposes the following members.

Constructors
 | Name | Description
Public method | StockStatus | Initializes an instance of the StockStatus class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Retrieves a hash code for the object. (Overrides ObjectGetHashCode.)
 | GetKnownValues | Gets a list of the well-known StockDetailsLevel values.
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Top
Operators
Name | Description
(Int32 to StockStatus) | Implicitly convverts an integer to a StockStatus.
(StockStatus to Int32) | Implicitly converts a StockStatus to an integer.
Top
Fields
Name | Description
BackOrderable | Indicates that the requested product is out of stock, but is back-orderable.
InStock | Indicates that the requested product is in stock.
OutOfStock | Indicates that the requested product is out of stock.
PreOrderable | Indicates that the requested product is not in stock yet, but is pre-orderable.
Top
Properties
 | Name | Description
Public property | Name | Gets the name of the stock status.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Value | Gets the integer value of the stock status.
Top
See Also

Reference

Sitecore.Commerce.Entities.Inventory Namespace


StockStatus Constructor

StockStatus Constructor
Initializes an instance of the StockStatus class.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockStatus(
    int value,
    string name
)
Public Sub New (
    value As Integer,
    name As String
)
public:
StockStatus(
    int value,
    String^ name
)
new :
        value : int *
        name : string -> StockStatus

Parameters

value
Type: SystemInt32
The value of the stock status.
name
Type: SystemString
The name of the stock status.
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus Fields

StockStatus Fields

The StockStatus type exposes the following members.

Fields
Name | Description
BackOrderable | Indicates that the requested product is out of stock, but is back-orderable.
InStock | Indicates that the requested product is in stock.
OutOfStock | Indicates that the requested product is out of stock.
PreOrderable | Indicates that the requested product is not in stock yet, but is pre-orderable.
Top
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus.BackOrderable Field

StockStatusBackOrderable Field
Indicates that the requested product is out of stock, but is back-orderable.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static readonly StockStatus BackOrderable
Public Shared ReadOnly BackOrderable As StockStatus
public:
static initonly StockStatus^ BackOrderable
static val BackOrderable: StockStatus

Field Value

Type: StockStatus
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus.InStock Field

StockStatusInStock Field
Indicates that the requested product is in stock.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static readonly StockStatus InStock
Public Shared ReadOnly InStock As StockStatus
public:
static initonly StockStatus^ InStock
static val InStock: StockStatus

Field Value

Type: StockStatus
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus.OutOfStock Field

StockStatusOutOfStock Field
Indicates that the requested product is out of stock.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static readonly StockStatus OutOfStock
Public Shared ReadOnly OutOfStock As StockStatus
public:
static initonly StockStatus^ OutOfStock
static val OutOfStock: StockStatus

Field Value

Type: StockStatus
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus.PreOrderable Field

StockStatusPreOrderable Field
Indicates that the requested product is not in stock yet, but is pre-orderable.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static readonly StockStatus PreOrderable
Public Shared ReadOnly PreOrderable As StockStatus
public:
static initonly StockStatus^ PreOrderable
static val PreOrderable: StockStatus

Field Value

Type: StockStatus
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus Methods

StockStatus Methods

The StockStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Retrieves a hash code for the object. (Overrides ObjectGetHashCode.)
 | GetKnownValues | Gets a list of the well-known StockDetailsLevel values.
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Top
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus.Equals Method

StockStatusEquals Method
Determines whether the specified object is equal to the current object.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
True if the specified object is equal to the current object; otherwise false.
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus.GetHashCode Method

StockStatusGetHashCode Method
Retrieves a hash code for the object.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus.GetKnownValues Method

StockStatusGetKnownValues Method
Gets a list of the well-known StockDetailsLevel values.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static IReadOnlyCollection GetKnownValues()
Public Shared Function GetKnownValues As IReadOnlyCollection
public:
static IReadOnlyCollection^ GetKnownValues()
static member GetKnownValues : unit -> IReadOnlyCollection

Return Value

Type: IReadOnlyCollectionT
A list of the well-known StockDetailsLevel values.
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus.ToString Method

StockStatusToString Method
Returns a string that represents the current object.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A string that represents the current object.
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus Type Conversions

StockStatus Type Conversions
Operators
Name | Description
(Int32 to StockStatus) | Implicitly convverts an integer to a StockStatus.
(StockStatus to Int32) | Implicitly converts a StockStatus to an integer.
Top
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus Implicit Conversion Operators

StockStatus Conversion Operators
Overload List
Name | Description
(Int32 to StockStatus) | Implicitly convverts an integer to a StockStatus.
(StockStatus to Int32) | Implicitly converts a StockStatus to an integer.
Top
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus Implicit Conversion (Int32 to StockStatus)

StockStatus Conversion (Int32 to StockStatus)
Implicitly convverts an integer to a StockStatus.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static implicit operator StockStatus (
    int value
)
Public Shared Widening Operator CType (
    value As Integer
) As StockStatus
static implicit operator StockStatus^ (
    int value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SystemInt32
The value to convert.

Return Value

Type: StockStatus
The converted value.
See Also

Reference

StockStatus Class
Overload
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus Implicit Conversion (StockStatus to Int32)

StockStatus Conversion (StockStatus to Int32)
Implicitly converts a StockStatus to an integer.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static implicit operator int (
    StockStatus value
)
Public Shared Widening Operator CType (
    value As StockStatus
) As Integer
static implicit operator int (
    StockStatus^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: Sitecore.Commerce.Entities.InventoryStockStatus
The value to convert.

Return Value

Type: Int32
The converted value.
See Also

Reference

StockStatus Class
Overload
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus Properties

StockStatus Properties

The StockStatus type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the stock status.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Value | Gets the integer value of the stock status.
Top
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus.Name Property

StockStatusName Property
Gets the name of the stock status.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatus.Value Property

StockStatusValue Property
Gets the integer value of the stock status.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public int Value { get; }
Public ReadOnly Property Value As Integer
    Get
public:
property int Value {
    int get ();
}
member Value : int with get

Property Value

Type: Int32
See Also

Reference

StockStatus Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatusConverter Class

StockStatusConverter Class
Type converter for the StockStatus entity.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
Sitecore.Commerce.Entities.InventoryStockStatusConverter

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class StockStatusConverter : TypeConverter
Public Class StockStatusConverter
    Inherits TypeConverter
public ref class StockStatusConverter : public TypeConverter
type StockStatusConverter =
    class
        inherit TypeConverter
    end

The StockStatusConverter type exposes the following members.

Constructors
 | Name | Description
Public method | StockStatusConverter | Initializes a new instance of the StockStatusConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter.)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Inventory Namespace


StockStatusConverter Constructor

StockStatusConverter Constructor
Initializes a new instance of the StockStatusConverter class

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockStatusConverter()
Public Sub New
public:
StockStatusConverter()
new : unit -> StockStatusConverter
See Also

Reference

StockStatusConverter Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatusConverter Methods

StockStatusConverter Methods

The StockStatusConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter.)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StockStatusConverter Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatusConverter.ConvertFrom Method

StockStatusConverterConvertFrom Method
Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

StockStatusConverter Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatusConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

StockStatusConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override
abstract ConvertFrom :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object -> Object
override ConvertFrom :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object -> Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The Object to convert.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

StockStatusConverter Class
ConvertFrom Overload
Sitecore.Commerce.Entities.Inventory Namespace


StockStatusConverter.ConvertTo Method

StockStatusConverterConvertTo Method
Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

StockStatusConverter Class
Sitecore.Commerce.Entities.Inventory Namespace


StockStatusConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

StockStatusConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
Converts the given value object to the specified type, using the specified context and culture information.

Namespace: Sitecore.Commerce.Entities.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override
abstract ConvertTo :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object *
        destinationType : Type -> Object
override ConvertTo :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object *
        destinationType : Type -> Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
A CultureInfo. If null is passed, the current culture is assumed.
value
Type: SystemObject
The Object to convert.
destinationType
Type: SystemType
The Type to convert the value parameter to.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

StockStatusConverter Class
ConvertTo Overload
Sitecore.Commerce.Entities.Inventory Namespace


Sitecore.Commerce.Entities.Orders Namespace

Sitecore.Commerce.Entities.Orders Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Entities.Orders"]

Classes
 | Class | Description
Public class | Order | Defines the Order class.
Public class | OrderHeader | Defines the OrderHeader class.


Order Class

Order Class
Defines the Order class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.CartsCartBase
Sitecore.Commerce.Entities.CartsCart
Sitecore.Commerce.Entities.OrdersOrder

Namespace: Sitecore.Commerce.Entities.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Order : Cart
<SerializableAttribute>
Public Class Order
    Inherits Cart
[SerializableAttribute]
public ref class Order : public Cart
[<SerializableAttribute>]
type Order =
    class
        inherit Cart
    end

The Order type exposes the following members.

Constructors
 | Name | Description
Public method | Order | Initializes a new instance of the Order class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
Name Description
Public property AccountingCustomerParty
Gets or sets the accounting customer party.
(Inherited from CartBase.)
Public property Adjustments
Gets or sets the adjustments that describe any differences between the total and the sum of the prices of the individual cart line items. Examples are coupon codes that are manually triggered and shipping surcharges that are automatically triggered.
(Inherited from Cart.)
Public property BuyerCustomerParty
Gets or sets the buyer customer party.
(Inherited from CartBase.)
CartType
Gets or sets the type of cart.
Examples
  • Regular
  • Wish list
(Inherited from CartBase.)
Public property CustomerId
Gets or sets the customer ID.
(Inherited from CartBase.)
Public property ExternalId
Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created.
(Inherited from MappedEntity.)
Public property IsLocked
Gets or sets a value that indicates whether the cart is locked.
(Inherited from CartBase.)
Public property Lines
Gets or sets the sublines of the cart line.
(Inherited from Cart.)
Public property Name
Gets or sets the cart name.
(Inherited from CartBase.)
Public property OrderID
Gets or sets the order identifier.
Public property Parties
Gets or sets the parties.
(Inherited from Cart.)
Public property Payment
Gets or sets the payment list.
(Inherited from Cart.)
Public property Properties
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
(Inherited from Entity.)
Public property Shipping
Gets or sets the shipping list.
(Inherited from Cart.)
Public property ShopName
Gets or sets the shop name.
(Inherited from CartBase.)
Public property Status
Gets or sets the cart status.
(Inherited from CartBase.)
Public property Total
Gets or sets the total for the products in the cart.
(Inherited from Cart.)
Public property UserId
Gets or sets the user ID.
(Inherited from CartBase.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Orders Namespace


Order Constructor

Order Constructor
Initializes a new instance of the Order class

Namespace: Sitecore.Commerce.Entities.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Order()
Public Sub New
public:
Order()
new : unit -> Order
See Also

Reference

Order Class
Sitecore.Commerce.Entities.Orders Namespace


Order Methods

Order Methods

The Order type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Order Class
Sitecore.Commerce.Entities.Orders Namespace


Order Properties

Order Properties

The Order type exposes the following members.

Properties
Name Description
Public property AccountingCustomerParty
Gets or sets the accounting customer party.
(Inherited from CartBase.)
Public property Adjustments
Gets or sets the adjustments that describe any differences between the total and the sum of the prices of the individual cart line items. Examples are coupon codes that are manually triggered and shipping surcharges that are automatically triggered.
(Inherited from Cart.)
Public property BuyerCustomerParty
Gets or sets the buyer customer party.
(Inherited from CartBase.)
CartType
Gets or sets the type of cart.
Examples
  • Regular
  • Wish list
(Inherited from CartBase.)
Public property CustomerId
Gets or sets the customer ID.
(Inherited from CartBase.)
Public property ExternalId
Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created.
(Inherited from MappedEntity.)
Public property IsLocked
Gets or sets a value that indicates whether the cart is locked.
(Inherited from CartBase.)
Public property Lines
Gets or sets the sublines of the cart line.
(Inherited from Cart.)
Public property Name
Gets or sets the cart name.
(Inherited from CartBase.)
Public property OrderID
Gets or sets the order identifier.
Public property Parties
Gets or sets the parties.
(Inherited from Cart.)
Public property Payment
Gets or sets the payment list.
(Inherited from Cart.)
Public property Properties
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
(Inherited from Entity.)
Public property Shipping
Gets or sets the shipping list.
(Inherited from Cart.)
Public property ShopName
Gets or sets the shop name.
(Inherited from CartBase.)
Public property Status
Gets or sets the cart status.
(Inherited from CartBase.)
Public property Total
Gets or sets the total for the products in the cart.
(Inherited from Cart.)
Public property UserId
Gets or sets the user ID.
(Inherited from CartBase.)
Top
See Also

Reference

Order Class
Sitecore.Commerce.Entities.Orders Namespace


Order.OrderID Property

OrderOrderID Property
Gets or sets the order identifier.

Namespace: Sitecore.Commerce.Entities.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}
member OrderID : string with get, set

Property Value

Type: String
The order identifier.
See Also

Reference

Order Class
Sitecore.Commerce.Entities.Orders Namespace


OrderHeader Class

OrderHeader Class
Defines the OrderHeader class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.CartsCartBase
Sitecore.Commerce.Entities.OrdersOrderHeader

Namespace: Sitecore.Commerce.Entities.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class OrderHeader : CartBase
<SerializableAttribute>
Public Class OrderHeader
    Inherits CartBase
[SerializableAttribute]
public ref class OrderHeader : public CartBase
[<SerializableAttribute>]
type OrderHeader =
    class
        inherit CartBase
    end

The OrderHeader type exposes the following members.

Constructors
 | Name | Description
Public method | OrderHeader | Initializes a new instance of the OrderHeader class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
Name Description
Public property AccountingCustomerParty
Gets or sets the accounting customer party.
(Inherited from CartBase.)
Public property BuyerCustomerParty
Gets or sets the buyer customer party.
(Inherited from CartBase.)
CartType
Gets or sets the type of cart.
Examples
  • Regular
  • Wish list
(Inherited from CartBase.)
Public property CustomerId
Gets or sets the customer ID.
(Inherited from CartBase.)
Public property ExternalId
Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created.
(Inherited from MappedEntity.)
Public property IsLocked
Gets or sets a value that indicates whether the cart is locked.
(Inherited from CartBase.)
Public property Name
Gets or sets the cart name.
(Inherited from CartBase.)
Public property OrderID
Gets or sets the order identifier.
Public property Properties
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
(Inherited from Entity.)
Public property ShopName
Gets or sets the shop name.
(Inherited from CartBase.)
Public property Status
Gets or sets the cart status.
(Inherited from CartBase.)
Public property UserId
Gets or sets the user ID.
(Inherited from CartBase.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Orders Namespace


OrderHeader Constructor

OrderHeader Constructor
Initializes a new instance of the OrderHeader class

Namespace: Sitecore.Commerce.Entities.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public OrderHeader()
Public Sub New
public:
OrderHeader()
new : unit -> OrderHeader
See Also

Reference

OrderHeader Class
Sitecore.Commerce.Entities.Orders Namespace


OrderHeader Methods

OrderHeader Methods

The OrderHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OrderHeader Class
Sitecore.Commerce.Entities.Orders Namespace


OrderHeader Properties

OrderHeader Properties

The OrderHeader type exposes the following members.

Properties
Name Description
Public property AccountingCustomerParty
Gets or sets the accounting customer party.
(Inherited from CartBase.)
Public property BuyerCustomerParty
Gets or sets the buyer customer party.
(Inherited from CartBase.)
CartType
Gets or sets the type of cart.
Examples
  • Regular
  • Wish list
(Inherited from CartBase.)
Public property CustomerId
Gets or sets the customer ID.
(Inherited from CartBase.)
Public property ExternalId
Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created.
(Inherited from MappedEntity.)
Public property IsLocked
Gets or sets a value that indicates whether the cart is locked.
(Inherited from CartBase.)
Public property Name
Gets or sets the cart name.
(Inherited from CartBase.)
Public property OrderID
Gets or sets the order identifier.
Public property Properties
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
(Inherited from Entity.)
Public property ShopName
Gets or sets the shop name.
(Inherited from CartBase.)
Public property Status
Gets or sets the cart status.
(Inherited from CartBase.)
Public property UserId
Gets or sets the user ID.
(Inherited from CartBase.)
Top
See Also

Reference

OrderHeader Class
Sitecore.Commerce.Entities.Orders Namespace


OrderHeader.OrderID Property

OrderHeaderOrderID Property
Gets or sets the order identifier.

Namespace: Sitecore.Commerce.Entities.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}
member OrderID : string with get, set

Property Value

Type: String
The order identifier.
See Also

Reference

OrderHeader Class
Sitecore.Commerce.Entities.Orders Namespace


Sitecore.Commerce.Entities.Prices Namespace

Sitecore.Commerce.Entities.Prices Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Entities.Prices"]

Classes
 | Class | Description
Public class | Price | Represents the price of a product. The Price object indicates the value that a customer pays for a single product, but the Total object indicates the total cost, which includes additional items such as tax and shipping. The Pricing Service Provider uses the GetProductPrices to return the price. A product may be assigned multiple prices. You can use one single call to get a group of objects that represent the different prices.
Public class | PriceCondition | Represents a condition that must be met in order for a price to be applied. For every external commerce system, you must extend the PriceCondition class to support the actual ConditionTypes, operators and possible return values.
Public class | TaxSubtotal | Represents a specific tax that is applied to an object, and the amount of the tax. This level of granularity is required in some countries.
Public class | TaxTotal | Represents the tax that applies to the total.
Public class | Total | Represents the total price that a customer pays for a product, cart line, or entire cart including charges, discounts, coupon codes, taxes, and shipping expenses. You can use the PricingServiceProvider layer to get the total price of the group of items.


Price Class

Price Class
Represents the price of a product. The Price object indicates the value that a customer pays for a single product, but the Total object indicates the total cost, which includes additional items such as tax and shipping. The Pricing Service Provider uses the GetProductPrices to return the price. A product may be assigned multiple prices. You can use one single call to get a group of objects that represent the different prices.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.PricesPrice

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Price : Entity
<SerializableAttribute>
Public Class Price
    Inherits Entity
[SerializableAttribute]
public ref class Price : public Entity
[<SerializableAttribute>]
type Price =
    class
        inherit Entity
    end

The Price type exposes the following members.

Constructors
 | Name | Description
Public method | Price | Initializes an instance of the Price class.
Public method | Price(Decimal, String) | Initializes an instance of the Price class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the price. (Overrides ObjectToString.)
Top
Properties
Name Description
Public property Amount
Gets or sets the price.
Conditions
Gets or sets the group of price conditions used for break pricing and campaigns, where a specific price is only applicable when certain conditions are met.
Examples
  • The customer has bought at least five products.
  • The date is in the year 2013.
Public property CurrencyCode
Gets or sets the currency that the price is displayed in.
Public property Description
Gets or sets the text that describes the price.
PriceType
Gets or sets the type of the price.
Examples
  • List Price
  • Customer Price
The list price is the original price without any condition. The customer price is the price that the customer pays taking all conditions into account.
Public property Properties
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
(Inherited from Entity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Prices Namespace


Price Constructor

Price Constructor
Overload List
 | Name | Description
Public method | Price | Initializes an instance of the Price class.
Public method | Price(Decimal, String) | Initializes an instance of the Price class.
Top
See Also

Reference

Price Class
Sitecore.Commerce.Entities.Prices Namespace


Price Constructor

Price Constructor
Initializes an instance of the Price class.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Price()
Public Sub New
public:
Price()
new : unit -> Price
See Also

Reference

Price Class
Price Overload
Sitecore.Commerce.Entities.Prices Namespace


Price Constructor (Decimal, String)

Price Constructor (Decimal, String)
Initializes an instance of the Price class.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Price(
    decimal amount,
    string currency
)
Public Sub New (
    amount As Decimal,
    currency As String
)
public:
Price(
    Decimal amount,
    String^ currency
)
new :
        amount : decimal *
        currency : string -> Price

Parameters

amount
Type: SystemDecimal
The value of the price.
currency
Type: SystemString
The currency of the price.
See Also

Reference

Price Class
Price Overload
Sitecore.Commerce.Entities.Prices Namespace


Price Methods

Price Methods

The Price type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the price. (Overrides ObjectToString.)
Top
See Also

Reference

Price Class
Sitecore.Commerce.Entities.Prices Namespace


Price.ToString Method

PriceToString Method
Returns a string that represents the price.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A string that represents the price.
See Also

Reference

Price Class
Sitecore.Commerce.Entities.Prices Namespace


Price Properties

Price Properties

The Price type exposes the following members.

Properties
Name Description
Public property Amount
Gets or sets the price.
Conditions
Gets or sets the group of price conditions used for break pricing and campaigns, where a specific price is only applicable when certain conditions are met.
Examples
  • The customer has bought at least five products.
  • The date is in the year 2013.
Public property CurrencyCode
Gets or sets the currency that the price is displayed in.
Public property Description
Gets or sets the text that describes the price.
PriceType
Gets or sets the type of the price.
Examples
  • List Price
  • Customer Price
The list price is the original price without any condition. The customer price is the price that the customer pays taking all conditions into account.
Public property Properties
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
(Inherited from Entity.)
Top
See Also

Reference

Price Class
Sitecore.Commerce.Entities.Prices Namespace


Price.Amount Property

PriceAmount Property
Gets or sets the price.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public decimal Amount { get; set; }
Public Property Amount As Decimal
    Get
    Set
public:
property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
member Amount : decimal with get, set

Property Value

Type: Decimal
The amount.
See Also

Reference

Price Class
Sitecore.Commerce.Entities.Prices Namespace


Price.Conditions Property

PriceConditions Property
Gets or sets the group of price conditions used for break pricing and campaigns, where a specific price is only applicable when certain conditions are met.
Examples
  • The customer has bought at least five products.
  • The date is in the year 2013.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection Conditions { get; set; }
Public Property Conditions As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ Conditions {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member Conditions : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
A collection of the price conditions.
See Also

Reference

Price Class
Sitecore.Commerce.Entities.Prices Namespace


Price.CurrencyCode Property

PriceCurrencyCode Property
Gets or sets the currency that the price is displayed in.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}
member CurrencyCode : string with get, set

Property Value

Type: String
The currency of the price.
See Also

Reference

Price Class
Sitecore.Commerce.Entities.Prices Namespace


Price.Description Property

PriceDescription Property
Gets or sets the text that describes the price.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
A description of the price.
See Also

Reference

Price Class
Sitecore.Commerce.Entities.Prices Namespace


Price.PriceType Property

PricePriceType Property
Gets or sets the type of the price.
Examples
  • List Price
  • Customer Price
The list price is the original price without any condition. The customer price is the price that the customer pays taking all conditions into account.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string PriceType { get; set; }
Public Property PriceType As String
    Get
    Set
public:
property String^ PriceType {
    String^ get ();
    void set (String^ value);
}
member PriceType : string with get, set

Property Value

Type: String
The type of the price.
See Also

Reference

Price Class
Sitecore.Commerce.Entities.Prices Namespace


PriceCondition Class

PriceCondition Class
Represents a condition that must be met in order for a price to be applied. For every external commerce system, you must extend the PriceCondition class to support the actual ConditionTypes, operators and possible return values.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.PricesPriceCondition

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PriceCondition : Entity
<SerializableAttribute>
Public Class PriceCondition
    Inherits Entity
[SerializableAttribute]
public ref class PriceCondition : public Entity
[<SerializableAttribute>]
type PriceCondition =
    class
        inherit Entity
    end

The PriceCondition type exposes the following members.

Constructors
 | Name | Description
Public method | PriceCondition | Initializes a new instance of the PriceCondition class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
Name Description
ConditionType
Gets or sets the type of the condition.
Examples
quantity, date and total
Public property Description
Gets or sets the text that describes the condition.
Operator
Gets or sets the operator that you can use to compare values in the condition.
Examples
greater than, equal to, and between
Public property Properties
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
(Inherited from Entity.)
Public property Sequence
Gets or sets the number that represents the sequential order of the condition.
Public property Value
Gets or sets the value. If the ConditionType is equals to Quantity, the value is typically:
  • A single integer with a logical operator like "greater than ‘>’", "less than ‘<’", "greater than or equal to ‘>=’" or "less than or equal to ‘<=’"
  • A range like 5-10 with the operator "between"
  • A single date with an operator like "greater than ‘>’", "less than ‘<’", "greater than or equal to ‘>=’" or "greater than or equal to ‘<=’"
  • A date range like A - B with the operator "between"
Top
See Also

Reference

Sitecore.Commerce.Entities.Prices Namespace


PriceCondition Constructor

PriceCondition Constructor
Initializes a new instance of the PriceCondition class

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PriceCondition()
Public Sub New
public:
PriceCondition()
new : unit -> PriceCondition
See Also

Reference

PriceCondition Class
Sitecore.Commerce.Entities.Prices Namespace


PriceCondition Methods

PriceCondition Methods

The PriceCondition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PriceCondition Class
Sitecore.Commerce.Entities.Prices Namespace


PriceCondition Properties

PriceCondition Properties

The PriceCondition type exposes the following members.

Properties
Name Description
ConditionType
Gets or sets the type of the condition.
Examples
quantity, date and total
Public property Description
Gets or sets the text that describes the condition.
Operator
Gets or sets the operator that you can use to compare values in the condition.
Examples
greater than, equal to, and between
Public property Properties
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
(Inherited from Entity.)
Public property Sequence
Gets or sets the number that represents the sequential order of the condition.
Public property Value
Gets or sets the value. If the ConditionType is equals to Quantity, the value is typically:
  • A single integer with a logical operator like "greater than ‘>’", "less than ‘<’", "greater than or equal to ‘>=’" or "less than or equal to ‘<=’"
  • A range like 5-10 with the operator "between"
  • A single date with an operator like "greater than ‘>’", "less than ‘<’", "greater than or equal to ‘>=’" or "greater than or equal to ‘<=’"
  • A date range like A - B with the operator "between"
Top
See Also

Reference

PriceCondition Class
Sitecore.Commerce.Entities.Prices Namespace


PriceCondition.ConditionType Property

PriceConditionConditionType Property
Gets or sets the type of the condition.
Examples
quantity, date and total

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ConditionType { get; set; }
Public Property ConditionType As String
    Get
    Set
public:
property String^ ConditionType {
    String^ get ();
    void set (String^ value);
}
member ConditionType : string with get, set

Property Value

Type: String
The type of the condition.
See Also

Reference

PriceCondition Class
Sitecore.Commerce.Entities.Prices Namespace


PriceCondition.Description Property

PriceConditionDescription Property
Gets or sets the text that describes the condition.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
The text that describes the condition.
See Also

Reference

PriceCondition Class
Sitecore.Commerce.Entities.Prices Namespace


PriceCondition.Operator Property

PriceConditionOperator Property
Gets or sets the operator that you can use to compare values in the condition.
Examples
greater than, equal to, and between

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Operator { get; set; }
Public Property Operator As String
    Get
    Set
public:
property String^ Operator {
    String^ get ();
    void set (String^ value);
}
member Operator : string with get, set

Property Value

Type: String
The operator that you can use to compare values in the condition.
See Also

Reference

PriceCondition Class
Sitecore.Commerce.Entities.Prices Namespace


PriceCondition.Sequence Property

PriceConditionSequence Property
Gets or sets the number that represents the sequential order of the condition.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public int Sequence { get; set; }
Public Property Sequence As Integer
    Get
    Set
public:
property int Sequence {
    int get ();
    void set (int value);
}
member Sequence : int with get, set

Property Value

Type: Int32
The sequential order of the condition.
See Also

Reference

PriceCondition Class
Sitecore.Commerce.Entities.Prices Namespace


PriceCondition.Value Property

PriceConditionValue Property
Gets or sets the value. If the ConditionType is equals to Quantity, the value is typically:
  • A single integer with a logical operator like "greater than ‘>’", "less than ‘<’", "greater than or equal to ‘>=’" or "less than or equal to ‘<=’"
  • A range like 5-10 with the operator "between"
  • A single date with an operator like "greater than ‘>’", "less than ‘<’", "greater than or equal to ‘>=’" or "greater than or equal to ‘<=’"
  • A date range like A - B with the operator "between"

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
The value that you use to compare the condition type with.
See Also

Reference

PriceCondition Class
Sitecore.Commerce.Entities.Prices Namespace


TaxSubtotal Class

TaxSubtotal Class
Represents a specific tax that is applied to an object, and the amount of the tax. This level of granularity is required in some countries.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.PricesTaxSubtotal

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class TaxSubtotal : Entity
<SerializableAttribute>
Public Class TaxSubtotal
    Inherits Entity
[SerializableAttribute]
public ref class TaxSubtotal : public Entity
[<SerializableAttribute>]
type TaxSubtotal =
    class
        inherit Entity
    end

The TaxSubtotal type exposes the following members.

Constructors
 | Name | Description
Public method | TaxSubtotal | Initializes a new instance of the TaxSubtotal class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BaseUnitMeasure | Gets or sets the number of items in a unit for which the fixed value (PerUnitAmount) applies to. The BaseUnitMeasure is not used if the Percent method is used.
Public property | Description | Gets or sets the text that describes the tax subtotal.
Public property | Percent | Gets or sets the tax percentage. It is equal to zero if a fixed value is used.
Public property | PerUnitAmount | Gets or sets the fixed value of the tax. It is equal to zero if a percentage is used.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
 | TaxSubtotalType | Gets or sets the type of the tax subtotal. Examples "CA state tax", "NYC city tax", and "special levy 003a"
Top
See Also

Reference

Sitecore.Commerce.Entities.Prices Namespace


TaxSubtotal Constructor

TaxSubtotal Constructor
Initializes a new instance of the TaxSubtotal class

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TaxSubtotal()
Public Sub New
public:
TaxSubtotal()
new : unit -> TaxSubtotal
See Also

Reference

TaxSubtotal Class
Sitecore.Commerce.Entities.Prices Namespace


TaxSubtotal Methods

TaxSubtotal Methods

The TaxSubtotal type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TaxSubtotal Class
Sitecore.Commerce.Entities.Prices Namespace


TaxSubtotal Properties

TaxSubtotal Properties

The TaxSubtotal type exposes the following members.

Properties
 | Name | Description
Public property | BaseUnitMeasure | Gets or sets the number of items in a unit for which the fixed value (PerUnitAmount) applies to. The BaseUnitMeasure is not used if the Percent method is used.
Public property | Description | Gets or sets the text that describes the tax subtotal.
Public property | Percent | Gets or sets the tax percentage. It is equal to zero if a fixed value is used.
Public property | PerUnitAmount | Gets or sets the fixed value of the tax. It is equal to zero if a percentage is used.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
 | TaxSubtotalType | Gets or sets the type of the tax subtotal. Examples "CA state tax", "NYC city tax", and "special levy 003a"
Top
See Also

Reference

TaxSubtotal Class
Sitecore.Commerce.Entities.Prices Namespace


TaxSubtotal.BaseUnitMeasure Property

TaxSubtotalBaseUnitMeasure Property
Gets or sets the number of items in a unit for which the fixed value (PerUnitAmount) applies to. The BaseUnitMeasure is not used if the Percent method is used.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string BaseUnitMeasure { get; set; }
Public Property BaseUnitMeasure As String
    Get
    Set
public:
property String^ BaseUnitMeasure {
    String^ get ();
    void set (String^ value);
}
member BaseUnitMeasure : string with get, set

Property Value

Type: String
The base unit measure.
See Also

Reference

TaxSubtotal Class
Sitecore.Commerce.Entities.Prices Namespace


TaxSubtotal.Description Property

TaxSubtotalDescription Property
Gets or sets the text that describes the tax subtotal.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
The text that describes the tax subtotal.
See Also

Reference

TaxSubtotal Class
Sitecore.Commerce.Entities.Prices Namespace


TaxSubtotal.Percent Property

TaxSubtotalPercent Property
Gets or sets the tax percentage. It is equal to zero if a fixed value is used.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public decimal Percent { get; set; }
Public Property Percent As Decimal
    Get
    Set
public:
property Decimal Percent {
    Decimal get ();
    void set (Decimal value);
}
member Percent : decimal with get, set

Property Value

Type: Decimal
The percentage that indicates the tax subtotal.
See Also

Reference

TaxSubtotal Class
Sitecore.Commerce.Entities.Prices Namespace


TaxSubtotal.PerUnitAmount Property

TaxSubtotalPerUnitAmount Property
Gets or sets the fixed value of the tax. It is equal to zero if a percentage is used.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public decimal PerUnitAmount { get; set; }
Public Property PerUnitAmount As Decimal
    Get
    Set
public:
property Decimal PerUnitAmount {
    Decimal get ();
    void set (Decimal value);
}
member PerUnitAmount : decimal with get, set

Property Value

Type: Decimal
The fixed tax value of the tax subtotal.
See Also

Reference

TaxSubtotal Class
Sitecore.Commerce.Entities.Prices Namespace


TaxSubtotal.TaxSubtotalType Property

TaxSubtotalTaxSubtotalType Property
Gets or sets the type of the tax subtotal.
Examples
"CA state tax", "NYC city tax", and "special levy 003a"

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string TaxSubtotalType { get; set; }
Public Property TaxSubtotalType As String
    Get
    Set
public:
property String^ TaxSubtotalType {
    String^ get ();
    void set (String^ value);
}
member TaxSubtotalType : string with get, set

Property Value

Type: String
The type of the tax subtotal.
See Also

Reference

TaxSubtotal Class
Sitecore.Commerce.Entities.Prices Namespace


TaxTotal Class

TaxTotal Class
Represents the tax that applies to the total.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.PricesTaxTotal

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class TaxTotal : Entity
<SerializableAttribute>
Public Class TaxTotal
    Inherits Entity
[SerializableAttribute]
public ref class TaxTotal : public Entity
[<SerializableAttribute>]
type TaxTotal =
    class
        inherit Entity
    end

The TaxTotal type exposes the following members.

Constructors
 | Name | Description
Public method | TaxTotal | Initializes a new instance of the TaxTotal class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Amount | Gets or sets the value of the total tax.
Public property | Description | Gets or sets the text that describes the tax total.
Public property | Id | Gets or sets the ID of the tax total. You can only use this value in an external commerce system. For example, you can use it in auditing applications.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | TaxSubtotals | Gets or sets the list of subtotal taxes that affect the total tax.
Top
See Also

Reference

Sitecore.Commerce.Entities.Prices Namespace


TaxTotal Constructor

TaxTotal Constructor
Initializes a new instance of the TaxTotal class

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TaxTotal()
Public Sub New
public:
TaxTotal()
new : unit -> TaxTotal
See Also

Reference

TaxTotal Class
Sitecore.Commerce.Entities.Prices Namespace


TaxTotal Methods

TaxTotal Methods

The TaxTotal type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TaxTotal Class
Sitecore.Commerce.Entities.Prices Namespace


TaxTotal Properties

TaxTotal Properties

The TaxTotal type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Gets or sets the value of the total tax.
Public property | Description | Gets or sets the text that describes the tax total.
Public property | Id | Gets or sets the ID of the tax total. You can only use this value in an external commerce system. For example, you can use it in auditing applications.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | TaxSubtotals | Gets or sets the list of subtotal taxes that affect the total tax.
Top
See Also

Reference

TaxTotal Class
Sitecore.Commerce.Entities.Prices Namespace


TaxTotal.Amount Property

TaxTotalAmount Property
Gets or sets the value of the total tax.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public decimal Amount { get; set; }
Public Property Amount As Decimal
    Get
    Set
public:
property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
member Amount : decimal with get, set

Property Value

Type: Decimal
The value of the tax total.
Remarks
The currency of the total tax is the same as that of the total price.
See Also

Reference

TaxTotal Class
Sitecore.Commerce.Entities.Prices Namespace


TaxTotal.Description Property

TaxTotalDescription Property
Gets or sets the text that describes the tax total.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
The description of the tax total.
See Also

Reference

TaxTotal Class
Sitecore.Commerce.Entities.Prices Namespace


TaxTotal.Id Property

TaxTotalId Property
Gets or sets the ID of the tax total. You can only use this value in an external commerce system. For example, you can use it in auditing applications.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
The ID of the tax total.
See Also

Reference

TaxTotal Class
Sitecore.Commerce.Entities.Prices Namespace


TaxTotal.TaxSubtotals Property

TaxTotalTaxSubtotals Property
Gets or sets the list of subtotal taxes that affect the total tax.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection TaxSubtotals { get; set; }
Public Property TaxSubtotals As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ TaxSubtotals {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member TaxSubtotals : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The tax subtotals.
See Also

Reference

TaxTotal Class
Sitecore.Commerce.Entities.Prices Namespace


Total Class

Total Class
Represents the total price that a customer pays for a product, cart line, or entire cart including charges, discounts, coupon codes, taxes, and shipping expenses. You can use the PricingServiceProvider layer to get the total price of the group of items.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Entities.PricesTotal

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Total : Entity
<SerializableAttribute>
Public Class Total
    Inherits Entity
[SerializableAttribute]
public ref class Total : public Entity
[<SerializableAttribute>]
type Total =
    class
        inherit Entity
    end

The Total type exposes the following members.

Constructors
 | Name | Description
Public method | Total | Initializes a new instance of the Total class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Amount | Gets or sets the value that represents the total amount.
Public property | CurrencyCode | Gets or sets the code that represents the currency.
Public property | Description | Gets or sets the text that describes the total.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | TaxTotal | Gets or sets the tax total that describes the tax. It is calculated from the tax subtotals.
Top
See Also

Reference

Sitecore.Commerce.Entities.Prices Namespace


Total Constructor

Total Constructor
Initializes a new instance of the Total class

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Total()
Public Sub New
public:
Total()
new : unit -> Total
See Also

Reference

Total Class
Sitecore.Commerce.Entities.Prices Namespace


Total Methods

Total Methods

The Total type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Total Class
Sitecore.Commerce.Entities.Prices Namespace


Total Properties

Total Properties

The Total type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Gets or sets the value that represents the total amount.
Public property | CurrencyCode | Gets or sets the code that represents the currency.
Public property | Description | Gets or sets the text that describes the total.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | TaxTotal | Gets or sets the tax total that describes the tax. It is calculated from the tax subtotals.
Top
See Also

Reference

Total Class
Sitecore.Commerce.Entities.Prices Namespace


Total.Amount Property

TotalAmount Property
Gets or sets the value that represents the total amount.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public decimal Amount { get; set; }
Public Property Amount As Decimal
    Get
    Set
public:
property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
member Amount : decimal with get, set

Property Value

Type: Decimal
The value of the total.
See Also

Reference

Total Class
Sitecore.Commerce.Entities.Prices Namespace


Total.CurrencyCode Property

TotalCurrencyCode Property
Gets or sets the code that represents the currency.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}
member CurrencyCode : string with get, set

Property Value

Type: String
The currency of the total.
See Also

Reference

Total Class
Sitecore.Commerce.Entities.Prices Namespace


Total.Description Property

TotalDescription Property
Gets or sets the text that describes the total.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
Text that describes the total.
See Also

Reference

Total Class
Sitecore.Commerce.Entities.Prices Namespace


Total.TaxTotal Property

TotalTaxTotal Property
Gets or sets the tax total that describes the tax. It is calculated from the tax subtotals.

Namespace: Sitecore.Commerce.Entities.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TaxTotal TaxTotal { get; set; }
Public Property TaxTotal As TaxTotal
    Get
    Set
public:
property TaxTotal^ TaxTotal {
    TaxTotal^ get ();
    void set (TaxTotal^ value);
}
member TaxTotal : TaxTotal with get, set

Property Value

Type: TaxTotal
An object that represents the taxes total.
See Also

Reference

Total Class
Sitecore.Commerce.Entities.Prices Namespace


Sitecore.Commerce.Entities.Products Namespace

Sitecore.Commerce.Entities.Products Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Entities.Products"]

Classes
 | Class | Description
Public class | Classification | Represents the classification of the product and its data. The ProductClassification class implements the ProductEntity class.
Public class | ClassificationGroup | Represents the group of classifications in a product. The ProductClassificationGroup class implements the ProductEntity class.
Public class | Division | Represents the product division and its data. The Division class implements the ProductEntity class.
Public class | GlobalSpecification | Represents the product specifications and the associated data. The GlobalSpecification class implements the ProductEntity class.
Public class | GlobalSpecificationOption | Represents the product specification option. The GlobalSpecificationOption class implements the ProductEntity class.
Public class | GlobalSpecifications | Represents the product specification collection and its data. The GlobalSpecifications class implements the ProductEntity class.
Public class | Manufacturer | Represents the manufacturer of the product and its data. The Manufacturer class implements the ProductEntity class.
Public class | Product | Represents the product and its data. The Product class implements the ProductEntity class.
Public class | ProductEntity | Defines the ProductEntity type. The ProductEntity class implements the Entity class.
Public class | ProductResource | Represents the product resource and its associated data. The ProductResource class implements the ProductEntity class.
Public class | ProductSpecifications | The specifications.
Public class | ProductType | Represents the product type and its data. The ProductType class implements the ProductEntity class.
Public class | ProductVariantSpecifications | Represents the product variant specifications and the associated data. The ProductVariantSpecifications class implements the ProductEntity class.
Public class | Relation | Represents the product relation and its data. The ProductRelation class implements the ProductEntity class.
Public class | RelationType | Represents the type of the product relation and the associated data. The ProductRelationType class implements the ProductEntity class.
Public class | Resource | Represents the product resource. The Resource class implements the ProductEntity class.
Public class | Specification | Represents the product specifications and its associated data. The ProductSpecification class implements the ProductEntity class.


Classification Class

Classification Class
Represents the classification of the product and its data. The ProductClassification class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsClassification

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Classification : ProductEntity
<SerializableAttribute>
Public Class Classification
    Inherits ProductEntity
[SerializableAttribute]
public ref class Classification : public ProductEntity
[<SerializableAttribute>]
type Classification =
    class
        inherit ProductEntity
    end

The Classification type exposes the following members.

Constructors
 | Name | Description
Public method | Classification | Initializes a new instance of the Classification class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | Description | Gets or sets the description of the product classification.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | ExternalParentId | Gets or sets the ID of the parent classification in the external commerce system.
Public property | Name | Gets or sets the name of the product classification.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Specifications | Gets or sets the specifications of the product classification.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


Classification Constructor

Classification Constructor
Initializes a new instance of the Classification class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Classification()
Public Sub New
public:
Classification()
new : unit -> Classification
See Also

Reference

Classification Class
Sitecore.Commerce.Entities.Products Namespace


Classification Methods

Classification Methods

The Classification type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Classification Class
Sitecore.Commerce.Entities.Products Namespace


Classification Properties

Classification Properties

The Classification type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | Description | Gets or sets the description of the product classification.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | ExternalParentId | Gets or sets the ID of the parent classification in the external commerce system.
Public property | Name | Gets or sets the name of the product classification.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Specifications | Gets or sets the specifications of the product classification.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Classification Class
Sitecore.Commerce.Entities.Products Namespace


Classification.Description Property

ClassificationDescription Property
Gets or sets the description of the product classification.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String
The description of the product classification
See Also

Reference

Classification Class
Sitecore.Commerce.Entities.Products Namespace


Classification.ExternalParentId Property

ClassificationExternalParentId Property
Gets or sets the ID of the parent classification in the external commerce system.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string ExternalParentId { get; set; }
Public Overridable Property ExternalParentId As String
    Get
    Set
public:
virtual property String^ ExternalParentId {
    String^ get ();
    void set (String^ value);
}
abstract ExternalParentId : string with get, set
override ExternalParentId : string with get, set

Property Value

Type: String
The ID of the parent classification in th external commerce system
See Also

Reference

Classification Class
Sitecore.Commerce.Entities.Products Namespace


Classification.Name Property

ClassificationName Property
Gets or sets the name of the product classification.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name of the product classification
See Also

Reference

Classification Class
Sitecore.Commerce.Entities.Products Namespace


Classification.Specifications Property

ClassificationSpecifications Property
Gets or sets the specifications of the product classification.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GlobalSpecifications Specifications { get; set; }
Public Overridable Property Specifications As GlobalSpecifications
    Get
    Set
public:
virtual property GlobalSpecifications^ Specifications {
    GlobalSpecifications^ get ();
    void set (GlobalSpecifications^ value);
}
abstract Specifications : GlobalSpecifications with get, set
override Specifications : GlobalSpecifications with get, set

Property Value

Type: GlobalSpecifications
The specifications of the product classification
See Also

Reference

Classification Class
Sitecore.Commerce.Entities.Products Namespace


ClassificationGroup Class

ClassificationGroup Class
Represents the group of classifications in a product. The ProductClassificationGroup class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsClassificationGroup

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ClassificationGroup : ProductEntity
<SerializableAttribute>
Public Class ClassificationGroup
    Inherits ProductEntity
[SerializableAttribute]
public ref class ClassificationGroup : public ProductEntity
[<SerializableAttribute>]
type ClassificationGroup =
    class
        inherit ProductEntity
    end

The ClassificationGroup type exposes the following members.

Constructors
 | Name | Description
Public method | ClassificationGroup | Initializes a new instance of the ClassificationGroup class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Classifications | Gets or sets the group of classifications for a product.
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | Description | Gets or sets the description of a classifications group.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the name of the group of product classifications.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


ClassificationGroup Constructor

ClassificationGroup Constructor
Initializes a new instance of the ClassificationGroup class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ClassificationGroup()
Public Sub New
public:
ClassificationGroup()
new : unit -> ClassificationGroup
See Also

Reference

ClassificationGroup Class
Sitecore.Commerce.Entities.Products Namespace


ClassificationGroup Methods

ClassificationGroup Methods

The ClassificationGroup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClassificationGroup Class
Sitecore.Commerce.Entities.Products Namespace


ClassificationGroup Properties

ClassificationGroup Properties

The ClassificationGroup type exposes the following members.

Properties
 | Name | Description
Public property | Classifications | Gets or sets the group of classifications for a product.
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | Description | Gets or sets the description of a classifications group.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the name of the group of product classifications.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

ClassificationGroup Class
Sitecore.Commerce.Entities.Products Namespace


ClassificationGroup.Classifications Property

ClassificationGroupClassifications Property
Gets or sets the group of classifications for a product.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection Classifications { get; set; }
Public Overridable Property Classifications As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ Classifications {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract Classifications : IReadOnlyCollection with get, set
override Classifications : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The group of classifications for a product
See Also

Reference

ClassificationGroup Class
Sitecore.Commerce.Entities.Products Namespace


ClassificationGroup.Description Property

ClassificationGroupDescription Property
Gets or sets the description of a classifications group.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String
The description of a classifications group
See Also

Reference

ClassificationGroup Class
Sitecore.Commerce.Entities.Products Namespace


ClassificationGroup.Name Property

ClassificationGroupName Property
Gets or sets the name of the group of product classifications.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name of the group of product classifications.
See Also

Reference

ClassificationGroup Class
Sitecore.Commerce.Entities.Products Namespace


Division Class

Division Class
Represents the product division and its data. The Division class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsDivision

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Division : ProductEntity
<SerializableAttribute>
Public Class Division
    Inherits ProductEntity
[SerializableAttribute]
public ref class Division : public ProductEntity
[<SerializableAttribute>]
type Division =
    class
        inherit ProductEntity
    end

The Division type exposes the following members.

Constructors
 | Name | Description
Public method | Division | Initializes a new instance of the Division class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | Description | Gets or sets the division description.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the division name.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | SubDivisions | Gets or sets a group of subdivisions in a division.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


Division Constructor

Division Constructor
Initializes a new instance of the Division class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Division()
Public Sub New
public:
Division()
new : unit -> Division
See Also

Reference

Division Class
Sitecore.Commerce.Entities.Products Namespace


Division Methods

Division Methods

The Division type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Division Class
Sitecore.Commerce.Entities.Products Namespace


Division Properties

Division Properties

The Division type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | Description | Gets or sets the division description.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the division name.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | SubDivisions | Gets or sets a group of subdivisions in a division.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Division Class
Sitecore.Commerce.Entities.Products Namespace


Division.Description Property

DivisionDescription Property
Gets or sets the division description.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String
The description.
See Also

Reference

Division Class
Sitecore.Commerce.Entities.Products Namespace


Division.Name Property

DivisionName Property
Gets or sets the division name.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

Division Class
Sitecore.Commerce.Entities.Products Namespace


Division.SubDivisions Property

DivisionSubDivisions Property
Gets or sets a group of subdivisions in a division.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection SubDivisions { get; set; }
Public Overridable Property SubDivisions As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ SubDivisions {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract SubDivisions : IReadOnlyCollection with get, set
override SubDivisions : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The subdivisions in a division.
See Also

Reference

Division Class
Sitecore.Commerce.Entities.Products Namespace


GlobalSpecification Class

GlobalSpecification Class
Represents the product specifications and the associated data. The GlobalSpecification class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsGlobalSpecification

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class GlobalSpecification : ProductEntity
<SerializableAttribute>
Public Class GlobalSpecification
    Inherits ProductEntity
[SerializableAttribute]
public ref class GlobalSpecification : public ProductEntity
[<SerializableAttribute>]
type GlobalSpecification =
    class
        inherit ProductEntity
    end

The GlobalSpecification type exposes the following members.

Constructors
 | Name | Description
Public method | GlobalSpecification | Initializes a new instance of the GlobalSpecification class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the name.
Public property | Options | Gets or sets the specifications.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


GlobalSpecification Constructor

GlobalSpecification Constructor
Initializes a new instance of the GlobalSpecification class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GlobalSpecification()
Public Sub New
public:
GlobalSpecification()
new : unit -> GlobalSpecification
See Also

Reference

GlobalSpecification Class
Sitecore.Commerce.Entities.Products Namespace


GlobalSpecification Methods

GlobalSpecification Methods

The GlobalSpecification type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GlobalSpecification Class
Sitecore.Commerce.Entities.Products Namespace


GlobalSpecification Properties

GlobalSpecification Properties

The GlobalSpecification type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the name.
Public property | Options | Gets or sets the specifications.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

GlobalSpecification Class
Sitecore.Commerce.Entities.Products Namespace


GlobalSpecification.Name Property

GlobalSpecificationName Property
Gets or sets the name.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

GlobalSpecification Class
Sitecore.Commerce.Entities.Products Namespace


GlobalSpecification.Options Property

GlobalSpecificationOptions Property
Gets or sets the specifications.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection Options { get; set; }
Public Overridable Property Options As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ Options {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract Options : IReadOnlyCollection with get, set
override Options : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The specifications.
See Also

Reference

GlobalSpecification Class
Sitecore.Commerce.Entities.Products Namespace


GlobalSpecificationOption Class

GlobalSpecificationOption Class
Represents the product specification option. The GlobalSpecificationOption class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsGlobalSpecificationOption

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class GlobalSpecificationOption : ProductEntity
<SerializableAttribute>
Public Class GlobalSpecificationOption
    Inherits ProductEntity
[SerializableAttribute]
public ref class GlobalSpecificationOption : public ProductEntity
[<SerializableAttribute>]
type GlobalSpecificationOption =
    class
        inherit ProductEntity
    end

The GlobalSpecificationOption type exposes the following members.

Constructors
 | Name | Description
Public method | GlobalSpecificationOption | Initializes a new instance of the GlobalSpecificationOption class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | ExternalSpecificationId | Gets or sets the external ID. The external ID is a unique identifier of the global specification option in the external commerce system. The external ID is not assigned any value before the global specification option has been created in the external commerce system.
Public property | Name | Gets or sets the option name of the global specification.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


GlobalSpecificationOption Constructor

GlobalSpecificationOption Constructor
Initializes a new instance of the GlobalSpecificationOption class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GlobalSpecificationOption()
Public Sub New
public:
GlobalSpecificationOption()
new : unit -> GlobalSpecificationOption
See Also

Reference

GlobalSpecificationOption Class
Sitecore.Commerce.Entities.Products Namespace


GlobalSpecificationOption Methods

GlobalSpecificationOption Methods

The GlobalSpecificationOption type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GlobalSpecificationOption Class
Sitecore.Commerce.Entities.Products Namespace


GlobalSpecificationOption Properties

GlobalSpecificationOption Properties

The GlobalSpecificationOption type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | ExternalSpecificationId | Gets or sets the external ID. The external ID is a unique identifier of the global specification option in the external commerce system. The external ID is not assigned any value before the global specification option has been created in the external commerce system.
Public property | Name | Gets or sets the option name of the global specification.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

GlobalSpecificationOption Class
Sitecore.Commerce.Entities.Products Namespace


GlobalSpecificationOption.ExternalSpecificationId Property

GlobalSpecificationOptionExternalSpecificationId Property
Gets or sets the external ID. The external ID is a unique identifier of the global specification option in the external commerce system. The external ID is not assigned any value before the global specification option has been created in the external commerce system.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string ExternalSpecificationId { get; set; }
Public Overridable Property ExternalSpecificationId As String
    Get
    Set
public:
virtual property String^ ExternalSpecificationId {
    String^ get ();
    void set (String^ value);
}
abstract ExternalSpecificationId : string with get, set
override ExternalSpecificationId : string with get, set

Property Value

Type: String
The ID of the global specification option in the external commerce system.
See Also

Reference

GlobalSpecificationOption Class
Sitecore.Commerce.Entities.Products Namespace


GlobalSpecificationOption.Name Property

GlobalSpecificationOptionName Property
Gets or sets the option name of the global specification.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The option name of the global specification.
See Also

Reference

GlobalSpecificationOption Class
Sitecore.Commerce.Entities.Products Namespace


GlobalSpecifications Class

GlobalSpecifications Class
Represents the product specification collection and its data. The GlobalSpecifications class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsGlobalSpecifications

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class GlobalSpecifications : ProductEntity
<SerializableAttribute>
Public Class GlobalSpecifications
    Inherits ProductEntity
[SerializableAttribute]
public ref class GlobalSpecifications : public ProductEntity
[<SerializableAttribute>]
type GlobalSpecifications =
    class
        inherit ProductEntity
    end

The GlobalSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | GlobalSpecifications | Initializes a new instance of the GlobalSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Specifications | Gets or sets the specifications.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


GlobalSpecifications Constructor

GlobalSpecifications Constructor
Initializes a new instance of the GlobalSpecifications class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GlobalSpecifications()
Public Sub New
public:
GlobalSpecifications()
new : unit -> GlobalSpecifications
See Also

Reference

GlobalSpecifications Class
Sitecore.Commerce.Entities.Products Namespace


GlobalSpecifications Methods

GlobalSpecifications Methods

The GlobalSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GlobalSpecifications Class
Sitecore.Commerce.Entities.Products Namespace


GlobalSpecifications Properties

GlobalSpecifications Properties

The GlobalSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Specifications | Gets or sets the specifications.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

GlobalSpecifications Class
Sitecore.Commerce.Entities.Products Namespace


GlobalSpecifications.Specifications Property

GlobalSpecificationsSpecifications Property
Gets or sets the specifications.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection Specifications { get; set; }
Public Overridable Property Specifications As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ Specifications {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract Specifications : IReadOnlyCollection with get, set
override Specifications : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The specifications.
See Also

Reference

GlobalSpecifications Class
Sitecore.Commerce.Entities.Products Namespace


Manufacturer Class

Manufacturer Class
Represents the manufacturer of the product and its data. The Manufacturer class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsManufacturer

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Manufacturer : ProductEntity
<SerializableAttribute>
Public Class Manufacturer
    Inherits ProductEntity
[SerializableAttribute]
public ref class Manufacturer : public ProductEntity
[<SerializableAttribute>]
type Manufacturer =
    class
        inherit ProductEntity
    end

The Manufacturer type exposes the following members.

Constructors
 | Name | Description
Public method | Manufacturer | Initializes a new instance of the Manufacturer class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | Description | Gets or sets the description of the manufacturer.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the name of the manufacturer.
Public property | ProductTypes | Gets or sets the product types that the manufacturer produces.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | WebSiteUrl | Gets or sets the URL of the manufacturer's website.
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


Manufacturer Constructor

Manufacturer Constructor
Initializes a new instance of the Manufacturer class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Manufacturer()
Public Sub New
public:
Manufacturer()
new : unit -> Manufacturer
See Also

Reference

Manufacturer Class
Sitecore.Commerce.Entities.Products Namespace


Manufacturer Methods

Manufacturer Methods

The Manufacturer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Manufacturer Class
Sitecore.Commerce.Entities.Products Namespace


Manufacturer Properties

Manufacturer Properties

The Manufacturer type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | Description | Gets or sets the description of the manufacturer.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the name of the manufacturer.
Public property | ProductTypes | Gets or sets the product types that the manufacturer produces.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | WebSiteUrl | Gets or sets the URL of the manufacturer's website.
Top
See Also

Reference

Manufacturer Class
Sitecore.Commerce.Entities.Products Namespace


Manufacturer.Description Property

ManufacturerDescription Property
Gets or sets the description of the manufacturer.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String
The description of the manufacturer.
See Also

Reference

Manufacturer Class
Sitecore.Commerce.Entities.Products Namespace


Manufacturer.Name Property

ManufacturerName Property
Gets or sets the name of the manufacturer.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name of the manufacturer.
See Also

Reference

Manufacturer Class
Sitecore.Commerce.Entities.Products Namespace


Manufacturer.ProductTypes Property

ManufacturerProductTypes Property
Gets or sets the product types that the manufacturer produces.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection ProductTypes { get; set; }
Public Overridable Property ProductTypes As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ ProductTypes {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract ProductTypes : IReadOnlyCollection with get, set
override ProductTypes : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The product types.
See Also

Reference

Manufacturer Class
Sitecore.Commerce.Entities.Products Namespace


Manufacturer.WebSiteUrl Property

ManufacturerWebSiteUrl Property
Gets or sets the URL of the manufacturer's website.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string WebSiteUrl { get; set; }
Public Overridable Property WebSiteUrl As String
    Get
    Set
public:
virtual property String^ WebSiteUrl {
    String^ get ();
    void set (String^ value);
}
abstract WebSiteUrl : string with get, set
override WebSiteUrl : string with get, set

Property Value

Type: String
The URL of the manufacturer's website.
See Also

Reference

Manufacturer Class
Sitecore.Commerce.Entities.Products Namespace


Product Class

Product Class
Represents the product and its data. The Product class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsProduct

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Product : ProductEntity
<SerializableAttribute>
Public Class Product
    Inherits ProductEntity
[SerializableAttribute]
public ref class Product : public ProductEntity
[<SerializableAttribute>]
type Product =
    class
        inherit ProductEntity
    end

The Product type exposes the following members.

Constructors
 | Name | Description
Public method | Product | Initializes a new instance of the Product class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ClassificationGroups | Gets or sets the classification groups for a product.
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | Divisions | Gets or sets the divisions.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | FullDescription | Gets or sets a full description of the product.
Public property | Identification | Gets or sets the identification dictionary.
Public property | Manufacturers | Gets or sets the name of the product's manufacturer.
Public property | Name | Gets or sets the name of the product.
Public property | ProductSpecifications | Gets or sets the product specifications.
Public property | ProductTypes | Gets or sets the type of the product.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | RelationTypes | Gets or sets the relation types.
Public property | Resources | Gets or sets the resources.
Public property | ShortDescription | Gets or sets a short description of the product.
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | VariantSpecifications | Gets or sets the variant specifications.
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


Product Constructor

Product Constructor
Initializes a new instance of the Product class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Product()
Public Sub New
public:
Product()
new : unit -> Product
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


Product Methods

Product Methods

The Product type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


Product Properties

Product Properties

The Product type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationGroups | Gets or sets the classification groups for a product.
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | Divisions | Gets or sets the divisions.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | FullDescription | Gets or sets a full description of the product.
Public property | Identification | Gets or sets the identification dictionary.
Public property | Manufacturers | Gets or sets the name of the product's manufacturer.
Public property | Name | Gets or sets the name of the product.
Public property | ProductSpecifications | Gets or sets the product specifications.
Public property | ProductTypes | Gets or sets the type of the product.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | RelationTypes | Gets or sets the relation types.
Public property | Resources | Gets or sets the resources.
Public property | ShortDescription | Gets or sets a short description of the product.
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | VariantSpecifications | Gets or sets the variant specifications.
Top
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


Product.ClassificationGroups Property

ProductClassificationGroups Property
Gets or sets the classification groups for a product.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection ClassificationGroups { get; set; }
Public Overridable Property ClassificationGroups As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ ClassificationGroups {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract ClassificationGroups : IReadOnlyCollection with get, set
override ClassificationGroups : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The classification groups for a product
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


Product.Divisions Property

ProductDivisions Property
Gets or sets the divisions.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection Divisions { get; set; }
Public Overridable Property Divisions As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ Divisions {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract Divisions : IReadOnlyCollection with get, set
override Divisions : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The divisions.
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


Product.FullDescription Property

ProductFullDescription Property
Gets or sets a full description of the product.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string FullDescription { get; set; }
Public Overridable Property FullDescription As String
    Get
    Set
public:
virtual property String^ FullDescription {
    String^ get ();
    void set (String^ value);
}
abstract FullDescription : string with get, set
override FullDescription : string with get, set

Property Value

Type: String
A full description of the product
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


Product.Identification Property

ProductIdentification Property
Gets or sets the identification dictionary.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IDictionary<string, string> Identification { get; set; }
Public Overridable Property Identification As IDictionary(Of String, String)
    Get
    Set
public:
virtual property IDictionary<String^, String^>^ Identification {
    IDictionary<String^, String^>^ get ();
    void set (IDictionary<String^, String^>^ value);
}
abstract Identification : IDictionary<string, string> with get, set
override Identification : IDictionary<string, string> with get, set

Property Value

Type: IDictionary String, String
The identification dictionary.
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


Product.Manufacturers Property

ProductManufacturers Property
Gets or sets the name of the product's manufacturer.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection Manufacturers { get; set; }
Public Overridable Property Manufacturers As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ Manufacturers {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract Manufacturers : IReadOnlyCollection with get, set
override Manufacturers : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The name of the product's manufacturer
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


Product.Name Property

ProductName Property
Gets or sets the name of the product.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name of the product
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


Product.ProductSpecifications Property

ProductProductSpecifications Property
Gets or sets the product specifications.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection ProductSpecifications { get; set; }
Public Overridable Property ProductSpecifications As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ ProductSpecifications {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract ProductSpecifications : IReadOnlyCollection with get, set
override ProductSpecifications : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The product specifications.
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


Product.ProductTypes Property

ProductProductTypes Property
Gets or sets the type of the product.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection ProductTypes { get; set; }
Public Overridable Property ProductTypes As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ ProductTypes {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract ProductTypes : IReadOnlyCollection with get, set
override ProductTypes : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The type of the product
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


Product.RelationTypes Property

ProductRelationTypes Property
Gets or sets the relation types.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection RelationTypes { get; set; }
Public Overridable Property RelationTypes As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ RelationTypes {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract RelationTypes : IReadOnlyCollection with get, set
override RelationTypes : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The relation types.
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


Product.Resources Property

ProductResources Property
Gets or sets the resources.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection Resources { get; set; }
Public Overridable Property Resources As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ Resources {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract Resources : IReadOnlyCollection with get, set
override Resources : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The resources.
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


Product.ShortDescription Property

ProductShortDescription Property
Gets or sets a short description of the product.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string ShortDescription { get; set; }
Public Overridable Property ShortDescription As String
    Get
    Set
public:
virtual property String^ ShortDescription {
    String^ get ();
    void set (String^ value);
}
abstract ShortDescription : string with get, set
override ShortDescription : string with get, set

Property Value

Type: String
A short description of the product
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


Product.VariantSpecifications Property

ProductVariantSpecifications Property
Gets or sets the variant specifications.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ProductVariantSpecifications VariantSpecifications { get; set; }
Public Overridable Property VariantSpecifications As ProductVariantSpecifications
    Get
    Set
public:
virtual property ProductVariantSpecifications^ VariantSpecifications {
    ProductVariantSpecifications^ get ();
    void set (ProductVariantSpecifications^ value);
}
abstract VariantSpecifications : ProductVariantSpecifications with get, set
override VariantSpecifications : ProductVariantSpecifications with get, set

Property Value

Type: ProductVariantSpecifications
The variant specifications.
See Also

Reference

Product Class
Sitecore.Commerce.Entities.Products Namespace


ProductEntity Class

ProductEntity Class
Defines the ProductEntity type. The ProductEntity class implements the Entity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
More...

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class ProductEntity : MappedEntity
<SerializableAttribute>
Public MustInherit Class ProductEntity
    Inherits MappedEntity
[SerializableAttribute]
public ref class ProductEntity abstract : public MappedEntity
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ProductEntity =
    class
        inherit MappedEntity
    end

The ProductEntity type exposes the following members.

Constructors
 | Name | Description
Protected method | ProductEntity | Initializes a new instance of the ProductEntity class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system.
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsClassification
Sitecore.Commerce.Entities.ProductsClassificationGroup
Sitecore.Commerce.Entities.ProductsDivision
Sitecore.Commerce.Entities.ProductsGlobalSpecification
Sitecore.Commerce.Entities.ProductsGlobalSpecificationOption
Sitecore.Commerce.Entities.ProductsGlobalSpecifications
Sitecore.Commerce.Entities.ProductsManufacturer
Sitecore.Commerce.Entities.ProductsProduct
Sitecore.Commerce.Entities.ProductsProductResource
Sitecore.Commerce.Entities.ProductsProductSpecifications
Sitecore.Commerce.Entities.ProductsProductType
Sitecore.Commerce.Entities.ProductsProductVariantSpecifications
Sitecore.Commerce.Entities.ProductsRelation
Sitecore.Commerce.Entities.ProductsRelationType
Sitecore.Commerce.Entities.ProductsResource
Sitecore.Commerce.Entities.ProductsSpecification


ProductEntity Constructor

ProductEntity Constructor
Initializes a new instance of the ProductEntity class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected ProductEntity()
Protected Sub New
protected:
ProductEntity()
new : unit -> ProductEntity
See Also

Reference

ProductEntity Class
Sitecore.Commerce.Entities.Products Namespace


ProductEntity Methods

ProductEntity Methods

The ProductEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductEntity Class
Sitecore.Commerce.Entities.Products Namespace


ProductEntity Properties

ProductEntity Properties

The ProductEntity type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system.
Top
See Also

Reference

ProductEntity Class
Sitecore.Commerce.Entities.Products Namespace


ProductEntity.Created Property

ProductEntityCreated Property
Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual DateTime Created { get; set; }
Public Overridable Property Created As DateTime
    Get
    Set
public:
virtual property DateTime Created {
    DateTime get ();
    void set (DateTime value);
}
abstract Created : DateTime with get, set
override Created : DateTime with get, set

Property Value

Type: DateTime
The creation date and time of the product
See Also

Reference

ProductEntity Class
Sitecore.Commerce.Entities.Products Namespace


ProductEntity.SitecoreItemId Property

ProductEntitySitecoreItemId Property
Gets or sets the ID of Sitecore item.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual Guid SitecoreItemId { get; set; }
Public Overridable Property SitecoreItemId As Guid
    Get
    Set
public:
virtual property Guid SitecoreItemId {
    Guid get ();
    void set (Guid value);
}
abstract SitecoreItemId : Guid with get, set
override SitecoreItemId : Guid with get, set

Property Value

Type: Guid
The ID of Sitecore item.
See Also

Reference

ProductEntity Class
Sitecore.Commerce.Entities.Products Namespace


ProductEntity.Updated Property

ProductEntityUpdated Property
Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual DateTime Updated { get; set; }
Public Overridable Property Updated As DateTime
    Get
    Set
public:
virtual property DateTime Updated {
    DateTime get ();
    void set (DateTime value);
}
abstract Updated : DateTime with get, set
override Updated : DateTime with get, set

Property Value

Type: DateTime
The update date and time of the product
See Also

Reference

ProductEntity Class
Sitecore.Commerce.Entities.Products Namespace


ProductResource Class

ProductResource Class
Represents the product resource and its associated data. The ProductResource class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsProductResource

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ProductResource : ProductEntity
<SerializableAttribute>
Public Class ProductResource
    Inherits ProductEntity
[SerializableAttribute]
public ref class ProductResource : public ProductEntity
[<SerializableAttribute>]
type ProductResource =
    class
        inherit ProductEntity
    end

The ProductResource type exposes the following members.

Constructors
 | Name | Description
Public method | ProductResource | Initializes a new instance of the ProductResource class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | MediaItemId | Gets or sets the media item identifier.
Public property | Name | Gets or sets the name.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Type | Gets or sets the type of the product resource.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | Uri | Gets or sets the resource URI.
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


ProductResource Constructor

ProductResource Constructor
Initializes a new instance of the ProductResource class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductResource()
Public Sub New
public:
ProductResource()
new : unit -> ProductResource
See Also

Reference

ProductResource Class
Sitecore.Commerce.Entities.Products Namespace


ProductResource Methods

ProductResource Methods

The ProductResource type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductResource Class
Sitecore.Commerce.Entities.Products Namespace


ProductResource Properties

ProductResource Properties

The ProductResource type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | MediaItemId | Gets or sets the media item identifier.
Public property | Name | Gets or sets the name.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Type | Gets or sets the type of the product resource.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | Uri | Gets or sets the resource URI.
Top
See Also

Reference

ProductResource Class
Sitecore.Commerce.Entities.Products Namespace


ProductResource.MediaItemId Property

ProductResourceMediaItemId Property
Gets or sets the media item identifier.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual Guid MediaItemId { get; set; }
Public Overridable Property MediaItemId As Guid
    Get
    Set
public:
virtual property Guid MediaItemId {
    Guid get ();
    void set (Guid value);
}
abstract MediaItemId : Guid with get, set
override MediaItemId : Guid with get, set

Property Value

Type: Guid
The media item identifier.
See Also

Reference

ProductResource Class
Sitecore.Commerce.Entities.Products Namespace


ProductResource.Name Property

ProductResourceName Property
Gets or sets the name.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

ProductResource Class
Sitecore.Commerce.Entities.Products Namespace


ProductResource.Type Property

ProductResourceType Property
Gets or sets the type of the product resource.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Type { get; set; }
Public Overridable Property Type As String
    Get
    Set
public:
virtual property String^ Type {
    String^ get ();
    void set (String^ value);
}
abstract Type : string with get, set
override Type : string with get, set

Property Value

Type: String
The type of the product resource.
See Also

Reference

ProductResource Class
Sitecore.Commerce.Entities.Products Namespace


ProductResource.Uri Property

ProductResourceUri Property
Gets or sets the resource URI.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Uri { get; set; }
Public Overridable Property Uri As String
    Get
    Set
public:
virtual property String^ Uri {
    String^ get ();
    void set (String^ value);
}
abstract Uri : string with get, set
override Uri : string with get, set

Property Value

Type: String
The resource URI.
See Also

Reference

ProductResource Class
Sitecore.Commerce.Entities.Products Namespace


ProductSpecifications Class

ProductSpecifications Class
The specifications.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsProductSpecifications

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ProductSpecifications : ProductEntity
<SerializableAttribute>
Public Class ProductSpecifications
    Inherits ProductEntity
[SerializableAttribute]
public ref class ProductSpecifications : public ProductEntity
[<SerializableAttribute>]
type ProductSpecifications =
    class
        inherit ProductEntity
    end

The ProductSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | ProductSpecifications | Initializes a new instance of the ProductSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | GroupName | Gets or sets the name of the group.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Specifications | Gets or sets the specifications.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


ProductSpecifications Constructor

ProductSpecifications Constructor
Initializes a new instance of the ProductSpecifications class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductSpecifications()
Public Sub New
public:
ProductSpecifications()
new : unit -> ProductSpecifications
See Also

Reference

ProductSpecifications Class
Sitecore.Commerce.Entities.Products Namespace


ProductSpecifications Methods

ProductSpecifications Methods

The ProductSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductSpecifications Class
Sitecore.Commerce.Entities.Products Namespace


ProductSpecifications Properties

ProductSpecifications Properties

The ProductSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | GroupName | Gets or sets the name of the group.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Specifications | Gets or sets the specifications.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

ProductSpecifications Class
Sitecore.Commerce.Entities.Products Namespace


ProductSpecifications.GroupName Property

ProductSpecificationsGroupName Property
Gets or sets the name of the group.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string GroupName { get; set; }
Public Overridable Property GroupName As String
    Get
    Set
public:
virtual property String^ GroupName {
    String^ get ();
    void set (String^ value);
}
abstract GroupName : string with get, set
override GroupName : string with get, set

Property Value

Type: String
See Also

Reference

ProductSpecifications Class
Sitecore.Commerce.Entities.Products Namespace


ProductSpecifications.Specifications Property

ProductSpecificationsSpecifications Property
Gets or sets the specifications.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection Specifications { get; set; }
Public Overridable Property Specifications As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ Specifications {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract Specifications : IReadOnlyCollection with get, set
override Specifications : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
See Also

Reference

ProductSpecifications Class
Sitecore.Commerce.Entities.Products Namespace


ProductType Class

ProductType Class
Represents the product type and its data. The ProductType class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsProductType

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ProductType : ProductEntity
<SerializableAttribute>
Public Class ProductType
    Inherits ProductEntity
[SerializableAttribute]
public ref class ProductType : public ProductEntity
[<SerializableAttribute>]
type ProductType =
    class
        inherit ProductEntity
    end

The ProductType type exposes the following members.

Constructors
 | Name | Description
Public method | ProductType | Initializes a new instance of the ProductType class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | DefaultValues | Gets or sets the default values of the specifications of the product type.
Public property | Description | Gets or sets the description of the product type.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the name.
Public property | ParentProductTypeId | Gets or sets the ID of the parent product type.
Public property | ProductTypeId | Gets or sets the ID of the product type.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Specifications | Gets or sets the specifications of the product type.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


ProductType Constructor

ProductType Constructor
Initializes a new instance of the ProductType class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductType()
Public Sub New
public:
ProductType()
new : unit -> ProductType
See Also

Reference

ProductType Class
Sitecore.Commerce.Entities.Products Namespace


ProductType Methods

ProductType Methods

The ProductType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductType Class
Sitecore.Commerce.Entities.Products Namespace


ProductType Properties

ProductType Properties

The ProductType type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | DefaultValues | Gets or sets the default values of the specifications of the product type.
Public property | Description | Gets or sets the description of the product type.
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the name.
Public property | ParentProductTypeId | Gets or sets the ID of the parent product type.
Public property | ProductTypeId | Gets or sets the ID of the product type.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Specifications | Gets or sets the specifications of the product type.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

ProductType Class
Sitecore.Commerce.Entities.Products Namespace


ProductType.DefaultValues Property

ProductTypeDefaultValues Property
Gets or sets the default values of the specifications of the product type.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ProductSpecifications DefaultValues { get; set; }
Public Overridable Property DefaultValues As ProductSpecifications
    Get
    Set
public:
virtual property ProductSpecifications^ DefaultValues {
    ProductSpecifications^ get ();
    void set (ProductSpecifications^ value);
}
abstract DefaultValues : ProductSpecifications with get, set
override DefaultValues : ProductSpecifications with get, set

Property Value

Type: ProductSpecifications
The default product type specification values
See Also

Reference

ProductType Class
Sitecore.Commerce.Entities.Products Namespace


ProductType.Description Property

ProductTypeDescription Property
Gets or sets the description of the product type.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String
The product type description.
See Also

Reference

ProductType Class
Sitecore.Commerce.Entities.Products Namespace


ProductType.Name Property

ProductTypeName Property
Gets or sets the name.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

ProductType Class
Sitecore.Commerce.Entities.Products Namespace


ProductType.ParentProductTypeId Property

ProductTypeParentProductTypeId Property
Gets or sets the ID of the parent product type.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string ParentProductTypeId { get; set; }
Public Overridable Property ParentProductTypeId As String
    Get
    Set
public:
virtual property String^ ParentProductTypeId {
    String^ get ();
    void set (String^ value);
}
abstract ParentProductTypeId : string with get, set
override ParentProductTypeId : string with get, set

Property Value

Type: String
The parent product type ID.
See Also

Reference

ProductType Class
Sitecore.Commerce.Entities.Products Namespace


ProductType.ProductTypeId Property

ProductTypeProductTypeId Property
Gets or sets the ID of the product type.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string ProductTypeId { get; set; }
Public Overridable Property ProductTypeId As String
    Get
    Set
public:
virtual property String^ ProductTypeId {
    String^ get ();
    void set (String^ value);
}
abstract ProductTypeId : string with get, set
override ProductTypeId : string with get, set

Property Value

Type: String
The ID of the product type
See Also

Reference

ProductType Class
Sitecore.Commerce.Entities.Products Namespace


ProductType.Specifications Property

ProductTypeSpecifications Property
Gets or sets the specifications of the product type.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GlobalSpecifications Specifications { get; set; }
Public Overridable Property Specifications As GlobalSpecifications
    Get
    Set
public:
virtual property GlobalSpecifications^ Specifications {
    GlobalSpecifications^ get ();
    void set (GlobalSpecifications^ value);
}
abstract Specifications : GlobalSpecifications with get, set
override Specifications : GlobalSpecifications with get, set

Property Value

Type: GlobalSpecifications
The product type specifications.
See Also

Reference

ProductType Class
Sitecore.Commerce.Entities.Products Namespace


ProductVariantSpecifications Class

ProductVariantSpecifications Class
Represents the product variant specifications and the associated data. The ProductVariantSpecifications class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsProductVariantSpecifications

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ProductVariantSpecifications : ProductEntity
<SerializableAttribute>
Public Class ProductVariantSpecifications
    Inherits ProductEntity
[SerializableAttribute]
public ref class ProductVariantSpecifications : public ProductEntity
[<SerializableAttribute>]
type ProductVariantSpecifications =
    class
        inherit ProductEntity
    end

The ProductVariantSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | ProductVariantSpecifications | Initializes a new instance of the ProductVariantSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Specifications | Gets or sets the specifications of the product variant.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


ProductVariantSpecifications Constructor

ProductVariantSpecifications Constructor
Initializes a new instance of the ProductVariantSpecifications class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductVariantSpecifications()
Public Sub New
public:
ProductVariantSpecifications()
new : unit -> ProductVariantSpecifications
See Also

Reference

ProductVariantSpecifications Class
Sitecore.Commerce.Entities.Products Namespace


ProductVariantSpecifications Methods

ProductVariantSpecifications Methods

The ProductVariantSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductVariantSpecifications Class
Sitecore.Commerce.Entities.Products Namespace


ProductVariantSpecifications Properties

ProductVariantSpecifications Properties

The ProductVariantSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Specifications | Gets or sets the specifications of the product variant.
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

ProductVariantSpecifications Class
Sitecore.Commerce.Entities.Products Namespace


ProductVariantSpecifications.Specifications Property

ProductVariantSpecificationsSpecifications Property
Gets or sets the specifications of the product variant.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection Specifications { get; set; }
Public Overridable Property Specifications As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ Specifications {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract Specifications : IReadOnlyCollection with get, set
override Specifications : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The product variant specifications.
See Also

Reference

ProductVariantSpecifications Class
Sitecore.Commerce.Entities.Products Namespace


Relation Class

Relation Class
Represents the product relation and its data. The ProductRelation class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsRelation

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Relation : ProductEntity
<SerializableAttribute>
Public Class Relation
    Inherits ProductEntity
[SerializableAttribute]
public ref class Relation : public ProductEntity
[<SerializableAttribute>]
type Relation =
    class
        inherit ProductEntity
    end

The Relation type exposes the following members.

Constructors
 | Name | Description
Public method | Relation | Initializes a new instance of the Relation class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Product | Gets or sets the ID of the product.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | ReferredProduct | Gets or sets the ID of the referred product.
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


Relation Constructor

Relation Constructor
Initializes a new instance of the Relation class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Relation()
Public Sub New
public:
Relation()
new : unit -> Relation
See Also

Reference

Relation Class
Sitecore.Commerce.Entities.Products Namespace


Relation Methods

Relation Methods

The Relation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Relation Class
Sitecore.Commerce.Entities.Products Namespace


Relation Properties

Relation Properties

The Relation type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Product | Gets or sets the ID of the product.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | ReferredProduct | Gets or sets the ID of the referred product.
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Relation Class
Sitecore.Commerce.Entities.Products Namespace


Relation.Product Property

RelationProduct Property
Gets or sets the ID of the product.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual Product Product { get; set; }
Public Overridable Property Product As Product
    Get
    Set
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
abstract Product : Product with get, set
override Product : Product with get, set

Property Value

Type: Product
The product ID
See Also

Reference

Relation Class
Sitecore.Commerce.Entities.Products Namespace


Relation.ReferredProduct Property

RelationReferredProduct Property
Gets or sets the ID of the referred product.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual Product ReferredProduct { get; set; }
Public Overridable Property ReferredProduct As Product
    Get
    Set
public:
virtual property Product^ ReferredProduct {
    Product^ get ();
    void set (Product^ value);
}
abstract ReferredProduct : Product with get, set
override ReferredProduct : Product with get, set

Property Value

Type: Product
The ID of the referred product
See Also

Reference

Relation Class
Sitecore.Commerce.Entities.Products Namespace


RelationType Class

RelationType Class
Represents the type of the product relation and the associated data. The ProductRelationType class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsRelationType

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class RelationType : ProductEntity
<SerializableAttribute>
Public Class RelationType
    Inherits ProductEntity
[SerializableAttribute]
public ref class RelationType : public ProductEntity
[<SerializableAttribute>]
type RelationType =
    class
        inherit ProductEntity
    end

The RelationType type exposes the following members.

Constructors
 | Name | Description
Public method | RelationType | Initializes a new instance of the RelationType class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the name of the product relation.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Relations | Gets or sets the relations.
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


RelationType Constructor

RelationType Constructor
Initializes a new instance of the RelationType class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RelationType()
Public Sub New
public:
RelationType()
new : unit -> RelationType
See Also

Reference

RelationType Class
Sitecore.Commerce.Entities.Products Namespace


RelationType Methods

RelationType Methods

The RelationType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RelationType Class
Sitecore.Commerce.Entities.Products Namespace


RelationType Properties

RelationType Properties

The RelationType type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Name | Gets or sets the name of the product relation.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | Relations | Gets or sets the relations.
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

RelationType Class
Sitecore.Commerce.Entities.Products Namespace


RelationType.Name Property

RelationTypeName Property
Gets or sets the name of the product relation.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name of the product relation
See Also

Reference

RelationType Class
Sitecore.Commerce.Entities.Products Namespace


RelationType.Relations Property

RelationTypeRelations Property
Gets or sets the relations.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyCollection Relations { get; set; }
Public Overridable Property Relations As IReadOnlyCollection
    Get
    Set
public:
virtual property IReadOnlyCollection^ Relations {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
abstract Relations : IReadOnlyCollection with get, set
override Relations : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The relations.
See Also

Reference

RelationType Class
Sitecore.Commerce.Entities.Products Namespace


Resource Class

Resource Class
Represents the product resource. The Resource class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsResource

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Resource : ProductEntity
<SerializableAttribute>
Public Class Resource
    Inherits ProductEntity
[SerializableAttribute]
public ref class Resource : public ProductEntity
[<SerializableAttribute>]
type Resource =
    class
        inherit ProductEntity
    end

The Resource type exposes the following members.

Constructors
 | Name | Description
Public method | Resource | Initializes a new instance of the Resource class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BinaryData | Gets or sets the binary data.
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | MimeType | Gets or sets the MIME type of the resource.
Public property | Name | Gets or sets the name of the resource.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | ResourceType | Gets or sets the type of the resource.
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


Resource Constructor

Resource Constructor
Initializes a new instance of the Resource class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Resource()
Public Sub New
public:
Resource()
new : unit -> Resource
See Also

Reference

Resource Class
Sitecore.Commerce.Entities.Products Namespace


Resource Methods

Resource Methods

The Resource type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resource Class
Sitecore.Commerce.Entities.Products Namespace


Resource Properties

Resource Properties

The Resource type exposes the following members.

Properties
 | Name | Description
Public property | BinaryData | Gets or sets the binary data.
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | MimeType | Gets or sets the MIME type of the resource.
Public property | Name | Gets or sets the name of the resource.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | ResourceType | Gets or sets the type of the resource.
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Top
See Also

Reference

Resource Class
Sitecore.Commerce.Entities.Products Namespace


Resource.BinaryData Property

ResourceBinaryData Property
Gets or sets the binary data.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual byte[] BinaryData { get; set; }
Public Overridable Property BinaryData As Byte()
    Get
    Set
public:
virtual property array<unsigned char>^ BinaryData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
abstract BinaryData : byte[] with get, set
override BinaryData : byte[] with get, set

Property Value

Type: Byte
The binary data.
See Also

Reference

Resource Class
Sitecore.Commerce.Entities.Products Namespace


Resource.MimeType Property

ResourceMimeType Property
Gets or sets the MIME type of the resource.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string MimeType { get; set; }
Public Overridable Property MimeType As String
    Get
    Set
public:
virtual property String^ MimeType {
    String^ get ();
    void set (String^ value);
}
abstract MimeType : string with get, set
override MimeType : string with get, set

Property Value

Type: String
The MIME type of the resource.
See Also

Reference

Resource Class
Sitecore.Commerce.Entities.Products Namespace


Resource.Name Property

ResourceName Property
Gets or sets the name of the resource.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The Resource name.
See Also

Reference

Resource Class
Sitecore.Commerce.Entities.Products Namespace


Resource.ResourceType Property

ResourceResourceType Property
Gets or sets the type of the resource.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string ResourceType { get; set; }
Public Overridable Property ResourceType As String
    Get
    Set
public:
virtual property String^ ResourceType {
    String^ get ();
    void set (String^ value);
}
abstract ResourceType : string with get, set
override ResourceType : string with get, set

Property Value

Type: String
The type of the resource.
See Also

Reference

Resource Class
Sitecore.Commerce.Entities.Products Namespace


Specification Class

Specification Class
Represents the product specifications and its associated data. The ProductSpecification class implements the ProductEntity class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.EntitiesMappedEntity
Sitecore.Commerce.Entities.ProductsProductEntity
Sitecore.Commerce.Entities.ProductsSpecification

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Specification : ProductEntity
<SerializableAttribute>
Public Class Specification
    Inherits ProductEntity
[SerializableAttribute]
public ref class Specification : public ProductEntity
[<SerializableAttribute>]
type Specification =
    class
        inherit ProductEntity
    end

The Specification type exposes the following members.

Constructors
 | Name | Description
Public method | Specification | Initializes a new instance of the Specification class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Group | Gets or sets the group that the product specification belongs to.
Public property | Key | Gets or sets the key that defines the value of the specification.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | Value | Gets or sets the value of the specification.
Top
See Also

Reference

Sitecore.Commerce.Entities.Products Namespace


Specification Constructor

Specification Constructor
Initializes a new instance of the Specification class

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Specification()
Public Sub New
public:
Specification()
new : unit -> Specification
See Also

Reference

Specification Class
Sitecore.Commerce.Entities.Products Namespace


Specification Methods

Specification Methods

The Specification type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Specification Class
Sitecore.Commerce.Entities.Products Namespace


Specification Properties

Specification Properties

The Specification type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets or sets the time stamp that indicates the creation date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | ExternalId | Gets or sets the external ID. The external ID is a unique identifier for the user in the external commerce system. You can use the API of the external commerce system to get a reference to the user. The external ID is not assigned to any value until an account has been created. (Inherited from MappedEntity.)
Public property | Group | Gets or sets the group that the product specification belongs to.
Public property | Key | Gets or sets the key that defines the value of the specification.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | SitecoreItemId | Gets or sets the ID of Sitecore item. (Inherited from ProductEntity.)
Public property | Updated | Gets or sets the time stamp that indicates the update date and time of the product entity. You can use it to synchronize the product's data between Sitecore and the external commerce system. (Inherited from ProductEntity.)
Public property | Value | Gets or sets the value of the specification.
Top
See Also

Reference

Specification Class
Sitecore.Commerce.Entities.Products Namespace


Specification.Group Property

SpecificationGroup Property
Gets or sets the group that the product specification belongs to.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Group { get; set; }
Public Overridable Property Group As String
    Get
    Set
public:
virtual property String^ Group {
    String^ get ();
    void set (String^ value);
}
abstract Group : string with get, set
override Group : string with get, set

Property Value

Type: String
The product specification group.
See Also

Reference

Specification Class
Sitecore.Commerce.Entities.Products Namespace


Specification.Key Property

SpecificationKey Property
Gets or sets the key that defines the value of the specification.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Key { get; set; }
Public Overridable Property Key As String
    Get
    Set
public:
virtual property String^ Key {
    String^ get ();
    void set (String^ value);
}
abstract Key : string with get, set
override Key : string with get, set

Property Value

Type: String
The specification key.
See Also

Reference

Specification Class
Sitecore.Commerce.Entities.Products Namespace


Specification.Value Property

SpecificationValue Property
Gets or sets the value of the specification.

Namespace: Sitecore.Commerce.Entities.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string Value { get; set; }
Public Overridable Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
The value.
See Also

Reference

Specification Class
Sitecore.Commerce.Entities.Products Namespace


Sitecore.Commerce.Install Namespace

Sitecore.Commerce.Install Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Install"]

Classes
 | Class | Description
Public class | PostSteps | Defines the post steps performed after package installation.


PostSteps Class

PostSteps Class
Defines the post steps performed after package installation.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.InstallPostSteps

Namespace: Sitecore.Commerce.Install
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class PostSteps : IPostStep
Public Class PostSteps
    Implements IPostStep
public ref class PostSteps : IPostStep
type PostSteps =
    class
        interface IPostStep
    end

The PostSteps type exposes the following members.

Constructors
 | Name | Description
Public method | PostSteps | Initializes a new instance of the PostSteps class
Top
Methods
 | Name | Description
Protected method | DeployPageEvent | Deploys the page event.
Protected method | DeployPageEvents | Deploys the page events.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Runs the specified output.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateDomainsConfig | Updates the domain config file.
Top
See Also

Reference

Sitecore.Commerce.Install Namespace


PostSteps Constructor

PostSteps Constructor
Initializes a new instance of the PostSteps class

Namespace: Sitecore.Commerce.Install
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PostSteps()
Public Sub New
public:
PostSteps()
new : unit -> PostSteps
See Also

Reference

PostSteps Class
Sitecore.Commerce.Install Namespace


PostSteps Methods

PostSteps Methods

The PostSteps type exposes the following members.

Methods
 | Name | Description
Protected method | DeployPageEvent | Deploys the page event.
Protected method | DeployPageEvents | Deploys the page events.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Runs the specified output.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateDomainsConfig | Updates the domain config file.
Top
See Also

Reference

PostSteps Class
Sitecore.Commerce.Install Namespace


PostSteps.DeployPageEvent Method

PostStepsDeployPageEvent Method
Deploys the page event.

Namespace: Sitecore.Commerce.Install
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void DeployPageEvent(
    Item pageEventItem
)
Protected Overridable Sub DeployPageEvent (
    pageEventItem As Item
)
protected:
virtual void DeployPageEvent(
    Item^ pageEventItem
)
abstract DeployPageEvent :
        pageEventItem : Item -> unit
override DeployPageEvent :
        pageEventItem : Item -> unit

Parameters

pageEventItem
Type: Item
The page event item.
See Also

Reference

PostSteps Class
Sitecore.Commerce.Install Namespace


PostSteps.DeployPageEvents Method

PostStepsDeployPageEvents Method
Deploys the page events.

Namespace: Sitecore.Commerce.Install
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void DeployPageEvents()
Protected Overridable Sub DeployPageEvents
protected:
virtual void DeployPageEvents()
abstract DeployPageEvents : unit -> unit
override DeployPageEvents : unit -> unit
See Also

Reference

PostSteps Class
Sitecore.Commerce.Install Namespace


PostSteps.Run Method

PostStepsRun Method
Runs the specified output.

Namespace: Sitecore.Commerce.Install
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public void Run(
    ITaskOutput output,
    NameValueCollection metaData
)
Public Sub Run (
    output As ITaskOutput,
    metaData As NameValueCollection
)
public:
virtual void Run(
    ITaskOutput^ output,
    NameValueCollection^ metaData
) sealed
abstract Run :
        output : ITaskOutput *
        metaData : NameValueCollection -> unit
override Run :
        output : ITaskOutput *
        metaData : NameValueCollection -> unit

Parameters

output
Type: ITaskOutput
The output.
metaData
Type: System.Collections.SpecializedNameValueCollection
The meta data.

Implements

IPostStep.Run(ITaskOutput, NameValueCollection)
See Also

Reference

PostSteps Class
Sitecore.Commerce.Install Namespace


PostSteps.UpdateDomainsConfig Method

PostStepsUpdateDomainsConfig Method
Updates the domain config file.

Namespace: Sitecore.Commerce.Install
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void UpdateDomainsConfig()
Protected Overridable Sub UpdateDomainsConfig
protected:
virtual void UpdateDomainsConfig()
abstract UpdateDomainsConfig : unit -> unit
override UpdateDomainsConfig : unit -> unit
See Also

Reference

PostSteps Class
Sitecore.Commerce.Install Namespace


Sitecore.Commerce.Install.Localization Namespace

Sitecore.Commerce.Install.Localization Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Install.Localization"]

Classes
Class Description
Public class JobManagerWrapper
Defines the wrapper class of the JobManager class. The JobManagerWrapper class uses only one ImportLanguage job. It is used in the package installation post-steps to import localization keys from the XML files to CMS. It is used for unit-testing because the JobManager class contains static methods.
Public class LanguageManagerWrapper
Defines the wrapper of the language manager. You can use this class to:
  • Wrap Sitecore's language manager that is defined by the LanguageManager class.
  • Retrieve a list of the languages in the specified database.
  • Perform the unit-testing because the LanguageManager class contains static methods.
Public class LocalizationInstaller
Defines the class that you can use to import the localization keys from the XML files that are in the installation packages. This class starts a Sitecore job for every language.
Public class LocalizationPostStep
Defines the localization process that is run after the package installation. This process imports localization keys from XML-files, that are in the package, to the Core and Master databases. The following is an example for the format of the list files: "folder" - "temp", "files" - "Core\da-DK.xml;Core\de-DE.xml;Core\ja-JP.xml" In this example:
  • "folder" and "temp" are meta data files.
  • The XML files that are called da-DK, de-DE, and ja-JP are taken from the ~/temp/Core folder.
  • The localization keys are imported from these XML files.


JobManagerWrapper Class

JobManagerWrapper Class
Defines the wrapper class of the JobManager class. The JobManagerWrapper class uses only one ImportLanguage job. It is used in the package installation post-steps to import localization keys from the XML files to CMS. It is used for unit-testing because the JobManager class contains static methods.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Install.LocalizationJobManagerWrapper

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class JobManagerWrapper
Public Class JobManagerWrapper
public ref class JobManagerWrapper
type JobManagerWrapper =  class end

The JobManagerWrapper type exposes the following members.

Constructors
 | Name | Description
Public method | JobManagerWrapper | Initializes a new instance of the JobManagerWrapper class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Starts the specified database name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Install.Localization Namespace


JobManagerWrapper Constructor

JobManagerWrapper Constructor
Initializes a new instance of the JobManagerWrapper class

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public JobManagerWrapper()
Public Sub New
public:
JobManagerWrapper()
new : unit -> JobManagerWrapper
See Also

Reference

JobManagerWrapper Class
Sitecore.Commerce.Install.Localization Namespace


JobManagerWrapper Methods

JobManagerWrapper Methods

The JobManagerWrapper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Starts the specified database name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobManagerWrapper Class
Sitecore.Commerce.Install.Localization Namespace


JobManagerWrapper.Start Method

JobManagerWrapperStart Method
Starts the specified database name.

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual Job Start(
    string databaseName,
    string filePath,
    List<string> languages
)
Public Overridable Function Start (
    databaseName As String,
    filePath As String,
    languages As List(Of String)
) As Job
public:
virtual Job^ Start(
    String^ databaseName,
    String^ filePath,
    List<String^>^ languages
)
abstract Start :
        databaseName : string *
        filePath : string *
        languages : List<string> -> Job
override Start :
        databaseName : string *
        filePath : string *
        languages : List<string> -> Job

Parameters

databaseName
Type: SystemString
The name of the database
filePath
Type: SystemString
The file path
languages
Type: System.Collections.GenericList String
The languages

Return Value

Type: Job
The job
See Also

Reference

JobManagerWrapper Class
Sitecore.Commerce.Install.Localization Namespace


LanguageManagerWrapper Class

LanguageManagerWrapper Class
Defines the wrapper of the language manager. You can use this class to:
  • Wrap Sitecore's language manager that is defined by the LanguageManager class.
  • Retrieve a list of the languages in the specified database.
  • Perform the unit-testing because the LanguageManager class contains static methods.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Install.LocalizationLanguageManagerWrapper

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class LanguageManagerWrapper
Public Class LanguageManagerWrapper
public ref class LanguageManagerWrapper
type LanguageManagerWrapper =  class end

The LanguageManagerWrapper type exposes the following members.

Constructors
 | Name | Description
Public method | LanguageManagerWrapper | Initializes an instance of the LanguageManagerWrapper class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLanguages | Gets a list of the languages.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Languages | Retrieves a list of the languages in the specified database. It is used for unit-testing because the default LanguageManager contains static methods.
Top
See Also

Reference

Sitecore.Commerce.Install.Localization Namespace


LanguageManagerWrapper Constructor

LanguageManagerWrapper Constructor
Initializes an instance of the LanguageManagerWrapper class.

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public LanguageManagerWrapper(
    Database database
)
Public Sub New (
    database As Database
)
public:
LanguageManagerWrapper(
    Database^ database
)
new :
        database : Database -> LanguageManagerWrapper

Parameters

database
Type: Database
The database
See Also

Reference

LanguageManagerWrapper Class
Sitecore.Commerce.Install.Localization Namespace


LanguageManagerWrapper Methods

LanguageManagerWrapper Methods

The LanguageManagerWrapper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLanguages | Gets a list of the languages.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LanguageManagerWrapper Class
Sitecore.Commerce.Install.Localization Namespace


LanguageManagerWrapper.GetLanguages Method

LanguageManagerWrapperGetLanguages Method
Gets a list of the languages.

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<string> GetLanguages()
Public Overridable Function GetLanguages As List(Of String)
public:
virtual List<String^>^ GetLanguages()
abstract GetLanguages : unit -> List<string>
override GetLanguages : unit -> List<string>

Return Value

Type: List String
The languages
See Also

Reference

LanguageManagerWrapper Class
Sitecore.Commerce.Install.Localization Namespace


LanguageManagerWrapper Properties

LanguageManagerWrapper Properties

The LanguageManagerWrapper type exposes the following members.

Properties
 | Name | Description
Public property | Languages | Retrieves a list of the languages in the specified database. It is used for unit-testing because the default LanguageManager contains static methods.
Top
See Also

Reference

LanguageManagerWrapper Class
Sitecore.Commerce.Install.Localization Namespace


LanguageManagerWrapper.Languages Property

LanguageManagerWrapperLanguages Property
Retrieves a list of the languages in the specified database. It is used for unit-testing because the default LanguageManager contains static methods.

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual List<string> Languages { get; set; }
Public Overridable Property Languages As List(Of String)
    Get
    Set
public:
virtual property List<String^>^ Languages {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
abstract Languages : List<string> with get, set
override Languages : List<string> with get, set

Property Value

Type: List String
The languages.
See Also

Reference

LanguageManagerWrapper Class
Sitecore.Commerce.Install.Localization Namespace


LocalizationInstaller Class

LocalizationInstaller Class
Defines the class that you can use to import the localization keys from the XML files that are in the installation packages. This class starts a Sitecore job for every language.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Install.LocalizationLocalizationInstaller

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class LocalizationInstaller
Public Class LocalizationInstaller
public ref class LocalizationInstaller
type LocalizationInstaller =  class end

The LocalizationInstaller type exposes the following members.

Constructors
 | Name | Description
Public method | LocalizationInstaller | Initializes an instance of the LocalizationInstaller class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Install | Imports the localization keys from the XML files to the specified database. This method starts a Sitecore job for each language.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Install.Localization Namespace


LocalizationInstaller Constructor

LocalizationInstaller Constructor
Initializes an instance of the LocalizationInstaller class.

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public LocalizationInstaller(
    LanguageManagerWrapper languageManagerWrapper,
    JobManagerWrapper jobManagerWrapper
)
Public Sub New (
    languageManagerWrapper As LanguageManagerWrapper,
    jobManagerWrapper As JobManagerWrapper
)
public:
LocalizationInstaller(
    LanguageManagerWrapper^ languageManagerWrapper,
    JobManagerWrapper^ jobManagerWrapper
)
new :
        languageManagerWrapper : LanguageManagerWrapper *
        jobManagerWrapper : JobManagerWrapper -> LocalizationInstaller

Parameters

languageManagerWrapper
Type: Sitecore.Commerce.Install.LocalizationLanguageManagerWrapper
The wrapper of the language manager
jobManagerWrapper
Type: Sitecore.Commerce.Install.LocalizationJobManagerWrapper
The wrapper of the job manager
See Also

Reference

LocalizationInstaller Class
Sitecore.Commerce.Install.Localization Namespace


LocalizationInstaller Methods

LocalizationInstaller Methods

The LocalizationInstaller type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Install | Imports the localization keys from the XML files to the specified database. This method starts a Sitecore job for each language.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LocalizationInstaller Class
Sitecore.Commerce.Install.Localization Namespace


LocalizationInstaller.Install Method

LocalizationInstallerInstall Method
Imports the localization keys from the XML files to the specified database. This method starts a Sitecore job for each language.

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Install(
    string databaseName,
    string filePath
)
Public Overridable Sub Install (
    databaseName As String,
    filePath As String
)
public:
virtual void Install(
    String^ databaseName,
    String^ filePath
)
abstract Install :
        databaseName : string *
        filePath : string -> unit
override Install :
        databaseName : string *
        filePath : string -> unit

Parameters

databaseName
Type: SystemString
The name of the database that you import the language to
filePath
Type: SystemString
The path to the file that contains the localization keys
See Also

Reference

LocalizationInstaller Class
Sitecore.Commerce.Install.Localization Namespace


LocalizationPostStep Class

LocalizationPostStep Class
Defines the localization process that is run after the package installation. This process imports localization keys from XML-files, that are in the package, to the Core and Master databases. The following is an example for the format of the list files: "folder" - "temp", "files" - "Core\da-DK.xml;Core\de-DE.xml;Core\ja-JP.xml" In this example:
  • "folder" and "temp" are meta data files.
  • The XML files that are called da-DK, de-DE, and ja-JP are taken from the ~/temp/Core folder.
  • The localization keys are imported from these XML files.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Install.LocalizationLocalizationPostStep

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class LocalizationPostStep : IPostStep
Public Class LocalizationPostStep
    Implements IPostStep
public ref class LocalizationPostStep : IPostStep
type LocalizationPostStep =
    class
        interface IPostStep
    end

The LocalizationPostStep type exposes the following members.

Constructors
 | Name | Description
Public method | LocalizationPostStep | Initializes a new instance of the LocalizationPostStep class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Runs the post step process.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Installer | Gets or sets the localization installer.
Public property | SiteRoot | Gets or sets the site root.
Top
See Also

Reference

Sitecore.Commerce.Install.Localization Namespace


LocalizationPostStep Constructor

LocalizationPostStep Constructor
Initializes a new instance of the LocalizationPostStep class

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public LocalizationPostStep()
Public Sub New
public:
LocalizationPostStep()
new : unit -> LocalizationPostStep
See Also

Reference

LocalizationPostStep Class
Sitecore.Commerce.Install.Localization Namespace


LocalizationPostStep Methods

LocalizationPostStep Methods

The LocalizationPostStep type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Runs the post step process.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LocalizationPostStep Class
Sitecore.Commerce.Install.Localization Namespace


LocalizationPostStep.Run Method

LocalizationPostStepRun Method
Runs the post step process.

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Run(
    ITaskOutput output,
    NameValueCollection metaData
)
Public Overridable Sub Run (
    output As ITaskOutput,
    metaData As NameValueCollection
)
public:
virtual void Run(
    ITaskOutput^ output,
    NameValueCollection^ metaData
)
abstract Run :
        output : ITaskOutput *
        metaData : NameValueCollection -> unit
override Run :
        output : ITaskOutput *
        metaData : NameValueCollection -> unit

Parameters

output
Type: ITaskOutput
The output
metaData
Type: System.Collections.SpecializedNameValueCollection
The meta data

Implements

IPostStep.Run(ITaskOutput, NameValueCollection)
See Also

Reference

LocalizationPostStep Class
Sitecore.Commerce.Install.Localization Namespace


LocalizationPostStep Properties

LocalizationPostStep Properties

The LocalizationPostStep type exposes the following members.

Properties
 | Name | Description
Public property | Installer | Gets or sets the localization installer.
Public property | SiteRoot | Gets or sets the site root.
Top
See Also

Reference

LocalizationPostStep Class
Sitecore.Commerce.Install.Localization Namespace


LocalizationPostStep.Installer Property

LocalizationPostStepInstaller Property
Gets or sets the localization installer.

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual LocalizationInstaller Installer { get; set; }
Public Overridable Property Installer As LocalizationInstaller
    Get
    Set
public:
virtual property LocalizationInstaller^ Installer {
    LocalizationInstaller^ get ();
    void set (LocalizationInstaller^ value);
}
abstract Installer : LocalizationInstaller with get, set
override Installer : LocalizationInstaller with get, set

Property Value

Type: LocalizationInstaller
The installer
See Also

Reference

LocalizationPostStep Class
Sitecore.Commerce.Install.Localization Namespace


LocalizationPostStep.SiteRoot Property

LocalizationPostStepSiteRoot Property
Gets or sets the site root.

Namespace: Sitecore.Commerce.Install.Localization
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string SiteRoot { get; set; }
Public Overridable Property SiteRoot As String
    Get
    Set
public:
virtual property String^ SiteRoot {
    String^ get ();
    void set (String^ value);
}
abstract SiteRoot : string with get, set
override SiteRoot : string with get, set

Property Value

Type: String
The site root.
See Also

Reference

LocalizationPostStep Class
Sitecore.Commerce.Install.Localization Namespace


Sitecore.Commerce.Multishop Namespace

Sitecore.Commerce.Multishop Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Multishop"]

Classes
 | Class | Description
Public class | CommerceContextBase | Defines the class which allows to determine commerce context.
Public class | EaPlanProvider | Is usedto determine the engagement plan by the shop name. This class implements the IEaPlanProvider interface.
Public class | InventoryProductBuilder | Creates an inventory product builder.
Interfaces
 | Interface | Description
Public interface | IEaPlanProvider | Defines the interface which allows its consumers to determine engagement plan by corresponding shop name.
Public interface | IInventoryProductBuilder | Creates an inventory product builder.


CommerceContextBase Class

CommerceContextBase Class
Defines the class which allows to determine commerce context.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.MultishopCommerceContextBase

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class CommerceContextBase
Public MustInherit Class CommerceContextBase
public ref class CommerceContextBase abstract
[<AbstractClassAttribute>]
type CommerceContextBase =  class end

The CommerceContextBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CommerceContextBase | Initializes a new instance of the CommerceContextBase class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | InventoryLocation | Gets the current inventory location.
Public property | ProductId | Gets the product id of the selected product.
Top
See Also

Reference

Sitecore.Commerce.Multishop Namespace


CommerceContextBase Constructor

CommerceContextBase Constructor
Initializes a new instance of the CommerceContextBase class

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected CommerceContextBase()
Protected Sub New
protected:
CommerceContextBase()
new : unit -> CommerceContextBase
See Also

Reference

CommerceContextBase Class
Sitecore.Commerce.Multishop Namespace


CommerceContextBase Methods

CommerceContextBase Methods

The CommerceContextBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommerceContextBase Class
Sitecore.Commerce.Multishop Namespace


CommerceContextBase Properties

CommerceContextBase Properties

The CommerceContextBase type exposes the following members.

Properties
 | Name | Description
Public property | InventoryLocation | Gets the current inventory location.
Public property | ProductId | Gets the product id of the selected product.
Top
See Also

Reference

CommerceContextBase Class
Sitecore.Commerce.Multishop Namespace


CommerceContextBase.InventoryLocation Property

CommerceContextBaseInventoryLocation Property
Gets the current inventory location.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string InventoryLocation { get; }
Public Overridable ReadOnly Property InventoryLocation As String
    Get
public:
virtual property String^ InventoryLocation {
    String^ get ();
}
abstract InventoryLocation : string with get
override InventoryLocation : string with get

Property Value

Type: String
The current inventory location.
See Also

Reference

CommerceContextBase Class
Sitecore.Commerce.Multishop Namespace


CommerceContextBase.ProductId Property

CommerceContextBaseProductId Property
Gets the product id of the selected product.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string ProductId { get; }
Public Overridable ReadOnly Property ProductId As String
    Get
public:
virtual property String^ ProductId {
    String^ get ();
}
abstract ProductId : string with get
override ProductId : string with get

Property Value

Type: String
The product id of the selected product.
See Also

Reference

CommerceContextBase Class
Sitecore.Commerce.Multishop Namespace


EaPlanProvider Class

EaPlanProvider Class
Is usedto determine the engagement plan by the shop name. This class implements the IEaPlanProvider interface.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.MultishopEaPlanProvider

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EaPlanProvider : IEaPlanProvider
Public Class EaPlanProvider
    Implements IEaPlanProvider
public ref class EaPlanProvider : IEaPlanProvider
type EaPlanProvider =
    class
        interface IEaPlanProvider
    end

The EaPlanProvider type exposes the following members.

Constructors
 | Name | Description
Public method | EaPlanProvider | Initializes a new instance of the EaPlanProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEaPlanId(String) | Gets the corresponding engagement plan ID by shop name.
Public method | GetEaPlanId(String, String, String) | Gets the corresponding engagement plan and initial state IDs by shop name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShopNameFromEaPlanName | Gets the name of the shop name from the engagement plan.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Multishop Namespace


EaPlanProvider Constructor

EaPlanProvider Constructor
Initializes a new instance of the EaPlanProvider class

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EaPlanProvider()
Public Sub New
public:
EaPlanProvider()
new : unit -> EaPlanProvider
See Also

Reference

EaPlanProvider Class
Sitecore.Commerce.Multishop Namespace


EaPlanProvider Methods

EaPlanProvider Methods

The EaPlanProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEaPlanId(String) | Gets the corresponding engagement plan ID by shop name.
Public method | GetEaPlanId(String, String, String) | Gets the corresponding engagement plan and initial state IDs by shop name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShopNameFromEaPlanName | Gets the name of the shop name from the engagement plan.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EaPlanProvider Class
Sitecore.Commerce.Multishop Namespace


EaPlanProvider.GetEaPlanId Method

EaPlanProviderGetEaPlanId Method
Overload List
 | Name | Description
Public method | GetEaPlanId(String) | Gets the corresponding engagement plan ID by shop name.
Public method | GetEaPlanId(String, String, String) | Gets the corresponding engagement plan and initial state IDs by shop name.
Top
See Also

Reference

EaPlanProvider Class
Sitecore.Commerce.Multishop Namespace


EaPlanProvider.GetEaPlanId Method (String)

EaPlanProviderGetEaPlanId Method (String)
Gets the corresponding engagement plan ID by shop name.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Tuple<ID, ID> GetEaPlanId(
    string shopName
)
Public Function GetEaPlanId (
    shopName As String
) As Tuple(Of ID, ID)
public:
virtual Tuple<ID^, ID^>^ GetEaPlanId(
    String^ shopName
) sealed
abstract GetEaPlanId :
        shopName : string -> Tuple<ID, ID>
override GetEaPlanId :
        shopName : string -> Tuple<ID, ID>

Parameters

shopName
Type: SystemString
Name of the shop.

Return Value

Type: Tuple ID, ID
ID of engagement plan for the specified shop name.

Implements

IEaPlanProviderGetEaPlanId(String)
See Also

Reference

EaPlanProvider Class
GetEaPlanId Overload
Sitecore.Commerce.Multishop Namespace


EaPlanProvider.GetEaPlanId Method (String, String, String)

EaPlanProviderGetEaPlanId Method (String, String, String)
Gets the corresponding engagement plan and initial state IDs by shop name.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Tuple<ID, ID> GetEaPlanId(
    string shopName,
    string engagementPlanName,
    string stateName
)
Public Function GetEaPlanId (
    shopName As String,
    engagementPlanName As String,
    stateName As String
) As Tuple(Of ID, ID)
public:
virtual Tuple<ID^, ID^>^ GetEaPlanId(
    String^ shopName,
    String^ engagementPlanName,
    String^ stateName
) sealed
abstract GetEaPlanId :
        shopName : string *
        engagementPlanName : string *
        stateName : string -> Tuple<ID, ID>
override GetEaPlanId :
        shopName : string *
        engagementPlanName : string *
        stateName : string -> Tuple<ID, ID>

Parameters

shopName
Type: SystemString
Name of the shop.
engagementPlanName
Type: SystemString
Name of the plan.
stateName
Type: SystemString
Name of the plan's initial state.

Return Value

Type: Tuple ID, ID
ID of engagement plan and initial state respectively for the specified shop name.

Implements

IEaPlanProviderGetEaPlanId(String, String, String)
See Also

Reference

EaPlanProvider Class
GetEaPlanId Overload
Sitecore.Commerce.Multishop Namespace


EaPlanProvider.GetShopNameFromEaPlanName Method

EaPlanProviderGetShopNameFromEaPlanName Method
Gets the name of the shop name from the engagement plan.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string GetShopNameFromEaPlanName(
    string engagementName
)
Public Function GetShopNameFromEaPlanName (
    engagementName As String
) As String
public:
virtual String^ GetShopNameFromEaPlanName(
    String^ engagementName
) sealed
abstract GetShopNameFromEaPlanName :
        engagementName : string -> string
override GetShopNameFromEaPlanName :
        engagementName : string -> string

Parameters

engagementName
Type: SystemString
Name of the engagement plan.

Return Value

Type: String

[Missing <returns> documentation for "M:Sitecore.Commerce.Multishop.EaPlanProvider.GetShopNameFromEaPlanName(System.String)"]

Implements

IEaPlanProviderGetShopNameFromEaPlanName(String)
See Also

Reference

EaPlanProvider Class
Sitecore.Commerce.Multishop Namespace


IEaPlanProvider Interface

IEaPlanProvider Interface
Defines the interface which allows its consumers to determine engagement plan by corresponding shop name.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public interface IEaPlanProvider
Public Interface IEaPlanProvider
public interface class IEaPlanProvider
type IEaPlanProvider =  interface end

The IEaPlanProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetEaPlanId(String) | Gets the corresponding engagement plan and initial state IDs by shop name.
Public method | GetEaPlanId(String, String, String) | Gets the corresponding engagement plan and initial state IDs by shop name and engagement plan name.
Public method | GetShopNameFromEaPlanName | Gets the name of the shop corresponding to engagement plan with the given name.
Top
See Also

Reference

Sitecore.Commerce.Multishop Namespace


IEaPlanProvider Methods

IEaPlanProvider Methods

The IEaPlanProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetEaPlanId(String) | Gets the corresponding engagement plan and initial state IDs by shop name.
Public method | GetEaPlanId(String, String, String) | Gets the corresponding engagement plan and initial state IDs by shop name and engagement plan name.
Public method | GetShopNameFromEaPlanName | Gets the name of the shop corresponding to engagement plan with the given name.
Top
See Also

Reference

IEaPlanProvider Interface
Sitecore.Commerce.Multishop Namespace


IEaPlanProvider.GetEaPlanId Method

IEaPlanProviderGetEaPlanId Method
Overload List
 | Name | Description
Public method | GetEaPlanId(String) | Gets the corresponding engagement plan and initial state IDs by shop name.
Public method | GetEaPlanId(String, String, String) | Gets the corresponding engagement plan and initial state IDs by shop name and engagement plan name.
Top
See Also

Reference

IEaPlanProvider Interface
Sitecore.Commerce.Multishop Namespace


IEaPlanProvider.GetEaPlanId Method (String)

IEaPlanProviderGetEaPlanId Method (String)
Gets the corresponding engagement plan and initial state IDs by shop name.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
Tuple<ID, ID> GetEaPlanId(
    string shopName
)
Function GetEaPlanId (
    shopName As String
) As Tuple(Of ID, ID)
Tuple<ID^, ID^>^ GetEaPlanId(
    String^ shopName
)
abstract GetEaPlanId :
        shopName : string -> Tuple<ID, ID>

Parameters

shopName
Type: SystemString
Name of the shop.

Return Value

Type: Tuple ID, ID
ID of engagement plan and initial state respectively for the specified shop name.
See Also

Reference

IEaPlanProvider Interface
GetEaPlanId Overload
Sitecore.Commerce.Multishop Namespace


IEaPlanProvider.GetEaPlanId Method (String, String, String)

IEaPlanProviderGetEaPlanId Method (String, String, String)
Gets the corresponding engagement plan and initial state IDs by shop name and engagement plan name.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
Tuple<ID, ID> GetEaPlanId(
    string shopName,
    string engagementPlanName,
    string stateName
)
Function GetEaPlanId (
    shopName As String,
    engagementPlanName As String,
    stateName As String
) As Tuple(Of ID, ID)
Tuple<ID^, ID^>^ GetEaPlanId(
    String^ shopName,
    String^ engagementPlanName,
    String^ stateName
)
abstract GetEaPlanId :
        shopName : string *
        engagementPlanName : string *
        stateName : string -> Tuple<ID, ID>

Parameters

shopName
Type: SystemString
Name of the shop.
engagementPlanName
Type: SystemString
Name of the plan.
stateName
Type: SystemString
Name of the plan's initial state.

Return Value

Type: Tuple ID, ID
ID of engagement plan and initial state respectively for the specified shop name.
See Also

Reference

IEaPlanProvider Interface
GetEaPlanId Overload
Sitecore.Commerce.Multishop Namespace


IEaPlanProvider.GetShopNameFromEaPlanName Method

IEaPlanProviderGetShopNameFromEaPlanName Method
Gets the name of the shop corresponding to engagement plan with the given name.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
string GetShopNameFromEaPlanName(
    string engagementName
)
Function GetShopNameFromEaPlanName (
    engagementName As String
) As String
String^ GetShopNameFromEaPlanName(
    String^ engagementName
)
abstract GetShopNameFromEaPlanName :
        engagementName : string -> string

Parameters

engagementName
Type: SystemString
Name of the engagement plan.

Return Value

Type: String
Name of the shop corresponding to engagement plan with the given name.
See Also

Reference

IEaPlanProvider Interface
Sitecore.Commerce.Multishop Namespace


IInventoryProductBuilder Interface

IInventoryProductBuilder Interface
Creates an inventory product builder.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public interface IInventoryProductBuilder
Public Interface IInventoryProductBuilder
public interface class IInventoryProductBuilder
type IInventoryProductBuilder =  interface end

The IInventoryProductBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AreProductsEqual | Compares two InventoryProduct objects for equality.
Public method | CreateInventoryProduct | Creates an inventory product
Public method | GetProductHashCode | Gets the hash code for a InventoryProduct.
Public method | ProductToString | Converts a InventoryProduct to a string.
Top
Properties
 | Name | Description
Public property | CommerceContext | Gets or sets the Commerce context
Public property | EntityFactory | Gets or sets the entity factory
Top
See Also

Reference

Sitecore.Commerce.Multishop Namespace


IInventoryProductBuilder Methods

IInventoryProductBuilder Methods

The IInventoryProductBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AreProductsEqual | Compares two InventoryProduct objects for equality.
Public method | CreateInventoryProduct | Creates an inventory product
Public method | GetProductHashCode | Gets the hash code for a InventoryProduct.
Public method | ProductToString | Converts a InventoryProduct to a string.
Top
See Also

Reference

IInventoryProductBuilder Interface
Sitecore.Commerce.Multishop Namespace


IInventoryProductBuilder.AreProductsEqual Method

IInventoryProductBuilderAreProductsEqual Method
Compares two InventoryProduct objects for equality.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
bool AreProductsEqual(
    InventoryProduct x,
    InventoryProduct y
)
Function AreProductsEqual (
    x As InventoryProduct,
    y As InventoryProduct
) As Boolean
bool AreProductsEqual(
    InventoryProduct^ x,
    InventoryProduct^ y
)
abstract AreProductsEqual :
        x : InventoryProduct *
        y : InventoryProduct -> bool

Parameters

x
Type: Sitecore.Commerce.Entities.InventoryInventoryProduct
The first object.
y
Type: Sitecore.Commerce.Entities.InventoryInventoryProduct
The second object.

Return Value

Type: Boolean
True if the objects are equal, otherwise false.
See Also

Reference

IInventoryProductBuilder Interface
Sitecore.Commerce.Multishop Namespace


IInventoryProductBuilder.CreateInventoryProduct Method

IInventoryProductBuilderCreateInventoryProduct Method
Creates an inventory product

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
InventoryProduct CreateInventoryProduct(
    string productId
)
Function CreateInventoryProduct (
    productId As String
) As InventoryProduct
InventoryProduct^ CreateInventoryProduct(
    String^ productId
)
abstract CreateInventoryProduct :
        productId : string -> InventoryProduct

Parameters

productId
Type: SystemString
The product id

Return Value

Type: InventoryProduct
An inventory product
See Also

Reference

IInventoryProductBuilder Interface
Sitecore.Commerce.Multishop Namespace


IInventoryProductBuilder.GetProductHashCode Method

IInventoryProductBuilderGetProductHashCode Method
Gets the hash code for a InventoryProduct.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
int GetProductHashCode(
    InventoryProduct obj
)
Function GetProductHashCode (
    obj As InventoryProduct
) As Integer
int GetProductHashCode(
    InventoryProduct^ obj
)
abstract GetProductHashCode :
        obj : InventoryProduct -> int

Parameters

obj
Type: Sitecore.Commerce.Entities.InventoryInventoryProduct
The object to hash.

Return Value

Type: Int32
The hash code for the object.
See Also

Reference

IInventoryProductBuilder Interface
Sitecore.Commerce.Multishop Namespace


IInventoryProductBuilder.ProductToString Method

IInventoryProductBuilderProductToString Method
Converts a InventoryProduct to a string.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
string ProductToString(
    InventoryProduct product
)
Function ProductToString (
    product As InventoryProduct
) As String
String^ ProductToString(
    InventoryProduct^ product
)
abstract ProductToString :
        product : InventoryProduct -> string

Parameters

product
Type: Sitecore.Commerce.Entities.InventoryInventoryProduct
The object to convert.

Return Value

Type: String
The string version of the object
See Also

Reference

IInventoryProductBuilder Interface
Sitecore.Commerce.Multishop Namespace


IInventoryProductBuilder Properties

IInventoryProductBuilder Properties

The IInventoryProductBuilder type exposes the following members.

Properties
 | Name | Description
Public property | CommerceContext | Gets or sets the Commerce context
Public property | EntityFactory | Gets or sets the entity factory
Top
See Also

Reference

IInventoryProductBuilder Interface
Sitecore.Commerce.Multishop Namespace


IInventoryProductBuilder.CommerceContext Property

IInventoryProductBuilderCommerceContext Property
Gets or sets the Commerce context

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
CommerceContextBase CommerceContext { get; set; }
Property CommerceContext As CommerceContextBase
    Get
    Set
property CommerceContextBase^ CommerceContext {
    CommerceContextBase^ get ();
    void set (CommerceContextBase^ value);
}
abstract CommerceContext : CommerceContextBase with get, set

Property Value

Type: CommerceContextBase
See Also

Reference

IInventoryProductBuilder Interface
Sitecore.Commerce.Multishop Namespace


IInventoryProductBuilder.EntityFactory Property

IInventoryProductBuilderEntityFactory Property
Gets or sets the entity factory

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
IEntityFactory EntityFactory { get; set; }
Property EntityFactory As IEntityFactory
    Get
    Set
property IEntityFactory^ EntityFactory {
    IEntityFactory^ get ();
    void set (IEntityFactory^ value);
}
abstract EntityFactory : IEntityFactory with get, set

Property Value

Type: IEntityFactory
See Also

Reference

IInventoryProductBuilder Interface
Sitecore.Commerce.Multishop Namespace


InventoryProductBuilder Class

InventoryProductBuilder Class
Creates an inventory product builder.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.MultishopInventoryProductBuilder

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class InventoryProductBuilder : IInventoryProductBuilder
Public Class InventoryProductBuilder
    Implements IInventoryProductBuilder
public ref class InventoryProductBuilder : IInventoryProductBuilder
type InventoryProductBuilder =
    class
        interface IInventoryProductBuilder
    end

The InventoryProductBuilder type exposes the following members.

Constructors
 | Name | Description
Public method | InventoryProductBuilder | Initializes a new instance of the InventoryProductBuilder class.
Top
Methods
 | Name | Description
Public method | AreProductsEqual | Compares two InventoryProduct objects for equality.
Public method | CreateInventoryProduct | Creates an inventory product
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProductHashCode | Gets the hash code for a InventoryProduct.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProductToString | Converts a InventoryProduct to a string.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceContext | Gets or sets the Commerce context
Public property | EntityFactory | Gets or sets the entity factory
Top
See Also

Reference

Sitecore.Commerce.Multishop Namespace


InventoryProductBuilder Constructor

InventoryProductBuilder Constructor
Initializes a new instance of the InventoryProductBuilder class.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public InventoryProductBuilder()
Public Sub New
public:
InventoryProductBuilder()
new : unit -> InventoryProductBuilder
See Also

Reference

InventoryProductBuilder Class
Sitecore.Commerce.Multishop Namespace


InventoryProductBuilder Methods

InventoryProductBuilder Methods

The InventoryProductBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AreProductsEqual | Compares two InventoryProduct objects for equality.
Public method | CreateInventoryProduct | Creates an inventory product
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProductHashCode | Gets the hash code for a InventoryProduct.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProductToString | Converts a InventoryProduct to a string.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InventoryProductBuilder Class
Sitecore.Commerce.Multishop Namespace


InventoryProductBuilder.AreProductsEqual Method

InventoryProductBuilderAreProductsEqual Method
Compares two InventoryProduct objects for equality.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual bool AreProductsEqual(
    InventoryProduct x,
    InventoryProduct y
)
Public Overridable Function AreProductsEqual (
    x As InventoryProduct,
    y As InventoryProduct
) As Boolean
public:
virtual bool AreProductsEqual(
    InventoryProduct^ x,
    InventoryProduct^ y
)
abstract AreProductsEqual :
        x : InventoryProduct *
        y : InventoryProduct -> bool
override AreProductsEqual :
        x : InventoryProduct *
        y : InventoryProduct -> bool

Parameters

x
Type: Sitecore.Commerce.Entities.InventoryInventoryProduct
The first object.
y
Type: Sitecore.Commerce.Entities.InventoryInventoryProduct
The second object.

Return Value

Type: Boolean
True if the objects are equal, otherwise false.

Implements

IInventoryProductBuilderAreProductsEqual(InventoryProduct, InventoryProduct)
See Also

Reference

InventoryProductBuilder Class
Sitecore.Commerce.Multishop Namespace


InventoryProductBuilder.CreateInventoryProduct Method

InventoryProductBuilderCreateInventoryProduct Method
Creates an inventory product

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual InventoryProduct CreateInventoryProduct(
    string productId
)
Public Overridable Function CreateInventoryProduct (
    productId As String
) As InventoryProduct
public:
virtual InventoryProduct^ CreateInventoryProduct(
    String^ productId
)
abstract CreateInventoryProduct :
        productId : string -> InventoryProduct
override CreateInventoryProduct :
        productId : string -> InventoryProduct

Parameters

productId
Type: SystemString
The product id

Return Value

Type: InventoryProduct
An inventory product

Implements

IInventoryProductBuilderCreateInventoryProduct(String)
See Also

Reference

InventoryProductBuilder Class
Sitecore.Commerce.Multishop Namespace


InventoryProductBuilder.GetProductHashCode Method

InventoryProductBuilderGetProductHashCode Method
Gets the hash code for a InventoryProduct.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual int GetProductHashCode(
    InventoryProduct obj
)
Public Overridable Function GetProductHashCode (
    obj As InventoryProduct
) As Integer
public:
virtual int GetProductHashCode(
    InventoryProduct^ obj
)
abstract GetProductHashCode :
        obj : InventoryProduct -> int
override GetProductHashCode :
        obj : InventoryProduct -> int

Parameters

obj
Type: Sitecore.Commerce.Entities.InventoryInventoryProduct
The object to hash.

Return Value

Type: Int32
The hash code for the object.

Implements

IInventoryProductBuilderGetProductHashCode(InventoryProduct)
See Also

Reference

InventoryProductBuilder Class
Sitecore.Commerce.Multishop Namespace


InventoryProductBuilder.ProductToString Method

InventoryProductBuilderProductToString Method
Converts a InventoryProduct to a string.

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string ProductToString(
    InventoryProduct product
)
Public Overridable Function ProductToString (
    product As InventoryProduct
) As String
public:
virtual String^ ProductToString(
    InventoryProduct^ product
)
abstract ProductToString :
        product : InventoryProduct -> string
override ProductToString :
        product : InventoryProduct -> string

Parameters

product
Type: Sitecore.Commerce.Entities.InventoryInventoryProduct
The object to convert.

Return Value

Type: String
The string version of the object

Implements

IInventoryProductBuilderProductToString(InventoryProduct)
See Also

Reference

InventoryProductBuilder Class
Sitecore.Commerce.Multishop Namespace


InventoryProductBuilder Properties

InventoryProductBuilder Properties

The InventoryProductBuilder type exposes the following members.

Properties
 | Name | Description
Public property | CommerceContext | Gets or sets the Commerce context
Public property | EntityFactory | Gets or sets the entity factory
Top
See Also

Reference

InventoryProductBuilder Class
Sitecore.Commerce.Multishop Namespace


InventoryProductBuilder.CommerceContext Property

InventoryProductBuilderCommerceContext Property
Gets or sets the Commerce context

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CommerceContextBase CommerceContext { get; set; }
Public Property CommerceContext As CommerceContextBase
    Get
    Set
public:
virtual property CommerceContextBase^ CommerceContext {
    CommerceContextBase^ get () sealed;
    void set (CommerceContextBase^ value) sealed;
}
abstract CommerceContext : CommerceContextBase with get, set
override CommerceContext : CommerceContextBase with get, set

Property Value

Type: CommerceContextBase

Implements

IInventoryProductBuilderCommerceContext
See Also

Reference

InventoryProductBuilder Class
Sitecore.Commerce.Multishop Namespace


InventoryProductBuilder.EntityFactory Property

InventoryProductBuilderEntityFactory Property
Gets or sets the entity factory

Namespace: Sitecore.Commerce.Multishop
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEntityFactory EntityFactory { get; set; }
Public Property EntityFactory As IEntityFactory
    Get
    Set
public:
virtual property IEntityFactory^ EntityFactory {
    IEntityFactory^ get () sealed;
    void set (IEntityFactory^ value) sealed;
}
abstract EntityFactory : IEntityFactory with get, set
override EntityFactory : IEntityFactory with get, set

Property Value

Type: IEntityFactory

Implements

IInventoryProductBuilderEntityFactory
See Also

Reference

InventoryProductBuilder Class
Sitecore.Commerce.Multishop Namespace


Sitecore.Commerce.Pipelines Namespace

Sitecore.Commerce.Pipelines Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines"]

Classes
 | Class | Description
Public class | PipelineName | Contains the Commerce pipeline names.
Public class | PipelineProcessorTArgs | Defines the base pipeline processor class.
Public class | PipelineService | Allows to get and set a pipeline service which allows to mock the service in unit testing.
Public class | RunPipelineProcessorTArgs | The Run Pipeline processor base class.
Public class | ServicePipelineArgs | The service pipeline args.


PipelineName Class

PipelineName Class
Contains the Commerce pipeline names.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineName

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class PipelineName
Public NotInheritable Class PipelineName
public ref class PipelineName abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PipelineName =  class end

The PipelineName type exposes the following members.

Fields
Name | Description
AddCartLines | The "addCartLines" pipeline name.
AddCustomerParties | The add customer parties
AddCustomers | The "addCustomers" pipeline name.
AddPartiesToCart | The "addParties" pipeline name
AddPartiesToCustomer | The add parties
AddPaymentInfo | The "addPaymentInfo" pipeline name
AddShippingInfo | The "AddShippingInfo" pipeline name.
AddUsers | The "addUsers" pipeline name.
CreateCart | The "createCart" pipeline name.
CreateCustomer | The "createCustomer" pipeline name.
CreateOrResumeCart | The "createOrResumeCart" pipeline name.
CreateUser | The "createUser" pipeline name.
DeleteCart | The "deleteCart" pipeline name.
DeleteCustomer | The "deleteCustomer" pipeline name.
DeleteUser | The "deleteUser" pipeline name.
DisableCustomer | The "disableCustomer" pipeline name.
DisableUser | The "disableUser" pipeline name.
EnableCustomer | The "enableCustomer" pipeline name.
EnableUser | The "enableUser" pipeline name.
GetBackInStockInformation | The "getBackInStockInformation" pipeline name.
GetBackOrderableInformation | The "getBackOrderableInformation" pipeline name.
GetCarts | The "getCarts" pipeline name.
GetCartTotal | The "getСartTotal" pipeline name.
GetCustomer | The "getCustomer" pipeline name.
GetCustomers | The "getCustomers" pipeline name.
GetExternalCommerceSystemProductList | The "getExternalCommerceSystemProductList" pipeline name.
GetParties | The get parties
GetPreOrderableInformation | The "getPreOrderableInformation" pipeline name.
GetProductBulkPrices | The get product bulk prices.
GetProductPrices | The get product prices.
GetSitecoreProductList | The "getSitecoreProductList" pipeline name.
GetStockInformation | The "getStockInformation" pipeline name.
GetUser | The "getUser" pipeline name.
GetUsers | The "getUsers" pipeline name.
GetVisitorOrder | The "getVisitorOrder" pipeline name.
GetVisitorOrders | The "getVisitorOrders" pipeline name.
LoadCart | The "loadCart" pipeline name.
LockCart | The "lockCart" pipeline name.
MergeCart | The "MergeCarts" pipeline name.
ProductsAreBackInStock | The "productsAreBackInStock" pipeline name.
RemoveCartLines | The "removeCartLines" pipeline name
RemoveCustomerParties | The remove customer parties
RemoveCustomers | The "removeCustomers" pipeline name.
RemoveParties | The remove parties
RemovePartiesFromCart | The "deleteParties" pipeline name.
RemovePaymentInfo | The "RemovePaymentInfo" pipeline name.
RemoveShippingInfo | The "RemoveShippingInfo" pipeline name.
RemoveUsers | The "removeUsers" pipeline name.
RemoveVisitorFromStockNotification | The "removeVisitorFromStockNotification" pipeline name.
ResumeCart | The "resumeCart" pipeline name.
SaveCart | The "saveCart" pipeline name.
StockStatusForIndexing | The "stockStatusForIndexing" pipeline name.
SubmitVisitorOrder | The "submitVisitorOrder" pipeline name.
SynchronizeArtifacts | The "synchronizeArtifacts" pipeline name.
SynchronizeClassifications | The "synchronizeClassifications" pipeline name.
SynchronizeClassificationSpecifications | The "synchronizeClassificationsSpecifications" pipeline name.
SynchronizeDivisions | The "synchronizeDivisions" pipeline name.
SynchronizeGlobalSpecifications | The "synchronizeGlobalSpecifications" pipeline name.
SynchronizeManufacturers | The "synchronizeManufacturers" pipeline name.
SynchronizeProduct | The "synchronizeProduct" pipeline name.
SynchronizeProductClassifications | The "synchronizeProductClassifications" pipeline name.
SynchronizeProductClassificationsSpecifications | The "synchronizeProductClassificationsSpecifications" pipeline name.
SynchronizeProductDivisions | The "synchronizeProductDivisions" pipeline name.
SynchronizeProductEntity | The "synchronizeProductEntity" pipeline name.
SynchronizeProductGlobalSpecifications | The "synchronizeProductGlobalSpecifications" pipeline name.
SynchronizeProductList | The "synchronizeProductList" pipeline name.
SynchronizeProductManufacturers | The "synchronizeProductManufacturers" pipeline name.
SynchronizeProductRelations | The "synchronizeProductRelations" pipeline name.
SynchronizeProductResources | The "synchronizeProductResources" pipeline name.
SynchronizeProducts | The "synchronizeProducts" pipeline name.
SynchronizeProductSpecifications | The "synchronizeProductSpecifications" pipeline name.
SynchronizeProductTypes | The "synchronizeProductTypes" pipeline name.
SynchronizeProductTypeSpecifications | The "synchronizeProductTypeSpecifications" pipeline name.
SynchronizeResources | The "synchronizeResources" pipeline name.
SynchronizeSpecifications | The "synchronizeSpecifications" pipeline name.
SynchronizeTypeDefaultValues | The synchronize type default values.
SynchronizeTypes | The "synchronizeTypes" pipeline name.
SynchronizeTypeSpecifications | The "synchronizeTypeSpecifications" pipeline name.
TriggerVisitedProductStockStatus | The "visitedProductStockStatus" pipeline name.
UnlockCart | The "unlockCart" pipeline name.
UpdateCart | The "updateCart" pipeline name.
UpdateCartLines | The "updateCartLines" pipeline name.
UpdateCustomer | The "updateCustomer" pipeline name.
UpdateCustomerParties | The update customer parties
UpdateParties | The update parties
UpdatePartiesInCart | The "updateParties" pipeline name.
UpdatePassword | The update user password
UpdateUser | The "updateUser" pipeline name.
VisitorOrderCancel | The "visitorOrderCancel" pipeline name.
VisitorSignUpForStockNotification | The "visitorSignUpForStockNotification" pipeline name.
Top
See Also

Reference

Sitecore.Commerce.Pipelines Namespace


PipelineName Fields

PipelineName Fields

The PipelineName type exposes the following members.

Fields
Name | Description
AddCartLines | The "addCartLines" pipeline name.
AddCustomerParties | The add customer parties
AddCustomers | The "addCustomers" pipeline name.
AddPartiesToCart | The "addParties" pipeline name
AddPartiesToCustomer | The add parties
AddPaymentInfo | The "addPaymentInfo" pipeline name
AddShippingInfo | The "AddShippingInfo" pipeline name.
AddUsers | The "addUsers" pipeline name.
CreateCart | The "createCart" pipeline name.
CreateCustomer | The "createCustomer" pipeline name.
CreateOrResumeCart | The "createOrResumeCart" pipeline name.
CreateUser | The "createUser" pipeline name.
DeleteCart | The "deleteCart" pipeline name.
DeleteCustomer | The "deleteCustomer" pipeline name.
DeleteUser | The "deleteUser" pipeline name.
DisableCustomer | The "disableCustomer" pipeline name.
DisableUser | The "disableUser" pipeline name.
EnableCustomer | The "enableCustomer" pipeline name.
EnableUser | The "enableUser" pipeline name.
GetBackInStockInformation | The "getBackInStockInformation" pipeline name.
GetBackOrderableInformation | The "getBackOrderableInformation" pipeline name.
GetCarts | The "getCarts" pipeline name.
GetCartTotal | The "getСartTotal" pipeline name.
GetCustomer | The "getCustomer" pipeline name.
GetCustomers | The "getCustomers" pipeline name.
GetExternalCommerceSystemProductList | The "getExternalCommerceSystemProductList" pipeline name.
GetParties | The get parties
GetPreOrderableInformation | The "getPreOrderableInformation" pipeline name.
GetProductBulkPrices | The get product bulk prices.
GetProductPrices | The get product prices.
GetSitecoreProductList | The "getSitecoreProductList" pipeline name.
GetStockInformation | The "getStockInformation" pipeline name.
GetUser | The "getUser" pipeline name.
GetUsers | The "getUsers" pipeline name.
GetVisitorOrder | The "getVisitorOrder" pipeline name.
GetVisitorOrders | The "getVisitorOrders" pipeline name.
LoadCart | The "loadCart" pipeline name.
LockCart | The "lockCart" pipeline name.
MergeCart | The "MergeCarts" pipeline name.
ProductsAreBackInStock | The "productsAreBackInStock" pipeline name.
RemoveCartLines | The "removeCartLines" pipeline name
RemoveCustomerParties | The remove customer parties
RemoveCustomers | The "removeCustomers" pipeline name.
RemoveParties | The remove parties
RemovePartiesFromCart | The "deleteParties" pipeline name.
RemovePaymentInfo | The "RemovePaymentInfo" pipeline name.
RemoveShippingInfo | The "RemoveShippingInfo" pipeline name.
RemoveUsers | The "removeUsers" pipeline name.
RemoveVisitorFromStockNotification | The "removeVisitorFromStockNotification" pipeline name.
ResumeCart | The "resumeCart" pipeline name.
SaveCart | The "saveCart" pipeline name.
StockStatusForIndexing | The "stockStatusForIndexing" pipeline name.
SubmitVisitorOrder | The "submitVisitorOrder" pipeline name.
SynchronizeArtifacts | The "synchronizeArtifacts" pipeline name.
SynchronizeClassifications | The "synchronizeClassifications" pipeline name.
SynchronizeClassificationSpecifications | The "synchronizeClassificationsSpecifications" pipeline name.
SynchronizeDivisions | The "synchronizeDivisions" pipeline name.
SynchronizeGlobalSpecifications | The "synchronizeGlobalSpecifications" pipeline name.
SynchronizeManufacturers | The "synchronizeManufacturers" pipeline name.
SynchronizeProduct | The "synchronizeProduct" pipeline name.
SynchronizeProductClassifications | The "synchronizeProductClassifications" pipeline name.
SynchronizeProductClassificationsSpecifications | The "synchronizeProductClassificationsSpecifications" pipeline name.
SynchronizeProductDivisions | The "synchronizeProductDivisions" pipeline name.
SynchronizeProductEntity | The "synchronizeProductEntity" pipeline name.
SynchronizeProductGlobalSpecifications | The "synchronizeProductGlobalSpecifications" pipeline name.
SynchronizeProductList | The "synchronizeProductList" pipeline name.
SynchronizeProductManufacturers | The "synchronizeProductManufacturers" pipeline name.
SynchronizeProductRelations | The "synchronizeProductRelations" pipeline name.
SynchronizeProductResources | The "synchronizeProductResources" pipeline name.
SynchronizeProducts | The "synchronizeProducts" pipeline name.
SynchronizeProductSpecifications | The "synchronizeProductSpecifications" pipeline name.
SynchronizeProductTypes | The "synchronizeProductTypes" pipeline name.
SynchronizeProductTypeSpecifications | The "synchronizeProductTypeSpecifications" pipeline name.
SynchronizeResources | The "synchronizeResources" pipeline name.
SynchronizeSpecifications | The "synchronizeSpecifications" pipeline name.
SynchronizeTypeDefaultValues | The synchronize type default values.
SynchronizeTypes | The "synchronizeTypes" pipeline name.
SynchronizeTypeSpecifications | The "synchronizeTypeSpecifications" pipeline name.
TriggerVisitedProductStockStatus | The "visitedProductStockStatus" pipeline name.
UnlockCart | The "unlockCart" pipeline name.
UpdateCart | The "updateCart" pipeline name.
UpdateCartLines | The "updateCartLines" pipeline name.
UpdateCustomer | The "updateCustomer" pipeline name.
UpdateCustomerParties | The update customer parties
UpdateParties | The update parties
UpdatePartiesInCart | The "updateParties" pipeline name.
UpdatePassword | The update user password
UpdateUser | The "updateUser" pipeline name.
VisitorOrderCancel | The "visitorOrderCancel" pipeline name.
VisitorSignUpForStockNotification | The "visitorSignUpForStockNotification" pipeline name.
Top
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.AddCartLines Field

PipelineNameAddCartLines Field
The "addCartLines" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string AddCartLines
Public Const AddCartLines As String
public:
literal String^ AddCartLines
static val mutable AddCartLines: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.AddCustomerParties Field

PipelineNameAddCustomerParties Field
The add customer parties

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string AddCustomerParties
Public Const AddCustomerParties As String
public:
literal String^ AddCustomerParties
static val mutable AddCustomerParties: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.AddCustomers Field

PipelineNameAddCustomers Field
The "addCustomers" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string AddCustomers
Public Const AddCustomers As String
public:
literal String^ AddCustomers
static val mutable AddCustomers: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.AddPartiesToCart Field

PipelineNameAddPartiesToCart Field
The "addParties" pipeline name

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string AddPartiesToCart
Public Const AddPartiesToCart As String
public:
literal String^ AddPartiesToCart
static val mutable AddPartiesToCart: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.AddPartiesToCustomer Field

PipelineNameAddPartiesToCustomer Field
The add parties

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string AddPartiesToCustomer
Public Const AddPartiesToCustomer As String
public:
literal String^ AddPartiesToCustomer
static val mutable AddPartiesToCustomer: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.AddPaymentInfo Field

PipelineNameAddPaymentInfo Field
The "addPaymentInfo" pipeline name

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string AddPaymentInfo
Public Const AddPaymentInfo As String
public:
literal String^ AddPaymentInfo
static val mutable AddPaymentInfo: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.AddShippingInfo Field

PipelineNameAddShippingInfo Field
The "AddShippingInfo" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string AddShippingInfo
Public Const AddShippingInfo As String
public:
literal String^ AddShippingInfo
static val mutable AddShippingInfo: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.AddUsers Field

PipelineNameAddUsers Field
The "addUsers" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string AddUsers
Public Const AddUsers As String
public:
literal String^ AddUsers
static val mutable AddUsers: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.CreateCart Field

PipelineNameCreateCart Field
The "createCart" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CreateCart
Public Const CreateCart As String
public:
literal String^ CreateCart
static val mutable CreateCart: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.CreateCustomer Field

PipelineNameCreateCustomer Field
The "createCustomer" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CreateCustomer
Public Const CreateCustomer As String
public:
literal String^ CreateCustomer
static val mutable CreateCustomer: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.CreateOrResumeCart Field

PipelineNameCreateOrResumeCart Field
The "createOrResumeCart" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CreateOrResumeCart
Public Const CreateOrResumeCart As String
public:
literal String^ CreateOrResumeCart
static val mutable CreateOrResumeCart: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.CreateUser Field

PipelineNameCreateUser Field
The "createUser" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string CreateUser
Public Const CreateUser As String
public:
literal String^ CreateUser
static val mutable CreateUser: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.DeleteCart Field

PipelineNameDeleteCart Field
The "deleteCart" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string DeleteCart
Public Const DeleteCart As String
public:
literal String^ DeleteCart
static val mutable DeleteCart: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.DeleteCustomer Field

PipelineNameDeleteCustomer Field
The "deleteCustomer" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string DeleteCustomer
Public Const DeleteCustomer As String
public:
literal String^ DeleteCustomer
static val mutable DeleteCustomer: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.DeleteUser Field

PipelineNameDeleteUser Field
The "deleteUser" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string DeleteUser
Public Const DeleteUser As String
public:
literal String^ DeleteUser
static val mutable DeleteUser: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.DisableCustomer Field

PipelineNameDisableCustomer Field
The "disableCustomer" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string DisableCustomer
Public Const DisableCustomer As String
public:
literal String^ DisableCustomer
static val mutable DisableCustomer: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.DisableUser Field

PipelineNameDisableUser Field
The "disableUser" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string DisableUser
Public Const DisableUser As String
public:
literal String^ DisableUser
static val mutable DisableUser: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.EnableCustomer Field

PipelineNameEnableCustomer Field
The "enableCustomer" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string EnableCustomer
Public Const EnableCustomer As String
public:
literal String^ EnableCustomer
static val mutable EnableCustomer: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.EnableUser Field

PipelineNameEnableUser Field
The "enableUser" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string EnableUser
Public Const EnableUser As String
public:
literal String^ EnableUser
static val mutable EnableUser: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetBackInStockInformation Field

PipelineNameGetBackInStockInformation Field
The "getBackInStockInformation" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetBackInStockInformation
Public Const GetBackInStockInformation As String
public:
literal String^ GetBackInStockInformation
static val mutable GetBackInStockInformation: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetBackOrderableInformation Field

PipelineNameGetBackOrderableInformation Field
The "getBackOrderableInformation" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetBackOrderableInformation
Public Const GetBackOrderableInformation As String
public:
literal String^ GetBackOrderableInformation
static val mutable GetBackOrderableInformation: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetCarts Field

PipelineNameGetCarts Field
The "getCarts" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetCarts
Public Const GetCarts As String
public:
literal String^ GetCarts
static val mutable GetCarts: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetCartTotal Field

PipelineNameGetCartTotal Field
The "getСartTotal" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetCartTotal
Public Const GetCartTotal As String
public:
literal String^ GetCartTotal
static val mutable GetCartTotal: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetCustomer Field

PipelineNameGetCustomer Field
The "getCustomer" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetCustomer
Public Const GetCustomer As String
public:
literal String^ GetCustomer
static val mutable GetCustomer: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetCustomers Field

PipelineNameGetCustomers Field
The "getCustomers" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetCustomers
Public Const GetCustomers As String
public:
literal String^ GetCustomers
static val mutable GetCustomers: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetExternalCommerceSystemProductList Field

PipelineNameGetExternalCommerceSystemProductList Field
The "getExternalCommerceSystemProductList" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetExternalCommerceSystemProductList
Public Const GetExternalCommerceSystemProductList As String
public:
literal String^ GetExternalCommerceSystemProductList
static val mutable GetExternalCommerceSystemProductList: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetParties Field

PipelineNameGetParties Field
The get parties

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetParties
Public Const GetParties As String
public:
literal String^ GetParties
static val mutable GetParties: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetPreOrderableInformation Field

PipelineNameGetPreOrderableInformation Field
The "getPreOrderableInformation" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetPreOrderableInformation
Public Const GetPreOrderableInformation As String
public:
literal String^ GetPreOrderableInformation
static val mutable GetPreOrderableInformation: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetProductBulkPrices Field

PipelineNameGetProductBulkPrices Field
The get product bulk prices.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetProductBulkPrices
Public Const GetProductBulkPrices As String
public:
literal String^ GetProductBulkPrices
static val mutable GetProductBulkPrices: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetProductPrices Field

PipelineNameGetProductPrices Field
The get product prices.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetProductPrices
Public Const GetProductPrices As String
public:
literal String^ GetProductPrices
static val mutable GetProductPrices: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetSitecoreProductList Field

PipelineNameGetSitecoreProductList Field
The "getSitecoreProductList" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetSitecoreProductList
Public Const GetSitecoreProductList As String
public:
literal String^ GetSitecoreProductList
static val mutable GetSitecoreProductList: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetStockInformation Field

PipelineNameGetStockInformation Field
The "getStockInformation" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetStockInformation
Public Const GetStockInformation As String
public:
literal String^ GetStockInformation
static val mutable GetStockInformation: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetUser Field

PipelineNameGetUser Field
The "getUser" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetUser
Public Const GetUser As String
public:
literal String^ GetUser
static val mutable GetUser: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetUsers Field

PipelineNameGetUsers Field
The "getUsers" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetUsers
Public Const GetUsers As String
public:
literal String^ GetUsers
static val mutable GetUsers: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetVisitorOrder Field

PipelineNameGetVisitorOrder Field
The "getVisitorOrder" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetVisitorOrder
Public Const GetVisitorOrder As String
public:
literal String^ GetVisitorOrder
static val mutable GetVisitorOrder: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.GetVisitorOrders Field

PipelineNameGetVisitorOrders Field
The "getVisitorOrders" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string GetVisitorOrders
Public Const GetVisitorOrders As String
public:
literal String^ GetVisitorOrders
static val mutable GetVisitorOrders: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.LoadCart Field

PipelineNameLoadCart Field
The "loadCart" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string LoadCart
Public Const LoadCart As String
public:
literal String^ LoadCart
static val mutable LoadCart: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.LockCart Field

PipelineNameLockCart Field
The "lockCart" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string LockCart
Public Const LockCart As String
public:
literal String^ LockCart
static val mutable LockCart: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.MergeCart Field

PipelineNameMergeCart Field
The "MergeCarts" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string MergeCart
Public Const MergeCart As String
public:
literal String^ MergeCart
static val mutable MergeCart: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.ProductsAreBackInStock Field

PipelineNameProductsAreBackInStock Field
The "productsAreBackInStock" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ProductsAreBackInStock
Public Const ProductsAreBackInStock As String
public:
literal String^ ProductsAreBackInStock
static val mutable ProductsAreBackInStock: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.RemoveCartLines Field

PipelineNameRemoveCartLines Field
The "removeCartLines" pipeline name

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string RemoveCartLines
Public Const RemoveCartLines As String
public:
literal String^ RemoveCartLines
static val mutable RemoveCartLines: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.RemoveCustomerParties Field

PipelineNameRemoveCustomerParties Field
The remove customer parties

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string RemoveCustomerParties
Public Const RemoveCustomerParties As String
public:
literal String^ RemoveCustomerParties
static val mutable RemoveCustomerParties: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.RemoveCustomers Field

PipelineNameRemoveCustomers Field
The "removeCustomers" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string RemoveCustomers
Public Const RemoveCustomers As String
public:
literal String^ RemoveCustomers
static val mutable RemoveCustomers: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.RemoveParties Field

PipelineNameRemoveParties Field
The remove parties

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string RemoveParties
Public Const RemoveParties As String
public:
literal String^ RemoveParties
static val mutable RemoveParties: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.RemovePartiesFromCart Field

PipelineNameRemovePartiesFromCart Field
The "deleteParties" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string RemovePartiesFromCart
Public Const RemovePartiesFromCart As String
public:
literal String^ RemovePartiesFromCart
static val mutable RemovePartiesFromCart: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.RemovePaymentInfo Field

PipelineNameRemovePaymentInfo Field
The "RemovePaymentInfo" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string RemovePaymentInfo
Public Const RemovePaymentInfo As String
public:
literal String^ RemovePaymentInfo
static val mutable RemovePaymentInfo: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.RemoveShippingInfo Field

PipelineNameRemoveShippingInfo Field
The "RemoveShippingInfo" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string RemoveShippingInfo
Public Const RemoveShippingInfo As String
public:
literal String^ RemoveShippingInfo
static val mutable RemoveShippingInfo: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.RemoveUsers Field

PipelineNameRemoveUsers Field
The "removeUsers" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string RemoveUsers
Public Const RemoveUsers As String
public:
literal String^ RemoveUsers
static val mutable RemoveUsers: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.RemoveVisitorFromStockNotification Field

PipelineNameRemoveVisitorFromStockNotification Field
The "removeVisitorFromStockNotification" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string RemoveVisitorFromStockNotification
Public Const RemoveVisitorFromStockNotification As String
public:
literal String^ RemoveVisitorFromStockNotification
static val mutable RemoveVisitorFromStockNotification: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.ResumeCart Field

PipelineNameResumeCart Field
The "resumeCart" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string ResumeCart
Public Const ResumeCart As String
public:
literal String^ ResumeCart
static val mutable ResumeCart: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SaveCart Field

PipelineNameSaveCart Field
The "saveCart" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SaveCart
Public Const SaveCart As String
public:
literal String^ SaveCart
static val mutable SaveCart: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.StockStatusForIndexing Field

PipelineNameStockStatusForIndexing Field
The "stockStatusForIndexing" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string StockStatusForIndexing
Public Const StockStatusForIndexing As String
public:
literal String^ StockStatusForIndexing
static val mutable StockStatusForIndexing: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SubmitVisitorOrder Field

PipelineNameSubmitVisitorOrder Field
The "submitVisitorOrder" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SubmitVisitorOrder
Public Const SubmitVisitorOrder As String
public:
literal String^ SubmitVisitorOrder
static val mutable SubmitVisitorOrder: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeArtifacts Field

PipelineNameSynchronizeArtifacts Field
The "synchronizeArtifacts" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeArtifacts
Public Const SynchronizeArtifacts As String
public:
literal String^ SynchronizeArtifacts
static val mutable SynchronizeArtifacts: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeClassifications Field

PipelineNameSynchronizeClassifications Field
The "synchronizeClassifications" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeClassifications
Public Const SynchronizeClassifications As String
public:
literal String^ SynchronizeClassifications
static val mutable SynchronizeClassifications: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeClassificationSpecifications Field

PipelineNameSynchronizeClassificationSpecifications Field
The "synchronizeClassificationsSpecifications" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeClassificationSpecifications
Public Const SynchronizeClassificationSpecifications As String
public:
literal String^ SynchronizeClassificationSpecifications
static val mutable SynchronizeClassificationSpecifications: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeDivisions Field

PipelineNameSynchronizeDivisions Field
The "synchronizeDivisions" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeDivisions
Public Const SynchronizeDivisions As String
public:
literal String^ SynchronizeDivisions
static val mutable SynchronizeDivisions: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeGlobalSpecifications Field

PipelineNameSynchronizeGlobalSpecifications Field
The "synchronizeGlobalSpecifications" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeGlobalSpecifications
Public Const SynchronizeGlobalSpecifications As String
public:
literal String^ SynchronizeGlobalSpecifications
static val mutable SynchronizeGlobalSpecifications: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeManufacturers Field

PipelineNameSynchronizeManufacturers Field
The "synchronizeManufacturers" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeManufacturers
Public Const SynchronizeManufacturers As String
public:
literal String^ SynchronizeManufacturers
static val mutable SynchronizeManufacturers: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeProduct Field

PipelineNameSynchronizeProduct Field
The "synchronizeProduct" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProduct
Public Const SynchronizeProduct As String
public:
literal String^ SynchronizeProduct
static val mutable SynchronizeProduct: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeProductClassifications Field

PipelineNameSynchronizeProductClassifications Field
The "synchronizeProductClassifications" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProductClassifications
Public Const SynchronizeProductClassifications As String
public:
literal String^ SynchronizeProductClassifications
static val mutable SynchronizeProductClassifications: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeProductClassificationsSpecifications Field

PipelineNameSynchronizeProductClassificationsSpecifications Field
The "synchronizeProductClassificationsSpecifications" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProductClassificationsSpecifications
Public Const SynchronizeProductClassificationsSpecifications As String
public:
literal String^ SynchronizeProductClassificationsSpecifications
static val mutable SynchronizeProductClassificationsSpecifications: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeProductDivisions Field

PipelineNameSynchronizeProductDivisions Field
The "synchronizeProductDivisions" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProductDivisions
Public Const SynchronizeProductDivisions As String
public:
literal String^ SynchronizeProductDivisions
static val mutable SynchronizeProductDivisions: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeProductEntity Field

PipelineNameSynchronizeProductEntity Field
The "synchronizeProductEntity" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProductEntity
Public Const SynchronizeProductEntity As String
public:
literal String^ SynchronizeProductEntity
static val mutable SynchronizeProductEntity: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeProductGlobalSpecifications Field

PipelineNameSynchronizeProductGlobalSpecifications Field
The "synchronizeProductGlobalSpecifications" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProductGlobalSpecifications
Public Const SynchronizeProductGlobalSpecifications As String
public:
literal String^ SynchronizeProductGlobalSpecifications
static val mutable SynchronizeProductGlobalSpecifications: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeProductList Field

PipelineNameSynchronizeProductList Field
The "synchronizeProductList" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProductList
Public Const SynchronizeProductList As String
public:
literal String^ SynchronizeProductList
static val mutable SynchronizeProductList: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeProductManufacturers Field

PipelineNameSynchronizeProductManufacturers Field
The "synchronizeProductManufacturers" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProductManufacturers
Public Const SynchronizeProductManufacturers As String
public:
literal String^ SynchronizeProductManufacturers
static val mutable SynchronizeProductManufacturers: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeProductRelations Field

PipelineNameSynchronizeProductRelations Field
The "synchronizeProductRelations" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProductRelations
Public Const SynchronizeProductRelations As String
public:
literal String^ SynchronizeProductRelations
static val mutable SynchronizeProductRelations: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeProductResources Field

PipelineNameSynchronizeProductResources Field
The "synchronizeProductResources" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProductResources
Public Const SynchronizeProductResources As String
public:
literal String^ SynchronizeProductResources
static val mutable SynchronizeProductResources: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeProducts Field

PipelineNameSynchronizeProducts Field
The "synchronizeProducts" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProducts
Public Const SynchronizeProducts As String
public:
literal String^ SynchronizeProducts
static val mutable SynchronizeProducts: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeProductSpecifications Field

PipelineNameSynchronizeProductSpecifications Field
The "synchronizeProductSpecifications" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProductSpecifications
Public Const SynchronizeProductSpecifications As String
public:
literal String^ SynchronizeProductSpecifications
static val mutable SynchronizeProductSpecifications: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeProductTypes Field

PipelineNameSynchronizeProductTypes Field
The "synchronizeProductTypes" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProductTypes
Public Const SynchronizeProductTypes As String
public:
literal String^ SynchronizeProductTypes
static val mutable SynchronizeProductTypes: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeProductTypeSpecifications Field

PipelineNameSynchronizeProductTypeSpecifications Field
The "synchronizeProductTypeSpecifications" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeProductTypeSpecifications
Public Const SynchronizeProductTypeSpecifications As String
public:
literal String^ SynchronizeProductTypeSpecifications
static val mutable SynchronizeProductTypeSpecifications: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeResources Field

PipelineNameSynchronizeResources Field
The "synchronizeResources" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeResources
Public Const SynchronizeResources As String
public:
literal String^ SynchronizeResources
static val mutable SynchronizeResources: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeSpecifications Field

PipelineNameSynchronizeSpecifications Field
The "synchronizeSpecifications" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeSpecifications
Public Const SynchronizeSpecifications As String
public:
literal String^ SynchronizeSpecifications
static val mutable SynchronizeSpecifications: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeTypeDefaultValues Field

PipelineNameSynchronizeTypeDefaultValues Field
The synchronize type default values.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeTypeDefaultValues
Public Const SynchronizeTypeDefaultValues As String
public:
literal String^ SynchronizeTypeDefaultValues
static val mutable SynchronizeTypeDefaultValues: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeTypes Field

PipelineNameSynchronizeTypes Field
The "synchronizeTypes" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeTypes
Public Const SynchronizeTypes As String
public:
literal String^ SynchronizeTypes
static val mutable SynchronizeTypes: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.SynchronizeTypeSpecifications Field

PipelineNameSynchronizeTypeSpecifications Field
The "synchronizeTypeSpecifications" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string SynchronizeTypeSpecifications
Public Const SynchronizeTypeSpecifications As String
public:
literal String^ SynchronizeTypeSpecifications
static val mutable SynchronizeTypeSpecifications: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.TriggerVisitedProductStockStatus Field

PipelineNameTriggerVisitedProductStockStatus Field
The "visitedProductStockStatus" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string TriggerVisitedProductStockStatus
Public Const TriggerVisitedProductStockStatus As String
public:
literal String^ TriggerVisitedProductStockStatus
static val mutable TriggerVisitedProductStockStatus: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.UnlockCart Field

PipelineNameUnlockCart Field
The "unlockCart" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UnlockCart
Public Const UnlockCart As String
public:
literal String^ UnlockCart
static val mutable UnlockCart: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.UpdateCart Field

PipelineNameUpdateCart Field
The "updateCart" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UpdateCart
Public Const UpdateCart As String
public:
literal String^ UpdateCart
static val mutable UpdateCart: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.UpdateCartLines Field

PipelineNameUpdateCartLines Field
The "updateCartLines" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UpdateCartLines
Public Const UpdateCartLines As String
public:
literal String^ UpdateCartLines
static val mutable UpdateCartLines: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.UpdateCustomer Field

PipelineNameUpdateCustomer Field
The "updateCustomer" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UpdateCustomer
Public Const UpdateCustomer As String
public:
literal String^ UpdateCustomer
static val mutable UpdateCustomer: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.UpdateCustomerParties Field

PipelineNameUpdateCustomerParties Field
The update customer parties

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UpdateCustomerParties
Public Const UpdateCustomerParties As String
public:
literal String^ UpdateCustomerParties
static val mutable UpdateCustomerParties: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.UpdateParties Field

PipelineNameUpdateParties Field
The update parties

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UpdateParties
Public Const UpdateParties As String
public:
literal String^ UpdateParties
static val mutable UpdateParties: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.UpdatePartiesInCart Field

PipelineNameUpdatePartiesInCart Field
The "updateParties" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UpdatePartiesInCart
Public Const UpdatePartiesInCart As String
public:
literal String^ UpdatePartiesInCart
static val mutable UpdatePartiesInCart: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.UpdatePassword Field

PipelineNameUpdatePassword Field
The update user password

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UpdatePassword
Public Const UpdatePassword As String
public:
literal String^ UpdatePassword
static val mutable UpdatePassword: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.UpdateUser Field

PipelineNameUpdateUser Field
The "updateUser" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string UpdateUser
Public Const UpdateUser As String
public:
literal String^ UpdateUser
static val mutable UpdateUser: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.VisitorOrderCancel Field

PipelineNameVisitorOrderCancel Field
The "visitorOrderCancel" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string VisitorOrderCancel
Public Const VisitorOrderCancel As String
public:
literal String^ VisitorOrderCancel
static val mutable VisitorOrderCancel: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineName.VisitorSignUpForStockNotification Field

PipelineNameVisitorSignUpForStockNotification Field
The "visitorSignUpForStockNotification" pipeline name.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string VisitorSignUpForStockNotification
Public Const VisitorSignUpForStockNotification As String
public:
literal String^ VisitorSignUpForStockNotification
static val mutable VisitorSignUpForStockNotification: string

Field Value

Type: String
See Also

Reference

PipelineName Class
Sitecore.Commerce.Pipelines Namespace


PipelineProcessor(TArgs) Class

PipelineProcessorTArgs Class
Defines the base pipeline processor class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessorTArgs
More...

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class PipelineProcessor<TArgs>
where TArgs : PipelineArgs

Public MustInherit Class PipelineProcessor(Of TArgs As PipelineArgs)
generic<typename TArgs>
where TArgs : PipelineArgs
public ref class PipelineProcessor abstract
[<AbstractClassAttribute>]
type PipelineProcessor<'TArgs when 'TArgs : PipelineArgs> =  class end

Type Parameters

TArgs
The type of the args.

The PipelineProcessorTArgs type exposes the following members.

Constructors
 | Name | Description
Protected method | PipelineProcessorTArgs | Initializes a new instance of the PipelineProcessorTArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessorTArgs
Sitecore.Commerce.Pipelines.Carts.AddCartLinesAddLinesToCart
Sitecore.Commerce.Pipelines.Carts.AddPartiesAddPartiesToCart
Sitecore.Commerce.Pipelines.Carts.AddPaymentInfoAddPaymentInfoToCart
Sitecore.Commerce.Pipelines.Carts.AddShippingInfoAddShippingInfoToCart
Sitecore.Commerce.Pipelines.Carts.CommonCartPipelineProcessor
Sitecore.Commerce.Pipelines.Carts.CommonCheckIfLocked
Sitecore.Commerce.Pipelines.Carts.CommonSaveCartToEaState
Sitecore.Commerce.Pipelines.Carts.CreateCartAddVisitorToEaPlan
Sitecore.Commerce.Pipelines.Carts.CreateCartCreateCart
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCartFindCartInEaState
Sitecore.Commerce.Pipelines.Carts.DeleteCartDeleteCartFromEaState
Sitecore.Commerce.Pipelines.Carts.GetCartsBuildQuery
Sitecore.Commerce.Pipelines.Carts.LockCartLockCart
Sitecore.Commerce.Pipelines.Carts.MergeCartMergeCart
Sitecore.Commerce.Pipelines.Carts.RemoveCartLinesRemoveLinesFromCart
Sitecore.Commerce.Pipelines.Carts.RemovePartiesRemovePartiesFromCart
Sitecore.Commerce.Pipelines.Carts.RemovePaymentInfoRemovePaymentInfoFromCart
Sitecore.Commerce.Pipelines.Carts.RemoveShippingInfoRemoveShippingInfoFromCart
Sitecore.Commerce.Pipelines.Carts.ResumeCartChangeCartStatus
Sitecore.Commerce.Pipelines.Carts.ResumeCartCheckCanBeResumed
Sitecore.Commerce.Pipelines.Carts.ResumeCartMoveVisitorToInitialState
Sitecore.Commerce.Pipelines.Carts.UnlockCartUnlockCart
Sitecore.Commerce.Pipelines.Carts.UpdateCartUpdateCart
Sitecore.Commerce.Pipelines.Carts.UpdateCartLinesUpdateLinesOnCart
Sitecore.Commerce.Pipelines.Carts.UpdatePartiesUpdatePartiesInCart
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.CustomersAddCustomerPartiesToExternalSystem
Sitecore.Commerce.Pipelines.CustomersAddCustomersToExternalSystem
Sitecore.Commerce.Pipelines.CustomersAddPartiesToExternalSystem
Sitecore.Commerce.Pipelines.CustomersAddUsersToExternalSystem
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.CommonUserPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.CreateCustomerCreateCustomerInExternalSystem
Sitecore.Commerce.Pipelines.Customers.CreateUserCreateUserInExternalSystem
Sitecore.Commerce.Pipelines.Customers.DeleteCustomerDeleteCustomerFromExternalSystem
Sitecore.Commerce.Pipelines.Customers.DeleteUserDeleteUserInExternalSystem
Sitecore.Commerce.Pipelines.Customers.DisableCustomerDisableCustomerInExternalSystem
Sitecore.Commerce.Pipelines.Customers.DisableUserDisableUserInExternalSystem
Sitecore.Commerce.Pipelines.Customers.EnableCustomerEnableCustomerInExternalSystem
Sitecore.Commerce.Pipelines.Customers.EnableUserEnableUserInExternalSystem
Sitecore.Commerce.Pipelines.Customers.GetCustomerGetCustomerFromExternalSystem
Sitecore.Commerce.Pipelines.Customers.GetCustomersGetCustomersFromExternalSystem
Sitecore.Commerce.Pipelines.CustomersGetPartiesFromExternalSystem
Sitecore.Commerce.Pipelines.Customers.GetUserGetUserFromExternalSystem
Sitecore.Commerce.Pipelines.Customers.GetUsersGetUsersFromExternalSystem
Sitecore.Commerce.Pipelines.CustomersRemoveCustomerPartiesFromExternalSystem
Sitecore.Commerce.Pipelines.CustomersRemoveCustomersFromExternalSystem
Sitecore.Commerce.Pipelines.CustomersRemovePartiesFromExternalSystem
Sitecore.Commerce.Pipelines.CustomersRemoveUsersFromExternalSystem
Sitecore.Commerce.Pipelines.Customers.UpdateCustomerUpdateCustomerInExternalSystem
Sitecore.Commerce.Pipelines.CustomersUpdateCustomerPartiesInExternalSystem
Sitecore.Commerce.Pipelines.Customers.UpdatePartiesUpdatePartiesInExternalSystem
Sitecore.Commerce.Pipelines.Customers.UpdateUserUpdateUserInExternalSystem
Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformationGetBackOrderableInformation
Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformationGetPreOrderableInformation
Sitecore.Commerce.Pipelines.Inventory.GetStockInformationGetBackInStockInformation
Sitecore.Commerce.Pipelines.Inventory.GetStockInformationGetStockInformation
Sitecore.Commerce.Pipelines.Inventory.GetStockInformationStockStatusForIndexing
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotificationRemoveVisitorFromStockNotification
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotificationVisitorSignUpForStockNotification
Sitecore.Commerce.Pipelines.Orders.CommonAddOrderToEAPlan
Sitecore.Commerce.Pipelines.Prices.GetCartTotalGetCartTotal
Sitecore.Commerce.Pipelines.Prices.GetProductBulkPricesGetProductBulkPrices
Sitecore.Commerce.Pipelines.Prices.GetProductPricesGetProductPrices
Sitecore.Commerce.Pipelines.Products.GetExternalCommerceSystemProductListGetExternalCommerceSystemProductList
Sitecore.Commerce.Pipelines.Products.GetSitecoreProductListGetSitecoreProductList
Sitecore.Commerce.Pipelines.ProductsResolveChangesProcessor
Sitecore.Commerce.Pipelines.ProductsSaveToSitecoreProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsReadSitecoreClassifications
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSaveClassificationsToExternalCommerceSystem
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecificationsReadExternalCommerceSystemClassificationsSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecificationsReadSitecoreClassificationsSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecificationsResolveClassificationsSpecificationsChanges
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecificationsSaveClassificationsSpecificationsToExternalCommerceSystem
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisionsReadSitecoreDivisions
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisionsSaveDivisionsToExternalCommerceSystem
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecificationsReadExternalCommerceSystemGlobalSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecificationsReadSitecoreGlobalSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecificationsResolveGlobalSpecificationsChanges
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecificationsSaveGlobalSpecificationsToExternalCommerceSystem
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturersReadSitecoreManufacturers
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturersSaveManufacturersToExternalCommerceSystem
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSaveProductClassificationsToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecificationsSaveProductClassificationsSpecificationsToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisionsSaveProductDivisionsToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntityDeleteProductFromSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntityReadProductFromSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntityResolveProductChanges
Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecificationsSaveProductGlobalSpecificationsToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListSearchIndexProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListSynchronizeProductRepositoryBucket
Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturersReadExternalCommerceSystemProductManufacturers
Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturersSaveProductManufacturersToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelationsSaveProductRelationsToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeProductResourcesSaveProductResourcesToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeProductsDeleteProductsFromSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeProductsEvaluateProductListUnionToSynchronize
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypesSaveProductTypesToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecificationsReadSitecoreProductTypeSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecificationsResolveProductTypeSpecificationsChanges
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecificationsSaveProductTypeSpecificationsToExternalCommerceSystem
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecificationsSaveProductTypeSpecificationsToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValuesReadSitecoreTypeDefaultValues
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValuesResolveTypeDefaultValuesChanges
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValuesSaveTypeDefaultValuesToExternalCommerceSystem
Sitecore.Commerce.Pipelines.Products.SynchronizeTypesReadSitecoreTypes
Sitecore.Commerce.Pipelines.Products.SynchronizeTypesSaveTypesToExternalCommerceSystem
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecificationsReadSitecoreTypeSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecificationsResolveTypeSpecificationsChanges
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecificationsSaveTypeSpecificationsToExternalCommerceSystem
Sitecore.Commerce.PipelinesRunPipelineProcessorTArgs


PipelineProcessor(TArgs) Constructor

PipelineProcessorTArgs Constructor
Initializes a new instance of the PipelineProcessorTArgs class

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected PipelineProcessor()
Protected Sub New
protected:
PipelineProcessor()
new : unit -> PipelineProcessor
See Also

Reference

PipelineProcessorTArgs Class
Sitecore.Commerce.Pipelines Namespace


PipelineProcessor(TArgs) Methods

PipelineProcessorTArgs Methods

The PipelineProcessorTArgs generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PipelineProcessorTArgs Class
Sitecore.Commerce.Pipelines Namespace


PipelineProcessor(TArgs).Process Method

PipelineProcessorTArgsProcess Method
Runs the pipeline processor.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract void Process(
    TArgs args
)
Public MustOverride Sub Process (
    args As TArgs
)
public:
virtual void Process(
    TArgs args
) abstract
abstract Process :
        args : 'TArgs -> unit

Parameters

args
Type: TArgs
The args.
See Also

Reference

PipelineProcessorTArgs Class
Sitecore.Commerce.Pipelines Namespace


PipelineService Class

PipelineService Class
Allows to get and set a pipeline service which allows to mock the service in unit testing.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineService

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class PipelineService
Public Class PipelineService
public ref class PipelineService
type PipelineService =  class end

The PipelineService type exposes the following members.

Constructors
 | Name | Description
Public method | PipelineService | Initializes a new instance of the PipelineService class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RunPipelineTArgs | Runs the pipeline.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines Namespace


PipelineService Constructor

PipelineService Constructor
Initializes a new instance of the PipelineService class

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PipelineService()
Public Sub New
public:
PipelineService()
new : unit -> PipelineService
See Also

Reference

PipelineService Class
Sitecore.Commerce.Pipelines Namespace


PipelineService Methods

PipelineService Methods

The PipelineService type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RunPipelineTArgs | Runs the pipeline.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PipelineService Class
Sitecore.Commerce.Pipelines Namespace


PipelineService.RunPipeline(TArgs) Method

PipelineServiceRunPipelineTArgs Method
Runs the pipeline.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void RunPipeline<TArgs>(
    string pipelineName,
    TArgs args
)
where TArgs : PipelineArgs

Public Overridable Sub RunPipeline(Of TArgs As PipelineArgs) (
    pipelineName As String,
    args As TArgs
)
public:
generic<typename TArgs>
where TArgs : PipelineArgs
virtual void RunPipeline(
    String^ pipelineName,
    TArgs args
)
abstract RunPipeline :
        pipelineName : string *
        args : 'TArgs -> unit  when 'TArgs : PipelineArgs
override RunPipeline :
        pipelineName : string *
        args : 'TArgs -> unit  when 'TArgs : PipelineArgs

Parameters

pipelineName
Type: SystemString
Name of the pipeline.
args
Type: TArgs
The args.

Type Parameters

TArgs
The type of the args.
See Also

Reference

PipelineService Class
Sitecore.Commerce.Pipelines Namespace


RunPipelineProcessor(TArgs) Class

RunPipelineProcessorTArgs Class
The Run Pipeline processor base class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor TArgs
Sitecore.Commerce.PipelinesRunPipelineProcessorTArgs
More...

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class RunPipelineProcessor<TArgs> : PipelineProcessor<TArgs>
where TArgs : PipelineArgs

Public MustInherit Class RunPipelineProcessor(Of TArgs As PipelineArgs)
    Inherits PipelineProcessor(Of TArgs)
generic<typename TArgs>
where TArgs : PipelineArgs
public ref class RunPipelineProcessor abstract : public PipelineProcessor<TArgs>
[<AbstractClassAttribute>]
type RunPipelineProcessor<'TArgs when 'TArgs : PipelineArgs> =
    class
        inherit PipelineProcessor<'TArgs>
    end

Type Parameters

TArgs
The type of the args.

The RunPipelineProcessorTArgs type exposes the following members.

Constructors
 | Name | Description
Protected method | RunPipelineProcessorTArgs | Initializes a new instance of the RunPipelineProcessorTArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Inherited from PipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline.
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service.
Top
See Also

Reference

Sitecore.Commerce.Pipelines Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor TArgs
Sitecore.Commerce.PipelinesRunPipelineProcessorTArgs
Sitecore.Commerce.Pipelines.Carts.CommonRunSaveCart
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCartRunCreateCart
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCartRunLoadCart
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCartRunResumeCart
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifactsRunSynchronizeClassifications
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifactsRunSynchronizeDivisions
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifactsRunSynchronizeManufacturers
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifactsRunSynchronizeResources
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifactsRunSynchronizeSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifactsRunSynchronizeTypes
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsReadExternalCommerceSystemClassifications
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisionsReadExternalCommerceSystemDivisions
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturersReadExternalCommerceSystemManufacturers
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductClassifications
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductDivisions
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductEntity
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductManufacturers
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductRelations
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductResources
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductTypes
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsReadExternalCommerceSystemProductClassifications
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecificationsReadExternalCommerceSystemProductClassificationsSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisionsReadExternalCommerceSystemProductDivisions
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntityReadExternalCommerceSystemProduct
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntitySaveProductToExternalCommerceSystem
Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecificationsReadExternalCommerceSystemProductGlobalSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListSynchronizeProductList
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelationsReadExternalCommerceSystemProductRelations
Sitecore.Commerce.Pipelines.Products.SynchronizeProductResourcesReadExternalCommerceSystemProductResources
Sitecore.Commerce.Pipelines.Products.SynchronizeProductsRunGetExternalCommerceSystemProductList
Sitecore.Commerce.Pipelines.Products.SynchronizeProductsRunGetSitecoreProductList
Sitecore.Commerce.Pipelines.Products.SynchronizeProductsRunSynchronizeArtifacts
Sitecore.Commerce.Pipelines.Products.SynchronizeProductsRunSynchronizeProductList
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecificationsRunSynchronizeProductClassificationsSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecificationsRunSynchronizeProductGlobalSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecificationsRunSynchronizeProductTypeSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypesReadExternalCommerceSystemProductTypes
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecificationsReadExternalCommerceSystemProductTypeSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecificationsRunSynchronizeClassificationSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecificationsRunSynchronizeGlobalSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecificationsRunSynchronizeTypeSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValuesReadExternalCommerceSystemTypeDefaultValues
Sitecore.Commerce.Pipelines.Products.SynchronizeTypesReadExternalCommerceSystemTypes
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecificationsReadExternalCommerceSystemTypeSpecifications
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecificationsRunSynchronizeTypeDefaultValues


RunPipelineProcessor(TArgs) Constructor

RunPipelineProcessorTArgs Constructor
Initializes a new instance of the RunPipelineProcessorTArgs class

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected RunPipelineProcessor()
Protected Sub New
protected:
RunPipelineProcessor()
new : unit -> RunPipelineProcessor
See Also

Reference

RunPipelineProcessorTArgs Class
Sitecore.Commerce.Pipelines Namespace


RunPipelineProcessor(TArgs) Methods

RunPipelineProcessorTArgs Methods

The RunPipelineProcessorTArgs generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Inherited from PipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline.
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunPipelineProcessorTArgs Class
Sitecore.Commerce.Pipelines Namespace


RunPipelineProcessor(TArgs).RunPipeline Method

RunPipelineProcessorTArgsRunPipeline Method
Overload List
 | Name | Description
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline.
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline.
Top
See Also

Reference

RunPipelineProcessorTArgs Class
Sitecore.Commerce.Pipelines Namespace


RunPipelineProcessor(TArgs).RunPipeline Method (String, ServicePipelineArgs)

RunPipelineProcessorTArgsRunPipeline Method (String, ServicePipelineArgs)
Runs the pipeline.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected void RunPipeline(
    string pipelineName,
    ServicePipelineArgs args
)
Protected Sub RunPipeline (
    pipelineName As String,
    args As ServicePipelineArgs
)
protected:
void RunPipeline(
    String^ pipelineName,
    ServicePipelineArgs^ args
)
member RunPipeline :
        pipelineName : string *
        args : ServicePipelineArgs -> unit

Parameters

pipelineName
Type: SystemString
Name of the pipeline.
args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunPipelineProcessorTArgs Class
RunPipeline Overload
Sitecore.Commerce.Pipelines Namespace


RunPipelineProcessor(TArgs).RunPipeline Method (String, ServicePipelineArgs, ServiceProviderRequest)

RunPipelineProcessorTArgsRunPipeline Method (String, ServicePipelineArgs, ServiceProviderRequest)
Runs the pipeline.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected void RunPipeline(
    string pipelineName,
    ServicePipelineArgs args,
    ServiceProviderRequest previousRequest
)
Protected Sub RunPipeline (
    pipelineName As String,
    args As ServicePipelineArgs,
    previousRequest As ServiceProviderRequest
)
protected:
void RunPipeline(
    String^ pipelineName,
    ServicePipelineArgs^ args,
    ServiceProviderRequest^ previousRequest
)
member RunPipeline :
        pipelineName : string *
        args : ServicePipelineArgs *
        previousRequest : ServiceProviderRequest -> unit

Parameters

pipelineName
Type: SystemString
Name of the pipeline.
args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
previousRequest
Type: Sitecore.Commerce.ServicesServiceProviderRequest
The previous request.
See Also

Reference

RunPipelineProcessorTArgs Class
RunPipeline Overload
Sitecore.Commerce.Pipelines Namespace


RunPipelineProcessor(TArgs) Properties

RunPipelineProcessorTArgs Properties

The RunPipelineProcessorTArgs generic type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service.
Top
See Also

Reference

RunPipelineProcessorTArgs Class
Sitecore.Commerce.Pipelines Namespace


RunPipelineProcessor(TArgs).PipelineService Property

RunPipelineProcessorTArgsPipelineService Property
Gets or sets the pipeline service.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PipelineService PipelineService { get; set; }
Public Property PipelineService As PipelineService
    Get
    Set
public:
property PipelineService^ PipelineService {
    PipelineService^ get ();
    void set (PipelineService^ value);
}
member PipelineService : PipelineService with get, set

Property Value

Type: PipelineService
The pipeline service.
See Also

Reference

RunPipelineProcessorTArgs Class
Sitecore.Commerce.Pipelines Namespace


ServicePipelineArgs Class

ServicePipelineArgs Class
The service pipeline args.
Inheritance Hierarchy
SystemObject
SystemEventArgs
PipelineArgs
Sitecore.Commerce.PipelinesServicePipelineArgs

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ServicePipelineArgs : PipelineArgs
<SerializableAttribute>
Public Class ServicePipelineArgs
    Inherits PipelineArgs
[SerializableAttribute]
public ref class ServicePipelineArgs : public PipelineArgs
[<SerializableAttribute>]
type ServicePipelineArgs =
    class
        inherit PipelineArgs
    end

The ServicePipelineArgs type exposes the following members.

Constructors
 | Name | Description
Protected method | ServicePipelineArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ServicePipelineArgs class.
Public method | ServicePipelineArgs(ServiceProviderRequest, ServiceProviderResult) | Initializes a new instance of the ServicePipelineArgs class.
Top
Methods
 | Name | Description
Public method | Abort | Obsolete. (Inherited from PipelineArgs.)
Public method | AbortPipeline | (Inherited from PipelineArgs.)
Public method | AddMessage(String) | (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | (Inherited from PipelineArgs.)
Protected method | DeserializeCustomData | (Inherited from PipelineArgs.)
Protected method | Dispose | (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages | (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | (Inherited from PipelineArgs.)
Protected method | Resume | (Inherited from PipelineArgs.)
Protected method | SerializeCustomData | (Inherited from PipelineArgs.)
Public method | Suspend | (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | (Inherited from PipelineArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Aborted | (Inherited from PipelineArgs.)
Public property | CustomData | (Inherited from PipelineArgs.)
Public property | Data | Obsolete. (Inherited from PipelineArgs.)
Public property | Message | (Inherited from PipelineArgs.)
Public property | ProcessorItem | (Inherited from PipelineArgs.)
Public property | Request | Gets the request.
Public property | Result | Gets the result.
Public property | Suspended | (Inherited from PipelineArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines Namespace


ServicePipelineArgs Constructor

ServicePipelineArgs Constructor
Overload List
 | Name | Description
Protected method | ServicePipelineArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ServicePipelineArgs class.
Public method | ServicePipelineArgs(ServiceProviderRequest, ServiceProviderResult) | Initializes a new instance of the ServicePipelineArgs class.
Top
See Also

Reference

ServicePipelineArgs Class
Sitecore.Commerce.Pipelines Namespace


ServicePipelineArgs Constructor (SerializationInfo, StreamingContext)

ServicePipelineArgs Constructor (SerializationInfo, StreamingContext)
Initializes a new instance of the ServicePipelineArgs class.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected ServicePipelineArgs(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ServicePipelineArgs(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ServicePipelineArgs

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialized data.
context
Type: System.Runtime.SerializationStreamingContext
The context.
See Also

Reference

ServicePipelineArgs Class
ServicePipelineArgs Overload
Sitecore.Commerce.Pipelines Namespace


ServicePipelineArgs Constructor (ServiceProviderRequest, ServiceProviderResult)

ServicePipelineArgs Constructor (ServiceProviderRequest, ServiceProviderResult)
Initializes a new instance of the ServicePipelineArgs class.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ServicePipelineArgs(
    ServiceProviderRequest request,
    ServiceProviderResult result
)
Public Sub New (
    request As ServiceProviderRequest,
    result As ServiceProviderResult
)
public:
ServicePipelineArgs(
    ServiceProviderRequest^ request,
    ServiceProviderResult^ result
)
new :
        request : ServiceProviderRequest *
        result : ServiceProviderResult -> ServicePipelineArgs

Parameters

request
Type: Sitecore.Commerce.ServicesServiceProviderRequest
The request.
result
Type: Sitecore.Commerce.ServicesServiceProviderResult
The result.
See Also

Reference

ServicePipelineArgs Class
ServicePipelineArgs Overload
Sitecore.Commerce.Pipelines Namespace


ServicePipelineArgs Methods

ServicePipelineArgs Methods

The ServicePipelineArgs type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Obsolete. (Inherited from PipelineArgs.)
Public method | AbortPipeline | (Inherited from PipelineArgs.)
Public method | AddMessage(String) | (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | (Inherited from PipelineArgs.)
Protected method | DeserializeCustomData | (Inherited from PipelineArgs.)
Protected method | Dispose | (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages | (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | (Inherited from PipelineArgs.)
Protected method | Resume | (Inherited from PipelineArgs.)
Protected method | SerializeCustomData | (Inherited from PipelineArgs.)
Public method | Suspend | (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | (Inherited from PipelineArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServicePipelineArgs Class
Sitecore.Commerce.Pipelines Namespace


ServicePipelineArgs.GetObjectData Method

ServicePipelineArgsGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ServicePipelineArgs Class
Sitecore.Commerce.Pipelines Namespace


ServicePipelineArgs Properties

ServicePipelineArgs Properties

The ServicePipelineArgs type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | (Inherited from PipelineArgs.)
Public property | CustomData | (Inherited from PipelineArgs.)
Public property | Data | Obsolete. (Inherited from PipelineArgs.)
Public property | Message | (Inherited from PipelineArgs.)
Public property | ProcessorItem | (Inherited from PipelineArgs.)
Public property | Request | Gets the request.
Public property | Result | Gets the result.
Public property | Suspended | (Inherited from PipelineArgs.)
Top
See Also

Reference

ServicePipelineArgs Class
Sitecore.Commerce.Pipelines Namespace


ServicePipelineArgs.Request Property

ServicePipelineArgsRequest Property
Gets the request.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ServiceProviderRequest Request { get; }
Public ReadOnly Property Request As ServiceProviderRequest
    Get
public:
property ServiceProviderRequest^ Request {
    ServiceProviderRequest^ get ();
}
member Request : ServiceProviderRequest with get

Property Value

Type: ServiceProviderRequest
The request.
See Also

Reference

ServicePipelineArgs Class
Sitecore.Commerce.Pipelines Namespace


ServicePipelineArgs.Result Property

ServicePipelineArgsResult Property
Gets the result.

Namespace: Sitecore.Commerce.Pipelines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ServiceProviderResult Result { get; }
Public ReadOnly Property Result As ServiceProviderResult
    Get
public:
property ServiceProviderResult^ Result {
    ServiceProviderResult^ get ();
}
member Result : ServiceProviderResult with get

Property Value

Type: ServiceProviderResult
The result.
See Also

Reference

ServicePipelineArgs Class
Sitecore.Commerce.Pipelines Namespace


Sitecore.Commerce.Pipelines.Carts.AddCartLines Namespace

Sitecore.Commerce.Pipelines.Carts.AddCartLines Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.AddCartLines"]

Classes
 | Class | Description
Public class | AddLinesToCart | Defines that processor that adds cart lines to a cart.


AddLinesToCart Class

AddLinesToCart Class
Defines that processor that adds cart lines to a cart.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.AddCartLinesAddLinesToCart

Namespace: Sitecore.Commerce.Pipelines.Carts.AddCartLines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddLinesToCart : PipelineProcessor<ServicePipelineArgs>
Public Class AddLinesToCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class AddLinesToCart : public PipelineProcessor<ServicePipelineArgs^>
type AddLinesToCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The AddLinesToCart type exposes the following members.

Constructors
 | Name | Description
Public method | AddLinesToCart | Initializes a new instance of the AddLinesToCart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the AddLinesToCart processor. The implementation of the Process method is generic, but you can use another implementation for the external commerce system. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.AddCartLines Namespace


AddLinesToCart Constructor

AddLinesToCart Constructor
Initializes a new instance of the AddLinesToCart class

Namespace: Sitecore.Commerce.Pipelines.Carts.AddCartLines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddLinesToCart()
Public Sub New
public:
AddLinesToCart()
new : unit -> AddLinesToCart
See Also

Reference

AddLinesToCart Class
Sitecore.Commerce.Pipelines.Carts.AddCartLines Namespace


AddLinesToCart Methods

AddLinesToCart Methods

The AddLinesToCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the AddLinesToCart processor. The implementation of the Process method is generic, but you can use another implementation for the external commerce system. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddLinesToCart Class
Sitecore.Commerce.Pipelines.Carts.AddCartLines Namespace


AddLinesToCart.Process Method

AddLinesToCartProcess Method
Executes the business logic of the AddLinesToCart processor. The implementation of the Process method is generic, but you can use another implementation for the external commerce system.

Namespace: Sitecore.Commerce.Pipelines.Carts.AddCartLines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
args: AddCartLinesRequest The AddcartLinesRequest request in args contains the cart to be updated and the lines to be added to the cart. The response contains the updated cart object after the pipeline is called.
See Also

Reference

AddLinesToCart Class
Sitecore.Commerce.Pipelines.Carts.AddCartLines Namespace


Sitecore.Commerce.Pipelines.Carts.AddParties Namespace

Sitecore.Commerce.Pipelines.Carts.AddParties Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.AddParties"]

Classes
 | Class | Description
Public class | AddPartiesToCart | Defines the AddParties class.


AddPartiesToCart Class

AddPartiesToCart Class
Defines the AddParties class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.AddPartiesAddPartiesToCart

Namespace: Sitecore.Commerce.Pipelines.Carts.AddParties
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddPartiesToCart : PipelineProcessor<ServicePipelineArgs>
Public Class AddPartiesToCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class AddPartiesToCart : public PipelineProcessor<ServicePipelineArgs^>
type AddPartiesToCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The AddPartiesToCart type exposes the following members.

Constructors
 | Name | Description
Public method | AddPartiesToCart | Initializes a new instance of the AddPartiesToCart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.AddParties Namespace


AddPartiesToCart Constructor

AddPartiesToCart Constructor
Initializes a new instance of the AddPartiesToCart class

Namespace: Sitecore.Commerce.Pipelines.Carts.AddParties
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddPartiesToCart()
Public Sub New
public:
AddPartiesToCart()
new : unit -> AddPartiesToCart
See Also

Reference

AddPartiesToCart Class
Sitecore.Commerce.Pipelines.Carts.AddParties Namespace


AddPartiesToCart Methods

AddPartiesToCart Methods

The AddPartiesToCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddPartiesToCart Class
Sitecore.Commerce.Pipelines.Carts.AddParties Namespace


AddPartiesToCart.Process Method

AddPartiesToCartProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Carts.AddParties
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

AddPartiesToCart Class
Sitecore.Commerce.Pipelines.Carts.AddParties Namespace


Sitecore.Commerce.Pipelines.Carts.AddPaymentInfo Namespace

Sitecore.Commerce.Pipelines.Carts.AddPaymentInfo Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.AddPaymentInfo"]

Classes
 | Class | Description
Public class | AddPaymentInfoToCart | Defines the AddPaymentInfoToCart processor.


AddPaymentInfoToCart Class

AddPaymentInfoToCart Class
Defines the AddPaymentInfoToCart processor.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.AddPaymentInfoAddPaymentInfoToCart

Namespace: Sitecore.Commerce.Pipelines.Carts.AddPaymentInfo
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddPaymentInfoToCart : PipelineProcessor<ServicePipelineArgs>
Public Class AddPaymentInfoToCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class AddPaymentInfoToCart : public PipelineProcessor<ServicePipelineArgs^>
type AddPaymentInfoToCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The AddPaymentInfoToCart type exposes the following members.

Constructors
 | Name | Description
Public method | AddPaymentInfoToCart | Initializes an instance of the AddPaymentInfoToCart class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidatePayment | Validates the payment and ensure the Party reference exists.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.AddPaymentInfo Namespace


AddPaymentInfoToCart Constructor

AddPaymentInfoToCart Constructor
Initializes an instance of the AddPaymentInfoToCart class.

Namespace: Sitecore.Commerce.Pipelines.Carts.AddPaymentInfo
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddPaymentInfoToCart(
    IEntityFactory entityFactory
)
Public Sub New (
    entityFactory As IEntityFactory
)
public:
AddPaymentInfoToCart(
    IEntityFactory^ entityFactory
)
new :
        entityFactory : IEntityFactory -> AddPaymentInfoToCart

Parameters

entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity type factory.
See Also

Reference

AddPaymentInfoToCart Class
Sitecore.Commerce.Pipelines.Carts.AddPaymentInfo Namespace


AddPaymentInfoToCart Methods

AddPaymentInfoToCart Methods

The AddPaymentInfoToCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidatePayment | Validates the payment and ensure the Party reference exists.
Top
See Also

Reference

AddPaymentInfoToCart Class
Sitecore.Commerce.Pipelines.Carts.AddPaymentInfo Namespace


AddPaymentInfoToCart.Process Method

AddPaymentInfoToCartProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Carts.AddPaymentInfo
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

AddPaymentInfoToCart Class
Sitecore.Commerce.Pipelines.Carts.AddPaymentInfo Namespace


AddPaymentInfoToCart.ValidatePayment Method

AddPaymentInfoToCartValidatePayment Method
Validates the payment and ensure the Party reference exists.

Namespace: Sitecore.Commerce.Pipelines.Carts.AddPaymentInfo
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual bool ValidatePayment(
    Cart cart,
    PaymentInfo payment
)
Protected Overridable Function ValidatePayment (
    cart As Cart,
    payment As PaymentInfo
) As Boolean
protected:
virtual bool ValidatePayment(
    Cart^ cart,
    PaymentInfo^ payment
)
abstract ValidatePayment :
        cart : Cart *
        payment : PaymentInfo -> bool
override ValidatePayment :
        cart : Cart *
        payment : PaymentInfo -> bool

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
payment
Type: Sitecore.Commerce.Entities.CartsPaymentInfo
The payment.

Return Value

Type: Boolean
True if the party reference exists, otherwise false.
See Also

Reference

AddPaymentInfoToCart Class
Sitecore.Commerce.Pipelines.Carts.AddPaymentInfo Namespace


Sitecore.Commerce.Pipelines.Carts.AddShippingInfo Namespace

Sitecore.Commerce.Pipelines.Carts.AddShippingInfo Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.AddShippingInfo"]

Classes
 | Class | Description
Public class | AddShippingInfoToCart | Defines the AddShippingInfoToCart processor.


AddShippingInfoToCart Class

AddShippingInfoToCart Class
Defines the AddShippingInfoToCart processor.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.AddShippingInfoAddShippingInfoToCart

Namespace: Sitecore.Commerce.Pipelines.Carts.AddShippingInfo
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddShippingInfoToCart : PipelineProcessor<ServicePipelineArgs>
Public Class AddShippingInfoToCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class AddShippingInfoToCart : public PipelineProcessor<ServicePipelineArgs^>
type AddShippingInfoToCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The AddShippingInfoToCart type exposes the following members.

Constructors
 | Name | Description
Public method | AddShippingInfoToCart | Initializes an instance of the AddShippingInfoToCart class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateShipping | Validates the payment and ensure the Party reference exists.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.AddShippingInfo Namespace


AddShippingInfoToCart Constructor

AddShippingInfoToCart Constructor
Initializes an instance of the AddShippingInfoToCart class.

Namespace: Sitecore.Commerce.Pipelines.Carts.AddShippingInfo
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddShippingInfoToCart(
    IEntityFactory entityFactory
)
Public Sub New (
    entityFactory As IEntityFactory
)
public:
AddShippingInfoToCart(
    IEntityFactory^ entityFactory
)
new :
        entityFactory : IEntityFactory -> AddShippingInfoToCart

Parameters

entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity type factory.
See Also

Reference

AddShippingInfoToCart Class
Sitecore.Commerce.Pipelines.Carts.AddShippingInfo Namespace


AddShippingInfoToCart Methods

AddShippingInfoToCart Methods

The AddShippingInfoToCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateShipping | Validates the payment and ensure the Party reference exists.
Top
See Also

Reference

AddShippingInfoToCart Class
Sitecore.Commerce.Pipelines.Carts.AddShippingInfo Namespace


AddShippingInfoToCart.Process Method

AddShippingInfoToCartProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Carts.AddShippingInfo
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

AddShippingInfoToCart Class
Sitecore.Commerce.Pipelines.Carts.AddShippingInfo Namespace


AddShippingInfoToCart.ValidateShipping Method

AddShippingInfoToCartValidateShipping Method
Validates the payment and ensure the Party reference exists.

Namespace: Sitecore.Commerce.Pipelines.Carts.AddShippingInfo
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual bool ValidateShipping(
    Cart cart,
    ShippingInfo shipping
)
Protected Overridable Function ValidateShipping (
    cart As Cart,
    shipping As ShippingInfo
) As Boolean
protected:
virtual bool ValidateShipping(
    Cart^ cart,
    ShippingInfo^ shipping
)
abstract ValidateShipping :
        cart : Cart *
        shipping : ShippingInfo -> bool
override ValidateShipping :
        cart : Cart *
        shipping : ShippingInfo -> bool

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
shipping
Type: Sitecore.Commerce.Entities.CartsShippingInfo
The payment.

Return Value

Type: Boolean
True if the party reference exists, otherwise false.
See Also

Reference

AddShippingInfoToCart Class
Sitecore.Commerce.Pipelines.Carts.AddShippingInfo Namespace


Sitecore.Commerce.Pipelines.Carts.Common Namespace

Sitecore.Commerce.Pipelines.Carts.Common Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.Common"]

Classes
Class Description
Public class CartPipelineProcessor
Base class for cart related pipeline processors.
Public class CheckIfLocked
Defines the processor that checks whether the cart is locked. If the cart is locked, the CheckIfLocked stops the pipeline. This processor returns an SystemMessages object to indicate the locked status. This processor is generic and all the pipelines that modify the cart content must use it. This processor is used by the following pipelines:
  • AddCartLines
  • RemoveCartLines
  • UpdateCartLines
  • DeleteCart
  • UpdateCart
Public class RunSaveCart
Defines the processor that executes the SaveCart pipeline. The RunSaveCart processor is called when changes are made to the cart. This processor is used by the following pipelines:
  • CreateCart
  • ResumeCart
  • AddCartLines
  • UpdateCart
  • LockCart
  • UnlockCart
Public class SaveCartToEaState
Defines the processor that saves the cart data in the repository of the Automation states. You can use this processor as follows:
  • If the external commerce system does not persist carts or if the handling of the carts is entirely executed in Sitecore, you can use this processor separately in the SaveCart pipeline.
  • If Sitecore recognizes the visitor, the visitor can load and resume using the cart that is stored in the repository of the Automation states.
  • If the external commerce system does not support all the information specified in the cart's domain model. The main data is written to the external commerce system and this processor writes the remaining data to the repository.
This processor is used by the SaveCart pipeline.
Public class TriggerCartLinesPageEvent
Defines the processor that triggers the page events when adding cart lines. The TriggerPageEventsForCartLines process is used by the following pipelines:
  • AddCartLines
  • RemoveCartLines
  • UpdateCartLines
The TriggerCartLinesPageEvent processor also registers the following values for a cart line:
  • The Product ID
  • The quantity
  • The price
  • The currency
The base class reads the name and text of the event. The specialized processor, in addition, adds information about the product ID, Quantity and Price to the event data.
Public class TriggerCartPageEvent
Defines the processor that triggers the page events for a cart. This class implements the TriggerPageEvent class.


CartPipelineProcessor Class

CartPipelineProcessor Class
Base class for cart related pipeline processors.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.CommonCartPipelineProcessor
Sitecore.Commerce.Pipelines.Carts.GetCartsExecuteQuery
Sitecore.Commerce.Pipelines.Carts.LoadCartLoadCartFromEaState

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class CartPipelineProcessor : PipelineProcessor<ServicePipelineArgs>
Public MustInherit Class CartPipelineProcessor
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class CartPipelineProcessor abstract : public PipelineProcessor<ServicePipelineArgs^>
[<AbstractClassAttribute>]
type CartPipelineProcessor =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The CartPipelineProcessor type exposes the following members.

Constructors
 | Name | Description
Protected method | CartPipelineProcessor | Initializes a new instance of the CartPipelineProcessor class
Top
Methods
 | Name | Description
Protected method | CombineCart | Combines the cart.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Inherited from PipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.Common Namespace


CartPipelineProcessor Constructor

CartPipelineProcessor Constructor
Initializes a new instance of the CartPipelineProcessor class

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected CartPipelineProcessor()
Protected Sub New
protected:
CartPipelineProcessor()
new : unit -> CartPipelineProcessor
See Also

Reference

CartPipelineProcessor Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


CartPipelineProcessor Methods

CartPipelineProcessor Methods

The CartPipelineProcessor type exposes the following members.

Methods
 | Name | Description
Protected method | CombineCart | Combines the cart.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Inherited from PipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CartPipelineProcessor Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


CartPipelineProcessor.CombineCart Method

CartPipelineProcessorCombineCart Method
Combines the cart.

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void CombineCart(
    CartBase externalSystemCart,
    CartBase engagementPlanCart
)
Protected Overridable Sub CombineCart (
    externalSystemCart As CartBase,
    engagementPlanCart As CartBase
)
protected:
virtual void CombineCart(
    CartBase^ externalSystemCart,
    CartBase^ engagementPlanCart
)
abstract CombineCart :
        externalSystemCart : CartBase *
        engagementPlanCart : CartBase -> unit
override CombineCart :
        externalSystemCart : CartBase *
        engagementPlanCart : CartBase -> unit

Parameters

externalSystemCart
Type: Sitecore.Commerce.Entities.CartsCartBase
The external system cart.
engagementPlanCart
Type: Sitecore.Commerce.Entities.CartsCartBase
The engagement plan cart.
See Also

Reference

CartPipelineProcessor Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


CheckIfLocked Class

CheckIfLocked Class
Defines the processor that checks whether the cart is locked. If the cart is locked, the CheckIfLocked stops the pipeline. This processor returns an SystemMessages object to indicate the locked status. This processor is generic and all the pipelines that modify the cart content must use it. This processor is used by the following pipelines:
  • AddCartLines
  • RemoveCartLines
  • UpdateCartLines
  • DeleteCart
  • UpdateCart
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.CommonCheckIfLocked

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CheckIfLocked : PipelineProcessor<ServicePipelineArgs>
Public Class CheckIfLocked
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class CheckIfLocked : public PipelineProcessor<ServicePipelineArgs^>
type CheckIfLocked =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The CheckIfLocked type exposes the following members.

Constructors
 | Name | Description
Public method | CheckIfLocked | Initializes an instance of the CheckIfLocked class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the CheckIfLocked processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.Common Namespace


CheckIfLocked Constructor

CheckIfLocked Constructor
Initializes an instance of the CheckIfLocked class.

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CheckIfLocked(
    IEntityFactory entityFactory
)
Public Sub New (
    entityFactory As IEntityFactory
)
public:
CheckIfLocked(
    IEntityFactory^ entityFactory
)
new :
        entityFactory : IEntityFactory -> CheckIfLocked

Parameters

entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity type factory.
See Also

Reference

CheckIfLocked Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


CheckIfLocked Methods

CheckIfLocked Methods

The CheckIfLocked type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the CheckIfLocked processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CheckIfLocked Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


CheckIfLocked.Process Method

CheckIfLockedProcess Method
Executes the business logic of the CheckIfLocked processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
args: LockCartRequest
See Also

Reference

CheckIfLocked Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


RunSaveCart Class

RunSaveCart Class
Defines the processor that executes the SaveCart pipeline. The RunSaveCart processor is called when changes are made to the cart. This processor is used by the following pipelines:
  • CreateCart
  • ResumeCart
  • AddCartLines
  • UpdateCart
  • LockCart
  • UnlockCart
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.CommonRunSaveCart

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSaveCart : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSaveCart
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSaveCart : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSaveCart =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSaveCart type exposes the following members.

Constructors
 | Name | Description
Public method | RunSaveCart | Initializes a new instance of the RunSaveCart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSaveCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.Common Namespace


RunSaveCart Constructor

RunSaveCart Constructor
Initializes a new instance of the RunSaveCart class

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSaveCart()
Public Sub New
public:
RunSaveCart()
new : unit -> RunSaveCart
See Also

Reference

RunSaveCart Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


RunSaveCart Methods

RunSaveCart Methods

The RunSaveCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSaveCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSaveCart Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


RunSaveCart.Process Method

RunSaveCartProcess Method
Executes the business logic of the RunSaveCart processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args: CreateOrResumeCartRequest
See Also

Reference

RunSaveCart Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


RunSaveCart Properties

RunSaveCart Properties

The RunSaveCart type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSaveCart Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


SaveCartToEaState Class

SaveCartToEaState Class
Defines the processor that saves the cart data in the repository of the Automation states. You can use this processor as follows:
  • If the external commerce system does not persist carts or if the handling of the carts is entirely executed in Sitecore, you can use this processor separately in the SaveCart pipeline.
  • If Sitecore recognizes the visitor, the visitor can load and resume using the cart that is stored in the repository of the Automation states.
  • If the external commerce system does not support all the information specified in the cart's domain model. The main data is written to the external commerce system and this processor writes the remaining data to the repository.
This processor is used by the SaveCart pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.CommonSaveCartToEaState

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveCartToEaState : PipelineProcessor<ServicePipelineArgs>
Public Class SaveCartToEaState
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveCartToEaState : public PipelineProcessor<ServicePipelineArgs^>
type SaveCartToEaState =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveCartToEaState type exposes the following members.

Constructors
 | Name | Description
Public method | SaveCartToEaState | Initializes an instance of the SaveCartToEaState class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveCartToEaSate processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.Common Namespace


SaveCartToEaState Constructor

SaveCartToEaState Constructor
Initializes an instance of the SaveCartToEaState class.

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveCartToEaState(
    ICartRepository repository
)
Public Sub New (
    repository As ICartRepository
)
public:
SaveCartToEaState(
    ICartRepository^ repository
)
new :
        repository : ICartRepository -> SaveCartToEaState

Parameters

repository
Type: Sitecore.Commerce.Data.CartsICartRepository
The repository that stores and places carts in an Engagement Automation state. The repository name is specified in the Sitecore.Commerce.config file.
See Also

Reference

SaveCartToEaState Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


SaveCartToEaState Methods

SaveCartToEaState Methods

The SaveCartToEaState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveCartToEaSate processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveCartToEaState Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


SaveCartToEaState.Process Method

SaveCartToEaStateProcess Method
Executes the business logic of the SaveCartToEaSate processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

SaveCartToEaState Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


TriggerCartLinesPageEvent Class

TriggerCartLinesPageEvent Class
Defines the processor that triggers the page events when adding cart lines. The TriggerPageEventsForCartLines process is used by the following pipelines:
  • AddCartLines
  • RemoveCartLines
  • UpdateCartLines
The TriggerCartLinesPageEvent processor also registers the following values for a cart line:
  • The Product ID
  • The quantity
  • The price
  • The currency
The base class reads the name and text of the event. The specialized processor, in addition, adds information about the product ID, Quantity and Price to the event data.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Carts.CommonTriggerCartLinesPageEvent

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerCartLinesPageEvent : TriggerPageEvent
Public Class TriggerCartLinesPageEvent
    Inherits TriggerPageEvent
public ref class TriggerCartLinesPageEvent : public TriggerPageEvent
type TriggerCartLinesPageEvent =
    class
        inherit TriggerPageEvent
    end

The TriggerCartLinesPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerCartLinesPageEvent | Initializes a new instance of the TriggerCartLinesPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.Common Namespace


TriggerCartLinesPageEvent Constructor

TriggerCartLinesPageEvent Constructor
Initializes a new instance of the TriggerCartLinesPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerCartLinesPageEvent()
Public Sub New
public:
TriggerCartLinesPageEvent()
new : unit -> TriggerCartLinesPageEvent
See Also

Reference

TriggerCartLinesPageEvent Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


TriggerCartLinesPageEvent Methods

TriggerCartLinesPageEvent Methods

The TriggerCartLinesPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerCartLinesPageEvent Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


TriggerCartLinesPageEvent.GetPageEventData Method

TriggerCartLinesPageEventGetPageEventData Method
Gets the page event data.

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetPageEventData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventData (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventData :
        args : ServicePipelineArgs -> string
override GetPageEventData :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
The page event data.
See Also

Reference

TriggerCartLinesPageEvent Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


TriggerCartLinesPageEvent Properties

TriggerCartLinesPageEvent Properties

The TriggerCartLinesPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerCartLinesPageEvent Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


TriggerCartPageEvent Class

TriggerCartPageEvent Class
Defines the processor that triggers the page events for a cart. This class implements the TriggerPageEvent class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Carts.CommonTriggerCartPageEvent
Sitecore.Commerce.Pipelines.Carts.CreateCartTriggerCartCreatedPageEvent
Sitecore.Commerce.Pipelines.Carts.ResumeCartTriggerCartResumedPageEvent
Sitecore.Commerce.Pipelines.Carts.UpdateCartTriggerCartUpdatedPageEvent

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerCartPageEvent : TriggerPageEvent
Public Class TriggerCartPageEvent
    Inherits TriggerPageEvent
public ref class TriggerCartPageEvent : public TriggerPageEvent
type TriggerCartPageEvent =
    class
        inherit TriggerPageEvent
    end

The TriggerCartPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerCartPageEvent | Initializes a new instance of the TriggerCartPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractCartData | Extracts the cart data and returns the data in a dictionary.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartFromArgs | Gets the cart from args.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data value from arguments. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.Common Namespace


TriggerCartPageEvent Constructor

TriggerCartPageEvent Constructor
Initializes a new instance of the TriggerCartPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerCartPageEvent()
Public Sub New
public:
TriggerCartPageEvent()
new : unit -> TriggerCartPageEvent
See Also

Reference

TriggerCartPageEvent Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


TriggerCartPageEvent Methods

TriggerCartPageEvent Methods

The TriggerCartPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractCartData | Extracts the cart data and returns the data in a dictionary.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartFromArgs | Gets the cart from args.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data value from arguments. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerCartPageEvent Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


TriggerCartPageEvent.ExtractCartData Method

TriggerCartPageEventExtractCartData Method
Extracts the cart data and returns the data in a dictionary.

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual IDictionary<string, string> ExtractCartData(
    CartBase cart
)
Protected Overridable Function ExtractCartData (
    cart As CartBase
) As IDictionary(Of String, String)
protected:
virtual IDictionary<String^, String^>^ ExtractCartData(
    CartBase^ cart
)
abstract ExtractCartData :
        cart : CartBase -> IDictionary<string, string>
override ExtractCartData :
        cart : CartBase -> IDictionary<string, string>

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCartBase
The cart.

Return Value

Type: IDictionary String, String
The dictionary with the required cart fields only.
See Also

Reference

TriggerCartPageEvent Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


TriggerCartPageEvent.GetCartFromArgs Method

TriggerCartPageEventGetCartFromArgs Method
Gets the cart from args.

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual CartBase GetCartFromArgs(
    ServicePipelineArgs args
)
Protected Overridable Function GetCartFromArgs (
    args As ServicePipelineArgs
) As CartBase
protected:
virtual CartBase^ GetCartFromArgs(
    ServicePipelineArgs^ args
)
abstract GetCartFromArgs :
        args : ServicePipelineArgs -> CartBase
override GetCartFromArgs :
        args : ServicePipelineArgs -> CartBase

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args

Return Value

Type: CartBase
The cart in the args parameter
See Also

Reference

TriggerCartPageEvent Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


TriggerCartPageEvent.GetPageEventData Method

TriggerCartPageEventGetPageEventData Method
Gets the page event data value from arguments.

Namespace: Sitecore.Commerce.Pipelines.Carts.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetPageEventData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventData (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventData :
        args : ServicePipelineArgs -> string
override GetPageEventData :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
Date for the specified arguments.
See Also

Reference

TriggerCartPageEvent Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


TriggerCartPageEvent Properties

TriggerCartPageEvent Properties

The TriggerCartPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerCartPageEvent Class
Sitecore.Commerce.Pipelines.Carts.Common Namespace


Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace

Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.CreateCart"]

Classes
 | Class | Description
Public class | AddVisitorToEaPlan | Defines the processor that enrolls visitors in the Engagement Automation (EA) plan. This processor adds the current visitor to an EA plan, for example, the Abandoned Cart EA plan. The current implementation supports multiple shops. You can use an IEaPlanProvider object to retrieve the plan and state IDs.
Public class | CreateCart | Defines the processor that creates a cart, initializes the values in it using the arguments, and returns it. If a cart with the same values already exists, the processor overwrites it. The default CreateCart processor is generic for creating a cart using the domain model and not the the external commerce system. In some integration scenarios, you must use the the external commerce system to create the cart. In this case, you can extend the CreateCart processor base class or replace it with another class. In other integration scenarios, the external commerce system does not create carts but rather manipulates cart lines or just saves carts. The implementation of the cart creation depends on the external commerce system that Sitecore is being integrated with.
Public class | TriggerCartCreatedPageEvent | Triggers the page events for the created cart.


AddVisitorToEaPlan Class

AddVisitorToEaPlan Class
Defines the processor that enrolls visitors in the Engagement Automation (EA) plan. This processor adds the current visitor to an EA plan, for example, the Abandoned Cart EA plan. The current implementation supports multiple shops. You can use an IEaPlanProvider object to retrieve the plan and state IDs.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.CreateCartAddVisitorToEaPlan

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddVisitorToEaPlan : PipelineProcessor<ServicePipelineArgs>
Public Class AddVisitorToEaPlan
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class AddVisitorToEaPlan : public PipelineProcessor<ServicePipelineArgs^>
type AddVisitorToEaPlan =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The AddVisitorToEaPlan type exposes the following members.

Constructors
 | Name | Description
Public method | AddVisitorToEaPlan | Initializes an instance of the AddVisitorToEaPlan class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the AddVisitorToPlan processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace


AddVisitorToEaPlan Constructor

AddVisitorToEaPlan Constructor
Initializes an instance of the AddVisitorToEaPlan class.

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddVisitorToEaPlan(
    IEaPlanProvider eaPlanProvider
)
Public Sub New (
    eaPlanProvider As IEaPlanProvider
)
public:
AddVisitorToEaPlan(
    IEaPlanProvider^ eaPlanProvider
)
new :
        eaPlanProvider : IEaPlanProvider -> AddVisitorToEaPlan

Parameters

eaPlanProvider
Type: Sitecore.Commerce.MultishopIEaPlanProvider
The Engagement Automation Plan provider.
See Also

Reference

AddVisitorToEaPlan Class
Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace


AddVisitorToEaPlan Methods

AddVisitorToEaPlan Methods

The AddVisitorToEaPlan type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the AddVisitorToPlan processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddVisitorToEaPlan Class
Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace


AddVisitorToEaPlan.Process Method

AddVisitorToEaPlanProcess Method
Executes the business logic of the AddVisitorToPlan processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

AddVisitorToEaPlan Class
Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace


CreateCart Class

CreateCart Class
Defines the processor that creates a cart, initializes the values in it using the arguments, and returns it. If a cart with the same values already exists, the processor overwrites it. The default CreateCart processor is generic for creating a cart using the domain model and not the the external commerce system. In some integration scenarios, you must use the the external commerce system to create the cart. In this case, you can extend the CreateCart processor base class or replace it with another class. In other integration scenarios, the external commerce system does not create carts but rather manipulates cart lines or just saves carts. The implementation of the cart creation depends on the external commerce system that Sitecore is being integrated with.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.CreateCartCreateCart

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CreateCart : PipelineProcessor<ServicePipelineArgs>
Public Class CreateCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class CreateCart : public PipelineProcessor<ServicePipelineArgs^>
type CreateCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The CreateCart type exposes the following members.

Constructors
 | Name | Description
Public method | CreateCart | Initializes an instance of the CreateCart class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the CreateCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace


CreateCart Constructor

CreateCart Constructor
Initializes an instance of the CreateCart class.

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CreateCart(
    IEntityFactory entityFactory
)
Public Sub New (
    entityFactory As IEntityFactory
)
public:
CreateCart(
    IEntityFactory^ entityFactory
)
new :
        entityFactory : IEntityFactory -> CreateCart

Parameters

entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity type factory.
See Also

Reference

CreateCart Class
Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace


CreateCart Methods

CreateCart Methods

The CreateCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the CreateCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateCart Class
Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace


CreateCart.Process Method

CreateCartProcess Method
Executes the business logic of the CreateCart processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

CreateCart Class
Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace


TriggerCartCreatedPageEvent Class

TriggerCartCreatedPageEvent Class
Triggers the page events for the created cart.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Carts.CommonTriggerCartPageEvent
Sitecore.Commerce.Pipelines.Carts.CreateCartTriggerCartCreatedPageEvent

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerCartCreatedPageEvent : TriggerCartPageEvent
Public Class TriggerCartCreatedPageEvent
    Inherits TriggerCartPageEvent
public ref class TriggerCartCreatedPageEvent : public TriggerCartPageEvent
type TriggerCartCreatedPageEvent =
    class
        inherit TriggerCartPageEvent
    end

The TriggerCartCreatedPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerCartCreatedPageEvent | Initializes a new instance of the TriggerCartCreatedPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractCartData | Extracts the cart data and returns the data in a dictionary. (Inherited from TriggerCartPageEvent.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartFromArgs | Gets the cart from args. (Overrides TriggerCartPageEventGetCartFromArgs(ServicePipelineArgs).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data value from arguments. (Inherited from TriggerCartPageEvent.)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace


TriggerCartCreatedPageEvent Constructor

TriggerCartCreatedPageEvent Constructor
Initializes a new instance of the TriggerCartCreatedPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerCartCreatedPageEvent()
Public Sub New
public:
TriggerCartCreatedPageEvent()
new : unit -> TriggerCartCreatedPageEvent
See Also

Reference

TriggerCartCreatedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace


TriggerCartCreatedPageEvent Methods

TriggerCartCreatedPageEvent Methods

The TriggerCartCreatedPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractCartData | Extracts the cart data and returns the data in a dictionary. (Inherited from TriggerCartPageEvent.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartFromArgs | Gets the cart from args. (Overrides TriggerCartPageEventGetCartFromArgs(ServicePipelineArgs).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data value from arguments. (Inherited from TriggerCartPageEvent.)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerCartCreatedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace


TriggerCartCreatedPageEvent.GetCartFromArgs Method

TriggerCartCreatedPageEventGetCartFromArgs Method
Gets the cart from args.

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override CartBase GetCartFromArgs(
    ServicePipelineArgs args
)
Protected Overrides Function GetCartFromArgs (
    args As ServicePipelineArgs
) As CartBase
protected:
virtual CartBase^ GetCartFromArgs(
    ServicePipelineArgs^ args
) override
abstract GetCartFromArgs :
        args : ServicePipelineArgs -> CartBase
override GetCartFromArgs :
        args : ServicePipelineArgs -> CartBase

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.

Return Value

Type: CartBase
The cart that is read from the arguments.
See Also

Reference

TriggerCartCreatedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace


TriggerCartCreatedPageEvent Properties

TriggerCartCreatedPageEvent Properties

The TriggerCartCreatedPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerCartCreatedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.CreateCart Namespace


Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace

Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart"]

Classes
Class Description
Public class FindCartInEaState
Searches for a visitor cart in its current Engagement Automation (EA) state with the following input parameters:
  • UserID
  • CustomerID
  • CartName
  • ShopName
If a matching cart is found, the custom pipeline argument args.Request.Properties[“CartID”] is assigned to the the ID of the matching cart. In the CreateOrResumeCart pipeline, the RunLoadCart processor uses the cart ID stored in the custom data. You can use the FindCartInEaState processor to search and retrieve the ID of an existing cart before executing the RunLoadCart processor.
Public class RunCreateCart
Defines the processor that executes the Sitecore.Commerce.Pipelines.Carts.CreateCart pipeline.
Public class RunLoadCart
Defines the processor that executes the Sitecore.Commerce.Pipelines.Carts.LoadCart pipeline. The cart ID is stored in custom data by the FindCartInEaState processor.
Public class RunResumeCart
Defines the processor that executes the Sitecore.Commerce.Pipelines.Carts.ResumeCart pipeline.


FindCartInEaState Class

FindCartInEaState Class
Searches for a visitor cart in its current Engagement Automation (EA) state with the following input parameters:
  • UserID
  • CustomerID
  • CartName
  • ShopName
If a matching cart is found, the custom pipeline argument args.Request.Properties[“CartID”] is assigned to the the ID of the matching cart. In the CreateOrResumeCart pipeline, the RunLoadCart processor uses the cart ID stored in the custom data. You can use the FindCartInEaState processor to search and retrieve the ID of an existing cart before executing the RunLoadCart processor.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCartFindCartInEaState

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class FindCartInEaState : PipelineProcessor<ServicePipelineArgs>
Public Class FindCartInEaState
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class FindCartInEaState : public PipelineProcessor<ServicePipelineArgs^>
type FindCartInEaState =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The FindCartInEaState type exposes the following members.

Constructors
 | Name | Description
Public method | FindCartInEaState | Initializes an instance of the FindCartInEaState class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the FindCartInEaState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


FindCartInEaState Constructor

FindCartInEaState Constructor
Initializes an instance of the FindCartInEaState class.

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public FindCartInEaState(
    ICartRepository repository
)
Public Sub New (
    repository As ICartRepository
)
public:
FindCartInEaState(
    ICartRepository^ repository
)
new :
        repository : ICartRepository -> FindCartInEaState

Parameters

repository
Type: Sitecore.Commerce.Data.CartsICartRepository
The repository.
See Also

Reference

FindCartInEaState Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


FindCartInEaState Methods

FindCartInEaState Methods

The FindCartInEaState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the FindCartInEaState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FindCartInEaState Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


FindCartInEaState.Process Method

FindCartInEaStateProcess Method
Executes the business logic of the FindCartInEaState processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

FindCartInEaState Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunCreateCart Class

RunCreateCart Class
Defines the processor that executes the Sitecore.Commerce.Pipelines.Carts.CreateCart pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCartRunCreateCart

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunCreateCart : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunCreateCart
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunCreateCart : public RunPipelineProcessor<ServicePipelineArgs^>
type RunCreateCart =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunCreateCart type exposes the following members.

Constructors
 | Name | Description
Public method | RunCreateCart | Initializes a new instance of the RunCreateCart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunCreateCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunCreateCart Constructor

RunCreateCart Constructor
Initializes a new instance of the RunCreateCart class

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunCreateCart()
Public Sub New
public:
RunCreateCart()
new : unit -> RunCreateCart
See Also

Reference

RunCreateCart Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunCreateCart Methods

RunCreateCart Methods

The RunCreateCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunCreateCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunCreateCart Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunCreateCart.Process Method

RunCreateCartProcess Method
Executes the business logic of the RunCreateCart processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

RunCreateCart Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunCreateCart Properties

RunCreateCart Properties

The RunCreateCart type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunCreateCart Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunLoadCart Class

RunLoadCart Class
Defines the processor that executes the Sitecore.Commerce.Pipelines.Carts.LoadCart pipeline. The cart ID is stored in custom data by the FindCartInEaState processor.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCartRunLoadCart

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunLoadCart : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunLoadCart
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunLoadCart : public RunPipelineProcessor<ServicePipelineArgs^>
type RunLoadCart =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunLoadCart type exposes the following members.

Constructors
 | Name | Description
Public method | RunLoadCart | Initializes a new instance of the RunLoadCart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunLoadCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunLoadCart Constructor

RunLoadCart Constructor
Initializes a new instance of the RunLoadCart class

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunLoadCart()
Public Sub New
public:
RunLoadCart()
new : unit -> RunLoadCart
See Also

Reference

RunLoadCart Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunLoadCart Methods

RunLoadCart Methods

The RunLoadCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunLoadCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunLoadCart Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunLoadCart.Process Method

RunLoadCartProcess Method
Executes the business logic of the RunLoadCart processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

RunLoadCart Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunLoadCart Properties

RunLoadCart Properties

The RunLoadCart type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunLoadCart Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunResumeCart Class

RunResumeCart Class
Defines the processor that executes the Sitecore.Commerce.Pipelines.Carts.ResumeCart pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCartRunResumeCart

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunResumeCart : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunResumeCart
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunResumeCart : public RunPipelineProcessor<ServicePipelineArgs^>
type RunResumeCart =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunResumeCart type exposes the following members.

Constructors
 | Name | Description
Public method | RunResumeCart | Initializes a new instance of the RunResumeCart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunResumeCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunResumeCart Constructor

RunResumeCart Constructor
Initializes a new instance of the RunResumeCart class

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunResumeCart()
Public Sub New
public:
RunResumeCart()
new : unit -> RunResumeCart
See Also

Reference

RunResumeCart Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunResumeCart Methods

RunResumeCart Methods

The RunResumeCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunResumeCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunResumeCart Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunResumeCart.Process Method

RunResumeCartProcess Method
Executes the business logic of the RunResumeCart processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

RunResumeCart Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


RunResumeCart Properties

RunResumeCart Properties

The RunResumeCart type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunResumeCart Class
Sitecore.Commerce.Pipelines.Carts.CreateOrResumeCart Namespace


Sitecore.Commerce.Pipelines.Carts.DeleteCart Namespace

Sitecore.Commerce.Pipelines.Carts.DeleteCart Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.DeleteCart"]

Classes
 | Class | Description
Public class | DeleteCartFromEaState | Defines the processor that locates and deletes a cart from the repository of the Engagement Automation states. This processor is used by the DeleteCart pipeline.


DeleteCartFromEaState Class

DeleteCartFromEaState Class
Defines the processor that locates and deletes a cart from the repository of the Engagement Automation states. This processor is used by the DeleteCart pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.DeleteCartDeleteCartFromEaState

Namespace: Sitecore.Commerce.Pipelines.Carts.DeleteCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DeleteCartFromEaState : PipelineProcessor<ServicePipelineArgs>
Public Class DeleteCartFromEaState
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class DeleteCartFromEaState : public PipelineProcessor<ServicePipelineArgs^>
type DeleteCartFromEaState =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The DeleteCartFromEaState type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteCartFromEaState | Initializes an instance of the DeleteCartFromEaState class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DeleteCartFromEAState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.DeleteCart Namespace


DeleteCartFromEaState Constructor

DeleteCartFromEaState Constructor
Initializes an instance of the DeleteCartFromEaState class.

Namespace: Sitecore.Commerce.Pipelines.Carts.DeleteCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DeleteCartFromEaState(
    ICartRepository repository
)
Public Sub New (
    repository As ICartRepository
)
public:
DeleteCartFromEaState(
    ICartRepository^ repository
)
new :
        repository : ICartRepository -> DeleteCartFromEaState

Parameters

repository
Type: Sitecore.Commerce.Data.CartsICartRepository
The repository.
See Also

Reference

DeleteCartFromEaState Class
Sitecore.Commerce.Pipelines.Carts.DeleteCart Namespace


DeleteCartFromEaState Methods

DeleteCartFromEaState Methods

The DeleteCartFromEaState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DeleteCartFromEAState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteCartFromEaState Class
Sitecore.Commerce.Pipelines.Carts.DeleteCart Namespace


DeleteCartFromEaState.Process Method

DeleteCartFromEaStateProcess Method
Executes the business logic of the DeleteCartFromEAState processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.DeleteCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

DeleteCartFromEaState Class
Sitecore.Commerce.Pipelines.Carts.DeleteCart Namespace


Sitecore.Commerce.Pipelines.Carts.GetCarts Namespace

Sitecore.Commerce.Pipelines.Carts.GetCarts Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.GetCarts"]

Classes
 | Class | Description
Public class | BuildQuery | Defines the processor that executes the first phase of the GetCarts pipeline. This processor creates the query that the ExecuteQuery processor uses to load carts.
Public class | ExecuteQuery | Defines the processor that executes the second phase of the GetCarts pipeline. This processor runs the query that the BuildQuery processor has created.


BuildQuery Class

BuildQuery Class
Defines the processor that executes the first phase of the GetCarts pipeline. This processor creates the query that the ExecuteQuery processor uses to load carts.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.GetCartsBuildQuery

Namespace: Sitecore.Commerce.Pipelines.Carts.GetCarts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class BuildQuery : PipelineProcessor<ServicePipelineArgs>
Public Class BuildQuery
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class BuildQuery : public PipelineProcessor<ServicePipelineArgs^>
type BuildQuery =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The BuildQuery type exposes the following members.

Constructors
 | Name | Description
Public method | BuildQuery | Initializes a new instance of the BuildQuery class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the BuildQuery processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.GetCarts Namespace


BuildQuery Constructor

BuildQuery Constructor
Initializes a new instance of the BuildQuery class

Namespace: Sitecore.Commerce.Pipelines.Carts.GetCarts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public BuildQuery()
Public Sub New
public:
BuildQuery()
new : unit -> BuildQuery
See Also

Reference

BuildQuery Class
Sitecore.Commerce.Pipelines.Carts.GetCarts Namespace


BuildQuery Methods

BuildQuery Methods

The BuildQuery type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the BuildQuery processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BuildQuery Class
Sitecore.Commerce.Pipelines.Carts.GetCarts Namespace


BuildQuery.Process Method

BuildQueryProcess Method
Executes the business logic of the BuildQuery processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.GetCarts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

BuildQuery Class
Sitecore.Commerce.Pipelines.Carts.GetCarts Namespace


ExecuteQuery Class

ExecuteQuery Class
Defines the processor that executes the second phase of the GetCarts pipeline. This processor runs the query that the BuildQuery processor has created.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.CommonCartPipelineProcessor
Sitecore.Commerce.Pipelines.Carts.GetCartsExecuteQuery

Namespace: Sitecore.Commerce.Pipelines.Carts.GetCarts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ExecuteQuery : CartPipelineProcessor
Public Class ExecuteQuery
    Inherits CartPipelineProcessor
public ref class ExecuteQuery : public CartPipelineProcessor
type ExecuteQuery =
    class
        inherit CartPipelineProcessor
    end

The ExecuteQuery type exposes the following members.

Constructors
 | Name | Description
Public method | ExecuteQuery | Initializes an instance of the ExecuteQuery class.
Top
Methods
 | Name | Description
Protected method | CombineCart | Combines the cart. (Inherited from CartPipelineProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ExecuteQuery processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.GetCarts Namespace


ExecuteQuery Constructor

ExecuteQuery Constructor
Initializes an instance of the ExecuteQuery class.

Namespace: Sitecore.Commerce.Pipelines.Carts.GetCarts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ExecuteQuery(
    ICartRepository repository
)
Public Sub New (
    repository As ICartRepository
)
public:
ExecuteQuery(
    ICartRepository^ repository
)
new :
        repository : ICartRepository -> ExecuteQuery

Parameters

repository
Type: Sitecore.Commerce.Data.CartsICartRepository
The repository.
See Also

Reference

ExecuteQuery Class
Sitecore.Commerce.Pipelines.Carts.GetCarts Namespace


ExecuteQuery Methods

ExecuteQuery Methods

The ExecuteQuery type exposes the following members.

Methods
 | Name | Description
Protected method | CombineCart | Combines the cart. (Inherited from CartPipelineProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ExecuteQuery processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExecuteQuery Class
Sitecore.Commerce.Pipelines.Carts.GetCarts Namespace


ExecuteQuery.Process Method

ExecuteQueryProcess Method
Executes the business logic of the ExecuteQuery processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.GetCarts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

ExecuteQuery Class
Sitecore.Commerce.Pipelines.Carts.GetCarts Namespace


Sitecore.Commerce.Pipelines.Carts.LoadCart Namespace

Sitecore.Commerce.Pipelines.Carts.LoadCart Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.LoadCart"]

Classes
Class Description
Public class LoadCartFromEaState
Defines the processor that takes the ID of the cart, takes the name of the shop, and loads the cart from the Engagement Automation (EA) state. Because searching for a cart by ID across all visitors is time consuming, to overcome performance issues, the default implementation works as follows:
  1. Carts are loaded from the data of the current visitor's EA state and filtered by the given parameters.
  2. If the cart is found, the operation stops and the cart is returned.
  3. If the cart is not found, all the carts of all the visitors are loaded and filtered by the given parameters.
  4. If the cart is found, the operation stops and the cart is returned.
You can use this processor as follows:
  • If the external commerce system does not load carts or if the handling of the carts is entirely executed in Sitecore, you can use this processor separately in the LoadCart pipeline.
  • If Sitecore recognizes the visitor, they can automatically load and resume the cart that is stored in the repository of the Automation states.
  • If the external commerce system does not support all the information specified in the cart's domain model. The main data is loaded from the external commerce system and this processor loads the remaining data from the repository.
Abandoned carts might have been purged from the external commerce system but could still be in an EA state in Sitecore. In this case, you should use the LoadCartfromEaState and LoadCartfromExternalSystem processors in the pipeline, so that Sitecore is acting as a backup storage for carts.


LoadCartFromEaState Class

LoadCartFromEaState Class
Defines the processor that takes the ID of the cart, takes the name of the shop, and loads the cart from the Engagement Automation (EA) state. Because searching for a cart by ID across all visitors is time consuming, to overcome performance issues, the default implementation works as follows:
  1. Carts are loaded from the data of the current visitor's EA state and filtered by the given parameters.
  2. If the cart is found, the operation stops and the cart is returned.
  3. If the cart is not found, all the carts of all the visitors are loaded and filtered by the given parameters.
  4. If the cart is found, the operation stops and the cart is returned.
You can use this processor as follows:
  • If the external commerce system does not load carts or if the handling of the carts is entirely executed in Sitecore, you can use this processor separately in the LoadCart pipeline.
  • If Sitecore recognizes the visitor, they can automatically load and resume the cart that is stored in the repository of the Automation states.
  • If the external commerce system does not support all the information specified in the cart's domain model. The main data is loaded from the external commerce system and this processor loads the remaining data from the repository.
Abandoned carts might have been purged from the external commerce system but could still be in an EA state in Sitecore. In this case, you should use the LoadCartfromEaState and LoadCartfromExternalSystem processors in the pipeline, so that Sitecore is acting as a backup storage for carts.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.CommonCartPipelineProcessor
Sitecore.Commerce.Pipelines.Carts.LoadCartLoadCartFromEaState

Namespace: Sitecore.Commerce.Pipelines.Carts.LoadCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class LoadCartFromEaState : CartPipelineProcessor
Public Class LoadCartFromEaState
    Inherits CartPipelineProcessor
public ref class LoadCartFromEaState : public CartPipelineProcessor
type LoadCartFromEaState =
    class
        inherit CartPipelineProcessor
    end

The LoadCartFromEaState type exposes the following members.

Constructors
 | Name | Description
Public method | LoadCartFromEaState | Initializes an instance of the LoadCartFromEaState class.
Top
Methods
 | Name | Description
Protected method | CombineCart | Combines the cart. (Inherited from CartPipelineProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the LoadCartFromEaState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.LoadCart Namespace


LoadCartFromEaState Constructor

LoadCartFromEaState Constructor
Initializes an instance of the LoadCartFromEaState class.

Namespace: Sitecore.Commerce.Pipelines.Carts.LoadCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public LoadCartFromEaState(
    ICartRepository repository
)
Public Sub New (
    repository As ICartRepository
)
public:
LoadCartFromEaState(
    ICartRepository^ repository
)
new :
        repository : ICartRepository -> LoadCartFromEaState

Parameters

repository
Type: Sitecore.Commerce.Data.CartsICartRepository
The cart repository.
See Also

Reference

LoadCartFromEaState Class
Sitecore.Commerce.Pipelines.Carts.LoadCart Namespace


LoadCartFromEaState Methods

LoadCartFromEaState Methods

The LoadCartFromEaState type exposes the following members.

Methods
 | Name | Description
Protected method | CombineCart | Combines the cart. (Inherited from CartPipelineProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the LoadCartFromEaState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LoadCartFromEaState Class
Sitecore.Commerce.Pipelines.Carts.LoadCart Namespace


LoadCartFromEaState.Process Method

LoadCartFromEaStateProcess Method
Executes the business logic of the LoadCartFromEaState processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.LoadCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

LoadCartFromEaState Class
Sitecore.Commerce.Pipelines.Carts.LoadCart Namespace


Sitecore.Commerce.Pipelines.Carts.LockCart Namespace

Sitecore.Commerce.Pipelines.Carts.LockCart Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.LockCart"]

Classes
 | Class | Description
Public class | LockCart | Defines the processor that locks the cart and sets the cart.IsLocked property to true. This processor is used by the LockCart pipeline.


LockCart Class

LockCart Class
Defines the processor that locks the cart and sets the cart.IsLocked property to true. This processor is used by the LockCart pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.LockCartLockCart

Namespace: Sitecore.Commerce.Pipelines.Carts.LockCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class LockCart : PipelineProcessor<ServicePipelineArgs>
Public Class LockCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class LockCart : public PipelineProcessor<ServicePipelineArgs^>
type LockCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The LockCart type exposes the following members.

Constructors
 | Name | Description
Public method | LockCart | Initializes an instance of the LockCart class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the LockCart process. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.LockCart Namespace


LockCart Constructor

LockCart Constructor
Initializes an instance of the LockCart class.

Namespace: Sitecore.Commerce.Pipelines.Carts.LockCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public LockCart(
    IEntityFactory entityFactory
)
Public Sub New (
    entityFactory As IEntityFactory
)
public:
LockCart(
    IEntityFactory^ entityFactory
)
new :
        entityFactory : IEntityFactory -> LockCart

Parameters

entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity type factory.
See Also

Reference

LockCart Class
Sitecore.Commerce.Pipelines.Carts.LockCart Namespace


LockCart Methods

LockCart Methods

The LockCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the LockCart process. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LockCart Class
Sitecore.Commerce.Pipelines.Carts.LockCart Namespace


LockCart.Process Method

LockCartProcess Method
Executes the business logic of the LockCart process.

Namespace: Sitecore.Commerce.Pipelines.Carts.LockCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

LockCart Class
Sitecore.Commerce.Pipelines.Carts.LockCart Namespace


Sitecore.Commerce.Pipelines.Carts.MergeCart Namespace

Sitecore.Commerce.Pipelines.Carts.MergeCart Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.MergeCart"]

Classes
 | Class | Description
Public class | MergeCart | Defines the processor that merges the Anonymous cart to the user cart. Once the merge is complete, the Anonymous cart is deleted.


MergeCart Class

MergeCart Class
Defines the processor that merges the Anonymous cart to the user cart. Once the merge is complete, the Anonymous cart is deleted.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.MergeCartMergeCart

Namespace: Sitecore.Commerce.Pipelines.Carts.MergeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class MergeCart : PipelineProcessor<ServicePipelineArgs>
Public Class MergeCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class MergeCart : public PipelineProcessor<ServicePipelineArgs^>
type MergeCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The MergeCart type exposes the following members.

Constructors
 | Name | Description
Public method | MergeCart | Initializes a new instance of the MergeCart class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIncrementedString | Gets incremented string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the buisiness logic to merge the 2 carts. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CartServiceProvider | Gets or sets the cart service provider.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.MergeCart Namespace


MergeCart Constructor

MergeCart Constructor
Initializes a new instance of the MergeCart class.

Namespace: Sitecore.Commerce.Pipelines.Carts.MergeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public MergeCart(
    CartServiceProvider cartServiceProvider
)
Public Sub New (
    cartServiceProvider As CartServiceProvider
)
public:
MergeCart(
    CartServiceProvider^ cartServiceProvider
)
new :
        cartServiceProvider : CartServiceProvider -> MergeCart

Parameters

cartServiceProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
The cart service provider.
See Also

Reference

MergeCart Class
Sitecore.Commerce.Pipelines.Carts.MergeCart Namespace


MergeCart Methods

MergeCart Methods

The MergeCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIncrementedString | Gets incremented string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the buisiness logic to merge the 2 carts. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MergeCart Class
Sitecore.Commerce.Pipelines.Carts.MergeCart Namespace


MergeCart.GetIncrementedString Method

MergeCartGetIncrementedString Method
Gets incremented string.

Namespace: Sitecore.Commerce.Pipelines.Carts.MergeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual string GetIncrementedString(
    string value
)
Protected Overridable Function GetIncrementedString (
    value As String
) As String
protected:
virtual String^ GetIncrementedString(
    String^ value
)
abstract GetIncrementedString :
        value : string -> string
override GetIncrementedString :
        value : string -> string

Parameters

value
Type: SystemString
The value.

Return Value

Type: String
The incremented string.
See Also

Reference

MergeCart Class
Sitecore.Commerce.Pipelines.Carts.MergeCart Namespace


MergeCart.Process Method

MergeCartProcess Method
Executes the buisiness logic to merge the 2 carts.

Namespace: Sitecore.Commerce.Pipelines.Carts.MergeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

MergeCart Class
Sitecore.Commerce.Pipelines.Carts.MergeCart Namespace


MergeCart Properties

MergeCart Properties

The MergeCart type exposes the following members.

Properties
 | Name | Description
Public property | CartServiceProvider | Gets or sets the cart service provider.
Top
See Also

Reference

MergeCart Class
Sitecore.Commerce.Pipelines.Carts.MergeCart Namespace


MergeCart.CartServiceProvider Property

MergeCartCartServiceProvider Property
Gets or sets the cart service provider.

Namespace: Sitecore.Commerce.Pipelines.Carts.MergeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CartServiceProvider CartServiceProvider { get; protected set; }
Public Property CartServiceProvider As CartServiceProvider
    Get
    Protected Set
public:
property CartServiceProvider^ CartServiceProvider {
    CartServiceProvider^ get ();
    protected: void set (CartServiceProvider^ value);
}
member CartServiceProvider : CartServiceProvider with get, set

Property Value

Type: CartServiceProvider
The cart service provider.
See Also

Reference

MergeCart Class
Sitecore.Commerce.Pipelines.Carts.MergeCart Namespace


Sitecore.Commerce.Pipelines.Carts.RemoveCartLines Namespace

Sitecore.Commerce.Pipelines.Carts.RemoveCartLines Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.RemoveCartLines"]

Classes
 | Class | Description
Public class | RemoveLinesFromCart | Defines the processor that removes lines from a cart. This processor is used by the RemoveCartLines pipeline.


RemoveLinesFromCart Class

RemoveLinesFromCart Class
Defines the processor that removes lines from a cart. This processor is used by the RemoveCartLines pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.RemoveCartLinesRemoveLinesFromCart

Namespace: Sitecore.Commerce.Pipelines.Carts.RemoveCartLines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveLinesFromCart : PipelineProcessor<ServicePipelineArgs>
Public Class RemoveLinesFromCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class RemoveLinesFromCart : public PipelineProcessor<ServicePipelineArgs^>
type RemoveLinesFromCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The RemoveLinesFromCart type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveLinesFromCart | Initializes a new instance of the RemoveLinesFromCart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RemoveLinesFromCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.RemoveCartLines Namespace


RemoveLinesFromCart Constructor

RemoveLinesFromCart Constructor
Initializes a new instance of the RemoveLinesFromCart class

Namespace: Sitecore.Commerce.Pipelines.Carts.RemoveCartLines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveLinesFromCart()
Public Sub New
public:
RemoveLinesFromCart()
new : unit -> RemoveLinesFromCart
See Also

Reference

RemoveLinesFromCart Class
Sitecore.Commerce.Pipelines.Carts.RemoveCartLines Namespace


RemoveLinesFromCart Methods

RemoveLinesFromCart Methods

The RemoveLinesFromCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RemoveLinesFromCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveLinesFromCart Class
Sitecore.Commerce.Pipelines.Carts.RemoveCartLines Namespace


RemoveLinesFromCart.Process Method

RemoveLinesFromCartProcess Method
Executes the business logic of the RemoveLinesFromCart processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.RemoveCartLines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

RemoveLinesFromCart Class
Sitecore.Commerce.Pipelines.Carts.RemoveCartLines Namespace


Sitecore.Commerce.Pipelines.Carts.RemoveParties Namespace

Sitecore.Commerce.Pipelines.Carts.RemoveParties Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.RemoveParties"]

Classes
 | Class | Description
Public class | RemovePartiesFromCart | Defines the RemovePartiesFromCart class.


RemovePartiesFromCart Class

RemovePartiesFromCart Class
Defines the RemovePartiesFromCart class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.RemovePartiesRemovePartiesFromCart

Namespace: Sitecore.Commerce.Pipelines.Carts.RemoveParties
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemovePartiesFromCart : PipelineProcessor<ServicePipelineArgs>
Public Class RemovePartiesFromCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class RemovePartiesFromCart : public PipelineProcessor<ServicePipelineArgs^>
type RemovePartiesFromCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The RemovePartiesFromCart type exposes the following members.

Constructors
 | Name | Description
Public method | RemovePartiesFromCart | Initializes a new instance of the RemovePartiesFromCart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RemovePartyAssociations | Removes the party associations.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.RemoveParties Namespace


RemovePartiesFromCart Constructor

RemovePartiesFromCart Constructor
Initializes a new instance of the RemovePartiesFromCart class

Namespace: Sitecore.Commerce.Pipelines.Carts.RemoveParties
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemovePartiesFromCart()
Public Sub New
public:
RemovePartiesFromCart()
new : unit -> RemovePartiesFromCart
See Also

Reference

RemovePartiesFromCart Class
Sitecore.Commerce.Pipelines.Carts.RemoveParties Namespace


RemovePartiesFromCart Methods

RemovePartiesFromCart Methods

The RemovePartiesFromCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RemovePartyAssociations | Removes the party associations.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemovePartiesFromCart Class
Sitecore.Commerce.Pipelines.Carts.RemoveParties Namespace


RemovePartiesFromCart.Process Method

RemovePartiesFromCartProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Carts.RemoveParties
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RemovePartiesFromCart Class
Sitecore.Commerce.Pipelines.Carts.RemoveParties Namespace


RemovePartiesFromCart.RemovePartyAssociations Method

RemovePartiesFromCartRemovePartyAssociations Method
Removes the party associations.

Namespace: Sitecore.Commerce.Pipelines.Carts.RemoveParties
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void RemovePartyAssociations(
    Cart cart,
    Party partyToRemove
)
Protected Overridable Sub RemovePartyAssociations (
    cart As Cart,
    partyToRemove As Party
)
protected:
virtual void RemovePartyAssociations(
    Cart^ cart,
    Party^ partyToRemove
)
abstract RemovePartyAssociations :
        cart : Cart *
        partyToRemove : Party -> unit
override RemovePartyAssociations :
        cart : Cart *
        partyToRemove : Party -> unit

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
partyToRemove
Type: Sitecore.Commerce.EntitiesParty
The party to remove.
See Also

Reference

RemovePartiesFromCart Class
Sitecore.Commerce.Pipelines.Carts.RemoveParties Namespace


Sitecore.Commerce.Pipelines.Carts.RemovePaymentInfo Namespace

Sitecore.Commerce.Pipelines.Carts.RemovePaymentInfo Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.RemovePaymentInfo"]

Classes
 | Class | Description
Public class | RemovePaymentInfoFromCart | Defines the RemovePaymentInfoFromCart processor.


RemovePaymentInfoFromCart Class

RemovePaymentInfoFromCart Class
Defines the RemovePaymentInfoFromCart processor.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.RemovePaymentInfoRemovePaymentInfoFromCart

Namespace: Sitecore.Commerce.Pipelines.Carts.RemovePaymentInfo
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemovePaymentInfoFromCart : PipelineProcessor<ServicePipelineArgs>
Public Class RemovePaymentInfoFromCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class RemovePaymentInfoFromCart : public PipelineProcessor<ServicePipelineArgs^>
type RemovePaymentInfoFromCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The RemovePaymentInfoFromCart type exposes the following members.

Constructors
 | Name | Description
Public method | RemovePaymentInfoFromCart | Initializes a new instance of the RemovePaymentInfoFromCart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.RemovePaymentInfo Namespace


RemovePaymentInfoFromCart Constructor

RemovePaymentInfoFromCart Constructor
Initializes a new instance of the RemovePaymentInfoFromCart class

Namespace: Sitecore.Commerce.Pipelines.Carts.RemovePaymentInfo
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemovePaymentInfoFromCart()
Public Sub New
public:
RemovePaymentInfoFromCart()
new : unit -> RemovePaymentInfoFromCart
See Also

Reference

RemovePaymentInfoFromCart Class
Sitecore.Commerce.Pipelines.Carts.RemovePaymentInfo Namespace


RemovePaymentInfoFromCart Methods

RemovePaymentInfoFromCart Methods

The RemovePaymentInfoFromCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemovePaymentInfoFromCart Class
Sitecore.Commerce.Pipelines.Carts.RemovePaymentInfo Namespace


RemovePaymentInfoFromCart.Process Method

RemovePaymentInfoFromCartProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Carts.RemovePaymentInfo
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RemovePaymentInfoFromCart Class
Sitecore.Commerce.Pipelines.Carts.RemovePaymentInfo Namespace


Sitecore.Commerce.Pipelines.Carts.RemoveShippingInfo Namespace

Sitecore.Commerce.Pipelines.Carts.RemoveShippingInfo Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.RemoveShippingInfo"]

Classes
 | Class | Description
Public class | RemoveShippingInfoFromCart | Defines the RemoveShippingInfoFromCart processor.


RemoveShippingInfoFromCart Class

RemoveShippingInfoFromCart Class
Defines the RemoveShippingInfoFromCart processor.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.RemoveShippingInfoRemoveShippingInfoFromCart

Namespace: Sitecore.Commerce.Pipelines.Carts.RemoveShippingInfo
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveShippingInfoFromCart : PipelineProcessor<ServicePipelineArgs>
Public Class RemoveShippingInfoFromCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class RemoveShippingInfoFromCart : public PipelineProcessor<ServicePipelineArgs^>
type RemoveShippingInfoFromCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The RemoveShippingInfoFromCart type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveShippingInfoFromCart | Initializes a new instance of the RemoveShippingInfoFromCart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.RemoveShippingInfo Namespace


RemoveShippingInfoFromCart Constructor

RemoveShippingInfoFromCart Constructor
Initializes a new instance of the RemoveShippingInfoFromCart class

Namespace: Sitecore.Commerce.Pipelines.Carts.RemoveShippingInfo
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveShippingInfoFromCart()
Public Sub New
public:
RemoveShippingInfoFromCart()
new : unit -> RemoveShippingInfoFromCart
See Also

Reference

RemoveShippingInfoFromCart Class
Sitecore.Commerce.Pipelines.Carts.RemoveShippingInfo Namespace


RemoveShippingInfoFromCart Methods

RemoveShippingInfoFromCart Methods

The RemoveShippingInfoFromCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveShippingInfoFromCart Class
Sitecore.Commerce.Pipelines.Carts.RemoveShippingInfo Namespace


RemoveShippingInfoFromCart.Process Method

RemoveShippingInfoFromCartProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Carts.RemoveShippingInfo
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RemoveShippingInfoFromCart Class
Sitecore.Commerce.Pipelines.Carts.RemoveShippingInfo Namespace


Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace

Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.ResumeCart"]

Classes
Class Description
Public class ChangeCartStatus
Defines the processor that assigns the status field of the cart the CartStatus.InProcess constant. The ChangeCartStatus is used by the ResumeCart pipeline.
Public class CheckCanBeResumed
Defines the processor that checks whether a cart can be resumed. If the visitor is not in the abandoned cart Engagement Automation (EA) plan and not in the initial state, the pipeline stops. This processor stores the values to the following parameters in the custom data:
  • CartSourceStateId, which is used by the MoveVisitorToInitialState processor.
  • CartDestinationStateId, which is used by the MoveVisitorToInitialState processor.
  • PreviousStateName, which is used by the TriggerCartResumedPageEvent processor.
The CheckCanBeResumed processor is used by the ResumeCart pipeline.
Public class MoveVisitorToInitialState
Define a generic processor that moves the current visitor between two states of an EA plan. The MoveVisitorToInitialState processor is used by the ResumeCart pipeline to move the visitor to the initial state of the Abandoned Cart EA plan This processor uses the source and destination state IDs of the cart that are stored in the custom data by the CheckCanBeResumed processor.
Public class TriggerCartResumedPageEvent
Defines the processor that triggers a specified page event when resuming the cart and registers the following cart values:
  • ExternalCartId, which contains the ID of the cart in the external commerce system.
  • UserId, which contains the ID of the visitor in Sitecore.
  • CartName, which contains the name of the cart in Sitecore.
  • CartStatus, which contains the current state of the cart in the EA plan.
The Page Event text is automatically localized using the Sitecore dictionary. The TriggerCartCreatedPageEventForResumedCart processor is used by the ResumeCart pipeline.


ChangeCartStatus Class

ChangeCartStatus Class
Defines the processor that assigns the status field of the cart the CartStatus.InProcess constant. The ChangeCartStatus is used by the ResumeCart pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.ResumeCartChangeCartStatus

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ChangeCartStatus : PipelineProcessor<ServicePipelineArgs>
Public Class ChangeCartStatus
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ChangeCartStatus : public PipelineProcessor<ServicePipelineArgs^>
type ChangeCartStatus =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ChangeCartStatus type exposes the following members.

Constructors
 | Name | Description
Public method | ChangeCartStatus | Initializes a new instance of the ChangeCartStatus class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ChangeCartStatus processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


ChangeCartStatus Constructor

ChangeCartStatus Constructor
Initializes a new instance of the ChangeCartStatus class

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ChangeCartStatus()
Public Sub New
public:
ChangeCartStatus()
new : unit -> ChangeCartStatus
See Also

Reference

ChangeCartStatus Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


ChangeCartStatus Methods

ChangeCartStatus Methods

The ChangeCartStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ChangeCartStatus processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChangeCartStatus Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


ChangeCartStatus.Process Method

ChangeCartStatusProcess Method
Executes the business logic of the ChangeCartStatus processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

ChangeCartStatus Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


CheckCanBeResumed Class

CheckCanBeResumed Class
Defines the processor that checks whether a cart can be resumed. If the visitor is not in the abandoned cart Engagement Automation (EA) plan and not in the initial state, the pipeline stops. This processor stores the values to the following parameters in the custom data:
  • CartSourceStateId, which is used by the MoveVisitorToInitialState processor.
  • CartDestinationStateId, which is used by the MoveVisitorToInitialState processor.
  • PreviousStateName, which is used by the TriggerCartResumedPageEvent processor.
The CheckCanBeResumed processor is used by the ResumeCart pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.ResumeCartCheckCanBeResumed

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CheckCanBeResumed : PipelineProcessor<ServicePipelineArgs>
Public Class CheckCanBeResumed
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class CheckCanBeResumed : public PipelineProcessor<ServicePipelineArgs^>
type CheckCanBeResumed =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The CheckCanBeResumed type exposes the following members.

Constructors
 | Name | Description
Public method | CheckCanBeResumed | Initializes an instance of the CheckCanBeResumed class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the CheckCanBeResumed processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


CheckCanBeResumed Constructor

CheckCanBeResumed Constructor
Initializes an instance of the CheckCanBeResumed class.

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CheckCanBeResumed(
    IEaPlanProvider eaPlanProvider
)
Public Sub New (
    eaPlanProvider As IEaPlanProvider
)
public:
CheckCanBeResumed(
    IEaPlanProvider^ eaPlanProvider
)
new :
        eaPlanProvider : IEaPlanProvider -> CheckCanBeResumed

Parameters

eaPlanProvider
Type: Sitecore.Commerce.MultishopIEaPlanProvider
The Engagement Automation plan provider
See Also

Reference

CheckCanBeResumed Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


CheckCanBeResumed Methods

CheckCanBeResumed Methods

The CheckCanBeResumed type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the CheckCanBeResumed processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CheckCanBeResumed Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


CheckCanBeResumed.Process Method

CheckCanBeResumedProcess Method
Executes the business logic of the CheckCanBeResumed processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

CheckCanBeResumed Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


MoveVisitorToInitialState Class

MoveVisitorToInitialState Class
Define a generic processor that moves the current visitor between two states of an EA plan. The MoveVisitorToInitialState processor is used by the ResumeCart pipeline to move the visitor to the initial state of the Abandoned Cart EA plan This processor uses the source and destination state IDs of the cart that are stored in the custom data by the CheckCanBeResumed processor.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.ResumeCartMoveVisitorToInitialState

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class MoveVisitorToInitialState : PipelineProcessor<ServicePipelineArgs>
Public Class MoveVisitorToInitialState
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class MoveVisitorToInitialState : public PipelineProcessor<ServicePipelineArgs^>
type MoveVisitorToInitialState =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The MoveVisitorToInitialState type exposes the following members.

Constructors
 | Name | Description
Public method | MoveVisitorToInitialState | Initializes a new instance of the MoveVisitorToInitialState class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the MoveVisitorToInitialState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


MoveVisitorToInitialState Constructor

MoveVisitorToInitialState Constructor
Initializes a new instance of the MoveVisitorToInitialState class

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public MoveVisitorToInitialState()
Public Sub New
public:
MoveVisitorToInitialState()
new : unit -> MoveVisitorToInitialState
See Also

Reference

MoveVisitorToInitialState Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


MoveVisitorToInitialState Methods

MoveVisitorToInitialState Methods

The MoveVisitorToInitialState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the MoveVisitorToInitialState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoveVisitorToInitialState Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


MoveVisitorToInitialState.Process Method

MoveVisitorToInitialStateProcess Method
Executes the business logic of the MoveVisitorToInitialState processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

MoveVisitorToInitialState Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


TriggerCartResumedPageEvent Class

TriggerCartResumedPageEvent Class
Defines the processor that triggers a specified page event when resuming the cart and registers the following cart values:
  • ExternalCartId, which contains the ID of the cart in the external commerce system.
  • UserId, which contains the ID of the visitor in Sitecore.
  • CartName, which contains the name of the cart in Sitecore.
  • CartStatus, which contains the current state of the cart in the EA plan.
The Page Event text is automatically localized using the Sitecore dictionary. The TriggerCartCreatedPageEventForResumedCart processor is used by the ResumeCart pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Carts.CommonTriggerCartPageEvent
Sitecore.Commerce.Pipelines.Carts.ResumeCartTriggerCartResumedPageEvent

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerCartResumedPageEvent : TriggerCartPageEvent
Public Class TriggerCartResumedPageEvent
    Inherits TriggerCartPageEvent
public ref class TriggerCartResumedPageEvent : public TriggerCartPageEvent
type TriggerCartResumedPageEvent =
    class
        inherit TriggerCartPageEvent
    end

The TriggerCartResumedPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerCartResumedPageEvent | Initializes a new instance of the TriggerCartResumedPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractCartData | Extracts the cart data and returns the data in a dictionary. (Inherited from TriggerCartPageEvent.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartFromArgs | Gets the cart from the arguments. (Overrides TriggerCartPageEventGetCartFromArgs(ServicePipelineArgs).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data value from the arguments. (Overrides TriggerCartPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Overrides TriggerPageEventGetPageEventText(ServicePipelineArgs).)
Protected method | GetPreviousStateName | Gets the name of the previous state. The previous state name is stored in the custom data by the CheckCanBeResumed processor.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


TriggerCartResumedPageEvent Constructor

TriggerCartResumedPageEvent Constructor
Initializes a new instance of the TriggerCartResumedPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerCartResumedPageEvent()
Public Sub New
public:
TriggerCartResumedPageEvent()
new : unit -> TriggerCartResumedPageEvent
See Also

Reference

TriggerCartResumedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


TriggerCartResumedPageEvent Methods

TriggerCartResumedPageEvent Methods

The TriggerCartResumedPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractCartData | Extracts the cart data and returns the data in a dictionary. (Inherited from TriggerCartPageEvent.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartFromArgs | Gets the cart from the arguments. (Overrides TriggerCartPageEventGetCartFromArgs(ServicePipelineArgs).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data value from the arguments. (Overrides TriggerCartPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Overrides TriggerPageEventGetPageEventText(ServicePipelineArgs).)
Protected method | GetPreviousStateName | Gets the name of the previous state. The previous state name is stored in the custom data by the CheckCanBeResumed processor.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerCartResumedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


TriggerCartResumedPageEvent.GetCartFromArgs Method

TriggerCartResumedPageEventGetCartFromArgs Method
Gets the cart from the arguments.

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override CartBase GetCartFromArgs(
    ServicePipelineArgs args
)
Protected Overrides Function GetCartFromArgs (
    args As ServicePipelineArgs
) As CartBase
protected:
virtual CartBase^ GetCartFromArgs(
    ServicePipelineArgs^ args
) override
abstract GetCartFromArgs :
        args : ServicePipelineArgs -> CartBase
override GetCartFromArgs :
        args : ServicePipelineArgs -> CartBase

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: CartBase
The cart extracted from arguments.
See Also

Reference

TriggerCartResumedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


TriggerCartResumedPageEvent.GetPageEventData Method

TriggerCartResumedPageEventGetPageEventData Method
Gets the page event data value from the arguments.

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetPageEventData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventData (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventData :
        args : ServicePipelineArgs -> string
override GetPageEventData :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
Date for the specified arguments.
See Also

Reference

TriggerCartResumedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


TriggerCartResumedPageEvent.GetPageEventText Method

TriggerCartResumedPageEventGetPageEventText Method
Gets the page event text.

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetPageEventText(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventText (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventText(
    ServicePipelineArgs^ args
) override
abstract GetPageEventText :
        args : ServicePipelineArgs -> string
override GetPageEventText :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
The page event text.
See Also

Reference

TriggerCartResumedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


TriggerCartResumedPageEvent.GetPreviousStateName Method

TriggerCartResumedPageEventGetPreviousStateName Method
Gets the name of the previous state. The previous state name is stored in the custom data by the CheckCanBeResumed processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.ResumeCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected string GetPreviousStateName(
    ServicePipelineArgs args
)
Protected Function GetPreviousStateName (
    args As ServicePipelineArgs
) As String
protected:
String^ GetPreviousStateName(
    ServicePipelineArgs^ args
)
member GetPreviousStateName :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
Name of the previous state.
See Also

Reference

TriggerCartResumedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


TriggerCartResumedPageEvent Properties

TriggerCartResumedPageEvent Properties

The TriggerCartResumedPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerCartResumedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.ResumeCart Namespace


Sitecore.Commerce.Pipelines.Carts.UnlockCart Namespace

Sitecore.Commerce.Pipelines.Carts.UnlockCart Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.UnlockCart"]

Classes
 | Class | Description
Public class | UnlockCart | Defines the processor that unlocks the cart and sets the Cart.IsLocked property to false.


UnlockCart Class

UnlockCart Class
Defines the processor that unlocks the cart and sets the Cart.IsLocked property to false.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.UnlockCartUnlockCart

Namespace: Sitecore.Commerce.Pipelines.Carts.UnlockCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UnlockCart : PipelineProcessor<ServicePipelineArgs>
Public Class UnlockCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class UnlockCart : public PipelineProcessor<ServicePipelineArgs^>
type UnlockCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The UnlockCart type exposes the following members.

Constructors
 | Name | Description
Public method | UnlockCart | Initializes an instance of the UnlockCart class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the UnlockCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.UnlockCart Namespace


UnlockCart Constructor

UnlockCart Constructor
Initializes an instance of the UnlockCart class.

Namespace: Sitecore.Commerce.Pipelines.Carts.UnlockCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UnlockCart(
    IEntityFactory entityFactory
)
Public Sub New (
    entityFactory As IEntityFactory
)
public:
UnlockCart(
    IEntityFactory^ entityFactory
)
new :
        entityFactory : IEntityFactory -> UnlockCart

Parameters

entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity type factory.
See Also

Reference

UnlockCart Class
Sitecore.Commerce.Pipelines.Carts.UnlockCart Namespace


UnlockCart Methods

UnlockCart Methods

The UnlockCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the UnlockCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnlockCart Class
Sitecore.Commerce.Pipelines.Carts.UnlockCart Namespace


UnlockCart.Process Method

UnlockCartProcess Method
Executes the business logic of the UnlockCart processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.UnlockCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

UnlockCart Class
Sitecore.Commerce.Pipelines.Carts.UnlockCart Namespace


Sitecore.Commerce.Pipelines.Carts.UpdateCart Namespace

Sitecore.Commerce.Pipelines.Carts.UpdateCart Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.UpdateCart"]

Classes
Class Description
Public class TriggerCartUpdatedPageEvent
Defines the processor that triggers a page event for the cart is updated and registers the values:
  • CustomerId
  • CartName
  • ShopName
The Page Event text is automatically localized using the Sitecore dictionary.
Public class UpdateCart
Defines the processor that updates the following fields in a cart:
  • The customer ID
  • The cart name
  • The shop name


TriggerCartUpdatedPageEvent Class

TriggerCartUpdatedPageEvent Class
Defines the processor that triggers a page event for the cart is updated and registers the values:
  • CustomerId
  • CartName
  • ShopName
The Page Event text is automatically localized using the Sitecore dictionary.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Carts.CommonTriggerCartPageEvent
Sitecore.Commerce.Pipelines.Carts.UpdateCartTriggerCartUpdatedPageEvent

Namespace: Sitecore.Commerce.Pipelines.Carts.UpdateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerCartUpdatedPageEvent : TriggerCartPageEvent
Public Class TriggerCartUpdatedPageEvent
    Inherits TriggerCartPageEvent
public ref class TriggerCartUpdatedPageEvent : public TriggerCartPageEvent
type TriggerCartUpdatedPageEvent =
    class
        inherit TriggerCartPageEvent
    end

The TriggerCartUpdatedPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerCartUpdatedPageEvent | Initializes a new instance of the TriggerCartUpdatedPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractCartData | Extracts the cart data. (Overrides TriggerCartPageEventExtractCartData(CartBase).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartFromArgs | Gets the cart from the arguments. (Overrides TriggerCartPageEventGetCartFromArgs(ServicePipelineArgs).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data value from arguments. (Inherited from TriggerCartPageEvent.)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.UpdateCart Namespace


TriggerCartUpdatedPageEvent Constructor

TriggerCartUpdatedPageEvent Constructor
Initializes a new instance of the TriggerCartUpdatedPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Carts.UpdateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerCartUpdatedPageEvent()
Public Sub New
public:
TriggerCartUpdatedPageEvent()
new : unit -> TriggerCartUpdatedPageEvent
See Also

Reference

TriggerCartUpdatedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.UpdateCart Namespace


TriggerCartUpdatedPageEvent Methods

TriggerCartUpdatedPageEvent Methods

The TriggerCartUpdatedPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractCartData | Extracts the cart data. (Overrides TriggerCartPageEventExtractCartData(CartBase).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartFromArgs | Gets the cart from the arguments. (Overrides TriggerCartPageEventGetCartFromArgs(ServicePipelineArgs).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data value from arguments. (Inherited from TriggerCartPageEvent.)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerCartUpdatedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.UpdateCart Namespace


TriggerCartUpdatedPageEvent.ExtractCartData Method

TriggerCartUpdatedPageEventExtractCartData Method
Extracts the cart data.

Namespace: Sitecore.Commerce.Pipelines.Carts.UpdateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IDictionary<string, string> ExtractCartData(
    CartBase cart
)
Protected Overrides Function ExtractCartData (
    cart As CartBase
) As IDictionary(Of String, String)
protected:
virtual IDictionary<String^, String^>^ ExtractCartData(
    CartBase^ cart
) override
abstract ExtractCartData :
        cart : CartBase -> IDictionary<string, string>
override ExtractCartData :
        cart : CartBase -> IDictionary<string, string>

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCartBase
The cart.

Return Value

Type: IDictionary String, String
The dictionary with required cart fields only.
See Also

Reference

TriggerCartUpdatedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.UpdateCart Namespace


TriggerCartUpdatedPageEvent.GetCartFromArgs Method

TriggerCartUpdatedPageEventGetCartFromArgs Method
Gets the cart from the arguments.

Namespace: Sitecore.Commerce.Pipelines.Carts.UpdateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override CartBase GetCartFromArgs(
    ServicePipelineArgs args
)
Protected Overrides Function GetCartFromArgs (
    args As ServicePipelineArgs
) As CartBase
protected:
virtual CartBase^ GetCartFromArgs(
    ServicePipelineArgs^ args
) override
abstract GetCartFromArgs :
        args : ServicePipelineArgs -> CartBase
override GetCartFromArgs :
        args : ServicePipelineArgs -> CartBase

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: CartBase
The cart extracted from arguments.
See Also

Reference

TriggerCartUpdatedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.UpdateCart Namespace


TriggerCartUpdatedPageEvent Properties

TriggerCartUpdatedPageEvent Properties

The TriggerCartUpdatedPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerCartUpdatedPageEvent Class
Sitecore.Commerce.Pipelines.Carts.UpdateCart Namespace


UpdateCart Class

UpdateCart Class
Defines the processor that updates the following fields in a cart:
  • The customer ID
  • The cart name
  • The shop name
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.UpdateCartUpdateCart

Namespace: Sitecore.Commerce.Pipelines.Carts.UpdateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateCart : PipelineProcessor<ServicePipelineArgs>
Public Class UpdateCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class UpdateCart : public PipelineProcessor<ServicePipelineArgs^>
type UpdateCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The UpdateCart type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateCart | Initializes a new instance of the UpdateCart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the UpdateCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateAdditionalProperties | Updates the additional properties.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.UpdateCart Namespace


UpdateCart Constructor

UpdateCart Constructor
Initializes a new instance of the UpdateCart class

Namespace: Sitecore.Commerce.Pipelines.Carts.UpdateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateCart()
Public Sub New
public:
UpdateCart()
new : unit -> UpdateCart
See Also

Reference

UpdateCart Class
Sitecore.Commerce.Pipelines.Carts.UpdateCart Namespace


UpdateCart Methods

UpdateCart Methods

The UpdateCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the UpdateCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateAdditionalProperties | Updates the additional properties.
Top
See Also

Reference

UpdateCart Class
Sitecore.Commerce.Pipelines.Carts.UpdateCart Namespace


UpdateCart.Process Method

UpdateCartProcess Method
Executes the business logic of the UpdateCart processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.UpdateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

UpdateCart Class
Sitecore.Commerce.Pipelines.Carts.UpdateCart Namespace


UpdateCart.UpdateAdditionalProperties Method

UpdateCartUpdateAdditionalProperties Method
Updates the additional properties.

Namespace: Sitecore.Commerce.Pipelines.Carts.UpdateCart
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void UpdateAdditionalProperties(
    Cart currentCart,
    CartBase changes
)
Protected Overridable Sub UpdateAdditionalProperties (
    currentCart As Cart,
    changes As CartBase
)
protected:
virtual void UpdateAdditionalProperties(
    Cart^ currentCart,
    CartBase^ changes
)
abstract UpdateAdditionalProperties :
        currentCart : Cart *
        changes : CartBase -> unit
override UpdateAdditionalProperties :
        currentCart : Cart *
        changes : CartBase -> unit

Parameters

currentCart
Type: Sitecore.Commerce.Entities.CartsCart
The current cart.
changes
Type: Sitecore.Commerce.Entities.CartsCartBase
The changes.
See Also

Reference

UpdateCart Class
Sitecore.Commerce.Pipelines.Carts.UpdateCart Namespace


Sitecore.Commerce.Pipelines.Carts.UpdateCartLines Namespace

Sitecore.Commerce.Pipelines.Carts.UpdateCartLines Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.UpdateCartLines"]

Classes
 | Class | Description
Public class | UpdateLinesOnCart | Defines the processor that updates the cart lines in a cart.


UpdateLinesOnCart Class

UpdateLinesOnCart Class
Defines the processor that updates the cart lines in a cart.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.UpdateCartLinesUpdateLinesOnCart

Namespace: Sitecore.Commerce.Pipelines.Carts.UpdateCartLines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateLinesOnCart : PipelineProcessor<ServicePipelineArgs>
Public Class UpdateLinesOnCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class UpdateLinesOnCart : public PipelineProcessor<ServicePipelineArgs^>
type UpdateLinesOnCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The UpdateLinesOnCart type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateLinesOnCart | Initializes a new instance of the UpdateLinesOnCart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the UpdateLinesOnCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.UpdateCartLines Namespace


UpdateLinesOnCart Constructor

UpdateLinesOnCart Constructor
Initializes a new instance of the UpdateLinesOnCart class

Namespace: Sitecore.Commerce.Pipelines.Carts.UpdateCartLines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateLinesOnCart()
Public Sub New
public:
UpdateLinesOnCart()
new : unit -> UpdateLinesOnCart
See Also

Reference

UpdateLinesOnCart Class
Sitecore.Commerce.Pipelines.Carts.UpdateCartLines Namespace


UpdateLinesOnCart Methods

UpdateLinesOnCart Methods

The UpdateLinesOnCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the UpdateLinesOnCart processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateLinesOnCart Class
Sitecore.Commerce.Pipelines.Carts.UpdateCartLines Namespace


UpdateLinesOnCart.Process Method

UpdateLinesOnCartProcess Method
Executes the business logic of the UpdateLinesOnCart processor.

Namespace: Sitecore.Commerce.Pipelines.Carts.UpdateCartLines
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments
See Also

Reference

UpdateLinesOnCart Class
Sitecore.Commerce.Pipelines.Carts.UpdateCartLines Namespace


Sitecore.Commerce.Pipelines.Carts.UpdateParties Namespace

Sitecore.Commerce.Pipelines.Carts.UpdateParties Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Carts.UpdateParties"]

Classes
 | Class | Description
Public class | UpdatePartiesInCart | Defines the UpdatePartiesInCart class.


UpdatePartiesInCart Class

UpdatePartiesInCart Class
Defines the UpdatePartiesInCart class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Carts.UpdatePartiesUpdatePartiesInCart

Namespace: Sitecore.Commerce.Pipelines.Carts.UpdateParties
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdatePartiesInCart : PipelineProcessor<ServicePipelineArgs>
Public Class UpdatePartiesInCart
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class UpdatePartiesInCart : public PipelineProcessor<ServicePipelineArgs^>
type UpdatePartiesInCart =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The UpdatePartiesInCart type exposes the following members.

Constructors
 | Name | Description
Public method | UpdatePartiesInCart | Initializes a new instance of the UpdatePartiesInCart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Carts.UpdateParties Namespace


UpdatePartiesInCart Constructor

UpdatePartiesInCart Constructor
Initializes a new instance of the UpdatePartiesInCart class

Namespace: Sitecore.Commerce.Pipelines.Carts.UpdateParties
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdatePartiesInCart()
Public Sub New
public:
UpdatePartiesInCart()
new : unit -> UpdatePartiesInCart
See Also

Reference

UpdatePartiesInCart Class
Sitecore.Commerce.Pipelines.Carts.UpdateParties Namespace


UpdatePartiesInCart Methods

UpdatePartiesInCart Methods

The UpdatePartiesInCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdatePartiesInCart Class
Sitecore.Commerce.Pipelines.Carts.UpdateParties Namespace


UpdatePartiesInCart.Process Method

UpdatePartiesInCartProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Carts.UpdateParties
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

UpdatePartiesInCart Class
Sitecore.Commerce.Pipelines.Carts.UpdateParties Namespace


Sitecore.Commerce.Pipelines.Common Namespace

Sitecore.Commerce.Pipelines.Common Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Common"]

Classes
 | Class | Description
Public class | TriggerPageEvent | Defines the processor that triggers a specified page event. The event name and associated text are read from the processor parameters in the configuration file. The page event text is localized using the Sitecore dictionary.


TriggerPageEvent Class

TriggerPageEvent Class
Defines the processor that triggers a specified page event. The event name and associated text are read from the processor parameters in the configuration file. The page event text is localized using the Sitecore dictionary.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
More...

Namespace: Sitecore.Commerce.Pipelines.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerPageEvent : PipelineProcessor<ServicePipelineArgs>
Public Class TriggerPageEvent
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class TriggerPageEvent : public PipelineProcessor<ServicePipelineArgs^>
type TriggerPageEvent =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The TriggerPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerPageEvent | Initializes a new instance of the TriggerPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data.
Protected method | GetPageEventText | Gets the page event text.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger.
Public property | Text | Gets or sets the page event text.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Common Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Carts.CommonTriggerCartLinesPageEvent
Sitecore.Commerce.Pipelines.Carts.CommonTriggerCartPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerAccountPageEvent
Sitecore.Commerce.Pipelines.Inventory.CommonTriggerAddToCartStockStatusPageEvent
Sitecore.Commerce.Pipelines.Inventory.ProductsAreBackInStockTriggerProductsAreBackInStockPageEvent
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotificationTriggerBackInStockUnsubscriptionPageEvent
Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatusTriggerVisitedProductStockStatusPageEvent
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotificationTriggerBackInStockSubscriptionPageEvent
Sitecore.Commerce.Pipelines.Orders.CommonTriggerOrderPageEvent


TriggerPageEvent Constructor

TriggerPageEvent Constructor
Initializes a new instance of the TriggerPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerPageEvent()
Public Sub New
public:
TriggerPageEvent()
new : unit -> TriggerPageEvent
See Also

Reference

TriggerPageEvent Class
Sitecore.Commerce.Pipelines.Common Namespace


TriggerPageEvent Methods

TriggerPageEvent Methods

The TriggerPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data.
Protected method | GetPageEventText | Gets the page event text.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerPageEvent Class
Sitecore.Commerce.Pipelines.Common Namespace


TriggerPageEvent.GetPageEventData Method

TriggerPageEventGetPageEventData Method
Gets the page event data.

Namespace: Sitecore.Commerce.Pipelines.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual string GetPageEventData(
    ServicePipelineArgs args
)
Protected Overridable Function GetPageEventData (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventData(
    ServicePipelineArgs^ args
)
abstract GetPageEventData :
        args : ServicePipelineArgs -> string
override GetPageEventData :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
The page event data.
See Also

Reference

TriggerPageEvent Class
Sitecore.Commerce.Pipelines.Common Namespace


TriggerPageEvent.GetPageEventText Method

TriggerPageEventGetPageEventText Method
Gets the page event text.

Namespace: Sitecore.Commerce.Pipelines.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual string GetPageEventText(
    ServicePipelineArgs args
)
Protected Overridable Function GetPageEventText (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventText(
    ServicePipelineArgs^ args
)
abstract GetPageEventText :
        args : ServicePipelineArgs -> string
override GetPageEventText :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
The page event text.
See Also

Reference

TriggerPageEvent Class
Sitecore.Commerce.Pipelines.Common Namespace


TriggerPageEvent.Process Method

TriggerPageEventProcess Method
Executes the business logic of the TriggerPageEevent processor.

Namespace: Sitecore.Commerce.Pipelines.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

TriggerPageEvent Class
Sitecore.Commerce.Pipelines.Common Namespace


TriggerPageEvent Properties

TriggerPageEvent Properties

The TriggerPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger.
Public property | Text | Gets or sets the page event text.
Top
See Also

Reference

TriggerPageEvent Class
Sitecore.Commerce.Pipelines.Common Namespace


TriggerPageEvent.Name Property

TriggerPageEventName Property
Gets or sets the name of the page event to trigger.

Namespace: Sitecore.Commerce.Pipelines.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

TriggerPageEvent Class
Sitecore.Commerce.Pipelines.Common Namespace


TriggerPageEvent.Text Property

TriggerPageEventText Property
Gets or sets the page event text.

Namespace: Sitecore.Commerce.Pipelines.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
The page event text.
See Also

Reference

TriggerPageEvent Class
Sitecore.Commerce.Pipelines.Common Namespace


Sitecore.Commerce.Pipelines.ContentIndex.CustomIndex Namespace

Sitecore.Commerce.Pipelines.ContentIndex.CustomIndex Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.ContentIndex.CustomIndex"]

Classes
 | Class | Description
Public class | FetchCustomIndex | Defines the pipeline processor that fetches custom index for products.


FetchCustomIndex Class

FetchCustomIndex Class
Defines the pipeline processor that fetches custom index for products.
Inheritance Hierarchy
SystemObject
SearchPipelineProcessorGetContextIndexArgs
GetContextIndexProcessor
Sitecore.Commerce.Pipelines.ContentIndex.CustomIndexFetchCustomIndex

Namespace: Sitecore.Commerce.Pipelines.ContentIndex.CustomIndex
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class FetchCustomIndex : GetContextIndexProcessor
Public Class FetchCustomIndex
    Inherits GetContextIndexProcessor
public ref class FetchCustomIndex : public GetContextIndexProcessor
type FetchCustomIndex =
    class
        inherit GetContextIndexProcessor
    end

The FetchCustomIndex type exposes the following members.

Constructors
 | Name | Description
Public method | FetchCustomIndex | Initializes a new instance of the FetchCustomIndex class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetContextIndex | Gets the index of the context.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Defines the fetch custom index pipeline processor class. (Overrides SearchPipelineProcessor.Process(UTP).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.ContentIndex.CustomIndex Namespace


FetchCustomIndex Constructor

FetchCustomIndex Constructor
Initializes a new instance of the FetchCustomIndex class

Namespace: Sitecore.Commerce.Pipelines.ContentIndex.CustomIndex
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public FetchCustomIndex()
Public Sub New
public:
FetchCustomIndex()
new : unit -> FetchCustomIndex
See Also

Reference

FetchCustomIndex Class
Sitecore.Commerce.Pipelines.ContentIndex.CustomIndex Namespace


FetchCustomIndex Methods

FetchCustomIndex Methods

The FetchCustomIndex type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetContextIndex | Gets the index of the context.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Defines the fetch custom index pipeline processor class. (Overrides SearchPipelineProcessor.Process(UTP).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FetchCustomIndex Class
Sitecore.Commerce.Pipelines.ContentIndex.CustomIndex Namespace


FetchCustomIndex.GetContextIndex Method

FetchCustomIndexGetContextIndex Method
Gets the index of the context.

Namespace: Sitecore.Commerce.Pipelines.ContentIndex.CustomIndex
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual string GetContextIndex(
    IIndexable indexable,
    GetContextIndexArgs args
)
Protected Overridable Function GetContextIndex (
    indexable As IIndexable,
    args As GetContextIndexArgs
) As String
protected:
virtual String^ GetContextIndex(
    IIndexable^ indexable,
    GetContextIndexArgs^ args
)
abstract GetContextIndex :
        indexable : IIndexable *
        args : GetContextIndexArgs -> string
override GetContextIndex :
        indexable : IIndexable *
        args : GetContextIndexArgs -> string

Parameters

indexable
Type: IIndexable
The indexable.
args
Type: GetContextIndexArgs
The arguments.

Return Value

Type: String

[Missing <returns> documentation for "M:Sitecore.Commerce.Pipelines.ContentIndex.CustomIndex.FetchCustomIndex.GetContextIndex(Sitecore.ContentSearch.IIndexable,Sitecore.ContentSearch.Pipelines.GetContextIndex.GetContextIndexArgs)"]

See Also

Reference

FetchCustomIndex Class
Sitecore.Commerce.Pipelines.ContentIndex.CustomIndex Namespace


FetchCustomIndex.Process Method

FetchCustomIndexProcess Method
Defines the fetch custom index pipeline processor class.

Namespace: Sitecore.Commerce.Pipelines.ContentIndex.CustomIndex
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    GetContextIndexArgs args
)
Public Overrides Sub Process (
    args As GetContextIndexArgs
)
public:
virtual void Process(
    GetContextIndexArgs^ args
) override
abstract Process :
        args : GetContextIndexArgs -> unit
override Process :
        args : GetContextIndexArgs -> unit

Parameters

args
Type: GetContextIndexArgs
The pipeline args.
See Also

Reference

FetchCustomIndex Class
Sitecore.Commerce.Pipelines.ContentIndex.CustomIndex Namespace


Sitecore.Commerce.Pipelines.Customers Namespace

Sitecore.Commerce.Pipelines.Customers Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers"]

Classes
 | Class | Description
Public class | AddCustomerPartiesToExternalSystem | Defines the AddCustomerPartiesToExternalSystem class.
Public class | AddCustomerPartiesToSitecore | Ddefines the AddCustomerPartiesToSitecore class.
Public class | AddCustomersToExternalSystem | Defines the AddCustomersToExternalSystem class.
Public class | AddCustomersToSitecore | Ddefines the AddCustomersToSitecore class.
Public class | AddPartiesToExternalSystem | Defines the AddPartiesToExternalSystem class.
Public class | AddPartiesToSitecore | Defines the AddPartiesToSitecore class.
Public class | AddUsersToExternalSystem | Defines the AddUsersToExternalSystem class.
Public class | AddUsersToSitecore | Ddefines the AddUsersToSitecore class.
Public class | GetPartiesFromExternalSystem | Defines the GetPartiesFromExternalSystem class.
Public class | GetPartiesFromSitecore | Defines the GetPartiesFromSitecore class.
Public class | RemoveCustomerPartiesFromExternalSystem | Defines the RemoveCustomerPartiesFromExternalSystem class.
Public class | RemoveCustomerPartiesFromSitecore | Defines the RemoveCustomerPartiesFromSitecore class.
Public class | RemoveCustomersFromExternalSystem | Defines the RemoveCustomersFromExternalSystem class.
Public class | RemoveCustomersFromSitecore | Ddefines the RemoveCustomersFromSitecore class.
Public class | RemovePartiesFromExternalSystem | Defines the RemovePartiesFromExternalSystem class.
Public class | RemovePartiesFromSitecore | Defines the RemovePartiesFromSitecore class.
Public class | RemoveUsersFromExternalSystem | Defines the RemoveUsersFromExternalSystem class.
Public class | RemoveUsersFromSitecore | Ddefines the RemoveUsersFromSitecore class.
Public class | UpdateCustomerPartiesInExternalSystem | Defines the UpdateCustomerPartiesInExternalSystem class.
Public class | UpdateCustomerPartiesInSitecore | Dedfines the UpdateCustomerPartiesInSitecore class.
Public class | UpdatePartiesInSitecore | Defines the UpdatePartiesInSitecore class.
Public class | UpdatePassword | Defines the processor that updates the user password.


AddCustomerPartiesToExternalSystem Class

AddCustomerPartiesToExternalSystem Class
Defines the AddCustomerPartiesToExternalSystem class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CustomersAddCustomerPartiesToExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddCustomerPartiesToExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class AddCustomerPartiesToExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class AddCustomerPartiesToExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type AddCustomerPartiesToExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The AddCustomerPartiesToExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | AddCustomerPartiesToExternalSystem | Initializes a new instance of the AddCustomerPartiesToExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomerPartiesToExternalSystem Constructor

AddCustomerPartiesToExternalSystem Constructor
Initializes a new instance of the AddCustomerPartiesToExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddCustomerPartiesToExternalSystem()
Public Sub New
public:
AddCustomerPartiesToExternalSystem()
new : unit -> AddCustomerPartiesToExternalSystem
See Also

Reference

AddCustomerPartiesToExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomerPartiesToExternalSystem Methods

AddCustomerPartiesToExternalSystem Methods

The AddCustomerPartiesToExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddCustomerPartiesToExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomerPartiesToExternalSystem.Process Method

AddCustomerPartiesToExternalSystemProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

AddCustomerPartiesToExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomerPartiesToSitecore Class

AddCustomerPartiesToSitecore Class
Ddefines the AddCustomerPartiesToSitecore class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.CustomersAddCustomerPartiesToSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddCustomerPartiesToSitecore : CustomerPipelineProcessor
Public Class AddCustomerPartiesToSitecore
    Inherits CustomerPipelineProcessor
public ref class AddCustomerPartiesToSitecore : public CustomerPipelineProcessor
type AddCustomerPartiesToSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The AddCustomerPartiesToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | AddCustomerPartiesToSitecore | Initializes a new instance of the AddCustomerPartiesToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomerPartiesToSitecore Constructor

AddCustomerPartiesToSitecore Constructor
Initializes a new instance of the AddCustomerPartiesToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddCustomerPartiesToSitecore(
    ICustomerRepository customerRepository
)
Public Sub New (
    customerRepository As ICustomerRepository
)
public:
AddCustomerPartiesToSitecore(
    ICustomerRepository^ customerRepository
)
new :
        customerRepository : ICustomerRepository -> AddCustomerPartiesToSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The customer repository.
See Also

Reference

AddCustomerPartiesToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomerPartiesToSitecore Methods

AddCustomerPartiesToSitecore Methods

The AddCustomerPartiesToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddCustomerPartiesToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomerPartiesToSitecore.Process Method

AddCustomerPartiesToSitecoreProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

AddCustomerPartiesToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomerPartiesToSitecore Properties

AddCustomerPartiesToSitecore Properties

The AddCustomerPartiesToSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

AddCustomerPartiesToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomersToExternalSystem Class

AddCustomersToExternalSystem Class
Defines the AddCustomersToExternalSystem class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CustomersAddCustomersToExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddCustomersToExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class AddCustomersToExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class AddCustomersToExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type AddCustomersToExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The AddCustomersToExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | AddCustomersToExternalSystem | Initializes a new instance of the AddCustomersToExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomersToExternalSystem Constructor

AddCustomersToExternalSystem Constructor
Initializes a new instance of the AddCustomersToExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddCustomersToExternalSystem()
Public Sub New
public:
AddCustomersToExternalSystem()
new : unit -> AddCustomersToExternalSystem
See Also

Reference

AddCustomersToExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomersToExternalSystem Methods

AddCustomersToExternalSystem Methods

The AddCustomersToExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddCustomersToExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomersToExternalSystem.Process Method

AddCustomersToExternalSystemProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

AddCustomersToExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomersToSitecore Class

AddCustomersToSitecore Class
Ddefines the AddCustomersToSitecore class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonUserPipelineProcessor
Sitecore.Commerce.Pipelines.CustomersAddCustomersToSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddCustomersToSitecore : UserPipelineProcessor
Public Class AddCustomersToSitecore
    Inherits UserPipelineProcessor
public ref class AddCustomersToSitecore : public UserPipelineProcessor
type AddCustomersToSitecore =
    class
        inherit UserPipelineProcessor
    end

The AddCustomersToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | AddCustomersToSitecore | Initializes a new instance of the AddCustomersToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomersToSitecore Constructor

AddCustomersToSitecore Constructor
Initializes a new instance of the AddCustomersToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddCustomersToSitecore(
    IUserRepository userRepository
)
Public Sub New (
    userRepository As IUserRepository
)
public:
AddCustomersToSitecore(
    IUserRepository^ userRepository
)
new :
        userRepository : IUserRepository -> AddCustomersToSitecore

Parameters

userRepository
Type: Sitecore.Commerce.Data.CustomersIUserRepository
The user repository.
See Also

Reference

AddCustomersToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomersToSitecore Methods

AddCustomersToSitecore Methods

The AddCustomersToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddCustomersToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomersToSitecore.Process Method

AddCustomersToSitecoreProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

AddCustomersToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddCustomersToSitecore Properties

AddCustomersToSitecore Properties

The AddCustomersToSitecore type exposes the following members.

Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

AddCustomersToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddPartiesToExternalSystem Class

AddPartiesToExternalSystem Class
Defines the AddPartiesToExternalSystem class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CustomersAddPartiesToExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddPartiesToExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class AddPartiesToExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class AddPartiesToExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type AddPartiesToExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The AddPartiesToExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | AddPartiesToExternalSystem | Initializes a new instance of the AddPartiesToExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


AddPartiesToExternalSystem Constructor

AddPartiesToExternalSystem Constructor
Initializes a new instance of the AddPartiesToExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddPartiesToExternalSystem()
Public Sub New
public:
AddPartiesToExternalSystem()
new : unit -> AddPartiesToExternalSystem
See Also

Reference

AddPartiesToExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddPartiesToExternalSystem Methods

AddPartiesToExternalSystem Methods

The AddPartiesToExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddPartiesToExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddPartiesToExternalSystem.Process Method

AddPartiesToExternalSystemProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

AddPartiesToExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddPartiesToSitecore Class

AddPartiesToSitecore Class
Defines the AddPartiesToSitecore class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.CustomersAddPartiesToSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddPartiesToSitecore : CustomerPipelineProcessor
Public Class AddPartiesToSitecore
    Inherits CustomerPipelineProcessor
public ref class AddPartiesToSitecore : public CustomerPipelineProcessor
type AddPartiesToSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The AddPartiesToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | AddPartiesToSitecore | Initializes a new instance of the AddPartiesToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


AddPartiesToSitecore Constructor

AddPartiesToSitecore Constructor
Initializes a new instance of the AddPartiesToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddPartiesToSitecore(
    ICustomerRepository customerRepository
)
Public Sub New (
    customerRepository As ICustomerRepository
)
public:
AddPartiesToSitecore(
    ICustomerRepository^ customerRepository
)
new :
        customerRepository : ICustomerRepository -> AddPartiesToSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The customer repository.
See Also

Reference

AddPartiesToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddPartiesToSitecore Methods

AddPartiesToSitecore Methods

The AddPartiesToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddPartiesToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddPartiesToSitecore.Process Method

AddPartiesToSitecoreProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

AddPartiesToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddPartiesToSitecore Properties

AddPartiesToSitecore Properties

The AddPartiesToSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

AddPartiesToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddUsersToExternalSystem Class

AddUsersToExternalSystem Class
Defines the AddUsersToExternalSystem class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CustomersAddUsersToExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddUsersToExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class AddUsersToExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class AddUsersToExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type AddUsersToExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The AddUsersToExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | AddUsersToExternalSystem | Initializes a new instance of the AddUsersToExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


AddUsersToExternalSystem Constructor

AddUsersToExternalSystem Constructor
Initializes a new instance of the AddUsersToExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddUsersToExternalSystem()
Public Sub New
public:
AddUsersToExternalSystem()
new : unit -> AddUsersToExternalSystem
See Also

Reference

AddUsersToExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddUsersToExternalSystem Methods

AddUsersToExternalSystem Methods

The AddUsersToExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddUsersToExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddUsersToExternalSystem.Process Method

AddUsersToExternalSystemProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

AddUsersToExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddUsersToSitecore Class

AddUsersToSitecore Class
Ddefines the AddUsersToSitecore class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.CustomersAddUsersToSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddUsersToSitecore : CustomerPipelineProcessor
Public Class AddUsersToSitecore
    Inherits CustomerPipelineProcessor
public ref class AddUsersToSitecore : public CustomerPipelineProcessor
type AddUsersToSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The AddUsersToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | AddUsersToSitecore | Initializes a new instance of the AddUsersToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


AddUsersToSitecore Constructor

AddUsersToSitecore Constructor
Initializes a new instance of the AddUsersToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddUsersToSitecore(
    ICustomerRepository customerRepository
)
Public Sub New (
    customerRepository As ICustomerRepository
)
public:
AddUsersToSitecore(
    ICustomerRepository^ customerRepository
)
new :
        customerRepository : ICustomerRepository -> AddUsersToSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The customer repository.
See Also

Reference

AddUsersToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddUsersToSitecore Methods

AddUsersToSitecore Methods

The AddUsersToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddUsersToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddUsersToSitecore.Process Method

AddUsersToSitecoreProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

AddUsersToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


AddUsersToSitecore Properties

AddUsersToSitecore Properties

The AddUsersToSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

AddUsersToSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


GetPartiesFromExternalSystem Class

GetPartiesFromExternalSystem Class
Defines the GetPartiesFromExternalSystem class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CustomersGetPartiesFromExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetPartiesFromExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class GetPartiesFromExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class GetPartiesFromExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type GetPartiesFromExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The GetPartiesFromExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | GetPartiesFromExternalSystem | Initializes a new instance of the GetPartiesFromExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


GetPartiesFromExternalSystem Constructor

GetPartiesFromExternalSystem Constructor
Initializes a new instance of the GetPartiesFromExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetPartiesFromExternalSystem()
Public Sub New
public:
GetPartiesFromExternalSystem()
new : unit -> GetPartiesFromExternalSystem
See Also

Reference

GetPartiesFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


GetPartiesFromExternalSystem Methods

GetPartiesFromExternalSystem Methods

The GetPartiesFromExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetPartiesFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


GetPartiesFromExternalSystem.Process Method

GetPartiesFromExternalSystemProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

GetPartiesFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


GetPartiesFromSitecore Class

GetPartiesFromSitecore Class
Defines the GetPartiesFromSitecore class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.CustomersGetPartiesFromSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetPartiesFromSitecore : CustomerPipelineProcessor
Public Class GetPartiesFromSitecore
    Inherits CustomerPipelineProcessor
public ref class GetPartiesFromSitecore : public CustomerPipelineProcessor
type GetPartiesFromSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The GetPartiesFromSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | GetPartiesFromSitecore | Initializes a new instance of the GetPartiesFromSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


GetPartiesFromSitecore Constructor

GetPartiesFromSitecore Constructor
Initializes a new instance of the GetPartiesFromSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetPartiesFromSitecore(
    ICustomerRepository customerRepository
)
Public Sub New (
    customerRepository As ICustomerRepository
)
public:
GetPartiesFromSitecore(
    ICustomerRepository^ customerRepository
)
new :
        customerRepository : ICustomerRepository -> GetPartiesFromSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The customer repository.
See Also

Reference

GetPartiesFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


GetPartiesFromSitecore Methods

GetPartiesFromSitecore Methods

The GetPartiesFromSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetPartiesFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


GetPartiesFromSitecore.Process Method

GetPartiesFromSitecoreProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

GetPartiesFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


GetPartiesFromSitecore Properties

GetPartiesFromSitecore Properties

The GetPartiesFromSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

GetPartiesFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomerPartiesFromExternalSystem Class

RemoveCustomerPartiesFromExternalSystem Class
Defines the RemoveCustomerPartiesFromExternalSystem class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CustomersRemoveCustomerPartiesFromExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveCustomerPartiesFromExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class RemoveCustomerPartiesFromExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class RemoveCustomerPartiesFromExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type RemoveCustomerPartiesFromExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The RemoveCustomerPartiesFromExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveCustomerPartiesFromExternalSystem | Initializes a new instance of the RemoveCustomerPartiesFromExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomerPartiesFromExternalSystem Constructor

RemoveCustomerPartiesFromExternalSystem Constructor
Initializes a new instance of the RemoveCustomerPartiesFromExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveCustomerPartiesFromExternalSystem()
Public Sub New
public:
RemoveCustomerPartiesFromExternalSystem()
new : unit -> RemoveCustomerPartiesFromExternalSystem
See Also

Reference

RemoveCustomerPartiesFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomerPartiesFromExternalSystem Methods

RemoveCustomerPartiesFromExternalSystem Methods

The RemoveCustomerPartiesFromExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveCustomerPartiesFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomerPartiesFromExternalSystem.Process Method

RemoveCustomerPartiesFromExternalSystemProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RemoveCustomerPartiesFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomerPartiesFromSitecore Class

RemoveCustomerPartiesFromSitecore Class
Defines the RemoveCustomerPartiesFromSitecore class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.CustomersRemoveCustomerPartiesFromSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveCustomerPartiesFromSitecore : CustomerPipelineProcessor
Public Class RemoveCustomerPartiesFromSitecore
    Inherits CustomerPipelineProcessor
public ref class RemoveCustomerPartiesFromSitecore : public CustomerPipelineProcessor
type RemoveCustomerPartiesFromSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The RemoveCustomerPartiesFromSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveCustomerPartiesFromSitecore | Initializes a new instance of the RemoveCustomerPartiesFromSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomerPartiesFromSitecore Constructor

RemoveCustomerPartiesFromSitecore Constructor
Initializes a new instance of the RemoveCustomerPartiesFromSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveCustomerPartiesFromSitecore(
    ICustomerRepository customerRepository
)
Public Sub New (
    customerRepository As ICustomerRepository
)
public:
RemoveCustomerPartiesFromSitecore(
    ICustomerRepository^ customerRepository
)
new :
        customerRepository : ICustomerRepository -> RemoveCustomerPartiesFromSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The customer repository.
See Also

Reference

RemoveCustomerPartiesFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomerPartiesFromSitecore Methods

RemoveCustomerPartiesFromSitecore Methods

The RemoveCustomerPartiesFromSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveCustomerPartiesFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomerPartiesFromSitecore.Process Method

RemoveCustomerPartiesFromSitecoreProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RemoveCustomerPartiesFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomerPartiesFromSitecore Properties

RemoveCustomerPartiesFromSitecore Properties

The RemoveCustomerPartiesFromSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

RemoveCustomerPartiesFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomersFromExternalSystem Class

RemoveCustomersFromExternalSystem Class
Defines the RemoveCustomersFromExternalSystem class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CustomersRemoveCustomersFromExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveCustomersFromExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class RemoveCustomersFromExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class RemoveCustomersFromExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type RemoveCustomersFromExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The RemoveCustomersFromExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveCustomersFromExternalSystem | Initializes a new instance of the RemoveCustomersFromExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomersFromExternalSystem Constructor

RemoveCustomersFromExternalSystem Constructor
Initializes a new instance of the RemoveCustomersFromExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveCustomersFromExternalSystem()
Public Sub New
public:
RemoveCustomersFromExternalSystem()
new : unit -> RemoveCustomersFromExternalSystem
See Also

Reference

RemoveCustomersFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomersFromExternalSystem Methods

RemoveCustomersFromExternalSystem Methods

The RemoveCustomersFromExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveCustomersFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomersFromExternalSystem.Process Method

RemoveCustomersFromExternalSystemProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RemoveCustomersFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomersFromSitecore Class

RemoveCustomersFromSitecore Class
Ddefines the RemoveCustomersFromSitecore class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonUserPipelineProcessor
Sitecore.Commerce.Pipelines.CustomersRemoveCustomersFromSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveCustomersFromSitecore : UserPipelineProcessor
Public Class RemoveCustomersFromSitecore
    Inherits UserPipelineProcessor
public ref class RemoveCustomersFromSitecore : public UserPipelineProcessor
type RemoveCustomersFromSitecore =
    class
        inherit UserPipelineProcessor
    end

The RemoveCustomersFromSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveCustomersFromSitecore | Initializes a new instance of the RemoveCustomersFromSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomersFromSitecore Constructor

RemoveCustomersFromSitecore Constructor
Initializes a new instance of the RemoveCustomersFromSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveCustomersFromSitecore(
    IUserRepository userRepository
)
Public Sub New (
    userRepository As IUserRepository
)
public:
RemoveCustomersFromSitecore(
    IUserRepository^ userRepository
)
new :
        userRepository : IUserRepository -> RemoveCustomersFromSitecore

Parameters

userRepository
Type: Sitecore.Commerce.Data.CustomersIUserRepository
The user repository.
See Also

Reference

RemoveCustomersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomersFromSitecore Methods

RemoveCustomersFromSitecore Methods

The RemoveCustomersFromSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveCustomersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomersFromSitecore.Process Method

RemoveCustomersFromSitecoreProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RemoveCustomersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveCustomersFromSitecore Properties

RemoveCustomersFromSitecore Properties

The RemoveCustomersFromSitecore type exposes the following members.

Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

RemoveCustomersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemovePartiesFromExternalSystem Class

RemovePartiesFromExternalSystem Class
Defines the RemovePartiesFromExternalSystem class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CustomersRemovePartiesFromExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemovePartiesFromExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class RemovePartiesFromExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class RemovePartiesFromExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type RemovePartiesFromExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The RemovePartiesFromExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | RemovePartiesFromExternalSystem | Initializes a new instance of the RemovePartiesFromExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


RemovePartiesFromExternalSystem Constructor

RemovePartiesFromExternalSystem Constructor
Initializes a new instance of the RemovePartiesFromExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemovePartiesFromExternalSystem()
Public Sub New
public:
RemovePartiesFromExternalSystem()
new : unit -> RemovePartiesFromExternalSystem
See Also

Reference

RemovePartiesFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemovePartiesFromExternalSystem Methods

RemovePartiesFromExternalSystem Methods

The RemovePartiesFromExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemovePartiesFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemovePartiesFromExternalSystem.Process Method

RemovePartiesFromExternalSystemProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RemovePartiesFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemovePartiesFromSitecore Class

RemovePartiesFromSitecore Class
Defines the RemovePartiesFromSitecore class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.CustomersRemovePartiesFromSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemovePartiesFromSitecore : CustomerPipelineProcessor
Public Class RemovePartiesFromSitecore
    Inherits CustomerPipelineProcessor
public ref class RemovePartiesFromSitecore : public CustomerPipelineProcessor
type RemovePartiesFromSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The RemovePartiesFromSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | RemovePartiesFromSitecore | Initializes a new instance of the RemovePartiesFromSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | RemoveParties Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


RemovePartiesFromSitecore Constructor

RemovePartiesFromSitecore Constructor
Initializes a new instance of the RemovePartiesFromSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemovePartiesFromSitecore(
    ICustomerRepository customerRepository
)
Public Sub New (
    customerRepository As ICustomerRepository
)
public:
RemovePartiesFromSitecore(
    ICustomerRepository^ customerRepository
)
new :
        customerRepository : ICustomerRepository -> RemovePartiesFromSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The customer repository.
See Also

Reference

RemovePartiesFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemovePartiesFromSitecore Methods

RemovePartiesFromSitecore Methods

The RemovePartiesFromSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | RemoveParties Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemovePartiesFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemovePartiesFromSitecore.Process Method

RemovePartiesFromSitecoreProcess Method
RemoveParties Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RemovePartiesFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemovePartiesFromSitecore Properties

RemovePartiesFromSitecore Properties

The RemovePartiesFromSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

RemovePartiesFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveUsersFromExternalSystem Class

RemoveUsersFromExternalSystem Class
Defines the RemoveUsersFromExternalSystem class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CustomersRemoveUsersFromExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveUsersFromExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class RemoveUsersFromExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class RemoveUsersFromExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type RemoveUsersFromExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The RemoveUsersFromExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveUsersFromExternalSystem | Initializes a new instance of the RemoveUsersFromExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


RemoveUsersFromExternalSystem Constructor

RemoveUsersFromExternalSystem Constructor
Initializes a new instance of the RemoveUsersFromExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveUsersFromExternalSystem()
Public Sub New
public:
RemoveUsersFromExternalSystem()
new : unit -> RemoveUsersFromExternalSystem
See Also

Reference

RemoveUsersFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveUsersFromExternalSystem Methods

RemoveUsersFromExternalSystem Methods

The RemoveUsersFromExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveUsersFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveUsersFromExternalSystem.Process Method

RemoveUsersFromExternalSystemProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RemoveUsersFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveUsersFromSitecore Class

RemoveUsersFromSitecore Class
Ddefines the RemoveUsersFromSitecore class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.CustomersRemoveUsersFromSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveUsersFromSitecore : CustomerPipelineProcessor
Public Class RemoveUsersFromSitecore
    Inherits CustomerPipelineProcessor
public ref class RemoveUsersFromSitecore : public CustomerPipelineProcessor
type RemoveUsersFromSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The RemoveUsersFromSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveUsersFromSitecore | Initializes a new instance of the RemoveUsersFromSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


RemoveUsersFromSitecore Constructor

RemoveUsersFromSitecore Constructor
Initializes a new instance of the RemoveUsersFromSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveUsersFromSitecore(
    ICustomerRepository customerRepository
)
Public Sub New (
    customerRepository As ICustomerRepository
)
public:
RemoveUsersFromSitecore(
    ICustomerRepository^ customerRepository
)
new :
        customerRepository : ICustomerRepository -> RemoveUsersFromSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The customer repository.
See Also

Reference

RemoveUsersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveUsersFromSitecore Methods

RemoveUsersFromSitecore Methods

The RemoveUsersFromSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveUsersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveUsersFromSitecore.Process Method

RemoveUsersFromSitecoreProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RemoveUsersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


RemoveUsersFromSitecore Properties

RemoveUsersFromSitecore Properties

The RemoveUsersFromSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

RemoveUsersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdateCustomerPartiesInExternalSystem Class

UpdateCustomerPartiesInExternalSystem Class
Defines the UpdateCustomerPartiesInExternalSystem class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CustomersUpdateCustomerPartiesInExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateCustomerPartiesInExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class UpdateCustomerPartiesInExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class UpdateCustomerPartiesInExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type UpdateCustomerPartiesInExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The UpdateCustomerPartiesInExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateCustomerPartiesInExternalSystem | Initializes a new instance of the UpdateCustomerPartiesInExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


UpdateCustomerPartiesInExternalSystem Constructor

UpdateCustomerPartiesInExternalSystem Constructor
Initializes a new instance of the UpdateCustomerPartiesInExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateCustomerPartiesInExternalSystem()
Public Sub New
public:
UpdateCustomerPartiesInExternalSystem()
new : unit -> UpdateCustomerPartiesInExternalSystem
See Also

Reference

UpdateCustomerPartiesInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdateCustomerPartiesInExternalSystem Methods

UpdateCustomerPartiesInExternalSystem Methods

The UpdateCustomerPartiesInExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateCustomerPartiesInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdateCustomerPartiesInExternalSystem.Process Method

UpdateCustomerPartiesInExternalSystemProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

UpdateCustomerPartiesInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdateCustomerPartiesInSitecore Class

UpdateCustomerPartiesInSitecore Class
Dedfines the UpdateCustomerPartiesInSitecore class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.CustomersUpdateCustomerPartiesInSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateCustomerPartiesInSitecore : CustomerPipelineProcessor
Public Class UpdateCustomerPartiesInSitecore
    Inherits CustomerPipelineProcessor
public ref class UpdateCustomerPartiesInSitecore : public CustomerPipelineProcessor
type UpdateCustomerPartiesInSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The UpdateCustomerPartiesInSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateCustomerPartiesInSitecore | Initializes a new instance of the UpdateCustomerPartiesInSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


UpdateCustomerPartiesInSitecore Constructor

UpdateCustomerPartiesInSitecore Constructor
Initializes a new instance of the UpdateCustomerPartiesInSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateCustomerPartiesInSitecore(
    ICustomerRepository customerRepository
)
Public Sub New (
    customerRepository As ICustomerRepository
)
public:
UpdateCustomerPartiesInSitecore(
    ICustomerRepository^ customerRepository
)
new :
        customerRepository : ICustomerRepository -> UpdateCustomerPartiesInSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The customer repository.
See Also

Reference

UpdateCustomerPartiesInSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdateCustomerPartiesInSitecore Methods

UpdateCustomerPartiesInSitecore Methods

The UpdateCustomerPartiesInSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateCustomerPartiesInSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdateCustomerPartiesInSitecore.Process Method

UpdateCustomerPartiesInSitecoreProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

UpdateCustomerPartiesInSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdateCustomerPartiesInSitecore Properties

UpdateCustomerPartiesInSitecore Properties

The UpdateCustomerPartiesInSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

UpdateCustomerPartiesInSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdatePartiesInSitecore Class

UpdatePartiesInSitecore Class
Defines the UpdatePartiesInSitecore class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.CustomersUpdatePartiesInSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdatePartiesInSitecore : CustomerPipelineProcessor
Public Class UpdatePartiesInSitecore
    Inherits CustomerPipelineProcessor
public ref class UpdatePartiesInSitecore : public CustomerPipelineProcessor
type UpdatePartiesInSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The UpdatePartiesInSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | UpdatePartiesInSitecore | Initializes a new instance of the UpdatePartiesInSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


UpdatePartiesInSitecore Constructor

UpdatePartiesInSitecore Constructor
Initializes a new instance of the UpdatePartiesInSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdatePartiesInSitecore(
    ICustomerRepository customerRepository
)
Public Sub New (
    customerRepository As ICustomerRepository
)
public:
UpdatePartiesInSitecore(
    ICustomerRepository^ customerRepository
)
new :
        customerRepository : ICustomerRepository -> UpdatePartiesInSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The customer repository.
See Also

Reference

UpdatePartiesInSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdatePartiesInSitecore Methods

UpdatePartiesInSitecore Methods

The UpdatePartiesInSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdatePartiesInSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdatePartiesInSitecore.Process Method

UpdatePartiesInSitecoreProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

UpdatePartiesInSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdatePartiesInSitecore Properties

UpdatePartiesInSitecore Properties

The UpdatePartiesInSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

UpdatePartiesInSitecore Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdatePassword Class

UpdatePassword Class
Defines the processor that updates the user password.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonUserPipelineProcessor
Sitecore.Commerce.Pipelines.CustomersUpdatePassword

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdatePassword : UserPipelineProcessor
Public Class UpdatePassword
    Inherits UserPipelineProcessor
public ref class UpdatePassword : public UserPipelineProcessor
type UpdatePassword =
    class
        inherit UserPipelineProcessor
    end

The UpdatePassword type exposes the following members.

Constructors
 | Name | Description
Public method | UpdatePassword | Initializes a new instance of the UpdatePassword class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the UpdatePassword processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers Namespace


UpdatePassword Constructor

UpdatePassword Constructor
Initializes a new instance of the UpdatePassword class.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdatePassword(
    IUserRepository userRepository
)
Public Sub New (
    userRepository As IUserRepository
)
public:
UpdatePassword(
    IUserRepository^ userRepository
)
new :
        userRepository : IUserRepository -> UpdatePassword

Parameters

userRepository
Type: Sitecore.Commerce.Data.CustomersIUserRepository
The user repository.
See Also

Reference

UpdatePassword Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdatePassword Methods

UpdatePassword Methods

The UpdatePassword type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the UpdatePassword processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdatePassword Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdatePassword.Process Method

UpdatePasswordProcess Method
Executes the business logic of the UpdatePassword processor.

Namespace: Sitecore.Commerce.Pipelines.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

UpdatePassword Class
Sitecore.Commerce.Pipelines.Customers Namespace


UpdatePassword Properties

UpdatePassword Properties

The UpdatePassword type exposes the following members.

Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

UpdatePassword Class
Sitecore.Commerce.Pipelines.Customers Namespace


Sitecore.Commerce.Pipelines.Customers.Common Namespace

Sitecore.Commerce.Pipelines.Customers.Common Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.Common"]

Classes
 | Class | Description
Public class | CustomerPipelineProcessor | Defines the base class used by all customer pipeline processors.
Public class | ManageUserInSitecore | Defines the processor that manages the user in Sitecore. The ManageUserInSitecore processor checks whether the user does not exist and if so, stops the pipeline and processes a request to change the user account in Sitecore.
Public class | TriggerAccountPageEvent | Defines the processor that triggers the page event of an account. This class implements the TriggerPageEvent class.
Public class | TriggerCustomerGoal | Defines the processor that triggers the event of a customer goal. This class implements the TriggerCustomerPageEvent class.
Public class | TriggerCustomerPageEvent | Defines the processor that triggers the page event of a customer. This class implements the TriggerAccountPageEvent class.
Public class | TriggerUserGoal | Defines the processor that triggers the goal for user. This class implements the TriggerUserPageEvent class.
Public class | TriggerUserPageEvent | Defines the processor that triggers page event for a user. This class implements the TriggerAccountPageEvent class.
Public class | UserPipelineProcessor | Defines the base class used by all user pipeline processors.


CustomerPipelineProcessor Class

CustomerPipelineProcessor Class
Defines the base class used by all customer pipeline processors.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
More...

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class CustomerPipelineProcessor : PipelineProcessor<ServicePipelineArgs>
Public MustInherit Class CustomerPipelineProcessor
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class CustomerPipelineProcessor abstract : public PipelineProcessor<ServicePipelineArgs^>
[<AbstractClassAttribute>]
type CustomerPipelineProcessor =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The CustomerPipelineProcessor type exposes the following members.

Constructors
 | Name | Description
Public method | CustomerPipelineProcessor | Initializes a new instance of the CustomerPipelineProcessor class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Inherited from PipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.Common Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.CustomersAddCustomerPartiesToSitecore
Sitecore.Commerce.Pipelines.CustomersAddPartiesToSitecore
Sitecore.Commerce.Pipelines.CustomersAddUsersToSitecore
Sitecore.Commerce.Pipelines.Customers.CreateCustomerCreateCustomerInSitecore
Sitecore.Commerce.Pipelines.Customers.DeleteCustomerDeleteCustomerFromSitecore
Sitecore.Commerce.Pipelines.Customers.DisableCustomerDisableCustomerInSitecore
Sitecore.Commerce.Pipelines.Customers.EnableCustomerEnableCustomerInSitecore
Sitecore.Commerce.Pipelines.Customers.GetCustomerGetCustomerFromSitecore
Sitecore.Commerce.Pipelines.Customers.GetCustomersGetCustomersFromSitecore
Sitecore.Commerce.Pipelines.CustomersGetPartiesFromSitecore
Sitecore.Commerce.Pipelines.CustomersRemoveCustomerPartiesFromSitecore
Sitecore.Commerce.Pipelines.CustomersRemovePartiesFromSitecore
Sitecore.Commerce.Pipelines.CustomersRemoveUsersFromSitecore
Sitecore.Commerce.Pipelines.Customers.UpdateCustomerUpdateCustomerInSitecore
Sitecore.Commerce.Pipelines.CustomersUpdateCustomerPartiesInSitecore
Sitecore.Commerce.Pipelines.CustomersUpdatePartiesInSitecore


CustomerPipelineProcessor Constructor

CustomerPipelineProcessor Constructor
Initializes a new instance of the CustomerPipelineProcessor class.

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CustomerPipelineProcessor(
    ICustomerRepository customerRepository
)
Public Sub New (
    customerRepository As ICustomerRepository
)
public:
CustomerPipelineProcessor(
    ICustomerRepository^ customerRepository
)
new :
        customerRepository : ICustomerRepository -> CustomerPipelineProcessor

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The customer repository.
See Also

Reference

CustomerPipelineProcessor Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


CustomerPipelineProcessor Methods

CustomerPipelineProcessor Methods

The CustomerPipelineProcessor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Inherited from PipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomerPipelineProcessor Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


CustomerPipelineProcessor Properties

CustomerPipelineProcessor Properties

The CustomerPipelineProcessor type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository.
Top
See Also

Reference

CustomerPipelineProcessor Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


CustomerPipelineProcessor.CustomerRepository Property

CustomerPipelineProcessorCustomerRepository Property
Gets or sets the customer repository.

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ICustomerRepository CustomerRepository { get; protected set; }
Public Property CustomerRepository As ICustomerRepository
    Get
    Protected Set
public:
property ICustomerRepository^ CustomerRepository {
    ICustomerRepository^ get ();
    protected: void set (ICustomerRepository^ value);
}
member CustomerRepository : ICustomerRepository with get, set

Property Value

Type: ICustomerRepository
The customer repository.
See Also

Reference

CustomerPipelineProcessor Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


ManageUserInSitecore Class

ManageUserInSitecore Class
Defines the processor that manages the user in Sitecore. The ManageUserInSitecore processor checks whether the user does not exist and if so, stops the pipeline and processes a request to change the user account in Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonUserPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.CommonManageUserInSitecore
Sitecore.Commerce.Pipelines.Customers.DeleteUserDeleteUserInSitecore
Sitecore.Commerce.Pipelines.Customers.UpdateUserUpdateUserInSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class ManageUserInSitecore : UserPipelineProcessor
Public MustInherit Class ManageUserInSitecore
    Inherits UserPipelineProcessor
public ref class ManageUserInSitecore abstract : public UserPipelineProcessor
[<AbstractClassAttribute>]
type ManageUserInSitecore =
    class
        inherit UserPipelineProcessor
    end

The ManageUserInSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | ManageUserInSitecore | Initializes a new instance of the ManageUserInSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ManageUserInSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | ProcessSitecoreUser | Processes the user account in sitecore.
Protected method | SetResult | Sets the result.
Protected method | ShouldAbortPipeline | Based on whether a user exists or not, determines whether the pipeline must stop.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.Common Namespace


ManageUserInSitecore Constructor

ManageUserInSitecore Constructor
Initializes a new instance of the ManageUserInSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ManageUserInSitecore(
    IUserRepository userRepository
)
Public Sub New (
    userRepository As IUserRepository
)
public:
ManageUserInSitecore(
    IUserRepository^ userRepository
)
new :
        userRepository : IUserRepository -> ManageUserInSitecore

Parameters

userRepository
Type: Sitecore.Commerce.Data.CustomersIUserRepository
The user repository.
See Also

Reference

ManageUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


ManageUserInSitecore Methods

ManageUserInSitecore Methods

The ManageUserInSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ManageUserInSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | ProcessSitecoreUser | Processes the user account in sitecore.
Protected method | SetResult | Sets the result.
Protected method | ShouldAbortPipeline | Based on whether a user exists or not, determines whether the pipeline must stop.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ManageUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


ManageUserInSitecore.Process Method

ManageUserInSitecoreProcess Method
Executes the business logic of the ManageUserInSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

ManageUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


ManageUserInSitecore.ProcessSitecoreUser Method

ManageUserInSitecoreProcessSitecoreUser Method
Processes the user account in sitecore.

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract void ProcessSitecoreUser(
    CommerceUser user,
    UserRequestWithUser request,
    ServiceProviderResult result
)
Protected MustOverride Sub ProcessSitecoreUser (
    user As CommerceUser,
    request As UserRequestWithUser,
    result As ServiceProviderResult
)
protected:
virtual void ProcessSitecoreUser(
    CommerceUser^ user,
    UserRequestWithUser^ request,
    ServiceProviderResult^ result
) abstract
abstract ProcessSitecoreUser :
        user : CommerceUser *
        request : UserRequestWithUser *
        result : ServiceProviderResult -> unit

Parameters

user
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The user.
request
Type: Sitecore.Commerce.Services.CustomersUserRequestWithUser
The request.
result
Type: Sitecore.Commerce.ServicesServiceProviderResult
The result.
See Also

Reference

ManageUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


ManageUserInSitecore.SetResult Method

ManageUserInSitecoreSetResult Method
Sets the result.

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void SetResult(
    UserRequestWithUser request,
    ServiceProviderResult result
)
Protected Overridable Sub SetResult (
    request As UserRequestWithUser,
    result As ServiceProviderResult
)
protected:
virtual void SetResult(
    UserRequestWithUser^ request,
    ServiceProviderResult^ result
)
abstract SetResult :
        request : UserRequestWithUser *
        result : ServiceProviderResult -> unit
override SetResult :
        request : UserRequestWithUser *
        result : ServiceProviderResult -> unit

Parameters

request
Type: Sitecore.Commerce.Services.CustomersUserRequestWithUser
The request.
result
Type: Sitecore.Commerce.ServicesServiceProviderResult
The result.
See Also

Reference

ManageUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


ManageUserInSitecore.ShouldAbortPipeline Method

ManageUserInSitecoreShouldAbortPipeline Method
Based on whether a user exists or not, determines whether the pipeline must stop.

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual bool ShouldAbortPipeline(
    CommerceUser user
)
Protected Overridable Function ShouldAbortPipeline (
    user As CommerceUser
) As Boolean
protected:
virtual bool ShouldAbortPipeline(
    CommerceUser^ user
)
abstract ShouldAbortPipeline :
        user : CommerceUser -> bool
override ShouldAbortPipeline :
        user : CommerceUser -> bool

Parameters

user
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The user.

Return Value

Type: Boolean
true if the pipeline must stop.
See Also

Reference

ManageUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


ManageUserInSitecore Properties

ManageUserInSitecore Properties

The ManageUserInSitecore type exposes the following members.

Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

ManageUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerAccountPageEvent Class

TriggerAccountPageEvent Class
Defines the processor that triggers the page event of an account. This class implements the TriggerPageEvent class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerAccountPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerCustomerPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerUserPageEvent

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class TriggerAccountPageEvent : TriggerPageEvent
Public MustInherit Class TriggerAccountPageEvent
    Inherits TriggerPageEvent
public ref class TriggerAccountPageEvent abstract : public TriggerPageEvent
[<AbstractClassAttribute>]
type TriggerAccountPageEvent =
    class
        inherit TriggerPageEvent
    end

The TriggerAccountPageEvent type exposes the following members.

Constructors
 | Name | Description
Protected method | TriggerAccountPageEvent | Initializes a new instance of the TriggerAccountPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | The get page event data value from arguments. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventMainData | Gets the page event main data.
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerAccountPageEvent Constructor

TriggerAccountPageEvent Constructor
Initializes a new instance of the TriggerAccountPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected TriggerAccountPageEvent()
Protected Sub New
protected:
TriggerAccountPageEvent()
new : unit -> TriggerAccountPageEvent
See Also

Reference

TriggerAccountPageEvent Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerAccountPageEvent Methods

TriggerAccountPageEvent Methods

The TriggerAccountPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | The get page event data value from arguments. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventMainData | Gets the page event main data.
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerAccountPageEvent Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerAccountPageEvent.GetPageEventData Method

TriggerAccountPageEventGetPageEventData Method
The get page event data value from arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetPageEventData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventData (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventData :
        args : ServicePipelineArgs -> string
override GetPageEventData :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.

Return Value

Type: String
The String.
See Also

Reference

TriggerAccountPageEvent Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerAccountPageEvent.GetPageEventMainData Method

TriggerAccountPageEventGetPageEventMainData Method
Gets the page event main data.

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract IDictionary<string, string> GetPageEventMainData(
    ServicePipelineArgs args
)
Protected MustOverride Function GetPageEventMainData (
    args As ServicePipelineArgs
) As IDictionary(Of String, String)
protected:
virtual IDictionary<String^, String^>^ GetPageEventMainData(
    ServicePipelineArgs^ args
) abstract
abstract GetPageEventMainData :
        args : ServicePipelineArgs -> IDictionary<string, string>

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: IDictionary String, String
The data dictionary.
See Also

Reference

TriggerAccountPageEvent Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerAccountPageEvent Properties

TriggerAccountPageEvent Properties

The TriggerAccountPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerAccountPageEvent Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerCustomerGoal Class

TriggerCustomerGoal Class
Defines the processor that triggers the event of a customer goal. This class implements the TriggerCustomerPageEvent class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerAccountPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerCustomerPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerCustomerGoal

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerCustomerGoal : TriggerCustomerPageEvent
Public Class TriggerCustomerGoal
    Inherits TriggerCustomerPageEvent
public ref class TriggerCustomerGoal : public TriggerCustomerPageEvent
type TriggerCustomerGoal =
    class
        inherit TriggerCustomerPageEvent
    end

The TriggerCustomerGoal type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerCustomerGoal | Initializes a new instance of the TriggerCustomerGoal class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | The get page event data value from arguments. (Inherited from TriggerAccountPageEvent.)
Protected method | GetPageEventMainData | Gets the page event main data. (Inherited from TriggerCustomerPageEvent.)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerCustomerGoal Constructor

TriggerCustomerGoal Constructor
Initializes a new instance of the TriggerCustomerGoal class

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerCustomerGoal()
Public Sub New
public:
TriggerCustomerGoal()
new : unit -> TriggerCustomerGoal
See Also

Reference

TriggerCustomerGoal Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerCustomerGoal Methods

TriggerCustomerGoal Methods

The TriggerCustomerGoal type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | The get page event data value from arguments. (Inherited from TriggerAccountPageEvent.)
Protected method | GetPageEventMainData | Gets the page event main data. (Inherited from TriggerCustomerPageEvent.)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerCustomerGoal Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerCustomerGoal Properties

TriggerCustomerGoal Properties

The TriggerCustomerGoal type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerCustomerGoal Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerCustomerPageEvent Class

TriggerCustomerPageEvent Class
Defines the processor that triggers the page event of a customer. This class implements the TriggerAccountPageEvent class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerAccountPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerCustomerPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerCustomerGoal

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerCustomerPageEvent : TriggerAccountPageEvent
Public Class TriggerCustomerPageEvent
    Inherits TriggerAccountPageEvent
public ref class TriggerCustomerPageEvent : public TriggerAccountPageEvent
type TriggerCustomerPageEvent =
    class
        inherit TriggerAccountPageEvent
    end

The TriggerCustomerPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerCustomerPageEvent | Initializes a new instance of the TriggerCustomerPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | The get page event data value from arguments. (Inherited from TriggerAccountPageEvent.)
Protected method | GetPageEventMainData | Gets the page event main data. (Overrides TriggerAccountPageEventGetPageEventMainData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerCustomerPageEvent Constructor

TriggerCustomerPageEvent Constructor
Initializes a new instance of the TriggerCustomerPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerCustomerPageEvent()
Public Sub New
public:
TriggerCustomerPageEvent()
new : unit -> TriggerCustomerPageEvent
See Also

Reference

TriggerCustomerPageEvent Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerCustomerPageEvent Methods

TriggerCustomerPageEvent Methods

The TriggerCustomerPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | The get page event data value from arguments. (Inherited from TriggerAccountPageEvent.)
Protected method | GetPageEventMainData | Gets the page event main data. (Overrides TriggerAccountPageEventGetPageEventMainData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerCustomerPageEvent Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerCustomerPageEvent.GetPageEventMainData Method

TriggerCustomerPageEventGetPageEventMainData Method
Gets the page event main data.

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IDictionary<string, string> GetPageEventMainData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventMainData (
    args As ServicePipelineArgs
) As IDictionary(Of String, String)
protected:
virtual IDictionary<String^, String^>^ GetPageEventMainData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventMainData :
        args : ServicePipelineArgs -> IDictionary<string, string>
override GetPageEventMainData :
        args : ServicePipelineArgs -> IDictionary<string, string>

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: IDictionary String, String
The data dictionary.
See Also

Reference

TriggerCustomerPageEvent Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerCustomerPageEvent Properties

TriggerCustomerPageEvent Properties

The TriggerCustomerPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerCustomerPageEvent Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerUserGoal Class

TriggerUserGoal Class
Defines the processor that triggers the goal for user. This class implements the TriggerUserPageEvent class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerAccountPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerUserPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerUserGoal

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerUserGoal : TriggerUserPageEvent
Public Class TriggerUserGoal
    Inherits TriggerUserPageEvent
public ref class TriggerUserGoal : public TriggerUserPageEvent
type TriggerUserGoal =
    class
        inherit TriggerUserPageEvent
    end

The TriggerUserGoal type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerUserGoal | Initializes a new instance of the TriggerUserGoal class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | The get page event data value from arguments. (Inherited from TriggerAccountPageEvent.)
Protected method | GetPageEventMainData | Gets the page event main data. (Inherited from TriggerUserPageEvent.)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerUserGoal Constructor

TriggerUserGoal Constructor
Initializes a new instance of the TriggerUserGoal class

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerUserGoal()
Public Sub New
public:
TriggerUserGoal()
new : unit -> TriggerUserGoal
See Also

Reference

TriggerUserGoal Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerUserGoal Methods

TriggerUserGoal Methods

The TriggerUserGoal type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | The get page event data value from arguments. (Inherited from TriggerAccountPageEvent.)
Protected method | GetPageEventMainData | Gets the page event main data. (Inherited from TriggerUserPageEvent.)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerUserGoal Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerUserGoal Properties

TriggerUserGoal Properties

The TriggerUserGoal type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerUserGoal Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerUserPageEvent Class

TriggerUserPageEvent Class
Defines the processor that triggers page event for a user. This class implements the TriggerAccountPageEvent class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerAccountPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerUserPageEvent
Sitecore.Commerce.Pipelines.Customers.CommonTriggerUserGoal

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerUserPageEvent : TriggerAccountPageEvent
Public Class TriggerUserPageEvent
    Inherits TriggerAccountPageEvent
public ref class TriggerUserPageEvent : public TriggerAccountPageEvent
type TriggerUserPageEvent =
    class
        inherit TriggerAccountPageEvent
    end

The TriggerUserPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerUserPageEvent | Initializes a new instance of the TriggerUserPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | The get page event data value from arguments. (Inherited from TriggerAccountPageEvent.)
Protected method | GetPageEventMainData | Gets the page event main data. (Overrides TriggerAccountPageEventGetPageEventMainData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerUserPageEvent Constructor

TriggerUserPageEvent Constructor
Initializes a new instance of the TriggerUserPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerUserPageEvent()
Public Sub New
public:
TriggerUserPageEvent()
new : unit -> TriggerUserPageEvent
See Also

Reference

TriggerUserPageEvent Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerUserPageEvent Methods

TriggerUserPageEvent Methods

The TriggerUserPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | The get page event data value from arguments. (Inherited from TriggerAccountPageEvent.)
Protected method | GetPageEventMainData | Gets the page event main data. (Overrides TriggerAccountPageEventGetPageEventMainData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerUserPageEvent Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerUserPageEvent.GetPageEventMainData Method

TriggerUserPageEventGetPageEventMainData Method
Gets the page event main data.

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IDictionary<string, string> GetPageEventMainData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventMainData (
    args As ServicePipelineArgs
) As IDictionary(Of String, String)
protected:
virtual IDictionary<String^, String^>^ GetPageEventMainData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventMainData :
        args : ServicePipelineArgs -> IDictionary<string, string>
override GetPageEventMainData :
        args : ServicePipelineArgs -> IDictionary<string, string>

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: IDictionary String, String
The data dictionary.
See Also

Reference

TriggerUserPageEvent Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


TriggerUserPageEvent Properties

TriggerUserPageEvent Properties

The TriggerUserPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerUserPageEvent Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


UserPipelineProcessor Class

UserPipelineProcessor Class
Defines the base class used by all user pipeline processors.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonUserPipelineProcessor
More...

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class UserPipelineProcessor : PipelineProcessor<ServicePipelineArgs>
Public MustInherit Class UserPipelineProcessor
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class UserPipelineProcessor abstract : public PipelineProcessor<ServicePipelineArgs^>
[<AbstractClassAttribute>]
type UserPipelineProcessor =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The UserPipelineProcessor type exposes the following members.

Constructors
 | Name | Description
Public method | UserPipelineProcessor | Initializes a new instance of the UserPipelineProcessor class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Inherited from PipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.Common Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonUserPipelineProcessor
Sitecore.Commerce.Pipelines.CustomersAddCustomersToSitecore
Sitecore.Commerce.Pipelines.Customers.CommonManageUserInSitecore
Sitecore.Commerce.Pipelines.Customers.CreateUserCreateUserInSitecore
Sitecore.Commerce.Pipelines.Customers.DisableUserDisableUserInSitecore
Sitecore.Commerce.Pipelines.Customers.EnableUserEnableUserInSitecore
Sitecore.Commerce.Pipelines.Customers.GetUserGetUserFromSitecore
Sitecore.Commerce.Pipelines.Customers.GetUsersGetUsersFromSitecore
Sitecore.Commerce.Pipelines.CustomersRemoveCustomersFromSitecore
Sitecore.Commerce.Pipelines.CustomersUpdatePassword


UserPipelineProcessor Constructor

UserPipelineProcessor Constructor
Initializes a new instance of the UserPipelineProcessor class.

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UserPipelineProcessor(
    IUserRepository userRepository
)
Public Sub New (
    userRepository As IUserRepository
)
public:
UserPipelineProcessor(
    IUserRepository^ userRepository
)
new :
        userRepository : IUserRepository -> UserPipelineProcessor

Parameters

userRepository
Type: Sitecore.Commerce.Data.CustomersIUserRepository
The user repository.
See Also

Reference

UserPipelineProcessor Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


UserPipelineProcessor Methods

UserPipelineProcessor Methods

The UserPipelineProcessor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Inherited from PipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UserPipelineProcessor Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


UserPipelineProcessor Properties

UserPipelineProcessor Properties

The UserPipelineProcessor type exposes the following members.

Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository.
Top
See Also

Reference

UserPipelineProcessor Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


UserPipelineProcessor.UserRepository Property

UserPipelineProcessorUserRepository Property
Gets or sets the user repository.

Namespace: Sitecore.Commerce.Pipelines.Customers.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IUserRepository UserRepository { get; protected set; }
Public Property UserRepository As IUserRepository
    Get
    Protected Set
public:
property IUserRepository^ UserRepository {
    IUserRepository^ get ();
    protected: void set (IUserRepository^ value);
}
member UserRepository : IUserRepository with get, set

Property Value

Type: IUserRepository
The user repository.
See Also

Reference

UserPipelineProcessor Class
Sitecore.Commerce.Pipelines.Customers.Common Namespace


Sitecore.Commerce.Pipelines.Customers.CreateCustomer Namespace

Sitecore.Commerce.Pipelines.Customers.CreateCustomer Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.CreateCustomer"]

Classes
 | Class | Description
Public class | CreateCustomerInExternalSystem | Defines the processor that creates a customer in the external commerce system.
Public class | CreateCustomerInSitecore | Defines the processor that assigns a customer to an engagement automation plan. This class implements the ManageCustomerInEaPlan class.


CreateCustomerInExternalSystem Class

CreateCustomerInExternalSystem Class
Defines the processor that creates a customer in the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CreateCustomerCreateCustomerInExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.CreateCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CreateCustomerInExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class CreateCustomerInExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class CreateCustomerInExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type CreateCustomerInExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The CreateCustomerInExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | CreateCustomerInExternalSystem | Initializes a new instance of the CreateCustomerInExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the CreateCustomerInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.CreateCustomer Namespace


CreateCustomerInExternalSystem Constructor

CreateCustomerInExternalSystem Constructor
Initializes a new instance of the CreateCustomerInExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers.CreateCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CreateCustomerInExternalSystem()
Public Sub New
public:
CreateCustomerInExternalSystem()
new : unit -> CreateCustomerInExternalSystem
See Also

Reference

CreateCustomerInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.CreateCustomer Namespace


CreateCustomerInExternalSystem Methods

CreateCustomerInExternalSystem Methods

The CreateCustomerInExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the CreateCustomerInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateCustomerInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.CreateCustomer Namespace


CreateCustomerInExternalSystem.Process Method

CreateCustomerInExternalSystemProcess Method
Executes the business logic of the CreateCustomerInExternalSystem processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.CreateCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

CreateCustomerInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.CreateCustomer Namespace


CreateCustomerInSitecore Class

CreateCustomerInSitecore Class
Defines the processor that assigns a customer to an engagement automation plan. This class implements the ManageCustomerInEaPlan class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.CreateCustomerCreateCustomerInSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.CreateCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CreateCustomerInSitecore : CustomerPipelineProcessor
Public Class CreateCustomerInSitecore
    Inherits CustomerPipelineProcessor
public ref class CreateCustomerInSitecore : public CustomerPipelineProcessor
type CreateCustomerInSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The CreateCustomerInSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | CreateCustomerInSitecore | Initializes an instance of the CreateCustomerInSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the AddCustomerToEaPlan processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.CreateCustomer Namespace


CreateCustomerInSitecore Constructor

CreateCustomerInSitecore Constructor
Initializes an instance of the CreateCustomerInSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.CreateCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CreateCustomerInSitecore(
    ICustomerRepository customerRepository,
    IEntityFactory entityFactory
)
Public Sub New (
    customerRepository As ICustomerRepository,
    entityFactory As IEntityFactory
)
public:
CreateCustomerInSitecore(
    ICustomerRepository^ customerRepository,
    IEntityFactory^ entityFactory
)
new :
        customerRepository : ICustomerRepository *
        entityFactory : IEntityFactory -> CreateCustomerInSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The repository of the state customer.
entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
See Also

Reference

CreateCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.CreateCustomer Namespace


CreateCustomerInSitecore Methods

CreateCustomerInSitecore Methods

The CreateCustomerInSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the AddCustomerToEaPlan processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.CreateCustomer Namespace


CreateCustomerInSitecore.Process Method

CreateCustomerInSitecoreProcess Method
Executes the business logic of the AddCustomerToEaPlan processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.CreateCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

CreateCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.CreateCustomer Namespace


CreateCustomerInSitecore Properties

CreateCustomerInSitecore Properties

The CreateCustomerInSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

CreateCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.CreateCustomer Namespace


Sitecore.Commerce.Pipelines.Customers.CreateUser Namespace

Sitecore.Commerce.Pipelines.Customers.CreateUser Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.CreateUser"]

Classes
 | Class | Description
Public class | CreateUserInExternalSystem | Defines the processor that creates a user in the external commerce system.
Public class | CreateUserInSitecore | Defines the processor that creates a user in Sitecore.


CreateUserInExternalSystem Class

CreateUserInExternalSystem Class
Defines the processor that creates a user in the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CreateUserCreateUserInExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.CreateUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CreateUserInExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class CreateUserInExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class CreateUserInExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type CreateUserInExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The CreateUserInExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | CreateUserInExternalSystem | Initializes an instance of the CreateUserInExternalSystem class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the CreateUserInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.CreateUser Namespace


CreateUserInExternalSystem Constructor

CreateUserInExternalSystem Constructor
Initializes an instance of the CreateUserInExternalSystem class.

Namespace: Sitecore.Commerce.Pipelines.Customers.CreateUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CreateUserInExternalSystem(
    IEntityFactory entityFactory
)
Public Sub New (
    entityFactory As IEntityFactory
)
public:
CreateUserInExternalSystem(
    IEntityFactory^ entityFactory
)
new :
        entityFactory : IEntityFactory -> CreateUserInExternalSystem

Parameters

entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
See Also

Reference

CreateUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.CreateUser Namespace


CreateUserInExternalSystem Methods

CreateUserInExternalSystem Methods

The CreateUserInExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the CreateUserInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.CreateUser Namespace


CreateUserInExternalSystem.Process Method

CreateUserInExternalSystemProcess Method
Executes the business logic of the CreateUserInExternalSystem processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.CreateUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

CreateUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.CreateUser Namespace


CreateUserInSitecore Class

CreateUserInSitecore Class
Defines the processor that creates a user in Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonUserPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.CreateUserCreateUserInSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.CreateUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CreateUserInSitecore : UserPipelineProcessor
Public Class CreateUserInSitecore
    Inherits UserPipelineProcessor
public ref class CreateUserInSitecore : public UserPipelineProcessor
type CreateUserInSitecore =
    class
        inherit UserPipelineProcessor
    end

The CreateUserInSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | CreateUserInSitecore | Initializes an instance of the CreateUserInSitecore class.
Top
Methods
 | Name | Description
Protected method | CreateUser | Creates the user.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the CreateUserInSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UserExists | Users the exists.
Top
Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.CreateUser Namespace


CreateUserInSitecore Constructor

CreateUserInSitecore Constructor
Initializes an instance of the CreateUserInSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.CreateUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CreateUserInSitecore(
    IUserRepository userRepository,
    IEntityFactory entityFactory
)
Public Sub New (
    userRepository As IUserRepository,
    entityFactory As IEntityFactory
)
public:
CreateUserInSitecore(
    IUserRepository^ userRepository,
    IEntityFactory^ entityFactory
)
new :
        userRepository : IUserRepository *
        entityFactory : IEntityFactory -> CreateUserInSitecore

Parameters

userRepository
Type: Sitecore.Commerce.Data.CustomersIUserRepository
The user repository.
entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
See Also

Reference

CreateUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.CreateUser Namespace


CreateUserInSitecore Methods

CreateUserInSitecore Methods

The CreateUserInSitecore type exposes the following members.

Methods
 | Name | Description
Protected method | CreateUser | Creates the user.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the CreateUserInSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UserExists | Users the exists.
Top
See Also

Reference

CreateUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.CreateUser Namespace


CreateUserInSitecore.CreateUser Method

CreateUserInSitecoreCreateUser Method
Creates the user.

Namespace: Sitecore.Commerce.Pipelines.Customers.CreateUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void CreateUser(
    CreateUserRequest request,
    CreateUserResult result
)
Protected Overridable Sub CreateUser (
    request As CreateUserRequest,
    result As CreateUserResult
)
protected:
virtual void CreateUser(
    CreateUserRequest^ request,
    CreateUserResult^ result
)
abstract CreateUser :
        request : CreateUserRequest *
        result : CreateUserResult -> unit
override CreateUser :
        request : CreateUserRequest *
        result : CreateUserResult -> unit

Parameters

request
Type: Sitecore.Commerce.Services.CustomersCreateUserRequest
The request.
result
Type: Sitecore.Commerce.Services.CustomersCreateUserResult
The result.
See Also

Reference

CreateUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.CreateUser Namespace


CreateUserInSitecore.Process Method

CreateUserInSitecoreProcess Method
Executes the business logic of the CreateUserInSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.CreateUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

CreateUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.CreateUser Namespace


CreateUserInSitecore.UserExists Method

CreateUserInSitecoreUserExists Method
Users the exists.

Namespace: Sitecore.Commerce.Pipelines.Customers.CreateUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual bool UserExists(
    CreateUserRequest request
)
Protected Overridable Function UserExists (
    request As CreateUserRequest
) As Boolean
protected:
virtual bool UserExists(
    CreateUserRequest^ request
)
abstract UserExists :
        request : CreateUserRequest -> bool
override UserExists :
        request : CreateUserRequest -> bool

Parameters

request
Type: Sitecore.Commerce.Services.CustomersCreateUserRequest
The request.

Return Value

Type: Boolean

Field Value

Type: Boolean
true if user already exists, otherwise

Field Value

Type: Boolean
false
See Also

Reference

CreateUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.CreateUser Namespace


CreateUserInSitecore Properties

CreateUserInSitecore Properties

The CreateUserInSitecore type exposes the following members.

Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

CreateUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.CreateUser Namespace


Sitecore.Commerce.Pipelines.Customers.DeleteCustomer Namespace

Sitecore.Commerce.Pipelines.Customers.DeleteCustomer Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.DeleteCustomer"]

Classes
 | Class | Description
Public class | DeleteCustomerFromExternalSystem | Defines the processor that deletes a customer from the external commerce system.
Public class | DeleteCustomerFromSitecore | Defines the processor that deletes a customer the sitecore user profile.


DeleteCustomerFromExternalSystem Class

DeleteCustomerFromExternalSystem Class
Defines the processor that deletes a customer from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.DeleteCustomerDeleteCustomerFromExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.DeleteCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DeleteCustomerFromExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class DeleteCustomerFromExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class DeleteCustomerFromExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type DeleteCustomerFromExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The DeleteCustomerFromExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteCustomerFromExternalSystem | Initializes a new instance of the DeleteCustomerFromExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DeleteCustomerFromExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.DeleteCustomer Namespace


DeleteCustomerFromExternalSystem Constructor

DeleteCustomerFromExternalSystem Constructor
Initializes a new instance of the DeleteCustomerFromExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers.DeleteCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DeleteCustomerFromExternalSystem()
Public Sub New
public:
DeleteCustomerFromExternalSystem()
new : unit -> DeleteCustomerFromExternalSystem
See Also

Reference

DeleteCustomerFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.DeleteCustomer Namespace


DeleteCustomerFromExternalSystem Methods

DeleteCustomerFromExternalSystem Methods

The DeleteCustomerFromExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DeleteCustomerFromExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteCustomerFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.DeleteCustomer Namespace


DeleteCustomerFromExternalSystem.Process Method

DeleteCustomerFromExternalSystemProcess Method
Executes the business logic of the DeleteCustomerFromExternalSystem processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.DeleteCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

DeleteCustomerFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.DeleteCustomer Namespace


DeleteCustomerFromSitecore Class

DeleteCustomerFromSitecore Class
Defines the processor that deletes a customer the sitecore user profile.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.DeleteCustomerDeleteCustomerFromSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.DeleteCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DeleteCustomerFromSitecore : CustomerPipelineProcessor
Public Class DeleteCustomerFromSitecore
    Inherits CustomerPipelineProcessor
public ref class DeleteCustomerFromSitecore : public CustomerPipelineProcessor
type DeleteCustomerFromSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The DeleteCustomerFromSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteCustomerFromSitecore | Initializes an instance of the DeleteCustomerFromSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DeleteCustomerFromEaState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.DeleteCustomer Namespace


DeleteCustomerFromSitecore Constructor

DeleteCustomerFromSitecore Constructor
Initializes an instance of the DeleteCustomerFromSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.DeleteCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DeleteCustomerFromSitecore(
    ICustomerRepository customerRepository,
    IEntityFactory entityFactory
)
Public Sub New (
    customerRepository As ICustomerRepository,
    entityFactory As IEntityFactory
)
public:
DeleteCustomerFromSitecore(
    ICustomerRepository^ customerRepository,
    IEntityFactory^ entityFactory
)
new :
        customerRepository : ICustomerRepository *
        entityFactory : IEntityFactory -> DeleteCustomerFromSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The repository of the state customer.
entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
See Also

Reference

DeleteCustomerFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.DeleteCustomer Namespace


DeleteCustomerFromSitecore Methods

DeleteCustomerFromSitecore Methods

The DeleteCustomerFromSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DeleteCustomerFromEaState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteCustomerFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.DeleteCustomer Namespace


DeleteCustomerFromSitecore.Process Method

DeleteCustomerFromSitecoreProcess Method
Executes the business logic of the DeleteCustomerFromEaState processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.DeleteCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

DeleteCustomerFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.DeleteCustomer Namespace


DeleteCustomerFromSitecore Properties

DeleteCustomerFromSitecore Properties

The DeleteCustomerFromSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

DeleteCustomerFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.DeleteCustomer Namespace


Sitecore.Commerce.Pipelines.Customers.DeleteUser Namespace

Sitecore.Commerce.Pipelines.Customers.DeleteUser Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.DeleteUser"]

Classes
 | Class | Description
Public class | DeleteUserInExternalSystem | Defines the processor that deletes a user in the external commerce system.
Public class | DeleteUserInSitecore | Defines the processor that deletes a user in Sitecore. This class implements the ManageUserInSitecore class.


DeleteUserInExternalSystem Class

DeleteUserInExternalSystem Class
Defines the processor that deletes a user in the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.DeleteUserDeleteUserInExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.DeleteUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DeleteUserInExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class DeleteUserInExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class DeleteUserInExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type DeleteUserInExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The DeleteUserInExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteUserInExternalSystem | Initializes a new instance of the DeleteUserInExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DeleteUserInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.DeleteUser Namespace


DeleteUserInExternalSystem Constructor

DeleteUserInExternalSystem Constructor
Initializes a new instance of the DeleteUserInExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers.DeleteUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DeleteUserInExternalSystem()
Public Sub New
public:
DeleteUserInExternalSystem()
new : unit -> DeleteUserInExternalSystem
See Also

Reference

DeleteUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.DeleteUser Namespace


DeleteUserInExternalSystem Methods

DeleteUserInExternalSystem Methods

The DeleteUserInExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DeleteUserInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.DeleteUser Namespace


DeleteUserInExternalSystem.Process Method

DeleteUserInExternalSystemProcess Method
Executes the business logic of the DeleteUserInExternalSystem processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.DeleteUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

DeleteUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.DeleteUser Namespace


DeleteUserInSitecore Class

DeleteUserInSitecore Class
Defines the processor that deletes a user in Sitecore. This class implements the ManageUserInSitecore class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonUserPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.CommonManageUserInSitecore
Sitecore.Commerce.Pipelines.Customers.DeleteUserDeleteUserInSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.DeleteUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DeleteUserInSitecore : ManageUserInSitecore
Public Class DeleteUserInSitecore
    Inherits ManageUserInSitecore
public ref class DeleteUserInSitecore : public ManageUserInSitecore
type DeleteUserInSitecore =
    class
        inherit ManageUserInSitecore
    end

The DeleteUserInSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteUserInSitecore | Initializes a new instance of the DeleteUserInSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ManageUserInSitecore processor. (Inherited from ManageUserInSitecore.)
Protected method | ProcessSitecoreUser | Processes the user account in sitecore. (Overrides ManageUserInSitecoreProcessSitecoreUser(CommerceUser, UserRequestWithUser, ServiceProviderResult).)
Protected method | SetResult | Sets the result. (Inherited from ManageUserInSitecore.)
Protected method | ShouldAbortPipeline | Based on whether a user exists or not, determines whether the pipeline must stop. (Inherited from ManageUserInSitecore.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.DeleteUser Namespace


DeleteUserInSitecore Constructor

DeleteUserInSitecore Constructor
Initializes a new instance of the DeleteUserInSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.DeleteUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DeleteUserInSitecore(
    IUserRepository userRepository
)
Public Sub New (
    userRepository As IUserRepository
)
public:
DeleteUserInSitecore(
    IUserRepository^ userRepository
)
new :
        userRepository : IUserRepository -> DeleteUserInSitecore

Parameters

userRepository
Type: Sitecore.Commerce.Data.CustomersIUserRepository
The user repository.
See Also

Reference

DeleteUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.DeleteUser Namespace


DeleteUserInSitecore Methods

DeleteUserInSitecore Methods

The DeleteUserInSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ManageUserInSitecore processor. (Inherited from ManageUserInSitecore.)
Protected method | ProcessSitecoreUser | Processes the user account in sitecore. (Overrides ManageUserInSitecoreProcessSitecoreUser(CommerceUser, UserRequestWithUser, ServiceProviderResult).)
Protected method | SetResult | Sets the result. (Inherited from ManageUserInSitecore.)
Protected method | ShouldAbortPipeline | Based on whether a user exists or not, determines whether the pipeline must stop. (Inherited from ManageUserInSitecore.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.DeleteUser Namespace


DeleteUserInSitecore.ProcessSitecoreUser Method

DeleteUserInSitecoreProcessSitecoreUser Method
Processes the user account in sitecore.

Namespace: Sitecore.Commerce.Pipelines.Customers.DeleteUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void ProcessSitecoreUser(
    CommerceUser user,
    UserRequestWithUser request,
    ServiceProviderResult result
)
Protected Overrides Sub ProcessSitecoreUser (
    user As CommerceUser,
    request As UserRequestWithUser,
    result As ServiceProviderResult
)
protected:
virtual void ProcessSitecoreUser(
    CommerceUser^ user,
    UserRequestWithUser^ request,
    ServiceProviderResult^ result
) override
abstract ProcessSitecoreUser :
        user : CommerceUser *
        request : UserRequestWithUser *
        result : ServiceProviderResult -> unit
override ProcessSitecoreUser :
        user : CommerceUser *
        request : UserRequestWithUser *
        result : ServiceProviderResult -> unit

Parameters

user
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The user.
request
Type: Sitecore.Commerce.Services.CustomersUserRequestWithUser
The request.
result
Type: Sitecore.Commerce.ServicesServiceProviderResult
The result.
See Also

Reference

DeleteUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.DeleteUser Namespace


DeleteUserInSitecore Properties

DeleteUserInSitecore Properties

The DeleteUserInSitecore type exposes the following members.

Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

DeleteUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.DeleteUser Namespace


Sitecore.Commerce.Pipelines.Customers.DisableCustomer Namespace

Sitecore.Commerce.Pipelines.Customers.DisableCustomer Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.DisableCustomer"]

Classes
 | Class | Description
Public class | DisableCustomerInExternalSystem | Defines the processor that disables a customer in the external commerce system.
Public class | DisableCustomerInSitecore | Defines the processor that disables a customer in the sitecore user profile.


DisableCustomerInExternalSystem Class

DisableCustomerInExternalSystem Class
Defines the processor that disables a customer in the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.DisableCustomerDisableCustomerInExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.DisableCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DisableCustomerInExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class DisableCustomerInExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class DisableCustomerInExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type DisableCustomerInExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The DisableCustomerInExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | DisableCustomerInExternalSystem | Initializes a new instance of the DisableCustomerInExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DisableCustomerInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.DisableCustomer Namespace


DisableCustomerInExternalSystem Constructor

DisableCustomerInExternalSystem Constructor
Initializes a new instance of the DisableCustomerInExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers.DisableCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DisableCustomerInExternalSystem()
Public Sub New
public:
DisableCustomerInExternalSystem()
new : unit -> DisableCustomerInExternalSystem
See Also

Reference

DisableCustomerInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.DisableCustomer Namespace


DisableCustomerInExternalSystem Methods

DisableCustomerInExternalSystem Methods

The DisableCustomerInExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DisableCustomerInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisableCustomerInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.DisableCustomer Namespace


DisableCustomerInExternalSystem.Process Method

DisableCustomerInExternalSystemProcess Method
Executes the business logic of the DisableCustomerInExternalSystem processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.DisableCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

DisableCustomerInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.DisableCustomer Namespace


DisableCustomerInSitecore Class

DisableCustomerInSitecore Class
Defines the processor that disables a customer in the sitecore user profile.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.DisableCustomerDisableCustomerInSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.DisableCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DisableCustomerInSitecore : CustomerPipelineProcessor
Public Class DisableCustomerInSitecore
    Inherits CustomerPipelineProcessor
public ref class DisableCustomerInSitecore : public CustomerPipelineProcessor
type DisableCustomerInSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The DisableCustomerInSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | DisableCustomerInSitecore | Initializes a new instance of the DisableCustomerInSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DisableCustomerInEaState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.DisableCustomer Namespace


DisableCustomerInSitecore Constructor

DisableCustomerInSitecore Constructor
Initializes a new instance of the DisableCustomerInSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.DisableCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DisableCustomerInSitecore(
    ICustomerRepository customerRepository,
    IEntityFactory entityFactory
)
Public Sub New (
    customerRepository As ICustomerRepository,
    entityFactory As IEntityFactory
)
public:
DisableCustomerInSitecore(
    ICustomerRepository^ customerRepository,
    IEntityFactory^ entityFactory
)
new :
        customerRepository : ICustomerRepository *
        entityFactory : IEntityFactory -> DisableCustomerInSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The customer repository.
entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
See Also

Reference

DisableCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.DisableCustomer Namespace


DisableCustomerInSitecore Methods

DisableCustomerInSitecore Methods

The DisableCustomerInSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DisableCustomerInEaState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisableCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.DisableCustomer Namespace


DisableCustomerInSitecore.Process Method

DisableCustomerInSitecoreProcess Method
Executes the business logic of the DisableCustomerInEaState processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.DisableCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

DisableCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.DisableCustomer Namespace


DisableCustomerInSitecore Properties

DisableCustomerInSitecore Properties

The DisableCustomerInSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

DisableCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.DisableCustomer Namespace


Sitecore.Commerce.Pipelines.Customers.DisableUser Namespace

Sitecore.Commerce.Pipelines.Customers.DisableUser Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.DisableUser"]

Classes
 | Class | Description
Public class | DisableUserInExternalSystem | Defines the processor that disables a user in the external commerce system.
Public class | DisableUserInSitecore | Defines the processor that disables a user in Sitecore.


DisableUserInExternalSystem Class

DisableUserInExternalSystem Class
Defines the processor that disables a user in the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.DisableUserDisableUserInExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.DisableUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DisableUserInExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class DisableUserInExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class DisableUserInExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type DisableUserInExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The DisableUserInExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | DisableUserInExternalSystem | Initializes a new instance of the DisableUserInExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DisableUserInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.DisableUser Namespace


DisableUserInExternalSystem Constructor

DisableUserInExternalSystem Constructor
Initializes a new instance of the DisableUserInExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers.DisableUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DisableUserInExternalSystem()
Public Sub New
public:
DisableUserInExternalSystem()
new : unit -> DisableUserInExternalSystem
See Also

Reference

DisableUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.DisableUser Namespace


DisableUserInExternalSystem Methods

DisableUserInExternalSystem Methods

The DisableUserInExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DisableUserInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisableUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.DisableUser Namespace


DisableUserInExternalSystem.Process Method

DisableUserInExternalSystemProcess Method
Executes the business logic of the DisableUserInExternalSystem processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.DisableUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

DisableUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.DisableUser Namespace


DisableUserInSitecore Class

DisableUserInSitecore Class
Defines the processor that disables a user in Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonUserPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.DisableUserDisableUserInSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.DisableUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DisableUserInSitecore : UserPipelineProcessor
Public Class DisableUserInSitecore
    Inherits UserPipelineProcessor
public ref class DisableUserInSitecore : public UserPipelineProcessor
type DisableUserInSitecore =
    class
        inherit UserPipelineProcessor
    end

The DisableUserInSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | DisableUserInSitecore | Initializes an instance of the DisableUserInSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DisableUserInSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.DisableUser Namespace


DisableUserInSitecore Constructor

DisableUserInSitecore Constructor
Initializes an instance of the DisableUserInSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.DisableUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DisableUserInSitecore(
    IUserRepository userRepository
)
Public Sub New (
    userRepository As IUserRepository
)
public:
DisableUserInSitecore(
    IUserRepository^ userRepository
)
new :
        userRepository : IUserRepository -> DisableUserInSitecore

Parameters

userRepository
Type: Sitecore.Commerce.Data.CustomersIUserRepository
The user repository.
See Also

Reference

DisableUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.DisableUser Namespace


DisableUserInSitecore Methods

DisableUserInSitecore Methods

The DisableUserInSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the DisableUserInSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisableUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.DisableUser Namespace


DisableUserInSitecore.Process Method

DisableUserInSitecoreProcess Method
Executes the business logic of the DisableUserInSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.DisableUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

DisableUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.DisableUser Namespace


DisableUserInSitecore Properties

DisableUserInSitecore Properties

The DisableUserInSitecore type exposes the following members.

Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

DisableUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.DisableUser Namespace


Sitecore.Commerce.Pipelines.Customers.EnableCustomer Namespace

Sitecore.Commerce.Pipelines.Customers.EnableCustomer Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.EnableCustomer"]

Classes
 | Class | Description
Public class | EnableCustomerInExternalSystem | Defines the processor that enables a customer in the external commerce system.
Public class | EnableCustomerInSitecore | Defines the processor that enables a customer in an engagement automation state. This class implements the ManageCustomerInEaPlan class.


EnableCustomerInExternalSystem Class

EnableCustomerInExternalSystem Class
Defines the processor that enables a customer in the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.EnableCustomerEnableCustomerInExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.EnableCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EnableCustomerInExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class EnableCustomerInExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class EnableCustomerInExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type EnableCustomerInExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The EnableCustomerInExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | EnableCustomerInExternalSystem | Initializes a new instance of the EnableCustomerInExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the EnableCustomerInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.EnableCustomer Namespace


EnableCustomerInExternalSystem Constructor

EnableCustomerInExternalSystem Constructor
Initializes a new instance of the EnableCustomerInExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers.EnableCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EnableCustomerInExternalSystem()
Public Sub New
public:
EnableCustomerInExternalSystem()
new : unit -> EnableCustomerInExternalSystem
See Also

Reference

EnableCustomerInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.EnableCustomer Namespace


EnableCustomerInExternalSystem Methods

EnableCustomerInExternalSystem Methods

The EnableCustomerInExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the EnableCustomerInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EnableCustomerInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.EnableCustomer Namespace


EnableCustomerInExternalSystem.Process Method

EnableCustomerInExternalSystemProcess Method
Executes the business logic of the EnableCustomerInExternalSystem processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.EnableCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

EnableCustomerInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.EnableCustomer Namespace


EnableCustomerInSitecore Class

EnableCustomerInSitecore Class
Defines the processor that enables a customer in an engagement automation state. This class implements the ManageCustomerInEaPlan class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.EnableCustomerEnableCustomerInSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.EnableCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EnableCustomerInSitecore : CustomerPipelineProcessor
Public Class EnableCustomerInSitecore
    Inherits CustomerPipelineProcessor
public ref class EnableCustomerInSitecore : public CustomerPipelineProcessor
type EnableCustomerInSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The EnableCustomerInSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | EnableCustomerInSitecore | Initializes an instance of the EnableCustomerInSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the EnableCustomerInEaState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.EnableCustomer Namespace


EnableCustomerInSitecore Constructor

EnableCustomerInSitecore Constructor
Initializes an instance of the EnableCustomerInSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.EnableCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EnableCustomerInSitecore(
    ICustomerRepository customerRepository,
    IEntityFactory entityFactory
)
Public Sub New (
    customerRepository As ICustomerRepository,
    entityFactory As IEntityFactory
)
public:
EnableCustomerInSitecore(
    ICustomerRepository^ customerRepository,
    IEntityFactory^ entityFactory
)
new :
        customerRepository : ICustomerRepository *
        entityFactory : IEntityFactory -> EnableCustomerInSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The repository of the state customer.
entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
See Also

Reference

EnableCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.EnableCustomer Namespace


EnableCustomerInSitecore Methods

EnableCustomerInSitecore Methods

The EnableCustomerInSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the EnableCustomerInEaState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EnableCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.EnableCustomer Namespace


EnableCustomerInSitecore.Process Method

EnableCustomerInSitecoreProcess Method
Executes the business logic of the EnableCustomerInEaState processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.EnableCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

EnableCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.EnableCustomer Namespace


EnableCustomerInSitecore Properties

EnableCustomerInSitecore Properties

The EnableCustomerInSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

EnableCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.EnableCustomer Namespace


Sitecore.Commerce.Pipelines.Customers.EnableUser Namespace

Sitecore.Commerce.Pipelines.Customers.EnableUser Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.EnableUser"]

Classes
 | Class | Description
Public class | EnableUserInExternalSystem | Defines the processor that enables a user in the external commerce system.
Public class | EnableUserInSitecore | Defines the processor that enables a user in Sitecore.


EnableUserInExternalSystem Class

EnableUserInExternalSystem Class
Defines the processor that enables a user in the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.EnableUserEnableUserInExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.EnableUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EnableUserInExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class EnableUserInExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class EnableUserInExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type EnableUserInExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The EnableUserInExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | EnableUserInExternalSystem | Initializes a new instance of the EnableUserInExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the EnableUserInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.EnableUser Namespace


EnableUserInExternalSystem Constructor

EnableUserInExternalSystem Constructor
Initializes a new instance of the EnableUserInExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers.EnableUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EnableUserInExternalSystem()
Public Sub New
public:
EnableUserInExternalSystem()
new : unit -> EnableUserInExternalSystem
See Also

Reference

EnableUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.EnableUser Namespace


EnableUserInExternalSystem Methods

EnableUserInExternalSystem Methods

The EnableUserInExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the EnableUserInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EnableUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.EnableUser Namespace


EnableUserInExternalSystem.Process Method

EnableUserInExternalSystemProcess Method
Executes the business logic of the EnableUserInExternalSystem processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.EnableUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

EnableUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.EnableUser Namespace


EnableUserInSitecore Class

EnableUserInSitecore Class
Defines the processor that enables a user in Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonUserPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.EnableUserEnableUserInSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.EnableUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EnableUserInSitecore : UserPipelineProcessor
Public Class EnableUserInSitecore
    Inherits UserPipelineProcessor
public ref class EnableUserInSitecore : public UserPipelineProcessor
type EnableUserInSitecore =
    class
        inherit UserPipelineProcessor
    end

The EnableUserInSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | EnableUserInSitecore | Initializes an instance of the EnableUserInSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the EnableUserInSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.EnableUser Namespace


EnableUserInSitecore Constructor

EnableUserInSitecore Constructor
Initializes an instance of the EnableUserInSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.EnableUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EnableUserInSitecore(
    IUserRepository userRepository
)
Public Sub New (
    userRepository As IUserRepository
)
public:
EnableUserInSitecore(
    IUserRepository^ userRepository
)
new :
        userRepository : IUserRepository -> EnableUserInSitecore

Parameters

userRepository
Type: Sitecore.Commerce.Data.CustomersIUserRepository
The user repository.
See Also

Reference

EnableUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.EnableUser Namespace


EnableUserInSitecore Methods

EnableUserInSitecore Methods

The EnableUserInSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the EnableUserInSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EnableUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.EnableUser Namespace


EnableUserInSitecore.Process Method

EnableUserInSitecoreProcess Method
Executes the business logic of the EnableUserInSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.EnableUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

EnableUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.EnableUser Namespace


EnableUserInSitecore Properties

EnableUserInSitecore Properties

The EnableUserInSitecore type exposes the following members.

Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

EnableUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.EnableUser Namespace


Sitecore.Commerce.Pipelines.Customers.GetCustomer Namespace

Sitecore.Commerce.Pipelines.Customers.GetCustomer Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.GetCustomer"]

Classes
 | Class | Description
Public class | GetCustomerFromExternalSystem | Defines the processor that get a customer from the external commerce system.
Public class | GetCustomerFromSitecore | Defines the processor that gets customers from Sitecore. This class implements the ManageCustomerInEaPlan class.


GetCustomerFromExternalSystem Class

GetCustomerFromExternalSystem Class
Defines the processor that get a customer from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.GetCustomerGetCustomerFromExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.GetCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetCustomerFromExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class GetCustomerFromExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class GetCustomerFromExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type GetCustomerFromExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The GetCustomerFromExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | GetCustomerFromExternalSystem | Initializes a new instance of the GetCustomerFromExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetCustomerFromExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.GetCustomer Namespace


GetCustomerFromExternalSystem Constructor

GetCustomerFromExternalSystem Constructor
Initializes a new instance of the GetCustomerFromExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers.GetCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetCustomerFromExternalSystem()
Public Sub New
public:
GetCustomerFromExternalSystem()
new : unit -> GetCustomerFromExternalSystem
See Also

Reference

GetCustomerFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.GetCustomer Namespace


GetCustomerFromExternalSystem Methods

GetCustomerFromExternalSystem Methods

The GetCustomerFromExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetCustomerFromExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetCustomerFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.GetCustomer Namespace


GetCustomerFromExternalSystem.Process Method

GetCustomerFromExternalSystemProcess Method
Executes the business logic of the GetCustomerFromExternalSystem processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.GetCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

GetCustomerFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.GetCustomer Namespace


GetCustomerFromSitecore Class

GetCustomerFromSitecore Class
Defines the processor that gets customers from Sitecore. This class implements the ManageCustomerInEaPlan class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.GetCustomerGetCustomerFromSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.GetCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetCustomerFromSitecore : CustomerPipelineProcessor
Public Class GetCustomerFromSitecore
    Inherits CustomerPipelineProcessor
public ref class GetCustomerFromSitecore : public CustomerPipelineProcessor
type GetCustomerFromSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The GetCustomerFromSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | GetCustomerFromSitecore | Initializes an instance of the GetCustomerFromSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetCustomerFromSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.GetCustomer Namespace


GetCustomerFromSitecore Constructor

GetCustomerFromSitecore Constructor
Initializes an instance of the GetCustomerFromSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.GetCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetCustomerFromSitecore(
    ICustomerRepository customerRepository
)
Public Sub New (
    customerRepository As ICustomerRepository
)
public:
GetCustomerFromSitecore(
    ICustomerRepository^ customerRepository
)
new :
        customerRepository : ICustomerRepository -> GetCustomerFromSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The repository of the state customer.
See Also

Reference

GetCustomerFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetCustomer Namespace


GetCustomerFromSitecore Methods

GetCustomerFromSitecore Methods

The GetCustomerFromSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetCustomerFromSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetCustomerFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetCustomer Namespace


GetCustomerFromSitecore.Process Method

GetCustomerFromSitecoreProcess Method
Executes the business logic of the GetCustomerFromSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.GetCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

GetCustomerFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetCustomer Namespace


GetCustomerFromSitecore Properties

GetCustomerFromSitecore Properties

The GetCustomerFromSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

GetCustomerFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetCustomer Namespace


Sitecore.Commerce.Pipelines.Customers.GetCustomers Namespace

Sitecore.Commerce.Pipelines.Customers.GetCustomers Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.GetCustomers"]

Classes
 | Class | Description
Public class | GetCustomersFromExternalSystem | Defines the processor that gets customers from the external commerce system.
Public class | GetCustomersFromSitecore | Defines the processor that gets customers from Sitecore. This class implements the ManageCustomerInEaPlan class.


GetCustomersFromExternalSystem Class

GetCustomersFromExternalSystem Class
Defines the processor that gets customers from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.GetCustomersGetCustomersFromExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.GetCustomers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetCustomersFromExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class GetCustomersFromExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class GetCustomersFromExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type GetCustomersFromExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The GetCustomersFromExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | GetCustomersFromExternalSystem | Initializes a new instance of the GetCustomersFromExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetCustomersFromExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.GetCustomers Namespace


GetCustomersFromExternalSystem Constructor

GetCustomersFromExternalSystem Constructor
Initializes a new instance of the GetCustomersFromExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers.GetCustomers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetCustomersFromExternalSystem()
Public Sub New
public:
GetCustomersFromExternalSystem()
new : unit -> GetCustomersFromExternalSystem
See Also

Reference

GetCustomersFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.GetCustomers Namespace


GetCustomersFromExternalSystem Methods

GetCustomersFromExternalSystem Methods

The GetCustomersFromExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetCustomersFromExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetCustomersFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.GetCustomers Namespace


GetCustomersFromExternalSystem.Process Method

GetCustomersFromExternalSystemProcess Method
Executes the business logic of the GetCustomersFromExternalSystem processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.GetCustomers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

GetCustomersFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.GetCustomers Namespace


GetCustomersFromSitecore Class

GetCustomersFromSitecore Class
Defines the processor that gets customers from Sitecore. This class implements the ManageCustomerInEaPlan class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.GetCustomersGetCustomersFromSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.GetCustomers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetCustomersFromSitecore : CustomerPipelineProcessor
Public Class GetCustomersFromSitecore
    Inherits CustomerPipelineProcessor
public ref class GetCustomersFromSitecore : public CustomerPipelineProcessor
type GetCustomersFromSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The GetCustomersFromSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | GetCustomersFromSitecore | Initializes an instance of the GetCustomersFromSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetCustomersFromSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.GetCustomers Namespace


GetCustomersFromSitecore Constructor

GetCustomersFromSitecore Constructor
Initializes an instance of the GetCustomersFromSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.GetCustomers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetCustomersFromSitecore(
    ICustomerRepository customerRepository
)
Public Sub New (
    customerRepository As ICustomerRepository
)
public:
GetCustomersFromSitecore(
    ICustomerRepository^ customerRepository
)
new :
        customerRepository : ICustomerRepository -> GetCustomersFromSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The repository of the state customer.
See Also

Reference

GetCustomersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetCustomers Namespace


GetCustomersFromSitecore Methods

GetCustomersFromSitecore Methods

The GetCustomersFromSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetCustomersFromSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetCustomersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetCustomers Namespace


GetCustomersFromSitecore.Process Method

GetCustomersFromSitecoreProcess Method
Executes the business logic of the GetCustomersFromSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.GetCustomers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

GetCustomersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetCustomers Namespace


GetCustomersFromSitecore Properties

GetCustomersFromSitecore Properties

The GetCustomersFromSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

GetCustomersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetCustomers Namespace


Sitecore.Commerce.Pipelines.Customers.GetUser Namespace

Sitecore.Commerce.Pipelines.Customers.GetUser Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.GetUser"]

Classes
 | Class | Description
Public class | GetUserFromExternalSystem | Defines the processor that gets a user from the external commerce system.
Public class | GetUserFromSitecore | Defines the processor that gets a user from Sitecore.


GetUserFromExternalSystem Class

GetUserFromExternalSystem Class
Defines the processor that gets a user from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.GetUserGetUserFromExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.GetUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetUserFromExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class GetUserFromExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class GetUserFromExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type GetUserFromExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The GetUserFromExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | GetUserFromExternalSystem | Initializes a new instance of the GetUserFromExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetUserFromExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.GetUser Namespace


GetUserFromExternalSystem Constructor

GetUserFromExternalSystem Constructor
Initializes a new instance of the GetUserFromExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers.GetUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetUserFromExternalSystem()
Public Sub New
public:
GetUserFromExternalSystem()
new : unit -> GetUserFromExternalSystem
See Also

Reference

GetUserFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.GetUser Namespace


GetUserFromExternalSystem Methods

GetUserFromExternalSystem Methods

The GetUserFromExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetUserFromExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetUserFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.GetUser Namespace


GetUserFromExternalSystem.Process Method

GetUserFromExternalSystemProcess Method
Executes the business logic of the GetUserFromExternalSystem processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.GetUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

GetUserFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.GetUser Namespace


GetUserFromSitecore Class

GetUserFromSitecore Class
Defines the processor that gets a user from Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonUserPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.GetUserGetUserFromSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.GetUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetUserFromSitecore : UserPipelineProcessor
Public Class GetUserFromSitecore
    Inherits UserPipelineProcessor
public ref class GetUserFromSitecore : public UserPipelineProcessor
type GetUserFromSitecore =
    class
        inherit UserPipelineProcessor
    end

The GetUserFromSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | GetUserFromSitecore | Initializes an instance of the GetUserFromSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetUserFromSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.GetUser Namespace


GetUserFromSitecore Constructor

GetUserFromSitecore Constructor
Initializes an instance of the GetUserFromSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.GetUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetUserFromSitecore(
    IUserRepository userRepository
)
Public Sub New (
    userRepository As IUserRepository
)
public:
GetUserFromSitecore(
    IUserRepository^ userRepository
)
new :
        userRepository : IUserRepository -> GetUserFromSitecore

Parameters

userRepository
Type: Sitecore.Commerce.Data.CustomersIUserRepository
The user repository.
See Also

Reference

GetUserFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetUser Namespace


GetUserFromSitecore Methods

GetUserFromSitecore Methods

The GetUserFromSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetUserFromSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetUserFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetUser Namespace


GetUserFromSitecore.Process Method

GetUserFromSitecoreProcess Method
Executes the business logic of the GetUserFromSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.GetUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

GetUserFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetUser Namespace


GetUserFromSitecore Properties

GetUserFromSitecore Properties

The GetUserFromSitecore type exposes the following members.

Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

GetUserFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetUser Namespace


Sitecore.Commerce.Pipelines.Customers.GetUsers Namespace

Sitecore.Commerce.Pipelines.Customers.GetUsers Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.GetUsers"]

Classes
 | Class | Description
Public class | GetUsersFromExternalSystem | Defines the processor that gets users from the external commerce system.
Public class | GetUsersFromSitecore | Defines the processor that gets users from Sitecore.


GetUsersFromExternalSystem Class

GetUsersFromExternalSystem Class
Defines the processor that gets users from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.GetUsersGetUsersFromExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.GetUsers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetUsersFromExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class GetUsersFromExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class GetUsersFromExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type GetUsersFromExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The GetUsersFromExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | GetUsersFromExternalSystem | Initializes a new instance of the GetUsersFromExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetUsersFromExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.GetUsers Namespace


GetUsersFromExternalSystem Constructor

GetUsersFromExternalSystem Constructor
Initializes a new instance of the GetUsersFromExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers.GetUsers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetUsersFromExternalSystem()
Public Sub New
public:
GetUsersFromExternalSystem()
new : unit -> GetUsersFromExternalSystem
See Also

Reference

GetUsersFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.GetUsers Namespace


GetUsersFromExternalSystem Methods

GetUsersFromExternalSystem Methods

The GetUsersFromExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetUsersFromExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetUsersFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.GetUsers Namespace


GetUsersFromExternalSystem.Process Method

GetUsersFromExternalSystemProcess Method
Executes the business logic of the GetUsersFromExternalSystem processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.GetUsers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

GetUsersFromExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.GetUsers Namespace


GetUsersFromSitecore Class

GetUsersFromSitecore Class
Defines the processor that gets users from Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonUserPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.GetUsersGetUsersFromSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.GetUsers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetUsersFromSitecore : UserPipelineProcessor
Public Class GetUsersFromSitecore
    Inherits UserPipelineProcessor
public ref class GetUsersFromSitecore : public UserPipelineProcessor
type GetUsersFromSitecore =
    class
        inherit UserPipelineProcessor
    end

The GetUsersFromSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | GetUsersFromSitecore | Initializes an instance of the GetUsersFromSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetUsersFromSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.GetUsers Namespace


GetUsersFromSitecore Constructor

GetUsersFromSitecore Constructor
Initializes an instance of the GetUsersFromSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.GetUsers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetUsersFromSitecore(
    IUserRepository userRepository
)
Public Sub New (
    userRepository As IUserRepository
)
public:
GetUsersFromSitecore(
    IUserRepository^ userRepository
)
new :
        userRepository : IUserRepository -> GetUsersFromSitecore

Parameters

userRepository
Type: Sitecore.Commerce.Data.CustomersIUserRepository
The user repository.
See Also

Reference

GetUsersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetUsers Namespace


GetUsersFromSitecore Methods

GetUsersFromSitecore Methods

The GetUsersFromSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetUsersFromSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetUsersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetUsers Namespace


GetUsersFromSitecore.Process Method

GetUsersFromSitecoreProcess Method
Executes the business logic of the GetUsersFromSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.GetUsers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

GetUsersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetUsers Namespace


GetUsersFromSitecore Properties

GetUsersFromSitecore Properties

The GetUsersFromSitecore type exposes the following members.

Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

GetUsersFromSitecore Class
Sitecore.Commerce.Pipelines.Customers.GetUsers Namespace


Sitecore.Commerce.Pipelines.Customers.UpdateCustomer Namespace

Sitecore.Commerce.Pipelines.Customers.UpdateCustomer Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.UpdateCustomer"]

Classes
 | Class | Description
Public class | UpdateCustomerInExternalSystem | Defines the processor that updates a customer in the external commerce system.
Public class | UpdateCustomerInSitecore | Defines the processor that updates a customer in the sitecore user profile.


UpdateCustomerInExternalSystem Class

UpdateCustomerInExternalSystem Class
Defines the processor that updates a customer in the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.UpdateCustomerUpdateCustomerInExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateCustomerInExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class UpdateCustomerInExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class UpdateCustomerInExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type UpdateCustomerInExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The UpdateCustomerInExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateCustomerInExternalSystem | Initializes a new instance of the UpdateCustomerInExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the UpdateCustomerInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.UpdateCustomer Namespace


UpdateCustomerInExternalSystem Constructor

UpdateCustomerInExternalSystem Constructor
Initializes a new instance of the UpdateCustomerInExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateCustomerInExternalSystem()
Public Sub New
public:
UpdateCustomerInExternalSystem()
new : unit -> UpdateCustomerInExternalSystem
See Also

Reference

UpdateCustomerInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.UpdateCustomer Namespace


UpdateCustomerInExternalSystem Methods

UpdateCustomerInExternalSystem Methods

The UpdateCustomerInExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the UpdateCustomerInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateCustomerInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.UpdateCustomer Namespace


UpdateCustomerInExternalSystem.Process Method

UpdateCustomerInExternalSystemProcess Method
Executes the business logic of the UpdateCustomerInExternalSystem processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

UpdateCustomerInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.UpdateCustomer Namespace


UpdateCustomerInSitecore Class

UpdateCustomerInSitecore Class
Defines the processor that updates a customer in the sitecore user profile.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonCustomerPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.UpdateCustomerUpdateCustomerInSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateCustomerInSitecore : CustomerPipelineProcessor
Public Class UpdateCustomerInSitecore
    Inherits CustomerPipelineProcessor
public ref class UpdateCustomerInSitecore : public CustomerPipelineProcessor
type UpdateCustomerInSitecore =
    class
        inherit CustomerPipelineProcessor
    end

The UpdateCustomerInSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateCustomerInSitecore | Initializes an instance of the UpdateCustomerInSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the UpdateCustomerInEaState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.UpdateCustomer Namespace


UpdateCustomerInSitecore Constructor

UpdateCustomerInSitecore Constructor
Initializes an instance of the UpdateCustomerInSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateCustomerInSitecore(
    ICustomerRepository customerRepository,
    IEntityFactory entityFactory
)
Public Sub New (
    customerRepository As ICustomerRepository,
    entityFactory As IEntityFactory
)
public:
UpdateCustomerInSitecore(
    ICustomerRepository^ customerRepository,
    IEntityFactory^ entityFactory
)
new :
        customerRepository : ICustomerRepository *
        entityFactory : IEntityFactory -> UpdateCustomerInSitecore

Parameters

customerRepository
Type: Sitecore.Commerce.Data.CustomersICustomerRepository
The customer repository.
entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
See Also

Reference

UpdateCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.UpdateCustomer Namespace


UpdateCustomerInSitecore Methods

UpdateCustomerInSitecore Methods

The UpdateCustomerInSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the UpdateCustomerInEaState processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.UpdateCustomer Namespace


UpdateCustomerInSitecore.Process Method

UpdateCustomerInSitecoreProcess Method
Executes the business logic of the UpdateCustomerInEaState processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateCustomer
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

UpdateCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.UpdateCustomer Namespace


UpdateCustomerInSitecore Properties

UpdateCustomerInSitecore Properties

The UpdateCustomerInSitecore type exposes the following members.

Properties
 | Name | Description
Public property | CustomerRepository | Gets or sets the customer repository. (Inherited from CustomerPipelineProcessor.)
Top
See Also

Reference

UpdateCustomerInSitecore Class
Sitecore.Commerce.Pipelines.Customers.UpdateCustomer Namespace


Sitecore.Commerce.Pipelines.Customers.UpdateParties Namespace

Sitecore.Commerce.Pipelines.Customers.UpdateParties Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.UpdateParties"]

Classes
 | Class | Description
Public class | UpdatePartiesInExternalSystem | Defines the UpdatePartiesInExternalSystem class.


UpdatePartiesInExternalSystem Class

UpdatePartiesInExternalSystem Class
Defines the UpdatePartiesInExternalSystem class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.UpdatePartiesUpdatePartiesInExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateParties
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdatePartiesInExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class UpdatePartiesInExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class UpdatePartiesInExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type UpdatePartiesInExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The UpdatePartiesInExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | UpdatePartiesInExternalSystem | Initializes a new instance of the UpdatePartiesInExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.UpdateParties Namespace


UpdatePartiesInExternalSystem Constructor

UpdatePartiesInExternalSystem Constructor
Initializes a new instance of the UpdatePartiesInExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateParties
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdatePartiesInExternalSystem()
Public Sub New
public:
UpdatePartiesInExternalSystem()
new : unit -> UpdatePartiesInExternalSystem
See Also

Reference

UpdatePartiesInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.UpdateParties Namespace


UpdatePartiesInExternalSystem Methods

UpdatePartiesInExternalSystem Methods

The UpdatePartiesInExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdatePartiesInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.UpdateParties Namespace


UpdatePartiesInExternalSystem.Process Method

UpdatePartiesInExternalSystemProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateParties
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

UpdatePartiesInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.UpdateParties Namespace


Sitecore.Commerce.Pipelines.Customers.UpdateUser Namespace

Sitecore.Commerce.Pipelines.Customers.UpdateUser Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Customers.UpdateUser"]

Classes
 | Class | Description
Public class | UpdateUserInExternalSystem | Defines the processor that updates a user in the external commerce system.
Public class | UpdateUserInSitecore | Defines the processor that updates a user in Sitecore. This class implements the ManageUserProfileInSitecore class.


UpdateUserInExternalSystem Class

UpdateUserInExternalSystem Class
Defines the processor that updates a user in the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.UpdateUserUpdateUserInExternalSystem

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateUserInExternalSystem : PipelineProcessor<ServicePipelineArgs>
Public Class UpdateUserInExternalSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class UpdateUserInExternalSystem : public PipelineProcessor<ServicePipelineArgs^>
type UpdateUserInExternalSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The UpdateUserInExternalSystem type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateUserInExternalSystem | Initializes a new instance of the UpdateUserInExternalSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the UpdateUserInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.UpdateUser Namespace


UpdateUserInExternalSystem Constructor

UpdateUserInExternalSystem Constructor
Initializes a new instance of the UpdateUserInExternalSystem class

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateUserInExternalSystem()
Public Sub New
public:
UpdateUserInExternalSystem()
new : unit -> UpdateUserInExternalSystem
See Also

Reference

UpdateUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.UpdateUser Namespace


UpdateUserInExternalSystem Methods

UpdateUserInExternalSystem Methods

The UpdateUserInExternalSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the UpdateUserInExternalSystem processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.UpdateUser Namespace


UpdateUserInExternalSystem.Process Method

UpdateUserInExternalSystemProcess Method
Executes the business logic of the UpdateUserInExternalSystem processor.

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

UpdateUserInExternalSystem Class
Sitecore.Commerce.Pipelines.Customers.UpdateUser Namespace


UpdateUserInSitecore Class

UpdateUserInSitecore Class
Defines the processor that updates a user in Sitecore. This class implements the ManageUserProfileInSitecore class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Customers.CommonUserPipelineProcessor
Sitecore.Commerce.Pipelines.Customers.CommonManageUserInSitecore
Sitecore.Commerce.Pipelines.Customers.UpdateUserUpdateUserInSitecore

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateUserInSitecore : ManageUserInSitecore
Public Class UpdateUserInSitecore
    Inherits ManageUserInSitecore
public ref class UpdateUserInSitecore : public ManageUserInSitecore
type UpdateUserInSitecore =
    class
        inherit ManageUserInSitecore
    end

The UpdateUserInSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateUserInSitecore | Initializes a new instance of the UpdateUserInSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ManageUserInSitecore processor. (Inherited from ManageUserInSitecore.)
Protected method | ProcessSitecoreUser | Processes the user account in sitecore. (Overrides ManageUserInSitecoreProcessSitecoreUser(CommerceUser, UserRequestWithUser, ServiceProviderResult).)
Protected method | SetResult | Sets the result. (Inherited from ManageUserInSitecore.)
Protected method | ShouldAbortPipeline | Based on whether a user exists or not, determines whether the pipeline must stop. (Inherited from ManageUserInSitecore.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Customers.UpdateUser Namespace


UpdateUserInSitecore Constructor

UpdateUserInSitecore Constructor
Initializes a new instance of the UpdateUserInSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateUserInSitecore(
    IUserRepository userRepository
)
Public Sub New (
    userRepository As IUserRepository
)
public:
UpdateUserInSitecore(
    IUserRepository^ userRepository
)
new :
        userRepository : IUserRepository -> UpdateUserInSitecore

Parameters

userRepository
Type: Sitecore.Commerce.Data.CustomersIUserRepository
The user repository.
See Also

Reference

UpdateUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.UpdateUser Namespace


UpdateUserInSitecore Methods

UpdateUserInSitecore Methods

The UpdateUserInSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ManageUserInSitecore processor. (Inherited from ManageUserInSitecore.)
Protected method | ProcessSitecoreUser | Processes the user account in sitecore. (Overrides ManageUserInSitecoreProcessSitecoreUser(CommerceUser, UserRequestWithUser, ServiceProviderResult).)
Protected method | SetResult | Sets the result. (Inherited from ManageUserInSitecore.)
Protected method | ShouldAbortPipeline | Based on whether a user exists or not, determines whether the pipeline must stop. (Inherited from ManageUserInSitecore.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.UpdateUser Namespace


UpdateUserInSitecore.ProcessSitecoreUser Method

UpdateUserInSitecoreProcessSitecoreUser Method
Processes the user account in sitecore.

Namespace: Sitecore.Commerce.Pipelines.Customers.UpdateUser
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void ProcessSitecoreUser(
    CommerceUser user,
    UserRequestWithUser request,
    ServiceProviderResult result
)
Protected Overrides Sub ProcessSitecoreUser (
    user As CommerceUser,
    request As UserRequestWithUser,
    result As ServiceProviderResult
)
protected:
virtual void ProcessSitecoreUser(
    CommerceUser^ user,
    UserRequestWithUser^ request,
    ServiceProviderResult^ result
) override
abstract ProcessSitecoreUser :
        user : CommerceUser *
        request : UserRequestWithUser *
        result : ServiceProviderResult -> unit
override ProcessSitecoreUser :
        user : CommerceUser *
        request : UserRequestWithUser *
        result : ServiceProviderResult -> unit

Parameters

user
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The user.
request
Type: Sitecore.Commerce.Services.CustomersUserRequestWithUser
The request.
result
Type: Sitecore.Commerce.ServicesServiceProviderResult
The result.
See Also

Reference

UpdateUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.UpdateUser Namespace


UpdateUserInSitecore Properties

UpdateUserInSitecore Properties

The UpdateUserInSitecore type exposes the following members.

Properties
 | Name | Description
Public property | UserRepository | Gets or sets the user repository. (Inherited from UserPipelineProcessor.)
Top
See Also

Reference

UpdateUserInSitecore Class
Sitecore.Commerce.Pipelines.Customers.UpdateUser Namespace


Sitecore.Commerce.Pipelines.Inventory.Common Namespace

Sitecore.Commerce.Pipelines.Inventory.Common Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Inventory.Common"]

Classes
 | Class | Description
Public class | TriggerAddToCartStockStatusPageEvent | Defines the processor which triggers page event to track cart lines stock status.


TriggerAddToCartStockStatusPageEvent Class

TriggerAddToCartStockStatusPageEvent Class
Defines the processor which triggers page event to track cart lines stock status.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Inventory.CommonTriggerAddToCartStockStatusPageEvent

Namespace: Sitecore.Commerce.Pipelines.Inventory.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerAddToCartStockStatusPageEvent : TriggerPageEvent
Public Class TriggerAddToCartStockStatusPageEvent
    Inherits TriggerPageEvent
public ref class TriggerAddToCartStockStatusPageEvent : public TriggerPageEvent
type TriggerAddToCartStockStatusPageEvent =
    class
        inherit TriggerPageEvent
    end

The TriggerAddToCartStockStatusPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerAddToCartStockStatusPageEvent | Initializes a new instance of the TriggerAddToCartStockStatusPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractCartData | Extracts the cart data and returns the data in a dictionary.
Protected method | ExtractCartLineData | Gets the cart line data.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartFromArgs | Gets the cart from args.
Protected method | GetCartLinesFromArgs | Gets the cart from args.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerVisitedProductStockStatusPageEvent processor. (Overrides TriggerPageEventProcess(ServicePipelineArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Inventory.Common Namespace


TriggerAddToCartStockStatusPageEvent Constructor

TriggerAddToCartStockStatusPageEvent Constructor
Initializes a new instance of the TriggerAddToCartStockStatusPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Inventory.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerAddToCartStockStatusPageEvent()
Public Sub New
public:
TriggerAddToCartStockStatusPageEvent()
new : unit -> TriggerAddToCartStockStatusPageEvent
See Also

Reference

TriggerAddToCartStockStatusPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.Common Namespace


TriggerAddToCartStockStatusPageEvent Methods

TriggerAddToCartStockStatusPageEvent Methods

The TriggerAddToCartStockStatusPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractCartData | Extracts the cart data and returns the data in a dictionary.
Protected method | ExtractCartLineData | Gets the cart line data.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartFromArgs | Gets the cart from args.
Protected method | GetCartLinesFromArgs | Gets the cart from args.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerVisitedProductStockStatusPageEvent processor. (Overrides TriggerPageEventProcess(ServicePipelineArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerAddToCartStockStatusPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.Common Namespace


TriggerAddToCartStockStatusPageEvent.ExtractCartData Method

TriggerAddToCartStockStatusPageEventExtractCartData Method
Extracts the cart data and returns the data in a dictionary.

Namespace: Sitecore.Commerce.Pipelines.Inventory.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual IDictionary<string, Object> ExtractCartData(
    CartBase cart,
    IEnumerable<IDictionary<string, string>> cartLines
)
Protected Overridable Function ExtractCartData (
    cart As CartBase,
    cartLines As IEnumerable(Of IDictionary(Of String, String))
) As IDictionary(Of String, Object)
protected:
virtual IDictionary<String^, Object^>^ ExtractCartData(
    CartBase^ cart,
    IEnumerable<IDictionary<String^, String^>^>^ cartLines
)
abstract ExtractCartData :
        cart : CartBase *
        cartLines : IEnumerable<IDictionary<string, string>> -> IDictionary<string, Object>
override ExtractCartData :
        cart : CartBase *
        cartLines : IEnumerable<IDictionary<string, string>> -> IDictionary<string, Object>

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCartBase
The cart.
cartLines
Type: System.Collections.GenericIEnumerable IDictionary String, String
The cart lines.

Return Value

Type: IDictionary String, Object
The dictionary with the required cart fields only.
See Also

Reference

TriggerAddToCartStockStatusPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.Common Namespace


TriggerAddToCartStockStatusPageEvent.ExtractCartLineData Method

TriggerAddToCartStockStatusPageEventExtractCartLineData Method
Gets the cart line data.

Namespace: Sitecore.Commerce.Pipelines.Inventory.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual IEnumerable<IDictionary<string, string>> ExtractCartLineData(
    IEnumerable<CartLine> cartLines
)
Protected Overridable Function ExtractCartLineData (
    cartLines As IEnumerable(Of CartLine)
) As IEnumerable(Of IDictionary(Of String, String))
protected:
virtual IEnumerable<IDictionary<String^, String^>^>^ ExtractCartLineData(
    IEnumerable<CartLine^>^ cartLines
)
abstract ExtractCartLineData :
        cartLines : IEnumerable<CartLine> -> IEnumerable<IDictionary<string, string>>
override ExtractCartLineData :
        cartLines : IEnumerable<CartLine> -> IEnumerable<IDictionary<string, string>>

Parameters

cartLines
Type: System.Collections.GenericIEnumerable CartLine
The cart lines.

Return Value

Type: IEnumerable IDictionary String, String
List of dictionaries with required fields.
See Also

Reference

TriggerAddToCartStockStatusPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.Common Namespace


TriggerAddToCartStockStatusPageEvent.GetCartFromArgs Method

TriggerAddToCartStockStatusPageEventGetCartFromArgs Method
Gets the cart from args.

Namespace: Sitecore.Commerce.Pipelines.Inventory.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual CartBase GetCartFromArgs(
    ServicePipelineArgs args
)
Protected Overridable Function GetCartFromArgs (
    args As ServicePipelineArgs
) As CartBase
protected:
virtual CartBase^ GetCartFromArgs(
    ServicePipelineArgs^ args
)
abstract GetCartFromArgs :
        args : ServicePipelineArgs -> CartBase
override GetCartFromArgs :
        args : ServicePipelineArgs -> CartBase

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args

Return Value

Type: CartBase
The cart in the args parameter
See Also

Reference

TriggerAddToCartStockStatusPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.Common Namespace


TriggerAddToCartStockStatusPageEvent.GetCartLinesFromArgs Method

TriggerAddToCartStockStatusPageEventGetCartLinesFromArgs Method
Gets the cart from args.

Namespace: Sitecore.Commerce.Pipelines.Inventory.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual IEnumerable<CartLine> GetCartLinesFromArgs(
    ServicePipelineArgs args
)
Protected Overridable Function GetCartLinesFromArgs (
    args As ServicePipelineArgs
) As IEnumerable(Of CartLine)
protected:
virtual IEnumerable<CartLine^>^ GetCartLinesFromArgs(
    ServicePipelineArgs^ args
)
abstract GetCartLinesFromArgs :
        args : ServicePipelineArgs -> IEnumerable<CartLine>
override GetCartLinesFromArgs :
        args : ServicePipelineArgs -> IEnumerable<CartLine>

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args

Return Value

Type: IEnumerable CartLine
The cart lines in the args parameter
See Also

Reference

TriggerAddToCartStockStatusPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.Common Namespace


TriggerAddToCartStockStatusPageEvent.GetPageEventData Method

TriggerAddToCartStockStatusPageEventGetPageEventData Method
Gets the page event data.

Namespace: Sitecore.Commerce.Pipelines.Inventory.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetPageEventData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventData (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventData :
        args : ServicePipelineArgs -> string
override GetPageEventData :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
The page event data.
See Also

Reference

TriggerAddToCartStockStatusPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.Common Namespace


TriggerAddToCartStockStatusPageEvent.Process Method

TriggerAddToCartStockStatusPageEventProcess Method
Executes the business logic of the TriggerVisitedProductStockStatusPageEvent processor.

Namespace: Sitecore.Commerce.Pipelines.Inventory.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

TriggerAddToCartStockStatusPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.Common Namespace


TriggerAddToCartStockStatusPageEvent Properties

TriggerAddToCartStockStatusPageEvent Properties

The TriggerAddToCartStockStatusPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerAddToCartStockStatusPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.Common Namespace


Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation Namespace

Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation"]

Classes
 | Class | Description
Public class | GetBackOrderableInformation | Defines the processor that executes the GetBackOrderableInformation pipeline.
Public class | GetPreOrderableInformation | Defines the processor that executes the GetPreOrderableInformation pipeline.


GetBackOrderableInformation Class

GetBackOrderableInformation Class
Defines the processor that executes the GetBackOrderableInformation pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformationGetBackOrderableInformation

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetBackOrderableInformation : PipelineProcessor<ServicePipelineArgs>
Public Class GetBackOrderableInformation
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class GetBackOrderableInformation : public PipelineProcessor<ServicePipelineArgs^>
type GetBackOrderableInformation =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The GetBackOrderableInformation type exposes the following members.

Constructors
 | Name | Description
Public method | GetBackOrderableInformation | Initializes a new instance of the GetBackOrderableInformation class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetBackOrderableInformation processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation Namespace


GetBackOrderableInformation Constructor

GetBackOrderableInformation Constructor
Initializes a new instance of the GetBackOrderableInformation class

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetBackOrderableInformation()
Public Sub New
public:
GetBackOrderableInformation()
new : unit -> GetBackOrderableInformation
See Also

Reference

GetBackOrderableInformation Class
Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation Namespace


GetBackOrderableInformation Methods

GetBackOrderableInformation Methods

The GetBackOrderableInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetBackOrderableInformation processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetBackOrderableInformation Class
Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation Namespace


GetBackOrderableInformation.Process Method

GetBackOrderableInformationProcess Method
Executes the business logic of the GetBackOrderableInformation processor.

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

GetBackOrderableInformation Class
Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation Namespace


GetPreOrderableInformation Class

GetPreOrderableInformation Class
Defines the processor that executes the GetPreOrderableInformation pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformationGetPreOrderableInformation

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetPreOrderableInformation : PipelineProcessor<ServicePipelineArgs>
Public Class GetPreOrderableInformation
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class GetPreOrderableInformation : public PipelineProcessor<ServicePipelineArgs^>
type GetPreOrderableInformation =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The GetPreOrderableInformation type exposes the following members.

Constructors
 | Name | Description
Public method | GetPreOrderableInformation | Initializes a new instance of the GetPreOrderableInformation class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetPreOrderableInformation processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation Namespace


GetPreOrderableInformation Constructor

GetPreOrderableInformation Constructor
Initializes a new instance of the GetPreOrderableInformation class

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetPreOrderableInformation()
Public Sub New
public:
GetPreOrderableInformation()
new : unit -> GetPreOrderableInformation
See Also

Reference

GetPreOrderableInformation Class
Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation Namespace


GetPreOrderableInformation Methods

GetPreOrderableInformation Methods

The GetPreOrderableInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetPreOrderableInformation processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetPreOrderableInformation Class
Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation Namespace


GetPreOrderableInformation.Process Method

GetPreOrderableInformationProcess Method
Executes the business logic of the GetPreOrderableInformation processor.

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

GetPreOrderableInformation Class
Sitecore.Commerce.Pipelines.Inventory.GetOrderableInformation Namespace


Sitecore.Commerce.Pipelines.Inventory.GetStockInformation Namespace

Sitecore.Commerce.Pipelines.Inventory.GetStockInformation Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Inventory.GetStockInformation"]

Classes
 | Class | Description
Public class | GetBackInStockInformation | Placeholder pipeline processor for the GetBackInStockInformation pipeline.
Public class | GetStockInformation | Placeholder pipeline processor for the GetStockInformation pipeline.
Public class | StockStatusForIndexing | Placeholder pipeline processor for the StockStatusForIndexing pipeline.


GetBackInStockInformation Class

GetBackInStockInformation Class
Placeholder pipeline processor for the GetBackInStockInformation pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Inventory.GetStockInformationGetBackInStockInformation

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetStockInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetBackInStockInformation : PipelineProcessor<ServicePipelineArgs>
Public Class GetBackInStockInformation
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class GetBackInStockInformation : public PipelineProcessor<ServicePipelineArgs^>
type GetBackInStockInformation =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The GetBackInStockInformation type exposes the following members.

Constructors
 | Name | Description
Public method | GetBackInStockInformation | Initializes a new instance of the GetBackInStockInformation class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Inventory.GetStockInformation Namespace


GetBackInStockInformation Constructor

GetBackInStockInformation Constructor
Initializes a new instance of the GetBackInStockInformation class

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetStockInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetBackInStockInformation()
Public Sub New
public:
GetBackInStockInformation()
new : unit -> GetBackInStockInformation
See Also

Reference

GetBackInStockInformation Class
Sitecore.Commerce.Pipelines.Inventory.GetStockInformation Namespace


GetBackInStockInformation Methods

GetBackInStockInformation Methods

The GetBackInStockInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetBackInStockInformation Class
Sitecore.Commerce.Pipelines.Inventory.GetStockInformation Namespace


GetBackInStockInformation.Process Method

GetBackInStockInformationProcess Method
Runs the pipeline processor.

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetStockInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

GetBackInStockInformation Class
Sitecore.Commerce.Pipelines.Inventory.GetStockInformation Namespace


GetStockInformation Class

GetStockInformation Class
Placeholder pipeline processor for the GetStockInformation pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Inventory.GetStockInformationGetStockInformation

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetStockInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetStockInformation : PipelineProcessor<ServicePipelineArgs>
Public Class GetStockInformation
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class GetStockInformation : public PipelineProcessor<ServicePipelineArgs^>
type GetStockInformation =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The GetStockInformation type exposes the following members.

Constructors
 | Name | Description
Public method | GetStockInformation | Initializes a new instance of the GetStockInformation class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Inventory.GetStockInformation Namespace


GetStockInformation Constructor

GetStockInformation Constructor
Initializes a new instance of the GetStockInformation class

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetStockInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetStockInformation()
Public Sub New
public:
GetStockInformation()
new : unit -> GetStockInformation
See Also

Reference

GetStockInformation Class
Sitecore.Commerce.Pipelines.Inventory.GetStockInformation Namespace


GetStockInformation Methods

GetStockInformation Methods

The GetStockInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetStockInformation Class
Sitecore.Commerce.Pipelines.Inventory.GetStockInformation Namespace


GetStockInformation.Process Method

GetStockInformationProcess Method
Runs the pipeline processor.

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetStockInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

GetStockInformation Class
Sitecore.Commerce.Pipelines.Inventory.GetStockInformation Namespace


StockStatusForIndexing Class

StockStatusForIndexing Class
Placeholder pipeline processor for the StockStatusForIndexing pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Inventory.GetStockInformationStockStatusForIndexing

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetStockInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class StockStatusForIndexing : PipelineProcessor<ServicePipelineArgs>
Public Class StockStatusForIndexing
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class StockStatusForIndexing : public PipelineProcessor<ServicePipelineArgs^>
type StockStatusForIndexing =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The StockStatusForIndexing type exposes the following members.

Constructors
 | Name | Description
Public method | StockStatusForIndexing | Initializes a new instance of the StockStatusForIndexing class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Inventory.GetStockInformation Namespace


StockStatusForIndexing Constructor

StockStatusForIndexing Constructor
Initializes a new instance of the StockStatusForIndexing class

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetStockInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockStatusForIndexing()
Public Sub New
public:
StockStatusForIndexing()
new : unit -> StockStatusForIndexing
See Also

Reference

StockStatusForIndexing Class
Sitecore.Commerce.Pipelines.Inventory.GetStockInformation Namespace


StockStatusForIndexing Methods

StockStatusForIndexing Methods

The StockStatusForIndexing type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StockStatusForIndexing Class
Sitecore.Commerce.Pipelines.Inventory.GetStockInformation Namespace


StockStatusForIndexing.Process Method

StockStatusForIndexingProcess Method
Runs the pipeline processor.

Namespace: Sitecore.Commerce.Pipelines.Inventory.GetStockInformation
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

StockStatusForIndexing Class
Sitecore.Commerce.Pipelines.Inventory.GetStockInformation Namespace


Sitecore.Commerce.Pipelines.Inventory.ProductsAreBackInStock Namespace

Sitecore.Commerce.Pipelines.Inventory.ProductsAreBackInStock Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Inventory.ProductsAreBackInStock"]

Classes
 | Class | Description
Public class | TriggerProductsAreBackInStockPageEvent | Defines the processor which triggers the page event Products Back In Stock, so that the visitors which have signed up, can be notified.


TriggerProductsAreBackInStockPageEvent Class

TriggerProductsAreBackInStockPageEvent Class
Defines the processor which triggers the page event Products Back In Stock, so that the visitors which have signed up, can be notified.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Inventory.ProductsAreBackInStockTriggerProductsAreBackInStockPageEvent

Namespace: Sitecore.Commerce.Pipelines.Inventory.ProductsAreBackInStock
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerProductsAreBackInStockPageEvent : TriggerPageEvent
Public Class TriggerProductsAreBackInStockPageEvent
    Inherits TriggerPageEvent
public ref class TriggerProductsAreBackInStockPageEvent : public TriggerPageEvent
type TriggerProductsAreBackInStockPageEvent =
    class
        inherit TriggerPageEvent
    end

The TriggerProductsAreBackInStockPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerProductsAreBackInStockPageEvent | Initializes a new instance of the TriggerProductsAreBackInStockPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Inventory.ProductsAreBackInStock Namespace


TriggerProductsAreBackInStockPageEvent Constructor

TriggerProductsAreBackInStockPageEvent Constructor
Initializes a new instance of the TriggerProductsAreBackInStockPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Inventory.ProductsAreBackInStock
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerProductsAreBackInStockPageEvent()
Public Sub New
public:
TriggerProductsAreBackInStockPageEvent()
new : unit -> TriggerProductsAreBackInStockPageEvent
See Also

Reference

TriggerProductsAreBackInStockPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.ProductsAreBackInStock Namespace


TriggerProductsAreBackInStockPageEvent Methods

TriggerProductsAreBackInStockPageEvent Methods

The TriggerProductsAreBackInStockPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerProductsAreBackInStockPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.ProductsAreBackInStock Namespace


TriggerProductsAreBackInStockPageEvent.GetPageEventData Method

TriggerProductsAreBackInStockPageEventGetPageEventData Method
Gets the page event data.

Namespace: Sitecore.Commerce.Pipelines.Inventory.ProductsAreBackInStock
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetPageEventData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventData (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventData :
        args : ServicePipelineArgs -> string
override GetPageEventData :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
The page event data.
See Also

Reference

TriggerProductsAreBackInStockPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.ProductsAreBackInStock Namespace


TriggerProductsAreBackInStockPageEvent Properties

TriggerProductsAreBackInStockPageEvent Properties

The TriggerProductsAreBackInStockPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerProductsAreBackInStockPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.ProductsAreBackInStock Namespace


Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace

Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification"]

Classes
 | Class | Description
Public class | RemoveVisitorFromStockNotification | Removes a back-in-stock notification request that a visitor has previously requested.
Public class | TriggerBackInStockUnsubscriptionPageEvent | Defines the pipeline processor which triggers page event to subscripte the user for back in stock notification.


RemoveVisitorFromStockNotification Class

RemoveVisitorFromStockNotification Class
Removes a back-in-stock notification request that a visitor has previously requested.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotificationRemoveVisitorFromStockNotification

Namespace: Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveVisitorFromStockNotification : PipelineProcessor<ServicePipelineArgs>
Public Class RemoveVisitorFromStockNotification
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class RemoveVisitorFromStockNotification : public PipelineProcessor<ServicePipelineArgs^>
type RemoveVisitorFromStockNotification =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The RemoveVisitorFromStockNotification type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveVisitorFromStockNotification | Initializes an instance of the RemoveVisitorFromStockNotification class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | ToStockNotificationRequest | Converts a RemoveVisitorFromStockNotificationRequest into a StockNotificationRequest.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | AutomationProvider | Gets the inventory automation provider.
Public property | EngagementPlanName | Gets or sets the engagement plan name.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


RemoveVisitorFromStockNotification Constructor

RemoveVisitorFromStockNotification Constructor
Initializes an instance of the RemoveVisitorFromStockNotification class.

Namespace: Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveVisitorFromStockNotification()
Public Sub New
public:
RemoveVisitorFromStockNotification()
new : unit -> RemoveVisitorFromStockNotification
See Also

Reference

RemoveVisitorFromStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


RemoveVisitorFromStockNotification Methods

RemoveVisitorFromStockNotification Methods

The RemoveVisitorFromStockNotification type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | ToStockNotificationRequest | Converts a RemoveVisitorFromStockNotificationRequest into a StockNotificationRequest.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveVisitorFromStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


RemoveVisitorFromStockNotification.Process Method

RemoveVisitorFromStockNotificationProcess Method
Runs the pipeline processor.

Namespace: Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

RemoveVisitorFromStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


RemoveVisitorFromStockNotification.ToStockNotificationRequest Method

RemoveVisitorFromStockNotificationToStockNotificationRequest Method
Converts a RemoveVisitorFromStockNotificationRequest into a StockNotificationRequest.

Namespace: Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual StockNotificationRequest ToStockNotificationRequest(
    RemoveVisitorFromStockNotificationRequest request
)
Protected Overridable Function ToStockNotificationRequest (
    request As RemoveVisitorFromStockNotificationRequest
) As StockNotificationRequest
protected:
virtual StockNotificationRequest^ ToStockNotificationRequest(
    RemoveVisitorFromStockNotificationRequest^ request
)
abstract ToStockNotificationRequest :
        request : RemoveVisitorFromStockNotificationRequest -> StockNotificationRequest
override ToStockNotificationRequest :
        request : RemoveVisitorFromStockNotificationRequest -> StockNotificationRequest

Parameters

request
Type: Sitecore.Commerce.Services.InventoryRemoveVisitorFromStockNotificationRequest
The RemoveVisitorFromStockNotificationRequest to convert.

Return Value

Type: StockNotificationRequest
The converted StockNotificationRequest.
See Also

Reference

RemoveVisitorFromStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


RemoveVisitorFromStockNotification Properties

RemoveVisitorFromStockNotification Properties

The RemoveVisitorFromStockNotification type exposes the following members.

Properties
 | Name | Description
Protected property | AutomationProvider | Gets the inventory automation provider.
Public property | EngagementPlanName | Gets or sets the engagement plan name.
Top
See Also

Reference

RemoveVisitorFromStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


RemoveVisitorFromStockNotification.AutomationProvider Property

RemoveVisitorFromStockNotificationAutomationProvider Property
Gets the inventory automation provider.

Namespace: Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected InventoryAutomationProvider AutomationProvider { get; }
Protected ReadOnly Property AutomationProvider As InventoryAutomationProvider
    Get
protected:
property InventoryAutomationProvider^ AutomationProvider {
    InventoryAutomationProvider^ get ();
}
member AutomationProvider : InventoryAutomationProvider with get

Property Value

Type: InventoryAutomationProvider
See Also

Reference

RemoveVisitorFromStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


RemoveVisitorFromStockNotification.EngagementPlanName Property

RemoveVisitorFromStockNotificationEngagementPlanName Property
Gets or sets the engagement plan name.

Namespace: Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string EngagementPlanName { get; set; }
Public Property EngagementPlanName As String
    Get
    Set
public:
property String^ EngagementPlanName {
    String^ get ();
    void set (String^ value);
}
member EngagementPlanName : string with get, set

Property Value

Type: String
The engagement plan name.
See Also

Reference

RemoveVisitorFromStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


TriggerBackInStockUnsubscriptionPageEvent Class

TriggerBackInStockUnsubscriptionPageEvent Class
Defines the pipeline processor which triggers page event to subscripte the user for back in stock notification.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotificationTriggerBackInStockUnsubscriptionPageEvent

Namespace: Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerBackInStockUnsubscriptionPageEvent : TriggerPageEvent
Public Class TriggerBackInStockUnsubscriptionPageEvent
    Inherits TriggerPageEvent
public ref class TriggerBackInStockUnsubscriptionPageEvent : public TriggerPageEvent
type TriggerBackInStockUnsubscriptionPageEvent =
    class
        inherit TriggerPageEvent
    end

The TriggerBackInStockUnsubscriptionPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerBackInStockUnsubscriptionPageEvent | Initializes a new instance of the TriggerBackInStockUnsubscriptionPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerBackInStockUnsubscriptionPageEvent processor. (Overrides TriggerPageEventProcess(ServicePipelineArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
RequestNotificationRemovedParameterName | The request context parameter that indicates whether the back-in-stock notification in the request parameters was successfully removed.
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


TriggerBackInStockUnsubscriptionPageEvent Constructor

TriggerBackInStockUnsubscriptionPageEvent Constructor
Initializes a new instance of the TriggerBackInStockUnsubscriptionPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerBackInStockUnsubscriptionPageEvent()
Public Sub New
public:
TriggerBackInStockUnsubscriptionPageEvent()
new : unit -> TriggerBackInStockUnsubscriptionPageEvent
See Also

Reference

TriggerBackInStockUnsubscriptionPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


TriggerBackInStockUnsubscriptionPageEvent Fields

TriggerBackInStockUnsubscriptionPageEvent Fields

The TriggerBackInStockUnsubscriptionPageEvent type exposes the following members.

Fields
Name | Description
RequestNotificationRemovedParameterName | The request context parameter that indicates whether the back-in-stock notification in the request parameters was successfully removed.
Top
See Also

Reference

TriggerBackInStockUnsubscriptionPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


TriggerBackInStockUnsubscriptionPageEvent.RequestNotificationRemovedParameterName Field

TriggerBackInStockUnsubscriptionPageEventRequestNotificationRemovedParameterName Field
The request context parameter that indicates whether the back-in-stock notification in the request parameters was successfully removed.

Namespace: Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public const string RequestNotificationRemovedParameterName
Public Const RequestNotificationRemovedParameterName As String
public:
literal String^ RequestNotificationRemovedParameterName
static val mutable RequestNotificationRemovedParameterName: string

Field Value

Type: String
See Also

Reference

TriggerBackInStockUnsubscriptionPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


TriggerBackInStockUnsubscriptionPageEvent Methods

TriggerBackInStockUnsubscriptionPageEvent Methods

The TriggerBackInStockUnsubscriptionPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerBackInStockUnsubscriptionPageEvent processor. (Overrides TriggerPageEventProcess(ServicePipelineArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerBackInStockUnsubscriptionPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


TriggerBackInStockUnsubscriptionPageEvent.GetPageEventData Method

TriggerBackInStockUnsubscriptionPageEventGetPageEventData Method
Gets the page event data.

Namespace: Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetPageEventData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventData (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventData :
        args : ServicePipelineArgs -> string
override GetPageEventData :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
The page event data.
See Also

Reference

TriggerBackInStockUnsubscriptionPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


TriggerBackInStockUnsubscriptionPageEvent.Process Method

TriggerBackInStockUnsubscriptionPageEventProcess Method
Executes the business logic of the TriggerBackInStockUnsubscriptionPageEvent processor.

Namespace: Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

TriggerBackInStockUnsubscriptionPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


TriggerBackInStockUnsubscriptionPageEvent Properties

TriggerBackInStockUnsubscriptionPageEvent Properties

The TriggerBackInStockUnsubscriptionPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerBackInStockUnsubscriptionPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.RemoveVisitorFromStockNotification Namespace


Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatus Namespace

Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatus Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatus"]

Classes
 | Class | Description
Public class | TriggerVisitedProductStockStatusPageEvent | Defines the processor which triggers page event to track product stock status.


TriggerVisitedProductStockStatusPageEvent Class

TriggerVisitedProductStockStatusPageEvent Class
Defines the processor which triggers page event to track product stock status.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatusTriggerVisitedProductStockStatusPageEvent

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatus
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerVisitedProductStockStatusPageEvent : TriggerPageEvent
Public Class TriggerVisitedProductStockStatusPageEvent
    Inherits TriggerPageEvent
public ref class TriggerVisitedProductStockStatusPageEvent : public TriggerPageEvent
type TriggerVisitedProductStockStatusPageEvent =
    class
        inherit TriggerPageEvent
    end

The TriggerVisitedProductStockStatusPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerVisitedProductStockStatusPageEvent | Initializes a new instance of the TriggerVisitedProductStockStatusPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerVisitedProductStockStatusPageEvent processor. (Overrides TriggerPageEventProcess(ServicePipelineArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatus Namespace


TriggerVisitedProductStockStatusPageEvent Constructor

TriggerVisitedProductStockStatusPageEvent Constructor
Initializes a new instance of the TriggerVisitedProductStockStatusPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatus
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerVisitedProductStockStatusPageEvent()
Public Sub New
public:
TriggerVisitedProductStockStatusPageEvent()
new : unit -> TriggerVisitedProductStockStatusPageEvent
See Also

Reference

TriggerVisitedProductStockStatusPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatus Namespace


TriggerVisitedProductStockStatusPageEvent Methods

TriggerVisitedProductStockStatusPageEvent Methods

The TriggerVisitedProductStockStatusPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerVisitedProductStockStatusPageEvent processor. (Overrides TriggerPageEventProcess(ServicePipelineArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerVisitedProductStockStatusPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatus Namespace


TriggerVisitedProductStockStatusPageEvent.GetPageEventData Method

TriggerVisitedProductStockStatusPageEventGetPageEventData Method
Gets the page event data.

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatus
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetPageEventData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventData (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventData :
        args : ServicePipelineArgs -> string
override GetPageEventData :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
The page event data.
See Also

Reference

TriggerVisitedProductStockStatusPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatus Namespace


TriggerVisitedProductStockStatusPageEvent.Process Method

TriggerVisitedProductStockStatusPageEventProcess Method
Executes the business logic of the TriggerVisitedProductStockStatusPageEvent processor.

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatus
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

TriggerVisitedProductStockStatusPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatus Namespace


TriggerVisitedProductStockStatusPageEvent Properties

TriggerVisitedProductStockStatusPageEvent Properties

The TriggerVisitedProductStockStatusPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerVisitedProductStockStatusPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.VisitedProductStockStatus Namespace


Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace

Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification"]

Classes
 | Class | Description
Public class | TriggerBackInStockSubscriptionPageEvent | Defines the pipeline processor which triggers page event to subscribe the user for back in stock notification.
Public class | VisitorSignUpForStockNotification | Defines the pipeline processor which adds the visitor to the EA plan back in stock notification.


TriggerBackInStockSubscriptionPageEvent Class

TriggerBackInStockSubscriptionPageEvent Class
Defines the pipeline processor which triggers page event to subscribe the user for back in stock notification.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotificationTriggerBackInStockSubscriptionPageEvent

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerBackInStockSubscriptionPageEvent : TriggerPageEvent
Public Class TriggerBackInStockSubscriptionPageEvent
    Inherits TriggerPageEvent
public ref class TriggerBackInStockSubscriptionPageEvent : public TriggerPageEvent
type TriggerBackInStockSubscriptionPageEvent =
    class
        inherit TriggerPageEvent
    end

The TriggerBackInStockSubscriptionPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerBackInStockSubscriptionPageEvent | Initializes a new instance of the TriggerBackInStockSubscriptionPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


TriggerBackInStockSubscriptionPageEvent Constructor

TriggerBackInStockSubscriptionPageEvent Constructor
Initializes a new instance of the TriggerBackInStockSubscriptionPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerBackInStockSubscriptionPageEvent()
Public Sub New
public:
TriggerBackInStockSubscriptionPageEvent()
new : unit -> TriggerBackInStockSubscriptionPageEvent
See Also

Reference

TriggerBackInStockSubscriptionPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


TriggerBackInStockSubscriptionPageEvent Methods

TriggerBackInStockSubscriptionPageEvent Methods

The TriggerBackInStockSubscriptionPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerBackInStockSubscriptionPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


TriggerBackInStockSubscriptionPageEvent.GetPageEventData Method

TriggerBackInStockSubscriptionPageEventGetPageEventData Method
Gets the page event data.

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetPageEventData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventData (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventData :
        args : ServicePipelineArgs -> string
override GetPageEventData :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
The page event data.
See Also

Reference

TriggerBackInStockSubscriptionPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


TriggerBackInStockSubscriptionPageEvent Properties

TriggerBackInStockSubscriptionPageEvent Properties

The TriggerBackInStockSubscriptionPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerBackInStockSubscriptionPageEvent Class
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


VisitorSignUpForStockNotification Class

VisitorSignUpForStockNotification Class
Defines the pipeline processor which adds the visitor to the EA plan back in stock notification.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotificationVisitorSignUpForStockNotification

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class VisitorSignUpForStockNotification : PipelineProcessor<ServicePipelineArgs>
Public Class VisitorSignUpForStockNotification
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class VisitorSignUpForStockNotification : public PipelineProcessor<ServicePipelineArgs^>
type VisitorSignUpForStockNotification =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The VisitorSignUpForStockNotification type exposes the following members.

Constructors
 | Name | Description
Public method | VisitorSignUpForStockNotification | Initializes an instance of the AddVisitorToEaPlan class.
Top
Methods
 | Name | Description
Protected method | AddVisitorToPlan | Adds a visitor to the initial state of an engagement plan.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | ToStockNotificationRequest | Converts a VisitorSignUpForStockNotificationRequest into a StockNotificationRequest.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateVisitorStateData | Updates the existing engagemtnt plan state for a a visitor.
Top
Properties
 | Name | Description
Protected property | AutomationProvider | Gets the inventory automation provider.
Public property | EngagementPlanName | Gets or sets the engagement plan name.
Public property | InitialStateName | Gets or sets the engagement plan's initial state name.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


VisitorSignUpForStockNotification Constructor

VisitorSignUpForStockNotification Constructor
Initializes an instance of the AddVisitorToEaPlan class.

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public VisitorSignUpForStockNotification(
    IEaPlanProvider eaPlanProvider
)
Public Sub New (
    eaPlanProvider As IEaPlanProvider
)
public:
VisitorSignUpForStockNotification(
    IEaPlanProvider^ eaPlanProvider
)
new :
        eaPlanProvider : IEaPlanProvider -> VisitorSignUpForStockNotification

Parameters

eaPlanProvider
Type: Sitecore.Commerce.MultishopIEaPlanProvider
The Engagement Automation Plan provider.
See Also

Reference

VisitorSignUpForStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


VisitorSignUpForStockNotification Methods

VisitorSignUpForStockNotification Methods

The VisitorSignUpForStockNotification type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisitorToPlan | Adds a visitor to the initial state of an engagement plan.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | ToStockNotificationRequest | Converts a VisitorSignUpForStockNotificationRequest into a StockNotificationRequest.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateVisitorStateData | Updates the existing engagemtnt plan state for a a visitor.
Top
See Also

Reference

VisitorSignUpForStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


VisitorSignUpForStockNotification.AddVisitorToPlan Method

VisitorSignUpForStockNotificationAddVisitorToPlan Method
Adds a visitor to the initial state of an engagement plan.

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void AddVisitorToPlan(
    string visitorId,
    ID initialStateId,
    VisitorSignUpForStockNotificationRequest request
)
Protected Overridable Sub AddVisitorToPlan (
    visitorId As String,
    initialStateId As ID,
    request As VisitorSignUpForStockNotificationRequest
)
protected:
virtual void AddVisitorToPlan(
    String^ visitorId,
    ID^ initialStateId,
    VisitorSignUpForStockNotificationRequest^ request
)
abstract AddVisitorToPlan :
        visitorId : string *
        initialStateId : ID *
        request : VisitorSignUpForStockNotificationRequest -> unit
override AddVisitorToPlan :
        visitorId : string *
        initialStateId : ID *
        request : VisitorSignUpForStockNotificationRequest -> unit

Parameters

visitorId
Type: SystemString
The visitor ID.
initialStateId
Type: ID
The ID of the engagemeent plan initial state.
request
Type: Sitecore.Commerce.Services.InventoryVisitorSignUpForStockNotificationRequest
The request that specifies the product for which the visitor is requesting back-in-stock notification.
See Also

Reference

VisitorSignUpForStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


VisitorSignUpForStockNotification.Process Method

VisitorSignUpForStockNotificationProcess Method
Runs the pipeline processor.

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

VisitorSignUpForStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


VisitorSignUpForStockNotification.ToStockNotificationRequest Method

VisitorSignUpForStockNotificationToStockNotificationRequest Method
Converts a VisitorSignUpForStockNotificationRequest into a StockNotificationRequest.

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual StockNotificationRequest ToStockNotificationRequest(
    VisitorSignUpForStockNotificationRequest request
)
Protected Overridable Function ToStockNotificationRequest (
    request As VisitorSignUpForStockNotificationRequest
) As StockNotificationRequest
protected:
virtual StockNotificationRequest^ ToStockNotificationRequest(
    VisitorSignUpForStockNotificationRequest^ request
)
abstract ToStockNotificationRequest :
        request : VisitorSignUpForStockNotificationRequest -> StockNotificationRequest
override ToStockNotificationRequest :
        request : VisitorSignUpForStockNotificationRequest -> StockNotificationRequest

Parameters

request
Type: Sitecore.Commerce.Services.InventoryVisitorSignUpForStockNotificationRequest
The VisitorSignUpForStockNotificationRequest to convert.

Return Value

Type: StockNotificationRequest
The converted StockNotificationRequest.
See Also

Reference

VisitorSignUpForStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


VisitorSignUpForStockNotification.UpdateVisitorStateData Method

VisitorSignUpForStockNotificationUpdateVisitorStateData Method
Updates the existing engagemtnt plan state for a a visitor.

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void UpdateVisitorStateData(
    string visitorId,
    ID stateId,
    VisitorSignUpForStockNotificationRequest request
)
Protected Overridable Sub UpdateVisitorStateData (
    visitorId As String,
    stateId As ID,
    request As VisitorSignUpForStockNotificationRequest
)
protected:
virtual void UpdateVisitorStateData(
    String^ visitorId,
    ID^ stateId,
    VisitorSignUpForStockNotificationRequest^ request
)
abstract UpdateVisitorStateData :
        visitorId : string *
        stateId : ID *
        request : VisitorSignUpForStockNotificationRequest -> unit
override UpdateVisitorStateData :
        visitorId : string *
        stateId : ID *
        request : VisitorSignUpForStockNotificationRequest -> unit

Parameters

visitorId
Type: SystemString
The visitor ID.
stateId
Type: ID
The ID of the engagement plan state to update.
request
Type: Sitecore.Commerce.Services.InventoryVisitorSignUpForStockNotificationRequest
The request that specifies the product for which the visitor is requesting back-in-stock notification.
See Also

Reference

VisitorSignUpForStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


VisitorSignUpForStockNotification Properties

VisitorSignUpForStockNotification Properties

The VisitorSignUpForStockNotification type exposes the following members.

Properties
 | Name | Description
Protected property | AutomationProvider | Gets the inventory automation provider.
Public property | EngagementPlanName | Gets or sets the engagement plan name.
Public property | InitialStateName | Gets or sets the engagement plan's initial state name.
Top
See Also

Reference

VisitorSignUpForStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


VisitorSignUpForStockNotification.AutomationProvider Property

VisitorSignUpForStockNotificationAutomationProvider Property
Gets the inventory automation provider.

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected InventoryAutomationProvider AutomationProvider { get; }
Protected ReadOnly Property AutomationProvider As InventoryAutomationProvider
    Get
protected:
property InventoryAutomationProvider^ AutomationProvider {
    InventoryAutomationProvider^ get ();
}
member AutomationProvider : InventoryAutomationProvider with get

Property Value

Type: InventoryAutomationProvider
See Also

Reference

VisitorSignUpForStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


VisitorSignUpForStockNotification.EngagementPlanName Property

VisitorSignUpForStockNotificationEngagementPlanName Property
Gets or sets the engagement plan name.

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string EngagementPlanName { get; set; }
Public Property EngagementPlanName As String
    Get
    Set
public:
property String^ EngagementPlanName {
    String^ get ();
    void set (String^ value);
}
member EngagementPlanName : string with get, set

Property Value

Type: String
The engagement plan name.
See Also

Reference

VisitorSignUpForStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


VisitorSignUpForStockNotification.InitialStateName Property

VisitorSignUpForStockNotificationInitialStateName Property
Gets or sets the engagement plan's initial state name.

Namespace: Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string InitialStateName { get; set; }
Public Property InitialStateName As String
    Get
    Set
public:
property String^ InitialStateName {
    String^ get ();
    void set (String^ value);
}
member InitialStateName : string with get, set

Property Value

Type: String
The engagement plan's initial state name.
See Also

Reference

VisitorSignUpForStockNotification Class
Sitecore.Commerce.Pipelines.Inventory.VisitorSignUpForStockNotification Namespace


Sitecore.Commerce.Pipelines.Orders.Common Namespace

Sitecore.Commerce.Pipelines.Orders.Common Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Orders.Common"]

Classes
 | Class | Description
Public class | AddOrderToEAPlan | Defines the AddOrderToEAPlan class.
Public class | TriggerOrderGoal | Defines the TriggerOrderGoal class.
Public class | TriggerOrderPageEvent | Defines the TriggerOrderPageEvent class.


AddOrderToEAPlan Class

AddOrderToEAPlan Class
Defines the AddOrderToEAPlan class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Orders.CommonAddOrderToEAPlan

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddOrderToEAPlan : PipelineProcessor<ServicePipelineArgs>
Public Class AddOrderToEAPlan
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class AddOrderToEAPlan : public PipelineProcessor<ServicePipelineArgs^>
type AddOrderToEAPlan =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The AddOrderToEAPlan type exposes the following members.

Constructors
 | Name | Description
Public method | AddOrderToEAPlan | Initializes a new instance of the AddOrderToEAPlan class.
Top
Methods
 | Name | Description
Protected method | AddVisitorToPlan | Adds the visitor to plan.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutomationStatesRow | Gets the automation states row.
Protected method | GetDataToSerialize | Gets the data to serialize.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | SetDataToStore | Sets the data to store.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateVisitorStateData | Updates the visitor state data.
Top
Properties
 | Name | Description
Public property | EngagementPlanName | Gets or sets the engagement plan name.
Public property | EntityFactory | Gets or sets the entity factory.
Public property | InitialStateName | Gets or sets the engagement plan's initial state name.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Orders.Common Namespace


AddOrderToEAPlan Constructor

AddOrderToEAPlan Constructor
Initializes a new instance of the AddOrderToEAPlan class.

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddOrderToEAPlan(
    IEaPlanProvider eaPlanProvider,
    IEntityFactory entityFactory
)
Public Sub New (
    eaPlanProvider As IEaPlanProvider,
    entityFactory As IEntityFactory
)
public:
AddOrderToEAPlan(
    IEaPlanProvider^ eaPlanProvider,
    IEntityFactory^ entityFactory
)
new :
        eaPlanProvider : IEaPlanProvider *
        entityFactory : IEntityFactory -> AddOrderToEAPlan

Parameters

eaPlanProvider
Type: Sitecore.Commerce.MultishopIEaPlanProvider
The ea plan provider.
entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
See Also

Reference

AddOrderToEAPlan Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


AddOrderToEAPlan Methods

AddOrderToEAPlan Methods

The AddOrderToEAPlan type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisitorToPlan | Adds the visitor to plan.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutomationStatesRow | Gets the automation states row.
Protected method | GetDataToSerialize | Gets the data to serialize.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | SetDataToStore | Sets the data to store.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateVisitorStateData | Updates the visitor state data.
Top
See Also

Reference

AddOrderToEAPlan Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


AddOrderToEAPlan.AddVisitorToPlan Method

AddOrderToEAPlanAddVisitorToPlan Method
Adds the visitor to plan.

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void AddVisitorToPlan(
    string visitorId,
    Order order,
    ID initialStateId
)
Protected Overridable Sub AddVisitorToPlan (
    visitorId As String,
    order As Order,
    initialStateId As ID
)
protected:
virtual void AddVisitorToPlan(
    String^ visitorId,
    Order^ order,
    ID^ initialStateId
)
abstract AddVisitorToPlan :
        visitorId : string *
        order : Order *
        initialStateId : ID -> unit
override AddVisitorToPlan :
        visitorId : string *
        order : Order *
        initialStateId : ID -> unit

Parameters

visitorId
Type: SystemString
The visitor identifier.
order
Type: Sitecore.Commerce.Entities.OrdersOrder
The order.
initialStateId
Type: ID
The initial state identifier.
See Also

Reference

AddOrderToEAPlan Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


AddOrderToEAPlan.GetAutomationStatesRow Method

AddOrderToEAPlanGetAutomationStatesRow Method
Gets the automation states row.

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual AutomationStatesRow GetAutomationStatesRow(
    string visitorId,
    ID stateId
)
Protected Overridable Function GetAutomationStatesRow (
    visitorId As String,
    stateId As ID
) As AutomationStatesRow
protected:
virtual AutomationStatesRow^ GetAutomationStatesRow(
    String^ visitorId,
    ID^ stateId
)
abstract GetAutomationStatesRow :
        visitorId : string *
        stateId : ID -> AutomationStatesRow
override GetAutomationStatesRow :
        visitorId : string *
        stateId : ID -> AutomationStatesRow

Parameters

visitorId
Type: SystemString
The visitor identifier.
stateId
Type: ID
The state identifier.

Return Value

Type: AutomationStatesRow

[Missing <returns> documentation for "M:Sitecore.Commerce.Pipelines.Orders.Common.AddOrderToEAPlan.GetAutomationStatesRow(System.String,Sitecore.Data.ID)"]

See Also

Reference

AddOrderToEAPlan Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


AddOrderToEAPlan.GetDataToSerialize Method

AddOrderToEAPlanGetDataToSerialize Method
Gets the data to serialize.

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual Order GetDataToSerialize(
    Order order
)
Protected Overridable Function GetDataToSerialize (
    order As Order
) As Order
protected:
virtual Order^ GetDataToSerialize(
    Order^ order
)
abstract GetDataToSerialize :
        order : Order -> Order
override GetDataToSerialize :
        order : Order -> Order

Parameters

order
Type: Sitecore.Commerce.Entities.OrdersOrder
The order.

Return Value

Type: Order
The order to serialize.
See Also

Reference

AddOrderToEAPlan Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


AddOrderToEAPlan.Process Method

AddOrderToEAPlanProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

AddOrderToEAPlan Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


AddOrderToEAPlan.SetDataToStore Method

AddOrderToEAPlanSetDataToStore Method
Sets the data to store.

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual string SetDataToStore(
    Object data,
    string dataColumnContent
)
Protected Overridable Function SetDataToStore (
    data As Object,
    dataColumnContent As String
) As String
protected:
virtual String^ SetDataToStore(
    Object^ data,
    String^ dataColumnContent
)
abstract SetDataToStore :
        data : Object *
        dataColumnContent : string -> string
override SetDataToStore :
        data : Object *
        dataColumnContent : string -> string

Parameters

data
Type: SystemObject
The data.
dataColumnContent
Type: SystemString
Content of the data column.

Return Value

Type: String

[Missing <returns> documentation for "M:Sitecore.Commerce.Pipelines.Orders.Common.AddOrderToEAPlan.SetDataToStore(System.Object,System.String)"]

See Also

Reference

AddOrderToEAPlan Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


AddOrderToEAPlan.UpdateVisitorStateData Method

AddOrderToEAPlanUpdateVisitorStateData Method
Updates the visitor state data.

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void UpdateVisitorStateData(
    string visitorId,
    ID stateId,
    Order order
)
Protected Overridable Sub UpdateVisitorStateData (
    visitorId As String,
    stateId As ID,
    order As Order
)
protected:
virtual void UpdateVisitorStateData(
    String^ visitorId,
    ID^ stateId,
    Order^ order
)
abstract UpdateVisitorStateData :
        visitorId : string *
        stateId : ID *
        order : Order -> unit
override UpdateVisitorStateData :
        visitorId : string *
        stateId : ID *
        order : Order -> unit

Parameters

visitorId
Type: SystemString
The visitor identifier.
stateId
Type: ID
The state identifier.
order
Type: Sitecore.Commerce.Entities.OrdersOrder
The order.
See Also

Reference

AddOrderToEAPlan Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


AddOrderToEAPlan Properties

AddOrderToEAPlan Properties

The AddOrderToEAPlan type exposes the following members.

Properties
 | Name | Description
Public property | EngagementPlanName | Gets or sets the engagement plan name.
Public property | EntityFactory | Gets or sets the entity factory.
Public property | InitialStateName | Gets or sets the engagement plan's initial state name.
Top
See Also

Reference

AddOrderToEAPlan Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


AddOrderToEAPlan.EngagementPlanName Property

AddOrderToEAPlanEngagementPlanName Property
Gets or sets the engagement plan name.

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string EngagementPlanName { get; set; }
Public Property EngagementPlanName As String
    Get
    Set
public:
property String^ EngagementPlanName {
    String^ get ();
    void set (String^ value);
}
member EngagementPlanName : string with get, set

Property Value

Type: String
The engagement plan name.
See Also

Reference

AddOrderToEAPlan Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


AddOrderToEAPlan.EntityFactory Property

AddOrderToEAPlanEntityFactory Property
Gets or sets the entity factory.

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEntityFactory EntityFactory { get; set; }
Public Property EntityFactory As IEntityFactory
    Get
    Set
public:
property IEntityFactory^ EntityFactory {
    IEntityFactory^ get ();
    void set (IEntityFactory^ value);
}
member EntityFactory : IEntityFactory with get, set

Property Value

Type: IEntityFactory
The entity factory.
See Also

Reference

AddOrderToEAPlan Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


AddOrderToEAPlan.InitialStateName Property

AddOrderToEAPlanInitialStateName Property
Gets or sets the engagement plan's initial state name.

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string InitialStateName { get; set; }
Public Property InitialStateName As String
    Get
    Set
public:
property String^ InitialStateName {
    String^ get ();
    void set (String^ value);
}
member InitialStateName : string with get, set

Property Value

Type: String
The engagement plan's initial state name.
See Also

Reference

AddOrderToEAPlan Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


TriggerOrderGoal Class

TriggerOrderGoal Class
Defines the TriggerOrderGoal class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Orders.CommonTriggerOrderPageEvent
Sitecore.Commerce.Pipelines.Orders.CommonTriggerOrderGoal

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerOrderGoal : TriggerOrderPageEvent
Public Class TriggerOrderGoal
    Inherits TriggerOrderPageEvent
public ref class TriggerOrderGoal : public TriggerOrderPageEvent
type TriggerOrderGoal =
    class
        inherit TriggerOrderPageEvent
    end

The TriggerOrderGoal type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerOrderGoal | Initializes a new instance of the TriggerOrderGoal class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOrderFromResult | Gets the order from result.
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerOrderPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Orders.Common Namespace


TriggerOrderGoal Constructor

TriggerOrderGoal Constructor
Initializes a new instance of the TriggerOrderGoal class

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerOrderGoal()
Public Sub New
public:
TriggerOrderGoal()
new : unit -> TriggerOrderGoal
See Also

Reference

TriggerOrderGoal Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


TriggerOrderGoal Methods

TriggerOrderGoal Methods

The TriggerOrderGoal type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOrderFromResult | Gets the order from result.
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerOrderPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerOrderGoal Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


TriggerOrderGoal.GetOrderFromResult Method

TriggerOrderGoalGetOrderFromResult Method
Gets the order from result.

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual Order GetOrderFromResult(
    OrdersResult result
)
Protected Overridable Function GetOrderFromResult (
    result As OrdersResult
) As Order
protected:
virtual Order^ GetOrderFromResult(
    OrdersResult^ result
)
abstract GetOrderFromResult :
        result : OrdersResult -> Order
override GetOrderFromResult :
        result : OrdersResult -> Order

Parameters

result
Type: Sitecore.Commerce.Services.OrdersOrdersResult
The result.

Return Value

Type: Order
The Order instance from the result object.
See Also

Reference

TriggerOrderGoal Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


TriggerOrderGoal.GetPageEventData Method

TriggerOrderGoalGetPageEventData Method
Gets the page event data.

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetPageEventData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventData (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventData :
        args : ServicePipelineArgs -> string
override GetPageEventData :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
The page event data.
See Also

Reference

TriggerOrderGoal Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


TriggerOrderGoal Properties

TriggerOrderGoal Properties

The TriggerOrderGoal type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerOrderGoal Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


TriggerOrderPageEvent Class

TriggerOrderPageEvent Class
Defines the TriggerOrderPageEvent class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Orders.CommonTriggerOrderPageEvent
Sitecore.Commerce.Pipelines.Orders.CommonTriggerOrderGoal
Sitecore.Commerce.Pipelines.Orders.GetVisitorOrderTriggerVisitorViewedOrderDetailsPageEvent
Sitecore.Commerce.Pipelines.Orders.GetVisitorOrdersTriggerVisitorViewedOrderHistoryPageEvent
Sitecore.Commerce.Pipelines.Orders.VisitorCancelOrderTriggerVisitorCancelOrderPageEvent

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerOrderPageEvent : TriggerPageEvent
Public Class TriggerOrderPageEvent
    Inherits TriggerPageEvent
public ref class TriggerOrderPageEvent : public TriggerPageEvent
type TriggerOrderPageEvent =
    class
        inherit TriggerPageEvent
    end

The TriggerOrderPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerOrderPageEvent | Initializes a new instance of the TriggerOrderPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Inherited from TriggerPageEvent.)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Overrides TriggerPageEventProcess(ServicePipelineArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Orders.Common Namespace


TriggerOrderPageEvent Constructor

TriggerOrderPageEvent Constructor
Initializes a new instance of the TriggerOrderPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerOrderPageEvent()
Public Sub New
public:
TriggerOrderPageEvent()
new : unit -> TriggerOrderPageEvent
See Also

Reference

TriggerOrderPageEvent Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


TriggerOrderPageEvent Methods

TriggerOrderPageEvent Methods

The TriggerOrderPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Inherited from TriggerPageEvent.)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Overrides TriggerPageEventProcess(ServicePipelineArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerOrderPageEvent Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


TriggerOrderPageEvent.Process Method

TriggerOrderPageEventProcess Method
Executes the business logic of the TriggerPageEevent processor.

Namespace: Sitecore.Commerce.Pipelines.Orders.Common
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

TriggerOrderPageEvent Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


TriggerOrderPageEvent Properties

TriggerOrderPageEvent Properties

The TriggerOrderPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerOrderPageEvent Class
Sitecore.Commerce.Pipelines.Orders.Common Namespace


Sitecore.Commerce.Pipelines.Orders.GetVisitorOrder Namespace

Sitecore.Commerce.Pipelines.Orders.GetVisitorOrder Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Orders.GetVisitorOrder"]

Classes
 | Class | Description
Public class | TriggerVisitorViewedOrderDetailsPageEvent | Defines the TriggerVisitorViewedOrderDetailsPageEvent class.


TriggerVisitorViewedOrderDetailsPageEvent Class

TriggerVisitorViewedOrderDetailsPageEvent Class
Defines the TriggerVisitorViewedOrderDetailsPageEvent class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Orders.CommonTriggerOrderPageEvent
Sitecore.Commerce.Pipelines.Orders.GetVisitorOrderTriggerVisitorViewedOrderDetailsPageEvent

Namespace: Sitecore.Commerce.Pipelines.Orders.GetVisitorOrder
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerVisitorViewedOrderDetailsPageEvent : TriggerOrderPageEvent
Public Class TriggerVisitorViewedOrderDetailsPageEvent
    Inherits TriggerOrderPageEvent
public ref class TriggerVisitorViewedOrderDetailsPageEvent : public TriggerOrderPageEvent
type TriggerVisitorViewedOrderDetailsPageEvent =
    class
        inherit TriggerOrderPageEvent
    end

The TriggerVisitorViewedOrderDetailsPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerVisitorViewedOrderDetailsPageEvent | Initializes a new instance of the TriggerVisitorViewedOrderDetailsPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerOrderPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Orders.GetVisitorOrder Namespace


TriggerVisitorViewedOrderDetailsPageEvent Constructor

TriggerVisitorViewedOrderDetailsPageEvent Constructor
Initializes a new instance of the TriggerVisitorViewedOrderDetailsPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Orders.GetVisitorOrder
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerVisitorViewedOrderDetailsPageEvent()
Public Sub New
public:
TriggerVisitorViewedOrderDetailsPageEvent()
new : unit -> TriggerVisitorViewedOrderDetailsPageEvent
See Also

Reference

TriggerVisitorViewedOrderDetailsPageEvent Class
Sitecore.Commerce.Pipelines.Orders.GetVisitorOrder Namespace


TriggerVisitorViewedOrderDetailsPageEvent Methods

TriggerVisitorViewedOrderDetailsPageEvent Methods

The TriggerVisitorViewedOrderDetailsPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerOrderPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerVisitorViewedOrderDetailsPageEvent Class
Sitecore.Commerce.Pipelines.Orders.GetVisitorOrder Namespace


TriggerVisitorViewedOrderDetailsPageEvent.GetPageEventData Method

TriggerVisitorViewedOrderDetailsPageEventGetPageEventData Method
Gets the page event data.

Namespace: Sitecore.Commerce.Pipelines.Orders.GetVisitorOrder
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetPageEventData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventData (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventData :
        args : ServicePipelineArgs -> string
override GetPageEventData :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
The page event data.
See Also

Reference

TriggerVisitorViewedOrderDetailsPageEvent Class
Sitecore.Commerce.Pipelines.Orders.GetVisitorOrder Namespace


TriggerVisitorViewedOrderDetailsPageEvent Properties

TriggerVisitorViewedOrderDetailsPageEvent Properties

The TriggerVisitorViewedOrderDetailsPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerVisitorViewedOrderDetailsPageEvent Class
Sitecore.Commerce.Pipelines.Orders.GetVisitorOrder Namespace


Sitecore.Commerce.Pipelines.Orders.GetVisitorOrders Namespace

Sitecore.Commerce.Pipelines.Orders.GetVisitorOrders Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Orders.GetVisitorOrders"]

Classes
 | Class | Description
Public class | TriggerVisitorViewedOrderHistoryPageEvent | Defines the TriggerVisitorViewedOrderHistoryPageEvent class.


TriggerVisitorViewedOrderHistoryPageEvent Class

TriggerVisitorViewedOrderHistoryPageEvent Class
Defines the TriggerVisitorViewedOrderHistoryPageEvent class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Orders.CommonTriggerOrderPageEvent
Sitecore.Commerce.Pipelines.Orders.GetVisitorOrdersTriggerVisitorViewedOrderHistoryPageEvent

Namespace: Sitecore.Commerce.Pipelines.Orders.GetVisitorOrders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerVisitorViewedOrderHistoryPageEvent : TriggerOrderPageEvent
Public Class TriggerVisitorViewedOrderHistoryPageEvent
    Inherits TriggerOrderPageEvent
public ref class TriggerVisitorViewedOrderHistoryPageEvent : public TriggerOrderPageEvent
type TriggerVisitorViewedOrderHistoryPageEvent =
    class
        inherit TriggerOrderPageEvent
    end

The TriggerVisitorViewedOrderHistoryPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerVisitorViewedOrderHistoryPageEvent | Initializes a new instance of the TriggerVisitorViewedOrderHistoryPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerOrderPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Orders.GetVisitorOrders Namespace


TriggerVisitorViewedOrderHistoryPageEvent Constructor

TriggerVisitorViewedOrderHistoryPageEvent Constructor
Initializes a new instance of the TriggerVisitorViewedOrderHistoryPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Orders.GetVisitorOrders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerVisitorViewedOrderHistoryPageEvent()
Public Sub New
public:
TriggerVisitorViewedOrderHistoryPageEvent()
new : unit -> TriggerVisitorViewedOrderHistoryPageEvent
See Also

Reference

TriggerVisitorViewedOrderHistoryPageEvent Class
Sitecore.Commerce.Pipelines.Orders.GetVisitorOrders Namespace


TriggerVisitorViewedOrderHistoryPageEvent Methods

TriggerVisitorViewedOrderHistoryPageEvent Methods

The TriggerVisitorViewedOrderHistoryPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerOrderPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerVisitorViewedOrderHistoryPageEvent Class
Sitecore.Commerce.Pipelines.Orders.GetVisitorOrders Namespace


TriggerVisitorViewedOrderHistoryPageEvent.GetPageEventData Method

TriggerVisitorViewedOrderHistoryPageEventGetPageEventData Method
Gets the page event data.

Namespace: Sitecore.Commerce.Pipelines.Orders.GetVisitorOrders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetPageEventData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventData (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventData :
        args : ServicePipelineArgs -> string
override GetPageEventData :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
The page event data.
See Also

Reference

TriggerVisitorViewedOrderHistoryPageEvent Class
Sitecore.Commerce.Pipelines.Orders.GetVisitorOrders Namespace


TriggerVisitorViewedOrderHistoryPageEvent Properties

TriggerVisitorViewedOrderHistoryPageEvent Properties

The TriggerVisitorViewedOrderHistoryPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerVisitorViewedOrderHistoryPageEvent Class
Sitecore.Commerce.Pipelines.Orders.GetVisitorOrders Namespace


Sitecore.Commerce.Pipelines.Orders.VisitorCancelOrder Namespace

Sitecore.Commerce.Pipelines.Orders.VisitorCancelOrder Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Orders.VisitorCancelOrder"]

Classes
 | Class | Description
Public class | TriggerVisitorCancelOrderPageEvent | Defines the TriggerVisitorCancelOrderPageEvent class.


TriggerVisitorCancelOrderPageEvent Class

TriggerVisitorCancelOrderPageEvent Class
Defines the TriggerVisitorCancelOrderPageEvent class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.CommonTriggerPageEvent
Sitecore.Commerce.Pipelines.Orders.CommonTriggerOrderPageEvent
Sitecore.Commerce.Pipelines.Orders.VisitorCancelOrderTriggerVisitorCancelOrderPageEvent

Namespace: Sitecore.Commerce.Pipelines.Orders.VisitorCancelOrder
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TriggerVisitorCancelOrderPageEvent : TriggerOrderPageEvent
Public Class TriggerVisitorCancelOrderPageEvent
    Inherits TriggerOrderPageEvent
public ref class TriggerVisitorCancelOrderPageEvent : public TriggerOrderPageEvent
type TriggerVisitorCancelOrderPageEvent =
    class
        inherit TriggerOrderPageEvent
    end

The TriggerVisitorCancelOrderPageEvent type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerVisitorCancelOrderPageEvent | Initializes a new instance of the TriggerVisitorCancelOrderPageEvent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerOrderPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Orders.VisitorCancelOrder Namespace


TriggerVisitorCancelOrderPageEvent Constructor

TriggerVisitorCancelOrderPageEvent Constructor
Initializes a new instance of the TriggerVisitorCancelOrderPageEvent class

Namespace: Sitecore.Commerce.Pipelines.Orders.VisitorCancelOrder
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TriggerVisitorCancelOrderPageEvent()
Public Sub New
public:
TriggerVisitorCancelOrderPageEvent()
new : unit -> TriggerVisitorCancelOrderPageEvent
See Also

Reference

TriggerVisitorCancelOrderPageEvent Class
Sitecore.Commerce.Pipelines.Orders.VisitorCancelOrder Namespace


TriggerVisitorCancelOrderPageEvent Methods

TriggerVisitorCancelOrderPageEvent Methods

The TriggerVisitorCancelOrderPageEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPageEventData | Gets the page event data. (Overrides TriggerPageEventGetPageEventData(ServicePipelineArgs).)
Protected method | GetPageEventText | Gets the page event text. (Inherited from TriggerPageEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the TriggerPageEevent processor. (Inherited from TriggerOrderPageEvent.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerVisitorCancelOrderPageEvent Class
Sitecore.Commerce.Pipelines.Orders.VisitorCancelOrder Namespace


TriggerVisitorCancelOrderPageEvent.GetPageEventData Method

TriggerVisitorCancelOrderPageEventGetPageEventData Method
Gets the page event data.

Namespace: Sitecore.Commerce.Pipelines.Orders.VisitorCancelOrder
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetPageEventData(
    ServicePipelineArgs args
)
Protected Overrides Function GetPageEventData (
    args As ServicePipelineArgs
) As String
protected:
virtual String^ GetPageEventData(
    ServicePipelineArgs^ args
) override
abstract GetPageEventData :
        args : ServicePipelineArgs -> string
override GetPageEventData :
        args : ServicePipelineArgs -> string

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: String
The page event data.
See Also

Reference

TriggerVisitorCancelOrderPageEvent Class
Sitecore.Commerce.Pipelines.Orders.VisitorCancelOrder Namespace


TriggerVisitorCancelOrderPageEvent Properties

TriggerVisitorCancelOrderPageEvent Properties

The TriggerVisitorCancelOrderPageEvent type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the page event to trigger. (Inherited from TriggerPageEvent.)
Public property | Text | Gets or sets the page event text. (Inherited from TriggerPageEvent.)
Top
See Also

Reference

TriggerVisitorCancelOrderPageEvent Class
Sitecore.Commerce.Pipelines.Orders.VisitorCancelOrder Namespace


Sitecore.Commerce.Pipelines.Prices.GetCartTotal Namespace

Sitecore.Commerce.Pipelines.Prices.GetCartTotal Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Prices.GetCartTotal"]

Classes
 | Class | Description
Public class | GetCartTotal | Gets total price for the cart.


GetCartTotal Class

GetCartTotal Class
Gets total price for the cart.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Prices.GetCartTotalGetCartTotal

Namespace: Sitecore.Commerce.Pipelines.Prices.GetCartTotal
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetCartTotal : PipelineProcessor<ServicePipelineArgs>
Public Class GetCartTotal
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class GetCartTotal : public PipelineProcessor<ServicePipelineArgs^>
type GetCartTotal =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The GetCartTotal type exposes the following members.

Constructors
 | Name | Description
Public method | GetCartTotal | Initializes a new instance of the GetCartTotal class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Prices.GetCartTotal Namespace


GetCartTotal Constructor

GetCartTotal Constructor
Initializes a new instance of the GetCartTotal class

Namespace: Sitecore.Commerce.Pipelines.Prices.GetCartTotal
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetCartTotal()
Public Sub New
public:
GetCartTotal()
new : unit -> GetCartTotal
See Also

Reference

GetCartTotal Class
Sitecore.Commerce.Pipelines.Prices.GetCartTotal Namespace


GetCartTotal Methods

GetCartTotal Methods

The GetCartTotal type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetCartTotal Class
Sitecore.Commerce.Pipelines.Prices.GetCartTotal Namespace


GetCartTotal.Process Method

GetCartTotalProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Prices.GetCartTotal
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

GetCartTotal Class
Sitecore.Commerce.Pipelines.Prices.GetCartTotal Namespace


Sitecore.Commerce.Pipelines.Prices.GetProductBulkPrices Namespace

Sitecore.Commerce.Pipelines.Prices.GetProductBulkPrices Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Prices.GetProductBulkPrices"]

Classes
 | Class | Description
Public class | GetProductBulkPrices | Gets product bulk prices.


GetProductBulkPrices Class

GetProductBulkPrices Class
Gets product bulk prices.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Prices.GetProductBulkPricesGetProductBulkPrices

Namespace: Sitecore.Commerce.Pipelines.Prices.GetProductBulkPrices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetProductBulkPrices : PipelineProcessor<ServicePipelineArgs>
Public Class GetProductBulkPrices
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class GetProductBulkPrices : public PipelineProcessor<ServicePipelineArgs^>
type GetProductBulkPrices =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The GetProductBulkPrices type exposes the following members.

Constructors
 | Name | Description
Public method | GetProductBulkPrices | Initializes a new instance of the GetProductBulkPrices class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Prices.GetProductBulkPrices Namespace


GetProductBulkPrices Constructor

GetProductBulkPrices Constructor
Initializes a new instance of the GetProductBulkPrices class

Namespace: Sitecore.Commerce.Pipelines.Prices.GetProductBulkPrices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetProductBulkPrices()
Public Sub New
public:
GetProductBulkPrices()
new : unit -> GetProductBulkPrices
See Also

Reference

GetProductBulkPrices Class
Sitecore.Commerce.Pipelines.Prices.GetProductBulkPrices Namespace


GetProductBulkPrices Methods

GetProductBulkPrices Methods

The GetProductBulkPrices type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetProductBulkPrices Class
Sitecore.Commerce.Pipelines.Prices.GetProductBulkPrices Namespace


GetProductBulkPrices.Process Method

GetProductBulkPricesProcess Method
Runs the pipeline processor.

Namespace: Sitecore.Commerce.Pipelines.Prices.GetProductBulkPrices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

GetProductBulkPrices Class
Sitecore.Commerce.Pipelines.Prices.GetProductBulkPrices Namespace


Sitecore.Commerce.Pipelines.Prices.GetProductPrices Namespace

Sitecore.Commerce.Pipelines.Prices.GetProductPrices Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Prices.GetProductPrices"]

Classes
 | Class | Description
Public class | GetProductPrices | Gets product prices.


GetProductPrices Class

GetProductPrices Class
Gets product prices.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Prices.GetProductPricesGetProductPrices

Namespace: Sitecore.Commerce.Pipelines.Prices.GetProductPrices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetProductPrices : PipelineProcessor<ServicePipelineArgs>
Public Class GetProductPrices
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class GetProductPrices : public PipelineProcessor<ServicePipelineArgs^>
type GetProductPrices =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The GetProductPrices type exposes the following members.

Constructors
 | Name | Description
Public method | GetProductPrices | Initializes a new instance of the GetProductPrices class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Prices.GetProductPrices Namespace


GetProductPrices Constructor

GetProductPrices Constructor
Initializes a new instance of the GetProductPrices class

Namespace: Sitecore.Commerce.Pipelines.Prices.GetProductPrices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetProductPrices()
Public Sub New
public:
GetProductPrices()
new : unit -> GetProductPrices
See Also

Reference

GetProductPrices Class
Sitecore.Commerce.Pipelines.Prices.GetProductPrices Namespace


GetProductPrices Methods

GetProductPrices Methods

The GetProductPrices type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetProductPrices Class
Sitecore.Commerce.Pipelines.Prices.GetProductPrices Namespace


GetProductPrices.Process Method

GetProductPricesProcess Method
Runs the pipeline processor.

Namespace: Sitecore.Commerce.Pipelines.Prices.GetProductPrices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

GetProductPrices Class
Sitecore.Commerce.Pipelines.Prices.GetProductPrices Namespace


Sitecore.Commerce.Pipelines.Products Namespace

Sitecore.Commerce.Pipelines.Products Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products"]

Classes
 | Class | Description
Public class | IEnumerableExtensions | The IEnumerable extensions.
Public class | ResolveChangesProcessor | The base class for all processors that resolve changes.
Public class | SaveToSitecoreProcessor | Defines the parent class of the classes that defines the processors that save entities in Sitecore.
Public class | StatusUpdater | The status updater.


IEnumerableExtensions Class

IEnumerableExtensions Class
The IEnumerable extensions.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Pipelines.ProductsIEnumerableExtensions

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class IEnumerableExtensions
<ExtensionAttribute>
Public NotInheritable Class IEnumerableExtensions
[ExtensionAttribute]
public ref class IEnumerableExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IEnumerableExtensions =  class end

The IEnumerableExtensions type exposes the following members.

Methods
Name | Description
ParallelForEachTSource | Parallels for each loop with maximum number of threads that is specified in NumberOfThreads setting of Sitecore.Commerce.Products config file.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products Namespace


IEnumerableExtensions Methods

IEnumerableExtensions Methods

The IEnumerableExtensions type exposes the following members.

Methods
Name | Description
ParallelForEachTSource | Parallels for each loop with maximum number of threads that is specified in NumberOfThreads setting of Sitecore.Commerce.Products config file.
Top
See Also

Reference

IEnumerableExtensions Class
Sitecore.Commerce.Pipelines.Products Namespace


IEnumerableExtensions.ParallelForEach(TSource) Method

IEnumerableExtensionsParallelForEachTSource Method
Parallels for each loop with maximum number of threads that is specified in NumberOfThreads setting of Sitecore.Commerce.Products config file.

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static void ParallelForEach<TSource>(
    this IEnumerable<TSource> source,
    Action<TSource> body
)

<ExtensionAttribute>
Public Shared Sub ParallelForEach(Of TSource) (
    source As IEnumerable(Of TSource),
    body As Action(Of TSource)
)
public:
[ExtensionAttribute]
generic<typename TSource>
static void ParallelForEach(
    IEnumerable<TSource>^ source,
    Action<TSource>^ body
)
static member ParallelForEach :
        source : IEnumerable<'TSource> *
        body : Action<'TSource> -> unit

Parameters

source
Type: System.Collections.GenericIEnumerable TSource
The source.
body
Type: SystemAction TSource
The body.

Type Parameters

TSource
The type of the source.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IEnumerableExtensions Class
Sitecore.Commerce.Pipelines.Products Namespace


ResolveChangesProcessor Class

ResolveChangesProcessor Class
The base class for all processors that resolve changes.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsResolveChangesProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsResolveClassificationsChanges
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisionsResolveDivisionsChanges
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturersResolveManufacturersChanges
Sitecore.Commerce.Pipelines.Products.SynchronizeTypesResolveTypesChanges

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class ResolveChangesProcessor : PipelineProcessor<ServicePipelineArgs>
Public MustInherit Class ResolveChangesProcessor
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ResolveChangesProcessor abstract : public PipelineProcessor<ServicePipelineArgs^>
[<AbstractClassAttribute>]
type ResolveChangesProcessor =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ResolveChangesProcessor type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveChangesProcessor | Initializes a new instance of the ResolveChangesProcessor class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetExternalCommerceSystemEntities | Gets entities stored in external commerce system.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSitecoreEntities | Gets entities stored in Sitecore.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | SaveEntities | Saves entities in pipeline arguments.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products Namespace


ResolveChangesProcessor Constructor

ResolveChangesProcessor Constructor
Initializes a new instance of the ResolveChangesProcessor class.

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ResolveChangesProcessor(
    ISynchronizationStrategy synchronizationStrategy
)
Public Sub New (
    synchronizationStrategy As ISynchronizationStrategy
)
public:
ResolveChangesProcessor(
    ISynchronizationStrategy^ synchronizationStrategy
)
new :
        synchronizationStrategy : ISynchronizationStrategy -> ResolveChangesProcessor

Parameters

synchronizationStrategy
Type: Sitecore.Commerce.ProductsISynchronizationStrategy
The synchronization strategy.
See Also

Reference

ResolveChangesProcessor Class
Sitecore.Commerce.Pipelines.Products Namespace


ResolveChangesProcessor Methods

ResolveChangesProcessor Methods

The ResolveChangesProcessor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetExternalCommerceSystemEntities | Gets entities stored in external commerce system.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSitecoreEntities | Gets entities stored in Sitecore.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | SaveEntities | Saves entities in pipeline arguments.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveChangesProcessor Class
Sitecore.Commerce.Pipelines.Products Namespace


ResolveChangesProcessor.GetExternalCommerceSystemEntities Method

ResolveChangesProcessorGetExternalCommerceSystemEntities Method
Gets entities stored in external commerce system.

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract IEnumerable<ProductEntity> GetExternalCommerceSystemEntities(
    ServicePipelineArgs args
)
Protected MustOverride Function GetExternalCommerceSystemEntities (
    args As ServicePipelineArgs
) As IEnumerable(Of ProductEntity)
protected:
virtual IEnumerable<ProductEntity^>^ GetExternalCommerceSystemEntities(
    ServicePipelineArgs^ args
) abstract
abstract GetExternalCommerceSystemEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: IEnumerable ProductEntity
External commerce system entities.
See Also

Reference

ResolveChangesProcessor Class
Sitecore.Commerce.Pipelines.Products Namespace


ResolveChangesProcessor.GetSitecoreEntities Method

ResolveChangesProcessorGetSitecoreEntities Method
Gets entities stored in Sitecore.

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract IEnumerable<ProductEntity> GetSitecoreEntities(
    ServicePipelineArgs args
)
Protected MustOverride Function GetSitecoreEntities (
    args As ServicePipelineArgs
) As IEnumerable(Of ProductEntity)
protected:
virtual IEnumerable<ProductEntity^>^ GetSitecoreEntities(
    ServicePipelineArgs^ args
) abstract
abstract GetSitecoreEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: IEnumerable ProductEntity
Sitecore entities.
See Also

Reference

ResolveChangesProcessor Class
Sitecore.Commerce.Pipelines.Products Namespace


ResolveChangesProcessor.Process Method

ResolveChangesProcessorProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ResolveChangesProcessor Class
Sitecore.Commerce.Pipelines.Products Namespace


ResolveChangesProcessor.SaveEntities Method

ResolveChangesProcessorSaveEntities Method
Saves entities in pipeline arguments.

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract void SaveEntities(
    ServicePipelineArgs args,
    IEnumerable<ProductEntity> productEntities
)
Protected MustOverride Sub SaveEntities (
    args As ServicePipelineArgs,
    productEntities As IEnumerable(Of ProductEntity)
)
protected:
virtual void SaveEntities(
    ServicePipelineArgs^ args,
    IEnumerable<ProductEntity^>^ productEntities
) abstract
abstract SaveEntities :
        args : ServicePipelineArgs *
        productEntities : IEnumerable<ProductEntity> -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
productEntities
Type: System.Collections.GenericIEnumerable ProductEntity
The product entities.
See Also

Reference

ResolveChangesProcessor Class
Sitecore.Commerce.Pipelines.Products Namespace


SaveToSitecoreProcessor Class

SaveToSitecoreProcessor Class
Defines the parent class of the classes that defines the processors that save entities in Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsSaveToSitecoreProcessor
More...

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class SaveToSitecoreProcessor : PipelineProcessor<ServicePipelineArgs>
Public MustInherit Class SaveToSitecoreProcessor
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveToSitecoreProcessor abstract : public PipelineProcessor<ServicePipelineArgs^>
[<AbstractClassAttribute>]
type SaveToSitecoreProcessor =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveToSitecoreProcessor type exposes the following members.

Constructors
 | Name | Description
Protected method | SaveToSitecoreProcessor | Initializes a new instance of the SaveToSitecoreProcessor class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Inherited from PipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status.
Protected method | UpdateStatus(String, String) | Updates the status.
Top
Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsSaveToSitecoreProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSaveAllClassifications
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecificationsSaveClassificationsSpecificationsToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisionsSaveDivisionsToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecificationsSaveGlobalSpecificationsToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturersSaveManufacturersToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntitySaveProductToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeResourcesSaveResourcesToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValuesSaveTypeDefaultValuesToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeTypesSaveTypesToSitecore
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecificationsSaveTypeSpecificationsToSitecore


SaveToSitecoreProcessor Constructor

SaveToSitecoreProcessor Constructor
Initializes a new instance of the SaveToSitecoreProcessor class

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected SaveToSitecoreProcessor()
Protected Sub New
protected:
SaveToSitecoreProcessor()
new : unit -> SaveToSitecoreProcessor
See Also

Reference

SaveToSitecoreProcessor Class
Sitecore.Commerce.Pipelines.Products Namespace


SaveToSitecoreProcessor Methods

SaveToSitecoreProcessor Methods

The SaveToSitecoreProcessor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the pipeline processor. (Inherited from PipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status.
Protected method | UpdateStatus(String, String) | Updates the status.
Top
See Also

Reference

SaveToSitecoreProcessor Class
Sitecore.Commerce.Pipelines.Products Namespace


SaveToSitecoreProcessor.UpdateStatus Method

SaveToSitecoreProcessorUpdateStatus Method
Overload List
 | Name | Description
Protected method | UpdateStatus(String) | Updates the status.
Protected method | UpdateStatus(String, String) | Updates the status.
Top
See Also

Reference

SaveToSitecoreProcessor Class
Sitecore.Commerce.Pipelines.Products Namespace


SaveToSitecoreProcessor.UpdateStatus Method (String)

SaveToSitecoreProcessorUpdateStatus Method (String)
Updates the status.

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void UpdateStatus(
    string message
)
Protected Overridable Sub UpdateStatus (
    message As String
)
protected:
virtual void UpdateStatus(
    String^ message
)
abstract UpdateStatus :
        message : string -> unit
override UpdateStatus :
        message : string -> unit

Parameters

message
Type: SystemString
The message.
See Also

Reference

SaveToSitecoreProcessor Class
UpdateStatus Overload
Sitecore.Commerce.Pipelines.Products Namespace


SaveToSitecoreProcessor.UpdateStatus Method (String, String)

SaveToSitecoreProcessorUpdateStatus Method (String, String)
Updates the status.

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void UpdateStatus(
    string message,
    string parameter
)
Protected Overridable Sub UpdateStatus (
    message As String,
    parameter As String
)
protected:
virtual void UpdateStatus(
    String^ message,
    String^ parameter
)
abstract UpdateStatus :
        message : string *
        parameter : string -> unit
override UpdateStatus :
        message : string *
        parameter : string -> unit

Parameters

message
Type: SystemString
The message.
parameter
Type: SystemString
The parameter.
See Also

Reference

SaveToSitecoreProcessor Class
UpdateStatus Overload
Sitecore.Commerce.Pipelines.Products Namespace


SaveToSitecoreProcessor Properties

SaveToSitecoreProcessor Properties

The SaveToSitecoreProcessor type exposes the following members.

Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater.
Top
See Also

Reference

SaveToSitecoreProcessor Class
Sitecore.Commerce.Pipelines.Products Namespace


SaveToSitecoreProcessor.StatusUpdater Property

SaveToSitecoreProcessorStatusUpdater Property
Gets or sets the status updater.

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StatusUpdater StatusUpdater { get; set; }
Public Property StatusUpdater As StatusUpdater
    Get
    Set
public:
property StatusUpdater^ StatusUpdater {
    StatusUpdater^ get ();
    void set (StatusUpdater^ value);
}
member StatusUpdater : StatusUpdater with get, set

Property Value

Type: StatusUpdater
The status updater.
See Also

Reference

SaveToSitecoreProcessor Class
Sitecore.Commerce.Pipelines.Products Namespace


StatusUpdater Class

StatusUpdater Class
The status updater.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Pipelines.ProductsStatusUpdater

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class StatusUpdater
Public Class StatusUpdater
public ref class StatusUpdater
type StatusUpdater =  class end

The StatusUpdater type exposes the following members.

Constructors
 | Name | Description
Public method | StatusUpdater | Initializes a new instance of the StatusUpdater class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the specified message.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products Namespace


StatusUpdater Constructor

StatusUpdater Constructor
Initializes a new instance of the StatusUpdater class

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StatusUpdater()
Public Sub New
public:
StatusUpdater()
new : unit -> StatusUpdater
See Also

Reference

StatusUpdater Class
Sitecore.Commerce.Pipelines.Products Namespace


StatusUpdater Methods

StatusUpdater Methods

The StatusUpdater type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the specified message.
Top
See Also

Reference

StatusUpdater Class
Sitecore.Commerce.Pipelines.Products Namespace


StatusUpdater.Update Method

StatusUpdaterUpdate Method
Updates the specified message.

Namespace: Sitecore.Commerce.Pipelines.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual void Update(
    string message
)
Public Overridable Sub Update (
    message As String
)
public:
virtual void Update(
    String^ message
)
abstract Update :
        message : string -> unit
override Update :
        message : string -> unit

Parameters

message
Type: SystemString
The message.
See Also

Reference

StatusUpdater Class
Sitecore.Commerce.Pipelines.Products Namespace


Sitecore.Commerce.Pipelines.Products.GetExternalCommerceSystemProductList Namespace

Sitecore.Commerce.Pipelines.Products.GetExternalCommerceSystemProductList Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.GetExternalCommerceSystemProductList"]

Classes
 | Class | Description
Public class | GetExternalCommerceSystemProductList | Defines the processor that gets the product list from the external commerce system.


GetExternalCommerceSystemProductList Class

GetExternalCommerceSystemProductList Class
Defines the processor that gets the product list from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.GetExternalCommerceSystemProductListGetExternalCommerceSystemProductList

Namespace: Sitecore.Commerce.Pipelines.Products.GetExternalCommerceSystemProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetExternalCommerceSystemProductList : PipelineProcessor<ServicePipelineArgs>
Public Class GetExternalCommerceSystemProductList
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class GetExternalCommerceSystemProductList : public PipelineProcessor<ServicePipelineArgs^>
type GetExternalCommerceSystemProductList =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The GetExternalCommerceSystemProductList type exposes the following members.

Constructors
 | Name | Description
Public method | GetExternalCommerceSystemProductList | Initializes a new instance of the GetExternalCommerceSystemProductList class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetExternalCommerceSystemProductList processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.GetExternalCommerceSystemProductList Namespace


GetExternalCommerceSystemProductList Constructor

GetExternalCommerceSystemProductList Constructor
Initializes a new instance of the GetExternalCommerceSystemProductList class

Namespace: Sitecore.Commerce.Pipelines.Products.GetExternalCommerceSystemProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetExternalCommerceSystemProductList()
Public Sub New
public:
GetExternalCommerceSystemProductList()
new : unit -> GetExternalCommerceSystemProductList
See Also

Reference

GetExternalCommerceSystemProductList Class
Sitecore.Commerce.Pipelines.Products.GetExternalCommerceSystemProductList Namespace


GetExternalCommerceSystemProductList Methods

GetExternalCommerceSystemProductList Methods

The GetExternalCommerceSystemProductList type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetExternalCommerceSystemProductList processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetExternalCommerceSystemProductList Class
Sitecore.Commerce.Pipelines.Products.GetExternalCommerceSystemProductList Namespace


GetExternalCommerceSystemProductList.Process Method

GetExternalCommerceSystemProductListProcess Method
Executes the business logic of the GetExternalCommerceSystemProductList processor.

Namespace: Sitecore.Commerce.Pipelines.Products.GetExternalCommerceSystemProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

GetExternalCommerceSystemProductList Class
Sitecore.Commerce.Pipelines.Products.GetExternalCommerceSystemProductList Namespace


Sitecore.Commerce.Pipelines.Products.GetSitecoreProductList Namespace

Sitecore.Commerce.Pipelines.Products.GetSitecoreProductList Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.GetSitecoreProductList"]

Classes
 | Class | Description
Public class | GetSitecoreProductList | Defines the processor that gets the product list from Sitecore. This processor stores the IDs of the products in the custom data. In the SynchronizeProducts pipeline, the EvaluateProductListUnionToSynchronize uses the Product IDs stored in the custom data.


GetSitecoreProductList Class

GetSitecoreProductList Class
Defines the processor that gets the product list from Sitecore. This processor stores the IDs of the products in the custom data. In the SynchronizeProducts pipeline, the EvaluateProductListUnionToSynchronize uses the Product IDs stored in the custom data.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.GetSitecoreProductListGetSitecoreProductList

Namespace: Sitecore.Commerce.Pipelines.Products.GetSitecoreProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetSitecoreProductList : PipelineProcessor<ServicePipelineArgs>
Public Class GetSitecoreProductList
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class GetSitecoreProductList : public PipelineProcessor<ServicePipelineArgs^>
type GetSitecoreProductList =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The GetSitecoreProductList type exposes the following members.

Constructors
 | Name | Description
Public method | GetSitecoreProductList | Initializes an instance of the GetSitecoreProductList class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetSitecoreProductList processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.GetSitecoreProductList Namespace


GetSitecoreProductList Constructor

GetSitecoreProductList Constructor
Initializes an instance of the GetSitecoreProductList class.

Namespace: Sitecore.Commerce.Pipelines.Products.GetSitecoreProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetSitecoreProductList(
    ArtifactRepository<Product> productRepository
)
Public Sub New (
    productRepository As ArtifactRepository(Of Product)
)
public:
GetSitecoreProductList(
    ArtifactRepository<Product^>^ productRepository
)
new :
        productRepository : ArtifactRepository<Product> -> GetSitecoreProductList

Parameters

productRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository Product
The product repository.
See Also

Reference

GetSitecoreProductList Class
Sitecore.Commerce.Pipelines.Products.GetSitecoreProductList Namespace


GetSitecoreProductList Methods

GetSitecoreProductList Methods

The GetSitecoreProductList type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the GetSitecoreProductList processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetSitecoreProductList Class
Sitecore.Commerce.Pipelines.Products.GetSitecoreProductList Namespace


GetSitecoreProductList.Process Method

GetSitecoreProductListProcess Method
Executes the business logic of the GetSitecoreProductList processor.

Namespace: Sitecore.Commerce.Pipelines.Products.GetSitecoreProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

GetSitecoreProductList Class
Sitecore.Commerce.Pipelines.Products.GetSitecoreProductList Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts"]

Classes
 | Class | Description
Public class | RunSynchronizeClassifications | Defines the processor that executes the SynchronizeClassifications pipeline.
Public class | RunSynchronizeDivisions | Defines the processor of the SynchronizeDivisions pipeline.
Public class | RunSynchronizeManufacturers | Defines the processor of the SynchronizeManufacturers pipeline.
Public class | RunSynchronizeResources | Defines the processor of the SynchronizeResources pipeline.
Public class | RunSynchronizeSpecifications | Defines the processor of the SynchronizeSpecifications pipeline.
Public class | RunSynchronizeTypes | Defines the processor of the SynchronizeTypes pipeline.


RunSynchronizeClassifications Class

RunSynchronizeClassifications Class
Defines the processor that executes the SynchronizeClassifications pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifactsRunSynchronizeClassifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeClassifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeClassifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeClassifications : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeClassifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeClassifications type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeClassifications | Initializes a new instance of the RunSynchronizeClassifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeClassifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeClassifications Constructor

RunSynchronizeClassifications Constructor
Initializes a new instance of the RunSynchronizeClassifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeClassifications()
Public Sub New
public:
RunSynchronizeClassifications()
new : unit -> RunSynchronizeClassifications
See Also

Reference

RunSynchronizeClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeClassifications Methods

RunSynchronizeClassifications Methods

The RunSynchronizeClassifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeClassifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeClassifications.Process Method

RunSynchronizeClassificationsProcess Method
Executes the business logic of the RunSynchronizeClassifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeClassifications Properties

RunSynchronizeClassifications Properties

The RunSynchronizeClassifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeDivisions Class

RunSynchronizeDivisions Class
Defines the processor of the SynchronizeDivisions pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifactsRunSynchronizeDivisions

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeDivisions : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeDivisions
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeDivisions : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeDivisions =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeDivisions type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeDivisions | Initializes a new instance of the RunSynchronizeDivisions class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeDivisions processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeDivisions Constructor

RunSynchronizeDivisions Constructor
Initializes a new instance of the RunSynchronizeDivisions class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeDivisions()
Public Sub New
public:
RunSynchronizeDivisions()
new : unit -> RunSynchronizeDivisions
See Also

Reference

RunSynchronizeDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeDivisions Methods

RunSynchronizeDivisions Methods

The RunSynchronizeDivisions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeDivisions processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeDivisions.Process Method

RunSynchronizeDivisionsProcess Method
Executes the business logic of the RunSynchronizeDivisions processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

RunSynchronizeDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeDivisions Properties

RunSynchronizeDivisions Properties

The RunSynchronizeDivisions type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeManufacturers Class

RunSynchronizeManufacturers Class
Defines the processor of the SynchronizeManufacturers pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifactsRunSynchronizeManufacturers

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeManufacturers : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeManufacturers
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeManufacturers : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeManufacturers =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeManufacturers type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeManufacturers | Initializes a new instance of the RunSynchronizeManufacturers class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeManufacturers processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeManufacturers Constructor

RunSynchronizeManufacturers Constructor
Initializes a new instance of the RunSynchronizeManufacturers class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeManufacturers()
Public Sub New
public:
RunSynchronizeManufacturers()
new : unit -> RunSynchronizeManufacturers
See Also

Reference

RunSynchronizeManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeManufacturers Methods

RunSynchronizeManufacturers Methods

The RunSynchronizeManufacturers type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeManufacturers processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeManufacturers.Process Method

RunSynchronizeManufacturersProcess Method
Executes the business logic of the RunSynchronizeManufacturers processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

RunSynchronizeManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeManufacturers Properties

RunSynchronizeManufacturers Properties

The RunSynchronizeManufacturers type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeResources Class

RunSynchronizeResources Class
Defines the processor of the SynchronizeResources pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifactsRunSynchronizeResources

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeResources : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeResources
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeResources : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeResources =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeResources type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeResources | Initializes a new instance of the RunSynchronizeResources class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeResources pipeline. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeResources Constructor

RunSynchronizeResources Constructor
Initializes a new instance of the RunSynchronizeResources class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeResources()
Public Sub New
public:
RunSynchronizeResources()
new : unit -> RunSynchronizeResources
See Also

Reference

RunSynchronizeResources Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeResources Methods

RunSynchronizeResources Methods

The RunSynchronizeResources type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeResources pipeline. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeResources Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeResources.Process Method

RunSynchronizeResourcesProcess Method
Executes the business logic of the RunSynchronizeResources pipeline.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

RunSynchronizeResources Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeResources Properties

RunSynchronizeResources Properties

The RunSynchronizeResources type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeResources Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeSpecifications Class

RunSynchronizeSpecifications Class
Defines the processor of the SynchronizeSpecifications pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifactsRunSynchronizeSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeSpecifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeSpecifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeSpecifications : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeSpecifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeSpecifications | Initializes a new instance of the RunSynchronizeSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeSpecifications Constructor

RunSynchronizeSpecifications Constructor
Initializes a new instance of the RunSynchronizeSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeSpecifications()
Public Sub New
public:
RunSynchronizeSpecifications()
new : unit -> RunSynchronizeSpecifications
See Also

Reference

RunSynchronizeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeSpecifications Methods

RunSynchronizeSpecifications Methods

The RunSynchronizeSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeSpecifications.Process Method

RunSynchronizeSpecificationsProcess Method
Executes the business logic of the RunSynchronizeSpecifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeSpecifications Properties

RunSynchronizeSpecifications Properties

The RunSynchronizeSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeTypes Class

RunSynchronizeTypes Class
Defines the processor of the SynchronizeTypes pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifactsRunSynchronizeTypes

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeTypes : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeTypes
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeTypes : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeTypes =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeTypes type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeTypes | Initializes a new instance of the RunSynchronizeTypes class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeTypes processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeTypes Constructor

RunSynchronizeTypes Constructor
Initializes a new instance of the RunSynchronizeTypes class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeTypes()
Public Sub New
public:
RunSynchronizeTypes()
new : unit -> RunSynchronizeTypes
See Also

Reference

RunSynchronizeTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeTypes Methods

RunSynchronizeTypes Methods

The RunSynchronizeTypes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeTypes processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeTypes.Process Method

RunSynchronizeTypesProcess Method
Executes the business logic of the RunSynchronizeTypes processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

RunSynchronizeTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


RunSynchronizeTypes Properties

RunSynchronizeTypes Properties

The RunSynchronizeTypes type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeArtifacts Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications"]

Classes
Class Description
Public class ReadExternalCommerceSystemClassifications
Reads the product classifications in the external commerce system.
Public class ReadSitecoreClassifications
Defines the processor that reads classifications from Sitecore. This processor stores Sitecore classification groups in the custom data. In the SynchronizeClassifiactions pipeline, the ResolveClassificationsChanges processor uses Sitecore classification groups that is stored in the custom data.
Public class ResolveClassificationsChanges
Defines the processor that resolves classifications changes between Sitecore and external commerce system. This processor uses:
  • The classification groups in Sitecore that are stored in the custom data by the ReadSitecoreClassifications processor.
  • The classification groups in the external commerce system that are stored in the custom data.
The ResolveClassificationsChanges class inherits from the ResolveChangesProcessor class.
Public class SaveAllClassifications
Defines the processor that saves all the product classifications in Sitecore. The SaveAllClassifications class inherits from SaveToSitecoreProcessor class. The SaveAllClassifications Processor uses the classification groups stored by the external commerce system in the Custom Data dictionary.
Public class SaveClassificationsToExternalCommerceSystem
The pipeline processor which saves divisions to external commerce system.


ReadExternalCommerceSystemClassifications Class

ReadExternalCommerceSystemClassifications Class
Reads the product classifications in the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsReadExternalCommerceSystemClassifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemClassifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemClassifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemClassifications : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemClassifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemClassifications type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemClassifications | Initializes a new instance of the ReadExternalCommerceSystemClassifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemClassifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ReadExternalCommerceSystemClassifications Constructor

ReadExternalCommerceSystemClassifications Constructor
Initializes a new instance of the ReadExternalCommerceSystemClassifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemClassifications()
Public Sub New
public:
ReadExternalCommerceSystemClassifications()
new : unit -> ReadExternalCommerceSystemClassifications
See Also

Reference

ReadExternalCommerceSystemClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ReadExternalCommerceSystemClassifications Methods

ReadExternalCommerceSystemClassifications Methods

The ReadExternalCommerceSystemClassifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemClassifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ReadExternalCommerceSystemClassifications.Process Method

ReadExternalCommerceSystemClassificationsProcess Method
Executes the business logic of the ReadExternalCommerceSystemClassifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ReadExternalCommerceSystemClassifications Properties

ReadExternalCommerceSystemClassifications Properties

The ReadExternalCommerceSystemClassifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ReadSitecoreClassifications Class

ReadSitecoreClassifications Class
Defines the processor that reads classifications from Sitecore. This processor stores Sitecore classification groups in the custom data. In the SynchronizeClassifiactions pipeline, the ResolveClassificationsChanges processor uses Sitecore classification groups that is stored in the custom data.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsReadSitecoreClassifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadSitecoreClassifications : PipelineProcessor<ServicePipelineArgs>
Public Class ReadSitecoreClassifications
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ReadSitecoreClassifications : public PipelineProcessor<ServicePipelineArgs^>
type ReadSitecoreClassifications =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ReadSitecoreClassifications type exposes the following members.

Constructors
 | Name | Description
Public method | ReadSitecoreClassifications | Initializes an instance of the ReadSitecoreClassifications class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ReadSitecoreClassifications Constructor

ReadSitecoreClassifications Constructor
Initializes an instance of the ReadSitecoreClassifications class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadSitecoreClassifications(
    ProductClassificationGroupRepository classificationGroupRepository,
    ProductClassificationRepository classificationRepository
)
Public Sub New (
    classificationGroupRepository As ProductClassificationGroupRepository,
    classificationRepository As ProductClassificationRepository
)
public:
ReadSitecoreClassifications(
    ProductClassificationGroupRepository^ classificationGroupRepository,
    ProductClassificationRepository^ classificationRepository
)
new :
        classificationGroupRepository : ProductClassificationGroupRepository *
        classificationRepository : ProductClassificationRepository -> ReadSitecoreClassifications

Parameters

classificationGroupRepository
Type: Sitecore.Commerce.Data.ProductsProductClassificationGroupRepository
The classification group repository.
classificationRepository
Type: Sitecore.Commerce.Data.ProductsProductClassificationRepository
The classification repository.
See Also

Reference

ReadSitecoreClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ReadSitecoreClassifications Methods

ReadSitecoreClassifications Methods

The ReadSitecoreClassifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadSitecoreClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ReadSitecoreClassifications.Process Method

ReadSitecoreClassificationsProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadSitecoreClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ResolveClassificationsChanges Class

ResolveClassificationsChanges Class
Defines the processor that resolves classifications changes between Sitecore and external commerce system. This processor uses:
  • The classification groups in Sitecore that are stored in the custom data by the ReadSitecoreClassifications processor.
  • The classification groups in the external commerce system that are stored in the custom data.
The ResolveClassificationsChanges class inherits from the ResolveChangesProcessor class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsResolveChangesProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsResolveClassificationsChanges

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ResolveClassificationsChanges : ResolveChangesProcessor
Public Class ResolveClassificationsChanges
    Inherits ResolveChangesProcessor
public ref class ResolveClassificationsChanges : public ResolveChangesProcessor
type ResolveClassificationsChanges =
    class
        inherit ResolveChangesProcessor
    end

The ResolveClassificationsChanges type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveClassificationsChanges | Initializes an instance of the ResolveClassificationsChanges class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetExternalCommerceSystemEntities | Gets entities stored in external commerce system. (Overrides ResolveChangesProcessorGetExternalCommerceSystemEntities(ServicePipelineArgs).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSitecoreEntities | Gets entities stored in Sitecore. (Overrides ResolveChangesProcessorGetSitecoreEntities(ServicePipelineArgs).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MergeClassifications | Merges the classifications.
Public method | Process | Processes the request. (Overrides ResolveChangesProcessorProcess(ServicePipelineArgs).)
Protected method | SaveEntities | Saves the entities to the arguments. (Overrides ResolveChangesProcessorSaveEntities(ServicePipelineArgs, IEnumerableProductEntity).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ResolveClassificationsChanges Constructor

ResolveClassificationsChanges Constructor
Initializes an instance of the ResolveClassificationsChanges class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ResolveClassificationsChanges(
    ISynchronizationStrategy synchronizationStrategy
)
Public Sub New (
    synchronizationStrategy As ISynchronizationStrategy
)
public:
ResolveClassificationsChanges(
    ISynchronizationStrategy^ synchronizationStrategy
)
new :
        synchronizationStrategy : ISynchronizationStrategy -> ResolveClassificationsChanges

Parameters

synchronizationStrategy
Type: Sitecore.Commerce.ProductsISynchronizationStrategy
The synchronization strategy.
See Also

Reference

ResolveClassificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ResolveClassificationsChanges Methods

ResolveClassificationsChanges Methods

The ResolveClassificationsChanges type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetExternalCommerceSystemEntities | Gets entities stored in external commerce system. (Overrides ResolveChangesProcessorGetExternalCommerceSystemEntities(ServicePipelineArgs).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSitecoreEntities | Gets entities stored in Sitecore. (Overrides ResolveChangesProcessorGetSitecoreEntities(ServicePipelineArgs).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MergeClassifications | Merges the classifications.
Public method | Process | Processes the request. (Overrides ResolveChangesProcessorProcess(ServicePipelineArgs).)
Protected method | SaveEntities | Saves the entities to the arguments. (Overrides ResolveChangesProcessorSaveEntities(ServicePipelineArgs, IEnumerableProductEntity).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveClassificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ResolveClassificationsChanges.GetExternalCommerceSystemEntities Method

ResolveClassificationsChangesGetExternalCommerceSystemEntities Method
Gets entities stored in external commerce system.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IEnumerable<ProductEntity> GetExternalCommerceSystemEntities(
    ServicePipelineArgs args
)
Protected Overrides Function GetExternalCommerceSystemEntities (
    args As ServicePipelineArgs
) As IEnumerable(Of ProductEntity)
protected:
virtual IEnumerable<ProductEntity^>^ GetExternalCommerceSystemEntities(
    ServicePipelineArgs^ args
) override
abstract GetExternalCommerceSystemEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>
override GetExternalCommerceSystemEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: IEnumerable ProductEntity
External commerce system entities.
See Also

Reference

ResolveClassificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ResolveClassificationsChanges.GetSitecoreEntities Method

ResolveClassificationsChangesGetSitecoreEntities Method
Gets entities stored in Sitecore.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IEnumerable<ProductEntity> GetSitecoreEntities(
    ServicePipelineArgs args
)
Protected Overrides Function GetSitecoreEntities (
    args As ServicePipelineArgs
) As IEnumerable(Of ProductEntity)
protected:
virtual IEnumerable<ProductEntity^>^ GetSitecoreEntities(
    ServicePipelineArgs^ args
) override
abstract GetSitecoreEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>
override GetSitecoreEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: IEnumerable ProductEntity
Sitecore entities.
See Also

Reference

ResolveClassificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ResolveClassificationsChanges.MergeClassifications Method

ResolveClassificationsChangesMergeClassifications Method
Merges the classifications.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual IEnumerable<Classification> MergeClassifications(
    Direction direction,
    IEnumerable<Classification> externalCommerceSystemClassifications,
    IEnumerable<Classification> sitecoreClassifications
)
Protected Overridable Function MergeClassifications (
    direction As Direction,
    externalCommerceSystemClassifications As IEnumerable(Of Classification),
    sitecoreClassifications As IEnumerable(Of Classification)
) As IEnumerable(Of Classification)
protected:
virtual IEnumerable<Classification^>^ MergeClassifications(
    Direction direction,
    IEnumerable<Classification^>^ externalCommerceSystemClassifications,
    IEnumerable<Classification^>^ sitecoreClassifications
)
abstract MergeClassifications :
        direction : Direction *
        externalCommerceSystemClassifications : IEnumerable<Classification> *
        sitecoreClassifications : IEnumerable<Classification> -> IEnumerable<Classification>
override MergeClassifications :
        direction : Direction *
        externalCommerceSystemClassifications : IEnumerable<Classification> *
        sitecoreClassifications : IEnumerable<Classification> -> IEnumerable<Classification>

Parameters

direction
Type: Sitecore.Commerce.ProductsDirection
The direction.
externalCommerceSystemClassifications
Type: System.Collections.GenericIEnumerable Classification
External commerce system classifications.
sitecoreClassifications
Type: System.Collections.GenericIEnumerable Classification
Sitecore classifications.

Return Value

Type: IEnumerable Classification

[Missing <returns> documentation for "M:Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications.ResolveClassificationsChanges.MergeClassifications(Sitecore.Commerce.Products.Direction,System.Collections.Generic.IEnumerable{Sitecore.Commerce.Entities.Products.Classification},System.Collections.Generic.IEnumerable{Sitecore.Commerce.Entities.Products.Classification})"]

See Also

Reference

ResolveClassificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ResolveClassificationsChanges.Process Method

ResolveClassificationsChangesProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ResolveClassificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


ResolveClassificationsChanges.SaveEntities Method

ResolveClassificationsChangesSaveEntities Method
Saves the entities to the arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void SaveEntities(
    ServicePipelineArgs args,
    IEnumerable<ProductEntity> productEntities
)
Protected Overrides Sub SaveEntities (
    args As ServicePipelineArgs,
    productEntities As IEnumerable(Of ProductEntity)
)
protected:
virtual void SaveEntities(
    ServicePipelineArgs^ args,
    IEnumerable<ProductEntity^>^ productEntities
) override
abstract SaveEntities :
        args : ServicePipelineArgs *
        productEntities : IEnumerable<ProductEntity> -> unit
override SaveEntities :
        args : ServicePipelineArgs *
        productEntities : IEnumerable<ProductEntity> -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
productEntities
Type: System.Collections.GenericIEnumerable ProductEntity
The product entities.
See Also

Reference

ResolveClassificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


SaveAllClassifications Class

SaveAllClassifications Class
Defines the processor that saves all the product classifications in Sitecore. The SaveAllClassifications class inherits from SaveToSitecoreProcessor class. The SaveAllClassifications Processor uses the classification groups stored by the external commerce system in the Custom Data dictionary.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsSaveToSitecoreProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSaveAllClassifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveAllClassifications : SaveToSitecoreProcessor
Public Class SaveAllClassifications
    Inherits SaveToSitecoreProcessor
public ref class SaveAllClassifications : public SaveToSitecoreProcessor
type SaveAllClassifications =
    class
        inherit SaveToSitecoreProcessor
    end

The SaveAllClassifications type exposes the following members.

Constructors
 | Name | Description
Public method | SaveAllClassifications | Initializes an instance of the SaveAllClassifications class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveAllClassifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


SaveAllClassifications Constructor

SaveAllClassifications Constructor
Initializes an instance of the SaveAllClassifications class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveAllClassifications(
    ArtifactRepository<ClassificationGroup> productClassificationGroupRepository,
    ProductClassificationRepository productClassificationRepository
)
Public Sub New (
    productClassificationGroupRepository As ArtifactRepository(Of ClassificationGroup),
    productClassificationRepository As ProductClassificationRepository
)
public:
SaveAllClassifications(
    ArtifactRepository<ClassificationGroup^>^ productClassificationGroupRepository,
    ProductClassificationRepository^ productClassificationRepository
)
new :
        productClassificationGroupRepository : ArtifactRepository<ClassificationGroup> *
        productClassificationRepository : ProductClassificationRepository -> SaveAllClassifications

Parameters

productClassificationGroupRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository ClassificationGroup
The product classification group repository.
productClassificationRepository
Type: Sitecore.Commerce.Data.ProductsProductClassificationRepository
The product classification repository.
See Also

Reference

SaveAllClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


SaveAllClassifications Methods

SaveAllClassifications Methods

The SaveAllClassifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveAllClassifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveAllClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


SaveAllClassifications.Process Method

SaveAllClassificationsProcess Method
Executes the business logic of the SaveAllClassifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

SaveAllClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


SaveAllClassifications Properties

SaveAllClassifications Properties

The SaveAllClassifications type exposes the following members.

Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveAllClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


SaveClassificationsToExternalCommerceSystem Class

SaveClassificationsToExternalCommerceSystem Class
The pipeline processor which saves divisions to external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSaveClassificationsToExternalCommerceSystem

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveClassificationsToExternalCommerceSystem : PipelineProcessor<ServicePipelineArgs>
Public Class SaveClassificationsToExternalCommerceSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveClassificationsToExternalCommerceSystem : public PipelineProcessor<ServicePipelineArgs^>
type SaveClassificationsToExternalCommerceSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveClassificationsToExternalCommerceSystem type exposes the following members.

Constructors
 | Name | Description
Public method | SaveClassificationsToExternalCommerceSystem | Initializes a new instance of the SaveClassificationsToExternalCommerceSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


SaveClassificationsToExternalCommerceSystem Constructor

SaveClassificationsToExternalCommerceSystem Constructor
Initializes a new instance of the SaveClassificationsToExternalCommerceSystem class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveClassificationsToExternalCommerceSystem()
Public Sub New
public:
SaveClassificationsToExternalCommerceSystem()
new : unit -> SaveClassificationsToExternalCommerceSystem
See Also

Reference

SaveClassificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


SaveClassificationsToExternalCommerceSystem Methods

SaveClassificationsToExternalCommerceSystem Methods

The SaveClassificationsToExternalCommerceSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveClassificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


SaveClassificationsToExternalCommerceSystem.Process Method

SaveClassificationsToExternalCommerceSystemProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveClassificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassifications Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications"]

Classes
 | Class | Description
Public class | ReadExternalCommerceSystemClassificationsSpecifications | Reads classification specifications of a product from the external commerce system.
Public class | ReadSitecoreClassificationsSpecifications | The pipeline processor which reads classifications specifications from Sitecore.
Public class | ResolveClassificationsSpecificationsChanges | The pipeline processor which resolves classifications specifications changes between Sitecore and external commerce system.
Public class | SaveClassificationsSpecificationsToExternalCommerceSystem | The pipeline processor which saves divisions to external commerce system.
Public class | SaveClassificationsSpecificationsToSitecore | Defines the processor that saves the classification specifications of a product in Sitecore. This processor uses the product classification groups stored in the custom data. This class inherits from the SaveToSitecoreProcessor class.


ReadExternalCommerceSystemClassificationsSpecifications Class

ReadExternalCommerceSystemClassificationsSpecifications Class
Reads classification specifications of a product from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecificationsReadExternalCommerceSystemClassificationsSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemClassificationsSpecifications : PipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemClassificationsSpecifications
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemClassificationsSpecifications : public PipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemClassificationsSpecifications =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemClassificationsSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemClassificationsSpecifications | Initializes a new instance of the ReadExternalCommerceSystemClassificationsSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemClassificationsSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


ReadExternalCommerceSystemClassificationsSpecifications Constructor

ReadExternalCommerceSystemClassificationsSpecifications Constructor
Initializes a new instance of the ReadExternalCommerceSystemClassificationsSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemClassificationsSpecifications()
Public Sub New
public:
ReadExternalCommerceSystemClassificationsSpecifications()
new : unit -> ReadExternalCommerceSystemClassificationsSpecifications
See Also

Reference

ReadExternalCommerceSystemClassificationsSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


ReadExternalCommerceSystemClassificationsSpecifications Methods

ReadExternalCommerceSystemClassificationsSpecifications Methods

The ReadExternalCommerceSystemClassificationsSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemClassificationsSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemClassificationsSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


ReadExternalCommerceSystemClassificationsSpecifications.Process Method

ReadExternalCommerceSystemClassificationsSpecificationsProcess Method
Executes the business logic of the ReadExternalCommerceSystemClassificationsSpecifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemClassificationsSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


ReadSitecoreClassificationsSpecifications Class

ReadSitecoreClassificationsSpecifications Class
The pipeline processor which reads classifications specifications from Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecificationsReadSitecoreClassificationsSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadSitecoreClassificationsSpecifications : PipelineProcessor<ServicePipelineArgs>
Public Class ReadSitecoreClassificationsSpecifications
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ReadSitecoreClassificationsSpecifications : public PipelineProcessor<ServicePipelineArgs^>
type ReadSitecoreClassificationsSpecifications =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ReadSitecoreClassificationsSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | ReadSitecoreClassificationsSpecifications | Initializes a new instance of the ReadSitecoreClassificationsSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


ReadSitecoreClassificationsSpecifications Constructor

ReadSitecoreClassificationsSpecifications Constructor
Initializes a new instance of the ReadSitecoreClassificationsSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadSitecoreClassificationsSpecifications()
Public Sub New
public:
ReadSitecoreClassificationsSpecifications()
new : unit -> ReadSitecoreClassificationsSpecifications
See Also

Reference

ReadSitecoreClassificationsSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


ReadSitecoreClassificationsSpecifications Methods

ReadSitecoreClassificationsSpecifications Methods

The ReadSitecoreClassificationsSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadSitecoreClassificationsSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


ReadSitecoreClassificationsSpecifications.Process Method

ReadSitecoreClassificationsSpecificationsProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadSitecoreClassificationsSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


ResolveClassificationsSpecificationsChanges Class

ResolveClassificationsSpecificationsChanges Class
The pipeline processor which resolves classifications specifications changes between Sitecore and external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecificationsResolveClassificationsSpecificationsChanges

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ResolveClassificationsSpecificationsChanges : PipelineProcessor<ServicePipelineArgs>
Public Class ResolveClassificationsSpecificationsChanges
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ResolveClassificationsSpecificationsChanges : public PipelineProcessor<ServicePipelineArgs^>
type ResolveClassificationsSpecificationsChanges =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ResolveClassificationsSpecificationsChanges type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveClassificationsSpecificationsChanges | Initializes a new instance of the ResolveClassificationsSpecificationsChanges class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


ResolveClassificationsSpecificationsChanges Constructor

ResolveClassificationsSpecificationsChanges Constructor
Initializes a new instance of the ResolveClassificationsSpecificationsChanges class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ResolveClassificationsSpecificationsChanges()
Public Sub New
public:
ResolveClassificationsSpecificationsChanges()
new : unit -> ResolveClassificationsSpecificationsChanges
See Also

Reference

ResolveClassificationsSpecificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


ResolveClassificationsSpecificationsChanges Methods

ResolveClassificationsSpecificationsChanges Methods

The ResolveClassificationsSpecificationsChanges type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveClassificationsSpecificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


ResolveClassificationsSpecificationsChanges.Process Method

ResolveClassificationsSpecificationsChangesProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ResolveClassificationsSpecificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


SaveClassificationsSpecificationsToExternalCommerceSystem Class

SaveClassificationsSpecificationsToExternalCommerceSystem Class
The pipeline processor which saves divisions to external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecificationsSaveClassificationsSpecificationsToExternalCommerceSystem

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveClassificationsSpecificationsToExternalCommerceSystem : PipelineProcessor<ServicePipelineArgs>
Public Class SaveClassificationsSpecificationsToExternalCommerceSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveClassificationsSpecificationsToExternalCommerceSystem : public PipelineProcessor<ServicePipelineArgs^>
type SaveClassificationsSpecificationsToExternalCommerceSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveClassificationsSpecificationsToExternalCommerceSystem type exposes the following members.

Constructors
 | Name | Description
Public method | SaveClassificationsSpecificationsToExternalCommerceSystem | Initializes a new instance of the SaveClassificationsSpecificationsToExternalCommerceSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


SaveClassificationsSpecificationsToExternalCommerceSystem Constructor

SaveClassificationsSpecificationsToExternalCommerceSystem Constructor
Initializes a new instance of the SaveClassificationsSpecificationsToExternalCommerceSystem class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveClassificationsSpecificationsToExternalCommerceSystem()
Public Sub New
public:
SaveClassificationsSpecificationsToExternalCommerceSystem()
new : unit -> SaveClassificationsSpecificationsToExternalCommerceSystem
See Also

Reference

SaveClassificationsSpecificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


SaveClassificationsSpecificationsToExternalCommerceSystem Methods

SaveClassificationsSpecificationsToExternalCommerceSystem Methods

The SaveClassificationsSpecificationsToExternalCommerceSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveClassificationsSpecificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


SaveClassificationsSpecificationsToExternalCommerceSystem.Process Method

SaveClassificationsSpecificationsToExternalCommerceSystemProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveClassificationsSpecificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


SaveClassificationsSpecificationsToSitecore Class

SaveClassificationsSpecificationsToSitecore Class
Defines the processor that saves the classification specifications of a product in Sitecore. This processor uses the product classification groups stored in the custom data. This class inherits from the SaveToSitecoreProcessor class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsSaveToSitecoreProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecificationsSaveClassificationsSpecificationsToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveClassificationsSpecificationsToSitecore : SaveToSitecoreProcessor
Public Class SaveClassificationsSpecificationsToSitecore
    Inherits SaveToSitecoreProcessor
public ref class SaveClassificationsSpecificationsToSitecore : public SaveToSitecoreProcessor
type SaveClassificationsSpecificationsToSitecore =
    class
        inherit SaveToSitecoreProcessor
    end

The SaveClassificationsSpecificationsToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveClassificationsSpecificationsToSitecore | Initializes an instance of the SaveClassificationsSpecificationsToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveClassificationsSpecificationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


SaveClassificationsSpecificationsToSitecore Constructor

SaveClassificationsSpecificationsToSitecore Constructor
Initializes an instance of the SaveClassificationsSpecificationsToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveClassificationsSpecificationsToSitecore(
    ProductClassificationRepository productClassificationRepository
)
Public Sub New (
    productClassificationRepository As ProductClassificationRepository
)
public:
SaveClassificationsSpecificationsToSitecore(
    ProductClassificationRepository^ productClassificationRepository
)
new :
        productClassificationRepository : ProductClassificationRepository -> SaveClassificationsSpecificationsToSitecore

Parameters

productClassificationRepository
Type: Sitecore.Commerce.Data.ProductsProductClassificationRepository
The product classification repository.
See Also

Reference

SaveClassificationsSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


SaveClassificationsSpecificationsToSitecore Methods

SaveClassificationsSpecificationsToSitecore Methods

The SaveClassificationsSpecificationsToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveClassificationsSpecificationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveClassificationsSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


SaveClassificationsSpecificationsToSitecore.Process Method

SaveClassificationsSpecificationsToSitecoreProcess Method
Executes the business logic of the SaveClassificationsSpecificationsToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

SaveClassificationsSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


SaveClassificationsSpecificationsToSitecore Properties

SaveClassificationsSpecificationsToSitecore Properties

The SaveClassificationsSpecificationsToSitecore type exposes the following members.

Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveClassificationsSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeClassificationsSpecifications Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions"]

Classes
Class Description
Public class ReadExternalCommerceSystemDivisions
Reads the product divisions from the external commerce system.
Public class ReadSitecoreDivisions
Defines the processor that reads divisions from Sitecore. This processor stores Sitecore divisions in the custom data. In the SynchronizeDivisions pipeline, the ResolveDivisionsChanges processor uses Sitecore divisions stored in the custom data.
Public class ResolveDivisionsChanges
Defines the processor that resolves divisions changes between Sitecore and external commerce system. This processor uses:
  • Sitecore divisions that are stored in the custom data by the ReadSitecoreDivisions processor.
  • The divisions of the external commerce systems that are stored in the custom data.
This class inherits from the ResolveChangesProcessor class.
Public class SaveDivisionsToExternalCommerceSystem
The pipeline processor which saves divisions to external commerce system.
Public class SaveDivisionsToSitecore
Defines the SaveDivisionsToSitecore processor.


ReadExternalCommerceSystemDivisions Class

ReadExternalCommerceSystemDivisions Class
Reads the product divisions from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisionsReadExternalCommerceSystemDivisions

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemDivisions : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemDivisions
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemDivisions : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemDivisions =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemDivisions type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemDivisions | Initializes a new instance of the ReadExternalCommerceSystemDivisions class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemDivisions processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


ReadExternalCommerceSystemDivisions Constructor

ReadExternalCommerceSystemDivisions Constructor
Initializes a new instance of the ReadExternalCommerceSystemDivisions class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemDivisions()
Public Sub New
public:
ReadExternalCommerceSystemDivisions()
new : unit -> ReadExternalCommerceSystemDivisions
See Also

Reference

ReadExternalCommerceSystemDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


ReadExternalCommerceSystemDivisions Methods

ReadExternalCommerceSystemDivisions Methods

The ReadExternalCommerceSystemDivisions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemDivisions processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


ReadExternalCommerceSystemDivisions.Process Method

ReadExternalCommerceSystemDivisionsProcess Method
Executes the business logic of the ReadExternalCommerceSystemDivisions processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

ReadExternalCommerceSystemDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


ReadExternalCommerceSystemDivisions Properties

ReadExternalCommerceSystemDivisions Properties

The ReadExternalCommerceSystemDivisions type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


ReadSitecoreDivisions Class

ReadSitecoreDivisions Class
Defines the processor that reads divisions from Sitecore. This processor stores Sitecore divisions in the custom data. In the SynchronizeDivisions pipeline, the ResolveDivisionsChanges processor uses Sitecore divisions stored in the custom data.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisionsReadSitecoreDivisions

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadSitecoreDivisions : PipelineProcessor<ServicePipelineArgs>
Public Class ReadSitecoreDivisions
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ReadSitecoreDivisions : public PipelineProcessor<ServicePipelineArgs^>
type ReadSitecoreDivisions =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ReadSitecoreDivisions type exposes the following members.

Constructors
 | Name | Description
Public method | ReadSitecoreDivisions | Initializes an instance of the ReadSitecoreDivisions class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


ReadSitecoreDivisions Constructor

ReadSitecoreDivisions Constructor
Initializes an instance of the ReadSitecoreDivisions class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadSitecoreDivisions(
    ArtifactRepository<Division> divisionRepository
)
Public Sub New (
    divisionRepository As ArtifactRepository(Of Division)
)
public:
ReadSitecoreDivisions(
    ArtifactRepository<Division^>^ divisionRepository
)
new :
        divisionRepository : ArtifactRepository<Division> -> ReadSitecoreDivisions

Parameters

divisionRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository Division
The division repository.
See Also

Reference

ReadSitecoreDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


ReadSitecoreDivisions Methods

ReadSitecoreDivisions Methods

The ReadSitecoreDivisions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadSitecoreDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


ReadSitecoreDivisions.Process Method

ReadSitecoreDivisionsProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadSitecoreDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


ResolveDivisionsChanges Class

ResolveDivisionsChanges Class
Defines the processor that resolves divisions changes between Sitecore and external commerce system. This processor uses:
  • Sitecore divisions that are stored in the custom data by the ReadSitecoreDivisions processor.
  • The divisions of the external commerce systems that are stored in the custom data.
This class inherits from the ResolveChangesProcessor class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsResolveChangesProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisionsResolveDivisionsChanges

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ResolveDivisionsChanges : ResolveChangesProcessor
Public Class ResolveDivisionsChanges
    Inherits ResolveChangesProcessor
public ref class ResolveDivisionsChanges : public ResolveChangesProcessor
type ResolveDivisionsChanges =
    class
        inherit ResolveChangesProcessor
    end

The ResolveDivisionsChanges type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveDivisionsChanges | Initializes an instance of the ResolveDivisionsChanges class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetExternalCommerceSystemEntities | Gets entities stored in external commerce system. (Overrides ResolveChangesProcessorGetExternalCommerceSystemEntities(ServicePipelineArgs).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSitecoreEntities | Gets entities stored in Sitecore. (Overrides ResolveChangesProcessorGetSitecoreEntities(ServicePipelineArgs).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Inherited from ResolveChangesProcessor.)
Protected method | SaveEntities | Saves the entities to the arguments. (Overrides ResolveChangesProcessorSaveEntities(ServicePipelineArgs, IEnumerableProductEntity).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


ResolveDivisionsChanges Constructor

ResolveDivisionsChanges Constructor
Initializes an instance of the ResolveDivisionsChanges class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ResolveDivisionsChanges(
    ISynchronizationStrategy synchronizationStrategy
)
Public Sub New (
    synchronizationStrategy As ISynchronizationStrategy
)
public:
ResolveDivisionsChanges(
    ISynchronizationStrategy^ synchronizationStrategy
)
new :
        synchronizationStrategy : ISynchronizationStrategy -> ResolveDivisionsChanges

Parameters

synchronizationStrategy
Type: Sitecore.Commerce.ProductsISynchronizationStrategy
The synchronization strategy.
See Also

Reference

ResolveDivisionsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


ResolveDivisionsChanges Methods

ResolveDivisionsChanges Methods

The ResolveDivisionsChanges type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetExternalCommerceSystemEntities | Gets entities stored in external commerce system. (Overrides ResolveChangesProcessorGetExternalCommerceSystemEntities(ServicePipelineArgs).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSitecoreEntities | Gets entities stored in Sitecore. (Overrides ResolveChangesProcessorGetSitecoreEntities(ServicePipelineArgs).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Inherited from ResolveChangesProcessor.)
Protected method | SaveEntities | Saves the entities to the arguments. (Overrides ResolveChangesProcessorSaveEntities(ServicePipelineArgs, IEnumerableProductEntity).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveDivisionsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


ResolveDivisionsChanges.GetExternalCommerceSystemEntities Method

ResolveDivisionsChangesGetExternalCommerceSystemEntities Method
Gets entities stored in external commerce system.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IEnumerable<ProductEntity> GetExternalCommerceSystemEntities(
    ServicePipelineArgs args
)
Protected Overrides Function GetExternalCommerceSystemEntities (
    args As ServicePipelineArgs
) As IEnumerable(Of ProductEntity)
protected:
virtual IEnumerable<ProductEntity^>^ GetExternalCommerceSystemEntities(
    ServicePipelineArgs^ args
) override
abstract GetExternalCommerceSystemEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>
override GetExternalCommerceSystemEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: IEnumerable ProductEntity
External commerce system entities.
See Also

Reference

ResolveDivisionsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


ResolveDivisionsChanges.GetSitecoreEntities Method

ResolveDivisionsChangesGetSitecoreEntities Method
Gets entities stored in Sitecore.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IEnumerable<ProductEntity> GetSitecoreEntities(
    ServicePipelineArgs args
)
Protected Overrides Function GetSitecoreEntities (
    args As ServicePipelineArgs
) As IEnumerable(Of ProductEntity)
protected:
virtual IEnumerable<ProductEntity^>^ GetSitecoreEntities(
    ServicePipelineArgs^ args
) override
abstract GetSitecoreEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>
override GetSitecoreEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: IEnumerable ProductEntity
Sitecore entities.
See Also

Reference

ResolveDivisionsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


ResolveDivisionsChanges.SaveEntities Method

ResolveDivisionsChangesSaveEntities Method
Saves the entities to the arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void SaveEntities(
    ServicePipelineArgs args,
    IEnumerable<ProductEntity> productEntities
)
Protected Overrides Sub SaveEntities (
    args As ServicePipelineArgs,
    productEntities As IEnumerable(Of ProductEntity)
)
protected:
virtual void SaveEntities(
    ServicePipelineArgs^ args,
    IEnumerable<ProductEntity^>^ productEntities
) override
abstract SaveEntities :
        args : ServicePipelineArgs *
        productEntities : IEnumerable<ProductEntity> -> unit
override SaveEntities :
        args : ServicePipelineArgs *
        productEntities : IEnumerable<ProductEntity> -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
productEntities
Type: System.Collections.GenericIEnumerable ProductEntity
The product entities.
See Also

Reference

ResolveDivisionsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


SaveDivisionsToExternalCommerceSystem Class

SaveDivisionsToExternalCommerceSystem Class
The pipeline processor which saves divisions to external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisionsSaveDivisionsToExternalCommerceSystem

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveDivisionsToExternalCommerceSystem : PipelineProcessor<ServicePipelineArgs>
Public Class SaveDivisionsToExternalCommerceSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveDivisionsToExternalCommerceSystem : public PipelineProcessor<ServicePipelineArgs^>
type SaveDivisionsToExternalCommerceSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveDivisionsToExternalCommerceSystem type exposes the following members.

Constructors
 | Name | Description
Public method | SaveDivisionsToExternalCommerceSystem | Initializes a new instance of the SaveDivisionsToExternalCommerceSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


SaveDivisionsToExternalCommerceSystem Constructor

SaveDivisionsToExternalCommerceSystem Constructor
Initializes a new instance of the SaveDivisionsToExternalCommerceSystem class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveDivisionsToExternalCommerceSystem()
Public Sub New
public:
SaveDivisionsToExternalCommerceSystem()
new : unit -> SaveDivisionsToExternalCommerceSystem
See Also

Reference

SaveDivisionsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


SaveDivisionsToExternalCommerceSystem Methods

SaveDivisionsToExternalCommerceSystem Methods

The SaveDivisionsToExternalCommerceSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveDivisionsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


SaveDivisionsToExternalCommerceSystem.Process Method

SaveDivisionsToExternalCommerceSystemProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveDivisionsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


SaveDivisionsToSitecore Class

SaveDivisionsToSitecore Class
Defines the SaveDivisionsToSitecore processor.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsSaveToSitecoreProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisionsSaveDivisionsToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveDivisionsToSitecore : SaveToSitecoreProcessor
Public Class SaveDivisionsToSitecore
    Inherits SaveToSitecoreProcessor
public ref class SaveDivisionsToSitecore : public SaveToSitecoreProcessor
type SaveDivisionsToSitecore =
    class
        inherit SaveToSitecoreProcessor
    end

The SaveDivisionsToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveDivisionsToSitecore | Initializes a new instance of the SaveDivisionsToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveDivisionsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


SaveDivisionsToSitecore Constructor

SaveDivisionsToSitecore Constructor
Initializes a new instance of the SaveDivisionsToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveDivisionsToSitecore(
    ArtifactRepository<Division> divisionRepository
)
Public Sub New (
    divisionRepository As ArtifactRepository(Of Division)
)
public:
SaveDivisionsToSitecore(
    ArtifactRepository<Division^>^ divisionRepository
)
new :
        divisionRepository : ArtifactRepository<Division> -> SaveDivisionsToSitecore

Parameters

divisionRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository Division
The division repository.
See Also

Reference

SaveDivisionsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


SaveDivisionsToSitecore Methods

SaveDivisionsToSitecore Methods

The SaveDivisionsToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveDivisionsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveDivisionsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


SaveDivisionsToSitecore.Process Method

SaveDivisionsToSitecoreProcess Method
Executes the business logic of the SaveDivisionsToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

SaveDivisionsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


SaveDivisionsToSitecore Properties

SaveDivisionsToSitecore Properties

The SaveDivisionsToSitecore type exposes the following members.

Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveDivisionsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeDivisions Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications"]

Classes
 | Class | Description
Public class | ReadExternalCommerceSystemGlobalSpecifications | Reads the global specifications of the external commerce system.
Public class | ReadSitecoreGlobalSpecifications | The pipeline processor which reads global specifications from Sitecore.
Public class | ResolveGlobalSpecificationsChanges | The pipeline processor which resolves global specification changes between Sitecore and external commerce system.
Public class | SaveGlobalSpecificationsToExternalCommerceSystem | The pipeline processor which saves divisions to external commerce system.
Public class | SaveGlobalSpecificationsToSitecore | Defines the processor that saves the global specifications in Sitecore. This processor uses the specifications stored in the custom data by external commerce systems. The SaveGlobalSpecificationsToSitecore class inherits from the SaveToSitecoreProcessor class.


ReadExternalCommerceSystemGlobalSpecifications Class

ReadExternalCommerceSystemGlobalSpecifications Class
Reads the global specifications of the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecificationsReadExternalCommerceSystemGlobalSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemGlobalSpecifications : PipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemGlobalSpecifications
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemGlobalSpecifications : public PipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemGlobalSpecifications =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemGlobalSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemGlobalSpecifications | Initializes a new instance of the ReadExternalCommerceSystemGlobalSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemGlobalSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


ReadExternalCommerceSystemGlobalSpecifications Constructor

ReadExternalCommerceSystemGlobalSpecifications Constructor
Initializes a new instance of the ReadExternalCommerceSystemGlobalSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemGlobalSpecifications()
Public Sub New
public:
ReadExternalCommerceSystemGlobalSpecifications()
new : unit -> ReadExternalCommerceSystemGlobalSpecifications
See Also

Reference

ReadExternalCommerceSystemGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


ReadExternalCommerceSystemGlobalSpecifications Methods

ReadExternalCommerceSystemGlobalSpecifications Methods

The ReadExternalCommerceSystemGlobalSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemGlobalSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


ReadExternalCommerceSystemGlobalSpecifications.Process Method

ReadExternalCommerceSystemGlobalSpecificationsProcess Method
Executes the business logic of the ReadExternalCommerceSystemGlobalSpecifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


ReadSitecoreGlobalSpecifications Class

ReadSitecoreGlobalSpecifications Class
The pipeline processor which reads global specifications from Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecificationsReadSitecoreGlobalSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadSitecoreGlobalSpecifications : PipelineProcessor<ServicePipelineArgs>
Public Class ReadSitecoreGlobalSpecifications
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ReadSitecoreGlobalSpecifications : public PipelineProcessor<ServicePipelineArgs^>
type ReadSitecoreGlobalSpecifications =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ReadSitecoreGlobalSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | ReadSitecoreGlobalSpecifications | Initializes a new instance of the ReadSitecoreGlobalSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


ReadSitecoreGlobalSpecifications Constructor

ReadSitecoreGlobalSpecifications Constructor
Initializes a new instance of the ReadSitecoreGlobalSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadSitecoreGlobalSpecifications()
Public Sub New
public:
ReadSitecoreGlobalSpecifications()
new : unit -> ReadSitecoreGlobalSpecifications
See Also

Reference

ReadSitecoreGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


ReadSitecoreGlobalSpecifications Methods

ReadSitecoreGlobalSpecifications Methods

The ReadSitecoreGlobalSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadSitecoreGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


ReadSitecoreGlobalSpecifications.Process Method

ReadSitecoreGlobalSpecificationsProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadSitecoreGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


ResolveGlobalSpecificationsChanges Class

ResolveGlobalSpecificationsChanges Class
The pipeline processor which resolves global specification changes between Sitecore and external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecificationsResolveGlobalSpecificationsChanges

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ResolveGlobalSpecificationsChanges : PipelineProcessor<ServicePipelineArgs>
Public Class ResolveGlobalSpecificationsChanges
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ResolveGlobalSpecificationsChanges : public PipelineProcessor<ServicePipelineArgs^>
type ResolveGlobalSpecificationsChanges =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ResolveGlobalSpecificationsChanges type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveGlobalSpecificationsChanges | Initializes a new instance of the ResolveGlobalSpecificationsChanges class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


ResolveGlobalSpecificationsChanges Constructor

ResolveGlobalSpecificationsChanges Constructor
Initializes a new instance of the ResolveGlobalSpecificationsChanges class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ResolveGlobalSpecificationsChanges()
Public Sub New
public:
ResolveGlobalSpecificationsChanges()
new : unit -> ResolveGlobalSpecificationsChanges
See Also

Reference

ResolveGlobalSpecificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


ResolveGlobalSpecificationsChanges Methods

ResolveGlobalSpecificationsChanges Methods

The ResolveGlobalSpecificationsChanges type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveGlobalSpecificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


ResolveGlobalSpecificationsChanges.Process Method

ResolveGlobalSpecificationsChangesProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ResolveGlobalSpecificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


SaveGlobalSpecificationsToExternalCommerceSystem Class

SaveGlobalSpecificationsToExternalCommerceSystem Class
The pipeline processor which saves divisions to external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecificationsSaveGlobalSpecificationsToExternalCommerceSystem

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveGlobalSpecificationsToExternalCommerceSystem : PipelineProcessor<ServicePipelineArgs>
Public Class SaveGlobalSpecificationsToExternalCommerceSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveGlobalSpecificationsToExternalCommerceSystem : public PipelineProcessor<ServicePipelineArgs^>
type SaveGlobalSpecificationsToExternalCommerceSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveGlobalSpecificationsToExternalCommerceSystem type exposes the following members.

Constructors
 | Name | Description
Public method | SaveGlobalSpecificationsToExternalCommerceSystem | Initializes a new instance of the SaveGlobalSpecificationsToExternalCommerceSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


SaveGlobalSpecificationsToExternalCommerceSystem Constructor

SaveGlobalSpecificationsToExternalCommerceSystem Constructor
Initializes a new instance of the SaveGlobalSpecificationsToExternalCommerceSystem class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveGlobalSpecificationsToExternalCommerceSystem()
Public Sub New
public:
SaveGlobalSpecificationsToExternalCommerceSystem()
new : unit -> SaveGlobalSpecificationsToExternalCommerceSystem
See Also

Reference

SaveGlobalSpecificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


SaveGlobalSpecificationsToExternalCommerceSystem Methods

SaveGlobalSpecificationsToExternalCommerceSystem Methods

The SaveGlobalSpecificationsToExternalCommerceSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveGlobalSpecificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


SaveGlobalSpecificationsToExternalCommerceSystem.Process Method

SaveGlobalSpecificationsToExternalCommerceSystemProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveGlobalSpecificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


SaveGlobalSpecificationsToSitecore Class

SaveGlobalSpecificationsToSitecore Class
Defines the processor that saves the global specifications in Sitecore. This processor uses the specifications stored in the custom data by external commerce systems. The SaveGlobalSpecificationsToSitecore class inherits from the SaveToSitecoreProcessor class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsSaveToSitecoreProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecificationsSaveGlobalSpecificationsToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveGlobalSpecificationsToSitecore : SaveToSitecoreProcessor
Public Class SaveGlobalSpecificationsToSitecore
    Inherits SaveToSitecoreProcessor
public ref class SaveGlobalSpecificationsToSitecore : public SaveToSitecoreProcessor
type SaveGlobalSpecificationsToSitecore =
    class
        inherit SaveToSitecoreProcessor
    end

The SaveGlobalSpecificationsToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveGlobalSpecificationsToSitecore | Initializes an instance of the SaveGlobalSpecificationsToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveGlobalSpecificationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


SaveGlobalSpecificationsToSitecore Constructor

SaveGlobalSpecificationsToSitecore Constructor
Initializes an instance of the SaveGlobalSpecificationsToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveGlobalSpecificationsToSitecore(
    SpecificationRepository repository
)
Public Sub New (
    repository As SpecificationRepository
)
public:
SaveGlobalSpecificationsToSitecore(
    SpecificationRepository^ repository
)
new :
        repository : SpecificationRepository -> SaveGlobalSpecificationsToSitecore

Parameters

repository
Type: Sitecore.Commerce.Data.ProductsSpecificationRepository
The global specification repository.
See Also

Reference

SaveGlobalSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


SaveGlobalSpecificationsToSitecore Methods

SaveGlobalSpecificationsToSitecore Methods

The SaveGlobalSpecificationsToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveGlobalSpecificationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveGlobalSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


SaveGlobalSpecificationsToSitecore.Process Method

SaveGlobalSpecificationsToSitecoreProcess Method
Executes the business logic of the SaveGlobalSpecificationsToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveGlobalSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


SaveGlobalSpecificationsToSitecore Properties

SaveGlobalSpecificationsToSitecore Properties

The SaveGlobalSpecificationsToSitecore type exposes the following members.

Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveGlobalSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeGlobalSpecifications Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers"]

Classes
Class Description
Public class ReadExternalCommerceSystemManufacturers
Reads the manufacturers of products in the external commerce system.
Public class ReadSitecoreManufacturers
Defines the processor that reads manufacturers from Sitecore. This processor stores Sitecore manufacturers in the custom data. In the SynchronizeManufacturers pipeline, the ResolveManufacturersChanges processor uses Sitecore manufacturers stored in the custom data.
Public class ResolveManufacturersChanges
Defines the processor that resolves manufacturer changes between Sitecore and external commerce system. This processor uses:
  • Sitecore manufacturers stored in the custom data by the ReadSitecoreManufacturers processor.
  • The external commerce system manufacturers stored in the custom data.
Public class SaveManufacturersToExternalCommerceSystem
The pipeline processor which saves divisions to external commerce system.
Public class SaveManufacturersToSitecore
Defines the processor of the SaveAllManufacturers pipeline. This class implements the SaveToSitecoreProcessor class.


ReadExternalCommerceSystemManufacturers Class

ReadExternalCommerceSystemManufacturers Class
Reads the manufacturers of products in the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturersReadExternalCommerceSystemManufacturers

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemManufacturers : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemManufacturers
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemManufacturers : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemManufacturers =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemManufacturers type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemManufacturers | Initializes a new instance of the ReadExternalCommerceSystemManufacturers class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemManufacturers processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


ReadExternalCommerceSystemManufacturers Constructor

ReadExternalCommerceSystemManufacturers Constructor
Initializes a new instance of the ReadExternalCommerceSystemManufacturers class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemManufacturers()
Public Sub New
public:
ReadExternalCommerceSystemManufacturers()
new : unit -> ReadExternalCommerceSystemManufacturers
See Also

Reference

ReadExternalCommerceSystemManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


ReadExternalCommerceSystemManufacturers Methods

ReadExternalCommerceSystemManufacturers Methods

The ReadExternalCommerceSystemManufacturers type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemManufacturers processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


ReadExternalCommerceSystemManufacturers.Process Method

ReadExternalCommerceSystemManufacturersProcess Method
Executes the business logic of the ReadExternalCommerceSystemManufacturers processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


ReadExternalCommerceSystemManufacturers Properties

ReadExternalCommerceSystemManufacturers Properties

The ReadExternalCommerceSystemManufacturers type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


ReadSitecoreManufacturers Class

ReadSitecoreManufacturers Class
Defines the processor that reads manufacturers from Sitecore. This processor stores Sitecore manufacturers in the custom data. In the SynchronizeManufacturers pipeline, the ResolveManufacturersChanges processor uses Sitecore manufacturers stored in the custom data.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturersReadSitecoreManufacturers

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadSitecoreManufacturers : PipelineProcessor<ServicePipelineArgs>
Public Class ReadSitecoreManufacturers
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ReadSitecoreManufacturers : public PipelineProcessor<ServicePipelineArgs^>
type ReadSitecoreManufacturers =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ReadSitecoreManufacturers type exposes the following members.

Constructors
 | Name | Description
Public method | ReadSitecoreManufacturers | Initializes an instance of the ReadSitecoreManufacturers class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


ReadSitecoreManufacturers Constructor

ReadSitecoreManufacturers Constructor
Initializes an instance of the ReadSitecoreManufacturers class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadSitecoreManufacturers(
    ArtifactRepository<Manufacturer> manufacturerRepository
)
Public Sub New (
    manufacturerRepository As ArtifactRepository(Of Manufacturer)
)
public:
ReadSitecoreManufacturers(
    ArtifactRepository<Manufacturer^>^ manufacturerRepository
)
new :
        manufacturerRepository : ArtifactRepository<Manufacturer> -> ReadSitecoreManufacturers

Parameters

manufacturerRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository Manufacturer
The manufacturer repository.
See Also

Reference

ReadSitecoreManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


ReadSitecoreManufacturers Methods

ReadSitecoreManufacturers Methods

The ReadSitecoreManufacturers type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadSitecoreManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


ReadSitecoreManufacturers.Process Method

ReadSitecoreManufacturersProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadSitecoreManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


ResolveManufacturersChanges Class

ResolveManufacturersChanges Class
Defines the processor that resolves manufacturer changes between Sitecore and external commerce system. This processor uses:
  • Sitecore manufacturers stored in the custom data by the ReadSitecoreManufacturers processor.
  • The external commerce system manufacturers stored in the custom data.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsResolveChangesProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturersResolveManufacturersChanges

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ResolveManufacturersChanges : ResolveChangesProcessor
Public Class ResolveManufacturersChanges
    Inherits ResolveChangesProcessor
public ref class ResolveManufacturersChanges : public ResolveChangesProcessor
type ResolveManufacturersChanges =
    class
        inherit ResolveChangesProcessor
    end

The ResolveManufacturersChanges type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveManufacturersChanges | Initializes an instance of the ResolveManufacturersChanges class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetExternalCommerceSystemEntities | Gets entities stored in external commerce system. (Overrides ResolveChangesProcessorGetExternalCommerceSystemEntities(ServicePipelineArgs).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSitecoreEntities | Gets entities stored in Sitecore. (Overrides ResolveChangesProcessorGetSitecoreEntities(ServicePipelineArgs).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Inherited from ResolveChangesProcessor.)
Protected method | SaveEntities | Saves the entities to the arguments. (Overrides ResolveChangesProcessorSaveEntities(ServicePipelineArgs, IEnumerableProductEntity).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


ResolveManufacturersChanges Constructor

ResolveManufacturersChanges Constructor
Initializes an instance of the ResolveManufacturersChanges class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ResolveManufacturersChanges(
    ISynchronizationStrategy synchronizationStrategy
)
Public Sub New (
    synchronizationStrategy As ISynchronizationStrategy
)
public:
ResolveManufacturersChanges(
    ISynchronizationStrategy^ synchronizationStrategy
)
new :
        synchronizationStrategy : ISynchronizationStrategy -> ResolveManufacturersChanges

Parameters

synchronizationStrategy
Type: Sitecore.Commerce.ProductsISynchronizationStrategy
The synchronization strategy.
See Also

Reference

ResolveManufacturersChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


ResolveManufacturersChanges Methods

ResolveManufacturersChanges Methods

The ResolveManufacturersChanges type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetExternalCommerceSystemEntities | Gets entities stored in external commerce system. (Overrides ResolveChangesProcessorGetExternalCommerceSystemEntities(ServicePipelineArgs).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSitecoreEntities | Gets entities stored in Sitecore. (Overrides ResolveChangesProcessorGetSitecoreEntities(ServicePipelineArgs).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Inherited from ResolveChangesProcessor.)
Protected method | SaveEntities | Saves the entities to the arguments. (Overrides ResolveChangesProcessorSaveEntities(ServicePipelineArgs, IEnumerableProductEntity).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveManufacturersChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


ResolveManufacturersChanges.GetExternalCommerceSystemEntities Method

ResolveManufacturersChangesGetExternalCommerceSystemEntities Method
Gets entities stored in external commerce system.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IEnumerable<ProductEntity> GetExternalCommerceSystemEntities(
    ServicePipelineArgs args
)
Protected Overrides Function GetExternalCommerceSystemEntities (
    args As ServicePipelineArgs
) As IEnumerable(Of ProductEntity)
protected:
virtual IEnumerable<ProductEntity^>^ GetExternalCommerceSystemEntities(
    ServicePipelineArgs^ args
) override
abstract GetExternalCommerceSystemEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>
override GetExternalCommerceSystemEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: IEnumerable ProductEntity
External commerce system entities.
See Also

Reference

ResolveManufacturersChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


ResolveManufacturersChanges.GetSitecoreEntities Method

ResolveManufacturersChangesGetSitecoreEntities Method
Gets entities stored in Sitecore.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IEnumerable<ProductEntity> GetSitecoreEntities(
    ServicePipelineArgs args
)
Protected Overrides Function GetSitecoreEntities (
    args As ServicePipelineArgs
) As IEnumerable(Of ProductEntity)
protected:
virtual IEnumerable<ProductEntity^>^ GetSitecoreEntities(
    ServicePipelineArgs^ args
) override
abstract GetSitecoreEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>
override GetSitecoreEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.

Return Value

Type: IEnumerable ProductEntity
Sitecore entities.
See Also

Reference

ResolveManufacturersChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


ResolveManufacturersChanges.SaveEntities Method

ResolveManufacturersChangesSaveEntities Method
Saves the entities to the arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void SaveEntities(
    ServicePipelineArgs args,
    IEnumerable<ProductEntity> productEntities
)
Protected Overrides Sub SaveEntities (
    args As ServicePipelineArgs,
    productEntities As IEnumerable(Of ProductEntity)
)
protected:
virtual void SaveEntities(
    ServicePipelineArgs^ args,
    IEnumerable<ProductEntity^>^ productEntities
) override
abstract SaveEntities :
        args : ServicePipelineArgs *
        productEntities : IEnumerable<ProductEntity> -> unit
override SaveEntities :
        args : ServicePipelineArgs *
        productEntities : IEnumerable<ProductEntity> -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
productEntities
Type: System.Collections.GenericIEnumerable ProductEntity
The product entities.
See Also

Reference

ResolveManufacturersChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


SaveManufacturersToExternalCommerceSystem Class

SaveManufacturersToExternalCommerceSystem Class
The pipeline processor which saves divisions to external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturersSaveManufacturersToExternalCommerceSystem

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveManufacturersToExternalCommerceSystem : PipelineProcessor<ServicePipelineArgs>
Public Class SaveManufacturersToExternalCommerceSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveManufacturersToExternalCommerceSystem : public PipelineProcessor<ServicePipelineArgs^>
type SaveManufacturersToExternalCommerceSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveManufacturersToExternalCommerceSystem type exposes the following members.

Constructors
 | Name | Description
Public method | SaveManufacturersToExternalCommerceSystem | Initializes a new instance of the SaveManufacturersToExternalCommerceSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


SaveManufacturersToExternalCommerceSystem Constructor

SaveManufacturersToExternalCommerceSystem Constructor
Initializes a new instance of the SaveManufacturersToExternalCommerceSystem class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveManufacturersToExternalCommerceSystem()
Public Sub New
public:
SaveManufacturersToExternalCommerceSystem()
new : unit -> SaveManufacturersToExternalCommerceSystem
See Also

Reference

SaveManufacturersToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


SaveManufacturersToExternalCommerceSystem Methods

SaveManufacturersToExternalCommerceSystem Methods

The SaveManufacturersToExternalCommerceSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveManufacturersToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


SaveManufacturersToExternalCommerceSystem.Process Method

SaveManufacturersToExternalCommerceSystemProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveManufacturersToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


SaveManufacturersToSitecore Class

SaveManufacturersToSitecore Class
Defines the processor of the SaveAllManufacturers pipeline. This class implements the SaveToSitecoreProcessor class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsSaveToSitecoreProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturersSaveManufacturersToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveManufacturersToSitecore : SaveToSitecoreProcessor
Public Class SaveManufacturersToSitecore
    Inherits SaveToSitecoreProcessor
public ref class SaveManufacturersToSitecore : public SaveToSitecoreProcessor
type SaveManufacturersToSitecore =
    class
        inherit SaveToSitecoreProcessor
    end

The SaveManufacturersToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveManufacturersToSitecore | Initializes an instance of the SaveManufacturersToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveManufacturersToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


SaveManufacturersToSitecore Constructor

SaveManufacturersToSitecore Constructor
Initializes an instance of the SaveManufacturersToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveManufacturersToSitecore(
    ArtifactRepository<Manufacturer> manufacturerRepository
)
Public Sub New (
    manufacturerRepository As ArtifactRepository(Of Manufacturer)
)
public:
SaveManufacturersToSitecore(
    ArtifactRepository<Manufacturer^>^ manufacturerRepository
)
new :
        manufacturerRepository : ArtifactRepository<Manufacturer> -> SaveManufacturersToSitecore

Parameters

manufacturerRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository Manufacturer
The manufacturer repository.
See Also

Reference

SaveManufacturersToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


SaveManufacturersToSitecore Methods

SaveManufacturersToSitecore Methods

The SaveManufacturersToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveManufacturersToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveManufacturersToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


SaveManufacturersToSitecore.Process Method

SaveManufacturersToSitecoreProcess Method
Executes the business logic of the SaveManufacturersToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

SaveManufacturersToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


SaveManufacturersToSitecore Properties

SaveManufacturersToSitecore Properties

The SaveManufacturersToSitecore type exposes the following members.

Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveManufacturersToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeManufacturers Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeProduct"]

Classes
 | Class | Description
Public class | RunSynchronizeProductClassifications | Defines the processor that executes the SynchronizeProductClassifications pipeline.
Public class | RunSynchronizeProductDivisions | Defines the processor that executes the SynchronizeProductDivisions pipeline.
Public class | RunSynchronizeProductEntity | The run synchronize product item.
Public class | RunSynchronizeProductManufacturers | Defines the processor that executes the SynchronizeProductManufacturers pipeline.
Public class | RunSynchronizeProductRelations | Defines the processor that executes the SynchronizeProductRelations pipeline.
Public class | RunSynchronizeProductResources | Defines the processor that executes the SynchronizeProductResources pipeline.
Public class | RunSynchronizeProductSpecifications | Defines the processor that executes the SynchronizeProductSpecifications pipeline.
Public class | RunSynchronizeProductTypes | Defines the processor that executes the SynchronizeProductTypes pipeline.


RunSynchronizeProductClassifications Class

RunSynchronizeProductClassifications Class
Defines the processor that executes the SynchronizeProductClassifications pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductClassifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeProductClassifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeProductClassifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeProductClassifications : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeProductClassifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeProductClassifications type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeProductClassifications | Initializes a new instance of the RunSynchronizeProductClassifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductClassifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductClassifications Constructor

RunSynchronizeProductClassifications Constructor
Initializes a new instance of the RunSynchronizeProductClassifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeProductClassifications()
Public Sub New
public:
RunSynchronizeProductClassifications()
new : unit -> RunSynchronizeProductClassifications
See Also

Reference

RunSynchronizeProductClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductClassifications Methods

RunSynchronizeProductClassifications Methods

The RunSynchronizeProductClassifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductClassifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeProductClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductClassifications.Process Method

RunSynchronizeProductClassificationsProcess Method
Executes the business logic of the RunSynchronizeProductClassifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

RunSynchronizeProductClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductClassifications Properties

RunSynchronizeProductClassifications Properties

The RunSynchronizeProductClassifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeProductClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductDivisions Class

RunSynchronizeProductDivisions Class
Defines the processor that executes the SynchronizeProductDivisions pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductDivisions

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeProductDivisions : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeProductDivisions
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeProductDivisions : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeProductDivisions =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeProductDivisions type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeProductDivisions | Initializes a new instance of the RunSynchronizeProductDivisions class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductDivisions processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductDivisions Constructor

RunSynchronizeProductDivisions Constructor
Initializes a new instance of the RunSynchronizeProductDivisions class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeProductDivisions()
Public Sub New
public:
RunSynchronizeProductDivisions()
new : unit -> RunSynchronizeProductDivisions
See Also

Reference

RunSynchronizeProductDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductDivisions Methods

RunSynchronizeProductDivisions Methods

The RunSynchronizeProductDivisions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductDivisions processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeProductDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductDivisions.Process Method

RunSynchronizeProductDivisionsProcess Method
Executes the business logic of the RunSynchronizeProductDivisions processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeProductDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductDivisions Properties

RunSynchronizeProductDivisions Properties

The RunSynchronizeProductDivisions type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeProductDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductEntity Class

RunSynchronizeProductEntity Class
The run synchronize product item.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductEntity

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeProductEntity : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeProductEntity
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeProductEntity : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeProductEntity =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeProductEntity type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeProductEntity | Initializes a new instance of the RunSynchronizeProductEntity class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductEntity Constructor

RunSynchronizeProductEntity Constructor
Initializes a new instance of the RunSynchronizeProductEntity class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeProductEntity()
Public Sub New
public:
RunSynchronizeProductEntity()
new : unit -> RunSynchronizeProductEntity
See Also

Reference

RunSynchronizeProductEntity Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductEntity Methods

RunSynchronizeProductEntity Methods

The RunSynchronizeProductEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeProductEntity Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductEntity.Process Method

RunSynchronizeProductEntityProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeProductEntity Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductEntity Properties

RunSynchronizeProductEntity Properties

The RunSynchronizeProductEntity type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeProductEntity Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductManufacturers Class

RunSynchronizeProductManufacturers Class
Defines the processor that executes the SynchronizeProductManufacturers pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductManufacturers

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeProductManufacturers : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeProductManufacturers
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeProductManufacturers : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeProductManufacturers =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeProductManufacturers type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeProductManufacturers | Initializes a new instance of the RunSynchronizeProductManufacturers class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductManufacturers processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductManufacturers Constructor

RunSynchronizeProductManufacturers Constructor
Initializes a new instance of the RunSynchronizeProductManufacturers class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeProductManufacturers()
Public Sub New
public:
RunSynchronizeProductManufacturers()
new : unit -> RunSynchronizeProductManufacturers
See Also

Reference

RunSynchronizeProductManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductManufacturers Methods

RunSynchronizeProductManufacturers Methods

The RunSynchronizeProductManufacturers type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductManufacturers processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeProductManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductManufacturers.Process Method

RunSynchronizeProductManufacturersProcess Method
Executes the business logic of the RunSynchronizeProductManufacturers processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

RunSynchronizeProductManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductManufacturers Properties

RunSynchronizeProductManufacturers Properties

The RunSynchronizeProductManufacturers type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeProductManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductRelations Class

RunSynchronizeProductRelations Class
Defines the processor that executes the SynchronizeProductRelations pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductRelations

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeProductRelations : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeProductRelations
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeProductRelations : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeProductRelations =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeProductRelations type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeProductRelations | Initializes a new instance of the RunSynchronizeProductRelations class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductRelations processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductRelations Constructor

RunSynchronizeProductRelations Constructor
Initializes a new instance of the RunSynchronizeProductRelations class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeProductRelations()
Public Sub New
public:
RunSynchronizeProductRelations()
new : unit -> RunSynchronizeProductRelations
See Also

Reference

RunSynchronizeProductRelations Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductRelations Methods

RunSynchronizeProductRelations Methods

The RunSynchronizeProductRelations type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductRelations processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeProductRelations Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductRelations.Process Method

RunSynchronizeProductRelationsProcess Method
Executes the business logic of the RunSynchronizeProductRelations processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeProductRelations Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductRelations Properties

RunSynchronizeProductRelations Properties

The RunSynchronizeProductRelations type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeProductRelations Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductResources Class

RunSynchronizeProductResources Class
Defines the processor that executes the SynchronizeProductResources pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductResources

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeProductResources : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeProductResources
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeProductResources : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeProductResources =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeProductResources type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeProductResources | Initializes a new instance of the RunSynchronizeProductResources class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductResources processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductResources Constructor

RunSynchronizeProductResources Constructor
Initializes a new instance of the RunSynchronizeProductResources class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeProductResources()
Public Sub New
public:
RunSynchronizeProductResources()
new : unit -> RunSynchronizeProductResources
See Also

Reference

RunSynchronizeProductResources Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductResources Methods

RunSynchronizeProductResources Methods

The RunSynchronizeProductResources type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductResources processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeProductResources Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductResources.Process Method

RunSynchronizeProductResourcesProcess Method
Executes the business logic of the RunSynchronizeProductResources processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeProductResources Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductResources Properties

RunSynchronizeProductResources Properties

The RunSynchronizeProductResources type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeProductResources Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductSpecifications Class

RunSynchronizeProductSpecifications Class
Defines the processor that executes the SynchronizeProductSpecifications pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeProductSpecifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeProductSpecifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeProductSpecifications : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeProductSpecifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeProductSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeProductSpecifications | Initializes a new instance of the RunSynchronizeProductSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductSpecifications Constructor

RunSynchronizeProductSpecifications Constructor
Initializes a new instance of the RunSynchronizeProductSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeProductSpecifications()
Public Sub New
public:
RunSynchronizeProductSpecifications()
new : unit -> RunSynchronizeProductSpecifications
See Also

Reference

RunSynchronizeProductSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductSpecifications Methods

RunSynchronizeProductSpecifications Methods

The RunSynchronizeProductSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeProductSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductSpecifications.Process Method

RunSynchronizeProductSpecificationsProcess Method
Executes the business logic of the RunSynchronizeProductSpecifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeProductSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductSpecifications Properties

RunSynchronizeProductSpecifications Properties

The RunSynchronizeProductSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeProductSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductTypes Class

RunSynchronizeProductTypes Class
Defines the processor that executes the SynchronizeProductTypes pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRunSynchronizeProductTypes

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeProductTypes : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeProductTypes
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeProductTypes : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeProductTypes =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeProductTypes type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeProductTypes | Initializes a new instance of the RunSynchronizeProductTypes class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductTypes processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductTypes Constructor

RunSynchronizeProductTypes Constructor
Initializes a new instance of the RunSynchronizeProductTypes class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeProductTypes()
Public Sub New
public:
RunSynchronizeProductTypes()
new : unit -> RunSynchronizeProductTypes
See Also

Reference

RunSynchronizeProductTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductTypes Methods

RunSynchronizeProductTypes Methods

The RunSynchronizeProductTypes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductTypes processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeProductTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductTypes.Process Method

RunSynchronizeProductTypesProcess Method
Executes the business logic of the RunSynchronizeProductTypes processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProduct
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeProductTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


RunSynchronizeProductTypes Properties

RunSynchronizeProductTypes Properties

The RunSynchronizeProductTypes type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeProductTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProduct Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications"]

Classes
 | Class | Description
Public class | ReadExternalCommerceSystemProductClassifications | Reads the product classifications from the external commerce system.
Public class | SaveProductClassificationsToSitecore | Saves product classifications in Sitecore.


ReadExternalCommerceSystemProductClassifications Class

ReadExternalCommerceSystemProductClassifications Class
Reads the product classifications from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsReadExternalCommerceSystemProductClassifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemProductClassifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemProductClassifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemProductClassifications : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemProductClassifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemProductClassifications type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemProductClassifications | Initializes a new instance of the ReadExternalCommerceSystemProductClassifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductClassifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications Namespace


ReadExternalCommerceSystemProductClassifications Constructor

ReadExternalCommerceSystemProductClassifications Constructor
Initializes a new instance of the ReadExternalCommerceSystemProductClassifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemProductClassifications()
Public Sub New
public:
ReadExternalCommerceSystemProductClassifications()
new : unit -> ReadExternalCommerceSystemProductClassifications
See Also

Reference

ReadExternalCommerceSystemProductClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications Namespace


ReadExternalCommerceSystemProductClassifications Methods

ReadExternalCommerceSystemProductClassifications Methods

The ReadExternalCommerceSystemProductClassifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductClassifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemProductClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications Namespace


ReadExternalCommerceSystemProductClassifications.Process Method

ReadExternalCommerceSystemProductClassificationsProcess Method
Executes the business logic of the ReadExternalCommerceSystemProductClassifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemProductClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications Namespace


ReadExternalCommerceSystemProductClassifications Properties

ReadExternalCommerceSystemProductClassifications Properties

The ReadExternalCommerceSystemProductClassifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemProductClassifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications Namespace


SaveProductClassificationsToSitecore Class

SaveProductClassificationsToSitecore Class
Saves product classifications in Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSaveProductClassificationsToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveProductClassificationsToSitecore : PipelineProcessor<ServicePipelineArgs>
Public Class SaveProductClassificationsToSitecore
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveProductClassificationsToSitecore : public PipelineProcessor<ServicePipelineArgs^>
type SaveProductClassificationsToSitecore =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveProductClassificationsToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveProductClassificationsToSitecore | Initializes a new instance of the SaveProductClassificationsToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductClassificationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications Namespace


SaveProductClassificationsToSitecore Constructor

SaveProductClassificationsToSitecore Constructor
Initializes a new instance of the SaveProductClassificationsToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveProductClassificationsToSitecore(
    ProductRepository productRepository
)
Public Sub New (
    productRepository As ProductRepository
)
public:
SaveProductClassificationsToSitecore(
    ProductRepository^ productRepository
)
new :
        productRepository : ProductRepository -> SaveProductClassificationsToSitecore

Parameters

productRepository
Type: Sitecore.Commerce.Data.ProductsProductRepository
The product repository.
See Also

Reference

SaveProductClassificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications Namespace


SaveProductClassificationsToSitecore Methods

SaveProductClassificationsToSitecore Methods

The SaveProductClassificationsToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductClassificationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveProductClassificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications Namespace


SaveProductClassificationsToSitecore.Process Method

SaveProductClassificationsToSitecoreProcess Method
Executes the business logic of the SaveProductClassificationsToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveProductClassificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassifications Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications"]

Classes
 | Class | Description
Public class | ReadExternalCommerceSystemProductClassificationsSpecifications | Reads product classification specifications from the external commerce system product.
Public class | SaveProductClassificationsSpecificationsToSitecore | Saves product classification specifications in Sitecore.


ReadExternalCommerceSystemProductClassificationsSpecifications Class

ReadExternalCommerceSystemProductClassificationsSpecifications Class
Reads product classification specifications from the external commerce system product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecificationsReadExternalCommerceSystemProductClassificationsSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemProductClassificationsSpecifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemProductClassificationsSpecifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemProductClassificationsSpecifications : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemProductClassificationsSpecifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemProductClassificationsSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemProductClassificationsSpecifications | Initializes a new instance of the ReadExternalCommerceSystemProductClassificationsSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductClassificationsSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications Namespace


ReadExternalCommerceSystemProductClassificationsSpecifications Constructor

ReadExternalCommerceSystemProductClassificationsSpecifications Constructor
Initializes a new instance of the ReadExternalCommerceSystemProductClassificationsSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemProductClassificationsSpecifications()
Public Sub New
public:
ReadExternalCommerceSystemProductClassificationsSpecifications()
new : unit -> ReadExternalCommerceSystemProductClassificationsSpecifications
See Also

Reference

ReadExternalCommerceSystemProductClassificationsSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications Namespace


ReadExternalCommerceSystemProductClassificationsSpecifications Methods

ReadExternalCommerceSystemProductClassificationsSpecifications Methods

The ReadExternalCommerceSystemProductClassificationsSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductClassificationsSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemProductClassificationsSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications Namespace


ReadExternalCommerceSystemProductClassificationsSpecifications.Process Method

ReadExternalCommerceSystemProductClassificationsSpecificationsProcess Method
Executes the business logic of the ReadExternalCommerceSystemProductClassificationsSpecifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemProductClassificationsSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications Namespace


ReadExternalCommerceSystemProductClassificationsSpecifications Properties

ReadExternalCommerceSystemProductClassificationsSpecifications Properties

The ReadExternalCommerceSystemProductClassificationsSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemProductClassificationsSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications Namespace


SaveProductClassificationsSpecificationsToSitecore Class

SaveProductClassificationsSpecificationsToSitecore Class
Saves product classification specifications in Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecificationsSaveProductClassificationsSpecificationsToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveProductClassificationsSpecificationsToSitecore : PipelineProcessor<ServicePipelineArgs>
Public Class SaveProductClassificationsSpecificationsToSitecore
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveProductClassificationsSpecificationsToSitecore : public PipelineProcessor<ServicePipelineArgs^>
type SaveProductClassificationsSpecificationsToSitecore =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveProductClassificationsSpecificationsToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveProductClassificationsSpecificationsToSitecore | Initializes an instance of the SaveProductClassificationsSpecificationsToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductClassificationsSpecificationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications Namespace


SaveProductClassificationsSpecificationsToSitecore Constructor

SaveProductClassificationsSpecificationsToSitecore Constructor
Initializes an instance of the SaveProductClassificationsSpecificationsToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveProductClassificationsSpecificationsToSitecore(
    ProductRepository productRepository,
    IIdGenerator idGenerator,
    string productClassificationGroupPrefix,
    string productClassificationPrefix,
    string productClassificationSpecificationPrefix
)
Public Sub New (
    productRepository As ProductRepository,
    idGenerator As IIdGenerator,
    productClassificationGroupPrefix As String,
    productClassificationPrefix As String,
    productClassificationSpecificationPrefix As String
)
public:
SaveProductClassificationsSpecificationsToSitecore(
    ProductRepository^ productRepository,
    IIdGenerator^ idGenerator,
    String^ productClassificationGroupPrefix,
    String^ productClassificationPrefix,
    String^ productClassificationSpecificationPrefix
)
new :
        productRepository : ProductRepository *
        idGenerator : IIdGenerator *
        productClassificationGroupPrefix : string *
        productClassificationPrefix : string *
        productClassificationSpecificationPrefix : string -> SaveProductClassificationsSpecificationsToSitecore

Parameters

productRepository
Type: Sitecore.Commerce.Data.ProductsProductRepository
The product repository.
idGenerator
Type: Sitecore.Commerce.Data.ProductsIIdGenerator
The id generator.
productClassificationGroupPrefix
Type: SystemString
The product classification group prefix.
productClassificationPrefix
Type: SystemString
The product classification prefix.
productClassificationSpecificationPrefix
Type: SystemString
The product classifications specifications prefix.
See Also

Reference

SaveProductClassificationsSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications Namespace


SaveProductClassificationsSpecificationsToSitecore Methods

SaveProductClassificationsSpecificationsToSitecore Methods

The SaveProductClassificationsSpecificationsToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductClassificationsSpecificationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveProductClassificationsSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications Namespace


SaveProductClassificationsSpecificationsToSitecore.Process Method

SaveProductClassificationsSpecificationsToSitecoreProcess Method
Executes the business logic of the SaveProductClassificationsSpecificationsToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

SaveProductClassificationsSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductClassificationsSpecifications Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions"]

Classes
 | Class | Description
Public class | ReadExternalCommerceSystemProductDivisions | Reads product divisions from the external commerce system.
Public class | SaveProductDivisionsToSitecore | Defines the processor that saves product divisions in Sitecore. This processor uses the division IDs stored in the custom data by the external commerce system.


ReadExternalCommerceSystemProductDivisions Class

ReadExternalCommerceSystemProductDivisions Class
Reads product divisions from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisionsReadExternalCommerceSystemProductDivisions

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemProductDivisions : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemProductDivisions
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemProductDivisions : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemProductDivisions =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemProductDivisions type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemProductDivisions | Initializes a new instance of the ReadExternalCommerceSystemProductDivisions class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductDivisions processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions Namespace


ReadExternalCommerceSystemProductDivisions Constructor

ReadExternalCommerceSystemProductDivisions Constructor
Initializes a new instance of the ReadExternalCommerceSystemProductDivisions class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemProductDivisions()
Public Sub New
public:
ReadExternalCommerceSystemProductDivisions()
new : unit -> ReadExternalCommerceSystemProductDivisions
See Also

Reference

ReadExternalCommerceSystemProductDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions Namespace


ReadExternalCommerceSystemProductDivisions Methods

ReadExternalCommerceSystemProductDivisions Methods

The ReadExternalCommerceSystemProductDivisions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductDivisions processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemProductDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions Namespace


ReadExternalCommerceSystemProductDivisions.Process Method

ReadExternalCommerceSystemProductDivisionsProcess Method
Executes the business logic of the ReadExternalCommerceSystemProductDivisions processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemProductDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions Namespace


ReadExternalCommerceSystemProductDivisions Properties

ReadExternalCommerceSystemProductDivisions Properties

The ReadExternalCommerceSystemProductDivisions type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemProductDivisions Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions Namespace


SaveProductDivisionsToSitecore Class

SaveProductDivisionsToSitecore Class
Defines the processor that saves product divisions in Sitecore. This processor uses the division IDs stored in the custom data by the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisionsSaveProductDivisionsToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveProductDivisionsToSitecore : PipelineProcessor<ServicePipelineArgs>
Public Class SaveProductDivisionsToSitecore
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveProductDivisionsToSitecore : public PipelineProcessor<ServicePipelineArgs^>
type SaveProductDivisionsToSitecore =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveProductDivisionsToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveProductDivisionsToSitecore | Initializes an instance of the SaveProductDivisionsToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductDivisionsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions Namespace


SaveProductDivisionsToSitecore Constructor

SaveProductDivisionsToSitecore Constructor
Initializes an instance of the SaveProductDivisionsToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveProductDivisionsToSitecore(
    ProductRepository productRepository
)
Public Sub New (
    productRepository As ProductRepository
)
public:
SaveProductDivisionsToSitecore(
    ProductRepository^ productRepository
)
new :
        productRepository : ProductRepository -> SaveProductDivisionsToSitecore

Parameters

productRepository
Type: Sitecore.Commerce.Data.ProductsProductRepository
The product repository.
See Also

Reference

SaveProductDivisionsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions Namespace


SaveProductDivisionsToSitecore Methods

SaveProductDivisionsToSitecore Methods

The SaveProductDivisionsToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductDivisionsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveProductDivisionsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions Namespace


SaveProductDivisionsToSitecore.Process Method

SaveProductDivisionsToSitecoreProcess Method
Executes the business logic of the SaveProductDivisionsToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

SaveProductDivisionsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductDivisions Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity"]

Classes
Class Description
Public class DeleteProductFromSitecore
The delete product from Sitecore processor.
Public class ReadExternalCommerceSystemProduct
Reads a product in the external commerce system.
Public class ReadProductFromSitecore
Defines the processor that reads products from Sitecore. This processor stores the products in the custom data. In the SynchronizeProductEntity pipeline, the ResolveProductChanges processor uses the products in the custom data.
Public class ResolveProductChanges
Defines the processor that resolves product changes. This processor uses:
  • Sitecore products that are stored in the custom data by the ReadProductFromSitecore processor.
  • The products that are stored in the custom data by the external commerce system.
Public class SaveProductToExternalCommerceSystem
The pipeline processor which saves the product to external commerce system.
Public class SaveProductToSitecore
Saves a product in Sitecore. This class implements the SaveToSitecoreProcessor class.


DeleteProductFromSitecore Class

DeleteProductFromSitecore Class
The delete product from Sitecore processor.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntityDeleteProductFromSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DeleteProductFromSitecore : PipelineProcessor<ServicePipelineArgs>
Public Class DeleteProductFromSitecore
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class DeleteProductFromSitecore : public PipelineProcessor<ServicePipelineArgs^>
type DeleteProductFromSitecore =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The DeleteProductFromSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteProductFromSitecore | Initializes an instance of the SaveProductToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


DeleteProductFromSitecore Constructor

DeleteProductFromSitecore Constructor
Initializes an instance of the SaveProductToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DeleteProductFromSitecore(
    ProductRepository productRepository,
    IEntityFactory entityFactory
)
Public Sub New (
    productRepository As ProductRepository,
    entityFactory As IEntityFactory
)
public:
DeleteProductFromSitecore(
    ProductRepository^ productRepository,
    IEntityFactory^ entityFactory
)
new :
        productRepository : ProductRepository *
        entityFactory : IEntityFactory -> DeleteProductFromSitecore

Parameters

productRepository
Type: Sitecore.Commerce.Data.ProductsProductRepository
The product repository.
entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
See Also

Reference

DeleteProductFromSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


DeleteProductFromSitecore Methods

DeleteProductFromSitecore Methods

The DeleteProductFromSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteProductFromSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


DeleteProductFromSitecore.Process Method

DeleteProductFromSitecoreProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

DeleteProductFromSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


ReadExternalCommerceSystemProduct Class

ReadExternalCommerceSystemProduct Class
Reads a product in the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntityReadExternalCommerceSystemProduct

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemProduct : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemProduct
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemProduct : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemProduct =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemProduct type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemProduct | Initializes a new instance of the ReadExternalCommerceSystemProduct class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProduct processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


ReadExternalCommerceSystemProduct Constructor

ReadExternalCommerceSystemProduct Constructor
Initializes a new instance of the ReadExternalCommerceSystemProduct class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemProduct()
Public Sub New
public:
ReadExternalCommerceSystemProduct()
new : unit -> ReadExternalCommerceSystemProduct
See Also

Reference

ReadExternalCommerceSystemProduct Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


ReadExternalCommerceSystemProduct Methods

ReadExternalCommerceSystemProduct Methods

The ReadExternalCommerceSystemProduct type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProduct processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemProduct Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


ReadExternalCommerceSystemProduct.Process Method

ReadExternalCommerceSystemProductProcess Method
Executes the business logic of the ReadExternalCommerceSystemProduct processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemProduct Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


ReadExternalCommerceSystemProduct Properties

ReadExternalCommerceSystemProduct Properties

The ReadExternalCommerceSystemProduct type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemProduct Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


ReadProductFromSitecore Class

ReadProductFromSitecore Class
Defines the processor that reads products from Sitecore. This processor stores the products in the custom data. In the SynchronizeProductEntity pipeline, the ResolveProductChanges processor uses the products in the custom data.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntityReadProductFromSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadProductFromSitecore : PipelineProcessor<ServicePipelineArgs>
Public Class ReadProductFromSitecore
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ReadProductFromSitecore : public PipelineProcessor<ServicePipelineArgs^>
type ReadProductFromSitecore =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ReadProductFromSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | ReadProductFromSitecore | Initializes an instance of the ReadProductFromSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


ReadProductFromSitecore Constructor

ReadProductFromSitecore Constructor
Initializes an instance of the ReadProductFromSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadProductFromSitecore(
    ArtifactRepository<Product> productRepository
)
Public Sub New (
    productRepository As ArtifactRepository(Of Product)
)
public:
ReadProductFromSitecore(
    ArtifactRepository<Product^>^ productRepository
)
new :
        productRepository : ArtifactRepository<Product> -> ReadProductFromSitecore

Parameters

productRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository Product
The product repository
See Also

Reference

ReadProductFromSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


ReadProductFromSitecore Methods

ReadProductFromSitecore Methods

The ReadProductFromSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadProductFromSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


ReadProductFromSitecore.Process Method

ReadProductFromSitecoreProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments
See Also

Reference

ReadProductFromSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


ResolveProductChanges Class

ResolveProductChanges Class
Defines the processor that resolves product changes. This processor uses:
  • Sitecore products that are stored in the custom data by the ReadProductFromSitecore processor.
  • The products that are stored in the custom data by the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntityResolveProductChanges

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ResolveProductChanges : PipelineProcessor<ServicePipelineArgs>
Public Class ResolveProductChanges
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ResolveProductChanges : public PipelineProcessor<ServicePipelineArgs^>
type ResolveProductChanges =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ResolveProductChanges type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveProductChanges | Initializes an instance of the ResolveProductChanges class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


ResolveProductChanges Constructor

ResolveProductChanges Constructor
Initializes an instance of the ResolveProductChanges class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ResolveProductChanges(
    ISynchronizationStrategy synchronizationStrategy
)
Public Sub New (
    synchronizationStrategy As ISynchronizationStrategy
)
public:
ResolveProductChanges(
    ISynchronizationStrategy^ synchronizationStrategy
)
new :
        synchronizationStrategy : ISynchronizationStrategy -> ResolveProductChanges

Parameters

synchronizationStrategy
Type: Sitecore.Commerce.ProductsISynchronizationStrategy
The synchronization strategy.
See Also

Reference

ResolveProductChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


ResolveProductChanges Methods

ResolveProductChanges Methods

The ResolveProductChanges type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveProductChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


ResolveProductChanges.Process Method

ResolveProductChangesProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ResolveProductChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


SaveProductToExternalCommerceSystem Class

SaveProductToExternalCommerceSystem Class
The pipeline processor which saves the product to external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntitySaveProductToExternalCommerceSystem

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveProductToExternalCommerceSystem : RunPipelineProcessor<ServicePipelineArgs>
Public Class SaveProductToExternalCommerceSystem
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class SaveProductToExternalCommerceSystem : public RunPipelineProcessor<ServicePipelineArgs^>
type SaveProductToExternalCommerceSystem =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The SaveProductToExternalCommerceSystem type exposes the following members.

Constructors
 | Name | Description
Public method | SaveProductToExternalCommerceSystem | Initializes a new instance of the SaveProductToExternalCommerceSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


SaveProductToExternalCommerceSystem Constructor

SaveProductToExternalCommerceSystem Constructor
Initializes a new instance of the SaveProductToExternalCommerceSystem class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveProductToExternalCommerceSystem()
Public Sub New
public:
SaveProductToExternalCommerceSystem()
new : unit -> SaveProductToExternalCommerceSystem
See Also

Reference

SaveProductToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


SaveProductToExternalCommerceSystem Methods

SaveProductToExternalCommerceSystem Methods

The SaveProductToExternalCommerceSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveProductToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


SaveProductToExternalCommerceSystem.Process Method

SaveProductToExternalCommerceSystemProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveProductToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


SaveProductToExternalCommerceSystem Properties

SaveProductToExternalCommerceSystem Properties

The SaveProductToExternalCommerceSystem type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

SaveProductToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


SaveProductToSitecore Class

SaveProductToSitecore Class
Saves a product in Sitecore. This class implements the SaveToSitecoreProcessor class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsSaveToSitecoreProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntitySaveProductToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveProductToSitecore : SaveToSitecoreProcessor
Public Class SaveProductToSitecore
    Inherits SaveToSitecoreProcessor
public ref class SaveProductToSitecore : public SaveToSitecoreProcessor
type SaveProductToSitecore =
    class
        inherit SaveToSitecoreProcessor
    end

The SaveProductToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveProductToSitecore | Initializes an instance of the SaveProductToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


SaveProductToSitecore Constructor

SaveProductToSitecore Constructor
Initializes an instance of the SaveProductToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveProductToSitecore(
    ArtifactRepository<Product> productRepository,
    IEntityFactory entityFactory
)
Public Sub New (
    productRepository As ArtifactRepository(Of Product),
    entityFactory As IEntityFactory
)
public:
SaveProductToSitecore(
    ArtifactRepository<Product^>^ productRepository,
    IEntityFactory^ entityFactory
)
new :
        productRepository : ArtifactRepository<Product> *
        entityFactory : IEntityFactory -> SaveProductToSitecore

Parameters

productRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository Product
The product repository.
entityFactory
Type: Sitecore.Commerce.EntitiesIEntityFactory
The entity factory.
See Also

Reference

SaveProductToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


SaveProductToSitecore Methods

SaveProductToSitecore Methods

The SaveProductToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveProductToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


SaveProductToSitecore.Process Method

SaveProductToSitecoreProcess Method
Executes the business logic of the SaveProductToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

SaveProductToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


SaveProductToSitecore Properties

SaveProductToSitecore Properties

The SaveProductToSitecore type exposes the following members.

Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveProductToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductEntity Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications"]

Classes
 | Class | Description
Public class | ReadExternalCommerceSystemProductGlobalSpecifications | Reads product global specifications from the external commerce system product global specifications.
Public class | SaveProductGlobalSpecificationsToSitecore | Saves global specifications of a product in Sitecore.


ReadExternalCommerceSystemProductGlobalSpecifications Class

ReadExternalCommerceSystemProductGlobalSpecifications Class
Reads product global specifications from the external commerce system product global specifications.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecificationsReadExternalCommerceSystemProductGlobalSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemProductGlobalSpecifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemProductGlobalSpecifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemProductGlobalSpecifications : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemProductGlobalSpecifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemProductGlobalSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemProductGlobalSpecifications | Initializes a new instance of the ReadExternalCommerceSystemProductGlobalSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductGlobalSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications Namespace


ReadExternalCommerceSystemProductGlobalSpecifications Constructor

ReadExternalCommerceSystemProductGlobalSpecifications Constructor
Initializes a new instance of the ReadExternalCommerceSystemProductGlobalSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemProductGlobalSpecifications()
Public Sub New
public:
ReadExternalCommerceSystemProductGlobalSpecifications()
new : unit -> ReadExternalCommerceSystemProductGlobalSpecifications
See Also

Reference

ReadExternalCommerceSystemProductGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications Namespace


ReadExternalCommerceSystemProductGlobalSpecifications Methods

ReadExternalCommerceSystemProductGlobalSpecifications Methods

The ReadExternalCommerceSystemProductGlobalSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductGlobalSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemProductGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications Namespace


ReadExternalCommerceSystemProductGlobalSpecifications.Process Method

ReadExternalCommerceSystemProductGlobalSpecificationsProcess Method
Executes the business logic of the ReadExternalCommerceSystemProductGlobalSpecifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemProductGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications Namespace


ReadExternalCommerceSystemProductGlobalSpecifications Properties

ReadExternalCommerceSystemProductGlobalSpecifications Properties

The ReadExternalCommerceSystemProductGlobalSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemProductGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications Namespace


SaveProductGlobalSpecificationsToSitecore Class

SaveProductGlobalSpecificationsToSitecore Class
Saves global specifications of a product in Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecificationsSaveProductGlobalSpecificationsToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveProductGlobalSpecificationsToSitecore : PipelineProcessor<ServicePipelineArgs>
Public Class SaveProductGlobalSpecificationsToSitecore
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveProductGlobalSpecificationsToSitecore : public PipelineProcessor<ServicePipelineArgs^>
type SaveProductGlobalSpecificationsToSitecore =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveProductGlobalSpecificationsToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveProductGlobalSpecificationsToSitecore | Initializes an instance of the SaveProductGlobalSpecificationsToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductGlobalSpecificationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications Namespace


SaveProductGlobalSpecificationsToSitecore Constructor

SaveProductGlobalSpecificationsToSitecore Constructor
Initializes an instance of the SaveProductGlobalSpecificationsToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveProductGlobalSpecificationsToSitecore(
    ProductRepository productRepository,
    IIdGenerator idGenerator,
    string globalSpecificationPrefix
)
Public Sub New (
    productRepository As ProductRepository,
    idGenerator As IIdGenerator,
    globalSpecificationPrefix As String
)
public:
SaveProductGlobalSpecificationsToSitecore(
    ProductRepository^ productRepository,
    IIdGenerator^ idGenerator,
    String^ globalSpecificationPrefix
)
new :
        productRepository : ProductRepository *
        idGenerator : IIdGenerator *
        globalSpecificationPrefix : string -> SaveProductGlobalSpecificationsToSitecore

Parameters

productRepository
Type: Sitecore.Commerce.Data.ProductsProductRepository
The product repository.
idGenerator
Type: Sitecore.Commerce.Data.ProductsIIdGenerator
The id generator.
globalSpecificationPrefix
Type: SystemString
The global specification prefix.
See Also

Reference

SaveProductGlobalSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications Namespace


SaveProductGlobalSpecificationsToSitecore Methods

SaveProductGlobalSpecificationsToSitecore Methods

The SaveProductGlobalSpecificationsToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductGlobalSpecificationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveProductGlobalSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications Namespace


SaveProductGlobalSpecificationsToSitecore.Process Method

SaveProductGlobalSpecificationsToSitecoreProcess Method
Executes the business logic of the SaveProductGlobalSpecificationsToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

SaveProductGlobalSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductGlobalSpecifications Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeProductList"]

Classes
 | Class | Description
Public class | PauseSearchIndexing | The pause search indexing.
Public class | RebuildSearchIndexes | The rebuild search indexes.
Public class | ResumeSearchIndexing | The resume search indexing.
Public class | SearchIndexProcessor | The search index processor base.
Public class | StopSearchIndexing | The stops search indexing.
Public class | SynchronizeProductList | Synchronizes a list of products.
Public class | SynchronizeProductRepositoryBucket | The synchronize product repository bucket.


PauseSearchIndexing Class

PauseSearchIndexing Class
The pause search indexing.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListSearchIndexProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListPauseSearchIndexing

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class PauseSearchIndexing : SearchIndexProcessor
Public Class PauseSearchIndexing
    Inherits SearchIndexProcessor
public ref class PauseSearchIndexing : public SearchIndexProcessor
type PauseSearchIndexing =
    class
        inherit SearchIndexProcessor
    end

The PauseSearchIndexing type exposes the following members.

Constructors
 | Name | Description
Public method | PauseSearchIndexing | Initializes a new instance of the PauseSearchIndexing class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSearchIndexes | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ManageIndex | Processes the specified arguments. (Overrides SearchIndexProcessorManageIndex(ISearchIndex).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IndexNames | Gets or sets the name of the index. (Inherited from SearchIndexProcessor.)
Public property | StatusMessageTemplate | Gets or sets the status message template. (Inherited from SearchIndexProcessor.)
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SearchIndexProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


PauseSearchIndexing Constructor

PauseSearchIndexing Constructor
Initializes a new instance of the PauseSearchIndexing class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PauseSearchIndexing()
Public Sub New
public:
PauseSearchIndexing()
new : unit -> PauseSearchIndexing
See Also

Reference

PauseSearchIndexing Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


PauseSearchIndexing Methods

PauseSearchIndexing Methods

The PauseSearchIndexing type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSearchIndexes | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ManageIndex | Processes the specified arguments. (Overrides SearchIndexProcessorManageIndex(ISearchIndex).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PauseSearchIndexing Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


PauseSearchIndexing.ManageIndex Method

PauseSearchIndexingManageIndex Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void ManageIndex(
    ISearchIndex index
)
Protected Overrides Sub ManageIndex (
    index As ISearchIndex
)
protected:
virtual void ManageIndex(
    ISearchIndex^ index
) override
abstract ManageIndex :
        index : ISearchIndex -> unit
override ManageIndex :
        index : ISearchIndex -> unit

Parameters

index
Type: ISearchIndex
The index.
See Also

Reference

PauseSearchIndexing Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


PauseSearchIndexing Properties

PauseSearchIndexing Properties

The PauseSearchIndexing type exposes the following members.

Properties
 | Name | Description
Public property | IndexNames | Gets or sets the name of the index. (Inherited from SearchIndexProcessor.)
Public property | StatusMessageTemplate | Gets or sets the status message template. (Inherited from SearchIndexProcessor.)
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SearchIndexProcessor.)
Top
See Also

Reference

PauseSearchIndexing Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


RebuildSearchIndexes Class

RebuildSearchIndexes Class
The rebuild search indexes.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListSearchIndexProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListRebuildSearchIndexes

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RebuildSearchIndexes : SearchIndexProcessor
Public Class RebuildSearchIndexes
    Inherits SearchIndexProcessor
public ref class RebuildSearchIndexes : public SearchIndexProcessor
type RebuildSearchIndexes =
    class
        inherit SearchIndexProcessor
    end

The RebuildSearchIndexes type exposes the following members.

Constructors
 | Name | Description
Public method | RebuildSearchIndexes | Initializes a new instance of the RebuildSearchIndexes class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSearchIndexes | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ManageIndex | Processes the specified arguments. (Overrides SearchIndexProcessorManageIndex(ISearchIndex).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IndexNames | Gets or sets the name of the index. (Inherited from SearchIndexProcessor.)
Public property | StatusMessageTemplate | Gets or sets the status message template. (Inherited from SearchIndexProcessor.)
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SearchIndexProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


RebuildSearchIndexes Constructor

RebuildSearchIndexes Constructor
Initializes a new instance of the RebuildSearchIndexes class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RebuildSearchIndexes()
Public Sub New
public:
RebuildSearchIndexes()
new : unit -> RebuildSearchIndexes
See Also

Reference

RebuildSearchIndexes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


RebuildSearchIndexes Methods

RebuildSearchIndexes Methods

The RebuildSearchIndexes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSearchIndexes | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ManageIndex | Processes the specified arguments. (Overrides SearchIndexProcessorManageIndex(ISearchIndex).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RebuildSearchIndexes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


RebuildSearchIndexes.ManageIndex Method

RebuildSearchIndexesManageIndex Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void ManageIndex(
    ISearchIndex index
)
Protected Overrides Sub ManageIndex (
    index As ISearchIndex
)
protected:
virtual void ManageIndex(
    ISearchIndex^ index
) override
abstract ManageIndex :
        index : ISearchIndex -> unit
override ManageIndex :
        index : ISearchIndex -> unit

Parameters

index
Type: ISearchIndex
The index.
See Also

Reference

RebuildSearchIndexes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


RebuildSearchIndexes Properties

RebuildSearchIndexes Properties

The RebuildSearchIndexes type exposes the following members.

Properties
 | Name | Description
Public property | IndexNames | Gets or sets the name of the index. (Inherited from SearchIndexProcessor.)
Public property | StatusMessageTemplate | Gets or sets the status message template. (Inherited from SearchIndexProcessor.)
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SearchIndexProcessor.)
Top
See Also

Reference

RebuildSearchIndexes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


ResumeSearchIndexing Class

ResumeSearchIndexing Class
The resume search indexing.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListSearchIndexProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListResumeSearchIndexing

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ResumeSearchIndexing : SearchIndexProcessor
Public Class ResumeSearchIndexing
    Inherits SearchIndexProcessor
public ref class ResumeSearchIndexing : public SearchIndexProcessor
type ResumeSearchIndexing =
    class
        inherit SearchIndexProcessor
    end

The ResumeSearchIndexing type exposes the following members.

Constructors
 | Name | Description
Public method | ResumeSearchIndexing | Initializes a new instance of the ResumeSearchIndexing class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSearchIndexes | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ManageIndex | Processes the specified arguments. (Overrides SearchIndexProcessorManageIndex(ISearchIndex).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IndexNames | Gets or sets the name of the index. (Inherited from SearchIndexProcessor.)
Public property | StatusMessageTemplate | Gets or sets the status message template. (Inherited from SearchIndexProcessor.)
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SearchIndexProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


ResumeSearchIndexing Constructor

ResumeSearchIndexing Constructor
Initializes a new instance of the ResumeSearchIndexing class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ResumeSearchIndexing()
Public Sub New
public:
ResumeSearchIndexing()
new : unit -> ResumeSearchIndexing
See Also

Reference

ResumeSearchIndexing Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


ResumeSearchIndexing Methods

ResumeSearchIndexing Methods

The ResumeSearchIndexing type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSearchIndexes | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ManageIndex | Processes the specified arguments. (Overrides SearchIndexProcessorManageIndex(ISearchIndex).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResumeSearchIndexing Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


ResumeSearchIndexing.ManageIndex Method

ResumeSearchIndexingManageIndex Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void ManageIndex(
    ISearchIndex index
)
Protected Overrides Sub ManageIndex (
    index As ISearchIndex
)
protected:
virtual void ManageIndex(
    ISearchIndex^ index
) override
abstract ManageIndex :
        index : ISearchIndex -> unit
override ManageIndex :
        index : ISearchIndex -> unit

Parameters

index
Type: ISearchIndex
The index.
See Also

Reference

ResumeSearchIndexing Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


ResumeSearchIndexing Properties

ResumeSearchIndexing Properties

The ResumeSearchIndexing type exposes the following members.

Properties
 | Name | Description
Public property | IndexNames | Gets or sets the name of the index. (Inherited from SearchIndexProcessor.)
Public property | StatusMessageTemplate | Gets or sets the status message template. (Inherited from SearchIndexProcessor.)
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SearchIndexProcessor.)
Top
See Also

Reference

ResumeSearchIndexing Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SearchIndexProcessor Class

SearchIndexProcessor Class
The search index processor base.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListSearchIndexProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListPauseSearchIndexing
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListRebuildSearchIndexes
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListResumeSearchIndexing
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListStopSearchIndexing

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class SearchIndexProcessor : PipelineProcessor<ServicePipelineArgs>
Public MustInherit Class SearchIndexProcessor
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SearchIndexProcessor abstract : public PipelineProcessor<ServicePipelineArgs^>
[<AbstractClassAttribute>]
type SearchIndexProcessor =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SearchIndexProcessor type exposes the following members.

Constructors
 | Name | Description
Protected method | SearchIndexProcessor | Initializes a new instance of the SearchIndexProcessor class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSearchIndexes | Processes the specified arguments.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ManageIndex | Manages the index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IndexNames | Gets or sets the name of the index.
Public property | StatusMessageTemplate | Gets or sets the status message template.
Public property | StatusUpdater | Gets or sets the status updater.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SearchIndexProcessor Constructor

SearchIndexProcessor Constructor
Initializes a new instance of the SearchIndexProcessor class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected SearchIndexProcessor()
Protected Sub New
protected:
SearchIndexProcessor()
new : unit -> SearchIndexProcessor
See Also

Reference

SearchIndexProcessor Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SearchIndexProcessor Methods

SearchIndexProcessor Methods

The SearchIndexProcessor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSearchIndexes | Processes the specified arguments.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ManageIndex | Manages the index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SearchIndexProcessor Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SearchIndexProcessor.GetSearchIndexes Method

SearchIndexProcessorGetSearchIndexes Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual IEnumerable<ISearchIndex> GetSearchIndexes()
Protected Overridable Function GetSearchIndexes As IEnumerable(Of ISearchIndex)
protected:
virtual IEnumerable<ISearchIndex^>^ GetSearchIndexes()
abstract GetSearchIndexes : unit -> IEnumerable<ISearchIndex>
override GetSearchIndexes : unit -> IEnumerable<ISearchIndex>

Return Value

Type: IEnumerable ISearchIndex
The search indexes.
See Also

Reference

SearchIndexProcessor Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SearchIndexProcessor.ManageIndex Method

SearchIndexProcessorManageIndex Method
Manages the index.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract void ManageIndex(
    ISearchIndex index
)
Protected MustOverride Sub ManageIndex (
    index As ISearchIndex
)
protected:
virtual void ManageIndex(
    ISearchIndex^ index
) abstract
abstract ManageIndex :
        index : ISearchIndex -> unit

Parameters

index
Type: ISearchIndex
The index.
See Also

Reference

SearchIndexProcessor Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SearchIndexProcessor.Process Method

SearchIndexProcessorProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SearchIndexProcessor Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SearchIndexProcessor Properties

SearchIndexProcessor Properties

The SearchIndexProcessor type exposes the following members.

Properties
 | Name | Description
Public property | IndexNames | Gets or sets the name of the index.
Public property | StatusMessageTemplate | Gets or sets the status message template.
Public property | StatusUpdater | Gets or sets the status updater.
Top
See Also

Reference

SearchIndexProcessor Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SearchIndexProcessor.IndexNames Property

SearchIndexProcessorIndexNames Property
Gets or sets the name of the index.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string IndexNames { get; set; }
Public Overridable Property IndexNames As String
    Get
    Set
public:
virtual property String^ IndexNames {
    String^ get ();
    void set (String^ value);
}
abstract IndexNames : string with get, set
override IndexNames : string with get, set

Property Value

Type: String
name of the index.
See Also

Reference

SearchIndexProcessor Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SearchIndexProcessor.StatusMessageTemplate Property

SearchIndexProcessorStatusMessageTemplate Property
Gets or sets the status message template.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string StatusMessageTemplate { get; set; }
Public Property StatusMessageTemplate As String
    Get
    Set
public:
property String^ StatusMessageTemplate {
    String^ get ();
    void set (String^ value);
}
member StatusMessageTemplate : string with get, set

Property Value

Type: String
The status message template.
See Also

Reference

SearchIndexProcessor Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SearchIndexProcessor.StatusUpdater Property

SearchIndexProcessorStatusUpdater Property
Gets or sets the status updater.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StatusUpdater StatusUpdater { get; set; }
Public Property StatusUpdater As StatusUpdater
    Get
    Set
public:
property StatusUpdater^ StatusUpdater {
    StatusUpdater^ get ();
    void set (StatusUpdater^ value);
}
member StatusUpdater : StatusUpdater with get, set

Property Value

Type: StatusUpdater
The status updater.
See Also

Reference

SearchIndexProcessor Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


StopSearchIndexing Class

StopSearchIndexing Class
The stops search indexing.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListSearchIndexProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListStopSearchIndexing

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class StopSearchIndexing : SearchIndexProcessor
Public Class StopSearchIndexing
    Inherits SearchIndexProcessor
public ref class StopSearchIndexing : public SearchIndexProcessor
type StopSearchIndexing =
    class
        inherit SearchIndexProcessor
    end

The StopSearchIndexing type exposes the following members.

Constructors
 | Name | Description
Public method | StopSearchIndexing | Initializes a new instance of the StopSearchIndexing class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSearchIndexes | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ManageIndex | Processes the specified arguments. (Overrides SearchIndexProcessorManageIndex(ISearchIndex).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IndexNames | Gets or sets the name of the index. (Inherited from SearchIndexProcessor.)
Public property | StatusMessageTemplate | Gets or sets the status message template. (Inherited from SearchIndexProcessor.)
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SearchIndexProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


StopSearchIndexing Constructor

StopSearchIndexing Constructor
Initializes a new instance of the StopSearchIndexing class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StopSearchIndexing()
Public Sub New
public:
StopSearchIndexing()
new : unit -> StopSearchIndexing
See Also

Reference

StopSearchIndexing Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


StopSearchIndexing Methods

StopSearchIndexing Methods

The StopSearchIndexing type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSearchIndexes | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ManageIndex | Processes the specified arguments. (Overrides SearchIndexProcessorManageIndex(ISearchIndex).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Inherited from SearchIndexProcessor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StopSearchIndexing Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


StopSearchIndexing.ManageIndex Method

StopSearchIndexingManageIndex Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void ManageIndex(
    ISearchIndex index
)
Protected Overrides Sub ManageIndex (
    index As ISearchIndex
)
protected:
virtual void ManageIndex(
    ISearchIndex^ index
) override
abstract ManageIndex :
        index : ISearchIndex -> unit
override ManageIndex :
        index : ISearchIndex -> unit

Parameters

index
Type: ISearchIndex
The index.
See Also

Reference

StopSearchIndexing Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


StopSearchIndexing Properties

StopSearchIndexing Properties

The StopSearchIndexing type exposes the following members.

Properties
 | Name | Description
Public property | IndexNames | Gets or sets the name of the index. (Inherited from SearchIndexProcessor.)
Public property | StatusMessageTemplate | Gets or sets the status message template. (Inherited from SearchIndexProcessor.)
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SearchIndexProcessor.)
Top
See Also

Reference

StopSearchIndexing Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SynchronizeProductList Class

SynchronizeProductList Class
Synchronizes a list of products.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListSynchronizeProductList

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductList : RunPipelineProcessor<ServicePipelineArgs>
Public Class SynchronizeProductList
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class SynchronizeProductList : public RunPipelineProcessor<ServicePipelineArgs^>
type SynchronizeProductList =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The SynchronizeProductList type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductList | Initializes a new instance of the SynchronizeProductList class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SynchronizeProductList processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket].
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SynchronizeProductList Constructor

SynchronizeProductList Constructor
Initializes a new instance of the SynchronizeProductList class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductList()
Public Sub New
public:
SynchronizeProductList()
new : unit -> SynchronizeProductList
See Also

Reference

SynchronizeProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SynchronizeProductList Methods

SynchronizeProductList Methods

The SynchronizeProductList type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SynchronizeProductList processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SynchronizeProductList.Process Method

SynchronizeProductListProcess Method
Executes the business logic of the SynchronizeProductList processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

SynchronizeProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SynchronizeProductList Properties

SynchronizeProductList Properties

The SynchronizeProductList type exposes the following members.

Properties
 | Name | Description
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket].
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

SynchronizeProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SynchronizeProductList.MoveToBucket Property

SynchronizeProductListMoveToBucket Property
Gets or sets a value indicating whether [move to bucket].

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public bool MoveToBucket { get; set; }
Public Property MoveToBucket As Boolean
    Get
    Set
public:
property bool MoveToBucket {
    bool get ();
    void set (bool value);
}
member MoveToBucket : bool with get, set

Property Value

Type: Boolean
true if [move to bucket]; otherwise, false.
See Also

Reference

SynchronizeProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SynchronizeProductRepositoryBucket Class

SynchronizeProductRepositoryBucket Class
The synchronize product repository bucket.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductListSynchronizeProductRepositoryBucket

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductRepositoryBucket : PipelineProcessor<ServicePipelineArgs>
Public Class SynchronizeProductRepositoryBucket
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SynchronizeProductRepositoryBucket : public PipelineProcessor<ServicePipelineArgs^>
type SynchronizeProductRepositoryBucket =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SynchronizeProductRepositoryBucket type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductRepositoryBucket | Initializes a new instance of the SynchronizeProductRepositoryBucket class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ProductRepositoryPath | Gets or sets the product repository path.
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SynchronizeProductRepositoryBucket Constructor

SynchronizeProductRepositoryBucket Constructor
Initializes a new instance of the SynchronizeProductRepositoryBucket class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductRepositoryBucket()
Public Sub New
public:
SynchronizeProductRepositoryBucket()
new : unit -> SynchronizeProductRepositoryBucket
See Also

Reference

SynchronizeProductRepositoryBucket Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SynchronizeProductRepositoryBucket Methods

SynchronizeProductRepositoryBucket Methods

The SynchronizeProductRepositoryBucket type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductRepositoryBucket Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SynchronizeProductRepositoryBucket.Process Method

SynchronizeProductRepositoryBucketProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SynchronizeProductRepositoryBucket Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SynchronizeProductRepositoryBucket Properties

SynchronizeProductRepositoryBucket Properties

The SynchronizeProductRepositoryBucket type exposes the following members.

Properties
 | Name | Description
Public property | ProductRepositoryPath | Gets or sets the product repository path.
Top
See Also

Reference

SynchronizeProductRepositoryBucket Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


SynchronizeProductRepositoryBucket.ProductRepositoryPath Property

SynchronizeProductRepositoryBucketProductRepositoryPath Property
Gets or sets the product repository path.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductList
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ProductRepositoryPath { get; set; }
Public Property ProductRepositoryPath As String
    Get
    Set
public:
property String^ ProductRepositoryPath {
    String^ get ();
    void set (String^ value);
}
member ProductRepositoryPath : string with get, set

Property Value

Type: String
The product repository path.
See Also

Reference

SynchronizeProductRepositoryBucket Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductList Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers"]

Classes
 | Class | Description
Public class | ReadExternalCommerceSystemProductManufacturers | Reads the product manufacturers in the external commerce system.
Public class | SaveProductManufacturersToSitecore | Defines the processor that saves the product manufacturers in Sitecore. This processor uses the manufacturers IDs that are stored in the custom data by the external commerce system.


ReadExternalCommerceSystemProductManufacturers Class

ReadExternalCommerceSystemProductManufacturers Class
Reads the product manufacturers in the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturersReadExternalCommerceSystemProductManufacturers

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemProductManufacturers : PipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemProductManufacturers
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemProductManufacturers : public PipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemProductManufacturers =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemProductManufacturers type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemProductManufacturers | Initializes a new instance of the ReadExternalCommerceSystemProductManufacturers class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductManufacturers processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers Namespace


ReadExternalCommerceSystemProductManufacturers Constructor

ReadExternalCommerceSystemProductManufacturers Constructor
Initializes a new instance of the ReadExternalCommerceSystemProductManufacturers class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemProductManufacturers()
Public Sub New
public:
ReadExternalCommerceSystemProductManufacturers()
new : unit -> ReadExternalCommerceSystemProductManufacturers
See Also

Reference

ReadExternalCommerceSystemProductManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers Namespace


ReadExternalCommerceSystemProductManufacturers Methods

ReadExternalCommerceSystemProductManufacturers Methods

The ReadExternalCommerceSystemProductManufacturers type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductManufacturers processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemProductManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers Namespace


ReadExternalCommerceSystemProductManufacturers.Process Method

ReadExternalCommerceSystemProductManufacturersProcess Method
Executes the business logic of the ReadExternalCommerceSystemProductManufacturers processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemProductManufacturers Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers Namespace


SaveProductManufacturersToSitecore Class

SaveProductManufacturersToSitecore Class
Defines the processor that saves the product manufacturers in Sitecore. This processor uses the manufacturers IDs that are stored in the custom data by the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturersSaveProductManufacturersToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveProductManufacturersToSitecore : PipelineProcessor<ServicePipelineArgs>
Public Class SaveProductManufacturersToSitecore
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveProductManufacturersToSitecore : public PipelineProcessor<ServicePipelineArgs^>
type SaveProductManufacturersToSitecore =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveProductManufacturersToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveProductManufacturersToSitecore | Initializes an instance of the SaveProductManufacturersToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductManufacturersToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers Namespace


SaveProductManufacturersToSitecore Constructor

SaveProductManufacturersToSitecore Constructor
Initializes an instance of the SaveProductManufacturersToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveProductManufacturersToSitecore(
    ProductRepository productRepository
)
Public Sub New (
    productRepository As ProductRepository
)
public:
SaveProductManufacturersToSitecore(
    ProductRepository^ productRepository
)
new :
        productRepository : ProductRepository -> SaveProductManufacturersToSitecore

Parameters

productRepository
Type: Sitecore.Commerce.Data.ProductsProductRepository
The product repository.
See Also

Reference

SaveProductManufacturersToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers Namespace


SaveProductManufacturersToSitecore Methods

SaveProductManufacturersToSitecore Methods

The SaveProductManufacturersToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductManufacturersToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveProductManufacturersToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers Namespace


SaveProductManufacturersToSitecore.Process Method

SaveProductManufacturersToSitecoreProcess Method
Executes the business logic of the SaveProductManufacturersToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args.
See Also

Reference

SaveProductManufacturersToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductManufacturers Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations"]

Classes
 | Class | Description
Public class | ReadExternalCommerceSystemProductRelations | Defines the processor that reads product relations from the external commerce system.
Public class | SaveProductRelationsToSitecore | Defines the processor that saves product relations in Sitecore. This processor uses the related products stored by the external commerce system in the custom data.


ReadExternalCommerceSystemProductRelations Class

ReadExternalCommerceSystemProductRelations Class
Defines the processor that reads product relations from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelationsReadExternalCommerceSystemProductRelations

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemProductRelations : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemProductRelations
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemProductRelations : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemProductRelations =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemProductRelations type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemProductRelations | Initializes a new instance of the ReadExternalCommerceSystemProductRelations class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductRelations processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations Namespace


ReadExternalCommerceSystemProductRelations Constructor

ReadExternalCommerceSystemProductRelations Constructor
Initializes a new instance of the ReadExternalCommerceSystemProductRelations class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemProductRelations()
Public Sub New
public:
ReadExternalCommerceSystemProductRelations()
new : unit -> ReadExternalCommerceSystemProductRelations
See Also

Reference

ReadExternalCommerceSystemProductRelations Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations Namespace


ReadExternalCommerceSystemProductRelations Methods

ReadExternalCommerceSystemProductRelations Methods

The ReadExternalCommerceSystemProductRelations type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductRelations processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemProductRelations Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations Namespace


ReadExternalCommerceSystemProductRelations.Process Method

ReadExternalCommerceSystemProductRelationsProcess Method
Executes the business logic of the ReadExternalCommerceSystemProductRelations processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemProductRelations Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations Namespace


ReadExternalCommerceSystemProductRelations Properties

ReadExternalCommerceSystemProductRelations Properties

The ReadExternalCommerceSystemProductRelations type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemProductRelations Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations Namespace


SaveProductRelationsToSitecore Class

SaveProductRelationsToSitecore Class
Defines the processor that saves product relations in Sitecore. This processor uses the related products stored by the external commerce system in the custom data.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelationsSaveProductRelationsToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveProductRelationsToSitecore : PipelineProcessor<ServicePipelineArgs>
Public Class SaveProductRelationsToSitecore
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveProductRelationsToSitecore : public PipelineProcessor<ServicePipelineArgs^>
type SaveProductRelationsToSitecore =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveProductRelationsToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveProductRelationsToSitecore | Initializes an instance of the SaveProductRelationsToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductRelationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations Namespace


SaveProductRelationsToSitecore Constructor

SaveProductRelationsToSitecore Constructor
Initializes an instance of the SaveProductRelationsToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveProductRelationsToSitecore(
    ProductRepository productRepository
)
Public Sub New (
    productRepository As ProductRepository
)
public:
SaveProductRelationsToSitecore(
    ProductRepository^ productRepository
)
new :
        productRepository : ProductRepository -> SaveProductRelationsToSitecore

Parameters

productRepository
Type: Sitecore.Commerce.Data.ProductsProductRepository
The product repository
See Also

Reference

SaveProductRelationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations Namespace


SaveProductRelationsToSitecore Methods

SaveProductRelationsToSitecore Methods

The SaveProductRelationsToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductRelationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveProductRelationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations Namespace


SaveProductRelationsToSitecore.Process Method

SaveProductRelationsToSitecoreProcess Method
Executes the business logic of the SaveProductRelationsToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments
See Also

Reference

SaveProductRelationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductRelations Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources"]

Classes
 | Class | Description
Public class | ReadExternalCommerceSystemProductResources | Defines the processor that reads product resources from the external commerce system.
Public class | SaveProductResourcesToSitecore | Defines the processor that saves product resources in Sitecore. This processor uses the product repository and resources stored by the external commerce system in the custom data.


ReadExternalCommerceSystemProductResources Class

ReadExternalCommerceSystemProductResources Class
Defines the processor that reads product resources from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductResourcesReadExternalCommerceSystemProductResources

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemProductResources : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemProductResources
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemProductResources : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemProductResources =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemProductResources type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemProductResources | Initializes a new instance of the ReadExternalCommerceSystemProductResources class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductResources processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources Namespace


ReadExternalCommerceSystemProductResources Constructor

ReadExternalCommerceSystemProductResources Constructor
Initializes a new instance of the ReadExternalCommerceSystemProductResources class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemProductResources()
Public Sub New
public:
ReadExternalCommerceSystemProductResources()
new : unit -> ReadExternalCommerceSystemProductResources
See Also

Reference

ReadExternalCommerceSystemProductResources Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources Namespace


ReadExternalCommerceSystemProductResources Methods

ReadExternalCommerceSystemProductResources Methods

The ReadExternalCommerceSystemProductResources type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductResources processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemProductResources Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources Namespace


ReadExternalCommerceSystemProductResources.Process Method

ReadExternalCommerceSystemProductResourcesProcess Method
Executes the business logic of the ReadExternalCommerceSystemProductResources processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemProductResources Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources Namespace


ReadExternalCommerceSystemProductResources Properties

ReadExternalCommerceSystemProductResources Properties

The ReadExternalCommerceSystemProductResources type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemProductResources Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources Namespace


SaveProductResourcesToSitecore Class

SaveProductResourcesToSitecore Class
Defines the processor that saves product resources in Sitecore. This processor uses the product repository and resources stored by the external commerce system in the custom data.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductResourcesSaveProductResourcesToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveProductResourcesToSitecore : PipelineProcessor<ServicePipelineArgs>
Public Class SaveProductResourcesToSitecore
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveProductResourcesToSitecore : public PipelineProcessor<ServicePipelineArgs^>
type SaveProductResourcesToSitecore =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveProductResourcesToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveProductResourcesToSitecore | Initializes an instance of the SaveProductResourcesToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductResourcesToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources Namespace


SaveProductResourcesToSitecore Constructor

SaveProductResourcesToSitecore Constructor
Initializes an instance of the SaveProductResourcesToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveProductResourcesToSitecore(
    ProductRepository productRepository
)
Public Sub New (
    productRepository As ProductRepository
)
public:
SaveProductResourcesToSitecore(
    ProductRepository^ productRepository
)
new :
        productRepository : ProductRepository -> SaveProductResourcesToSitecore

Parameters

productRepository
Type: Sitecore.Commerce.Data.ProductsProductRepository
The product repository.
See Also

Reference

SaveProductResourcesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources Namespace


SaveProductResourcesToSitecore Methods

SaveProductResourcesToSitecore Methods

The SaveProductResourcesToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductResourcesToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveProductResourcesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources Namespace


SaveProductResourcesToSitecore.Process Method

SaveProductResourcesToSitecoreProcess Method
Executes the business logic of the SaveProductResourcesToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args
See Also

Reference

SaveProductResourcesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductResources Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeProducts"]

Classes
 | Class | Description
Public class | DeleteProductsFromSitecore | Deletes products from Sitecore that were deleted from the external system.
Public class | EvaluateProductListUnionToSynchronize | Defines the processor that gets the list resulted from the union of the products in Sitecore and the external commerce system. This processor uses the Sitecore product IDs and the prodcut IDs of the external commerce system stored in the custom data.
Public class | RunGetExternalCommerceSystemProductList | Defines the processor that executes the GetExternalCommerceSystemProductList pipeline.
Public class | RunGetSitecoreProductList | Defines the processor that executes the GetSitecoreProductList pipeline.
Public class | RunSynchronizeArtifacts | Defines the processor that executes the SynchronizeArtifacts pipeline.
Public class | RunSynchronizeProductList | Defines the processor that executes the SynchronizeProductList pipeline.


DeleteProductsFromSitecore Class

DeleteProductsFromSitecore Class
Deletes products from Sitecore that were deleted from the external system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductsDeleteProductsFromSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DeleteProductsFromSitecore : PipelineProcessor<ServicePipelineArgs>
Public Class DeleteProductsFromSitecore
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class DeleteProductsFromSitecore : public PipelineProcessor<ServicePipelineArgs^>
type DeleteProductsFromSitecore =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The DeleteProductsFromSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteProductsFromSitecore | Initializes an instance of the DeleteProductsFromSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


DeleteProductsFromSitecore Constructor

DeleteProductsFromSitecore Constructor
Initializes an instance of the DeleteProductsFromSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DeleteProductsFromSitecore(
    ProductRepository productRepository
)
Public Sub New (
    productRepository As ProductRepository
)
public:
DeleteProductsFromSitecore(
    ProductRepository^ productRepository
)
new :
        productRepository : ProductRepository -> DeleteProductsFromSitecore

Parameters

productRepository
Type: Sitecore.Commerce.Data.ProductsProductRepository
The product repository.
See Also

Reference

DeleteProductsFromSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


DeleteProductsFromSitecore Methods

DeleteProductsFromSitecore Methods

The DeleteProductsFromSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteProductsFromSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


DeleteProductsFromSitecore.Process Method

DeleteProductsFromSitecoreProcess Method
Processes the specified arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

DeleteProductsFromSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


EvaluateProductListUnionToSynchronize Class

EvaluateProductListUnionToSynchronize Class
Defines the processor that gets the list resulted from the union of the products in Sitecore and the external commerce system. This processor uses the Sitecore product IDs and the prodcut IDs of the external commerce system stored in the custom data.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductsEvaluateProductListUnionToSynchronize

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EvaluateProductListUnionToSynchronize : PipelineProcessor<ServicePipelineArgs>
Public Class EvaluateProductListUnionToSynchronize
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class EvaluateProductListUnionToSynchronize : public PipelineProcessor<ServicePipelineArgs^>
type EvaluateProductListUnionToSynchronize =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The EvaluateProductListUnionToSynchronize type exposes the following members.

Constructors
 | Name | Description
Public method | EvaluateProductListUnionToSynchronize | Initializes a new instance of the EvaluateProductListUnionToSynchronize class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the EvaluateProductListUnionToSynchronize processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


EvaluateProductListUnionToSynchronize Constructor

EvaluateProductListUnionToSynchronize Constructor
Initializes a new instance of the EvaluateProductListUnionToSynchronize class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EvaluateProductListUnionToSynchronize()
Public Sub New
public:
EvaluateProductListUnionToSynchronize()
new : unit -> EvaluateProductListUnionToSynchronize
See Also

Reference

EvaluateProductListUnionToSynchronize Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


EvaluateProductListUnionToSynchronize Methods

EvaluateProductListUnionToSynchronize Methods

The EvaluateProductListUnionToSynchronize type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the EvaluateProductListUnionToSynchronize processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EvaluateProductListUnionToSynchronize Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


EvaluateProductListUnionToSynchronize.Process Method

EvaluateProductListUnionToSynchronizeProcess Method
Executes the business logic of the EvaluateProductListUnionToSynchronize processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

EvaluateProductListUnionToSynchronize Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunGetExternalCommerceSystemProductList Class

RunGetExternalCommerceSystemProductList Class
Defines the processor that executes the GetExternalCommerceSystemProductList pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductsRunGetExternalCommerceSystemProductList

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunGetExternalCommerceSystemProductList : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunGetExternalCommerceSystemProductList
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunGetExternalCommerceSystemProductList : public RunPipelineProcessor<ServicePipelineArgs^>
type RunGetExternalCommerceSystemProductList =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunGetExternalCommerceSystemProductList type exposes the following members.

Constructors
 | Name | Description
Public method | RunGetExternalCommerceSystemProductList | Initializes a new instance of the RunGetExternalCommerceSystemProductList class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunGetExternalCommerceSystemProductList processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunGetExternalCommerceSystemProductList Constructor

RunGetExternalCommerceSystemProductList Constructor
Initializes a new instance of the RunGetExternalCommerceSystemProductList class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunGetExternalCommerceSystemProductList()
Public Sub New
public:
RunGetExternalCommerceSystemProductList()
new : unit -> RunGetExternalCommerceSystemProductList
See Also

Reference

RunGetExternalCommerceSystemProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunGetExternalCommerceSystemProductList Methods

RunGetExternalCommerceSystemProductList Methods

The RunGetExternalCommerceSystemProductList type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunGetExternalCommerceSystemProductList processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunGetExternalCommerceSystemProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunGetExternalCommerceSystemProductList.Process Method

RunGetExternalCommerceSystemProductListProcess Method
Executes the business logic of the RunGetExternalCommerceSystemProductList processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunGetExternalCommerceSystemProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunGetExternalCommerceSystemProductList Properties

RunGetExternalCommerceSystemProductList Properties

The RunGetExternalCommerceSystemProductList type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunGetExternalCommerceSystemProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunGetSitecoreProductList Class

RunGetSitecoreProductList Class
Defines the processor that executes the GetSitecoreProductList pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductsRunGetSitecoreProductList

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunGetSitecoreProductList : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunGetSitecoreProductList
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunGetSitecoreProductList : public RunPipelineProcessor<ServicePipelineArgs^>
type RunGetSitecoreProductList =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunGetSitecoreProductList type exposes the following members.

Constructors
 | Name | Description
Public method | RunGetSitecoreProductList | Initializes a new instance of the RunGetSitecoreProductList class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunGetSitecoreProductList processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunGetSitecoreProductList Constructor

RunGetSitecoreProductList Constructor
Initializes a new instance of the RunGetSitecoreProductList class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunGetSitecoreProductList()
Public Sub New
public:
RunGetSitecoreProductList()
new : unit -> RunGetSitecoreProductList
See Also

Reference

RunGetSitecoreProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunGetSitecoreProductList Methods

RunGetSitecoreProductList Methods

The RunGetSitecoreProductList type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunGetSitecoreProductList processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunGetSitecoreProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunGetSitecoreProductList.Process Method

RunGetSitecoreProductListProcess Method
Executes the business logic of the RunGetSitecoreProductList processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunGetSitecoreProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunGetSitecoreProductList Properties

RunGetSitecoreProductList Properties

The RunGetSitecoreProductList type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunGetSitecoreProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunSynchronizeArtifacts Class

RunSynchronizeArtifacts Class
Defines the processor that executes the SynchronizeArtifacts pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductsRunSynchronizeArtifacts

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeArtifacts : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeArtifacts
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeArtifacts : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeArtifacts =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeArtifacts type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeArtifacts | Initializes a new instance of the RunSynchronizeArtifacts class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeArtifacts processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunSynchronizeArtifacts Constructor

RunSynchronizeArtifacts Constructor
Initializes a new instance of the RunSynchronizeArtifacts class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeArtifacts()
Public Sub New
public:
RunSynchronizeArtifacts()
new : unit -> RunSynchronizeArtifacts
See Also

Reference

RunSynchronizeArtifacts Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunSynchronizeArtifacts Methods

RunSynchronizeArtifacts Methods

The RunSynchronizeArtifacts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeArtifacts processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeArtifacts Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunSynchronizeArtifacts.Process Method

RunSynchronizeArtifactsProcess Method
Executes the business logic of the RunSynchronizeArtifacts processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeArtifacts Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunSynchronizeArtifacts Properties

RunSynchronizeArtifacts Properties

The RunSynchronizeArtifacts type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeArtifacts Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunSynchronizeProductList Class

RunSynchronizeProductList Class
Defines the processor that executes the SynchronizeProductList pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductsRunSynchronizeProductList

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeProductList : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeProductList
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeProductList : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeProductList =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeProductList type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeProductList | Initializes a new instance of the RunSynchronizeProductList class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductList processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunSynchronizeProductList Constructor

RunSynchronizeProductList Constructor
Initializes a new instance of the RunSynchronizeProductList class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeProductList()
Public Sub New
public:
RunSynchronizeProductList()
new : unit -> RunSynchronizeProductList
See Also

Reference

RunSynchronizeProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunSynchronizeProductList Methods

RunSynchronizeProductList Methods

The RunSynchronizeProductList type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductList processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunSynchronizeProductList.Process Method

RunSynchronizeProductListProcess Method
Executes the business logic of the RunSynchronizeProductList processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProducts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


RunSynchronizeProductList Properties

RunSynchronizeProductList Properties

The RunSynchronizeProductList type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeProductList Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProducts Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications"]

Classes
 | Class | Description
Public class | RunSynchronizeProductClassificationsSpecifications | Defines the processor that executes the SynchronizeProductClassificationsSpecifications pipeline.
Public class | RunSynchronizeProductGlobalSpecifications | Defines the processor that executes the SynchronizeProductGlobalSpecifications pipeline.
Public class | RunSynchronizeProductTypeSpecifications | Defines the processor that executes the SynchronizeProductTypeSpecifications pipeline.


RunSynchronizeProductClassificationsSpecifications Class

RunSynchronizeProductClassificationsSpecifications Class
Defines the processor that executes the SynchronizeProductClassificationsSpecifications pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecificationsRunSynchronizeProductClassificationsSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeProductClassificationsSpecifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeProductClassificationsSpecifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeProductClassificationsSpecifications : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeProductClassificationsSpecifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeProductClassificationsSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeProductClassificationsSpecifications | Initializes a new instance of the RunSynchronizeProductClassificationsSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductClassificationsSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


RunSynchronizeProductClassificationsSpecifications Constructor

RunSynchronizeProductClassificationsSpecifications Constructor
Initializes a new instance of the RunSynchronizeProductClassificationsSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeProductClassificationsSpecifications()
Public Sub New
public:
RunSynchronizeProductClassificationsSpecifications()
new : unit -> RunSynchronizeProductClassificationsSpecifications
See Also

Reference

RunSynchronizeProductClassificationsSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


RunSynchronizeProductClassificationsSpecifications Methods

RunSynchronizeProductClassificationsSpecifications Methods

The RunSynchronizeProductClassificationsSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductClassificationsSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeProductClassificationsSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


RunSynchronizeProductClassificationsSpecifications.Process Method

RunSynchronizeProductClassificationsSpecificationsProcess Method
Executes the business logic of the RunSynchronizeProductClassificationsSpecifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeProductClassificationsSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


RunSynchronizeProductClassificationsSpecifications Properties

RunSynchronizeProductClassificationsSpecifications Properties

The RunSynchronizeProductClassificationsSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeProductClassificationsSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


RunSynchronizeProductGlobalSpecifications Class

RunSynchronizeProductGlobalSpecifications Class
Defines the processor that executes the SynchronizeProductGlobalSpecifications pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecificationsRunSynchronizeProductGlobalSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeProductGlobalSpecifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeProductGlobalSpecifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeProductGlobalSpecifications : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeProductGlobalSpecifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeProductGlobalSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeProductGlobalSpecifications | Initializes a new instance of the RunSynchronizeProductGlobalSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductGlobalSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


RunSynchronizeProductGlobalSpecifications Constructor

RunSynchronizeProductGlobalSpecifications Constructor
Initializes a new instance of the RunSynchronizeProductGlobalSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeProductGlobalSpecifications()
Public Sub New
public:
RunSynchronizeProductGlobalSpecifications()
new : unit -> RunSynchronizeProductGlobalSpecifications
See Also

Reference

RunSynchronizeProductGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


RunSynchronizeProductGlobalSpecifications Methods

RunSynchronizeProductGlobalSpecifications Methods

The RunSynchronizeProductGlobalSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductGlobalSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeProductGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


RunSynchronizeProductGlobalSpecifications.Process Method

RunSynchronizeProductGlobalSpecificationsProcess Method
Executes the business logic of the RunSynchronizeProductGlobalSpecifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeProductGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


RunSynchronizeProductGlobalSpecifications Properties

RunSynchronizeProductGlobalSpecifications Properties

The RunSynchronizeProductGlobalSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeProductGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


RunSynchronizeProductTypeSpecifications Class

RunSynchronizeProductTypeSpecifications Class
Defines the processor that executes the SynchronizeProductTypeSpecifications pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecificationsRunSynchronizeProductTypeSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeProductTypeSpecifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeProductTypeSpecifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeProductTypeSpecifications : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeProductTypeSpecifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeProductTypeSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeProductTypeSpecifications | Initializes a new instance of the RunSynchronizeProductTypeSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductTypeSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


RunSynchronizeProductTypeSpecifications Constructor

RunSynchronizeProductTypeSpecifications Constructor
Initializes a new instance of the RunSynchronizeProductTypeSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeProductTypeSpecifications()
Public Sub New
public:
RunSynchronizeProductTypeSpecifications()
new : unit -> RunSynchronizeProductTypeSpecifications
See Also

Reference

RunSynchronizeProductTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


RunSynchronizeProductTypeSpecifications Methods

RunSynchronizeProductTypeSpecifications Methods

The RunSynchronizeProductTypeSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeProductTypeSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeProductTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


RunSynchronizeProductTypeSpecifications.Process Method

RunSynchronizeProductTypeSpecificationsProcess Method
Executes the business logic of the RunSynchronizeProductTypeSpecifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeProductTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


RunSynchronizeProductTypeSpecifications Properties

RunSynchronizeProductTypeSpecifications Properties

The RunSynchronizeProductTypeSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeProductTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductSpecifications Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes"]

Classes
 | Class | Description
Public class | ReadExternalCommerceSystemProductTypes | Defines the processor that reads the product types from the external commerce system.
Public class | SaveProductTypesToSitecore | Defines the processor that saves product types in Sitecore. This processor uses the product type IDs stored in the custom data by the external commerce system.


ReadExternalCommerceSystemProductTypes Class

ReadExternalCommerceSystemProductTypes Class
Defines the processor that reads the product types from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypesReadExternalCommerceSystemProductTypes

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemProductTypes : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemProductTypes
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemProductTypes : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemProductTypes =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemProductTypes type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemProductTypes | Initializes a new instance of the ReadExternalCommerceSystemProductTypes class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductTypes processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes Namespace


ReadExternalCommerceSystemProductTypes Constructor

ReadExternalCommerceSystemProductTypes Constructor
Initializes a new instance of the ReadExternalCommerceSystemProductTypes class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemProductTypes()
Public Sub New
public:
ReadExternalCommerceSystemProductTypes()
new : unit -> ReadExternalCommerceSystemProductTypes
See Also

Reference

ReadExternalCommerceSystemProductTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes Namespace


ReadExternalCommerceSystemProductTypes Methods

ReadExternalCommerceSystemProductTypes Methods

The ReadExternalCommerceSystemProductTypes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductTypes processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemProductTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes Namespace


ReadExternalCommerceSystemProductTypes.Process Method

ReadExternalCommerceSystemProductTypesProcess Method
Executes the business logic of the ReadExternalCommerceSystemProductTypes processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemProductTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes Namespace


ReadExternalCommerceSystemProductTypes Properties

ReadExternalCommerceSystemProductTypes Properties

The ReadExternalCommerceSystemProductTypes type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemProductTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes Namespace


SaveProductTypesToSitecore Class

SaveProductTypesToSitecore Class
Defines the processor that saves product types in Sitecore. This processor uses the product type IDs stored in the custom data by the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypesSaveProductTypesToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveProductTypesToSitecore : PipelineProcessor<ServicePipelineArgs>
Public Class SaveProductTypesToSitecore
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveProductTypesToSitecore : public PipelineProcessor<ServicePipelineArgs^>
type SaveProductTypesToSitecore =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveProductTypesToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveProductTypesToSitecore | Initializes an instance of the SaveProductTypesToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductTypesToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes Namespace


SaveProductTypesToSitecore Constructor

SaveProductTypesToSitecore Constructor
Initializes an instance of the SaveProductTypesToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveProductTypesToSitecore(
    ProductRepository productRepository
)
Public Sub New (
    productRepository As ProductRepository
)
public:
SaveProductTypesToSitecore(
    ProductRepository^ productRepository
)
new :
        productRepository : ProductRepository -> SaveProductTypesToSitecore

Parameters

productRepository
Type: Sitecore.Commerce.Data.ProductsProductRepository
The product repository
See Also

Reference

SaveProductTypesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes Namespace


SaveProductTypesToSitecore Methods

SaveProductTypesToSitecore Methods

The SaveProductTypesToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductTypesToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveProductTypesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes Namespace


SaveProductTypesToSitecore.Process Method

SaveProductTypesToSitecoreProcess Method
Executes the business logic of the SaveProductTypesToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The args
See Also

Reference

SaveProductTypesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypes Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications"]

Classes
 | Class | Description
Public class | ReadExternalCommerceSystemProductTypeSpecifications | Defines the processor that reads the specifications of a product type from the external commerce system.
Public class | ReadSitecoreProductTypeSpecifications | The pipeline processor which reads product type specifications from Sitecore.
Public class | ResolveProductTypeSpecificationsChanges | The pipeline processor which resolves product type specification changes between Sitecore and external commerce system.
Public class | SaveProductTypeSpecificationsToExternalCommerceSystem | The pipeline processor which saves divisions to external commerce system.
Public class | SaveProductTypeSpecificationsToSitecore | Defines the processor that saves the specifications of a product type in Sitcore.


ReadExternalCommerceSystemProductTypeSpecifications Class

ReadExternalCommerceSystemProductTypeSpecifications Class
Defines the processor that reads the specifications of a product type from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecificationsReadExternalCommerceSystemProductTypeSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemProductTypeSpecifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemProductTypeSpecifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemProductTypeSpecifications : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemProductTypeSpecifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemProductTypeSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemProductTypeSpecifications | Initializes a new instance of the ReadExternalCommerceSystemProductTypeSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductTypeSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


ReadExternalCommerceSystemProductTypeSpecifications Constructor

ReadExternalCommerceSystemProductTypeSpecifications Constructor
Initializes a new instance of the ReadExternalCommerceSystemProductTypeSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemProductTypeSpecifications()
Public Sub New
public:
ReadExternalCommerceSystemProductTypeSpecifications()
new : unit -> ReadExternalCommerceSystemProductTypeSpecifications
See Also

Reference

ReadExternalCommerceSystemProductTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


ReadExternalCommerceSystemProductTypeSpecifications Methods

ReadExternalCommerceSystemProductTypeSpecifications Methods

The ReadExternalCommerceSystemProductTypeSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemProductTypeSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemProductTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


ReadExternalCommerceSystemProductTypeSpecifications.Process Method

ReadExternalCommerceSystemProductTypeSpecificationsProcess Method
Executes the business logic of the ReadExternalCommerceSystemProductTypeSpecifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemProductTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


ReadExternalCommerceSystemProductTypeSpecifications Properties

ReadExternalCommerceSystemProductTypeSpecifications Properties

The ReadExternalCommerceSystemProductTypeSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemProductTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


ReadSitecoreProductTypeSpecifications Class

ReadSitecoreProductTypeSpecifications Class
The pipeline processor which reads product type specifications from Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecificationsReadSitecoreProductTypeSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadSitecoreProductTypeSpecifications : PipelineProcessor<ServicePipelineArgs>
Public Class ReadSitecoreProductTypeSpecifications
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ReadSitecoreProductTypeSpecifications : public PipelineProcessor<ServicePipelineArgs^>
type ReadSitecoreProductTypeSpecifications =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ReadSitecoreProductTypeSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | ReadSitecoreProductTypeSpecifications | Initializes a new instance of the ReadSitecoreProductTypeSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


ReadSitecoreProductTypeSpecifications Constructor

ReadSitecoreProductTypeSpecifications Constructor
Initializes a new instance of the ReadSitecoreProductTypeSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadSitecoreProductTypeSpecifications()
Public Sub New
public:
ReadSitecoreProductTypeSpecifications()
new : unit -> ReadSitecoreProductTypeSpecifications
See Also

Reference

ReadSitecoreProductTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


ReadSitecoreProductTypeSpecifications Methods

ReadSitecoreProductTypeSpecifications Methods

The ReadSitecoreProductTypeSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadSitecoreProductTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


ReadSitecoreProductTypeSpecifications.Process Method

ReadSitecoreProductTypeSpecificationsProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadSitecoreProductTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


ResolveProductTypeSpecificationsChanges Class

ResolveProductTypeSpecificationsChanges Class
The pipeline processor which resolves product type specification changes between Sitecore and external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecificationsResolveProductTypeSpecificationsChanges

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ResolveProductTypeSpecificationsChanges : PipelineProcessor<ServicePipelineArgs>
Public Class ResolveProductTypeSpecificationsChanges
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ResolveProductTypeSpecificationsChanges : public PipelineProcessor<ServicePipelineArgs^>
type ResolveProductTypeSpecificationsChanges =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ResolveProductTypeSpecificationsChanges type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveProductTypeSpecificationsChanges | Initializes a new instance of the ResolveProductTypeSpecificationsChanges class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


ResolveProductTypeSpecificationsChanges Constructor

ResolveProductTypeSpecificationsChanges Constructor
Initializes a new instance of the ResolveProductTypeSpecificationsChanges class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ResolveProductTypeSpecificationsChanges()
Public Sub New
public:
ResolveProductTypeSpecificationsChanges()
new : unit -> ResolveProductTypeSpecificationsChanges
See Also

Reference

ResolveProductTypeSpecificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


ResolveProductTypeSpecificationsChanges Methods

ResolveProductTypeSpecificationsChanges Methods

The ResolveProductTypeSpecificationsChanges type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveProductTypeSpecificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


ResolveProductTypeSpecificationsChanges.Process Method

ResolveProductTypeSpecificationsChangesProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ResolveProductTypeSpecificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


SaveProductTypeSpecificationsToExternalCommerceSystem Class

SaveProductTypeSpecificationsToExternalCommerceSystem Class
The pipeline processor which saves divisions to external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecificationsSaveProductTypeSpecificationsToExternalCommerceSystem

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveProductTypeSpecificationsToExternalCommerceSystem : PipelineProcessor<ServicePipelineArgs>
Public Class SaveProductTypeSpecificationsToExternalCommerceSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveProductTypeSpecificationsToExternalCommerceSystem : public PipelineProcessor<ServicePipelineArgs^>
type SaveProductTypeSpecificationsToExternalCommerceSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveProductTypeSpecificationsToExternalCommerceSystem type exposes the following members.

Constructors
 | Name | Description
Public method | SaveProductTypeSpecificationsToExternalCommerceSystem | Initializes a new instance of the SaveProductTypeSpecificationsToExternalCommerceSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


SaveProductTypeSpecificationsToExternalCommerceSystem Constructor

SaveProductTypeSpecificationsToExternalCommerceSystem Constructor
Initializes a new instance of the SaveProductTypeSpecificationsToExternalCommerceSystem class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveProductTypeSpecificationsToExternalCommerceSystem()
Public Sub New
public:
SaveProductTypeSpecificationsToExternalCommerceSystem()
new : unit -> SaveProductTypeSpecificationsToExternalCommerceSystem
See Also

Reference

SaveProductTypeSpecificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


SaveProductTypeSpecificationsToExternalCommerceSystem Methods

SaveProductTypeSpecificationsToExternalCommerceSystem Methods

The SaveProductTypeSpecificationsToExternalCommerceSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveProductTypeSpecificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


SaveProductTypeSpecificationsToExternalCommerceSystem.Process Method

SaveProductTypeSpecificationsToExternalCommerceSystemProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveProductTypeSpecificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


SaveProductTypeSpecificationsToSitecore Class

SaveProductTypeSpecificationsToSitecore Class
Defines the processor that saves the specifications of a product type in Sitcore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecificationsSaveProductTypeSpecificationsToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveProductTypeSpecificationsToSitecore : PipelineProcessor<ServicePipelineArgs>
Public Class SaveProductTypeSpecificationsToSitecore
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveProductTypeSpecificationsToSitecore : public PipelineProcessor<ServicePipelineArgs^>
type SaveProductTypeSpecificationsToSitecore =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveProductTypeSpecificationsToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveProductTypeSpecificationsToSitecore | Initializes an instance of the SaveProductTypeSpecificationsToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductTypeSpecificationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


SaveProductTypeSpecificationsToSitecore Constructor

SaveProductTypeSpecificationsToSitecore Constructor
Initializes an instance of the SaveProductTypeSpecificationsToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveProductTypeSpecificationsToSitecore(
    ProductRepository productRepository,
    IIdGenerator idGenerator,
    string productTypePrefix,
    string productTypeSpecificationPrefix
)
Public Sub New (
    productRepository As ProductRepository,
    idGenerator As IIdGenerator,
    productTypePrefix As String,
    productTypeSpecificationPrefix As String
)
public:
SaveProductTypeSpecificationsToSitecore(
    ProductRepository^ productRepository,
    IIdGenerator^ idGenerator,
    String^ productTypePrefix,
    String^ productTypeSpecificationPrefix
)
new :
        productRepository : ProductRepository *
        idGenerator : IIdGenerator *
        productTypePrefix : string *
        productTypeSpecificationPrefix : string -> SaveProductTypeSpecificationsToSitecore

Parameters

productRepository
Type: Sitecore.Commerce.Data.ProductsProductRepository
The product repository.
idGenerator
Type: Sitecore.Commerce.Data.ProductsIIdGenerator
The id generator.
productTypePrefix
Type: SystemString
The product type prefix.
productTypeSpecificationPrefix
Type: SystemString
The product type specification prefix.
See Also

Reference

SaveProductTypeSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


SaveProductTypeSpecificationsToSitecore Methods

SaveProductTypeSpecificationsToSitecore Methods

The SaveProductTypeSpecificationsToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveProductTypeSpecificationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveProductTypeSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


SaveProductTypeSpecificationsToSitecore.Process Method

SaveProductTypeSpecificationsToSitecoreProcess Method
Executes the business logic of the SaveProductTypeSpecificationsToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveProductTypeSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeProductTypeSpecifications Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeResources Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeResources Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeResources"]

Classes
 | Class | Description
Public class | SaveResourcesToSitecore | Defines the processor that saves resources in Sitecore. This class implements the SaveToSitecoreProcessor class. The SaveResourcesToSitecore processor uses the resources stored in the custom data by the external commerce system.


SaveResourcesToSitecore Class

SaveResourcesToSitecore Class
Defines the processor that saves resources in Sitecore. This class implements the SaveToSitecoreProcessor class. The SaveResourcesToSitecore processor uses the resources stored in the custom data by the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsSaveToSitecoreProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeResourcesSaveResourcesToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeResources
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveResourcesToSitecore : SaveToSitecoreProcessor
Public Class SaveResourcesToSitecore
    Inherits SaveToSitecoreProcessor
public ref class SaveResourcesToSitecore : public SaveToSitecoreProcessor
type SaveResourcesToSitecore =
    class
        inherit SaveToSitecoreProcessor
    end

The SaveResourcesToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveResourcesToSitecore | Initializes an instance of the SaveResourcesToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveResourcesToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeResources Namespace


SaveResourcesToSitecore Constructor

SaveResourcesToSitecore Constructor
Initializes an instance of the SaveResourcesToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeResources
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveResourcesToSitecore(
    ArtifactRepository<Resource> resourceRepository
)
Public Sub New (
    resourceRepository As ArtifactRepository(Of Resource)
)
public:
SaveResourcesToSitecore(
    ArtifactRepository<Resource^>^ resourceRepository
)
new :
        resourceRepository : ArtifactRepository<Resource> -> SaveResourcesToSitecore

Parameters

resourceRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository Resource
The repository.
See Also

Reference

SaveResourcesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeResources Namespace


SaveResourcesToSitecore Methods

SaveResourcesToSitecore Methods

The SaveResourcesToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveResourcesToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveResourcesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeResources Namespace


SaveResourcesToSitecore.Process Method

SaveResourcesToSitecoreProcess Method
Executes the business logic of the SaveResourcesToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeResources
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments
See Also

Reference

SaveResourcesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeResources Namespace


SaveResourcesToSitecore Properties

SaveResourcesToSitecore Properties

The SaveResourcesToSitecore type exposes the following members.

Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveResourcesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeResources Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications"]

Classes
 | Class | Description
Public class | RunSynchronizeClassificationSpecifications | Defines the processor that executes the SynchronizeClassificationSpecifications pipeline.
Public class | RunSynchronizeGlobalSpecifications | Defines the processor that executes the SynchronizeGlobalSpecifications pipeline.
Public class | RunSynchronizeTypeSpecifications | Defines the processor that executes the SynchronizeTypeSpecifications pipeline.


RunSynchronizeClassificationSpecifications Class

RunSynchronizeClassificationSpecifications Class
Defines the processor that executes the SynchronizeClassificationSpecifications pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecificationsRunSynchronizeClassificationSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeClassificationSpecifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeClassificationSpecifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeClassificationSpecifications : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeClassificationSpecifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeClassificationSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeClassificationSpecifications | Initializes a new instance of the RunSynchronizeClassificationSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeClassificationSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


RunSynchronizeClassificationSpecifications Constructor

RunSynchronizeClassificationSpecifications Constructor
Initializes a new instance of the RunSynchronizeClassificationSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeClassificationSpecifications()
Public Sub New
public:
RunSynchronizeClassificationSpecifications()
new : unit -> RunSynchronizeClassificationSpecifications
See Also

Reference

RunSynchronizeClassificationSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


RunSynchronizeClassificationSpecifications Methods

RunSynchronizeClassificationSpecifications Methods

The RunSynchronizeClassificationSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeClassificationSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeClassificationSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


RunSynchronizeClassificationSpecifications.Process Method

RunSynchronizeClassificationSpecificationsProcess Method
Executes the business logic of the RunSynchronizeClassificationSpecifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeClassificationSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


RunSynchronizeClassificationSpecifications Properties

RunSynchronizeClassificationSpecifications Properties

The RunSynchronizeClassificationSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeClassificationSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


RunSynchronizeGlobalSpecifications Class

RunSynchronizeGlobalSpecifications Class
Defines the processor that executes the SynchronizeGlobalSpecifications pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecificationsRunSynchronizeGlobalSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeGlobalSpecifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeGlobalSpecifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeGlobalSpecifications : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeGlobalSpecifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeGlobalSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeGlobalSpecifications | Initializes a new instance of the RunSynchronizeGlobalSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeGlobalSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


RunSynchronizeGlobalSpecifications Constructor

RunSynchronizeGlobalSpecifications Constructor
Initializes a new instance of the RunSynchronizeGlobalSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeGlobalSpecifications()
Public Sub New
public:
RunSynchronizeGlobalSpecifications()
new : unit -> RunSynchronizeGlobalSpecifications
See Also

Reference

RunSynchronizeGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


RunSynchronizeGlobalSpecifications Methods

RunSynchronizeGlobalSpecifications Methods

The RunSynchronizeGlobalSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeGlobalSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


RunSynchronizeGlobalSpecifications.Process Method

RunSynchronizeGlobalSpecificationsProcess Method
Executes the business logic of the RunSynchronizeGlobalSpecifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


RunSynchronizeGlobalSpecifications Properties

RunSynchronizeGlobalSpecifications Properties

The RunSynchronizeGlobalSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeGlobalSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


RunSynchronizeTypeSpecifications Class

RunSynchronizeTypeSpecifications Class
Defines the processor that executes the SynchronizeTypeSpecifications pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecificationsRunSynchronizeTypeSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeTypeSpecifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeTypeSpecifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeTypeSpecifications : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeTypeSpecifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeTypeSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeTypeSpecifications | Initializes a new instance of the RunSynchronizeTypeSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeTypeSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


RunSynchronizeTypeSpecifications Constructor

RunSynchronizeTypeSpecifications Constructor
Initializes a new instance of the RunSynchronizeTypeSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeTypeSpecifications()
Public Sub New
public:
RunSynchronizeTypeSpecifications()
new : unit -> RunSynchronizeTypeSpecifications
See Also

Reference

RunSynchronizeTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


RunSynchronizeTypeSpecifications Methods

RunSynchronizeTypeSpecifications Methods

The RunSynchronizeTypeSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeTypeSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


RunSynchronizeTypeSpecifications.Process Method

RunSynchronizeTypeSpecificationsProcess Method
Executes the business logic of the RunSynchronizeTypeSpecifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


RunSynchronizeTypeSpecifications Properties

RunSynchronizeTypeSpecifications Properties

The RunSynchronizeTypeSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeSpecifications Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues"]

Classes
 | Class | Description
Public class | ReadExternalCommerceSystemTypeDefaultValues | Defines the processor that reads the default values of a type from the external commerce system.
Public class | ReadSitecoreTypeDefaultValues | The pipeline processor which reads type default values from Sitecore.
Public class | ResolveTypeDefaultValuesChanges | The pipeline processor which resolves type default values changes between Sitecore and external commerce system.
Public class | SaveTypeDefaultValuesToExternalCommerceSystem | The pipeline processor which saves divisions to external commerce system.
Public class | SaveTypeDefaultValuesToSitecore | Defines the processor that saves the default values of type in Sitecore. This class implements the SaveToSitecoreProcessor class.


ReadExternalCommerceSystemTypeDefaultValues Class

ReadExternalCommerceSystemTypeDefaultValues Class
Defines the processor that reads the default values of a type from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValuesReadExternalCommerceSystemTypeDefaultValues

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemTypeDefaultValues : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemTypeDefaultValues
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemTypeDefaultValues : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemTypeDefaultValues =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemTypeDefaultValues type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemTypeDefaultValues | Initializes a new instance of the ReadExternalCommerceSystemTypeDefaultValues class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemTypeDefaultValues processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


ReadExternalCommerceSystemTypeDefaultValues Constructor

ReadExternalCommerceSystemTypeDefaultValues Constructor
Initializes a new instance of the ReadExternalCommerceSystemTypeDefaultValues class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemTypeDefaultValues()
Public Sub New
public:
ReadExternalCommerceSystemTypeDefaultValues()
new : unit -> ReadExternalCommerceSystemTypeDefaultValues
See Also

Reference

ReadExternalCommerceSystemTypeDefaultValues Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


ReadExternalCommerceSystemTypeDefaultValues Methods

ReadExternalCommerceSystemTypeDefaultValues Methods

The ReadExternalCommerceSystemTypeDefaultValues type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemTypeDefaultValues processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemTypeDefaultValues Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


ReadExternalCommerceSystemTypeDefaultValues.Process Method

ReadExternalCommerceSystemTypeDefaultValuesProcess Method
Executes the business logic of the ReadExternalCommerceSystemTypeDefaultValues processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemTypeDefaultValues Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


ReadExternalCommerceSystemTypeDefaultValues Properties

ReadExternalCommerceSystemTypeDefaultValues Properties

The ReadExternalCommerceSystemTypeDefaultValues type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemTypeDefaultValues Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


ReadSitecoreTypeDefaultValues Class

ReadSitecoreTypeDefaultValues Class
The pipeline processor which reads type default values from Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValuesReadSitecoreTypeDefaultValues

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadSitecoreTypeDefaultValues : PipelineProcessor<ServicePipelineArgs>
Public Class ReadSitecoreTypeDefaultValues
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ReadSitecoreTypeDefaultValues : public PipelineProcessor<ServicePipelineArgs^>
type ReadSitecoreTypeDefaultValues =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ReadSitecoreTypeDefaultValues type exposes the following members.

Constructors
 | Name | Description
Public method | ReadSitecoreTypeDefaultValues | Initializes a new instance of the ReadSitecoreTypeDefaultValues class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


ReadSitecoreTypeDefaultValues Constructor

ReadSitecoreTypeDefaultValues Constructor
Initializes a new instance of the ReadSitecoreTypeDefaultValues class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadSitecoreTypeDefaultValues()
Public Sub New
public:
ReadSitecoreTypeDefaultValues()
new : unit -> ReadSitecoreTypeDefaultValues
See Also

Reference

ReadSitecoreTypeDefaultValues Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


ReadSitecoreTypeDefaultValues Methods

ReadSitecoreTypeDefaultValues Methods

The ReadSitecoreTypeDefaultValues type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadSitecoreTypeDefaultValues Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


ReadSitecoreTypeDefaultValues.Process Method

ReadSitecoreTypeDefaultValuesProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadSitecoreTypeDefaultValues Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


ResolveTypeDefaultValuesChanges Class

ResolveTypeDefaultValuesChanges Class
The pipeline processor which resolves type default values changes between Sitecore and external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValuesResolveTypeDefaultValuesChanges

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ResolveTypeDefaultValuesChanges : PipelineProcessor<ServicePipelineArgs>
Public Class ResolveTypeDefaultValuesChanges
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ResolveTypeDefaultValuesChanges : public PipelineProcessor<ServicePipelineArgs^>
type ResolveTypeDefaultValuesChanges =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ResolveTypeDefaultValuesChanges type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveTypeDefaultValuesChanges | Initializes a new instance of the ResolveTypeDefaultValuesChanges class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


ResolveTypeDefaultValuesChanges Constructor

ResolveTypeDefaultValuesChanges Constructor
Initializes a new instance of the ResolveTypeDefaultValuesChanges class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ResolveTypeDefaultValuesChanges()
Public Sub New
public:
ResolveTypeDefaultValuesChanges()
new : unit -> ResolveTypeDefaultValuesChanges
See Also

Reference

ResolveTypeDefaultValuesChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


ResolveTypeDefaultValuesChanges Methods

ResolveTypeDefaultValuesChanges Methods

The ResolveTypeDefaultValuesChanges type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveTypeDefaultValuesChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


ResolveTypeDefaultValuesChanges.Process Method

ResolveTypeDefaultValuesChangesProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ResolveTypeDefaultValuesChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


SaveTypeDefaultValuesToExternalCommerceSystem Class

SaveTypeDefaultValuesToExternalCommerceSystem Class
The pipeline processor which saves divisions to external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValuesSaveTypeDefaultValuesToExternalCommerceSystem

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveTypeDefaultValuesToExternalCommerceSystem : PipelineProcessor<ServicePipelineArgs>
Public Class SaveTypeDefaultValuesToExternalCommerceSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveTypeDefaultValuesToExternalCommerceSystem : public PipelineProcessor<ServicePipelineArgs^>
type SaveTypeDefaultValuesToExternalCommerceSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveTypeDefaultValuesToExternalCommerceSystem type exposes the following members.

Constructors
 | Name | Description
Public method | SaveTypeDefaultValuesToExternalCommerceSystem | Initializes a new instance of the SaveTypeDefaultValuesToExternalCommerceSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


SaveTypeDefaultValuesToExternalCommerceSystem Constructor

SaveTypeDefaultValuesToExternalCommerceSystem Constructor
Initializes a new instance of the SaveTypeDefaultValuesToExternalCommerceSystem class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveTypeDefaultValuesToExternalCommerceSystem()
Public Sub New
public:
SaveTypeDefaultValuesToExternalCommerceSystem()
new : unit -> SaveTypeDefaultValuesToExternalCommerceSystem
See Also

Reference

SaveTypeDefaultValuesToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


SaveTypeDefaultValuesToExternalCommerceSystem Methods

SaveTypeDefaultValuesToExternalCommerceSystem Methods

The SaveTypeDefaultValuesToExternalCommerceSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveTypeDefaultValuesToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


SaveTypeDefaultValuesToExternalCommerceSystem.Process Method

SaveTypeDefaultValuesToExternalCommerceSystemProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveTypeDefaultValuesToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


SaveTypeDefaultValuesToSitecore Class

SaveTypeDefaultValuesToSitecore Class
Defines the processor that saves the default values of type in Sitecore. This class implements the SaveToSitecoreProcessor class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsSaveToSitecoreProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValuesSaveTypeDefaultValuesToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveTypeDefaultValuesToSitecore : SaveToSitecoreProcessor
Public Class SaveTypeDefaultValuesToSitecore
    Inherits SaveToSitecoreProcessor
public ref class SaveTypeDefaultValuesToSitecore : public SaveToSitecoreProcessor
type SaveTypeDefaultValuesToSitecore =
    class
        inherit SaveToSitecoreProcessor
    end

The SaveTypeDefaultValuesToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveTypeDefaultValuesToSitecore | Initializes an instance of the SaveTypeDefaultValuesToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveTypeDefaultValuesToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


SaveTypeDefaultValuesToSitecore Constructor

SaveTypeDefaultValuesToSitecore Constructor
Initializes an instance of the SaveTypeDefaultValuesToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveTypeDefaultValuesToSitecore(
    TypeRepository productTypeRepository
)
Public Sub New (
    productTypeRepository As TypeRepository
)
public:
SaveTypeDefaultValuesToSitecore(
    TypeRepository^ productTypeRepository
)
new :
        productTypeRepository : TypeRepository -> SaveTypeDefaultValuesToSitecore

Parameters

productTypeRepository
Type: Sitecore.Commerce.Data.ProductsTypeRepository
The product type repository.
See Also

Reference

SaveTypeDefaultValuesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


SaveTypeDefaultValuesToSitecore Methods

SaveTypeDefaultValuesToSitecore Methods

The SaveTypeDefaultValuesToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveTypeDefaultValuesToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveTypeDefaultValuesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


SaveTypeDefaultValuesToSitecore.Process Method

SaveTypeDefaultValuesToSitecoreProcess Method
Executes the business logic of the SaveTypeDefaultValuesToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveTypeDefaultValuesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


SaveTypeDefaultValuesToSitecore Properties

SaveTypeDefaultValuesToSitecore Properties

The SaveTypeDefaultValuesToSitecore type exposes the following members.

Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveTypeDefaultValuesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeDefaultValues Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeTypes"]

Classes
 | Class | Description
Public class | ReadExternalCommerceSystemTypes | Defines the processor that reads types from the external commerce system types.
Public class | ReadSitecoreTypes | Defines the processor which reads types from Sitecore. This processor stores Sitecore product types in the custom data. In the SynchronizeTypes pipeline, the ResolveTypesChanges processor uses Sitecore product types stored by the ReadSitecoreTypes processor in the custom data.
Public class | ResolveTypesChanges | Defines the processor that resolves the type changes between Sitecore and the external commerce system. The ResolveTypesChanges class inherits from the the ResolveChangesProcessor class. The ResolveTypesChanges processor uses the product types stored by Sitecore and the external commerce system in the custom data.
Public class | SaveTypesToExternalCommerceSystem | The pipeline processor which saves divisions to external commerce system.
Public class | SaveTypesToSitecore | Defines the processor that saves types in Sitecore. This class implements the SaveToSitecoreProcessor class.


ReadExternalCommerceSystemTypes Class

ReadExternalCommerceSystemTypes Class
Defines the processor that reads types from the external commerce system types.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeTypesReadExternalCommerceSystemTypes

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemTypes : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemTypes
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemTypes : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemTypes =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemTypes type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemTypes | Initializes a new instance of the ReadExternalCommerceSystemTypes class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemTypes processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


ReadExternalCommerceSystemTypes Constructor

ReadExternalCommerceSystemTypes Constructor
Initializes a new instance of the ReadExternalCommerceSystemTypes class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemTypes()
Public Sub New
public:
ReadExternalCommerceSystemTypes()
new : unit -> ReadExternalCommerceSystemTypes
See Also

Reference

ReadExternalCommerceSystemTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


ReadExternalCommerceSystemTypes Methods

ReadExternalCommerceSystemTypes Methods

The ReadExternalCommerceSystemTypes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemTypes processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


ReadExternalCommerceSystemTypes.Process Method

ReadExternalCommerceSystemTypesProcess Method
Executes the business logic of the ReadExternalCommerceSystemTypes processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


ReadExternalCommerceSystemTypes Properties

ReadExternalCommerceSystemTypes Properties

The ReadExternalCommerceSystemTypes type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


ReadSitecoreTypes Class

ReadSitecoreTypes Class
Defines the processor which reads types from Sitecore. This processor stores Sitecore product types in the custom data. In the SynchronizeTypes pipeline, the ResolveTypesChanges processor uses Sitecore product types stored by the ReadSitecoreTypes processor in the custom data.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeTypesReadSitecoreTypes

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadSitecoreTypes : PipelineProcessor<ServicePipelineArgs>
Public Class ReadSitecoreTypes
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ReadSitecoreTypes : public PipelineProcessor<ServicePipelineArgs^>
type ReadSitecoreTypes =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ReadSitecoreTypes type exposes the following members.

Constructors
 | Name | Description
Public method | ReadSitecoreTypes | Initializes an instance of the ReadSitecoreTypes class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


ReadSitecoreTypes Constructor

ReadSitecoreTypes Constructor
Initializes an instance of the ReadSitecoreTypes class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadSitecoreTypes(
    ArtifactRepository<ProductType> typeRepository
)
Public Sub New (
    typeRepository As ArtifactRepository(Of ProductType)
)
public:
ReadSitecoreTypes(
    ArtifactRepository<ProductType^>^ typeRepository
)
new :
        typeRepository : ArtifactRepository<ProductType> -> ReadSitecoreTypes

Parameters

typeRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository ProductType
The type repository
See Also

Reference

ReadSitecoreTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


ReadSitecoreTypes Methods

ReadSitecoreTypes Methods

The ReadSitecoreTypes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadSitecoreTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


ReadSitecoreTypes.Process Method

ReadSitecoreTypesProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments
See Also

Reference

ReadSitecoreTypes Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


ResolveTypesChanges Class

ResolveTypesChanges Class
Defines the processor that resolves the type changes between Sitecore and the external commerce system. The ResolveTypesChanges class inherits from the the ResolveChangesProcessor class. The ResolveTypesChanges processor uses the product types stored by Sitecore and the external commerce system in the custom data.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsResolveChangesProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeTypesResolveTypesChanges

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ResolveTypesChanges : ResolveChangesProcessor
Public Class ResolveTypesChanges
    Inherits ResolveChangesProcessor
public ref class ResolveTypesChanges : public ResolveChangesProcessor
type ResolveTypesChanges =
    class
        inherit ResolveChangesProcessor
    end

The ResolveTypesChanges type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveTypesChanges | Initializes an instance of the ResolveTypesChanges class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetExternalCommerceSystemEntities | Gets entities stored in external commerce system. (Overrides ResolveChangesProcessorGetExternalCommerceSystemEntities(ServicePipelineArgs).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSitecoreEntities | Gets entities stored in Sitecore. (Overrides ResolveChangesProcessorGetSitecoreEntities(ServicePipelineArgs).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Inherited from ResolveChangesProcessor.)
Protected method | SaveEntities | Saves the entities to the arguments. (Overrides ResolveChangesProcessorSaveEntities(ServicePipelineArgs, IEnumerableProductEntity).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


ResolveTypesChanges Constructor

ResolveTypesChanges Constructor
Initializes an instance of the ResolveTypesChanges class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ResolveTypesChanges(
    ISynchronizationStrategy synchronizationStrategy
)
Public Sub New (
    synchronizationStrategy As ISynchronizationStrategy
)
public:
ResolveTypesChanges(
    ISynchronizationStrategy^ synchronizationStrategy
)
new :
        synchronizationStrategy : ISynchronizationStrategy -> ResolveTypesChanges

Parameters

synchronizationStrategy
Type: Sitecore.Commerce.ProductsISynchronizationStrategy
The synchronization strategy.
See Also

Reference

ResolveTypesChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


ResolveTypesChanges Methods

ResolveTypesChanges Methods

The ResolveTypesChanges type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetExternalCommerceSystemEntities | Gets entities stored in external commerce system. (Overrides ResolveChangesProcessorGetExternalCommerceSystemEntities(ServicePipelineArgs).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSitecoreEntities | Gets entities stored in Sitecore. (Overrides ResolveChangesProcessorGetSitecoreEntities(ServicePipelineArgs).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Inherited from ResolveChangesProcessor.)
Protected method | SaveEntities | Saves the entities to the arguments. (Overrides ResolveChangesProcessorSaveEntities(ServicePipelineArgs, IEnumerableProductEntity).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveTypesChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


ResolveTypesChanges.GetExternalCommerceSystemEntities Method

ResolveTypesChangesGetExternalCommerceSystemEntities Method
Gets entities stored in external commerce system.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IEnumerable<ProductEntity> GetExternalCommerceSystemEntities(
    ServicePipelineArgs args
)
Protected Overrides Function GetExternalCommerceSystemEntities (
    args As ServicePipelineArgs
) As IEnumerable(Of ProductEntity)
protected:
virtual IEnumerable<ProductEntity^>^ GetExternalCommerceSystemEntities(
    ServicePipelineArgs^ args
) override
abstract GetExternalCommerceSystemEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>
override GetExternalCommerceSystemEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments

Return Value

Type: IEnumerable ProductEntity
External commerce system entities
See Also

Reference

ResolveTypesChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


ResolveTypesChanges.GetSitecoreEntities Method

ResolveTypesChangesGetSitecoreEntities Method
Gets entities stored in Sitecore.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IEnumerable<ProductEntity> GetSitecoreEntities(
    ServicePipelineArgs args
)
Protected Overrides Function GetSitecoreEntities (
    args As ServicePipelineArgs
) As IEnumerable(Of ProductEntity)
protected:
virtual IEnumerable<ProductEntity^>^ GetSitecoreEntities(
    ServicePipelineArgs^ args
) override
abstract GetSitecoreEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>
override GetSitecoreEntities :
        args : ServicePipelineArgs -> IEnumerable<ProductEntity>

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments

Return Value

Type: IEnumerable ProductEntity
Sitecore entities
See Also

Reference

ResolveTypesChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


ResolveTypesChanges.SaveEntities Method

ResolveTypesChangesSaveEntities Method
Saves the entities to the arguments.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void SaveEntities(
    ServicePipelineArgs args,
    IEnumerable<ProductEntity> productEntities
)
Protected Overrides Sub SaveEntities (
    args As ServicePipelineArgs,
    productEntities As IEnumerable(Of ProductEntity)
)
protected:
virtual void SaveEntities(
    ServicePipelineArgs^ args,
    IEnumerable<ProductEntity^>^ productEntities
) override
abstract SaveEntities :
        args : ServicePipelineArgs *
        productEntities : IEnumerable<ProductEntity> -> unit
override SaveEntities :
        args : ServicePipelineArgs *
        productEntities : IEnumerable<ProductEntity> -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments
productEntities
Type: System.Collections.GenericIEnumerable ProductEntity
The product entities
See Also

Reference

ResolveTypesChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


SaveTypesToExternalCommerceSystem Class

SaveTypesToExternalCommerceSystem Class
The pipeline processor which saves divisions to external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeTypesSaveTypesToExternalCommerceSystem

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveTypesToExternalCommerceSystem : PipelineProcessor<ServicePipelineArgs>
Public Class SaveTypesToExternalCommerceSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveTypesToExternalCommerceSystem : public PipelineProcessor<ServicePipelineArgs^>
type SaveTypesToExternalCommerceSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveTypesToExternalCommerceSystem type exposes the following members.

Constructors
 | Name | Description
Public method | SaveTypesToExternalCommerceSystem | Initializes a new instance of the SaveTypesToExternalCommerceSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


SaveTypesToExternalCommerceSystem Constructor

SaveTypesToExternalCommerceSystem Constructor
Initializes a new instance of the SaveTypesToExternalCommerceSystem class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveTypesToExternalCommerceSystem()
Public Sub New
public:
SaveTypesToExternalCommerceSystem()
new : unit -> SaveTypesToExternalCommerceSystem
See Also

Reference

SaveTypesToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


SaveTypesToExternalCommerceSystem Methods

SaveTypesToExternalCommerceSystem Methods

The SaveTypesToExternalCommerceSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveTypesToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


SaveTypesToExternalCommerceSystem.Process Method

SaveTypesToExternalCommerceSystemProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveTypesToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


SaveTypesToSitecore Class

SaveTypesToSitecore Class
Defines the processor that saves types in Sitecore. This class implements the SaveToSitecoreProcessor class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsSaveToSitecoreProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeTypesSaveTypesToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveTypesToSitecore : SaveToSitecoreProcessor
Public Class SaveTypesToSitecore
    Inherits SaveToSitecoreProcessor
public ref class SaveTypesToSitecore : public SaveToSitecoreProcessor
type SaveTypesToSitecore =
    class
        inherit SaveToSitecoreProcessor
    end

The SaveTypesToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveTypesToSitecore | Initializes an instance of the SaveTypesToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveTypesToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


SaveTypesToSitecore Constructor

SaveTypesToSitecore Constructor
Initializes an instance of the SaveTypesToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveTypesToSitecore(
    ArtifactRepository<ProductType> productTypeRepository
)
Public Sub New (
    productTypeRepository As ArtifactRepository(Of ProductType)
)
public:
SaveTypesToSitecore(
    ArtifactRepository<ProductType^>^ productTypeRepository
)
new :
        productTypeRepository : ArtifactRepository<ProductType> -> SaveTypesToSitecore

Parameters

productTypeRepository
Type: Sitecore.Commerce.Data.ProductsArtifactRepository ProductType
The product type repository.
See Also

Reference

SaveTypesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


SaveTypesToSitecore Methods

SaveTypesToSitecore Methods

The SaveTypesToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveTypesToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveTypesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


SaveTypesToSitecore.Process Method

SaveTypesToSitecoreProcess Method
Executes the business logic of the SaveTypesToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypes
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveTypesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


SaveTypesToSitecore Properties

SaveTypesToSitecore Properties

The SaveTypesToSitecore type exposes the following members.

Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveTypesToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypes Namespace


Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace

Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications"]

Classes
 | Class | Description
Public class | ReadExternalCommerceSystemTypeSpecifications | Defines the processor that reads type specifications from the external commerce system.
Public class | ReadSitecoreTypeSpecifications | The pipeline processor which reads type specifications from Sitecore.
Public class | ResolveTypeSpecificationsChanges | The pipeline processor which resolves type specifications changes between Sitecore and external commerce system.
Public class | RunSynchronizeTypeDefaultValues | Defines the processor that execute the SynchronizeTypeDefaultValues pipeline.
Public class | SaveTypeSpecificationsToExternalCommerceSystem | The pipeline processor which saves divisions to external commerce system.
Public class | SaveTypeSpecificationsToSitecore | Defines the processor that saves type specifications in Sitecore. This class implements the SaveToSitecoreProcessor class.


ReadExternalCommerceSystemTypeSpecifications Class

ReadExternalCommerceSystemTypeSpecifications Class
Defines the processor that reads type specifications from the external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecificationsReadExternalCommerceSystemTypeSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadExternalCommerceSystemTypeSpecifications : RunPipelineProcessor<ServicePipelineArgs>
Public Class ReadExternalCommerceSystemTypeSpecifications
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class ReadExternalCommerceSystemTypeSpecifications : public RunPipelineProcessor<ServicePipelineArgs^>
type ReadExternalCommerceSystemTypeSpecifications =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The ReadExternalCommerceSystemTypeSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | ReadExternalCommerceSystemTypeSpecifications | Initializes a new instance of the ReadExternalCommerceSystemTypeSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemTypeSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


ReadExternalCommerceSystemTypeSpecifications Constructor

ReadExternalCommerceSystemTypeSpecifications Constructor
Initializes a new instance of the ReadExternalCommerceSystemTypeSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadExternalCommerceSystemTypeSpecifications()
Public Sub New
public:
ReadExternalCommerceSystemTypeSpecifications()
new : unit -> ReadExternalCommerceSystemTypeSpecifications
See Also

Reference

ReadExternalCommerceSystemTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


ReadExternalCommerceSystemTypeSpecifications Methods

ReadExternalCommerceSystemTypeSpecifications Methods

The ReadExternalCommerceSystemTypeSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the ReadExternalCommerceSystemTypeSpecifications processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadExternalCommerceSystemTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


ReadExternalCommerceSystemTypeSpecifications.Process Method

ReadExternalCommerceSystemTypeSpecificationsProcess Method
Executes the business logic of the ReadExternalCommerceSystemTypeSpecifications processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadExternalCommerceSystemTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


ReadExternalCommerceSystemTypeSpecifications Properties

ReadExternalCommerceSystemTypeSpecifications Properties

The ReadExternalCommerceSystemTypeSpecifications type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

ReadExternalCommerceSystemTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


ReadSitecoreTypeSpecifications Class

ReadSitecoreTypeSpecifications Class
The pipeline processor which reads type specifications from Sitecore.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecificationsReadSitecoreTypeSpecifications

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ReadSitecoreTypeSpecifications : PipelineProcessor<ServicePipelineArgs>
Public Class ReadSitecoreTypeSpecifications
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ReadSitecoreTypeSpecifications : public PipelineProcessor<ServicePipelineArgs^>
type ReadSitecoreTypeSpecifications =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ReadSitecoreTypeSpecifications type exposes the following members.

Constructors
 | Name | Description
Public method | ReadSitecoreTypeSpecifications | Initializes a new instance of the ReadSitecoreTypeSpecifications class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


ReadSitecoreTypeSpecifications Constructor

ReadSitecoreTypeSpecifications Constructor
Initializes a new instance of the ReadSitecoreTypeSpecifications class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ReadSitecoreTypeSpecifications()
Public Sub New
public:
ReadSitecoreTypeSpecifications()
new : unit -> ReadSitecoreTypeSpecifications
See Also

Reference

ReadSitecoreTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


ReadSitecoreTypeSpecifications Methods

ReadSitecoreTypeSpecifications Methods

The ReadSitecoreTypeSpecifications type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadSitecoreTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


ReadSitecoreTypeSpecifications.Process Method

ReadSitecoreTypeSpecificationsProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ReadSitecoreTypeSpecifications Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


ResolveTypeSpecificationsChanges Class

ResolveTypeSpecificationsChanges Class
The pipeline processor which resolves type specifications changes between Sitecore and external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecificationsResolveTypeSpecificationsChanges

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ResolveTypeSpecificationsChanges : PipelineProcessor<ServicePipelineArgs>
Public Class ResolveTypeSpecificationsChanges
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class ResolveTypeSpecificationsChanges : public PipelineProcessor<ServicePipelineArgs^>
type ResolveTypeSpecificationsChanges =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The ResolveTypeSpecificationsChanges type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveTypeSpecificationsChanges | Initializes a new instance of the ResolveTypeSpecificationsChanges class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


ResolveTypeSpecificationsChanges Constructor

ResolveTypeSpecificationsChanges Constructor
Initializes a new instance of the ResolveTypeSpecificationsChanges class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ResolveTypeSpecificationsChanges()
Public Sub New
public:
ResolveTypeSpecificationsChanges()
new : unit -> ResolveTypeSpecificationsChanges
See Also

Reference

ResolveTypeSpecificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


ResolveTypeSpecificationsChanges Methods

ResolveTypeSpecificationsChanges Methods

The ResolveTypeSpecificationsChanges type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveTypeSpecificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


ResolveTypeSpecificationsChanges.Process Method

ResolveTypeSpecificationsChangesProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

ResolveTypeSpecificationsChanges Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


RunSynchronizeTypeDefaultValues Class

RunSynchronizeTypeDefaultValues Class
Defines the processor that execute the SynchronizeTypeDefaultValues pipeline.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.PipelinesRunPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecificationsRunSynchronizeTypeDefaultValues

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RunSynchronizeTypeDefaultValues : RunPipelineProcessor<ServicePipelineArgs>
Public Class RunSynchronizeTypeDefaultValues
    Inherits RunPipelineProcessor(Of ServicePipelineArgs)
public ref class RunSynchronizeTypeDefaultValues : public RunPipelineProcessor<ServicePipelineArgs^>
type RunSynchronizeTypeDefaultValues =
    class
        inherit RunPipelineProcessor<ServicePipelineArgs>
    end

The RunSynchronizeTypeDefaultValues type exposes the following members.

Constructors
 | Name | Description
Public method | RunSynchronizeTypeDefaultValues | Initializes a new instance of the RunSynchronizeTypeDefaultValues class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeTypeDefaultValues processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


RunSynchronizeTypeDefaultValues Constructor

RunSynchronizeTypeDefaultValues Constructor
Initializes a new instance of the RunSynchronizeTypeDefaultValues class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RunSynchronizeTypeDefaultValues()
Public Sub New
public:
RunSynchronizeTypeDefaultValues()
new : unit -> RunSynchronizeTypeDefaultValues
See Also

Reference

RunSynchronizeTypeDefaultValues Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


RunSynchronizeTypeDefaultValues Methods

RunSynchronizeTypeDefaultValues Methods

The RunSynchronizeTypeDefaultValues type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the RunSynchronizeTypeDefaultValues processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Protected method | RunPipeline(String, ServicePipelineArgs) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Protected method | RunPipeline(String, ServicePipelineArgs, ServiceProviderRequest) | Runs the pipeline. (Inherited from RunPipelineProcessorTArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunSynchronizeTypeDefaultValues Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


RunSynchronizeTypeDefaultValues.Process Method

RunSynchronizeTypeDefaultValuesProcess Method
Executes the business logic of the RunSynchronizeTypeDefaultValues processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

RunSynchronizeTypeDefaultValues Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


RunSynchronizeTypeDefaultValues Properties

RunSynchronizeTypeDefaultValues Properties

The RunSynchronizeTypeDefaultValues type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from RunPipelineProcessorTArgs.)
Top
See Also

Reference

RunSynchronizeTypeDefaultValues Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


SaveTypeSpecificationsToExternalCommerceSystem Class

SaveTypeSpecificationsToExternalCommerceSystem Class
The pipeline processor which saves divisions to external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecificationsSaveTypeSpecificationsToExternalCommerceSystem

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveTypeSpecificationsToExternalCommerceSystem : PipelineProcessor<ServicePipelineArgs>
Public Class SaveTypeSpecificationsToExternalCommerceSystem
    Inherits PipelineProcessor(Of ServicePipelineArgs)
public ref class SaveTypeSpecificationsToExternalCommerceSystem : public PipelineProcessor<ServicePipelineArgs^>
type SaveTypeSpecificationsToExternalCommerceSystem =
    class
        inherit PipelineProcessor<ServicePipelineArgs>
    end

The SaveTypeSpecificationsToExternalCommerceSystem type exposes the following members.

Constructors
 | Name | Description
Public method | SaveTypeSpecificationsToExternalCommerceSystem | Initializes a new instance of the SaveTypeSpecificationsToExternalCommerceSystem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


SaveTypeSpecificationsToExternalCommerceSystem Constructor

SaveTypeSpecificationsToExternalCommerceSystem Constructor
Initializes a new instance of the SaveTypeSpecificationsToExternalCommerceSystem class

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveTypeSpecificationsToExternalCommerceSystem()
Public Sub New
public:
SaveTypeSpecificationsToExternalCommerceSystem()
new : unit -> SaveTypeSpecificationsToExternalCommerceSystem
See Also

Reference

SaveTypeSpecificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


SaveTypeSpecificationsToExternalCommerceSystem Methods

SaveTypeSpecificationsToExternalCommerceSystem Methods

The SaveTypeSpecificationsToExternalCommerceSystem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the request. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveTypeSpecificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


SaveTypeSpecificationsToExternalCommerceSystem.Process Method

SaveTypeSpecificationsToExternalCommerceSystemProcess Method
Processes the request.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveTypeSpecificationsToExternalCommerceSystem Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


SaveTypeSpecificationsToSitecore Class

SaveTypeSpecificationsToSitecore Class
Defines the processor that saves type specifications in Sitecore. This class implements the SaveToSitecoreProcessor class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.PipelinesPipelineProcessor ServicePipelineArgs
Sitecore.Commerce.Pipelines.ProductsSaveToSitecoreProcessor
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecificationsSaveTypeSpecificationsToSitecore

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveTypeSpecificationsToSitecore : SaveToSitecoreProcessor
Public Class SaveTypeSpecificationsToSitecore
    Inherits SaveToSitecoreProcessor
public ref class SaveTypeSpecificationsToSitecore : public SaveToSitecoreProcessor
type SaveTypeSpecificationsToSitecore =
    class
        inherit SaveToSitecoreProcessor
    end

The SaveTypeSpecificationsToSitecore type exposes the following members.

Constructors
 | Name | Description
Public method | SaveTypeSpecificationsToSitecore | Initializes an instance of the SaveTypeSpecificationsToSitecore class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveTypeSpecificationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


SaveTypeSpecificationsToSitecore Constructor

SaveTypeSpecificationsToSitecore Constructor
Initializes an instance of the SaveTypeSpecificationsToSitecore class.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveTypeSpecificationsToSitecore(
    TypeRepository productTypeRepository
)
Public Sub New (
    productTypeRepository As TypeRepository
)
public:
SaveTypeSpecificationsToSitecore(
    TypeRepository^ productTypeRepository
)
new :
        productTypeRepository : TypeRepository -> SaveTypeSpecificationsToSitecore

Parameters

productTypeRepository
Type: Sitecore.Commerce.Data.ProductsTypeRepository
The product type repository.
See Also

Reference

SaveTypeSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


SaveTypeSpecificationsToSitecore Methods

SaveTypeSpecificationsToSitecore Methods

The SaveTypeSpecificationsToSitecore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Executes the business logic of the SaveTypeSpecificationsToSitecore processor. (Overrides PipelineProcessorTArgsProcess(TArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateStatus(String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Protected method | UpdateStatus(String, String) | Updates the status. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveTypeSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


SaveTypeSpecificationsToSitecore.Process Method

SaveTypeSpecificationsToSitecoreProcess Method
Executes the business logic of the SaveTypeSpecificationsToSitecore processor.

Namespace: Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override void Process(
    ServicePipelineArgs args
)
Public Overrides Sub Process (
    args As ServicePipelineArgs
)
public:
virtual void Process(
    ServicePipelineArgs^ args
) override
abstract Process :
        args : ServicePipelineArgs -> unit
override Process :
        args : ServicePipelineArgs -> unit

Parameters

args
Type: Sitecore.Commerce.PipelinesServicePipelineArgs
The arguments.
See Also

Reference

SaveTypeSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


SaveTypeSpecificationsToSitecore Properties

SaveTypeSpecificationsToSitecore Properties

The SaveTypeSpecificationsToSitecore type exposes the following members.

Properties
 | Name | Description
Public property | StatusUpdater | Gets or sets the status updater. (Inherited from SaveToSitecoreProcessor.)
Top
See Also

Reference

SaveTypeSpecificationsToSitecore Class
Sitecore.Commerce.Pipelines.Products.SynchronizeTypeSpecifications Namespace


Sitecore.Commerce.Products Namespace

Sitecore.Commerce.Products Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Products"]

Classes
 | Class | Description
Public class | DateTimeSynchronizationStrategy | The synchronization strategy based on updated date of entity in external system and content management system.
Public class | ItemClassificationService | Provides information about the type entities that an Item represents.
Interfaces
 | Interface | Description
Public interface | IItemClassificationService | Provides information about the type entities that an Item represents.
Public interface | ISynchronizationStrategy | The SynchronizationStrategy interface.
Enumerations
 | Enumeration | Description
Public enumeration | Direction | The direction of product synchronization.
Public enumeration | UpdateIn | Describes the system where to update the data.


DateTimeSynchronizationStrategy Class

DateTimeSynchronizationStrategy Class
The synchronization strategy based on updated date of entity in external system and content management system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ProductsDateTimeSynchronizationStrategy

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DateTimeSynchronizationStrategy : ISynchronizationStrategy
Public Class DateTimeSynchronizationStrategy
    Implements ISynchronizationStrategy
public ref class DateTimeSynchronizationStrategy : ISynchronizationStrategy
type DateTimeSynchronizationStrategy =
    class
        interface ISynchronizationStrategy
    end

The DateTimeSynchronizationStrategy type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimeSynchronizationStrategy | Initializes a new instance of the DateTimeSynchronizationStrategy class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Resolve | Resolves the specified direction.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Products Namespace


DateTimeSynchronizationStrategy Constructor

DateTimeSynchronizationStrategy Constructor
Initializes a new instance of the DateTimeSynchronizationStrategy class

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DateTimeSynchronizationStrategy()
Public Sub New
public:
DateTimeSynchronizationStrategy()
new : unit -> DateTimeSynchronizationStrategy
See Also

Reference

DateTimeSynchronizationStrategy Class
Sitecore.Commerce.Products Namespace


DateTimeSynchronizationStrategy Methods

DateTimeSynchronizationStrategy Methods

The DateTimeSynchronizationStrategy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Resolve | Resolves the specified direction.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DateTimeSynchronizationStrategy Class
Sitecore.Commerce.Products Namespace


DateTimeSynchronizationStrategy.Resolve Method

DateTimeSynchronizationStrategyResolve Method
Resolves the specified direction.

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateIn Resolve(
    Direction direction,
    ProductEntity externalSystemEntity,
    ProductEntity sitecoreEntity
)
Public Function Resolve (
    direction As Direction,
    externalSystemEntity As ProductEntity,
    sitecoreEntity As ProductEntity
) As UpdateIn
public:
virtual UpdateIn Resolve(
    Direction direction,
    ProductEntity^ externalSystemEntity,
    ProductEntity^ sitecoreEntity
) sealed
abstract Resolve :
        direction : Direction *
        externalSystemEntity : ProductEntity *
        sitecoreEntity : ProductEntity -> UpdateIn
override Resolve :
        direction : Direction *
        externalSystemEntity : ProductEntity *
        sitecoreEntity : ProductEntity -> UpdateIn

Parameters

direction
Type: Sitecore.Commerce.ProductsDirection
The direction.
externalSystemEntity
Type: Sitecore.Commerce.Entities.ProductsProductEntity
The external system entity.
sitecoreEntity
Type: Sitecore.Commerce.Entities.ProductsProductEntity
The entity from content management system.

Return Value

Type: UpdateIn
The place, where we decide if entity is updated.

Implements

ISynchronizationStrategyResolve(Direction, ProductEntity, ProductEntity)
See Also

Reference

DateTimeSynchronizationStrategy Class
Sitecore.Commerce.Products Namespace


Direction Enumeration

Direction Enumeration
The direction of product synchronization.

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public enum Direction
Public Enumeration Direction
public enum class Direction
type Direction
Members
Member name | Value | Description
Inbound | 0 | The inbound direction from External Commerce System to Sitecore.
Outbound | 1 | The outbound direction from Sitecore to External Commerce System.
Both | 2 | The synchronization in both ways. From Sitecore to External Commerce System and vice versa.
See Also

Reference

Sitecore.Commerce.Products Namespace


IItemClassificationService Interface

IItemClassificationService Interface
Provides information about the type entities that an Item represents.

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public interface IItemClassificationService
Public Interface IItemClassificationService
public interface class IItemClassificationService
type IItemClassificationService =  interface end

The IItemClassificationService type exposes the following members.

Methods
 | Name | Description
Public method | GetProductId | Retrieves the ID of an item that represents a Product entity.
Public method | IsProduct | Determines if the provided Item represents a Product entity.
Public method | IsProductTemplate | Determines if the provided template ID represents a Product entity template.
Top
See Also

Reference

Sitecore.Commerce.Products Namespace


IItemClassificationService Methods

IItemClassificationService Methods

The IItemClassificationService type exposes the following members.

Methods
 | Name | Description
Public method | GetProductId | Retrieves the ID of an item that represents a Product entity.
Public method | IsProduct | Determines if the provided Item represents a Product entity.
Public method | IsProductTemplate | Determines if the provided template ID represents a Product entity template.
Top
See Also

Reference

IItemClassificationService Interface
Sitecore.Commerce.Products Namespace


IItemClassificationService.GetProductId Method

IItemClassificationServiceGetProductId Method
Retrieves the ID of an item that represents a Product entity.

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
string GetProductId(
    Item productItem
)
Function GetProductId (
    productItem As Item
) As String
String^ GetProductId(
    Item^ productItem
)
abstract GetProductId :
        productItem : Item -> string

Parameters

productItem
Type: Item
A Item that represents a Product entity.

Return Value

Type: String
The ID of the Product.
See Also

Reference

IItemClassificationService Interface
Sitecore.Commerce.Products Namespace


IItemClassificationService.IsProduct Method

IItemClassificationServiceIsProduct Method
Determines if the provided Item represents a Product entity.

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
bool IsProduct(
    Item item
)
Function IsProduct (
    item As Item
) As Boolean
bool IsProduct(
    Item^ item
)
abstract IsProduct :
        item : Item -> bool

Parameters

item
Type: Item
The Item to examine.

Return Value

Type: Boolean
True if the item represents a Product entity, otherwise false.
See Also

Reference

IItemClassificationService Interface
Sitecore.Commerce.Products Namespace


IItemClassificationService.IsProductTemplate Method

IItemClassificationServiceIsProductTemplate Method
Determines if the provided template ID represents a Product entity template.

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
bool IsProductTemplate(
    ID templateId
)
Function IsProductTemplate (
    templateId As ID
) As Boolean
bool IsProductTemplate(
    ID^ templateId
)
abstract IsProductTemplate :
        templateId : ID -> bool

Parameters

templateId
Type: ID
The template ID to examine.

Return Value

Type: Boolean
True if the template ID represents a Product entity template, otherwise false.
See Also

Reference

IItemClassificationService Interface
Sitecore.Commerce.Products Namespace


ISynchronizationStrategy Interface

ISynchronizationStrategy Interface
The SynchronizationStrategy interface.

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public interface ISynchronizationStrategy
Public Interface ISynchronizationStrategy
public interface class ISynchronizationStrategy
type ISynchronizationStrategy =  interface end

The ISynchronizationStrategy type exposes the following members.

Methods
 | Name | Description
Public method | Resolve | Resolves the specified direction.
Top
See Also

Reference

Sitecore.Commerce.Products Namespace


ISynchronizationStrategy Methods

ISynchronizationStrategy Methods

The ISynchronizationStrategy type exposes the following members.

Methods
 | Name | Description
Public method | Resolve | Resolves the specified direction.
Top
See Also

Reference

ISynchronizationStrategy Interface
Sitecore.Commerce.Products Namespace


ISynchronizationStrategy.Resolve Method

ISynchronizationStrategyResolve Method
Resolves the specified direction.

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
UpdateIn Resolve(
    Direction direction,
    ProductEntity externalSystemEntity,
    ProductEntity sitecoreEntity
)
Function Resolve (
    direction As Direction,
    externalSystemEntity As ProductEntity,
    sitecoreEntity As ProductEntity
) As UpdateIn
UpdateIn Resolve(
    Direction direction,
    ProductEntity^ externalSystemEntity,
    ProductEntity^ sitecoreEntity
)
abstract Resolve :
        direction : Direction *
        externalSystemEntity : ProductEntity *
        sitecoreEntity : ProductEntity -> UpdateIn

Parameters

direction
Type: Sitecore.Commerce.ProductsDirection
The direction.
externalSystemEntity
Type: Sitecore.Commerce.Entities.ProductsProductEntity
The external system entity.
sitecoreEntity
Type: Sitecore.Commerce.Entities.ProductsProductEntity
The entity from content management system.

Return Value

Type: UpdateIn
The place, where we decide if entity is updated.
See Also

Reference

ISynchronizationStrategy Interface
Sitecore.Commerce.Products Namespace


ItemClassificationService Class

ItemClassificationService Class
Provides information about the type entities that an Item represents.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ProductsItemClassificationService

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ItemClassificationService : IItemClassificationService
Public Class ItemClassificationService
    Implements IItemClassificationService
public ref class ItemClassificationService : IItemClassificationService
type ItemClassificationService =
    class
        interface IItemClassificationService
    end

The ItemClassificationService type exposes the following members.

Constructors
 | Name | Description
Public method | ItemClassificationService | Initializes a new instance of the ItemClassificationService class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProductId | Retrieves the ID of an item that represents a Product entity.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsProduct | Determines if the provided Item represents a Product entity.
Public method | IsProductTemplate | Determines if the provided template ID represents a Product entity template.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Products Namespace


ItemClassificationService Constructor

ItemClassificationService Constructor
Initializes a new instance of the ItemClassificationService class

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ItemClassificationService()
Public Sub New
public:
ItemClassificationService()
new : unit -> ItemClassificationService
See Also

Reference

ItemClassificationService Class
Sitecore.Commerce.Products Namespace


ItemClassificationService Methods

ItemClassificationService Methods

The ItemClassificationService type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProductId | Retrieves the ID of an item that represents a Product entity.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsProduct | Determines if the provided Item represents a Product entity.
Public method | IsProductTemplate | Determines if the provided template ID represents a Product entity template.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ItemClassificationService Class
Sitecore.Commerce.Products Namespace


ItemClassificationService.GetProductId Method

ItemClassificationServiceGetProductId Method
Retrieves the ID of an item that represents a Product entity.

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string GetProductId(
    Item productItem
)
Public Function GetProductId (
    productItem As Item
) As String
public:
virtual String^ GetProductId(
    Item^ productItem
) sealed
abstract GetProductId :
        productItem : Item -> string
override GetProductId :
        productItem : Item -> string

Parameters

productItem
Type: Item
A Item that represents a Product entity.

Return Value

Type: String
The ID of the Product.

Implements

IItemClassificationServiceGetProductId(Item)
See Also

Reference

ItemClassificationService Class
Sitecore.Commerce.Products Namespace


ItemClassificationService.IsProduct Method

ItemClassificationServiceIsProduct Method
Determines if the provided Item represents a Product entity.

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public bool IsProduct(
    Item item
)
Public Function IsProduct (
    item As Item
) As Boolean
public:
virtual bool IsProduct(
    Item^ item
) sealed
abstract IsProduct :
        item : Item -> bool
override IsProduct :
        item : Item -> bool

Parameters

item
Type: Item
The Item to examine.

Return Value

Type: Boolean
True if the item represents a Product entity, otherwise false.

Implements

IItemClassificationServiceIsProduct(Item)
See Also

Reference

ItemClassificationService Class
Sitecore.Commerce.Products Namespace


ItemClassificationService.IsProductTemplate Method

ItemClassificationServiceIsProductTemplate Method
Determines if the provided template ID represents a Product entity template.

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public bool IsProductTemplate(
    ID templateId
)
Public Function IsProductTemplate (
    templateId As ID
) As Boolean
public:
virtual bool IsProductTemplate(
    ID^ templateId
) sealed
abstract IsProductTemplate :
        templateId : ID -> bool
override IsProductTemplate :
        templateId : ID -> bool

Parameters

templateId
Type: ID
The template ID to examine.

Return Value

Type: Boolean
True if the template ID represents a Product entity template, otherwise false.

Implements

IItemClassificationServiceIsProductTemplate(ID)
See Also

Reference

ItemClassificationService Class
Sitecore.Commerce.Products Namespace


UpdateIn Enumeration

UpdateIn Enumeration
Describes the system where to update the data.

Namespace: Sitecore.Commerce.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public enum UpdateIn
Public Enumeration UpdateIn
public enum class UpdateIn
type UpdateIn
Members
Member name | Value | Description
None | 0 | Do not update data in any system.
Sitecore | 1 | Update data in Sitecore.
ExternalCommerceSystem | 2 | Update data in the External Commerce System.
See Also

Reference

Sitecore.Commerce.Products Namespace


Sitecore.Commerce.Rules.Conditions Namespace

Sitecore.Commerce.Rules.Conditions Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Rules.Conditions"]

Classes
 | Class | Description
Public class | BaseCartMetricsConditionT | Defines the base class for all condition classes that operate on cart metrics.
Public class | CartTotalConditionT | Defines a condition for the cart total with a predefined value: The condition follows the following format: “where the user's cart total [compares to] [CartTotal]” In this format, the [Compares to] clause can be any two-operand comparison operator: <,>,<=,=,=>
Public class | HasTriggeredPageEventsConditionT | Defines the condition that determines whether a user has triggered a group of page events during a period of time. The condition follows the following format: “where the current visitor has triggered [PageEventName] for at least [MinimalNumberOfTimes] during last [TimeRange]”
Public class | SpecificProductQuantityConditionT | Defines the condition to compare the quantity of a product with a predefined value. The condition follows the following format: “where the quantity of product [ProductId] in user's cart [Compares to] [ProductQuantity]” I this format, the [Compares to] clause can be any two-operand comparison operator: <,>,<=,=,=>
Public class | TotalProductQuantityConditionT | Defines the condition that determines the total quantity of products that the cart of the current visitor contains. This condition follows the following format: “Where the quantity of all products in the user's cart [compares to] [TotalProductQuantity]”


BaseCartMetricsCondition(T) Class

BaseCartMetricsConditionT Class
Defines the base class for all condition classes that operate on cart metrics.
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
OperatorConditionT
Sitecore.Commerce.Rules.ConditionsBaseCartMetricsConditionT
Sitecore.Commerce.Rules.ConditionsCartTotalConditionT
Sitecore.Commerce.Rules.ConditionsSpecificProductQuantityConditionT
Sitecore.Commerce.Rules.ConditionsTotalProductQuantityConditionT

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class BaseCartMetricsCondition<T> : OperatorCondition<T>
where T : RuleContext

Public MustInherit Class BaseCartMetricsCondition(Of T As RuleContext)
    Inherits OperatorCondition(Of T)
generic<typename T>
where T : RuleContext
public ref class BaseCartMetricsCondition abstract : public OperatorCondition<T>
[<AbstractClassAttribute>]
type BaseCartMetricsCondition<'T when 'T : RuleContext> =
    class
        inherit OperatorCondition<'T>
    end

Type Parameters

T
Type of rule context.

The BaseCartMetricsConditionT type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseCartMetricsConditionT | Initializes a new instance of the BaseCartMetricsConditionT class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | Executes the specified rule context. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartMetrics | Gets the cart metrics.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | (Inherited from OperatorConditionT.)
Protected method | GetPredefinedValue | Gets the predefined value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | CartServiceProvider | Gets or sets the cart service provider.
Public property | OperatorId | (Inherited from OperatorConditionT.)
Protected property | VisitorFactory | Gets or sets the visitor factory.
Top
See Also

Reference

Sitecore.Commerce.Rules.Conditions Namespace


BaseCartMetricsCondition(T) Constructor

BaseCartMetricsConditionT Constructor
Initializes a new instance of the BaseCartMetricsConditionT class.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected BaseCartMetricsCondition()
Protected Sub New
protected:
BaseCartMetricsCondition()
new : unit -> BaseCartMetricsCondition
See Also

Reference

BaseCartMetricsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


BaseCartMetricsCondition(T) Methods

BaseCartMetricsConditionT Methods

The BaseCartMetricsConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | Executes the specified rule context. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartMetrics | Gets the cart metrics.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | (Inherited from OperatorConditionT .)
Protected method | GetPredefinedValue | Gets the predefined value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseCartMetricsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


BaseCartMetricsCondition(T).Execute Method

BaseCartMetricsConditionTExecute Method
Executes the specified rule context.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override bool Execute(
    T ruleContext
)
Protected Overrides Function Execute (
    ruleContext As T
) As Boolean
protected:
virtual bool Execute(
    T ruleContext
) override
abstract Execute :
        ruleContext : 'T -> bool
override Execute :
        ruleContext : 'T -> bool

Parameters

ruleContext
Type: T
The rule context.

Return Value

Type: Boolean
Result of condition execution.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when unknown operator was specified.
See Also

Reference

BaseCartMetricsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


BaseCartMetricsCondition(T).GetCartMetrics Method

BaseCartMetricsConditionTGetCartMetrics Method
Gets the cart metrics.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract IComparable GetCartMetrics(
    IEnumerable<Cart> carts
)
Protected MustOverride Function GetCartMetrics (
    carts As IEnumerable(Of Cart)
) As IComparable
protected:
virtual IComparable^ GetCartMetrics(
    IEnumerable<Cart^>^ carts
) abstract
abstract GetCartMetrics :
        carts : IEnumerable<Cart> -> IComparable

Parameters

carts
Type: System.Collections.GenericIEnumerable Cart
The carts.

Return Value

Type: IComparable
Metrics of the cart that can be compared with predefined value.
See Also

Reference

BaseCartMetricsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


BaseCartMetricsCondition(T).GetPredefinedValue Method

BaseCartMetricsConditionTGetPredefinedValue Method
Gets the predefined value.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract Object GetPredefinedValue()
Protected MustOverride Function GetPredefinedValue As Object
protected:
virtual Object^ GetPredefinedValue() abstract
abstract GetPredefinedValue : unit -> Object

Return Value

Type: Object
The predefined value to compare with.
See Also

Reference

BaseCartMetricsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


BaseCartMetricsCondition(T) Properties

BaseCartMetricsConditionT Properties

The BaseCartMetricsConditionT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CartServiceProvider | Gets or sets the cart service provider.
Public property | OperatorId | (Inherited from OperatorConditionT .)
Protected property | VisitorFactory | Gets or sets the visitor factory.
Top
See Also

Reference

BaseCartMetricsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


BaseCartMetricsCondition(T).CartServiceProvider Property

BaseCartMetricsConditionTCartServiceProvider Property
Gets or sets the cart service provider.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected CartServiceProvider CartServiceProvider { get; set; }
Protected Property CartServiceProvider As CartServiceProvider
    Get
    Set
protected:
property CartServiceProvider^ CartServiceProvider {
    CartServiceProvider^ get ();
    void set (CartServiceProvider^ value);
}
member CartServiceProvider : CartServiceProvider with get, set

Property Value

Type: CartServiceProvider
The cart service provider.
See Also

Reference

BaseCartMetricsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


BaseCartMetricsCondition(T).VisitorFactory Property

BaseCartMetricsConditionTVisitorFactory Property
Gets or sets the visitor factory.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected VisitorFactory VisitorFactory { get; set; }
Protected Property VisitorFactory As VisitorFactory
    Get
    Set
protected:
property VisitorFactory^ VisitorFactory {
    VisitorFactory^ get ();
    void set (VisitorFactory^ value);
}
member VisitorFactory : VisitorFactory with get, set

Property Value

Type: VisitorFactory
The visitor factory.
See Also

Reference

BaseCartMetricsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


CartTotalCondition(T) Class

CartTotalConditionT Class
Defines a condition for the cart total with a predefined value: The condition follows the following format: “where the user's cart total [compares to] [CartTotal]” In this format, the [Compares to] clause can be any two-operand comparison operator: <,>,<=,=,=>
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
OperatorConditionT
Sitecore.Commerce.Rules.ConditionsBaseCartMetricsCondition T
Sitecore.Commerce.Rules.ConditionsCartTotalConditionT

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CartTotalCondition<T> : BaseCartMetricsCondition<T>
where T : RuleContext

Public Class CartTotalCondition(Of T As RuleContext)
    Inherits BaseCartMetricsCondition(Of T)
generic<typename T>
where T : RuleContext
public ref class CartTotalCondition : public BaseCartMetricsCondition<T>
type CartTotalCondition<'T when 'T : RuleContext> =
    class
        inherit BaseCartMetricsCondition<'T>
    end

Type Parameters

T
Type of rule context.

The CartTotalConditionT type exposes the following members.

Constructors
 | Name | Description
Public method | CartTotalConditionT | Initializes a new instance of the CartTotalConditionT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | Executes the specified rule context. (Inherited from BaseCartMetricsConditionT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartMetrics | Gets the cart metrics. (Overrides BaseCartMetricsConditionTGetCartMetrics(IEnumerableCart).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | (Inherited from OperatorConditionT.)
Protected method | GetPredefinedValue | Gets the predefined value. (Overrides BaseCartMetricsConditionTGetPredefinedValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | CartServiceProvider | Gets or sets the cart service provider. (Inherited from BaseCartMetricsConditionT.)
Public property | CartTotal | Gets or sets the cart total.
Public property | OperatorId | (Inherited from OperatorConditionT.)
Protected property | VisitorFactory | Gets or sets the visitor factory. (Inherited from BaseCartMetricsConditionT.)
Top
See Also

Reference

Sitecore.Commerce.Rules.Conditions Namespace


CartTotalCondition(T) Constructor

CartTotalConditionT Constructor
Initializes a new instance of the CartTotalConditionT class

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CartTotalCondition()
Public Sub New
public:
CartTotalCondition()
new : unit -> CartTotalCondition
See Also

Reference

CartTotalConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


CartTotalCondition(T) Methods

CartTotalConditionT Methods

The CartTotalConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | Executes the specified rule context. (Inherited from BaseCartMetricsConditionT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartMetrics | Gets the cart metrics. (Overrides BaseCartMetricsConditionTGetCartMetrics(IEnumerableCart).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | (Inherited from OperatorConditionT .)
Protected method | GetPredefinedValue | Gets the predefined value. (Overrides BaseCartMetricsConditionTGetPredefinedValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CartTotalConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


CartTotalCondition(T).GetCartMetrics Method

CartTotalConditionTGetCartMetrics Method
Gets the cart metrics.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IComparable GetCartMetrics(
    IEnumerable<Cart> carts
)
Protected Overrides Function GetCartMetrics (
    carts As IEnumerable(Of Cart)
) As IComparable
protected:
virtual IComparable^ GetCartMetrics(
    IEnumerable<Cart^>^ carts
) override
abstract GetCartMetrics :
        carts : IEnumerable<Cart> -> IComparable
override GetCartMetrics :
        carts : IEnumerable<Cart> -> IComparable

Parameters

carts
Type: System.Collections.GenericIEnumerable Cart
The carts.

Return Value

Type: IComparable
The cart total.
See Also

Reference

CartTotalConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


CartTotalCondition(T).GetPredefinedValue Method

CartTotalConditionTGetPredefinedValue Method
Gets the predefined value.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override Object GetPredefinedValue()
Protected Overrides Function GetPredefinedValue As Object
protected:
virtual Object^ GetPredefinedValue() override
abstract GetPredefinedValue : unit -> Object
override GetPredefinedValue : unit -> Object

Return Value

Type: Object
The cart total to compare with
See Also

Reference

CartTotalConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


CartTotalCondition(T) Properties

CartTotalConditionT Properties

The CartTotalConditionT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CartServiceProvider | Gets or sets the cart service provider. (Inherited from BaseCartMetricsConditionT.)
Public property | CartTotal | Gets or sets the cart total.
Public property | OperatorId | (Inherited from OperatorConditionT .)
Protected property | VisitorFactory | Gets or sets the visitor factory. (Inherited from BaseCartMetricsConditionT.)
Top
See Also

Reference

CartTotalConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


CartTotalCondition(T).CartTotal Property

CartTotalConditionTCartTotal Property
Gets or sets the cart total.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public decimal CartTotal { get; set; }
Public Property CartTotal As Decimal
    Get
    Set
public:
property Decimal CartTotal {
    Decimal get ();
    void set (Decimal value);
}
member CartTotal : decimal with get, set

Property Value

Type: Decimal
The cart total.
See Also

Reference

CartTotalConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


HasTriggeredPageEventsCondition(T) Class

HasTriggeredPageEventsConditionT Class
Defines the condition that determines whether a user has triggered a group of page events during a period of time. The condition follows the following format: “where the current visitor has triggered [PageEventName] for at least [MinimalNumberOfTimes] during last [TimeRange]”
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
Sitecore.Commerce.Rules.ConditionsHasTriggeredPageEventsConditionT

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class HasTriggeredPageEventsCondition<T> : WhenCondition<T>
where T : RuleContext

Public Class HasTriggeredPageEventsCondition(Of T As RuleContext)
    Inherits WhenCondition(Of T)
generic<typename T>
where T : RuleContext
public ref class HasTriggeredPageEventsCondition : public WhenCondition<T>
type HasTriggeredPageEventsCondition<'T when 'T : RuleContext> =
    class
        inherit WhenCondition<'T>
    end

Type Parameters

T
Type of rule context.

The HasTriggeredPageEventsConditionT type exposes the following members.

Constructors
 | Name | Description
Public method | HasTriggeredPageEventsConditionT | Initializes a new instance of the HasTriggeredPageEventsConditionT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | Executes the specified rule context. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | MinimalNumberOfTimes | Gets or sets the minimal number of times.
Public property | PageEventName | Gets or sets the name of the page event.
Public property | TimeRange | Gets or sets the time range.
Top
See Also

Reference

Sitecore.Commerce.Rules.Conditions Namespace


HasTriggeredPageEventsCondition(T) Constructor

HasTriggeredPageEventsConditionT Constructor
Initializes a new instance of the HasTriggeredPageEventsConditionT class

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public HasTriggeredPageEventsCondition()
Public Sub New
public:
HasTriggeredPageEventsCondition()
new : unit -> HasTriggeredPageEventsCondition
See Also

Reference

HasTriggeredPageEventsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


HasTriggeredPageEventsCondition(T) Methods

HasTriggeredPageEventsConditionT Methods

The HasTriggeredPageEventsConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | Executes the specified rule context. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HasTriggeredPageEventsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


HasTriggeredPageEventsCondition(T).Execute Method

HasTriggeredPageEventsConditionTExecute Method
Executes the specified rule context.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override bool Execute(
    T ruleContext
)
Protected Overrides Function Execute (
    ruleContext As T
) As Boolean
protected:
virtual bool Execute(
    T ruleContext
) override
abstract Execute :
        ruleContext : 'T -> bool
override Execute :
        ruleContext : 'T -> bool

Parameters

ruleContext
Type: T
The rule context.

Return Value

Type: Boolean
true if user have triggered specified amount of page events, otherwise false.
See Also

Reference

HasTriggeredPageEventsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


HasTriggeredPageEventsCondition(T) Properties

HasTriggeredPageEventsConditionT Properties

The HasTriggeredPageEventsConditionT generic type exposes the following members.

Properties
 | Name | Description
Public property | MinimalNumberOfTimes | Gets or sets the minimal number of times.
Public property | PageEventName | Gets or sets the name of the page event.
Public property | TimeRange | Gets or sets the time range.
Top
See Also

Reference

HasTriggeredPageEventsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


HasTriggeredPageEventsCondition(T).MinimalNumberOfTimes Property

HasTriggeredPageEventsConditionTMinimalNumberOfTimes Property
Gets or sets the minimal number of times.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public int MinimalNumberOfTimes { get; set; }
Public Property MinimalNumberOfTimes As Integer
    Get
    Set
public:
property int MinimalNumberOfTimes {
    int get ();
    void set (int value);
}
member MinimalNumberOfTimes : int with get, set

Property Value

Type: Int32
The minimal number of times.
See Also

Reference

HasTriggeredPageEventsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


HasTriggeredPageEventsCondition(T).PageEventName Property

HasTriggeredPageEventsConditionTPageEventName Property
Gets or sets the name of the page event.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string PageEventName { get; set; }
Public Property PageEventName As String
    Get
    Set
public:
property String^ PageEventName {
    String^ get ();
    void set (String^ value);
}
member PageEventName : string with get, set

Property Value

Type: String
The name of the page event.
See Also

Reference

HasTriggeredPageEventsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


HasTriggeredPageEventsCondition(T).TimeRange Property

HasTriggeredPageEventsConditionTTimeRange Property
Gets or sets the time range.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TimeSpan TimeRange { get; set; }
Public Property TimeRange As TimeSpan
    Get
    Set
public:
property TimeSpan TimeRange {
    TimeSpan get ();
    void set (TimeSpan value);
}
member TimeRange : TimeSpan with get, set

Property Value

Type: TimeSpan
The time range.
See Also

Reference

HasTriggeredPageEventsConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


SpecificProductQuantityCondition(T) Class

SpecificProductQuantityConditionT Class
Defines the condition to compare the quantity of a product with a predefined value. The condition follows the following format: “where the quantity of product [ProductId] in user's cart [Compares to] [ProductQuantity]” I this format, the [Compares to] clause can be any two-operand comparison operator: <,>,<=,=,=>
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
OperatorConditionT
Sitecore.Commerce.Rules.ConditionsBaseCartMetricsCondition T
Sitecore.Commerce.Rules.ConditionsSpecificProductQuantityConditionT

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SpecificProductQuantityCondition<T> : BaseCartMetricsCondition<T>
where T : RuleContext

Public Class SpecificProductQuantityCondition(Of T As RuleContext)
    Inherits BaseCartMetricsCondition(Of T)
generic<typename T>
where T : RuleContext
public ref class SpecificProductQuantityCondition : public BaseCartMetricsCondition<T>
type SpecificProductQuantityCondition<'T when 'T : RuleContext> =
    class
        inherit BaseCartMetricsCondition<'T>
    end

Type Parameters

T
Type of rule context.

The SpecificProductQuantityConditionT type exposes the following members.

Constructors
 | Name | Description
Public method | SpecificProductQuantityConditionT | Initializes a new instance of the SpecificProductQuantityConditionT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | Executes the specified rule context. (Inherited from BaseCartMetricsConditionT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartMetrics | Gets the cart metrics. (Overrides BaseCartMetricsConditionTGetCartMetrics(IEnumerableCart).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | (Inherited from OperatorConditionT.)
Protected method | GetPredefinedValue | Gets the predefined value. (Overrides BaseCartMetricsConditionTGetPredefinedValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | CartServiceProvider | Gets or sets the cart service provider. (Inherited from BaseCartMetricsConditionT.)
Public property | OperatorId | (Inherited from OperatorConditionT.)
Public property | ProductId | Gets or sets the product id.
Public property | ProductQuantity | Gets or sets the product quantity.
Protected property | VisitorFactory | Gets or sets the visitor factory. (Inherited from BaseCartMetricsConditionT.)
Top
See Also

Reference

Sitecore.Commerce.Rules.Conditions Namespace


SpecificProductQuantityCondition(T) Constructor

SpecificProductQuantityConditionT Constructor
Initializes a new instance of the SpecificProductQuantityConditionT class

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SpecificProductQuantityCondition()
Public Sub New
public:
SpecificProductQuantityCondition()
new : unit -> SpecificProductQuantityCondition
See Also

Reference

SpecificProductQuantityConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


SpecificProductQuantityCondition(T) Methods

SpecificProductQuantityConditionT Methods

The SpecificProductQuantityConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | Executes the specified rule context. (Inherited from BaseCartMetricsConditionT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartMetrics | Gets the cart metrics. (Overrides BaseCartMetricsConditionTGetCartMetrics(IEnumerableCart).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | (Inherited from OperatorConditionT .)
Protected method | GetPredefinedValue | Gets the predefined value. (Overrides BaseCartMetricsConditionTGetPredefinedValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SpecificProductQuantityConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


SpecificProductQuantityCondition(T).GetCartMetrics Method

SpecificProductQuantityConditionTGetCartMetrics Method
Gets the cart metrics.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IComparable GetCartMetrics(
    IEnumerable<Cart> carts
)
Protected Overrides Function GetCartMetrics (
    carts As IEnumerable(Of Cart)
) As IComparable
protected:
virtual IComparable^ GetCartMetrics(
    IEnumerable<Cart^>^ carts
) override
abstract GetCartMetrics :
        carts : IEnumerable<Cart> -> IComparable
override GetCartMetrics :
        carts : IEnumerable<Cart> -> IComparable

Parameters

carts
Type: System.Collections.GenericIEnumerable Cart
The carts.

Return Value

Type: IComparable
The metric of the cart.
See Also

Reference

SpecificProductQuantityConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


SpecificProductQuantityCondition(T).GetPredefinedValue Method

SpecificProductQuantityConditionTGetPredefinedValue Method
Gets the predefined value.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override Object GetPredefinedValue()
Protected Overrides Function GetPredefinedValue As Object
protected:
virtual Object^ GetPredefinedValue() override
abstract GetPredefinedValue : unit -> Object
override GetPredefinedValue : unit -> Object

Return Value

Type: Object
The value to compare with.
See Also

Reference

SpecificProductQuantityConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


SpecificProductQuantityCondition(T) Properties

SpecificProductQuantityConditionT Properties

The SpecificProductQuantityConditionT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CartServiceProvider | Gets or sets the cart service provider. (Inherited from BaseCartMetricsConditionT.)
Public property | OperatorId | (Inherited from OperatorConditionT .)
Public property | ProductId | Gets or sets the product id.
Public property | ProductQuantity | Gets or sets the product quantity.
Protected property | VisitorFactory | Gets or sets the visitor factory. (Inherited from BaseCartMetricsConditionT.)
Top
See Also

Reference

SpecificProductQuantityConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


SpecificProductQuantityCondition(T).ProductId Property

SpecificProductQuantityConditionTProductId Property
Gets or sets the product id.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ProductId { get; set; }
Public Property ProductId As String
    Get
    Set
public:
property String^ ProductId {
    String^ get ();
    void set (String^ value);
}
member ProductId : string with get, set

Property Value

Type: String
The product id.
See Also

Reference

SpecificProductQuantityConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


SpecificProductQuantityCondition(T).ProductQuantity Property

SpecificProductQuantityConditionTProductQuantity Property
Gets or sets the product quantity.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public uint ProductQuantity { get; set; }
Public Property ProductQuantity As UInteger
    Get
    Set
public:
property unsigned int ProductQuantity {
    unsigned int get ();
    void set (unsigned int value);
}
member ProductQuantity : uint32 with get, set

Property Value

Type: UInt32
The product quantity.
See Also

Reference

SpecificProductQuantityConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


TotalProductQuantityCondition(T) Class

TotalProductQuantityConditionT Class
Defines the condition that determines the total quantity of products that the cart of the current visitor contains. This condition follows the following format: “Where the quantity of all products in the user's cart [compares to] [TotalProductQuantity]”
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
OperatorConditionT
Sitecore.Commerce.Rules.ConditionsBaseCartMetricsCondition T
Sitecore.Commerce.Rules.ConditionsTotalProductQuantityConditionT

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class TotalProductQuantityCondition<T> : BaseCartMetricsCondition<T>
where T : RuleContext

Public Class TotalProductQuantityCondition(Of T As RuleContext)
    Inherits BaseCartMetricsCondition(Of T)
generic<typename T>
where T : RuleContext
public ref class TotalProductQuantityCondition : public BaseCartMetricsCondition<T>
type TotalProductQuantityCondition<'T when 'T : RuleContext> =
    class
        inherit BaseCartMetricsCondition<'T>
    end

Type Parameters

T
Type of rule context.

The TotalProductQuantityConditionT type exposes the following members.

Constructors
 | Name | Description
Public method | TotalProductQuantityConditionT | Initializes a new instance of the TotalProductQuantityConditionT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | Executes the specified rule context. (Inherited from BaseCartMetricsConditionT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartMetrics | Gets the cart metrics. (Overrides BaseCartMetricsConditionTGetCartMetrics(IEnumerableCart).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | (Inherited from OperatorConditionT.)
Protected method | GetPredefinedValue | Gets the predefined value. (Overrides BaseCartMetricsConditionTGetPredefinedValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | CartServiceProvider | Gets or sets the cart service provider. (Inherited from BaseCartMetricsConditionT.)
Public property | OperatorId | (Inherited from OperatorConditionT.)
Public property | TotalProductQuantity | Gets or sets the number of order lines to compare actual count with.
Protected property | VisitorFactory | Gets or sets the visitor factory. (Inherited from BaseCartMetricsConditionT.)
Top
See Also

Reference

Sitecore.Commerce.Rules.Conditions Namespace


TotalProductQuantityCondition(T) Constructor

TotalProductQuantityConditionT Constructor
Initializes a new instance of the TotalProductQuantityConditionT class

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public TotalProductQuantityCondition()
Public Sub New
public:
TotalProductQuantityCondition()
new : unit -> TotalProductQuantityCondition
See Also

Reference

TotalProductQuantityConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


TotalProductQuantityCondition(T) Methods

TotalProductQuantityConditionT Methods

The TotalProductQuantityConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | Executes the specified rule context. (Inherited from BaseCartMetricsConditionT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCartMetrics | Gets the cart metrics. (Overrides BaseCartMetricsConditionTGetCartMetrics(IEnumerableCart).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | (Inherited from OperatorConditionT .)
Protected method | GetPredefinedValue | Gets the predefined value. (Overrides BaseCartMetricsConditionTGetPredefinedValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TotalProductQuantityConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


TotalProductQuantityCondition(T).GetCartMetrics Method

TotalProductQuantityConditionTGetCartMetrics Method
Gets the cart metrics.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override IComparable GetCartMetrics(
    IEnumerable<Cart> carts
)
Protected Overrides Function GetCartMetrics (
    carts As IEnumerable(Of Cart)
) As IComparable
protected:
virtual IComparable^ GetCartMetrics(
    IEnumerable<Cart^>^ carts
) override
abstract GetCartMetrics :
        carts : IEnumerable<Cart> -> IComparable
override GetCartMetrics :
        carts : IEnumerable<Cart> -> IComparable

Parameters

carts
Type: System.Collections.GenericIEnumerable Cart
The carts.

Return Value

Type: IComparable
Total number of products in cart.
See Also

Reference

TotalProductQuantityConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


TotalProductQuantityCondition(T).GetPredefinedValue Method

TotalProductQuantityConditionTGetPredefinedValue Method
Gets the predefined value.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override Object GetPredefinedValue()
Protected Overrides Function GetPredefinedValue As Object
protected:
virtual Object^ GetPredefinedValue() override
abstract GetPredefinedValue : unit -> Object
override GetPredefinedValue : unit -> Object

Return Value

Type: Object
Number of products to compare with.
See Also

Reference

TotalProductQuantityConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


TotalProductQuantityCondition(T) Properties

TotalProductQuantityConditionT Properties

The TotalProductQuantityConditionT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CartServiceProvider | Gets or sets the cart service provider. (Inherited from BaseCartMetricsConditionT.)
Public property | OperatorId | (Inherited from OperatorConditionT .)
Public property | TotalProductQuantity | Gets or sets the number of order lines to compare actual count with.
Protected property | VisitorFactory | Gets or sets the visitor factory. (Inherited from BaseCartMetricsConditionT.)
Top
See Also

Reference

TotalProductQuantityConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


TotalProductQuantityCondition(T).TotalProductQuantity Property

TotalProductQuantityConditionTTotalProductQuantity Property
Gets or sets the number of order lines to compare actual count with.

Namespace: Sitecore.Commerce.Rules.Conditions
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public uint TotalProductQuantity { get; set; }
Public Property TotalProductQuantity As UInteger
    Get
    Set
public:
property unsigned int TotalProductQuantity {
    unsigned int get ();
    void set (unsigned int value);
}
member TotalProductQuantity : uint32 with get, set

Property Value

Type: UInt32
The number of order lines.
See Also

Reference

TotalProductQuantityConditionT Class
Sitecore.Commerce.Rules.Conditions Namespace


Sitecore.Commerce.Rules.Conditions.Inventory Namespace

Sitecore.Commerce.Rules.Conditions.Inventory Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Rules.Conditions.Inventory"]

Classes
 | Class | Description
Public class | CurrentProductStockCountByLocationConditionT | Defines the condition to compare the stock count of a product with a predefined value. The condition follows the following format: “where the stock count of current product [Compares to] [ProductStockCount] in the location [Location]” I this format, the [Compares to] clause can be any two-operand comparison operator: <,>,<=,=,=>
Public class | CurrentProductStockCountConditionT | Defines the condition to compare the stock count of a product with a predefined value. The condition follows the following format: “where the stock count of current product [Compares to] [ProductStockCount]” I this format, the [Compares to] clause can be any two-operand comparison operator: <,>,<=,=,=>
Public class | CurrentProductStockStatusByLocationConditionT | Defines the condition to compare the stock status of a product with a predefined value. The condition follows the following format: “where current product has stock status equal to [ProductStockStatus] in the location [Location]”
Public class | CurrentProductStockStatusConditionT | Defines the condition to compare the stock status of a product with a predefined value. The condition follows the following format: “where current product has stock status equal to [ProductStockStatus]”
Public class | SpecificProductStockCountByLocationConditionT | Defines the condition to compare the stock count of a product with a predefined value. The condition follows the following format: “where the stock count of product [ProductId] [Compares to] [ProductStockCount] in the location [Location]” I this format, the [Compares to] clause can be any two-operand comparison operator: <,>,<=,=,=>
Public class | SpecificProductStockCountConditionT | Defines the condition to compare the stock count of a product with a predefined value. The condition follows the following format: “where the stock count of product [ProductId] [Compares to] [ProductStockCount]” I this format, the [Compares to] clause can be any two-operand comparison operator: <,>,<=,=,=>
Public class | StockCountConditionBaseT | Defines the base class for all condition classes that operate on stock status.
Public class | StockStatusConditionBaseT | Defines the base class for all condition classes that operate on stock status.


CurrentProductStockCountByLocationCondition(T) Class

CurrentProductStockCountByLocationConditionT Class
Defines the condition to compare the stock count of a product with a predefined value. The condition follows the following format: “where the stock count of current product [Compares to] [ProductStockCount] in the location [Location]” I this format, the [Compares to] clause can be any two-operand comparison operator: <,>,<=,=,=>
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
OperatorConditionT
Sitecore.Commerce.Rules.Conditions.InventoryStockCountConditionBase T
Sitecore.Commerce.Rules.Conditions.InventoryCurrentProductStockCountByLocationConditionT

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CurrentProductStockCountByLocationCondition<T> : StockCountConditionBase<T>
where T : RuleContext

Public Class CurrentProductStockCountByLocationCondition(Of T As RuleContext)
    Inherits StockCountConditionBase(Of T)
generic<typename T>
where T : RuleContext
public ref class CurrentProductStockCountByLocationCondition : public StockCountConditionBase<T>
type CurrentProductStockCountByLocationCondition<'T when 'T : RuleContext> =
    class
        inherit StockCountConditionBase<'T>
    end

Type Parameters

T
Type of rule context.

The CurrentProductStockCountByLocationConditionT type exposes the following members.

Constructors
 | Name | Description
Public method | CurrentProductStockCountByLocationConditionT | Initializes a new instance of the CurrentProductStockCountByLocationConditionT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | Executes the specified rule context. (Inherited from StockCountConditionBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location. (Overrides StockCountConditionBaseTGetLocation.)
Protected method | GetOperator | (Inherited from OperatorConditionT.)
Protected method | GetProductId | Gets the product id. (Overrides StockCountConditionBaseTGetProductId.)
Protected method | GetStockInformation | Gets the stock information. (Inherited from StockCountConditionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context. (Inherited from StockCountConditionBaseT.)
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider. (Inherited from StockCountConditionBaseT.)
Public property | Location | Gets or sets the location.
Public property | OperatorId | (Inherited from OperatorConditionT.)
Public property | StockCount | Gets or sets the product stock count. (Inherited from StockCountConditionBaseT.)
Top
See Also

Reference

Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockCountByLocationCondition(T) Constructor

CurrentProductStockCountByLocationConditionT Constructor
Initializes a new instance of the CurrentProductStockCountByLocationConditionT class

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CurrentProductStockCountByLocationCondition()
Public Sub New
public:
CurrentProductStockCountByLocationCondition()
new : unit -> CurrentProductStockCountByLocationCondition
See Also

Reference

CurrentProductStockCountByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockCountByLocationCondition(T) Methods

CurrentProductStockCountByLocationConditionT Methods

The CurrentProductStockCountByLocationConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | Executes the specified rule context. (Inherited from StockCountConditionBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location. (Overrides StockCountConditionBaseTGetLocation.)
Protected method | GetOperator | (Inherited from OperatorConditionT .)
Protected method | GetProductId | Gets the product id. (Overrides StockCountConditionBaseTGetProductId.)
Protected method | GetStockInformation | Gets the stock information. (Inherited from StockCountConditionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CurrentProductStockCountByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockCountByLocationCondition(T).GetLocation Method

CurrentProductStockCountByLocationConditionTGetLocation Method
Gets the location.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetLocation()
Protected Overrides Function GetLocation As String
protected:
virtual String^ GetLocation() override
abstract GetLocation : unit -> string
override GetLocation : unit -> string

Return Value

Type: String
The location.
See Also

Reference

CurrentProductStockCountByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockCountByLocationCondition(T).GetProductId Method

CurrentProductStockCountByLocationConditionTGetProductId Method
Gets the product id.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetProductId()
Protected Overrides Function GetProductId As String
protected:
virtual String^ GetProductId() override
abstract GetProductId : unit -> string
override GetProductId : unit -> string

Return Value

Type: String
The product id.
See Also

Reference

CurrentProductStockCountByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockCountByLocationCondition(T) Properties

CurrentProductStockCountByLocationConditionT Properties

The CurrentProductStockCountByLocationConditionT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context. (Inherited from StockCountConditionBaseT.)
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider. (Inherited from StockCountConditionBaseT.)
Public property | Location | Gets or sets the location.
Public property | OperatorId | (Inherited from OperatorConditionT .)
Public property | StockCount | Gets or sets the product stock count. (Inherited from StockCountConditionBaseT.)
Top
See Also

Reference

CurrentProductStockCountByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockCountByLocationCondition(T).Location Property

CurrentProductStockCountByLocationConditionTLocation Property
Gets or sets the location.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
The shop location.
See Also

Reference

CurrentProductStockCountByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockCountCondition(T) Class

CurrentProductStockCountConditionT Class
Defines the condition to compare the stock count of a product with a predefined value. The condition follows the following format: “where the stock count of current product [Compares to] [ProductStockCount]” I this format, the [Compares to] clause can be any two-operand comparison operator: <,>,<=,=,=>
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
OperatorConditionT
Sitecore.Commerce.Rules.Conditions.InventoryStockCountConditionBase T
Sitecore.Commerce.Rules.Conditions.InventoryCurrentProductStockCountConditionT

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CurrentProductStockCountCondition<T> : StockCountConditionBase<T>
where T : RuleContext

Public Class CurrentProductStockCountCondition(Of T As RuleContext)
    Inherits StockCountConditionBase(Of T)
generic<typename T>
where T : RuleContext
public ref class CurrentProductStockCountCondition : public StockCountConditionBase<T>
type CurrentProductStockCountCondition<'T when 'T : RuleContext> =
    class
        inherit StockCountConditionBase<'T>
    end

Type Parameters

T
Type of rule context.

The CurrentProductStockCountConditionT type exposes the following members.

Constructors
 | Name | Description
Public method | CurrentProductStockCountConditionT | Initializes a new instance of the CurrentProductStockCountConditionT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | Executes the specified rule context. (Inherited from StockCountConditionBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location. (Overrides StockCountConditionBaseTGetLocation.)
Protected method | GetOperator | (Inherited from OperatorConditionT.)
Protected method | GetProductId | Gets the product id. (Overrides StockCountConditionBaseTGetProductId.)
Protected method | GetStockInformation | Gets the stock information. (Inherited from StockCountConditionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context. (Inherited from StockCountConditionBaseT.)
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider. (Inherited from StockCountConditionBaseT.)
Public property | OperatorId | (Inherited from OperatorConditionT.)
Public property | StockCount | Gets or sets the product stock count. (Inherited from StockCountConditionBaseT.)
Top
See Also

Reference

Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockCountCondition(T) Constructor

CurrentProductStockCountConditionT Constructor
Initializes a new instance of the CurrentProductStockCountConditionT class

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CurrentProductStockCountCondition()
Public Sub New
public:
CurrentProductStockCountCondition()
new : unit -> CurrentProductStockCountCondition
See Also

Reference

CurrentProductStockCountConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockCountCondition(T) Methods

CurrentProductStockCountConditionT Methods

The CurrentProductStockCountConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | Executes the specified rule context. (Inherited from StockCountConditionBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location. (Overrides StockCountConditionBaseTGetLocation.)
Protected method | GetOperator | (Inherited from OperatorConditionT .)
Protected method | GetProductId | Gets the product id. (Overrides StockCountConditionBaseTGetProductId.)
Protected method | GetStockInformation | Gets the stock information. (Inherited from StockCountConditionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CurrentProductStockCountConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockCountCondition(T).GetLocation Method

CurrentProductStockCountConditionTGetLocation Method
Gets the location.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetLocation()
Protected Overrides Function GetLocation As String
protected:
virtual String^ GetLocation() override
abstract GetLocation : unit -> string
override GetLocation : unit -> string

Return Value

Type: String
The location.
See Also

Reference

CurrentProductStockCountConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockCountCondition(T).GetProductId Method

CurrentProductStockCountConditionTGetProductId Method
Gets the product id.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetProductId()
Protected Overrides Function GetProductId As String
protected:
virtual String^ GetProductId() override
abstract GetProductId : unit -> string
override GetProductId : unit -> string

Return Value

Type: String
The product id.
See Also

Reference

CurrentProductStockCountConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockCountCondition(T) Properties

CurrentProductStockCountConditionT Properties

The CurrentProductStockCountConditionT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context. (Inherited from StockCountConditionBaseT.)
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider. (Inherited from StockCountConditionBaseT.)
Public property | OperatorId | (Inherited from OperatorConditionT .)
Public property | StockCount | Gets or sets the product stock count. (Inherited from StockCountConditionBaseT.)
Top
See Also

Reference

CurrentProductStockCountConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockStatusByLocationCondition(T) Class

CurrentProductStockStatusByLocationConditionT Class
Defines the condition to compare the stock status of a product with a predefined value. The condition follows the following format: “where current product has stock status equal to [ProductStockStatus] in the location [Location]”
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
Sitecore.Commerce.Rules.Conditions.InventoryStockStatusConditionBase T
Sitecore.Commerce.Rules.Conditions.InventoryCurrentProductStockStatusByLocationConditionT

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CurrentProductStockStatusByLocationCondition<T> : StockStatusConditionBase<T>
where T : RuleContext

Public Class CurrentProductStockStatusByLocationCondition(Of T As RuleContext)
    Inherits StockStatusConditionBase(Of T)
generic<typename T>
where T : RuleContext
public ref class CurrentProductStockStatusByLocationCondition : public StockStatusConditionBase<T>
type CurrentProductStockStatusByLocationCondition<'T when 'T : RuleContext> =
    class
        inherit StockStatusConditionBase<'T>
    end

Type Parameters

T
Type of rule context.

The CurrentProductStockStatusByLocationConditionT type exposes the following members.

Constructors
 | Name | Description
Public method | CurrentProductStockStatusByLocationConditionT | Initializes a new instance of the CurrentProductStockStatusByLocationConditionT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | Executes the specified rule context. (Inherited from StockStatusConditionBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location. (Overrides StockStatusConditionBaseTGetLocation.)
Protected method | GetStockInformation | Gets the stock information. (Inherited from StockStatusConditionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context. (Inherited from StockStatusConditionBaseT.)
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider. (Inherited from StockStatusConditionBaseT.)
Public property | Location | Gets or sets the location.
Public property | StockStatus | Gets or sets the product stock count. (Inherited from StockStatusConditionBaseT.)
Top
See Also

Reference

Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockStatusByLocationCondition(T) Constructor

CurrentProductStockStatusByLocationConditionT Constructor
Initializes a new instance of the CurrentProductStockStatusByLocationConditionT class

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CurrentProductStockStatusByLocationCondition()
Public Sub New
public:
CurrentProductStockStatusByLocationCondition()
new : unit -> CurrentProductStockStatusByLocationCondition
See Also

Reference

CurrentProductStockStatusByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockStatusByLocationCondition(T) Methods

CurrentProductStockStatusByLocationConditionT Methods

The CurrentProductStockStatusByLocationConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | Executes the specified rule context. (Inherited from StockStatusConditionBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location. (Overrides StockStatusConditionBaseTGetLocation.)
Protected method | GetStockInformation | Gets the stock information. (Inherited from StockStatusConditionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CurrentProductStockStatusByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockStatusByLocationCondition(T).GetLocation Method

CurrentProductStockStatusByLocationConditionTGetLocation Method
Gets the location.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetLocation()
Protected Overrides Function GetLocation As String
protected:
virtual String^ GetLocation() override
abstract GetLocation : unit -> string
override GetLocation : unit -> string

Return Value

Type: String
The location.
See Also

Reference

CurrentProductStockStatusByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockStatusByLocationCondition(T) Properties

CurrentProductStockStatusByLocationConditionT Properties

The CurrentProductStockStatusByLocationConditionT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context. (Inherited from StockStatusConditionBaseT.)
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider. (Inherited from StockStatusConditionBaseT.)
Public property | Location | Gets or sets the location.
Public property | StockStatus | Gets or sets the product stock count. (Inherited from StockStatusConditionBaseT.)
Top
See Also

Reference

CurrentProductStockStatusByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockStatusByLocationCondition(T).Location Property

CurrentProductStockStatusByLocationConditionTLocation Property
Gets or sets the location.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
The shop location.
See Also

Reference

CurrentProductStockStatusByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockStatusCondition(T) Class

CurrentProductStockStatusConditionT Class
Defines the condition to compare the stock status of a product with a predefined value. The condition follows the following format: “where current product has stock status equal to [ProductStockStatus]”
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
Sitecore.Commerce.Rules.Conditions.InventoryStockStatusConditionBase T
Sitecore.Commerce.Rules.Conditions.InventoryCurrentProductStockStatusConditionT

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CurrentProductStockStatusCondition<T> : StockStatusConditionBase<T>
where T : RuleContext

Public Class CurrentProductStockStatusCondition(Of T As RuleContext)
    Inherits StockStatusConditionBase(Of T)
generic<typename T>
where T : RuleContext
public ref class CurrentProductStockStatusCondition : public StockStatusConditionBase<T>
type CurrentProductStockStatusCondition<'T when 'T : RuleContext> =
    class
        inherit StockStatusConditionBase<'T>
    end

Type Parameters

T
Type of rule context.

The CurrentProductStockStatusConditionT type exposes the following members.

Constructors
 | Name | Description
Public method | CurrentProductStockStatusConditionT | Initializes a new instance of the CurrentProductStockStatusConditionT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | Executes the specified rule context. (Inherited from StockStatusConditionBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location. (Overrides StockStatusConditionBaseTGetLocation.)
Protected method | GetStockInformation | Gets the stock information. (Inherited from StockStatusConditionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context. (Inherited from StockStatusConditionBaseT.)
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider. (Inherited from StockStatusConditionBaseT.)
Public property | StockStatus | Gets or sets the product stock count. (Inherited from StockStatusConditionBaseT.)
Top
See Also

Reference

Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockStatusCondition(T) Constructor

CurrentProductStockStatusConditionT Constructor
Initializes a new instance of the CurrentProductStockStatusConditionT class

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CurrentProductStockStatusCondition()
Public Sub New
public:
CurrentProductStockStatusCondition()
new : unit -> CurrentProductStockStatusCondition
See Also

Reference

CurrentProductStockStatusConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockStatusCondition(T) Methods

CurrentProductStockStatusConditionT Methods

The CurrentProductStockStatusConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | Executes the specified rule context. (Inherited from StockStatusConditionBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location. (Overrides StockStatusConditionBaseTGetLocation.)
Protected method | GetStockInformation | Gets the stock information. (Inherited from StockStatusConditionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CurrentProductStockStatusConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockStatusCondition(T).GetLocation Method

CurrentProductStockStatusConditionTGetLocation Method
Gets the location.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetLocation()
Protected Overrides Function GetLocation As String
protected:
virtual String^ GetLocation() override
abstract GetLocation : unit -> string
override GetLocation : unit -> string

Return Value

Type: String
The location.
See Also

Reference

CurrentProductStockStatusConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


CurrentProductStockStatusCondition(T) Properties

CurrentProductStockStatusConditionT Properties

The CurrentProductStockStatusConditionT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context. (Inherited from StockStatusConditionBaseT.)
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider. (Inherited from StockStatusConditionBaseT.)
Public property | StockStatus | Gets or sets the product stock count. (Inherited from StockStatusConditionBaseT.)
Top
See Also

Reference

CurrentProductStockStatusConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountByLocationCondition(T) Class

SpecificProductStockCountByLocationConditionT Class
Defines the condition to compare the stock count of a product with a predefined value. The condition follows the following format: “where the stock count of product [ProductId] [Compares to] [ProductStockCount] in the location [Location]” I this format, the [Compares to] clause can be any two-operand comparison operator: <,>,<=,=,=>
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
OperatorConditionT
Sitecore.Commerce.Rules.Conditions.InventoryStockCountConditionBase T
Sitecore.Commerce.Rules.Conditions.InventorySpecificProductStockCountByLocationConditionT

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SpecificProductStockCountByLocationCondition<T> : StockCountConditionBase<T>
where T : RuleContext

Public Class SpecificProductStockCountByLocationCondition(Of T As RuleContext)
    Inherits StockCountConditionBase(Of T)
generic<typename T>
where T : RuleContext
public ref class SpecificProductStockCountByLocationCondition : public StockCountConditionBase<T>
type SpecificProductStockCountByLocationCondition<'T when 'T : RuleContext> =
    class
        inherit StockCountConditionBase<'T>
    end

Type Parameters

T
Type of rule context.

The SpecificProductStockCountByLocationConditionT type exposes the following members.

Constructors
 | Name | Description
Public method | SpecificProductStockCountByLocationConditionT | Initializes a new instance of the SpecificProductStockCountByLocationConditionT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | Executes the specified rule context. (Inherited from StockCountConditionBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location. (Overrides StockCountConditionBaseTGetLocation.)
Protected method | GetOperator | (Inherited from OperatorConditionT.)
Protected method | GetProductId | Gets the product id. (Overrides StockCountConditionBaseTGetProductId.)
Protected method | GetStockInformation | Gets the stock information. (Inherited from StockCountConditionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context. (Inherited from StockCountConditionBaseT.)
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider. (Inherited from StockCountConditionBaseT.)
Public property | Location | Gets or sets the location.
Public property | OperatorId | (Inherited from OperatorConditionT.)
Public property | ProductId | Gets or sets the product id.
Public property | StockCount | Gets or sets the product stock count. (Inherited from StockCountConditionBaseT.)
Top
See Also

Reference

Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountByLocationCondition(T) Constructor

SpecificProductStockCountByLocationConditionT Constructor
Initializes a new instance of the SpecificProductStockCountByLocationConditionT class

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SpecificProductStockCountByLocationCondition()
Public Sub New
public:
SpecificProductStockCountByLocationCondition()
new : unit -> SpecificProductStockCountByLocationCondition
See Also

Reference

SpecificProductStockCountByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountByLocationCondition(T) Methods

SpecificProductStockCountByLocationConditionT Methods

The SpecificProductStockCountByLocationConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | Executes the specified rule context. (Inherited from StockCountConditionBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location. (Overrides StockCountConditionBaseTGetLocation.)
Protected method | GetOperator | (Inherited from OperatorConditionT .)
Protected method | GetProductId | Gets the product id. (Overrides StockCountConditionBaseTGetProductId.)
Protected method | GetStockInformation | Gets the stock information. (Inherited from StockCountConditionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SpecificProductStockCountByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountByLocationCondition(T).GetLocation Method

SpecificProductStockCountByLocationConditionTGetLocation Method
Gets the location.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetLocation()
Protected Overrides Function GetLocation As String
protected:
virtual String^ GetLocation() override
abstract GetLocation : unit -> string
override GetLocation : unit -> string

Return Value

Type: String
The location.
See Also

Reference

SpecificProductStockCountByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountByLocationCondition(T).GetProductId Method

SpecificProductStockCountByLocationConditionTGetProductId Method
Gets the product id.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetProductId()
Protected Overrides Function GetProductId As String
protected:
virtual String^ GetProductId() override
abstract GetProductId : unit -> string
override GetProductId : unit -> string

Return Value

Type: String
The product id.
See Also

Reference

SpecificProductStockCountByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountByLocationCondition(T) Properties

SpecificProductStockCountByLocationConditionT Properties

The SpecificProductStockCountByLocationConditionT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context. (Inherited from StockCountConditionBaseT.)
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider. (Inherited from StockCountConditionBaseT.)
Public property | Location | Gets or sets the location.
Public property | OperatorId | (Inherited from OperatorConditionT .)
Public property | ProductId | Gets or sets the product id.
Public property | StockCount | Gets or sets the product stock count. (Inherited from StockCountConditionBaseT.)
Top
See Also

Reference

SpecificProductStockCountByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountByLocationCondition(T).Location Property

SpecificProductStockCountByLocationConditionTLocation Property
Gets or sets the location.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
The shop location.
See Also

Reference

SpecificProductStockCountByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountByLocationCondition(T).ProductId Property

SpecificProductStockCountByLocationConditionTProductId Property
Gets or sets the product id.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ProductId { get; set; }
Public Property ProductId As String
    Get
    Set
public:
property String^ ProductId {
    String^ get ();
    void set (String^ value);
}
member ProductId : string with get, set

Property Value

Type: String
The product id.
See Also

Reference

SpecificProductStockCountByLocationConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountCondition(T) Class

SpecificProductStockCountConditionT Class
Defines the condition to compare the stock count of a product with a predefined value. The condition follows the following format: “where the stock count of product [ProductId] [Compares to] [ProductStockCount]” I this format, the [Compares to] clause can be any two-operand comparison operator: <,>,<=,=,=>
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
OperatorConditionT
Sitecore.Commerce.Rules.Conditions.InventoryStockCountConditionBase T
Sitecore.Commerce.Rules.Conditions.InventorySpecificProductStockCountConditionT

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SpecificProductStockCountCondition<T> : StockCountConditionBase<T>
where T : RuleContext

Public Class SpecificProductStockCountCondition(Of T As RuleContext)
    Inherits StockCountConditionBase(Of T)
generic<typename T>
where T : RuleContext
public ref class SpecificProductStockCountCondition : public StockCountConditionBase<T>
type SpecificProductStockCountCondition<'T when 'T : RuleContext> =
    class
        inherit StockCountConditionBase<'T>
    end

Type Parameters

T
Type of rule context.

The SpecificProductStockCountConditionT type exposes the following members.

Constructors
 | Name | Description
Public method | SpecificProductStockCountConditionT | Initializes a new instance of the SpecificProductStockCountConditionT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | Executes the specified rule context. (Inherited from StockCountConditionBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location. (Overrides StockCountConditionBaseTGetLocation.)
Protected method | GetOperator | (Inherited from OperatorConditionT.)
Protected method | GetProductId | Gets the product id. (Overrides StockCountConditionBaseTGetProductId.)
Protected method | GetStockInformation | Gets the stock information. (Inherited from StockCountConditionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context. (Inherited from StockCountConditionBaseT.)
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider. (Inherited from StockCountConditionBaseT.)
Public property | OperatorId | (Inherited from OperatorConditionT.)
Public property | ProductId | Gets or sets the product id.
Public property | StockCount | Gets or sets the product stock count. (Inherited from StockCountConditionBaseT.)
Top
See Also

Reference

Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountCondition(T) Constructor

SpecificProductStockCountConditionT Constructor
Initializes a new instance of the SpecificProductStockCountConditionT class

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SpecificProductStockCountCondition()
Public Sub New
public:
SpecificProductStockCountCondition()
new : unit -> SpecificProductStockCountCondition
See Also

Reference

SpecificProductStockCountConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountCondition(T) Methods

SpecificProductStockCountConditionT Methods

The SpecificProductStockCountConditionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | Executes the specified rule context. (Inherited from StockCountConditionBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location. (Overrides StockCountConditionBaseTGetLocation.)
Protected method | GetOperator | (Inherited from OperatorConditionT .)
Protected method | GetProductId | Gets the product id. (Overrides StockCountConditionBaseTGetProductId.)
Protected method | GetStockInformation | Gets the stock information. (Inherited from StockCountConditionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SpecificProductStockCountConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountCondition(T).GetLocation Method

SpecificProductStockCountConditionTGetLocation Method
Gets the location.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetLocation()
Protected Overrides Function GetLocation As String
protected:
virtual String^ GetLocation() override
abstract GetLocation : unit -> string
override GetLocation : unit -> string

Return Value

Type: String
The location.
See Also

Reference

SpecificProductStockCountConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountCondition(T).GetProductId Method

SpecificProductStockCountConditionTGetProductId Method
Gets the product id.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override string GetProductId()
Protected Overrides Function GetProductId As String
protected:
virtual String^ GetProductId() override
abstract GetProductId : unit -> string
override GetProductId : unit -> string

Return Value

Type: String
The product id.
See Also

Reference

SpecificProductStockCountConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountCondition(T) Properties

SpecificProductStockCountConditionT Properties

The SpecificProductStockCountConditionT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context. (Inherited from StockCountConditionBaseT.)
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider. (Inherited from StockCountConditionBaseT.)
Public property | OperatorId | (Inherited from OperatorConditionT .)
Public property | ProductId | Gets or sets the product id.
Public property | StockCount | Gets or sets the product stock count. (Inherited from StockCountConditionBaseT.)
Top
See Also

Reference

SpecificProductStockCountConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


SpecificProductStockCountCondition(T).ProductId Property

SpecificProductStockCountConditionTProductId Property
Gets or sets the product id.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ProductId { get; set; }
Public Property ProductId As String
    Get
    Set
public:
property String^ ProductId {
    String^ get ();
    void set (String^ value);
}
member ProductId : string with get, set

Property Value

Type: String
The product id.
See Also

Reference

SpecificProductStockCountConditionT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockCountConditionBase(T) Class

StockCountConditionBaseT Class
Defines the base class for all condition classes that operate on stock status.
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
OperatorConditionT
Sitecore.Commerce.Rules.Conditions.InventoryStockCountConditionBaseT
Sitecore.Commerce.Rules.Conditions.InventoryCurrentProductStockCountByLocationConditionT
Sitecore.Commerce.Rules.Conditions.InventoryCurrentProductStockCountConditionT
Sitecore.Commerce.Rules.Conditions.InventorySpecificProductStockCountByLocationConditionT
Sitecore.Commerce.Rules.Conditions.InventorySpecificProductStockCountConditionT

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class StockCountConditionBase<T> : OperatorCondition<T>
where T : RuleContext

Public MustInherit Class StockCountConditionBase(Of T As RuleContext)
    Inherits OperatorCondition(Of T)
generic<typename T>
where T : RuleContext
public ref class StockCountConditionBase abstract : public OperatorCondition<T>
[<AbstractClassAttribute>]
type StockCountConditionBase<'T when 'T : RuleContext> =
    class
        inherit OperatorCondition<'T>
    end

Type Parameters

T
Type of rule context.

The StockCountConditionBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | StockCountConditionBaseT | Initializes a new instance of the StockCountConditionBaseT class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | Executes the specified rule context. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location.
Protected method | GetOperator | (Inherited from OperatorConditionT.)
Protected method | GetProductId | Gets the product id.
Protected method | GetStockInformation | Gets the stock information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context.
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider.
Public property | OperatorId | (Inherited from OperatorConditionT.)
Public property | StockCount | Gets or sets the product stock count.
Top
See Also

Reference

Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockCountConditionBase(T) Constructor

StockCountConditionBaseT Constructor
Initializes a new instance of the StockCountConditionBaseT class.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected StockCountConditionBase()
Protected Sub New
protected:
StockCountConditionBase()
new : unit -> StockCountConditionBase
See Also

Reference

StockCountConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockCountConditionBase(T) Methods

StockCountConditionBaseT Methods

The StockCountConditionBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | Executes the specified rule context. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location.
Protected method | GetOperator | (Inherited from OperatorConditionT .)
Protected method | GetProductId | Gets the product id.
Protected method | GetStockInformation | Gets the stock information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StockCountConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockCountConditionBase(T).Execute Method

StockCountConditionBaseTExecute Method
Executes the specified rule context.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override bool Execute(
    T ruleContext
)
Protected Overrides Function Execute (
    ruleContext As T
) As Boolean
protected:
virtual bool Execute(
    T ruleContext
) override
abstract Execute :
        ruleContext : 'T -> bool
override Execute :
        ruleContext : 'T -> bool

Parameters

ruleContext
Type: T
The rule context.

Return Value

Type: Boolean
Result of condition execution.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when unknown operator was specified.
See Also

Reference

StockCountConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockCountConditionBase(T).GetLocation Method

StockCountConditionBaseTGetLocation Method
Gets the location.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract string GetLocation()
Protected MustOverride Function GetLocation As String
protected:
virtual String^ GetLocation() abstract
abstract GetLocation : unit -> string

Return Value

Type: String
The location.
See Also

Reference

StockCountConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockCountConditionBase(T).GetProductId Method

StockCountConditionBaseTGetProductId Method
Gets the product id.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract string GetProductId()
Protected MustOverride Function GetProductId As String
protected:
virtual String^ GetProductId() abstract
abstract GetProductId : unit -> string

Return Value

Type: String
The product id.
See Also

Reference

StockCountConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockCountConditionBase(T).GetStockInformation Method

StockCountConditionBaseTGetStockInformation Method
Gets the stock information.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual StockInformation GetStockInformation(
    string location,
    string productId
)
Protected Overridable Function GetStockInformation (
    location As String,
    productId As String
) As StockInformation
protected:
virtual StockInformation^ GetStockInformation(
    String^ location,
    String^ productId
)
abstract GetStockInformation :
        location : string *
        productId : string -> StockInformation
override GetStockInformation :
        location : string *
        productId : string -> StockInformation

Parameters

location
Type: SystemString
The location.
productId
Type: SystemString
The product id.

Return Value

Type: StockInformation
Te.
See Also

Reference

StockCountConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockCountConditionBase(T) Properties

StockCountConditionBaseT Properties

The StockCountConditionBaseT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context.
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider.
Public property | OperatorId | (Inherited from OperatorConditionT .)
Public property | StockCount | Gets or sets the product stock count.
Top
See Also

Reference

StockCountConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockCountConditionBase(T).CommerceContext Property

StockCountConditionBaseTCommerceContext Property
Gets or sets the commerce context.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected CommerceContextBase CommerceContext { get; set; }
Protected Property CommerceContext As CommerceContextBase
    Get
    Set
protected:
property CommerceContextBase^ CommerceContext {
    CommerceContextBase^ get ();
    void set (CommerceContextBase^ value);
}
member CommerceContext : CommerceContextBase with get, set

Property Value

Type: CommerceContextBase
The commerce context.
See Also

Reference

StockCountConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockCountConditionBase(T).InventoryServiceProvider Property

StockCountConditionBaseTInventoryServiceProvider Property
Gets or sets the inventory service provider.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected InventoryServiceProvider InventoryServiceProvider { get; set; }
Protected Property InventoryServiceProvider As InventoryServiceProvider
    Get
    Set
protected:
property InventoryServiceProvider^ InventoryServiceProvider {
    InventoryServiceProvider^ get ();
    void set (InventoryServiceProvider^ value);
}
member InventoryServiceProvider : InventoryServiceProvider with get, set

Property Value

Type: InventoryServiceProvider
The inventory service provider.
See Also

Reference

StockCountConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockCountConditionBase(T).StockCount Property

StockCountConditionBaseTStockCount Property
Gets or sets the product stock count.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public uint StockCount { get; set; }
Public Property StockCount As UInteger
    Get
    Set
public:
property unsigned int StockCount {
    unsigned int get ();
    void set (unsigned int value);
}
member StockCount : uint32 with get, set

Property Value

Type: UInt32
The product stock count.
See Also

Reference

StockCountConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockStatusConditionBase(T) Class

StockStatusConditionBaseT Class
Defines the base class for all condition classes that operate on stock status.
Inheritance Hierarchy
SystemObject
RuleConditionT
WhenConditionT
Sitecore.Commerce.Rules.Conditions.InventoryStockStatusConditionBaseT
Sitecore.Commerce.Rules.Conditions.InventoryCurrentProductStockStatusByLocationConditionT
Sitecore.Commerce.Rules.Conditions.InventoryCurrentProductStockStatusConditionT

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class StockStatusConditionBase<T> : WhenCondition<T>
where T : RuleContext

Public MustInherit Class StockStatusConditionBase(Of T As RuleContext)
    Inherits WhenCondition(Of T)
generic<typename T>
where T : RuleContext
public ref class StockStatusConditionBase abstract : public WhenCondition<T>
[<AbstractClassAttribute>]
type StockStatusConditionBase<'T when 'T : RuleContext> =
    class
        inherit WhenCondition<'T>
    end

Type Parameters

T
Type of rule context.

The StockStatusConditionBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | StockStatusConditionBaseT | Initializes a new instance of the StockStatusConditionBaseT class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT.)
Protected method | Execute | Executes the specified rule context. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location.
Protected method | GetStockInformation | Gets the stock information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context.
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider.
Public property | StockStatus | Gets or sets the product stock count.
Top
See Also

Reference

Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockStatusConditionBase(T) Constructor

StockStatusConditionBaseT Constructor
Initializes a new instance of the StockStatusConditionBaseT class.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected StockStatusConditionBase()
Protected Sub New
protected:
StockStatusConditionBase()
new : unit -> StockStatusConditionBase
See Also

Reference

StockStatusConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockStatusConditionBase(T) Methods

StockStatusConditionBaseT Methods

The StockStatusConditionBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Inherited from WhenConditionT .)
Protected method | Execute | Executes the specified rule context. (Overrides WhenCondition.Execute(UTP).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocation | Gets the location.
Protected method | GetStockInformation | Gets the stock information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StockStatusConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockStatusConditionBase(T).Execute Method

StockStatusConditionBaseTExecute Method
Executes the specified rule context.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override bool Execute(
    T ruleContext
)
Protected Overrides Function Execute (
    ruleContext As T
) As Boolean
protected:
virtual bool Execute(
    T ruleContext
) override
abstract Execute :
        ruleContext : 'T -> bool
override Execute :
        ruleContext : 'T -> bool

Parameters

ruleContext
Type: T
The rule context.

Return Value

Type: Boolean
Result of condition execution.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when unknown operator was specified.
See Also

Reference

StockStatusConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockStatusConditionBase(T).GetLocation Method

StockStatusConditionBaseTGetLocation Method
Gets the location.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected abstract string GetLocation()
Protected MustOverride Function GetLocation As String
protected:
virtual String^ GetLocation() abstract
abstract GetLocation : unit -> string

Return Value

Type: String
The location.
See Also

Reference

StockStatusConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockStatusConditionBase(T).GetStockInformation Method

StockStatusConditionBaseTGetStockInformation Method
Gets the stock information.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual StockInformation GetStockInformation(
    string location,
    string productId
)
Protected Overridable Function GetStockInformation (
    location As String,
    productId As String
) As StockInformation
protected:
virtual StockInformation^ GetStockInformation(
    String^ location,
    String^ productId
)
abstract GetStockInformation :
        location : string *
        productId : string -> StockInformation
override GetStockInformation :
        location : string *
        productId : string -> StockInformation

Parameters

location
Type: SystemString
The location.
productId
Type: SystemString
The product id.

Return Value

Type: StockInformation
Te.
See Also

Reference

StockStatusConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockStatusConditionBase(T) Properties

StockStatusConditionBaseT Properties

The StockStatusConditionBaseT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CommerceContext | Gets or sets the commerce context.
Protected property | InventoryServiceProvider | Gets or sets the inventory service provider.
Public property | StockStatus | Gets or sets the product stock count.
Top
See Also

Reference

StockStatusConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockStatusConditionBase(T).CommerceContext Property

StockStatusConditionBaseTCommerceContext Property
Gets or sets the commerce context.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected CommerceContextBase CommerceContext { get; set; }
Protected Property CommerceContext As CommerceContextBase
    Get
    Set
protected:
property CommerceContextBase^ CommerceContext {
    CommerceContextBase^ get ();
    void set (CommerceContextBase^ value);
}
member CommerceContext : CommerceContextBase with get, set

Property Value

Type: CommerceContextBase
The commerce context.
See Also

Reference

StockStatusConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockStatusConditionBase(T).InventoryServiceProvider Property

StockStatusConditionBaseTInventoryServiceProvider Property
Gets or sets the inventory service provider.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected InventoryServiceProvider InventoryServiceProvider { get; set; }
Protected Property InventoryServiceProvider As InventoryServiceProvider
    Get
    Set
protected:
property InventoryServiceProvider^ InventoryServiceProvider {
    InventoryServiceProvider^ get ();
    void set (InventoryServiceProvider^ value);
}
member InventoryServiceProvider : InventoryServiceProvider with get, set

Property Value

Type: InventoryServiceProvider
The inventory service provider.
See Also

Reference

StockStatusConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


StockStatusConditionBase(T).StockStatus Property

StockStatusConditionBaseTStockStatus Property
Gets or sets the product stock count.

Namespace: Sitecore.Commerce.Rules.Conditions.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string StockStatus { get; set; }
Public Property StockStatus As String
    Get
    Set
public:
property String^ StockStatus {
    String^ get ();
    void set (String^ value);
}
member StockStatus : string with get, set

Property Value

Type: String
The product stock count.
See Also

Reference

StockStatusConditionBaseT Class
Sitecore.Commerce.Rules.Conditions.Inventory Namespace


Sitecore.Commerce.Search Namespace

Sitecore.Commerce.Search Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Search"]

Classes
 | Class | Description
Public class | ProductItemCrawler | Inclusing products, ignoring global excluded settings


ProductItemCrawler Class

ProductItemCrawler Class
Inclusing products, ignoring global excluded settings
Inheritance Hierarchy
SystemObject
CrawlerSitecoreIndexableItem
HierarchicalDataCrawlerSitecoreIndexableItem
SitecoreItemCrawler
Sitecore.Commerce.SearchProductItemCrawler

Namespace: Sitecore.Commerce.Search
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ProductItemCrawler : SitecoreItemCrawler
Public Class ProductItemCrawler
    Inherits SitecoreItemCrawler
public ref class ProductItemCrawler : public SitecoreItemCrawler
type ProductItemCrawler =
    class
        inherit SitecoreItemCrawler
    end

The ProductItemCrawler type exposes the following members.

Constructors
 | Name | Description
Public method | ProductItemCrawler | Initializes a new instance of the ProductItemCrawler class
Top
Methods
 | Name | Description
Protected method | AddHierarchicalRecursive(UTP, IProviderUpdateContext, ProviderIndexConfiguration) | Obsolete. (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Protected method | AddHierarchicalRecursive(UTP, IProviderUpdateContext, ProviderIndexConfiguration, CancellationToken) | (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Protected method | AddHieraricalRecursive | Obsolete. (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Public method | Delete(IProviderUpdateContext, IIndexableId, IndexingOptions) | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | Delete(IProviderUpdateContext, IIndexableUniqueId, IndexingOptions) | (Inherited from CrawlerSitecoreIndexableItem.)
Protected method | DoAdd | (Inherited from SitecoreItemCrawler.)
Protected method | DoUpdate | (Inherited from SitecoreItemCrawler.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChildList | (Inherited from SitecoreItemCrawler.)
Public method | GetCustomIncludeTemplates | Retrieves a list of templates ids
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIncludeTemplates | Retrieves a list of global and custom include templates
Protected method | GetIndexable(IIndexableUniqueId) | (Inherited from SitecoreItemCrawler.)
Protected method | GetIndexable(IIndexableId, CultureInfo) | (Inherited from SitecoreItemCrawler.)
Protected method | GetIndexableAndCheckDeletes | (Inherited from SitecoreItemCrawler.)
Protected method | GetIndexableChildren | (Inherited from SitecoreItemCrawler.)
Protected method | GetIndexableChildrenIds | (Inherited from SitecoreItemCrawler.)
Public method | GetIndexableRoot | (Inherited from SitecoreItemCrawler.)
Protected method | GetIndexablesToUpdateOnDelete | (Inherited from SitecoreItemCrawler.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GroupShouldBeDeleted | (Inherited from SitecoreItemCrawler.)
Protected method | IndexUpdateNeedDelete | (Inherited from SitecoreItemCrawler.)
Public method | Initialize | (Inherited from SitecoreItemCrawler.)
Protected method | IsAncestorOf | (Inherited from SitecoreItemCrawler.)
Public method | IsExcludedFromIndex(IIndexable) | (Inherited from SitecoreItemCrawler.)
Protected method | IsExcludedFromIndex(IIndexableUniqueId) | (Inherited from SitecoreItemCrawler.)
Protected method | IsExcludedFromIndex(SitecoreIndexableItem, Boolean) | Determines whether [is excluded from index] [the specified indexable]. (Overrides SitecoreItemCrawler.IsExcludedFromIndex(SitecoreIndexableItem, Boolean).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPauseIndexing | (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Protected method | OnResumeIndexing | (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Protected method | OnStopIndexing | (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Public method | PauseIndexing | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | RebuildFromRoot(IProviderUpdateContext, IndexingOptions) | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | RebuildFromRoot(IProviderUpdateContext, IndexingOptions, CancellationToken) | (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Public method | RefreshFromRoot(IProviderUpdateContext, IIndexable, IndexingOptions) | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | RefreshFromRoot(IProviderUpdateContext, UTP, IndexingOptions) | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | RefreshFromRoot(IProviderUpdateContext, UTP, IndexingOptions, CancellationToken) | (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Public method | RefreshFromRoot(IProviderUpdateContext, IIndexable, IndexingOptions, CancellationToken) | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | ResumeIndexing | (Inherited from CrawlerSitecoreIndexableItem.)
Protected method | ShouldStartIndexing | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | StopIndexing | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | (Inherited from CrawlerSitecoreIndexableItem.)
Protected method | UpdateDependents | (Inherited from CrawlerSitecoreIndexableItem.)
Protected method | UpdateHierarchicalRecursive | (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Protected method | UpdateRecursive | Obsolete. (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Protected method | WaitUntilUnPaused | (Inherited from CrawlerSitecoreIndexableItem.)
Top
Fields
 | Name | Description
Protected field | index | (Inherited from CrawlerSitecoreIndexableItem.)
Protected field | state | (Inherited from CrawlerSitecoreIndexableItem.)
Top
Properties
 | Name | Description
Public property | Database | (Inherited from SitecoreItemCrawler.)
Public property | DocumentOptions | (Inherited from CrawlerSitecoreIndexableItem.)
Public property | Index | (Inherited from CrawlerSitecoreIndexableItem.)
Protected property | Operations | (Inherited from CrawlerSitecoreIndexableItem.)
Public property | Root | (Inherited from SitecoreItemCrawler.)
Public property | RootItem | (Inherited from SitecoreItemCrawler.)
Public property | StopOnError | (Inherited from CrawlerSitecoreIndexableItem.)
Top
See Also

Reference

Sitecore.Commerce.Search Namespace


ProductItemCrawler Constructor

ProductItemCrawler Constructor
Initializes a new instance of the ProductItemCrawler class

Namespace: Sitecore.Commerce.Search
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductItemCrawler()
Public Sub New
public:
ProductItemCrawler()
new : unit -> ProductItemCrawler
See Also

Reference

ProductItemCrawler Class
Sitecore.Commerce.Search Namespace


ProductItemCrawler Fields

ProductItemCrawler Fields

The ProductItemCrawler type exposes the following members.

Fields
 | Name | Description
Protected field | index | (Inherited from CrawlerSitecoreIndexableItem.)
Protected field | state | (Inherited from CrawlerSitecoreIndexableItem.)
Top
See Also

Reference

ProductItemCrawler Class
Sitecore.Commerce.Search Namespace


ProductItemCrawler Methods

ProductItemCrawler Methods

The ProductItemCrawler type exposes the following members.

Methods
 | Name | Description
Protected method | AddHierarchicalRecursive(UTP, IProviderUpdateContext, ProviderIndexConfiguration) | Obsolete. (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Protected method | AddHierarchicalRecursive(UTP, IProviderUpdateContext, ProviderIndexConfiguration, CancellationToken) | (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Protected method | AddHieraricalRecursive | Obsolete. (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Public method | Delete(IProviderUpdateContext, IIndexableId, IndexingOptions) | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | Delete(IProviderUpdateContext, IIndexableUniqueId, IndexingOptions) | (Inherited from CrawlerSitecoreIndexableItem.)
Protected method | DoAdd | (Inherited from SitecoreItemCrawler.)
Protected method | DoUpdate | (Inherited from SitecoreItemCrawler.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChildList | (Inherited from SitecoreItemCrawler.)
Public method | GetCustomIncludeTemplates | Retrieves a list of templates ids
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIncludeTemplates | Retrieves a list of global and custom include templates
Protected method | GetIndexable(IIndexableUniqueId) | (Inherited from SitecoreItemCrawler.)
Protected method | GetIndexable(IIndexableId, CultureInfo) | (Inherited from SitecoreItemCrawler.)
Protected method | GetIndexableAndCheckDeletes | (Inherited from SitecoreItemCrawler.)
Protected method | GetIndexableChildren | (Inherited from SitecoreItemCrawler.)
Protected method | GetIndexableChildrenIds | (Inherited from SitecoreItemCrawler.)
Public method | GetIndexableRoot | (Inherited from SitecoreItemCrawler.)
Protected method | GetIndexablesToUpdateOnDelete | (Inherited from SitecoreItemCrawler.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GroupShouldBeDeleted | (Inherited from SitecoreItemCrawler.)
Protected method | IndexUpdateNeedDelete | (Inherited from SitecoreItemCrawler.)
Public method | Initialize | (Inherited from SitecoreItemCrawler.)
Protected method | IsAncestorOf | (Inherited from SitecoreItemCrawler.)
Public method | IsExcludedFromIndex(IIndexable) | (Inherited from SitecoreItemCrawler.)
Protected method | IsExcludedFromIndex(IIndexableUniqueId) | (Inherited from SitecoreItemCrawler.)
Protected method | IsExcludedFromIndex(SitecoreIndexableItem, Boolean) | Determines whether [is excluded from index] [the specified indexable]. (Overrides SitecoreItemCrawler.IsExcludedFromIndex(SitecoreIndexableItem, Boolean).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPauseIndexing | (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Protected method | OnResumeIndexing | (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Protected method | OnStopIndexing | (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Public method | PauseIndexing | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | RebuildFromRoot(IProviderUpdateContext, IndexingOptions) | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | RebuildFromRoot(IProviderUpdateContext, IndexingOptions, CancellationToken) | (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Public method | RefreshFromRoot(IProviderUpdateContext, IIndexable, IndexingOptions) | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | RefreshFromRoot(IProviderUpdateContext, UTP, IndexingOptions) | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | RefreshFromRoot(IProviderUpdateContext, UTP, IndexingOptions, CancellationToken) | (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Public method | RefreshFromRoot(IProviderUpdateContext, IIndexable, IndexingOptions, CancellationToken) | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | ResumeIndexing | (Inherited from CrawlerSitecoreIndexableItem.)
Protected method | ShouldStartIndexing | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | StopIndexing | (Inherited from CrawlerSitecoreIndexableItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | (Inherited from CrawlerSitecoreIndexableItem.)
Protected method | UpdateDependents | (Inherited from CrawlerSitecoreIndexableItem.)
Protected method | UpdateHierarchicalRecursive | (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Protected method | UpdateRecursive | Obsolete. (Inherited from HierarchicalDataCrawlerSitecoreIndexableItem.)
Protected method | WaitUntilUnPaused | (Inherited from CrawlerSitecoreIndexableItem.)
Top
See Also

Reference

ProductItemCrawler Class
Sitecore.Commerce.Search Namespace


ProductItemCrawler.GetCustomIncludeTemplates Method

ProductItemCrawlerGetCustomIncludeTemplates Method
Retrieves a list of templates ids

Namespace: Sitecore.Commerce.Search
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<string> GetCustomIncludeTemplates(
    string configPath
)
Public Overridable Function GetCustomIncludeTemplates (
    configPath As String
) As IEnumerable(Of String)
public:
virtual IEnumerable<String^>^ GetCustomIncludeTemplates(
    String^ configPath
)
abstract GetCustomIncludeTemplates :
        configPath : string -> IEnumerable<string>
override GetCustomIncludeTemplates :
        configPath : string -> IEnumerable<string>

Parameters

configPath
Type: SystemString

[Missing <param name="configPath"/> documentation for "M:Sitecore.Commerce.Search.ProductItemCrawler.GetCustomIncludeTemplates(System.String)"]

Return Value

Type: IEnumerable String
List of templates ids
See Also

Reference

ProductItemCrawler Class
Sitecore.Commerce.Search Namespace


ProductItemCrawler.GetIncludeTemplates Method

ProductItemCrawlerGetIncludeTemplates Method
Retrieves a list of global and custom include templates

Namespace: Sitecore.Commerce.Search
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual HashSet<string> GetIncludeTemplates()
Public Overridable Function GetIncludeTemplates As HashSet(Of String)
public:
virtual HashSet<String^>^ GetIncludeTemplates()
abstract GetIncludeTemplates : unit -> HashSet<string>
override GetIncludeTemplates : unit -> HashSet<string>

Return Value

Type: HashSet String
A list of global and custom include templates
See Also

Reference

ProductItemCrawler Class
Sitecore.Commerce.Search Namespace


ProductItemCrawler.IsExcludedFromIndex Method

ProductItemCrawlerIsExcludedFromIndex Method
Overload List
 | Name | Description
Public method | IsExcludedFromIndex(IIndexable) | (Inherited from SitecoreItemCrawler.)
Protected method | IsExcludedFromIndex(IIndexableUniqueId) | (Inherited from SitecoreItemCrawler.)
Protected method | IsExcludedFromIndex(SitecoreIndexableItem, Boolean) | Determines whether [is excluded from index] [the specified indexable]. (Overrides SitecoreItemCrawler.IsExcludedFromIndex(SitecoreIndexableItem, Boolean).)
Top
See Also

Reference

ProductItemCrawler Class
Sitecore.Commerce.Search Namespace


ProductItemCrawler.IsExcludedFromIndex Method (SitecoreIndexableItem, Boolean)

ProductItemCrawlerIsExcludedFromIndex Method (SitecoreIndexableItem, Boolean)
Determines whether [is excluded from index] [the specified indexable].

Namespace: Sitecore.Commerce.Search
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override bool IsExcludedFromIndex(
    SitecoreIndexableItem indexable,
    bool checkLocation = false
)
Protected Overrides Function IsExcludedFromIndex (
    indexable As SitecoreIndexableItem,
    Optional checkLocation As Boolean = false
) As Boolean
protected:
virtual bool IsExcludedFromIndex(
    SitecoreIndexableItem^ indexable,
    bool checkLocation = false
) override
abstract IsExcludedFromIndex :
        indexable : SitecoreIndexableItem *
        ?checkLocation : bool
(* Defaults:
        let _checkLocation = defaultArg checkLocation false
*)
-> bool
override IsExcludedFromIndex :
        indexable : SitecoreIndexableItem *
        ?checkLocation : bool
(* Defaults:
        let _checkLocation = defaultArg checkLocation false
*)
-> bool

Parameters

indexable
Type: SitecoreIndexableItem
The indexable.
checkLocation (Optional)
Type: SystemBoolean
if set to true [check location].

Return Value

Type: Boolean
true if the specified item is exluded from index; otherwise, false.
See Also

Reference

ProductItemCrawler Class
IsExcludedFromIndex Overload
Sitecore.Commerce.Search Namespace


ProductItemCrawler Properties

ProductItemCrawler Properties

The ProductItemCrawler type exposes the following members.

Properties
 | Name | Description
Public property | Database | (Inherited from SitecoreItemCrawler.)
Public property | DocumentOptions | (Inherited from CrawlerSitecoreIndexableItem.)
Public property | Index | (Inherited from CrawlerSitecoreIndexableItem.)
Protected property | Operations | (Inherited from CrawlerSitecoreIndexableItem.)
Public property | Root | (Inherited from SitecoreItemCrawler.)
Public property | RootItem | (Inherited from SitecoreItemCrawler.)
Public property | StopOnError | (Inherited from CrawlerSitecoreIndexableItem.)
Top
See Also

Reference

ProductItemCrawler Class
Sitecore.Commerce.Search Namespace


Sitecore.Commerce.Search.ComputedFields Namespace

Sitecore.Commerce.Search.ComputedFields Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Search.ComputedFields"]

Classes
 | Class | Description
Public class | BaseComputedField | Base class for all computef fields
Public class | BaseInventoryComputedField | Base computed field class for inventory information.
Public class | CategoryName | Category Name computed field
Public class | InStockLocations | InStockLocations computed field
Public class | ManufacturerName | Manufacturer Name computed field
Public class | OrderableLocations | OrderableLocations computed field
Public class | OutOfStockLocations | OutOfStockLocations computed field
Public class | PreOrderable | PreOrderable computed field
Public class | ProductTypeName | Type Name computed field


BaseComputedField Class

BaseComputedField Class
Base class for all computef fields
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Search.ComputedFieldsBaseComputedField
Sitecore.Commerce.Search.ComputedFieldsBaseInventoryComputedField
Sitecore.Commerce.Search.ComputedFieldsCategoryName
Sitecore.Commerce.Search.ComputedFieldsManufacturerName
Sitecore.Commerce.Search.ComputedFieldsProductTypeName

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class BaseComputedField : IComputedIndexField
Public MustInherit Class BaseComputedField
    Implements IComputedIndexField
public ref class BaseComputedField abstract : IComputedIndexField
[<AbstractClassAttribute>]
type BaseComputedField =
    class
        interface IComputedIndexField
    end

The BaseComputedField type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseComputedField | Initializes a new instance of the BaseComputedField class
Top
Methods
 | Name | Description
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call
Public method | ComputeValue | Abstract method used to kick off a computation of an indexable to build the desired value
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IdsToNameList | Converts a string of ids to a list of dispaly names for those ids
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name
Public property | ReturnType | Gets or sets the return type
Top
See Also

Reference

Sitecore.Commerce.Search.ComputedFields Namespace


BaseComputedField Constructor

BaseComputedField Constructor
Initializes a new instance of the BaseComputedField class

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected BaseComputedField()
Protected Sub New
protected:
BaseComputedField()
new : unit -> BaseComputedField
See Also

Reference

BaseComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseComputedField Methods

BaseComputedField Methods

The BaseComputedField type exposes the following members.

Methods
 | Name | Description
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call
Public method | ComputeValue | Abstract method used to kick off a computation of an indexable to build the desired value
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IdsToNameList | Converts a string of ids to a list of dispaly names for those ids
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseComputedField.ComputeFieldValue Method

BaseComputedFieldComputeFieldValue Method
Initial method called in by sitecore to launch a compute value call

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Object ComputeFieldValue(
    IIndexable indexable
)
Public Function ComputeFieldValue (
    indexable As IIndexable
) As Object
public:
virtual Object^ ComputeFieldValue(
    IIndexable^ indexable
) sealed
abstract ComputeFieldValue :
        indexable : IIndexable -> Object
override ComputeFieldValue :
        indexable : IIndexable -> Object

Parameters

indexable
Type: IIndexable
The item to index

Return Value

Type: Object
The computed fields

Implements

IComputedIndexField.ComputeFieldValue(IIndexable)
See Also

Reference

BaseComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseComputedField.ComputeValue Method

BaseComputedFieldComputeValue Method
Abstract method used to kick off a computation of an indexable to build the desired value

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract Object ComputeValue(
    IIndexable itemToIndex
)
Public MustOverride Function ComputeValue (
    itemToIndex As IIndexable
) As Object
public:
virtual Object^ ComputeValue(
    IIndexable^ itemToIndex
) abstract
abstract ComputeValue :
        itemToIndex : IIndexable -> Object

Parameters

itemToIndex
Type: IIndexable
The indexable item

Return Value

Type: Object
The computed value
See Also

Reference

BaseComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseComputedField.IdsToNameList Method

BaseComputedFieldIdsToNameList Method
Converts a string of ids to a list of dispaly names for those ids

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected static List<string> IdsToNameList(
    Item item,
    string fieldName
)
Protected Shared Function IdsToNameList (
    item As Item,
    fieldName As String
) As List(Of String)
protected:
static List<String^>^ IdsToNameList(
    Item^ item,
    String^ fieldName
)
static member IdsToNameList :
        item : Item *
        fieldName : string -> List<string>

Parameters

item
Type: Item
the indexable item
fieldName
Type: SystemString
the fieldName on the item to convert

Return Value

Type: List String

[Missing <returns> documentation for "M:Sitecore.Commerce.Search.ComputedFields.BaseComputedField.IdsToNameList(Sitecore.Data.Items.Item,System.String)"]

See Also

Reference

BaseComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseComputedField Properties

BaseComputedField Properties

The BaseComputedField type exposes the following members.

Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name
Public property | ReturnType | Gets or sets the return type
Top
See Also

Reference

BaseComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseComputedField.FieldName Property

BaseComputedFieldFieldName Property
Gets or sets the field name

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string FieldName { get; set; }
Public Property FieldName As String
    Get
    Set
public:
virtual property String^ FieldName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FieldName : string with get, set
override FieldName : string with get, set

Property Value

Type: String

Implements

IComputedIndexField.FieldName
See Also

Reference

BaseComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseComputedField.ReturnType Property

BaseComputedFieldReturnType Property
Gets or sets the return type

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ReturnType { get; set; }
Public Property ReturnType As String
    Get
    Set
public:
virtual property String^ ReturnType {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ReturnType : string with get, set
override ReturnType : string with get, set

Property Value

Type: String

Implements

IComputedIndexField.ReturnType
See Also

Reference

BaseComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseInventoryComputedField Class

BaseInventoryComputedField Class
Base computed field class for inventory information.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Search.ComputedFieldsBaseComputedField
Sitecore.Commerce.Search.ComputedFieldsBaseInventoryComputedField
Sitecore.Commerce.Search.ComputedFieldsInStockLocations
Sitecore.Commerce.Search.ComputedFieldsOrderableLocations
Sitecore.Commerce.Search.ComputedFieldsOutOfStockLocations
Sitecore.Commerce.Search.ComputedFieldsPreOrderable

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class BaseInventoryComputedField : BaseComputedField
Public MustInherit Class BaseInventoryComputedField
    Inherits BaseComputedField
public ref class BaseInventoryComputedField abstract : public BaseComputedField
[<AbstractClassAttribute>]
type BaseInventoryComputedField =
    class
        inherit BaseComputedField
    end

The BaseInventoryComputedField type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseInventoryComputedField | Initializes a new instance of the BaseInventoryComputedField class
Top
Methods
 | Name | Description
Protected method | BuildServicePipelineArgs | Builds a service request to retrieve indexing information for a specific Item.
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Abstract method used to kick off a computation of an indexable to build the desired value (Inherited from BaseComputedField.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsRequestForItem | Checks if a StockStatusForIndexingRequest will retrieve indexing information for a specific Item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RunPipeline | Executes the commerce.inventory.stockStatusForIndexing pipeline to retrieve inventory indexing information for the provided item.
Protected method | ShouldProcessItem | Checks if a computed field value should be generated for an item.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Protected property | ItemClassificationService | Gets the item classification service.
Public property | PipelineService | Gets or sets the pipeline service.
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

Sitecore.Commerce.Search.ComputedFields Namespace


BaseInventoryComputedField Constructor

BaseInventoryComputedField Constructor
Initializes a new instance of the BaseInventoryComputedField class

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected BaseInventoryComputedField()
Protected Sub New
protected:
BaseInventoryComputedField()
new : unit -> BaseInventoryComputedField
See Also

Reference

BaseInventoryComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseInventoryComputedField Methods

BaseInventoryComputedField Methods

The BaseInventoryComputedField type exposes the following members.

Methods
 | Name | Description
Protected method | BuildServicePipelineArgs | Builds a service request to retrieve indexing information for a specific Item.
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Abstract method used to kick off a computation of an indexable to build the desired value (Inherited from BaseComputedField.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsRequestForItem | Checks if a StockStatusForIndexingRequest will retrieve indexing information for a specific Item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RunPipeline | Executes the commerce.inventory.stockStatusForIndexing pipeline to retrieve inventory indexing information for the provided item.
Protected method | ShouldProcessItem | Checks if a computed field value should be generated for an item.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseInventoryComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseInventoryComputedField.BuildServicePipelineArgs Method

BaseInventoryComputedFieldBuildServicePipelineArgs Method
Builds a service request to retrieve indexing information for a specific Item.

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual ServicePipelineArgs BuildServicePipelineArgs(
    Item item
)
Protected Overridable Function BuildServicePipelineArgs (
    item As Item
) As ServicePipelineArgs
protected:
virtual ServicePipelineArgs^ BuildServicePipelineArgs(
    Item^ item
)
abstract BuildServicePipelineArgs :
        item : Item -> ServicePipelineArgs
override BuildServicePipelineArgs :
        item : Item -> ServicePipelineArgs

Parameters

item
Type: Item
The Item being indexed.

Return Value

Type: ServicePipelineArgs
A StockStatusForIndexingRequest that will retrieve indexing information for the specified item.
See Also

Reference

BaseInventoryComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseInventoryComputedField.IsRequestForItem Method

BaseInventoryComputedFieldIsRequestForItem Method
Checks if a StockStatusForIndexingRequest will retrieve indexing information for a specific Item.

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual bool IsRequestForItem(
    StockStatusForIndexingRequest request,
    Item item
)
Protected Overridable Function IsRequestForItem (
    request As StockStatusForIndexingRequest,
    item As Item
) As Boolean
protected:
virtual bool IsRequestForItem(
    StockStatusForIndexingRequest^ request,
    Item^ item
)
abstract IsRequestForItem :
        request : StockStatusForIndexingRequest *
        item : Item -> bool
override IsRequestForItem :
        request : StockStatusForIndexingRequest *
        item : Item -> bool

Parameters

request
Type: Sitecore.Commerce.Services.InventoryStockStatusForIndexingRequest
The service request.
item
Type: Item
The item being indexed.

Return Value

Type: Boolean
True if the request will retrieve information for the specified item.
See Also

Reference

BaseInventoryComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseInventoryComputedField.RunPipeline Method

BaseInventoryComputedFieldRunPipeline Method
Executes the commerce.inventory.stockStatusForIndexing pipeline to retrieve inventory indexing information for the provided item.

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual StockStatusForIndexingResult RunPipeline(
    Item item
)
Protected Overridable Function RunPipeline (
    item As Item
) As StockStatusForIndexingResult
protected:
virtual StockStatusForIndexingResult^ RunPipeline(
    Item^ item
)
abstract RunPipeline :
        item : Item -> StockStatusForIndexingResult
override RunPipeline :
        item : Item -> StockStatusForIndexingResult

Parameters

item
Type: Item
The item whose indexing information should be retrieved.

Return Value

Type: StockStatusForIndexingResult
The StockStatusForIndexingResult returned by the commerce.inventory.stockStatusForIndexing pipeline.
See Also

Reference

BaseInventoryComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseInventoryComputedField.ShouldProcessItem Method

BaseInventoryComputedFieldShouldProcessItem Method
Checks if a computed field value should be generated for an item.

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual bool ShouldProcessItem(
    Item item
)
Protected Overridable Function ShouldProcessItem (
    item As Item
) As Boolean
protected:
virtual bool ShouldProcessItem(
    Item^ item
)
abstract ShouldProcessItem :
        item : Item -> bool
override ShouldProcessItem :
        item : Item -> bool

Parameters

item
Type: Item
The item to examine.

Return Value

Type: Boolean
True if a computed field value should be generated for the item, otherwise false.
See Also

Reference

BaseInventoryComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseInventoryComputedField Properties

BaseInventoryComputedField Properties

The BaseInventoryComputedField type exposes the following members.

Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Protected property | ItemClassificationService | Gets the item classification service.
Public property | PipelineService | Gets or sets the pipeline service.
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

BaseInventoryComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseInventoryComputedField.ItemClassificationService Property

BaseInventoryComputedFieldItemClassificationService Property
Gets the item classification service.

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected IItemClassificationService ItemClassificationService { get; }
Protected ReadOnly Property ItemClassificationService As IItemClassificationService
    Get
protected:
property IItemClassificationService^ ItemClassificationService {
    IItemClassificationService^ get ();
}
member ItemClassificationService : IItemClassificationService with get

Property Value

Type: IItemClassificationService
See Also

Reference

BaseInventoryComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


BaseInventoryComputedField.PipelineService Property

BaseInventoryComputedFieldPipelineService Property
Gets or sets the pipeline service.

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PipelineService PipelineService { get; set; }
Public Property PipelineService As PipelineService
    Get
    Set
public:
property PipelineService^ PipelineService {
    PipelineService^ get ();
    void set (PipelineService^ value);
}
member PipelineService : PipelineService with get, set

Property Value

Type: PipelineService
The pipeline service.
See Also

Reference

BaseInventoryComputedField Class
Sitecore.Commerce.Search.ComputedFields Namespace


CategoryName Class

CategoryName Class
Category Name computed field
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Search.ComputedFieldsBaseComputedField
Sitecore.Commerce.Search.ComputedFieldsCategoryName

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CategoryName : BaseComputedField
Public Class CategoryName
    Inherits BaseComputedField
public ref class CategoryName : public BaseComputedField
type CategoryName =
    class
        inherit BaseComputedField
    end

The CategoryName type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryName | Initializes a new instance of the CategoryName class
Top
Methods
 | Name | Description
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Computes the value of an indexable item to build the desired value (Overrides BaseComputedFieldComputeValue(IIndexable).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

Sitecore.Commerce.Search.ComputedFields Namespace


CategoryName Constructor

CategoryName Constructor
Initializes a new instance of the CategoryName class

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CategoryName()
Public Sub New
public:
CategoryName()
new : unit -> CategoryName
See Also

Reference

CategoryName Class
Sitecore.Commerce.Search.ComputedFields Namespace


CategoryName Methods

CategoryName Methods

The CategoryName type exposes the following members.

Methods
 | Name | Description
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Computes the value of an indexable item to build the desired value (Overrides BaseComputedFieldComputeValue(IIndexable).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CategoryName Class
Sitecore.Commerce.Search.ComputedFields Namespace


CategoryName.ComputeValue Method

CategoryNameComputeValue Method
Computes the value of an indexable item to build the desired value

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override Object ComputeValue(
    IIndexable itemToIndex
)
Public Overrides Function ComputeValue (
    itemToIndex As IIndexable
) As Object
public:
virtual Object^ ComputeValue(
    IIndexable^ itemToIndex
) override
abstract ComputeValue :
        itemToIndex : IIndexable -> Object
override ComputeValue :
        itemToIndex : IIndexable -> Object

Parameters

itemToIndex
Type: IIndexable
The indexable item

Return Value

Type: Object
The computed value
See Also

Reference

CategoryName Class
Sitecore.Commerce.Search.ComputedFields Namespace


CategoryName Properties

CategoryName Properties

The CategoryName type exposes the following members.

Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

CategoryName Class
Sitecore.Commerce.Search.ComputedFields Namespace


InStockLocations Class

InStockLocations Class
InStockLocations computed field
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Search.ComputedFieldsBaseComputedField
Sitecore.Commerce.Search.ComputedFieldsBaseInventoryComputedField
Sitecore.Commerce.Search.ComputedFieldsInStockLocations

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class InStockLocations : BaseInventoryComputedField
Public Class InStockLocations
    Inherits BaseInventoryComputedField
public ref class InStockLocations : public BaseInventoryComputedField
type InStockLocations =
    class
        inherit BaseInventoryComputedField
    end

The InStockLocations type exposes the following members.

Constructors
 | Name | Description
Public method | InStockLocations | Initializes a new instance of the InStockLocations class
Top
Methods
 | Name | Description
Protected method | BuildServicePipelineArgs | Builds a service request to retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Computes the value of an indexable item to build the desired value (Overrides BaseComputedFieldComputeValue(IIndexable).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsRequestForItem | Checks if a StockStatusForIndexingRequest will retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RunPipeline | Executes the commerce.inventory.stockStatusForIndexing pipeline to retrieve inventory indexing information for the provided item. (Inherited from BaseInventoryComputedField.)
Protected method | ShouldProcessItem | Checks if a computed field value should be generated for an item. (Inherited from BaseInventoryComputedField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Protected property | ItemClassificationService | Gets the item classification service. (Inherited from BaseInventoryComputedField.)
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from BaseInventoryComputedField.)
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

Sitecore.Commerce.Search.ComputedFields Namespace


InStockLocations Constructor

InStockLocations Constructor
Initializes a new instance of the InStockLocations class

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public InStockLocations()
Public Sub New
public:
InStockLocations()
new : unit -> InStockLocations
See Also

Reference

InStockLocations Class
Sitecore.Commerce.Search.ComputedFields Namespace


InStockLocations Methods

InStockLocations Methods

The InStockLocations type exposes the following members.

Methods
 | Name | Description
Protected method | BuildServicePipelineArgs | Builds a service request to retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Computes the value of an indexable item to build the desired value (Overrides BaseComputedFieldComputeValue(IIndexable).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsRequestForItem | Checks if a StockStatusForIndexingRequest will retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RunPipeline | Executes the commerce.inventory.stockStatusForIndexing pipeline to retrieve inventory indexing information for the provided item. (Inherited from BaseInventoryComputedField.)
Protected method | ShouldProcessItem | Checks if a computed field value should be generated for an item. (Inherited from BaseInventoryComputedField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InStockLocations Class
Sitecore.Commerce.Search.ComputedFields Namespace


InStockLocations.ComputeValue Method

InStockLocationsComputeValue Method
Computes the value of an indexable item to build the desired value

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override Object ComputeValue(
    IIndexable itemToIndex
)
Public Overrides Function ComputeValue (
    itemToIndex As IIndexable
) As Object
public:
virtual Object^ ComputeValue(
    IIndexable^ itemToIndex
) override
abstract ComputeValue :
        itemToIndex : IIndexable -> Object
override ComputeValue :
        itemToIndex : IIndexable -> Object

Parameters

itemToIndex
Type: IIndexable
The indexable item

Return Value

Type: Object
The computed value
See Also

Reference

InStockLocations Class
Sitecore.Commerce.Search.ComputedFields Namespace


InStockLocations Properties

InStockLocations Properties

The InStockLocations type exposes the following members.

Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Protected property | ItemClassificationService | Gets the item classification service. (Inherited from BaseInventoryComputedField.)
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from BaseInventoryComputedField.)
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

InStockLocations Class
Sitecore.Commerce.Search.ComputedFields Namespace


ManufacturerName Class

ManufacturerName Class
Manufacturer Name computed field
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Search.ComputedFieldsBaseComputedField
Sitecore.Commerce.Search.ComputedFieldsManufacturerName

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ManufacturerName : BaseComputedField
Public Class ManufacturerName
    Inherits BaseComputedField
public ref class ManufacturerName : public BaseComputedField
type ManufacturerName =
    class
        inherit BaseComputedField
    end

The ManufacturerName type exposes the following members.

Constructors
 | Name | Description
Public method | ManufacturerName | Initializes a new instance of the ManufacturerName class
Top
Methods
 | Name | Description
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Computes the value of an indexable item to build the desired value (Overrides BaseComputedFieldComputeValue(IIndexable).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

Sitecore.Commerce.Search.ComputedFields Namespace


ManufacturerName Constructor

ManufacturerName Constructor
Initializes a new instance of the ManufacturerName class

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ManufacturerName()
Public Sub New
public:
ManufacturerName()
new : unit -> ManufacturerName
See Also

Reference

ManufacturerName Class
Sitecore.Commerce.Search.ComputedFields Namespace


ManufacturerName Methods

ManufacturerName Methods

The ManufacturerName type exposes the following members.

Methods
 | Name | Description
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Computes the value of an indexable item to build the desired value (Overrides BaseComputedFieldComputeValue(IIndexable).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ManufacturerName Class
Sitecore.Commerce.Search.ComputedFields Namespace


ManufacturerName.ComputeValue Method

ManufacturerNameComputeValue Method
Computes the value of an indexable item to build the desired value

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override Object ComputeValue(
    IIndexable itemToIndex
)
Public Overrides Function ComputeValue (
    itemToIndex As IIndexable
) As Object
public:
virtual Object^ ComputeValue(
    IIndexable^ itemToIndex
) override
abstract ComputeValue :
        itemToIndex : IIndexable -> Object
override ComputeValue :
        itemToIndex : IIndexable -> Object

Parameters

itemToIndex
Type: IIndexable
The indexable item

Return Value

Type: Object
The computed value
See Also

Reference

ManufacturerName Class
Sitecore.Commerce.Search.ComputedFields Namespace


ManufacturerName Properties

ManufacturerName Properties

The ManufacturerName type exposes the following members.

Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

ManufacturerName Class
Sitecore.Commerce.Search.ComputedFields Namespace


OrderableLocations Class

OrderableLocations Class
OrderableLocations computed field
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Search.ComputedFieldsBaseComputedField
Sitecore.Commerce.Search.ComputedFieldsBaseInventoryComputedField
Sitecore.Commerce.Search.ComputedFieldsOrderableLocations

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class OrderableLocations : BaseInventoryComputedField
Public Class OrderableLocations
    Inherits BaseInventoryComputedField
public ref class OrderableLocations : public BaseInventoryComputedField
type OrderableLocations =
    class
        inherit BaseInventoryComputedField
    end

The OrderableLocations type exposes the following members.

Constructors
 | Name | Description
Public method | OrderableLocations | Initializes a new instance of the OrderableLocations class
Top
Methods
 | Name | Description
Protected method | BuildServicePipelineArgs | Builds a service request to retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Computes the value of an indexable item to build the desired value (Overrides BaseComputedFieldComputeValue(IIndexable).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsRequestForItem | Checks if a StockStatusForIndexingRequest will retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RunPipeline | Executes the commerce.inventory.stockStatusForIndexing pipeline to retrieve inventory indexing information for the provided item. (Inherited from BaseInventoryComputedField.)
Protected method | ShouldProcessItem | Checks if a computed field value should be generated for an item. (Inherited from BaseInventoryComputedField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Protected property | ItemClassificationService | Gets the item classification service. (Inherited from BaseInventoryComputedField.)
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from BaseInventoryComputedField.)
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

Sitecore.Commerce.Search.ComputedFields Namespace


OrderableLocations Constructor

OrderableLocations Constructor
Initializes a new instance of the OrderableLocations class

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public OrderableLocations()
Public Sub New
public:
OrderableLocations()
new : unit -> OrderableLocations
See Also

Reference

OrderableLocations Class
Sitecore.Commerce.Search.ComputedFields Namespace


OrderableLocations Methods

OrderableLocations Methods

The OrderableLocations type exposes the following members.

Methods
 | Name | Description
Protected method | BuildServicePipelineArgs | Builds a service request to retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Computes the value of an indexable item to build the desired value (Overrides BaseComputedFieldComputeValue(IIndexable).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsRequestForItem | Checks if a StockStatusForIndexingRequest will retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RunPipeline | Executes the commerce.inventory.stockStatusForIndexing pipeline to retrieve inventory indexing information for the provided item. (Inherited from BaseInventoryComputedField.)
Protected method | ShouldProcessItem | Checks if a computed field value should be generated for an item. (Inherited from BaseInventoryComputedField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OrderableLocations Class
Sitecore.Commerce.Search.ComputedFields Namespace


OrderableLocations.ComputeValue Method

OrderableLocationsComputeValue Method
Computes the value of an indexable item to build the desired value

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override Object ComputeValue(
    IIndexable itemToIndex
)
Public Overrides Function ComputeValue (
    itemToIndex As IIndexable
) As Object
public:
virtual Object^ ComputeValue(
    IIndexable^ itemToIndex
) override
abstract ComputeValue :
        itemToIndex : IIndexable -> Object
override ComputeValue :
        itemToIndex : IIndexable -> Object

Parameters

itemToIndex
Type: IIndexable
The indexable item

Return Value

Type: Object
The computed value
See Also

Reference

OrderableLocations Class
Sitecore.Commerce.Search.ComputedFields Namespace


OrderableLocations Properties

OrderableLocations Properties

The OrderableLocations type exposes the following members.

Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Protected property | ItemClassificationService | Gets the item classification service. (Inherited from BaseInventoryComputedField.)
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from BaseInventoryComputedField.)
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

OrderableLocations Class
Sitecore.Commerce.Search.ComputedFields Namespace


OutOfStockLocations Class

OutOfStockLocations Class
OutOfStockLocations computed field
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Search.ComputedFieldsBaseComputedField
Sitecore.Commerce.Search.ComputedFieldsBaseInventoryComputedField
Sitecore.Commerce.Search.ComputedFieldsOutOfStockLocations

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class OutOfStockLocations : BaseInventoryComputedField
Public Class OutOfStockLocations
    Inherits BaseInventoryComputedField
public ref class OutOfStockLocations : public BaseInventoryComputedField
type OutOfStockLocations =
    class
        inherit BaseInventoryComputedField
    end

The OutOfStockLocations type exposes the following members.

Constructors
 | Name | Description
Public method | OutOfStockLocations | Initializes a new instance of the OutOfStockLocations class
Top
Methods
 | Name | Description
Protected method | BuildServicePipelineArgs | Builds a service request to retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Computes the value of an indexable item to build the desired value (Overrides BaseComputedFieldComputeValue(IIndexable).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsRequestForItem | Checks if a StockStatusForIndexingRequest will retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RunPipeline | Executes the commerce.inventory.stockStatusForIndexing pipeline to retrieve inventory indexing information for the provided item. (Inherited from BaseInventoryComputedField.)
Protected method | ShouldProcessItem | Checks if a computed field value should be generated for an item. (Inherited from BaseInventoryComputedField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Protected property | ItemClassificationService | Gets the item classification service. (Inherited from BaseInventoryComputedField.)
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from BaseInventoryComputedField.)
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

Sitecore.Commerce.Search.ComputedFields Namespace


OutOfStockLocations Constructor

OutOfStockLocations Constructor
Initializes a new instance of the OutOfStockLocations class

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public OutOfStockLocations()
Public Sub New
public:
OutOfStockLocations()
new : unit -> OutOfStockLocations
See Also

Reference

OutOfStockLocations Class
Sitecore.Commerce.Search.ComputedFields Namespace


OutOfStockLocations Methods

OutOfStockLocations Methods

The OutOfStockLocations type exposes the following members.

Methods
 | Name | Description
Protected method | BuildServicePipelineArgs | Builds a service request to retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Computes the value of an indexable item to build the desired value (Overrides BaseComputedFieldComputeValue(IIndexable).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsRequestForItem | Checks if a StockStatusForIndexingRequest will retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RunPipeline | Executes the commerce.inventory.stockStatusForIndexing pipeline to retrieve inventory indexing information for the provided item. (Inherited from BaseInventoryComputedField.)
Protected method | ShouldProcessItem | Checks if a computed field value should be generated for an item. (Inherited from BaseInventoryComputedField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OutOfStockLocations Class
Sitecore.Commerce.Search.ComputedFields Namespace


OutOfStockLocations.ComputeValue Method

OutOfStockLocationsComputeValue Method
Computes the value of an indexable item to build the desired value

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override Object ComputeValue(
    IIndexable itemToIndex
)
Public Overrides Function ComputeValue (
    itemToIndex As IIndexable
) As Object
public:
virtual Object^ ComputeValue(
    IIndexable^ itemToIndex
) override
abstract ComputeValue :
        itemToIndex : IIndexable -> Object
override ComputeValue :
        itemToIndex : IIndexable -> Object

Parameters

itemToIndex
Type: IIndexable
The indexable item

Return Value

Type: Object
The computed value
See Also

Reference

OutOfStockLocations Class
Sitecore.Commerce.Search.ComputedFields Namespace


OutOfStockLocations Properties

OutOfStockLocations Properties

The OutOfStockLocations type exposes the following members.

Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Protected property | ItemClassificationService | Gets the item classification service. (Inherited from BaseInventoryComputedField.)
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from BaseInventoryComputedField.)
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

OutOfStockLocations Class
Sitecore.Commerce.Search.ComputedFields Namespace


PreOrderable Class

PreOrderable Class
PreOrderable computed field
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Search.ComputedFieldsBaseComputedField
Sitecore.Commerce.Search.ComputedFieldsBaseInventoryComputedField
Sitecore.Commerce.Search.ComputedFieldsPreOrderable

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class PreOrderable : BaseInventoryComputedField
Public Class PreOrderable
    Inherits BaseInventoryComputedField
public ref class PreOrderable : public BaseInventoryComputedField
type PreOrderable =
    class
        inherit BaseInventoryComputedField
    end

The PreOrderable type exposes the following members.

Constructors
 | Name | Description
Public method | PreOrderable | Initializes a new instance of the PreOrderable class
Top
Methods
 | Name | Description
Protected method | BuildServicePipelineArgs | Builds a service request to retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Computes the value of an indexable item to build the desired value (Overrides BaseComputedFieldComputeValue(IIndexable).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsRequestForItem | Checks if a StockStatusForIndexingRequest will retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RunPipeline | Executes the commerce.inventory.stockStatusForIndexing pipeline to retrieve inventory indexing information for the provided item. (Inherited from BaseInventoryComputedField.)
Protected method | ShouldProcessItem | Checks if a computed field value should be generated for an item. (Inherited from BaseInventoryComputedField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Protected property | ItemClassificationService | Gets the item classification service. (Inherited from BaseInventoryComputedField.)
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from BaseInventoryComputedField.)
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

Sitecore.Commerce.Search.ComputedFields Namespace


PreOrderable Constructor

PreOrderable Constructor
Initializes a new instance of the PreOrderable class

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PreOrderable()
Public Sub New
public:
PreOrderable()
new : unit -> PreOrderable
See Also

Reference

PreOrderable Class
Sitecore.Commerce.Search.ComputedFields Namespace


PreOrderable Methods

PreOrderable Methods

The PreOrderable type exposes the following members.

Methods
 | Name | Description
Protected method | BuildServicePipelineArgs | Builds a service request to retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Computes the value of an indexable item to build the desired value (Overrides BaseComputedFieldComputeValue(IIndexable).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsRequestForItem | Checks if a StockStatusForIndexingRequest will retrieve indexing information for a specific Item. (Inherited from BaseInventoryComputedField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RunPipeline | Executes the commerce.inventory.stockStatusForIndexing pipeline to retrieve inventory indexing information for the provided item. (Inherited from BaseInventoryComputedField.)
Protected method | ShouldProcessItem | Checks if a computed field value should be generated for an item. (Inherited from BaseInventoryComputedField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PreOrderable Class
Sitecore.Commerce.Search.ComputedFields Namespace


PreOrderable.ComputeValue Method

PreOrderableComputeValue Method
Computes the value of an indexable item to build the desired value

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override Object ComputeValue(
    IIndexable itemToIndex
)
Public Overrides Function ComputeValue (
    itemToIndex As IIndexable
) As Object
public:
virtual Object^ ComputeValue(
    IIndexable^ itemToIndex
) override
abstract ComputeValue :
        itemToIndex : IIndexable -> Object
override ComputeValue :
        itemToIndex : IIndexable -> Object

Parameters

itemToIndex
Type: IIndexable
The indexable item

Return Value

Type: Object
The computed value
See Also

Reference

PreOrderable Class
Sitecore.Commerce.Search.ComputedFields Namespace


PreOrderable Properties

PreOrderable Properties

The PreOrderable type exposes the following members.

Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Protected property | ItemClassificationService | Gets the item classification service. (Inherited from BaseInventoryComputedField.)
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from BaseInventoryComputedField.)
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

PreOrderable Class
Sitecore.Commerce.Search.ComputedFields Namespace


ProductTypeName Class

ProductTypeName Class
Type Name computed field
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Search.ComputedFieldsBaseComputedField
Sitecore.Commerce.Search.ComputedFieldsProductTypeName

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ProductTypeName : BaseComputedField
Public Class ProductTypeName
    Inherits BaseComputedField
public ref class ProductTypeName : public BaseComputedField
type ProductTypeName =
    class
        inherit BaseComputedField
    end

The ProductTypeName type exposes the following members.

Constructors
 | Name | Description
Public method | ProductTypeName | Initializes a new instance of the ProductTypeName class
Top
Methods
 | Name | Description
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Computes the value of an indexable item to build the desired value (Overrides BaseComputedFieldComputeValue(IIndexable).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

Sitecore.Commerce.Search.ComputedFields Namespace


ProductTypeName Constructor

ProductTypeName Constructor
Initializes a new instance of the ProductTypeName class

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductTypeName()
Public Sub New
public:
ProductTypeName()
new : unit -> ProductTypeName
See Also

Reference

ProductTypeName Class
Sitecore.Commerce.Search.ComputedFields Namespace


ProductTypeName Methods

ProductTypeName Methods

The ProductTypeName type exposes the following members.

Methods
 | Name | Description
Public method | ComputeFieldValue | Initial method called in by sitecore to launch a compute value call (Inherited from BaseComputedField.)
Public method | ComputeValue | Computes the value of an indexable item to build the desired value (Overrides BaseComputedFieldComputeValue(IIndexable).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductTypeName Class
Sitecore.Commerce.Search.ComputedFields Namespace


ProductTypeName.ComputeValue Method

ProductTypeNameComputeValue Method
Computes the value of an indexable item to build the desired value

Namespace: Sitecore.Commerce.Search.ComputedFields
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override Object ComputeValue(
    IIndexable itemToIndex
)
Public Overrides Function ComputeValue (
    itemToIndex As IIndexable
) As Object
public:
virtual Object^ ComputeValue(
    IIndexable^ itemToIndex
) override
abstract ComputeValue :
        itemToIndex : IIndexable -> Object
override ComputeValue :
        itemToIndex : IIndexable -> Object

Parameters

itemToIndex
Type: IIndexable
The indexable item

Return Value

Type: Object
The computed value
See Also

Reference

ProductTypeName Class
Sitecore.Commerce.Search.ComputedFields Namespace


ProductTypeName Properties

ProductTypeName Properties

The ProductTypeName type exposes the following members.

Properties
 | Name | Description
Public property | FieldName | Gets or sets the field name (Inherited from BaseComputedField.)
Public property | ReturnType | Gets or sets the return type (Inherited from BaseComputedField.)
Top
See Also

Reference

ProductTypeName Class
Sitecore.Commerce.Search.ComputedFields Namespace


Sitecore.Commerce.Services Namespace

Sitecore.Commerce.Services Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Services"]

Classes
 | Class | Description
Public class | ServiceProvider | Defines the base class for service providers. The class instantiates service pipeline arguments, runs service pipeline and returns result.
Public class | ServiceProviderRequest | Base class of all requests.
Public class | ServiceProviderRequestContext | Defines the ServiceProviderRequestContext class. Used to provide the ability to share context between pipelines and pipeline processors.
Public class | ServiceProviderResult | Represents the result of the service provider.
Public class | SystemMessage | Represents messages from the external system. This is how error conditions can be reported.


ServiceProvider Class

ServiceProvider Class
Defines the base class for service providers. The class instantiates service pipeline arguments, runs service pipeline and returns result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProvider
More...

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class ServiceProvider
Public MustInherit Class ServiceProvider
public ref class ServiceProvider abstract
[<AbstractClassAttribute>]
type ServiceProvider =  class end

The ServiceProvider type exposes the following members.

Constructors
 | Name | Description
Protected method | ServiceProvider | Initializes a new instance of the ServiceProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RunPipelineTRequest, TResult | Runs the pipeline.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service.
Top
See Also

Reference

Sitecore.Commerce.Services Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProvider
Sitecore.Commerce.Services.CartsCartServiceProvider
Sitecore.Commerce.Services.CustomersCustomerServiceProvider
Sitecore.Commerce.Services.InventoryInventoryServiceProvider
Sitecore.Commerce.Services.OrdersOrderServiceProvider
Sitecore.Commerce.Services.PricesPricingServiceProvider
Sitecore.Commerce.Services.ProductsProductSynchronizationProvider


ServiceProvider Constructor

ServiceProvider Constructor
Initializes a new instance of the ServiceProvider class

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected ServiceProvider()
Protected Sub New
protected:
ServiceProvider()
new : unit -> ServiceProvider
See Also

Reference

ServiceProvider Class
Sitecore.Commerce.Services Namespace


ServiceProvider Methods

ServiceProvider Methods

The ServiceProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RunPipelineTRequest, TResult | Runs the pipeline.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceProvider Class
Sitecore.Commerce.Services Namespace


ServiceProvider.RunPipeline(TRequest, TResult) Method

ServiceProviderRunPipelineTRequest, TResult Method
Runs the pipeline.

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual TResult RunPipeline<TRequest, TResult>(
    string pipelineName,
    TRequest request
)
where TRequest : ServiceProviderRequest
where TResult : new(), ServiceProviderResult

Public Overridable Function RunPipeline(Of TRequest As ServiceProviderRequest, TResult As {New, ServiceProviderResult}) (
    pipelineName As String,
    request As TRequest
) As TResult
public:
generic<typename TRequest, typename TResult>
where TRequest : ServiceProviderRequest
where TResult : gcnew(), ServiceProviderResult
virtual TResult RunPipeline(
    String^ pipelineName,
    TRequest request
)
abstract RunPipeline :
        pipelineName : string *
        request : 'TRequest -> 'TResult  when 'TRequest : ServiceProviderRequest when 'TResult : new() and ServiceProviderResult
override RunPipeline :
        pipelineName : string *
        request : 'TRequest -> 'TResult  when 'TRequest : ServiceProviderRequest when 'TResult : new() and ServiceProviderResult

Parameters

pipelineName
Type: SystemString
Name of the pipeline.
request
Type: TRequest
The request.

Type Parameters

TRequest
The type of the request.
TResult
The type of the result.

Return Value

Type: TResult
The result.
See Also

Reference

ServiceProvider Class
Sitecore.Commerce.Services Namespace


ServiceProvider Properties

ServiceProvider Properties

The ServiceProvider type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service.
Top
See Also

Reference

ServiceProvider Class
Sitecore.Commerce.Services Namespace


ServiceProvider.PipelineService Property

ServiceProviderPipelineService Property
Gets or sets the pipeline service.

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PipelineService PipelineService { get; set; }
Public Property PipelineService As PipelineService
    Get
    Set
public:
property PipelineService^ PipelineService {
    PipelineService^ get ();
    void set (PipelineService^ value);
}
member PipelineService : PipelineService with get, set

Property Value

Type: PipelineService
The pipeline service.
See Also

Reference

ServiceProvider Class
Sitecore.Commerce.Services Namespace


ServiceProviderRequest Class

ServiceProviderRequest Class
Base class of all requests.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
More...

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ServiceProviderRequest
Public Class ServiceProviderRequest
public ref class ServiceProviderRequest
type ServiceProviderRequest =  class end

The ServiceProviderRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceProviderRequest | Initializes a new instance of the ServiceProviderRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
Public property | RequestContext | Gets or sets the request context.
Top
See Also

Reference

Sitecore.Commerce.Services Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersUpdatePasswordRequest
Sitecore.Commerce.Services.CustomersUserRequest
Sitecore.Commerce.Services.InventoryGetBackInStockInformationRequest
Sitecore.Commerce.Services.InventoryGetStockInformationRequest
Sitecore.Commerce.Services.InventoryOrderableInformationRequestBase
Sitecore.Commerce.Services.InventoryProductsAreBackInStockRequest
Sitecore.Commerce.Services.InventoryRemoveVisitorFromStockNotificationRequest
Sitecore.Commerce.Services.InventoryStockStatusForIndexingRequest
Sitecore.Commerce.Services.InventoryVisitedProductStockStatusRequest
Sitecore.Commerce.Services.InventoryVisitorSignUpForStockNotificationRequest
Sitecore.Commerce.Services.OrdersOrdersRequest
Sitecore.Commerce.Services.PricesPriceRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest


ServiceProviderRequest Constructor

ServiceProviderRequest Constructor
Initializes a new instance of the ServiceProviderRequest class.

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ServiceProviderRequest()
Public Sub New
public:
ServiceProviderRequest()
new : unit -> ServiceProviderRequest
See Also

Reference

ServiceProviderRequest Class
Sitecore.Commerce.Services Namespace


ServiceProviderRequest Methods

ServiceProviderRequest Methods

The ServiceProviderRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceProviderRequest Class
Sitecore.Commerce.Services Namespace


ServiceProviderRequest Properties

ServiceProviderRequest Properties

The ServiceProviderRequest type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
Public property | RequestContext | Gets or sets the request context.
Top
See Also

Reference

ServiceProviderRequest Class
Sitecore.Commerce.Services Namespace


ServiceProviderRequest.Properties Property

ServiceProviderRequestProperties Property
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PropertyCollection Properties { get; set; }
Public Property Properties As PropertyCollection
    Get
    Set
public:
property PropertyCollection^ Properties {
    PropertyCollection^ get ();
    void set (PropertyCollection^ value);
}
member Properties : PropertyCollection with get, set

Property Value

Type: PropertyCollection
The properties.
See Also

Reference

ServiceProviderRequest Class
Sitecore.Commerce.Services Namespace


ServiceProviderRequest.RequestContext Property

ServiceProviderRequestRequestContext Property
Gets or sets the request context.

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ServiceProviderRequestContext RequestContext { get; set; }
Public Property RequestContext As ServiceProviderRequestContext
    Get
    Set
public:
property ServiceProviderRequestContext^ RequestContext {
    ServiceProviderRequestContext^ get ();
    void set (ServiceProviderRequestContext^ value);
}
member RequestContext : ServiceProviderRequestContext with get, set

Property Value

Type: ServiceProviderRequestContext
The request context.
See Also

Reference

ServiceProviderRequest Class
Sitecore.Commerce.Services Namespace


ServiceProviderRequestContext Class

ServiceProviderRequestContext Class
Defines the ServiceProviderRequestContext class. Used to provide the ability to share context between pipelines and pipeline processors.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequestContext

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ServiceProviderRequestContext
Public Class ServiceProviderRequestContext
public ref class ServiceProviderRequestContext
type ServiceProviderRequestContext =  class end

The ServiceProviderRequestContext type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceProviderRequestContext | Initializes a new instance of the ServiceProviderRequestContext class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
Top
See Also

Reference

Sitecore.Commerce.Services Namespace


ServiceProviderRequestContext Constructor

ServiceProviderRequestContext Constructor
Initializes a new instance of the ServiceProviderRequestContext class

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ServiceProviderRequestContext()
Public Sub New
public:
ServiceProviderRequestContext()
new : unit -> ServiceProviderRequestContext
See Also

Reference

ServiceProviderRequestContext Class
Sitecore.Commerce.Services Namespace


ServiceProviderRequestContext Methods

ServiceProviderRequestContext Methods

The ServiceProviderRequestContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceProviderRequestContext Class
Sitecore.Commerce.Services Namespace


ServiceProviderRequestContext Properties

ServiceProviderRequestContext Properties

The ServiceProviderRequestContext type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
Top
See Also

Reference

ServiceProviderRequestContext Class
Sitecore.Commerce.Services Namespace


ServiceProviderRequestContext.Properties Property

ServiceProviderRequestContextProperties Property
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PropertyCollection Properties { get; set; }
Public Property Properties As PropertyCollection
    Get
    Set
public:
property PropertyCollection^ Properties {
    PropertyCollection^ get ();
    void set (PropertyCollection^ value);
}
member Properties : PropertyCollection with get, set

Property Value

Type: PropertyCollection
The properties.
See Also

Reference

ServiceProviderRequestContext Class
Sitecore.Commerce.Services Namespace


ServiceProviderResult Class

ServiceProviderResult Class
Represents the result of the service provider.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
More...

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ServiceProviderResult
Public Class ServiceProviderResult
public ref class ServiceProviderResult
type ServiceProviderResult =  class end

The ServiceProviderResult type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceProviderResult | Initializes a new instance of the ServiceProviderResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded.
Public property | SystemMessages | Gets the external system messages.
Top
See Also

Reference

Sitecore.Commerce.Services Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CartsCartResult
Sitecore.Commerce.Services.CartsGetCartsResult
Sitecore.Commerce.Services.CustomersCustomerPartiesResult
Sitecore.Commerce.Services.CustomersCustomerResult
Sitecore.Commerce.Services.CustomersUpdatePasswordResult
Sitecore.Commerce.Services.CustomersUserResult
Sitecore.Commerce.Services.InventoryGetBackInStockInformationResult
Sitecore.Commerce.Services.InventoryGetStockInformationResult
Sitecore.Commerce.Services.InventoryOrderableInformationResultBase
Sitecore.Commerce.Services.InventoryProductsAreBackInStockResult
Sitecore.Commerce.Services.InventoryRemoveVisitorFromStockNotificationResult
Sitecore.Commerce.Services.InventoryStockStatusForIndexingResult
Sitecore.Commerce.Services.InventoryVisitedProductStockStatusResult
Sitecore.Commerce.Services.InventoryVisitorSignUpForStockNotificationResult
Sitecore.Commerce.Services.OrdersOrdersResult
Sitecore.Commerce.Services.PricesGetCartTotalResult
Sitecore.Commerce.Services.PricesGetProductBulkPricesResult
Sitecore.Commerce.Services.PricesGetProductPricesResult


ServiceProviderResult Constructor

ServiceProviderResult Constructor
Initializes a new instance of the ServiceProviderResult class

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ServiceProviderResult()
Public Sub New
public:
ServiceProviderResult()
new : unit -> ServiceProviderResult
See Also

Reference

ServiceProviderResult Class
Sitecore.Commerce.Services Namespace


ServiceProviderResult Methods

ServiceProviderResult Methods

The ServiceProviderResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceProviderResult Class
Sitecore.Commerce.Services Namespace


ServiceProviderResult Properties

ServiceProviderResult Properties

The ServiceProviderResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded.
Public property | SystemMessages | Gets the external system messages.
Top
See Also

Reference

ServiceProviderResult Class
Sitecore.Commerce.Services Namespace


ServiceProviderResult.Properties Property

ServiceProviderResultProperties Property
Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity.

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PropertyCollection Properties { get; set; }
Public Property Properties As PropertyCollection
    Get
    Set
public:
property PropertyCollection^ Properties {
    PropertyCollection^ get ();
    void set (PropertyCollection^ value);
}
member Properties : PropertyCollection with get, set

Property Value

Type: PropertyCollection
The properties.
See Also

Reference

ServiceProviderResult Class
Sitecore.Commerce.Services Namespace


ServiceProviderResult.Success Property

ServiceProviderResultSuccess Property
Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded.

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public bool Success { get; set; }
Public Property Success As Boolean
    Get
    Set
public:
property bool Success {
    bool get ();
    void set (bool value);
}
member Success : bool with get, set

Property Value

Type: Boolean
true if success; otherwise, false.
See Also

Reference

ServiceProviderResult Class
Sitecore.Commerce.Services Namespace


ServiceProviderResult.SystemMessages Property

ServiceProviderResultSystemMessages Property
Gets the external system messages.

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ICollection<SystemMessage> SystemMessages { get; }
Public ReadOnly Property SystemMessages As ICollection(Of SystemMessage)
    Get
public:
property ICollection<SystemMessage^>^ SystemMessages {
    ICollection<SystemMessage^>^ get ();
}
member SystemMessages : ICollection<SystemMessage> with get

Property Value

Type: ICollection SystemMessage
See Also

Reference

ServiceProviderResult Class
Sitecore.Commerce.Services Namespace


SystemMessage Class

SystemMessage Class
Represents messages from the external system. This is how error conditions can be reported.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesSystemMessage

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SystemMessage
Public Class SystemMessage
public ref class SystemMessage
type SystemMessage =  class end

The SystemMessage type exposes the following members.

Constructors
 | Name | Description
Public method | SystemMessage | Initializes a new instance of the SystemMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Message | Gets or sets the message.
Top
See Also

Reference

Sitecore.Commerce.Services Namespace


SystemMessage Constructor

SystemMessage Constructor
Initializes a new instance of the SystemMessage class

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SystemMessage()
Public Sub New
public:
SystemMessage()
new : unit -> SystemMessage
See Also

Reference

SystemMessage Class
Sitecore.Commerce.Services Namespace


SystemMessage Methods

SystemMessage Methods

The SystemMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemMessage Class
Sitecore.Commerce.Services Namespace


SystemMessage Properties

SystemMessage Properties

The SystemMessage type exposes the following members.

Properties
 | Name | Description
Public property | Message | Gets or sets the message.
Top
See Also

Reference

SystemMessage Class
Sitecore.Commerce.Services Namespace


SystemMessage.Message Property

SystemMessageMessage Property
Gets or sets the message.

Namespace: Sitecore.Commerce.Services
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
The message.
See Also

Reference

SystemMessage Class
Sitecore.Commerce.Services Namespace


Sitecore.Commerce.Services.Carts Namespace

Sitecore.Commerce.Services.Carts Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Services.Carts"]

Classes
 | Class | Description
Public class | AddCartLinesRequest | Contains the cart to be updated, along with what lines should be added to the cart.
Public class | AddPartiesRequest | Defines the AddPartiesRequest class.
Public class | AddPartiesResult | Defines the AddPartiesResult class.
Public class | AddPaymentInfoRequest | Defines the AddPaymentInfoRequest class.
Public class | AddPaymentInfoResult | Defines the AddPaymentInfoResult class.
Public class | AddShippingInfoRequest | Defines the AddShippingInfoRequest class.
Public class | AddShippingInfoResult | Defines the AddShippingInfoResult class.
Public class | CartLinesRequest | The cart lines request.
Public class | CartRequest | The cart request.
Public class | CartRequestWithCart | Base class used by all Cart requests that require a cart to be passed down.
Public class | CartResult | The cart result.
Public class | CartServiceProvider | Represents the interaction with the carts. Service providers are wrapper objects that ease the interaction with CommerceConnect pipelines. Service providers only implement the logic that calls pipelines. All the business logic is implemented in the pipeline's processors. Every method receives a request object and returns a result object, for example, GetCarts receives GetCartsRequest and returns GetCartsResult. To follow the best practice and ease the API optimization as implemented in the domain model, every class must be defined as an abstract class rather than an interface. The CartServiceProvider class implements the ServiceProvider class.
Public class | CartStatus | Defines CartStatus class with fundamental cart statuses.
Public class | CreateOrResumeCartRequest | Contains the criteria that determine which cart should be created.
Public class | DeleteCartRequest | Contains the cart to be deleted.
Public class | GetCartsRequest | Defines the request to the Product Synchronization Provider that can contain some search parameters. In this request, the shop name is required. The lists of user IDs, customer identifiers, cart names and cart statuses are optional.
Public class | GetCartsResult | The get carts result.
Public class | LoadCartRequest | Contains the criteria that determine which cart should be retrieved.
Public class | LockCartRequest | Contains the cart to be locked.
Public class | MergeCartRequest |
Public class | RemoveCartLinesRequest | Contains the cart to be updated along with the cart lines to be removed.
Public class | RemovePartiesRequest | Defines the RemovePartiesRequest class.
Public class | RemovePartiesResult | Defines the RemovePartiesResult class.
Public class | RemovePaymentInfoRequest | Defines the RemovePaymentInfoRequest class.
Public class | RemovePaymentInfoResult | Defines the RemovePaymentInfoResult class.
Public class | RemoveShippingInfoRequest | Defines the RemoveShippingInfoRequest class.
Public class | RemoveShippingInfoResult | Defines the RemoveShippingInfoResult result.
Public class | SaveCartRequest | The save cart request.
Public class | UnlockCartRequest | Contains the cart to be unlocked.
Public class | UpdateCartLinesRequest | Contains the cart along with the cart lines to be updated.
Public class | UpdateCartRequest | Contains the cart and the data to be updated in CartBase.
Public class | UpdatePartiesRequest | Defines the UpdatePartiesRequest class.
Public class | UpdatePartiesResult | Defines the UpdatePartiesResult class.


AddCartLinesRequest Class

AddCartLinesRequest Class
Contains the cart to be updated, along with what lines should be added to the cart.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsCartLinesRequest
Sitecore.Commerce.Services.CartsAddCartLinesRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddCartLinesRequest : CartLinesRequest
Public Class AddCartLinesRequest
    Inherits CartLinesRequest
public ref class AddCartLinesRequest : public CartLinesRequest
type AddCartLinesRequest =
    class
        inherit CartLinesRequest
    end

The AddCartLinesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | AddCartLinesRequest | Initializes a new instance of the AddCartLinesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Lines | Gets or sets the cart lines. (Inherited from CartLinesRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


AddCartLinesRequest Constructor

AddCartLinesRequest Constructor
Initializes a new instance of the AddCartLinesRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddCartLinesRequest(
    Cart cart,
    IEnumerable<CartLine> lines
)
Public Sub New (
    cart As Cart,
    lines As IEnumerable(Of CartLine)
)
public:
AddCartLinesRequest(
    Cart^ cart,
    IEnumerable<CartLine^>^ lines
)
new :
        cart : Cart *
        lines : IEnumerable<CartLine> -> AddCartLinesRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
lines
Type: System.Collections.GenericIEnumerable CartLine
The cart lines.
See Also

Reference

AddCartLinesRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddCartLinesRequest Methods

AddCartLinesRequest Methods

The AddCartLinesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddCartLinesRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddCartLinesRequest Properties

AddCartLinesRequest Properties

The AddCartLinesRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Lines | Gets or sets the cart lines. (Inherited from CartLinesRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

AddCartLinesRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddPartiesRequest Class

AddPartiesRequest Class
Defines the AddPartiesRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsAddPartiesRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddPartiesRequest : CartRequestWithCart
Public Class AddPartiesRequest
    Inherits CartRequestWithCart
public ref class AddPartiesRequest : public CartRequestWithCart
type AddPartiesRequest =
    class
        inherit CartRequestWithCart
    end

The AddPartiesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | AddPartiesRequest | Initializes a new instance of the AddPartiesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


AddPartiesRequest Constructor

AddPartiesRequest Constructor
Initializes a new instance of the AddPartiesRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddPartiesRequest(
    Cart cart,
    List<Party> parties
)
Public Sub New (
    cart As Cart,
    parties As List(Of Party)
)
public:
AddPartiesRequest(
    Cart^ cart,
    List<Party^>^ parties
)
new :
        cart : Cart *
        parties : List<Party> -> AddPartiesRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
parties
Type: System.Collections.GenericList Party
The parties.
See Also

Reference

AddPartiesRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddPartiesRequest Methods

AddPartiesRequest Methods

The AddPartiesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddPartiesRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddPartiesRequest Properties

AddPartiesRequest Properties

The AddPartiesRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

AddPartiesRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddPartiesRequest.Parties Property

AddPartiesRequestParties Property
Gets or sets the parties.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<Party> Parties { get; set; }
Public Property Parties As List(Of Party)
    Get
    Set
public:
property List<Party^>^ Parties {
    List<Party^>^ get ();
    void set (List<Party^>^ value);
}
member Parties : List<Party> with get, set

Property Value

Type: List Party
The parties.
See Also

Reference

AddPartiesRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddPartiesResult Class

AddPartiesResult Class
Defines the AddPartiesResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CartsCartResult
Sitecore.Commerce.Services.CartsAddPartiesResult

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddPartiesResult : CartResult
Public Class AddPartiesResult
    Inherits CartResult
public ref class AddPartiesResult : public CartResult
type AddPartiesResult =
    class
        inherit CartResult
    end

The AddPartiesResult type exposes the following members.

Constructors
 | Name | Description
Public method | AddPartiesResult | Initializes a new instance of the AddPartiesResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartResult.)
Public property | Parties | Gets or sets the parties that were added.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


AddPartiesResult Constructor

AddPartiesResult Constructor
Initializes a new instance of the AddPartiesResult class

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddPartiesResult()
Public Sub New
public:
AddPartiesResult()
new : unit -> AddPartiesResult
See Also

Reference

AddPartiesResult Class
Sitecore.Commerce.Services.Carts Namespace


AddPartiesResult Methods

AddPartiesResult Methods

The AddPartiesResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddPartiesResult Class
Sitecore.Commerce.Services.Carts Namespace


AddPartiesResult Properties

AddPartiesResult Properties

The AddPartiesResult type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartResult.)
Public property | Parties | Gets or sets the parties that were added.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

AddPartiesResult Class
Sitecore.Commerce.Services.Carts Namespace


AddPartiesResult.Parties Property

AddPartiesResultParties Property
Gets or sets the parties that were added.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<Party> Parties { get; set; }
Public Property Parties As List(Of Party)
    Get
    Set
public:
property List<Party^>^ Parties {
    List<Party^>^ get ();
    void set (List<Party^>^ value);
}
member Parties : List<Party> with get, set

Property Value

Type: List Party
The parties.
See Also

Reference

AddPartiesResult Class
Sitecore.Commerce.Services.Carts Namespace


AddPaymentInfoRequest Class

AddPaymentInfoRequest Class
Defines the AddPaymentInfoRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsAddPaymentInfoRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddPaymentInfoRequest : CartRequestWithCart
Public Class AddPaymentInfoRequest
    Inherits CartRequestWithCart
public ref class AddPaymentInfoRequest : public CartRequestWithCart
type AddPaymentInfoRequest =
    class
        inherit CartRequestWithCart
    end

The AddPaymentInfoRequest type exposes the following members.

Constructors
 | Name | Description
Public method | AddPaymentInfoRequest | Initializes a new instance of the AddPaymentInfoRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Payments | Gets or sets the payments.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


AddPaymentInfoRequest Constructor

AddPaymentInfoRequest Constructor
Initializes a new instance of the AddPaymentInfoRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddPaymentInfoRequest(
    Cart cart,
    List<PaymentInfo> payments
)
Public Sub New (
    cart As Cart,
    payments As List(Of PaymentInfo)
)
public:
AddPaymentInfoRequest(
    Cart^ cart,
    List<PaymentInfo^>^ payments
)
new :
        cart : Cart *
        payments : List<PaymentInfo> -> AddPaymentInfoRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
payments
Type: System.Collections.GenericList PaymentInfo
The payments.
See Also

Reference

AddPaymentInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddPaymentInfoRequest Methods

AddPaymentInfoRequest Methods

The AddPaymentInfoRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddPaymentInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddPaymentInfoRequest Properties

AddPaymentInfoRequest Properties

The AddPaymentInfoRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Payments | Gets or sets the payments.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

AddPaymentInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddPaymentInfoRequest.Payments Property

AddPaymentInfoRequestPayments Property
Gets or sets the payments.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<PaymentInfo> Payments { get; set; }
Public Property Payments As List(Of PaymentInfo)
    Get
    Set
public:
property List<PaymentInfo^>^ Payments {
    List<PaymentInfo^>^ get ();
    void set (List<PaymentInfo^>^ value);
}
member Payments : List<PaymentInfo> with get, set

Property Value

Type: List PaymentInfo
The payments.
See Also

Reference

AddPaymentInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddPaymentInfoResult Class

AddPaymentInfoResult Class
Defines the AddPaymentInfoResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CartsCartResult
Sitecore.Commerce.Services.CartsAddPaymentInfoResult

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddPaymentInfoResult : CartResult
Public Class AddPaymentInfoResult
    Inherits CartResult
public ref class AddPaymentInfoResult : public CartResult
type AddPaymentInfoResult =
    class
        inherit CartResult
    end

The AddPaymentInfoResult type exposes the following members.

Constructors
 | Name | Description
Public method | AddPaymentInfoResult | Initializes a new instance of the AddPaymentInfoResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartResult.)
Public property | Payments | Gets or sets the payments that were added.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


AddPaymentInfoResult Constructor

AddPaymentInfoResult Constructor
Initializes a new instance of the AddPaymentInfoResult class

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddPaymentInfoResult()
Public Sub New
public:
AddPaymentInfoResult()
new : unit -> AddPaymentInfoResult
See Also

Reference

AddPaymentInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


AddPaymentInfoResult Methods

AddPaymentInfoResult Methods

The AddPaymentInfoResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddPaymentInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


AddPaymentInfoResult Properties

AddPaymentInfoResult Properties

The AddPaymentInfoResult type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartResult.)
Public property | Payments | Gets or sets the payments that were added.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

AddPaymentInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


AddPaymentInfoResult.Payments Property

AddPaymentInfoResultPayments Property
Gets or sets the payments that were added.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<PaymentInfo> Payments { get; set; }
Public Property Payments As List(Of PaymentInfo)
    Get
    Set
public:
property List<PaymentInfo^>^ Payments {
    List<PaymentInfo^>^ get ();
    void set (List<PaymentInfo^>^ value);
}
member Payments : List<PaymentInfo> with get, set

Property Value

Type: List PaymentInfo
The payments that were added.
See Also

Reference

AddPaymentInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


AddShippingInfoRequest Class

AddShippingInfoRequest Class
Defines the AddShippingInfoRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsAddShippingInfoRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddShippingInfoRequest : CartRequestWithCart
Public Class AddShippingInfoRequest
    Inherits CartRequestWithCart
public ref class AddShippingInfoRequest : public CartRequestWithCart
type AddShippingInfoRequest =
    class
        inherit CartRequestWithCart
    end

The AddShippingInfoRequest type exposes the following members.

Constructors
 | Name | Description
Public method | AddShippingInfoRequest | Initializes a new instance of the AddShippingInfoRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | Shippings | Gets or sets the shippings.
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


AddShippingInfoRequest Constructor

AddShippingInfoRequest Constructor
Initializes a new instance of the AddShippingInfoRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddShippingInfoRequest(
    Cart cart,
    List<ShippingInfo> shippings
)
Public Sub New (
    cart As Cart,
    shippings As List(Of ShippingInfo)
)
public:
AddShippingInfoRequest(
    Cart^ cart,
    List<ShippingInfo^>^ shippings
)
new :
        cart : Cart *
        shippings : List<ShippingInfo> -> AddShippingInfoRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
shippings
Type: System.Collections.GenericList ShippingInfo
The shippings.
See Also

Reference

AddShippingInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddShippingInfoRequest Methods

AddShippingInfoRequest Methods

The AddShippingInfoRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddShippingInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddShippingInfoRequest Properties

AddShippingInfoRequest Properties

The AddShippingInfoRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | Shippings | Gets or sets the shippings.
Top
See Also

Reference

AddShippingInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddShippingInfoRequest.Shippings Property

AddShippingInfoRequestShippings Property
Gets or sets the shippings.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<ShippingInfo> Shippings { get; set; }
Public Property Shippings As List(Of ShippingInfo)
    Get
    Set
public:
property List<ShippingInfo^>^ Shippings {
    List<ShippingInfo^>^ get ();
    void set (List<ShippingInfo^>^ value);
}
member Shippings : List<ShippingInfo> with get, set

Property Value

Type: List ShippingInfo
The shippings.
See Also

Reference

AddShippingInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


AddShippingInfoResult Class

AddShippingInfoResult Class
Defines the AddShippingInfoResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CartsCartResult
Sitecore.Commerce.Services.CartsAddShippingInfoResult

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddShippingInfoResult : CartResult
Public Class AddShippingInfoResult
    Inherits CartResult
public ref class AddShippingInfoResult : public CartResult
type AddShippingInfoResult =
    class
        inherit CartResult
    end

The AddShippingInfoResult type exposes the following members.

Constructors
 | Name | Description
Public method | AddShippingInfoResult | Initializes a new instance of the AddShippingInfoResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartResult.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Shippings | Gets or sets the shippings that were added.
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


AddShippingInfoResult Constructor

AddShippingInfoResult Constructor
Initializes a new instance of the AddShippingInfoResult class

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddShippingInfoResult()
Public Sub New
public:
AddShippingInfoResult()
new : unit -> AddShippingInfoResult
See Also

Reference

AddShippingInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


AddShippingInfoResult Methods

AddShippingInfoResult Methods

The AddShippingInfoResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddShippingInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


AddShippingInfoResult Properties

AddShippingInfoResult Properties

The AddShippingInfoResult type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartResult.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Shippings | Gets or sets the shippings that were added.
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

AddShippingInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


AddShippingInfoResult.Shippings Property

AddShippingInfoResultShippings Property
Gets or sets the shippings that were added.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<ShippingInfo> Shippings { get; set; }
Public Property Shippings As List(Of ShippingInfo)
    Get
    Set
public:
property List<ShippingInfo^>^ Shippings {
    List<ShippingInfo^>^ get ();
    void set (List<ShippingInfo^>^ value);
}
member Shippings : List<ShippingInfo> with get, set

Property Value

Type: List ShippingInfo
The shippings that were added.
See Also

Reference

AddShippingInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


CartLinesRequest Class

CartLinesRequest Class
The cart lines request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsCartLinesRequest
Sitecore.Commerce.Services.CartsAddCartLinesRequest
Sitecore.Commerce.Services.CartsRemoveCartLinesRequest
Sitecore.Commerce.Services.CartsUpdateCartLinesRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class CartLinesRequest : CartRequestWithCart
Public MustInherit Class CartLinesRequest
    Inherits CartRequestWithCart
public ref class CartLinesRequest abstract : public CartRequestWithCart
[<AbstractClassAttribute>]
type CartLinesRequest =
    class
        inherit CartRequestWithCart
    end

The CartLinesRequest type exposes the following members.

Constructors
 | Name | Description
Protected method | CartLinesRequest | Initializes a new instance of the CartLinesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Lines | Gets or sets the cart lines.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


CartLinesRequest Constructor

CartLinesRequest Constructor
Initializes a new instance of the CartLinesRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected CartLinesRequest(
    Cart cart,
    IEnumerable<CartLine> lines
)
Protected Sub New (
    cart As Cart,
    lines As IEnumerable(Of CartLine)
)
protected:
CartLinesRequest(
    Cart^ cart,
    IEnumerable<CartLine^>^ lines
)
new :
        cart : Cart *
        lines : IEnumerable<CartLine> -> CartLinesRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
lines
Type: System.Collections.GenericIEnumerable CartLine
The cart lines.
See Also

Reference

CartLinesRequest Class
Sitecore.Commerce.Services.Carts Namespace


CartLinesRequest Methods

CartLinesRequest Methods

The CartLinesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CartLinesRequest Class
Sitecore.Commerce.Services.Carts Namespace


CartLinesRequest Properties

CartLinesRequest Properties

The CartLinesRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Lines | Gets or sets the cart lines.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

CartLinesRequest Class
Sitecore.Commerce.Services.Carts Namespace


CartLinesRequest.Lines Property

CartLinesRequestLines Property
Gets or sets the cart lines.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<CartLine> Lines { get; set; }
Public Property Lines As IEnumerable(Of CartLine)
    Get
    Set
public:
property IEnumerable<CartLine^>^ Lines {
    IEnumerable<CartLine^>^ get ();
    void set (IEnumerable<CartLine^>^ value);
}
member Lines : IEnumerable<CartLine> with get, set

Property Value

Type: IEnumerable CartLine
The cart lines.
See Also

Reference

CartLinesRequest Class
Sitecore.Commerce.Services.Carts Namespace


CartRequest Class

CartRequest Class
The cart request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsCreateOrResumeCartRequest
Sitecore.Commerce.Services.CartsGetCartsRequest
Sitecore.Commerce.Services.CartsLoadCartRequest
Sitecore.Commerce.Services.CartsMergeCartRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class CartRequest : ServiceProviderRequest
Public MustInherit Class CartRequest
    Inherits ServiceProviderRequest
public ref class CartRequest abstract : public ServiceProviderRequest
[<AbstractClassAttribute>]
type CartRequest =
    class
        inherit ServiceProviderRequest
    end

The CartRequest type exposes the following members.

Constructors
 | Name | Description
Protected method | CartRequest | Initializes a new instance of the CartRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


CartRequest Constructor

CartRequest Constructor
Initializes a new instance of the CartRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected CartRequest()
Protected Sub New
protected:
CartRequest()
new : unit -> CartRequest
See Also

Reference

CartRequest Class
Sitecore.Commerce.Services.Carts Namespace


CartRequest Methods

CartRequest Methods

The CartRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CartRequest Class
Sitecore.Commerce.Services.Carts Namespace


CartRequest Properties

CartRequest Properties

The CartRequest type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

CartRequest Class
Sitecore.Commerce.Services.Carts Namespace


CartRequestWithCart Class

CartRequestWithCart Class
Base class used by all Cart requests that require a cart to be passed down.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
More...

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class CartRequestWithCart : CartRequest
Public MustInherit Class CartRequestWithCart
    Inherits CartRequest
public ref class CartRequestWithCart abstract : public CartRequest
[<AbstractClassAttribute>]
type CartRequestWithCart =
    class
        inherit CartRequest
    end

The CartRequestWithCart type exposes the following members.

Constructors
 | Name | Description
Protected method | CartRequestWithCart | Initializes a new instance of the CartRequestWithCart class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsAddPartiesRequest
Sitecore.Commerce.Services.CartsAddPaymentInfoRequest
Sitecore.Commerce.Services.CartsAddShippingInfoRequest
Sitecore.Commerce.Services.CartsCartLinesRequest
Sitecore.Commerce.Services.CartsDeleteCartRequest
Sitecore.Commerce.Services.CartsLockCartRequest
Sitecore.Commerce.Services.CartsRemovePartiesRequest
Sitecore.Commerce.Services.CartsRemovePaymentInfoRequest
Sitecore.Commerce.Services.CartsRemoveShippingInfoRequest
Sitecore.Commerce.Services.CartsSaveCartRequest
Sitecore.Commerce.Services.CartsUnlockCartRequest
Sitecore.Commerce.Services.CartsUpdateCartRequest
Sitecore.Commerce.Services.CartsUpdatePartiesRequest


CartRequestWithCart Constructor

CartRequestWithCart Constructor
Initializes a new instance of the CartRequestWithCart class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected CartRequestWithCart(
    Cart cart
)
Protected Sub New (
    cart As Cart
)
protected:
CartRequestWithCart(
    Cart^ cart
)
new :
        cart : Cart -> CartRequestWithCart

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
See Also

Reference

CartRequestWithCart Class
Sitecore.Commerce.Services.Carts Namespace


CartRequestWithCart Methods

CartRequestWithCart Methods

The CartRequestWithCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CartRequestWithCart Class
Sitecore.Commerce.Services.Carts Namespace


CartRequestWithCart Properties

CartRequestWithCart Properties

The CartRequestWithCart type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

CartRequestWithCart Class
Sitecore.Commerce.Services.Carts Namespace


CartRequestWithCart.Cart Property

CartRequestWithCartCart Property
Gets or sets the cart.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Cart Cart { get; protected set; }
Public Property Cart As Cart
    Get
    Protected Set
public:
property Cart^ Cart {
    Cart^ get ();
    protected: void set (Cart^ value);
}
member Cart : Cart with get, set

Property Value

Type: Cart
See Also

Reference

CartRequestWithCart Class
Sitecore.Commerce.Services.Carts Namespace


CartResult Class

CartResult Class
The cart result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CartsCartResult
More...

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CartResult : ServiceProviderResult
Public Class CartResult
    Inherits ServiceProviderResult
public ref class CartResult : public ServiceProviderResult
type CartResult =
    class
        inherit ServiceProviderResult
    end

The CartResult type exposes the following members.

Constructors
 | Name | Description
Public method | CartResult | Initializes a new instance of the CartResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CartsCartResult
Sitecore.Commerce.Services.CartsAddPartiesResult
Sitecore.Commerce.Services.CartsAddPaymentInfoResult
Sitecore.Commerce.Services.CartsAddShippingInfoResult
Sitecore.Commerce.Services.CartsRemovePartiesResult
Sitecore.Commerce.Services.CartsRemovePaymentInfoResult
Sitecore.Commerce.Services.CartsRemoveShippingInfoResult
Sitecore.Commerce.Services.CartsUpdatePartiesResult


CartResult Constructor

CartResult Constructor
Initializes a new instance of the CartResult class

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CartResult()
Public Sub New
public:
CartResult()
new : unit -> CartResult
See Also

Reference

CartResult Class
Sitecore.Commerce.Services.Carts Namespace


CartResult Methods

CartResult Methods

The CartResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CartResult Class
Sitecore.Commerce.Services.Carts Namespace


CartResult Properties

CartResult Properties

The CartResult type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

CartResult Class
Sitecore.Commerce.Services.Carts Namespace


CartResult.Cart Property

CartResultCart Property
Gets or sets the cart.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Cart Cart { get; set; }
Public Property Cart As Cart
    Get
    Set
public:
property Cart^ Cart {
    Cart^ get ();
    void set (Cart^ value);
}
member Cart : Cart with get, set

Property Value

Type: Cart
See Also

Reference

CartResult Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider Class

CartServiceProvider Class
Represents the interaction with the carts. Service providers are wrapper objects that ease the interaction with CommerceConnect pipelines. Service providers only implement the logic that calls pipelines. All the business logic is implemented in the pipeline's processors. Every method receives a request object and returns a result object, for example, GetCarts receives GetCartsRequest and returns GetCartsResult. To follow the best practice and ease the API optimization as implemented in the domain model, every class must be defined as an abstract class rather than an interface. The CartServiceProvider class implements the ServiceProvider class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProvider
Sitecore.Commerce.Services.CartsCartServiceProvider

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CartServiceProvider : ServiceProvider
Public Class CartServiceProvider
    Inherits ServiceProvider
public ref class CartServiceProvider : public ServiceProvider
type CartServiceProvider =
    class
        inherit ServiceProvider
    end

The CartServiceProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CartServiceProvider | Initializes a new instance of the CartServiceProvider class
Top
Methods
Name Description
AddCartLines
Adds the cart lines. It is called when you add a list of cart lines. On the user interface, it is called when the visitor clicks the Add to Cart button. The AddLinesToCart pipeline:
  • Adds lines on a cart, even if the lines that already exist on the cart contain the same products of the new lines.
  • Records the corresponding page event in the Digital Marketing System (DMS).
The AddLinestoCart pipeline executes the following processors:
  • CheckIfLocked
  • AddLinesToCart
  • RunSaveCart
  • TriggerPageEventsForCartLines
AddParties
Adds the parties.
Public method AddPaymentInfo
Adds the payment information.
Public method AddShippingInfo
Adds the shipping information.
CreateOrResumeCart
Initiates the creation of a shopping cart and in the process, it :
  • Loads any persisted or abandoned cart.
  • Triggers events in DMS.
  • Enrolls the visitor in the Engagement Automation (EA) plan and stores the cart data in the AutomationStates object.
DeleteCart
Deletes a cart permanently and triggers an event in DMS to inform that the cart is deleted. On the user interface, it is called:
  • When the user has gone through the scenario of paying, an order has been created and registered.
  • After a cart has been in the abandoned state for a particular period.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetCarts
Gets the carts that match the specified criteria. The GetCards method calls the GetCart pipeline It queries the cart data in the external commerce system and gets a collection of CartBase objects that contains the summary of the main cart data. For example, you can use the GetCarts method to:
  • Get the carts for a specific visitor.
  • Get one of the carts for the current visitor in a multi-cart solution.
  • Get the carts that have not been used within a particular period, such as abandoned carts.
For more information, see the CartBase class.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method LoadCart
Gets the details of a cart that is assigned to a Cart ID on a webshop. The LoadCart method calls the LoadCart pipeline and returns the full cart object with all associated cart lines.
LockCart
Sets the cart to the locked state where it is ready to be committed to an order. Before any optional payment transaction is performed, this method:
  • Sets the cart to locked and save it.
  • Triggers an event in DMS to inform that the cart is in the locked state.
When a cart is in the locked state, it indicates that you cannot use other service layer methods to modify the shopping cart content. you can lock the cart to prevent further changes in the cart before submitting the order. For example, the LockCart method is called during the checkout process, just before any payment transaction is executed and before turning the cart into an order. On the user interface, it is triggered when a user in the checkout flow has confirmed the cart's content. There is a corresponding UnlockCart method.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
MergeCart
Merges the carts. Called to merge an anonymous cart to a user cart.
RemoveCartLines
Removes cart lines from a cart. It is called when you remove one or more cart lines from the shopping cart. On the user interface, it is called when the user updates the cart to remove one or more lines.
RemoveParties
Removes the parties.
Public method RemovePaymentInfo
Removes the payment information.
Public method RemoveShippingInfo
Removes the shipping information.
Public method RunPipelineTRequest, TResult
Runs the pipeline.
(Inherited from ServiceProvider.)
Public method SaveCart
Saves a cart in the external commerce system if supported and sets it to the Sitecore Engagement Automation (EA) state. It calls the SaveCart pipeline. You cannot call the SaveCart method directly. Other methods in the service layer call it when a specific cart needs to be saved. It is executed when you modify the cart, such as updating, adding, deleting cart lines and when you lock and unlock a cart.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
UnlockCart
Sets the cart in the unlocked state, saves it, and triggers an event in DMS to inform that the cart is in the unlocked state. If a cart is in the unlocked state, it is editable. It is typically called if user returns to the cart and decides to modify the content after starting the checkout process and payment transaction. There is a corresponding LockCart method.
UpdateCart
Passes an updated cart to the external commerce system. It triggers an event in DMS to inform that the cart is being updated. The method is executed after any operation that modifies the cart, typically when an adjustment is made to a cart.
Public method UpdateCartLines
Updates the cart lines. It is called when you update the lines in a shopping cart. On the user interface, it is called when the user updates the cart of a specific product. This typically happens when a user:
  • Changes the quantity.
  • Adds a service, such as, insurance or shipping.
  • Enters a promotion code for a given product.
  • Replaces the product with another variant.
UpdateParties
Updates the parties.
Top
Extension Methods
Name Description
Public Extension Method AddCartLinesTAddCartLinesRequest, TAddCartLinesResult
Adds the cart lines.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method AddPartiesTAddPartiesRequest, TAddPartiesResult
Adds the parties.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method AddPaymentInfoTAddPaymentInfoRequest, TAddPaymentInfoResult
Adds the payment information.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method AddShippingInfoTAddShippingInfoRequest, TAddShippingInfoResult
Adds the shipping information.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method CreateOrResumeCartTCreateOrResumeCartRequest, TCreateCartResult
Initiate the creation of a shopping cart and in the process:
  • Tries to load persisted, potentially abandoned cart, if present
  • Triggers an event in DMS
  • Enters the a user in the Engagement Automation (EA) plan with the ID of the shopping cart.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method DeleteCartTDeleteCartRequest, TDeleteCartResult
Deletes a cart.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method GetCartsTGetCartsRequest, TGetCartsResult
Gets the carts that match the specified criteria. It calls the GetCarts pipeline.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method LoadCartTLoadCartRequest, TLoadCartResult
Gets the cart with given Cart ID. Calls the LoadCart pipeline. This method returns the full cart object with all cart lines associated.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method LockCartTLockCartRequest, TLockCartResult
The lock cart.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method RemoveCartLinesTRemoveCartLinesRequest, TRemoveCartLinesResult
Removes the cart lines.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method RemovePartiesTRemovePartiesRequest, TRemovePartiesResult
Removes the parties.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method RemovePaymentInfoTRemovePaymentInfoRequest, TRemovePaymentInfoResult
Removes the payment information.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method RemoveShippingInfoTRemoveShippingInfoRequest, TRemoveShippingInfoResult
Removes the shipping information.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method SaveCartTSaveCartRequest, TSaveCartResult
Saves the specified cart in the external system if supported and in EA state. Calls the pipeline "saveCart". Called from other service layer methods, but not called explicitly.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method UnlockCartTUnlockCartRequest, TUnlockCartResult
Unlocks the cart.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method UpdateCartTUpdateCartRequest, TUpdateCartResult
Updates a cart.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method UpdateCartLinesTUpdateCartLinesRequest, TUpdateCartLinesResult
Updates the cart lines.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method UpdatePartiesTUpdatePartiesRequest, TUpdatePartiesResult
Updates the parties.
(Defined by GenericCartServiceProviderExtensions.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from ServiceProvider.)
Top
Remarks
The Cart Provider methods call the cart pipelines to interact with the carts.
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider Constructor

CartServiceProvider Constructor
Initializes a new instance of the CartServiceProvider class

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CartServiceProvider()
Public Sub New
public:
CartServiceProvider()
new : unit -> CartServiceProvider
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider Methods

CartServiceProvider Methods

The CartServiceProvider type exposes the following members.

Methods
Name Description
AddCartLines
Adds the cart lines. It is called when you add a list of cart lines. On the user interface, it is called when the visitor clicks the Add to Cart button. The AddLinesToCart pipeline:
  • Adds lines on a cart, even if the lines that already exist on the cart contain the same products of the new lines.
  • Records the corresponding page event in the Digital Marketing System (DMS).
The AddLinestoCart pipeline executes the following processors:
  • CheckIfLocked
  • AddLinesToCart
  • RunSaveCart
  • TriggerPageEventsForCartLines
AddParties
Adds the parties.
Public method AddPaymentInfo
Adds the payment information.
Public method AddShippingInfo
Adds the shipping information.
CreateOrResumeCart
Initiates the creation of a shopping cart and in the process, it :
  • Loads any persisted or abandoned cart.
  • Triggers events in DMS.
  • Enrolls the visitor in the Engagement Automation (EA) plan and stores the cart data in the AutomationStates object.
DeleteCart
Deletes a cart permanently and triggers an event in DMS to inform that the cart is deleted. On the user interface, it is called:
  • When the user has gone through the scenario of paying, an order has been created and registered.
  • After a cart has been in the abandoned state for a particular period.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetCarts
Gets the carts that match the specified criteria. The GetCards method calls the GetCart pipeline It queries the cart data in the external commerce system and gets a collection of CartBase objects that contains the summary of the main cart data. For example, you can use the GetCarts method to:
  • Get the carts for a specific visitor.
  • Get one of the carts for the current visitor in a multi-cart solution.
  • Get the carts that have not been used within a particular period, such as abandoned carts.
For more information, see the CartBase class.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method LoadCart
Gets the details of a cart that is assigned to a Cart ID on a webshop. The LoadCart method calls the LoadCart pipeline and returns the full cart object with all associated cart lines.
LockCart
Sets the cart to the locked state where it is ready to be committed to an order. Before any optional payment transaction is performed, this method:
  • Sets the cart to locked and save it.
  • Triggers an event in DMS to inform that the cart is in the locked state.
When a cart is in the locked state, it indicates that you cannot use other service layer methods to modify the shopping cart content. you can lock the cart to prevent further changes in the cart before submitting the order. For example, the LockCart method is called during the checkout process, just before any payment transaction is executed and before turning the cart into an order. On the user interface, it is triggered when a user in the checkout flow has confirmed the cart's content. There is a corresponding UnlockCart method.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
MergeCart
Merges the carts. Called to merge an anonymous cart to a user cart.
RemoveCartLines
Removes cart lines from a cart. It is called when you remove one or more cart lines from the shopping cart. On the user interface, it is called when the user updates the cart to remove one or more lines.
RemoveParties
Removes the parties.
Public method RemovePaymentInfo
Removes the payment information.
Public method RemoveShippingInfo
Removes the shipping information.
Public method RunPipelineTRequest, TResult
Runs the pipeline.
(Inherited from ServiceProvider.)
Public method SaveCart
Saves a cart in the external commerce system if supported and sets it to the Sitecore Engagement Automation (EA) state. It calls the SaveCart pipeline. You cannot call the SaveCart method directly. Other methods in the service layer call it when a specific cart needs to be saved. It is executed when you modify the cart, such as updating, adding, deleting cart lines and when you lock and unlock a cart.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
UnlockCart
Sets the cart in the unlocked state, saves it, and triggers an event in DMS to inform that the cart is in the unlocked state. If a cart is in the unlocked state, it is editable. It is typically called if user returns to the cart and decides to modify the content after starting the checkout process and payment transaction. There is a corresponding LockCart method.
UpdateCart
Passes an updated cart to the external commerce system. It triggers an event in DMS to inform that the cart is being updated. The method is executed after any operation that modifies the cart, typically when an adjustment is made to a cart.
Public method UpdateCartLines
Updates the cart lines. It is called when you update the lines in a shopping cart. On the user interface, it is called when the user updates the cart of a specific product. This typically happens when a user:
  • Changes the quantity.
  • Adds a service, such as, insurance or shipping.
  • Enters a promotion code for a given product.
  • Replaces the product with another variant.
UpdateParties
Updates the parties.
Top
Extension Methods
Name Description
Public Extension Method AddCartLinesTAddCartLinesRequest, TAddCartLinesResult
Adds the cart lines.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method AddPartiesTAddPartiesRequest, TAddPartiesResult
Adds the parties.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method AddPaymentInfoTAddPaymentInfoRequest, TAddPaymentInfoResult
Adds the payment information.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method AddShippingInfoTAddShippingInfoRequest, TAddShippingInfoResult
Adds the shipping information.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method CreateOrResumeCartTCreateOrResumeCartRequest, TCreateCartResult
Initiate the creation of a shopping cart and in the process:
  • Tries to load persisted, potentially abandoned cart, if present
  • Triggers an event in DMS
  • Enters the a user in the Engagement Automation (EA) plan with the ID of the shopping cart.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method DeleteCartTDeleteCartRequest, TDeleteCartResult
Deletes a cart.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method GetCartsTGetCartsRequest, TGetCartsResult
Gets the carts that match the specified criteria. It calls the GetCarts pipeline.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method LoadCartTLoadCartRequest, TLoadCartResult
Gets the cart with given Cart ID. Calls the LoadCart pipeline. This method returns the full cart object with all cart lines associated.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method LockCartTLockCartRequest, TLockCartResult
The lock cart.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method RemoveCartLinesTRemoveCartLinesRequest, TRemoveCartLinesResult
Removes the cart lines.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method RemovePartiesTRemovePartiesRequest, TRemovePartiesResult
Removes the parties.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method RemovePaymentInfoTRemovePaymentInfoRequest, TRemovePaymentInfoResult
Removes the payment information.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method RemoveShippingInfoTRemoveShippingInfoRequest, TRemoveShippingInfoResult
Removes the shipping information.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method SaveCartTSaveCartRequest, TSaveCartResult
Saves the specified cart in the external system if supported and in EA state. Calls the pipeline "saveCart". Called from other service layer methods, but not called explicitly.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method UnlockCartTUnlockCartRequest, TUnlockCartResult
Unlocks the cart.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method UpdateCartTUpdateCartRequest, TUpdateCartResult
Updates a cart.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method UpdateCartLinesTUpdateCartLinesRequest, TUpdateCartLinesResult
Updates the cart lines.
(Defined by GenericCartServiceProviderExtensions.)
Public Extension Method UpdatePartiesTUpdatePartiesRequest, TUpdatePartiesResult
Updates the parties.
(Defined by GenericCartServiceProviderExtensions.)
Top
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.AddCartLines Method

CartServiceProviderAddCartLines Method
Adds the cart lines. It is called when you add a list of cart lines. On the user interface, it is called when the visitor clicks the Add to Cart button. The AddLinesToCart pipeline:
  • Adds lines on a cart, even if the lines that already exist on the cart contain the same products of the new lines.
  • Records the corresponding page event in the Digital Marketing System (DMS).
The AddLinestoCart pipeline executes the following processors:
  • CheckIfLocked
  • AddLinesToCart
  • RunSaveCart
  • TriggerPageEventsForCartLines

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CartResult AddCartLines(
    AddCartLinesRequest request
)
Public Overridable Function AddCartLines (
    request As AddCartLinesRequest
) As CartResult
public:
virtual CartResult^ AddCartLines(
    AddCartLinesRequest^ request
)
abstract AddCartLines :
        request : AddCartLinesRequest -> CartResult
override AddCartLines :
        request : AddCartLinesRequest -> CartResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsAddCartLinesRequest
An AddCartLinesRequest object that contains the cart ID, the shop name and a collection of cart lines that you want to add.

Return Value

Type: CartResult
A CartResult object that contains a collection of messages that are received from the external commerce system.
Examples
The following snippet is an example of using the AddCartLines method:
C#
Copy
public void CreateCartAndAddOneCartLineWithSublines()
{
// Create instance of CartServiceProvider
var cartServiceProvider = new CartServiceProvider();

// Create prefix instance
var createCartRequest = new CreateOrResumeCartRequest("Autohaus", "Ivan");
var cart = cartServiceProvider.CreateOrResumeCart(createCartRequest).Cart;

// Create prefix line with subline
var cartLines = new ReadOnlyCollection<CartLine>(new Collection<CartLine> { new CartLine { Product = new CartProduct { ProductId = "Audi", Price = new Price(10000, "USD") }, Quantity = 1, SubLines = new Collection<CartLine> { new CartLine { Product = new CartProduct { ProductId = "Winter Tyres", Price = new Price(100, "USD") }, Quantity = 4 }, new CartLine { Product = new CartProduct { ProductId = "Summer Tyres", Price = new Price(80, "USD") }, Quantity = 4 } } } });

// Create request with prefix and prefix lines
var request = new AddCartLinesRequest(cart, cartLines);

// Add prefix lines into prefix
var result = cartServiceProvider.AddCartLines(request);
var resultCart = result.Cart;

Tracker.Submit();
}
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.AddParties Method

CartServiceProviderAddParties Method
Adds the parties.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual AddPartiesResult AddParties(
    AddPartiesRequest request
)
Public Overridable Function AddParties (
    request As AddPartiesRequest
) As AddPartiesResult
public:
virtual AddPartiesResult^ AddParties(
    AddPartiesRequest^ request
)
abstract AddParties :
        request : AddPartiesRequest -> AddPartiesResult
override AddParties :
        request : AddPartiesRequest -> AddPartiesResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsAddPartiesRequest
The request.

Return Value

Type: AddPartiesResult

[Missing <returns> documentation for "M:Sitecore.Commerce.Services.Carts.CartServiceProvider.AddParties(Sitecore.Commerce.Services.Carts.AddPartiesRequest)"]

Examples
C#
Copy
public void AddPartiesTest()
{
    var service = new CartServiceProvider();
    var cart = service.LoadCart(new LoadCartRequest(shopName, cartId)).Cart;

    Party party = new Party() { ExternalId = externalId, FirstName = firstName, LastName = lastName, Address1 = address1, City = city, State = state, Country = country };

    var request = new AddPartiesRequest(cart, new List<Party> { party });
    service.AddParties(request);
}
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.AddPaymentInfo Method

CartServiceProviderAddPaymentInfo Method
Adds the payment information.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual AddPaymentInfoResult AddPaymentInfo(
    AddPaymentInfoRequest request
)
Public Overridable Function AddPaymentInfo (
    request As AddPaymentInfoRequest
) As AddPaymentInfoResult
public:
virtual AddPaymentInfoResult^ AddPaymentInfo(
    AddPaymentInfoRequest^ request
)
abstract AddPaymentInfo :
        request : AddPaymentInfoRequest -> AddPaymentInfoResult
override AddPaymentInfo :
        request : AddPaymentInfoRequest -> AddPaymentInfoResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsAddPaymentInfoRequest
The request.

Return Value

Type: AddPaymentInfoResult
A AddPaymentInfoResult object instance.
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.AddShippingInfo Method

CartServiceProviderAddShippingInfo Method
Adds the shipping information.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual AddShippingInfoResult AddShippingInfo(
    AddShippingInfoRequest request
)
Public Overridable Function AddShippingInfo (
    request As AddShippingInfoRequest
) As AddShippingInfoResult
public:
virtual AddShippingInfoResult^ AddShippingInfo(
    AddShippingInfoRequest^ request
)
abstract AddShippingInfo :
        request : AddShippingInfoRequest -> AddShippingInfoResult
override AddShippingInfo :
        request : AddShippingInfoRequest -> AddShippingInfoResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsAddShippingInfoRequest
The request.

Return Value

Type: AddShippingInfoResult
A AddShippingInfoResult object.
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.CreateOrResumeCart Method

CartServiceProviderCreateOrResumeCart Method
Initiates the creation of a shopping cart and in the process, it :
  • Loads any persisted or abandoned cart.
  • Triggers events in DMS.
  • Enrolls the visitor in the Engagement Automation (EA) plan and stores the cart data in the AutomationStates object.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CartResult CreateOrResumeCart(
    CreateOrResumeCartRequest request
)
Public Overridable Function CreateOrResumeCart (
    request As CreateOrResumeCartRequest
) As CartResult
public:
virtual CartResult^ CreateOrResumeCart(
    CreateOrResumeCartRequest^ request
)
abstract CreateOrResumeCart :
        request : CreateOrResumeCartRequest -> CartResult
override CreateOrResumeCart :
        request : CreateOrResumeCartRequest -> CartResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsCreateOrResumeCartRequest
A CreateOrResumeCartRequest object that contains the cart ID and the shop name.

Return Value

Type: CartResult
A CartResult object that contains the created or resumed cart.
Examples
The following snippet is an example of using the CreateOrResumeCart method:
C#
Copy
public void CreateAndDeleteCart()
{
// Create prefix service provider.
var cartServiceProvider = new CartServiceProvider();

// Create sample prefix.
var createCartRequest = new CreateOrResumeCartRequest("Autohaus", "Bred");
var cart = cartServiceProvider.CreateOrResumeCart(createCartRequest).Cart;
var id = cart.ExternalCartId;

// Create request to remove prefix this prefix.
var deleteCartRequest = new DeleteCartRequest(cart);

// Call service provider and receive the result.
cartServiceProvider.DeleteCart(deleteCartRequest);
}
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.DeleteCart Method

CartServiceProviderDeleteCart Method
Deletes a cart permanently and triggers an event in DMS to inform that the cart is deleted. On the user interface, it is called:
  • When the user has gone through the scenario of paying, an order has been created and registered.
  • After a cart has been in the abandoned state for a particular period.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult DeleteCart(
    DeleteCartRequest request
)
Public Overridable Function DeleteCart (
    request As DeleteCartRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ DeleteCart(
    DeleteCartRequest^ request
)
abstract DeleteCart :
        request : DeleteCartRequest -> ServiceProviderResult
override DeleteCart :
        request : DeleteCartRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsDeleteCartRequest
A DeleteCartRequest object that contains the cart ID and the shop name.

Return Value

Type: ServiceProviderResult
A group of objects that represent the messages that are received from the external commerce system.
Examples
The following snippet is an example of using the DeleteCart method:
C#
Copy
public void CreateAndDeleteCart()
{
// Create prefix service provider.
var cartServiceProvider = new CartServiceProvider();

// Create sample prefix.
var createCartRequest = new CreateOrResumeCartRequest("Autohaus", "Bred");
var cart = cartServiceProvider.CreateOrResumeCart(createCartRequest).Cart;
var id = cart.ExternalCartId;

// Create request to remove prefix this prefix.
var deleteCartRequest = new DeleteCartRequest(cart);

// Call service provider and receive the result.
cartServiceProvider.DeleteCart(deleteCartRequest);
}
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.GetCarts Method

CartServiceProviderGetCarts Method
Gets the carts that match the specified criteria. The GetCards method calls the GetCart pipeline It queries the cart data in the external commerce system and gets a collection of CartBase objects that contains the summary of the main cart data. For example, you can use the GetCarts method to:
  • Get the carts for a specific visitor.
  • Get one of the carts for the current visitor in a multi-cart solution.
  • Get the carts that have not been used within a particular period, such as abandoned carts.
For more information, see the CartBase class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetCartsResult GetCarts(
    GetCartsRequest request
)
Public Overridable Function GetCarts (
    request As GetCartsRequest
) As GetCartsResult
public:
virtual GetCartsResult^ GetCarts(
    GetCartsRequest^ request
)
abstract GetCarts :
        request : GetCartsRequest -> GetCartsResult
override GetCarts :
        request : GetCartsRequest -> GetCartsResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsGetCartsRequest
A GetCartsRequest object that contains the search criteria.

Return Value

Type: GetCartsResult
A group of objects that represent the queried carts.
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.LoadCart Method

CartServiceProviderLoadCart Method
Gets the details of a cart that is assigned to a Cart ID on a webshop. The LoadCart method calls the LoadCart pipeline and returns the full cart object with all associated cart lines.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CartResult LoadCart(
    LoadCartRequest request
)
Public Overridable Function LoadCart (
    request As LoadCartRequest
) As CartResult
public:
virtual CartResult^ LoadCart(
    LoadCartRequest^ request
)
abstract LoadCart :
        request : LoadCartRequest -> CartResult
override LoadCart :
        request : LoadCartRequest -> CartResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsLoadCartRequest
A LoadCartRequest object that contains the cart ID and the shop name.

Return Value

Type: CartResult
A CartResult object that contains the loaded cart.
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.LockCart Method

CartServiceProviderLockCart Method
Sets the cart to the locked state where it is ready to be committed to an order. Before any optional payment transaction is performed, this method:
  • Sets the cart to locked and save it.
  • Triggers an event in DMS to inform that the cart is in the locked state.
When a cart is in the locked state, it indicates that you cannot use other service layer methods to modify the shopping cart content. you can lock the cart to prevent further changes in the cart before submitting the order. For example, the LockCart method is called during the checkout process, just before any payment transaction is executed and before turning the cart into an order. On the user interface, it is triggered when a user in the checkout flow has confirmed the cart's content. There is a corresponding UnlockCart method.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CartResult LockCart(
    LockCartRequest request
)
Public Overridable Function LockCart (
    request As LockCartRequest
) As CartResult
public:
virtual CartResult^ LockCart(
    LockCartRequest^ request
)
abstract LockCart :
        request : LockCartRequest -> CartResult
override LockCart :
        request : LockCartRequest -> CartResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsLockCartRequest
A LockCartRequest object that contains the cart ID and the shop name.

Return Value

Type: CartResult
A CartResult object that represents the locked cart.
Examples
The following snippet is an example of using the LockCart method:
C#
Copy
public void LockCartTest()
{
  // Create prefix service provider.
  var cartServiceProvider = new CartServiceProvider();

  // Create a sample prefix.
  var createCartRequest = new CreateOrResumeCartRequest("Autohaus", "Jho");
  var cart = cartServiceProvider.CreateOrResumeCart(createCartRequest).Cart;

  // Create request to lock this prefix.
  var lockCartRequest = new LockCartRequest(cart);

  // Call service provider and receive the result.
  var result = cartServiceProvider.LockCart(lockCartRequest);
}
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.MergeCart Method

CartServiceProviderMergeCart Method
Merges the carts. Called to merge an anonymous cart to a user cart.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CartResult MergeCart(
    MergeCartRequest request
)
Public Overridable Function MergeCart (
    request As MergeCartRequest
) As CartResult
public:
virtual CartResult^ MergeCart(
    MergeCartRequest^ request
)
abstract MergeCart :
        request : MergeCartRequest -> CartResult
override MergeCart :
        request : MergeCartRequest -> CartResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsMergeCartRequest
The request.

Return Value

Type: CartResult

[Missing <returns> documentation for "M:Sitecore.Commerce.Services.Carts.CartServiceProvider.MergeCart(Sitecore.Commerce.Services.Carts.MergeCartRequest)"]

Examples
C#
Copy
public void MergeCartTest()
{
    var cartServiceProvider = new CartServiceProvider();
    var toCart = this.GetCart(this.UserId);
    var fromCart = this.GetCart(this.VisitorId);
    var mergeCartRequest = new MergeCartRequest(fromCart, toCart);
    return cartServiceProvider.MergeCart(mergeCartsRequest);
}
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.RemoveCartLines Method

CartServiceProviderRemoveCartLines Method
Removes cart lines from a cart. It is called when you remove one or more cart lines from the shopping cart. On the user interface, it is called when the user updates the cart to remove one or more lines.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CartResult RemoveCartLines(
    RemoveCartLinesRequest request
)
Public Overridable Function RemoveCartLines (
    request As RemoveCartLinesRequest
) As CartResult
public:
virtual CartResult^ RemoveCartLines(
    RemoveCartLinesRequest^ request
)
abstract RemoveCartLines :
        request : RemoveCartLinesRequest -> CartResult
override RemoveCartLines :
        request : RemoveCartLinesRequest -> CartResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsRemoveCartLinesRequest
A RemoveCartLinesRequest that contains the cart ID, the shop name and a collection of cart lines to be removed.

Return Value

Type: CartResult
A CartResult object that contains the updated cart in the external commerce system.
Examples
C#
Copy
public void RemoveCartLinesTest()
{
   // Create prefix service provider.
   var cartServiceProvider = new CartServiceProvider();

   // Create prefix with "Audi Q10", "BMW X7" and "Citroen C3"
   var createCartRequest = new CreateOrResumeCartRequest("Autohaus", "John");
   var cart = cartServiceProvider.CreateOrResumeCart(createCartRequest).Cart;
   var cartLine1 = new CartLine { Quantity = 1, Product = new CartProduct { ProductId = "Audi Q10", Price = new Price(55, "USD") } };
   var cartLine2 = new CartLine { Quantity = 2, Product = new CartProduct { ProductId = "BMW X7", Price = new Price(10, "USD") } };
   var cartLine3 = new CartLine { Quantity = 1, Product = new CartProduct { ProductId = "Citroen C3", Price = new Price(25, "USD") } };
   var cartLines = new Collection<CartLine> { cartLine1, cartLine2, cartLine3 };
   var addCartLinesRequest = new AddCartLinesRequest(cart, cartLines);
   cart = cartServiceProvider.AddCartLines(addCartLinesRequest).Cart;

   // Create request to remove prefix line "BMW X7".
   var request = new RemoveCartLinesRequest(cart, cart.CartLines.Where(l => l.Product.ProductId == "BMW X7").ToArray());

   // Call service provider and receive the result.
   var result = cartServiceProvider.RemoveCartLines(request);
}
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.RemoveParties Method

CartServiceProviderRemoveParties Method
Removes the parties.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual RemovePartiesResult RemoveParties(
    RemovePartiesRequest request
)
Public Overridable Function RemoveParties (
    request As RemovePartiesRequest
) As RemovePartiesResult
public:
virtual RemovePartiesResult^ RemoveParties(
    RemovePartiesRequest^ request
)
abstract RemoveParties :
        request : RemovePartiesRequest -> RemovePartiesResult
override RemoveParties :
        request : RemovePartiesRequest -> RemovePartiesResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsRemovePartiesRequest
The request.

Return Value

Type: RemovePartiesResult

[Missing <returns> documentation for "M:Sitecore.Commerce.Services.Carts.CartServiceProvider.RemoveParties(Sitecore.Commerce.Services.Carts.RemovePartiesRequest)"]

Examples
C#
Copy
public void RemovePartiesTest()
{
    var service = new CartServiceProvider();
    var cart = service.LoadCart(new LoadCartRequest(shopName, cartId)).Cart;

    Party party = new Party() { ExternalId = externalId };

    var request = new RemovePartiesRequest(cart, new List<Party> { party });
    service.RemoveParties(request);
}
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.RemovePaymentInfo Method

CartServiceProviderRemovePaymentInfo Method
Removes the payment information.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual RemovePaymentInfoResult RemovePaymentInfo(
    RemovePaymentInfoRequest request
)
Public Overridable Function RemovePaymentInfo (
    request As RemovePaymentInfoRequest
) As RemovePaymentInfoResult
public:
virtual RemovePaymentInfoResult^ RemovePaymentInfo(
    RemovePaymentInfoRequest^ request
)
abstract RemovePaymentInfo :
        request : RemovePaymentInfoRequest -> RemovePaymentInfoResult
override RemovePaymentInfo :
        request : RemovePaymentInfoRequest -> RemovePaymentInfoResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsRemovePaymentInfoRequest
The request.

Return Value

Type: RemovePaymentInfoResult
A RemovePaymentInfoResult object.
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.RemoveShippingInfo Method

CartServiceProviderRemoveShippingInfo Method
Removes the shipping information.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual RemoveShippingInfoResult RemoveShippingInfo(
    RemoveShippingInfoRequest request
)
Public Overridable Function RemoveShippingInfo (
    request As RemoveShippingInfoRequest
) As RemoveShippingInfoResult
public:
virtual RemoveShippingInfoResult^ RemoveShippingInfo(
    RemoveShippingInfoRequest^ request
)
abstract RemoveShippingInfo :
        request : RemoveShippingInfoRequest -> RemoveShippingInfoResult
override RemoveShippingInfo :
        request : RemoveShippingInfoRequest -> RemoveShippingInfoResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsRemoveShippingInfoRequest
The request.

Return Value

Type: RemoveShippingInfoResult
A RemoveShippingInfoResult object.
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.SaveCart Method

CartServiceProviderSaveCart Method
Saves a cart in the external commerce system if supported and sets it to the Sitecore Engagement Automation (EA) state. It calls the SaveCart pipeline. You cannot call the SaveCart method directly. Other methods in the service layer call it when a specific cart needs to be saved. It is executed when you modify the cart, such as updating, adding, deleting cart lines and when you lock and unlock a cart.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SaveCart(
    SaveCartRequest request
)
Public Overridable Function SaveCart (
    request As SaveCartRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SaveCart(
    SaveCartRequest^ request
)
abstract SaveCart :
        request : SaveCartRequest -> ServiceProviderResult
override SaveCart :
        request : SaveCartRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsSaveCartRequest
A SaveCartRequest object contains the cart ID and the shop name.

Return Value

Type: ServiceProviderResult
A ServiceProviderResult object that contains a group of messages that are received from the external commerce system.
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.UnlockCart Method

CartServiceProviderUnlockCart Method
Sets the cart in the unlocked state, saves it, and triggers an event in DMS to inform that the cart is in the unlocked state. If a cart is in the unlocked state, it is editable. It is typically called if user returns to the cart and decides to modify the content after starting the checkout process and payment transaction. There is a corresponding LockCart method.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CartResult UnlockCart(
    UnlockCartRequest request
)
Public Overridable Function UnlockCart (
    request As UnlockCartRequest
) As CartResult
public:
virtual CartResult^ UnlockCart(
    UnlockCartRequest^ request
)
abstract UnlockCart :
        request : UnlockCartRequest -> CartResult
override UnlockCart :
        request : UnlockCartRequest -> CartResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsUnlockCartRequest
A UnlockCartRequest object that contains the cart ID and the shop name.

Return Value

Type: CartResult
A CartResult object that represents the unlocked cart.
Examples
The following snippet is an example of using the UnlockCart method:
C#
Copy
public void UnlockCartTest()
{
// Create prefix service provider.
var cartServiceProvider = new CartServiceProvider();
// Create prefix and lock it.
var createCartRequest = new CreateOrResumeCartRequest("Autohaus", "Mark");
var cart = cartServiceProvider.CreateOrResumeCart(createCartRequest).Cart;
var lockCartRequest = new LockCartRequest(cart);
cart = cartServiceProvider.LockCart(lockCartRequest).Cart;

// Create request to unlock this prefix.
var unlockCartRequest = new UnlockCartRequest(cart);

// Call service provider and receive the result.
var result = cartServiceProvider.UnlockCart(unlockCartRequest);
}
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.UpdateCart Method

CartServiceProviderUpdateCart Method
Passes an updated cart to the external commerce system. It triggers an event in DMS to inform that the cart is being updated. The method is executed after any operation that modifies the cart, typically when an adjustment is made to a cart.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CartResult UpdateCart(
    UpdateCartRequest request
)
Public Overridable Function UpdateCart (
    request As UpdateCartRequest
) As CartResult
public:
virtual CartResult^ UpdateCart(
    UpdateCartRequest^ request
)
abstract UpdateCart :
        request : UpdateCartRequest -> CartResult
override UpdateCart :
        request : UpdateCartRequest -> CartResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsUpdateCartRequest
An UpdateCartRequest object that contains the cart ID and the shop name.

Return Value

Type: CartResult
A CartResult object that represents updated cart.
Examples
The following snippet is an example of using the UpdateCart method:
C#
Copy
public void UpdateCartBody()
{
 // Create prefix service provider.
 var cartServiceProvider = new CartServiceProvider();

 // Create prefix.
 var createCartRequest = new CreateOrResumeCartRequest("Autohaus", "Peter");
 var cart = cartServiceProvider.CreateOrResumeCart(createCartRequest).Cart;

 // Create the instance of the CartBase with properties that should be changed in existing prefix.
 var changes = new CartBase { CustomerId = "Customer Peter", CartName = "Peter's Cart", ShopName = "Autohaus" };

 // Create request to update the prefix.
 var updateCartRequest = new UpdateCartRequest(cart, changes);

 // Call service provider with prepared request and receive the result.
 var result = cartServiceProvider.UpdateCart(updateCartRequest);
}
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.UpdateCartLines Method

CartServiceProviderUpdateCartLines Method
Updates the cart lines. It is called when you update the lines in a shopping cart. On the user interface, it is called when the user updates the cart of a specific product. This typically happens when a user:
  • Changes the quantity.
  • Adds a service, such as, insurance or shipping.
  • Enters a promotion code for a given product.
  • Replaces the product with another variant.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CartResult UpdateCartLines(
    UpdateCartLinesRequest request
)
Public Overridable Function UpdateCartLines (
    request As UpdateCartLinesRequest
) As CartResult
public:
virtual CartResult^ UpdateCartLines(
    UpdateCartLinesRequest^ request
)
abstract UpdateCartLines :
        request : UpdateCartLinesRequest -> CartResult
override UpdateCartLines :
        request : UpdateCartLinesRequest -> CartResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsUpdateCartLinesRequest
An UpdateCartLinesRequest object that contains the cart ID, the shop name and a group of cart lines that you want to update on the cart.

Return Value

Type: CartResult
A group of objects that represent the updated cart lines.
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider.UpdateParties Method

CartServiceProviderUpdateParties Method
Updates the parties.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual UpdatePartiesResult UpdateParties(
    UpdatePartiesRequest request
)
Public Overridable Function UpdateParties (
    request As UpdatePartiesRequest
) As UpdatePartiesResult
public:
virtual UpdatePartiesResult^ UpdateParties(
    UpdatePartiesRequest^ request
)
abstract UpdateParties :
        request : UpdatePartiesRequest -> UpdatePartiesResult
override UpdateParties :
        request : UpdatePartiesRequest -> UpdatePartiesResult

Parameters

request
Type: Sitecore.Commerce.Services.CartsUpdatePartiesRequest
The request.

Return Value

Type: UpdatePartiesResult

[Missing <returns> documentation for "M:Sitecore.Commerce.Services.Carts.CartServiceProvider.UpdateParties(Sitecore.Commerce.Services.Carts.UpdatePartiesRequest)"]

Examples
C#
Copy
public void UpdatePartiesTest()
{
    var service = new CartServiceProvider();
    var cart = service.LoadCart(new LoadCartRequest(shopName, cartId)).Cart;

    Party party = new Party() { ExternalId = externalId, FirstName = "changed firstname", LastName = lastName, Address1 = address1, City = city, State = state, Country = country };

    var request = new UpdatePartiesRequest(cart, new List<Party> { party });
    service.UpdateParties(request);
}
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartServiceProvider Properties

CartServiceProvider Properties

The CartServiceProvider type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from ServiceProvider.)
Top
See Also

Reference

CartServiceProvider Class
Sitecore.Commerce.Services.Carts Namespace


CartStatus Class

CartStatus Class
Defines CartStatus class with fundamental cart statuses.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Services.CartsCartStatus

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class CartStatus
Public NotInheritable Class CartStatus
public ref class CartStatus abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CartStatus =  class end

The CartStatus type exposes the following members.

Fields
Name | Description
Abandoned | The "Abandoned" cart status.
InProcess | The "InProcess" cart status.
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


CartStatus Fields

CartStatus Fields

The CartStatus type exposes the following members.

Fields
Name | Description
Abandoned | The "Abandoned" cart status.
InProcess | The "InProcess" cart status.
Top
See Also

Reference

CartStatus Class
Sitecore.Commerce.Services.Carts Namespace


CartStatus.Abandoned Field

CartStatusAbandoned Field
The "Abandoned" cart status.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static readonly string Abandoned
Public Shared ReadOnly Abandoned As String
public:
static initonly String^ Abandoned
static val Abandoned: string

Field Value

Type: String
See Also

Reference

CartStatus Class
Sitecore.Commerce.Services.Carts Namespace


CartStatus.InProcess Field

CartStatusInProcess Field
The "InProcess" cart status.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static readonly string InProcess
Public Shared ReadOnly InProcess As String
public:
static initonly String^ InProcess
static val InProcess: string

Field Value

Type: String
See Also

Reference

CartStatus Class
Sitecore.Commerce.Services.Carts Namespace


CreateOrResumeCartRequest Class

CreateOrResumeCartRequest Class
Contains the criteria that determine which cart should be created.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCreateOrResumeCartRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CreateOrResumeCartRequest : CartRequest
Public Class CreateOrResumeCartRequest
    Inherits CartRequest
public ref class CreateOrResumeCartRequest : public CartRequest
type CreateOrResumeCartRequest =
    class
        inherit CartRequest
    end

The CreateOrResumeCartRequest type exposes the following members.

Constructors
 | Name | Description
Public method | CreateOrResumeCartRequest | Initializes a new instance of the CreateOrResumeCartRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerId | Gets or sets the customer id.
Public property | Name | Gets or sets the cart name.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Public property | UserId | Gets or sets the user id.
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


CreateOrResumeCartRequest Constructor

CreateOrResumeCartRequest Constructor
Initializes a new instance of the CreateOrResumeCartRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CreateOrResumeCartRequest(
    string shopName,
    string userId,
    string cartName = null,
    string customerId = null
)
Public Sub New (
    shopName As String,
    userId As String,
    Optional cartName As String = Nothing,
    Optional customerId As String = Nothing
)
public:
CreateOrResumeCartRequest(
    String^ shopName,
    String^ userId,
    String^ cartName = nullptr,
    String^ customerId = nullptr
)
new :
        shopName : string *
        userId : string *
        ?cartName : string *
        ?customerId : string
(* Defaults:
        let _cartName = defaultArg cartName null
        let _customerId = defaultArg customerId null
*)
-> CreateOrResumeCartRequest

Parameters

shopName
Type: SystemString
Name of the shop.
userId
Type: SystemString
The user id.
cartName (Optional)
Type: SystemString
Name of the cart.
customerId (Optional)
Type: SystemString
The customer id.
See Also

Reference

CreateOrResumeCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


CreateOrResumeCartRequest Methods

CreateOrResumeCartRequest Methods

The CreateOrResumeCartRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateOrResumeCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


CreateOrResumeCartRequest Properties

CreateOrResumeCartRequest Properties

The CreateOrResumeCartRequest type exposes the following members.

Properties
 | Name | Description
Public property | CustomerId | Gets or sets the customer id.
Public property | Name | Gets or sets the cart name.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Public property | UserId | Gets or sets the user id.
Top
See Also

Reference

CreateOrResumeCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


CreateOrResumeCartRequest.CustomerId Property

CreateOrResumeCartRequestCustomerId Property
Gets or sets the customer id.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string CustomerId { get; set; }
Public Property CustomerId As String
    Get
    Set
public:
property String^ CustomerId {
    String^ get ();
    void set (String^ value);
}
member CustomerId : string with get, set

Property Value

Type: String
See Also

Reference

CreateOrResumeCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


CreateOrResumeCartRequest.Name Property

CreateOrResumeCartRequestName Property
Gets or sets the cart name.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

CreateOrResumeCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


CreateOrResumeCartRequest.ShopName Property

CreateOrResumeCartRequestShopName Property
Gets or sets the name of the shop.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; protected set; }
Public Property ShopName As String
    Get
    Protected Set
public:
property String^ ShopName {
    String^ get ();
    protected: void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
The name of the shop.
See Also

Reference

CreateOrResumeCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


CreateOrResumeCartRequest.UserId Property

CreateOrResumeCartRequestUserId Property
Gets or sets the user id.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string UserId { get; protected set; }
Public Property UserId As String
    Get
    Protected Set
public:
property String^ UserId {
    String^ get ();
    protected: void set (String^ value);
}
member UserId : string with get, set

Property Value

Type: String
The user id.
See Also

Reference

CreateOrResumeCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


DeleteCartRequest Class

DeleteCartRequest Class
Contains the cart to be deleted.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsDeleteCartRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DeleteCartRequest : CartRequestWithCart
Public Class DeleteCartRequest
    Inherits CartRequestWithCart
public ref class DeleteCartRequest : public CartRequestWithCart
type DeleteCartRequest =
    class
        inherit CartRequestWithCart
    end

The DeleteCartRequest type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteCartRequest | Initializes a new instance of the DeleteCartRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


DeleteCartRequest Constructor

DeleteCartRequest Constructor
Initializes a new instance of the DeleteCartRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DeleteCartRequest(
    Cart cart
)
Public Sub New (
    cart As Cart
)
public:
DeleteCartRequest(
    Cart^ cart
)
new :
        cart : Cart -> DeleteCartRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
See Also

Reference

DeleteCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


DeleteCartRequest Methods

DeleteCartRequest Methods

The DeleteCartRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


DeleteCartRequest Properties

DeleteCartRequest Properties

The DeleteCartRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

DeleteCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


GetCartsRequest Class

GetCartsRequest Class
Defines the request to the Product Synchronization Provider that can contain some search parameters. In this request, the shop name is required. The lists of user IDs, customer identifiers, cart names and cart statuses are optional.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsGetCartsRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetCartsRequest : CartRequest
Public Class GetCartsRequest
    Inherits CartRequest
public ref class GetCartsRequest : public CartRequest
type GetCartsRequest =
    class
        inherit CartRequest
    end

The GetCartsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetCartsRequest | Initializes an instance of the GetCartsRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerIds | Gets or sets the customer IDs.
Public property | IsLocked | Gets or sets a value indicating whether this instance is locked.
Public property | Names | Gets or sets the cart names.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | Query | Gets or sets the query.
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop to get carts from.
Public property | Statuses | Gets or sets the cart statuses.
Public property | UserIds | Gets or sets the user IDs.
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


GetCartsRequest Constructor

GetCartsRequest Constructor
Initializes an instance of the GetCartsRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetCartsRequest(
    string shopName
)
Public Sub New (
    shopName As String
)
public:
GetCartsRequest(
    String^ shopName
)
new :
        shopName : string -> GetCartsRequest

Parameters

shopName
Type: SystemString
The name of the shop
See Also

Reference

GetCartsRequest Class
Sitecore.Commerce.Services.Carts Namespace


GetCartsRequest Methods

GetCartsRequest Methods

The GetCartsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetCartsRequest Class
Sitecore.Commerce.Services.Carts Namespace


GetCartsRequest Properties

GetCartsRequest Properties

The GetCartsRequest type exposes the following members.

Properties
 | Name | Description
Public property | CustomerIds | Gets or sets the customer IDs.
Public property | IsLocked | Gets or sets a value indicating whether this instance is locked.
Public property | Names | Gets or sets the cart names.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | Query | Gets or sets the query.
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop to get carts from.
Public property | Statuses | Gets or sets the cart statuses.
Public property | UserIds | Gets or sets the user IDs.
Top
See Also

Reference

GetCartsRequest Class
Sitecore.Commerce.Services.Carts Namespace


GetCartsRequest.CustomerIds Property

GetCartsRequestCustomerIds Property
Gets or sets the customer IDs.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> CustomerIds { get; set; }
Public Property CustomerIds As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ CustomerIds {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member CustomerIds : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The customer IDs
See Also

Reference

GetCartsRequest Class
Sitecore.Commerce.Services.Carts Namespace


GetCartsRequest.IsLocked Property

GetCartsRequestIsLocked Property
Gets or sets a value indicating whether this instance is locked.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> IsLocked { get; set; }
Public Property IsLocked As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsLocked {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member IsLocked : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
true if this instance is locked
See Also

Reference

GetCartsRequest Class
Sitecore.Commerce.Services.Carts Namespace


GetCartsRequest.Names Property

GetCartsRequestNames Property
Gets or sets the cart names.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> Names { get; set; }
Public Property Names As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ Names {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member Names : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The cart names
See Also

Reference

GetCartsRequest Class
Sitecore.Commerce.Services.Carts Namespace


GetCartsRequest.Query Property

GetCartsRequestQuery Property
Gets or sets the query.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Expression<Func<CartBase, bool>> Query { get; set; }
Public Property Query As Expression(Of Func(Of CartBase, Boolean))
    Get
    Set
public:
property Expression<Func<CartBase^, bool>^>^ Query {
    Expression<Func<CartBase^, bool>^>^ get ();
    void set (Expression<Func<CartBase^, bool>^>^ value);
}
member Query : Expression<Func<CartBase, bool>> with get, set

Property Value

Type: Expression Func CartBase, Boolean
The query
See Also

Reference

GetCartsRequest Class
Sitecore.Commerce.Services.Carts Namespace


GetCartsRequest.ShopName Property

GetCartsRequestShopName Property
Gets or sets the name of the shop to get carts from.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
The name of the shop
See Also

Reference

GetCartsRequest Class
Sitecore.Commerce.Services.Carts Namespace


GetCartsRequest.Statuses Property

GetCartsRequestStatuses Property
Gets or sets the cart statuses.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> Statuses { get; set; }
Public Property Statuses As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ Statuses {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member Statuses : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The cart statuses
See Also

Reference

GetCartsRequest Class
Sitecore.Commerce.Services.Carts Namespace


GetCartsRequest.UserIds Property

GetCartsRequestUserIds Property
Gets or sets the user IDs.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> UserIds { get; set; }
Public Property UserIds As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ UserIds {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member UserIds : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The user IDs
See Also

Reference

GetCartsRequest Class
Sitecore.Commerce.Services.Carts Namespace


GetCartsResult Class

GetCartsResult Class
The get carts result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CartsGetCartsResult

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetCartsResult : ServiceProviderResult
Public Class GetCartsResult
    Inherits ServiceProviderResult
public ref class GetCartsResult : public ServiceProviderResult
type GetCartsResult =
    class
        inherit ServiceProviderResult
    end

The GetCartsResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetCartsResult | Initializes a new instance of the GetCartsResult class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Carts | Gets or sets the carts.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


GetCartsResult Constructor

GetCartsResult Constructor
Initializes a new instance of the GetCartsResult class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetCartsResult()
Public Sub New
public:
GetCartsResult()
new : unit -> GetCartsResult
See Also

Reference

GetCartsResult Class
Sitecore.Commerce.Services.Carts Namespace


GetCartsResult Methods

GetCartsResult Methods

The GetCartsResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetCartsResult Class
Sitecore.Commerce.Services.Carts Namespace


GetCartsResult Properties

GetCartsResult Properties

The GetCartsResult type exposes the following members.

Properties
 | Name | Description
Public property | Carts | Gets or sets the carts.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetCartsResult Class
Sitecore.Commerce.Services.Carts Namespace


GetCartsResult.Carts Property

GetCartsResultCarts Property
Gets or sets the carts.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<CartBase> Carts { get; set; }
Public Property Carts As IEnumerable(Of CartBase)
    Get
    Set
public:
property IEnumerable<CartBase^>^ Carts {
    IEnumerable<CartBase^>^ get ();
    void set (IEnumerable<CartBase^>^ value);
}
member Carts : IEnumerable<CartBase> with get, set

Property Value

Type: IEnumerable CartBase
See Also

Reference

GetCartsResult Class
Sitecore.Commerce.Services.Carts Namespace


LoadCartRequest Class

LoadCartRequest Class
Contains the criteria that determine which cart should be retrieved.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsLoadCartRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class LoadCartRequest : CartRequest
Public Class LoadCartRequest
    Inherits CartRequest
public ref class LoadCartRequest : public CartRequest
type LoadCartRequest =
    class
        inherit CartRequest
    end

The LoadCartRequest type exposes the following members.

Constructors
 | Name | Description
Public method | LoadCartRequest | Initializes a new instance of the LoadCartRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CartId | Gets or sets the cart id.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Public property | UserId | Gets or sets the user identifier.
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


LoadCartRequest Constructor

LoadCartRequest Constructor
Initializes a new instance of the LoadCartRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public LoadCartRequest(
    string shopName,
    string cartId,
    string userId = null
)
Public Sub New (
    shopName As String,
    cartId As String,
    Optional userId As String = Nothing
)
public:
LoadCartRequest(
    String^ shopName,
    String^ cartId,
    String^ userId = nullptr
)
new :
        shopName : string *
        cartId : string *
        ?userId : string
(* Defaults:
        let _userId = defaultArg userId null
*)
-> LoadCartRequest

Parameters

shopName
Type: SystemString
Name of the shop.
cartId
Type: SystemString
The cart id.
userId (Optional)
Type: SystemString
The user identifier.
See Also

Reference

LoadCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


LoadCartRequest Methods

LoadCartRequest Methods

The LoadCartRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LoadCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


LoadCartRequest Properties

LoadCartRequest Properties

The LoadCartRequest type exposes the following members.

Properties
 | Name | Description
Public property | CartId | Gets or sets the cart id.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Public property | UserId | Gets or sets the user identifier.
Top
See Also

Reference

LoadCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


LoadCartRequest.CartId Property

LoadCartRequestCartId Property
Gets or sets the cart id.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string CartId { get; protected set; }
Public Property CartId As String
    Get
    Protected Set
public:
property String^ CartId {
    String^ get ();
    protected: void set (String^ value);
}
member CartId : string with get, set

Property Value

Type: String
The cart id.
See Also

Reference

LoadCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


LoadCartRequest.ShopName Property

LoadCartRequestShopName Property
Gets or sets the name of the shop.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; protected set; }
Public Property ShopName As String
    Get
    Protected Set
public:
property String^ ShopName {
    String^ get ();
    protected: void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
The name of the shop.
See Also

Reference

LoadCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


LoadCartRequest.UserId Property

LoadCartRequestUserId Property
Gets or sets the user identifier.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string UserId { get; protected set; }
Public Property UserId As String
    Get
    Protected Set
public:
property String^ UserId {
    String^ get ();
    protected: void set (String^ value);
}
member UserId : string with get, set

Property Value

Type: String
The user identifier.
See Also

Reference

LoadCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


LockCartRequest Class

LockCartRequest Class
Contains the cart to be locked.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsLockCartRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class LockCartRequest : CartRequestWithCart
Public Class LockCartRequest
    Inherits CartRequestWithCart
public ref class LockCartRequest : public CartRequestWithCart
type LockCartRequest =
    class
        inherit CartRequestWithCart
    end

The LockCartRequest type exposes the following members.

Constructors
 | Name | Description
Public method | LockCartRequest | Initializes a new instance of the LockCartRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


LockCartRequest Constructor

LockCartRequest Constructor
Initializes a new instance of the LockCartRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public LockCartRequest(
    Cart cart
)
Public Sub New (
    cart As Cart
)
public:
LockCartRequest(
    Cart^ cart
)
new :
        cart : Cart -> LockCartRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
See Also

Reference

LockCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


LockCartRequest Methods

LockCartRequest Methods

The LockCartRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LockCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


LockCartRequest Properties

LockCartRequest Properties

The LockCartRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

LockCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


MergeCartRequest Class

MergeCartRequest Class

[Missing <summary> documentation for "T:Sitecore.Commerce.Services.Carts.MergeCartRequest"]

Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsMergeCartRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class MergeCartRequest : CartRequest
Public Class MergeCartRequest
    Inherits CartRequest
public ref class MergeCartRequest : public CartRequest
type MergeCartRequest =
    class
        inherit CartRequest
    end

The MergeCartRequest type exposes the following members.

Constructors
 | Name | Description
Public method | MergeCartRequest | Initializes a new instance of the MergeCartRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FromCart | Gets or sets the 'from' cart.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ToCart | Gets or sets the user cart.
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


MergeCartRequest Constructor

MergeCartRequest Constructor
Initializes a new instance of the MergeCartRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public MergeCartRequest(
    Cart fromCart,
    Cart toCart
)
Public Sub New (
    fromCart As Cart,
    toCart As Cart
)
public:
MergeCartRequest(
    Cart^ fromCart,
    Cart^ toCart
)
new :
        fromCart : Cart *
        toCart : Cart -> MergeCartRequest

Parameters

fromCart
Type: Sitecore.Commerce.Entities.CartsCart
The cart that will be merged.
toCart
Type: Sitecore.Commerce.Entities.CartsCart
The cart we are merging into.
See Also

Reference

MergeCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


MergeCartRequest Methods

MergeCartRequest Methods

The MergeCartRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MergeCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


MergeCartRequest Properties

MergeCartRequest Properties

The MergeCartRequest type exposes the following members.

Properties
 | Name | Description
Public property | FromCart | Gets or sets the 'from' cart.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ToCart | Gets or sets the user cart.
Top
See Also

Reference

MergeCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


MergeCartRequest.FromCart Property

MergeCartRequestFromCart Property
Gets or sets the 'from' cart.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Cart FromCart { get; protected set; }
Public Property FromCart As Cart
    Get
    Protected Set
public:
property Cart^ FromCart {
    Cart^ get ();
    protected: void set (Cart^ value);
}
member FromCart : Cart with get, set

Property Value

Type: Cart
The anonymous cart.
See Also

Reference

MergeCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


MergeCartRequest.ToCart Property

MergeCartRequestToCart Property
Gets or sets the user cart.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Cart ToCart { get; protected set; }
Public Property ToCart As Cart
    Get
    Protected Set
public:
property Cart^ ToCart {
    Cart^ get ();
    protected: void set (Cart^ value);
}
member ToCart : Cart with get, set

Property Value

Type: Cart
The user cart.
See Also

Reference

MergeCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemoveCartLinesRequest Class

RemoveCartLinesRequest Class
Contains the cart to be updated along with the cart lines to be removed.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsCartLinesRequest
Sitecore.Commerce.Services.CartsRemoveCartLinesRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveCartLinesRequest : CartLinesRequest
Public Class RemoveCartLinesRequest
    Inherits CartLinesRequest
public ref class RemoveCartLinesRequest : public CartLinesRequest
type RemoveCartLinesRequest =
    class
        inherit CartLinesRequest
    end

The RemoveCartLinesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveCartLinesRequest | Initializes a new instance of the RemoveCartLinesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Lines | Gets or sets the cart lines. (Inherited from CartLinesRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


RemoveCartLinesRequest Constructor

RemoveCartLinesRequest Constructor
Initializes a new instance of the RemoveCartLinesRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveCartLinesRequest(
    Cart cart,
    IEnumerable<CartLine> lines
)
Public Sub New (
    cart As Cart,
    lines As IEnumerable(Of CartLine)
)
public:
RemoveCartLinesRequest(
    Cart^ cart,
    IEnumerable<CartLine^>^ lines
)
new :
        cart : Cart *
        lines : IEnumerable<CartLine> -> RemoveCartLinesRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
lines
Type: System.Collections.GenericIEnumerable CartLine
The cart lines.
See Also

Reference

RemoveCartLinesRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemoveCartLinesRequest Methods

RemoveCartLinesRequest Methods

The RemoveCartLinesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveCartLinesRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemoveCartLinesRequest Properties

RemoveCartLinesRequest Properties

The RemoveCartLinesRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Lines | Gets or sets the cart lines. (Inherited from CartLinesRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

RemoveCartLinesRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemovePartiesRequest Class

RemovePartiesRequest Class
Defines the RemovePartiesRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsRemovePartiesRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemovePartiesRequest : CartRequestWithCart
Public Class RemovePartiesRequest
    Inherits CartRequestWithCart
public ref class RemovePartiesRequest : public CartRequestWithCart
type RemovePartiesRequest =
    class
        inherit CartRequestWithCart
    end

The RemovePartiesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | RemovePartiesRequest | Initializes a new instance of the RemovePartiesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Parties | Gets or sets the parties to be removed.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


RemovePartiesRequest Constructor

RemovePartiesRequest Constructor
Initializes a new instance of the RemovePartiesRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemovePartiesRequest(
    Cart cart,
    List<Party> parties
)
Public Sub New (
    cart As Cart,
    parties As List(Of Party)
)
public:
RemovePartiesRequest(
    Cart^ cart,
    List<Party^>^ parties
)
new :
        cart : Cart *
        parties : List<Party> -> RemovePartiesRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
parties
Type: System.Collections.GenericList Party
The parties.
See Also

Reference

RemovePartiesRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemovePartiesRequest Methods

RemovePartiesRequest Methods

The RemovePartiesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemovePartiesRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemovePartiesRequest Properties

RemovePartiesRequest Properties

The RemovePartiesRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Parties | Gets or sets the parties to be removed.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

RemovePartiesRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemovePartiesRequest.Parties Property

RemovePartiesRequestParties Property
Gets or sets the parties to be removed.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<Party> Parties { get; set; }
Public Property Parties As List(Of Party)
    Get
    Set
public:
property List<Party^>^ Parties {
    List<Party^>^ get ();
    void set (List<Party^>^ value);
}
member Parties : List<Party> with get, set

Property Value

Type: List Party
The parties.
See Also

Reference

RemovePartiesRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemovePartiesResult Class

RemovePartiesResult Class
Defines the RemovePartiesResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CartsCartResult
Sitecore.Commerce.Services.CartsRemovePartiesResult

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemovePartiesResult : CartResult
Public Class RemovePartiesResult
    Inherits CartResult
public ref class RemovePartiesResult : public CartResult
type RemovePartiesResult =
    class
        inherit CartResult
    end

The RemovePartiesResult type exposes the following members.

Constructors
 | Name | Description
Public method | RemovePartiesResult | Initializes a new instance of the RemovePartiesResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartResult.)
Public property | Parties | Gets or sets the parties that were removed.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


RemovePartiesResult Constructor

RemovePartiesResult Constructor
Initializes a new instance of the RemovePartiesResult class

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemovePartiesResult()
Public Sub New
public:
RemovePartiesResult()
new : unit -> RemovePartiesResult
See Also

Reference

RemovePartiesResult Class
Sitecore.Commerce.Services.Carts Namespace


RemovePartiesResult Methods

RemovePartiesResult Methods

The RemovePartiesResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemovePartiesResult Class
Sitecore.Commerce.Services.Carts Namespace


RemovePartiesResult Properties

RemovePartiesResult Properties

The RemovePartiesResult type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartResult.)
Public property | Parties | Gets or sets the parties that were removed.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

RemovePartiesResult Class
Sitecore.Commerce.Services.Carts Namespace


RemovePartiesResult.Parties Property

RemovePartiesResultParties Property
Gets or sets the parties that were removed.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<Party> Parties { get; set; }
Public Property Parties As List(Of Party)
    Get
    Set
public:
property List<Party^>^ Parties {
    List<Party^>^ get ();
    void set (List<Party^>^ value);
}
member Parties : List<Party> with get, set

Property Value

Type: List Party
The parties.
See Also

Reference

RemovePartiesResult Class
Sitecore.Commerce.Services.Carts Namespace


RemovePaymentInfoRequest Class

RemovePaymentInfoRequest Class
Defines the RemovePaymentInfoRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsRemovePaymentInfoRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemovePaymentInfoRequest : CartRequestWithCart
Public Class RemovePaymentInfoRequest
    Inherits CartRequestWithCart
public ref class RemovePaymentInfoRequest : public CartRequestWithCart
type RemovePaymentInfoRequest =
    class
        inherit CartRequestWithCart
    end

The RemovePaymentInfoRequest type exposes the following members.

Constructors
 | Name | Description
Public method | RemovePaymentInfoRequest | Initializes a new instance of the RemovePaymentInfoRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Payments | Gets or sets the payments.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


RemovePaymentInfoRequest Constructor

RemovePaymentInfoRequest Constructor
Initializes a new instance of the RemovePaymentInfoRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemovePaymentInfoRequest(
    Cart cart,
    List<PaymentInfo> payments
)
Public Sub New (
    cart As Cart,
    payments As List(Of PaymentInfo)
)
public:
RemovePaymentInfoRequest(
    Cart^ cart,
    List<PaymentInfo^>^ payments
)
new :
        cart : Cart *
        payments : List<PaymentInfo> -> RemovePaymentInfoRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
payments
Type: System.Collections.GenericList PaymentInfo
The payments to be removed.
See Also

Reference

RemovePaymentInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemovePaymentInfoRequest Methods

RemovePaymentInfoRequest Methods

The RemovePaymentInfoRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemovePaymentInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemovePaymentInfoRequest Properties

RemovePaymentInfoRequest Properties

The RemovePaymentInfoRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Payments | Gets or sets the payments.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

RemovePaymentInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemovePaymentInfoRequest.Payments Property

RemovePaymentInfoRequestPayments Property
Gets or sets the payments.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<PaymentInfo> Payments { get; set; }
Public Property Payments As List(Of PaymentInfo)
    Get
    Set
public:
property List<PaymentInfo^>^ Payments {
    List<PaymentInfo^>^ get ();
    void set (List<PaymentInfo^>^ value);
}
member Payments : List<PaymentInfo> with get, set

Property Value

Type: List PaymentInfo
The payments.
See Also

Reference

RemovePaymentInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemovePaymentInfoResult Class

RemovePaymentInfoResult Class
Defines the RemovePaymentInfoResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CartsCartResult
Sitecore.Commerce.Services.CartsRemovePaymentInfoResult

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemovePaymentInfoResult : CartResult
Public Class RemovePaymentInfoResult
    Inherits CartResult
public ref class RemovePaymentInfoResult : public CartResult
type RemovePaymentInfoResult =
    class
        inherit CartResult
    end

The RemovePaymentInfoResult type exposes the following members.

Constructors
 | Name | Description
Public method | RemovePaymentInfoResult | Initializes a new instance of the RemovePaymentInfoResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartResult.)
Public property | Payments | Gets or sets the payments that were removed.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


RemovePaymentInfoResult Constructor

RemovePaymentInfoResult Constructor
Initializes a new instance of the RemovePaymentInfoResult class

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemovePaymentInfoResult()
Public Sub New
public:
RemovePaymentInfoResult()
new : unit -> RemovePaymentInfoResult
See Also

Reference

RemovePaymentInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


RemovePaymentInfoResult Methods

RemovePaymentInfoResult Methods

The RemovePaymentInfoResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemovePaymentInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


RemovePaymentInfoResult Properties

RemovePaymentInfoResult Properties

The RemovePaymentInfoResult type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartResult.)
Public property | Payments | Gets or sets the payments that were removed.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

RemovePaymentInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


RemovePaymentInfoResult.Payments Property

RemovePaymentInfoResultPayments Property
Gets or sets the payments that were removed.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<PaymentInfo> Payments { get; set; }
Public Property Payments As List(Of PaymentInfo)
    Get
    Set
public:
property List<PaymentInfo^>^ Payments {
    List<PaymentInfo^>^ get ();
    void set (List<PaymentInfo^>^ value);
}
member Payments : List<PaymentInfo> with get, set

Property Value

Type: List PaymentInfo
The removed payments.
See Also

Reference

RemovePaymentInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


RemoveShippingInfoRequest Class

RemoveShippingInfoRequest Class
Defines the RemoveShippingInfoRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsRemoveShippingInfoRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveShippingInfoRequest : CartRequestWithCart
Public Class RemoveShippingInfoRequest
    Inherits CartRequestWithCart
public ref class RemoveShippingInfoRequest : public CartRequestWithCart
type RemoveShippingInfoRequest =
    class
        inherit CartRequestWithCart
    end

The RemoveShippingInfoRequest type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveShippingInfoRequest | Initializes a new instance of the RemoveShippingInfoRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | Shippings | Gets or sets the shippings.
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


RemoveShippingInfoRequest Constructor

RemoveShippingInfoRequest Constructor
Initializes a new instance of the RemoveShippingInfoRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveShippingInfoRequest(
    Cart cart,
    List<ShippingInfo> shippings
)
Public Sub New (
    cart As Cart,
    shippings As List(Of ShippingInfo)
)
public:
RemoveShippingInfoRequest(
    Cart^ cart,
    List<ShippingInfo^>^ shippings
)
new :
        cart : Cart *
        shippings : List<ShippingInfo> -> RemoveShippingInfoRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
shippings
Type: System.Collections.GenericList ShippingInfo
The shippings.
See Also

Reference

RemoveShippingInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemoveShippingInfoRequest Methods

RemoveShippingInfoRequest Methods

The RemoveShippingInfoRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveShippingInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemoveShippingInfoRequest Properties

RemoveShippingInfoRequest Properties

The RemoveShippingInfoRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | Shippings | Gets or sets the shippings.
Top
See Also

Reference

RemoveShippingInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemoveShippingInfoRequest.Shippings Property

RemoveShippingInfoRequestShippings Property
Gets or sets the shippings.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<ShippingInfo> Shippings { get; set; }
Public Property Shippings As List(Of ShippingInfo)
    Get
    Set
public:
property List<ShippingInfo^>^ Shippings {
    List<ShippingInfo^>^ get ();
    void set (List<ShippingInfo^>^ value);
}
member Shippings : List<ShippingInfo> with get, set

Property Value

Type: List ShippingInfo
The shippings.
See Also

Reference

RemoveShippingInfoRequest Class
Sitecore.Commerce.Services.Carts Namespace


RemoveShippingInfoResult Class

RemoveShippingInfoResult Class
Defines the RemoveShippingInfoResult result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CartsCartResult
Sitecore.Commerce.Services.CartsRemoveShippingInfoResult

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveShippingInfoResult : CartResult
Public Class RemoveShippingInfoResult
    Inherits CartResult
public ref class RemoveShippingInfoResult : public CartResult
type RemoveShippingInfoResult =
    class
        inherit CartResult
    end

The RemoveShippingInfoResult type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveShippingInfoResult | Initializes a new instance of the RemoveShippingInfoResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartResult.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Shippings | Gets or sets the remove shippings list.
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


RemoveShippingInfoResult Constructor

RemoveShippingInfoResult Constructor
Initializes a new instance of the RemoveShippingInfoResult class

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveShippingInfoResult()
Public Sub New
public:
RemoveShippingInfoResult()
new : unit -> RemoveShippingInfoResult
See Also

Reference

RemoveShippingInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


RemoveShippingInfoResult Methods

RemoveShippingInfoResult Methods

The RemoveShippingInfoResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveShippingInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


RemoveShippingInfoResult Properties

RemoveShippingInfoResult Properties

The RemoveShippingInfoResult type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartResult.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Shippings | Gets or sets the remove shippings list.
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

RemoveShippingInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


RemoveShippingInfoResult.Shippings Property

RemoveShippingInfoResultShippings Property
Gets or sets the remove shippings list.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<ShippingInfo> Shippings { get; set; }
Public Property Shippings As List(Of ShippingInfo)
    Get
    Set
public:
property List<ShippingInfo^>^ Shippings {
    List<ShippingInfo^>^ get ();
    void set (List<ShippingInfo^>^ value);
}
member Shippings : List<ShippingInfo> with get, set

Property Value

Type: List ShippingInfo
The removed shippings.
See Also

Reference

RemoveShippingInfoResult Class
Sitecore.Commerce.Services.Carts Namespace


SaveCartRequest Class

SaveCartRequest Class
The save cart request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsSaveCartRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SaveCartRequest : CartRequestWithCart
Public Class SaveCartRequest
    Inherits CartRequestWithCart
public ref class SaveCartRequest : public CartRequestWithCart
type SaveCartRequest =
    class
        inherit CartRequestWithCart
    end

The SaveCartRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SaveCartRequest | Initializes a new instance of the SaveCartRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


SaveCartRequest Constructor

SaveCartRequest Constructor
Initializes a new instance of the SaveCartRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SaveCartRequest(
    Cart cart
)
Public Sub New (
    cart As Cart
)
public:
SaveCartRequest(
    Cart^ cart
)
new :
        cart : Cart -> SaveCartRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
See Also

Reference

SaveCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


SaveCartRequest Methods

SaveCartRequest Methods

The SaveCartRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SaveCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


SaveCartRequest Properties

SaveCartRequest Properties

The SaveCartRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

SaveCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


UnlockCartRequest Class

UnlockCartRequest Class
Contains the cart to be unlocked.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsUnlockCartRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UnlockCartRequest : CartRequestWithCart
Public Class UnlockCartRequest
    Inherits CartRequestWithCart
public ref class UnlockCartRequest : public CartRequestWithCart
type UnlockCartRequest =
    class
        inherit CartRequestWithCart
    end

The UnlockCartRequest type exposes the following members.

Constructors
 | Name | Description
Public method | UnlockCartRequest | Initializes a new instance of the UnlockCartRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


UnlockCartRequest Constructor

UnlockCartRequest Constructor
Initializes a new instance of the UnlockCartRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UnlockCartRequest(
    Cart cart
)
Public Sub New (
    cart As Cart
)
public:
UnlockCartRequest(
    Cart^ cart
)
new :
        cart : Cart -> UnlockCartRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
See Also

Reference

UnlockCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


UnlockCartRequest Methods

UnlockCartRequest Methods

The UnlockCartRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnlockCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


UnlockCartRequest Properties

UnlockCartRequest Properties

The UnlockCartRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

UnlockCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


UpdateCartLinesRequest Class

UpdateCartLinesRequest Class
Contains the cart along with the cart lines to be updated.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsCartLinesRequest
Sitecore.Commerce.Services.CartsUpdateCartLinesRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateCartLinesRequest : CartLinesRequest
Public Class UpdateCartLinesRequest
    Inherits CartLinesRequest
public ref class UpdateCartLinesRequest : public CartLinesRequest
type UpdateCartLinesRequest =
    class
        inherit CartLinesRequest
    end

The UpdateCartLinesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateCartLinesRequest | Initializes a new instance of the UpdateCartLinesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Lines | Gets or sets the cart lines. (Inherited from CartLinesRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


UpdateCartLinesRequest Constructor

UpdateCartLinesRequest Constructor
Initializes a new instance of the UpdateCartLinesRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateCartLinesRequest(
    Cart cart,
    IEnumerable<CartLine> lines
)
Public Sub New (
    cart As Cart,
    lines As IEnumerable(Of CartLine)
)
public:
UpdateCartLinesRequest(
    Cart^ cart,
    IEnumerable<CartLine^>^ lines
)
new :
        cart : Cart *
        lines : IEnumerable<CartLine> -> UpdateCartLinesRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
lines
Type: System.Collections.GenericIEnumerable CartLine
The cart lines.
See Also

Reference

UpdateCartLinesRequest Class
Sitecore.Commerce.Services.Carts Namespace


UpdateCartLinesRequest Methods

UpdateCartLinesRequest Methods

The UpdateCartLinesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateCartLinesRequest Class
Sitecore.Commerce.Services.Carts Namespace


UpdateCartLinesRequest Properties

UpdateCartLinesRequest Properties

The UpdateCartLinesRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Lines | Gets or sets the cart lines. (Inherited from CartLinesRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

UpdateCartLinesRequest Class
Sitecore.Commerce.Services.Carts Namespace


UpdateCartRequest Class

UpdateCartRequest Class
Contains the cart and the data to be updated in CartBase.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsUpdateCartRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateCartRequest : CartRequestWithCart
Public Class UpdateCartRequest
    Inherits CartRequestWithCart
public ref class UpdateCartRequest : public CartRequestWithCart
type UpdateCartRequest =
    class
        inherit CartRequestWithCart
    end

The UpdateCartRequest type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateCartRequest | Initializes a new instance of the UpdateCartRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Changes | Gets or sets the changes.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


UpdateCartRequest Constructor

UpdateCartRequest Constructor
Initializes a new instance of the UpdateCartRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateCartRequest(
    Cart cart,
    CartBase changes
)
Public Sub New (
    cart As Cart,
    changes As CartBase
)
public:
UpdateCartRequest(
    Cart^ cart,
    CartBase^ changes
)
new :
        cart : Cart *
        changes : CartBase -> UpdateCartRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
changes
Type: Sitecore.Commerce.Entities.CartsCartBase
The changes.
See Also

Reference

UpdateCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


UpdateCartRequest Methods

UpdateCartRequest Methods

The UpdateCartRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


UpdateCartRequest Properties

UpdateCartRequest Properties

The UpdateCartRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Changes | Gets or sets the changes.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

UpdateCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


UpdateCartRequest.Changes Property

UpdateCartRequestChanges Property
Gets or sets the changes.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CartBase Changes { get; set; }
Public Property Changes As CartBase
    Get
    Set
public:
property CartBase^ Changes {
    CartBase^ get ();
    void set (CartBase^ value);
}
member Changes : CartBase with get, set

Property Value

Type: CartBase
See Also

Reference

UpdateCartRequest Class
Sitecore.Commerce.Services.Carts Namespace


UpdatePartiesRequest Class

UpdatePartiesRequest Class
Defines the UpdatePartiesRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CartsCartRequest
Sitecore.Commerce.Services.CartsCartRequestWithCart
Sitecore.Commerce.Services.CartsUpdatePartiesRequest

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdatePartiesRequest : CartRequestWithCart
Public Class UpdatePartiesRequest
    Inherits CartRequestWithCart
public ref class UpdatePartiesRequest : public CartRequestWithCart
type UpdatePartiesRequest =
    class
        inherit CartRequestWithCart
    end

The UpdatePartiesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | UpdatePartiesRequest | Initializes a new instance of the UpdatePartiesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


UpdatePartiesRequest Constructor

UpdatePartiesRequest Constructor
Initializes a new instance of the UpdatePartiesRequest class.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdatePartiesRequest(
    Cart cart,
    List<Party> parties
)
Public Sub New (
    cart As Cart,
    parties As List(Of Party)
)
public:
UpdatePartiesRequest(
    Cart^ cart,
    List<Party^>^ parties
)
new :
        cart : Cart *
        parties : List<Party> -> UpdatePartiesRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
parties
Type: System.Collections.GenericList Party
The parties.
See Also

Reference

UpdatePartiesRequest Class
Sitecore.Commerce.Services.Carts Namespace


UpdatePartiesRequest Methods

UpdatePartiesRequest Methods

The UpdatePartiesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdatePartiesRequest Class
Sitecore.Commerce.Services.Carts Namespace


UpdatePartiesRequest Properties

UpdatePartiesRequest Properties

The UpdatePartiesRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartRequestWithCart.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

UpdatePartiesRequest Class
Sitecore.Commerce.Services.Carts Namespace


UpdatePartiesRequest.Parties Property

UpdatePartiesRequestParties Property
Gets or sets the parties.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<Party> Parties { get; set; }
Public Property Parties As List(Of Party)
    Get
    Set
public:
property List<Party^>^ Parties {
    List<Party^>^ get ();
    void set (List<Party^>^ value);
}
member Parties : List<Party> with get, set

Property Value

Type: List Party
The parties.
See Also

Reference

UpdatePartiesRequest Class
Sitecore.Commerce.Services.Carts Namespace


UpdatePartiesResult Class

UpdatePartiesResult Class
Defines the UpdatePartiesResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CartsCartResult
Sitecore.Commerce.Services.CartsUpdatePartiesResult

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdatePartiesResult : CartResult
Public Class UpdatePartiesResult
    Inherits CartResult
public ref class UpdatePartiesResult : public CartResult
type UpdatePartiesResult =
    class
        inherit CartResult
    end

The UpdatePartiesResult type exposes the following members.

Constructors
 | Name | Description
Public method | UpdatePartiesResult | Initializes a new instance of the UpdatePartiesResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartResult.)
Public property | Parties | Gets or sets the parties that were updated.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Carts Namespace


UpdatePartiesResult Constructor

UpdatePartiesResult Constructor
Initializes a new instance of the UpdatePartiesResult class

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdatePartiesResult()
Public Sub New
public:
UpdatePartiesResult()
new : unit -> UpdatePartiesResult
See Also

Reference

UpdatePartiesResult Class
Sitecore.Commerce.Services.Carts Namespace


UpdatePartiesResult Methods

UpdatePartiesResult Methods

The UpdatePartiesResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdatePartiesResult Class
Sitecore.Commerce.Services.Carts Namespace


UpdatePartiesResult Properties

UpdatePartiesResult Properties

The UpdatePartiesResult type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart. (Inherited from CartResult.)
Public property | Parties | Gets or sets the parties that were updated.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

UpdatePartiesResult Class
Sitecore.Commerce.Services.Carts Namespace


UpdatePartiesResult.Parties Property

UpdatePartiesResultParties Property
Gets or sets the parties that were updated.

Namespace: Sitecore.Commerce.Services.Carts
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<Party> Parties { get; set; }
Public Property Parties As List(Of Party)
    Get
    Set
public:
property List<Party^>^ Parties {
    List<Party^>^ get ();
    void set (List<Party^>^ value);
}
member Parties : List<Party> with get, set

Property Value

Type: List Party
The parties.
See Also

Reference

UpdatePartiesResult Class
Sitecore.Commerce.Services.Carts Namespace


Sitecore.Commerce.Services.Carts.Generics Namespace

Sitecore.Commerce.Services.Carts.Generics Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Services.Carts.Generics"]

Classes
 | Class | Description
Public class | GenericCartServiceProviderExtensions | Extends the CartServiceProvider class with some generic methods. It allows you to specify the result type of a custom service call.


GenericCartServiceProviderExtensions Class

GenericCartServiceProviderExtensions Class
Extends the CartServiceProvider class with some generic methods. It allows you to specify the result type of a custom service call.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Services.Carts.GenericsGenericCartServiceProviderExtensions

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class GenericCartServiceProviderExtensions
<ExtensionAttribute>
Public NotInheritable Class GenericCartServiceProviderExtensions
[ExtensionAttribute]
public ref class GenericCartServiceProviderExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GenericCartServiceProviderExtensions =  class end

The GenericCartServiceProviderExtensions type exposes the following members.

Methods
Name Description
AddCartLinesTAddCartLinesRequest, TAddCartLinesResult
Adds the cart lines.
AddPartiesTAddPartiesRequest, TAddPartiesResult
Adds the parties.
AddPaymentInfoTAddPaymentInfoRequest, TAddPaymentInfoResult
Adds the payment information.
AddShippingInfoTAddShippingInfoRequest, TAddShippingInfoResult
Adds the shipping information.
CreateOrResumeCartTCreateOrResumeCartRequest, TCreateCartResult
Initiate the creation of a shopping cart and in the process:
  • Tries to load persisted, potentially abandoned cart, if present
  • Triggers an event in DMS
  • Enters the a user in the Engagement Automation (EA) plan with the ID of the shopping cart.
DeleteCartTDeleteCartRequest, TDeleteCartResult
Deletes a cart.
GetCartsTGetCartsRequest, TGetCartsResult
Gets the carts that match the specified criteria. It calls the GetCarts pipeline.
LoadCartTLoadCartRequest, TLoadCartResult
Gets the cart with given Cart ID. Calls the LoadCart pipeline. This method returns the full cart object with all cart lines associated.
LockCartTLockCartRequest, TLockCartResult
The lock cart.
RemoveCartLinesTRemoveCartLinesRequest, TRemoveCartLinesResult
Removes the cart lines.
RemovePartiesTRemovePartiesRequest, TRemovePartiesResult
Removes the parties.
RemovePaymentInfoTRemovePaymentInfoRequest, TRemovePaymentInfoResult
Removes the payment information.
RemoveShippingInfoTRemoveShippingInfoRequest, TRemoveShippingInfoResult
Removes the shipping information.
SaveCartTSaveCartRequest, TSaveCartResult
Saves the specified cart in the external system if supported and in EA state. Calls the pipeline "saveCart". Called from other service layer methods, but not called explicitly.
UnlockCartTUnlockCartRequest, TUnlockCartResult
Unlocks the cart.
UpdateCartTUpdateCartRequest, TUpdateCartResult
Updates a cart.
UpdateCartLinesTUpdateCartLinesRequest, TUpdateCartLinesResult
Updates the cart lines.
UpdatePartiesTUpdatePartiesRequest, TUpdatePartiesResult
Updates the parties.
Top
See Also

Reference

Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions Methods

GenericCartServiceProviderExtensions Methods

The GenericCartServiceProviderExtensions type exposes the following members.

Methods
Name Description
AddCartLinesTAddCartLinesRequest, TAddCartLinesResult
Adds the cart lines.
AddPartiesTAddPartiesRequest, TAddPartiesResult
Adds the parties.
AddPaymentInfoTAddPaymentInfoRequest, TAddPaymentInfoResult
Adds the payment information.
AddShippingInfoTAddShippingInfoRequest, TAddShippingInfoResult
Adds the shipping information.
CreateOrResumeCartTCreateOrResumeCartRequest, TCreateCartResult
Initiate the creation of a shopping cart and in the process:
  • Tries to load persisted, potentially abandoned cart, if present
  • Triggers an event in DMS
  • Enters the a user in the Engagement Automation (EA) plan with the ID of the shopping cart.
DeleteCartTDeleteCartRequest, TDeleteCartResult
Deletes a cart.
GetCartsTGetCartsRequest, TGetCartsResult
Gets the carts that match the specified criteria. It calls the GetCarts pipeline.
LoadCartTLoadCartRequest, TLoadCartResult
Gets the cart with given Cart ID. Calls the LoadCart pipeline. This method returns the full cart object with all cart lines associated.
LockCartTLockCartRequest, TLockCartResult
The lock cart.
RemoveCartLinesTRemoveCartLinesRequest, TRemoveCartLinesResult
Removes the cart lines.
RemovePartiesTRemovePartiesRequest, TRemovePartiesResult
Removes the parties.
RemovePaymentInfoTRemovePaymentInfoRequest, TRemovePaymentInfoResult
Removes the payment information.
RemoveShippingInfoTRemoveShippingInfoRequest, TRemoveShippingInfoResult
Removes the shipping information.
SaveCartTSaveCartRequest, TSaveCartResult
Saves the specified cart in the external system if supported and in EA state. Calls the pipeline "saveCart". Called from other service layer methods, but not called explicitly.
UnlockCartTUnlockCartRequest, TUnlockCartResult
Unlocks the cart.
UpdateCartTUpdateCartRequest, TUpdateCartResult
Updates a cart.
UpdateCartLinesTUpdateCartLinesRequest, TUpdateCartLinesResult
Updates the cart lines.
UpdatePartiesTUpdatePartiesRequest, TUpdatePartiesResult
Updates the parties.
Top
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.AddCartLines(TAddCartLinesRequest, TAddCartLinesResult) Method

GenericCartServiceProviderExtensionsAddCartLinesTAddCartLinesRequest, TAddCartLinesResult Method
Adds the cart lines.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TAddCartLinesResult AddCartLines<TAddCartLinesRequest, TAddCartLinesResult>(
    this CartServiceProvider cartProvider,
    TAddCartLinesRequest request
)
where TAddCartLinesRequest : AddCartLinesRequest
where TAddCartLinesResult : new(), CartResult

<ExtensionAttribute>
Public Shared Function AddCartLines(Of TAddCartLinesRequest As AddCartLinesRequest, TAddCartLinesResult As {New, CartResult}) (
    cartProvider As CartServiceProvider,
    request As TAddCartLinesRequest
) As TAddCartLinesResult
public:
[ExtensionAttribute]
generic<typename TAddCartLinesRequest, typename TAddCartLinesResult>
where TAddCartLinesRequest : AddCartLinesRequest
where TAddCartLinesResult : gcnew(), CartResult
static TAddCartLinesResult AddCartLines(
    CartServiceProvider^ cartProvider,
    TAddCartLinesRequest request
)
static member AddCartLines :
        cartProvider : CartServiceProvider *
        request : 'TAddCartLinesRequest -> 'TAddCartLinesResult  when 'TAddCartLinesRequest : AddCartLinesRequest when 'TAddCartLinesResult : new() and CartResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
A CartServiceProviderobject.
request
Type: TAddCartLinesRequest
A AddCartLinesRequestobject.

Type Parameters

TAddCartLinesRequest
The extended type of the AddCartLinesRequestclass.
TAddCartLinesResult
The extended type of the CartResultclass.

Return Value

Type: TAddCartLinesResult
An extended version of the CartResultobject.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.AddParties(TAddPartiesRequest, TAddPartiesResult) Method

GenericCartServiceProviderExtensionsAddPartiesTAddPartiesRequest, TAddPartiesResult Method
Adds the parties.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TAddPartiesResult AddParties<TAddPartiesRequest, TAddPartiesResult>(
    this CartServiceProvider cartProvider,
    TAddPartiesRequest request
)
where TAddPartiesRequest : AddPartiesRequest
where TAddPartiesResult : new(), CartResult

<ExtensionAttribute>
Public Shared Function AddParties(Of TAddPartiesRequest As AddPartiesRequest, TAddPartiesResult As {New, CartResult}) (
    cartProvider As CartServiceProvider,
    request As TAddPartiesRequest
) As TAddPartiesResult
public:
[ExtensionAttribute]
generic<typename TAddPartiesRequest, typename TAddPartiesResult>
where TAddPartiesRequest : AddPartiesRequest
where TAddPartiesResult : gcnew(), CartResult
static TAddPartiesResult AddParties(
    CartServiceProvider^ cartProvider,
    TAddPartiesRequest request
)
static member AddParties :
        cartProvider : CartServiceProvider *
        request : 'TAddPartiesRequest -> 'TAddPartiesResult  when 'TAddPartiesRequest : AddPartiesRequest when 'TAddPartiesResult : new() and CartResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
The cart provider.
request
Type: TAddPartiesRequest
The request.

Type Parameters

TAddPartiesRequest
The extended type of the AddPartiesRequestclass.
TAddPartiesResult
The type of the add parties result.

Return Value

Type: TAddPartiesResult
An instance of the AddPartiesResultobject.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.AddPaymentInfo(TAddPaymentInfoRequest, TAddPaymentInfoResult) Method

GenericCartServiceProviderExtensionsAddPaymentInfoTAddPaymentInfoRequest, TAddPaymentInfoResult Method
Adds the payment information.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TAddPaymentInfoResult AddPaymentInfo<TAddPaymentInfoRequest, TAddPaymentInfoResult>(
    this CartServiceProvider cartProvider,
    TAddPaymentInfoRequest request
)
where TAddPaymentInfoRequest : AddPaymentInfoRequest
where TAddPaymentInfoResult : new(), AddPaymentInfoResult

<ExtensionAttribute>
Public Shared Function AddPaymentInfo(Of TAddPaymentInfoRequest As AddPaymentInfoRequest, TAddPaymentInfoResult As {New, AddPaymentInfoResult}) (
    cartProvider As CartServiceProvider,
    request As TAddPaymentInfoRequest
) As TAddPaymentInfoResult
public:
[ExtensionAttribute]
generic<typename TAddPaymentInfoRequest, typename TAddPaymentInfoResult>
where TAddPaymentInfoRequest : AddPaymentInfoRequest
where TAddPaymentInfoResult : gcnew(), AddPaymentInfoResult
static TAddPaymentInfoResult AddPaymentInfo(
    CartServiceProvider^ cartProvider,
    TAddPaymentInfoRequest request
)
static member AddPaymentInfo :
        cartProvider : CartServiceProvider *
        request : 'TAddPaymentInfoRequest -> 'TAddPaymentInfoResult  when 'TAddPaymentInfoRequest : AddPaymentInfoRequest when 'TAddPaymentInfoResult : new() and AddPaymentInfoResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
The cart provider.
request
Type: TAddPaymentInfoRequest
The request.

Type Parameters

TAddPaymentInfoRequest
The type of the add payment information request.
TAddPaymentInfoResult
The type of the add payment information result.

Return Value

Type: TAddPaymentInfoResult

[Missing <returns> documentation for "M:Sitecore.Commerce.Services.Carts.Generics.GenericCartServiceProviderExtensions.AddPaymentInfo``2(Sitecore.Commerce.Services.Carts.CartServiceProvider,``0)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.AddShippingInfo(TAddShippingInfoRequest, TAddShippingInfoResult) Method

GenericCartServiceProviderExtensionsAddShippingInfoTAddShippingInfoRequest, TAddShippingInfoResult Method
Adds the shipping information.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TAddShippingInfoResult AddShippingInfo<TAddShippingInfoRequest, TAddShippingInfoResult>(
    this CartServiceProvider cartProvider,
    TAddShippingInfoRequest request
)
where TAddShippingInfoRequest : AddShippingInfoRequest
where TAddShippingInfoResult : new(), AddShippingInfoResult

<ExtensionAttribute>
Public Shared Function AddShippingInfo(Of TAddShippingInfoRequest As AddShippingInfoRequest, TAddShippingInfoResult As {New, AddShippingInfoResult}) (
    cartProvider As CartServiceProvider,
    request As TAddShippingInfoRequest
) As TAddShippingInfoResult
public:
[ExtensionAttribute]
generic<typename TAddShippingInfoRequest, typename TAddShippingInfoResult>
where TAddShippingInfoRequest : AddShippingInfoRequest
where TAddShippingInfoResult : gcnew(), AddShippingInfoResult
static TAddShippingInfoResult AddShippingInfo(
    CartServiceProvider^ cartProvider,
    TAddShippingInfoRequest request
)
static member AddShippingInfo :
        cartProvider : CartServiceProvider *
        request : 'TAddShippingInfoRequest -> 'TAddShippingInfoResult  when 'TAddShippingInfoRequest : AddShippingInfoRequest when 'TAddShippingInfoResult : new() and AddShippingInfoResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
The cart provider.
request
Type: TAddShippingInfoRequest
The request.

Type Parameters

TAddShippingInfoRequest
The type of the add shipping information request.
TAddShippingInfoResult
The type of the add shipping information result.

Return Value

Type: TAddShippingInfoResult

[Missing <returns> documentation for "M:Sitecore.Commerce.Services.Carts.Generics.GenericCartServiceProviderExtensions.AddShippingInfo``2(Sitecore.Commerce.Services.Carts.CartServiceProvider,``0)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.CreateOrResumeCart(TCreateOrResumeCartRequest, TCreateCartResult) Method

GenericCartServiceProviderExtensionsCreateOrResumeCartTCreateOrResumeCartRequest, TCreateCartResult Method
Initiate the creation of a shopping cart and in the process:
  • Tries to load persisted, potentially abandoned cart, if present
  • Triggers an event in DMS
  • Enters the a user in the Engagement Automation (EA) plan with the ID of the shopping cart.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TCreateCartResult CreateOrResumeCart<TCreateOrResumeCartRequest, TCreateCartResult>(
    this CartServiceProvider cartProvider,
    TCreateOrResumeCartRequest request
)
where TCreateOrResumeCartRequest : CreateOrResumeCartRequest
where TCreateCartResult : new(), CartResult

<ExtensionAttribute>
Public Shared Function CreateOrResumeCart(Of TCreateOrResumeCartRequest As CreateOrResumeCartRequest, TCreateCartResult As {New, CartResult}) (
    cartProvider As CartServiceProvider,
    request As TCreateOrResumeCartRequest
) As TCreateCartResult
public:
[ExtensionAttribute]
generic<typename TCreateOrResumeCartRequest, typename TCreateCartResult>
where TCreateOrResumeCartRequest : CreateOrResumeCartRequest
where TCreateCartResult : gcnew(), CartResult
static TCreateCartResult CreateOrResumeCart(
    CartServiceProvider^ cartProvider,
    TCreateOrResumeCartRequest request
)
static member CreateOrResumeCart :
        cartProvider : CartServiceProvider *
        request : 'TCreateOrResumeCartRequest -> 'TCreateCartResult  when 'TCreateOrResumeCartRequest : CreateOrResumeCartRequest when 'TCreateCartResult : new() and CartResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
A CartServiceProviderobject.
request
Type: TCreateOrResumeCartRequest
A CreateOrResumeCartRequestobject.

Type Parameters

TCreateOrResumeCartRequest
The extended type of the CreateOrResumeCartRequestclass.
TCreateCartResult
The extended type of the CartResultobject.

Return Value

Type: TCreateCartResult
The extended CartResultobject.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.DeleteCart(TDeleteCartRequest, TDeleteCartResult) Method

GenericCartServiceProviderExtensionsDeleteCartTDeleteCartRequest, TDeleteCartResult Method
Deletes a cart.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TDeleteCartResult DeleteCart<TDeleteCartRequest, TDeleteCartResult>(
    this CartServiceProvider cartProvider,
    TDeleteCartRequest request
)
where TDeleteCartRequest : DeleteCartRequest
where TDeleteCartResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function DeleteCart(Of TDeleteCartRequest As DeleteCartRequest, TDeleteCartResult As {New, ServiceProviderResult}) (
    cartProvider As CartServiceProvider,
    request As TDeleteCartRequest
) As TDeleteCartResult
public:
[ExtensionAttribute]
generic<typename TDeleteCartRequest, typename TDeleteCartResult>
where TDeleteCartRequest : DeleteCartRequest
where TDeleteCartResult : gcnew(), ServiceProviderResult
static TDeleteCartResult DeleteCart(
    CartServiceProvider^ cartProvider,
    TDeleteCartRequest request
)
static member DeleteCart :
        cartProvider : CartServiceProvider *
        request : 'TDeleteCartRequest -> 'TDeleteCartResult  when 'TDeleteCartRequest : DeleteCartRequest when 'TDeleteCartResult : new() and ServiceProviderResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
A CartServiceProviderobject.
request
Type: TDeleteCartRequest
A DeleteCartRequestobject.

Type Parameters

TDeleteCartRequest
The extended type of the DeleteCartRequestclass.
TDeleteCartResult
The extended type of the ServiceProviderResultclass.

Return Value

Type: TDeleteCartResult
An extended version of the ServiceProviderResultobject.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.GetCarts(TGetCartsRequest, TGetCartsResult) Method

GenericCartServiceProviderExtensionsGetCartsTGetCartsRequest, TGetCartsResult Method
Gets the carts that match the specified criteria. It calls the GetCarts pipeline.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetCartsResult GetCarts<TGetCartsRequest, TGetCartsResult>(
    this CartServiceProvider cartProvider,
    TGetCartsRequest request
)
where TGetCartsRequest : GetCartsRequest
where TGetCartsResult : new(), GetCartsResult

<ExtensionAttribute>
Public Shared Function GetCarts(Of TGetCartsRequest As GetCartsRequest, TGetCartsResult As {New, GetCartsResult}) (
    cartProvider As CartServiceProvider,
    request As TGetCartsRequest
) As TGetCartsResult
public:
[ExtensionAttribute]
generic<typename TGetCartsRequest, typename TGetCartsResult>
where TGetCartsRequest : GetCartsRequest
where TGetCartsResult : gcnew(), GetCartsResult
static TGetCartsResult GetCarts(
    CartServiceProvider^ cartProvider,
    TGetCartsRequest request
)
static member GetCarts :
        cartProvider : CartServiceProvider *
        request : 'TGetCartsRequest -> 'TGetCartsResult  when 'TGetCartsRequest : GetCartsRequest when 'TGetCartsResult : new() and GetCartsResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
A CartServiceProvider object.
request
Type: TGetCartsRequest
The GetCartsRequest Contains the search criteria.

Type Parameters

TGetCartsRequest
The extended type of the GetCartsRequestclass.
TGetCartsResult
The extended type of the GetCartsResultclass.

Return Value

Type: TGetCartsResult
The extended GetCartsResult.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.LoadCart(TLoadCartRequest, TLoadCartResult) Method

GenericCartServiceProviderExtensionsLoadCartTLoadCartRequest, TLoadCartResult Method
Gets the cart with given Cart ID. Calls the LoadCart pipeline. This method returns the full cart object with all cart lines associated.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TLoadCartResult LoadCart<TLoadCartRequest, TLoadCartResult>(
    this CartServiceProvider cartProvider,
    TLoadCartRequest request
)
where TLoadCartRequest : LoadCartRequest
where TLoadCartResult : new(), CartResult

<ExtensionAttribute>
Public Shared Function LoadCart(Of TLoadCartRequest As LoadCartRequest, TLoadCartResult As {New, CartResult}) (
    cartProvider As CartServiceProvider,
    request As TLoadCartRequest
) As TLoadCartResult
public:
[ExtensionAttribute]
generic<typename TLoadCartRequest, typename TLoadCartResult>
where TLoadCartRequest : LoadCartRequest
where TLoadCartResult : gcnew(), CartResult
static TLoadCartResult LoadCart(
    CartServiceProvider^ cartProvider,
    TLoadCartRequest request
)
static member LoadCart :
        cartProvider : CartServiceProvider *
        request : 'TLoadCartRequest -> 'TLoadCartResult  when 'TLoadCartRequest : LoadCartRequest when 'TLoadCartResult : new() and CartResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
A CartServiceProviderobject.
request
Type: TLoadCartRequest
A LoadCartRequestobject.

Type Parameters

TLoadCartRequest
The extended type of the LoadCartRequestclass.
TLoadCartResult
The extended type of the CartResult.

Return Value

Type: TLoadCartResult
The extended CartResultobject.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.LockCart(TLockCartRequest, TLockCartResult) Method

GenericCartServiceProviderExtensionsLockCartTLockCartRequest, TLockCartResult Method
The lock cart.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TLockCartResult LockCart<TLockCartRequest, TLockCartResult>(
    this CartServiceProvider cartProvider,
    TLockCartRequest request
)
where TLockCartRequest : LockCartRequest
where TLockCartResult : new(), CartResult

<ExtensionAttribute>
Public Shared Function LockCart(Of TLockCartRequest As LockCartRequest, TLockCartResult As {New, CartResult}) (
    cartProvider As CartServiceProvider,
    request As TLockCartRequest
) As TLockCartResult
public:
[ExtensionAttribute]
generic<typename TLockCartRequest, typename TLockCartResult>
where TLockCartRequest : LockCartRequest
where TLockCartResult : gcnew(), CartResult
static TLockCartResult LockCart(
    CartServiceProvider^ cartProvider,
    TLockCartRequest request
)
static member LockCart :
        cartProvider : CartServiceProvider *
        request : 'TLockCartRequest -> 'TLockCartResult  when 'TLockCartRequest : LockCartRequest when 'TLockCartResult : new() and CartResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
A CartServiceProviderobject.
request
Type: TLockCartRequest
A LockCartRequestobject.

Type Parameters

TLockCartRequest
The extended type of the LockCartRequestclass.
TLockCartResult
The extended type of the CartResultclass.

Return Value

Type: TLockCartResult
An extended version of the CartResultobject.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.RemoveCartLines(TRemoveCartLinesRequest, TRemoveCartLinesResult) Method

GenericCartServiceProviderExtensionsRemoveCartLinesTRemoveCartLinesRequest, TRemoveCartLinesResult Method
Removes the cart lines.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TRemoveCartLinesResult RemoveCartLines<TRemoveCartLinesRequest, TRemoveCartLinesResult>(
    this CartServiceProvider cartProvider,
    TRemoveCartLinesRequest request
)
where TRemoveCartLinesRequest : RemoveCartLinesRequest
where TRemoveCartLinesResult : new(), CartResult

<ExtensionAttribute>
Public Shared Function RemoveCartLines(Of TRemoveCartLinesRequest As RemoveCartLinesRequest, TRemoveCartLinesResult As {New, CartResult}) (
    cartProvider As CartServiceProvider,
    request As TRemoveCartLinesRequest
) As TRemoveCartLinesResult
public:
[ExtensionAttribute]
generic<typename TRemoveCartLinesRequest, typename TRemoveCartLinesResult>
where TRemoveCartLinesRequest : RemoveCartLinesRequest
where TRemoveCartLinesResult : gcnew(), CartResult
static TRemoveCartLinesResult RemoveCartLines(
    CartServiceProvider^ cartProvider,
    TRemoveCartLinesRequest request
)
static member RemoveCartLines :
        cartProvider : CartServiceProvider *
        request : 'TRemoveCartLinesRequest -> 'TRemoveCartLinesResult  when 'TRemoveCartLinesRequest : RemoveCartLinesRequest when 'TRemoveCartLinesResult : new() and CartResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
A CartServiceProviderobject.
request
Type: TRemoveCartLinesRequest
A RemoveCartLinesRequestobject.

Type Parameters

TRemoveCartLinesRequest
The extended type of the RemoveCartLinesRequestclass.
TRemoveCartLinesResult
The extended type of the CartResult class.

Return Value

Type: TRemoveCartLinesResult
An extended version of the CartResultobject.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.RemoveParties(TRemovePartiesRequest, TRemovePartiesResult) Method

GenericCartServiceProviderExtensionsRemovePartiesTRemovePartiesRequest, TRemovePartiesResult Method
Removes the parties.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TRemovePartiesResult RemoveParties<TRemovePartiesRequest, TRemovePartiesResult>(
    this CartServiceProvider cartProvider,
    TRemovePartiesRequest request
)
where TRemovePartiesRequest : RemovePartiesRequest
where TRemovePartiesResult : new(), CartResult

<ExtensionAttribute>
Public Shared Function RemoveParties(Of TRemovePartiesRequest As RemovePartiesRequest, TRemovePartiesResult As {New, CartResult}) (
    cartProvider As CartServiceProvider,
    request As TRemovePartiesRequest
) As TRemovePartiesResult
public:
[ExtensionAttribute]
generic<typename TRemovePartiesRequest, typename TRemovePartiesResult>
where TRemovePartiesRequest : RemovePartiesRequest
where TRemovePartiesResult : gcnew(), CartResult
static TRemovePartiesResult RemoveParties(
    CartServiceProvider^ cartProvider,
    TRemovePartiesRequest request
)
static member RemoveParties :
        cartProvider : CartServiceProvider *
        request : 'TRemovePartiesRequest -> 'TRemovePartiesResult  when 'TRemovePartiesRequest : RemovePartiesRequest when 'TRemovePartiesResult : new() and CartResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
The cart provider.
request
Type: TRemovePartiesRequest
The request.

Type Parameters

TRemovePartiesRequest
The extended type of the RemovePartiesRequestclass.
TRemovePartiesResult
The type of the remove parties result.

Return Value

Type: TRemovePartiesResult
An instance of the RemovePartiesResultobject.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.RemovePaymentInfo(TRemovePaymentInfoRequest, TRemovePaymentInfoResult) Method

GenericCartServiceProviderExtensionsRemovePaymentInfoTRemovePaymentInfoRequest, TRemovePaymentInfoResult Method
Removes the payment information.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TRemovePaymentInfoResult RemovePaymentInfo<TRemovePaymentInfoRequest, TRemovePaymentInfoResult>(
    this CartServiceProvider cartProvider,
    TRemovePaymentInfoRequest request
)
where TRemovePaymentInfoRequest : RemovePaymentInfoRequest
where TRemovePaymentInfoResult : new(), RemovePaymentInfoResult

<ExtensionAttribute>
Public Shared Function RemovePaymentInfo(Of TRemovePaymentInfoRequest As RemovePaymentInfoRequest, TRemovePaymentInfoResult As {New, RemovePaymentInfoResult}) (
    cartProvider As CartServiceProvider,
    request As TRemovePaymentInfoRequest
) As TRemovePaymentInfoResult
public:
[ExtensionAttribute]
generic<typename TRemovePaymentInfoRequest, typename TRemovePaymentInfoResult>
where TRemovePaymentInfoRequest : RemovePaymentInfoRequest
where TRemovePaymentInfoResult : gcnew(), RemovePaymentInfoResult
static TRemovePaymentInfoResult RemovePaymentInfo(
    CartServiceProvider^ cartProvider,
    TRemovePaymentInfoRequest request
)
static member RemovePaymentInfo :
        cartProvider : CartServiceProvider *
        request : 'TRemovePaymentInfoRequest -> 'TRemovePaymentInfoResult  when 'TRemovePaymentInfoRequest : RemovePaymentInfoRequest when 'TRemovePaymentInfoResult : new() and RemovePaymentInfoResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
The cart provider.
request
Type: TRemovePaymentInfoRequest
The request.

Type Parameters

TRemovePaymentInfoRequest
The type of the remove payment information request.
TRemovePaymentInfoResult
The type of the remove payment information result.

Return Value

Type: TRemovePaymentInfoResult

[Missing <returns> documentation for "M:Sitecore.Commerce.Services.Carts.Generics.GenericCartServiceProviderExtensions.RemovePaymentInfo``2(Sitecore.Commerce.Services.Carts.CartServiceProvider,``0)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.RemoveShippingInfo(TRemoveShippingInfoRequest, TRemoveShippingInfoResult) Method

GenericCartServiceProviderExtensionsRemoveShippingInfoTRemoveShippingInfoRequest, TRemoveShippingInfoResult Method
Removes the shipping information.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TRemoveShippingInfoResult RemoveShippingInfo<TRemoveShippingInfoRequest, TRemoveShippingInfoResult>(
    this CartServiceProvider cartProvider,
    TRemoveShippingInfoRequest request
)
where TRemoveShippingInfoRequest : RemoveShippingInfoRequest
where TRemoveShippingInfoResult : new(), RemoveShippingInfoResult

<ExtensionAttribute>
Public Shared Function RemoveShippingInfo(Of TRemoveShippingInfoRequest As RemoveShippingInfoRequest, TRemoveShippingInfoResult As {New, RemoveShippingInfoResult}) (
    cartProvider As CartServiceProvider,
    request As TRemoveShippingInfoRequest
) As TRemoveShippingInfoResult
public:
[ExtensionAttribute]
generic<typename TRemoveShippingInfoRequest, typename TRemoveShippingInfoResult>
where TRemoveShippingInfoRequest : RemoveShippingInfoRequest
where TRemoveShippingInfoResult : gcnew(), RemoveShippingInfoResult
static TRemoveShippingInfoResult RemoveShippingInfo(
    CartServiceProvider^ cartProvider,
    TRemoveShippingInfoRequest request
)
static member RemoveShippingInfo :
        cartProvider : CartServiceProvider *
        request : 'TRemoveShippingInfoRequest -> 'TRemoveShippingInfoResult  when 'TRemoveShippingInfoRequest : RemoveShippingInfoRequest when 'TRemoveShippingInfoResult : new() and RemoveShippingInfoResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
The cart provider.
request
Type: TRemoveShippingInfoRequest
The request.

Type Parameters

TRemoveShippingInfoRequest
The type of the remove shipping information request.
TRemoveShippingInfoResult
The type of the remove shipping information result.

Return Value

Type: TRemoveShippingInfoResult

[Missing <returns> documentation for "M:Sitecore.Commerce.Services.Carts.Generics.GenericCartServiceProviderExtensions.RemoveShippingInfo``2(Sitecore.Commerce.Services.Carts.CartServiceProvider,``0)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.SaveCart(TSaveCartRequest, TSaveCartResult) Method

GenericCartServiceProviderExtensionsSaveCartTSaveCartRequest, TSaveCartResult Method
Saves the specified cart in the external system if supported and in EA state. Calls the pipeline "saveCart". Called from other service layer methods, but not called explicitly.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TSaveCartResult SaveCart<TSaveCartRequest, TSaveCartResult>(
    this CartServiceProvider cartProvider,
    TSaveCartRequest request
)
where TSaveCartRequest : SaveCartRequest
where TSaveCartResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SaveCart(Of TSaveCartRequest As SaveCartRequest, TSaveCartResult As {New, ServiceProviderResult}) (
    cartProvider As CartServiceProvider,
    request As TSaveCartRequest
) As TSaveCartResult
public:
[ExtensionAttribute]
generic<typename TSaveCartRequest, typename TSaveCartResult>
where TSaveCartRequest : SaveCartRequest
where TSaveCartResult : gcnew(), ServiceProviderResult
static TSaveCartResult SaveCart(
    CartServiceProvider^ cartProvider,
    TSaveCartRequest request
)
static member SaveCart :
        cartProvider : CartServiceProvider *
        request : 'TSaveCartRequest -> 'TSaveCartResult  when 'TSaveCartRequest : SaveCartRequest when 'TSaveCartResult : new() and ServiceProviderResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
The CartServiceProviderobject.
request
Type: TSaveCartRequest
The SaveCartRequestobject.

Type Parameters

TSaveCartRequest
The extended type of the SaveCartRequestclass.
TSaveCartResult
The extended type of the ServiceProviderResultobject.

Return Value

Type: TSaveCartResult
The extended ServiceProviderResultobject.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.UnlockCart(TUnlockCartRequest, TUnlockCartResult) Method

GenericCartServiceProviderExtensionsUnlockCartTUnlockCartRequest, TUnlockCartResult Method
Unlocks the cart.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TUnlockCartResult UnlockCart<TUnlockCartRequest, TUnlockCartResult>(
    this CartServiceProvider cartProvider,
    TUnlockCartRequest request
)
where TUnlockCartRequest : UnlockCartRequest
where TUnlockCartResult : new(), CartResult

<ExtensionAttribute>
Public Shared Function UnlockCart(Of TUnlockCartRequest As UnlockCartRequest, TUnlockCartResult As {New, CartResult}) (
    cartProvider As CartServiceProvider,
    request As TUnlockCartRequest
) As TUnlockCartResult
public:
[ExtensionAttribute]
generic<typename TUnlockCartRequest, typename TUnlockCartResult>
where TUnlockCartRequest : UnlockCartRequest
where TUnlockCartResult : gcnew(), CartResult
static TUnlockCartResult UnlockCart(
    CartServiceProvider^ cartProvider,
    TUnlockCartRequest request
)
static member UnlockCart :
        cartProvider : CartServiceProvider *
        request : 'TUnlockCartRequest -> 'TUnlockCartResult  when 'TUnlockCartRequest : UnlockCartRequest when 'TUnlockCartResult : new() and CartResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
A CartServiceProviderobject.
request
Type: TUnlockCartRequest
A UnlockCartRequestobject.

Type Parameters

TUnlockCartRequest
The extended type of the UnlockCartRequestclass.
TUnlockCartResult
The extended type of the CartResultclass.

Return Value

Type: TUnlockCartResult
An extended version of the CartResultobject.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.UpdateCart(TUpdateCartRequest, TUpdateCartResult) Method

GenericCartServiceProviderExtensionsUpdateCartTUpdateCartRequest, TUpdateCartResult Method
Updates a cart.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TUpdateCartResult UpdateCart<TUpdateCartRequest, TUpdateCartResult>(
    this CartServiceProvider cartProvider,
    TUpdateCartRequest request
)
where TUpdateCartRequest : UpdateCartRequest
where TUpdateCartResult : new(), CartResult

<ExtensionAttribute>
Public Shared Function UpdateCart(Of TUpdateCartRequest As UpdateCartRequest, TUpdateCartResult As {New, CartResult}) (
    cartProvider As CartServiceProvider,
    request As TUpdateCartRequest
) As TUpdateCartResult
public:
[ExtensionAttribute]
generic<typename TUpdateCartRequest, typename TUpdateCartResult>
where TUpdateCartRequest : UpdateCartRequest
where TUpdateCartResult : gcnew(), CartResult
static TUpdateCartResult UpdateCart(
    CartServiceProvider^ cartProvider,
    TUpdateCartRequest request
)
static member UpdateCart :
        cartProvider : CartServiceProvider *
        request : 'TUpdateCartRequest -> 'TUpdateCartResult  when 'TUpdateCartRequest : UpdateCartRequest when 'TUpdateCartResult : new() and CartResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
A CartServiceProviderobject.
request
Type: TUpdateCartRequest
A DeleteCartRequestobject.

Type Parameters

TUpdateCartRequest
The extended type of the UpdateCartRequestclass.
TUpdateCartResult
The extended type of the CartResultclass.

Return Value

Type: TUpdateCartResult
An extended version of the CartResultobject.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.UpdateCartLines(TUpdateCartLinesRequest, TUpdateCartLinesResult) Method

GenericCartServiceProviderExtensionsUpdateCartLinesTUpdateCartLinesRequest, TUpdateCartLinesResult Method
Updates the cart lines.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TUpdateCartLinesResult UpdateCartLines<TUpdateCartLinesRequest, TUpdateCartLinesResult>(
    this CartServiceProvider cartProvider,
    TUpdateCartLinesRequest request
)
where TUpdateCartLinesRequest : UpdateCartLinesRequest
where TUpdateCartLinesResult : new(), CartResult

<ExtensionAttribute>
Public Shared Function UpdateCartLines(Of TUpdateCartLinesRequest As UpdateCartLinesRequest, TUpdateCartLinesResult As {New, CartResult}) (
    cartProvider As CartServiceProvider,
    request As TUpdateCartLinesRequest
) As TUpdateCartLinesResult
public:
[ExtensionAttribute]
generic<typename TUpdateCartLinesRequest, typename TUpdateCartLinesResult>
where TUpdateCartLinesRequest : UpdateCartLinesRequest
where TUpdateCartLinesResult : gcnew(), CartResult
static TUpdateCartLinesResult UpdateCartLines(
    CartServiceProvider^ cartProvider,
    TUpdateCartLinesRequest request
)
static member UpdateCartLines :
        cartProvider : CartServiceProvider *
        request : 'TUpdateCartLinesRequest -> 'TUpdateCartLinesResult  when 'TUpdateCartLinesRequest : UpdateCartLinesRequest when 'TUpdateCartLinesResult : new() and CartResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
A CartServiceProviderobject.
request
Type: TUpdateCartLinesRequest
A UpdateCartLinesRequestobject.

Type Parameters

TUpdateCartLinesRequest

[Missing <typeparam name="TUpdateCartLinesRequest"/> documentation for "M:Sitecore.Commerce.Services.Carts.Generics.GenericCartServiceProviderExtensions.UpdateCartLines``2(Sitecore.Commerce.Services.Carts.CartServiceProvider,``0)"]

TUpdateCartLinesResult
The extended type of the CartResultclass.

Return Value

Type: TUpdateCartLinesResult
An extended version of the CartResultobject.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


GenericCartServiceProviderExtensions.UpdateParties(TUpdatePartiesRequest, TUpdatePartiesResult) Method

GenericCartServiceProviderExtensionsUpdatePartiesTUpdatePartiesRequest, TUpdatePartiesResult Method
Updates the parties.

Namespace: Sitecore.Commerce.Services.Carts.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TUpdatePartiesResult UpdateParties<TUpdatePartiesRequest, TUpdatePartiesResult>(
    this CartServiceProvider cartProvider,
    TUpdatePartiesRequest request
)
where TUpdatePartiesRequest : UpdatePartiesRequest
where TUpdatePartiesResult : new(), CartResult

<ExtensionAttribute>
Public Shared Function UpdateParties(Of TUpdatePartiesRequest As UpdatePartiesRequest, TUpdatePartiesResult As {New, CartResult}) (
    cartProvider As CartServiceProvider,
    request As TUpdatePartiesRequest
) As TUpdatePartiesResult
public:
[ExtensionAttribute]
generic<typename TUpdatePartiesRequest, typename TUpdatePartiesResult>
where TUpdatePartiesRequest : UpdatePartiesRequest
where TUpdatePartiesResult : gcnew(), CartResult
static TUpdatePartiesResult UpdateParties(
    CartServiceProvider^ cartProvider,
    TUpdatePartiesRequest request
)
static member UpdateParties :
        cartProvider : CartServiceProvider *
        request : 'TUpdatePartiesRequest -> 'TUpdatePartiesResult  when 'TUpdatePartiesRequest : UpdatePartiesRequest when 'TUpdatePartiesResult : new() and CartResult

Parameters

cartProvider
Type: Sitecore.Commerce.Services.CartsCartServiceProvider
The cart provider.
request
Type: TUpdatePartiesRequest
The request.

Type Parameters

TUpdatePartiesRequest
The extended type of the UpdatePartiesRequestclass.
TUpdatePartiesResult
The type of the update parties result.

Return Value

Type: TUpdatePartiesResult
An instance of the UpdatePartiesResultobject.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CartServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCartServiceProviderExtensions Class
Sitecore.Commerce.Services.Carts.Generics Namespace


Sitecore.Commerce.Services.Customers Namespace

Sitecore.Commerce.Services.Customers Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Services.Customers"]

Classes
 | Class | Description
Public class | AddCustomerPartiesRequest | Defines the AddCustomerPartiesRequest class.
Public class | AddCustomersRequest | Defines the AddUsersRequest class.
Public class | AddCustomersResult | Defines the AddCustomersResult result class.
Public class | AddPartiesRequest | Defines the AddPartiesRequest class.
Public class | AddPartiesResult | Defines the AddPartiesResult result class.
Public class | AddUsersRequest | Defines the AddUsersRequest class.
Public class | AddUsersResult | Defines the AddUsersResult result class.
Public class | CreateCustomerRequest | The create customer request.
Public class | CreateCustomerResult | The create customer result.
Public class | CreateUserRequest | The create user request.
Public class | CreateUserResult | The create user result.
Public class | CustomerPartiesResult | Defines the CustomerPartiesResult class.
Public class | CustomerRequest | Class used as the base of all customer requests.
Public class | CustomerRequestWithCustomer | The base reuqets of all Customer requests that require a Customer model to be passed in.
Public class | CustomerResult | Defines the base class of all customer results.
Public class | CustomerResultWithCart | The customer result.
Public class | CustomerSearchCriteria | Defines the class containing the search criteria for customers.
Public class | CustomerServiceProvider | Defines the provider that is used to perform any operation on the stored users or customers. It runs the corresponding pipelines that delegate the tasks to the processors. This class inherits from the ServiceProvider class.
Public class | DeleteCustomerRequest | The delete customer request.
Public class | DeleteCustomerResult | The delete customer result.
Public class | DeleteUserRequest | The delete user request.
Public class | DeleteUserResult | The delete user result.
Public class | DisableCustomerRequest | The disable customer request.
Public class | DisableCustomerResult | The disable customer result.
Public class | DisableUserRequest | The disable user request.
Public class | DisableUserResult | The disable user result.
Public class | EnableCustomerRequest | The enable customer request.
Public class | EnableCustomerResult | The enable customer result.
Public class | EnableUserRequest | The enable user request.
Public class | EnableUserResult | The enable user result.
Public class | GetCustomerRequest | The get customer request.
Public class | GetCustomerResult | The get customers result.
Public class | GetCustomersRequest | The get customers request.
Public class | GetCustomersResult | The get customers result.
Public class | GetPartiesRequest | Defines the GetPartiesRequest class.
Public class | GetPartiesResult | Defines the GetPartiesResult class.
Public class | GetUserRequest | The get users request.
Public class | GetUserResult | The get user result.
Public class | GetUsersRequest | The get users request.
Public class | GetUsersResult | The get users result.
Public class | RemoveCustomerPartiesRequest | Defines the RemoveCustomerPartiesRequest class.
Public class | RemoveCustomersRequest | Defines the RemoveCustomersRequest class.
Public class | RemoveCustomersResult | Defines the RemoveCustomersResult result class.
Public class | RemovePartiesRequest | Defines the RemovePartiesRequest class.
Public class | RemoveUsersRequest | Defines the RemoveUsersRequest class.
Public class | RemoveUsersResult | Defines the RemoveUsersResult class.
Public class | UpdateCustomerPartiesRequest | Defines the UpdateCustomerPartiesRequest class.
Public class | UpdateCustomerRequest | The update customer request.
Public class | UpdateCustomerResult | The update customer result.
Public class | UpdatePartiesRequest | Defines the UpdatePartiesRequest class.
Public class | UpdatePasswordRequest | Updates user password request.
Public class | UpdatePasswordResult | Updates user password result.
Public class | UpdateUserRequest | The update user request.
Public class | UpdateUserResult | The update user result.
Public class | UserRequest | Class used as the base of all user requests.
Public class | UserRequestWithUser | Defines the base class for all of the one-user-related requests to the customer service provider.
Public class | UserResult | Defines the base class of all user requests.
Public class | UserResultWithUser | The user result.
Public class | UserSearchCriteria | Defines the class containing the search criteria for users.


AddCustomerPartiesRequest Class

AddCustomerPartiesRequest Class
Defines the AddCustomerPartiesRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersAddCustomerPartiesRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddCustomerPartiesRequest : CustomerRequestWithCustomer
Public Class AddCustomerPartiesRequest
    Inherits CustomerRequestWithCustomer
public ref class AddCustomerPartiesRequest : public CustomerRequestWithCustomer
type AddCustomerPartiesRequest =
    class
        inherit CustomerRequestWithCustomer
    end

The AddCustomerPartiesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | AddCustomerPartiesRequest | Initializes a new instance of the AddCustomerPartiesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


AddCustomerPartiesRequest Constructor

AddCustomerPartiesRequest Constructor
Initializes a new instance of the AddCustomerPartiesRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddCustomerPartiesRequest(
    CommerceCustomer commerceCustomer,
    List<CustomerParty> parties
)
Public Sub New (
    commerceCustomer As CommerceCustomer,
    parties As List(Of CustomerParty)
)
public:
AddCustomerPartiesRequest(
    CommerceCustomer^ commerceCustomer,
    List<CustomerParty^>^ parties
)
new :
        commerceCustomer : CommerceCustomer *
        parties : List<CustomerParty> -> AddCustomerPartiesRequest

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList CustomerParty
The parties.
See Also

Reference

AddCustomerPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddCustomerPartiesRequest Methods

AddCustomerPartiesRequest Methods

The AddCustomerPartiesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddCustomerPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddCustomerPartiesRequest Properties

AddCustomerPartiesRequest Properties

The AddCustomerPartiesRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

AddCustomerPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddCustomerPartiesRequest.Parties Property

AddCustomerPartiesRequestParties Property
Gets or sets the parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<CustomerParty> Parties { get; set; }
Public Property Parties As List(Of CustomerParty)
    Get
    Set
public:
property List<CustomerParty^>^ Parties {
    List<CustomerParty^>^ get ();
    void set (List<CustomerParty^>^ value);
}
member Parties : List<CustomerParty> with get, set

Property Value

Type: List CustomerParty
The parties.
See Also

Reference

AddCustomerPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddCustomersRequest Class

AddCustomersRequest Class
Defines the AddUsersRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersUserRequest
Sitecore.Commerce.Services.CustomersUserRequestWithUser
Sitecore.Commerce.Services.CustomersAddCustomersRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddCustomersRequest : UserRequestWithUser
Public Class AddCustomersRequest
    Inherits UserRequestWithUser
public ref class AddCustomersRequest : public UserRequestWithUser
type AddCustomersRequest =
    class
        inherit UserRequestWithUser
    end

The AddCustomersRequest type exposes the following members.

Constructors
 | Name | Description
Public method | AddCustomersRequest | Initializes a new instance of the AddCustomersRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceUser | Gets the commerce user. (Inherited from UserRequestWithUser.)
Public property | CustomerIds | Gets or sets the customer ids.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


AddCustomersRequest Constructor

AddCustomersRequest Constructor
Initializes a new instance of the AddCustomersRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddCustomersRequest(
    CommerceUser commerceUser,
    List<string> customerIds
)
Public Sub New (
    commerceUser As CommerceUser,
    customerIds As List(Of String)
)
public:
AddCustomersRequest(
    CommerceUser^ commerceUser,
    List<String^>^ customerIds
)
new :
        commerceUser : CommerceUser *
        customerIds : List<string> -> AddCustomersRequest

Parameters

commerceUser
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The user.
customerIds
Type: System.Collections.GenericList String
The customer ids.
See Also

Reference

AddCustomersRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddCustomersRequest Methods

AddCustomersRequest Methods

The AddCustomersRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddCustomersRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddCustomersRequest Properties

AddCustomersRequest Properties

The AddCustomersRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceUser | Gets the commerce user. (Inherited from UserRequestWithUser.)
Public property | CustomerIds | Gets or sets the customer ids.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

AddCustomersRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddCustomersRequest.CustomerIds Property

AddCustomersRequestCustomerIds Property
Gets or sets the customer ids.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<string> CustomerIds { get; set; }
Public Property CustomerIds As List(Of String)
    Get
    Set
public:
property List<String^>^ CustomerIds {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member CustomerIds : List<string> with get, set

Property Value

Type: List String
The customer ids.
See Also

Reference

AddCustomersRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddCustomersResult Class

AddCustomersResult Class
Defines the AddCustomersResult result class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersUserResult
Sitecore.Commerce.Services.CustomersAddCustomersResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddCustomersResult : UserResult
Public Class AddCustomersResult
    Inherits UserResult
public ref class AddCustomersResult : public UserResult
type AddCustomersResult =
    class
        inherit UserResult
    end

The AddCustomersResult type exposes the following members.

Constructors
 | Name | Description
Public method | AddCustomersResult | Initializes a new instance of the AddCustomersResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerIds | Gets or sets the customer ids.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


AddCustomersResult Constructor

AddCustomersResult Constructor
Initializes a new instance of the AddCustomersResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddCustomersResult()
Public Sub New
public:
AddCustomersResult()
new : unit -> AddCustomersResult
See Also

Reference

AddCustomersResult Class
Sitecore.Commerce.Services.Customers Namespace


AddCustomersResult Methods

AddCustomersResult Methods

The AddCustomersResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddCustomersResult Class
Sitecore.Commerce.Services.Customers Namespace


AddCustomersResult Properties

AddCustomersResult Properties

The AddCustomersResult type exposes the following members.

Properties
 | Name | Description
Public property | CustomerIds | Gets or sets the customer ids.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

AddCustomersResult Class
Sitecore.Commerce.Services.Customers Namespace


AddCustomersResult.CustomerIds Property

AddCustomersResultCustomerIds Property
Gets or sets the customer ids.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ICollection<string> CustomerIds { get; set; }
Public Property CustomerIds As ICollection(Of String)
    Get
    Set
public:
property ICollection<String^>^ CustomerIds {
    ICollection<String^>^ get ();
    void set (ICollection<String^>^ value);
}
member CustomerIds : ICollection<string> with get, set

Property Value

Type: ICollection String
The customer ids.
See Also

Reference

AddCustomersResult Class
Sitecore.Commerce.Services.Customers Namespace


AddPartiesRequest Class

AddPartiesRequest Class
Defines the AddPartiesRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersAddPartiesRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddPartiesRequest : CustomerRequestWithCustomer
Public Class AddPartiesRequest
    Inherits CustomerRequestWithCustomer
public ref class AddPartiesRequest : public CustomerRequestWithCustomer
type AddPartiesRequest =
    class
        inherit CustomerRequestWithCustomer
    end

The AddPartiesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | AddPartiesRequest | Initializes a new instance of the AddPartiesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


AddPartiesRequest Constructor

AddPartiesRequest Constructor
Initializes a new instance of the AddPartiesRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddPartiesRequest(
    CommerceCustomer commerceCustomer,
    List<Party> parties
)
Public Sub New (
    commerceCustomer As CommerceCustomer,
    parties As List(Of Party)
)
public:
AddPartiesRequest(
    CommerceCustomer^ commerceCustomer,
    List<Party^>^ parties
)
new :
        commerceCustomer : CommerceCustomer *
        parties : List<Party> -> AddPartiesRequest

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList Party
The parties.
See Also

Reference

AddPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddPartiesRequest Methods

AddPartiesRequest Methods

The AddPartiesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddPartiesRequest Properties

AddPartiesRequest Properties

The AddPartiesRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

AddPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddPartiesRequest.Parties Property

AddPartiesRequestParties Property
Gets or sets the parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<Party> Parties { get; set; }
Public Property Parties As List(Of Party)
    Get
    Set
public:
property List<Party^>^ Parties {
    List<Party^>^ get ();
    void set (List<Party^>^ value);
}
member Parties : List<Party> with get, set

Property Value

Type: List Party
The parties.
See Also

Reference

AddPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddPartiesResult Class

AddPartiesResult Class
Defines the AddPartiesResult result class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerResult
Sitecore.Commerce.Services.CustomersAddPartiesResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddPartiesResult : CustomerResult
Public Class AddPartiesResult
    Inherits CustomerResult
public ref class AddPartiesResult : public CustomerResult
type AddPartiesResult =
    class
        inherit CustomerResult
    end

The AddPartiesResult type exposes the following members.

Constructors
 | Name | Description
Public method | AddPartiesResult | Initializes a new instance of the AddPartiesResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


AddPartiesResult Constructor

AddPartiesResult Constructor
Initializes a new instance of the AddPartiesResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddPartiesResult()
Public Sub New
public:
AddPartiesResult()
new : unit -> AddPartiesResult
See Also

Reference

AddPartiesResult Class
Sitecore.Commerce.Services.Customers Namespace


AddPartiesResult Methods

AddPartiesResult Methods

The AddPartiesResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddPartiesResult Class
Sitecore.Commerce.Services.Customers Namespace


AddPartiesResult Properties

AddPartiesResult Properties

The AddPartiesResult type exposes the following members.

Properties
 | Name | Description
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

AddPartiesResult Class
Sitecore.Commerce.Services.Customers Namespace


AddPartiesResult.Parties Property

AddPartiesResultParties Property
Gets or sets the parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ICollection<Party> Parties { get; set; }
Public Property Parties As ICollection(Of Party)
    Get
    Set
public:
property ICollection<Party^>^ Parties {
    ICollection<Party^>^ get ();
    void set (ICollection<Party^>^ value);
}
member Parties : ICollection<Party> with get, set

Property Value

Type: ICollection Party
The parties.
See Also

Reference

AddPartiesResult Class
Sitecore.Commerce.Services.Customers Namespace


AddUsersRequest Class

AddUsersRequest Class
Defines the AddUsersRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersAddUsersRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddUsersRequest : CustomerRequestWithCustomer
Public Class AddUsersRequest
    Inherits CustomerRequestWithCustomer
public ref class AddUsersRequest : public CustomerRequestWithCustomer
type AddUsersRequest =
    class
        inherit CustomerRequestWithCustomer
    end

The AddUsersRequest type exposes the following members.

Constructors
 | Name | Description
Public method | AddUsersRequest | Initializes a new instance of the AddUsersRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UserIds | Gets or sets the user ids.
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


AddUsersRequest Constructor

AddUsersRequest Constructor
Initializes a new instance of the AddUsersRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddUsersRequest(
    CommerceCustomer commerceCustomer,
    List<string> userIds
)
Public Sub New (
    commerceCustomer As CommerceCustomer,
    userIds As List(Of String)
)
public:
AddUsersRequest(
    CommerceCustomer^ commerceCustomer,
    List<String^>^ userIds
)
new :
        commerceCustomer : CommerceCustomer *
        userIds : List<string> -> AddUsersRequest

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
userIds
Type: System.Collections.GenericList String
The user ids.
See Also

Reference

AddUsersRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddUsersRequest Methods

AddUsersRequest Methods

The AddUsersRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddUsersRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddUsersRequest Properties

AddUsersRequest Properties

The AddUsersRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UserIds | Gets or sets the user ids.
Top
See Also

Reference

AddUsersRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddUsersRequest.UserIds Property

AddUsersRequestUserIds Property
Gets or sets the user ids.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<string> UserIds { get; set; }
Public Property UserIds As List(Of String)
    Get
    Set
public:
property List<String^>^ UserIds {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member UserIds : List<string> with get, set

Property Value

Type: List String
The user ids.
See Also

Reference

AddUsersRequest Class
Sitecore.Commerce.Services.Customers Namespace


AddUsersResult Class

AddUsersResult Class
Defines the AddUsersResult result class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerResult
Sitecore.Commerce.Services.CustomersAddUsersResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class AddUsersResult : CustomerResult
Public Class AddUsersResult
    Inherits CustomerResult
public ref class AddUsersResult : public CustomerResult
type AddUsersResult =
    class
        inherit CustomerResult
    end

The AddUsersResult type exposes the following members.

Constructors
 | Name | Description
Public method | AddUsersResult | Initializes a new instance of the AddUsersResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Public property | UserIds | Gets or sets the user ids.
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


AddUsersResult Constructor

AddUsersResult Constructor
Initializes a new instance of the AddUsersResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public AddUsersResult()
Public Sub New
public:
AddUsersResult()
new : unit -> AddUsersResult
See Also

Reference

AddUsersResult Class
Sitecore.Commerce.Services.Customers Namespace


AddUsersResult Methods

AddUsersResult Methods

The AddUsersResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddUsersResult Class
Sitecore.Commerce.Services.Customers Namespace


AddUsersResult Properties

AddUsersResult Properties

The AddUsersResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Public property | UserIds | Gets or sets the user ids.
Top
See Also

Reference

AddUsersResult Class
Sitecore.Commerce.Services.Customers Namespace


AddUsersResult.UserIds Property

AddUsersResultUserIds Property
Gets or sets the user ids.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ICollection<string> UserIds { get; set; }
Public Property UserIds As ICollection(Of String)
    Get
    Set
public:
property ICollection<String^>^ UserIds {
    ICollection<String^>^ get ();
    void set (ICollection<String^>^ value);
}
member UserIds : ICollection<string> with get, set

Property Value

Type: ICollection String
The user ids.
See Also

Reference

AddUsersResult Class
Sitecore.Commerce.Services.Customers Namespace


CreateCustomerRequest Class

CreateCustomerRequest Class
The create customer request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersCreateCustomerRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CreateCustomerRequest : CustomerRequestWithCustomer
Public Class CreateCustomerRequest
    Inherits CustomerRequestWithCustomer
public ref class CreateCustomerRequest : public CustomerRequestWithCustomer
type CreateCustomerRequest =
    class
        inherit CustomerRequestWithCustomer
    end

The CreateCustomerRequest type exposes the following members.

Constructors
 | Name | Description
Public method | CreateCustomerRequest | Initializes a new instance of the CreateCustomerRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


CreateCustomerRequest Constructor

CreateCustomerRequest Constructor
Initializes a new instance of the CreateCustomerRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CreateCustomerRequest(
    CommerceCustomer commerceCustomer
)
Public Sub New (
    commerceCustomer As CommerceCustomer
)
public:
CreateCustomerRequest(
    CommerceCustomer^ commerceCustomer
)
new :
        commerceCustomer : CommerceCustomer -> CreateCustomerRequest

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The commerce customer.
See Also

Reference

CreateCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


CreateCustomerRequest Methods

CreateCustomerRequest Methods

The CreateCustomerRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


CreateCustomerRequest Properties

CreateCustomerRequest Properties

The CreateCustomerRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

CreateCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


CreateCustomerResult Class

CreateCustomerResult Class
The create customer result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerResult
Sitecore.Commerce.Services.CustomersCustomerResultWithCart
Sitecore.Commerce.Services.CustomersCreateCustomerResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CreateCustomerResult : CustomerResultWithCart
Public Class CreateCustomerResult
    Inherits CustomerResultWithCart
public ref class CreateCustomerResult : public CustomerResultWithCart
type CreateCustomerResult =
    class
        inherit CustomerResultWithCart
    end

The CreateCustomerResult type exposes the following members.

Constructors
 | Name | Description
Public method | CreateCustomerResult | Initializes a new instance of the CreateCustomerResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce customer. (Inherited from CustomerResultWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


CreateCustomerResult Constructor

CreateCustomerResult Constructor
Initializes a new instance of the CreateCustomerResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CreateCustomerResult()
Public Sub New
public:
CreateCustomerResult()
new : unit -> CreateCustomerResult
See Also

Reference

CreateCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


CreateCustomerResult Methods

CreateCustomerResult Methods

The CreateCustomerResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


CreateCustomerResult Properties

CreateCustomerResult Properties

The CreateCustomerResult type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce customer. (Inherited from CustomerResultWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

CreateCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


CreateUserRequest Class

CreateUserRequest Class
The create user request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersUserRequest
Sitecore.Commerce.Services.CustomersCreateUserRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CreateUserRequest : UserRequest
Public Class CreateUserRequest
    Inherits UserRequest
public ref class CreateUserRequest : public UserRequest
type CreateUserRequest =
    class
        inherit UserRequest
    end

The CreateUserRequest type exposes the following members.

Constructors
 | Name | Description
Public method | CreateUserRequest | Initializes a new instance of the CreateUserRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Email | Gets the email.
Public property | Password | Gets the password.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets the shop name.
Public property | UserName | Gets the user name.
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


CreateUserRequest Constructor

CreateUserRequest Constructor
Initializes a new instance of the CreateUserRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CreateUserRequest(
    string userName,
    string password,
    string email,
    string shopName
)
Public Sub New (
    userName As String,
    password As String,
    email As String,
    shopName As String
)
public:
CreateUserRequest(
    String^ userName,
    String^ password,
    String^ email,
    String^ shopName
)
new :
        userName : string *
        password : string *
        email : string *
        shopName : string -> CreateUserRequest

Parameters

userName
Type: SystemString
Name of the user.
password
Type: SystemString
The password.
email
Type: SystemString
The email.
shopName
Type: SystemString
Name of the shop.
See Also

Reference

CreateUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


CreateUserRequest Methods

CreateUserRequest Methods

The CreateUserRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


CreateUserRequest Properties

CreateUserRequest Properties

The CreateUserRequest type exposes the following members.

Properties
 | Name | Description
Public property | Email | Gets the email.
Public property | Password | Gets the password.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets the shop name.
Public property | UserName | Gets the user name.
Top
See Also

Reference

CreateUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


CreateUserRequest.Email Property

CreateUserRequestEmail Property
Gets the email.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Email { get; }
Public ReadOnly Property Email As String
    Get
public:
property String^ Email {
    String^ get ();
}
member Email : string with get

Property Value

Type: String
See Also

Reference

CreateUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


CreateUserRequest.Password Property

CreateUserRequestPassword Property
Gets the password.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Password { get; }
Public ReadOnly Property Password As String
    Get
public:
property String^ Password {
    String^ get ();
}
member Password : string with get

Property Value

Type: String
The password.
See Also

Reference

CreateUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


CreateUserRequest.ShopName Property

CreateUserRequestShopName Property
Gets the shop name.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; }
Public ReadOnly Property ShopName As String
    Get
public:
property String^ ShopName {
    String^ get ();
}
member ShopName : string with get

Property Value

Type: String
See Also

Reference

CreateUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


CreateUserRequest.UserName Property

CreateUserRequestUserName Property
Gets the user name.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; }
Public ReadOnly Property UserName As String
    Get
public:
property String^ UserName {
    String^ get ();
}
member UserName : string with get

Property Value

Type: String
See Also

Reference

CreateUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


CreateUserResult Class

CreateUserResult Class
The create user result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersUserResult
Sitecore.Commerce.Services.CustomersUserResultWithUser
Sitecore.Commerce.Services.CustomersCreateUserResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CreateUserResult : UserResultWithUser
Public Class CreateUserResult
    Inherits UserResultWithUser
public ref class CreateUserResult : public UserResultWithUser
type CreateUserResult =
    class
        inherit UserResultWithUser
    end

The CreateUserResult type exposes the following members.

Constructors
 | Name | Description
Public method | CreateUserResult | Initializes a new instance of the CreateUserResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceUser | Gets or sets the commerce user. (Inherited from UserResultWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


CreateUserResult Constructor

CreateUserResult Constructor
Initializes a new instance of the CreateUserResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CreateUserResult()
Public Sub New
public:
CreateUserResult()
new : unit -> CreateUserResult
See Also

Reference

CreateUserResult Class
Sitecore.Commerce.Services.Customers Namespace


CreateUserResult Methods

CreateUserResult Methods

The CreateUserResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateUserResult Class
Sitecore.Commerce.Services.Customers Namespace


CreateUserResult Properties

CreateUserResult Properties

The CreateUserResult type exposes the following members.

Properties
 | Name | Description
Public property | CommerceUser | Gets or sets the commerce user. (Inherited from UserResultWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

CreateUserResult Class
Sitecore.Commerce.Services.Customers Namespace


CustomerPartiesResult Class

CustomerPartiesResult Class
Defines the CustomerPartiesResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerPartiesResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CustomerPartiesResult : ServiceProviderResult
Public Class CustomerPartiesResult
    Inherits ServiceProviderResult
public ref class CustomerPartiesResult : public ServiceProviderResult
type CustomerPartiesResult =
    class
        inherit ServiceProviderResult
    end

The CustomerPartiesResult type exposes the following members.

Constructors
 | Name | Description
Public method | CustomerPartiesResult | Initializes a new instance of the CustomerPartiesResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


CustomerPartiesResult Constructor

CustomerPartiesResult Constructor
Initializes a new instance of the CustomerPartiesResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CustomerPartiesResult()
Public Sub New
public:
CustomerPartiesResult()
new : unit -> CustomerPartiesResult
See Also

Reference

CustomerPartiesResult Class
Sitecore.Commerce.Services.Customers Namespace


CustomerPartiesResult Methods

CustomerPartiesResult Methods

The CustomerPartiesResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomerPartiesResult Class
Sitecore.Commerce.Services.Customers Namespace


CustomerPartiesResult Properties

CustomerPartiesResult Properties

The CustomerPartiesResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

CustomerPartiesResult Class
Sitecore.Commerce.Services.Customers Namespace


CustomerRequest Class

CustomerRequest Class
Class used as the base of all customer requests.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersGetCustomerRequest
Sitecore.Commerce.Services.CustomersGetCustomersRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CustomerRequest : ServiceProviderRequest
Public Class CustomerRequest
    Inherits ServiceProviderRequest
public ref class CustomerRequest : public ServiceProviderRequest
type CustomerRequest =
    class
        inherit ServiceProviderRequest
    end

The CustomerRequest type exposes the following members.

Constructors
 | Name | Description
Public method | CustomerRequest | Initializes a new instance of the CustomerRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


CustomerRequest Constructor

CustomerRequest Constructor
Initializes a new instance of the CustomerRequest class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CustomerRequest()
Public Sub New
public:
CustomerRequest()
new : unit -> CustomerRequest
See Also

Reference

CustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


CustomerRequest Methods

CustomerRequest Methods

The CustomerRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


CustomerRequest Properties

CustomerRequest Properties

The CustomerRequest type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

CustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


CustomerRequestWithCustomer Class

CustomerRequestWithCustomer Class
The base reuqets of all Customer requests that require a Customer model to be passed in.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
More...

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class CustomerRequestWithCustomer : CustomerRequest
Public MustInherit Class CustomerRequestWithCustomer
    Inherits CustomerRequest
public ref class CustomerRequestWithCustomer abstract : public CustomerRequest
[<AbstractClassAttribute>]
type CustomerRequestWithCustomer =
    class
        inherit CustomerRequest
    end

The CustomerRequestWithCustomer type exposes the following members.

Constructors
 | Name | Description
Protected method | CustomerRequestWithCustomer | Initializes a new instance of the CustomerRequestWithCustomer class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersAddCustomerPartiesRequest
Sitecore.Commerce.Services.CustomersAddPartiesRequest
Sitecore.Commerce.Services.CustomersAddUsersRequest
Sitecore.Commerce.Services.CustomersCreateCustomerRequest
Sitecore.Commerce.Services.CustomersDeleteCustomerRequest
Sitecore.Commerce.Services.CustomersDisableCustomerRequest
Sitecore.Commerce.Services.CustomersEnableCustomerRequest
Sitecore.Commerce.Services.CustomersGetPartiesRequest
Sitecore.Commerce.Services.CustomersRemoveCustomerPartiesRequest
Sitecore.Commerce.Services.CustomersRemovePartiesRequest
Sitecore.Commerce.Services.CustomersRemoveUsersRequest
Sitecore.Commerce.Services.CustomersUpdateCustomerPartiesRequest
Sitecore.Commerce.Services.CustomersUpdateCustomerRequest
Sitecore.Commerce.Services.CustomersUpdatePartiesRequest


CustomerRequestWithCustomer Constructor

CustomerRequestWithCustomer Constructor
Initializes a new instance of the CustomerRequestWithCustomer class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected CustomerRequestWithCustomer(
    CommerceCustomer commerceCustomer
)
Protected Sub New (
    commerceCustomer As CommerceCustomer
)
protected:
CustomerRequestWithCustomer(
    CommerceCustomer^ commerceCustomer
)
new :
        commerceCustomer : CommerceCustomer -> CustomerRequestWithCustomer

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The commerce customer.
See Also

Reference

CustomerRequestWithCustomer Class
Sitecore.Commerce.Services.Customers Namespace


CustomerRequestWithCustomer Methods

CustomerRequestWithCustomer Methods

The CustomerRequestWithCustomer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomerRequestWithCustomer Class
Sitecore.Commerce.Services.Customers Namespace


CustomerRequestWithCustomer Properties

CustomerRequestWithCustomer Properties

The CustomerRequestWithCustomer type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

CustomerRequestWithCustomer Class
Sitecore.Commerce.Services.Customers Namespace


CustomerRequestWithCustomer.CommerceCustomer Property

CustomerRequestWithCustomerCommerceCustomer Property
Gets or sets the commerce user.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CommerceCustomer CommerceCustomer { get; set; }
Public Property CommerceCustomer As CommerceCustomer
    Get
    Set
public:
property CommerceCustomer^ CommerceCustomer {
    CommerceCustomer^ get ();
    void set (CommerceCustomer^ value);
}
member CommerceCustomer : CommerceCustomer with get, set

Property Value

Type: CommerceCustomer
The commerce user.
See Also

Reference

CustomerRequestWithCustomer Class
Sitecore.Commerce.Services.Customers Namespace


CustomerResult Class

CustomerResult Class
Defines the base class of all customer results.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerResult
More...

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CustomerResult : ServiceProviderResult
Public Class CustomerResult
    Inherits ServiceProviderResult
public ref class CustomerResult : public ServiceProviderResult
type CustomerResult =
    class
        inherit ServiceProviderResult
    end

The CustomerResult type exposes the following members.

Constructors
 | Name | Description
Public method | CustomerResult | Initializes a new instance of the CustomerResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerResult
Sitecore.Commerce.Services.CustomersAddPartiesResult
Sitecore.Commerce.Services.CustomersAddUsersResult
Sitecore.Commerce.Services.CustomersCustomerResultWithCart
Sitecore.Commerce.Services.CustomersDeleteCustomerResult
Sitecore.Commerce.Services.CustomersGetCustomerResult
Sitecore.Commerce.Services.CustomersGetCustomersResult
Sitecore.Commerce.Services.CustomersGetPartiesResult
Sitecore.Commerce.Services.CustomersRemoveUsersResult


CustomerResult Constructor

CustomerResult Constructor
Initializes a new instance of the CustomerResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CustomerResult()
Public Sub New
public:
CustomerResult()
new : unit -> CustomerResult
See Also

Reference

CustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


CustomerResult Methods

CustomerResult Methods

The CustomerResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


CustomerResult Properties

CustomerResult Properties

The CustomerResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

CustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


CustomerResultWithCart Class

CustomerResultWithCart Class
The customer result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerResult
Sitecore.Commerce.Services.CustomersCustomerResultWithCart
Sitecore.Commerce.Services.CustomersCreateCustomerResult
Sitecore.Commerce.Services.CustomersDisableCustomerResult
Sitecore.Commerce.Services.CustomersEnableCustomerResult
Sitecore.Commerce.Services.CustomersUpdateCustomerResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CustomerResultWithCart : CustomerResult
Public Class CustomerResultWithCart
    Inherits CustomerResult
public ref class CustomerResultWithCart : public CustomerResult
type CustomerResultWithCart =
    class
        inherit CustomerResult
    end

The CustomerResultWithCart type exposes the following members.

Constructors
 | Name | Description
Public method | CustomerResultWithCart | Initializes a new instance of the CustomerResultWithCart class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce customer.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


CustomerResultWithCart Constructor

CustomerResultWithCart Constructor
Initializes a new instance of the CustomerResultWithCart class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CustomerResultWithCart()
Public Sub New
public:
CustomerResultWithCart()
new : unit -> CustomerResultWithCart
See Also

Reference

CustomerResultWithCart Class
Sitecore.Commerce.Services.Customers Namespace


CustomerResultWithCart Methods

CustomerResultWithCart Methods

The CustomerResultWithCart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomerResultWithCart Class
Sitecore.Commerce.Services.Customers Namespace


CustomerResultWithCart Properties

CustomerResultWithCart Properties

The CustomerResultWithCart type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce customer.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

CustomerResultWithCart Class
Sitecore.Commerce.Services.Customers Namespace


CustomerResultWithCart.CommerceCustomer Property

CustomerResultWithCartCommerceCustomer Property
Gets or sets the commerce customer.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CommerceCustomer CommerceCustomer { get; set; }
Public Property CommerceCustomer As CommerceCustomer
    Get
    Set
public:
property CommerceCustomer^ CommerceCustomer {
    CommerceCustomer^ get ();
    void set (CommerceCustomer^ value);
}
member CommerceCustomer : CommerceCustomer with get, set

Property Value

Type: CommerceCustomer
The commerce customer.
See Also

Reference

CustomerResultWithCart Class
Sitecore.Commerce.Services.Customers Namespace


CustomerSearchCriteria Class

CustomerSearchCriteria Class
Defines the class containing the search criteria for customers.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Services.CustomersCustomerSearchCriteria

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CustomerSearchCriteria : Entity
Public Class CustomerSearchCriteria
    Inherits Entity
public ref class CustomerSearchCriteria : public Entity
type CustomerSearchCriteria =
    class
        inherit Entity
    end

The CustomerSearchCriteria type exposes the following members.

Constructors
 | Name | Description
Public method | CustomerSearchCriteria | Initializes a new instance of the CustomerSearchCriteria class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ExternalIDs | Gets or sets the external Ids.
Public property | ExternalUserIDs | Gets or sets the external customer Ids.
Public property | IsDisabled | Gets or sets the is disabled.
Public property | Name | Gets or sets the name.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | ShopName | Gets or sets the shop name.
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


CustomerSearchCriteria Constructor

CustomerSearchCriteria Constructor
Initializes a new instance of the CustomerSearchCriteria class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CustomerSearchCriteria()
Public Sub New
public:
CustomerSearchCriteria()
new : unit -> CustomerSearchCriteria
See Also

Reference

CustomerSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


CustomerSearchCriteria Methods

CustomerSearchCriteria Methods

The CustomerSearchCriteria type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomerSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


CustomerSearchCriteria Properties

CustomerSearchCriteria Properties

The CustomerSearchCriteria type exposes the following members.

Properties
 | Name | Description
Public property | ExternalIDs | Gets or sets the external Ids.
Public property | ExternalUserIDs | Gets or sets the external customer Ids.
Public property | IsDisabled | Gets or sets the is disabled.
Public property | Name | Gets or sets the name.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | ShopName | Gets or sets the shop name.
Top
See Also

Reference

CustomerSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


CustomerSearchCriteria.ExternalIDs Property

CustomerSearchCriteriaExternalIDs Property
Gets or sets the external Ids.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ExternalIDs { get; set; }
Public Property ExternalIDs As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ ExternalIDs {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member ExternalIDs : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The external I ds.
See Also

Reference

CustomerSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


CustomerSearchCriteria.ExternalUserIDs Property

CustomerSearchCriteriaExternalUserIDs Property
Gets or sets the external customer Ids.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ExternalUserIDs { get; set; }
Public Property ExternalUserIDs As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ ExternalUserIDs {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member ExternalUserIDs : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The external customer Ids.
See Also

Reference

CustomerSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


CustomerSearchCriteria.IsDisabled Property

CustomerSearchCriteriaIsDisabled Property
Gets or sets the is disabled.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> IsDisabled { get; set; }
Public Property IsDisabled As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsDisabled {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member IsDisabled : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

CustomerSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


CustomerSearchCriteria.Name Property

CustomerSearchCriteriaName Property
Gets or sets the name.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

CustomerSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


CustomerSearchCriteria.ShopName Property

CustomerSearchCriteriaShopName Property
Gets or sets the shop name.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
See Also

Reference

CustomerSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider Class

CustomerServiceProvider Class
Defines the provider that is used to perform any operation on the stored users or customers. It runs the corresponding pipelines that delegate the tasks to the processors. This class inherits from the ServiceProvider class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProvider
Sitecore.Commerce.Services.CustomersCustomerServiceProvider

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class CustomerServiceProvider : ServiceProvider
Public Class CustomerServiceProvider
    Inherits ServiceProvider
public ref class CustomerServiceProvider : public ServiceProvider
type CustomerServiceProvider =
    class
        inherit ServiceProvider
    end

The CustomerServiceProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CustomerServiceProvider | Initializes a new instance of the CustomerServiceProvider class
Top
Methods
 | Name | Description
Public method | AddCustomerParties | Adds the customer parties.
Public method | AddCustomers | The Add customers.
Public method | AddParties | Adds the parties.
Public method | AddUsers | The Add users.
Public method | CreateCustomer | Creates the customer.
Public method | CreateUser | Synchronizes the product.
Public method | DeleteCustomer | The delete customer.
Public method | DeleteUser | Deletes the user.
Public method | DisableCustomer | Disables the customer.
Public method | DisableUser | Disables the user.
Public method | EnableCustomer | Enables the customer.
Public method | EnableUser | Enables the user.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCustomer | The get customer.
Public method | GetCustomers | The get customers.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParties | Gets the parties.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUser | Gets the user.
Public method | GetUsers | Gets the users.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveCustomerParties | Removes the customer parties.
Public method | RemoveCustomers | The remove customers.
Public method | RemoveParties | Removes the parties.
Public method | RemoveUsers | The remove users.
Public method | RunPipelineTRequest, TResult | Runs the pipeline. (Inherited from ServiceProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateCustomer | Updates the customer.
Public method | UpdateCustomerParties | Updates the customer parties.
Public method | UpdateParties | Updates the parties.
Public method | UpdatePassword | Updates user password.
Public method | UpdateUser | Updates the user.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddCustomerPartiesTAddCustomerPatiesRequest, TCustomerPartiesResult | Adds the customer parties. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | AddCustomersTAddCustomersRequest, TAddCustomersResult | Adds customers to an existing user. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | AddPartiesTAddPatiesRequest, TAddPartiesResult | Adds the parties. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | AddUsersTAddUsersRequest, TAddUsersResult | Adds users to an existing customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | CreateCustomerTCreateCustomerRequest, TCreateCustomerResult | Creates a customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | CreateUserTCreateUserRequest, TCreateUserResult | Creates the user. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | DeleteCustomerTDeleteCustomerRequest, TDeleteCustomerResult | Deletes the customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | DeleteUserTDeleteUserRequest, TDeleteUserResult | Updates the user. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | DisableCustomerTDisableCustomerRequest, TDisableCustomerResult | Disables the customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | DisableUserTDisableUserRequest, TDisableUserResult | Updates the user. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | EnableCustomerTEnableCustomerRequest, TEnableCustomerResult | Enables the customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | EnableUserTEnableUserRequest, TEnableUserResult | Updates the user. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | GetCustomerTGetCustomerRequest, TGetCustomerResult | Gets the customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | GetCustomersTGetCustomersRequest, TGetCustomersResult | Gets the customers. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | GetPartiesTGetPartiesRequest, TGetPartiesResult | Gets the parties. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | GetUserTGetUserRequest, TGetUserResult | Gets the user. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | GetUsersTGetUsersRequest, TGetUsersResult | Gets the users. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | RemoveCustomerPartiesTRemoveCustomerPatiesRequest, TCustomerPartiesResult | Removes the customer parties. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | RemoveCustomersTRemoveCustomersRequest, TRemoveCustomersResult | Removes customers from an existing user. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | RemovePartiesTRemovePatiesRequest, TCustomerResult | Removes the parties associated with the given customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | RemoveUsersTRemoveUsersRequest, TRemoveUsersResult | Removes users from an existing customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | UpdateCustomerTUpdateCustomerRequest, TUpdateCustomerResult | Updates the customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | UpdateCustomerPartiesTUpdateCustomerPatiesRequest, TCustomerPartiesResult | Updates the customer parties. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | UpdatePartiesTUpdatePatiesRequest, TCustomerResult | Updates the parties information associated with the given customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | UpdatePasswordTUpdatePasswordRequest, TUpdatePasswordResult | Updates the parties information associated with the given customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | UpdateUserTUpdateUserRequest, TUpdateUserResult | Updates the user. (Defined by GenericCustomerServiceProviderExtensions.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from ServiceProvider.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider Constructor

CustomerServiceProvider Constructor
Initializes a new instance of the CustomerServiceProvider class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CustomerServiceProvider()
Public Sub New
public:
CustomerServiceProvider()
new : unit -> CustomerServiceProvider
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider Methods

CustomerServiceProvider Methods

The CustomerServiceProvider type exposes the following members.

Methods
 | Name | Description
Public method | AddCustomerParties | Adds the customer parties.
Public method | AddCustomers | The Add customers.
Public method | AddParties | Adds the parties.
Public method | AddUsers | The Add users.
Public method | CreateCustomer | Creates the customer.
Public method | CreateUser | Synchronizes the product.
Public method | DeleteCustomer | The delete customer.
Public method | DeleteUser | Deletes the user.
Public method | DisableCustomer | Disables the customer.
Public method | DisableUser | Disables the user.
Public method | EnableCustomer | Enables the customer.
Public method | EnableUser | Enables the user.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCustomer | The get customer.
Public method | GetCustomers | The get customers.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParties | Gets the parties.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUser | Gets the user.
Public method | GetUsers | Gets the users.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveCustomerParties | Removes the customer parties.
Public method | RemoveCustomers | The remove customers.
Public method | RemoveParties | Removes the parties.
Public method | RemoveUsers | The remove users.
Public method | RunPipelineTRequest, TResult | Runs the pipeline. (Inherited from ServiceProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateCustomer | Updates the customer.
Public method | UpdateCustomerParties | Updates the customer parties.
Public method | UpdateParties | Updates the parties.
Public method | UpdatePassword | Updates user password.
Public method | UpdateUser | Updates the user.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddCustomerPartiesTAddCustomerPatiesRequest, TCustomerPartiesResult | Adds the customer parties. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | AddCustomersTAddCustomersRequest, TAddCustomersResult | Adds customers to an existing user. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | AddPartiesTAddPatiesRequest, TAddPartiesResult | Adds the parties. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | AddUsersTAddUsersRequest, TAddUsersResult | Adds users to an existing customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | CreateCustomerTCreateCustomerRequest, TCreateCustomerResult | Creates a customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | CreateUserTCreateUserRequest, TCreateUserResult | Creates the user. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | DeleteCustomerTDeleteCustomerRequest, TDeleteCustomerResult | Deletes the customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | DeleteUserTDeleteUserRequest, TDeleteUserResult | Updates the user. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | DisableCustomerTDisableCustomerRequest, TDisableCustomerResult | Disables the customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | DisableUserTDisableUserRequest, TDisableUserResult | Updates the user. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | EnableCustomerTEnableCustomerRequest, TEnableCustomerResult | Enables the customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | EnableUserTEnableUserRequest, TEnableUserResult | Updates the user. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | GetCustomerTGetCustomerRequest, TGetCustomerResult | Gets the customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | GetCustomersTGetCustomersRequest, TGetCustomersResult | Gets the customers. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | GetPartiesTGetPartiesRequest, TGetPartiesResult | Gets the parties. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | GetUserTGetUserRequest, TGetUserResult | Gets the user. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | GetUsersTGetUsersRequest, TGetUsersResult | Gets the users. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | RemoveCustomerPartiesTRemoveCustomerPatiesRequest, TCustomerPartiesResult | Removes the customer parties. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | RemoveCustomersTRemoveCustomersRequest, TRemoveCustomersResult | Removes customers from an existing user. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | RemovePartiesTRemovePatiesRequest, TCustomerResult | Removes the parties associated with the given customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | RemoveUsersTRemoveUsersRequest, TRemoveUsersResult | Removes users from an existing customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | UpdateCustomerTUpdateCustomerRequest, TUpdateCustomerResult | Updates the customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | UpdateCustomerPartiesTUpdateCustomerPatiesRequest, TCustomerPartiesResult | Updates the customer parties. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | UpdatePartiesTUpdatePatiesRequest, TCustomerResult | Updates the parties information associated with the given customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | UpdatePasswordTUpdatePasswordRequest, TUpdatePasswordResult | Updates the parties information associated with the given customer. (Defined by GenericCustomerServiceProviderExtensions.)
Public Extension Method | UpdateUserTUpdateUserRequest, TUpdateUserResult | Updates the user. (Defined by GenericCustomerServiceProviderExtensions.)
Top
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.AddCustomerParties Method

CustomerServiceProviderAddCustomerParties Method
Adds the customer parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CustomerPartiesResult AddCustomerParties(
    AddCustomerPartiesRequest request
)
Public Overridable Function AddCustomerParties (
    request As AddCustomerPartiesRequest
) As CustomerPartiesResult
public:
virtual CustomerPartiesResult^ AddCustomerParties(
    AddCustomerPartiesRequest^ request
)
abstract AddCustomerParties :
        request : AddCustomerPartiesRequest -> CustomerPartiesResult
override AddCustomerParties :
        request : AddCustomerPartiesRequest -> CustomerPartiesResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersAddCustomerPartiesRequest
The request.

Return Value

Type: CustomerPartiesResult
An object of type CustomerPartiesResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.AddCustomers Method

CustomerServiceProviderAddCustomers Method
The Add customers.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual AddCustomersResult AddCustomers(
    AddCustomersRequest request
)
Public Overridable Function AddCustomers (
    request As AddCustomersRequest
) As AddCustomersResult
public:
virtual AddCustomersResult^ AddCustomers(
    AddCustomersRequest^ request
)
abstract AddCustomers :
        request : AddCustomersRequest -> AddCustomersResult
override AddCustomers :
        request : AddCustomersRequest -> AddCustomersResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersAddCustomersRequest
The request.

Return Value

Type: AddCustomersResult
An object of type AddCustomersResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.AddParties Method

CustomerServiceProviderAddParties Method
Adds the parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual AddPartiesResult AddParties(
    AddPartiesRequest request
)
Public Overridable Function AddParties (
    request As AddPartiesRequest
) As AddPartiesResult
public:
virtual AddPartiesResult^ AddParties(
    AddPartiesRequest^ request
)
abstract AddParties :
        request : AddPartiesRequest -> AddPartiesResult
override AddParties :
        request : AddPartiesRequest -> AddPartiesResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersAddPartiesRequest
The request.

Return Value

Type: AddPartiesResult
An object of type AddPartiesResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.AddUsers Method

CustomerServiceProviderAddUsers Method
The Add users.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual AddUsersResult AddUsers(
    AddUsersRequest request
)
Public Overridable Function AddUsers (
    request As AddUsersRequest
) As AddUsersResult
public:
virtual AddUsersResult^ AddUsers(
    AddUsersRequest^ request
)
abstract AddUsers :
        request : AddUsersRequest -> AddUsersResult
override AddUsers :
        request : AddUsersRequest -> AddUsersResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersAddUsersRequest
The request.

Return Value

Type: AddUsersResult
An object of type AddUsersResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.CreateCustomer Method

CustomerServiceProviderCreateCustomer Method
Creates the customer.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CreateCustomerResult CreateCustomer(
    CreateCustomerRequest request
)
Public Overridable Function CreateCustomer (
    request As CreateCustomerRequest
) As CreateCustomerResult
public:
virtual CreateCustomerResult^ CreateCustomer(
    CreateCustomerRequest^ request
)
abstract CreateCustomer :
        request : CreateCustomerRequest -> CreateCustomerResult
override CreateCustomer :
        request : CreateCustomerRequest -> CreateCustomerResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersCreateCustomerRequest
The request

Return Value

Type: CreateCustomerResult
An object of type CreateCustomerResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.CreateUser Method

CustomerServiceProviderCreateUser Method
Synchronizes the product.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CreateUserResult CreateUser(
    CreateUserRequest request
)
Public Overridable Function CreateUser (
    request As CreateUserRequest
) As CreateUserResult
public:
virtual CreateUserResult^ CreateUser(
    CreateUserRequest^ request
)
abstract CreateUser :
        request : CreateUserRequest -> CreateUserResult
override CreateUser :
        request : CreateUserRequest -> CreateUserResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersCreateUserRequest
The request

Return Value

Type: CreateUserResult
An object of type CreateUserResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.DeleteCustomer Method

CustomerServiceProviderDeleteCustomer Method
The delete customer.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual DeleteCustomerResult DeleteCustomer(
    DeleteCustomerRequest request
)
Public Overridable Function DeleteCustomer (
    request As DeleteCustomerRequest
) As DeleteCustomerResult
public:
virtual DeleteCustomerResult^ DeleteCustomer(
    DeleteCustomerRequest^ request
)
abstract DeleteCustomer :
        request : DeleteCustomerRequest -> DeleteCustomerResult
override DeleteCustomer :
        request : DeleteCustomerRequest -> DeleteCustomerResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersDeleteCustomerRequest
The request.

Return Value

Type: DeleteCustomerResult
An object of type DeleteCustomerResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.DeleteUser Method

CustomerServiceProviderDeleteUser Method
Deletes the user.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual DeleteUserResult DeleteUser(
    DeleteUserRequest request
)
Public Overridable Function DeleteUser (
    request As DeleteUserRequest
) As DeleteUserResult
public:
virtual DeleteUserResult^ DeleteUser(
    DeleteUserRequest^ request
)
abstract DeleteUser :
        request : DeleteUserRequest -> DeleteUserResult
override DeleteUser :
        request : DeleteUserRequest -> DeleteUserResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersDeleteUserRequest
The request

Return Value

Type: DeleteUserResult
An object of type DeleteUserResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.DisableCustomer Method

CustomerServiceProviderDisableCustomer Method
Disables the customer.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual DisableCustomerResult DisableCustomer(
    DisableCustomerRequest request
)
Public Overridable Function DisableCustomer (
    request As DisableCustomerRequest
) As DisableCustomerResult
public:
virtual DisableCustomerResult^ DisableCustomer(
    DisableCustomerRequest^ request
)
abstract DisableCustomer :
        request : DisableCustomerRequest -> DisableCustomerResult
override DisableCustomer :
        request : DisableCustomerRequest -> DisableCustomerResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersDisableCustomerRequest
The request

Return Value

Type: DisableCustomerResult
An object of type DisableCustomerResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.DisableUser Method

CustomerServiceProviderDisableUser Method
Disables the user.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual DisableUserResult DisableUser(
    DisableUserRequest request
)
Public Overridable Function DisableUser (
    request As DisableUserRequest
) As DisableUserResult
public:
virtual DisableUserResult^ DisableUser(
    DisableUserRequest^ request
)
abstract DisableUser :
        request : DisableUserRequest -> DisableUserResult
override DisableUser :
        request : DisableUserRequest -> DisableUserResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersDisableUserRequest
The request

Return Value

Type: DisableUserResult
An object of type DisableUserResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.EnableCustomer Method

CustomerServiceProviderEnableCustomer Method
Enables the customer.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual EnableCustomerResult EnableCustomer(
    EnableCustomerRequest request
)
Public Overridable Function EnableCustomer (
    request As EnableCustomerRequest
) As EnableCustomerResult
public:
virtual EnableCustomerResult^ EnableCustomer(
    EnableCustomerRequest^ request
)
abstract EnableCustomer :
        request : EnableCustomerRequest -> EnableCustomerResult
override EnableCustomer :
        request : EnableCustomerRequest -> EnableCustomerResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersEnableCustomerRequest
The request

Return Value

Type: EnableCustomerResult
An object of type EnableCustomerResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.EnableUser Method

CustomerServiceProviderEnableUser Method
Enables the user.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual EnableUserResult EnableUser(
    EnableUserRequest request
)
Public Overridable Function EnableUser (
    request As EnableUserRequest
) As EnableUserResult
public:
virtual EnableUserResult^ EnableUser(
    EnableUserRequest^ request
)
abstract EnableUser :
        request : EnableUserRequest -> EnableUserResult
override EnableUser :
        request : EnableUserRequest -> EnableUserResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersEnableUserRequest
The request

Return Value

Type: EnableUserResult
An object of type EnableUserResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.GetCustomer Method

CustomerServiceProviderGetCustomer Method
The get customer.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetCustomerResult GetCustomer(
    GetCustomerRequest request
)
Public Overridable Function GetCustomer (
    request As GetCustomerRequest
) As GetCustomerResult
public:
virtual GetCustomerResult^ GetCustomer(
    GetCustomerRequest^ request
)
abstract GetCustomer :
        request : GetCustomerRequest -> GetCustomerResult
override GetCustomer :
        request : GetCustomerRequest -> GetCustomerResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersGetCustomerRequest
The request.

Return Value

Type: GetCustomerResult
An object of type GetCustomerResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.GetCustomers Method

CustomerServiceProviderGetCustomers Method
The get customers.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetCustomersResult GetCustomers(
    GetCustomersRequest request
)
Public Overridable Function GetCustomers (
    request As GetCustomersRequest
) As GetCustomersResult
public:
virtual GetCustomersResult^ GetCustomers(
    GetCustomersRequest^ request
)
abstract GetCustomers :
        request : GetCustomersRequest -> GetCustomersResult
override GetCustomers :
        request : GetCustomersRequest -> GetCustomersResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersGetCustomersRequest
The request.

Return Value

Type: GetCustomersResult
An object of type GetCustomersResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.GetParties Method

CustomerServiceProviderGetParties Method
Gets the parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetPartiesResult GetParties(
    GetPartiesRequest request
)
Public Overridable Function GetParties (
    request As GetPartiesRequest
) As GetPartiesResult
public:
virtual GetPartiesResult^ GetParties(
    GetPartiesRequest^ request
)
abstract GetParties :
        request : GetPartiesRequest -> GetPartiesResult
override GetParties :
        request : GetPartiesRequest -> GetPartiesResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersGetPartiesRequest
The request.

Return Value

Type: GetPartiesResult
An object of type GetPartiesResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.GetUser Method

CustomerServiceProviderGetUser Method
Gets the user.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetUserResult GetUser(
    GetUserRequest request
)
Public Overridable Function GetUser (
    request As GetUserRequest
) As GetUserResult
public:
virtual GetUserResult^ GetUser(
    GetUserRequest^ request
)
abstract GetUser :
        request : GetUserRequest -> GetUserResult
override GetUser :
        request : GetUserRequest -> GetUserResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersGetUserRequest
The request.

Return Value

Type: GetUserResult
An object of type GetUserResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.GetUsers Method

CustomerServiceProviderGetUsers Method
Gets the users.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetUsersResult GetUsers(
    GetUsersRequest request
)
Public Overridable Function GetUsers (
    request As GetUsersRequest
) As GetUsersResult
public:
virtual GetUsersResult^ GetUsers(
    GetUsersRequest^ request
)
abstract GetUsers :
        request : GetUsersRequest -> GetUsersResult
override GetUsers :
        request : GetUsersRequest -> GetUsersResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersGetUsersRequest
The request.

Return Value

Type: GetUsersResult
An object of type GetUsersResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.RemoveCustomerParties Method

CustomerServiceProviderRemoveCustomerParties Method
Removes the customer parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CustomerPartiesResult RemoveCustomerParties(
    RemoveCustomerPartiesRequest request
)
Public Overridable Function RemoveCustomerParties (
    request As RemoveCustomerPartiesRequest
) As CustomerPartiesResult
public:
virtual CustomerPartiesResult^ RemoveCustomerParties(
    RemoveCustomerPartiesRequest^ request
)
abstract RemoveCustomerParties :
        request : RemoveCustomerPartiesRequest -> CustomerPartiesResult
override RemoveCustomerParties :
        request : RemoveCustomerPartiesRequest -> CustomerPartiesResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersRemoveCustomerPartiesRequest
The request.

Return Value

Type: CustomerPartiesResult
An object of type CustomerPartiesResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.RemoveCustomers Method

CustomerServiceProviderRemoveCustomers Method
The remove customers.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual RemoveCustomersResult RemoveCustomers(
    RemoveCustomersRequest request
)
Public Overridable Function RemoveCustomers (
    request As RemoveCustomersRequest
) As RemoveCustomersResult
public:
virtual RemoveCustomersResult^ RemoveCustomers(
    RemoveCustomersRequest^ request
)
abstract RemoveCustomers :
        request : RemoveCustomersRequest -> RemoveCustomersResult
override RemoveCustomers :
        request : RemoveCustomersRequest -> RemoveCustomersResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersRemoveCustomersRequest
The request.

Return Value

Type: RemoveCustomersResult
An object of type RemoveCustomersResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.RemoveParties Method

CustomerServiceProviderRemoveParties Method
Removes the parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CustomerResult RemoveParties(
    RemovePartiesRequest request
)
Public Overridable Function RemoveParties (
    request As RemovePartiesRequest
) As CustomerResult
public:
virtual CustomerResult^ RemoveParties(
    RemovePartiesRequest^ request
)
abstract RemoveParties :
        request : RemovePartiesRequest -> CustomerResult
override RemoveParties :
        request : RemovePartiesRequest -> CustomerResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersRemovePartiesRequest
The request.

Return Value

Type: CustomerResult
An object of type CustomerResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.RemoveUsers Method

CustomerServiceProviderRemoveUsers Method
The remove users.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual RemoveUsersResult RemoveUsers(
    RemoveUsersRequest request
)
Public Overridable Function RemoveUsers (
    request As RemoveUsersRequest
) As RemoveUsersResult
public:
virtual RemoveUsersResult^ RemoveUsers(
    RemoveUsersRequest^ request
)
abstract RemoveUsers :
        request : RemoveUsersRequest -> RemoveUsersResult
override RemoveUsers :
        request : RemoveUsersRequest -> RemoveUsersResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersRemoveUsersRequest
The request.

Return Value

Type: RemoveUsersResult
An object of type RemoveUsersResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.UpdateCustomer Method

CustomerServiceProviderUpdateCustomer Method
Updates the customer.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual UpdateCustomerResult UpdateCustomer(
    UpdateCustomerRequest request
)
Public Overridable Function UpdateCustomer (
    request As UpdateCustomerRequest
) As UpdateCustomerResult
public:
virtual UpdateCustomerResult^ UpdateCustomer(
    UpdateCustomerRequest^ request
)
abstract UpdateCustomer :
        request : UpdateCustomerRequest -> UpdateCustomerResult
override UpdateCustomer :
        request : UpdateCustomerRequest -> UpdateCustomerResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersUpdateCustomerRequest
The request

Return Value

Type: UpdateCustomerResult
An object of type UpdateCustomerResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.UpdateCustomerParties Method

CustomerServiceProviderUpdateCustomerParties Method
Updates the customer parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CustomerPartiesResult UpdateCustomerParties(
    UpdateCustomerPartiesRequest request
)
Public Overridable Function UpdateCustomerParties (
    request As UpdateCustomerPartiesRequest
) As CustomerPartiesResult
public:
virtual CustomerPartiesResult^ UpdateCustomerParties(
    UpdateCustomerPartiesRequest^ request
)
abstract UpdateCustomerParties :
        request : UpdateCustomerPartiesRequest -> CustomerPartiesResult
override UpdateCustomerParties :
        request : UpdateCustomerPartiesRequest -> CustomerPartiesResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersUpdateCustomerPartiesRequest
The request.

Return Value

Type: CustomerPartiesResult
An object of type CustomerPartiesResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.UpdateParties Method

CustomerServiceProviderUpdateParties Method
Updates the parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual CustomerResult UpdateParties(
    UpdatePartiesRequest request
)
Public Overridable Function UpdateParties (
    request As UpdatePartiesRequest
) As CustomerResult
public:
virtual CustomerResult^ UpdateParties(
    UpdatePartiesRequest^ request
)
abstract UpdateParties :
        request : UpdatePartiesRequest -> CustomerResult
override UpdateParties :
        request : UpdatePartiesRequest -> CustomerResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersUpdatePartiesRequest
The request.

Return Value

Type: CustomerResult
An object of type CustomerResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.UpdatePassword Method

CustomerServiceProviderUpdatePassword Method
Updates user password.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual UpdatePasswordResult UpdatePassword(
    UpdatePasswordRequest request
)
Public Overridable Function UpdatePassword (
    request As UpdatePasswordRequest
) As UpdatePasswordResult
public:
virtual UpdatePasswordResult^ UpdatePassword(
    UpdatePasswordRequest^ request
)
abstract UpdatePassword :
        request : UpdatePasswordRequest -> UpdatePasswordResult
override UpdatePassword :
        request : UpdatePasswordRequest -> UpdatePasswordResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersUpdatePasswordRequest
The request.

Return Value

Type: UpdatePasswordResult
An object of type UpdatePasswordResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider.UpdateUser Method

CustomerServiceProviderUpdateUser Method
Updates the user.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual UpdateUserResult UpdateUser(
    UpdateUserRequest request
)
Public Overridable Function UpdateUser (
    request As UpdateUserRequest
) As UpdateUserResult
public:
virtual UpdateUserResult^ UpdateUser(
    UpdateUserRequest^ request
)
abstract UpdateUser :
        request : UpdateUserRequest -> UpdateUserResult
override UpdateUser :
        request : UpdateUserRequest -> UpdateUserResult

Parameters

request
Type: Sitecore.Commerce.Services.CustomersUpdateUserRequest
The request

Return Value

Type: UpdateUserResult
An object of type UpdateUserResult
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


CustomerServiceProvider Properties

CustomerServiceProvider Properties

The CustomerServiceProvider type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from ServiceProvider.)
Top
See Also

Reference

CustomerServiceProvider Class
Sitecore.Commerce.Services.Customers Namespace


DeleteCustomerRequest Class

DeleteCustomerRequest Class
The delete customer request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersDeleteCustomerRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DeleteCustomerRequest : CustomerRequestWithCustomer
Public Class DeleteCustomerRequest
    Inherits CustomerRequestWithCustomer
public ref class DeleteCustomerRequest : public CustomerRequestWithCustomer
type DeleteCustomerRequest =
    class
        inherit CustomerRequestWithCustomer
    end

The DeleteCustomerRequest type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteCustomerRequest | Initializes a new instance of the DeleteCustomerRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


DeleteCustomerRequest Constructor

DeleteCustomerRequest Constructor
Initializes a new instance of the DeleteCustomerRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DeleteCustomerRequest(
    CommerceCustomer commerceCustomer
)
Public Sub New (
    commerceCustomer As CommerceCustomer
)
public:
DeleteCustomerRequest(
    CommerceCustomer^ commerceCustomer
)
new :
        commerceCustomer : CommerceCustomer -> DeleteCustomerRequest

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The commerce customer.
See Also

Reference

DeleteCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


DeleteCustomerRequest Methods

DeleteCustomerRequest Methods

The DeleteCustomerRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


DeleteCustomerRequest Properties

DeleteCustomerRequest Properties

The DeleteCustomerRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

DeleteCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


DeleteCustomerResult Class

DeleteCustomerResult Class
The delete customer result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerResult
Sitecore.Commerce.Services.CustomersDeleteCustomerResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DeleteCustomerResult : CustomerResult
Public Class DeleteCustomerResult
    Inherits CustomerResult
public ref class DeleteCustomerResult : public CustomerResult
type DeleteCustomerResult =
    class
        inherit CustomerResult
    end

The DeleteCustomerResult type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteCustomerResult | Initializes a new instance of the DeleteCustomerResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


DeleteCustomerResult Constructor

DeleteCustomerResult Constructor
Initializes a new instance of the DeleteCustomerResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DeleteCustomerResult()
Public Sub New
public:
DeleteCustomerResult()
new : unit -> DeleteCustomerResult
See Also

Reference

DeleteCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


DeleteCustomerResult Methods

DeleteCustomerResult Methods

The DeleteCustomerResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


DeleteCustomerResult Properties

DeleteCustomerResult Properties

The DeleteCustomerResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

DeleteCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


DeleteUserRequest Class

DeleteUserRequest Class
The delete user request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersUserRequest
Sitecore.Commerce.Services.CustomersUserRequestWithUser
Sitecore.Commerce.Services.CustomersDeleteUserRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DeleteUserRequest : UserRequestWithUser
Public Class DeleteUserRequest
    Inherits UserRequestWithUser
public ref class DeleteUserRequest : public UserRequestWithUser
type DeleteUserRequest =
    class
        inherit UserRequestWithUser
    end

The DeleteUserRequest type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteUserRequest | Initializes a new instance of the DeleteUserRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceUser | Gets the commerce user. (Inherited from UserRequestWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


DeleteUserRequest Constructor

DeleteUserRequest Constructor
Initializes a new instance of the DeleteUserRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DeleteUserRequest(
    CommerceUser commerceUser
)
Public Sub New (
    commerceUser As CommerceUser
)
public:
DeleteUserRequest(
    CommerceUser^ commerceUser
)
new :
        commerceUser : CommerceUser -> DeleteUserRequest

Parameters

commerceUser
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The commerce user.
See Also

Reference

DeleteUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


DeleteUserRequest Methods

DeleteUserRequest Methods

The DeleteUserRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


DeleteUserRequest Properties

DeleteUserRequest Properties

The DeleteUserRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceUser | Gets the commerce user. (Inherited from UserRequestWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

DeleteUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


DeleteUserResult Class

DeleteUserResult Class
The delete user result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersUserResult
Sitecore.Commerce.Services.CustomersDeleteUserResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DeleteUserResult : UserResult
Public Class DeleteUserResult
    Inherits UserResult
public ref class DeleteUserResult : public UserResult
type DeleteUserResult =
    class
        inherit UserResult
    end

The DeleteUserResult type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteUserResult | Initializes a new instance of the DeleteUserResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


DeleteUserResult Constructor

DeleteUserResult Constructor
Initializes a new instance of the DeleteUserResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DeleteUserResult()
Public Sub New
public:
DeleteUserResult()
new : unit -> DeleteUserResult
See Also

Reference

DeleteUserResult Class
Sitecore.Commerce.Services.Customers Namespace


DeleteUserResult Methods

DeleteUserResult Methods

The DeleteUserResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteUserResult Class
Sitecore.Commerce.Services.Customers Namespace


DeleteUserResult Properties

DeleteUserResult Properties

The DeleteUserResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

DeleteUserResult Class
Sitecore.Commerce.Services.Customers Namespace


DisableCustomerRequest Class

DisableCustomerRequest Class
The disable customer request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersDisableCustomerRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DisableCustomerRequest : CustomerRequestWithCustomer
Public Class DisableCustomerRequest
    Inherits CustomerRequestWithCustomer
public ref class DisableCustomerRequest : public CustomerRequestWithCustomer
type DisableCustomerRequest =
    class
        inherit CustomerRequestWithCustomer
    end

The DisableCustomerRequest type exposes the following members.

Constructors
 | Name | Description
Public method | DisableCustomerRequest | Initializes a new instance of the DisableCustomerRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Comment | Gets or sets the comment.
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


DisableCustomerRequest Constructor

DisableCustomerRequest Constructor
Initializes a new instance of the DisableCustomerRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DisableCustomerRequest(
    CommerceCustomer commerceCustomer
)
Public Sub New (
    commerceCustomer As CommerceCustomer
)
public:
DisableCustomerRequest(
    CommerceCustomer^ commerceCustomer
)
new :
        commerceCustomer : CommerceCustomer -> DisableCustomerRequest

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The commerce customer.
See Also

Reference

DisableCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


DisableCustomerRequest Methods

DisableCustomerRequest Methods

The DisableCustomerRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisableCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


DisableCustomerRequest Properties

DisableCustomerRequest Properties

The DisableCustomerRequest type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or sets the comment.
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

DisableCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


DisableCustomerRequest.Comment Property

DisableCustomerRequestComment Property
Gets or sets the comment.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
member Comment : string with get, set

Property Value

Type: String
See Also

Reference

DisableCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


DisableCustomerResult Class

DisableCustomerResult Class
The disable customer result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerResult
Sitecore.Commerce.Services.CustomersCustomerResultWithCart
Sitecore.Commerce.Services.CustomersDisableCustomerResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DisableCustomerResult : CustomerResultWithCart
Public Class DisableCustomerResult
    Inherits CustomerResultWithCart
public ref class DisableCustomerResult : public CustomerResultWithCart
type DisableCustomerResult =
    class
        inherit CustomerResultWithCart
    end

The DisableCustomerResult type exposes the following members.

Constructors
 | Name | Description
Public method | DisableCustomerResult | Initializes a new instance of the DisableCustomerResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce customer. (Inherited from CustomerResultWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


DisableCustomerResult Constructor

DisableCustomerResult Constructor
Initializes a new instance of the DisableCustomerResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DisableCustomerResult()
Public Sub New
public:
DisableCustomerResult()
new : unit -> DisableCustomerResult
See Also

Reference

DisableCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


DisableCustomerResult Methods

DisableCustomerResult Methods

The DisableCustomerResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisableCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


DisableCustomerResult Properties

DisableCustomerResult Properties

The DisableCustomerResult type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce customer. (Inherited from CustomerResultWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

DisableCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


DisableUserRequest Class

DisableUserRequest Class
The disable user request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersUserRequest
Sitecore.Commerce.Services.CustomersUserRequestWithUser
Sitecore.Commerce.Services.CustomersDisableUserRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DisableUserRequest : UserRequestWithUser
Public Class DisableUserRequest
    Inherits UserRequestWithUser
public ref class DisableUserRequest : public UserRequestWithUser
type DisableUserRequest =
    class
        inherit UserRequestWithUser
    end

The DisableUserRequest type exposes the following members.

Constructors
 | Name | Description
Public method | DisableUserRequest | Initializes a new instance of the DisableUserRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Comment | Gets or sets the comment.
Public property | CommerceUser | Gets the commerce user. (Inherited from UserRequestWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


DisableUserRequest Constructor

DisableUserRequest Constructor
Initializes a new instance of the DisableUserRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DisableUserRequest(
    CommerceUser commerceUser
)
Public Sub New (
    commerceUser As CommerceUser
)
public:
DisableUserRequest(
    CommerceUser^ commerceUser
)
new :
        commerceUser : CommerceUser -> DisableUserRequest

Parameters

commerceUser
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The commerce user.
See Also

Reference

DisableUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


DisableUserRequest Methods

DisableUserRequest Methods

The DisableUserRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisableUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


DisableUserRequest Properties

DisableUserRequest Properties

The DisableUserRequest type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or sets the comment.
Public property | CommerceUser | Gets the commerce user. (Inherited from UserRequestWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

DisableUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


DisableUserRequest.Comment Property

DisableUserRequestComment Property
Gets or sets the comment.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
member Comment : string with get, set

Property Value

Type: String
See Also

Reference

DisableUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


DisableUserResult Class

DisableUserResult Class
The disable user result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersUserResult
Sitecore.Commerce.Services.CustomersUserResultWithUser
Sitecore.Commerce.Services.CustomersDisableUserResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class DisableUserResult : UserResultWithUser
Public Class DisableUserResult
    Inherits UserResultWithUser
public ref class DisableUserResult : public UserResultWithUser
type DisableUserResult =
    class
        inherit UserResultWithUser
    end

The DisableUserResult type exposes the following members.

Constructors
 | Name | Description
Public method | DisableUserResult | Initializes a new instance of the DisableUserResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceUser | Gets or sets the commerce user. (Inherited from UserResultWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


DisableUserResult Constructor

DisableUserResult Constructor
Initializes a new instance of the DisableUserResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DisableUserResult()
Public Sub New
public:
DisableUserResult()
new : unit -> DisableUserResult
See Also

Reference

DisableUserResult Class
Sitecore.Commerce.Services.Customers Namespace


DisableUserResult Methods

DisableUserResult Methods

The DisableUserResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisableUserResult Class
Sitecore.Commerce.Services.Customers Namespace


DisableUserResult Properties

DisableUserResult Properties

The DisableUserResult type exposes the following members.

Properties
 | Name | Description
Public property | CommerceUser | Gets or sets the commerce user. (Inherited from UserResultWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

DisableUserResult Class
Sitecore.Commerce.Services.Customers Namespace


EnableCustomerRequest Class

EnableCustomerRequest Class
The enable customer request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersEnableCustomerRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EnableCustomerRequest : CustomerRequestWithCustomer
Public Class EnableCustomerRequest
    Inherits CustomerRequestWithCustomer
public ref class EnableCustomerRequest : public CustomerRequestWithCustomer
type EnableCustomerRequest =
    class
        inherit CustomerRequestWithCustomer
    end

The EnableCustomerRequest type exposes the following members.

Constructors
 | Name | Description
Public method | EnableCustomerRequest | Initializes a new instance of the EnableCustomerRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Comment | Gets or sets the comment.
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


EnableCustomerRequest Constructor

EnableCustomerRequest Constructor
Initializes a new instance of the EnableCustomerRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EnableCustomerRequest(
    CommerceCustomer commerceCustomer
)
Public Sub New (
    commerceCustomer As CommerceCustomer
)
public:
EnableCustomerRequest(
    CommerceCustomer^ commerceCustomer
)
new :
        commerceCustomer : CommerceCustomer -> EnableCustomerRequest

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The commerce customer.
See Also

Reference

EnableCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


EnableCustomerRequest Methods

EnableCustomerRequest Methods

The EnableCustomerRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EnableCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


EnableCustomerRequest Properties

EnableCustomerRequest Properties

The EnableCustomerRequest type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or sets the comment.
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

EnableCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


EnableCustomerRequest.Comment Property

EnableCustomerRequestComment Property
Gets or sets the comment.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
member Comment : string with get, set

Property Value

Type: String
See Also

Reference

EnableCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


EnableCustomerResult Class

EnableCustomerResult Class
The enable customer result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerResult
Sitecore.Commerce.Services.CustomersCustomerResultWithCart
Sitecore.Commerce.Services.CustomersEnableCustomerResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EnableCustomerResult : CustomerResultWithCart
Public Class EnableCustomerResult
    Inherits CustomerResultWithCart
public ref class EnableCustomerResult : public CustomerResultWithCart
type EnableCustomerResult =
    class
        inherit CustomerResultWithCart
    end

The EnableCustomerResult type exposes the following members.

Constructors
 | Name | Description
Public method | EnableCustomerResult | Initializes a new instance of the EnableCustomerResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce customer. (Inherited from CustomerResultWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


EnableCustomerResult Constructor

EnableCustomerResult Constructor
Initializes a new instance of the EnableCustomerResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EnableCustomerResult()
Public Sub New
public:
EnableCustomerResult()
new : unit -> EnableCustomerResult
See Also

Reference

EnableCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


EnableCustomerResult Methods

EnableCustomerResult Methods

The EnableCustomerResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EnableCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


EnableCustomerResult Properties

EnableCustomerResult Properties

The EnableCustomerResult type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce customer. (Inherited from CustomerResultWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

EnableCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


EnableUserRequest Class

EnableUserRequest Class
The enable user request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersUserRequest
Sitecore.Commerce.Services.CustomersUserRequestWithUser
Sitecore.Commerce.Services.CustomersEnableUserRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EnableUserRequest : UserRequestWithUser
Public Class EnableUserRequest
    Inherits UserRequestWithUser
public ref class EnableUserRequest : public UserRequestWithUser
type EnableUserRequest =
    class
        inherit UserRequestWithUser
    end

The EnableUserRequest type exposes the following members.

Constructors
 | Name | Description
Public method | EnableUserRequest | Initializes a new instance of the EnableUserRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Comment | Gets or sets the comment.
Public property | CommerceUser | Gets the commerce user. (Inherited from UserRequestWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


EnableUserRequest Constructor

EnableUserRequest Constructor
Initializes a new instance of the EnableUserRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EnableUserRequest(
    CommerceUser commerceUser
)
Public Sub New (
    commerceUser As CommerceUser
)
public:
EnableUserRequest(
    CommerceUser^ commerceUser
)
new :
        commerceUser : CommerceUser -> EnableUserRequest

Parameters

commerceUser
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The commerce user.
See Also

Reference

EnableUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


EnableUserRequest Methods

EnableUserRequest Methods

The EnableUserRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EnableUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


EnableUserRequest Properties

EnableUserRequest Properties

The EnableUserRequest type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or sets the comment.
Public property | CommerceUser | Gets the commerce user. (Inherited from UserRequestWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

EnableUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


EnableUserRequest.Comment Property

EnableUserRequestComment Property
Gets or sets the comment.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
member Comment : string with get, set

Property Value

Type: String
See Also

Reference

EnableUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


EnableUserResult Class

EnableUserResult Class
The enable user result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersUserResult
Sitecore.Commerce.Services.CustomersUserResultWithUser
Sitecore.Commerce.Services.CustomersEnableUserResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class EnableUserResult : UserResultWithUser
Public Class EnableUserResult
    Inherits UserResultWithUser
public ref class EnableUserResult : public UserResultWithUser
type EnableUserResult =
    class
        inherit UserResultWithUser
    end

The EnableUserResult type exposes the following members.

Constructors
 | Name | Description
Public method | EnableUserResult | Initializes a new instance of the EnableUserResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceUser | Gets or sets the commerce user. (Inherited from UserResultWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


EnableUserResult Constructor

EnableUserResult Constructor
Initializes a new instance of the EnableUserResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EnableUserResult()
Public Sub New
public:
EnableUserResult()
new : unit -> EnableUserResult
See Also

Reference

EnableUserResult Class
Sitecore.Commerce.Services.Customers Namespace


EnableUserResult Methods

EnableUserResult Methods

The EnableUserResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EnableUserResult Class
Sitecore.Commerce.Services.Customers Namespace


EnableUserResult Properties

EnableUserResult Properties

The EnableUserResult type exposes the following members.

Properties
 | Name | Description
Public property | CommerceUser | Gets or sets the commerce user. (Inherited from UserResultWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

EnableUserResult Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomerRequest Class

GetCustomerRequest Class
The get customer request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersGetCustomerRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetCustomerRequest : CustomerRequest
Public Class GetCustomerRequest
    Inherits CustomerRequest
public ref class GetCustomerRequest : public CustomerRequest
type GetCustomerRequest =
    class
        inherit CustomerRequest
    end

The GetCustomerRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetCustomerRequest | Initializes a new instance of the GetCustomerRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ExternalId | Gets or sets the External Id.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


GetCustomerRequest Constructor

GetCustomerRequest Constructor
Initializes a new instance of the GetCustomerRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetCustomerRequest(
    string externalId
)
Public Sub New (
    externalId As String
)
public:
GetCustomerRequest(
    String^ externalId
)
new :
        externalId : string -> GetCustomerRequest

Parameters

externalId
Type: SystemString
The externalId for the requested customer.
See Also

Reference

GetCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomerRequest Methods

GetCustomerRequest Methods

The GetCustomerRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomerRequest Properties

GetCustomerRequest Properties

The GetCustomerRequest type exposes the following members.

Properties
 | Name | Description
Public property | ExternalId | Gets or sets the External Id.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

GetCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomerRequest.ExternalId Property

GetCustomerRequestExternalId Property
Gets or sets the External Id.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ExternalId { get; set; }
Public Property ExternalId As String
    Get
    Set
public:
property String^ ExternalId {
    String^ get ();
    void set (String^ value);
}
member ExternalId : string with get, set

Property Value

Type: String
The external id of the customer.
See Also

Reference

GetCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomerResult Class

GetCustomerResult Class
The get customers result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerResult
Sitecore.Commerce.Services.CustomersGetCustomerResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetCustomerResult : CustomerResult
Public Class GetCustomerResult
    Inherits CustomerResult
public ref class GetCustomerResult : public CustomerResult
type GetCustomerResult =
    class
        inherit CustomerResult
    end

The GetCustomerResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetCustomerResult | Initializes a new instance of the GetCustomerResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce customer.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


GetCustomerResult Constructor

GetCustomerResult Constructor
Initializes a new instance of the GetCustomerResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetCustomerResult()
Public Sub New
public:
GetCustomerResult()
new : unit -> GetCustomerResult
See Also

Reference

GetCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomerResult Methods

GetCustomerResult Methods

The GetCustomerResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomerResult Properties

GetCustomerResult Properties

The GetCustomerResult type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce customer.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomerResult.CommerceCustomer Property

GetCustomerResultCommerceCustomer Property
Gets or sets the commerce customer.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CommerceCustomer CommerceCustomer { get; set; }
Public Property CommerceCustomer As CommerceCustomer
    Get
    Set
public:
property CommerceCustomer^ CommerceCustomer {
    CommerceCustomer^ get ();
    void set (CommerceCustomer^ value);
}
member CommerceCustomer : CommerceCustomer with get, set

Property Value

Type: CommerceCustomer
See Also

Reference

GetCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomersRequest Class

GetCustomersRequest Class
The get customers request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersGetCustomersRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetCustomersRequest : CustomerRequest
Public Class GetCustomersRequest
    Inherits CustomerRequest
public ref class GetCustomersRequest : public CustomerRequest
type GetCustomersRequest =
    class
        inherit CustomerRequest
    end

The GetCustomersRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetCustomersRequest | Initializes a new instance of the GetCustomersRequest class.
Public method | GetCustomersRequest(CustomerSearchCriteria) | Initializes a new instance of the GetCustomersRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerSearchCriteria | Gets or sets the search users.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


GetCustomersRequest Constructor

GetCustomersRequest Constructor
Overload List
 | Name | Description
Public method | GetCustomersRequest | Initializes a new instance of the GetCustomersRequest class.
Public method | GetCustomersRequest(CustomerSearchCriteria) | Initializes a new instance of the GetCustomersRequest class.
Top
See Also

Reference

GetCustomersRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomersRequest Constructor

GetCustomersRequest Constructor
Initializes a new instance of the GetCustomersRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetCustomersRequest()
Public Sub New
public:
GetCustomersRequest()
new : unit -> GetCustomersRequest
See Also

Reference

GetCustomersRequest Class
GetCustomersRequest Overload
Sitecore.Commerce.Services.Customers Namespace


GetCustomersRequest Constructor (CustomerSearchCriteria)

GetCustomersRequest Constructor (CustomerSearchCriteria)
Initializes a new instance of the GetCustomersRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetCustomersRequest(
    CustomerSearchCriteria customerSearchCriteria
)
Public Sub New (
    customerSearchCriteria As CustomerSearchCriteria
)
public:
GetCustomersRequest(
    CustomerSearchCriteria^ customerSearchCriteria
)
new :
        customerSearchCriteria : CustomerSearchCriteria -> GetCustomersRequest

Parameters

customerSearchCriteria
Type: Sitecore.Commerce.Services.CustomersCustomerSearchCriteria
The search criteria for users.
See Also

Reference

GetCustomersRequest Class
GetCustomersRequest Overload
Sitecore.Commerce.Services.Customers Namespace


GetCustomersRequest Methods

GetCustomersRequest Methods

The GetCustomersRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetCustomersRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomersRequest Properties

GetCustomersRequest Properties

The GetCustomersRequest type exposes the following members.

Properties
 | Name | Description
Public property | CustomerSearchCriteria | Gets or sets the search users.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

GetCustomersRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomersRequest.CustomerSearchCriteria Property

GetCustomersRequestCustomerSearchCriteria Property
Gets or sets the search users.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CustomerSearchCriteria CustomerSearchCriteria { get; set; }
Public Property CustomerSearchCriteria As CustomerSearchCriteria
    Get
    Set
public:
property CustomerSearchCriteria^ CustomerSearchCriteria {
    CustomerSearchCriteria^ get ();
    void set (CustomerSearchCriteria^ value);
}
member CustomerSearchCriteria : CustomerSearchCriteria with get, set

Property Value

Type: CustomerSearchCriteria
The search users.
See Also

Reference

GetCustomersRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomersResult Class

GetCustomersResult Class
The get customers result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerResult
Sitecore.Commerce.Services.CustomersGetCustomersResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetCustomersResult : CustomerResult
Public Class GetCustomersResult
    Inherits CustomerResult
public ref class GetCustomersResult : public CustomerResult
type GetCustomersResult =
    class
        inherit CustomerResult
    end

The GetCustomersResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetCustomersResult | Initializes a new instance of the GetCustomersResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomers | Gets the commerce users.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


GetCustomersResult Constructor

GetCustomersResult Constructor
Initializes a new instance of the GetCustomersResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetCustomersResult()
Public Sub New
public:
GetCustomersResult()
new : unit -> GetCustomersResult
See Also

Reference

GetCustomersResult Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomersResult Methods

GetCustomersResult Methods

The GetCustomersResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetCustomersResult Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomersResult Properties

GetCustomersResult Properties

The GetCustomersResult type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomers | Gets the commerce users.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetCustomersResult Class
Sitecore.Commerce.Services.Customers Namespace


GetCustomersResult.CommerceCustomers Property

GetCustomersResultCommerceCustomers Property
Gets the commerce users.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ICollection<CommerceCustomer> CommerceCustomers { get; }
Public ReadOnly Property CommerceCustomers As ICollection(Of CommerceCustomer)
    Get
public:
property ICollection<CommerceCustomer^>^ CommerceCustomers {
    ICollection<CommerceCustomer^>^ get ();
}
member CommerceCustomers : ICollection<CommerceCustomer> with get

Property Value

Type: ICollection CommerceCustomer
The commerce users.
See Also

Reference

GetCustomersResult Class
Sitecore.Commerce.Services.Customers Namespace


GetPartiesRequest Class

GetPartiesRequest Class
Defines the GetPartiesRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersGetPartiesRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetPartiesRequest : CustomerRequestWithCustomer
Public Class GetPartiesRequest
    Inherits CustomerRequestWithCustomer
public ref class GetPartiesRequest : public CustomerRequestWithCustomer
type GetPartiesRequest =
    class
        inherit CustomerRequestWithCustomer
    end

The GetPartiesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetPartiesRequest | Initializes a new instance of the GetPartiesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


GetPartiesRequest Constructor

GetPartiesRequest Constructor
Initializes a new instance of the GetPartiesRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetPartiesRequest(
    CommerceCustomer commerceCustomer
)
Public Sub New (
    commerceCustomer As CommerceCustomer
)
public:
GetPartiesRequest(
    CommerceCustomer^ commerceCustomer
)
new :
        commerceCustomer : CommerceCustomer -> GetPartiesRequest

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
See Also

Reference

GetPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetPartiesRequest Methods

GetPartiesRequest Methods

The GetPartiesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetPartiesRequest Properties

GetPartiesRequest Properties

The GetPartiesRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

GetPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetPartiesResult Class

GetPartiesResult Class
Defines the GetPartiesResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerResult
Sitecore.Commerce.Services.CustomersGetPartiesResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetPartiesResult : CustomerResult
Public Class GetPartiesResult
    Inherits CustomerResult
public ref class GetPartiesResult : public CustomerResult
type GetPartiesResult =
    class
        inherit CustomerResult
    end

The GetPartiesResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetPartiesResult | Initializes a new instance of the GetPartiesResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


GetPartiesResult Constructor

GetPartiesResult Constructor
Initializes a new instance of the GetPartiesResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetPartiesResult()
Public Sub New
public:
GetPartiesResult()
new : unit -> GetPartiesResult
See Also

Reference

GetPartiesResult Class
Sitecore.Commerce.Services.Customers Namespace


GetPartiesResult Methods

GetPartiesResult Methods

The GetPartiesResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetPartiesResult Class
Sitecore.Commerce.Services.Customers Namespace


GetPartiesResult Properties

GetPartiesResult Properties

The GetPartiesResult type exposes the following members.

Properties
 | Name | Description
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetPartiesResult Class
Sitecore.Commerce.Services.Customers Namespace


GetPartiesResult.Parties Property

GetPartiesResultParties Property
Gets or sets the parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ICollection<Party> Parties { get; set; }
Public Property Parties As ICollection(Of Party)
    Get
    Set
public:
property ICollection<Party^>^ Parties {
    ICollection<Party^>^ get ();
    void set (ICollection<Party^>^ value);
}
member Parties : ICollection<Party> with get, set

Property Value

Type: ICollection Party
The parties.
See Also

Reference

GetPartiesResult Class
Sitecore.Commerce.Services.Customers Namespace


GetUserRequest Class

GetUserRequest Class
The get users request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersUserRequest
Sitecore.Commerce.Services.CustomersGetUserRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetUserRequest : UserRequest
Public Class GetUserRequest
    Inherits UserRequest
public ref class GetUserRequest : public UserRequest
type GetUserRequest =
    class
        inherit UserRequest
    end

The GetUserRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetUserRequest | Initializes a new instance of the GetUserRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UserName | Gets or sets the name of the user.
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


GetUserRequest Constructor

GetUserRequest Constructor
Initializes a new instance of the GetUserRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetUserRequest(
    string userName
)
Public Sub New (
    userName As String
)
public:
GetUserRequest(
    String^ userName
)
new :
        userName : string -> GetUserRequest

Parameters

userName
Type: SystemString
The userName of the requested user.
See Also

Reference

GetUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetUserRequest Methods

GetUserRequest Methods

The GetUserRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetUserRequest Properties

GetUserRequest Properties

The GetUserRequest type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UserName | Gets or sets the name of the user.
Top
See Also

Reference

GetUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetUserRequest.UserName Property

GetUserRequestUserName Property
Gets or sets the name of the user.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
The name of the user.
See Also

Reference

GetUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetUserResult Class

GetUserResult Class
The get user result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersUserResult
Sitecore.Commerce.Services.CustomersGetUserResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetUserResult : UserResult
Public Class GetUserResult
    Inherits UserResult
public ref class GetUserResult : public UserResult
type GetUserResult =
    class
        inherit UserResult
    end

The GetUserResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetUserResult | Initializes a new instance of the GetUserResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceUser | Gets or sets the commerce user.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


GetUserResult Constructor

GetUserResult Constructor
Initializes a new instance of the GetUserResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetUserResult()
Public Sub New
public:
GetUserResult()
new : unit -> GetUserResult
See Also

Reference

GetUserResult Class
Sitecore.Commerce.Services.Customers Namespace


GetUserResult Methods

GetUserResult Methods

The GetUserResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetUserResult Class
Sitecore.Commerce.Services.Customers Namespace


GetUserResult Properties

GetUserResult Properties

The GetUserResult type exposes the following members.

Properties
 | Name | Description
Public property | CommerceUser | Gets or sets the commerce user.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetUserResult Class
Sitecore.Commerce.Services.Customers Namespace


GetUserResult.CommerceUser Property

GetUserResultCommerceUser Property
Gets or sets the commerce user.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CommerceUser CommerceUser { get; set; }
Public Property CommerceUser As CommerceUser
    Get
    Set
public:
property CommerceUser^ CommerceUser {
    CommerceUser^ get ();
    void set (CommerceUser^ value);
}
member CommerceUser : CommerceUser with get, set

Property Value

Type: CommerceUser
See Also

Reference

GetUserResult Class
Sitecore.Commerce.Services.Customers Namespace


GetUsersRequest Class

GetUsersRequest Class
The get users request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersUserRequest
Sitecore.Commerce.Services.CustomersGetUsersRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetUsersRequest : UserRequest
Public Class GetUsersRequest
    Inherits UserRequest
public ref class GetUsersRequest : public UserRequest
type GetUsersRequest =
    class
        inherit UserRequest
    end

The GetUsersRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetUsersRequest | Initializes a new instance of the GetUsersRequest class.
Public method | GetUsersRequest(UserSearchCriteria) | Initializes a new instance of the GetUsersRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UserSearchCriteria | Gets or sets the search users.
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


GetUsersRequest Constructor

GetUsersRequest Constructor
Overload List
 | Name | Description
Public method | GetUsersRequest | Initializes a new instance of the GetUsersRequest class.
Public method | GetUsersRequest(UserSearchCriteria) | Initializes a new instance of the GetUsersRequest class.
Top
See Also

Reference

GetUsersRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetUsersRequest Constructor

GetUsersRequest Constructor
Initializes a new instance of the GetUsersRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetUsersRequest()
Public Sub New
public:
GetUsersRequest()
new : unit -> GetUsersRequest
See Also

Reference

GetUsersRequest Class
GetUsersRequest Overload
Sitecore.Commerce.Services.Customers Namespace


GetUsersRequest Constructor (UserSearchCriteria)

GetUsersRequest Constructor (UserSearchCriteria)
Initializes a new instance of the GetUsersRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetUsersRequest(
    UserSearchCriteria userSearchCriteria
)
Public Sub New (
    userSearchCriteria As UserSearchCriteria
)
public:
GetUsersRequest(
    UserSearchCriteria^ userSearchCriteria
)
new :
        userSearchCriteria : UserSearchCriteria -> GetUsersRequest

Parameters

userSearchCriteria
Type: Sitecore.Commerce.Services.CustomersUserSearchCriteria
The search criteria for users.
See Also

Reference

GetUsersRequest Class
GetUsersRequest Overload
Sitecore.Commerce.Services.Customers Namespace


GetUsersRequest Methods

GetUsersRequest Methods

The GetUsersRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetUsersRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetUsersRequest Properties

GetUsersRequest Properties

The GetUsersRequest type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UserSearchCriteria | Gets or sets the search users.
Top
See Also

Reference

GetUsersRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetUsersRequest.UserSearchCriteria Property

GetUsersRequestUserSearchCriteria Property
Gets or sets the search users.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UserSearchCriteria UserSearchCriteria { get; set; }
Public Property UserSearchCriteria As UserSearchCriteria
    Get
    Set
public:
property UserSearchCriteria^ UserSearchCriteria {
    UserSearchCriteria^ get ();
    void set (UserSearchCriteria^ value);
}
member UserSearchCriteria : UserSearchCriteria with get, set

Property Value

Type: UserSearchCriteria
The search users.
See Also

Reference

GetUsersRequest Class
Sitecore.Commerce.Services.Customers Namespace


GetUsersResult Class

GetUsersResult Class
The get users result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersUserResult
Sitecore.Commerce.Services.CustomersGetUsersResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetUsersResult : UserResult
Public Class GetUsersResult
    Inherits UserResult
public ref class GetUsersResult : public UserResult
type GetUsersResult =
    class
        inherit UserResult
    end

The GetUsersResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetUsersResult | Initializes a new instance of the GetUsersResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceUsers | Gets the commerce users.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


GetUsersResult Constructor

GetUsersResult Constructor
Initializes a new instance of the GetUsersResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetUsersResult()
Public Sub New
public:
GetUsersResult()
new : unit -> GetUsersResult
See Also

Reference

GetUsersResult Class
Sitecore.Commerce.Services.Customers Namespace


GetUsersResult Methods

GetUsersResult Methods

The GetUsersResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetUsersResult Class
Sitecore.Commerce.Services.Customers Namespace


GetUsersResult Properties

GetUsersResult Properties

The GetUsersResult type exposes the following members.

Properties
 | Name | Description
Public property | CommerceUsers | Gets the commerce users.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetUsersResult Class
Sitecore.Commerce.Services.Customers Namespace


GetUsersResult.CommerceUsers Property

GetUsersResultCommerceUsers Property
Gets the commerce users.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ICollection<CommerceUser> CommerceUsers { get; }
Public ReadOnly Property CommerceUsers As ICollection(Of CommerceUser)
    Get
public:
property ICollection<CommerceUser^>^ CommerceUsers {
    ICollection<CommerceUser^>^ get ();
}
member CommerceUsers : ICollection<CommerceUser> with get

Property Value

Type: ICollection CommerceUser
The commerce users.
See Also

Reference

GetUsersResult Class
Sitecore.Commerce.Services.Customers Namespace


RemoveCustomerPartiesRequest Class

RemoveCustomerPartiesRequest Class
Defines the RemoveCustomerPartiesRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersRemoveCustomerPartiesRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveCustomerPartiesRequest : CustomerRequestWithCustomer
Public Class RemoveCustomerPartiesRequest
    Inherits CustomerRequestWithCustomer
public ref class RemoveCustomerPartiesRequest : public CustomerRequestWithCustomer
type RemoveCustomerPartiesRequest =
    class
        inherit CustomerRequestWithCustomer
    end

The RemoveCustomerPartiesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveCustomerPartiesRequest | Initializes a new instance of the RemoveCustomerPartiesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


RemoveCustomerPartiesRequest Constructor

RemoveCustomerPartiesRequest Constructor
Initializes a new instance of the RemoveCustomerPartiesRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveCustomerPartiesRequest(
    CommerceCustomer commerceCustomer,
    List<CustomerParty> parties
)
Public Sub New (
    commerceCustomer As CommerceCustomer,
    parties As List(Of CustomerParty)
)
public:
RemoveCustomerPartiesRequest(
    CommerceCustomer^ commerceCustomer,
    List<CustomerParty^>^ parties
)
new :
        commerceCustomer : CommerceCustomer *
        parties : List<CustomerParty> -> RemoveCustomerPartiesRequest

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList CustomerParty
The parties.
See Also

Reference

RemoveCustomerPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemoveCustomerPartiesRequest Methods

RemoveCustomerPartiesRequest Methods

The RemoveCustomerPartiesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveCustomerPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemoveCustomerPartiesRequest Properties

RemoveCustomerPartiesRequest Properties

The RemoveCustomerPartiesRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

RemoveCustomerPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemoveCustomerPartiesRequest.Parties Property

RemoveCustomerPartiesRequestParties Property
Gets or sets the parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<CustomerParty> Parties { get; set; }
Public Property Parties As List(Of CustomerParty)
    Get
    Set
public:
property List<CustomerParty^>^ Parties {
    List<CustomerParty^>^ get ();
    void set (List<CustomerParty^>^ value);
}
member Parties : List<CustomerParty> with get, set

Property Value

Type: List CustomerParty
The parties.
See Also

Reference

RemoveCustomerPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemoveCustomersRequest Class

RemoveCustomersRequest Class
Defines the RemoveCustomersRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersUserRequest
Sitecore.Commerce.Services.CustomersUserRequestWithUser
Sitecore.Commerce.Services.CustomersRemoveCustomersRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveCustomersRequest : UserRequestWithUser
Public Class RemoveCustomersRequest
    Inherits UserRequestWithUser
public ref class RemoveCustomersRequest : public UserRequestWithUser
type RemoveCustomersRequest =
    class
        inherit UserRequestWithUser
    end

The RemoveCustomersRequest type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveCustomersRequest | Initializes a new instance of the RemoveCustomersRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceUser | Gets the commerce user. (Inherited from UserRequestWithUser.)
Public property | CustomerIds | Gets or sets the customer ids.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


RemoveCustomersRequest Constructor

RemoveCustomersRequest Constructor
Initializes a new instance of the RemoveCustomersRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveCustomersRequest(
    CommerceUser commerceUser,
    List<string> customerIds
)
Public Sub New (
    commerceUser As CommerceUser,
    customerIds As List(Of String)
)
public:
RemoveCustomersRequest(
    CommerceUser^ commerceUser,
    List<String^>^ customerIds
)
new :
        commerceUser : CommerceUser *
        customerIds : List<string> -> RemoveCustomersRequest

Parameters

commerceUser
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The user.
customerIds
Type: System.Collections.GenericList String
The customer ids.
See Also

Reference

RemoveCustomersRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemoveCustomersRequest Methods

RemoveCustomersRequest Methods

The RemoveCustomersRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveCustomersRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemoveCustomersRequest Properties

RemoveCustomersRequest Properties

The RemoveCustomersRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceUser | Gets the commerce user. (Inherited from UserRequestWithUser.)
Public property | CustomerIds | Gets or sets the customer ids.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

RemoveCustomersRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemoveCustomersRequest.CustomerIds Property

RemoveCustomersRequestCustomerIds Property
Gets or sets the customer ids.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<string> CustomerIds { get; set; }
Public Property CustomerIds As List(Of String)
    Get
    Set
public:
property List<String^>^ CustomerIds {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member CustomerIds : List<string> with get, set

Property Value

Type: List String
The customer ids.
See Also

Reference

RemoveCustomersRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemoveCustomersResult Class

RemoveCustomersResult Class
Defines the RemoveCustomersResult result class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersUserResult
Sitecore.Commerce.Services.CustomersRemoveCustomersResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveCustomersResult : UserResult
Public Class RemoveCustomersResult
    Inherits UserResult
public ref class RemoveCustomersResult : public UserResult
type RemoveCustomersResult =
    class
        inherit UserResult
    end

The RemoveCustomersResult type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveCustomersResult | Initializes a new instance of the RemoveCustomersResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerIds | Gets or sets the customer ids.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


RemoveCustomersResult Constructor

RemoveCustomersResult Constructor
Initializes a new instance of the RemoveCustomersResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveCustomersResult()
Public Sub New
public:
RemoveCustomersResult()
new : unit -> RemoveCustomersResult
See Also

Reference

RemoveCustomersResult Class
Sitecore.Commerce.Services.Customers Namespace


RemoveCustomersResult Methods

RemoveCustomersResult Methods

The RemoveCustomersResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveCustomersResult Class
Sitecore.Commerce.Services.Customers Namespace


RemoveCustomersResult Properties

RemoveCustomersResult Properties

The RemoveCustomersResult type exposes the following members.

Properties
 | Name | Description
Public property | CustomerIds | Gets or sets the customer ids.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

RemoveCustomersResult Class
Sitecore.Commerce.Services.Customers Namespace


RemoveCustomersResult.CustomerIds Property

RemoveCustomersResultCustomerIds Property
Gets or sets the customer ids.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ICollection<string> CustomerIds { get; set; }
Public Property CustomerIds As ICollection(Of String)
    Get
    Set
public:
property ICollection<String^>^ CustomerIds {
    ICollection<String^>^ get ();
    void set (ICollection<String^>^ value);
}
member CustomerIds : ICollection<string> with get, set

Property Value

Type: ICollection String
The customer ids.
See Also

Reference

RemoveCustomersResult Class
Sitecore.Commerce.Services.Customers Namespace


RemovePartiesRequest Class

RemovePartiesRequest Class
Defines the RemovePartiesRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersRemovePartiesRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemovePartiesRequest : CustomerRequestWithCustomer
Public Class RemovePartiesRequest
    Inherits CustomerRequestWithCustomer
public ref class RemovePartiesRequest : public CustomerRequestWithCustomer
type RemovePartiesRequest =
    class
        inherit CustomerRequestWithCustomer
    end

The RemovePartiesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | RemovePartiesRequest | Initializes a new instance of the RemovePartiesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


RemovePartiesRequest Constructor

RemovePartiesRequest Constructor
Initializes a new instance of the RemovePartiesRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemovePartiesRequest(
    CommerceCustomer commerceCustomer,
    List<Party> parties
)
Public Sub New (
    commerceCustomer As CommerceCustomer,
    parties As List(Of Party)
)
public:
RemovePartiesRequest(
    CommerceCustomer^ commerceCustomer,
    List<Party^>^ parties
)
new :
        commerceCustomer : CommerceCustomer *
        parties : List<Party> -> RemovePartiesRequest

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList Party
The parties.
See Also

Reference

RemovePartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemovePartiesRequest Methods

RemovePartiesRequest Methods

The RemovePartiesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemovePartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemovePartiesRequest Properties

RemovePartiesRequest Properties

The RemovePartiesRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

RemovePartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemovePartiesRequest.Parties Property

RemovePartiesRequestParties Property
Gets or sets the parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<Party> Parties { get; set; }
Public Property Parties As List(Of Party)
    Get
    Set
public:
property List<Party^>^ Parties {
    List<Party^>^ get ();
    void set (List<Party^>^ value);
}
member Parties : List<Party> with get, set

Property Value

Type: List Party
The parties.
See Also

Reference

RemovePartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemoveUsersRequest Class

RemoveUsersRequest Class
Defines the RemoveUsersRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersRemoveUsersRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveUsersRequest : CustomerRequestWithCustomer
Public Class RemoveUsersRequest
    Inherits CustomerRequestWithCustomer
public ref class RemoveUsersRequest : public CustomerRequestWithCustomer
type RemoveUsersRequest =
    class
        inherit CustomerRequestWithCustomer
    end

The RemoveUsersRequest type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveUsersRequest | Initializes a new instance of the RemoveUsersRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UserIds | Gets or sets the user ids.
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


RemoveUsersRequest Constructor

RemoveUsersRequest Constructor
Initializes a new instance of the RemoveUsersRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveUsersRequest(
    CommerceCustomer commerceCustomer,
    List<string> userIds
)
Public Sub New (
    commerceCustomer As CommerceCustomer,
    userIds As List(Of String)
)
public:
RemoveUsersRequest(
    CommerceCustomer^ commerceCustomer,
    List<String^>^ userIds
)
new :
        commerceCustomer : CommerceCustomer *
        userIds : List<string> -> RemoveUsersRequest

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
userIds
Type: System.Collections.GenericList String
The user ids.
See Also

Reference

RemoveUsersRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemoveUsersRequest Methods

RemoveUsersRequest Methods

The RemoveUsersRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveUsersRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemoveUsersRequest Properties

RemoveUsersRequest Properties

The RemoveUsersRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UserIds | Gets or sets the user ids.
Top
See Also

Reference

RemoveUsersRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemoveUsersRequest.UserIds Property

RemoveUsersRequestUserIds Property
Gets or sets the user ids.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<string> UserIds { get; set; }
Public Property UserIds As List(Of String)
    Get
    Set
public:
property List<String^>^ UserIds {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member UserIds : List<string> with get, set

Property Value

Type: List String
The user ids.
See Also

Reference

RemoveUsersRequest Class
Sitecore.Commerce.Services.Customers Namespace


RemoveUsersResult Class

RemoveUsersResult Class
Defines the RemoveUsersResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerResult
Sitecore.Commerce.Services.CustomersRemoveUsersResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveUsersResult : CustomerResult
Public Class RemoveUsersResult
    Inherits CustomerResult
public ref class RemoveUsersResult : public CustomerResult
type RemoveUsersResult =
    class
        inherit CustomerResult
    end

The RemoveUsersResult type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveUsersResult | Initializes a new instance of the RemoveUsersResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Public property | UserIds | Gets or sets the user ids.
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


RemoveUsersResult Constructor

RemoveUsersResult Constructor
Initializes a new instance of the RemoveUsersResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveUsersResult()
Public Sub New
public:
RemoveUsersResult()
new : unit -> RemoveUsersResult
See Also

Reference

RemoveUsersResult Class
Sitecore.Commerce.Services.Customers Namespace


RemoveUsersResult Methods

RemoveUsersResult Methods

The RemoveUsersResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveUsersResult Class
Sitecore.Commerce.Services.Customers Namespace


RemoveUsersResult Properties

RemoveUsersResult Properties

The RemoveUsersResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Public property | UserIds | Gets or sets the user ids.
Top
See Also

Reference

RemoveUsersResult Class
Sitecore.Commerce.Services.Customers Namespace


RemoveUsersResult.UserIds Property

RemoveUsersResultUserIds Property
Gets or sets the user ids.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ICollection<string> UserIds { get; set; }
Public Property UserIds As ICollection(Of String)
    Get
    Set
public:
property ICollection<String^>^ UserIds {
    ICollection<String^>^ get ();
    void set (ICollection<String^>^ value);
}
member UserIds : ICollection<string> with get, set

Property Value

Type: ICollection String
The user ids.
See Also

Reference

RemoveUsersResult Class
Sitecore.Commerce.Services.Customers Namespace


UpdateCustomerPartiesRequest Class

UpdateCustomerPartiesRequest Class
Defines the UpdateCustomerPartiesRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersUpdateCustomerPartiesRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateCustomerPartiesRequest : CustomerRequestWithCustomer
Public Class UpdateCustomerPartiesRequest
    Inherits CustomerRequestWithCustomer
public ref class UpdateCustomerPartiesRequest : public CustomerRequestWithCustomer
type UpdateCustomerPartiesRequest =
    class
        inherit CustomerRequestWithCustomer
    end

The UpdateCustomerPartiesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateCustomerPartiesRequest | Initializes a new instance of the UpdateCustomerPartiesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


UpdateCustomerPartiesRequest Constructor

UpdateCustomerPartiesRequest Constructor
Initializes a new instance of the UpdateCustomerPartiesRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateCustomerPartiesRequest(
    CommerceCustomer commerceCustomer,
    List<CustomerParty> parties
)
Public Sub New (
    commerceCustomer As CommerceCustomer,
    parties As List(Of CustomerParty)
)
public:
UpdateCustomerPartiesRequest(
    CommerceCustomer^ commerceCustomer,
    List<CustomerParty^>^ parties
)
new :
        commerceCustomer : CommerceCustomer *
        parties : List<CustomerParty> -> UpdateCustomerPartiesRequest

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList CustomerParty
The parties.
See Also

Reference

UpdateCustomerPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdateCustomerPartiesRequest Methods

UpdateCustomerPartiesRequest Methods

The UpdateCustomerPartiesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateCustomerPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdateCustomerPartiesRequest Properties

UpdateCustomerPartiesRequest Properties

The UpdateCustomerPartiesRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

UpdateCustomerPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdateCustomerPartiesRequest.Parties Property

UpdateCustomerPartiesRequestParties Property
Gets or sets the parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<CustomerParty> Parties { get; set; }
Public Property Parties As List(Of CustomerParty)
    Get
    Set
public:
property List<CustomerParty^>^ Parties {
    List<CustomerParty^>^ get ();
    void set (List<CustomerParty^>^ value);
}
member Parties : List<CustomerParty> with get, set

Property Value

Type: List CustomerParty
The parties.
See Also

Reference

UpdateCustomerPartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdateCustomerRequest Class

UpdateCustomerRequest Class
The update customer request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersUpdateCustomerRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateCustomerRequest : CustomerRequestWithCustomer
Public Class UpdateCustomerRequest
    Inherits CustomerRequestWithCustomer
public ref class UpdateCustomerRequest : public CustomerRequestWithCustomer
type UpdateCustomerRequest =
    class
        inherit CustomerRequestWithCustomer
    end

The UpdateCustomerRequest type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateCustomerRequest | Initializes a new instance of the UpdateCustomerRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


UpdateCustomerRequest Constructor

UpdateCustomerRequest Constructor
Initializes a new instance of the UpdateCustomerRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateCustomerRequest(
    CommerceCustomer commerceCustomer
)
Public Sub New (
    commerceCustomer As CommerceCustomer
)
public:
UpdateCustomerRequest(
    CommerceCustomer^ commerceCustomer
)
new :
        commerceCustomer : CommerceCustomer -> UpdateCustomerRequest

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The commerce customer.
See Also

Reference

UpdateCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdateCustomerRequest Methods

UpdateCustomerRequest Methods

The UpdateCustomerRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdateCustomerRequest Properties

UpdateCustomerRequest Properties

The UpdateCustomerRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

UpdateCustomerRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdateCustomerResult Class

UpdateCustomerResult Class
The update customer result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersCustomerResult
Sitecore.Commerce.Services.CustomersCustomerResultWithCart
Sitecore.Commerce.Services.CustomersUpdateCustomerResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateCustomerResult : CustomerResultWithCart
Public Class UpdateCustomerResult
    Inherits CustomerResultWithCart
public ref class UpdateCustomerResult : public CustomerResultWithCart
type UpdateCustomerResult =
    class
        inherit CustomerResultWithCart
    end

The UpdateCustomerResult type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateCustomerResult | Initializes a new instance of the UpdateCustomerResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce customer. (Inherited from CustomerResultWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


UpdateCustomerResult Constructor

UpdateCustomerResult Constructor
Initializes a new instance of the UpdateCustomerResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateCustomerResult()
Public Sub New
public:
UpdateCustomerResult()
new : unit -> UpdateCustomerResult
See Also

Reference

UpdateCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


UpdateCustomerResult Methods

UpdateCustomerResult Methods

The UpdateCustomerResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


UpdateCustomerResult Properties

UpdateCustomerResult Properties

The UpdateCustomerResult type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce customer. (Inherited from CustomerResultWithCart.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

UpdateCustomerResult Class
Sitecore.Commerce.Services.Customers Namespace


UpdatePartiesRequest Class

UpdatePartiesRequest Class
Defines the UpdatePartiesRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersCustomerRequest
Sitecore.Commerce.Services.CustomersCustomerRequestWithCustomer
Sitecore.Commerce.Services.CustomersUpdatePartiesRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdatePartiesRequest : CustomerRequestWithCustomer
Public Class UpdatePartiesRequest
    Inherits CustomerRequestWithCustomer
public ref class UpdatePartiesRequest : public CustomerRequestWithCustomer
type UpdatePartiesRequest =
    class
        inherit CustomerRequestWithCustomer
    end

The UpdatePartiesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | UpdatePartiesRequest | Initializes a new instance of the UpdatePartiesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


UpdatePartiesRequest Constructor

UpdatePartiesRequest Constructor
Initializes a new instance of the UpdatePartiesRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdatePartiesRequest(
    CommerceCustomer commerceCustomer,
    List<Party> parties
)
Public Sub New (
    commerceCustomer As CommerceCustomer,
    parties As List(Of Party)
)
public:
UpdatePartiesRequest(
    CommerceCustomer^ commerceCustomer,
    List<Party^>^ parties
)
new :
        commerceCustomer : CommerceCustomer *
        parties : List<Party> -> UpdatePartiesRequest

Parameters

commerceCustomer
Type: Sitecore.Commerce.Entities.CustomersCommerceCustomer
The customer.
parties
Type: System.Collections.GenericList Party
The parties.
See Also

Reference

UpdatePartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdatePartiesRequest Methods

UpdatePartiesRequest Methods

The UpdatePartiesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdatePartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdatePartiesRequest Properties

UpdatePartiesRequest Properties

The UpdatePartiesRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceCustomer | Gets or sets the commerce user. (Inherited from CustomerRequestWithCustomer.)
Public property | Parties | Gets or sets the parties.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

UpdatePartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdatePartiesRequest.Parties Property

UpdatePartiesRequestParties Property
Gets or sets the parties.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public List<Party> Parties { get; set; }
Public Property Parties As List(Of Party)
    Get
    Set
public:
property List<Party^>^ Parties {
    List<Party^>^ get ();
    void set (List<Party^>^ value);
}
member Parties : List<Party> with get, set

Property Value

Type: List Party
The parties.
See Also

Reference

UpdatePartiesRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdatePasswordRequest Class

UpdatePasswordRequest Class
Updates user password request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersUpdatePasswordRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdatePasswordRequest : ServiceProviderRequest
Public Class UpdatePasswordRequest
    Inherits ServiceProviderRequest
public ref class UpdatePasswordRequest : public ServiceProviderRequest
type UpdatePasswordRequest =
    class
        inherit ServiceProviderRequest
    end

The UpdatePasswordRequest type exposes the following members.

Constructors
 | Name | Description
Public method | UpdatePasswordRequest | Initializes a new instance of the UpdatePasswordRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | NewPassword | Gets and sets the user new password
Public property | OldPassword | Gets and sets the user old password
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UserName | Gets and sets the user name
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


UpdatePasswordRequest Constructor

UpdatePasswordRequest Constructor
Initializes a new instance of the UpdatePasswordRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdatePasswordRequest(
    string userName,
    string oldPassword,
    string newPassword
)
Public Sub New (
    userName As String,
    oldPassword As String,
    newPassword As String
)
public:
UpdatePasswordRequest(
    String^ userName,
    String^ oldPassword,
    String^ newPassword
)
new :
        userName : string *
        oldPassword : string *
        newPassword : string -> UpdatePasswordRequest

Parameters

userName
Type: SystemString
The user name
oldPassword
Type: SystemString
The user old password
newPassword
Type: SystemString
The user new password
See Also

Reference

UpdatePasswordRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdatePasswordRequest Methods

UpdatePasswordRequest Methods

The UpdatePasswordRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdatePasswordRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdatePasswordRequest Properties

UpdatePasswordRequest Properties

The UpdatePasswordRequest type exposes the following members.

Properties
 | Name | Description
Public property | NewPassword | Gets and sets the user new password
Public property | OldPassword | Gets and sets the user old password
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UserName | Gets and sets the user name
Top
See Also

Reference

UpdatePasswordRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdatePasswordRequest.NewPassword Property

UpdatePasswordRequestNewPassword Property
Gets and sets the user new password

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string NewPassword { get; set; }
Public Property NewPassword As String
    Get
    Set
public:
property String^ NewPassword {
    String^ get ();
    void set (String^ value);
}
member NewPassword : string with get, set

Property Value

Type: String
See Also

Reference

UpdatePasswordRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdatePasswordRequest.OldPassword Property

UpdatePasswordRequestOldPassword Property
Gets and sets the user old password

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string OldPassword { get; set; }
Public Property OldPassword As String
    Get
    Set
public:
property String^ OldPassword {
    String^ get ();
    void set (String^ value);
}
member OldPassword : string with get, set

Property Value

Type: String
See Also

Reference

UpdatePasswordRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdatePasswordRequest.UserName Property

UpdatePasswordRequestUserName Property
Gets and sets the user name

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

UpdatePasswordRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdatePasswordResult Class

UpdatePasswordResult Class
Updates user password result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersUpdatePasswordResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdatePasswordResult : ServiceProviderResult
Public Class UpdatePasswordResult
    Inherits ServiceProviderResult
public ref class UpdatePasswordResult : public ServiceProviderResult
type UpdatePasswordResult =
    class
        inherit ServiceProviderResult
    end

The UpdatePasswordResult type exposes the following members.

Constructors
 | Name | Description
Public method | UpdatePasswordResult | Initializes a new instance of the UpdatePasswordResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


UpdatePasswordResult Constructor

UpdatePasswordResult Constructor
Initializes a new instance of the UpdatePasswordResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdatePasswordResult()
Public Sub New
public:
UpdatePasswordResult()
new : unit -> UpdatePasswordResult
See Also

Reference

UpdatePasswordResult Class
Sitecore.Commerce.Services.Customers Namespace


UpdatePasswordResult Methods

UpdatePasswordResult Methods

The UpdatePasswordResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdatePasswordResult Class
Sitecore.Commerce.Services.Customers Namespace


UpdatePasswordResult Properties

UpdatePasswordResult Properties

The UpdatePasswordResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

UpdatePasswordResult Class
Sitecore.Commerce.Services.Customers Namespace


UpdateUserRequest Class

UpdateUserRequest Class
The update user request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersUserRequest
Sitecore.Commerce.Services.CustomersUserRequestWithUser
Sitecore.Commerce.Services.CustomersUpdateUserRequest

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateUserRequest : UserRequestWithUser
Public Class UpdateUserRequest
    Inherits UserRequestWithUser
public ref class UpdateUserRequest : public UserRequestWithUser
type UpdateUserRequest =
    class
        inherit UserRequestWithUser
    end

The UpdateUserRequest type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateUserRequest | Initializes a new instance of the UpdateUserRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceUser | Gets the commerce user. (Inherited from UserRequestWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


UpdateUserRequest Constructor

UpdateUserRequest Constructor
Initializes a new instance of the UpdateUserRequest class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateUserRequest(
    CommerceUser commerceUser
)
Public Sub New (
    commerceUser As CommerceUser
)
public:
UpdateUserRequest(
    CommerceUser^ commerceUser
)
new :
        commerceUser : CommerceUser -> UpdateUserRequest

Parameters

commerceUser
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The commerce user.
See Also

Reference

UpdateUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdateUserRequest Methods

UpdateUserRequest Methods

The UpdateUserRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdateUserRequest Properties

UpdateUserRequest Properties

The UpdateUserRequest type exposes the following members.

Properties
 | Name | Description
Public property | CommerceUser | Gets the commerce user. (Inherited from UserRequestWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

UpdateUserRequest Class
Sitecore.Commerce.Services.Customers Namespace


UpdateUserResult Class

UpdateUserResult Class
The update user result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersUserResult
Sitecore.Commerce.Services.CustomersUserResultWithUser
Sitecore.Commerce.Services.CustomersUpdateUserResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UpdateUserResult : UserResultWithUser
Public Class UpdateUserResult
    Inherits UserResultWithUser
public ref class UpdateUserResult : public UserResultWithUser
type UpdateUserResult =
    class
        inherit UserResultWithUser
    end

The UpdateUserResult type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateUserResult | Initializes a new instance of the UpdateUserResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceUser | Gets or sets the commerce user. (Inherited from UserResultWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


UpdateUserResult Constructor

UpdateUserResult Constructor
Initializes a new instance of the UpdateUserResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateUserResult()
Public Sub New
public:
UpdateUserResult()
new : unit -> UpdateUserResult
See Also

Reference

UpdateUserResult Class
Sitecore.Commerce.Services.Customers Namespace


UpdateUserResult Methods

UpdateUserResult Methods

The UpdateUserResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateUserResult Class
Sitecore.Commerce.Services.Customers Namespace


UpdateUserResult Properties

UpdateUserResult Properties

The UpdateUserResult type exposes the following members.

Properties
 | Name | Description
Public property | CommerceUser | Gets or sets the commerce user. (Inherited from UserResultWithUser.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

UpdateUserResult Class
Sitecore.Commerce.Services.Customers Namespace


UserRequest Class

UserRequest Class
Class used as the base of all user requests.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersUserRequest
Sitecore.Commerce.Services.CustomersCreateUserRequest
Sitecore.Commerce.Services.CustomersGetUserRequest
Sitecore.Commerce.Services.CustomersGetUsersRequest
Sitecore.Commerce.Services.CustomersUserRequestWithUser

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UserRequest : ServiceProviderRequest
Public Class UserRequest
    Inherits ServiceProviderRequest
public ref class UserRequest : public ServiceProviderRequest
type UserRequest =
    class
        inherit ServiceProviderRequest
    end

The UserRequest type exposes the following members.

Constructors
 | Name | Description
Public method | UserRequest | Initializes a new instance of the UserRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


UserRequest Constructor

UserRequest Constructor
Initializes a new instance of the UserRequest class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UserRequest()
Public Sub New
public:
UserRequest()
new : unit -> UserRequest
See Also

Reference

UserRequest Class
Sitecore.Commerce.Services.Customers Namespace


UserRequest Methods

UserRequest Methods

The UserRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UserRequest Class
Sitecore.Commerce.Services.Customers Namespace


UserRequest Properties

UserRequest Properties

The UserRequest type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

UserRequest Class
Sitecore.Commerce.Services.Customers Namespace


UserRequestWithUser Class

UserRequestWithUser Class
Defines the base class for all of the one-user-related requests to the customer service provider.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersUserRequest
Sitecore.Commerce.Services.CustomersUserRequestWithUser
More...

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public abstract class UserRequestWithUser : UserRequest
Public MustInherit Class UserRequestWithUser
    Inherits UserRequest
public ref class UserRequestWithUser abstract : public UserRequest
[<AbstractClassAttribute>]
type UserRequestWithUser =
    class
        inherit UserRequest
    end

The UserRequestWithUser type exposes the following members.

Constructors
 | Name | Description
Protected method | UserRequestWithUser | Initializes an instance of the UserRequestWithUser class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceUser | Gets the commerce user.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.CustomersUserRequest
Sitecore.Commerce.Services.CustomersUserRequestWithUser
Sitecore.Commerce.Services.CustomersAddCustomersRequest
Sitecore.Commerce.Services.CustomersDeleteUserRequest
Sitecore.Commerce.Services.CustomersDisableUserRequest
Sitecore.Commerce.Services.CustomersEnableUserRequest
Sitecore.Commerce.Services.CustomersRemoveCustomersRequest
Sitecore.Commerce.Services.CustomersUpdateUserRequest


UserRequestWithUser Constructor

UserRequestWithUser Constructor
Initializes an instance of the UserRequestWithUser class.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected UserRequestWithUser(
    CommerceUser commerceUser
)
Protected Sub New (
    commerceUser As CommerceUser
)
protected:
UserRequestWithUser(
    CommerceUser^ commerceUser
)
new :
        commerceUser : CommerceUser -> UserRequestWithUser

Parameters

commerceUser
Type: Sitecore.Commerce.Entities.CustomersCommerceUser
The commerce user
See Also

Reference

UserRequestWithUser Class
Sitecore.Commerce.Services.Customers Namespace


UserRequestWithUser Methods

UserRequestWithUser Methods

The UserRequestWithUser type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UserRequestWithUser Class
Sitecore.Commerce.Services.Customers Namespace


UserRequestWithUser Properties

UserRequestWithUser Properties

The UserRequestWithUser type exposes the following members.

Properties
 | Name | Description
Public property | CommerceUser | Gets the commerce user.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

UserRequestWithUser Class
Sitecore.Commerce.Services.Customers Namespace


UserRequestWithUser.CommerceUser Property

UserRequestWithUserCommerceUser Property
Gets the commerce user.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CommerceUser CommerceUser { get; }
Public ReadOnly Property CommerceUser As CommerceUser
    Get
public:
property CommerceUser^ CommerceUser {
    CommerceUser^ get ();
}
member CommerceUser : CommerceUser with get

Property Value

Type: CommerceUser
The commerce user
See Also

Reference

UserRequestWithUser Class
Sitecore.Commerce.Services.Customers Namespace


UserResult Class

UserResult Class
Defines the base class of all user requests.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersUserResult
More...

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UserResult : ServiceProviderResult
Public Class UserResult
    Inherits ServiceProviderResult
public ref class UserResult : public ServiceProviderResult
type UserResult =
    class
        inherit ServiceProviderResult
    end

The UserResult type exposes the following members.

Constructors
 | Name | Description
Public method | UserResult | Initializes a new instance of the UserResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersUserResult
Sitecore.Commerce.Services.CustomersAddCustomersResult
Sitecore.Commerce.Services.CustomersDeleteUserResult
Sitecore.Commerce.Services.CustomersGetUserResult
Sitecore.Commerce.Services.CustomersGetUsersResult
Sitecore.Commerce.Services.CustomersRemoveCustomersResult
Sitecore.Commerce.Services.CustomersUserResultWithUser


UserResult Constructor

UserResult Constructor
Initializes a new instance of the UserResult class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UserResult()
Public Sub New
public:
UserResult()
new : unit -> UserResult
See Also

Reference

UserResult Class
Sitecore.Commerce.Services.Customers Namespace


UserResult Methods

UserResult Methods

The UserResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UserResult Class
Sitecore.Commerce.Services.Customers Namespace


UserResult Properties

UserResult Properties

The UserResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

UserResult Class
Sitecore.Commerce.Services.Customers Namespace


UserResultWithUser Class

UserResultWithUser Class
The user result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.CustomersUserResult
Sitecore.Commerce.Services.CustomersUserResultWithUser
Sitecore.Commerce.Services.CustomersCreateUserResult
Sitecore.Commerce.Services.CustomersDisableUserResult
Sitecore.Commerce.Services.CustomersEnableUserResult
Sitecore.Commerce.Services.CustomersUpdateUserResult

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UserResultWithUser : UserResult
Public Class UserResultWithUser
    Inherits UserResult
public ref class UserResultWithUser : public UserResult
type UserResultWithUser =
    class
        inherit UserResult
    end

The UserResultWithUser type exposes the following members.

Constructors
 | Name | Description
Public method | UserResultWithUser | Initializes a new instance of the UserResultWithUser class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommerceUser | Gets or sets the commerce user.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


UserResultWithUser Constructor

UserResultWithUser Constructor
Initializes a new instance of the UserResultWithUser class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UserResultWithUser()
Public Sub New
public:
UserResultWithUser()
new : unit -> UserResultWithUser
See Also

Reference

UserResultWithUser Class
Sitecore.Commerce.Services.Customers Namespace


UserResultWithUser Methods

UserResultWithUser Methods

The UserResultWithUser type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UserResultWithUser Class
Sitecore.Commerce.Services.Customers Namespace


UserResultWithUser Properties

UserResultWithUser Properties

The UserResultWithUser type exposes the following members.

Properties
 | Name | Description
Public property | CommerceUser | Gets or sets the commerce user.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

UserResultWithUser Class
Sitecore.Commerce.Services.Customers Namespace


UserResultWithUser.CommerceUser Property

UserResultWithUserCommerceUser Property
Gets or sets the commerce user.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public CommerceUser CommerceUser { get; set; }
Public Property CommerceUser As CommerceUser
    Get
    Set
public:
property CommerceUser^ CommerceUser {
    CommerceUser^ get ();
    void set (CommerceUser^ value);
}
member CommerceUser : CommerceUser with get, set

Property Value

Type: CommerceUser
The commerce user.
See Also

Reference

UserResultWithUser Class
Sitecore.Commerce.Services.Customers Namespace


UserSearchCriteria Class

UserSearchCriteria Class
Defines the class containing the search criteria for users.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.EntitiesEntity
Sitecore.Commerce.Services.CustomersUserSearchCriteria

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class UserSearchCriteria : Entity
Public Class UserSearchCriteria
    Inherits Entity
public ref class UserSearchCriteria : public Entity
type UserSearchCriteria =
    class
        inherit Entity
    end

The UserSearchCriteria type exposes the following members.

Constructors
 | Name | Description
Public method | UserSearchCriteria | Initializes a new instance of the UserSearchCriteria class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Email | Gets or sets the email.
Public property | ExternalCustomerIDs | Gets or sets the external customer Ids.
Public property | ExternalIDs | Gets or sets the external Ids.
Public property | IsDisabled | Gets or sets a value indicating whether this instance is disabled.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | ShopName | Gets or sets the name of the shop.
Public property | UserName | Gets or sets the name of the user.
Top
See Also

Reference

Sitecore.Commerce.Services.Customers Namespace


UserSearchCriteria Constructor

UserSearchCriteria Constructor
Initializes a new instance of the UserSearchCriteria class

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UserSearchCriteria()
Public Sub New
public:
UserSearchCriteria()
new : unit -> UserSearchCriteria
See Also

Reference

UserSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


UserSearchCriteria Methods

UserSearchCriteria Methods

The UserSearchCriteria type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets a property value. (Inherited from Entity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertyValue(String) | Sets a property value. (Inherited from Entity.)
Public method | SetPropertyValue(String, Object) | Sets a property value. (Inherited from Entity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UserSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


UserSearchCriteria Properties

UserSearchCriteria Properties

The UserSearchCriteria type exposes the following members.

Properties
 | Name | Description
Public property | Email | Gets or sets the email.
Public property | ExternalCustomerIDs | Gets or sets the external customer Ids.
Public property | ExternalIDs | Gets or sets the external Ids.
Public property | IsDisabled | Gets or sets a value indicating whether this instance is disabled.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from Entity.)
Public property | ShopName | Gets or sets the name of the shop.
Public property | UserName | Gets or sets the name of the user.
Top
See Also

Reference

UserSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


UserSearchCriteria.Email Property

UserSearchCriteriaEmail Property
Gets or sets the email.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}
member Email : string with get, set

Property Value

Type: String
The email.
See Also

Reference

UserSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


UserSearchCriteria.ExternalCustomerIDs Property

UserSearchCriteriaExternalCustomerIDs Property
Gets or sets the external customer Ids.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ExternalCustomerIDs { get; set; }
Public Property ExternalCustomerIDs As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ ExternalCustomerIDs {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member ExternalCustomerIDs : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The external customer Ids.
See Also

Reference

UserSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


UserSearchCriteria.ExternalIDs Property

UserSearchCriteriaExternalIDs Property
Gets or sets the external Ids.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ExternalIDs { get; set; }
Public Property ExternalIDs As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ ExternalIDs {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member ExternalIDs : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The external I ds.
See Also

Reference

UserSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


UserSearchCriteria.IsDisabled Property

UserSearchCriteriaIsDisabled Property
Gets or sets a value indicating whether this instance is disabled.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> IsDisabled { get; set; }
Public Property IsDisabled As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsDisabled {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member IsDisabled : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
true if this instance is disabled; otherwise, false.
See Also

Reference

UserSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


UserSearchCriteria.ShopName Property

UserSearchCriteriaShopName Property
Gets or sets the name of the shop.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
The name of the shop.
See Also

Reference

UserSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


UserSearchCriteria.UserName Property

UserSearchCriteriaUserName Property
Gets or sets the name of the user.

Namespace: Sitecore.Commerce.Services.Customers
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
The name of the user.
See Also

Reference

UserSearchCriteria Class
Sitecore.Commerce.Services.Customers Namespace


Sitecore.Commerce.Services.Customers.Generics Namespace

Sitecore.Commerce.Services.Customers.Generics Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Services.Customers.Generics"]

Classes
Class Description
Public class GenericCustomerServiceProviderExtensions
Defines a set of extensions for the CustomerServiceProvider class. The GenericCustomerServiceProviderExtensionsclass contains the same methods as in the CustomerServiceProvider class.

The methods of this class are:
  • Generic
  • Accept a custom request that is inherited from the default request
  • Return a custom result that is inherited from the default result
  • Implement the default constructor


GenericCustomerServiceProviderExtensions Class

GenericCustomerServiceProviderExtensions Class
Defines a set of extensions for the CustomerServiceProvider class. The GenericCustomerServiceProviderExtensionsclass contains the same methods as in the CustomerServiceProvider class.

The methods of this class are:
  • Generic
  • Accept a custom request that is inherited from the default request
  • Return a custom result that is inherited from the default result
  • Implement the default constructor
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Services.Customers.GenericsGenericCustomerServiceProviderExtensions

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class GenericCustomerServiceProviderExtensions
<ExtensionAttribute>
Public NotInheritable Class GenericCustomerServiceProviderExtensions
[ExtensionAttribute]
public ref class GenericCustomerServiceProviderExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GenericCustomerServiceProviderExtensions =  class end

The GenericCustomerServiceProviderExtensions type exposes the following members.

Methods
Name | Description
AddCustomerPartiesTAddCustomerPatiesRequest, TCustomerPartiesResult | Adds the customer parties.
AddCustomersTAddCustomersRequest, TAddCustomersResult | Adds customers to an existing user.
AddPartiesTAddPatiesRequest, TAddPartiesResult | Adds the parties.
AddUsersTAddUsersRequest, TAddUsersResult | Adds users to an existing customer.
CreateCustomerTCreateCustomerRequest, TCreateCustomerResult | Creates a customer.
CreateUserTCreateUserRequest, TCreateUserResult | Creates the user.
DeleteCustomerTDeleteCustomerRequest, TDeleteCustomerResult | Deletes the customer.
DeleteUserTDeleteUserRequest, TDeleteUserResult | Updates the user.
DisableCustomerTDisableCustomerRequest, TDisableCustomerResult | Disables the customer.
DisableUserTDisableUserRequest, TDisableUserResult | Updates the user.
EnableCustomerTEnableCustomerRequest, TEnableCustomerResult | Enables the customer.
EnableUserTEnableUserRequest, TEnableUserResult | Updates the user.
GetCustomerTGetCustomerRequest, TGetCustomerResult | Gets the customer.
GetCustomersTGetCustomersRequest, TGetCustomersResult | Gets the customers.
GetPartiesTGetPartiesRequest, TGetPartiesResult | Gets the parties.
GetUserTGetUserRequest, TGetUserResult | Gets the user.
GetUsersTGetUsersRequest, TGetUsersResult | Gets the users.
RemoveCustomerPartiesTRemoveCustomerPatiesRequest, TCustomerPartiesResult | Removes the customer parties.
RemoveCustomersTRemoveCustomersRequest, TRemoveCustomersResult | Removes customers from an existing user.
RemovePartiesTRemovePatiesRequest, TCustomerResult | Removes the parties associated with the given customer.
RemoveUsersTRemoveUsersRequest, TRemoveUsersResult | Removes users from an existing customer.
UpdateCustomerTUpdateCustomerRequest, TUpdateCustomerResult | Updates the customer.
UpdateCustomerPartiesTUpdateCustomerPatiesRequest, TCustomerPartiesResult | Updates the customer parties.
UpdatePartiesTUpdatePatiesRequest, TCustomerResult | Updates the parties information associated with the given customer.
UpdatePasswordTUpdatePasswordRequest, TUpdatePasswordResult | Updates the parties information associated with the given customer.
UpdateUserTUpdateUserRequest, TUpdateUserResult | Updates the user.
Top
See Also

Reference

Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions Methods

GenericCustomerServiceProviderExtensions Methods

The GenericCustomerServiceProviderExtensions type exposes the following members.

Methods
Name | Description
AddCustomerPartiesTAddCustomerPatiesRequest, TCustomerPartiesResult | Adds the customer parties.
AddCustomersTAddCustomersRequest, TAddCustomersResult | Adds customers to an existing user.
AddPartiesTAddPatiesRequest, TAddPartiesResult | Adds the parties.
AddUsersTAddUsersRequest, TAddUsersResult | Adds users to an existing customer.
CreateCustomerTCreateCustomerRequest, TCreateCustomerResult | Creates a customer.
CreateUserTCreateUserRequest, TCreateUserResult | Creates the user.
DeleteCustomerTDeleteCustomerRequest, TDeleteCustomerResult | Deletes the customer.
DeleteUserTDeleteUserRequest, TDeleteUserResult | Updates the user.
DisableCustomerTDisableCustomerRequest, TDisableCustomerResult | Disables the customer.
DisableUserTDisableUserRequest, TDisableUserResult | Updates the user.
EnableCustomerTEnableCustomerRequest, TEnableCustomerResult | Enables the customer.
EnableUserTEnableUserRequest, TEnableUserResult | Updates the user.
GetCustomerTGetCustomerRequest, TGetCustomerResult | Gets the customer.
GetCustomersTGetCustomersRequest, TGetCustomersResult | Gets the customers.
GetPartiesTGetPartiesRequest, TGetPartiesResult | Gets the parties.
GetUserTGetUserRequest, TGetUserResult | Gets the user.
GetUsersTGetUsersRequest, TGetUsersResult | Gets the users.
RemoveCustomerPartiesTRemoveCustomerPatiesRequest, TCustomerPartiesResult | Removes the customer parties.
RemoveCustomersTRemoveCustomersRequest, TRemoveCustomersResult | Removes customers from an existing user.
RemovePartiesTRemovePatiesRequest, TCustomerResult | Removes the parties associated with the given customer.
RemoveUsersTRemoveUsersRequest, TRemoveUsersResult | Removes users from an existing customer.
UpdateCustomerTUpdateCustomerRequest, TUpdateCustomerResult | Updates the customer.
UpdateCustomerPartiesTUpdateCustomerPatiesRequest, TCustomerPartiesResult | Updates the customer parties.
UpdatePartiesTUpdatePatiesRequest, TCustomerResult | Updates the parties information associated with the given customer.
UpdatePasswordTUpdatePasswordRequest, TUpdatePasswordResult | Updates the parties information associated with the given customer.
UpdateUserTUpdateUserRequest, TUpdateUserResult | Updates the user.
Top
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.AddCustomerParties(TAddCustomerPatiesRequest, TCustomerPartiesResult) Method

GenericCustomerServiceProviderExtensionsAddCustomerPartiesTAddCustomerPatiesRequest, TCustomerPartiesResult Method
Adds the customer parties.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TCustomerPartiesResult AddCustomerParties<TAddCustomerPatiesRequest, TCustomerPartiesResult>(
    this CustomerServiceProvider customerServiceProvider,
    TAddCustomerPatiesRequest request
)
where TAddCustomerPatiesRequest : AddCustomerPartiesRequest
where TCustomerPartiesResult : new(), CustomerPartiesResult

<ExtensionAttribute>
Public Shared Function AddCustomerParties(Of TAddCustomerPatiesRequest As AddCustomerPartiesRequest, TCustomerPartiesResult As {New, CustomerPartiesResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TAddCustomerPatiesRequest
) As TCustomerPartiesResult
public:
[ExtensionAttribute]
generic<typename TAddCustomerPatiesRequest, typename TCustomerPartiesResult>
where TAddCustomerPatiesRequest : AddCustomerPartiesRequest
where TCustomerPartiesResult : gcnew(), CustomerPartiesResult
static TCustomerPartiesResult AddCustomerParties(
    CustomerServiceProvider^ customerServiceProvider,
    TAddCustomerPatiesRequest request
)
static member AddCustomerParties :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TAddCustomerPatiesRequest -> 'TCustomerPartiesResult  when 'TAddCustomerPatiesRequest : AddCustomerPartiesRequest when 'TCustomerPartiesResult : new() and CustomerPartiesResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider.
request
Type: TAddCustomerPatiesRequest
The request.

Type Parameters

TAddCustomerPatiesRequest
The type of the add customer paties request.
TCustomerPartiesResult
The type of the customer parties result.

Return Value

Type: TCustomerPartiesResult
An object of type CustomerPartiesResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.AddCustomers(TAddCustomersRequest, TAddCustomersResult) Method

GenericCustomerServiceProviderExtensionsAddCustomersTAddCustomersRequest, TAddCustomersResult Method
Adds customers to an existing user.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TAddCustomersResult AddCustomers<TAddCustomersRequest, TAddCustomersResult>(
    this CustomerServiceProvider customerServiceProvider,
    TAddCustomersRequest request
)
where TAddCustomersRequest : AddCustomersRequest
where TAddCustomersResult : new(), AddCustomersResult

<ExtensionAttribute>
Public Shared Function AddCustomers(Of TAddCustomersRequest As AddCustomersRequest, TAddCustomersResult As {New, AddCustomersResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TAddCustomersRequest
) As TAddCustomersResult
public:
[ExtensionAttribute]
generic<typename TAddCustomersRequest, typename TAddCustomersResult>
where TAddCustomersRequest : AddCustomersRequest
where TAddCustomersResult : gcnew(), AddCustomersResult
static TAddCustomersResult AddCustomers(
    CustomerServiceProvider^ customerServiceProvider,
    TAddCustomersRequest request
)
static member AddCustomers :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TAddCustomersRequest -> 'TAddCustomersResult  when 'TAddCustomersRequest : AddCustomersRequest when 'TAddCustomersResult : new() and AddCustomersResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TAddCustomersRequest
The request

Type Parameters

TAddCustomersRequest
The type of the AddCustomersRequest
TAddCustomersResult
The type of the AddCustomersResult

Return Value

Type: TAddCustomersResult
An object of type AddCustomersResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.AddParties(TAddPatiesRequest, TAddPartiesResult) Method

GenericCustomerServiceProviderExtensionsAddPartiesTAddPatiesRequest, TAddPartiesResult Method
Adds the parties.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TAddPartiesResult AddParties<TAddPatiesRequest, TAddPartiesResult>(
    this CustomerServiceProvider customerServiceProvider,
    TAddPatiesRequest request
)
where TAddPatiesRequest : AddPartiesRequest
where TAddPartiesResult : new(), AddPartiesResult

<ExtensionAttribute>
Public Shared Function AddParties(Of TAddPatiesRequest As AddPartiesRequest, TAddPartiesResult As {New, AddPartiesResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TAddPatiesRequest
) As TAddPartiesResult
public:
[ExtensionAttribute]
generic<typename TAddPatiesRequest, typename TAddPartiesResult>
where TAddPatiesRequest : AddPartiesRequest
where TAddPartiesResult : gcnew(), AddPartiesResult
static TAddPartiesResult AddParties(
    CustomerServiceProvider^ customerServiceProvider,
    TAddPatiesRequest request
)
static member AddParties :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TAddPatiesRequest -> 'TAddPartiesResult  when 'TAddPatiesRequest : AddPartiesRequest when 'TAddPartiesResult : new() and AddPartiesResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider.
request
Type: TAddPatiesRequest
The request.

Type Parameters

TAddPatiesRequest
The type of the add paties request.
TAddPartiesResult
The type of the add parties result.

Return Value

Type: TAddPartiesResult
An object of type AddPartiesResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.AddUsers(TAddUsersRequest, TAddUsersResult) Method

GenericCustomerServiceProviderExtensionsAddUsersTAddUsersRequest, TAddUsersResult Method
Adds users to an existing customer.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TAddUsersResult AddUsers<TAddUsersRequest, TAddUsersResult>(
    this CustomerServiceProvider customerServiceProvider,
    TAddUsersRequest request
)
where TAddUsersRequest : AddUsersRequest
where TAddUsersResult : new(), AddUsersResult

<ExtensionAttribute>
Public Shared Function AddUsers(Of TAddUsersRequest As AddUsersRequest, TAddUsersResult As {New, AddUsersResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TAddUsersRequest
) As TAddUsersResult
public:
[ExtensionAttribute]
generic<typename TAddUsersRequest, typename TAddUsersResult>
where TAddUsersRequest : AddUsersRequest
where TAddUsersResult : gcnew(), AddUsersResult
static TAddUsersResult AddUsers(
    CustomerServiceProvider^ customerServiceProvider,
    TAddUsersRequest request
)
static member AddUsers :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TAddUsersRequest -> 'TAddUsersResult  when 'TAddUsersRequest : AddUsersRequest when 'TAddUsersResult : new() and AddUsersResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TAddUsersRequest
The request

Type Parameters

TAddUsersRequest
The type of the AddUsersRequest
TAddUsersResult
The type of the AddUsersResult

Return Value

Type: TAddUsersResult
An object of type AddUsersResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.CreateCustomer(TCreateCustomerRequest, TCreateCustomerResult) Method

GenericCustomerServiceProviderExtensionsCreateCustomerTCreateCustomerRequest, TCreateCustomerResult Method
Creates a customer.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TCreateCustomerResult CreateCustomer<TCreateCustomerRequest, TCreateCustomerResult>(
    this CustomerServiceProvider customerServiceProvider,
    TCreateCustomerRequest request
)
where TCreateCustomerRequest : CreateCustomerRequest
where TCreateCustomerResult : new(), CreateCustomerResult

<ExtensionAttribute>
Public Shared Function CreateCustomer(Of TCreateCustomerRequest As CreateCustomerRequest, TCreateCustomerResult As {New, CreateCustomerResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TCreateCustomerRequest
) As TCreateCustomerResult
public:
[ExtensionAttribute]
generic<typename TCreateCustomerRequest, typename TCreateCustomerResult>
where TCreateCustomerRequest : CreateCustomerRequest
where TCreateCustomerResult : gcnew(), CreateCustomerResult
static TCreateCustomerResult CreateCustomer(
    CustomerServiceProvider^ customerServiceProvider,
    TCreateCustomerRequest request
)
static member CreateCustomer :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TCreateCustomerRequest -> 'TCreateCustomerResult  when 'TCreateCustomerRequest : CreateCustomerRequest when 'TCreateCustomerResult : new() and CreateCustomerResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TCreateCustomerRequest
The request

Type Parameters

TCreateCustomerRequest
The type of the CreateCustomerRequest
TCreateCustomerResult
The type of the CreateCustomerResult

Return Value

Type: TCreateCustomerResult
An object of type CreateCustomerResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.CreateUser(TCreateUserRequest, TCreateUserResult) Method

GenericCustomerServiceProviderExtensionsCreateUserTCreateUserRequest, TCreateUserResult Method
Creates the user.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TCreateUserResult CreateUser<TCreateUserRequest, TCreateUserResult>(
    this CustomerServiceProvider customerServiceProvider,
    TCreateUserRequest request
)
where TCreateUserRequest : CreateUserRequest
where TCreateUserResult : new(), CreateUserResult

<ExtensionAttribute>
Public Shared Function CreateUser(Of TCreateUserRequest As CreateUserRequest, TCreateUserResult As {New, CreateUserResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TCreateUserRequest
) As TCreateUserResult
public:
[ExtensionAttribute]
generic<typename TCreateUserRequest, typename TCreateUserResult>
where TCreateUserRequest : CreateUserRequest
where TCreateUserResult : gcnew(), CreateUserResult
static TCreateUserResult CreateUser(
    CustomerServiceProvider^ customerServiceProvider,
    TCreateUserRequest request
)
static member CreateUser :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TCreateUserRequest -> 'TCreateUserResult  when 'TCreateUserRequest : CreateUserRequest when 'TCreateUserResult : new() and CreateUserResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TCreateUserRequest
The request

Type Parameters

TCreateUserRequest
The type of the CreateUserRequest
TCreateUserResult
The type of the CreateUserResult

Return Value

Type: TCreateUserResult
An object of type CreateUserResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.DeleteCustomer(TDeleteCustomerRequest, TDeleteCustomerResult) Method

GenericCustomerServiceProviderExtensionsDeleteCustomerTDeleteCustomerRequest, TDeleteCustomerResult Method
Deletes the customer.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TDeleteCustomerResult DeleteCustomer<TDeleteCustomerRequest, TDeleteCustomerResult>(
    this CustomerServiceProvider customerServiceProvider,
    TDeleteCustomerRequest request
)
where TDeleteCustomerRequest : DeleteCustomerRequest
where TDeleteCustomerResult : new(), DeleteCustomerResult

<ExtensionAttribute>
Public Shared Function DeleteCustomer(Of TDeleteCustomerRequest As DeleteCustomerRequest, TDeleteCustomerResult As {New, DeleteCustomerResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TDeleteCustomerRequest
) As TDeleteCustomerResult
public:
[ExtensionAttribute]
generic<typename TDeleteCustomerRequest, typename TDeleteCustomerResult>
where TDeleteCustomerRequest : DeleteCustomerRequest
where TDeleteCustomerResult : gcnew(), DeleteCustomerResult
static TDeleteCustomerResult DeleteCustomer(
    CustomerServiceProvider^ customerServiceProvider,
    TDeleteCustomerRequest request
)
static member DeleteCustomer :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TDeleteCustomerRequest -> 'TDeleteCustomerResult  when 'TDeleteCustomerRequest : DeleteCustomerRequest when 'TDeleteCustomerResult : new() and DeleteCustomerResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TDeleteCustomerRequest
The request

Type Parameters

TDeleteCustomerRequest
The type of the DeleteCustomerRequest
TDeleteCustomerResult
The type of the DeleteCustomerResult

Return Value

Type: TDeleteCustomerResult
An object of type DeleteCustomerResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.DeleteUser(TDeleteUserRequest, TDeleteUserResult) Method

GenericCustomerServiceProviderExtensionsDeleteUserTDeleteUserRequest, TDeleteUserResult Method
Updates the user.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TDeleteUserResult DeleteUser<TDeleteUserRequest, TDeleteUserResult>(
    this CustomerServiceProvider customerServiceProvider,
    TDeleteUserRequest request
)
where TDeleteUserRequest : DeleteUserRequest
where TDeleteUserResult : new(), DeleteUserResult

<ExtensionAttribute>
Public Shared Function DeleteUser(Of TDeleteUserRequest As DeleteUserRequest, TDeleteUserResult As {New, DeleteUserResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TDeleteUserRequest
) As TDeleteUserResult
public:
[ExtensionAttribute]
generic<typename TDeleteUserRequest, typename TDeleteUserResult>
where TDeleteUserRequest : DeleteUserRequest
where TDeleteUserResult : gcnew(), DeleteUserResult
static TDeleteUserResult DeleteUser(
    CustomerServiceProvider^ customerServiceProvider,
    TDeleteUserRequest request
)
static member DeleteUser :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TDeleteUserRequest -> 'TDeleteUserResult  when 'TDeleteUserRequest : DeleteUserRequest when 'TDeleteUserResult : new() and DeleteUserResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TDeleteUserRequest
The request

Type Parameters

TDeleteUserRequest
The type of the DeleteUserRequest
TDeleteUserResult
The type of the DeleteUserResult

Return Value

Type: TDeleteUserResult
An object of type DeleteUserResult result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.DisableCustomer(TDisableCustomerRequest, TDisableCustomerResult) Method

GenericCustomerServiceProviderExtensionsDisableCustomerTDisableCustomerRequest, TDisableCustomerResult Method
Disables the customer.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TDisableCustomerResult DisableCustomer<TDisableCustomerRequest, TDisableCustomerResult>(
    this CustomerServiceProvider customerServiceProvider,
    TDisableCustomerRequest request
)
where TDisableCustomerRequest : DisableCustomerRequest
where TDisableCustomerResult : new(), DisableCustomerResult

<ExtensionAttribute>
Public Shared Function DisableCustomer(Of TDisableCustomerRequest As DisableCustomerRequest, TDisableCustomerResult As {New, DisableCustomerResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TDisableCustomerRequest
) As TDisableCustomerResult
public:
[ExtensionAttribute]
generic<typename TDisableCustomerRequest, typename TDisableCustomerResult>
where TDisableCustomerRequest : DisableCustomerRequest
where TDisableCustomerResult : gcnew(), DisableCustomerResult
static TDisableCustomerResult DisableCustomer(
    CustomerServiceProvider^ customerServiceProvider,
    TDisableCustomerRequest request
)
static member DisableCustomer :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TDisableCustomerRequest -> 'TDisableCustomerResult  when 'TDisableCustomerRequest : DisableCustomerRequest when 'TDisableCustomerResult : new() and DisableCustomerResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TDisableCustomerRequest
The request

Type Parameters

TDisableCustomerRequest
The type of the DisableCustomerRequest
TDisableCustomerResult
The type of the DisableCustomerResult

Return Value

Type: TDisableCustomerResult
An object of type DisableCustomerResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.DisableUser(TDisableUserRequest, TDisableUserResult) Method

GenericCustomerServiceProviderExtensionsDisableUserTDisableUserRequest, TDisableUserResult Method
Updates the user.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TDisableUserResult DisableUser<TDisableUserRequest, TDisableUserResult>(
    this CustomerServiceProvider customerServiceProvider,
    TDisableUserRequest request
)
where TDisableUserRequest : DisableUserRequest
where TDisableUserResult : new(), DisableUserResult

<ExtensionAttribute>
Public Shared Function DisableUser(Of TDisableUserRequest As DisableUserRequest, TDisableUserResult As {New, DisableUserResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TDisableUserRequest
) As TDisableUserResult
public:
[ExtensionAttribute]
generic<typename TDisableUserRequest, typename TDisableUserResult>
where TDisableUserRequest : DisableUserRequest
where TDisableUserResult : gcnew(), DisableUserResult
static TDisableUserResult DisableUser(
    CustomerServiceProvider^ customerServiceProvider,
    TDisableUserRequest request
)
static member DisableUser :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TDisableUserRequest -> 'TDisableUserResult  when 'TDisableUserRequest : DisableUserRequest when 'TDisableUserResult : new() and DisableUserResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TDisableUserRequest
The request

Type Parameters

TDisableUserRequest
The type of the DisableUserRequest
TDisableUserResult
The type of the DisableUserResult

Return Value

Type: TDisableUserResult
An object of type DisableUserResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.EnableCustomer(TEnableCustomerRequest, TEnableCustomerResult) Method

GenericCustomerServiceProviderExtensionsEnableCustomerTEnableCustomerRequest, TEnableCustomerResult Method
Enables the customer.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TEnableCustomerResult EnableCustomer<TEnableCustomerRequest, TEnableCustomerResult>(
    this CustomerServiceProvider customerServiceProvider,
    TEnableCustomerRequest request
)
where TEnableCustomerRequest : EnableCustomerRequest
where TEnableCustomerResult : new(), EnableCustomerResult

<ExtensionAttribute>
Public Shared Function EnableCustomer(Of TEnableCustomerRequest As EnableCustomerRequest, TEnableCustomerResult As {New, EnableCustomerResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TEnableCustomerRequest
) As TEnableCustomerResult
public:
[ExtensionAttribute]
generic<typename TEnableCustomerRequest, typename TEnableCustomerResult>
where TEnableCustomerRequest : EnableCustomerRequest
where TEnableCustomerResult : gcnew(), EnableCustomerResult
static TEnableCustomerResult EnableCustomer(
    CustomerServiceProvider^ customerServiceProvider,
    TEnableCustomerRequest request
)
static member EnableCustomer :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TEnableCustomerRequest -> 'TEnableCustomerResult  when 'TEnableCustomerRequest : EnableCustomerRequest when 'TEnableCustomerResult : new() and EnableCustomerResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TEnableCustomerRequest
The request

Type Parameters

TEnableCustomerRequest
The type of the EnableCustomerRequest
TEnableCustomerResult
The type of the EnableCustomerResult

Return Value

Type: TEnableCustomerResult
An object of type EnableCustomerResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.EnableUser(TEnableUserRequest, TEnableUserResult) Method

GenericCustomerServiceProviderExtensionsEnableUserTEnableUserRequest, TEnableUserResult Method
Updates the user.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TEnableUserResult EnableUser<TEnableUserRequest, TEnableUserResult>(
    this CustomerServiceProvider customerServiceProvider,
    TEnableUserRequest request
)
where TEnableUserRequest : EnableUserRequest
where TEnableUserResult : new(), EnableUserResult

<ExtensionAttribute>
Public Shared Function EnableUser(Of TEnableUserRequest As EnableUserRequest, TEnableUserResult As {New, EnableUserResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TEnableUserRequest
) As TEnableUserResult
public:
[ExtensionAttribute]
generic<typename TEnableUserRequest, typename TEnableUserResult>
where TEnableUserRequest : EnableUserRequest
where TEnableUserResult : gcnew(), EnableUserResult
static TEnableUserResult EnableUser(
    CustomerServiceProvider^ customerServiceProvider,
    TEnableUserRequest request
)
static member EnableUser :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TEnableUserRequest -> 'TEnableUserResult  when 'TEnableUserRequest : EnableUserRequest when 'TEnableUserResult : new() and EnableUserResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TEnableUserRequest
The request

Type Parameters

TEnableUserRequest
The type of the EnableUserRequest
TEnableUserResult
The type of the EnableUserResult

Return Value

Type: TEnableUserResult
An object of type EnableUserResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.GetCustomer(TGetCustomerRequest, TGetCustomerResult) Method

GenericCustomerServiceProviderExtensionsGetCustomerTGetCustomerRequest, TGetCustomerResult Method
Gets the customer.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetCustomerResult GetCustomer<TGetCustomerRequest, TGetCustomerResult>(
    this CustomerServiceProvider customerServiceProvider,
    TGetCustomerRequest request
)
where TGetCustomerRequest : GetCustomerRequest
where TGetCustomerResult : new(), GetCustomerResult

<ExtensionAttribute>
Public Shared Function GetCustomer(Of TGetCustomerRequest As GetCustomerRequest, TGetCustomerResult As {New, GetCustomerResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TGetCustomerRequest
) As TGetCustomerResult
public:
[ExtensionAttribute]
generic<typename TGetCustomerRequest, typename TGetCustomerResult>
where TGetCustomerRequest : GetCustomerRequest
where TGetCustomerResult : gcnew(), GetCustomerResult
static TGetCustomerResult GetCustomer(
    CustomerServiceProvider^ customerServiceProvider,
    TGetCustomerRequest request
)
static member GetCustomer :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TGetCustomerRequest -> 'TGetCustomerResult  when 'TGetCustomerRequest : GetCustomerRequest when 'TGetCustomerResult : new() and GetCustomerResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TGetCustomerRequest
The request

Type Parameters

TGetCustomerRequest
The type of the GetCustomerRequest
TGetCustomerResult
The type of the GetCustomerResult

Return Value

Type: TGetCustomerResult
An object of type GetCustomerResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.GetCustomers(TGetCustomersRequest, TGetCustomersResult) Method

GenericCustomerServiceProviderExtensionsGetCustomersTGetCustomersRequest, TGetCustomersResult Method
Gets the customers.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetCustomersResult GetCustomers<TGetCustomersRequest, TGetCustomersResult>(
    this CustomerServiceProvider customerServiceProvider,
    TGetCustomersRequest request
)
where TGetCustomersRequest : GetCustomersRequest
where TGetCustomersResult : new(), GetCustomersResult

<ExtensionAttribute>
Public Shared Function GetCustomers(Of TGetCustomersRequest As GetCustomersRequest, TGetCustomersResult As {New, GetCustomersResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TGetCustomersRequest
) As TGetCustomersResult
public:
[ExtensionAttribute]
generic<typename TGetCustomersRequest, typename TGetCustomersResult>
where TGetCustomersRequest : GetCustomersRequest
where TGetCustomersResult : gcnew(), GetCustomersResult
static TGetCustomersResult GetCustomers(
    CustomerServiceProvider^ customerServiceProvider,
    TGetCustomersRequest request
)
static member GetCustomers :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TGetCustomersRequest -> 'TGetCustomersResult  when 'TGetCustomersRequest : GetCustomersRequest when 'TGetCustomersResult : new() and GetCustomersResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TGetCustomersRequest
The request

Type Parameters

TGetCustomersRequest
The type of the GetCustomersRequest
TGetCustomersResult
The type of the GetCustomersResult

Return Value

Type: TGetCustomersResult
An object of type GetCustomersResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.GetParties(TGetPartiesRequest, TGetPartiesResult) Method

GenericCustomerServiceProviderExtensionsGetPartiesTGetPartiesRequest, TGetPartiesResult Method
Gets the parties.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetPartiesResult GetParties<TGetPartiesRequest, TGetPartiesResult>(
    this CustomerServiceProvider customerServiceProvider,
    TGetPartiesRequest request
)
where TGetPartiesRequest : GetPartiesRequest
where TGetPartiesResult : new(), GetPartiesResult

<ExtensionAttribute>
Public Shared Function GetParties(Of TGetPartiesRequest As GetPartiesRequest, TGetPartiesResult As {New, GetPartiesResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TGetPartiesRequest
) As TGetPartiesResult
public:
[ExtensionAttribute]
generic<typename TGetPartiesRequest, typename TGetPartiesResult>
where TGetPartiesRequest : GetPartiesRequest
where TGetPartiesResult : gcnew(), GetPartiesResult
static TGetPartiesResult GetParties(
    CustomerServiceProvider^ customerServiceProvider,
    TGetPartiesRequest request
)
static member GetParties :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TGetPartiesRequest -> 'TGetPartiesResult  when 'TGetPartiesRequest : GetPartiesRequest when 'TGetPartiesResult : new() and GetPartiesResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider.
request
Type: TGetPartiesRequest
The request.

Type Parameters

TGetPartiesRequest
The type of the get paties request.
TGetPartiesResult
The type of the get parties result.

Return Value

Type: TGetPartiesResult
An object of type GetPartiesResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.GetUser(TGetUserRequest, TGetUserResult) Method

GenericCustomerServiceProviderExtensionsGetUserTGetUserRequest, TGetUserResult Method
Gets the user.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetUserResult GetUser<TGetUserRequest, TGetUserResult>(
    this CustomerServiceProvider customerServiceProvider,
    TGetUserRequest request
)
where TGetUserRequest : GetUserRequest
where TGetUserResult : new(), GetUserResult

<ExtensionAttribute>
Public Shared Function GetUser(Of TGetUserRequest As GetUserRequest, TGetUserResult As {New, GetUserResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TGetUserRequest
) As TGetUserResult
public:
[ExtensionAttribute]
generic<typename TGetUserRequest, typename TGetUserResult>
where TGetUserRequest : GetUserRequest
where TGetUserResult : gcnew(), GetUserResult
static TGetUserResult GetUser(
    CustomerServiceProvider^ customerServiceProvider,
    TGetUserRequest request
)
static member GetUser :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TGetUserRequest -> 'TGetUserResult  when 'TGetUserRequest : GetUserRequest when 'TGetUserResult : new() and GetUserResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TGetUserRequest
The request

Type Parameters

TGetUserRequest
The type of the GetUserRequest
TGetUserResult
The type of the GetUserResult

Return Value

Type: TGetUserResult
An object of type GetUserResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.GetUsers(TGetUsersRequest, TGetUsersResult) Method

GenericCustomerServiceProviderExtensionsGetUsersTGetUsersRequest, TGetUsersResult Method
Gets the users.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetUsersResult GetUsers<TGetUsersRequest, TGetUsersResult>(
    this CustomerServiceProvider customerServiceProvider,
    TGetUsersRequest request
)
where TGetUsersRequest : GetUsersRequest
where TGetUsersResult : new(), GetUsersResult

<ExtensionAttribute>
Public Shared Function GetUsers(Of TGetUsersRequest As GetUsersRequest, TGetUsersResult As {New, GetUsersResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TGetUsersRequest
) As TGetUsersResult
public:
[ExtensionAttribute]
generic<typename TGetUsersRequest, typename TGetUsersResult>
where TGetUsersRequest : GetUsersRequest
where TGetUsersResult : gcnew(), GetUsersResult
static TGetUsersResult GetUsers(
    CustomerServiceProvider^ customerServiceProvider,
    TGetUsersRequest request
)
static member GetUsers :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TGetUsersRequest -> 'TGetUsersResult  when 'TGetUsersRequest : GetUsersRequest when 'TGetUsersResult : new() and GetUsersResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TGetUsersRequest
The request

Type Parameters

TGetUsersRequest
The type of the GetUsersRequest
TGetUsersResult
The type of the GetUsersResult

Return Value

Type: TGetUsersResult
An object of type GetUsersResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.RemoveCustomerParties(TRemoveCustomerPatiesRequest, TCustomerPartiesResult) Method

GenericCustomerServiceProviderExtensionsRemoveCustomerPartiesTRemoveCustomerPatiesRequest, TCustomerPartiesResult Method
Removes the customer parties.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TCustomerPartiesResult RemoveCustomerParties<TRemoveCustomerPatiesRequest, TCustomerPartiesResult>(
    this CustomerServiceProvider customerServiceProvider,
    TRemoveCustomerPatiesRequest request
)
where TRemoveCustomerPatiesRequest : RemoveCustomerPartiesRequest
where TCustomerPartiesResult : new(), CustomerPartiesResult

<ExtensionAttribute>
Public Shared Function RemoveCustomerParties(Of TRemoveCustomerPatiesRequest As RemoveCustomerPartiesRequest, TCustomerPartiesResult As {New, CustomerPartiesResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TRemoveCustomerPatiesRequest
) As TCustomerPartiesResult
public:
[ExtensionAttribute]
generic<typename TRemoveCustomerPatiesRequest, typename TCustomerPartiesResult>
where TRemoveCustomerPatiesRequest : RemoveCustomerPartiesRequest
where TCustomerPartiesResult : gcnew(), CustomerPartiesResult
static TCustomerPartiesResult RemoveCustomerParties(
    CustomerServiceProvider^ customerServiceProvider,
    TRemoveCustomerPatiesRequest request
)
static member RemoveCustomerParties :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TRemoveCustomerPatiesRequest -> 'TCustomerPartiesResult  when 'TRemoveCustomerPatiesRequest : RemoveCustomerPartiesRequest when 'TCustomerPartiesResult : new() and CustomerPartiesResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider.
request
Type: TRemoveCustomerPatiesRequest
The request.

Type Parameters

TRemoveCustomerPatiesRequest
The type of the remove customer paties request.
TCustomerPartiesResult
The type of the customer parties result.

Return Value

Type: TCustomerPartiesResult
An object of type CustomerPartiesResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.RemoveCustomers(TRemoveCustomersRequest, TRemoveCustomersResult) Method

GenericCustomerServiceProviderExtensionsRemoveCustomersTRemoveCustomersRequest, TRemoveCustomersResult Method
Removes customers from an existing user.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TRemoveCustomersResult RemoveCustomers<TRemoveCustomersRequest, TRemoveCustomersResult>(
    this CustomerServiceProvider customerServiceProvider,
    TRemoveCustomersRequest request
)
where TRemoveCustomersRequest : RemoveCustomersRequest
where TRemoveCustomersResult : new(), RemoveCustomersResult

<ExtensionAttribute>
Public Shared Function RemoveCustomers(Of TRemoveCustomersRequest As RemoveCustomersRequest, TRemoveCustomersResult As {New, RemoveCustomersResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TRemoveCustomersRequest
) As TRemoveCustomersResult
public:
[ExtensionAttribute]
generic<typename TRemoveCustomersRequest, typename TRemoveCustomersResult>
where TRemoveCustomersRequest : RemoveCustomersRequest
where TRemoveCustomersResult : gcnew(), RemoveCustomersResult
static TRemoveCustomersResult RemoveCustomers(
    CustomerServiceProvider^ customerServiceProvider,
    TRemoveCustomersRequest request
)
static member RemoveCustomers :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TRemoveCustomersRequest -> 'TRemoveCustomersResult  when 'TRemoveCustomersRequest : RemoveCustomersRequest when 'TRemoveCustomersResult : new() and RemoveCustomersResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TRemoveCustomersRequest
The request

Type Parameters

TRemoveCustomersRequest
The type of the RemoveCustomersRequest
TRemoveCustomersResult
The type of the RemoveCustomersResult

Return Value

Type: TRemoveCustomersResult
An object of type RemoveCustomersResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.RemoveParties(TRemovePatiesRequest, TCustomerResult) Method

GenericCustomerServiceProviderExtensionsRemovePartiesTRemovePatiesRequest, TCustomerResult Method
Removes the parties associated with the given customer.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TCustomerResult RemoveParties<TRemovePatiesRequest, TCustomerResult>(
    this CustomerServiceProvider customerServiceProvider,
    TRemovePatiesRequest request
)
where TRemovePatiesRequest : RemovePartiesRequest
where TCustomerResult : new(), CustomerResult

<ExtensionAttribute>
Public Shared Function RemoveParties(Of TRemovePatiesRequest As RemovePartiesRequest, TCustomerResult As {New, CustomerResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TRemovePatiesRequest
) As TCustomerResult
public:
[ExtensionAttribute]
generic<typename TRemovePatiesRequest, typename TCustomerResult>
where TRemovePatiesRequest : RemovePartiesRequest
where TCustomerResult : gcnew(), CustomerResult
static TCustomerResult RemoveParties(
    CustomerServiceProvider^ customerServiceProvider,
    TRemovePatiesRequest request
)
static member RemoveParties :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TRemovePatiesRequest -> 'TCustomerResult  when 'TRemovePatiesRequest : RemovePartiesRequest when 'TCustomerResult : new() and CustomerResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider.
request
Type: TRemovePatiesRequest
The request.

Type Parameters

TRemovePatiesRequest
The type of the remove customer paties request.
TCustomerResult
The type of the customer result.

Return Value

Type: TCustomerResult
An object of type CustomerResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.RemoveUsers(TRemoveUsersRequest, TRemoveUsersResult) Method

GenericCustomerServiceProviderExtensionsRemoveUsersTRemoveUsersRequest, TRemoveUsersResult Method
Removes users from an existing customer.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TRemoveUsersResult RemoveUsers<TRemoveUsersRequest, TRemoveUsersResult>(
    this CustomerServiceProvider customerServiceProvider,
    TRemoveUsersRequest request
)
where TRemoveUsersRequest : RemoveUsersRequest
where TRemoveUsersResult : new(), RemoveUsersResult

<ExtensionAttribute>
Public Shared Function RemoveUsers(Of TRemoveUsersRequest As RemoveUsersRequest, TRemoveUsersResult As {New, RemoveUsersResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TRemoveUsersRequest
) As TRemoveUsersResult
public:
[ExtensionAttribute]
generic<typename TRemoveUsersRequest, typename TRemoveUsersResult>
where TRemoveUsersRequest : RemoveUsersRequest
where TRemoveUsersResult : gcnew(), RemoveUsersResult
static TRemoveUsersResult RemoveUsers(
    CustomerServiceProvider^ customerServiceProvider,
    TRemoveUsersRequest request
)
static member RemoveUsers :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TRemoveUsersRequest -> 'TRemoveUsersResult  when 'TRemoveUsersRequest : RemoveUsersRequest when 'TRemoveUsersResult : new() and RemoveUsersResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TRemoveUsersRequest
The request

Type Parameters

TRemoveUsersRequest
The type of the RemoveUsersRequest
TRemoveUsersResult
The type of the RemoveUsersResult

Return Value

Type: TRemoveUsersResult
An object of type RemoveUsersResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.UpdateCustomer(TUpdateCustomerRequest, TUpdateCustomerResult) Method

GenericCustomerServiceProviderExtensionsUpdateCustomerTUpdateCustomerRequest, TUpdateCustomerResult Method
Updates the customer.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TUpdateCustomerResult UpdateCustomer<TUpdateCustomerRequest, TUpdateCustomerResult>(
    this CustomerServiceProvider customerServiceProvider,
    TUpdateCustomerRequest request
)
where TUpdateCustomerRequest : UpdateCustomerRequest
where TUpdateCustomerResult : new(), UpdateCustomerResult

<ExtensionAttribute>
Public Shared Function UpdateCustomer(Of TUpdateCustomerRequest As UpdateCustomerRequest, TUpdateCustomerResult As {New, UpdateCustomerResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TUpdateCustomerRequest
) As TUpdateCustomerResult
public:
[ExtensionAttribute]
generic<typename TUpdateCustomerRequest, typename TUpdateCustomerResult>
where TUpdateCustomerRequest : UpdateCustomerRequest
where TUpdateCustomerResult : gcnew(), UpdateCustomerResult
static TUpdateCustomerResult UpdateCustomer(
    CustomerServiceProvider^ customerServiceProvider,
    TUpdateCustomerRequest request
)
static member UpdateCustomer :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TUpdateCustomerRequest -> 'TUpdateCustomerResult  when 'TUpdateCustomerRequest : UpdateCustomerRequest when 'TUpdateCustomerResult : new() and UpdateCustomerResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TUpdateCustomerRequest
The request

Type Parameters

TUpdateCustomerRequest
The type of the UpdateCustomerRequest
TUpdateCustomerResult
The type of the UpdateCustomerResult

Return Value

Type: TUpdateCustomerResult
An object of type UpdateCustomerResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.UpdateCustomerParties(TUpdateCustomerPatiesRequest, TCustomerPartiesResult) Method

GenericCustomerServiceProviderExtensionsUpdateCustomerPartiesTUpdateCustomerPatiesRequest, TCustomerPartiesResult Method
Updates the customer parties.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TCustomerPartiesResult UpdateCustomerParties<TUpdateCustomerPatiesRequest, TCustomerPartiesResult>(
    this CustomerServiceProvider customerServiceProvider,
    TUpdateCustomerPatiesRequest request
)
where TUpdateCustomerPatiesRequest : UpdateCustomerPartiesRequest
where TCustomerPartiesResult : new(), CustomerPartiesResult

<ExtensionAttribute>
Public Shared Function UpdateCustomerParties(Of TUpdateCustomerPatiesRequest As UpdateCustomerPartiesRequest, TCustomerPartiesResult As {New, CustomerPartiesResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TUpdateCustomerPatiesRequest
) As TCustomerPartiesResult
public:
[ExtensionAttribute]
generic<typename TUpdateCustomerPatiesRequest, typename TCustomerPartiesResult>
where TUpdateCustomerPatiesRequest : UpdateCustomerPartiesRequest
where TCustomerPartiesResult : gcnew(), CustomerPartiesResult
static TCustomerPartiesResult UpdateCustomerParties(
    CustomerServiceProvider^ customerServiceProvider,
    TUpdateCustomerPatiesRequest request
)
static member UpdateCustomerParties :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TUpdateCustomerPatiesRequest -> 'TCustomerPartiesResult  when 'TUpdateCustomerPatiesRequest : UpdateCustomerPartiesRequest when 'TCustomerPartiesResult : new() and CustomerPartiesResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider.
request
Type: TUpdateCustomerPatiesRequest
The request.

Type Parameters

TUpdateCustomerPatiesRequest
The type of the update customer paties request.
TCustomerPartiesResult
The type of the customer parties result.

Return Value

Type: TCustomerPartiesResult
An object of type CustomerPartiesResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.UpdateParties(TUpdatePatiesRequest, TCustomerResult) Method

GenericCustomerServiceProviderExtensionsUpdatePartiesTUpdatePatiesRequest, TCustomerResult Method
Updates the parties information associated with the given customer.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TCustomerResult UpdateParties<TUpdatePatiesRequest, TCustomerResult>(
    this CustomerServiceProvider customerServiceProvider,
    TUpdatePatiesRequest request
)
where TUpdatePatiesRequest : UpdatePartiesRequest
where TCustomerResult : new(), CustomerResult

<ExtensionAttribute>
Public Shared Function UpdateParties(Of TUpdatePatiesRequest As UpdatePartiesRequest, TCustomerResult As {New, CustomerResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TUpdatePatiesRequest
) As TCustomerResult
public:
[ExtensionAttribute]
generic<typename TUpdatePatiesRequest, typename TCustomerResult>
where TUpdatePatiesRequest : UpdatePartiesRequest
where TCustomerResult : gcnew(), CustomerResult
static TCustomerResult UpdateParties(
    CustomerServiceProvider^ customerServiceProvider,
    TUpdatePatiesRequest request
)
static member UpdateParties :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TUpdatePatiesRequest -> 'TCustomerResult  when 'TUpdatePatiesRequest : UpdatePartiesRequest when 'TCustomerResult : new() and CustomerResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider.
request
Type: TUpdatePatiesRequest
The request.

Type Parameters

TUpdatePatiesRequest
The type of the update customer paties request.
TCustomerResult
The type of the customer result.

Return Value

Type: TCustomerResult
An object of type CustomerResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.UpdatePassword(TUpdatePasswordRequest, TUpdatePasswordResult) Method

GenericCustomerServiceProviderExtensionsUpdatePasswordTUpdatePasswordRequest, TUpdatePasswordResult Method
Updates the parties information associated with the given customer.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TUpdatePasswordResult UpdatePassword<TUpdatePasswordRequest, TUpdatePasswordResult>(
    this CustomerServiceProvider customerServiceProvider,
    TUpdatePasswordRequest request
)
where TUpdatePasswordRequest : UpdatePasswordRequest
where TUpdatePasswordResult : new(), UpdatePasswordResult

<ExtensionAttribute>
Public Shared Function UpdatePassword(Of TUpdatePasswordRequest As UpdatePasswordRequest, TUpdatePasswordResult As {New, UpdatePasswordResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TUpdatePasswordRequest
) As TUpdatePasswordResult
public:
[ExtensionAttribute]
generic<typename TUpdatePasswordRequest, typename TUpdatePasswordResult>
where TUpdatePasswordRequest : UpdatePasswordRequest
where TUpdatePasswordResult : gcnew(), UpdatePasswordResult
static TUpdatePasswordResult UpdatePassword(
    CustomerServiceProvider^ customerServiceProvider,
    TUpdatePasswordRequest request
)
static member UpdatePassword :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TUpdatePasswordRequest -> 'TUpdatePasswordResult  when 'TUpdatePasswordRequest : UpdatePasswordRequest when 'TUpdatePasswordResult : new() and UpdatePasswordResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider.
request
Type: TUpdatePasswordRequest
The request.

Type Parameters

TUpdatePasswordRequest
The type of the update password request.
TUpdatePasswordResult
The type of the update password result.

Return Value

Type: TUpdatePasswordResult
An object of type UpdatePasswordResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


GenericCustomerServiceProviderExtensions.UpdateUser(TUpdateUserRequest, TUpdateUserResult) Method

GenericCustomerServiceProviderExtensionsUpdateUserTUpdateUserRequest, TUpdateUserResult Method
Updates the user.

Namespace: Sitecore.Commerce.Services.Customers.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TUpdateUserResult UpdateUser<TUpdateUserRequest, TUpdateUserResult>(
    this CustomerServiceProvider customerServiceProvider,
    TUpdateUserRequest request
)
where TUpdateUserRequest : UpdateUserRequest
where TUpdateUserResult : new(), UpdateUserResult

<ExtensionAttribute>
Public Shared Function UpdateUser(Of TUpdateUserRequest As UpdateUserRequest, TUpdateUserResult As {New, UpdateUserResult}) (
    customerServiceProvider As CustomerServiceProvider,
    request As TUpdateUserRequest
) As TUpdateUserResult
public:
[ExtensionAttribute]
generic<typename TUpdateUserRequest, typename TUpdateUserResult>
where TUpdateUserRequest : UpdateUserRequest
where TUpdateUserResult : gcnew(), UpdateUserResult
static TUpdateUserResult UpdateUser(
    CustomerServiceProvider^ customerServiceProvider,
    TUpdateUserRequest request
)
static member UpdateUser :
        customerServiceProvider : CustomerServiceProvider *
        request : 'TUpdateUserRequest -> 'TUpdateUserResult  when 'TUpdateUserRequest : UpdateUserRequest when 'TUpdateUserResult : new() and UpdateUserResult

Parameters

customerServiceProvider
Type: Sitecore.Commerce.Services.CustomersCustomerServiceProvider
The customer service provider
request
Type: TUpdateUserRequest
The request

Type Parameters

TUpdateUserRequest
The type of the UpdateUserRequest
TUpdateUserResult
The type of the UpdateUserResult

Return Value

Type: TUpdateUserResult
An object of type UpdateUserResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CustomerServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericCustomerServiceProviderExtensions Class
Sitecore.Commerce.Services.Customers.Generics Namespace


Sitecore.Commerce.Services.Inventory Namespace

Sitecore.Commerce.Services.Inventory Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Services.Inventory"]

Classes
 | Class | Description
Public class | GetBackInStockInformationRequest | The request parameters required to retrieve updated stock information for products from an external commerce system.
Public class | GetBackInStockInformationResult | The result returned by a request to retrieve back-in-stock information for a product.
Public class | GetBackOrderableInformationRequest | The request parameters required to retrieve back-orderable information for a product.
Public class | GetBackOrderableInformationResult | The result returned by a request to retrieve back-orderable information for a product.
Public class | GetPreOrderableInformationRequest | The request parameters required to retrieve pre-orderable information for a product.
Public class | GetPreOrderableInformationResult | The result returned by a request to retrieve pre-orderable information for a product.
Public class | GetStockInformationRequest | The request parameters required for to retrieve stock information for a product.
Public class | GetStockInformationResult | The response returned by a request to retrieve stock information for a product.
Public class | InventoryServiceProvider | Represents the interaction with the inventory service. Service providers are wrapper objects that ease the interaction with the implementation pipelines. The providers only implement the calling pipelines. All the business logic is implemented in the pipeline processors. The InventoryServiceProvider class implements the ServiceProvider class.
Public class | OrderableInformationRequestBase | Base request parameters required to retrieve orderable information for a product.
Public class | OrderableInformationResultBase | The result returned by a request to retrieve orderable information for a product.
Public class | ProductsAreBackInStockRequest | The request parameters required for to call ProductAreBackInStock service method.
Public class | ProductsAreBackInStockResult | The result returned by a request to ProductAreBackInStock service method.
Public class | RemoveVisitorFromStockNotificationRequest | The request parameters required to remove a visitor from EA plan so they will no longer be notified when a product gets back in stock
Public class | RemoveVisitorFromStockNotificationResult | The result returned by a request to RemoveVisitorFromStockNotification service method.
Public class | StockStatusForIndexingRequest | The request parameters required for to retrieve stock information for a product.
Public class | StockStatusForIndexingResult | The response returned by a request to retrieve stock information for a product.
Public class | VisitedProductStockStatusRequest | The request parameters required for to trigger visitedn product stock status page event.
Public class | VisitedProductStockStatusResult | The result returned by a request to VisitedProductStockStatus service method.
Public class | VisitorSignUpForStockNotificationRequest | The request parameters required to add visitor to EA plan back in stock notification and trigger back in stock subscription page event.
Public class | VisitorSignUpForStockNotificationResult | The result returned by a request to VisitorSignUpForStockNotification service method.


GetBackInStockInformationRequest Class

GetBackInStockInformationRequest Class
The request parameters required to retrieve updated stock information for products from an external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.InventoryGetBackInStockInformationRequest

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetBackInStockInformationRequest : ServiceProviderRequest
Public Class GetBackInStockInformationRequest
    Inherits ServiceProviderRequest
public ref class GetBackInStockInformationRequest : public ServiceProviderRequest
type GetBackInStockInformationRequest =
    class
        inherit ServiceProviderRequest
    end

The GetBackInStockInformationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetBackInStockInformationRequest | Initializes an instance of the GetBackInStockInformationRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Products | Gets or sets the products whose stock information is requested.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop that will be examined for stock information.
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


GetBackInStockInformationRequest Constructor

GetBackInStockInformationRequest Constructor
Initializes an instance of the GetBackInStockInformationRequest class.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetBackInStockInformationRequest(
    string shopName
)
Public Sub New (
    shopName As String
)
public:
GetBackInStockInformationRequest(
    String^ shopName
)
new :
        shopName : string -> GetBackInStockInformationRequest

Parameters

shopName
Type: SystemString
The name of the shop that will be examined for stock information.
See Also

Reference

GetBackInStockInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetBackInStockInformationRequest Methods

GetBackInStockInformationRequest Methods

The GetBackInStockInformationRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetBackInStockInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetBackInStockInformationRequest Properties

GetBackInStockInformationRequest Properties

The GetBackInStockInformationRequest type exposes the following members.

Properties
 | Name | Description
Public property | Products | Gets or sets the products whose stock information is requested.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop that will be examined for stock information.
Top
See Also

Reference

GetBackInStockInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetBackInStockInformationRequest.Products Property

GetBackInStockInformationRequestProducts Property
Gets or sets the products whose stock information is requested.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<InventoryProduct> Products { get; set; }
Public Property Products As IEnumerable(Of InventoryProduct)
    Get
    Set
public:
property IEnumerable<InventoryProduct^>^ Products {
    IEnumerable<InventoryProduct^>^ get ();
    void set (IEnumerable<InventoryProduct^>^ value);
}
member Products : IEnumerable<InventoryProduct> with get, set

Property Value

Type: IEnumerable InventoryProduct
See Also

Reference

GetBackInStockInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetBackInStockInformationRequest.ShopName Property

GetBackInStockInformationRequestShopName Property
Gets or sets the name of the shop that will be examined for stock information.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
See Also

Reference

GetBackInStockInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetBackInStockInformationResult Class

GetBackInStockInformationResult Class
The result returned by a request to retrieve back-in-stock information for a product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.InventoryGetBackInStockInformationResult

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetBackInStockInformationResult : ServiceProviderResult
Public Class GetBackInStockInformationResult
    Inherits ServiceProviderResult
public ref class GetBackInStockInformationResult : public ServiceProviderResult
type GetBackInStockInformationResult =
    class
        inherit ServiceProviderResult
    end

The GetBackInStockInformationResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetBackInStockInformationResult | Initializes a new instance of the GetBackInStockInformationResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | StockInformationUpdates | Gets or sets the IDs of the products whose stock information is Resulted.
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


GetBackInStockInformationResult Constructor

GetBackInStockInformationResult Constructor
Initializes a new instance of the GetBackInStockInformationResult class

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetBackInStockInformationResult()
Public Sub New
public:
GetBackInStockInformationResult()
new : unit -> GetBackInStockInformationResult
See Also

Reference

GetBackInStockInformationResult Class
Sitecore.Commerce.Services.Inventory Namespace


GetBackInStockInformationResult Methods

GetBackInStockInformationResult Methods

The GetBackInStockInformationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetBackInStockInformationResult Class
Sitecore.Commerce.Services.Inventory Namespace


GetBackInStockInformationResult Properties

GetBackInStockInformationResult Properties

The GetBackInStockInformationResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | StockInformationUpdates | Gets or sets the IDs of the products whose stock information is Resulted.
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetBackInStockInformationResult Class
Sitecore.Commerce.Services.Inventory Namespace


GetBackInStockInformationResult.StockInformationUpdates Property

GetBackInStockInformationResultStockInformationUpdates Property
Gets or sets the IDs of the products whose stock information is Resulted.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection StockInformationUpdates { get; set; }
Public Property StockInformationUpdates As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ StockInformationUpdates {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member StockInformationUpdates : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
See Also

Reference

GetBackInStockInformationResult Class
Sitecore.Commerce.Services.Inventory Namespace


GetBackOrderableInformationRequest Class

GetBackOrderableInformationRequest Class
The request parameters required to retrieve back-orderable information for a product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.InventoryOrderableInformationRequestBase
Sitecore.Commerce.Services.InventoryGetBackOrderableInformationRequest

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetBackOrderableInformationRequest : OrderableInformationRequestBase
Public Class GetBackOrderableInformationRequest
    Inherits OrderableInformationRequestBase
public ref class GetBackOrderableInformationRequest : public OrderableInformationRequestBase
type GetBackOrderableInformationRequest =
    class
        inherit OrderableInformationRequestBase
    end

The GetBackOrderableInformationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetBackOrderableInformationRequest | Initializes an instance of the GetBackOrderableInformationRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Location | Gets or sets the specific warehouse or central storage where where stock information is requested. (Inherited from OrderableInformationRequestBase.)
Public property | Products | Gets or sets the products whose orderable information is requested. (Inherited from OrderableInformationRequestBase.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop that will be examined for orderable information. (Inherited from OrderableInformationRequestBase.)
Public property | VisitorId | Gets or sets the ID of the visitor or customer requesting orderable information. (Inherited from OrderableInformationRequestBase.)
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


GetBackOrderableInformationRequest Constructor

GetBackOrderableInformationRequest Constructor
Initializes an instance of the GetBackOrderableInformationRequest class.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetBackOrderableInformationRequest(
    string shopName,
    IEnumerable<InventoryProduct> products
)
Public Sub New (
    shopName As String,
    products As IEnumerable(Of InventoryProduct)
)
public:
GetBackOrderableInformationRequest(
    String^ shopName,
    IEnumerable<InventoryProduct^>^ products
)
new :
        shopName : string *
        products : IEnumerable<InventoryProduct> -> GetBackOrderableInformationRequest

Parameters

shopName
Type: SystemString
The name of the shop that will be examined for back-orderable information.
products
Type: System.Collections.GenericIEnumerable InventoryProduct
The products whose back-orderable information is requested.
See Also

Reference

GetBackOrderableInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetBackOrderableInformationRequest Methods

GetBackOrderableInformationRequest Methods

The GetBackOrderableInformationRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetBackOrderableInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetBackOrderableInformationRequest Properties

GetBackOrderableInformationRequest Properties

The GetBackOrderableInformationRequest type exposes the following members.

Properties
 | Name | Description
Public property | Location | Gets or sets the specific warehouse or central storage where where stock information is requested. (Inherited from OrderableInformationRequestBase.)
Public property | Products | Gets or sets the products whose orderable information is requested. (Inherited from OrderableInformationRequestBase.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop that will be examined for orderable information. (Inherited from OrderableInformationRequestBase.)
Public property | VisitorId | Gets or sets the ID of the visitor or customer requesting orderable information. (Inherited from OrderableInformationRequestBase.)
Top
See Also

Reference

GetBackOrderableInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetBackOrderableInformationResult Class

GetBackOrderableInformationResult Class
The result returned by a request to retrieve back-orderable information for a product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.InventoryOrderableInformationResultBase
Sitecore.Commerce.Services.InventoryGetBackOrderableInformationResult

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetBackOrderableInformationResult : OrderableInformationResultBase
Public Class GetBackOrderableInformationResult
    Inherits OrderableInformationResultBase
public ref class GetBackOrderableInformationResult : public OrderableInformationResultBase
type GetBackOrderableInformationResult =
    class
        inherit OrderableInformationResultBase
    end

The GetBackOrderableInformationResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetBackOrderableInformationResult | Initializes a new instance of the GetBackOrderableInformationResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | OrderableInformation | Gets or sets the orderable information for the requested products. (Inherited from OrderableInformationResultBase.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


GetBackOrderableInformationResult Constructor

GetBackOrderableInformationResult Constructor
Initializes a new instance of the GetBackOrderableInformationResult class

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetBackOrderableInformationResult()
Public Sub New
public:
GetBackOrderableInformationResult()
new : unit -> GetBackOrderableInformationResult
See Also

Reference

GetBackOrderableInformationResult Class
Sitecore.Commerce.Services.Inventory Namespace


GetBackOrderableInformationResult Methods

GetBackOrderableInformationResult Methods

The GetBackOrderableInformationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetBackOrderableInformationResult Class
Sitecore.Commerce.Services.Inventory Namespace


GetBackOrderableInformationResult Properties

GetBackOrderableInformationResult Properties

The GetBackOrderableInformationResult type exposes the following members.

Properties
 | Name | Description
Public property | OrderableInformation | Gets or sets the orderable information for the requested products. (Inherited from OrderableInformationResultBase.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetBackOrderableInformationResult Class
Sitecore.Commerce.Services.Inventory Namespace


GetPreOrderableInformationRequest Class

GetPreOrderableInformationRequest Class
The request parameters required to retrieve pre-orderable information for a product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.InventoryOrderableInformationRequestBase
Sitecore.Commerce.Services.InventoryGetPreOrderableInformationRequest

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetPreOrderableInformationRequest : OrderableInformationRequestBase
Public Class GetPreOrderableInformationRequest
    Inherits OrderableInformationRequestBase
public ref class GetPreOrderableInformationRequest : public OrderableInformationRequestBase
type GetPreOrderableInformationRequest =
    class
        inherit OrderableInformationRequestBase
    end

The GetPreOrderableInformationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetPreOrderableInformationRequest | Initializes an instance of the GetPreOrderableInformationRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Location | Gets or sets the specific warehouse or central storage where where stock information is requested. (Inherited from OrderableInformationRequestBase.)
Public property | Products | Gets or sets the products whose orderable information is requested. (Inherited from OrderableInformationRequestBase.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop that will be examined for orderable information. (Inherited from OrderableInformationRequestBase.)
Public property | VisitorId | Gets or sets the ID of the visitor or customer requesting orderable information. (Inherited from OrderableInformationRequestBase.)
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


GetPreOrderableInformationRequest Constructor

GetPreOrderableInformationRequest Constructor
Initializes an instance of the GetPreOrderableInformationRequest class.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetPreOrderableInformationRequest(
    string shopName,
    IEnumerable<InventoryProduct> products
)
Public Sub New (
    shopName As String,
    products As IEnumerable(Of InventoryProduct)
)
public:
GetPreOrderableInformationRequest(
    String^ shopName,
    IEnumerable<InventoryProduct^>^ products
)
new :
        shopName : string *
        products : IEnumerable<InventoryProduct> -> GetPreOrderableInformationRequest

Parameters

shopName
Type: SystemString
The name of the shop that will be examined for pre-orderable information.
products
Type: System.Collections.GenericIEnumerable InventoryProduct
The products whose pre-orderable information is requested.
See Also

Reference

GetPreOrderableInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetPreOrderableInformationRequest Methods

GetPreOrderableInformationRequest Methods

The GetPreOrderableInformationRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetPreOrderableInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetPreOrderableInformationRequest Properties

GetPreOrderableInformationRequest Properties

The GetPreOrderableInformationRequest type exposes the following members.

Properties
 | Name | Description
Public property | Location | Gets or sets the specific warehouse or central storage where where stock information is requested. (Inherited from OrderableInformationRequestBase.)
Public property | Products | Gets or sets the products whose orderable information is requested. (Inherited from OrderableInformationRequestBase.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop that will be examined for orderable information. (Inherited from OrderableInformationRequestBase.)
Public property | VisitorId | Gets or sets the ID of the visitor or customer requesting orderable information. (Inherited from OrderableInformationRequestBase.)
Top
See Also

Reference

GetPreOrderableInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetPreOrderableInformationResult Class

GetPreOrderableInformationResult Class
The result returned by a request to retrieve pre-orderable information for a product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.InventoryOrderableInformationResultBase
Sitecore.Commerce.Services.InventoryGetPreOrderableInformationResult

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetPreOrderableInformationResult : OrderableInformationResultBase
Public Class GetPreOrderableInformationResult
    Inherits OrderableInformationResultBase
public ref class GetPreOrderableInformationResult : public OrderableInformationResultBase
type GetPreOrderableInformationResult =
    class
        inherit OrderableInformationResultBase
    end

The GetPreOrderableInformationResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetPreOrderableInformationResult | Initializes a new instance of the GetPreOrderableInformationResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | OrderableInformation | Gets or sets the orderable information for the requested products. (Inherited from OrderableInformationResultBase.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


GetPreOrderableInformationResult Constructor

GetPreOrderableInformationResult Constructor
Initializes a new instance of the GetPreOrderableInformationResult class

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetPreOrderableInformationResult()
Public Sub New
public:
GetPreOrderableInformationResult()
new : unit -> GetPreOrderableInformationResult
See Also

Reference

GetPreOrderableInformationResult Class
Sitecore.Commerce.Services.Inventory Namespace


GetPreOrderableInformationResult Methods

GetPreOrderableInformationResult Methods

The GetPreOrderableInformationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetPreOrderableInformationResult Class
Sitecore.Commerce.Services.Inventory Namespace


GetPreOrderableInformationResult Properties

GetPreOrderableInformationResult Properties

The GetPreOrderableInformationResult type exposes the following members.

Properties
 | Name | Description
Public property | OrderableInformation | Gets or sets the orderable information for the requested products. (Inherited from OrderableInformationResultBase.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetPreOrderableInformationResult Class
Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationRequest Class

GetStockInformationRequest Class
The request parameters required for to retrieve stock information for a product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.InventoryGetStockInformationRequest

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetStockInformationRequest : ServiceProviderRequest
Public Class GetStockInformationRequest
    Inherits ServiceProviderRequest
public ref class GetStockInformationRequest : public ServiceProviderRequest
type GetStockInformationRequest =
    class
        inherit ServiceProviderRequest
    end

The GetStockInformationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetStockInformationRequest(String, IEnumerableInventoryProduct) | Initializes an instance of the GetStockInformationRequest class.
Public method | GetStockInformationRequest(String, IEnumerableInventoryProduct, StockDetailsLevel) | Initializes an instance of the GetStockInformationRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DetailsLevel | Gets or sets the level of stock details that are requested.
Public property | Location | Gets or sets the specific warehouse or central storage where where stock information is requested.
Public property | Products | Gets or sets the products whose stock information is requested..
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop that will be examined for stock information.
Public property | VisitorId | Gets or sets the ID of the customer requesting stock information, in case the stock information is dependent on the actual customer.
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationRequest Constructor

GetStockInformationRequest Constructor
Overload List
 | Name | Description
Public method | GetStockInformationRequest(String, IEnumerableInventoryProduct) | Initializes an instance of the GetStockInformationRequest class.
Public method | GetStockInformationRequest(String, IEnumerableInventoryProduct, StockDetailsLevel) | Initializes an instance of the GetStockInformationRequest class.
Top
See Also

Reference

GetStockInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationRequest Constructor (String, IEnumerable(InventoryProduct))

GetStockInformationRequest Constructor (String, IEnumerableInventoryProduct)
Initializes an instance of the GetStockInformationRequest class.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetStockInformationRequest(
    string shopName,
    IEnumerable<InventoryProduct> products
)
Public Sub New (
    shopName As String,
    products As IEnumerable(Of InventoryProduct)
)
public:
GetStockInformationRequest(
    String^ shopName,
    IEnumerable<InventoryProduct^>^ products
)
new :
        shopName : string *
        products : IEnumerable<InventoryProduct> -> GetStockInformationRequest

Parameters

shopName
Type: SystemString
The name of the shop that will be examined for stock information.
products
Type: System.Collections.GenericIEnumerable InventoryProduct
The products whose stock information is requested.
See Also

Reference

GetStockInformationRequest Class
GetStockInformationRequest Overload
Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationRequest Constructor (String, IEnumerable(InventoryProduct), StockDetailsLevel)

GetStockInformationRequest Constructor (String, IEnumerableInventoryProduct, StockDetailsLevel)
Initializes an instance of the GetStockInformationRequest class.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetStockInformationRequest(
    string shopName,
    IEnumerable<InventoryProduct> products,
    StockDetailsLevel detailsLevel
)
Public Sub New (
    shopName As String,
    products As IEnumerable(Of InventoryProduct),
    detailsLevel As StockDetailsLevel
)
public:
GetStockInformationRequest(
    String^ shopName,
    IEnumerable<InventoryProduct^>^ products,
    StockDetailsLevel^ detailsLevel
)
new :
        shopName : string *
        products : IEnumerable<InventoryProduct> *
        detailsLevel : StockDetailsLevel -> GetStockInformationRequest

Parameters

shopName
Type: SystemString
The name of the shop that will be examined for stock information.
products
Type: System.Collections.GenericIEnumerable InventoryProduct
The products whose stock information is requested.
detailsLevel
Type: Sitecore.Commerce.Entities.InventoryStockDetailsLevel
The level of stock details that are requested.
See Also

Reference

GetStockInformationRequest Class
GetStockInformationRequest Overload
Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationRequest Methods

GetStockInformationRequest Methods

The GetStockInformationRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetStockInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationRequest Properties

GetStockInformationRequest Properties

The GetStockInformationRequest type exposes the following members.

Properties
 | Name | Description
Public property | DetailsLevel | Gets or sets the level of stock details that are requested.
Public property | Location | Gets or sets the specific warehouse or central storage where where stock information is requested.
Public property | Products | Gets or sets the products whose stock information is requested..
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop that will be examined for stock information.
Public property | VisitorId | Gets or sets the ID of the customer requesting stock information, in case the stock information is dependent on the actual customer.
Top
See Also

Reference

GetStockInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationRequest.DetailsLevel Property

GetStockInformationRequestDetailsLevel Property
Gets or sets the level of stock details that are requested.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(StockDetailsLevelConverter))]
public StockDetailsLevel DetailsLevel { get; set; }
<TypeConverterAttribute(GetType(StockDetailsLevelConverter))>
Public Property DetailsLevel As StockDetailsLevel
    Get
    Set
public:
[TypeConverterAttribute(typeof(StockDetailsLevelConverter))]
property StockDetailsLevel^ DetailsLevel {
    StockDetailsLevel^ get ();
    void set (StockDetailsLevel^ value);
}
[<TypeConverterAttribute(typeof(StockDetailsLevelConverter))>]
member DetailsLevel : StockDetailsLevel with get, set

Property Value

Type: StockDetailsLevel
See Also

Reference

GetStockInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationRequest.Location Property

GetStockInformationRequestLocation Property
Gets or sets the specific warehouse or central storage where where stock information is requested.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
See Also

Reference

GetStockInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationRequest.Products Property

GetStockInformationRequestProducts Property
Gets or sets the products whose stock information is requested..

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<InventoryProduct> Products { get; set; }
Public Property Products As IEnumerable(Of InventoryProduct)
    Get
    Set
public:
property IEnumerable<InventoryProduct^>^ Products {
    IEnumerable<InventoryProduct^>^ get ();
    void set (IEnumerable<InventoryProduct^>^ value);
}
member Products : IEnumerable<InventoryProduct> with get, set

Property Value

Type: IEnumerable InventoryProduct
See Also

Reference

GetStockInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationRequest.ShopName Property

GetStockInformationRequestShopName Property
Gets or sets the name of the shop that will be examined for stock information.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
See Also

Reference

GetStockInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationRequest.VisitorId Property

GetStockInformationRequestVisitorId Property
Gets or sets the ID of the customer requesting stock information, in case the stock information is dependent on the actual customer.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string VisitorId { get; set; }
Public Property VisitorId As String
    Get
    Set
public:
property String^ VisitorId {
    String^ get ();
    void set (String^ value);
}
member VisitorId : string with get, set

Property Value

Type: String
See Also

Reference

GetStockInformationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationResult Class

GetStockInformationResult Class
The response returned by a request to retrieve stock information for a product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.InventoryGetStockInformationResult

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetStockInformationResult : ServiceProviderResult
Public Class GetStockInformationResult
    Inherits ServiceProviderResult
public ref class GetStockInformationResult : public ServiceProviderResult
type GetStockInformationResult =
    class
        inherit ServiceProviderResult
    end

The GetStockInformationResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetStockInformationResult | Initializes a new instance of the GetStockInformationResult class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | StockInformation | Gets or sets the stock information for the requested products.
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationResult Constructor

GetStockInformationResult Constructor
Initializes a new instance of the GetStockInformationResult class.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetStockInformationResult()
Public Sub New
public:
GetStockInformationResult()
new : unit -> GetStockInformationResult
See Also

Reference

GetStockInformationResult Class
Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationResult Methods

GetStockInformationResult Methods

The GetStockInformationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetStockInformationResult Class
Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationResult Properties

GetStockInformationResult Properties

The GetStockInformationResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | StockInformation | Gets or sets the stock information for the requested products.
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetStockInformationResult Class
Sitecore.Commerce.Services.Inventory Namespace


GetStockInformationResult.StockInformation Property

GetStockInformationResultStockInformation Property
Gets or sets the stock information for the requested products.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<StockInformation> StockInformation { get; set; }
Public Property StockInformation As IEnumerable(Of StockInformation)
    Get
    Set
public:
property IEnumerable<StockInformation^>^ StockInformation {
    IEnumerable<StockInformation^>^ get ();
    void set (IEnumerable<StockInformation^>^ value);
}
member StockInformation : IEnumerable<StockInformation> with get, set

Property Value

Type: IEnumerable StockInformation
See Also

Reference

GetStockInformationResult Class
Sitecore.Commerce.Services.Inventory Namespace


InventoryServiceProvider Class

InventoryServiceProvider Class
Represents the interaction with the inventory service. Service providers are wrapper objects that ease the interaction with the implementation pipelines. The providers only implement the calling pipelines. All the business logic is implemented in the pipeline processors. The InventoryServiceProvider class implements the ServiceProvider class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProvider
Sitecore.Commerce.Services.InventoryInventoryServiceProvider

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class InventoryServiceProvider : ServiceProvider
Public Class InventoryServiceProvider
    Inherits ServiceProvider
public ref class InventoryServiceProvider : public ServiceProvider
type InventoryServiceProvider =
    class
        inherit ServiceProvider
    end

The InventoryServiceProvider type exposes the following members.

Constructors
 | Name | Description
Public method | InventoryServiceProvider | Initializes a new instance of the InventoryServiceProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBackInStockInformation | Retrieves updated stock information for products from an external commerce system.
Public method | GetBackOrderableInformation | Retrieves back-rderable information for products.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPreOrderableInformation | Retrieves pre-orderable information for products.
Public method | GetStockInformation | Retrieves stock information for products.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProductsAreBackInStock | Updates a product stock count
Public method | RemoveVisitorFromStockNotification | Adds a visitor to EA plan so they can be notified when the product gets back in stock
Public method | RunPipelineTRequest, TResult | Runs the pipeline. (Inherited from ServiceProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VisitedProductStockStatus | Track product stock status for customers visiting product details pages
Public method | VisitorSignUpForStockNotification | Adds a visitor to EA plan so they can be notified when the product gets back in stock
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBackInStockInformationTGetBackInStockInformationRequest, TGetBackInStockInformationResult | Retrieves updated stock information for products from an external commerce system. (Defined by GenericInventoryServiceProviderExtensions.)
Public Extension Method | GetBackOrderableInformationTGetBackOrderableInformationRequest, TGetBackOrderableInformationResult | Retrieves backorderable information for products. It calls the GetBackOrderableInformation pipeline. (Defined by GenericInventoryServiceProviderExtensions.)
Public Extension Method | GetPreOrderableInformationTGetPreOrderableInformationRequest, TGetPreOrderableInformationResult | Retrieves preorderable information for products. It calls the GetPreOrderableInformation pipeline. (Defined by GenericInventoryServiceProviderExtensions.)
Public Extension Method | GetStockInformationTGetStockInformationRequest, TGetStockInformationResult | Retrieves stock information for products. It calls the GetStockInformation pipeline. (Defined by GenericInventoryServiceProviderExtensions.)
Public Extension Method | ProductsAreBackInStockTProductsAreBackInStockRequest, TProductsAreBackInStockResult | Updates a product stock count (Defined by GenericInventoryServiceProviderExtensions.)
Public Extension Method | RemoveVisitorFromStockNotificationTRemoveVisitorFromStockNotificationRequest, TRemoveVisitorFromStockNotificationResult | Removes a visitor from EA plan so they will no longer be notified when a product gets back in stock (Defined by GenericInventoryServiceProviderExtensions.)
Public Extension Method | VisitedProductStockStatusTVisitedProductStockStatusRequest, TVisitedProductStockStatusResult | Track product stock status for customers visiting product details pages (Defined by GenericInventoryServiceProviderExtensions.)
Public Extension Method | VisitorSignUpForStockNotificationTVisitorSignUpForStockNotificationRequest, TVisitorSignUpForStockNotificationResult | Adds a visitor to EA plan so they can be notified when the product gets back in stock (Defined by GenericInventoryServiceProviderExtensions.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from ServiceProvider.)
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


InventoryServiceProvider Constructor

InventoryServiceProvider Constructor
Initializes a new instance of the InventoryServiceProvider class

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public InventoryServiceProvider()
Public Sub New
public:
InventoryServiceProvider()
new : unit -> InventoryServiceProvider
See Also

Reference

InventoryServiceProvider Class
Sitecore.Commerce.Services.Inventory Namespace


InventoryServiceProvider Methods

InventoryServiceProvider Methods

The InventoryServiceProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBackInStockInformation | Retrieves updated stock information for products from an external commerce system.
Public method | GetBackOrderableInformation | Retrieves back-rderable information for products.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPreOrderableInformation | Retrieves pre-orderable information for products.
Public method | GetStockInformation | Retrieves stock information for products.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProductsAreBackInStock | Updates a product stock count
Public method | RemoveVisitorFromStockNotification | Adds a visitor to EA plan so they can be notified when the product gets back in stock
Public method | RunPipelineTRequest, TResult | Runs the pipeline. (Inherited from ServiceProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VisitedProductStockStatus | Track product stock status for customers visiting product details pages
Public method | VisitorSignUpForStockNotification | Adds a visitor to EA plan so they can be notified when the product gets back in stock
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBackInStockInformationTGetBackInStockInformationRequest, TGetBackInStockInformationResult | Retrieves updated stock information for products from an external commerce system. (Defined by GenericInventoryServiceProviderExtensions.)
Public Extension Method | GetBackOrderableInformationTGetBackOrderableInformationRequest, TGetBackOrderableInformationResult | Retrieves backorderable information for products. It calls the GetBackOrderableInformation pipeline. (Defined by GenericInventoryServiceProviderExtensions.)
Public Extension Method | GetPreOrderableInformationTGetPreOrderableInformationRequest, TGetPreOrderableInformationResult | Retrieves preorderable information for products. It calls the GetPreOrderableInformation pipeline. (Defined by GenericInventoryServiceProviderExtensions.)
Public Extension Method | GetStockInformationTGetStockInformationRequest, TGetStockInformationResult | Retrieves stock information for products. It calls the GetStockInformation pipeline. (Defined by GenericInventoryServiceProviderExtensions.)
Public Extension Method | ProductsAreBackInStockTProductsAreBackInStockRequest, TProductsAreBackInStockResult | Updates a product stock count (Defined by GenericInventoryServiceProviderExtensions.)
Public Extension Method | RemoveVisitorFromStockNotificationTRemoveVisitorFromStockNotificationRequest, TRemoveVisitorFromStockNotificationResult | Removes a visitor from EA plan so they will no longer be notified when a product gets back in stock (Defined by GenericInventoryServiceProviderExtensions.)
Public Extension Method | VisitedProductStockStatusTVisitedProductStockStatusRequest, TVisitedProductStockStatusResult | Track product stock status for customers visiting product details pages (Defined by GenericInventoryServiceProviderExtensions.)
Public Extension Method | VisitorSignUpForStockNotificationTVisitorSignUpForStockNotificationRequest, TVisitorSignUpForStockNotificationResult | Adds a visitor to EA plan so they can be notified when the product gets back in stock (Defined by GenericInventoryServiceProviderExtensions.)
Top
See Also

Reference

InventoryServiceProvider Class
Sitecore.Commerce.Services.Inventory Namespace


InventoryServiceProvider.GetBackInStockInformation Method

InventoryServiceProviderGetBackInStockInformation Method
Retrieves updated stock information for products from an external commerce system.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetBackInStockInformationResult GetBackInStockInformation(
    GetBackInStockInformationRequest request
)
Public Overridable Function GetBackInStockInformation (
    request As GetBackInStockInformationRequest
) As GetBackInStockInformationResult
public:
virtual GetBackInStockInformationResult^ GetBackInStockInformation(
    GetBackInStockInformationRequest^ request
)
abstract GetBackInStockInformation :
        request : GetBackInStockInformationRequest -> GetBackInStockInformationResult
override GetBackInStockInformation :
        request : GetBackInStockInformationRequest -> GetBackInStockInformationResult

Parameters

request
Type: Sitecore.Commerce.Services.InventoryGetBackInStockInformationRequest

[Missing <param name="request"/> documentation for "M:Sitecore.Commerce.Services.Inventory.InventoryServiceProvider.GetBackInStockInformation(Sitecore.Commerce.Services.Inventory.GetBackInStockInformationRequest)"]

Return Value

Type: GetBackInStockInformationResult
The service response.
See Also

Reference

InventoryServiceProvider Class
Sitecore.Commerce.Services.Inventory Namespace


InventoryServiceProvider.GetBackOrderableInformation Method

InventoryServiceProviderGetBackOrderableInformation Method
Retrieves back-rderable information for products.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetBackOrderableInformationResult GetBackOrderableInformation(
    GetBackOrderableInformationRequest request
)
Public Overridable Function GetBackOrderableInformation (
    request As GetBackOrderableInformationRequest
) As GetBackOrderableInformationResult
public:
virtual GetBackOrderableInformationResult^ GetBackOrderableInformation(
    GetBackOrderableInformationRequest^ request
)
abstract GetBackOrderableInformation :
        request : GetBackOrderableInformationRequest -> GetBackOrderableInformationResult
override GetBackOrderableInformation :
        request : GetBackOrderableInformationRequest -> GetBackOrderableInformationResult

Parameters

request
Type: Sitecore.Commerce.Services.InventoryGetBackOrderableInformationRequest
The service request.

Return Value

Type: GetBackOrderableInformationResult
The service response.
See Also

Reference

InventoryServiceProvider Class
Sitecore.Commerce.Services.Inventory Namespace


InventoryServiceProvider.GetPreOrderableInformation Method

InventoryServiceProviderGetPreOrderableInformation Method
Retrieves pre-orderable information for products.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetPreOrderableInformationResult GetPreOrderableInformation(
    GetPreOrderableInformationRequest request
)
Public Overridable Function GetPreOrderableInformation (
    request As GetPreOrderableInformationRequest
) As GetPreOrderableInformationResult
public:
virtual GetPreOrderableInformationResult^ GetPreOrderableInformation(
    GetPreOrderableInformationRequest^ request
)
abstract GetPreOrderableInformation :
        request : GetPreOrderableInformationRequest -> GetPreOrderableInformationResult
override GetPreOrderableInformation :
        request : GetPreOrderableInformationRequest -> GetPreOrderableInformationResult

Parameters

request
Type: Sitecore.Commerce.Services.InventoryGetPreOrderableInformationRequest
The service request.

Return Value

Type: GetPreOrderableInformationResult
The service response.
See Also

Reference

InventoryServiceProvider Class
Sitecore.Commerce.Services.Inventory Namespace


InventoryServiceProvider.GetStockInformation Method

InventoryServiceProviderGetStockInformation Method
Retrieves stock information for products.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetStockInformationResult GetStockInformation(
    GetStockInformationRequest request
)
Public Overridable Function GetStockInformation (
    request As GetStockInformationRequest
) As GetStockInformationResult
public:
virtual GetStockInformationResult^ GetStockInformation(
    GetStockInformationRequest^ request
)
abstract GetStockInformation :
        request : GetStockInformationRequest -> GetStockInformationResult
override GetStockInformation :
        request : GetStockInformationRequest -> GetStockInformationResult

Parameters

request
Type: Sitecore.Commerce.Services.InventoryGetStockInformationRequest
The service request.

Return Value

Type: GetStockInformationResult
The service response.
See Also

Reference

InventoryServiceProvider Class
Sitecore.Commerce.Services.Inventory Namespace


InventoryServiceProvider.ProductsAreBackInStock Method

InventoryServiceProviderProductsAreBackInStock Method
Updates a product stock count

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ProductsAreBackInStockResult ProductsAreBackInStock(
    ProductsAreBackInStockRequest request
)
Public Overridable Function ProductsAreBackInStock (
    request As ProductsAreBackInStockRequest
) As ProductsAreBackInStockResult
public:
virtual ProductsAreBackInStockResult^ ProductsAreBackInStock(
    ProductsAreBackInStockRequest^ request
)
abstract ProductsAreBackInStock :
        request : ProductsAreBackInStockRequest -> ProductsAreBackInStockResult
override ProductsAreBackInStock :
        request : ProductsAreBackInStockRequest -> ProductsAreBackInStockResult

Parameters

request
Type: Sitecore.Commerce.Services.InventoryProductsAreBackInStockRequest
The service request.

Return Value

Type: ProductsAreBackInStockResult
The service response.
See Also

Reference

InventoryServiceProvider Class
Sitecore.Commerce.Services.Inventory Namespace


InventoryServiceProvider.RemoveVisitorFromStockNotification Method

InventoryServiceProviderRemoveVisitorFromStockNotification Method
Adds a visitor to EA plan so they can be notified when the product gets back in stock

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual RemoveVisitorFromStockNotificationResult RemoveVisitorFromStockNotification(
    RemoveVisitorFromStockNotificationRequest request
)
Public Overridable Function RemoveVisitorFromStockNotification (
    request As RemoveVisitorFromStockNotificationRequest
) As RemoveVisitorFromStockNotificationResult
public:
virtual RemoveVisitorFromStockNotificationResult^ RemoveVisitorFromStockNotification(
    RemoveVisitorFromStockNotificationRequest^ request
)
abstract RemoveVisitorFromStockNotification :
        request : RemoveVisitorFromStockNotificationRequest -> RemoveVisitorFromStockNotificationResult
override RemoveVisitorFromStockNotification :
        request : RemoveVisitorFromStockNotificationRequest -> RemoveVisitorFromStockNotificationResult

Parameters

request
Type: Sitecore.Commerce.Services.InventoryRemoveVisitorFromStockNotificationRequest
The service request.

Return Value

Type: RemoveVisitorFromStockNotificationResult
The service response.
See Also

Reference

InventoryServiceProvider Class
Sitecore.Commerce.Services.Inventory Namespace


InventoryServiceProvider.VisitedProductStockStatus Method

InventoryServiceProviderVisitedProductStockStatus Method
Track product stock status for customers visiting product details pages

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual VisitedProductStockStatusResult VisitedProductStockStatus(
    VisitedProductStockStatusRequest request
)
Public Overridable Function VisitedProductStockStatus (
    request As VisitedProductStockStatusRequest
) As VisitedProductStockStatusResult
public:
virtual VisitedProductStockStatusResult^ VisitedProductStockStatus(
    VisitedProductStockStatusRequest^ request
)
abstract VisitedProductStockStatus :
        request : VisitedProductStockStatusRequest -> VisitedProductStockStatusResult
override VisitedProductStockStatus :
        request : VisitedProductStockStatusRequest -> VisitedProductStockStatusResult

Parameters

request
Type: Sitecore.Commerce.Services.InventoryVisitedProductStockStatusRequest
The service request.

Return Value

Type: VisitedProductStockStatusResult
The service response.
See Also

Reference

InventoryServiceProvider Class
Sitecore.Commerce.Services.Inventory Namespace


InventoryServiceProvider.VisitorSignUpForStockNotification Method

InventoryServiceProviderVisitorSignUpForStockNotification Method
Adds a visitor to EA plan so they can be notified when the product gets back in stock

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual VisitorSignUpForStockNotificationResult VisitorSignUpForStockNotification(
    VisitorSignUpForStockNotificationRequest request
)
Public Overridable Function VisitorSignUpForStockNotification (
    request As VisitorSignUpForStockNotificationRequest
) As VisitorSignUpForStockNotificationResult
public:
virtual VisitorSignUpForStockNotificationResult^ VisitorSignUpForStockNotification(
    VisitorSignUpForStockNotificationRequest^ request
)
abstract VisitorSignUpForStockNotification :
        request : VisitorSignUpForStockNotificationRequest -> VisitorSignUpForStockNotificationResult
override VisitorSignUpForStockNotification :
        request : VisitorSignUpForStockNotificationRequest -> VisitorSignUpForStockNotificationResult

Parameters

request
Type: Sitecore.Commerce.Services.InventoryVisitorSignUpForStockNotificationRequest
The service request.

Return Value

Type: VisitorSignUpForStockNotificationResult
The service response.
See Also

Reference

InventoryServiceProvider Class
Sitecore.Commerce.Services.Inventory Namespace


InventoryServiceProvider Properties

InventoryServiceProvider Properties

The InventoryServiceProvider type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from ServiceProvider.)
Top
See Also

Reference

InventoryServiceProvider Class
Sitecore.Commerce.Services.Inventory Namespace


OrderableInformationRequestBase Class

OrderableInformationRequestBase Class
Base request parameters required to retrieve orderable information for a product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.InventoryOrderableInformationRequestBase
Sitecore.Commerce.Services.InventoryGetBackOrderableInformationRequest
Sitecore.Commerce.Services.InventoryGetPreOrderableInformationRequest

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class OrderableInformationRequestBase : ServiceProviderRequest
Public Class OrderableInformationRequestBase
    Inherits ServiceProviderRequest
public ref class OrderableInformationRequestBase : public ServiceProviderRequest
type OrderableInformationRequestBase =
    class
        inherit ServiceProviderRequest
    end

The OrderableInformationRequestBase type exposes the following members.

Constructors
 | Name | Description
Public method | OrderableInformationRequestBase | Initializes an instance of the OrderableInformationRequestBase class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Location | Gets or sets the specific warehouse or central storage where where stock information is requested.
Public property | Products | Gets or sets the products whose orderable information is requested.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop that will be examined for orderable information.
Public property | VisitorId | Gets or sets the ID of the visitor or customer requesting orderable information.
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


OrderableInformationRequestBase Constructor

OrderableInformationRequestBase Constructor
Initializes an instance of the OrderableInformationRequestBase class.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public OrderableInformationRequestBase(
    string shopName,
    IEnumerable<InventoryProduct> products
)
Public Sub New (
    shopName As String,
    products As IEnumerable(Of InventoryProduct)
)
public:
OrderableInformationRequestBase(
    String^ shopName,
    IEnumerable<InventoryProduct^>^ products
)
new :
        shopName : string *
        products : IEnumerable<InventoryProduct> -> OrderableInformationRequestBase

Parameters

shopName
Type: SystemString
The name of the shop that will be examined for orderable information.
products
Type: System.Collections.GenericIEnumerable InventoryProduct
The products whose orderable information is requested.
See Also

Reference

OrderableInformationRequestBase Class
Sitecore.Commerce.Services.Inventory Namespace


OrderableInformationRequestBase Methods

OrderableInformationRequestBase Methods

The OrderableInformationRequestBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OrderableInformationRequestBase Class
Sitecore.Commerce.Services.Inventory Namespace


OrderableInformationRequestBase Properties

OrderableInformationRequestBase Properties

The OrderableInformationRequestBase type exposes the following members.

Properties
 | Name | Description
Public property | Location | Gets or sets the specific warehouse or central storage where where stock information is requested.
Public property | Products | Gets or sets the products whose orderable information is requested.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop that will be examined for orderable information.
Public property | VisitorId | Gets or sets the ID of the visitor or customer requesting orderable information.
Top
See Also

Reference

OrderableInformationRequestBase Class
Sitecore.Commerce.Services.Inventory Namespace


OrderableInformationRequestBase.Location Property

OrderableInformationRequestBaseLocation Property
Gets or sets the specific warehouse or central storage where where stock information is requested.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
See Also

Reference

OrderableInformationRequestBase Class
Sitecore.Commerce.Services.Inventory Namespace


OrderableInformationRequestBase.Products Property

OrderableInformationRequestBaseProducts Property
Gets or sets the products whose orderable information is requested.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<InventoryProduct> Products { get; set; }
Public Property Products As IEnumerable(Of InventoryProduct)
    Get
    Set
public:
property IEnumerable<InventoryProduct^>^ Products {
    IEnumerable<InventoryProduct^>^ get ();
    void set (IEnumerable<InventoryProduct^>^ value);
}
member Products : IEnumerable<InventoryProduct> with get, set

Property Value

Type: IEnumerable InventoryProduct
See Also

Reference

OrderableInformationRequestBase Class
Sitecore.Commerce.Services.Inventory Namespace


OrderableInformationRequestBase.ShopName Property

OrderableInformationRequestBaseShopName Property
Gets or sets the name of the shop that will be examined for orderable information.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
See Also

Reference

OrderableInformationRequestBase Class
Sitecore.Commerce.Services.Inventory Namespace


OrderableInformationRequestBase.VisitorId Property

OrderableInformationRequestBaseVisitorId Property
Gets or sets the ID of the visitor or customer requesting orderable information.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string VisitorId { get; set; }
Public Property VisitorId As String
    Get
    Set
public:
property String^ VisitorId {
    String^ get ();
    void set (String^ value);
}
member VisitorId : string with get, set

Property Value

Type: String
See Also

Reference

OrderableInformationRequestBase Class
Sitecore.Commerce.Services.Inventory Namespace


OrderableInformationResultBase Class

OrderableInformationResultBase Class
The result returned by a request to retrieve orderable information for a product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.InventoryOrderableInformationResultBase
Sitecore.Commerce.Services.InventoryGetBackOrderableInformationResult
Sitecore.Commerce.Services.InventoryGetPreOrderableInformationResult

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class OrderableInformationResultBase : ServiceProviderResult
Public Class OrderableInformationResultBase
    Inherits ServiceProviderResult
public ref class OrderableInformationResultBase : public ServiceProviderResult
type OrderableInformationResultBase =
    class
        inherit ServiceProviderResult
    end

The OrderableInformationResultBase type exposes the following members.

Constructors
 | Name | Description
Public method | OrderableInformationResultBase | Initializes a new instance of the OrderableInformationResultBase class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | OrderableInformation | Gets or sets the orderable information for the requested products.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


OrderableInformationResultBase Constructor

OrderableInformationResultBase Constructor
Initializes a new instance of the OrderableInformationResultBase class.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public OrderableInformationResultBase()
Public Sub New
public:
OrderableInformationResultBase()
new : unit -> OrderableInformationResultBase
See Also

Reference

OrderableInformationResultBase Class
Sitecore.Commerce.Services.Inventory Namespace


OrderableInformationResultBase Methods

OrderableInformationResultBase Methods

The OrderableInformationResultBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OrderableInformationResultBase Class
Sitecore.Commerce.Services.Inventory Namespace


OrderableInformationResultBase Properties

OrderableInformationResultBase Properties

The OrderableInformationResultBase type exposes the following members.

Properties
 | Name | Description
Public property | OrderableInformation | Gets or sets the orderable information for the requested products.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

OrderableInformationResultBase Class
Sitecore.Commerce.Services.Inventory Namespace


OrderableInformationResultBase.OrderableInformation Property

OrderableInformationResultBaseOrderableInformation Property
Gets or sets the orderable information for the requested products.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<OrderableInformation> OrderableInformation { get; set; }
Public Property OrderableInformation As IEnumerable(Of OrderableInformation)
    Get
    Set
public:
property IEnumerable<OrderableInformation^>^ OrderableInformation {
    IEnumerable<OrderableInformation^>^ get ();
    void set (IEnumerable<OrderableInformation^>^ value);
}
member OrderableInformation : IEnumerable<OrderableInformation> with get, set

Property Value

Type: IEnumerable OrderableInformation
See Also

Reference

OrderableInformationResultBase Class
Sitecore.Commerce.Services.Inventory Namespace


ProductsAreBackInStockRequest Class

ProductsAreBackInStockRequest Class
The request parameters required for to call ProductAreBackInStock service method.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.InventoryProductsAreBackInStockRequest

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ProductsAreBackInStockRequest : ServiceProviderRequest
Public Class ProductsAreBackInStockRequest
    Inherits ServiceProviderRequest
public ref class ProductsAreBackInStockRequest : public ServiceProviderRequest
type ProductsAreBackInStockRequest =
    class
        inherit ServiceProviderRequest
    end

The ProductsAreBackInStockRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ProductsAreBackInStockRequest | Initializes an instance of the ProductsAreBackInStockRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Products | Gets or sets the list of products.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


ProductsAreBackInStockRequest Constructor

ProductsAreBackInStockRequest Constructor
Initializes an instance of the ProductsAreBackInStockRequest class.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductsAreBackInStockRequest(
    string shopName,
    IEnumerable<InventoryProduct> products
)
Public Sub New (
    shopName As String,
    products As IEnumerable(Of InventoryProduct)
)
public:
ProductsAreBackInStockRequest(
    String^ shopName,
    IEnumerable<InventoryProduct^>^ products
)
new :
        shopName : string *
        products : IEnumerable<InventoryProduct> -> ProductsAreBackInStockRequest

Parameters

shopName
Type: SystemString
The name of the shop
products
Type: System.Collections.GenericIEnumerable InventoryProduct
The list of product s.
See Also

Reference

ProductsAreBackInStockRequest Class
Sitecore.Commerce.Services.Inventory Namespace


ProductsAreBackInStockRequest Methods

ProductsAreBackInStockRequest Methods

The ProductsAreBackInStockRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductsAreBackInStockRequest Class
Sitecore.Commerce.Services.Inventory Namespace


ProductsAreBackInStockRequest Properties

ProductsAreBackInStockRequest Properties

The ProductsAreBackInStockRequest type exposes the following members.

Properties
 | Name | Description
Public property | Products | Gets or sets the list of products.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Top
See Also

Reference

ProductsAreBackInStockRequest Class
Sitecore.Commerce.Services.Inventory Namespace


ProductsAreBackInStockRequest.Products Property

ProductsAreBackInStockRequestProducts Property
Gets or sets the list of products.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<InventoryProduct> Products { get; set; }
Public Property Products As IEnumerable(Of InventoryProduct)
    Get
    Set
public:
property IEnumerable<InventoryProduct^>^ Products {
    IEnumerable<InventoryProduct^>^ get ();
    void set (IEnumerable<InventoryProduct^>^ value);
}
member Products : IEnumerable<InventoryProduct> with get, set

Property Value

Type: IEnumerable InventoryProduct
See Also

Reference

ProductsAreBackInStockRequest Class
Sitecore.Commerce.Services.Inventory Namespace


ProductsAreBackInStockRequest.ShopName Property

ProductsAreBackInStockRequestShopName Property
Gets or sets the name of the shop.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
See Also

Reference

ProductsAreBackInStockRequest Class
Sitecore.Commerce.Services.Inventory Namespace


ProductsAreBackInStockResult Class

ProductsAreBackInStockResult Class
The result returned by a request to ProductAreBackInStock service method.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.InventoryProductsAreBackInStockResult

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ProductsAreBackInStockResult : ServiceProviderResult
Public Class ProductsAreBackInStockResult
    Inherits ServiceProviderResult
public ref class ProductsAreBackInStockResult : public ServiceProviderResult
type ProductsAreBackInStockResult =
    class
        inherit ServiceProviderResult
    end

The ProductsAreBackInStockResult type exposes the following members.

Constructors
 | Name | Description
Public method | ProductsAreBackInStockResult | Initializes a new instance of the ProductsAreBackInStockResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


ProductsAreBackInStockResult Constructor

ProductsAreBackInStockResult Constructor
Initializes a new instance of the ProductsAreBackInStockResult class

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductsAreBackInStockResult()
Public Sub New
public:
ProductsAreBackInStockResult()
new : unit -> ProductsAreBackInStockResult
See Also

Reference

ProductsAreBackInStockResult Class
Sitecore.Commerce.Services.Inventory Namespace


ProductsAreBackInStockResult Methods

ProductsAreBackInStockResult Methods

The ProductsAreBackInStockResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductsAreBackInStockResult Class
Sitecore.Commerce.Services.Inventory Namespace


ProductsAreBackInStockResult Properties

ProductsAreBackInStockResult Properties

The ProductsAreBackInStockResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

ProductsAreBackInStockResult Class
Sitecore.Commerce.Services.Inventory Namespace


RemoveVisitorFromStockNotificationRequest Class

RemoveVisitorFromStockNotificationRequest Class
The request parameters required to remove a visitor from EA plan so they will no longer be notified when a product gets back in stock
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.InventoryRemoveVisitorFromStockNotificationRequest

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveVisitorFromStockNotificationRequest : ServiceProviderRequest
Public Class RemoveVisitorFromStockNotificationRequest
    Inherits ServiceProviderRequest
public ref class RemoveVisitorFromStockNotificationRequest : public ServiceProviderRequest
type RemoveVisitorFromStockNotificationRequest =
    class
        inherit ServiceProviderRequest
    end

The RemoveVisitorFromStockNotificationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveVisitorFromStockNotificationRequest | Initializes an instance of the RemoveVisitorFromStockNotificationRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Location | Gets or sets the specific warehouse or central storage where where stock information is requested.
Public property | Product | Gets or sets the product whose the visitor is requesting back in stock notification.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop that will be examined for stock information.
Public property | VisitorId | Gets or sets the ID of the customer signing up for back in stock notifications.
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


RemoveVisitorFromStockNotificationRequest Constructor

RemoveVisitorFromStockNotificationRequest Constructor
Initializes an instance of the RemoveVisitorFromStockNotificationRequest class.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveVisitorFromStockNotificationRequest(
    string shopName,
    string visitorId,
    InventoryProduct product
)
Public Sub New (
    shopName As String,
    visitorId As String,
    product As InventoryProduct
)
public:
RemoveVisitorFromStockNotificationRequest(
    String^ shopName,
    String^ visitorId,
    InventoryProduct^ product
)
new :
        shopName : string *
        visitorId : string *
        product : InventoryProduct -> RemoveVisitorFromStockNotificationRequest

Parameters

shopName
Type: SystemString
The name of the shop
visitorId
Type: SystemString
The visitor id.
product
Type: Sitecore.Commerce.Entities.InventoryInventoryProduct
The product.
See Also

Reference

RemoveVisitorFromStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


RemoveVisitorFromStockNotificationRequest Methods

RemoveVisitorFromStockNotificationRequest Methods

The RemoveVisitorFromStockNotificationRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveVisitorFromStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


RemoveVisitorFromStockNotificationRequest Properties

RemoveVisitorFromStockNotificationRequest Properties

The RemoveVisitorFromStockNotificationRequest type exposes the following members.

Properties
 | Name | Description
Public property | Location | Gets or sets the specific warehouse or central storage where where stock information is requested.
Public property | Product | Gets or sets the product whose the visitor is requesting back in stock notification.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop that will be examined for stock information.
Public property | VisitorId | Gets or sets the ID of the customer signing up for back in stock notifications.
Top
See Also

Reference

RemoveVisitorFromStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


RemoveVisitorFromStockNotificationRequest.Location Property

RemoveVisitorFromStockNotificationRequestLocation Property
Gets or sets the specific warehouse or central storage where where stock information is requested.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
See Also

Reference

RemoveVisitorFromStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


RemoveVisitorFromStockNotificationRequest.Product Property

RemoveVisitorFromStockNotificationRequestProduct Property
Gets or sets the product whose the visitor is requesting back in stock notification.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public InventoryProduct Product { get; set; }
Public Property Product As InventoryProduct
    Get
    Set
public:
property InventoryProduct^ Product {
    InventoryProduct^ get ();
    void set (InventoryProduct^ value);
}
member Product : InventoryProduct with get, set

Property Value

Type: InventoryProduct
See Also

Reference

RemoveVisitorFromStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


RemoveVisitorFromStockNotificationRequest.ShopName Property

RemoveVisitorFromStockNotificationRequestShopName Property
Gets or sets the name of the shop that will be examined for stock information.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
See Also

Reference

RemoveVisitorFromStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


RemoveVisitorFromStockNotificationRequest.VisitorId Property

RemoveVisitorFromStockNotificationRequestVisitorId Property
Gets or sets the ID of the customer signing up for back in stock notifications.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string VisitorId { get; set; }
Public Property VisitorId As String
    Get
    Set
public:
property String^ VisitorId {
    String^ get ();
    void set (String^ value);
}
member VisitorId : string with get, set

Property Value

Type: String
See Also

Reference

RemoveVisitorFromStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


RemoveVisitorFromStockNotificationResult Class

RemoveVisitorFromStockNotificationResult Class
The result returned by a request to RemoveVisitorFromStockNotification service method.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.InventoryRemoveVisitorFromStockNotificationResult

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class RemoveVisitorFromStockNotificationResult : ServiceProviderResult
Public Class RemoveVisitorFromStockNotificationResult
    Inherits ServiceProviderResult
public ref class RemoveVisitorFromStockNotificationResult : public ServiceProviderResult
type RemoveVisitorFromStockNotificationResult =
    class
        inherit ServiceProviderResult
    end

The RemoveVisitorFromStockNotificationResult type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveVisitorFromStockNotificationResult | Initializes a new instance of the RemoveVisitorFromStockNotificationResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


RemoveVisitorFromStockNotificationResult Constructor

RemoveVisitorFromStockNotificationResult Constructor
Initializes a new instance of the RemoveVisitorFromStockNotificationResult class

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public RemoveVisitorFromStockNotificationResult()
Public Sub New
public:
RemoveVisitorFromStockNotificationResult()
new : unit -> RemoveVisitorFromStockNotificationResult
See Also

Reference

RemoveVisitorFromStockNotificationResult Class
Sitecore.Commerce.Services.Inventory Namespace


RemoveVisitorFromStockNotificationResult Methods

RemoveVisitorFromStockNotificationResult Methods

The RemoveVisitorFromStockNotificationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveVisitorFromStockNotificationResult Class
Sitecore.Commerce.Services.Inventory Namespace


RemoveVisitorFromStockNotificationResult Properties

RemoveVisitorFromStockNotificationResult Properties

The RemoveVisitorFromStockNotificationResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

RemoveVisitorFromStockNotificationResult Class
Sitecore.Commerce.Services.Inventory Namespace


StockStatusForIndexingRequest Class

StockStatusForIndexingRequest Class
The request parameters required for to retrieve stock information for a product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.InventoryStockStatusForIndexingRequest

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class StockStatusForIndexingRequest : ServiceProviderRequest
Public Class StockStatusForIndexingRequest
    Inherits ServiceProviderRequest
public ref class StockStatusForIndexingRequest : public ServiceProviderRequest
type StockStatusForIndexingRequest =
    class
        inherit ServiceProviderRequest
    end

The StockStatusForIndexingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | StockStatusForIndexingRequest | Initializes an instance of the StockStatusForIndexingRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Products | Gets or sets the IDs of the products whose stock information is requested..
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


StockStatusForIndexingRequest Constructor

StockStatusForIndexingRequest Constructor
Initializes an instance of the StockStatusForIndexingRequest class.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockStatusForIndexingRequest(
    IEnumerable<InventoryProduct> products
)
Public Sub New (
    products As IEnumerable(Of InventoryProduct)
)
public:
StockStatusForIndexingRequest(
    IEnumerable<InventoryProduct^>^ products
)
new :
        products : IEnumerable<InventoryProduct> -> StockStatusForIndexingRequest

Parameters

products
Type: System.Collections.GenericIEnumerable InventoryProduct
The products whose stock information is requested.
See Also

Reference

StockStatusForIndexingRequest Class
Sitecore.Commerce.Services.Inventory Namespace


StockStatusForIndexingRequest Methods

StockStatusForIndexingRequest Methods

The StockStatusForIndexingRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StockStatusForIndexingRequest Class
Sitecore.Commerce.Services.Inventory Namespace


StockStatusForIndexingRequest Properties

StockStatusForIndexingRequest Properties

The StockStatusForIndexingRequest type exposes the following members.

Properties
 | Name | Description
Public property | Products | Gets or sets the IDs of the products whose stock information is requested..
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

StockStatusForIndexingRequest Class
Sitecore.Commerce.Services.Inventory Namespace


StockStatusForIndexingRequest.Products Property

StockStatusForIndexingRequestProducts Property
Gets or sets the IDs of the products whose stock information is requested..

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<InventoryProduct> Products { get; set; }
Public Property Products As IEnumerable(Of InventoryProduct)
    Get
    Set
public:
property IEnumerable<InventoryProduct^>^ Products {
    IEnumerable<InventoryProduct^>^ get ();
    void set (IEnumerable<InventoryProduct^>^ value);
}
member Products : IEnumerable<InventoryProduct> with get, set

Property Value

Type: IEnumerable InventoryProduct
See Also

Reference

StockStatusForIndexingRequest Class
Sitecore.Commerce.Services.Inventory Namespace


StockStatusForIndexingResult Class

StockStatusForIndexingResult Class
The response returned by a request to retrieve stock information for a product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.InventoryStockStatusForIndexingResult

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class StockStatusForIndexingResult : ServiceProviderResult
Public Class StockStatusForIndexingResult
    Inherits ServiceProviderResult
public ref class StockStatusForIndexingResult : public ServiceProviderResult
type StockStatusForIndexingResult =
    class
        inherit ServiceProviderResult
    end

The StockStatusForIndexingResult type exposes the following members.

Constructors
 | Name | Description
Public method | StockStatusForIndexingResult | Initializes a new instance of the StockStatusForIndexingResult class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IndexStockInformation | Gets or sets the stock information for the requested products.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


StockStatusForIndexingResult Constructor

StockStatusForIndexingResult Constructor
Initializes a new instance of the StockStatusForIndexingResult class.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockStatusForIndexingResult()
Public Sub New
public:
StockStatusForIndexingResult()
new : unit -> StockStatusForIndexingResult
See Also

Reference

StockStatusForIndexingResult Class
Sitecore.Commerce.Services.Inventory Namespace


StockStatusForIndexingResult Methods

StockStatusForIndexingResult Methods

The StockStatusForIndexingResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StockStatusForIndexingResult Class
Sitecore.Commerce.Services.Inventory Namespace


StockStatusForIndexingResult Properties

StockStatusForIndexingResult Properties

The StockStatusForIndexingResult type exposes the following members.

Properties
 | Name | Description
Public property | IndexStockInformation | Gets or sets the stock information for the requested products.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

StockStatusForIndexingResult Class
Sitecore.Commerce.Services.Inventory Namespace


StockStatusForIndexingResult.IndexStockInformation Property

StockStatusForIndexingResultIndexStockInformation Property
Gets or sets the stock information for the requested products.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IndexStockInformation> IndexStockInformation { get; set; }
Public Property IndexStockInformation As IEnumerable(Of IndexStockInformation)
    Get
    Set
public:
property IEnumerable<IndexStockInformation^>^ IndexStockInformation {
    IEnumerable<IndexStockInformation^>^ get ();
    void set (IEnumerable<IndexStockInformation^>^ value);
}
member IndexStockInformation : IEnumerable<IndexStockInformation> with get, set

Property Value

Type: IEnumerable IndexStockInformation
See Also

Reference

StockStatusForIndexingResult Class
Sitecore.Commerce.Services.Inventory Namespace


VisitedProductStockStatusRequest Class

VisitedProductStockStatusRequest Class
The request parameters required for to trigger visitedn product stock status page event.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.InventoryVisitedProductStockStatusRequest

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class VisitedProductStockStatusRequest : ServiceProviderRequest
Public Class VisitedProductStockStatusRequest
    Inherits ServiceProviderRequest
public ref class VisitedProductStockStatusRequest : public ServiceProviderRequest
type VisitedProductStockStatusRequest =
    class
        inherit ServiceProviderRequest
    end

The VisitedProductStockStatusRequest type exposes the following members.

Constructors
 | Name | Description
Public method | VisitedProductStockStatusRequest | Initializes an instance of the VisitedProductStockStatusRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Location | Gets or sets the ID of the visitor.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Public property | StockInformation | Gets or sets the orderable information.
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


VisitedProductStockStatusRequest Constructor

VisitedProductStockStatusRequest Constructor
Initializes an instance of the VisitedProductStockStatusRequest class.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public VisitedProductStockStatusRequest(
    string shopName,
    StockInformation stockInformation
)
Public Sub New (
    shopName As String,
    stockInformation As StockInformation
)
public:
VisitedProductStockStatusRequest(
    String^ shopName,
    StockInformation^ stockInformation
)
new :
        shopName : string *
        stockInformation : StockInformation -> VisitedProductStockStatusRequest

Parameters

shopName
Type: SystemString
The name of the shop
stockInformation
Type: Sitecore.Commerce.Entities.InventoryStockInformation
The product orderable inforamtion.
See Also

Reference

VisitedProductStockStatusRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitedProductStockStatusRequest Methods

VisitedProductStockStatusRequest Methods

The VisitedProductStockStatusRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VisitedProductStockStatusRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitedProductStockStatusRequest Properties

VisitedProductStockStatusRequest Properties

The VisitedProductStockStatusRequest type exposes the following members.

Properties
 | Name | Description
Public property | Location | Gets or sets the ID of the visitor.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Public property | StockInformation | Gets or sets the orderable information.
Top
See Also

Reference

VisitedProductStockStatusRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitedProductStockStatusRequest.Location Property

VisitedProductStockStatusRequestLocation Property
Gets or sets the ID of the visitor.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
See Also

Reference

VisitedProductStockStatusRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitedProductStockStatusRequest.ShopName Property

VisitedProductStockStatusRequestShopName Property
Gets or sets the name of the shop.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
See Also

Reference

VisitedProductStockStatusRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitedProductStockStatusRequest.StockInformation Property

VisitedProductStockStatusRequestStockInformation Property
Gets or sets the orderable information.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public StockInformation StockInformation { get; set; }
Public Property StockInformation As StockInformation
    Get
    Set
public:
property StockInformation^ StockInformation {
    StockInformation^ get ();
    void set (StockInformation^ value);
}
member StockInformation : StockInformation with get, set

Property Value

Type: StockInformation
See Also

Reference

VisitedProductStockStatusRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitedProductStockStatusResult Class

VisitedProductStockStatusResult Class
The result returned by a request to VisitedProductStockStatus service method.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.InventoryVisitedProductStockStatusResult

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class VisitedProductStockStatusResult : ServiceProviderResult
Public Class VisitedProductStockStatusResult
    Inherits ServiceProviderResult
public ref class VisitedProductStockStatusResult : public ServiceProviderResult
type VisitedProductStockStatusResult =
    class
        inherit ServiceProviderResult
    end

The VisitedProductStockStatusResult type exposes the following members.

Constructors
 | Name | Description
Public method | VisitedProductStockStatusResult | Initializes a new instance of the VisitedProductStockStatusResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


VisitedProductStockStatusResult Constructor

VisitedProductStockStatusResult Constructor
Initializes a new instance of the VisitedProductStockStatusResult class

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public VisitedProductStockStatusResult()
Public Sub New
public:
VisitedProductStockStatusResult()
new : unit -> VisitedProductStockStatusResult
See Also

Reference

VisitedProductStockStatusResult Class
Sitecore.Commerce.Services.Inventory Namespace


VisitedProductStockStatusResult Methods

VisitedProductStockStatusResult Methods

The VisitedProductStockStatusResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VisitedProductStockStatusResult Class
Sitecore.Commerce.Services.Inventory Namespace


VisitedProductStockStatusResult Properties

VisitedProductStockStatusResult Properties

The VisitedProductStockStatusResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

VisitedProductStockStatusResult Class
Sitecore.Commerce.Services.Inventory Namespace


VisitorSignUpForStockNotificationRequest Class

VisitorSignUpForStockNotificationRequest Class
The request parameters required to add visitor to EA plan back in stock notification and trigger back in stock subscription page event.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.InventoryVisitorSignUpForStockNotificationRequest

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class VisitorSignUpForStockNotificationRequest : ServiceProviderRequest
Public Class VisitorSignUpForStockNotificationRequest
    Inherits ServiceProviderRequest
public ref class VisitorSignUpForStockNotificationRequest : public ServiceProviderRequest
type VisitorSignUpForStockNotificationRequest =
    class
        inherit ServiceProviderRequest
    end

The VisitorSignUpForStockNotificationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | VisitorSignUpForStockNotificationRequest | Initializes an instance of the VisitorSignUpForStockNotificationRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Email | Gets or sets the email of the customer signing up for back in stock notifications.
Public property | InterestDate | Gets or sets the a date and time that signals the deadline for which to notify the visitor
Public property | Location | Gets or sets the specific warehouse or central storage where where stock information is requested.
Public property | Product | Gets or sets the product whose the visitor is requesting back in stock notification.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop that will be examined for stock information.
Public property | VisitorId | Gets or sets the ID of the customer signing up for back in stock notifications.
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


VisitorSignUpForStockNotificationRequest Constructor

VisitorSignUpForStockNotificationRequest Constructor
Initializes an instance of the VisitorSignUpForStockNotificationRequest class.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public VisitorSignUpForStockNotificationRequest(
    string shopName,
    string visitorId,
    string email,
    InventoryProduct product
)
Public Sub New (
    shopName As String,
    visitorId As String,
    email As String,
    product As InventoryProduct
)
public:
VisitorSignUpForStockNotificationRequest(
    String^ shopName,
    String^ visitorId,
    String^ email,
    InventoryProduct^ product
)
new :
        shopName : string *
        visitorId : string *
        email : string *
        product : InventoryProduct -> VisitorSignUpForStockNotificationRequest

Parameters

shopName
Type: SystemString
The name of the shop
visitorId
Type: SystemString
The visitor id.
email
Type: SystemString
The visitor email.
product
Type: Sitecore.Commerce.Entities.InventoryInventoryProduct
The product.
See Also

Reference

VisitorSignUpForStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitorSignUpForStockNotificationRequest Methods

VisitorSignUpForStockNotificationRequest Methods

The VisitorSignUpForStockNotificationRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VisitorSignUpForStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitorSignUpForStockNotificationRequest Properties

VisitorSignUpForStockNotificationRequest Properties

The VisitorSignUpForStockNotificationRequest type exposes the following members.

Properties
 | Name | Description
Public property | Email | Gets or sets the email of the customer signing up for back in stock notifications.
Public property | InterestDate | Gets or sets the a date and time that signals the deadline for which to notify the visitor
Public property | Location | Gets or sets the specific warehouse or central storage where where stock information is requested.
Public property | Product | Gets or sets the product whose the visitor is requesting back in stock notification.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop that will be examined for stock information.
Public property | VisitorId | Gets or sets the ID of the customer signing up for back in stock notifications.
Top
See Also

Reference

VisitorSignUpForStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitorSignUpForStockNotificationRequest.Email Property

VisitorSignUpForStockNotificationRequestEmail Property
Gets or sets the email of the customer signing up for back in stock notifications.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}
member Email : string with get, set

Property Value

Type: String
See Also

Reference

VisitorSignUpForStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitorSignUpForStockNotificationRequest.InterestDate Property

VisitorSignUpForStockNotificationRequestInterestDate Property
Gets or sets the a date and time that signals the deadline for which to notify the visitor

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> InterestDate { get; set; }
Public Property InterestDate As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> InterestDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member InterestDate : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

VisitorSignUpForStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitorSignUpForStockNotificationRequest.Location Property

VisitorSignUpForStockNotificationRequestLocation Property
Gets or sets the specific warehouse or central storage where where stock information is requested.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
See Also

Reference

VisitorSignUpForStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitorSignUpForStockNotificationRequest.Product Property

VisitorSignUpForStockNotificationRequestProduct Property
Gets or sets the product whose the visitor is requesting back in stock notification.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public InventoryProduct Product { get; set; }
Public Property Product As InventoryProduct
    Get
    Set
public:
property InventoryProduct^ Product {
    InventoryProduct^ get ();
    void set (InventoryProduct^ value);
}
member Product : InventoryProduct with get, set

Property Value

Type: InventoryProduct
See Also

Reference

VisitorSignUpForStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitorSignUpForStockNotificationRequest.ShopName Property

VisitorSignUpForStockNotificationRequestShopName Property
Gets or sets the name of the shop that will be examined for stock information.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
See Also

Reference

VisitorSignUpForStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitorSignUpForStockNotificationRequest.VisitorId Property

VisitorSignUpForStockNotificationRequestVisitorId Property
Gets or sets the ID of the customer signing up for back in stock notifications.

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string VisitorId { get; set; }
Public Property VisitorId As String
    Get
    Set
public:
property String^ VisitorId {
    String^ get ();
    void set (String^ value);
}
member VisitorId : string with get, set

Property Value

Type: String
See Also

Reference

VisitorSignUpForStockNotificationRequest Class
Sitecore.Commerce.Services.Inventory Namespace


VisitorSignUpForStockNotificationResult Class

VisitorSignUpForStockNotificationResult Class
The result returned by a request to VisitorSignUpForStockNotification service method.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.InventoryVisitorSignUpForStockNotificationResult

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class VisitorSignUpForStockNotificationResult : ServiceProviderResult
Public Class VisitorSignUpForStockNotificationResult
    Inherits ServiceProviderResult
public ref class VisitorSignUpForStockNotificationResult : public ServiceProviderResult
type VisitorSignUpForStockNotificationResult =
    class
        inherit ServiceProviderResult
    end

The VisitorSignUpForStockNotificationResult type exposes the following members.

Constructors
 | Name | Description
Public method | VisitorSignUpForStockNotificationResult | Initializes a new instance of the VisitorSignUpForStockNotificationResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory Namespace


VisitorSignUpForStockNotificationResult Constructor

VisitorSignUpForStockNotificationResult Constructor
Initializes a new instance of the VisitorSignUpForStockNotificationResult class

Namespace: Sitecore.Commerce.Services.Inventory
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public VisitorSignUpForStockNotificationResult()
Public Sub New
public:
VisitorSignUpForStockNotificationResult()
new : unit -> VisitorSignUpForStockNotificationResult
See Also

Reference

VisitorSignUpForStockNotificationResult Class
Sitecore.Commerce.Services.Inventory Namespace


VisitorSignUpForStockNotificationResult Methods

VisitorSignUpForStockNotificationResult Methods

The VisitorSignUpForStockNotificationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VisitorSignUpForStockNotificationResult Class
Sitecore.Commerce.Services.Inventory Namespace


VisitorSignUpForStockNotificationResult Properties

VisitorSignUpForStockNotificationResult Properties

The VisitorSignUpForStockNotificationResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

VisitorSignUpForStockNotificationResult Class
Sitecore.Commerce.Services.Inventory Namespace


Sitecore.Commerce.Services.Inventory.Generics Namespace

Sitecore.Commerce.Services.Inventory.Generics Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Services.Inventory.Generics"]

Classes
 | Class | Description
Public class | GenericInventoryServiceProviderExtensions | Extends the InventoryServiceProvider class with some generic methods. It allows you to specify the result type of a custom service call.


GenericInventoryServiceProviderExtensions Class

GenericInventoryServiceProviderExtensions Class
Extends the InventoryServiceProvider class with some generic methods. It allows you to specify the result type of a custom service call.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Services.Inventory.GenericsGenericInventoryServiceProviderExtensions

Namespace: Sitecore.Commerce.Services.Inventory.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class GenericInventoryServiceProviderExtensions
<ExtensionAttribute>
Public NotInheritable Class GenericInventoryServiceProviderExtensions
[ExtensionAttribute]
public ref class GenericInventoryServiceProviderExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GenericInventoryServiceProviderExtensions =  class end

The GenericInventoryServiceProviderExtensions type exposes the following members.

Methods
Name | Description
GetBackInStockInformationTGetBackInStockInformationRequest, TGetBackInStockInformationResult | Retrieves updated stock information for products from an external commerce system.
GetBackOrderableInformationTGetBackOrderableInformationRequest, TGetBackOrderableInformationResult | Retrieves backorderable information for products. It calls the GetBackOrderableInformation pipeline.
GetPreOrderableInformationTGetPreOrderableInformationRequest, TGetPreOrderableInformationResult | Retrieves preorderable information for products. It calls the GetPreOrderableInformation pipeline.
GetStockInformationTGetStockInformationRequest, TGetStockInformationResult | Retrieves stock information for products. It calls the GetStockInformation pipeline.
ProductsAreBackInStockTProductsAreBackInStockRequest, TProductsAreBackInStockResult | Updates a product stock count
RemoveVisitorFromStockNotificationTRemoveVisitorFromStockNotificationRequest, TRemoveVisitorFromStockNotificationResult | Removes a visitor from EA plan so they will no longer be notified when a product gets back in stock
VisitedProductStockStatusTVisitedProductStockStatusRequest, TVisitedProductStockStatusResult | Track product stock status for customers visiting product details pages
VisitorSignUpForStockNotificationTVisitorSignUpForStockNotificationRequest, TVisitorSignUpForStockNotificationResult | Adds a visitor to EA plan so they can be notified when the product gets back in stock
Top
See Also

Reference

Sitecore.Commerce.Services.Inventory.Generics Namespace


GenericInventoryServiceProviderExtensions Methods

GenericInventoryServiceProviderExtensions Methods

The GenericInventoryServiceProviderExtensions type exposes the following members.

Methods
Name | Description
GetBackInStockInformationTGetBackInStockInformationRequest, TGetBackInStockInformationResult | Retrieves updated stock information for products from an external commerce system.
GetBackOrderableInformationTGetBackOrderableInformationRequest, TGetBackOrderableInformationResult | Retrieves backorderable information for products. It calls the GetBackOrderableInformation pipeline.
GetPreOrderableInformationTGetPreOrderableInformationRequest, TGetPreOrderableInformationResult | Retrieves preorderable information for products. It calls the GetPreOrderableInformation pipeline.
GetStockInformationTGetStockInformationRequest, TGetStockInformationResult | Retrieves stock information for products. It calls the GetStockInformation pipeline.
ProductsAreBackInStockTProductsAreBackInStockRequest, TProductsAreBackInStockResult | Updates a product stock count
RemoveVisitorFromStockNotificationTRemoveVisitorFromStockNotificationRequest, TRemoveVisitorFromStockNotificationResult | Removes a visitor from EA plan so they will no longer be notified when a product gets back in stock
VisitedProductStockStatusTVisitedProductStockStatusRequest, TVisitedProductStockStatusResult | Track product stock status for customers visiting product details pages
VisitorSignUpForStockNotificationTVisitorSignUpForStockNotificationRequest, TVisitorSignUpForStockNotificationResult | Adds a visitor to EA plan so they can be notified when the product gets back in stock
Top
See Also

Reference

GenericInventoryServiceProviderExtensions Class
Sitecore.Commerce.Services.Inventory.Generics Namespace


GenericInventoryServiceProviderExtensions.GetBackInStockInformation(TGetBackInStockInformationRequest, TGetBackInStockInformationResult) Method

GenericInventoryServiceProviderExtensionsGetBackInStockInformationTGetBackInStockInformationRequest, TGetBackInStockInformationResult Method
Retrieves updated stock information for products from an external commerce system.

Namespace: Sitecore.Commerce.Services.Inventory.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetBackInStockInformationResult GetBackInStockInformation<TGetBackInStockInformationRequest, TGetBackInStockInformationResult>(
    this InventoryServiceProvider inventoryProvider,
    TGetBackInStockInformationRequest request
)
where TGetBackInStockInformationRequest : GetBackInStockInformationRequest
where TGetBackInStockInformationResult : new(), GetBackInStockInformationResult

<ExtensionAttribute>
Public Shared Function GetBackInStockInformation(Of TGetBackInStockInformationRequest As GetBackInStockInformationRequest, TGetBackInStockInformationResult As {New, GetBackInStockInformationResult}) (
    inventoryProvider As InventoryServiceProvider,
    request As TGetBackInStockInformationRequest
) As TGetBackInStockInformationResult
public:
[ExtensionAttribute]
generic<typename TGetBackInStockInformationRequest, typename TGetBackInStockInformationResult>
where TGetBackInStockInformationRequest : GetBackInStockInformationRequest
where TGetBackInStockInformationResult : gcnew(), GetBackInStockInformationResult
static TGetBackInStockInformationResult GetBackInStockInformation(
    InventoryServiceProvider^ inventoryProvider,
    TGetBackInStockInformationRequest request
)
static member GetBackInStockInformation :
        inventoryProvider : InventoryServiceProvider *
        request : 'TGetBackInStockInformationRequest -> 'TGetBackInStockInformationResult  when 'TGetBackInStockInformationRequest : GetBackInStockInformationRequest when 'TGetBackInStockInformationResult : new() and GetBackInStockInformationResult

Parameters

inventoryProvider
Type: Sitecore.Commerce.Services.InventoryInventoryServiceProvider
A InventoryServiceProvider object.
request
Type: TGetBackInStockInformationRequest
The GetBackInStockInformationRequest Contains the search criteria.

Type Parameters

TGetBackInStockInformationRequest
The extended type of the GetBackInStockInformationRequestclass.
TGetBackInStockInformationResult
The extended type of the GetBackInStockInformationResultclass.

Return Value

Type: TGetBackInStockInformationResult
The extended GetBackInStockInformationResult.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type InventoryServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericInventoryServiceProviderExtensions Class
Sitecore.Commerce.Services.Inventory.Generics Namespace


GenericInventoryServiceProviderExtensions.GetBackOrderableInformation(TGetBackOrderableInformationRequest, TGetBackOrderableInformationResult) Method

GenericInventoryServiceProviderExtensionsGetBackOrderableInformationTGetBackOrderableInformationRequest, TGetBackOrderableInformationResult Method
Retrieves backorderable information for products. It calls the GetBackOrderableInformation pipeline.

Namespace: Sitecore.Commerce.Services.Inventory.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetBackOrderableInformationResult GetBackOrderableInformation<TGetBackOrderableInformationRequest, TGetBackOrderableInformationResult>(
    this InventoryServiceProvider inventoryProvider,
    TGetBackOrderableInformationRequest request
)
where TGetBackOrderableInformationRequest : GetBackOrderableInformationRequest
where TGetBackOrderableInformationResult : new(), GetBackOrderableInformationResult

<ExtensionAttribute>
Public Shared Function GetBackOrderableInformation(Of TGetBackOrderableInformationRequest As GetBackOrderableInformationRequest, TGetBackOrderableInformationResult As {New, GetBackOrderableInformationResult}) (
    inventoryProvider As InventoryServiceProvider,
    request As TGetBackOrderableInformationRequest
) As TGetBackOrderableInformationResult
public:
[ExtensionAttribute]
generic<typename TGetBackOrderableInformationRequest, typename TGetBackOrderableInformationResult>
where TGetBackOrderableInformationRequest : GetBackOrderableInformationRequest
where TGetBackOrderableInformationResult : gcnew(), GetBackOrderableInformationResult
static TGetBackOrderableInformationResult GetBackOrderableInformation(
    InventoryServiceProvider^ inventoryProvider,
    TGetBackOrderableInformationRequest request
)
static member GetBackOrderableInformation :
        inventoryProvider : InventoryServiceProvider *
        request : 'TGetBackOrderableInformationRequest -> 'TGetBackOrderableInformationResult  when 'TGetBackOrderableInformationRequest : GetBackOrderableInformationRequest when 'TGetBackOrderableInformationResult : new() and GetBackOrderableInformationResult

Parameters

inventoryProvider
Type: Sitecore.Commerce.Services.InventoryInventoryServiceProvider
A InventoryServiceProvider object.
request
Type: TGetBackOrderableInformationRequest
The GetBackOrderableInformationRequest Contains the search criteria.

Type Parameters

TGetBackOrderableInformationRequest
The extended type of the GetBackOrderableInformationRequestclass.
TGetBackOrderableInformationResult
The extended type of the GetBackOrderableInformationResultclass.

Return Value

Type: TGetBackOrderableInformationResult
The extended GetBackOrderableInformationResult.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type InventoryServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericInventoryServiceProviderExtensions Class
Sitecore.Commerce.Services.Inventory.Generics Namespace


GenericInventoryServiceProviderExtensions.GetPreOrderableInformation(TGetPreOrderableInformationRequest, TGetPreOrderableInformationResult) Method

GenericInventoryServiceProviderExtensionsGetPreOrderableInformationTGetPreOrderableInformationRequest, TGetPreOrderableInformationResult Method
Retrieves preorderable information for products. It calls the GetPreOrderableInformation pipeline.

Namespace: Sitecore.Commerce.Services.Inventory.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetPreOrderableInformationResult GetPreOrderableInformation<TGetPreOrderableInformationRequest, TGetPreOrderableInformationResult>(
    this InventoryServiceProvider inventoryProvider,
    TGetPreOrderableInformationRequest request
)
where TGetPreOrderableInformationRequest : GetPreOrderableInformationRequest
where TGetPreOrderableInformationResult : new(), GetPreOrderableInformationResult

<ExtensionAttribute>
Public Shared Function GetPreOrderableInformation(Of TGetPreOrderableInformationRequest As GetPreOrderableInformationRequest, TGetPreOrderableInformationResult As {New, GetPreOrderableInformationResult}) (
    inventoryProvider As InventoryServiceProvider,
    request As TGetPreOrderableInformationRequest
) As TGetPreOrderableInformationResult
public:
[ExtensionAttribute]
generic<typename TGetPreOrderableInformationRequest, typename TGetPreOrderableInformationResult>
where TGetPreOrderableInformationRequest : GetPreOrderableInformationRequest
where TGetPreOrderableInformationResult : gcnew(), GetPreOrderableInformationResult
static TGetPreOrderableInformationResult GetPreOrderableInformation(
    InventoryServiceProvider^ inventoryProvider,
    TGetPreOrderableInformationRequest request
)
static member GetPreOrderableInformation :
        inventoryProvider : InventoryServiceProvider *
        request : 'TGetPreOrderableInformationRequest -> 'TGetPreOrderableInformationResult  when 'TGetPreOrderableInformationRequest : GetPreOrderableInformationRequest when 'TGetPreOrderableInformationResult : new() and GetPreOrderableInformationResult

Parameters

inventoryProvider
Type: Sitecore.Commerce.Services.InventoryInventoryServiceProvider
A InventoryServiceProvider object.
request
Type: TGetPreOrderableInformationRequest
The GetPreOrderableInformationRequest Contains the search criteria.

Type Parameters

TGetPreOrderableInformationRequest
The extended type of the GetPreOrderableInformationRequestclass.
TGetPreOrderableInformationResult
The extended type of the GetPreOrderableInformationResultclass.

Return Value

Type: TGetPreOrderableInformationResult
The extended GetPreOrderableInformationResult.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type InventoryServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericInventoryServiceProviderExtensions Class
Sitecore.Commerce.Services.Inventory.Generics Namespace


GenericInventoryServiceProviderExtensions.GetStockInformation(TGetStockInformationRequest, TGetStockInformationResult) Method

GenericInventoryServiceProviderExtensionsGetStockInformationTGetStockInformationRequest, TGetStockInformationResult Method
Retrieves stock information for products. It calls the GetStockInformation pipeline.

Namespace: Sitecore.Commerce.Services.Inventory.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetStockInformationResult GetStockInformation<TGetStockInformationRequest, TGetStockInformationResult>(
    this InventoryServiceProvider inventoryProvider,
    TGetStockInformationRequest request
)
where TGetStockInformationRequest : GetStockInformationRequest
where TGetStockInformationResult : new(), GetStockInformationResult

<ExtensionAttribute>
Public Shared Function GetStockInformation(Of TGetStockInformationRequest As GetStockInformationRequest, TGetStockInformationResult As {New, GetStockInformationResult}) (
    inventoryProvider As InventoryServiceProvider,
    request As TGetStockInformationRequest
) As TGetStockInformationResult
public:
[ExtensionAttribute]
generic<typename TGetStockInformationRequest, typename TGetStockInformationResult>
where TGetStockInformationRequest : GetStockInformationRequest
where TGetStockInformationResult : gcnew(), GetStockInformationResult
static TGetStockInformationResult GetStockInformation(
    InventoryServiceProvider^ inventoryProvider,
    TGetStockInformationRequest request
)
static member GetStockInformation :
        inventoryProvider : InventoryServiceProvider *
        request : 'TGetStockInformationRequest -> 'TGetStockInformationResult  when 'TGetStockInformationRequest : GetStockInformationRequest when 'TGetStockInformationResult : new() and GetStockInformationResult

Parameters

inventoryProvider
Type: Sitecore.Commerce.Services.InventoryInventoryServiceProvider
A InventoryServiceProvider object.
request
Type: TGetStockInformationRequest
The GetStockInformationRequest Contains the search criteria.

Type Parameters

TGetStockInformationRequest
The extended type of the GetStockInformationRequestclass.
TGetStockInformationResult
The extended type of the GetStockInformationResultclass.

Return Value

Type: TGetStockInformationResult
The extended GetStockInformationResult.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type InventoryServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericInventoryServiceProviderExtensions Class
Sitecore.Commerce.Services.Inventory.Generics Namespace


GenericInventoryServiceProviderExtensions.ProductsAreBackInStock(TProductsAreBackInStockRequest, TProductsAreBackInStockResult) Method

GenericInventoryServiceProviderExtensionsProductsAreBackInStockTProductsAreBackInStockRequest, TProductsAreBackInStockResult Method
Updates a product stock count

Namespace: Sitecore.Commerce.Services.Inventory.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TProductsAreBackInStockResult ProductsAreBackInStock<TProductsAreBackInStockRequest, TProductsAreBackInStockResult>(
    this InventoryServiceProvider inventoryProvider,
    TProductsAreBackInStockRequest request
)
where TProductsAreBackInStockRequest : ProductsAreBackInStockRequest
where TProductsAreBackInStockResult : new(), ProductsAreBackInStockResult

<ExtensionAttribute>
Public Shared Function ProductsAreBackInStock(Of TProductsAreBackInStockRequest As ProductsAreBackInStockRequest, TProductsAreBackInStockResult As {New, ProductsAreBackInStockResult}) (
    inventoryProvider As InventoryServiceProvider,
    request As TProductsAreBackInStockRequest
) As TProductsAreBackInStockResult
public:
[ExtensionAttribute]
generic<typename TProductsAreBackInStockRequest, typename TProductsAreBackInStockResult>
where TProductsAreBackInStockRequest : ProductsAreBackInStockRequest
where TProductsAreBackInStockResult : gcnew(), ProductsAreBackInStockResult
static TProductsAreBackInStockResult ProductsAreBackInStock(
    InventoryServiceProvider^ inventoryProvider,
    TProductsAreBackInStockRequest request
)
static member ProductsAreBackInStock :
        inventoryProvider : InventoryServiceProvider *
        request : 'TProductsAreBackInStockRequest -> 'TProductsAreBackInStockResult  when 'TProductsAreBackInStockRequest : ProductsAreBackInStockRequest when 'TProductsAreBackInStockResult : new() and ProductsAreBackInStockResult

Parameters

inventoryProvider
Type: Sitecore.Commerce.Services.InventoryInventoryServiceProvider
A InventoryServiceProvider object.
request
Type: TProductsAreBackInStockRequest
The ProductsAreBackInStockRequest Contains the search criteria.

Type Parameters

TProductsAreBackInStockRequest
The extended type of the ProductsAreBackInStockRequestclass.
TProductsAreBackInStockResult
The extended type of the ProductsAreBackInStockResultclass.

Return Value

Type: TProductsAreBackInStockResult
The extended ProductsAreBackInStockResult.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type InventoryServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericInventoryServiceProviderExtensions Class
Sitecore.Commerce.Services.Inventory.Generics Namespace


GenericInventoryServiceProviderExtensions.RemoveVisitorFromStockNotification(TRemoveVisitorFromStockNotificationRequest, TRemoveVisitorFromStockNotificationResult) Method

GenericInventoryServiceProviderExtensionsRemoveVisitorFromStockNotificationTRemoveVisitorFromStockNotificationRequest, TRemoveVisitorFromStockNotificationResult Method
Removes a visitor from EA plan so they will no longer be notified when a product gets back in stock

Namespace: Sitecore.Commerce.Services.Inventory.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TRemoveVisitorFromStockNotificationResult RemoveVisitorFromStockNotification<TRemoveVisitorFromStockNotificationRequest, TRemoveVisitorFromStockNotificationResult>(
    this InventoryServiceProvider inventoryProvider,
    TRemoveVisitorFromStockNotificationRequest request
)
where TRemoveVisitorFromStockNotificationRequest : RemoveVisitorFromStockNotificationRequest
where TRemoveVisitorFromStockNotificationResult : new(), RemoveVisitorFromStockNotificationResult

<ExtensionAttribute>
Public Shared Function RemoveVisitorFromStockNotification(Of TRemoveVisitorFromStockNotificationRequest As RemoveVisitorFromStockNotificationRequest, TRemoveVisitorFromStockNotificationResult As {New, RemoveVisitorFromStockNotificationResult}) (
    inventoryProvider As InventoryServiceProvider,
    request As TRemoveVisitorFromStockNotificationRequest
) As TRemoveVisitorFromStockNotificationResult
public:
[ExtensionAttribute]
generic<typename TRemoveVisitorFromStockNotificationRequest, typename TRemoveVisitorFromStockNotificationResult>
where TRemoveVisitorFromStockNotificationRequest : RemoveVisitorFromStockNotificationRequest
where TRemoveVisitorFromStockNotificationResult : gcnew(), RemoveVisitorFromStockNotificationResult
static TRemoveVisitorFromStockNotificationResult RemoveVisitorFromStockNotification(
    InventoryServiceProvider^ inventoryProvider,
    TRemoveVisitorFromStockNotificationRequest request
)
static member RemoveVisitorFromStockNotification :
        inventoryProvider : InventoryServiceProvider *
        request : 'TRemoveVisitorFromStockNotificationRequest -> 'TRemoveVisitorFromStockNotificationResult  when 'TRemoveVisitorFromStockNotificationRequest : RemoveVisitorFromStockNotificationRequest when 'TRemoveVisitorFromStockNotificationResult : new() and RemoveVisitorFromStockNotificationResult

Parameters

inventoryProvider
Type: Sitecore.Commerce.Services.InventoryInventoryServiceProvider
A InventoryServiceProvider object.
request
Type: TRemoveVisitorFromStockNotificationRequest
The RemoveVisitorFromStockNotificationRequest Contains the search criteria.

Type Parameters

TRemoveVisitorFromStockNotificationRequest
The extended type of the RemoveVisitorFromStockNotificationRequestclass.
TRemoveVisitorFromStockNotificationResult
The extended type of the RemoveVisitorFromStockNotificationResultclass.

Return Value

Type: TRemoveVisitorFromStockNotificationResult
The extended RemoveVisitorFromStockNotificationResult.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type InventoryServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericInventoryServiceProviderExtensions Class
Sitecore.Commerce.Services.Inventory.Generics Namespace


GenericInventoryServiceProviderExtensions.VisitedProductStockStatus(TVisitedProductStockStatusRequest, TVisitedProductStockStatusResult) Method

GenericInventoryServiceProviderExtensionsVisitedProductStockStatusTVisitedProductStockStatusRequest, TVisitedProductStockStatusResult Method
Track product stock status for customers visiting product details pages

Namespace: Sitecore.Commerce.Services.Inventory.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TVisitedProductStockStatusResult VisitedProductStockStatus<TVisitedProductStockStatusRequest, TVisitedProductStockStatusResult>(
    this InventoryServiceProvider inventoryProvider,
    TVisitedProductStockStatusRequest request
)
where TVisitedProductStockStatusRequest : VisitedProductStockStatusRequest
where TVisitedProductStockStatusResult : new(), VisitedProductStockStatusResult

<ExtensionAttribute>
Public Shared Function VisitedProductStockStatus(Of TVisitedProductStockStatusRequest As VisitedProductStockStatusRequest, TVisitedProductStockStatusResult As {New, VisitedProductStockStatusResult}) (
    inventoryProvider As InventoryServiceProvider,
    request As TVisitedProductStockStatusRequest
) As TVisitedProductStockStatusResult
public:
[ExtensionAttribute]
generic<typename TVisitedProductStockStatusRequest, typename TVisitedProductStockStatusResult>
where TVisitedProductStockStatusRequest : VisitedProductStockStatusRequest
where TVisitedProductStockStatusResult : gcnew(), VisitedProductStockStatusResult
static TVisitedProductStockStatusResult VisitedProductStockStatus(
    InventoryServiceProvider^ inventoryProvider,
    TVisitedProductStockStatusRequest request
)
static member VisitedProductStockStatus :
        inventoryProvider : InventoryServiceProvider *
        request : 'TVisitedProductStockStatusRequest -> 'TVisitedProductStockStatusResult  when 'TVisitedProductStockStatusRequest : VisitedProductStockStatusRequest when 'TVisitedProductStockStatusResult : new() and VisitedProductStockStatusResult

Parameters

inventoryProvider
Type: Sitecore.Commerce.Services.InventoryInventoryServiceProvider
A InventoryServiceProvider object.
request
Type: TVisitedProductStockStatusRequest
The VisitedProductStockStatusRequest Contains the search criteria.

Type Parameters

TVisitedProductStockStatusRequest
The extended type of the VisitedProductStockStatusRequestclass.
TVisitedProductStockStatusResult
The extended type of the VisitedProductStockStatusResultclass.

Return Value

Type: TVisitedProductStockStatusResult
The extended VisitedProductStockStatusResult.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type InventoryServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericInventoryServiceProviderExtensions Class
Sitecore.Commerce.Services.Inventory.Generics Namespace


GenericInventoryServiceProviderExtensions.VisitorSignUpForStockNotification(TVisitorSignUpForStockNotificationRequest, TVisitorSignUpForStockNotificationResult) Method

GenericInventoryServiceProviderExtensionsVisitorSignUpForStockNotificationTVisitorSignUpForStockNotificationRequest, TVisitorSignUpForStockNotificationResult Method
Adds a visitor to EA plan so they can be notified when the product gets back in stock

Namespace: Sitecore.Commerce.Services.Inventory.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TVisitorSignUpForStockNotificationResult VisitorSignUpForStockNotification<TVisitorSignUpForStockNotificationRequest, TVisitorSignUpForStockNotificationResult>(
    this InventoryServiceProvider inventoryProvider,
    TVisitorSignUpForStockNotificationRequest request
)
where TVisitorSignUpForStockNotificationRequest : VisitorSignUpForStockNotificationRequest
where TVisitorSignUpForStockNotificationResult : new(), VisitorSignUpForStockNotificationResult

<ExtensionAttribute>
Public Shared Function VisitorSignUpForStockNotification(Of TVisitorSignUpForStockNotificationRequest As VisitorSignUpForStockNotificationRequest, TVisitorSignUpForStockNotificationResult As {New, VisitorSignUpForStockNotificationResult}) (
    inventoryProvider As InventoryServiceProvider,
    request As TVisitorSignUpForStockNotificationRequest
) As TVisitorSignUpForStockNotificationResult
public:
[ExtensionAttribute]
generic<typename TVisitorSignUpForStockNotificationRequest, typename TVisitorSignUpForStockNotificationResult>
where TVisitorSignUpForStockNotificationRequest : VisitorSignUpForStockNotificationRequest
where TVisitorSignUpForStockNotificationResult : gcnew(), VisitorSignUpForStockNotificationResult
static TVisitorSignUpForStockNotificationResult VisitorSignUpForStockNotification(
    InventoryServiceProvider^ inventoryProvider,
    TVisitorSignUpForStockNotificationRequest request
)
static member VisitorSignUpForStockNotification :
        inventoryProvider : InventoryServiceProvider *
        request : 'TVisitorSignUpForStockNotificationRequest -> 'TVisitorSignUpForStockNotificationResult  when 'TVisitorSignUpForStockNotificationRequest : VisitorSignUpForStockNotificationRequest when 'TVisitorSignUpForStockNotificationResult : new() and VisitorSignUpForStockNotificationResult

Parameters

inventoryProvider
Type: Sitecore.Commerce.Services.InventoryInventoryServiceProvider
A InventoryServiceProvider object.
request
Type: TVisitorSignUpForStockNotificationRequest
The VisitorSignUpForStockNotificationRequest Contains the search criteria.

Type Parameters

TVisitorSignUpForStockNotificationRequest
The extended type of the VisitorSignUpForStockNotificationRequestclass.
TVisitorSignUpForStockNotificationResult
The extended type of the VisitorSignUpForStockNotificationResultclass.

Return Value

Type: TVisitorSignUpForStockNotificationResult
The extended VisitorSignUpForStockNotificationResult.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type InventoryServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericInventoryServiceProviderExtensions Class
Sitecore.Commerce.Services.Inventory.Generics Namespace


Sitecore.Commerce.Services.Orders Namespace

Sitecore.Commerce.Services.Orders Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Services.Orders"]

Classes
 | Class | Description
Public class | GetVisitorOrderRequest | Defines the GetVisitorOrderRequest class.
Public class | GetVisitorOrderResult | Defines the GetVisitorOrderResult class.
Public class | GetVisitorOrdersRequest | Defines the GetVisitorOrdersRequest class.
Public class | GetVisitorOrdersResult | Defines the GetVisitorOrdersResult class.
Public class | OrderServiceProvider | Represents the interaction with the orders. Service providers are wrapper objects that ease the interaction with Commerce Connect pipelines. Service providers only implement the logic that calls pipelines. All the business logic is implemented in the pipeline's processors. Every method receives a request object and returns a result object, for example, SubmitVisitorOrder receives SubmitVisitorOrderRequest and returns SubmitVisitorOrderResult. To follow the best practice and ease the API optimization as implemented in the domain model, every class must be defined as an abstract class rather than an interface. The OrderServiceProvider class implements the ServiceProvider class.
Public class | OrdersRequest | Defines the OrdersRequest class.
Public class | OrdersResult | Defines the OrdersResult class.
Public class | SubmitVisitorOrderRequest | Defines the SubmitVisitorOrderRequest class.
Public class | SubmitVisitorOrderResult | Defines the SubmitVisitorOrderResult class.
Public class | VisitorCancelOrderRequest | Defines the VisitorCancelOrderRequest class.
Public class | VisitorCancelOrderResult | Defines the VisitorCancelOrderResult class.


GetVisitorOrderRequest Class

GetVisitorOrderRequest Class
Defines the GetVisitorOrderRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.OrdersOrdersRequest
Sitecore.Commerce.Services.OrdersGetVisitorOrderRequest

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetVisitorOrderRequest : OrdersRequest
Public Class GetVisitorOrderRequest
    Inherits OrdersRequest
public ref class GetVisitorOrderRequest : public OrdersRequest
type GetVisitorOrderRequest =
    class
        inherit OrdersRequest
    end

The GetVisitorOrderRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetVisitorOrderRequest | Initializes a new instance of the GetVisitorOrderRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerID | Gets or sets the customer identifier.
Public property | OrderID | Gets or sets the order identifier.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Top
See Also

Reference

Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrderRequest Constructor

GetVisitorOrderRequest Constructor
Initializes a new instance of the GetVisitorOrderRequest class.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetVisitorOrderRequest(
    string orderID,
    string customerID,
    string shopName
)
Public Sub New (
    orderID As String,
    customerID As String,
    shopName As String
)
public:
GetVisitorOrderRequest(
    String^ orderID,
    String^ customerID,
    String^ shopName
)
new :
        orderID : string *
        customerID : string *
        shopName : string -> GetVisitorOrderRequest

Parameters

orderID
Type: SystemString
The order identifier.
customerID
Type: SystemString
The customer identifier.
shopName
Type: SystemString
Name of the shop.
See Also

Reference

GetVisitorOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrderRequest Methods

GetVisitorOrderRequest Methods

The GetVisitorOrderRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetVisitorOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrderRequest Properties

GetVisitorOrderRequest Properties

The GetVisitorOrderRequest type exposes the following members.

Properties
 | Name | Description
Public property | CustomerID | Gets or sets the customer identifier.
Public property | OrderID | Gets or sets the order identifier.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Top
See Also

Reference

GetVisitorOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrderRequest.CustomerID Property

GetVisitorOrderRequestCustomerID Property
Gets or sets the customer identifier.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string CustomerID { get; set; }
Public Property CustomerID As String
    Get
    Set
public:
property String^ CustomerID {
    String^ get ();
    void set (String^ value);
}
member CustomerID : string with get, set

Property Value

Type: String
The customer identifier.
See Also

Reference

GetVisitorOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrderRequest.OrderID Property

GetVisitorOrderRequestOrderID Property
Gets or sets the order identifier.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}
member OrderID : string with get, set

Property Value

Type: String
The order identifier.
See Also

Reference

GetVisitorOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrderRequest.ShopName Property

GetVisitorOrderRequestShopName Property
Gets or sets the name of the shop.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
The name of the shop.
See Also

Reference

GetVisitorOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrderResult Class

GetVisitorOrderResult Class
Defines the GetVisitorOrderResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.OrdersOrdersResult
Sitecore.Commerce.Services.OrdersGetVisitorOrderResult

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetVisitorOrderResult : OrdersResult
Public Class GetVisitorOrderResult
    Inherits OrdersResult
public ref class GetVisitorOrderResult : public OrdersResult
type GetVisitorOrderResult =
    class
        inherit OrdersResult
    end

The GetVisitorOrderResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetVisitorOrderResult | Initializes a new instance of the GetVisitorOrderResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Order | Gets or sets the order.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrderResult Constructor

GetVisitorOrderResult Constructor
Initializes a new instance of the GetVisitorOrderResult class

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetVisitorOrderResult()
Public Sub New
public:
GetVisitorOrderResult()
new : unit -> GetVisitorOrderResult
See Also

Reference

GetVisitorOrderResult Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrderResult Methods

GetVisitorOrderResult Methods

The GetVisitorOrderResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetVisitorOrderResult Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrderResult Properties

GetVisitorOrderResult Properties

The GetVisitorOrderResult type exposes the following members.

Properties
 | Name | Description
Public property | Order | Gets or sets the order.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetVisitorOrderResult Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrderResult.Order Property

GetVisitorOrderResultOrder Property
Gets or sets the order.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Order Order { get; set; }
Public Property Order As Order
    Get
    Set
public:
property Order^ Order {
    Order^ get ();
    void set (Order^ value);
}
member Order : Order with get, set

Property Value

Type: Order
The order.
See Also

Reference

GetVisitorOrderResult Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrdersRequest Class

GetVisitorOrdersRequest Class
Defines the GetVisitorOrdersRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.OrdersOrdersRequest
Sitecore.Commerce.Services.OrdersGetVisitorOrdersRequest

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetVisitorOrdersRequest : OrdersRequest
Public Class GetVisitorOrdersRequest
    Inherits OrdersRequest
public ref class GetVisitorOrdersRequest : public OrdersRequest
type GetVisitorOrdersRequest =
    class
        inherit OrdersRequest
    end

The GetVisitorOrdersRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetVisitorOrdersRequest | Initializes a new instance of the GetVisitorOrdersRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerID | Gets or sets the customer identifier.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Public property | StateFilter | Gets or sets the state filter.
Top
See Also

Reference

Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrdersRequest Constructor

GetVisitorOrdersRequest Constructor
Initializes a new instance of the GetVisitorOrdersRequest class.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetVisitorOrdersRequest(
    string customerID,
    string shopName,
    string stateFilter = null
)
Public Sub New (
    customerID As String,
    shopName As String,
    Optional stateFilter As String = Nothing
)
public:
GetVisitorOrdersRequest(
    String^ customerID,
    String^ shopName,
    String^ stateFilter = nullptr
)
new :
        customerID : string *
        shopName : string *
        ?stateFilter : string
(* Defaults:
        let _stateFilter = defaultArg stateFilter null
*)
-> GetVisitorOrdersRequest

Parameters

customerID
Type: SystemString
The customer identifier.
shopName
Type: SystemString
Name of the shop.
stateFilter (Optional)
Type: SystemString
The state filter.
See Also

Reference

GetVisitorOrdersRequest Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrdersRequest Methods

GetVisitorOrdersRequest Methods

The GetVisitorOrdersRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetVisitorOrdersRequest Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrdersRequest Properties

GetVisitorOrdersRequest Properties

The GetVisitorOrdersRequest type exposes the following members.

Properties
 | Name | Description
Public property | CustomerID | Gets or sets the customer identifier.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Public property | StateFilter | Gets or sets the state filter.
Top
See Also

Reference

GetVisitorOrdersRequest Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrdersRequest.CustomerID Property

GetVisitorOrdersRequestCustomerID Property
Gets or sets the customer identifier.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string CustomerID { get; set; }
Public Property CustomerID As String
    Get
    Set
public:
property String^ CustomerID {
    String^ get ();
    void set (String^ value);
}
member CustomerID : string with get, set

Property Value

Type: String
The customer identifier.
See Also

Reference

GetVisitorOrdersRequest Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrdersRequest.ShopName Property

GetVisitorOrdersRequestShopName Property
Gets or sets the name of the shop.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
The name of the shop.
See Also

Reference

GetVisitorOrdersRequest Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrdersRequest.StateFilter Property

GetVisitorOrdersRequestStateFilter Property
Gets or sets the state filter.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string StateFilter { get; set; }
Public Property StateFilter As String
    Get
    Set
public:
property String^ StateFilter {
    String^ get ();
    void set (String^ value);
}
member StateFilter : string with get, set

Property Value

Type: String
The state filter.
See Also

Reference

GetVisitorOrdersRequest Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrdersResult Class

GetVisitorOrdersResult Class
Defines the GetVisitorOrdersResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.OrdersOrdersResult
Sitecore.Commerce.Services.OrdersGetVisitorOrdersResult

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetVisitorOrdersResult : OrdersResult
Public Class GetVisitorOrdersResult
    Inherits OrdersResult
public ref class GetVisitorOrdersResult : public OrdersResult
type GetVisitorOrdersResult =
    class
        inherit OrdersResult
    end

The GetVisitorOrdersResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetVisitorOrdersResult | Initializes a new instance of the GetVisitorOrdersResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | OrderHeaders | Gets or sets the order headers.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrdersResult Constructor

GetVisitorOrdersResult Constructor
Initializes a new instance of the GetVisitorOrdersResult class

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetVisitorOrdersResult()
Public Sub New
public:
GetVisitorOrdersResult()
new : unit -> GetVisitorOrdersResult
See Also

Reference

GetVisitorOrdersResult Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrdersResult Methods

GetVisitorOrdersResult Methods

The GetVisitorOrdersResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetVisitorOrdersResult Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrdersResult Properties

GetVisitorOrdersResult Properties

The GetVisitorOrdersResult type exposes the following members.

Properties
 | Name | Description
Public property | OrderHeaders | Gets or sets the order headers.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetVisitorOrdersResult Class
Sitecore.Commerce.Services.Orders Namespace


GetVisitorOrdersResult.OrderHeaders Property

GetVisitorOrdersResultOrderHeaders Property
Gets or sets the order headers.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection OrderHeaders { get; set; }
Public Property OrderHeaders As IReadOnlyCollection
    Get
    Set
public:
property IReadOnlyCollection^ OrderHeaders {
    IReadOnlyCollection^ get ();
    void set (IReadOnlyCollection^ value);
}
member OrderHeaders : IReadOnlyCollection with get, set

Property Value

Type: IReadOnlyCollectionT
The order headers.
See Also

Reference

GetVisitorOrdersResult Class
Sitecore.Commerce.Services.Orders Namespace


OrderServiceProvider Class

OrderServiceProvider Class
Represents the interaction with the orders. Service providers are wrapper objects that ease the interaction with Commerce Connect pipelines. Service providers only implement the logic that calls pipelines. All the business logic is implemented in the pipeline's processors. Every method receives a request object and returns a result object, for example, SubmitVisitorOrder receives SubmitVisitorOrderRequest and returns SubmitVisitorOrderResult. To follow the best practice and ease the API optimization as implemented in the domain model, every class must be defined as an abstract class rather than an interface. The OrderServiceProvider class implements the ServiceProvider class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProvider
Sitecore.Commerce.Services.OrdersOrderServiceProvider

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class OrderServiceProvider : ServiceProvider
Public Class OrderServiceProvider
    Inherits ServiceProvider
public ref class OrderServiceProvider : public ServiceProvider
type OrderServiceProvider =
    class
        inherit ServiceProvider
    end

The OrderServiceProvider type exposes the following members.

Constructors
 | Name | Description
Public method | OrderServiceProvider | Initializes a new instance of the OrderServiceProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVisitorOrder | Gets the visitor order.
Public method | GetVisitorOrders | Gets the visitor orders.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RunPipelineTRequest, TResult | Runs the pipeline. (Inherited from ServiceProvider.)
Public method | SubmitVisitorOrder | Submits the visitor order.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VisitorCancelOrder | Visitor cancels and order.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetVisitorOrderTGetVisitorOrderRequest, TGetVisitorOrderResult | Gets the visitor order. (Defined by GenericOrderServiceProviderExtensions.)
Public Extension Method | GetVisitorOrdersTGetVisitorOrdersRequest, TGetVisitorOrdersResult | Gets the visitor orders. (Defined by GenericOrderServiceProviderExtensions.)
Public Extension Method | SubmitVisitorOrderTSubmitVisitorOrderRequest, TSubmitVisitorOrderResult | Submits the visitor order. (Defined by GenericOrderServiceProviderExtensions.)
Public Extension Method | VisitorCancelOrderTVisitorCancelOrderRequest, TVisitorCancelOrderResult | Visitor cancels an order. (Defined by GenericOrderServiceProviderExtensions.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from ServiceProvider.)
Top
Remarks
The Order Provider methods call the order pipelines to interact with the carts.
See Also

Reference

Sitecore.Commerce.Services.Orders Namespace


OrderServiceProvider Constructor

OrderServiceProvider Constructor
Initializes a new instance of the OrderServiceProvider class

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public OrderServiceProvider()
Public Sub New
public:
OrderServiceProvider()
new : unit -> OrderServiceProvider
See Also

Reference

OrderServiceProvider Class
Sitecore.Commerce.Services.Orders Namespace


OrderServiceProvider Methods

OrderServiceProvider Methods

The OrderServiceProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVisitorOrder | Gets the visitor order.
Public method | GetVisitorOrders | Gets the visitor orders.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RunPipelineTRequest, TResult | Runs the pipeline. (Inherited from ServiceProvider.)
Public method | SubmitVisitorOrder | Submits the visitor order.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VisitorCancelOrder | Visitor cancels and order.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetVisitorOrderTGetVisitorOrderRequest, TGetVisitorOrderResult | Gets the visitor order. (Defined by GenericOrderServiceProviderExtensions.)
Public Extension Method | GetVisitorOrdersTGetVisitorOrdersRequest, TGetVisitorOrdersResult | Gets the visitor orders. (Defined by GenericOrderServiceProviderExtensions.)
Public Extension Method | SubmitVisitorOrderTSubmitVisitorOrderRequest, TSubmitVisitorOrderResult | Submits the visitor order. (Defined by GenericOrderServiceProviderExtensions.)
Public Extension Method | VisitorCancelOrderTVisitorCancelOrderRequest, TVisitorCancelOrderResult | Visitor cancels an order. (Defined by GenericOrderServiceProviderExtensions.)
Top
See Also

Reference

OrderServiceProvider Class
Sitecore.Commerce.Services.Orders Namespace


OrderServiceProvider.GetVisitorOrder Method

OrderServiceProviderGetVisitorOrder Method
Gets the visitor order.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetVisitorOrderResult GetVisitorOrder(
    GetVisitorOrderRequest request
)
Public Overridable Function GetVisitorOrder (
    request As GetVisitorOrderRequest
) As GetVisitorOrderResult
public:
virtual GetVisitorOrderResult^ GetVisitorOrder(
    GetVisitorOrderRequest^ request
)
abstract GetVisitorOrder :
        request : GetVisitorOrderRequest -> GetVisitorOrderResult
override GetVisitorOrder :
        request : GetVisitorOrderRequest -> GetVisitorOrderResult

Parameters

request
Type: Sitecore.Commerce.Services.OrdersGetVisitorOrderRequest
The request.

Return Value

Type: GetVisitorOrderResult
An instance of the GetVisitorOrderResult class.
See Also

Reference

OrderServiceProvider Class
Sitecore.Commerce.Services.Orders Namespace


OrderServiceProvider.GetVisitorOrders Method

OrderServiceProviderGetVisitorOrders Method
Gets the visitor orders.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetVisitorOrdersResult GetVisitorOrders(
    GetVisitorOrdersRequest request
)
Public Overridable Function GetVisitorOrders (
    request As GetVisitorOrdersRequest
) As GetVisitorOrdersResult
public:
virtual GetVisitorOrdersResult^ GetVisitorOrders(
    GetVisitorOrdersRequest^ request
)
abstract GetVisitorOrders :
        request : GetVisitorOrdersRequest -> GetVisitorOrdersResult
override GetVisitorOrders :
        request : GetVisitorOrdersRequest -> GetVisitorOrdersResult

Parameters

request
Type: Sitecore.Commerce.Services.OrdersGetVisitorOrdersRequest
The request.

Return Value

Type: GetVisitorOrdersResult
An instance of the GetVisitorOrdersResult class.
See Also

Reference

OrderServiceProvider Class
Sitecore.Commerce.Services.Orders Namespace


OrderServiceProvider.SubmitVisitorOrder Method

OrderServiceProviderSubmitVisitorOrder Method
Submits the visitor order.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual SubmitVisitorOrderResult SubmitVisitorOrder(
    SubmitVisitorOrderRequest request
)
Public Overridable Function SubmitVisitorOrder (
    request As SubmitVisitorOrderRequest
) As SubmitVisitorOrderResult
public:
virtual SubmitVisitorOrderResult^ SubmitVisitorOrder(
    SubmitVisitorOrderRequest^ request
)
abstract SubmitVisitorOrder :
        request : SubmitVisitorOrderRequest -> SubmitVisitorOrderResult
override SubmitVisitorOrder :
        request : SubmitVisitorOrderRequest -> SubmitVisitorOrderResult

Parameters

request
Type: Sitecore.Commerce.Services.OrdersSubmitVisitorOrderRequest
The request.

Return Value

Type: SubmitVisitorOrderResult
An instance of the SubmitVisitorOrderResult class.
See Also

Reference

OrderServiceProvider Class
Sitecore.Commerce.Services.Orders Namespace


OrderServiceProvider.VisitorCancelOrder Method

OrderServiceProviderVisitorCancelOrder Method
Visitor cancels and order.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual VisitorCancelOrderResult VisitorCancelOrder(
    VisitorCancelOrderRequest request
)
Public Overridable Function VisitorCancelOrder (
    request As VisitorCancelOrderRequest
) As VisitorCancelOrderResult
public:
virtual VisitorCancelOrderResult^ VisitorCancelOrder(
    VisitorCancelOrderRequest^ request
)
abstract VisitorCancelOrder :
        request : VisitorCancelOrderRequest -> VisitorCancelOrderResult
override VisitorCancelOrder :
        request : VisitorCancelOrderRequest -> VisitorCancelOrderResult

Parameters

request
Type: Sitecore.Commerce.Services.OrdersVisitorCancelOrderRequest
The request.

Return Value

Type: VisitorCancelOrderResult
An instance of the VisitorOrderCancelResult class.
See Also

Reference

OrderServiceProvider Class
Sitecore.Commerce.Services.Orders Namespace


OrderServiceProvider Properties

OrderServiceProvider Properties

The OrderServiceProvider type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from ServiceProvider.)
Top
See Also

Reference

OrderServiceProvider Class
Sitecore.Commerce.Services.Orders Namespace


OrdersRequest Class

OrdersRequest Class
Defines the OrdersRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.OrdersOrdersRequest
Sitecore.Commerce.Services.OrdersGetVisitorOrderRequest
Sitecore.Commerce.Services.OrdersGetVisitorOrdersRequest
Sitecore.Commerce.Services.OrdersSubmitVisitorOrderRequest
Sitecore.Commerce.Services.OrdersVisitorCancelOrderRequest

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class OrdersRequest : ServiceProviderRequest
Public Class OrdersRequest
    Inherits ServiceProviderRequest
public ref class OrdersRequest : public ServiceProviderRequest
type OrdersRequest =
    class
        inherit ServiceProviderRequest
    end

The OrdersRequest type exposes the following members.

Constructors
 | Name | Description
Public method | OrdersRequest | Initializes a new instance of the OrdersRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Orders Namespace


OrdersRequest Constructor

OrdersRequest Constructor
Initializes a new instance of the OrdersRequest class

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public OrdersRequest()
Public Sub New
public:
OrdersRequest()
new : unit -> OrdersRequest
See Also

Reference

OrdersRequest Class
Sitecore.Commerce.Services.Orders Namespace


OrdersRequest Methods

OrdersRequest Methods

The OrdersRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OrdersRequest Class
Sitecore.Commerce.Services.Orders Namespace


OrdersRequest Properties

OrdersRequest Properties

The OrdersRequest type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

OrdersRequest Class
Sitecore.Commerce.Services.Orders Namespace


OrdersResult Class

OrdersResult Class
Defines the OrdersResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.OrdersOrdersResult
Sitecore.Commerce.Services.OrdersGetVisitorOrderResult
Sitecore.Commerce.Services.OrdersGetVisitorOrdersResult
Sitecore.Commerce.Services.OrdersSubmitVisitorOrderResult
Sitecore.Commerce.Services.OrdersVisitorCancelOrderResult

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class OrdersResult : ServiceProviderResult
Public Class OrdersResult
    Inherits ServiceProviderResult
public ref class OrdersResult : public ServiceProviderResult
type OrdersResult =
    class
        inherit ServiceProviderResult
    end

The OrdersResult type exposes the following members.

Constructors
 | Name | Description
Public method | OrdersResult | Initializes a new instance of the OrdersResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Orders Namespace


OrdersResult Constructor

OrdersResult Constructor
Initializes a new instance of the OrdersResult class

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public OrdersResult()
Public Sub New
public:
OrdersResult()
new : unit -> OrdersResult
See Also

Reference

OrdersResult Class
Sitecore.Commerce.Services.Orders Namespace


OrdersResult Methods

OrdersResult Methods

The OrdersResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OrdersResult Class
Sitecore.Commerce.Services.Orders Namespace


OrdersResult Properties

OrdersResult Properties

The OrdersResult type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

OrdersResult Class
Sitecore.Commerce.Services.Orders Namespace


SubmitVisitorOrderRequest Class

SubmitVisitorOrderRequest Class
Defines the SubmitVisitorOrderRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.OrdersOrdersRequest
Sitecore.Commerce.Services.OrdersSubmitVisitorOrderRequest

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SubmitVisitorOrderRequest : OrdersRequest
Public Class SubmitVisitorOrderRequest
    Inherits OrdersRequest
public ref class SubmitVisitorOrderRequest : public OrdersRequest
type SubmitVisitorOrderRequest =
    class
        inherit OrdersRequest
    end

The SubmitVisitorOrderRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SubmitVisitorOrderRequest | Initializes a new instance of the SubmitVisitorOrderRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Orders Namespace


SubmitVisitorOrderRequest Constructor

SubmitVisitorOrderRequest Constructor
Initializes a new instance of the SubmitVisitorOrderRequest class.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SubmitVisitorOrderRequest(
    Cart cart
)
Public Sub New (
    cart As Cart
)
public:
SubmitVisitorOrderRequest(
    Cart^ cart
)
new :
        cart : Cart -> SubmitVisitorOrderRequest

Parameters

cart
Type: Sitecore.Commerce.Entities.CartsCart
The cart.
See Also

Reference

SubmitVisitorOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


SubmitVisitorOrderRequest Methods

SubmitVisitorOrderRequest Methods

The SubmitVisitorOrderRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SubmitVisitorOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


SubmitVisitorOrderRequest Properties

SubmitVisitorOrderRequest Properties

The SubmitVisitorOrderRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

SubmitVisitorOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


SubmitVisitorOrderRequest.Cart Property

SubmitVisitorOrderRequestCart Property
Gets or sets the cart.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Cart Cart { get; set; }
Public Property Cart As Cart
    Get
    Set
public:
property Cart^ Cart {
    Cart^ get ();
    void set (Cart^ value);
}
member Cart : Cart with get, set

Property Value

Type: Cart
The cart.
See Also

Reference

SubmitVisitorOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


SubmitVisitorOrderResult Class

SubmitVisitorOrderResult Class
Defines the SubmitVisitorOrderResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.OrdersOrdersResult
Sitecore.Commerce.Services.OrdersSubmitVisitorOrderResult

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SubmitVisitorOrderResult : OrdersResult
Public Class SubmitVisitorOrderResult
    Inherits OrdersResult
public ref class SubmitVisitorOrderResult : public OrdersResult
type SubmitVisitorOrderResult =
    class
        inherit OrdersResult
    end

The SubmitVisitorOrderResult type exposes the following members.

Constructors
 | Name | Description
Public method | SubmitVisitorOrderResult | Initializes a new instance of the SubmitVisitorOrderResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CartWithErrors | Gets or sets the cart that caused for the submit operation to fail. Additional information can be found in the cart.
Public property | Order | Gets or sets the order.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Orders Namespace


SubmitVisitorOrderResult Constructor

SubmitVisitorOrderResult Constructor
Initializes a new instance of the SubmitVisitorOrderResult class

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SubmitVisitorOrderResult()
Public Sub New
public:
SubmitVisitorOrderResult()
new : unit -> SubmitVisitorOrderResult
See Also

Reference

SubmitVisitorOrderResult Class
Sitecore.Commerce.Services.Orders Namespace


SubmitVisitorOrderResult Methods

SubmitVisitorOrderResult Methods

The SubmitVisitorOrderResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SubmitVisitorOrderResult Class
Sitecore.Commerce.Services.Orders Namespace


SubmitVisitorOrderResult Properties

SubmitVisitorOrderResult Properties

The SubmitVisitorOrderResult type exposes the following members.

Properties
 | Name | Description
Public property | CartWithErrors | Gets or sets the cart that caused for the submit operation to fail. Additional information can be found in the cart.
Public property | Order | Gets or sets the order.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

SubmitVisitorOrderResult Class
Sitecore.Commerce.Services.Orders Namespace


SubmitVisitorOrderResult.CartWithErrors Property

SubmitVisitorOrderResultCartWithErrors Property
Gets or sets the cart that caused for the submit operation to fail. Additional information can be found in the cart.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Cart CartWithErrors { get; set; }
Public Property CartWithErrors As Cart
    Get
    Set
public:
property Cart^ CartWithErrors {
    Cart^ get ();
    void set (Cart^ value);
}
member CartWithErrors : Cart with get, set

Property Value

Type: Cart
The cart with errors.
See Also

Reference

SubmitVisitorOrderResult Class
Sitecore.Commerce.Services.Orders Namespace


SubmitVisitorOrderResult.Order Property

SubmitVisitorOrderResultOrder Property
Gets or sets the order.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Order Order { get; set; }
Public Property Order As Order
    Get
    Set
public:
property Order^ Order {
    Order^ get ();
    void set (Order^ value);
}
member Order : Order with get, set

Property Value

Type: Order
The order.
See Also

Reference

SubmitVisitorOrderResult Class
Sitecore.Commerce.Services.Orders Namespace


VisitorCancelOrderRequest Class

VisitorCancelOrderRequest Class
Defines the VisitorCancelOrderRequest class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.OrdersOrdersRequest
Sitecore.Commerce.Services.OrdersVisitorCancelOrderRequest

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class VisitorCancelOrderRequest : OrdersRequest
Public Class VisitorCancelOrderRequest
    Inherits OrdersRequest
public ref class VisitorCancelOrderRequest : public OrdersRequest
type VisitorCancelOrderRequest =
    class
        inherit OrdersRequest
    end

The VisitorCancelOrderRequest type exposes the following members.

Constructors
 | Name | Description
Public method | VisitorCancelOrderRequest | Initializes a new instance of the VisitorCancelOrderRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomerID | Gets or sets the customer identifier.
Public property | OrderID | Gets or sets the order identifier.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Top
See Also

Reference

Sitecore.Commerce.Services.Orders Namespace


VisitorCancelOrderRequest Constructor

VisitorCancelOrderRequest Constructor
Initializes a new instance of the VisitorCancelOrderRequest class.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public VisitorCancelOrderRequest(
    string orderID,
    string customerID,
    string shopName
)
Public Sub New (
    orderID As String,
    customerID As String,
    shopName As String
)
public:
VisitorCancelOrderRequest(
    String^ orderID,
    String^ customerID,
    String^ shopName
)
new :
        orderID : string *
        customerID : string *
        shopName : string -> VisitorCancelOrderRequest

Parameters

orderID
Type: SystemString
The order identifier.
customerID
Type: SystemString
The customer identifier.
shopName
Type: SystemString
Name of the shop.
See Also

Reference

VisitorCancelOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


VisitorCancelOrderRequest Methods

VisitorCancelOrderRequest Methods

The VisitorCancelOrderRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VisitorCancelOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


VisitorCancelOrderRequest Properties

VisitorCancelOrderRequest Properties

The VisitorCancelOrderRequest type exposes the following members.

Properties
 | Name | Description
Public property | CustomerID | Gets or sets the customer identifier.
Public property | OrderID | Gets or sets the order identifier.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Top
See Also

Reference

VisitorCancelOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


VisitorCancelOrderRequest.CustomerID Property

VisitorCancelOrderRequestCustomerID Property
Gets or sets the customer identifier.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string CustomerID { get; set; }
Public Property CustomerID As String
    Get
    Set
public:
property String^ CustomerID {
    String^ get ();
    void set (String^ value);
}
member CustomerID : string with get, set

Property Value

Type: String
The customer identifier.
See Also

Reference

VisitorCancelOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


VisitorCancelOrderRequest.OrderID Property

VisitorCancelOrderRequestOrderID Property
Gets or sets the order identifier.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}
member OrderID : string with get, set

Property Value

Type: String
The order identifier.
See Also

Reference

VisitorCancelOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


VisitorCancelOrderRequest.ShopName Property

VisitorCancelOrderRequestShopName Property
Gets or sets the name of the shop.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
The name of the shop.
See Also

Reference

VisitorCancelOrderRequest Class
Sitecore.Commerce.Services.Orders Namespace


VisitorCancelOrderResult Class

VisitorCancelOrderResult Class
Defines the VisitorCancelOrderResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.OrdersOrdersResult
Sitecore.Commerce.Services.OrdersVisitorCancelOrderResult

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class VisitorCancelOrderResult : OrdersResult
Public Class VisitorCancelOrderResult
    Inherits OrdersResult
public ref class VisitorCancelOrderResult : public OrdersResult
type VisitorCancelOrderResult =
    class
        inherit OrdersResult
    end

The VisitorCancelOrderResult type exposes the following members.

Constructors
 | Name | Description
Public method | VisitorCancelOrderResult | Initializes a new instance of the VisitorCancelOrderResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CancelledOrder | Gets or sets the cancelled order.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Orders Namespace


VisitorCancelOrderResult Constructor

VisitorCancelOrderResult Constructor
Initializes a new instance of the VisitorCancelOrderResult class

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public VisitorCancelOrderResult()
Public Sub New
public:
VisitorCancelOrderResult()
new : unit -> VisitorCancelOrderResult
See Also

Reference

VisitorCancelOrderResult Class
Sitecore.Commerce.Services.Orders Namespace


VisitorCancelOrderResult Methods

VisitorCancelOrderResult Methods

The VisitorCancelOrderResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VisitorCancelOrderResult Class
Sitecore.Commerce.Services.Orders Namespace


VisitorCancelOrderResult Properties

VisitorCancelOrderResult Properties

The VisitorCancelOrderResult type exposes the following members.

Properties
 | Name | Description
Public property | CancelledOrder | Gets or sets the cancelled order.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

VisitorCancelOrderResult Class
Sitecore.Commerce.Services.Orders Namespace


VisitorCancelOrderResult.CancelledOrder Property

VisitorCancelOrderResultCancelledOrder Property
Gets or sets the cancelled order.

Namespace: Sitecore.Commerce.Services.Orders
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Order CancelledOrder { get; set; }
Public Property CancelledOrder As Order
    Get
    Set
public:
property Order^ CancelledOrder {
    Order^ get ();
    void set (Order^ value);
}
member CancelledOrder : Order with get, set

Property Value

Type: Order
The cancelled order.
See Also

Reference

VisitorCancelOrderResult Class
Sitecore.Commerce.Services.Orders Namespace


Sitecore.Commerce.Services.Orders.Generics Namespace

Sitecore.Commerce.Services.Orders.Generics Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Services.Orders.Generics"]

Classes
 | Class | Description
Public class | GenericOrderServiceProviderExtensions | Extends the OrderServiceProvider class with some generic methods. It allows you to specify the result type of a custom service call.


GenericOrderServiceProviderExtensions Class

GenericOrderServiceProviderExtensions Class
Extends the OrderServiceProvider class with some generic methods. It allows you to specify the result type of a custom service call.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Services.Orders.GenericsGenericOrderServiceProviderExtensions

Namespace: Sitecore.Commerce.Services.Orders.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class GenericOrderServiceProviderExtensions
<ExtensionAttribute>
Public NotInheritable Class GenericOrderServiceProviderExtensions
[ExtensionAttribute]
public ref class GenericOrderServiceProviderExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GenericOrderServiceProviderExtensions =  class end

The GenericOrderServiceProviderExtensions type exposes the following members.

Methods
Name | Description
GetVisitorOrderTGetVisitorOrderRequest, TGetVisitorOrderResult | Gets the visitor order.
GetVisitorOrdersTGetVisitorOrdersRequest, TGetVisitorOrdersResult | Gets the visitor orders.
SubmitVisitorOrderTSubmitVisitorOrderRequest, TSubmitVisitorOrderResult | Submits the visitor order.
VisitorCancelOrderTVisitorCancelOrderRequest, TVisitorCancelOrderResult | Visitor cancels an order.
Top
See Also

Reference

Sitecore.Commerce.Services.Orders.Generics Namespace


GenericOrderServiceProviderExtensions Methods

GenericOrderServiceProviderExtensions Methods

The GenericOrderServiceProviderExtensions type exposes the following members.

Methods
Name | Description
GetVisitorOrderTGetVisitorOrderRequest, TGetVisitorOrderResult | Gets the visitor order.
GetVisitorOrdersTGetVisitorOrdersRequest, TGetVisitorOrdersResult | Gets the visitor orders.
SubmitVisitorOrderTSubmitVisitorOrderRequest, TSubmitVisitorOrderResult | Submits the visitor order.
VisitorCancelOrderTVisitorCancelOrderRequest, TVisitorCancelOrderResult | Visitor cancels an order.
Top
See Also

Reference

GenericOrderServiceProviderExtensions Class
Sitecore.Commerce.Services.Orders.Generics Namespace


GenericOrderServiceProviderExtensions.GetVisitorOrder(TGetVisitorOrderRequest, TGetVisitorOrderResult) Method

GenericOrderServiceProviderExtensionsGetVisitorOrderTGetVisitorOrderRequest, TGetVisitorOrderResult Method
Gets the visitor order.

Namespace: Sitecore.Commerce.Services.Orders.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetVisitorOrderResult GetVisitorOrder<TGetVisitorOrderRequest, TGetVisitorOrderResult>(
    this OrderServiceProvider orderProvider,
    TGetVisitorOrderRequest request
)
where TGetVisitorOrderRequest : GetVisitorOrderRequest
where TGetVisitorOrderResult : new(), GetVisitorOrderResult

<ExtensionAttribute>
Public Shared Function GetVisitorOrder(Of TGetVisitorOrderRequest As GetVisitorOrderRequest, TGetVisitorOrderResult As {New, GetVisitorOrderResult}) (
    orderProvider As OrderServiceProvider,
    request As TGetVisitorOrderRequest
) As TGetVisitorOrderResult
public:
[ExtensionAttribute]
generic<typename TGetVisitorOrderRequest, typename TGetVisitorOrderResult>
where TGetVisitorOrderRequest : GetVisitorOrderRequest
where TGetVisitorOrderResult : gcnew(), GetVisitorOrderResult
static TGetVisitorOrderResult GetVisitorOrder(
    OrderServiceProvider^ orderProvider,
    TGetVisitorOrderRequest request
)
static member GetVisitorOrder :
        orderProvider : OrderServiceProvider *
        request : 'TGetVisitorOrderRequest -> 'TGetVisitorOrderResult  when 'TGetVisitorOrderRequest : GetVisitorOrderRequest when 'TGetVisitorOrderResult : new() and GetVisitorOrderResult

Parameters

orderProvider
Type: Sitecore.Commerce.Services.OrdersOrderServiceProvider
The order provider.
request
Type: TGetVisitorOrderRequest
The request.

Type Parameters

TGetVisitorOrderRequest
The type of the get visitor order request.
TGetVisitorOrderResult
The type of the get visitor order result.

Return Value

Type: TGetVisitorOrderResult
A TGetVisitorOrderResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OrderServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericOrderServiceProviderExtensions Class
Sitecore.Commerce.Services.Orders.Generics Namespace


GenericOrderServiceProviderExtensions.GetVisitorOrders(TGetVisitorOrdersRequest, TGetVisitorOrdersResult) Method

GenericOrderServiceProviderExtensionsGetVisitorOrdersTGetVisitorOrdersRequest, TGetVisitorOrdersResult Method
Gets the visitor orders.

Namespace: Sitecore.Commerce.Services.Orders.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetVisitorOrdersResult GetVisitorOrders<TGetVisitorOrdersRequest, TGetVisitorOrdersResult>(
    this OrderServiceProvider orderProvider,
    TGetVisitorOrdersRequest request
)
where TGetVisitorOrdersRequest : GetVisitorOrdersRequest
where TGetVisitorOrdersResult : new(), GetVisitorOrdersResult

<ExtensionAttribute>
Public Shared Function GetVisitorOrders(Of TGetVisitorOrdersRequest As GetVisitorOrdersRequest, TGetVisitorOrdersResult As {New, GetVisitorOrdersResult}) (
    orderProvider As OrderServiceProvider,
    request As TGetVisitorOrdersRequest
) As TGetVisitorOrdersResult
public:
[ExtensionAttribute]
generic<typename TGetVisitorOrdersRequest, typename TGetVisitorOrdersResult>
where TGetVisitorOrdersRequest : GetVisitorOrdersRequest
where TGetVisitorOrdersResult : gcnew(), GetVisitorOrdersResult
static TGetVisitorOrdersResult GetVisitorOrders(
    OrderServiceProvider^ orderProvider,
    TGetVisitorOrdersRequest request
)
static member GetVisitorOrders :
        orderProvider : OrderServiceProvider *
        request : 'TGetVisitorOrdersRequest -> 'TGetVisitorOrdersResult  when 'TGetVisitorOrdersRequest : GetVisitorOrdersRequest when 'TGetVisitorOrdersResult : new() and GetVisitorOrdersResult

Parameters

orderProvider
Type: Sitecore.Commerce.Services.OrdersOrderServiceProvider
The order provider.
request
Type: TGetVisitorOrdersRequest
The request.

Type Parameters

TGetVisitorOrdersRequest
The type of the get visitor orders request.
TGetVisitorOrdersResult
The type of the get visitor orders result.

Return Value

Type: TGetVisitorOrdersResult
A TGetVisitorOrdersResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OrderServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericOrderServiceProviderExtensions Class
Sitecore.Commerce.Services.Orders.Generics Namespace


GenericOrderServiceProviderExtensions.SubmitVisitorOrder(TSubmitVisitorOrderRequest, TSubmitVisitorOrderResult) Method

GenericOrderServiceProviderExtensionsSubmitVisitorOrderTSubmitVisitorOrderRequest, TSubmitVisitorOrderResult Method
Submits the visitor order.

Namespace: Sitecore.Commerce.Services.Orders.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TSubmitVisitorOrderResult SubmitVisitorOrder<TSubmitVisitorOrderRequest, TSubmitVisitorOrderResult>(
    this OrderServiceProvider orderProvider,
    TSubmitVisitorOrderRequest request
)
where TSubmitVisitorOrderRequest : SubmitVisitorOrderRequest
where TSubmitVisitorOrderResult : new(), SubmitVisitorOrderResult

<ExtensionAttribute>
Public Shared Function SubmitVisitorOrder(Of TSubmitVisitorOrderRequest As SubmitVisitorOrderRequest, TSubmitVisitorOrderResult As {New, SubmitVisitorOrderResult}) (
    orderProvider As OrderServiceProvider,
    request As TSubmitVisitorOrderRequest
) As TSubmitVisitorOrderResult
public:
[ExtensionAttribute]
generic<typename TSubmitVisitorOrderRequest, typename TSubmitVisitorOrderResult>
where TSubmitVisitorOrderRequest : SubmitVisitorOrderRequest
where TSubmitVisitorOrderResult : gcnew(), SubmitVisitorOrderResult
static TSubmitVisitorOrderResult SubmitVisitorOrder(
    OrderServiceProvider^ orderProvider,
    TSubmitVisitorOrderRequest request
)
static member SubmitVisitorOrder :
        orderProvider : OrderServiceProvider *
        request : 'TSubmitVisitorOrderRequest -> 'TSubmitVisitorOrderResult  when 'TSubmitVisitorOrderRequest : SubmitVisitorOrderRequest when 'TSubmitVisitorOrderResult : new() and SubmitVisitorOrderResult

Parameters

orderProvider
Type: Sitecore.Commerce.Services.OrdersOrderServiceProvider
The order provider.
request
Type: TSubmitVisitorOrderRequest
The request.

Type Parameters

TSubmitVisitorOrderRequest
The type of the submit visitor order request.
TSubmitVisitorOrderResult
The type of the submit visitor order result.

Return Value

Type: TSubmitVisitorOrderResult
A TSubmitVisitorOrderResult.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OrderServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericOrderServiceProviderExtensions Class
Sitecore.Commerce.Services.Orders.Generics Namespace


GenericOrderServiceProviderExtensions.VisitorCancelOrder(TVisitorCancelOrderRequest, TVisitorCancelOrderResult) Method

GenericOrderServiceProviderExtensionsVisitorCancelOrderTVisitorCancelOrderRequest, TVisitorCancelOrderResult Method
Visitor cancels an order.

Namespace: Sitecore.Commerce.Services.Orders.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TVisitorCancelOrderResult VisitorCancelOrder<TVisitorCancelOrderRequest, TVisitorCancelOrderResult>(
    this OrderServiceProvider orderProvider,
    TVisitorCancelOrderRequest request
)
where TVisitorCancelOrderRequest : VisitorCancelOrderRequest
where TVisitorCancelOrderResult : new(), VisitorCancelOrderResult

<ExtensionAttribute>
Public Shared Function VisitorCancelOrder(Of TVisitorCancelOrderRequest As VisitorCancelOrderRequest, TVisitorCancelOrderResult As {New, VisitorCancelOrderResult}) (
    orderProvider As OrderServiceProvider,
    request As TVisitorCancelOrderRequest
) As TVisitorCancelOrderResult
public:
[ExtensionAttribute]
generic<typename TVisitorCancelOrderRequest, typename TVisitorCancelOrderResult>
where TVisitorCancelOrderRequest : VisitorCancelOrderRequest
where TVisitorCancelOrderResult : gcnew(), VisitorCancelOrderResult
static TVisitorCancelOrderResult VisitorCancelOrder(
    OrderServiceProvider^ orderProvider,
    TVisitorCancelOrderRequest request
)
static member VisitorCancelOrder :
        orderProvider : OrderServiceProvider *
        request : 'TVisitorCancelOrderRequest -> 'TVisitorCancelOrderResult  when 'TVisitorCancelOrderRequest : VisitorCancelOrderRequest when 'TVisitorCancelOrderResult : new() and VisitorCancelOrderResult

Parameters

orderProvider
Type: Sitecore.Commerce.Services.OrdersOrderServiceProvider
The order provider.
request
Type: TVisitorCancelOrderRequest
The request.

Type Parameters

TVisitorCancelOrderRequest
The type of the visitor cancel order request.
TVisitorCancelOrderResult
The type of the visitor cancel order result.

Return Value

Type: TVisitorCancelOrderResult
A TVisitorCancelOrderResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OrderServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericOrderServiceProviderExtensions Class
Sitecore.Commerce.Services.Orders.Generics Namespace


Sitecore.Commerce.Services.Prices Namespace

Sitecore.Commerce.Services.Prices Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Services.Prices"]

Classes
 | Class | Description
Public class | GetCartTotalRequest | The get cart total request.
Public class | GetCartTotalResult | The get cart total result.
Public class | GetProductBulkPricesRequest | Defines the request which allows to request prices for a set of product.
Public class | GetProductBulkPricesResult | Defines the result object for product bulk price getting operation.
Public class | GetProductPricesRequest | The get product prices request.
Public class | GetProductPricesResult | Defines the result object for the Get-Product-Price operation. This class inherits from the ServiceProviderResult class.
Public class | PriceRequest | Defines the base class of all Price requests.
Public class | PricingServiceProvider | Represents the interaction with the pricing service. Service providers are wrapper objects that ease the interaction with the implementation pipelines. The providers only implement the calling pipelines. All the business logic is implemented in the pipeline processors. The PricingServiceProvider class implements the ServiceProvider class.


GetCartTotalRequest Class

GetCartTotalRequest Class
The get cart total request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.PricesPriceRequest
Sitecore.Commerce.Services.PricesGetCartTotalRequest

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetCartTotalRequest : PriceRequest
Public Class GetCartTotalRequest
    Inherits PriceRequest
public ref class GetCartTotalRequest : public PriceRequest
type GetCartTotalRequest =
    class
        inherit PriceRequest
    end

The GetCartTotalRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetCartTotalRequest | Initializes a new instance of the GetCartTotalRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart.
Public property | CurrencyCode | Gets or sets the currency code.
Public property | DateTime | Gets or sets the date time.
Public property | Location | Gets or sets the location.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Public property | UserId | Gets or sets the user id.
Top
See Also

Reference

Sitecore.Commerce.Services.Prices Namespace


GetCartTotalRequest Constructor

GetCartTotalRequest Constructor
Initializes a new instance of the GetCartTotalRequest class

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetCartTotalRequest()
Public Sub New
public:
GetCartTotalRequest()
new : unit -> GetCartTotalRequest
See Also

Reference

GetCartTotalRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetCartTotalRequest Methods

GetCartTotalRequest Methods

The GetCartTotalRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetCartTotalRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetCartTotalRequest Properties

GetCartTotalRequest Properties

The GetCartTotalRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart.
Public property | CurrencyCode | Gets or sets the currency code.
Public property | DateTime | Gets or sets the date time.
Public property | Location | Gets or sets the location.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Public property | UserId | Gets or sets the user id.
Top
See Also

Reference

GetCartTotalRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetCartTotalRequest.Cart Property

GetCartTotalRequestCart Property
Gets or sets the cart.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Cart Cart { get; set; }
Public Property Cart As Cart
    Get
    Set
public:
property Cart^ Cart {
    Cart^ get ();
    void set (Cart^ value);
}
member Cart : Cart with get, set

Property Value

Type: Cart
See Also

Reference

GetCartTotalRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetCartTotalRequest.CurrencyCode Property

GetCartTotalRequestCurrencyCode Property
Gets or sets the currency code.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}
member CurrencyCode : string with get, set

Property Value

Type: String
The currency code.
See Also

Reference

GetCartTotalRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetCartTotalRequest.DateTime Property

GetCartTotalRequestDateTime Property
Gets or sets the date time.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DateTime DateTime { get; set; }
Public Property DateTime As DateTime
    Get
    Set
public:
property DateTime DateTime {
    DateTime get ();
    void set (DateTime value);
}
member DateTime : DateTime with get, set

Property Value

Type: DateTime
The date time.
See Also

Reference

GetCartTotalRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetCartTotalRequest.Location Property

GetCartTotalRequestLocation Property
Gets or sets the location.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
The location.
See Also

Reference

GetCartTotalRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetCartTotalRequest.ShopName Property

GetCartTotalRequestShopName Property
Gets or sets the name of the shop.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
The name of the shop.
See Also

Reference

GetCartTotalRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetCartTotalRequest.UserId Property

GetCartTotalRequestUserId Property
Gets or sets the user id.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string UserId { get; set; }
Public Property UserId As String
    Get
    Set
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}
member UserId : string with get, set

Property Value

Type: String
The user id.
See Also

Reference

GetCartTotalRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetCartTotalResult Class

GetCartTotalResult Class
The get cart total result.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.PricesGetCartTotalResult

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetCartTotalResult : ServiceProviderResult
Public Class GetCartTotalResult
    Inherits ServiceProviderResult
public ref class GetCartTotalResult : public ServiceProviderResult
type GetCartTotalResult =
    class
        inherit ServiceProviderResult
    end

The GetCartTotalResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetCartTotalResult | Initializes a new instance of the GetCartTotalResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cart | Gets or sets the cart.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Prices Namespace


GetCartTotalResult Constructor

GetCartTotalResult Constructor
Initializes a new instance of the GetCartTotalResult class

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetCartTotalResult()
Public Sub New
public:
GetCartTotalResult()
new : unit -> GetCartTotalResult
See Also

Reference

GetCartTotalResult Class
Sitecore.Commerce.Services.Prices Namespace


GetCartTotalResult Methods

GetCartTotalResult Methods

The GetCartTotalResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetCartTotalResult Class
Sitecore.Commerce.Services.Prices Namespace


GetCartTotalResult Properties

GetCartTotalResult Properties

The GetCartTotalResult type exposes the following members.

Properties
 | Name | Description
Public property | Cart | Gets or sets the cart.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetCartTotalResult Class
Sitecore.Commerce.Services.Prices Namespace


GetCartTotalResult.Cart Property

GetCartTotalResultCart Property
Gets or sets the cart.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Cart Cart { get; set; }
Public Property Cart As Cart
    Get
    Set
public:
property Cart^ Cart {
    Cart^ get ();
    void set (Cart^ value);
}
member Cart : Cart with get, set

Property Value

Type: Cart
See Also

Reference

GetCartTotalResult Class
Sitecore.Commerce.Services.Prices Namespace


GetProductBulkPricesRequest Class

GetProductBulkPricesRequest Class
Defines the request which allows to request prices for a set of product.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.PricesPriceRequest
Sitecore.Commerce.Services.PricesGetProductBulkPricesRequest

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetProductBulkPricesRequest : PriceRequest
Public Class GetProductBulkPricesRequest
    Inherits PriceRequest
public ref class GetProductBulkPricesRequest : public PriceRequest
type GetProductBulkPricesRequest =
    class
        inherit PriceRequest
    end

The GetProductBulkPricesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetProductBulkPricesRequest(IEnumerableString) | Initializes a new instance of the GetProductBulkPricesRequest class.
Public method | GetProductBulkPricesRequest(IEnumerableString, String) | Initializes a new instance of the GetProductBulkPricesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CurrencyCode | Gets or sets the currency code.
Public property | PriceType | Gets or sets the type of the price.
Public property | ProductIds | Gets or sets the product ids.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Prices Namespace


GetProductBulkPricesRequest Constructor

GetProductBulkPricesRequest Constructor
Overload List
 | Name | Description
Public method | GetProductBulkPricesRequest(IEnumerableString) | Initializes a new instance of the GetProductBulkPricesRequest class.
Public method | GetProductBulkPricesRequest(IEnumerableString, String) | Initializes a new instance of the GetProductBulkPricesRequest class.
Top
See Also

Reference

GetProductBulkPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductBulkPricesRequest Constructor (IEnumerable(String))

GetProductBulkPricesRequest Constructor (IEnumerableString)
Initializes a new instance of the GetProductBulkPricesRequest class.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetProductBulkPricesRequest(
    IEnumerable<string> productIds
)
Public Sub New (
    productIds As IEnumerable(Of String)
)
public:
GetProductBulkPricesRequest(
    IEnumerable<String^>^ productIds
)
new :
        productIds : IEnumerable<string> -> GetProductBulkPricesRequest

Parameters

productIds
Type: System.Collections.GenericIEnumerable String
The product ids.
See Also

Reference

GetProductBulkPricesRequest Class
GetProductBulkPricesRequest Overload
Sitecore.Commerce.Services.Prices Namespace


GetProductBulkPricesRequest Constructor (IEnumerable(String), String)

GetProductBulkPricesRequest Constructor (IEnumerableString, String)
Initializes a new instance of the GetProductBulkPricesRequest class.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetProductBulkPricesRequest(
    IEnumerable<string> productIds,
    string priceType
)
Public Sub New (
    productIds As IEnumerable(Of String),
    priceType As String
)
public:
GetProductBulkPricesRequest(
    IEnumerable<String^>^ productIds,
    String^ priceType
)
new :
        productIds : IEnumerable<string> *
        priceType : string -> GetProductBulkPricesRequest

Parameters

productIds
Type: System.Collections.GenericIEnumerable String
The product ids.
priceType
Type: SystemString
Type of the price.
See Also

Reference

GetProductBulkPricesRequest Class
GetProductBulkPricesRequest Overload
Sitecore.Commerce.Services.Prices Namespace


GetProductBulkPricesRequest Methods

GetProductBulkPricesRequest Methods

The GetProductBulkPricesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetProductBulkPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductBulkPricesRequest Properties

GetProductBulkPricesRequest Properties

The GetProductBulkPricesRequest type exposes the following members.

Properties
 | Name | Description
Public property | CurrencyCode | Gets or sets the currency code.
Public property | PriceType | Gets or sets the type of the price.
Public property | ProductIds | Gets or sets the product ids.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

GetProductBulkPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductBulkPricesRequest.CurrencyCode Property

GetProductBulkPricesRequestCurrencyCode Property
Gets or sets the currency code.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}
member CurrencyCode : string with get, set

Property Value

Type: String
The currency code.
See Also

Reference

GetProductBulkPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductBulkPricesRequest.PriceType Property

GetProductBulkPricesRequestPriceType Property
Gets or sets the type of the price.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string PriceType { get; protected set; }
Public Property PriceType As String
    Get
    Protected Set
public:
property String^ PriceType {
    String^ get ();
    protected: void set (String^ value);
}
member PriceType : string with get, set

Property Value

Type: String
The type of the price.
See Also

Reference

GetProductBulkPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductBulkPricesRequest.ProductIds Property

GetProductBulkPricesRequestProductIds Property
Gets or sets the product ids.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ProductIds { get; protected set; }
Public Property ProductIds As IEnumerable(Of String)
    Get
    Protected Set
public:
property IEnumerable<String^>^ ProductIds {
    IEnumerable<String^>^ get ();
    protected: void set (IEnumerable<String^>^ value);
}
member ProductIds : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The product ids.
See Also

Reference

GetProductBulkPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductBulkPricesResult Class

GetProductBulkPricesResult Class
Defines the result object for product bulk price getting operation.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.PricesGetProductBulkPricesResult

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetProductBulkPricesResult : ServiceProviderResult
Public Class GetProductBulkPricesResult
    Inherits ServiceProviderResult
public ref class GetProductBulkPricesResult : public ServiceProviderResult
type GetProductBulkPricesResult =
    class
        inherit ServiceProviderResult
    end

The GetProductBulkPricesResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetProductBulkPricesResult | Initializes a new instance of the GetProductBulkPricesResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Prices | Gets the P.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Prices Namespace


GetProductBulkPricesResult Constructor

GetProductBulkPricesResult Constructor
Initializes a new instance of the GetProductBulkPricesResult class

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetProductBulkPricesResult()
Public Sub New
public:
GetProductBulkPricesResult()
new : unit -> GetProductBulkPricesResult
See Also

Reference

GetProductBulkPricesResult Class
Sitecore.Commerce.Services.Prices Namespace


GetProductBulkPricesResult Methods

GetProductBulkPricesResult Methods

The GetProductBulkPricesResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetProductBulkPricesResult Class
Sitecore.Commerce.Services.Prices Namespace


GetProductBulkPricesResult Properties

GetProductBulkPricesResult Properties

The GetProductBulkPricesResult type exposes the following members.

Properties
 | Name | Description
Public property | Prices | Gets the P.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetProductBulkPricesResult Class
Sitecore.Commerce.Services.Prices Namespace


GetProductBulkPricesResult.Prices Property

GetProductBulkPricesResultPrices Property
Gets the P.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, Price> Prices { get; }
Public ReadOnly Property Prices As IDictionary(Of String, Price)
    Get
public:
property IDictionary<String^, Price^>^ Prices {
    IDictionary<String^, Price^>^ get ();
}
member Prices : IDictionary<string, Price> with get

Property Value

Type: IDictionary String, Price
The P.
See Also

Reference

GetProductBulkPricesResult Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesRequest Class

GetProductPricesRequest Class
The get product prices request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.PricesPriceRequest
Sitecore.Commerce.Services.PricesGetProductPricesRequest

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetProductPricesRequest : PriceRequest
Public Class GetProductPricesRequest
    Inherits PriceRequest
public ref class GetProductPricesRequest : public PriceRequest
type GetProductPricesRequest =
    class
        inherit PriceRequest
    end

The GetProductPricesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetProductPricesRequest | Initializes a new instance of the GetProductPricesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CurrencyCode | Gets or sets the currency code.
Public property | DateTime | Gets or sets the date time.
Public property | Location | Gets or sets the location.
Public property | PriceTypeIds | Gets or sets the price type ids.
Public property | ProductId | Gets or sets the product id.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | Quantity | Gets or sets the quantity.
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Public property | UserId | Gets or sets the user id.
Top
See Also

Reference

Sitecore.Commerce.Services.Prices Namespace


GetProductPricesRequest Constructor

GetProductPricesRequest Constructor
Initializes a new instance of the GetProductPricesRequest class.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetProductPricesRequest(
    string productId,
    params string[] priceTypeIds
)
Public Sub New (
    productId As String,
    ParamArray priceTypeIds As String()
)
public:
GetProductPricesRequest(
    String^ productId,
    ... array<String^>^ priceTypeIds
)
new :
        productId : string *
        priceTypeIds : string[] -> GetProductPricesRequest

Parameters

productId
Type: SystemString
The product id.
priceTypeIds
Type: SystemString
The price type ids.
See Also

Reference

GetProductPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesRequest Methods

GetProductPricesRequest Methods

The GetProductPricesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetProductPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesRequest Properties

GetProductPricesRequest Properties

The GetProductPricesRequest type exposes the following members.

Properties
 | Name | Description
Public property | CurrencyCode | Gets or sets the currency code.
Public property | DateTime | Gets or sets the date time.
Public property | Location | Gets or sets the location.
Public property | PriceTypeIds | Gets or sets the price type ids.
Public property | ProductId | Gets or sets the product id.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | Quantity | Gets or sets the quantity.
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | ShopName | Gets or sets the name of the shop.
Public property | UserId | Gets or sets the user id.
Top
See Also

Reference

GetProductPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesRequest.CurrencyCode Property

GetProductPricesRequestCurrencyCode Property
Gets or sets the currency code.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}
member CurrencyCode : string with get, set

Property Value

Type: String
The currency code.
See Also

Reference

GetProductPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesRequest.DateTime Property

GetProductPricesRequestDateTime Property
Gets or sets the date time.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DateTime DateTime { get; set; }
Public Property DateTime As DateTime
    Get
    Set
public:
property DateTime DateTime {
    DateTime get ();
    void set (DateTime value);
}
member DateTime : DateTime with get, set

Property Value

Type: DateTime
The date time.
See Also

Reference

GetProductPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesRequest.Location Property

GetProductPricesRequestLocation Property
Gets or sets the location.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
The location.
See Also

Reference

GetProductPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesRequest.PriceTypeIds Property

GetProductPricesRequestPriceTypeIds Property
Gets or sets the price type ids.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> PriceTypeIds { get; protected set; }
Public Property PriceTypeIds As IEnumerable(Of String)
    Get
    Protected Set
public:
property IEnumerable<String^>^ PriceTypeIds {
    IEnumerable<String^>^ get ();
    protected: void set (IEnumerable<String^>^ value);
}
member PriceTypeIds : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The price type ids.
See Also

Reference

GetProductPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesRequest.ProductId Property

GetProductPricesRequestProductId Property
Gets or sets the product id.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ProductId { get; protected set; }
Public Property ProductId As String
    Get
    Protected Set
public:
property String^ ProductId {
    String^ get ();
    protected: void set (String^ value);
}
member ProductId : string with get, set

Property Value

Type: String
The product id.
See Also

Reference

GetProductPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesRequest.Quantity Property

GetProductPricesRequestQuantity Property
Gets or sets the quantity.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public uint Quantity { get; set; }
Public Property Quantity As UInteger
    Get
    Set
public:
property unsigned int Quantity {
    unsigned int get ();
    void set (unsigned int value);
}
member Quantity : uint32 with get, set

Property Value

Type: UInt32
The quantity.
See Also

Reference

GetProductPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesRequest.ShopName Property

GetProductPricesRequestShopName Property
Gets or sets the name of the shop.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ShopName { get; set; }
Public Property ShopName As String
    Get
    Set
public:
property String^ ShopName {
    String^ get ();
    void set (String^ value);
}
member ShopName : string with get, set

Property Value

Type: String
The name of the shop.
See Also

Reference

GetProductPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesRequest.UserId Property

GetProductPricesRequestUserId Property
Gets or sets the user id.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string UserId { get; set; }
Public Property UserId As String
    Get
    Set
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}
member UserId : string with get, set

Property Value

Type: String
The user id.
See Also

Reference

GetProductPricesRequest Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesResult Class

GetProductPricesResult Class
Defines the result object for the Get-Product-Price operation. This class inherits from the ServiceProviderResult class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderResult
Sitecore.Commerce.Services.PricesGetProductPricesResult

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetProductPricesResult : ServiceProviderResult
Public Class GetProductPricesResult
    Inherits ServiceProviderResult
public ref class GetProductPricesResult : public ServiceProviderResult
type GetProductPricesResult =
    class
        inherit ServiceProviderResult
    end

The GetProductPricesResult type exposes the following members.

Constructors
 | Name | Description
Public method | GetProductPricesResult | Initializes a new instance of the GetProductPricesResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Prices | Gets the prices.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

Sitecore.Commerce.Services.Prices Namespace


GetProductPricesResult Constructor

GetProductPricesResult Constructor
Initializes a new instance of the GetProductPricesResult class

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetProductPricesResult()
Public Sub New
public:
GetProductPricesResult()
new : unit -> GetProductPricesResult
See Also

Reference

GetProductPricesResult Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesResult Methods

GetProductPricesResult Methods

The GetProductPricesResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetProductPricesResult Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesResult Properties

GetProductPricesResult Properties

The GetProductPricesResult type exposes the following members.

Properties
 | Name | Description
Public property | Prices | Gets the prices.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderResult.)
Public property | Success | Gets or sets a value indicating whether pipeline ServiceProviderResult succeeded. (Inherited from ServiceProviderResult.)
Public property | SystemMessages | Gets the external system messages. (Inherited from ServiceProviderResult.)
Top
See Also

Reference

GetProductPricesResult Class
Sitecore.Commerce.Services.Prices Namespace


GetProductPricesResult.Prices Property

GetProductPricesResultPrices Property
Gets the prices.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, Price> Prices { get; }
Public ReadOnly Property Prices As IDictionary(Of String, Price)
    Get
public:
property IDictionary<String^, Price^>^ Prices {
    IDictionary<String^, Price^>^ get ();
}
member Prices : IDictionary<string, Price> with get

Property Value

Type: IDictionary String, Price
The prices.
See Also

Reference

GetProductPricesResult Class
Sitecore.Commerce.Services.Prices Namespace


PriceRequest Class

PriceRequest Class
Defines the base class of all Price requests.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.PricesPriceRequest
Sitecore.Commerce.Services.PricesGetCartTotalRequest
Sitecore.Commerce.Services.PricesGetProductBulkPricesRequest
Sitecore.Commerce.Services.PricesGetProductPricesRequest

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class PriceRequest : ServiceProviderRequest
Public Class PriceRequest
    Inherits ServiceProviderRequest
public ref class PriceRequest : public ServiceProviderRequest
type PriceRequest =
    class
        inherit ServiceProviderRequest
    end

The PriceRequest type exposes the following members.

Constructors
 | Name | Description
Public method | PriceRequest | Initializes a new instance of the PriceRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Prices Namespace


PriceRequest Constructor

PriceRequest Constructor
Initializes a new instance of the PriceRequest class

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PriceRequest()
Public Sub New
public:
PriceRequest()
new : unit -> PriceRequest
See Also

Reference

PriceRequest Class
Sitecore.Commerce.Services.Prices Namespace


PriceRequest Methods

PriceRequest Methods

The PriceRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PriceRequest Class
Sitecore.Commerce.Services.Prices Namespace


PriceRequest Properties

PriceRequest Properties

The PriceRequest type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Top
See Also

Reference

PriceRequest Class
Sitecore.Commerce.Services.Prices Namespace


PricingServiceProvider Class

PricingServiceProvider Class
Represents the interaction with the pricing service. Service providers are wrapper objects that ease the interaction with the implementation pipelines. The providers only implement the calling pipelines. All the business logic is implemented in the pipeline processors. The PricingServiceProvider class implements the ServiceProvider class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProvider
Sitecore.Commerce.Services.PricesPricingServiceProvider

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class PricingServiceProvider : ServiceProvider
Public Class PricingServiceProvider
    Inherits ServiceProvider
public ref class PricingServiceProvider : public ServiceProvider
type PricingServiceProvider =
    class
        inherit ServiceProvider
    end

The PricingServiceProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PricingServiceProvider | Initializes a new instance of the PricingServiceProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCartTotal | Gets the cart total.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProductBulkPrices | Gets the price for a specific cart. It is called when Sitecore needs the price for a specific cart.
 | GetProductPrices | Gets the prices of a specific product. It is called when Sitecore needs the prices for a specific product.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RunPipelineTRequest, TResult | Runs the pipeline. (Inherited from ServiceProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetCartTotalTGetCartTotalRequest, TGetCartTotalResult | Gets the cart total. (Defined by GenericPricingServiceProviderExtensions.)
Public Extension Method | GetProductBulkPricesTGetProductBulkPricesRequest, TGetProductBulkPricesResult | Gets the product bulk prices. (Defined by GenericPricingServiceProviderExtensions.)
Public Extension Method | GetProductPricesTGetProductPricesRequest, TGetProductPricesResult | Gets the product prices. (Defined by GenericPricingServiceProviderExtensions.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from ServiceProvider.)
Top
See Also

Reference

Sitecore.Commerce.Services.Prices Namespace


PricingServiceProvider Constructor

PricingServiceProvider Constructor
Initializes a new instance of the PricingServiceProvider class

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public PricingServiceProvider()
Public Sub New
public:
PricingServiceProvider()
new : unit -> PricingServiceProvider
See Also

Reference

PricingServiceProvider Class
Sitecore.Commerce.Services.Prices Namespace


PricingServiceProvider Methods

PricingServiceProvider Methods

The PricingServiceProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCartTotal | Gets the cart total.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProductBulkPrices | Gets the price for a specific cart. It is called when Sitecore needs the price for a specific cart.
 | GetProductPrices | Gets the prices of a specific product. It is called when Sitecore needs the prices for a specific product.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RunPipelineTRequest, TResult | Runs the pipeline. (Inherited from ServiceProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetCartTotalTGetCartTotalRequest, TGetCartTotalResult | Gets the cart total. (Defined by GenericPricingServiceProviderExtensions.)
Public Extension Method | GetProductBulkPricesTGetProductBulkPricesRequest, TGetProductBulkPricesResult | Gets the product bulk prices. (Defined by GenericPricingServiceProviderExtensions.)
Public Extension Method | GetProductPricesTGetProductPricesRequest, TGetProductPricesResult | Gets the product prices. (Defined by GenericPricingServiceProviderExtensions.)
Top
See Also

Reference

PricingServiceProvider Class
Sitecore.Commerce.Services.Prices Namespace


PricingServiceProvider.GetCartTotal Method

PricingServiceProviderGetCartTotal Method
Gets the cart total.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetCartTotalResult GetCartTotal(
    GetCartTotalRequest request
)
Public Overridable Function GetCartTotal (
    request As GetCartTotalRequest
) As GetCartTotalResult
public:
virtual GetCartTotalResult^ GetCartTotal(
    GetCartTotalRequest^ request
)
abstract GetCartTotal :
        request : GetCartTotalRequest -> GetCartTotalResult
override GetCartTotal :
        request : GetCartTotalRequest -> GetCartTotalResult

Parameters

request
Type: Sitecore.Commerce.Services.PricesGetCartTotalRequest
A GetCartTotalRequest object that contains the cart, user's ID, currency code, location, shop name, and date time.

Return Value

Type: GetCartTotalResult
A group of objects that contain the prices and the messages that are received from the external commerce systems.
See Also

Reference

PricingServiceProvider Class
Sitecore.Commerce.Services.Prices Namespace


PricingServiceProvider.GetProductBulkPrices Method

PricingServiceProviderGetProductBulkPrices Method
Gets the price for a specific cart. It is called when Sitecore needs the price for a specific cart.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetProductBulkPricesResult GetProductBulkPrices(
    GetProductBulkPricesRequest request
)
Public Overridable Function GetProductBulkPrices (
    request As GetProductBulkPricesRequest
) As GetProductBulkPricesResult
public:
virtual GetProductBulkPricesResult^ GetProductBulkPrices(
    GetProductBulkPricesRequest^ request
)
abstract GetProductBulkPrices :
        request : GetProductBulkPricesRequest -> GetProductBulkPricesResult
override GetProductBulkPrices :
        request : GetProductBulkPricesRequest -> GetProductBulkPricesResult

Parameters

request
Type: Sitecore.Commerce.Services.PricesGetProductBulkPricesRequest
The request.

Return Value

Type: GetProductBulkPricesResult
The GetProductPricesResult.
See Also

Reference

PricingServiceProvider Class
Sitecore.Commerce.Services.Prices Namespace


PricingServiceProvider.GetProductPrices Method

PricingServiceProviderGetProductPrices Method
Gets the prices of a specific product. It is called when Sitecore needs the prices for a specific product.

Namespace: Sitecore.Commerce.Services.Prices
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual GetProductPricesResult GetProductPrices(
    GetProductPricesRequest request
)
Public Overridable Function GetProductPrices (
    request As GetProductPricesRequest
) As GetProductPricesResult
public:
virtual GetProductPricesResult^ GetProductPrices(
    GetProductPricesRequest^ request
)
abstract GetProductPrices :
        request : GetProductPricesRequest -> GetProductPricesResult
override GetProductPrices :
        request : GetProductPricesRequest -> GetProductPricesResult

Parameters

request
Type: Sitecore.Commerce.Services.PricesGetProductPricesRequest
A GetProductPricesRequest object that contains the user's ID, currency code, location, quantity, date time, shop name, and price type IDs.

Return Value

Type: GetProductPricesResult
A group of objects that contain the prices and the messages that are received from the external commerce systems.
Examples
You can use the GetProductPrices method to get the default price:
C#
Copy
public void GetDefaultPrice()
{
// Create a  GetProductPricesRequest object, specify the product's ID and do not specify any price types.
GetProductPricesRequest request = new GetProductPricesRequest("Audi A8L");

// Call the service provider and receive the result.
GetProductPricesResult result = this.pricingServiceProvider.GetProductPrices(request);

// Result prices contains the list price only.
result.Prices.Should().NotBeNull();
result.Prices.Count.Should().Be(1);
result.Prices.First().Value.ShouldBeEquivalentTo(this.defaultPrice);
}
You can use the GetProductPrices to get the customer price:
C#
Copy
public void GetCustomerPrice()
{
// Create a GetProductPricesRequest object, specify the product's ID and price type 'Customer'.
GetProductPricesRequest request = new GetProductPricesRequest("Audi A8L", "Customer");

// Call service provider and receive the result.
GetProductPricesResult result = this.pricingServiceProvider.GetProductPrices(request);

// Result prices contains the Customer price only.
result.Prices.Should().NotBeNull();
result.Prices.Count.Should().Be(1);
result.Prices.First().Value.ShouldBeEquivalentTo(this.customerPrice);
}
See Also

Reference

PricingServiceProvider Class
Sitecore.Commerce.Services.Prices Namespace


PricingServiceProvider Properties

PricingServiceProvider Properties

The PricingServiceProvider type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from ServiceProvider.)
Top
See Also

Reference

PricingServiceProvider Class
Sitecore.Commerce.Services.Prices Namespace


Sitecore.Commerce.Services.Prices.Generics Namespace

Sitecore.Commerce.Services.Prices.Generics Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Services.Prices.Generics"]

Classes
Class Description
Public class GenericPricingServiceProviderExtensions
Defines a set of extensions for the PricingServiceProvider class. The GenericPricingServiceProviderExtensions contains the same methods as in the PricingServiceProvider class.

The methods of this class:
  • Are generic
  • Accept a custom request that is inherited from the default request
  • Return a custom result that is inherited from the default result
  • Implement the default constructor
To use custom request or result:
  1. Define custom request and result:
    C#
    Copy
    private class MyGetCartTotalRequest : GetCartTotalRequest
{
}
private class MyGetCartTotalResult : GetCartTotalResult
{
  public string Note { get; set; }
}
  2. Create the custom processor that sets the Note property.
  3. Call the generic method:
    C#
    Copy
    MyGetCartTotalResult result = new PricingServiceProvider().GetCartTotal<MyGetCartTotalRequest, MyGetCartTotalResult>(new MyGetCartTotalRequest());
  4. The result contains the Note property that is set with a value.


GenericPricingServiceProviderExtensions Class

GenericPricingServiceProviderExtensions Class
Defines a set of extensions for the PricingServiceProvider class. The GenericPricingServiceProviderExtensions contains the same methods as in the PricingServiceProvider class.

The methods of this class:
  • Are generic
  • Accept a custom request that is inherited from the default request
  • Return a custom result that is inherited from the default result
  • Implement the default constructor
To use custom request or result:
  1. Define custom request and result:
    C#
    Copy
    private class MyGetCartTotalRequest : GetCartTotalRequest
{
}
private class MyGetCartTotalResult : GetCartTotalResult
{
  public string Note { get; set; }
}
  2. Create the custom processor that sets the Note property.
  3. Call the generic method:
    C#
    Copy
    MyGetCartTotalResult result = new PricingServiceProvider().GetCartTotal<MyGetCartTotalRequest, MyGetCartTotalResult>(new MyGetCartTotalRequest());
  4. The result contains the Note property that is set with a value.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Services.Prices.GenericsGenericPricingServiceProviderExtensions

Namespace: Sitecore.Commerce.Services.Prices.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class GenericPricingServiceProviderExtensions
<ExtensionAttribute>
Public NotInheritable Class GenericPricingServiceProviderExtensions
[ExtensionAttribute]
public ref class GenericPricingServiceProviderExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GenericPricingServiceProviderExtensions =  class end

The GenericPricingServiceProviderExtensions type exposes the following members.

Methods
Name | Description
GetCartTotalTGetCartTotalRequest, TGetCartTotalResult | Gets the cart total.
GetProductBulkPricesTGetProductBulkPricesRequest, TGetProductBulkPricesResult | Gets the product bulk prices.
GetProductPricesTGetProductPricesRequest, TGetProductPricesResult | Gets the product prices.
Top
See Also

Reference

Sitecore.Commerce.Services.Prices.Generics Namespace


GenericPricingServiceProviderExtensions Methods

GenericPricingServiceProviderExtensions Methods

The GenericPricingServiceProviderExtensions type exposes the following members.

Methods
Name | Description
GetCartTotalTGetCartTotalRequest, TGetCartTotalResult | Gets the cart total.
GetProductBulkPricesTGetProductBulkPricesRequest, TGetProductBulkPricesResult | Gets the product bulk prices.
GetProductPricesTGetProductPricesRequest, TGetProductPricesResult | Gets the product prices.
Top
See Also

Reference

GenericPricingServiceProviderExtensions Class
Sitecore.Commerce.Services.Prices.Generics Namespace


GenericPricingServiceProviderExtensions.GetCartTotal(TGetCartTotalRequest, TGetCartTotalResult) Method

GenericPricingServiceProviderExtensionsGetCartTotalTGetCartTotalRequest, TGetCartTotalResult Method
Gets the cart total.

Namespace: Sitecore.Commerce.Services.Prices.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetCartTotalResult GetCartTotal<TGetCartTotalRequest, TGetCartTotalResult>(
    this PricingServiceProvider pricingServiceProvider,
    TGetCartTotalRequest request
)
where TGetCartTotalRequest : GetCartTotalRequest
where TGetCartTotalResult : new(), GetCartTotalResult

<ExtensionAttribute>
Public Shared Function GetCartTotal(Of TGetCartTotalRequest As GetCartTotalRequest, TGetCartTotalResult As {New, GetCartTotalResult}) (
    pricingServiceProvider As PricingServiceProvider,
    request As TGetCartTotalRequest
) As TGetCartTotalResult
public:
[ExtensionAttribute]
generic<typename TGetCartTotalRequest, typename TGetCartTotalResult>
where TGetCartTotalRequest : GetCartTotalRequest
where TGetCartTotalResult : gcnew(), GetCartTotalResult
static TGetCartTotalResult GetCartTotal(
    PricingServiceProvider^ pricingServiceProvider,
    TGetCartTotalRequest request
)
static member GetCartTotal :
        pricingServiceProvider : PricingServiceProvider *
        request : 'TGetCartTotalRequest -> 'TGetCartTotalResult  when 'TGetCartTotalRequest : GetCartTotalRequest when 'TGetCartTotalResult : new() and GetCartTotalResult

Parameters

pricingServiceProvider
Type: Sitecore.Commerce.Services.PricesPricingServiceProvider
The pricing service provider
request
Type: TGetCartTotalRequest
The request

Type Parameters

TGetCartTotalRequest
The type of the GetCartTotalRequest
TGetCartTotalResult
The type of the GetCartTotalResult

Return Value

Type: TGetCartTotalResult
An object of type GetCartTotalResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PricingServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericPricingServiceProviderExtensions Class
Sitecore.Commerce.Services.Prices.Generics Namespace


GenericPricingServiceProviderExtensions.GetProductBulkPrices(TGetProductBulkPricesRequest, TGetProductBulkPricesResult) Method

GenericPricingServiceProviderExtensionsGetProductBulkPricesTGetProductBulkPricesRequest, TGetProductBulkPricesResult Method
Gets the product bulk prices.

Namespace: Sitecore.Commerce.Services.Prices.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetProductBulkPricesResult GetProductBulkPrices<TGetProductBulkPricesRequest, TGetProductBulkPricesResult>(
    this PricingServiceProvider pricingServiceProvider,
    TGetProductBulkPricesRequest request
)
where TGetProductBulkPricesRequest : GetProductBulkPricesRequest
where TGetProductBulkPricesResult : new(), GetProductBulkPricesResult

<ExtensionAttribute>
Public Shared Function GetProductBulkPrices(Of TGetProductBulkPricesRequest As GetProductBulkPricesRequest, TGetProductBulkPricesResult As {New, GetProductBulkPricesResult}) (
    pricingServiceProvider As PricingServiceProvider,
    request As TGetProductBulkPricesRequest
) As TGetProductBulkPricesResult
public:
[ExtensionAttribute]
generic<typename TGetProductBulkPricesRequest, typename TGetProductBulkPricesResult>
where TGetProductBulkPricesRequest : GetProductBulkPricesRequest
where TGetProductBulkPricesResult : gcnew(), GetProductBulkPricesResult
static TGetProductBulkPricesResult GetProductBulkPrices(
    PricingServiceProvider^ pricingServiceProvider,
    TGetProductBulkPricesRequest request
)
static member GetProductBulkPrices :
        pricingServiceProvider : PricingServiceProvider *
        request : 'TGetProductBulkPricesRequest -> 'TGetProductBulkPricesResult  when 'TGetProductBulkPricesRequest : GetProductBulkPricesRequest when 'TGetProductBulkPricesResult : new() and GetProductBulkPricesResult

Parameters

pricingServiceProvider
Type: Sitecore.Commerce.Services.PricesPricingServiceProvider
The pricing service provider
request
Type: TGetProductBulkPricesRequest
The request

Type Parameters

TGetProductBulkPricesRequest
The type of the GetProductBulkPricesRequest
TGetProductBulkPricesResult
The type of the GetProductBulkPricesResult

Return Value

Type: TGetProductBulkPricesResult
An object of type GetProductBulkPricesResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PricingServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericPricingServiceProviderExtensions Class
Sitecore.Commerce.Services.Prices.Generics Namespace


GenericPricingServiceProviderExtensions.GetProductPrices(TGetProductPricesRequest, TGetProductPricesResult) Method

GenericPricingServiceProviderExtensionsGetProductPricesTGetProductPricesRequest, TGetProductPricesResult Method
Gets the product prices.

Namespace: Sitecore.Commerce.Services.Prices.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TGetProductPricesResult GetProductPrices<TGetProductPricesRequest, TGetProductPricesResult>(
    this PricingServiceProvider pricingServiceProvider,
    TGetProductPricesRequest request
)
where TGetProductPricesRequest : GetProductPricesRequest
where TGetProductPricesResult : new(), GetProductPricesResult

<ExtensionAttribute>
Public Shared Function GetProductPrices(Of TGetProductPricesRequest As GetProductPricesRequest, TGetProductPricesResult As {New, GetProductPricesResult}) (
    pricingServiceProvider As PricingServiceProvider,
    request As TGetProductPricesRequest
) As TGetProductPricesResult
public:
[ExtensionAttribute]
generic<typename TGetProductPricesRequest, typename TGetProductPricesResult>
where TGetProductPricesRequest : GetProductPricesRequest
where TGetProductPricesResult : gcnew(), GetProductPricesResult
static TGetProductPricesResult GetProductPrices(
    PricingServiceProvider^ pricingServiceProvider,
    TGetProductPricesRequest request
)
static member GetProductPrices :
        pricingServiceProvider : PricingServiceProvider *
        request : 'TGetProductPricesRequest -> 'TGetProductPricesResult  when 'TGetProductPricesRequest : GetProductPricesRequest when 'TGetProductPricesResult : new() and GetProductPricesResult

Parameters

pricingServiceProvider
Type: Sitecore.Commerce.Services.PricesPricingServiceProvider
The pricing service provider
request
Type: TGetProductPricesRequest
The request

Type Parameters

TGetProductPricesRequest
The type of the GetProductPricesRequest
TGetProductPricesResult
The type of the GetProductPricesResult

Return Value

Type: TGetProductPricesResult
An object of type GetProductPricesResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PricingServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericPricingServiceProviderExtensions Class
Sitecore.Commerce.Services.Prices.Generics Namespace


Sitecore.Commerce.Services.Products Namespace

Sitecore.Commerce.Services.Products Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Services.Products"]

Classes
 | Class | Description
Public class | GetExternalCommerceSystemProductListRequest | Defines the request used to get product list from external commerce system.
Public class | GetSitecoreProductListRequest | Defines the request used to get sitecore product list.
Public class | ProductSynchronizationProvider | Defines the provider that is used to perform any product or artifact synchronization activity between Sitecore CMS and the external commerce system. It runs the corresponding pipelines that delegate the task to the processors. The ProductSynchronizationProvider class inherits from the ServiceProvider class.
Public class | ProductSynchronizationRequest | The product id synchronization request.
Public class | SynchronizationContext | Defines the synchronization context. This class Utilizes some of the Sitecore CMS facilities to speed up the synchronization of the artifacts between Sitecore CMS and the external commerce system. You can use this class to disable proxies, the event handling, and database cache. You can also use it to update all items in the content tree at once.
Public class | SynchronizationRequest | Defines the base class for all types of requests to the Product Synchronization Provider. These requests manipulate all types of artifacts.
Public class | SynchronizeArtifactsRequest | The synchronize artifacts request.
Public class | SynchronizeClassificationSpecificationsRequest | The synchronize classifications specifications request.
Public class | SynchronizeClassificationsRequest | Defines the request used to synchronize product classifications.
Public class | SynchronizeDivisionsRequest | The synchronize divisions request.
Public class | SynchronizeGlobalSpecificationsRequest | The synchronize global specification request.
Public class | SynchronizeManufacturersRequest | Defines the request used to synchronize product manufacturer collection.
Public class | SynchronizeProductClassificationsRequest | The synchronize product classifications request.
Public class | SynchronizeProductClassificationsSpecificationsRequest | The synchronize product classifications specifications request.
Public class | SynchronizeProductDivisionsRequest | The synchronize product divisions request.
Public class | SynchronizeProductEntityRequest | The synchronize product item request.
Public class | SynchronizeProductGlobalSpecificationsRequest | The synchronize product global specifications request.
Public class | SynchronizeProductListRequest | Defines the request used to synchronize product lists.
Public class | SynchronizeProductManufacturersRequest | The synchronize product manufacturers request.
Public class | SynchronizeProductRelationsRequest | The synchronize product relations request.
Public class | SynchronizeProductRequest | Defines the request used to synchronize products.
Public class | SynchronizeProductResourcesRequest | The synchronize product resources request.
Public class | SynchronizeProductSpecificationsRequest | The synchronize product specifications request.
Public class | SynchronizeProductsRequest | Defines the request used to synchronize product collections.
Public class | SynchronizeProductTypeSpecificationsRequest | The synchronize product type specifications request.
Public class | SynchronizeProductTypesRequest | The synchronize product types request.
Public class | SynchronizeResourcesRequest | The synchronize resources request.
Public class | SynchronizeSpecificationsRequest | The synchronize specifications request.
Public class | SynchronizeTypeDefaultValuesRequest | The synchronize type default values request.
Public class | SynchronizeTypeSpecificationsRequest | The synchronize type specifications request.
Public class | SynchronizeTypesRequest | The synchronize types request.


GetExternalCommerceSystemProductListRequest Class

GetExternalCommerceSystemProductListRequest Class
Defines the request used to get product list from external commerce system.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsGetExternalCommerceSystemProductListRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetExternalCommerceSystemProductListRequest : SynchronizationRequest
Public Class GetExternalCommerceSystemProductListRequest
    Inherits SynchronizationRequest
public ref class GetExternalCommerceSystemProductListRequest : public SynchronizationRequest
type GetExternalCommerceSystemProductListRequest =
    class
        inherit SynchronizationRequest
    end

The GetExternalCommerceSystemProductListRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetExternalCommerceSystemProductListRequest | Initializes a new instance of the GetExternalCommerceSystemProductListRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


GetExternalCommerceSystemProductListRequest Constructor

GetExternalCommerceSystemProductListRequest Constructor
Initializes a new instance of the GetExternalCommerceSystemProductListRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetExternalCommerceSystemProductListRequest()
Public Sub New
public:
GetExternalCommerceSystemProductListRequest()
new : unit -> GetExternalCommerceSystemProductListRequest
See Also

Reference

GetExternalCommerceSystemProductListRequest Class
Sitecore.Commerce.Services.Products Namespace


GetExternalCommerceSystemProductListRequest Methods

GetExternalCommerceSystemProductListRequest Methods

The GetExternalCommerceSystemProductListRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetExternalCommerceSystemProductListRequest Class
Sitecore.Commerce.Services.Products Namespace


GetExternalCommerceSystemProductListRequest Properties

GetExternalCommerceSystemProductListRequest Properties

The GetExternalCommerceSystemProductListRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

GetExternalCommerceSystemProductListRequest Class
Sitecore.Commerce.Services.Products Namespace


GetSitecoreProductListRequest Class

GetSitecoreProductListRequest Class
Defines the request used to get sitecore product list.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsGetSitecoreProductListRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class GetSitecoreProductListRequest : SynchronizationRequest
Public Class GetSitecoreProductListRequest
    Inherits SynchronizationRequest
public ref class GetSitecoreProductListRequest : public SynchronizationRequest
type GetSitecoreProductListRequest =
    class
        inherit SynchronizationRequest
    end

The GetSitecoreProductListRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetSitecoreProductListRequest | Initializes a new instance of the GetSitecoreProductListRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


GetSitecoreProductListRequest Constructor

GetSitecoreProductListRequest Constructor
Initializes a new instance of the GetSitecoreProductListRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public GetSitecoreProductListRequest()
Public Sub New
public:
GetSitecoreProductListRequest()
new : unit -> GetSitecoreProductListRequest
See Also

Reference

GetSitecoreProductListRequest Class
Sitecore.Commerce.Services.Products Namespace


GetSitecoreProductListRequest Methods

GetSitecoreProductListRequest Methods

The GetSitecoreProductListRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetSitecoreProductListRequest Class
Sitecore.Commerce.Services.Products Namespace


GetSitecoreProductListRequest Properties

GetSitecoreProductListRequest Properties

The GetSitecoreProductListRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

GetSitecoreProductListRequest Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider Class

ProductSynchronizationProvider Class
Defines the provider that is used to perform any product or artifact synchronization activity between Sitecore CMS and the external commerce system. It runs the corresponding pipelines that delegate the task to the processors. The ProductSynchronizationProvider class inherits from the ServiceProvider class.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProvider
Sitecore.Commerce.Services.ProductsProductSynchronizationProvider

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ProductSynchronizationProvider : ServiceProvider
Public Class ProductSynchronizationProvider
    Inherits ServiceProvider
public ref class ProductSynchronizationProvider : public ServiceProvider
type ProductSynchronizationProvider =
    class
        inherit ServiceProvider
    end

The ProductSynchronizationProvider type exposes the following members.

Constructors
 | Name | Description
Public method | ProductSynchronizationProvider | Initializes a new instance of the ProductSynchronizationProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetExternalCommerceSystemProductList | Gets the external commerce system product list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSitecoreProductList | Gets the product list from Sitecore CMS.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RunPipelineTRequest, TResult | Runs the pipeline. (Overrides ServiceProviderRunPipelineTRequest, TResult(String, TRequest).)
Public method | SynchronizeArtifacts | Synchronizes the artifacts.
Public method | SynchronizeClassifications | Synchronizes the classification.
Public method | SynchronizeClassificationSpecifications | Synchronizes the classifications specifications.
Public method | SynchronizeDivisions | Synchronizes the divisions.
Public method | SynchronizeGlobalSpecifications | Synchronizes the global specifications.
Public method | SynchronizeManufacturers | Synchronizes the manufacturers.
Public method | SynchronizeProduct | Synchronizes the product.
Public method | SynchronizeProductClassifications | Synchronizes the classification.
Public method | SynchronizeProductClassificationsSpecifications | Synchronizes the product classifications specifications.
Public method | SynchronizeProductDivisions | Synchronizes the product divisions.
Public method | SynchronizeProductEntity | Synchronizes the product item.
Public method | SynchronizeProductGlobalSpecifications | Synchronizes the product global specifications.
Public method | SynchronizeProductList | Synchronizes the product list.
Public method | SynchronizeProductManufacturers | Synchronizes the product manufacturers.
Public method | SynchronizeProductRelations | Synchronizes the product relations.
Public method | SynchronizeProductResources | Synchronizes the product resources.
Public method | SynchronizeProducts | Synchronizes the products.
Public method | SynchronizeProductSpecifications | Synchronizes the product global specifications.
Public method | SynchronizeProductTypes | Synchronizes the product types.
Public method | SynchronizeProductTypeSpecifications | Synchronizes the product type specifications.
Public method | SynchronizeResources | Synchronizes the resources.
Public method | SynchronizeSpecifications | Synchronizes the specifications.
Public method | SynchronizeTypeDefaultValues | Synchronizes the type default values.
Public method | SynchronizeTypes | Synchronizes the types.
Public method | SynchronizeTypeSpecifications | Synchronizes the type specifications.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetExternalCommerceSystemProductListTSynchronizationRequest, TServiceProviderResult | Gets the product list of the external commerce system . (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | GetSitecoreProductListTSynchronizationRequest, TServiceProviderResult | Gets Sitecore product list. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeArtifactsTSynchronizationRequest, TServiceProviderResult | Synchronizes the artifacts. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeClassificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the classifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeClassificationSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the classification specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeDivisionsTSynchronizationRequest, TServiceProviderResult | Synchronizes the divisions. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeGlobalSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the global specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeManufacturersTSynchronizationRequest, TServiceProviderResult | Synchronizes the manufacturers. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductClassificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product classifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductClassificationsSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product classifications specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductDivisionsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product divisions. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductEntityTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product item. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductGlobalSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product global specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductListTSynchronizeProductListRequest, TServiceProviderResult | Synchronizes the product list. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductManufacturersTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product manufacturers. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductRelationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product relations. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductResourcesTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product resources. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductsTSynchronizationRequest, TServiceProviderResult | Synchronizes the products. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductTypesTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product types. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductTypeSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product type specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeResourcesTSynchronizationRequest, TServiceProviderResult | Synchronizes the resources. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeTypeDefaultValuesTSynchronizationRequest, TServiceProviderResult | Synchronizes the type default values. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeTypesTSynchronizationRequest, TServiceProviderResult | Synchronizes the types. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeTypeSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the type specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Top
Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from ServiceProvider.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider Constructor

ProductSynchronizationProvider Constructor
Initializes a new instance of the ProductSynchronizationProvider class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductSynchronizationProvider()
Public Sub New
public:
ProductSynchronizationProvider()
new : unit -> ProductSynchronizationProvider
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider Methods

ProductSynchronizationProvider Methods

The ProductSynchronizationProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetExternalCommerceSystemProductList | Gets the external commerce system product list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSitecoreProductList | Gets the product list from Sitecore CMS.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RunPipelineTRequest, TResult | Runs the pipeline. (Overrides ServiceProviderRunPipelineTRequest, TResult(String, TRequest).)
Public method | SynchronizeArtifacts | Synchronizes the artifacts.
Public method | SynchronizeClassifications | Synchronizes the classification.
Public method | SynchronizeClassificationSpecifications | Synchronizes the classifications specifications.
Public method | SynchronizeDivisions | Synchronizes the divisions.
Public method | SynchronizeGlobalSpecifications | Synchronizes the global specifications.
Public method | SynchronizeManufacturers | Synchronizes the manufacturers.
Public method | SynchronizeProduct | Synchronizes the product.
Public method | SynchronizeProductClassifications | Synchronizes the classification.
Public method | SynchronizeProductClassificationsSpecifications | Synchronizes the product classifications specifications.
Public method | SynchronizeProductDivisions | Synchronizes the product divisions.
Public method | SynchronizeProductEntity | Synchronizes the product item.
Public method | SynchronizeProductGlobalSpecifications | Synchronizes the product global specifications.
Public method | SynchronizeProductList | Synchronizes the product list.
Public method | SynchronizeProductManufacturers | Synchronizes the product manufacturers.
Public method | SynchronizeProductRelations | Synchronizes the product relations.
Public method | SynchronizeProductResources | Synchronizes the product resources.
Public method | SynchronizeProducts | Synchronizes the products.
Public method | SynchronizeProductSpecifications | Synchronizes the product global specifications.
Public method | SynchronizeProductTypes | Synchronizes the product types.
Public method | SynchronizeProductTypeSpecifications | Synchronizes the product type specifications.
Public method | SynchronizeResources | Synchronizes the resources.
Public method | SynchronizeSpecifications | Synchronizes the specifications.
Public method | SynchronizeTypeDefaultValues | Synchronizes the type default values.
Public method | SynchronizeTypes | Synchronizes the types.
Public method | SynchronizeTypeSpecifications | Synchronizes the type specifications.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetExternalCommerceSystemProductListTSynchronizationRequest, TServiceProviderResult | Gets the product list of the external commerce system . (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | GetSitecoreProductListTSynchronizationRequest, TServiceProviderResult | Gets Sitecore product list. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeArtifactsTSynchronizationRequest, TServiceProviderResult | Synchronizes the artifacts. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeClassificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the classifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeClassificationSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the classification specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeDivisionsTSynchronizationRequest, TServiceProviderResult | Synchronizes the divisions. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeGlobalSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the global specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeManufacturersTSynchronizationRequest, TServiceProviderResult | Synchronizes the manufacturers. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductClassificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product classifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductClassificationsSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product classifications specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductDivisionsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product divisions. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductEntityTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product item. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductGlobalSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product global specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductListTSynchronizeProductListRequest, TServiceProviderResult | Synchronizes the product list. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductManufacturersTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product manufacturers. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductRelationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product relations. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductResourcesTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product resources. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductsTSynchronizationRequest, TServiceProviderResult | Synchronizes the products. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductTypesTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product types. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeProductTypeSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product type specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeResourcesTSynchronizationRequest, TServiceProviderResult | Synchronizes the resources. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeTypeDefaultValuesTSynchronizationRequest, TServiceProviderResult | Synchronizes the type default values. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeTypesTSynchronizationRequest, TServiceProviderResult | Synchronizes the types. (Defined by GenericProductSynchronizationProviderExtensions.)
Public Extension Method | SynchronizeTypeSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the type specifications. (Defined by GenericProductSynchronizationProviderExtensions.)
Top
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.GetExternalCommerceSystemProductList Method

ProductSynchronizationProviderGetExternalCommerceSystemProductList Method
Gets the external commerce system product list.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult GetExternalCommerceSystemProductList(
    SynchronizationRequest request
)
Public Overridable Function GetExternalCommerceSystemProductList (
    request As SynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ GetExternalCommerceSystemProductList(
    SynchronizationRequest^ request
)
abstract GetExternalCommerceSystemProductList :
        request : SynchronizationRequest -> ServiceProviderResult
override GetExternalCommerceSystemProductList :
        request : SynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.GetSitecoreProductList Method

ProductSynchronizationProviderGetSitecoreProductList Method
Gets the product list from Sitecore CMS.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult GetSitecoreProductList(
    SynchronizationRequest request
)
Public Overridable Function GetSitecoreProductList (
    request As SynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ GetSitecoreProductList(
    SynchronizationRequest^ request
)
abstract GetSitecoreProductList :
        request : SynchronizationRequest -> ServiceProviderResult
override GetSitecoreProductList :
        request : SynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.RunPipeline(TRequest, TResult) Method

ProductSynchronizationProviderRunPipelineTRequest, TResult Method
Runs the pipeline.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public override TResult RunPipeline<TRequest, TResult>(
    string pipelineName,
    TRequest request
)
where TRequest : ServiceProviderRequest
where TResult : new(), ServiceProviderResult

Public Overrides Function RunPipeline(Of TRequest As ServiceProviderRequest, TResult As {New, ServiceProviderResult}) (
    pipelineName As String,
    request As TRequest
) As TResult
public:
generic<typename TRequest, typename TResult>
where TRequest : ServiceProviderRequest
where TResult : gcnew(), ServiceProviderResult
virtual TResult RunPipeline(
    String^ pipelineName,
    TRequest request
) override
abstract RunPipeline :
        pipelineName : string *
        request : 'TRequest -> 'TResult  when 'TRequest : ServiceProviderRequest when 'TResult : new() and ServiceProviderResult
override RunPipeline :
        pipelineName : string *
        request : 'TRequest -> 'TResult  when 'TRequest : ServiceProviderRequest when 'TResult : new() and ServiceProviderResult

Parameters

pipelineName
Type: SystemString
Name of the pipeline
request
Type: TRequest
The request

Type Parameters

TRequest
The type of the request
TResult
The type of the result

Return Value

Type: TResult
The result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeArtifacts Method

ProductSynchronizationProviderSynchronizeArtifacts Method
Synchronizes the artifacts.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeArtifacts(
    SynchronizationRequest request
)
Public Overridable Function SynchronizeArtifacts (
    request As SynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeArtifacts(
    SynchronizationRequest^ request
)
abstract SynchronizeArtifacts :
        request : SynchronizationRequest -> ServiceProviderResult
override SynchronizeArtifacts :
        request : SynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeClassifications Method

ProductSynchronizationProviderSynchronizeClassifications Method
Synchronizes the classification.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeClassifications(
    SynchronizationRequest request
)
Public Overridable Function SynchronizeClassifications (
    request As SynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeClassifications(
    SynchronizationRequest^ request
)
abstract SynchronizeClassifications :
        request : SynchronizationRequest -> ServiceProviderResult
override SynchronizeClassifications :
        request : SynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeClassificationSpecifications Method

ProductSynchronizationProviderSynchronizeClassificationSpecifications Method
Synchronizes the classifications specifications.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeClassificationSpecifications(
    SynchronizationRequest request
)
Public Overridable Function SynchronizeClassificationSpecifications (
    request As SynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeClassificationSpecifications(
    SynchronizationRequest^ request
)
abstract SynchronizeClassificationSpecifications :
        request : SynchronizationRequest -> ServiceProviderResult
override SynchronizeClassificationSpecifications :
        request : SynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
The service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeDivisions Method

ProductSynchronizationProviderSynchronizeDivisions Method
Synchronizes the divisions.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeDivisions(
    SynchronizationRequest request
)
Public Overridable Function SynchronizeDivisions (
    request As SynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeDivisions(
    SynchronizationRequest^ request
)
abstract SynchronizeDivisions :
        request : SynchronizationRequest -> ServiceProviderResult
override SynchronizeDivisions :
        request : SynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeGlobalSpecifications Method

ProductSynchronizationProviderSynchronizeGlobalSpecifications Method
Synchronizes the global specifications.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeGlobalSpecifications(
    SynchronizationRequest request
)
Public Overridable Function SynchronizeGlobalSpecifications (
    request As SynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeGlobalSpecifications(
    SynchronizationRequest^ request
)
abstract SynchronizeGlobalSpecifications :
        request : SynchronizationRequest -> ServiceProviderResult
override SynchronizeGlobalSpecifications :
        request : SynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
The service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeManufacturers Method

ProductSynchronizationProviderSynchronizeManufacturers Method
Synchronizes the manufacturers.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeManufacturers(
    SynchronizationRequest request
)
Public Overridable Function SynchronizeManufacturers (
    request As SynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeManufacturers(
    SynchronizationRequest^ request
)
abstract SynchronizeManufacturers :
        request : SynchronizationRequest -> ServiceProviderResult
override SynchronizeManufacturers :
        request : SynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeProduct Method

ProductSynchronizationProviderSynchronizeProduct Method
Synchronizes the product.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeProduct(
    ProductSynchronizationRequest request
)
Public Overridable Function SynchronizeProduct (
    request As ProductSynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeProduct(
    ProductSynchronizationRequest^ request
)
abstract SynchronizeProduct :
        request : ProductSynchronizationRequest -> ServiceProviderResult
override SynchronizeProduct :
        request : ProductSynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeProductClassifications Method

ProductSynchronizationProviderSynchronizeProductClassifications Method
Synchronizes the classification.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeProductClassifications(
    ProductSynchronizationRequest request
)
Public Overridable Function SynchronizeProductClassifications (
    request As ProductSynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeProductClassifications(
    ProductSynchronizationRequest^ request
)
abstract SynchronizeProductClassifications :
        request : ProductSynchronizationRequest -> ServiceProviderResult
override SynchronizeProductClassifications :
        request : ProductSynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeProductClassificationsSpecifications Method

ProductSynchronizationProviderSynchronizeProductClassificationsSpecifications Method
Synchronizes the product classifications specifications.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeProductClassificationsSpecifications(
    ProductSynchronizationRequest request
)
Public Overridable Function SynchronizeProductClassificationsSpecifications (
    request As ProductSynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeProductClassificationsSpecifications(
    ProductSynchronizationRequest^ request
)
abstract SynchronizeProductClassificationsSpecifications :
        request : ProductSynchronizationRequest -> ServiceProviderResult
override SynchronizeProductClassificationsSpecifications :
        request : ProductSynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
The service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeProductDivisions Method

ProductSynchronizationProviderSynchronizeProductDivisions Method
Synchronizes the product divisions.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeProductDivisions(
    ProductSynchronizationRequest request
)
Public Overridable Function SynchronizeProductDivisions (
    request As ProductSynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeProductDivisions(
    ProductSynchronizationRequest^ request
)
abstract SynchronizeProductDivisions :
        request : ProductSynchronizationRequest -> ServiceProviderResult
override SynchronizeProductDivisions :
        request : ProductSynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Synchronize product divisions result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeProductEntity Method

ProductSynchronizationProviderSynchronizeProductEntity Method
Synchronizes the product item.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeProductEntity(
    ProductSynchronizationRequest request
)
Public Overridable Function SynchronizeProductEntity (
    request As ProductSynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeProductEntity(
    ProductSynchronizationRequest^ request
)
abstract SynchronizeProductEntity :
        request : ProductSynchronizationRequest -> ServiceProviderResult
override SynchronizeProductEntity :
        request : ProductSynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeProductGlobalSpecifications Method

ProductSynchronizationProviderSynchronizeProductGlobalSpecifications Method
Synchronizes the product global specifications.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeProductGlobalSpecifications(
    ProductSynchronizationRequest request
)
Public Overridable Function SynchronizeProductGlobalSpecifications (
    request As ProductSynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeProductGlobalSpecifications(
    ProductSynchronizationRequest^ request
)
abstract SynchronizeProductGlobalSpecifications :
        request : ProductSynchronizationRequest -> ServiceProviderResult
override SynchronizeProductGlobalSpecifications :
        request : ProductSynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
The service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeProductList Method

ProductSynchronizationProviderSynchronizeProductList Method
Synchronizes the product list.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeProductList(
    SynchronizeProductListRequest request
)
Public Overridable Function SynchronizeProductList (
    request As SynchronizeProductListRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeProductList(
    SynchronizeProductListRequest^ request
)
abstract SynchronizeProductList :
        request : SynchronizeProductListRequest -> ServiceProviderResult
override SynchronizeProductList :
        request : SynchronizeProductListRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizeProductListRequest
The request

Return Value

Type: ServiceProviderResult
Service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeProductManufacturers Method

ProductSynchronizationProviderSynchronizeProductManufacturers Method
Synchronizes the product manufacturers.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeProductManufacturers(
    ProductSynchronizationRequest request
)
Public Overridable Function SynchronizeProductManufacturers (
    request As ProductSynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeProductManufacturers(
    ProductSynchronizationRequest^ request
)
abstract SynchronizeProductManufacturers :
        request : ProductSynchronizationRequest -> ServiceProviderResult
override SynchronizeProductManufacturers :
        request : ProductSynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Synchronize product manufacturers result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeProductRelations Method

ProductSynchronizationProviderSynchronizeProductRelations Method
Synchronizes the product relations.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeProductRelations(
    ProductSynchronizationRequest request
)
Public Overridable Function SynchronizeProductRelations (
    request As ProductSynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeProductRelations(
    ProductSynchronizationRequest^ request
)
abstract SynchronizeProductRelations :
        request : ProductSynchronizationRequest -> ServiceProviderResult
override SynchronizeProductRelations :
        request : ProductSynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeProductResources Method

ProductSynchronizationProviderSynchronizeProductResources Method
Synchronizes the product resources.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeProductResources(
    ProductSynchronizationRequest request
)
Public Overridable Function SynchronizeProductResources (
    request As ProductSynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeProductResources(
    ProductSynchronizationRequest^ request
)
abstract SynchronizeProductResources :
        request : ProductSynchronizationRequest -> ServiceProviderResult
override SynchronizeProductResources :
        request : ProductSynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
The service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeProducts Method

ProductSynchronizationProviderSynchronizeProducts Method
Synchronizes the products.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeProducts(
    SynchronizationRequest request
)
Public Overridable Function SynchronizeProducts (
    request As SynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeProducts(
    SynchronizationRequest^ request
)
abstract SynchronizeProducts :
        request : SynchronizationRequest -> ServiceProviderResult
override SynchronizeProducts :
        request : SynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeProductSpecifications Method

ProductSynchronizationProviderSynchronizeProductSpecifications Method
Synchronizes the product global specifications.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeProductSpecifications(
    ProductSynchronizationRequest request
)
Public Overridable Function SynchronizeProductSpecifications (
    request As ProductSynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeProductSpecifications(
    ProductSynchronizationRequest^ request
)
abstract SynchronizeProductSpecifications :
        request : ProductSynchronizationRequest -> ServiceProviderResult
override SynchronizeProductSpecifications :
        request : ProductSynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
The service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeProductTypes Method

ProductSynchronizationProviderSynchronizeProductTypes Method
Synchronizes the product types.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeProductTypes(
    ProductSynchronizationRequest request
)
Public Overridable Function SynchronizeProductTypes (
    request As ProductSynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeProductTypes(
    ProductSynchronizationRequest^ request
)
abstract SynchronizeProductTypes :
        request : ProductSynchronizationRequest -> ServiceProviderResult
override SynchronizeProductTypes :
        request : ProductSynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Synchronize product types result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeProductTypeSpecifications Method

ProductSynchronizationProviderSynchronizeProductTypeSpecifications Method
Synchronizes the product type specifications.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeProductTypeSpecifications(
    ProductSynchronizationRequest request
)
Public Overridable Function SynchronizeProductTypeSpecifications (
    request As ProductSynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeProductTypeSpecifications(
    ProductSynchronizationRequest^ request
)
abstract SynchronizeProductTypeSpecifications :
        request : ProductSynchronizationRequest -> ServiceProviderResult
override SynchronizeProductTypeSpecifications :
        request : ProductSynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
The service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeResources Method

ProductSynchronizationProviderSynchronizeResources Method
Synchronizes the resources.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeResources(
    SynchronizationRequest request
)
Public Overridable Function SynchronizeResources (
    request As SynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeResources(
    SynchronizationRequest^ request
)
abstract SynchronizeResources :
        request : SynchronizationRequest -> ServiceProviderResult
override SynchronizeResources :
        request : SynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
The service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeSpecifications Method

ProductSynchronizationProviderSynchronizeSpecifications Method
Synchronizes the specifications.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeSpecifications(
    SynchronizationRequest request
)
Public Overridable Function SynchronizeSpecifications (
    request As SynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeSpecifications(
    SynchronizationRequest^ request
)
abstract SynchronizeSpecifications :
        request : SynchronizationRequest -> ServiceProviderResult
override SynchronizeSpecifications :
        request : SynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeTypeDefaultValues Method

ProductSynchronizationProviderSynchronizeTypeDefaultValues Method
Synchronizes the type default values.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeTypeDefaultValues(
    SynchronizationRequest request
)
Public Overridable Function SynchronizeTypeDefaultValues (
    request As SynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeTypeDefaultValues(
    SynchronizationRequest^ request
)
abstract SynchronizeTypeDefaultValues :
        request : SynchronizationRequest -> ServiceProviderResult
override SynchronizeTypeDefaultValues :
        request : SynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
The service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeTypes Method

ProductSynchronizationProviderSynchronizeTypes Method
Synchronizes the types.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeTypes(
    SynchronizationRequest request
)
Public Overridable Function SynchronizeTypes (
    request As SynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeTypes(
    SynchronizationRequest^ request
)
abstract SynchronizeTypes :
        request : SynchronizationRequest -> ServiceProviderResult
override SynchronizeTypes :
        request : SynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
Service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider.SynchronizeTypeSpecifications Method

ProductSynchronizationProviderSynchronizeTypeSpecifications Method
Synchronizes the type specifications.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual ServiceProviderResult SynchronizeTypeSpecifications(
    SynchronizationRequest request
)
Public Overridable Function SynchronizeTypeSpecifications (
    request As SynchronizationRequest
) As ServiceProviderResult
public:
virtual ServiceProviderResult^ SynchronizeTypeSpecifications(
    SynchronizationRequest^ request
)
abstract SynchronizeTypeSpecifications :
        request : SynchronizationRequest -> ServiceProviderResult
override SynchronizeTypeSpecifications :
        request : SynchronizationRequest -> ServiceProviderResult

Parameters

request
Type: Sitecore.Commerce.Services.ProductsSynchronizationRequest
The request

Return Value

Type: ServiceProviderResult
The service provider result
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationProvider Properties

ProductSynchronizationProvider Properties

The ProductSynchronizationProvider type exposes the following members.

Properties
 | Name | Description
Public property | PipelineService | Gets or sets the pipeline service. (Inherited from ServiceProvider.)
Top
See Also

Reference

ProductSynchronizationProvider Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationRequest Class

ProductSynchronizationRequest Class
The product id synchronization request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
More...

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class ProductSynchronizationRequest : SynchronizationRequest
Public Class ProductSynchronizationRequest
    Inherits SynchronizationRequest
public ref class ProductSynchronizationRequest : public SynchronizationRequest
type ProductSynchronizationRequest =
    class
        inherit SynchronizationRequest
    end

The ProductSynchronizationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ProductSynchronizationRequest | Initializes a new instance of the ProductSynchronizationRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket].
Public property | ProductId | Gets or sets the external id.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductClassificationsRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductClassificationsSpecificationsRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductDivisionsRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductEntityRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductGlobalSpecificationsRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductManufacturersRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductRelationsRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductResourcesRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductSpecificationsRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductTypeSpecificationsRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductTypesRequest


ProductSynchronizationRequest Constructor

ProductSynchronizationRequest Constructor
Initializes a new instance of the ProductSynchronizationRequest class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProductSynchronizationRequest(
    string productId
)
Public Sub New (
    productId As String
)
public:
ProductSynchronizationRequest(
    String^ productId
)
new :
        productId : string -> ProductSynchronizationRequest

Parameters

productId
Type: SystemString
The external product id.
See Also

Reference

ProductSynchronizationRequest Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationRequest Methods

ProductSynchronizationRequest Methods

The ProductSynchronizationRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductSynchronizationRequest Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationRequest Properties

ProductSynchronizationRequest Properties

The ProductSynchronizationRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket].
Public property | ProductId | Gets or sets the external id.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

ProductSynchronizationRequest Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationRequest.MoveToBucket Property

ProductSynchronizationRequestMoveToBucket Property
Gets or sets a value indicating whether [move to bucket].

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public bool MoveToBucket { get; set; }
Public Property MoveToBucket As Boolean
    Get
    Set
public:
property bool MoveToBucket {
    bool get ();
    void set (bool value);
}
member MoveToBucket : bool with get, set

Property Value

Type: Boolean
true if [move to bucket]; otherwise, false.
See Also

Reference

ProductSynchronizationRequest Class
Sitecore.Commerce.Services.Products Namespace


ProductSynchronizationRequest.ProductId Property

ProductSynchronizationRequestProductId Property
Gets or sets the external id.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string ProductId { get; protected set; }
Public Property ProductId As String
    Get
    Protected Set
public:
property String^ ProductId {
    String^ get ();
    protected: void set (String^ value);
}
member ProductId : string with get, set

Property Value

Type: String
The external id.
See Also

Reference

ProductSynchronizationRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationContext Class

SynchronizationContext Class
Defines the synchronization context. This class Utilizes some of the Sitecore CMS facilities to speed up the synchronization of the artifacts between Sitecore CMS and the external commerce system. You can use this class to disable proxies, the event handling, and database cache. You can also use it to update all items in the content tree at once.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Services.ProductsSynchronizationContext

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizationContext : IDisposable
Public Class SynchronizationContext
    Implements IDisposable
public ref class SynchronizationContext : IDisposable
type SynchronizationContext =
    class
        interface IDisposable
    end

The SynchronizationContext type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizationContext | Initializes an instance of the SynchronizationContext class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs the application-defined tasks that are associated with freeing, releasing, and resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the SynchronizationContext class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BulkUpdateContext | Gets the bulk update context.
Public property | DatabaseCacheDisabler | Gets the database cache disabler.
Public property | EventDisabler | Gets the event disabler.
Public property | ProxyDisabler | Gets the proxy disabler.
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizationContext Constructor

SynchronizationContext Constructor
Initializes an instance of the SynchronizationContext class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizationContext()
Public Sub New
public:
SynchronizationContext()
new : unit -> SynchronizationContext
See Also

Reference

SynchronizationContext Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationContext Methods

SynchronizationContext Methods

The SynchronizationContext type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs the application-defined tasks that are associated with freeing, releasing, and resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the SynchronizationContext class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizationContext Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationContext.Dispose Method

SynchronizationContextDispose Method
Overload List
 | Name | Description
Public method | Dispose | Performs the application-defined tasks that are associated with freeing, releasing, and resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

SynchronizationContext Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationContext.Dispose Method

SynchronizationContextDispose Method
Performs the application-defined tasks that are associated with freeing, releasing, and resetting unmanaged resources.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SynchronizationContext Class
Dispose Overload
Sitecore.Commerce.Services.Products Namespace


SynchronizationContext.Dispose Method (Boolean)

SynchronizationContextDispose Method (Boolean)
Releases unmanaged and - optionally - managed resources.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

SynchronizationContext Class
Dispose Overload
Sitecore.Commerce.Services.Products Namespace


SynchronizationContext.Finalize Method

SynchronizationContextFinalize Method
Finalizes an instance of the SynchronizationContext class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

SynchronizationContext Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationContext Properties

SynchronizationContext Properties

The SynchronizationContext type exposes the following members.

Properties
 | Name | Description
Public property | BulkUpdateContext | Gets the bulk update context.
Public property | DatabaseCacheDisabler | Gets the database cache disabler.
Public property | EventDisabler | Gets the event disabler.
Public property | ProxyDisabler | Gets the proxy disabler.
Top
See Also

Reference

SynchronizationContext Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationContext.BulkUpdateContext Property

SynchronizationContextBulkUpdateContext Property
Gets the bulk update context.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public BulkUpdateContext BulkUpdateContext { get; }
Public ReadOnly Property BulkUpdateContext As BulkUpdateContext
    Get
public:
property BulkUpdateContext^ BulkUpdateContext {
    BulkUpdateContext^ get ();
}
member BulkUpdateContext : BulkUpdateContext with get

Property Value

Type: BulkUpdateContext
The bulk update context.
See Also

Reference

SynchronizationContext Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationContext.DatabaseCacheDisabler Property

SynchronizationContextDatabaseCacheDisabler Property
Gets the database cache disabler.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public DatabaseCacheDisabler DatabaseCacheDisabler { get; }
Public ReadOnly Property DatabaseCacheDisabler As DatabaseCacheDisabler
    Get
public:
property DatabaseCacheDisabler^ DatabaseCacheDisabler {
    DatabaseCacheDisabler^ get ();
}
member DatabaseCacheDisabler : DatabaseCacheDisabler with get

Property Value

Type: DatabaseCacheDisabler
The database cache disabler.
See Also

Reference

SynchronizationContext Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationContext.EventDisabler Property

SynchronizationContextEventDisabler Property
Gets the event disabler.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public EventDisabler EventDisabler { get; }
Public ReadOnly Property EventDisabler As EventDisabler
    Get
public:
property EventDisabler^ EventDisabler {
    EventDisabler^ get ();
}
member EventDisabler : EventDisabler with get

Property Value

Type: EventDisabler
The event disabler.
See Also

Reference

SynchronizationContext Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationContext.ProxyDisabler Property

SynchronizationContextProxyDisabler Property
Gets the proxy disabler.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public ProxyDisabler ProxyDisabler { get; }
Public ReadOnly Property ProxyDisabler As ProxyDisabler
    Get
public:
property ProxyDisabler^ ProxyDisabler {
    ProxyDisabler^ get ();
}
member ProxyDisabler : ProxyDisabler with get

Property Value

Type: ProxyDisabler
The proxy disabler.
See Also

Reference

SynchronizationContext Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationRequest Class

SynchronizationRequest Class
Defines the base class for all types of requests to the Product Synchronization Provider. These requests manipulate all types of artifacts.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
More...

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizationRequest : ServiceProviderRequest
Public Class SynchronizationRequest
    Inherits ServiceProviderRequest
public ref class SynchronizationRequest : public ServiceProviderRequest
type SynchronizationRequest =
    class
        inherit ServiceProviderRequest
    end

The SynchronizationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizationRequest | Initializes a new instance of the SynchronizationRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways.
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere.
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsGetExternalCommerceSystemProductListRequest
Sitecore.Commerce.Services.ProductsGetSitecoreProductListRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeArtifactsRequest
Sitecore.Commerce.Services.ProductsSynchronizeClassificationSpecificationsRequest
Sitecore.Commerce.Services.ProductsSynchronizeClassificationsRequest
Sitecore.Commerce.Services.ProductsSynchronizeDivisionsRequest
Sitecore.Commerce.Services.ProductsSynchronizeGlobalSpecificationsRequest
Sitecore.Commerce.Services.ProductsSynchronizeManufacturersRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductListRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductsRequest
Sitecore.Commerce.Services.ProductsSynchronizeResourcesRequest
Sitecore.Commerce.Services.ProductsSynchronizeSpecificationsRequest
Sitecore.Commerce.Services.ProductsSynchronizeTypeDefaultValuesRequest
Sitecore.Commerce.Services.ProductsSynchronizeTypeSpecificationsRequest
Sitecore.Commerce.Services.ProductsSynchronizeTypesRequest


SynchronizationRequest Constructor

SynchronizationRequest Constructor
Initializes a new instance of the SynchronizationRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizationRequest()
Public Sub New
public:
SynchronizationRequest()
new : unit -> SynchronizationRequest
See Also

Reference

SynchronizationRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationRequest Methods

SynchronizationRequest Methods

The SynchronizationRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizationRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationRequest Properties

SynchronizationRequest Properties

The SynchronizationRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways.
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere.
Top
See Also

Reference

SynchronizationRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationRequest.Direction Property

SynchronizationRequestDirection Property
Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public Direction Direction { get; set; }
Public Property Direction As Direction
    Get
    Set
public:
property Direction Direction {
    Direction get ();
    void set (Direction value);
}
member Direction : Direction with get, set

Property Value

Type: Direction
The direction
See Also

Reference

SynchronizationRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationRequest.Language Property

SynchronizationRequestLanguage Property
Gets or sets the language to synchronize the artifact in. The default language is English.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}
member Language : string with get, set

Property Value

Type: String
The language
See Also

Reference

SynchronizationRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizationRequest.UpdateIn Property

SynchronizationRequestUpdateIn Property
Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public UpdateIn UpdateIn { get; set; }
Public Property UpdateIn As UpdateIn
    Get
    Set
public:
property UpdateIn UpdateIn {
    UpdateIn get ();
    void set (UpdateIn value);
}
member UpdateIn : UpdateIn with get, set

Property Value

Type: UpdateIn
The location
See Also

Reference

SynchronizationRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeArtifactsRequest Class

SynchronizeArtifactsRequest Class
The synchronize artifacts request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeArtifactsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeArtifactsRequest : SynchronizationRequest
Public Class SynchronizeArtifactsRequest
    Inherits SynchronizationRequest
public ref class SynchronizeArtifactsRequest : public SynchronizationRequest
type SynchronizeArtifactsRequest =
    class
        inherit SynchronizationRequest
    end

The SynchronizeArtifactsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeArtifactsRequest | Initializes a new instance of the SynchronizeArtifactsRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeArtifactsRequest Constructor

SynchronizeArtifactsRequest Constructor
Initializes a new instance of the SynchronizeArtifactsRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeArtifactsRequest()
Public Sub New
public:
SynchronizeArtifactsRequest()
new : unit -> SynchronizeArtifactsRequest
See Also

Reference

SynchronizeArtifactsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeArtifactsRequest Methods

SynchronizeArtifactsRequest Methods

The SynchronizeArtifactsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeArtifactsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeArtifactsRequest Properties

SynchronizeArtifactsRequest Properties

The SynchronizeArtifactsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeArtifactsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeClassificationSpecificationsRequest Class

SynchronizeClassificationSpecificationsRequest Class
The synchronize classifications specifications request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeClassificationSpecificationsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeClassificationSpecificationsRequest : SynchronizationRequest
Public Class SynchronizeClassificationSpecificationsRequest
    Inherits SynchronizationRequest
public ref class SynchronizeClassificationSpecificationsRequest : public SynchronizationRequest
type SynchronizeClassificationSpecificationsRequest =
    class
        inherit SynchronizationRequest
    end

The SynchronizeClassificationSpecificationsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeClassificationSpecificationsRequest | Initializes a new instance of the SynchronizeClassificationSpecificationsRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeClassificationSpecificationsRequest Constructor

SynchronizeClassificationSpecificationsRequest Constructor
Initializes a new instance of the SynchronizeClassificationSpecificationsRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeClassificationSpecificationsRequest()
Public Sub New
public:
SynchronizeClassificationSpecificationsRequest()
new : unit -> SynchronizeClassificationSpecificationsRequest
See Also

Reference

SynchronizeClassificationSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeClassificationSpecificationsRequest Methods

SynchronizeClassificationSpecificationsRequest Methods

The SynchronizeClassificationSpecificationsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeClassificationSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeClassificationSpecificationsRequest Properties

SynchronizeClassificationSpecificationsRequest Properties

The SynchronizeClassificationSpecificationsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeClassificationSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeClassificationsRequest Class

SynchronizeClassificationsRequest Class
Defines the request used to synchronize product classifications.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeClassificationsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeClassificationsRequest : SynchronizationRequest
Public Class SynchronizeClassificationsRequest
    Inherits SynchronizationRequest
public ref class SynchronizeClassificationsRequest : public SynchronizationRequest
type SynchronizeClassificationsRequest =
    class
        inherit SynchronizationRequest
    end

The SynchronizeClassificationsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeClassificationsRequest | Initializes a new instance of the SynchronizeClassificationsRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeClassificationsRequest Constructor

SynchronizeClassificationsRequest Constructor
Initializes a new instance of the SynchronizeClassificationsRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeClassificationsRequest()
Public Sub New
public:
SynchronizeClassificationsRequest()
new : unit -> SynchronizeClassificationsRequest
See Also

Reference

SynchronizeClassificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeClassificationsRequest Methods

SynchronizeClassificationsRequest Methods

The SynchronizeClassificationsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeClassificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeClassificationsRequest Properties

SynchronizeClassificationsRequest Properties

The SynchronizeClassificationsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeClassificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeDivisionsRequest Class

SynchronizeDivisionsRequest Class
The synchronize divisions request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeDivisionsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeDivisionsRequest : SynchronizationRequest
Public Class SynchronizeDivisionsRequest
    Inherits SynchronizationRequest
public ref class SynchronizeDivisionsRequest : public SynchronizationRequest
type SynchronizeDivisionsRequest =
    class
        inherit SynchronizationRequest
    end

The SynchronizeDivisionsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeDivisionsRequest | Initializes a new instance of the SynchronizeDivisionsRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeDivisionsRequest Constructor

SynchronizeDivisionsRequest Constructor
Initializes a new instance of the SynchronizeDivisionsRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeDivisionsRequest()
Public Sub New
public:
SynchronizeDivisionsRequest()
new : unit -> SynchronizeDivisionsRequest
See Also

Reference

SynchronizeDivisionsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeDivisionsRequest Methods

SynchronizeDivisionsRequest Methods

The SynchronizeDivisionsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeDivisionsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeDivisionsRequest Properties

SynchronizeDivisionsRequest Properties

The SynchronizeDivisionsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeDivisionsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeGlobalSpecificationsRequest Class

SynchronizeGlobalSpecificationsRequest Class
The synchronize global specification request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeGlobalSpecificationsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeGlobalSpecificationsRequest : SynchronizationRequest
Public Class SynchronizeGlobalSpecificationsRequest
    Inherits SynchronizationRequest
public ref class SynchronizeGlobalSpecificationsRequest : public SynchronizationRequest
type SynchronizeGlobalSpecificationsRequest =
    class
        inherit SynchronizationRequest
    end

The SynchronizeGlobalSpecificationsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeGlobalSpecificationsRequest | Initializes a new instance of the SynchronizeGlobalSpecificationsRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeGlobalSpecificationsRequest Constructor

SynchronizeGlobalSpecificationsRequest Constructor
Initializes a new instance of the SynchronizeGlobalSpecificationsRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeGlobalSpecificationsRequest()
Public Sub New
public:
SynchronizeGlobalSpecificationsRequest()
new : unit -> SynchronizeGlobalSpecificationsRequest
See Also

Reference

SynchronizeGlobalSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeGlobalSpecificationsRequest Methods

SynchronizeGlobalSpecificationsRequest Methods

The SynchronizeGlobalSpecificationsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeGlobalSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeGlobalSpecificationsRequest Properties

SynchronizeGlobalSpecificationsRequest Properties

The SynchronizeGlobalSpecificationsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeGlobalSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeManufacturersRequest Class

SynchronizeManufacturersRequest Class
Defines the request used to synchronize product manufacturer collection.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeManufacturersRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeManufacturersRequest : SynchronizationRequest
Public Class SynchronizeManufacturersRequest
    Inherits SynchronizationRequest
public ref class SynchronizeManufacturersRequest : public SynchronizationRequest
type SynchronizeManufacturersRequest =
    class
        inherit SynchronizationRequest
    end

The SynchronizeManufacturersRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeManufacturersRequest | Initializes a new instance of the SynchronizeManufacturersRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeManufacturersRequest Constructor

SynchronizeManufacturersRequest Constructor
Initializes a new instance of the SynchronizeManufacturersRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeManufacturersRequest()
Public Sub New
public:
SynchronizeManufacturersRequest()
new : unit -> SynchronizeManufacturersRequest
See Also

Reference

SynchronizeManufacturersRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeManufacturersRequest Methods

SynchronizeManufacturersRequest Methods

The SynchronizeManufacturersRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeManufacturersRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeManufacturersRequest Properties

SynchronizeManufacturersRequest Properties

The SynchronizeManufacturersRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeManufacturersRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductClassificationsRequest Class

SynchronizeProductClassificationsRequest Class
The synchronize product classifications request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductClassificationsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductClassificationsRequest : ProductSynchronizationRequest
Public Class SynchronizeProductClassificationsRequest
    Inherits ProductSynchronizationRequest
public ref class SynchronizeProductClassificationsRequest : public ProductSynchronizationRequest
type SynchronizeProductClassificationsRequest =
    class
        inherit ProductSynchronizationRequest
    end

The SynchronizeProductClassificationsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductClassificationsRequest | Initializes a new instance of the SynchronizeProductClassificationsRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeProductClassificationsRequest Constructor

SynchronizeProductClassificationsRequest Constructor
Initializes a new instance of the SynchronizeProductClassificationsRequest class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductClassificationsRequest(
    string productId
)
Public Sub New (
    productId As String
)
public:
SynchronizeProductClassificationsRequest(
    String^ productId
)
new :
        productId : string -> SynchronizeProductClassificationsRequest

Parameters

productId
Type: SystemString
The external product id.
See Also

Reference

SynchronizeProductClassificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductClassificationsRequest Methods

SynchronizeProductClassificationsRequest Methods

The SynchronizeProductClassificationsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductClassificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductClassificationsRequest Properties

SynchronizeProductClassificationsRequest Properties

The SynchronizeProductClassificationsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeProductClassificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductClassificationsSpecificationsRequest Class

SynchronizeProductClassificationsSpecificationsRequest Class
The synchronize product classifications specifications request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductClassificationsSpecificationsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductClassificationsSpecificationsRequest : ProductSynchronizationRequest
Public Class SynchronizeProductClassificationsSpecificationsRequest
    Inherits ProductSynchronizationRequest
public ref class SynchronizeProductClassificationsSpecificationsRequest : public ProductSynchronizationRequest
type SynchronizeProductClassificationsSpecificationsRequest =
    class
        inherit ProductSynchronizationRequest
    end

The SynchronizeProductClassificationsSpecificationsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductClassificationsSpecificationsRequest | Initializes a new instance of the SynchronizeProductClassificationsSpecificationsRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeProductClassificationsSpecificationsRequest Constructor

SynchronizeProductClassificationsSpecificationsRequest Constructor
Initializes a new instance of the SynchronizeProductClassificationsSpecificationsRequest class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductClassificationsSpecificationsRequest(
    string productId
)
Public Sub New (
    productId As String
)
public:
SynchronizeProductClassificationsSpecificationsRequest(
    String^ productId
)
new :
        productId : string -> SynchronizeProductClassificationsSpecificationsRequest

Parameters

productId
Type: SystemString
The external product id.
See Also

Reference

SynchronizeProductClassificationsSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductClassificationsSpecificationsRequest Methods

SynchronizeProductClassificationsSpecificationsRequest Methods

The SynchronizeProductClassificationsSpecificationsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductClassificationsSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductClassificationsSpecificationsRequest Properties

SynchronizeProductClassificationsSpecificationsRequest Properties

The SynchronizeProductClassificationsSpecificationsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeProductClassificationsSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductDivisionsRequest Class

SynchronizeProductDivisionsRequest Class
The synchronize product divisions request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductDivisionsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductDivisionsRequest : ProductSynchronizationRequest
Public Class SynchronizeProductDivisionsRequest
    Inherits ProductSynchronizationRequest
public ref class SynchronizeProductDivisionsRequest : public ProductSynchronizationRequest
type SynchronizeProductDivisionsRequest =
    class
        inherit ProductSynchronizationRequest
    end

The SynchronizeProductDivisionsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductDivisionsRequest | Initializes a new instance of the SynchronizeProductDivisionsRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeProductDivisionsRequest Constructor

SynchronizeProductDivisionsRequest Constructor
Initializes a new instance of the SynchronizeProductDivisionsRequest class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductDivisionsRequest(
    string productId
)
Public Sub New (
    productId As String
)
public:
SynchronizeProductDivisionsRequest(
    String^ productId
)
new :
        productId : string -> SynchronizeProductDivisionsRequest

Parameters

productId
Type: SystemString
The external product id.
See Also

Reference

SynchronizeProductDivisionsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductDivisionsRequest Methods

SynchronizeProductDivisionsRequest Methods

The SynchronizeProductDivisionsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductDivisionsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductDivisionsRequest Properties

SynchronizeProductDivisionsRequest Properties

The SynchronizeProductDivisionsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeProductDivisionsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductEntityRequest Class

SynchronizeProductEntityRequest Class
The synchronize product item request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductEntityRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductEntityRequest : ProductSynchronizationRequest
Public Class SynchronizeProductEntityRequest
    Inherits ProductSynchronizationRequest
public ref class SynchronizeProductEntityRequest : public ProductSynchronizationRequest
type SynchronizeProductEntityRequest =
    class
        inherit ProductSynchronizationRequest
    end

The SynchronizeProductEntityRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductEntityRequest | Initializes a new instance of the SynchronizeProductEntityRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeProductEntityRequest Constructor

SynchronizeProductEntityRequest Constructor
Initializes a new instance of the SynchronizeProductEntityRequest class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductEntityRequest(
    string productId
)
Public Sub New (
    productId As String
)
public:
SynchronizeProductEntityRequest(
    String^ productId
)
new :
        productId : string -> SynchronizeProductEntityRequest

Parameters

productId
Type: SystemString
The external product id.
See Also

Reference

SynchronizeProductEntityRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductEntityRequest Methods

SynchronizeProductEntityRequest Methods

The SynchronizeProductEntityRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductEntityRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductEntityRequest Properties

SynchronizeProductEntityRequest Properties

The SynchronizeProductEntityRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeProductEntityRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductGlobalSpecificationsRequest Class

SynchronizeProductGlobalSpecificationsRequest Class
The synchronize product global specifications request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductGlobalSpecificationsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductGlobalSpecificationsRequest : ProductSynchronizationRequest
Public Class SynchronizeProductGlobalSpecificationsRequest
    Inherits ProductSynchronizationRequest
public ref class SynchronizeProductGlobalSpecificationsRequest : public ProductSynchronizationRequest
type SynchronizeProductGlobalSpecificationsRequest =
    class
        inherit ProductSynchronizationRequest
    end

The SynchronizeProductGlobalSpecificationsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductGlobalSpecificationsRequest | Initializes a new instance of the SynchronizeProductGlobalSpecificationsRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeProductGlobalSpecificationsRequest Constructor

SynchronizeProductGlobalSpecificationsRequest Constructor
Initializes a new instance of the SynchronizeProductGlobalSpecificationsRequest class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductGlobalSpecificationsRequest(
    string productId
)
Public Sub New (
    productId As String
)
public:
SynchronizeProductGlobalSpecificationsRequest(
    String^ productId
)
new :
        productId : string -> SynchronizeProductGlobalSpecificationsRequest

Parameters

productId
Type: SystemString
The external product id.
See Also

Reference

SynchronizeProductGlobalSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductGlobalSpecificationsRequest Methods

SynchronizeProductGlobalSpecificationsRequest Methods

The SynchronizeProductGlobalSpecificationsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductGlobalSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductGlobalSpecificationsRequest Properties

SynchronizeProductGlobalSpecificationsRequest Properties

The SynchronizeProductGlobalSpecificationsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeProductGlobalSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductListRequest Class

SynchronizeProductListRequest Class
Defines the request used to synchronize product lists.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductListRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductListRequest : SynchronizationRequest
Public Class SynchronizeProductListRequest
    Inherits SynchronizationRequest
public ref class SynchronizeProductListRequest : public SynchronizationRequest
type SynchronizeProductListRequest =
    class
        inherit SynchronizationRequest
    end

The SynchronizeProductListRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductListRequest | Initializes a new instance of the SynchronizeProductListRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | ProductIds | Gets or sets the product.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeProductListRequest Constructor

SynchronizeProductListRequest Constructor
Initializes a new instance of the SynchronizeProductListRequest class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductListRequest(
    IEnumerable<string> productIds
)
Public Sub New (
    productIds As IEnumerable(Of String)
)
public:
SynchronizeProductListRequest(
    IEnumerable<String^>^ productIds
)
new :
        productIds : IEnumerable<string> -> SynchronizeProductListRequest

Parameters

productIds
Type: System.Collections.GenericIEnumerable String
The external ids.
See Also

Reference

SynchronizeProductListRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductListRequest Methods

SynchronizeProductListRequest Methods

The SynchronizeProductListRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductListRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductListRequest Properties

SynchronizeProductListRequest Properties

The SynchronizeProductListRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | ProductIds | Gets or sets the product.
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeProductListRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductListRequest.ProductIds Property

SynchronizeProductListRequestProductIds Property
Gets or sets the product.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ProductIds { get; protected set; }
Public Property ProductIds As IEnumerable(Of String)
    Get
    Protected Set
public:
property IEnumerable<String^>^ ProductIds {
    IEnumerable<String^>^ get ();
    protected: void set (IEnumerable<String^>^ value);
}
member ProductIds : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The product.
See Also

Reference

SynchronizeProductListRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductManufacturersRequest Class

SynchronizeProductManufacturersRequest Class
The synchronize product manufacturers request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductManufacturersRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductManufacturersRequest : ProductSynchronizationRequest
Public Class SynchronizeProductManufacturersRequest
    Inherits ProductSynchronizationRequest
public ref class SynchronizeProductManufacturersRequest : public ProductSynchronizationRequest
type SynchronizeProductManufacturersRequest =
    class
        inherit ProductSynchronizationRequest
    end

The SynchronizeProductManufacturersRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductManufacturersRequest | Initializes a new instance of the SynchronizeProductManufacturersRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeProductManufacturersRequest Constructor

SynchronizeProductManufacturersRequest Constructor
Initializes a new instance of the SynchronizeProductManufacturersRequest class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductManufacturersRequest(
    string productId
)
Public Sub New (
    productId As String
)
public:
SynchronizeProductManufacturersRequest(
    String^ productId
)
new :
        productId : string -> SynchronizeProductManufacturersRequest

Parameters

productId
Type: SystemString
The external product id.
See Also

Reference

SynchronizeProductManufacturersRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductManufacturersRequest Methods

SynchronizeProductManufacturersRequest Methods

The SynchronizeProductManufacturersRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductManufacturersRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductManufacturersRequest Properties

SynchronizeProductManufacturersRequest Properties

The SynchronizeProductManufacturersRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeProductManufacturersRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductRelationsRequest Class

SynchronizeProductRelationsRequest Class
The synchronize product relations request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductRelationsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductRelationsRequest : ProductSynchronizationRequest
Public Class SynchronizeProductRelationsRequest
    Inherits ProductSynchronizationRequest
public ref class SynchronizeProductRelationsRequest : public ProductSynchronizationRequest
type SynchronizeProductRelationsRequest =
    class
        inherit ProductSynchronizationRequest
    end

The SynchronizeProductRelationsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductRelationsRequest | Initializes a new instance of the SynchronizeProductRelationsRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeProductRelationsRequest Constructor

SynchronizeProductRelationsRequest Constructor
Initializes a new instance of the SynchronizeProductRelationsRequest class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductRelationsRequest(
    string productId
)
Public Sub New (
    productId As String
)
public:
SynchronizeProductRelationsRequest(
    String^ productId
)
new :
        productId : string -> SynchronizeProductRelationsRequest

Parameters

productId
Type: SystemString
The external product id.
See Also

Reference

SynchronizeProductRelationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductRelationsRequest Methods

SynchronizeProductRelationsRequest Methods

The SynchronizeProductRelationsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductRelationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductRelationsRequest Properties

SynchronizeProductRelationsRequest Properties

The SynchronizeProductRelationsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeProductRelationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductRequest Class

SynchronizeProductRequest Class
Defines the request used to synchronize products.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductRequest : ProductSynchronizationRequest
Public Class SynchronizeProductRequest
    Inherits ProductSynchronizationRequest
public ref class SynchronizeProductRequest : public ProductSynchronizationRequest
type SynchronizeProductRequest =
    class
        inherit ProductSynchronizationRequest
    end

The SynchronizeProductRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductRequest | Initializes a new instance of the SynchronizeProductRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeProductRequest Constructor

SynchronizeProductRequest Constructor
Initializes a new instance of the SynchronizeProductRequest class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductRequest(
    string productId
)
Public Sub New (
    productId As String
)
public:
SynchronizeProductRequest(
    String^ productId
)
new :
        productId : string -> SynchronizeProductRequest

Parameters

productId
Type: SystemString
The external product id.
See Also

Reference

SynchronizeProductRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductRequest Methods

SynchronizeProductRequest Methods

The SynchronizeProductRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductRequest Properties

SynchronizeProductRequest Properties

The SynchronizeProductRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeProductRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductResourcesRequest Class

SynchronizeProductResourcesRequest Class
The synchronize product resources request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductResourcesRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductResourcesRequest : ProductSynchronizationRequest
Public Class SynchronizeProductResourcesRequest
    Inherits ProductSynchronizationRequest
public ref class SynchronizeProductResourcesRequest : public ProductSynchronizationRequest
type SynchronizeProductResourcesRequest =
    class
        inherit ProductSynchronizationRequest
    end

The SynchronizeProductResourcesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductResourcesRequest | Initializes a new instance of the SynchronizeProductResourcesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeProductResourcesRequest Constructor

SynchronizeProductResourcesRequest Constructor
Initializes a new instance of the SynchronizeProductResourcesRequest class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductResourcesRequest(
    string productId
)
Public Sub New (
    productId As String
)
public:
SynchronizeProductResourcesRequest(
    String^ productId
)
new :
        productId : string -> SynchronizeProductResourcesRequest

Parameters

productId
Type: SystemString
The external product id.
See Also

Reference

SynchronizeProductResourcesRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductResourcesRequest Methods

SynchronizeProductResourcesRequest Methods

The SynchronizeProductResourcesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductResourcesRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductResourcesRequest Properties

SynchronizeProductResourcesRequest Properties

The SynchronizeProductResourcesRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeProductResourcesRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductSpecificationsRequest Class

SynchronizeProductSpecificationsRequest Class
The synchronize product specifications request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductSpecificationsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductSpecificationsRequest : ProductSynchronizationRequest
Public Class SynchronizeProductSpecificationsRequest
    Inherits ProductSynchronizationRequest
public ref class SynchronizeProductSpecificationsRequest : public ProductSynchronizationRequest
type SynchronizeProductSpecificationsRequest =
    class
        inherit ProductSynchronizationRequest
    end

The SynchronizeProductSpecificationsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductSpecificationsRequest | Initializes a new instance of the SynchronizeProductSpecificationsRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeProductSpecificationsRequest Constructor

SynchronizeProductSpecificationsRequest Constructor
Initializes a new instance of the SynchronizeProductSpecificationsRequest class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductSpecificationsRequest(
    string productId
)
Public Sub New (
    productId As String
)
public:
SynchronizeProductSpecificationsRequest(
    String^ productId
)
new :
        productId : string -> SynchronizeProductSpecificationsRequest

Parameters

productId
Type: SystemString
The external product id.
See Also

Reference

SynchronizeProductSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductSpecificationsRequest Methods

SynchronizeProductSpecificationsRequest Methods

The SynchronizeProductSpecificationsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductSpecificationsRequest Properties

SynchronizeProductSpecificationsRequest Properties

The SynchronizeProductSpecificationsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeProductSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductsRequest Class

SynchronizeProductsRequest Class
Defines the request used to synchronize product collections.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductsRequest : SynchronizationRequest
Public Class SynchronizeProductsRequest
    Inherits SynchronizationRequest
public ref class SynchronizeProductsRequest : public SynchronizationRequest
type SynchronizeProductsRequest =
    class
        inherit SynchronizationRequest
    end

The SynchronizeProductsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductsRequest | Initializes a new instance of the SynchronizeProductsRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeProductsRequest Constructor

SynchronizeProductsRequest Constructor
Initializes a new instance of the SynchronizeProductsRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductsRequest()
Public Sub New
public:
SynchronizeProductsRequest()
new : unit -> SynchronizeProductsRequest
See Also

Reference

SynchronizeProductsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductsRequest Methods

SynchronizeProductsRequest Methods

The SynchronizeProductsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductsRequest Properties

SynchronizeProductsRequest Properties

The SynchronizeProductsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeProductsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductTypeSpecificationsRequest Class

SynchronizeProductTypeSpecificationsRequest Class
The synchronize product type specifications request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductTypeSpecificationsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductTypeSpecificationsRequest : ProductSynchronizationRequest
Public Class SynchronizeProductTypeSpecificationsRequest
    Inherits ProductSynchronizationRequest
public ref class SynchronizeProductTypeSpecificationsRequest : public ProductSynchronizationRequest
type SynchronizeProductTypeSpecificationsRequest =
    class
        inherit ProductSynchronizationRequest
    end

The SynchronizeProductTypeSpecificationsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductTypeSpecificationsRequest | Initializes a new instance of the SynchronizeProductTypeSpecificationsRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeProductTypeSpecificationsRequest Constructor

SynchronizeProductTypeSpecificationsRequest Constructor
Initializes a new instance of the SynchronizeProductTypeSpecificationsRequest class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductTypeSpecificationsRequest(
    string productId
)
Public Sub New (
    productId As String
)
public:
SynchronizeProductTypeSpecificationsRequest(
    String^ productId
)
new :
        productId : string -> SynchronizeProductTypeSpecificationsRequest

Parameters

productId
Type: SystemString
The external product id.
See Also

Reference

SynchronizeProductTypeSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductTypeSpecificationsRequest Methods

SynchronizeProductTypeSpecificationsRequest Methods

The SynchronizeProductTypeSpecificationsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductTypeSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductTypeSpecificationsRequest Properties

SynchronizeProductTypeSpecificationsRequest Properties

The SynchronizeProductTypeSpecificationsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeProductTypeSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductTypesRequest Class

SynchronizeProductTypesRequest Class
The synchronize product types request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsProductSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeProductTypesRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeProductTypesRequest : ProductSynchronizationRequest
Public Class SynchronizeProductTypesRequest
    Inherits ProductSynchronizationRequest
public ref class SynchronizeProductTypesRequest : public ProductSynchronizationRequest
type SynchronizeProductTypesRequest =
    class
        inherit ProductSynchronizationRequest
    end

The SynchronizeProductTypesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeProductTypesRequest | Initializes a new instance of the SynchronizeProductTypesRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeProductTypesRequest Constructor

SynchronizeProductTypesRequest Constructor
Initializes a new instance of the SynchronizeProductTypesRequest class.

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeProductTypesRequest(
    string productId
)
Public Sub New (
    productId As String
)
public:
SynchronizeProductTypesRequest(
    String^ productId
)
new :
        productId : string -> SynchronizeProductTypesRequest

Parameters

productId
Type: SystemString
The external product id.
See Also

Reference

SynchronizeProductTypesRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductTypesRequest Methods

SynchronizeProductTypesRequest Methods

The SynchronizeProductTypesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeProductTypesRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeProductTypesRequest Properties

SynchronizeProductTypesRequest Properties

The SynchronizeProductTypesRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | MoveToBucket | Gets or sets a value indicating whether [move to bucket]. (Inherited from ProductSynchronizationRequest.)
Public property | ProductId | Gets or sets the external id. (Inherited from ProductSynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeProductTypesRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeResourcesRequest Class

SynchronizeResourcesRequest Class
The synchronize resources request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeResourcesRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeResourcesRequest : SynchronizationRequest
Public Class SynchronizeResourcesRequest
    Inherits SynchronizationRequest
public ref class SynchronizeResourcesRequest : public SynchronizationRequest
type SynchronizeResourcesRequest =
    class
        inherit SynchronizationRequest
    end

The SynchronizeResourcesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeResourcesRequest | Initializes a new instance of the SynchronizeResourcesRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeResourcesRequest Constructor

SynchronizeResourcesRequest Constructor
Initializes a new instance of the SynchronizeResourcesRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeResourcesRequest()
Public Sub New
public:
SynchronizeResourcesRequest()
new : unit -> SynchronizeResourcesRequest
See Also

Reference

SynchronizeResourcesRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeResourcesRequest Methods

SynchronizeResourcesRequest Methods

The SynchronizeResourcesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeResourcesRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeResourcesRequest Properties

SynchronizeResourcesRequest Properties

The SynchronizeResourcesRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeResourcesRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeSpecificationsRequest Class

SynchronizeSpecificationsRequest Class
The synchronize specifications request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeSpecificationsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeSpecificationsRequest : SynchronizationRequest
Public Class SynchronizeSpecificationsRequest
    Inherits SynchronizationRequest
public ref class SynchronizeSpecificationsRequest : public SynchronizationRequest
type SynchronizeSpecificationsRequest =
    class
        inherit SynchronizationRequest
    end

The SynchronizeSpecificationsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeSpecificationsRequest | Initializes a new instance of the SynchronizeSpecificationsRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeSpecificationsRequest Constructor

SynchronizeSpecificationsRequest Constructor
Initializes a new instance of the SynchronizeSpecificationsRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeSpecificationsRequest()
Public Sub New
public:
SynchronizeSpecificationsRequest()
new : unit -> SynchronizeSpecificationsRequest
See Also

Reference

SynchronizeSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeSpecificationsRequest Methods

SynchronizeSpecificationsRequest Methods

The SynchronizeSpecificationsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeSpecificationsRequest Properties

SynchronizeSpecificationsRequest Properties

The SynchronizeSpecificationsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeTypeDefaultValuesRequest Class

SynchronizeTypeDefaultValuesRequest Class
The synchronize type default values request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeTypeDefaultValuesRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeTypeDefaultValuesRequest : SynchronizationRequest
Public Class SynchronizeTypeDefaultValuesRequest
    Inherits SynchronizationRequest
public ref class SynchronizeTypeDefaultValuesRequest : public SynchronizationRequest
type SynchronizeTypeDefaultValuesRequest =
    class
        inherit SynchronizationRequest
    end

The SynchronizeTypeDefaultValuesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeTypeDefaultValuesRequest | Initializes a new instance of the SynchronizeTypeDefaultValuesRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeTypeDefaultValuesRequest Constructor

SynchronizeTypeDefaultValuesRequest Constructor
Initializes a new instance of the SynchronizeTypeDefaultValuesRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeTypeDefaultValuesRequest()
Public Sub New
public:
SynchronizeTypeDefaultValuesRequest()
new : unit -> SynchronizeTypeDefaultValuesRequest
See Also

Reference

SynchronizeTypeDefaultValuesRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeTypeDefaultValuesRequest Methods

SynchronizeTypeDefaultValuesRequest Methods

The SynchronizeTypeDefaultValuesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeTypeDefaultValuesRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeTypeDefaultValuesRequest Properties

SynchronizeTypeDefaultValuesRequest Properties

The SynchronizeTypeDefaultValuesRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeTypeDefaultValuesRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeTypeSpecificationsRequest Class

SynchronizeTypeSpecificationsRequest Class
The synchronize type specifications request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeTypeSpecificationsRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeTypeSpecificationsRequest : SynchronizationRequest
Public Class SynchronizeTypeSpecificationsRequest
    Inherits SynchronizationRequest
public ref class SynchronizeTypeSpecificationsRequest : public SynchronizationRequest
type SynchronizeTypeSpecificationsRequest =
    class
        inherit SynchronizationRequest
    end

The SynchronizeTypeSpecificationsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeTypeSpecificationsRequest | Initializes a new instance of the SynchronizeTypeSpecificationsRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeTypeSpecificationsRequest Constructor

SynchronizeTypeSpecificationsRequest Constructor
Initializes a new instance of the SynchronizeTypeSpecificationsRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeTypeSpecificationsRequest()
Public Sub New
public:
SynchronizeTypeSpecificationsRequest()
new : unit -> SynchronizeTypeSpecificationsRequest
See Also

Reference

SynchronizeTypeSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeTypeSpecificationsRequest Methods

SynchronizeTypeSpecificationsRequest Methods

The SynchronizeTypeSpecificationsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeTypeSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeTypeSpecificationsRequest Properties

SynchronizeTypeSpecificationsRequest Properties

The SynchronizeTypeSpecificationsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeTypeSpecificationsRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeTypesRequest Class

SynchronizeTypesRequest Class
The synchronize types request.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.ServicesServiceProviderRequest
Sitecore.Commerce.Services.ProductsSynchronizationRequest
Sitecore.Commerce.Services.ProductsSynchronizeTypesRequest

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeTypesRequest : SynchronizationRequest
Public Class SynchronizeTypesRequest
    Inherits SynchronizationRequest
public ref class SynchronizeTypesRequest : public SynchronizationRequest
type SynchronizeTypesRequest =
    class
        inherit SynchronizationRequest
    end

The SynchronizeTypesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeTypesRequest | Initializes a new instance of the SynchronizeTypesRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

Sitecore.Commerce.Services.Products Namespace


SynchronizeTypesRequest Constructor

SynchronizeTypesRequest Constructor
Initializes a new instance of the SynchronizeTypesRequest class

Namespace: Sitecore.Commerce.Services.Products
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public SynchronizeTypesRequest()
Public Sub New
public:
SynchronizeTypesRequest()
new : unit -> SynchronizeTypesRequest
See Also

Reference

SynchronizeTypesRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeTypesRequest Methods

SynchronizeTypesRequest Methods

The SynchronizeTypesRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SynchronizeTypesRequest Class
Sitecore.Commerce.Services.Products Namespace


SynchronizeTypesRequest Properties

SynchronizeTypesRequest Properties

The SynchronizeTypesRequest type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Defines the direction of the artifact synchronization: From the external commerce system to Sitecore, in opposite direction or both ways. (Inherited from SynchronizationRequest.)
Public property | Language | Gets or sets the language to synchronize the artifact in. The default language is English. (Inherited from SynchronizationRequest.)
Public property | Properties | Gets or sets the dictionary used to hold all of the simple properties (i.e. strings, int, etc…) associated with the commerce entity. (Inherited from ServiceProviderRequest.)
Public property | RequestContext | Gets or sets the request context. (Inherited from ServiceProviderRequest.)
Public property | UpdateIn | Determines where the artifact must be updated: In external commerce system, in Sitecore or nowhere. (Inherited from SynchronizationRequest.)
Top
See Also

Reference

SynchronizeTypesRequest Class
Sitecore.Commerce.Services.Products Namespace


Sitecore.Commerce.Services.Products.Generics Namespace

Sitecore.Commerce.Services.Products.Generics Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Services.Products.Generics"]

Classes
Class Description
Public class GenericProductSynchronizationProviderExtensions
Defines a set of extensions for the ProductSynchronizationProvider class. The GenericProductSynchronizationProviderExtensions contains the same methods as in the ProductSynchronizationProvider class.

The methods of this class:
  • Are Generic
  • Accept a custom request that is inherited from the default request
  • Return a custom result that is inherited from the default result
  • Implement the default constructor


GenericProductSynchronizationProviderExtensions Class

GenericProductSynchronizationProviderExtensions Class
Defines a set of extensions for the ProductSynchronizationProvider class. The GenericProductSynchronizationProviderExtensions contains the same methods as in the ProductSynchronizationProvider class.

The methods of this class:
  • Are Generic
  • Accept a custom request that is inherited from the default request
  • Return a custom result that is inherited from the default result
  • Implement the default constructor
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.Services.Products.GenericsGenericProductSynchronizationProviderExtensions

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static class GenericProductSynchronizationProviderExtensions
<ExtensionAttribute>
Public NotInheritable Class GenericProductSynchronizationProviderExtensions
[ExtensionAttribute]
public ref class GenericProductSynchronizationProviderExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GenericProductSynchronizationProviderExtensions =  class end

The GenericProductSynchronizationProviderExtensions type exposes the following members.

Methods
Name | Description
GetExternalCommerceSystemProductListTSynchronizationRequest, TServiceProviderResult | Gets the product list of the external commerce system .
GetSitecoreProductListTSynchronizationRequest, TServiceProviderResult | Gets Sitecore product list.
SynchronizeArtifactsTSynchronizationRequest, TServiceProviderResult | Synchronizes the artifacts.
SynchronizeClassificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the classifications.
SynchronizeClassificationSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the classification specifications.
SynchronizeDivisionsTSynchronizationRequest, TServiceProviderResult | Synchronizes the divisions.
SynchronizeGlobalSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the global specifications.
SynchronizeManufacturersTSynchronizationRequest, TServiceProviderResult | Synchronizes the manufacturers.
SynchronizeProductTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product.
SynchronizeProductClassificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product classifications.
SynchronizeProductClassificationsSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product classifications specifications.
SynchronizeProductDivisionsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product divisions.
SynchronizeProductEntityTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product item.
SynchronizeProductGlobalSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product global specifications.
SynchronizeProductListTSynchronizeProductListRequest, TServiceProviderResult | Synchronizes the product list.
SynchronizeProductManufacturersTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product manufacturers.
SynchronizeProductRelationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product relations.
SynchronizeProductResourcesTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product resources.
SynchronizeProductsTSynchronizationRequest, TServiceProviderResult | Synchronizes the products.
SynchronizeProductSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product specifications.
SynchronizeProductTypesTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product types.
SynchronizeProductTypeSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product type specifications.
SynchronizeResourcesTSynchronizationRequest, TServiceProviderResult | Synchronizes the resources.
SynchronizeSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the specifications.
SynchronizeTypeDefaultValuesTSynchronizationRequest, TServiceProviderResult | Synchronizes the type default values.
SynchronizeTypesTSynchronizationRequest, TServiceProviderResult | Synchronizes the types.
SynchronizeTypeSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the type specifications.
Top
See Also

Reference

Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions Methods

GenericProductSynchronizationProviderExtensions Methods

The GenericProductSynchronizationProviderExtensions type exposes the following members.

Methods
Name | Description
GetExternalCommerceSystemProductListTSynchronizationRequest, TServiceProviderResult | Gets the product list of the external commerce system .
GetSitecoreProductListTSynchronizationRequest, TServiceProviderResult | Gets Sitecore product list.
SynchronizeArtifactsTSynchronizationRequest, TServiceProviderResult | Synchronizes the artifacts.
SynchronizeClassificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the classifications.
SynchronizeClassificationSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the classification specifications.
SynchronizeDivisionsTSynchronizationRequest, TServiceProviderResult | Synchronizes the divisions.
SynchronizeGlobalSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the global specifications.
SynchronizeManufacturersTSynchronizationRequest, TServiceProviderResult | Synchronizes the manufacturers.
SynchronizeProductTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product.
SynchronizeProductClassificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product classifications.
SynchronizeProductClassificationsSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product classifications specifications.
SynchronizeProductDivisionsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product divisions.
SynchronizeProductEntityTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product item.
SynchronizeProductGlobalSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product global specifications.
SynchronizeProductListTSynchronizeProductListRequest, TServiceProviderResult | Synchronizes the product list.
SynchronizeProductManufacturersTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product manufacturers.
SynchronizeProductRelationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product relations.
SynchronizeProductResourcesTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product resources.
SynchronizeProductsTSynchronizationRequest, TServiceProviderResult | Synchronizes the products.
SynchronizeProductSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product specifications.
SynchronizeProductTypesTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product types.
SynchronizeProductTypeSpecificationsTProductSynchronizationRequest, TServiceProviderResult | Synchronizes the product type specifications.
SynchronizeResourcesTSynchronizationRequest, TServiceProviderResult | Synchronizes the resources.
SynchronizeSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the specifications.
SynchronizeTypeDefaultValuesTSynchronizationRequest, TServiceProviderResult | Synchronizes the type default values.
SynchronizeTypesTSynchronizationRequest, TServiceProviderResult | Synchronizes the types.
SynchronizeTypeSpecificationsTSynchronizationRequest, TServiceProviderResult | Synchronizes the type specifications.
Top
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.GetExternalCommerceSystemProductList(TSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsGetExternalCommerceSystemProductListTSynchronizationRequest, TServiceProviderResult Method
Gets the product list of the external commerce system .

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult GetExternalCommerceSystemProductList<TSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizationRequest request
)
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function GetExternalCommerceSystemProductList(Of TSynchronizationRequest As SynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizationRequest, typename TServiceProviderResult>
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult GetExternalCommerceSystemProductList(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizationRequest request
)
static member GetExternalCommerceSystemProductList :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizationRequest -> 'TServiceProviderResult  when 'TSynchronizationRequest : SynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizationRequest
The request

Type Parameters

TSynchronizationRequest
The type of the synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.GetSitecoreProductList(TSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsGetSitecoreProductListTSynchronizationRequest, TServiceProviderResult Method
Gets Sitecore product list.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult GetSitecoreProductList<TSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizationRequest request
)
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function GetSitecoreProductList(Of TSynchronizationRequest As SynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizationRequest, typename TServiceProviderResult>
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult GetSitecoreProductList(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizationRequest request
)
static member GetSitecoreProductList :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizationRequest -> 'TServiceProviderResult  when 'TSynchronizationRequest : SynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizationRequest
The request

Type Parameters

TSynchronizationRequest
The type of the synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeArtifacts(TSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeArtifactsTSynchronizationRequest, TServiceProviderResult Method
Synchronizes the artifacts.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeArtifacts<TSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizationRequest request
)
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeArtifacts(Of TSynchronizationRequest As SynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizationRequest, typename TServiceProviderResult>
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeArtifacts(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizationRequest request
)
static member SynchronizeArtifacts :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizationRequest -> 'TServiceProviderResult  when 'TSynchronizationRequest : SynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizationRequest
The request

Type Parameters

TSynchronizationRequest
The type of the synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeClassifications(TSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeClassificationsTSynchronizationRequest, TServiceProviderResult Method
Synchronizes the classifications.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeClassifications<TSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizationRequest request
)
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeClassifications(Of TSynchronizationRequest As SynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizationRequest, typename TServiceProviderResult>
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeClassifications(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizationRequest request
)
static member SynchronizeClassifications :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizationRequest -> 'TServiceProviderResult  when 'TSynchronizationRequest : SynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizationRequest
The request

Type Parameters

TSynchronizationRequest
The type of the synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeClassificationSpecifications(TSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeClassificationSpecificationsTSynchronizationRequest, TServiceProviderResult Method
Synchronizes the classification specifications.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeClassificationSpecifications<TSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizationRequest request
)
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeClassificationSpecifications(Of TSynchronizationRequest As SynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizationRequest, typename TServiceProviderResult>
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeClassificationSpecifications(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizationRequest request
)
static member SynchronizeClassificationSpecifications :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizationRequest -> 'TServiceProviderResult  when 'TSynchronizationRequest : SynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizationRequest
The request

Type Parameters

TSynchronizationRequest
The type of the synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeDivisions(TSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeDivisionsTSynchronizationRequest, TServiceProviderResult Method
Synchronizes the divisions.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeDivisions<TSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizationRequest request
)
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeDivisions(Of TSynchronizationRequest As SynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizationRequest, typename TServiceProviderResult>
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeDivisions(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizationRequest request
)
static member SynchronizeDivisions :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizationRequest -> 'TServiceProviderResult  when 'TSynchronizationRequest : SynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizationRequest
The request

Type Parameters

TSynchronizationRequest
The type of the synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeGlobalSpecifications(TSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeGlobalSpecificationsTSynchronizationRequest, TServiceProviderResult Method
Synchronizes the global specifications.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeGlobalSpecifications<TSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizationRequest request
)
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeGlobalSpecifications(Of TSynchronizationRequest As SynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizationRequest, typename TServiceProviderResult>
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeGlobalSpecifications(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizationRequest request
)
static member SynchronizeGlobalSpecifications :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizationRequest -> 'TServiceProviderResult  when 'TSynchronizationRequest : SynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizationRequest
The request

Type Parameters

TSynchronizationRequest
The type of the synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeManufacturers(TSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeManufacturersTSynchronizationRequest, TServiceProviderResult Method
Synchronizes the manufacturers.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeManufacturers<TSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizationRequest request
)
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeManufacturers(Of TSynchronizationRequest As SynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizationRequest, typename TServiceProviderResult>
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeManufacturers(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizationRequest request
)
static member SynchronizeManufacturers :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizationRequest -> 'TServiceProviderResult  when 'TSynchronizationRequest : SynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizationRequest
The request

Type Parameters

TSynchronizationRequest
The type of the synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeProduct(TProductSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeProductTProductSynchronizationRequest, TServiceProviderResult Method
Synchronizes the product.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeProduct<TProductSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TProductSynchronizationRequest request
)
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeProduct(Of TProductSynchronizationRequest As ProductSynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TProductSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TProductSynchronizationRequest, typename TServiceProviderResult>
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeProduct(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TProductSynchronizationRequest request
)
static member SynchronizeProduct :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TProductSynchronizationRequest -> 'TServiceProviderResult  when 'TProductSynchronizationRequest : ProductSynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TProductSynchronizationRequest
The request

Type Parameters

TProductSynchronizationRequest
The type of the product synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeProductClassifications(TProductSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeProductClassificationsTProductSynchronizationRequest, TServiceProviderResult Method
Synchronizes the product classifications.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeProductClassifications<TProductSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TProductSynchronizationRequest request
)
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeProductClassifications(Of TProductSynchronizationRequest As ProductSynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TProductSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TProductSynchronizationRequest, typename TServiceProviderResult>
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeProductClassifications(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TProductSynchronizationRequest request
)
static member SynchronizeProductClassifications :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TProductSynchronizationRequest -> 'TServiceProviderResult  when 'TProductSynchronizationRequest : ProductSynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TProductSynchronizationRequest
The request

Type Parameters

TProductSynchronizationRequest
The type of the product synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeProductClassificationsSpecifications(TProductSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeProductClassificationsSpecificationsTProductSynchronizationRequest, TServiceProviderResult Method
Synchronizes the product classifications specifications.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeProductClassificationsSpecifications<TProductSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TProductSynchronizationRequest request
)
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeProductClassificationsSpecifications(Of TProductSynchronizationRequest As ProductSynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TProductSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TProductSynchronizationRequest, typename TServiceProviderResult>
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeProductClassificationsSpecifications(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TProductSynchronizationRequest request
)
static member SynchronizeProductClassificationsSpecifications :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TProductSynchronizationRequest -> 'TServiceProviderResult  when 'TProductSynchronizationRequest : ProductSynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TProductSynchronizationRequest
The request

Type Parameters

TProductSynchronizationRequest
The type of the product synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeProductDivisions(TProductSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeProductDivisionsTProductSynchronizationRequest, TServiceProviderResult Method
Synchronizes the product divisions.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeProductDivisions<TProductSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TProductSynchronizationRequest request
)
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeProductDivisions(Of TProductSynchronizationRequest As ProductSynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TProductSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TProductSynchronizationRequest, typename TServiceProviderResult>
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeProductDivisions(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TProductSynchronizationRequest request
)
static member SynchronizeProductDivisions :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TProductSynchronizationRequest -> 'TServiceProviderResult  when 'TProductSynchronizationRequest : ProductSynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TProductSynchronizationRequest
The request

Type Parameters

TProductSynchronizationRequest
The type of the product synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeProductEntity(TProductSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeProductEntityTProductSynchronizationRequest, TServiceProviderResult Method
Synchronizes the product item.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeProductEntity<TProductSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TProductSynchronizationRequest request
)
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeProductEntity(Of TProductSynchronizationRequest As ProductSynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TProductSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TProductSynchronizationRequest, typename TServiceProviderResult>
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeProductEntity(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TProductSynchronizationRequest request
)
static member SynchronizeProductEntity :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TProductSynchronizationRequest -> 'TServiceProviderResult  when 'TProductSynchronizationRequest : ProductSynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TProductSynchronizationRequest
The request

Type Parameters

TProductSynchronizationRequest
The type of the product synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeProductGlobalSpecifications(TProductSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeProductGlobalSpecificationsTProductSynchronizationRequest, TServiceProviderResult Method
Synchronizes the product global specifications.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeProductGlobalSpecifications<TProductSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TProductSynchronizationRequest request
)
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeProductGlobalSpecifications(Of TProductSynchronizationRequest As ProductSynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TProductSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TProductSynchronizationRequest, typename TServiceProviderResult>
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeProductGlobalSpecifications(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TProductSynchronizationRequest request
)
static member SynchronizeProductGlobalSpecifications :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TProductSynchronizationRequest -> 'TServiceProviderResult  when 'TProductSynchronizationRequest : ProductSynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TProductSynchronizationRequest
The request

Type Parameters

TProductSynchronizationRequest
The type of the product synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeProductList(TSynchronizeProductListRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeProductListTSynchronizeProductListRequest, TServiceProviderResult Method
Synchronizes the product list.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeProductList<TSynchronizeProductListRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizeProductListRequest request
)
where TSynchronizeProductListRequest : SynchronizeProductListRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeProductList(Of TSynchronizeProductListRequest As SynchronizeProductListRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizeProductListRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizeProductListRequest, typename TServiceProviderResult>
where TSynchronizeProductListRequest : SynchronizeProductListRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeProductList(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizeProductListRequest request
)
static member SynchronizeProductList :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizeProductListRequest -> 'TServiceProviderResult  when 'TSynchronizeProductListRequest : SynchronizeProductListRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizeProductListRequest
The request

Type Parameters

TSynchronizeProductListRequest
The type of the synchronize product list request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeProductManufacturers(TProductSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeProductManufacturersTProductSynchronizationRequest, TServiceProviderResult Method
Synchronizes the product manufacturers.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeProductManufacturers<TProductSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TProductSynchronizationRequest request
)
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeProductManufacturers(Of TProductSynchronizationRequest As ProductSynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TProductSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TProductSynchronizationRequest, typename TServiceProviderResult>
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeProductManufacturers(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TProductSynchronizationRequest request
)
static member SynchronizeProductManufacturers :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TProductSynchronizationRequest -> 'TServiceProviderResult  when 'TProductSynchronizationRequest : ProductSynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TProductSynchronizationRequest
The request

Type Parameters

TProductSynchronizationRequest
The type of the product synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeProductRelations(TProductSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeProductRelationsTProductSynchronizationRequest, TServiceProviderResult Method
Synchronizes the product relations.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeProductRelations<TProductSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TProductSynchronizationRequest request
)
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeProductRelations(Of TProductSynchronizationRequest As ProductSynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TProductSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TProductSynchronizationRequest, typename TServiceProviderResult>
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeProductRelations(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TProductSynchronizationRequest request
)
static member SynchronizeProductRelations :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TProductSynchronizationRequest -> 'TServiceProviderResult  when 'TProductSynchronizationRequest : ProductSynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TProductSynchronizationRequest
The request

Type Parameters

TProductSynchronizationRequest
The type of the product synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeProductResources(TProductSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeProductResourcesTProductSynchronizationRequest, TServiceProviderResult Method
Synchronizes the product resources.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeProductResources<TProductSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TProductSynchronizationRequest request
)
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeProductResources(Of TProductSynchronizationRequest As ProductSynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TProductSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TProductSynchronizationRequest, typename TServiceProviderResult>
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeProductResources(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TProductSynchronizationRequest request
)
static member SynchronizeProductResources :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TProductSynchronizationRequest -> 'TServiceProviderResult  when 'TProductSynchronizationRequest : ProductSynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TProductSynchronizationRequest
The request

Type Parameters

TProductSynchronizationRequest
The type of the product synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeProducts(TSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeProductsTSynchronizationRequest, TServiceProviderResult Method
Synchronizes the products.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeProducts<TSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizationRequest request
)
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeProducts(Of TSynchronizationRequest As SynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizationRequest, typename TServiceProviderResult>
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeProducts(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizationRequest request
)
static member SynchronizeProducts :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizationRequest -> 'TServiceProviderResult  when 'TSynchronizationRequest : SynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizationRequest
The request

Type Parameters

TSynchronizationRequest
The type of the synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeProductSpecifications(TProductSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeProductSpecificationsTProductSynchronizationRequest, TServiceProviderResult Method
Synchronizes the product specifications.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeProductSpecifications<TProductSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TProductSynchronizationRequest request
)
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeProductSpecifications(Of TProductSynchronizationRequest As ProductSynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TProductSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TProductSynchronizationRequest, typename TServiceProviderResult>
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeProductSpecifications(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TProductSynchronizationRequest request
)
static member SynchronizeProductSpecifications :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TProductSynchronizationRequest -> 'TServiceProviderResult  when 'TProductSynchronizationRequest : ProductSynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TProductSynchronizationRequest
The request

Type Parameters

TProductSynchronizationRequest
The type of the product synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeProductTypes(TProductSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeProductTypesTProductSynchronizationRequest, TServiceProviderResult Method
Synchronizes the product types.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeProductTypes<TProductSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TProductSynchronizationRequest request
)
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeProductTypes(Of TProductSynchronizationRequest As ProductSynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TProductSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TProductSynchronizationRequest, typename TServiceProviderResult>
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeProductTypes(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TProductSynchronizationRequest request
)
static member SynchronizeProductTypes :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TProductSynchronizationRequest -> 'TServiceProviderResult  when 'TProductSynchronizationRequest : ProductSynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TProductSynchronizationRequest
The request

Type Parameters

TProductSynchronizationRequest
The type of the product synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeProductTypeSpecifications(TProductSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeProductTypeSpecificationsTProductSynchronizationRequest, TServiceProviderResult Method
Synchronizes the product type specifications.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeProductTypeSpecifications<TProductSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TProductSynchronizationRequest request
)
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeProductTypeSpecifications(Of TProductSynchronizationRequest As ProductSynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TProductSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TProductSynchronizationRequest, typename TServiceProviderResult>
where TProductSynchronizationRequest : ProductSynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeProductTypeSpecifications(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TProductSynchronizationRequest request
)
static member SynchronizeProductTypeSpecifications :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TProductSynchronizationRequest -> 'TServiceProviderResult  when 'TProductSynchronizationRequest : ProductSynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TProductSynchronizationRequest
The request

Type Parameters

TProductSynchronizationRequest
The type of the product synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeResources(TSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeResourcesTSynchronizationRequest, TServiceProviderResult Method
Synchronizes the resources.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeResources<TSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizationRequest request
)
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeResources(Of TSynchronizationRequest As SynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizationRequest, typename TServiceProviderResult>
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeResources(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizationRequest request
)
static member SynchronizeResources :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizationRequest -> 'TServiceProviderResult  when 'TSynchronizationRequest : SynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizationRequest
The request

Type Parameters

TSynchronizationRequest
The type of the synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeSpecifications(TSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeSpecificationsTSynchronizationRequest, TServiceProviderResult Method
Synchronizes the specifications.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeSpecifications<TSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizationRequest request
)
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeSpecifications(Of TSynchronizationRequest As SynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizationRequest, typename TServiceProviderResult>
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeSpecifications(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizationRequest request
)
static member SynchronizeSpecifications :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizationRequest -> 'TServiceProviderResult  when 'TSynchronizationRequest : SynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizationRequest
The request

Type Parameters

TSynchronizationRequest
The type of the synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeTypeDefaultValues(TSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeTypeDefaultValuesTSynchronizationRequest, TServiceProviderResult Method
Synchronizes the type default values.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeTypeDefaultValues<TSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizationRequest request
)
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeTypeDefaultValues(Of TSynchronizationRequest As SynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizationRequest, typename TServiceProviderResult>
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeTypeDefaultValues(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizationRequest request
)
static member SynchronizeTypeDefaultValues :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizationRequest -> 'TServiceProviderResult  when 'TSynchronizationRequest : SynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizationRequest
The request

Type Parameters

TSynchronizationRequest
The type of the synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeTypes(TSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeTypesTSynchronizationRequest, TServiceProviderResult Method
Synchronizes the types.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeTypes<TSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizationRequest request
)
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeTypes(Of TSynchronizationRequest As SynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizationRequest, typename TServiceProviderResult>
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeTypes(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizationRequest request
)
static member SynchronizeTypes :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizationRequest -> 'TServiceProviderResult  when 'TSynchronizationRequest : SynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizationRequest
The request

Type Parameters

TSynchronizationRequest
The type of the synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


GenericProductSynchronizationProviderExtensions.SynchronizeTypeSpecifications(TSynchronizationRequest, TServiceProviderResult) Method

GenericProductSynchronizationProviderExtensionsSynchronizeTypeSpecificationsTSynchronizationRequest, TServiceProviderResult Method
Synchronizes the type specifications.

Namespace: Sitecore.Commerce.Services.Products.Generics
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public static TServiceProviderResult SynchronizeTypeSpecifications<TSynchronizationRequest, TServiceProviderResult>(
    this ProductSynchronizationProvider productSynchronizationProvider,
    TSynchronizationRequest request
)
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : new(), ServiceProviderResult

<ExtensionAttribute>
Public Shared Function SynchronizeTypeSpecifications(Of TSynchronizationRequest As SynchronizationRequest, TServiceProviderResult As {New, ServiceProviderResult}) (
    productSynchronizationProvider As ProductSynchronizationProvider,
    request As TSynchronizationRequest
) As TServiceProviderResult
public:
[ExtensionAttribute]
generic<typename TSynchronizationRequest, typename TServiceProviderResult>
where TSynchronizationRequest : SynchronizationRequest
where TServiceProviderResult : gcnew(), ServiceProviderResult
static TServiceProviderResult SynchronizeTypeSpecifications(
    ProductSynchronizationProvider^ productSynchronizationProvider,
    TSynchronizationRequest request
)
static member SynchronizeTypeSpecifications :
        productSynchronizationProvider : ProductSynchronizationProvider *
        request : 'TSynchronizationRequest -> 'TServiceProviderResult  when 'TSynchronizationRequest : SynchronizationRequest when 'TServiceProviderResult : new() and ServiceProviderResult

Parameters

productSynchronizationProvider
Type: Sitecore.Commerce.Services.ProductsProductSynchronizationProvider
The product synchronization provider
request
Type: TSynchronizationRequest
The request

Type Parameters

TSynchronizationRequest
The type of the synchronization request
TServiceProviderResult
The type of the service provider result

Return Value

Type: TServiceProviderResult
Service provider result.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProductSynchronizationProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GenericProductSynchronizationProviderExtensions Class
Sitecore.Commerce.Services.Products.Generics Namespace


Sitecore.Commerce.Visitors Namespace

Sitecore.Commerce.Visitors Namespace

[Missing <summary> documentation for "N:Sitecore.Commerce.Visitors"]

Classes
 | Class | Description
Public class | VisitorFactory | Defines the current visitor using Sitecore Analytics. This class is needed to distinguish anonymous users from each other.


VisitorFactory Class

VisitorFactory Class
Defines the current visitor using Sitecore Analytics. This class is needed to distinguish anonymous users from each other.
Inheritance Hierarchy
SystemObject
Sitecore.Commerce.VisitorsVisitorFactory

Namespace: Sitecore.Commerce.Visitors
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public class VisitorFactory
Public Class VisitorFactory
public ref class VisitorFactory
type VisitorFactory =  class end

The VisitorFactory type exposes the following members.

Constructors
 | Name | Description
Public method | VisitorFactory | Initializes a new instance of the VisitorFactory class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVisitor | Gets the visitor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Sitecore.Commerce.Visitors Namespace


VisitorFactory Constructor

VisitorFactory Constructor
Initializes a new instance of the VisitorFactory class

Namespace: Sitecore.Commerce.Visitors
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public VisitorFactory()
Public Sub New
public:
VisitorFactory()
new : unit -> VisitorFactory
See Also

Reference

VisitorFactory Class
Sitecore.Commerce.Visitors Namespace


VisitorFactory Methods

VisitorFactory Methods

The VisitorFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVisitor | Gets the visitor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VisitorFactory Class
Sitecore.Commerce.Visitors Namespace


VisitorFactory.GetVisitor Method

VisitorFactoryGetVisitor Method
Gets the visitor.

Namespace: Sitecore.Commerce.Visitors
Assembly: Sitecore.Commerce (in Sitecore.Commerce.dll) Version: 1.0 rev. 140513
Syntax
C#
VB
C++
F#
Copy
public virtual string GetVisitor()
Public Overridable Function GetVisitor As String
public:
virtual String^ GetVisitor()
abstract GetVisitor : unit -> string
override GetVisitor : unit -> string

Return Value

Type: String
The visitor
See Also

Reference

VisitorFactory Class
Sitecore.Commerce.Visitors Namespace